QSK95 CM2350 K113

Last Modified: 12 February 2020

Copyright © 2020
Cummins Inc.
All rights reserved


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Fault Code Path Selection

FAULT CODE 111
Fault Code Path Selection

Is the ECM source address 00? | Go to 402-fc111sa00
Is the ECM source address 01? | Go to 402-fc111sa01
Is the ECM source address 144? | Go to 402-fc111sa144
Is the ECM source address 186? | Go to 402-fc111sa186

Last Modified: 20-Apr-2016
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1117

Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1117 PID: S251 SPN: 3597 FMI: 2/2 LAMP: None SRT: | Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect. Supply voltage to the ECM fell below a calibrated limit momentarily, or the ECM was not allowed to power down correctly. | Possible reduced engine performance.
Engine Control Module (ECM) Supply Voltage Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from power supplies through the unswitched power supply circuit.

Component Location

The engine control module (ECM) is connected to the supply voltage by a combination of engine harness and original equipment manufacturer (OEM) harness connected in series. The direct link provides a constant power supply for the ECM. The type and location of power supply will vary with OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the ECM power supply was removed before power-down parameters could be saved. The fault code will be active when the keyswitch is turned ON following the incomplete power-down event.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • Power-down data like trip information, maintenance monitor, and fault information will not get saved to permanent memory when the keyswitch is turned OFF.

Conditions for Clearing the Fault Code

  • To validate the repair, turn keyswitch on for 1 minute, turn keyswitch off for 1 minute, and then turn keyswitch on for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Make sure the ECM unswitched power supply is coming directly from the source. If unswitched power is coming from the starting motor, it is possible for the voltage to drop low enough during cranking to set this fault active. This fault can also be caused by resistance in the ECM power supply (+) or (-) circuits. Use of power supply disconnect switches can cause this fault to become active.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1117.

Last Modified: 02-Dec-2015


Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

FAULT CODE 111 (sa00)

Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 (sa00) PID: S254 SPN: 629 FMI: 12/12 LAMP: Red SRT: | Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component. Error internal to the engine control module (ECM) related to memory hardware malfunctions or internal ECM voltage supply circuits. | Engine may not start or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The Engine Control Modules (ECMs) are mounted at the front of the engine above the gear housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a read or write error internal to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Refer to Troubleshooting Fault Code 111 (sa00).

Last Modified: 10-May-2016


Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

FAULT CODE 111 (sa01)

Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 (sa01) PID: S254 SPN: 629 FMI: 12/12 LAMP: Red SRT: | Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component. Error internal to the engine control module (ECM) related to memory hardware malfunctions or internal ECM voltage supply circuits. | Engine may not start or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The Engine Control Modules (ECMs) are mounted at the front of the engine above the gear housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a read or write error internal to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Refer to Troubleshooting Fault Code 111 (sa01).

Last Modified: 10-May-2016


Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

FAULT CODE 111 (sa144)

Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 (sa144) PID: S254 SPN: 629 FMI: 12/12 LAMP: Red SRT: | Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component. Error internal to the engine control module (ECM) related to memory hardware malfunctions or internal ECM voltage supply circuits. | Engine may not start or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The Engine Control Modules (ECMs) are mounted at the front of the engine above the gear housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a read or write error internal to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Refer to Troubleshooting Fault Code 111 (sa144).

Last Modified: 10-May-2016


Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

FAULT CODE 111 (sa186)

Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 (sa186) PID: S254 SPN: 629 FMI: 12/12 LAMP: Red SRT: | Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component. Error internal to the engine control module (ECM) related to memory hardware malfunctions or internal ECM voltage supply circuits. | Engine may not start or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The Engine Control Modules (ECMs) are mounted at the front of the engine above the gear housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a read or write error internal to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Refer to Troubleshooting Fault Code 111 (sa186).

Last Modified: 10-May-2016


SAE J1939 Data Link 2 Engine Network - Abnormal Update Rate

FAULT CODE 1135

SAE J1939 Data Link 2 Engine Network - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1135 PID: S206 SPN: 1231 FMI: 9/9 LAMP: Red SRT: | SAE J1939 Data Link 2 Engine Network - Abnormal Update Rate. No communication or an invalid data transfer rate detected on the J1939 data link between the primary ECM and one or more secondary ECMs. | Engine may run rough, may stop running, may not start, or may be difficult to start.
SAE J1939 Data Link 2 Circuit

Circuit Description

The SAE J1939 data link circuit consists of one positive and one negative wire. Two 120 ohm resistors are connected in parallel to terminate the ends of the backbone. Stubs connect the engine control modules (ECM) to the J1939 backbone.

The engine control modules use the J1939 data link 2 for communication between modules.

Component Location

The Engine Control Modules (ECMs) are mounted at the front of the engine above the gear housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The primary engine control module (ECM 1) lost communication with one or more secondary ECMs via the J1939 data link 2.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A secondary ECM is not receiving power from the battery supply circuit in the harness. This can be caused by an open circuit in the power supply wire, blown ECM fuse, or open return wire.
  • Tripped circuit breaker in the OEM power supply circuit.
  • An open or short circuit in the SAE J1939 datalink circuit
  • Intermittent communication between the ECMs.
Refer to Troubleshooting Fault Code 1135.

Last Modified: 10-May-2016


Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

FAULT CODE 115

Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115 PID: P190 SPN: 612 FMI: 2/2 LAMP: Red SRT: | Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect. At least one of the engine control modules has lost the camshaft and crankshaft position sensor signals. | Possible reduced engine performance.
Crankshaft Position Sensor Circuit
Camshaft Position Sensor Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply and a return circuit to the position sensors. As holes drilled in the flywheel or slots in the front of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM uses this signal to determine engine speed. Offset spacing of the drillings or slots indicate to the ECM the position of the engine.

Component Location

The camshaft position sensor is located in the gear cover.

The crankshaft position sensor is located on the left bank side of the engine in the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

At least one engine control module (ECM) has lost both the camshaft and crankshaft position sensor signals while another ECM is still detecting both signals.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open in both engine position sensor circuits to one ECM.
Refer to Troubleshooting Fault Code 115.

Last Modified: 02-Dec-2015


Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 122

Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: P102 SPN: 102 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the intake manifold pressure circuit. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the low temperature air transfer connection on the left bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 122, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal wire shorted to sensor supply or ECM supply voltage.
  • A malfunctioning intake manifold pressure sensor
Refer to Troubleshooting Fault Code 122.

Last Modified: 02-Dec-2015


Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 123

Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: P102 SPN: 102 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or open circuit detected at the intake manifold pressure circuit. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the low temperature air transfer connection on the left bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 123, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
  • A malfunctioning intake manifold pressure sensor
Refer to Troubleshooting Fault Code 123.

Last Modified: 02-Dec-2015


Fault Code Path Selection

FAULT CODE 1256
Fault Code Path Selection

Is the ECM source address 00? | Go to 402-fc1256sa00
Is the ECM source address 01? | Go to 402-fc1256sa01
Is the ECM source address 144? | Go to 402-fc1256sa144
Is the ECM source address 186? | Go to 402-fc1256sa186

Last Modified: 20-Apr-2016


Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1256 (sa00)

Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1256 (sa00) PID: P234 SPN: 1563 FMI: 2/2 LAMP: Amber SRT: | Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect. The control module identification input state is incorrect. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Control Module Identification Circuit

Circuit Description

The engine control module (ECM) uses the control module identification circuit to verify its location in the harness. The combination of control module identification signal pins that are connected to return allow the ECM to make this determination.

Component Location

The control module identification circuit is located in the harness.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

An invalid control module identification input has been detected.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open or short circuit on one or more control module identification signal wire(s).
Refer to Troubleshooting Fault Code 1256 (sa00).

Last Modified: 10-May-2016


Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1256 (sa01)

Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1256 (sa01) PID: P234 SPN: 1563 FMI: 2/2 LAMP: Amber SRT: | Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect. The control module identification input state is incorrect. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Control Module Identification Circuit

Circuit Description

The engine control module (ECM) uses the control module identification circuit to verify its location in the harness. The combination of control module identification signal pins that are connected to return allow the ECM to make this determination.

Component Location

The control module identification circuit is located in the harness.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

An invalid control module identification input has been detected.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, turn keyswitch on for 1 minute, turn keyswitch off for 1 minute, and then turn keyswitch on for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open or short circuit on one or more control module identification signal wire(s).
  • Duplicate or incorrect ECM calibrations downloaded to the ECM(s).
  • Two or more ECMs installed in the wrong location.
Refer to Troubleshooting Fault Code 1256 (sa01).

Last Modified: 10-May-2016


Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1256 (sa144)

Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1256 (sa144) PID: P234 SPN: 1563 FMI: 2/2 LAMP: Amber SRT: | Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect. The control module identification input state is incorrect. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Control Module Identification Circuit

Circuit Description

The engine control module (ECM) uses the control module identification circuit to verify its location in the harness. The combination of control module identification signal pins that are connected to return allow the ECM to make this determination.

Component Location

The control module identification circuit is located in the harness.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

An invalid control module identification input has been detected.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open or short circuit on one or more control module identification signal wire(s).
Refer to Troubleshooting Fault Code 1256 (sa144).

Last Modified: 10-May-2016


Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1256 (sa186)

Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1256 (sa186) PID: P234 SPN: 1563 FMI: 2/2 LAMP: Amber SRT: | Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect. The control module identification input state is incorrect. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Control Module Identification Circuit

Circuit Description

The engine control module (ECM) uses the control module identification circuit to verify its location in the harness. The combination of control module identification signal pins that are connected to return allow the ECM to make this determination.

Component Location

The control module identification circuit is located in the harness.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

An invalid control module identification input has been detected.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open or short circuit on one or more control module identification signal wire(s).
Refer to Troubleshooting Fault Code 1256 (sa186).

Last Modified: 10-May-2016


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 135

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3/3 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the engine oil pressure circuit. | None on performance.
Oil Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located on the outlet of the oil filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The oil pressure sensor shares supply and return wires in the engine harness with other sensors, opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 135, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • A signal circuit shorted to sensor supply or ECM supply voltage.
Refer to Troubleshooting Fault Code 135.

Last Modified: 02-Dec-2015


Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1358

Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1358 PID: P91 SPN: 91 FMI: 3/3 LAMP: Amber SRT: | Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at accelerator pedal position number 1 circuit. | Engine will only idle.
Accelerator Pedal Position Sensor Circuit

Circuit Description

The accelerator position sensor can either be Hall effect or potentiometer type sensor that is integrated into the accelerator pedal assembly. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the accelerator pedal signal voltage was out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The accelerator pedal or lever position sensor signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by INSITE™ electronic service tool.

Possible causes of this fault code include:

A signal circuit shorted to sensor supply or ECM supply voltage.

Open accelerator pedal return circuit in the harness or connections

A malfunctioning accelerator pedal position sensor.

NOTE: The three wires in the accelerator position sensor circuit must be twisted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1358.

Last Modified: 14-Dec-2017


Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1359

Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1359 PID: P91 SPN: 91 FMI: 4/4 LAMP: Amber SRT: | Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at accelerator pedal position number 1 signal circuit. | Engine will only idle.
Accelerator Pedal or Level Position Sensor Circuit

Circuit Description

The accelerator position sensor can either be Hall effect or potentiometer type sensor that is integrated into the accelerator pedal assembly. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the accelerator pedal signal voltage was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The accelerator pedal or lever position sensor signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by INSITE™ electronic service tool.

Possible causes of this fault code include:

Accelerator pedal or lever position signal shorted to engine ground or return wires in the OEM harness or sensor

A malfunctioning accelerator pedal position sensor.

Open circuit in the accelerator signal or supply wire in the harness or connectors.

NOTE: The three wires in the accelerator position sensor circuit must be twisted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1359.

Last Modified: 14-Dec-2017


Engine Oil Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1362

Engine Oil Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1362 PID: P99 SPN: 99 FMI: 0/16 LAMP: Amber SRT: | Engine Oil Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. High oil filter restriction has been detected. | None on performance.
Pre-Oil Filter Pressure Sensor Circuit
Oil Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) uses the oil filter intake pressure sensor and engine oil pressure sensor to determine the oil filter restriction.

Component Location

The pre-oil filter pressure sensor is located on the intake of the oil filter head.

The engine oil pressure sensor is located on the outlet of the oil filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected high oil filter restriction.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and operate at rated speed for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • High oil filter restriction.
  • Malfunctioning engine oil pressure sensor.
  • Malfunctioning pre-oil filter pressure sensor.
Refer to Troubleshooting Fault Code 1362.

Last Modified: 11-Dec-2015


Pre-Oil Filter Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1367

Pre-Oil Filter Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1367 PID: SPN: 1208 FMI: 3/3 LAMP: Maintenance SRT: | Pre-Oil Filter Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the engine oil filter intake pressure circuit. | None on performance.
Pre-Oil Filter Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the oil filter intake pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The oil filter intake pressure sensor provides a signal to the ECM on the oil filter intake pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure before the oil filters. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The pre-oil filter pressure sensor is located on the intake of the oil filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil filter intake pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

A default value for the engine oil filter intake pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Signal wire shorted to sensor supply or ECM supply voltage.
  • A malfunctioning engine oil filter intake pressure sensor.
Refer to Troubleshooting Fault Code 1367.

Last Modified: 11-Dec-2015


Pre-Oil Filter Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1368

Pre-Oil Filter Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1368 PID: SPN: 1208 FMI: 4/4 LAMP: Maintenance SRT: | Pre-Oil Filter Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected in the engine oil filter intake pressure circuit. | None on performance.
Pre-Oil Filter Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the oil filter intake pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The oil filter intake pressure sensor provides a signal to the ECM on the oil filter intake pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure before the oil filters. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The pre-oil filter pressure sensor is located on the intake of the oil filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil filter intake pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

A default value for the engine oil filter intake pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor.
  • Supply wire open or shorted to ground.
  • A malfunctioning engine oil filter intake pressure sensor.
Refer to Troubleshooting Fault Code 1368.

Last Modified: 11-Dec-2015


Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1376

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1376 PID: S64 SPN: 723 FMI: 2/2 LAMP: Maintenance SRT: | Engine Camshaft Speed / Position Sensor - Data Erratic, Intermittent, or Incorrect. The ECM has detected a loss of signal from the camshaft position sensor. | Possible reduced engine performance.
Camshaft Position Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5-VDC supply to the camshaft position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. As slots in the front of the camshaft gear move past the position sensor, a signal is generated on the signal circuit. The ECM uses this signal to determine engine speed and position. Offset spacing of the cam gear slots indicate to the ECM the position of the engine. This sensor is used as a backup sensor if the engine crankshaft position signal is lost.

Component Location

The camshaft position sensor is located in the gear cover.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the camshaft speed/position sensor while the engine was running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Open or short circuit of the +5-VDC supply, signal, or return wire in the engine harness
  • Damaged or malfunctioning camshaft position sensor.
  • Damaged camshaft gear.
Refer to Troubleshooting Fault Code 1376.

Last Modified: 11-Dec-2015


Fuel Supply Pump Intake Pressure - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 1379

Fuel Supply Pump Intake Pressure - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1379 PID: P15 SPN: 1381 FMI: 1/17 LAMP: Maintenance SRT: | The Engine Control Module (ECM) has diagnosed that intake pressure of the fuel supply pump is below a calibrated threshold. | Possible reduced engine performance.
Fuel Supply Pump Intake Pressure Sensor Circuit

Circuit Description

The engine fuel supply pump provides a 5 volt supply to the fuel supply pump intake pressure sensor using a dedicated sensor supply circuit. The supply pump also provides a ground on the sensor return circuit. The fuel supply pump intake pressure sensor provides a pressure signal to the pump on the fuel supply pump intake pressure sensor signal circuit. This sensor signal voltage changes based on the pressure at the intake of the engine fuel supply pump.

Component Location

The engine fuel supply pump intake pressure sensor is located on the inlet of the fuel supply pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the fuel supply pump intake pressure is below a calibrated threshold.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

Malfunctioning engine fuel supply pump.

Stage 0 fuel filter restriction excessive.

Stage 1 fuel filter restriction excessive.

Refer to Troubleshooting Fault Code 1379 .

Last Modified: 03-Dec-2019


Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1383

Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1383 PID: P102 SPN: 102 FMI: 3/3 LAMP: Maintenance SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the intake manifold pressure circuit. | Possible reduced engine performance.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold pressure sensor 1 is located in intake manifold 1.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
  • A malfunctioning intake manifold pressure sensor
Refer to Troubleshooting Fault Code 1383.

Last Modified: 02-Dec-2015


Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1384

Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1384 PID: P102 SPN: 102 FMI: 4/4 LAMP: Maintenance SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or open circuit detected at the intake manifold pressure circuit. | Possible reduced engine performance.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold pressure sensor 1 is located in intake manifold 1.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
  • A malfunctioning intake manifold pressure sensor
Refer to Troubleshooting Fault Code 1384.

Last Modified: 02-Dec-2015


Intake Manifold 2 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1385

Intake Manifold 2 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1385 PID: SPN: 1128 FMI: 3/3 LAMP: Maintenance SRT: | Intake Manifold 2 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the intake manifold pressure circuit. | Possible reduced engine performance.
Intake Manifold 2 Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 2 pressure/temperature sensor is located in the low temperature air transfer connection on the right bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
  • A malfunctioning intake manifold pressure sensor
Refer to Troubleshooting Fault Code 1385.

Last Modified: 01-Sep-2015


Intake Manifold 2 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1386

Intake Manifold 2 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1386 PID: SPN: 1128 FMI: 4/4 LAMP: Maintenance SRT: | Intake Manifold 2 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or open circuit detected at the intake manifold pressure circuit. | Possible reduced engine performance.
Intake Manifold 2 Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 2 pressure/temperature sensor is located in the low temperature air transfer connection on the right bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
  • A malfunctioning intake manifold pressure sensor
Refer to Troubleshooting Fault Code 1386.

Last Modified: 01-Sep-2015


Fuel Supply Pump Intake Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 1389

Fuel Supply Pump Intake Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1389 PID: P15 SPN: 1381 FMI: 0/15 LAMP: Maintenance SRT: | High fuel supply pump intake pressure has been detected. | Possible reduced engine performance.
Fuel Supply Pump Intake Pressure Sensor Circuit

Circuit Description

The engine fuel supply pump provides a 5 volt supply to the fuel supply pump intake pressure sensor using a dedicated sensor supply circuit. The supply pump also provides a ground on the sensor return circuit. The fuel supply pump intake pressure sensor provides a pressure signal to the pump on the fuel supply pump intake pressure sensor signal circuit. This sensor signal voltage changes based on the pressure at the intake of the engine fuel supply pump.

Component Location

The fuel supply pump intake pressure sensor is located on the inlet of the engine fuel supply pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The engine control module (ECM) has detected that the fuel supply pump intake pressure is above a calibrated threshold.

Action Taken When the Fault Code is Active

The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Malfunctioning fuel pressure regulator valve or recirculation hose.

A malfunctioning fuel lift pump

Malfunctioning fuel supply pump intake pressure sensor.

Refer to Troubleshooting Fault Code 1389 .

Last Modified: 21-Aug-2019


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 141

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4/4 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or open circuit detected at the engine oil pressure circuit. | None on performance.
Oil Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located on the outlet of the oil filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The oil pressure sensor shares supply and return wires in the engine harness with other sensors, opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 141, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 141.

Last Modified: 02-Dec-2015


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 143

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 1/18 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Valid But Below Normal Operational Range - Moderately Severe Level. Engine oil pressure signal indicates engine oil pressure is below the engine protection warning limit. | Possible reduced engine performance.
Oil Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located on the outlet of the oil filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure was below minimum operating limits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • High oil filter restriction.
  • Malfunctioning oil pump.
  • Blocked or restricted oil passage.
  • Incorrect oil level
  • Damaged oil pressure sensor
Refer to Troubleshooting Fault Code 143.

Last Modified: 02-Dec-2015


Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 144

Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3/3 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at engine coolant temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM).
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the engine coolant temperature reading.
  • Fan will stay ON if controlled by the engine control module (ECM).

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This sensor shares return wires in the engine harness with other sensors. An open or shorted return can cause multiple fault codes to be active. Before troubleshooting this fault code, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning engine coolant temperature sensor
Refer to Troubleshooting Fault Code 144.

Last Modified: 02-Dec-2015


Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 145

Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4/4 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at engine coolant temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM).
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the engine coolant temperature reading.
  • Fan will stay ON if controlled by the engine control module (ECM).

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This sensor shares return wires in the engine harness with other sensors. An open or shorted return can cause multiple fault codes to be active. Before troubleshooting this fault code, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.
  • Malfunctioning engine coolant temperature sensor
Refer to Troubleshooting Fault Code 145.

Last Modified: 02-Dec-2015


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 146

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 146 PID: P110 SPN: 110 FMI: 0/16 LAMP: Amber SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Moderately Severe Level. Engine coolant temperature is above engine protection warning limit. | Possible reduced engine performance.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than a calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limit for high coolant temperature.

Refer to Troubleshooting Fault Code 146.

Last Modified: 02-Dec-2015


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 151

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0/0 LAMP: Red SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Most Severe Level. Engine coolant temperature signal indicates engine coolant temperature above engine protection critical limit. | Engine may be shut down.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than a calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limit for high coolant temperature.

During active Red Lamp conditions the OEM may inhibit starting. See OEM Service Manual.

Refer to Troubleshooting Fault Code 151.

Last Modified: 12-Oct-2016


Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1521

Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1521 PID: S131 SPN: 1139 FMI: 3/3 LAMP: Maintenance SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

Engine speed greater than 500 RPM.

Engine oil temperature greater than 60C [140F].

The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.

Malfunctioning exhaust gas temperature sensor.

Refer to Troubleshooting Fault Code 1521 .

Last Modified: 21-Aug-2019


Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1522

Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1522 PID: S133 SPN: 1141 FMI: 3/3 LAMP: Maintenance SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

Engine speed greater than 500 RPM.

Engine oil temperature greater than 60C [140F].

The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.

Malfunctioning exhaust gas temperature sensor.

Refer to Troubleshooting Fault Code 1522 .

Last Modified: 21-Aug-2019


Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1523

Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1523 PID: S135 SPN: 1143 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60C [140F].
  • The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1523.

Last Modified: 10-Aug-2015


Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1524

Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1524 PID: S137 SPN: 1145 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60C [140F].
  • The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1524.

Last Modified: 10-Aug-2015


Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1525

Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1525 PID: S139 SPN: 1147 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60C [140F].
  • The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1525.

Last Modified: 10-Aug-2015


Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1526

Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1526 PID: S141 SPN: 1149 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60C [140F].
  • The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1526.

Last Modified: 10-Aug-2015


Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1527

Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1527 PID: S143 SPN: 1151 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60C [140F].
  • The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1527.

Last Modified: 10-Aug-2015


Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1529

Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1529 PID: S130 SPN: 1138 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60C [140F].
  • The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1529.

Last Modified: 10-Aug-2015


Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 153

Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at intake manifold air temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM). Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the low temperature air transfer connection on the left bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This sensor shares return wires in the engine harness with other sensors. An open or shorted return can cause multiple fault codes to be active. Before troubleshooting this fault code, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to voltage source.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 153.

Last Modified: 02-Dec-2015


Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1531

Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1531 PID: S134 SPN: 1142 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60C [140F].
  • The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1531.

Last Modified: 10-Aug-2015


Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1532

Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1532 PID: S136 SPN: 1144 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60C [140F].
  • The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1532.

Last Modified: 10-Aug-2015


Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1533

Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1533 PID: S138 SPN: 1146 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60C [140F].
  • The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1533.

Last Modified: 10-Aug-2015


Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1534

Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1534 PID: S140 SPN: 1148 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60C [140F].
  • The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1534.

Last Modified: 10-Aug-2015


Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1535

Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1535 PID: S142 SPN: 1150 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60C [140F].
  • The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1535.

Last Modified: 10-Aug-2015


Exhaust Gas Temperature Sensor Circuit Cylinder 16 (B8) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1536

Exhaust Gas Temperature Sensor Circuit Cylinder 16 (B8) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1536 PID: S144 SPN: 1152 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 16 (B8) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60C [140F].
  • The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1536.

Last Modified: 10-Aug-2015


Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 154

Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at intake manifold air temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM). Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the low temperature air transfer connection on the left bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.
  • Fan will stay ON if controlled by the engine control module (ECM).

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This sensor shares return wires in the engine harness with other sensors. An open or shorted return can cause multiple fault codes to be active. Before troubleshooting this fault code, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 154.

Last Modified: 02-Dec-2015


Injector Solenoid Driver Cylinder 7 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1548

Injector Solenoid Driver Cylinder 7 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1548 PID: S7 SPN: 657 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 7 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 7 circuit. | Possible reduced engine performance.
Injector 7 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the two injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.
Refer to Troubleshooting Fault Code 1548.

Last Modified: 11-Dec-2015


Injector Solenoid Driver Cylinder 8 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1549

Injector Solenoid Driver Cylinder 8 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1549 PID: S8 SPN: 658 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 8 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 8 circuit. | Possible reduced engine performance.
Injector 8 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the two injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.
Refer to Troubleshooting Fault Code 1549.

Last Modified: 11-Dec-2015


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 155

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0/0 LAMP: Red SRT: | Intake Manifold 1 Temperature - Data Valid But Above Normal Operational Range - Most Severe Level. Intake manifold air temperature signal indicates intake manifold air temperature above engine protection critical limit. | Engine may be shut down.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the low temperature air transfer connection on the left bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Restricted air flow through the radiator.
  • Malfunctioning high temperature aftercooler element.
  • Malfunctioning low temperature aftercooler element.
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 155.

Last Modified: 02-Dec-2015


Injector Solenoid Driver Cylinder 10 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1551

Injector Solenoid Driver Cylinder 10 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1551 PID: S10 SPN: 660 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 10 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 10 circuit. | Possible reduced engine performance.
Injector 10 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the two injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.
Refer to Troubleshooting Fault Code 1551.

Last Modified: 11-Dec-2015


Injector Solenoid Driver Cylinder 11 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1552

Injector Solenoid Driver Cylinder 11 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1552 PID: S11 SPN: 661 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 11 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 11 circuit. | Possible reduced engine performance.
Injector 11 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the two injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.
Refer to Troubleshooting Fault Code 1552.

Last Modified: 11-Dec-2015


Injector Solenoid Driver Cylinder 12 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1553

Injector Solenoid Driver Cylinder 12 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1553 PID: S12 SPN: 662 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 12 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 12 circuit. | Possible reduced engine performance.
Injector 12 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the two injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.
Refer to Troubleshooting Fault Code 1553.

Last Modified: 11-Dec-2015


Injector Solenoid Driver Cylinder 13 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1554

Injector Solenoid Driver Cylinder 13 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1554 PID: S13 SPN: 663 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 13 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 13 circuit. | Possible reduced engine performance.
Injector 13 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the two injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.
Refer to Troubleshooting Fault Code 1554.

Last Modified: 11-Dec-2015


Injector Solenoid Driver Cylinder 14 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1555

Injector Solenoid Driver Cylinder 14 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1555 PID: S14 SPN: 664 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 14 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 14 circuit. | Possible reduced engine performance.
Injector 14 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the two injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.
Refer to Troubleshooting Fault Code 1555.

Last Modified: 11-Dec-2015


Injector Solenoid Driver Cylinder 15 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1556

Injector Solenoid Driver Cylinder 15 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1556 PID: S15 SPN: 665 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 15 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 15 circuit. | Possible reduced engine performance.
Injector 15 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the two injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.
Refer to Troubleshooting Fault Code 1556.

Last Modified: 11-Dec-2015


Injector Solenoid Driver Cylinder 16 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1557

Injector Solenoid Driver Cylinder 16 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1557 PID: S16 SPN: 666 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 16 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 16 circuit. | Possible reduced engine performance.
Injector 16 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the two injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.
Refer to Troubleshooting Fault Code 1557.

Last Modified: 11-Dec-2015


Intake Manifold 2 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 156

Intake Manifold 2 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 156 PID: SPN: 1131 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 2 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at intake manifold air temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM). Possible reduced engine performance.
Intake Manifold 2 Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 2 pressure/temperature sensor is located in the low temperature air transfer connection on the right bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.
  • Fan will stay ON if controlled by the engine control module (ECM).

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This sensor shares return wires in the engine harness with other sensors. An open or shorted return can cause multiple fault codes to be active. Before troubleshooting this fault code, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to voltage source.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 156.

Last Modified: 02-Dec-2015


Intake Manifold 2 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 157

Intake Manifold 2 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 157 PID: SPN: 1131 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold 2 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at intake manifold air temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM). Possible reduced engine performance.
Intake Manifold 2 Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 2 pressure/temperature sensor is located in the low temperature air transfer connection on the right bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.
  • Fan will stay ON if controlled by the engine control module (ECM).

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This sensor shares return wires in the engine harness with other sensors. An open or shorted return can cause multiple fault codes to be active. Before troubleshooting this fault code, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 157.

Last Modified: 02-Dec-2015


Intake Manifold 2 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 158

Intake Manifold 2 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 158 PID: SPN: 1131 FMI: 0/0 LAMP: Red SRT: | Intake Manifold 2 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. Intake manifold air temperature signal indicates intake manifold air temperature above engine protection critical limit. | Engine may be shut down.
Intake Manifold 2 Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 2 pressure/temperature sensor is located in the low temperature air transfer connection on the right bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Restricted air flow through the radiator.
  • Malfunctioning high temperature aftercooler element.
  • Malfunctioning low temperature aftercooler element.
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 158.

Last Modified: 02-Dec-2015


Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1618

Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1618 PID: S129 SPN: 1137 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60C [140F].
  • The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1618.

Last Modified: 10-Aug-2015


Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1619

Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1619 PID: S132 SPN: 1140 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60C [140F].
  • The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1619.

Last Modified: 10-Aug-2015


Injector Solenoid Driver Cylinder 9 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1622

Injector Solenoid Driver Cylinder 9 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1622 PID: S9 SPN: 659 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 9 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 9 circuit. | Possible reduced engine performance.
Injector 9 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the two injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.
Refer to Troubleshooting Fault Code 1622.

Last Modified: 11-Dec-2015


Intake Manifold 2 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1636

Intake Manifold 2 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1636 PID: SPN: 1128 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 2 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the intake manifold pressure circuit. | Possible reduced engine performance.
Intake Manifold 2 Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 2 pressure/temperature sensor is located in the low temperature air transfer connection on the right bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
  • A malfunctioning intake manifold pressure sensor
Refer to Troubleshooting Fault Code 1636.

Last Modified: 16-Dec-2015


Intake Manifold 2 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1637

Intake Manifold 2 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1637 PID: SPN: 1128 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold 2 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or open circuit detected at the intake manifold pressure circuit. | Possible reduced engine performance.
Intake Manifold 2 Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 2 pressure/temperature sensor is located in the low temperature air transfer connection on the right bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
  • A malfunctioning intake manifold pressure sensor
Refer to Troubleshooting Fault Code 1637.

Last Modified: 16-Dec-2015


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1668 (2-Wire Sensor)

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1668 (2-Wire Sensor) PID: SPN: 1761 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel exhaust fluid tank level sensor circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid level sensor is used to monitor the diesel exhaust fluid level inside the diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank level sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank level sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1668 (2-Wire Sensor).

Last Modified: 10-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1668 (3-Wire Sensor)

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1668 (3-Wire Sensor) PID: SPN: 1761 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel exhaust fluid tank level sensor circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid level sensor is used to monitor the diesel exhaust fluid level inside the diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank level sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank level sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1668 (3-Wire Sensor).

Last Modified: 10-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1668

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1668 PID: SPN: 1761 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel exhaust fluid tank level sensor circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid level sensor is used to monitor the diesel exhaust fluid level inside the diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank level sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank level sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1668.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1669 (2-Wire Sensor)

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1669 (2-Wire Sensor) PID: SPN: 1761 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the catalyst tank level sensor circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid level sensor is used to monitor the diesel exhaust fluid level inside the diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank level sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank level sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1669 (2-Wire Sensor).

Last Modified: 10-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1669 (3-Wire Sensor)

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1669 (3-Wire Sensor) PID: SPN: 1761 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the catalyst tank level sensor circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid level sensor is used to monitor the diesel exhaust fluid level inside the diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank level sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank level sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1669 (3-Wire Sensor).

Last Modified: 10-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1669

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1669 PID: SPN: 1761 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the catalyst tank level sensor circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid level sensor is used to monitor the diesel exhaust fluid level inside the diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank level sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank level sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1669.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 1673

Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1673 PID: SPN: 1761 FMI: 1/1 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Most Severe Level. The aftertreatment diesel exhaust fluid tank level has fallen below the critical warning level. | None on performance.
Aftertreatment Diesel Exhaust Fluid Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid level sensor is used to monitor the diesel exhaust fluid level inside the diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The diesel exhaust fluid tank was critically low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that the Diesel Exhaust Fluid (DEF) level is critically low.

Refer to Troubleshooting Fault Code 1673.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1677

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1677 PID: SPN: 3031 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the diesel exhaust fluid tank temperature sensor circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is used to monitor the diesel exhaust fluid temperature inside the diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor
  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1677.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source

FAULT CODE 1678

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1678 PID: SPN: 3031 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at the diesel exhaust fluid tank temperature sensor circuit | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is used to monitor the temperature of the aftertreatment diesel exhaust fluid inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor
  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1678.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1679

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1679 PID: SPN: 3031 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Temperature - Data Erratic, Intermittent, or Incorrect. The diesel exhaust fluid tank temperature sensor has indicated a tank temperature too high or too low for the ambient conditions. | None on performance.
Aftertreatment Diesel Exhaust Fluid Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is used to monitor the diesel exhaust fluid temperature inside the diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

The engine must be turned OFF for period of 8 hours before this diagnostic will run. This diagnostic runs when the keyswitch is turned to the ON position after an 8 hour cold soak.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank temperature sensor reading was higher or lower than the other temperature sensors on the engine.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, the engine must be shut down with the keyswitch in the OFF position for 8 hours. After the 8 hour cold soak, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • In-range failure of the diesel exhaust fluid tank temperature sensor
  • Damaged wiring harness

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1679.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists

FAULT CODE 1682

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1682 PID: SPN: 3362 FMI: 11/31 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists. The aftertreatment diesel exhaust fluid dosing unit is unable to prime. | None on performance.
Aftertreatment Diesel Exhaust Fluid Dosing Valve Circuit

Circuit Description

The diesel exhaust fluid dosing unit lines are responsible for transporting diesel exhaust fluid between the dosing unit, dosing valve, and diesel exhaust fluid tank.

Component Location

There are three diesel exhaust fluid lines. One line is between the diesel exhaust fluid tank and the dosing unit (suction line), one line is between the dosing unit and dosing valve (pressure line) and one line is between the dosing valve and the diesel exhaust fluid tank (return line). These lines can be partially hidden from view by the SCR system and other equipment components. Line routing will vary, based on the aftertreatment architecture and the OEM.

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing unit is in the priming or dosing state.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid dosing unit was unable to successfully prime after multiple attempts.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once the aftertreatment diesel exhaust fluid system is able to successfully prime.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low aftertreatment diesel exhaust fluid level in the diesel exhaust fluid tank
  • The line heaters are not successfully thawing the frozen diesel exhaust fluid
  • The diesel exhaust fluid pressure line between the dosing unit and dosing valve is kinked, broken, or disconnected
  • The diesel exhaust fluid suction line between the diesel exhaust fluid tank and the dosing unit is kinked, broken, or disconnected
  • Malfunctioning diesel exhaust fluid dosing unit
  • Debris from the diesel exhaust fluid tank. If debris is found in the diesel exhaust fluid tank, clean the diesel exhaust fluid tank thoroughly and fill with certified diesel exhaust fluid.
  • The diesel exhaust fluid lines are routed incorrectly. Ensure diesel exhaust fluid dosing unit is connected to the corresponding diesel exhaust fluid dosing valve.
Refer to Troubleshooting Fault Code 1682.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Voltage Above Normal or Shorted to High Source

FAULT CODE 1683

Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1683 PID: SPN: 3363 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid tank heater circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater thaws and prevents the diesel exhaust fluid from freezing during operation. The tank heater consists of an electrically powered tank heater control valve which controls the flow of engine coolant to a heating coil inside the diesel exhaust fluid tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The location of the aftertreatment diesel exhaust fluid tank heater control valve will vary depending on the OEM. The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when diesel exhaust fluid tank heating is being commanded.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank heater circuit is shorted to ECM supply voltage or open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid tank heating will be disabled.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Diesel exhaust fluid tank heater signal wire and return wire shorted together
  • Malfunctioning diesel exhaust fluid tank heater control valve

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1683.

Last Modified: 10-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1684

Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1684 PID: SPN: 3363 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel exhaust fluid tank heater circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater thaws and prevents the diesel exhaust fluid from freezing during operation. The tank heater consists of an electrically powered tank heater control valve which controls the flow of engine coolant to a heating coil inside the diesel exhaust fluid tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The location of the aftertreatment diesel exhaust fluid tank heater control valve will vary depending on the OEM. The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when diesel exhaust fluid tank heating is being commanded.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low signal voltage or a short to ground at the diesel exhaust fluid tank heater circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid tank heating will be disabled.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning diesel exhaust fluid tank heater control valve
  • A short circuit to ground
Refer to Troubleshooting Fault Code 1684.

Last Modified: 05-May-2017


Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1685

Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1685 PID: SPN: 3364 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit - Voltage below normal, or shorted to low source | None on performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Aftertreatment DEF quality sensor reported an out of range low voltage condition.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible cause of this fault code:

  • Malfunctioning Aftertreatment DEF Quality Sensor.
Refer to Troubleshooting Fault Code 1685.

Last Modified: 03-May-2016


Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1686

Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1686 PID: SPN: 3364 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit - Voltage above normal, or shorted to high source | None on performance.
Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid quality sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible cause of this fault code:

  • Malfunctioning Aftertreatment DEF Quality Sensor.
Refer to Troubleshooting Fault Code 1686.

Last Modified: 03-May-2016


Fault Code Path Selection

FAULT CODE 1695
Fault Code Path Selection

Is the sensor supply 5 circuit fault code generated from ECM 3 source address 00? | Go to 402-fc1695sa00
Is the sensor supply 5 circuit fault code generated from ECM 2 source address 144? | Go to 402-fc1695sa144

Last Modified: 20-Apr-2016


Sensor Supply 5 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1695 (sa00)

Sensor Supply 5 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1695 (sa00) PID: S232 SPN: 3513 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 5 - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 5 circuit in the OEM harness. | None on performance.
Sensor Supply 5 Circuit

Circuit Description

The sensor supply 5 circuit of the engine control module (ECM) provides a 5 volt supply for various sensors.

Component Location

Sensor Supply 5 originates in the OEM connector portion of the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 5 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

High voltage on the 5-VDC supply wire can be caused by a short circuit to a power supply, a damaged sensor, or a damaged ECM power supply.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1695 (sa00).

Last Modified: 23-May-2016


Sensor Supply 5 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1695 (sa144)

Sensor Supply 5 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1695 (sa144) PID: S232 SPN: 3513 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 5 - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 5 circuit in the OEM harness. | None on performance.
Sensor Supply 5 Circuit

Circuit Description

The sensor supply 5 circuit of the engine control module (ECM) provides a 5 volt supply for various sensors.

Component Location

Sensor Supply 5 originates in the OEM connector portion of the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 5 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

High voltage on the 5-VDC supply wire can be caused by a short circuit to a power supply, a damaged sensor, or a damaged ECM power supply.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1695 (sa144).

Last Modified: 16-Dec-2015


Fault Code Path Selection

FAULT CODE 1696
Fault Code Path Selection

Is the sensor supply 5 circuit fault code generated from ECM 3 source address 00? | Go to 402-fc1696sa00
Is the sensor supply 5 circuit fault code generated from ECM 2 source address 144? | Go to 402-fc1696sa144

Last Modified: 20-Apr-2016


Sensor Supply 5 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1696 (sa00)

Sensor Supply 5 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1696 (sa00) PID: S232 SPN: 3513 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 5 - Voltage Below Normal or Shorted to Low Source. Low voltage detected at sensor supply number 5 circuit in the OEM harness. | None on performance.
Sensor Supply 5 Circuit

Circuit Description

The sensor supply 5 circuit of the engine control module (ECM) provides a 5 volt supply for various sensors.

Component Location

Sensor Supply 5 originates in the OEM connector portion of the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 5 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Low voltage on the 5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a damaged sensor, or a damaged ECM power supply.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1696 (sa00).

Last Modified: 16-Dec-2015


Sensor Supply 5 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1696 (sa144)

Sensor Supply 5 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1696 (sa144) PID: S232 SPN: 3513 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 5 - Voltage Below Normal or Shorted to Low Source. Low voltage detected at sensor supply number 5 circuit in the OEM harness. | None on performance.
Sensor Supply 5 Circuit

Circuit Description

The sensor supply 5 circuit of the engine control module (ECM) provides a 5 volt supply for various sensors.

Component Location

Sensor Supply 5 originates in the OEM connector portion of the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 5 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Low voltage on the 5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a damaged sensor, or a damaged ECM power supply.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1696 (sa144).

Last Modified: 16-Dec-2015


Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 1712

Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1712 PID: SPN: 3363 FMI: 1/18 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level. The aftertreatment diesel exhaust fluid tank heater is unable to thaw the frozen diesel exhaust fluid. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater thaws and prevents the diesel exhaust fluid from freezing during operation. The tank heater consists of an electrically powered tank heater control valve which controls the flow of engine coolant to a heating coil inside the diesel exhaust fluid tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The location of the aftertreatment diesel exhaust fluid tank heater control valve will vary depending on the OEM. The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs a calibrated amount of time after diesel exhaust fluid tank heating is first commanded.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank temperature failed to thaw after the aftertreatment diesel exhaust fluid tank heater control valve was commanded open for a calibrated time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The fault code status in INSITE™ electronic service tool will change to INACTIVE immediately after the system is able to adequately heat and the diagnostic runs and passes. If heating can not be completed, use the "Diesel Exhaust Fluid Doser System Heater Test" found under "ECM Diagnostic Test" in INSITE™ electronic service tool to command heating to the tank heater and all line heaters.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Blockage or restrictons in the coolant plumbing to the diesel exhaust fluid tank heater
  • Malfunctioning aftertreatment diesel exhaust fluid tank heater control valve
  • Aftertreatment DEF tank heater coolant plumbing not connected or malfunctioning.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1712.

Last Modified: 10-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1713

Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1713 PID: SPN: 3363 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level. The diesel exhaust fluid tank heater is continuously in the ON position. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater thaws and prevents the diesel exhaust fluid from freezing during operation. The tank heater consists of an electrically powered tank heater control valve which controls the flow of engine coolant to a heating coil inside the diesel exhaust fluid tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The location of the aftertreatment diesel exhaust fluid tank heater control valve will vary depending on the OEM. The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when diesel exhaust fluid tank heating is NOT being commanded.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the DEF tank temperature was greater than a calibrated temperature, indicating the aftertreatment diesel exhaust fluid tank heater control valve was in the ON position when the ECM was commanding the valve to be in the OFF position.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Before troubleshooting this fault code, make sure the equipment is not equipped with an auxiliary heating device for the diesel exhaust fluid tank. Such a device can result in overheating the diesel exhaust fluid in the tank.

  • This fault code may be inactive when the equipment brought in for service. Even if inactive, follow the troubleshooting tree completely.

Possible causes of this fault code include:

  • Aftertreatment diesel exhaust fluid tank heater control valve installed incorrectly, reversed relative to coolant flow direction.
  • Malfunctioning aftertreatment diesel exhaust fluid tank heater control valve – stuck open or leakage past the valve seat.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1713.

Last Modified: 10-May-2016


Aftertreatment Diesel Exhaust Fluid Quality - Out of Calibration

FAULT CODE 1714

Aftertreatment Diesel Exhaust Fluid Quality - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1714 PID: SPN: 3364 FMI: 13/13 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality - Out of Calibration. The received datalink message was not valid. | None on performance.
Aftertreatment Diesel Exhaut Fluid Quality Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a software or calibration error.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes for this fault code include:

This fault code sets when the ECM detects an internal reset of the sensor. This internal reset is caused by an intermittent voltage supply. All wiring and connectors should be closely inspected for intermittent connections.

Refer to Troubleshooting Fault Code 1714.

Last Modified: 18-May-2016


Aftertreatment Diesel Exhaust Fluid Quality - Root Cause Not Known

FAULT CODE 1715

Aftertreatment Diesel Exhaust Fluid Quality - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1715 PID: SPN: 3364 FMI: 11/11 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality - Root Cause Not Known | None on performance.
Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The DEF quality sensor has detected a read or write error internal to the quality sensor sensing module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code sets when the ECM detects an internal reset of the sensor. This internal reset is caused by an intermittent voltage supply. All wiring and connectors should be closely inspected for intermittent connections.

Refer to Troubleshooting Fault Code 1715.

Last Modified: 03-May-2016


Engine Oil Priming Pump Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1774

Engine Oil Priming Pump Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1774 PID: SPN: 3589 FMI: 3/3 LAMP: Amber SRT: | Engine Oil Priming Pump Control Circuit - Voltage Above Normal or Shorted to High Source. A malfunctioning OEM switch circuit has been detected. | None on performance.
OEM Switch Circuit

Circuit Description

The OEM can configure the OEM switch SIGNAL circuit to be switched to ground or voltage source. Refer to the OEM service manual for information on the engine’s configuration.

Component Location

The OEM switch is located in the engine oil supply system.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and the engine is OFF.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the OEM switch is indicating pre-lubricating pressure is present when engine conditions and the oil pressure sensor indicate it is not.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open or shorted signal circuit.
  • Malfunctioning OEM switch.
Refer to Troubleshooting Fault Code 1774.

Last Modified: 11-Dec-2015


Engine Oil Priming Pump Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1775

Engine Oil Priming Pump Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1775 PID: SPN: 3589 FMI: 4/4 LAMP: Amber SRT: | Engine Oil Priming Pump Control Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected in the oil priming pump control circuit. | None on performance.
Oil Pump Priming Relay

Circuit Description

The OEM switch signal is used by the ECM to determine when adequate pre-lubricating oil pressure has been achieved.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the oil priming pump relay control has been shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and allow the ECM to be powered with the keyswitch ON and the oil priming pump OFF for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Malfunctioning pre-lube pump relay.
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 1775.

Last Modified: 23-May-2016


Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1843

Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1843 PID: P101 SPN: 101 FMI: 3/3 LAMP: Amber SRT: | Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the crankcase pressure circuit. | None on performance.
Engine Crankcase Pressure Sensor

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located in the oil fill hand hole cover on the left bank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the crankcase pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This sensor shares supply and return wires in the engine harness with other sensors. An open or shorted supply or return can cause multiple fault codes to be active. Before troubleshooting this fault code, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal wire shorted to sensor supply or ECM supply voltage.
  • Malfunctioning crankcase pressure sensor.
Refer to Troubleshooting Fault Code 1843.

Last Modified: 16-Dec-2015


Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1844

Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1844 PID: P101 SPN: 101 FMI: 4/4 LAMP: Amber SRT: | Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the crankcase pressure circuit. | None on performance.
Engine Crankcase Pressure Sensor

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located in the oil fill hand hole cover on the left bank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the crankcase pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This sensor shares supply and return wires in the engine harness with other sensors. An open or shorted supply or return can cause multiple fault codes to be active. Before troubleshooting this fault code, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
  • Malfunctioning crankcase pressure sensor.
Refer to Troubleshooting Fault Code 1844.

Last Modified: 16-Dec-2015


Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1845

Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1845 PID: P97 SPN: 97 FMI: 3/3 LAMP: Maintenance SRT: | Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the water-in-fuel circuit. | None on performance.
Water-in-Fuel Sensor Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

Each stage 1 fuel filter has a water in fuel sensor. The wiring harness is connected to two of the water in fuel sensors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the water in fuel sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

Open RETURN or SIGNAL circuit in the harness, connectors, or sensor

Signal wire shorted to sensor supply or ECM supply voltage.

Malfunctioning water in fuel sensor.

Refer to Troubleshooting Fault Code 1845.

Last Modified: 27-Sep-2017


Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1846

Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1846 PID: P97 SPN: 97 FMI: 4/4 LAMP: Maintenance SRT: | Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the water-in-fuel circuit. | None on performance.
Water-in-Fuel Sensor Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

Each stage 1 fuel filter has a water in fuel sensor. The wiring harness is connected to two of the water in fuel sensors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the water in fuel sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

Signal circuit shorted to ground in the harness, sensor or connectors

Malfunctioning water in fuel sensor.

Refer to Troubleshooting Fault Code 1846.

Last Modified: 27-Sep-2017


Engine Coolant Temperature - Special Instructions

FAULT CODE 1847

Engine Coolant Temperature - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1847 PID: P110 SPN: 110 FMI: 14/14 LAMP: Red SRT: | Engine Coolant Temperature - Special Instructions. Engine coolant temperature signal indicates engine coolant temperature is above the engine protection warning limit. | Engine torque output will be reduced. Engine may be shut down.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than 104°C [ 220°F] for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine speed may be limited to engine idle speed.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature.

Refer to Troubleshooting Fault Code 1847.

Last Modified: 02-Dec-2015


Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1852

Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1852 PID: P97 SPN: 97 FMI: /16 LAMP: Amber SRT: | Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level.Â The Water in Fuel Indicator indicates that the water level is above warning level. | None on performance.
Water-in-Fuel Sensor Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

Each stage 1 fuel filter has a water in fuel sensor. The wiring harness is connected to two of the water in fuel sensors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected water in the fuel filter was above the sensor level.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITEâ„¢ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITEâ„¢ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each ECM has an individual source address that displays when INSITEâ„¢ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITEâ„¢ electronic service tool to determine which ECM and circuit is affected.

Water in the fuel can do extensive damage to the fuel system, due to the tight tolerances of the fuel system components.

Bulk fuel supply may be contaminated.

Drain the stage 1 fuel filters and stage 0 fuel-water separator, if equipped.

If this fault code is active and there is no water in the fuel filter then a malfunctioning Water-In-Fuel sensor or water in the sensor connector could be causing the fault.

Refer to Troubleshooting Fault Code 1852.

Last Modified: 27-Jul-2017


Fault Code Path Selection

FAULT CODE 187
Fault Code Path Selection

Is the sensor supply 2 circuit fault code generated from ECM 3 source address 00? | Go to 402-fc187sa00
Is the sensor supply 2 circuit fault code generated from ECM 2 source address 01? | Go to 402-fc187sa01

Last Modified: 20-Apr-2016


Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 187 (sa00)

Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 (sa00) PID: S211 SPN: 3510 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the sensor supply number 2 circuit. | Possible reduced engine performance.
Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 2 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 2 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 2 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Low voltage on the +5 volt supply line can be caused by a short circuit to ground in a supply line, a short circuit between a supply line and a return line, a malfunctioning sensor, or a malfunctioning ECM power supply.

During the fault code response test outlined for each sensor connected to sensor supply number 2, Fault Code 187 must be active before unplugging each sensor. If the fault code is not active, but can be easily duplicated by operating the engine, the following can be performed:

Refer to Troubleshooting Fault Code 187 (sa00).

Last Modified: 02-Dec-2015


Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 187 (sa01)

Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 (sa01) PID: S211 SPN: 3510 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the sensor supply number 2 circuit. | Possible reduced engine performance.
Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 2 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 2 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 2 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Low voltage on the +5 volt supply line can be caused by a short circuit to ground in a supply line, a short circuit between a supply line and a return line, a malfunctioning sensor, or a malfunctioning ECM power supply.

During the fault code response test outlined for each sensor connected to sensor supply number 2, Fault Code 187 must be active before unplugging each sensor. If the fault code is not active, but can be easily duplicated by operating the engine, the following can be performed:

Refer to Troubleshooting Fault Code 187 (sa01).

Last Modified: 02-Dec-2015


Aftertreatment 1 Intake NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1885

Aftertreatment 1 Intake NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1885 PID: SPN: 3216 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 1 Intake NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source. An internal circuit error has been detected by the aftertreatment intake NOx sensor. | None on performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment 1 intake NOx sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment 1 intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment 1 intake NOx sensor is used to measure the NOx emissions at the engine exhaust outlet connection.

Component Location

The aftertreatment 1 intake NOx sensor is mounted on the left bank engine exhaust outlet connection.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment selective catalytic reduction intake temperature has reached a calibrated threshold.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment intake NOx sensor assembly.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • The aftertreatment intake NOx sensor has malfunctioned or is damaged
  • The aftertreatment intake NOx sensor internal heater has malfunctioned
  • The NOx sensor part number is incorrect.
Refer to Troubleshooting Fault Code 1885.

Last Modified: 03-May-2016


Aftertreatment 1 Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1887

Aftertreatment 1 Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1887 PID: SPN: 3226 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source.Â An internal circuit error has been detected by the aftertreatment outlet NOx sensor. | None on performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

The engine is running.

The aftertreatment SCR outlet temperature must be above 180C (356F) before the aftertreatment outlet NOx sensor can run its internal diagnostics.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment outlet NOx sensor assembly.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The aftertreatment SCR outlet temperature must be above 180C (356F) before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

The aftertreatment outlet NOx sensor has malfunctioned or is damaged

The NOx sensor part number is incorrect.

Refer to Troubleshooting Fault Code 1887.

Last Modified: 17-Jan-2018


Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 195 (2-Wire Sensor)

Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 195 (2-Wire Sensor) PID: P111 SPN: 111 FMI: 3/3 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at engine coolant level circuit. | None on performance.
Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This sensor shares return wires in the engine harness with other sensors. An open or shorted return can cause multiple fault codes to be active. Before troubleshooting this fault code, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor.
  • Signal wire shorted to sensor supply or ECM supply voltage.
Refer to Troubleshooting Fault Code 195 (2-Wire Sensor).

Last Modified: 02-Dec-2015


Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 195 (3-Wire Sensor)

Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 195 (3-Wire Sensor) PID: P111 SPN: 111 FMI: 3/3 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at engine coolant level circuit. | None on performance.
Coolant Level Sensor Circuit

Circuit Description

The engine control module (ECM) supplies a 5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor signal circuit. This sensor signal voltage changes based on the coolant level in the expansion tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This sensor shares supply and return wires in the engine harness with other sensors. An open or shorted supply or return can cause multiple fault codes to be active. Before troubleshooting this fault code, check for multiple fault codes.

Possible causes of this fault code include:

  • A signal circuit shorted to sensor supply or ECM supply voltage.
  • An open circuit in the harness
  • A malfunctioning engine coolant level sensor
Refer to Troubleshooting Fault Code 195 (3-Wire Sensor).

Last Modified: 02-Dec-2015


Fault Code Path Selection

FAULT CODE 195
Fault Code Path Selection

Is the coolant level sensor 1 a 2-wire sensor? | Go to 402-fc195-2wire
Is the coolant level sensor 1 a 3-wire sensor? | Go to 402-fc195-3wire

Last Modified: 20-Apr-2016


Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 196 (2-Wire Sensor)

Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 196 (2-Wire Sensor) PID: P111 SPN: 111 FMI: 4/4 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the engine coolant level circuit. | None on performance.
Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This sensor shares return wires in the engine harness with other sensors. An open or shorted return can cause multiple fault codes to be active. Before troubleshooting this fault code, check for multiple fault codes.

Possible causes of this fault code include:

  • Open signal circuit in the engine harness, connectors, or sensor
  • Signal circuit shorted to ground in the harness, sensor or connectors
  • A malfunctioning engine coolant level sensor
Refer to Troubleshooting Fault Code 196 (2-Wire Sensor).

Last Modified: 02-Dec-2015


Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 196 (3-Wire Sensor)

Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 196 (3-Wire Sensor) PID: P111 SPN: 111 FMI: 4/4 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the engine coolant level circuit. | None on performance.
Coolant Level Sensor Circuit

Circuit Description

The engine control module (ECM) supplies a 5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor signal circuit. This sensor signal voltage changes based on the coolant level in the expansion tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This sensor shares supply and return wires in the engine harness with other sensors. An open or shorted supply or return can cause multiple fault codes to be active. Before troubleshooting this fault code, check for multiple fault codes.

Possible causes of this fault code include:

  • A short circuit to ground in the harness
  • An open circuit in the OEM harness
  • A malfunctioning engine coolant level sensor
Refer to Troubleshooting Fault Code 196 (3-Wire Sensor).

Last Modified: 02-Dec-2015


Fault Code Path Selection

FAULT CODE 196
Fault Code Path Selection

Is the coolant level sensor 1 a 2-wire sensor? | Go to 402-fc196-2wire
Is the coolant level sensor 1 a 3-wire sensor? | Go to 402-fc196-3wire

Last Modified: 20-Apr-2016


Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 197

Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 197 PID: P111 SPN: 111 FMI: 1/18 LAMP: Amber SRT: | Coolant Level - Data Valid But Below Normal Operational Range - Moderately Severe Level. Low engine coolant level detected. | None on performance.
Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level was below normal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

If this fault code is active and the coolant level is not low, disconnect the coolant level sensor and check the connectors for traces of coolant. If coolant is found at the electrical connectors, the sensor has malfunctioned and must be replaced.

Refer to Troubleshooting Fault Code 197.

Last Modified: 02-Dec-2015


Intake Manifold 2 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1984

Intake Manifold 2 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1984 PID: SPN: 1131 FMI: 0/16 LAMP: Amber SRT: | Intake Manifold 2 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. Intake manifold air temperature signal indicates intake manifold air temperature is above engine protection warning limit. | Possible reduced engine performance.
Intake Manifold 2 Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 2 pressure/temperature sensor is located in the low temperature air transfer connection on the right bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature was greater than a calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The intake manifold air temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Restricted air flow through the radiator.
  • Malfunctioning high temperature aftercooler element.
  • Malfunctioning low temperature aftercooler element.
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 1984.

Last Modified: 16-Dec-2015


Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 212

Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 212 PID: P175 SPN: 175 FMI: 3/3 LAMP: Amber SRT: | Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or an open circuit detected at the engine oil temperature circuit. | None on performance.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil pan.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the engine oil temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This sensor shares return wires in the engine harness with other sensors. An open or shorted return can cause multiple fault codes to be active. Before troubleshooting this fault code, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
  • A malfunctioning oil temperature sensor.
Refer to Troubleshooting Fault Code 212.

Last Modified: 02-Dec-2015


Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2121

Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2121 PID: S129 SPN: 1137 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Above Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The temperature to clear this fault code is lower than the temperature it set at.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2121.

Last Modified: 10-May-2016


Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2122

Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2122 PID: S131 SPN: 1139 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Above Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60C [140F].
  • Net engine torque is above a calibrated threshold.
  • The engine speed is greater than the calibrated threshold.
  • The exhaust gas temperature sensor reading is above engine average by a calibrated amount continuously for a calibrated time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2122.

Last Modified: 16-Dec-2015


Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2123

Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2123 PID: S133 SPN: 1141 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Above Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60C [140F].
  • Net engine torque is above a calibrated threshold.
  • The engine speed is greater than the calibrated threshold.
  • The exhaust gas temperature sensor reading is above engine average by a calibrated amount continuously for a calibrated time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2123.

Last Modified: 16-Dec-2015


Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2124

Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2124 PID: S135 SPN: 1143 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Above Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60C [140F].
  • Net engine torque is above a calibrated threshold.
  • The engine speed is greater than the calibrated threshold.
  • The exhaust gas temperature sensor reading is above engine average by a calibrated amount continuously for a calibrated time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2124.

Last Modified: 16-Dec-2015


Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2125

Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2125 PID: S137 SPN: 1145 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Above Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60C [140F].
  • Net engine torque is above a calibrated threshold.
  • The engine speed is greater than the calibrated threshold.
  • The exhaust gas temperature sensor reading is above engine average by a calibrated amount continuously for a calibrated time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2125.

Last Modified: 16-Dec-2015


Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2126

Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2126 PID: S139 SPN: 1147 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Above Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60C [140F].
  • Net engine torque is above a calibrated threshold.
  • The engine speed is greater than the calibrated threshold.
  • The exhaust gas temperature sensor reading is above engine average by a calibrated amount continuously for a calibrated time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2126.

Last Modified: 16-Dec-2015


Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2127

Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2127 PID: S141 SPN: 1149 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Above Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60C [140F].
  • Net engine torque is above a calibrated threshold.
  • The engine speed is greater than the calibrated threshold.
  • The exhaust gas temperature sensor reading is above engine average by a calibrated amount continuously for a calibrated time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2127.

Last Modified: 16-Dec-2015


Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2128

Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2128 PID: S143 SPN: 1151 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Above Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60C [140F].
  • Net engine torque is above a calibrated threshold.
  • The engine speed is greater than the calibrated threshold.
  • The exhaust gas temperature sensor reading is above engine average by a calibrated amount continuously for a calibrated time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2128.

Last Modified: 16-Dec-2015


Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 213

Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 213 PID: P175 SPN: 175 FMI: 4/4 LAMP: Amber SRT: | Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the engine oil temperature circuit. | None on performance.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil pan.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the engine oil temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This sensor shares return wires in the engine harness with other sensors. An open or shorted return can cause multiple fault codes to be active. Before troubleshooting this fault code, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the engine harness
  • Signal shorted to return or ground in the sensor.
  • A malfunctioning oil temperature sensor.
Refer to Troubleshooting Fault Code 213.

Last Modified: 02-Dec-2015


Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2131

Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2131 PID: S130 SPN: 1138 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Above Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60C [140F].
  • Net engine torque is above a calibrated threshold.
  • The engine speed is greater than the calibrated threshold.
  • The exhaust gas temperature sensor reading is above engine average by a calibrated amount continuously for a calibrated time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2131.

Last Modified: 16-Dec-2015


Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2132

Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2132 PID: S132 SPN: 1140 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Above Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60C [140F].
  • Net engine torque is above a calibrated threshold.
  • The engine speed is greater than the calibrated threshold.
  • The exhaust gas temperature sensor reading is above engine average by a calibrated amount continuously for a calibrated time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2132.

Last Modified: 16-Dec-2015


Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2133

Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2133 PID: S134 SPN: 1142 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Above Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60C [140F].
  • Net engine torque is above a calibrated threshold.
  • The engine speed is greater than the calibrated threshold.
  • The exhaust gas temperature sensor reading is above engine average by a calibrated amount continuously for a calibrated time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2133.

Last Modified: 16-Dec-2015


Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2134

Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2134 PID: S136 SPN: 1144 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Above Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60C [140F].
  • Net engine torque is above a calibrated threshold.
  • The engine speed is greater than the calibrated threshold.
  • The exhaust gas temperature sensor reading is above engine average by a calibrated amount continuously for a calibrated time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2134.

Last Modified: 16-Dec-2015


Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2135

Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2135 PID: S138 SPN: 1146 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Above Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60C [140F].
  • Net engine torque is above a calibrated threshold.
  • The engine speed is greater than the calibrated threshold.
  • The exhaust gas temperature sensor reading is above engine average by a calibrated amount continuously for a calibrated time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2135.

Last Modified: 16-Dec-2015


Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2136

Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2136 PID: S140 SPN: 1148 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Above Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60C [140F].
  • Net engine torque is above a calibrated threshold.
  • The engine speed is greater than the calibrated threshold.
  • The exhaust gas temperature sensor reading is above engine average by a calibrated amount continuously for a calibrated time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2136.

Last Modified: 16-Dec-2015


Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2137

Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2137 PID: S142 SPN: 1150 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Above Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60C [140F].
  • Net engine torque is above a calibrated threshold.
  • The engine speed is greater than the calibrated threshold.
  • The exhaust gas temperature sensor reading is above engine average by a calibrated amount continuously for a calibrated time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2137.

Last Modified: 16-Dec-2015


Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2138

Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2138 PID: S144 SPN: 1152 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Above Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60C [140F].
  • Net engine torque is above a calibrated threshold.
  • The engine speed is greater than the calibrated threshold.
  • The exhaust gas temperature sensor reading is above engine average by a calibrated amount continuously for a calibrated time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2138.

Last Modified: 16-Dec-2015


Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 214

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 214 PID: P175 SPN: 175 FMI: 0/0 LAMP: Red SRT: | Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. Engine oil temperature signal indicates engine oil temperature above engine protection critical limit. | Engine may be shut down.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil pan.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that the engine oil temperature has exceeded the maximum engine protection limit for oil temperature. Troubleshoot the cause of high engine oil temperature.

Refer to Troubleshooting Fault Code 214.

Last Modified: 02-Dec-2015


Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2185

Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2185 PID: S232 SPN: 3512 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at 5 VDC sensor supply circuit to the accelerator pedal position sensor. | Engine will only idle.
Sensor Supply 4 Circuit

Circuit Description

Sensor supply 4 of the engine control module (ECM) provides a 5 VDC supply to the accelerator pedal position sensor.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 4 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The engine will only idle.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2185.

Last Modified: 11-Dec-2015


Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2186

Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2186 PID: S232 SPN: 3512 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the 5 VDC sensor supply circuit to the accelerator pedal position sensor. | Engine will only idle.
Sensor Supply 4 Circuit

Circuit Description

Sensor supply 4 of the engine control module (ECM) provides a 5 VDC supply to the accelerator pedal position sensor.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 4 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The engine will only idle.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2186.

Last Modified: 11-Dec-2015


Engine Oil Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2196

Engine Oil Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2196 PID: P175 SPN: 175 FMI: 1/18 LAMP: Amber SRT: | Engine Oil Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level. The engine control module (ECM) has detected the oil temperature is below a calibrated threshold and a normal Start was attempted. | Engine may not start.
Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil pan.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is attempting to start.

Conditions for Setting the Fault Codes

The engine control module (ECM) has detected the oil temperature is below a calibrated threshold and a normal Start was attempted.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The engine will not start.

Conditions for Clearing the Fault Code

  • Heat the lubricating oil system and perform a normal Start.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is information only. No troubleshooting necessary.

This fault code indicates that normal Starting was inhibited due to oil temperature being below a calibrated threshold. Oil temperature must be increased to complete a Pre-Lube cycle and a normal Start.

Refer to Troubleshooting Fault Code 2196.

Last Modified: 22-Mar-2017


Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 221

Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 221 PID: P108 SPN: 108 FMI: 3/3 LAMP: Amber SRT: | Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at barometric pressure circuit. | Possible reduced engine performance.
Barometric Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes occur based on the elevation where the engine is presently operating. The barometric pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

Component Location

The barometric pressure sensor is located on the left bank engine harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the barometric air pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the barometric pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This sensor shares supply and return wires in the engine harness with other sensors. An open or shorted supply or return can cause multiple fault codes to be active. Before troubleshooting this fault code, check for multiple fault codes.

Possible causes of this fault code include:

  • A short circuit to ECM supply voltage in the engine harness.
  • An open return circuit in the engine harness
  • A malfunctioning barometric air pressure sensor
Refer to Troubleshooting Fault Code 221.

Last Modified: 02-Dec-2015


Fuel Pump Delivery Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2215

Fuel Pump Delivery Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2215 PID: P94 SPN: 94 FMI: 1/18 LAMP: Amber SRT: | Fuel Pump Delivery Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low fuel delivery pressure has been detected. | Possible reduced engine performance.
Fuel Delivery Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel delivery pressure sensor using a sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel delivery pressure sensor provides a fuel delivery pressure signal to the ECM on the fuel delivery pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the low pressure fuel delivery system. The ECM will detect a high signal voltage at high delivery pressure conditions. The ECM will detect a low signal voltage during low delivery pressure conditions.

Component Location

The fuel delivery pressure sensor is located on the outlet of the stage 2 fuel filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel delivery pressure was lower than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Fuel inlet restriction high.
  • Stage 1 fuel filter restriction excessive.
  • Stage 2 fuel filter restriction excessive.
  • Air in the fuel
  • Malfunctioning fuel delivery pressure sensor.
  • Malfunctioning engine fuel supply pump.
Refer to Troubleshooting Fault Code 2215.

Last Modified: 03-May-2016


Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 222

Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 222 PID: P108 SPN: 108 FMI: 4/4 LAMP: Amber SRT: | Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at barometric pressure circuit. | Possible reduced engine performance.
Barometric Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes occur based on the elevation where the engine is presently operating. The barometric pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

Component Location

The barometric pressure sensor is located on the left bank engine harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the barometric air pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the barometric pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This sensor shares supply and return wires in the engine harness with other sensors. An open or shorted supply or return can cause multiple fault codes to be active. Before troubleshooting this fault code, check for multiple fault codes.

Possible causes of this fault code include:

  • A short circuit to ground in the engine harness
  • An open circuit in the engine harness
  • A malfunctioning barometric air pressure sensor
Refer to Troubleshooting Fault Code 222.

Last Modified: 02-Dec-2015


Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 2249

Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2249 PID: P157 SPN: 157 FMI: 1/1 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Most Severe Level. The ECM has detected that fuel pressure is lower than commanded pressure. | Engine may run rough, may stop running, may not start, or may be difficult to start.
ECM

Circuit Description

The engine control module (ECM) monitors engine operating conditions, including the reading of fuel rail pressure, and changes the flow command to either increase (OPEN the fuel metering valve) or decrease (CLOSE the fuel metering valve) the fuel supply to the high-pressure pump.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel metering valve, fuel rail pressure sensor, and fuel pressure relief valve are mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the measured fuel rail pressure was below commanded fuel rail pressure by a calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes for this fault code include:

  • High fuel inlet restriction
  • Malfunctioning high-pressure fuel pump
  • Leaking fuel rail pressure relief valve
  • Leaking injectors and/or injector supply lines
Refer to Troubleshooting Fault Code 2249.

Last Modified: 11-Dec-2015


Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2261

Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2261 PID: P94 SPN: 94 FMI: 0/15 LAMP: Maintenance SRT: | Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Least Severe Level. High fuel delivery pressure has been detected. | Possible reduced engine performance.
Fuel Delivery Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel delivery pressure sensor using a sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel delivery pressure sensor provides a fuel delivery pressure signal to the ECM on the fuel delivery pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the low pressure fuel delivery system. The ECM will detect a high signal voltage at high delivery pressure conditions. The ECM will detect a low signal voltage during low delivery pressure conditions.

Component Location

The fuel delivery pressure sensor is located on the outlet of the stage 2 fuel filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel delivery pressure was higher than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Fuel supply line pinched or damaged
  • Malfunctioning fuel delivery pressure sensor.
  • Malfunctioning engine fuel supply pump.
Refer to Troubleshooting Fault Code 2261.

Last Modified: 03-May-2016


Fuel Pump Delivery Pressure - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 2262

Fuel Pump Delivery Pressure - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2262 PID: P94 SPN: 94 FMI: 1/17 LAMP: Maintenance SRT: | Fuel Pump Delivery Pressure - Data Valid But Below Normal Operating Range - Least Severe Level. Low fuel delivery pressure has been detected. | Possible reduced engine performance.
Fuel Delivery Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel delivery pressure sensor using a sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel delivery pressure sensor provides a fuel delivery pressure signal to the ECM on the fuel delivery pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the low pressure fuel delivery system. The ECM will detect a high signal voltage at high delivery pressure conditions. The ECM will detect a low signal voltage during low delivery pressure conditions.

Component Location

The fuel delivery pressure sensor is located on the outlet of the stage 2 fuel filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel delivery pressure was lower than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Fuel inlet restriction high.
  • Stage 1 fuel filter restriction excessive.
  • Stage 2 fuel filter restriction excessive.
  • Air in the fuel
  • Malfunctioning fuel delivery pressure sensor.
  • Malfunctioning engine fuel supply pump.
Refer to Troubleshooting Fault Code 2262.

Last Modified: 03-May-2016


Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 227

Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 227 PID: S211 SPN: 3510 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 2 circuit. | Possible reduced engine performance.
ECM 1 Sensor Supply 2 Circuit
ECM 2 Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 2 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 2 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 2 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

High voltage on the +5 volt supply wire can be caused by a short to ECM supply voltage in the engine harness or connectors, or a damaged ECM.

Refer to Troubleshooting Fault Code 227.

Last Modified: 02-Dec-2015


Coolant Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 228

Coolant Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 228 PID: P109 SPN: 109 FMI: 1/1 LAMP: Red SRT: | Coolant Pressure - Data Valid But Below Normal Operating Range - Most Severe Level. Low coolant pressure has been detected. | Engine may be shut down.
Engine Coolant Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the coolant pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The coolant pressure sensor provides a signal to the ECM on the coolant pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the cooling system.

Component Location

The coolant pressure sensor is located on the high temperature circuit outlet of the water pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant pressure was less than the engine protection limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low coolant level
  • A malfunctioning radiator cap.
  • A malfunctioning coolant pressure sensor.
  • A malfunctioning water pump.
Refer to Troubleshooting Fault Code 228.

Last Modified: 02-Dec-2015


Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2288

Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2288 PID: P103 SPN: 103 FMI: 0/15 LAMP: None SRT: | Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Least Severe Level. High turbocharger speed has been detected by the ECM. | Possible reduced engine performance.
Turbocharger Speed Sensor Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The Engine Control Module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor 1 is located on the left bank front turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger speed was above the maximum calibratible limits.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

When the engine has taken the necessary action to reduce the turbocharger speed, this fault code is logged. This fault code is for information only and no repairs are necessary. The engine can possibly be derated when operating near the maximum turbocharger speed limits.

Refer to Troubleshooting Fault Code 2288.

Last Modified: 11-Dec-2015


Coolant Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 231

Coolant Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 231 PID: P109 SPN: 109 FMI: 3/3 LAMP: Amber SRT: | Coolant Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at coolant pressure circuit. | None on performance.
Engine Coolant Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the coolant pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The coolant pressure sensor provides a signal to the ECM on the coolant pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the cooling system.

Component Location

The coolant pressure sensor is located on the high temperature circuit outlet of the water pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This sensor shares supply and return wires in the engine harness with other sensors. An open or shorted supply or return can cause multiple fault codes to be active. Before troubleshooting this fault code, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Signal wire shorted to sensor supply or ECM supply voltage.
  • A malfunctioning coolant pressure sensor.
Refer to Troubleshooting Fault Code 231.

Last Modified: 02-Dec-2015


Coolant Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 232

Coolant Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 232 PID: P109 SPN: 109 FMI: 4/4 LAMP: Amber SRT: | Coolant Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at coolant pressure circuit. | None on performance.
Engine Coolant Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the coolant pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The coolant pressure sensor provides a signal to the ECM on the coolant pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the cooling system.

Component Location

The coolant pressure sensor is located on the high temperature circuit outlet of the water pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This sensor shares supply and return wires in the engine harness with other sensors. An open or shorted supply or return can cause multiple fault codes to be active. Before troubleshooting this fault code, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness, sensor, or connector.
  • Supply wire open or shorted to ground.
  • A malfunctioning coolant pressure sensor.
Refer to Troubleshooting Fault Code 232.

Last Modified: 02-Dec-2015


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 234

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: P190 SPN: 190 FMI: 0/0 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid But Above Normal Operational Range - Most Severe Level. Engine speed signal indicates engine speed above engine protection limit. | Engine will shut down.
Crankshaft Position Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5-VDC supply to the crankshaft position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. As holes drilled in the flywheel move past the position sensor, a signal is generated on the signal circuit. The ECM uses this signal to determine engine speed and position. Offset spacing of the drillings indicate to the ECM the engine position.

Component Location

The crankshaft position sensor is located on the left bank side of the engine in the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine speed had exceeded the calibration limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • External fuel sources drawn into the intake air passage
  • Tampering of the engine speed/position sensors.

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify there are no oil leaks. Inspect the engine speed/position sensors for damage or tampering.

Refer to Troubleshooting Fault Code 234.

Last Modified: 02-Dec-2015


Fuel Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2343

Fuel Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2343 PID: P95 SPN: 95 FMI: 0/15 LAMP: Maintenance SRT: | Fuel filter restriction has exceeded a pre-set threshold. | Possible reduced engine performance.
Engine Fuel Supply Pump

Circuit Description

The engine fuel supply pump uses fuel delivery pressure, pump speed, and pump motor current to calculate stage 2 fuel filter restriction.

Component Location

The engine fuel supply pump is located on the left side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The engine fuel supply pump has detected that stage 2 fuel filter restriction was above a customer determined threshold.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code is intended to allow customizeable early detection of stage 2 filter plugging. The fault threshold can be configured based on the engine fuel supply pump stage 2 filter life monitor parameter.

Refer to Troubleshooting Fault Code 2343 .

Last Modified: 21-Aug-2019


Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 235

Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 235 PID: P111 SPN: 111 FMI: 1/1 LAMP: Red SRT: | Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level. The engine coolant is severely low. | Engine torque output will be reduced. Engine may be shut down.
Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level was below normal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

If this fault code is active and the coolant level is not low, disconnect the coolant level sensor and check the connectors for traces of coolant. If coolant is found at the electrical connectors, the sensor has malfunctioned and must be replaced.

Refer to Troubleshooting Fault Code 235.

Last Modified: 02-Dec-2015


Fuel Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2372

Fuel Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2372 PID: P95 SPN: 95 FMI: 0/16 LAMP: Amber SRT: | Excessive fuel flow restriction to the high pressure fuel pump has been detected. | Possible reduced engine performance.
Engine Fuel Supply Pump

Circuit Description

The engine fuel supply pump uses fuel delivery pressure, pump speed, and pump motor current to calculate stage 2 fuel filter restriction.

Component Location

The engine fuel supply pump is located on the left side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The engine fuel supply pump has detected high stage 2 fuel filter restriction.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Stage 2 fuel filter restriction excessive.

Malfunctioning fuel delivery pressure sensor.

Malfunctioning engine fuel supply pump.

Refer to Troubleshooting Fault Code 2372 .

Last Modified: 21-Aug-2019


Fan Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2377

Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2377 PID: S33 SPN: 647 FMI: 3/3 LAMP: Amber SRT: | Fan Control Circuit - Voltage Above Normal or Shorted to High Source. Open circuit or high voltage detected at the fan control circuit. | The fan can stay on continuously or not run at all.
Fan Control Circuit

Circuit Description

The fan control circuit is a device used by the engine to control the fan operation. When the engine control module (ECM) energizes the fan control circuit, the engine fan is engaged.

The fan control circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

There are two types of fans supported by the fan control circuit; variable speed and ON/OFF. INSITE™ electronic service tool can be used to determine which fan type is currently set up for use. The fan control circuit varies by original equipment manufacturer (OEM). Certain OEMs can use a solenoid return that is wired to the ECM or can use a return that goes to the engine block or chassis ground.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM service manual to determine the location.

Conditions for Running the Diagnostics

For ON/OFF and variable speed fan types, the diagnostic runs when the fan is turned off and will latch active when the fan PWM signal is 100 percent. For all other fan types, the diagnostic runs when the fan PWM signal is less than 100 percent and will latch active when the fan PWM signal is 100 percent.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fan control circuit pulse width modulated (PWM) signal voltage was greater then 0-VDC when the PWM signal was commanded OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Fan operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If Fault Code 2377 is still active after completing all the steps in this fault code troubleshooting tree, consult the OEM service literature for procedures to check the fan clutch device for an open circuit or short circuit to ground.

Possible causes of this fault include:

  • An open circuit in the harness or fan control solenoid.
  • A short circuit to voltage source in the wiring harness
  • A malfunctioning ECM.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2377.

Last Modified: 10-Aug-2015


Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 238

Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 238 PID: S232 SPN: 3511 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected on the +5 volt sensor supply circuit to the crankshaft position sensor. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides a 5 volt supply to the crankshaft position sensor.

Component Location

Sensor supply 3 originates in the engine connector portion of the ECM. It provides 5 VDC to the crankshaft position sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 3 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The camshaft position sensor will be used by the ECM to determine engine speed and position.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Short circuit to ground in the engine harness, sensor, or ECM.
Refer to Troubleshooting Fault Code 238.

Last Modified: 02-Dec-2015


Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 239

Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 239 PID: S232 SPN: 3511 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected on the 5 volt sensor supply circuit to the crankshaft position sensor. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides a 5 volt supply to the crankshaft position sensor.

Component Location

Sensor supply 3 originates in the engine connector portion of the ECM. It provides 5 VDC to the crankshaft position sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 3 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The camshaft position sensor will be used by the ECM to determine engine speed and position.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

High voltage on the +5 volt supply wire can be caused by a short to ECM supply voltage in the engine harness or connectors, or a damaged ECM.

Refer to Troubleshooting Fault Code 239.

Last Modified: 02-Dec-2015


Injector Solenoid Driver Cylinder 1 - Out of Calibration

FAULT CODE 2442

Injector Solenoid Driver Cylinder 1 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2442 PID: S1 SPN: 651 FMI: 13/13 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 1 - Out of Calibration. Invalid injector barcode information has been entered. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 1 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode needs to be entered into the ECM with INSITE™ electronic service tool. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector barcode values can be read directly off the top of each injector without the need of removing any additional parts. Use INSITE™ electronic service tool to enter the barcode values into the ECM for this fault code to go inactive.

Refer to Troubleshooting Fault Code 2442.

Last Modified: 10-Aug-2015


Injector Solenoid Driver Cylinder 2 - Out of Calibration

FAULT CODE 2443

Injector Solenoid Driver Cylinder 2 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2443 PID: S2 SPN: 652 FMI: 13/13 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 2 - Out of Calibration. Invalid injector barcode information has been entered. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 2 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode needs to be entered into the ECM with INSITE™ electronic service tool. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector barcode values can be read directly off the top of each injector without the need of removing any additional parts. Use INSITE™ electronic service tool to enter the barcode values into the ECM for this fault code to go inactive.

Refer to Troubleshooting Fault Code 2443.

Last Modified: 10-Aug-2015


Injector Solenoid Driver Cylinder 3 - Out of Calibration

FAULT CODE 2444

Injector Solenoid Driver Cylinder 3 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2444 PID: S3 SPN: 653 FMI: 13/13 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 3 - Out of Calibration. Invalid injector barcode information has been entered. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 3 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode needs to be entered into the ECM with INSITE™ electronic service tool. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector barcode values can be read directly off the top of each injector without the need of removing any additional parts. Use INSITE™ electronic service tool to enter the barcode values into the ECM for this fault code to go inactive.

Refer to Troubleshooting Fault Code 2444.

Last Modified: 10-Aug-2015


Injector Solenoid Driver Cylinder 4 - Out of Calibration

FAULT CODE 2445

Injector Solenoid Driver Cylinder 4 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2445 PID: S4 SPN: 654 FMI: 13/13 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 4 - Out of Calibration. Invalid injector barcode information has been entered. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 4 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode needs to be entered into the ECM with INSITE™ electronic service tool. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector barcode values can be read directly off the top of each injector without the need of removing any additional parts. Use INSITE™ electronic service tool to enter the barcode values into the ECM for this fault code to go inactive.

Refer to Troubleshooting Fault Code 2445.

Last Modified: 10-Aug-2015


Injector Solenoid Driver Cylinder 5 - Out of Calibration

FAULT CODE 2446

Injector Solenoid Driver Cylinder 5 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2446 PID: S5 SPN: 655 FMI: 13/13 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 5 - Out of Calibration. Invalid injector barcode information has been entered. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 5 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode needs to be entered into the ECM with INSITE™ electronic service tool. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector barcode values can be read directly off the top of each injector without the need of removing any additional parts. Use INSITE™ electronic service tool to enter the barcode values into the ECM for this fault code to go inactive.

Refer to Troubleshooting Fault Code 2446.

Last Modified: 10-Aug-2015


Injector Solenoid Driver Cylinder 6 - Out of Calibration

FAULT CODE 2447

Injector Solenoid Driver Cylinder 6 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2447 PID: S6 SPN: 656 FMI: 13/13 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 6 - Out of Calibration. Invalid injector barcode information has been entered. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 6 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode needs to be entered into the ECM with INSITE™ electronic service tool. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector barcode values can be read directly off the top of each injector without the need of removing any additional parts. Use INSITE™ electronic service tool to enter the barcode values into the ECM for this fault code to go inactive.

Refer to Troubleshooting Fault Code 2447.

Last Modified: 10-Aug-2015


Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 245

Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 245 PID: S33 SPN: 647 FMI: 4/4 LAMP: Amber SRT: | Fan Control Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the fan control circuit when commanded ON. | The fan can stay on continuously or not run at all.
Fan Control Circuit

Circuit Description

The fan control circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

There are two types of fans supported by the fan control circuit; variable speed and ON/OFF. INSITE™ electronic service tool can be used to determine which fan type is presently set up for use. The fan control circuit varies by the OEM. OEMs can use a solenoid return that is wired to the ECM or use a return that goes to engine block or chassis ground.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM service manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fan control circuit pulse width modulated (PWM) signal was not at system voltage when the pulse width modulated (PWM) signal was commanded ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Fan operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The fan control logic can be adjusted with INSITE™ electronic service tool. There are two choices: 12 or 24 volts ON, or 0 volts ON. For proper fan operation, the fan control logic setup with INSITE™ electronic service tool must match the hardware configuration on the vehicle.

This fault code is logged when the ECM commands 12 or 24-VDC to the fan control solenoid, but the voltage on the fan control signal circuit is less than 12 or 24-VDC. The low voltage on the signal circuit usually indicates a short circuit to ground in the harness or solenoid.

If Fault Code 245 is still active after completing the following troubleshooting steps, consult the OEM service manual for procedures to check the fan control circuit for a short circuit to ground.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 245.

Last Modified: 10-Aug-2015


Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2474

Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2474 PID: P103 SPN: 103 FMI: 2/2 LAMP: Maintenance SRT: | Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect. An invalid turbocharger speed signal has been detected by the ECM. | Possible reduced engine performance.
Turbocharger Speed Sensor Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The Engine Control Module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor 1 is located on the left bank front turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic only runs when engine speed is greater than 1250 RPM and the ratio of boost pressure to barometric pressure is at or above 1.2.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger speed was less than 3000 RPM for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • The ECM will estimate the turbocharger speed.

Conditions for Clearing the Fault Code

  • To validate the repair, it will be necessary to operate the engine under load in order to get the intake manifold pressure high enough for the diagnostic to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Damaged turbocharger speed sensor
  • Damaged engine harness
Refer to Troubleshooting Fault Code 2474.

Last Modified: 03-Feb-2016


Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 249

Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 249 PID: P171 SPN: 171 FMI: 3/3 LAMP: Amber SRT: | Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at ambient air temperature circuit. | None on performance.
Ambient Air Temperature Sensor Circuit

Circuit Description

The ambient air temperature sensor is a variable resistor and is used to measure the temperature of the ambient air. The engine control module (ECM) uses this temperature reading to determine if heating of the DEF dosing system is required. The engine control module (ECM) supplies 5 volts to the ambient air temperature signal circuit. The engine control module (ECM) monitors the change in voltage caused by changes in the resistance of the sensor to determine the ambient air temperature.

Component Location

The mounting location for the ambient air temperature sensor is OEM dependent. Refer to the appropriate OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the ambient air temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the ambient air temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 249.

Last Modified: 02-Dec-2015


Engine Turbocharger Wastegate Actuator 2 Position Control - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 251

Engine Turbocharger Wastegate Actuator 2 Position Control - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 251 PID: S88 SPN: 1189 FMI: 7/7 LAMP: Amber SRT: | Engine Turbocharger Wastegate Actuator 2 Position Control - Mechanical System Not Responding or Out of Adjustment. The turbocharger wastegate is unable to meet commanded position. | Possible reduced engine performance.
Turbocharger Wastegate 2 Circuit

Circuit Description

The turbocharger wastegate is controlled by a brushless motor located on top of the wastegate valve. The turbocharger wastegate motor uses three different motor legs to move the valve through its range of motion. The ECM uses the turbocharger wastegate motor A, B, and C wires to command the turbocharger wastegate to the appropriate position in order to maintain appropriate intake manifold pressure and turbocharger speed. The turbocharger wastegate motor contains three position sensors that detect the location of the wastegate. These sensors report the position of the wastegate back to the ECM over the turbocharger wastegate position A, B, and C wires.

Component Location

Turbocharger wastegates are mounted on the outboard side of the exhaust outlet connections.

The turbocharger wastegate position sensors are internal to the turbocharger wastegate assembly and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The turbocharger wastegate was unable to reach the commanded position for more than 30 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Intermittent open or short in the wiring harness
  • Malfunctioning turbocharger wastegate
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 251.

Last Modified: 02-Dec-2015


Engine ECU Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2544

Engine ECU Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2544 PID: P21 SPN: 1136 FMI: 0/0 LAMP: Red SRT: | Engine ECU Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. High internal ECM temperature detected. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

The Engine Control Module (ECM) internal temperature sensor is located inside the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected internal temperatures above the critical limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Incorrect or restricted air flow over the ECM and engine.
  • Malfunctioning engine control module (ECM) cooling system.
Refer to Troubleshooting Fault Code 2544.

Last Modified: 16-Dec-2015


Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 256

Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 256 PID: P171 SPN: 171 FMI: 4/4 LAMP: Amber SRT: | Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at ambient air temperature circuit. | None on performance.
Ambient Air Temperature Sensor Circuit

Circuit Description

The ambient air temperature sensor is a variable resistor and is used to measure the temperature of the ambient air. The engine control module (ECM) uses this temperature reading to determine if heating of the DEF dosing system is required. The engine control module (ECM) supplies 5 volts to the ambient air temperature signal circuit. The engine control module (ECM) monitors the change in voltage caused by changes in the resistance of the sensor to determine the ambient air temperature.

Component Location

The mounting location for the ambient air temperature sensor is OEM dependent. Refer to the appropriate OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the ambient air temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the ambient air temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 256.

Last Modified: 02-Dec-2015


Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 261

Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 261 PID: P174 SPN: 174 FMI: 0/16 LAMP: Amber SRT: | Fuel temperature above the warning level has been detected. | Possible reduced engine performance.
Engine Fuel Temperature Sensor Circuit

Circuit Description

The engine fuel temperature sensor is a variable resistor sensor and is used to measure the temperature of the fuel at the stage 2 filter housing. The engine control module (ECM) supplies 5 volts to the engine fuel temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the delivery fuel temperature.

Component Location

The engine fuel temperature sensor is located in the stage 2 fuel filter housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine fuel temperature exceeded the warning limit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Malfunctioning fuel cooler.

Operating the engine in a hot ambient environment with a low fuel tank level

  • Malfunctioning fuel heat exchanger control valve.
Refer to Troubleshooting Fault Code 261.

Last Modified: 19-Feb-2019


Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 263

Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 263 PID: P174 SPN: 174 FMI: 3/3 LAMP: Amber SRT: | Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the engine fuel temperature circuit. | None on performance.
Engine Fuel Temperature Sensor Circuit

Circuit Description

The engine fuel temperature sensor is a variable resistor sensor and is used to measure the temperature of the fuel at the stage 2 filter housing. The engine control module (ECM) supplies 5 volts to the engine fuel temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the delivery fuel temperature.

Component Location

The engine fuel temperature sensor is located in the stage 2 fuel filter housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine fuel temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the engine fuel temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This sensor shares return wires in the engine harness with other sensors. An open or shorted return can cause multiple fault codes to be active. Before troubleshooting this fault code, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source
  • Malfunctioning fuel temperature sensor
Refer to Troubleshooting Fault Code 263.

Last Modified: 03-May-2016


Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 265

Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 265 PID: P174 SPN: 174 FMI: 4/4 LAMP: Amber SRT: | Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the engine fuel temperature sensor circuit. | None on performance.
Engine Fuel Temperature Sensor Circuit

Circuit Description

The engine fuel temperature sensor is a variable resistor sensor and is used to measure the temperature of the fuel at the stage 2 filter housing. The engine control module (ECM) supplies 5 volts to the engine fuel temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the delivery fuel temperature.

Component Location

The engine fuel temperature sensor is located in the stage 2 fuel filter housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine fuel temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the engine fuel temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This sensor shares return wires in the engine harness with other sensors. An open or shorted return can cause multiple fault codes to be active. Before troubleshooting this fault code, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness.
  • Signal shorted to return or ground in the sensor.
  • Malfunctioning fuel temperature sensor
Refer to Troubleshooting Fault Code 265.

Last Modified: 03-May-2016


Engine Exhaust Gas Temperature - Bank 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2651

Engine Exhaust Gas Temperature - Bank 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2651 PID: SPN: 2433 FMI: 3/3 LAMP: Maintenance SRT: | Engine Exhaust Gas Temperature - Bank 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the right bank exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The right bank exhaust gas temperature sensor is located in the right bank exhaust outlet connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60C [140F].
  • The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2651.

Last Modified: 16-Dec-2015


Engine Exhaust Gas Temperature - Bank 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2652

Engine Exhaust Gas Temperature - Bank 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2652 PID: SPN: 2433 FMI: 4/4 LAMP: Maintenance SRT: | Engine Exhaust Gas Temperature - Bank 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the right bank exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The right bank exhaust gas temperature sensor is located in the right bank exhaust outlet connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

Engine speed greater than 500 RPM.

Engine oil temperature greater than 60C [140F].

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Signal shorted to ground in the harness.

Signal shorted to return or ground in the sensor.

Refer to Troubleshooting Fault Code 2652.

Last Modified: 27-Sep-2017


Engine Exhaust Gas Temperature - Bank 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2653

Engine Exhaust Gas Temperature - Bank 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2653 PID: SPN: 2433 FMI: 0/16 LAMP: Amber SRT: | Engine Exhaust Gas Temperature - Bank 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The right bank exhaust gas temperature sensor is located in the right bank exhaust outlet connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2653.

Last Modified: 03-May-2016


Engine Exhaust Gas Temperature - Bank 2 - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2654

Engine Exhaust Gas Temperature - Bank 2 - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2654 PID: SPN: 2433 FMI: 0/0 LAMP: Red SRT: | Engine Exhaust Gas Temperature - Bank 2 - Data Valid But Above Normal Operating Range - Most Severe Level. The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The right bank exhaust gas temperature sensor is located in the right bank exhaust outlet connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2654.

Last Modified: 03-May-2016


Engine Exhaust Gas Temperature - Bank 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2655

Engine Exhaust Gas Temperature - Bank 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2655 PID: SPN: 2434 FMI: 3/3 LAMP: Maintenance SRT: | Engine Exhaust Gas Temperature - Bank 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the left bank exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The left bank exhaust gas temperature sensor is located in the left bank exhaust outlet connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60C [140F].
  • The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2655.

Last Modified: 10-Aug-2015


Engine Exhaust Gas Temperature - Bank 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2656

Engine Exhaust Gas Temperature - Bank 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2656 PID: SPN: 2434 FMI: 4/4 LAMP: Maintenance SRT: | Engine Exhaust Gas Temperature - Bank 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the left bank exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The left bank exhaust gas temperature sensor is located in the left bank exhaust outlet connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

Engine speed greater than 500 RPM.

Engine oil temperature greater than 60C [140F].

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Signal shorted to ground in the harness.

Signal shorted to return or ground in the sensor.

Refer to Troubleshooting Fault Code 2656.

Last Modified: 27-Sep-2017


Engine Exhaust Gas Temperature - Bank 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2657

Engine Exhaust Gas Temperature - Bank 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2657 PID: SPN: 2434 FMI: 0/16 LAMP: Amber SRT: | Engine Exhaust Gas Temperature - Bank 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The left bank exhaust gas temperature sensor is located in the left bank exhaust outlet connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2657.

Last Modified: 03-May-2016


Engine Exhaust Gas Temperature - Bank 1 - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2658

Engine Exhaust Gas Temperature - Bank 1 - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2658 PID: SPN: 2434 FMI: 0/0 LAMP: Red SRT: | Engine Exhaust Gas Temperature - Bank 1 - Data Valid But Above Normal Operating Range - Most Severe Level. The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The left bank exhaust gas temperature sensor is located in the left bank exhaust outlet connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2658.

Last Modified: 03-May-2016


Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 266

Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 266 PID: P174 SPN: 174 FMI: 0/0 LAMP: Red SRT: | Fuel temperature above the critical limit has been detected. | Engine will shut down.
Engine Fuel Temperature Sensor Circuit

Circuit Description

The engine fuel temperature sensor is a variable resistor sensor and is used to measure the temperature of the fuel at the stage 2 filter housing. The engine control module (ECM) supplies 5 volts to the engine fuel temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the delivery fuel temperature.

Component Location

The engine fuel temperature sensor is located in the stage 2 fuel filter housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine fuel temperature exceeded the critical limit.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and run it at high idle for 5 minutes.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Malfunctioning fuel cooler.

Operating the engine in a hot ambient environment with a low fuel tank level

  • Malfunctioning fuel heat exchanger control valve.
Refer to Troubleshooting Fault Code 266.

Last Modified: 19-Feb-2019


SAE J1939 Data Link 2 Engine Network - Abnormal Update Rate

FAULT CODE 2727

SAE J1939 Data Link 2 Engine Network - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2727 PID: S206 SPN: 1231 FMI: 9/9 LAMP: Maintenance SRT: | SAE J1939 Data Link 2 Engine Network - Abnormal Update Rate. No communication or an invalid data transfer rate detected on the J1939 data link between the primary ECM and one or more secondary ECMs. | Engine may run rough, may stop running, may not start, or may be difficult to start.
SAE J1939 Data Link 2 Circuit

Circuit Description

The SAE J1939 data link circuit consists of one positive and one negative wire. Two 120 ohm resistors are connected in parallel to terminate the ends of the backbone. Stubs connect the engine control modules (ECM) to the J1939 backbone.

The engine control modules use the J1939 data link 2 for communication between modules.

Component Location

The Engine Control Modules (ECMs) are mounted at the front of the engine above the gear housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The primary engine control module (ECM 1) lost communication with one or more secondary ECMs via the J1939 data link 2.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A secondary ECM is not receiving power from the ECM supply voltage circuit in the harness. This can be caused by an open circuit in the power supply wire, blown ECM fuse, or open return wire.
  • Tripped circuit breaker in the OEM power supply circuit.
  • An open or short circuit in the SAE J1939 datalink circuit
  • Intermittent communication between the ECMs.
Refer to Troubleshooting Fault Code 2727.

Last Modified: 16-Dec-2015


Aftertreatment 1 Outlet NOx Sensor - Abnormal Update Rate

FAULT CODE 2771

Aftertreatment 1 Outlet NOx Sensor - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2771 PID: SPN: 3226 FMI: 9/9 LAMP: Amber SRT: | Aftertreatment 1 Outlet NOx Sensor - Abnormal Update Rate. No communication or an invalid data transfer rate detected on the J1939 data link between the ECM and the aftertreatment outlet NOx sensor. | None on performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment 1 outlet NOx sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment 1 outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment 1 outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment 1 outlet NOx sensor is mounted in the aftertreatment 1 SCR outlet.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) lost communication with the aftertreatment outlet NOx sensor via the J1939 data link.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low supply voltage
  • Open return circuit.
  • Open or short circuit on the J1939 data link circuit between the engine ECM and aftertreatment outlet NOx sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2771.

Last Modified: 03-May-2016


SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

FAULT CODE 285

SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 285 PID: S231 SPN: 639 FMI: 9/9 LAMP: Amber SRT: | SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate. The ECM expected information from a multiplexed device but did not receive it soon enough or did not receive it at all. | At least one multiplexed device will not operate properly.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) electronic control unit (ECU). Then component values and states from components such as sensors, throttle input, and switches can be transmitted from the OEM ECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM ECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

The Engine Control Module (ECM) detected an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

When this fault code is active, some multiplexed devices can possibly not function as desired.

This fault can occur for the following reasons:

  • A multiplexed component is enabled in the ECM, but the OEM ECU source address of the ECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM ECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a damaged J1939 data link connection between the OEM ECU and Cummins® ECM, a damaged connection between the component and the OEM ECU, damaged OEM ECU or damaged Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 285.

Last Modified: 11-Dec-2015


SAE J1939 Multiplexing Configuration Error - Out of Calibration

FAULT CODE 286

SAE J1939 Multiplexing Configuration Error - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 286 PID: S231 SPN: 639 FMI: 13/13 LAMP: Amber SRT: | SAE J1939 Multiplexing Configuration Error - Out of Calibration. The ECM expected information from a multiplexed device but only received a portion of the necessary information. | At least one multiplexed device will not operate properly.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) electronic control unit (ECU). Then component values and states from components such as sensors, throttle input, and switches can be transmitted from the OEM ECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM ECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) received an invalid J1939 data link message from a multiplexed device for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault can occur when the ECM is set up properly (components enabled and OEM ECU source addressed correctly) to receive information from an OEM ECU, but the OEM ECU is transmitting a message that says that component is not available for multiplexing.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Refer to Troubleshooting Fault Code 286.

Last Modified: 11-Dec-2015


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2963

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2963 PID: P110 SPN: 110 FMI: 0/15 LAMP: None SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Least Severe Level. Engine coolant temperature is above the engine protection warning limit. | Possible reduced engine performance.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than a calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limit for high coolant temperature.

Refer to Troubleshooting Fault Code 2963.

Last Modified: 03-May-2016


Aftertreatment 1 SCR Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3142

Aftertreatment 1 SCR Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3142 PID: SPN: 4360 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 1 SCR Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the selective catalytic reduction (SCR) intake temperature sensor circuit. | None on performance.
Aftertreatment Selective Catalytic Reduction Temperature Sensor Module

Circuit Description

The aftertreatment 1 SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment 1 SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment 1 SCR temperature sensor module is used to measure the aftertreatment 1 SCR intake temperature and aftertreatment 1 SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment 1 SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment 1 SCR temperature module is mounted to the aftertreatment SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported the aftertreatment SCR intake temperature signal was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the SCR catalyst intake temperature is used.
  • Aftertreatment DEF dosing system will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment SCR intake temperature sensor
Refer to Troubleshooting Fault Code 3142.

Last Modified: 03-May-2016


Aftertreatment 1 SCR Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3143

Aftertreatment 1 SCR Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3143 PID: SPN: 4360 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment SCR Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the selective catalytic reduction (SCR) intake temperature sensor circuit. | None on performance.
Aftertreatment Selective Catalytic Reduction Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported the aftertreatment SCR intake temperature signal was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the SCR catalyst intake temperature is used.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment SCR intake temperature sensor
Refer to Troubleshooting Fault Code 3143.

Last Modified: 10-May-2016


Aftertreatment 1 SCR Intake Temperature Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3144

Aftertreatment 1 SCR Intake Temperature Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3144 PID: SPN: 4360 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment 1 SCR Intake Temperature Sensor - Data Erratic, Intermittent, or Incorrect. The SCR intake temperature sensor is not changing with engine operating conditions. | None on performance.
Aftertreatment Selective Catalytic Reduction Temperature Sensor Module

Circuit Description

The aftertreatment 1 SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment 1 SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment 1 SCR temperature sensor module is used to measure the aftertreatment 1 SCR intake temperature and aftertreatment 1 SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment 1 SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment 1 SCR temperature module is mounted to the aftertreatment SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and exhaust flow is above a minimum level.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment SCR intake temperature sensor signal was irrational for more than 5 minutes.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the SCR catalyst intake temperature is used.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment SCR intake temperature sensor
Refer to Troubleshooting Fault Code 3144.

Last Modified: 03-May-2016


Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3146

Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3146 PID: SPN: 4363 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the SCR outlet temperature sensor circuit. | None on performance.
Aftertreatment SCR Catalyst Temperature Sensor Module

Circuit Description

The aftertreatment 1 SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment 1 SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment 1 SCR temperature sensor module is used to measure the aftertreatment 1 SCR intake temperature and aftertreatment 1 SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment 1 SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment 1 SCR temperature module is mounted to the aftertreatment SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported the aftertreatment SCR outlet temperature signal was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the SCR catalyst outlet temperature is used.
  • Aftertreatment DEF dosing system will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR outlet temperature sensor

Refer to Troubleshooting Fault Code 3146.

Last Modified: 03-May-2016


Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3147

Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3147 PID: SPN: 4363 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the SCR outlet temperature sensor circuit. | None on performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment 1 SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment 1 SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment 1 SCR temperature sensor module is used to measure the aftertreatment 1 SCR intake temperature and aftertreatment 1 SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment 1 SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment 1 SCR temperature module is mounted to the aftertreatment SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported the aftertreatment SCR outlet temperature signal was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the SCR catalyst outlet temperature is used.
  • Aftertreatment DEF dosing system will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR outlet temperature sensor

Refer to Troubleshooting Fault Code 3147.

Last Modified: 03-May-2016


Aftertreatment 1 SCR Outlet Temperature Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3148

Aftertreatment 1 SCR Outlet Temperature Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3148 PID: SPN: 4363 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment 1 SCR Outlet Temperature Sensor - Data Erratic, Intermittent, or Incorrect. The selective catalytic reduction (SCR) outlet temperature sensor is not changing with engine operating conditions. | None on performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment 1 SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment 1 SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment 1 SCR temperature sensor module is used to measure the aftertreatment 1 SCR intake temperature and aftertreatment 1 SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment 1 SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment 1 SCR temperature module is mounted to the aftertreatment SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and exhaust flow is above a minimum level.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment SCR outlet temperature sensor signal was irrational for more than 5 minutes.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the SCR catalyst outlet temperature is used.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR outlet temperature sensor

Refer to Troubleshooting Fault Code 3148.

Last Modified: 03-May-2016


Aftertreatment 1 SCR Catalyst System Missing - Condition Exists

FAULT CODE 3151

Aftertreatment 1 SCR Catalyst System Missing - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3151 PID: SPN: 4794 FMI: 11/31 LAMP: Amber SRT: | Aftertreatment SCR Catalyst System Missing - Condition Exists. The aftertreatment SCR catalyst in the exhaust system is not present. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) monitors the NOx concentration in the engine exhaust gases using an aftertreatment intake NOx sensor and an aftertreatment outlet NOx sensor. By comparing these two values, the ECM determines the conversion efficiency of the SCR catalyst and aftertreatment DEF dosing system.

Component Location

The SCR catalyst is located in the SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the NOx conversion efficiency of the SCR catalyst was critically low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

It is necessary to use the "Reset All Faults" command in INSITE™ electronic service tool to clear this fault and extinguish the amber CHECK ENGINE lamp.

Shop Talk

Troubleshoot all other active NOx sensor and SCR dosing system related fault codes before this fault.

Possible causes of this fault include:

  • Tampering with SCR catalyst system, removal of SCR catalyst from equipment, or malfunctioning SCR catalyst.
  • Malfunctioning aftertreatment diesel exhaust fluid dosing system.
  • Exhaust system leaks
  • Degraded, diluted, or incorrect diesel exhaust fluid
  • Diesel exhaust fluid crystallization or deposits
Refer to Troubleshooting Fault Code 3151.

Last Modified: 03-May-2016


Aftertreatment 1 SCR Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 3164

Aftertreatment 1 SCR Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3164 PID: SPN: 4360 FMI: 0/15 LAMP: None SRT: | Aftertreatment 1 SCR Intake Temperature - Data Valid But Above Normal Operational Range – Least Severe Level. The selective catalytic reduction (SCR) intake temperature sensor reading has exceeded the calibrated temperature limit. | None on performance.
Aftertreatment Selective Catalytic Reduction Temperature Sensor Module

Circuit Description

The aftertreatment 1 SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment 1 SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment 1 SCR temperature sensor module is used to measure the aftertreatment 1 SCR intake temperature and aftertreatment 1 SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment 1 SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment 1 SCR temperature module is mounted to the aftertreatment SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the temperature at the SCR catalyst intake was greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Operating the engine under heavy load especially in hot ambient conditions.
  • Malfunctioning in-range SCR intake temperature sensor
Refer to Troubleshooting Fault Code 3164.

Last Modified: 03-May-2016


Aftertreatment 1 SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 3165

Aftertreatment 1 SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3165 PID: SPN: 4363 FMI: 0/0 LAMP: Red SRT: | Aftertreatment SCR Outlet Temperature - Data Valid But Above Normal Operational Range - Most Severe Level. The selective catalytic reduction (SCR) outlet temperature sensor reading has exceeded the maximum temperature limit. | None on performance.
SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature module is mounted to the aftertreatment SCR catalyst assembly.

Aftertreatment 1 components correspond with exhaust gas originating from the left bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the temperature at the SCR catalyst outlet was greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning turbocharger wastegate.
  • Contaminated diesel exhaust fluid
  • Leaking turbocharger oil seals
  • Leaks in the charge air system plumbing
  • Malfunctioning fuel injectors
  • Malfunctioning in-range SCR outlet temperature sensor.
Refer to Troubleshooting Fault Code 3165.

Last Modified: 03-May-2016


Real Time Clock - Data Erratic, Intermittent, or Incorrect

FAULT CODE 319

Real Time Clock - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 319 PID: P251 SPN: 251 FMI: 2/2 LAMP: Maintenance SRT: | Real Time Clock - Data Erratic, Intermittent, or Incorrect. The ECM has diagnosed that the real time clock (RTC) information is increasing abnormally or that power was lost while the RTC is running. | None on performance.
Engine Control Module (ECM)

Circuit Description

Under ordinary operating conditions, the real-time clock in the Engine Control Module (ECM) is powered by the ECM supply voltage. If ECM supply voltage to the ECM is lost, then the real-time clock will be powered by a battery in the engine harness.

Component Location

The real time clock is a timing chip internal to the ECM and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM has diagnosed that the real time clock (RTC) information is increasing abnormally or that power was lost while the RTC is running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

For hard-wired real time clock with battery pack, reset the time in INSITE™ to make the fault go inactive.

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes for this fault include: a weak or damaged real time clock battery, damaged wiring or connectors between the battery and ECM, or the supply voltage to the ECM is lost.

Refer to Troubleshooting Fault Code 319.

Last Modified: 02-Dec-2015


Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

FAULT CODE 322

Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 322 PID: S1 SPN: 651 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 1 circuit. | Possible reduced engine performance.
Injector 1 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

•Open circuit in the engine harness(es) or injector solenoid

•High resistance in a single injector or injector solenoid

• Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)

• Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the two injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.
Refer to Troubleshooting Fault Code 322.

Last Modified: 11-Dec-2015


Aftertreatment 1 SCR Intake Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 3229

Aftertreatment 1 SCR Intake Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3229 PID: SPN: 4360 FMI: 0/0 LAMP: Red SRT: | Aftertreatment 1 SCR Intake Temperature - Data Valid But Above Normal Operational Range - Most Severe Level. The selective catalytic reduction (SCR) intake temperature sensor reading has exceeded the maximum temperature limit. | Possible reduced engine performance.
SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature module is mounted to the aftertreatment SCR catalyst assembly.

Aftertreatment 1 components correspond with exhaust gas originating from the left bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the temperature at the SCR catalyst intake was greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be severely reduced.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning turbocharger wastegate.
  • Leaks in the charge air system plumbing
  • Malfunctioning fuel injectors
  • Malfunctioning in-range SCR intake temperature sensor
Refer to Troubleshooting Fault Code 3229.

Last Modified: 03-May-2016


Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

FAULT CODE 323

Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 323 PID: S5 SPN: 655 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 5 circuit. | Possible reduced engine performance.
Injector 5 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

•Open circuit in the engine harness(es) or injector solenoid

•High resistance in a single injector or injector solenoid

• Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)

• Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the two injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

  • Injector Bank 5: Fault Codes 323 and 1552.
Refer to Troubleshooting Fault Code 323.

Last Modified: 10-Aug-2015


Aftertreatment 1 SCR Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3231

Aftertreatment 1 SCR Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3231 PID: SPN: 4360 FMI: 0/16 LAMP: Red SRT: | Aftertreatment 1 SCR Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. High selective catalytic reduction (SCR) intake temperature has been detected. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment 1 SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment 1 SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment 1 SCR temperature sensor module is used to measure the aftertreatment 1 SCR intake temperature and aftertreatment 1 SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment 1 SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment 1 SCR temperature module is mounted to the aftertreatment SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The engine control module (ECM) has diagnosed that the SCR intake temperature is above a calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code are:

  • Malfunctioning fuel injectors
  • Contaminated diesel exhaust fluid
Refer to Troubleshooting Fault Code 3231.

Last Modified: 03-May-2016


Aftertreatment 1 Intake NOx Sensor - Abnormal Update Rate

FAULT CODE 3232

Aftertreatment 1 Intake NOx Sensor - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3232 PID: SPN: 3216 FMI: 9/9 LAMP: Amber SRT: | Aftertreatment Intake NOx Sensor - Abnormal Update Rate. No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the aftertreatment intake NOx sensor. | None on performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine exhaust outlet connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code is triggered when the ECM loses J1939 data link communications with the aftertreatment intake NOx sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • The Aftertreatment Intake NOx Sensor is not receiving power from the ECM power supply circuit in the harness. This can be caused by an open circuit in the power supply wire, blown NOx sensor fuse, malfunctioning aftertreatment power relay or low supply voltage.
  • Open return circuit on the aftertreatment intake NOx sensor circuit between the ECM power supply circuit aftertreatment intake NOx sensor.
  • Open or short circuit on the J1939 data link circuit between the engine ECM and aftertreatment intake NOx sensor.
  • Intermittent communications between the aftertreatment intake NOx sensor and the ECM on the J1939 data link

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3232.

Last Modified: 03-May-2016


Aftertreatment 1 SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3235

Aftertreatment 1 SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3235 PID: SPN: 4363 FMI: 0/16 LAMP: Red SRT: | Aftertreatment 1 SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. High selective catalytic reduction (SCR) outlet temperature has been detected. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment 1 SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment 1 SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment 1 SCR temperature sensor module is used to measure the aftertreatment 1 SCR intake temperature and aftertreatment 1 SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment 1 SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment 1 SCR temperature module is mounted to the aftertreatment SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the temperature at the SCR catalyst outlet was greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault will go inactive immediately after the SCR outlet temperature drops below the warning limit, and will likely be inactive at the time of diagnosis. For these reasons this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

  • Malfunctioning turbocharger wastegate.
  • Degraded, diluted, or incorrect diesel exhaust fluid
  • Leaking turbocharger oil seals
  • Malfunctioning fuel injectors
  • Malfunctioning in-range SCR outlet temperature sensor.
Refer to Troubleshooting Fault Code 3235.

Last Modified: 03-May-2016


Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

FAULT CODE 324

Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 324 PID: S3 SPN: 653 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 3 circuit. | Possible reduced engine performance.
Injector 3 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

•Open circuit in the engine harness(es) or injector solenoid

•High resistance in a single injector or injector solenoid

• Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)

• Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the two injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

  • Injector Bank 3: Fault Codes 324 and 1554.
Refer to Troubleshooting Fault Code 324.

Last Modified: 10-Aug-2015


Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3242

Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3242 PID: SPN: 3363 FMI: 7/7 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Mechanical System Not Responding or Out of Adjustment. The aftertreatment diesel exhaust fluid temperature did not increase when the aftertreatment diesel exhaust fluid tank heater was commanded ON. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater thaws and prevents the diesel exhaust fluid from freezing during operation. The tank heater consists of an electrically powered tank heater control valve which controls the flow of engine coolant to a heating coil inside the diesel exhaust fluid tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The location of the aftertreatment diesel exhaust fluid tank heater control valve will vary depending on the OEM. The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs a calibrated amount of time after diesel exhaust fluid tank heating is first commanded.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid tank heater was commanded on by the engine engine control module (ECM), but no corresponding temperature increase in the aftertreatment diesel exhaust fluid tank temperature was recorded by the tank temperature sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The fault code status in INSITE™ electronic service tool will change to INACTIVE immediately after the system is able to adequately heat and the diagnostic runs and passes. If heating can not be completed, use the "Diesel Exhaust Fluid Doser System Heater Test" found under "ECM Diagnostic Test" in INSITE™ electronic service tool to command heating to the tank heater and all line heaters.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Aftertreatment diesel exhaust fluid tank heater control valve stuck closed
  • Blockage or restrictions in the coolant plumbing to the diesel exhaust fluid tank heater
  • Engine coolant level low
  • Malfunctioning aftertreatment diesel exhaust fluid tank heater control valve

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3242.

Last Modified: 10-May-2016


Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

FAULT CODE 325

Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 325 PID: S6 SPN: 656 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 6 circuit. | Possible reduced engine performance.
Injector 6 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the two injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

  • Injector Bank 6: Fault Codes 325 and 1553.
Refer to Troubleshooting Fault Code 325.

Last Modified: 10-Aug-2015


Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

FAULT CODE 331

Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 331 PID: S2 SPN: 652 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 2 circuit. | Possible reduced engine performance.
Injector 2 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the two injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

  • Injector Bank 2: Fault Codes 331 and 1557.
Refer to Troubleshooting Fault Code 331.

Last Modified: 10-Aug-2015


Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

FAULT CODE 332

Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 332 PID: S4 SPN: 654 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 4 circuit. | Possible reduced engine performance.
Injector 4 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the two injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

  • Injector Bank 4: Fault Codes 332 and 1555.
Refer to Troubleshooting Fault Code 332.

Last Modified: 10-Aug-2015


J1939 Network #2 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3329

J1939 Network #2 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3329 PID: SPN: 1231 FMI: 2/2 LAMP: None SRT: | J1939 Network #2 - Data Erratic, Intermittent, or Incorrect. A circuit malfunction has been detected on J1939 network 2. | Possible reduced engine performance.
SAE J1939 Data Link 2

Circuit Description

The SAE J1939 data link circuit consists of one positive and one negative wire. Two 120 ohm resistors are connected in parallel to terminate the ends of the backbone. Stubs connect the smart devices to the J1939 backbone.

The engine control modules use the J1939 data link 2 for communication between modules.

Component Location

The SAE J1939 data link 2 is located in the engine harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has detected an open on the J1939 data link backbone or a short circuit.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Open or short circuit on J1939 data link
Refer to Troubleshooting Fault Code 3329.

Last Modified: 11-Dec-2015


J1939 Network #3 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3331

J1939 Network #3 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3331 PID: SPN: 1235 FMI: 2/2 LAMP: None SRT: | J1939 Network #3 - Data Erratic, Intermittent, or Incorrect. A circuit malfunction has been detected on J1939 network 3. | Possible reduced engine performance.
SAE J1939 Data Link 3

Circuit Description

The SAE J1939 data link circuit consists of one positive and one negative wire. Two 120 ohm resistors are connected in parallel to terminate the ends of the backbone. Stubs connect the smart devices to the J1939 backbone.

The Engine Control Module (ECM) uses J1939 data link 3 to communicate with the engine fuel supply pump and fuel metering valve.

Component Location

The SAE J1939 data link 3 is located in the engine harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has detected an open on the J1939 data link backbone or a short circuit.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open or short circuit on J1939 data link
Refer to Troubleshooting Fault Code 3331.

Last Modified: 03-Feb-2016


Engine ECU Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3379

Engine ECU Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3379 PID: P21 SPN: 1136 FMI: 0/16 LAMP: Amber SRT: | Engine ECU Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. High internal ECM temperature has been detected. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

The Engine Control Module (ECM) internal temperature sensor is located inside the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected internal temperatures above the warning limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • A malfunctioning ECM cooling circuit.
Refer to Troubleshooting Fault Code 3379.

Last Modified: 03-May-2016


Electronic Calibration Code Incompatibility - Out of Calibration

FAULT CODE 342

Electronic Calibration Code Incompatibility - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 342 PID: S253 SPN: 630 FMI: 13/13 LAMP: Red SRT: | Electronic Calibration Code Incompatibilty - Out of Calibration. Calibration mismatch detected between modules. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The engine control modules use the J1939 data link 2 for communication between modules.

Component Location

The Engine Control Modules (ECMs) are mounted at the front of the engine above the gear housing.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

Calibration mismatch or incompatibility detected between ECMs in the system.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Duplicate or incorrect ECM calibrations downloaded to the ECM(s).
  • Corrupted engine calibration
Refer to Troubleshooting Fault Code 342.

Last Modified: 11-Dec-2015


Fuel Filter (suction side) Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 344

Fuel Filter (suction side) Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 344 PID: P16 SPN: 1382 FMI: 0/15 LAMP: Maintenance SRT: | The engine fuel supply pump has detected high fuel intake restriction. | Possible reduced engine performance.
Engine Fuel Supply Pump Circuit

Circuit Description

The engine fuel supply pump is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The engine fuel supply pump maintains appropriate supply fuel pressure, performs internal and system diagnostics and reports malfunctions back to the ECM. The ECM supplies 24-VDC to the supply pump control unit. The OEM provides supply voltage to the engine fuel supply pump motor. The fuel delivery pressure signal is wired in parallel between the ECM and engine fuel supply pump.

The fuel supply pump intake pressure sensor measures the gauge pressure at the inlet of the engine fuel supply pump. The sensor is connected directly to the pump and the sensor value is communicated to the ECMs via the engine datalink.

Component Location

The engine fuel supply pump is located on the left side of the engine.

The fuel supply pump intake pressure sensor is located on the inlet of the engine fuel supply pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine fuel supply pump detected that fuel intake restriction was above the calibrated threshold.

Action Taken When the Fault Code is Active

The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Stage 0 fuel filter restriction excessive.

Stage 1 fuel filter restriction excessive.

A malfunctioning fuel lift pump

High fuel inlet restriction

Malfunctioning fuel supply pump intake pressure sensor.

Refer to Troubleshooting Fault Code 344 .

Last Modified: 21-Aug-2019


Transmission Output Shaft Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 349

Transmission Output Shaft Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 349 PID: P191 SPN: 191 FMI: 0/16 LAMP: Amber SRT: | Transmission Output Shaft Speed - Data Valid but Above Normal Operating Range - Moderately Severe Level. High auxillary speed signal frequency has been detected. | Possible reduced engine performance.
Auxillary Speed Sensor Circuit

Circuit Description

The auxillary speed input is a frequency signal from an auxiliary speed sensor. The signal is used by the ECM to govern engine speed.

Component Location

Refer to the OEM service manual for the location of the auxillary speed sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected auxillary speed sensor frequency above the OEM defined limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the auxillary speed sensor reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

For troubleshooting information on this fault code refer to the OEM service manual.

Refer to Troubleshooting Fault Code 349.

Last Modified: 10-Aug-2015


Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 3497

Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3497 PID: SPN: 1761 FMI: 1/17 LAMP: Maintenance SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Least Severe Level. The aftertreatment diesel exhaust fluid tank level is low. | None on performance.
Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The diesel exhaust fluid tank level was low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that the diesel exhaust fluid level is low, and the tank must be refilled at the operator's earliest convenience.

Refer to Troubleshooting Fault Code 3497.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3498

Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3498 PID: SPN: 1761 FMI: 1/18 LAMP: Maintenance SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Moderately Severe Level. The aftertreatment diesel exhaust fluid tank level is very low. | None on performance.
Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid level sensor is used to monitor the diesel exhaust fluid level inside the diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The diesel exhaust fluid tank level was very low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that the diesel exhaust fluid level is very low. The diesel exhaust fluid tank must be refilled.

Refer to Troubleshooting Fault Code 3498.

Last Modified: 03-May-2016


Injector Power Supply - Bad Intelligent Device or Component

FAULT CODE 351

Injector Power Supply - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 351 PID: S251 SPN: 3597 FMI: 12/12 LAMP: Amber SRT: | Injector Power Supply - Bad Intelligent Device or Component. The ECM measured injector boost voltage is low. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

Between each injection event, the Engine Control Module (ECM) attempts to recharge the injector power supply. The injector power supply consists of a bank of capacitors. This power supply is maintained at high voltage. Recharging is accomplished by recovering energy stored in the injector solenoids.

Component Location

The engine harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the measured injector power supply voltage was less than the commanded injector power supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

For the injector power supply to remain fully charged, there must be good ECM supply voltage and ground, a good engine speed/position sensor, and good injector circuits.

Refer to Troubleshooting Fault Code 351.

Last Modified: 11-Dec-2015


Fault Code Path Selection

FAULT CODE 352
Fault Code Path Selection

Is the sensor supply 1 circuit fault code generated from ECM 3 source address 00? | Go to 402-fc352sa00
Is the sensor supply 1 circuit fault code generated from ECM 2 source address 01? | Go to 402-fc352sa01

Last Modified: 20-Apr-2016


Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 352 (sa00)

Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 (sa00) PID: S212 SPN: 3509 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at sensor supply number 1 circuit. | Possible reduced engine performance.
Sensor Supply 1 Circuit

Circuit Description

The sensor supply 1 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 1 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 1 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 1 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Low voltage on the +5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a malfunctioning sensor, or a malfunctioning ECM power supply.

Refer to Troubleshooting Fault Code 352 (sa00).

Last Modified: 11-Dec-2015


Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 352 (sa01)

Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 (sa01) PID: S212 SPN: 3509 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at sensor supply number 1 circuit. | Possible reduced engine performance.
Sensor Supply 1 Circuit

Circuit Description

The sensor supply 1 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 1 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 1 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 1 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Low voltage on the +5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a malfunctioning sensor, or a malfunctioning ECM power supply.

Refer to Troubleshooting Fault Code 352 (sa01).

Last Modified: 11-Dec-2015


NOx Limits Exceeded Due to Insufficient Reagent Quality - Condition Exists

FAULT CODE 3543

NOx Limits Exceeded Due to Insufficient Reagent Quality - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3543 PID: SPN: 4094 FMI: 11/31 LAMP: Amber SRT: | NOx Limits Exceeded Due to Insufficient Reagent Quality - Condition Exists. The diesel exhaust fluid quality is not sufficient enough to provide adequate NOx reduction. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) monitors the NOx concentration in the engine's exhaust gases using an aftertreatment intake NOx sensor and an aftertreatment outlet NOx sensor. By comparing these two values, the ECM is able to determine the conversion efficiency of the SCR catalyst and dosing system.

Component Location

The SCR catalyst is located in the exhaust system.

Conditions for Running the Diagnostics

This diagnostic runs after the diesel exhaust fluid tank has been refilled. Specific engine and aftertreatment conditions must be met. NOx sensor data is gathered over varying engine speeds and loads. When enough data has been gathered, the diagnostic will run, make a pass/fail decision, and begin to gather data again.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the NOx conversion across the SCR catalyst was less than expected, and the diesel exhaust fluid tank has recently been refilled.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

It is necessary to use the "Reset All Faults" command in INSITE™ electronic service tool to clear this fault and extinguish the amber CHECK ENGINE lamp.

Shop Talk

Troubleshoot all other active NOx sensor and SCR dosing system related fault codes before this fault.

Possible causes of this fault include:

  • Malfunctioning diesel exhaust fluid dosing system
  • Exhaust system leaks
  • Malfunctioning SCR catalyst
  • Degraded, diluted, or incorrect diesel exhaust fluid
  • Diesel exhaust fluid deposits in the decomposition chamber.
Refer to Troubleshooting Fault Code 3543.

Last Modified: 03-Feb-2016


Aftertreatment 1 Outlet NOx Sensor - Abnormal Rate of Change

FAULT CODE 3545

Aftertreatment 1 Outlet NOx Sensor - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3545 PID: SPN: 3226 FMI: 10/10 LAMP: Amber SRT: | Aftertreatment 1 Outlet NOx Sensor Circuit - Abnormal Rate of Change. The aftertreatment outlet NOx sensor reading is not valid. | None on performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment 1 outlet NOx sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment 1 outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment 1 outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment 1 outlet NOx sensor is mounted in the aftertreatment 1 SCR outlet.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and the aftertreatment SCR outlet temperature is above a calibrated threshold for a calibrated period of time.

Conditions for Setting the Fault Codes

The aftertreatment outlet NOx sensor reading was not valid.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code sets when the aftertreatment outlet NOx sensor indicates to the ECM that it is not providing valid data.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3545.

Last Modified: 03-May-2016


Aftertreatment Diesel Exhaust Fluid Tank Empty - Condition Exists

FAULT CODE 3547

Aftertreatment Diesel Exhaust Fluid Tank Empty - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3547 PID: SPN: 4096 FMI: 11/31 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Empty - Condition Exists. The diesel exhaust fluid tank is empty. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid level sensor is used to monitor the diesel exhaust fluid level inside the diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The diesel exhaust fluid tank is empty.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The Diesel Exhaust Fluid Lamp will be flashing.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the diesel exhaust fluid lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that the aftertreatment diesel exhaust fluid tank is empty and needs refilled immediately.

Refer to Troubleshooting Fault Code 3547.

Last Modified: 10-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3558

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3558 PID: SPN: 3361 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid dosing unit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit filters and pressurizes DEF for the DEF dosing valve. The ECM provides supply voltage and a ground to the diesel exhaust fluid dosing unit. The ECM also supplies a signal to the dosing unit to control the diesel exhaust fluid output. This signal changes, based on the diesel exhaust fluid pressure being commanded.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit signal voltage was greater than a calibrated value or the diesel exhaust fluid dosing unit supply was shorted to ECM supply voltage or open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • Perform a key cycle, and leave the key switch in the ON position for at least 2 minutes.
  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid System Leak Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A signal circuit shorted to sensor supply or ECM supply voltage.
  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3558.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3559

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3559 PID: SPN: 3361 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel exhaust fluid dosing unit. | None on performance.
Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit filters and pressurizes DEF for the DEF dosing valve. The ECM provides supply voltage and a ground to the diesel exhaust fluid dosing unit. The ECM also supplies a signal to the dosing unit to control the diesel exhaust fluid output. This signal changes, based on the diesel exhaust fluid pressure being commanded.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit signal voltage or the aftertreatment diesel exhaust fluid dosing unit supply voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid System Leak Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Short to ground in the diesel exhaust fluid dosing unit
  • Supply wire shorted to ground.
  • Control signal wire shorted to ground or open.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3559.

Last Modified: 03-May-2016


Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Above Normal or Shorted to High Source

FAULT CODE 3562

Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3562 PID: SPN: 5491 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the diesel exhaust fluid line heater relay. | None on performance.
Aftertreatment Diesel Exhaust Fluid Line Heater Relay Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater relay is used to provide power to the aftertreatment diesel exhaust fluid line heaters.

Component Location

The aftertreatment diesel exhaust fluid line heater relays are located in the aftertreatment junction box.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid line heater relay signal was open or shorted to high source.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to voltage source in the wiring harness
  • Malfunctioning line heater relay

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3562.

Last Modified: 18-May-2016


Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3563

Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3563 PID: SPN: 5491 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the diesel exhaust fluid line heater relay. | None on performance.
Aftertreatment Diesel Exhaust Fluid Line Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater relay is used to provide power to the aftertreatment diesel exhaust fluid line heaters.

Component Location

The aftertreatment diesel exhaust fluid line heater relays are located in the aftertreatment junction box.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid line heater relay control signal was shorted to ground.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use the recommended Cummins® electronic service tool or equivalent to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Signal circuit shorted to ground in the harness

Malfunctioning line heater relay

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3563 .

Last Modified: 21-Aug-2019


Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 1 Circuit - Current Below Normal or Open Circuit

FAULT CODE 3567

Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 1 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3567 PID: SPN: 5394 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Valve - Current Below Normal or Open Circuit. A circuit error has been detected in the aftertreatment diesel exhaust fluid dosing valve circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Dosing Valve Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the ECM. When the engine control module (ECM) commands DEF dosing, the ECM sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid dosing valve is installed in the exhaust system. It is mounted directly to the aftertreatment decomposition tube, before the selective catalytic reduction (SCR) catalyst. Installation position will vary, based on the aftertreatment architecture and the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing valve is being commanded on.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing valve circuit was shorted high, shorted low, or open.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the diesel exhaust fluid dosing valve
  • A short circuit to battery in the OEM harness
  • A short circuit to ground in the OEM harness
  • An open circuit in the OEM harness

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3567.

Last Modified: 18-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3571

Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3571 PID: SPN: 4334 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid pressure sensor circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal wire shorted to sensor supply or ECM supply voltage.
  • Open return circuit in the harness, connectors, or sensor.
  • A malfunctioning aftertreatment diesel exhaust fluid pressure sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3571.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3572

Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3572 PID: SPN: 4334 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the diesel exhaust fluid pressure sensor circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground.
  • Sensor supply wire open or shorted to ground
  • A malfunctioning aftertreatment diesel exhaust fluid pressure sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3572.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit - Current Below Normal or Open Circuit

FAULT CODE 3573

Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3573 PID: SPN: 4334 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit - Current Below Normal or Open Circuit. A circuit error has been detected in the aftertreatment diesel exhaust fluid pressure sensor circuit. | None on performance.
Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the ECM. When the engine control module (ECM) commands DEF dosing, the ECM sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The aftertreatment diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure sensor circuit was shorted high, shorted low, or open.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes for this fault include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing valve
Refer to Troubleshooting Fault Code 3573.

Last Modified: 18-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3574

Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3574 PID: SPN: 4334 FMI: 1/18 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low diesel exhaust fluid pressure has been detected in the dosing valve. | None on performance.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs after the diesel exhaust fluid dosing system has primed.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure was less than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low diesel exhaust fluid tank level
  • Blocked, restricted, or frozen diesel exhaust fluid dosing unit supply line
  • Blocked, restricted, or frozen diesel exhaust fluid dosing valve supply line
  • Blocked or restricted diesel exhaust fluid tank filter
  • Blocked or restricted diesel exhaust fluid dosing unit filter
  • Malfunctioning diesel exhaust fluid dosing unit
  • Blocked or restricted DEF dosing valve
  • Contaminated diesel exhaust fluid

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3574.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3575

Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3575 PID: SPN: 4334 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level. The diesel exhaust fluid dosing valve has detected a blockage in the diesel exhaust fluid return flow. | None on performance.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs after the diesel exhaust fluid dosing system has primed.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure was greater than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Blocked, restricted, or frozen diesel exhaust fluid dosing valve return line or return line connector.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3575.

Last Modified: 03-May-2016


Aftertreatment 1 Outlet NOx Sensor Heater - Abnormal Rate of Change

FAULT CODE 3583

Aftertreatment 1 Outlet NOx Sensor Heater - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3583 PID: SPN: 5031 FMI: 10/10 LAMP: Amber SRT: | Aftertreatment Outlet NOx Sensor Heater - Abnormal Rate of Change. The aftertreatment outlet NOx sensor heater is unable to maintain its normal operating temperature. | None on performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment 1 outlet NOx sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment 1 outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment 1 outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment 1 outlet NOx sensor is mounted in the aftertreatment 1 SCR outlet.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature has been above 200°C [392° F] for a calibratible period of time while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the NOx sensor heater was unable to maintain its normal operating temperature.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The aftertreatment SCR outlet temperature must be above 200° C [392° F] for 60 seconds before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The NOx sensor heater is internal to the NOx sensor assembly, and can not be serviced separately.

Possible causes of this fault code include:

  • A damaged aftertreatment outlet NOx sensor
  • Intermittent power connection to the aftertreatment outlet NOx sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3583.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3596

Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3596 PID: SPN: 4334 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Erratic, Intermittent, or Incorrect. The diesel exhaust fluid pressure sensor has reported a reading too high or low for the operating conditions. | None on performance.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs after the diesel exhaust fluid dosing system has primed.

Conditions for Setting the Fault Codes

The diesel exhaust fluid dosing unit was unable to maintain the commanded diesel exhaust fluid pressure.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Air in the DEF.
  • Leaking diesel exhaust fluid lines
  • Malfunctioning diesel exhaust fluid dosing unit
  • Blocked or restricted diesel exhaust fluid dosing unit supply line fitting
  • Blocked or restricted diesel exhaust fluid filters
  • Malfunctioning diesel exhaust fluid pressure sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3596.

Last Modified: 03-May-2016


Coolant Level Sensor - Abnormal Update Rate

FAULT CODE 3613

Coolant Level Sensor - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3613 PID: SPN: 111 FMI: 9/9 LAMP: Amber SRT: | Coolant Level - Abnormal Update Rate. No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the coolant level sensor. | None on performance.
J1939 Datalink Circuit

Circuit Description

The coolant level sensor communicates with the engine control module (ECM) via the J1939 data link.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning SAE J1939 datalink circuit
  • A malfunctioning engine coolant level sensor
Refer to Troubleshooting Fault Code 3613.

Last Modified: 10-May-2016


Turbocharger 2 Speed Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3622

Turbocharger 2 Speed Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3622 PID: P352 SPN: 1169 FMI: 2/2 LAMP: Maintenance SRT: | Turbocharger 2 Speed Sensor - Data Erratic, Intermittent, or Incorrect. An invalid turbocharger speed signal has been detected. | Possible reduced engine performance.
Turbocharger Speed Sensor Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The Engine Control Module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor 2 is located on the right bank front turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic only runs when engine speed is greater than 1250 RPM and the ratio of boost pressure to barometric pressure is at or above 1.2.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger speed was less than 3000 RPM for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • The ECM will estimate the turbocharger speed.

Conditions for Clearing the Fault Code

  • To validate the repair, it will be necessary to operate the engine under load in order to get the intake manifold pressure high enough for the diagnostic to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Damaged turbocharger speed sensor
  • Damaged engine harness
Refer to Troubleshooting Fault Code 3622.

Last Modified: 03-Feb-2016


Aftertreatment 1 Intake NOx Sensor Heater - Abnormal Rate of Change

FAULT CODE 3649

Aftertreatment 1 Intake NOx Sensor Heater - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3649 PID: SPN: 5024 FMI: 10/10 LAMP: Amber SRT: | Aftertreatment 1 Intake NOx Sensor Heater - Abnormal rate of change. The aftertreatment intake NOx sensor heater is unable to maintain its normal operating temperature. | None on performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment 1 intake NOx sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment 1 intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment 1 intake NOx sensor is used to measure the NOx emissions at the engine exhaust outlet connection.

Component Location

The aftertreatment 1 intake NOx sensor is mounted on the left bank engine exhaust outlet connection.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment selective catalytic reduction intake temperature has reached a calibrated threshold.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the NOx sensor heater was unable to maintain its normal operating temperature.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The NOx sensor heater is internal to the NOx sensor assembly, and can not be serviced separately.

Possible causes of this fault code include:

  • Damaged aftertreatment intake NOx sensor
  • Intermittent power connection to the aftertreatment intake NOx sensor.
Refer to Troubleshooting Fault Code 3649.

Last Modified: 03-May-2016


Aftertreatment 1 Outlet NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3681

Aftertreatment 1 Outlet NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3681 PID: SPN: 3228 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment 1 outlet NOx sensor power supply - Data erratic, intermittent, or incorrect. The aftertreatment 1 outlet NOx sensor indicates that the power supply to the sensor is incorrect. | None on performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment 1 outlet NOx sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment 1 outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment 1 outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment 1 outlet NOx sensor is mounted in the aftertreatment 1 SCR outlet.

Conditions for Running the Diagnostics

The engine is running.

The aftertreatment SCR outlet temperature must be above 180C (356F) before the aftertreatment outlet NOx sensor can run its internal diagnostics.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the power supply to the outlet NOx sensor was above or below a calibrated threshold.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The aftertreatment SCR outlet temperature must be above 150Â° C [302Â° F] for 60 seconds before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Open NOx sensor power supply circuit.

Supply wire shorted to ground.

Internal malfunction of the outlet NOx sensor

The NOx sensor part number is incorrect.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3681.

Last Modified: 17-Jan-2018


Aftertreatment 1 Intake NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3682

Aftertreatment 1 Intake NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3682 PID: SPN: 3218 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment 1 Intake NOx Sensor Power Supply - Data Erratic, Intermittent or Incorrect. The aftertreatment intake NOx sensor indicates that the power supply to the sensor is incorrect. | None on performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment 1 intake NOx sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment 1 intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment 1 intake NOx sensor is used to measure the NOx emissions at the engine exhaust outlet connection.

Component Location

The aftertreatment 1 intake NOx sensor is mounted on the left bank engine exhaust outlet connection.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment selective catalytic reduction intake temperature has reached a calibrated threshold.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the power supply to the intake NOx sensor was above or below a calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open NOx sensor power supply circuit.
  • Supply wire shorted to ground.
  • Incorrect system voltage set-up in INSITE™ electronic service tool
  • Internal malfunction of the intake NOx sensor
  • The NOx sensor part number is incorrect.
Refer to Troubleshooting Fault Code 3682.

Last Modified: 03-May-2016


Engine Control Module Calibration Memory - Bad Intelligent Device or Component

FAULT CODE 3697

Engine Control Module Calibration Memory - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3697 PID: S253 SPN: 630 FMI: 12/12 LAMP: Red SRT: | Engine Control Module Calibration Memory - Bad Intelligent Device or Component. Error internal to the ECM related to engine software failures. | Engine may not start or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a software or calibration error.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code can only be caused by an internal ECM malfunction. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code 3697.

Last Modified: 02-Feb-2017


Aftertreatment SCR Operator Inducement - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 3712

Aftertreatment SCR Operator Inducement - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3712 PID: SPN: 5246 FMI: 0/0 LAMP: Red SRT: | Aftertreatment SCR Operator Inducement - Data Valid But Above Normal Operational Range - Most Severe Level. Critical SCR related fault codes have been active for an extended period of time and require immediate attention. | None on performance.
Engine Control Module (ECM)

Circuit Description

The ECM continuously monitors the engine's fault code status to determine if any fault codes critical to successful engine operation are active.

Component Location

The Engine Control Modules (ECMs) are mounted at the front of the engine above the gear housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine has been operated for an extended amount of time with critical SCR faults active, and no repair action has been taken. This amount of time will vary, depending on which SCR faults are active.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once all other active fault codes have been addressed. Refer to the appropriate fault code troubleshooting tree.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only, and indicates that the engine has been locked on low idle in order to make sure that the critical SCR related fault codes that are presently active in the ECM are addressed as quickly as possible.

Refer to Troubleshooting Fault Code 3712.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Line Heater Relay - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3713

Aftertreatment 1 Diesel Exhaust Fluid Line Heater Relay - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3713 PID: SPN: 5491 FMI: 7/7 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Line Heater Relay - Mechanical System Not Responding or Out of Adjustment. A short circuit to ECM power supply voltage has been detected on the diesel exhaust fluid line heater power supply circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Line Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater relay is used to provide power to the aftertreatment diesel exhaust fluid line heaters.

Component Location

The aftertreatment diesel exhaust fluid line heater relays are located in the aftertreatment junction box.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel exhaust fluid line heater relay is commanded OFF.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected voltage on the line heater relay diagnostic circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid line heating will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If the line heater relay diagnostic wire is open or its path to ground through the line heater is open, the ECM will see the 5-VDC pull-up voltage when the line heater relay is commanded off and this fault will become active.

Possible causes of this fault code include:

  • Switch side of line heater relay stuck closed
  • Open circuit in the wiring harness
  • Open circuit in one or more DEF line heaters.
  • Short to ECM power supply voltage in the wire between the relay and line heater elements.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3713.

Last Modified: 03-May-2016


Engine Protection Torque Derate - Condition Exists

FAULT CODE 3714

Engine Protection Torque Derate - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3714 PID: SPN: 1569 FMI: 11/31 LAMP: Amber SRT: | Engine Protection Torque Derate - Condition Exists. Critical fault codes related to engine operation are active. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM continuously monitors the engine's fault code status to determine if any fault codes critical to successful engine operation are active.

Component Location

The Engine Control Modules (ECMs) are mounted at the front of the engine above the gear housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected certain critical fault codes related to engine operation were active and the engine continued to operate.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once all other active fault codes have been addressed. Refer to the appropriate fault code troubleshooting tree.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only, and indicates that an engine power derate has been implemented in order to make sure that the critical fault codes that are presently active in the ECM are addressed as quickly as possible.

Refer to Troubleshooting Fault Code 3714.

Last Modified: 03-Feb-2016


Aftertreatment 1 Intake NOx - Out of Calibration

FAULT CODE 3718

Aftertreatment 1 Intake NOx - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3718 PID: SPN: 3216 FMI: 13/13 LAMP: Amber SRT: | Aftertreatment Intake NOx - Out of Calibration. A nominal system voltage mismatch has been detected by the aftertreatment intake NOx sensor. | None on performance.
Aftertreatment Intake NOx Sensor Power Supply

Circuit Description

The aftertreatment 1 intake NOx sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment 1 intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment 1 intake NOx sensor is used to measure the NOx emissions at the engine exhaust outlet connection.

Component Location

The aftertreatment 1 intake NOx sensor is mounted on the left bank engine exhaust outlet connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a mismatch between the engine's electrical system voltage and the NOx sensor voltage rating.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • System voltage is incorrect for the installed aftertreatment intake NOx sensor part number.
  • Incorrect aftertreatment intake NOx sensor is installed in exhaust system.
Refer to Troubleshooting Fault Code 3718.

Last Modified: 03-May-2016


Aftertreatment 1 Intake NOx Sensor - Abnormal Rate of Change

FAULT CODE 3725

Aftertreatment 1 Intake NOx Sensor - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3725 PID: SPN: 3216 FMI: 10/10 LAMP: Amber SRT: | Aftertreatment 1 Intake NOx Sensor – Abnormal Rate of Change. The aftertreatment intake NOx sensor reading is not valid. | None on performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment 1 intake NOx sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment 1 intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment 1 intake NOx sensor is used to measure the NOx emissions at the engine exhaust outlet connection.

Component Location

The aftertreatment 1 intake NOx sensor is mounted on the left bank engine exhaust outlet connection.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment selective catalytic reduction intake temperature has reached a calibrated threshold.

Conditions for Setting the Fault Codes

The aftertreatment intake Nox sensor reading was not valid.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

  • This fault code sets when the aftertreatment intake NOx sensor indicates to the ECM that it is not providing valid data.
Refer to Troubleshooting Fault Code 3725.

Last Modified: 03-May-2016


High Pressure Common Rail Fuel Pressure Relief Valve - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3727

High Pressure Common Rail Fuel Pressure Relief Valve - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3727 PID: SPN: 5571 FMI: 7/7 LAMP: None SRT: | High-Pressure Common Rail Fuel Pressure Relief Valve - Mechanical System Not Responding or Out of Adjustment. The fuel rail high-pressure relief valve has opened at a lower than expected pressure. | Possible reduced engine performance.
Fuel Rail Pressure Sensor Circuit

Circuit Description

The high-pressure relief valve is a mechanical device that opens when the fuel pressure in the fuel rail exceeds a critical limit.

Component Location

The fuel rail pressure sensor and fuel pressure relief valve are mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel pressure relief valve had opened at a pressure lower than expected.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code will become inactive at each key OFF event, and will not become active again until the fault condition reoccurs. Troubleshoot inactive or active occurences of this fault code the same.

This fault code may also be triggered by a sudden and significant loss of fuel pressure in the fuel system or a malfunctioning fuel rail pressure sensor.

Refer to Troubleshooting Fault Code 3727.

Last Modified: 12-Oct-2016


High Pressure Common Rail Fuel Pressure Relief Valve - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 3741

High Pressure Common Rail Fuel Pressure Relief Valve - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3741 PID: SPN: 5571 FMI: 0/0 LAMP: Amber SRT: | High Pressure Common Rail Fuel Pressure Relief Valve - Data valid but above normal operational range - Most Severe Level. The fuel rail pressure relief valve has opened due to high fuel rail pressure. | Progressive power derate increasing in severity from time of alert.
Fuel Rail Pressure Sensor Circuit

Circuit Description

The high-pressure relief valve is a mechanical device that opens when the fuel pressure in the fuel rail exceeds a critical limit.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel metering valve, fuel rail pressure sensor, and fuel pressure relief valve are mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure had exceeded the fuel pressure relief valve opening pressure, and the fuel pressure relief valve opened.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque and/or engine speed derate will be active.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • High fuel drain line restriction
  • A malfunctioning fuel metering valve.
  • Air in the fuel
  • A malfunctioning fuel rail pressure sensor
Refer to Troubleshooting Fault Code 3741.

Last Modified: 03-May-2016


Aftertreatment 1 Intake NOx Sensor - Data Not Rational - Drifted High

FAULT CODE 3748

Aftertreatment 1 Intake NOx Sensor - Data Not Rational - Drifted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3748 PID: SPN: 3216 FMI: 2/20 LAMP: Amber SRT: | Aftertreatment 1 Intake NOx Sensor - Data Not Rational - Drifted High. An offset in the intake NOx sensor reading has been detected. | None on performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment 1 intake NOx sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment 1 intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment 1 intake NOx sensor is used to measure the NOx emissions at the engine exhaust outlet connection.

Component Location

The aftertreatment 1 intake NOx sensor is mounted on the left bank engine exhaust outlet connection.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment selective catalytic reduction intake temperature is above 150°C [302°F], and the engine is in a motoring condition.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment intake NOx sensor was not reading zero while in a motoring (non-fueling) condition.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, cycle the keyswitch from OFF to ON.
  • The aftertreatment selective catalytic reduction intake temperature must be above 150° C [302° F] for 5 seconds before the aftertreatment intake NOx sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning aftertreatment intake NOx sensor
  • Improperly installed aftertreatment intake NOx sensor.
Refer to Troubleshooting Fault Code 3748.

Last Modified: 18-May-2016


Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 386

Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: S212 SPN: 3509 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 1 circuit. | Possible reduced engine performance.
ECM 1 Sensor Supply 1 Circuit
ECM 2 Sensor Supply 1 Circuit

Circuit Description

The sensor supply 1 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 1 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 1 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 1 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

High voltage on the +5 volt supply wire can be caused by a short to ECM supply voltage in the engine harness or connectors, or a damaged ECM.

Refer to Troubleshooting Fault Code 386.

Last Modified: 11-Dec-2015


Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 3866

Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3866 PID: SPN: 3364 FMI: 1/1 LAMP: Amber SRT: | The diesel exhaust fluid (DEF) quality has been detected to be below a critical threshold. | None on performance.
Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The DEF quality sensor has detected that the DEF concentration has fallen below a critical threshold.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

Degraded, diluted, or incorrect diesel exhaust fluid

Refer to Troubleshooting Fault Code 3866.

Last Modified: 19-Nov-2018


Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3867

Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3867 PID: SPN: 3364 FMI: 1/18 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Below Normal Operating Range - Moderately Severe Level. The diesel exhaust fluid (DEF) quality has been detected to be below a critical threshold. | None on performance.
Aftertreatment Diesel Exhaust Fluid Quality Circuit

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The DEF quality sensor has detected that the DEF concentration has fallen below a critical threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • Degraded, diluted, or incorrect diesel exhaust fluid
Refer to Troubleshooting Fault Code 3867.

Last Modified: 12-Oct-2016


Aftertreatment Diesel Exhaust Fluid Quality - Abnormal Update Rate

FAULT CODE 3868

Aftertreatment Diesel Exhaust Fluid Quality - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3868 PID: SPN: 3364 FMI: 9/9 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality - Abnormal Rate of Change. The Urea Quality Sensor has been unable to generate a concentration value for a period of time. | None on performance.
Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) lost communication with the aftertreatment DEF quality sensor via the J1939 data link.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • Open or short circuit on J1939 data link
Refer to Troubleshooting Fault Code 3868.

Last Modified: 18-May-2016


Aftertreatment Diesel Exhaust Fluid Quality - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3878

Aftertreatment Diesel Exhaust Fluid Quality - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3878 PID: SPN: 3364 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality - Data Erratic, Intermittent, or Incorrect. The diesel exhaust fluid (DEF) quality sensor has detected an over temperature condition. | None on performance.
Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code is triggered when the DEF quality sensor detects that the internal temperature is above a calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning Aftertreatment DEF Quality Sensor.
Refer to Troubleshooting Fault Code 3878.

Last Modified: 10-May-2016


Engine Turbocharger Wastegate Actuator 1 Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3925

Engine Turbocharger Wastegate Actuator 1 Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3925 PID: SPN: 1188 FMI: 2/2 LAMP: Amber SRT: | Engine Turbocharger Wastegate Actuator 1 Position - Data Erratic, Intermittent, or Incorrect. An error has been detected in the turbocharger wastegate position sensor circuit. | Possible reduced engine performance.
Turbocharger Wastegate Circuit

Circuit Description

The turbocharger wastegate is controlled by an electric motor located on the wastegate valve. The turbocharger wastegate motor uses three different motor legs to move the valve through its range of motion. The ECM uses the turbocharger wastegate motor A, B, and C wires to command the turbocharger wastegate to the appropriate position in order to maintain appropriate intake manifold pressure and turbocharger speed. The turbocharger wastegate motor contains three position sensors that detect the location of the wastegate. These sensors report the position of the wastegate back to the ECM over the turbocharger wastegate position A, B, and C wires.

Component Location

Turbocharger wastegates are mounted on the outboard side of the exhaust outlet connections.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger wastegate position sensor signal voltage was higher or lower than expected.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Turbocharger wastegate operation will be disabled.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Turbocharger wastegate position sensor wiring shorted to ground, open circuit, or shorted to power supply.
Refer to Troubleshooting Fault Code 3925.

Last Modified: 11-Dec-2015


Engine Turbocharger Wastegate Actuator 1 Position - Current Above Normal or Grounded Circuit

FAULT CODE 3969

Engine Turbocharger Wastegate Actuator 1 Position - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3969 PID: SPN: 1188 FMI: 6/6 LAMP: Amber SRT: | Engine Turbocharger Wastegate Actuator 1 Position - Current above normal or grounded circuit. A short circuit to ground has been detected in the turbocharger wastegate motor circuit. | Possible reduced engine performance.
Turbocharger Wastegate Circuit

Circuit Description

The turbocharger wastegate is controlled by an electric motor located on the wastegate valve. The turbocharger wastegate motor uses three different motor legs to move the valve through its range of motion. The ECM uses the turbocharger wastegate motor A, B, and C wires to command the turbocharger wastegate to the appropriate position in order to maintain appropriate intake manifold pressure and turbocharger speed. The turbocharger wastegate motor contains three position sensors that detect the location of the wastegate. These sensors report the position of the wastegate back to the ECM over the turbocharger wastegate position A, B, and C wires.

Component Location

Turbocharger wastegates are mounted on the outboard side of the exhaust outlet connections.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a short circuit to ground in the turbocharger wastegate motor signal circuits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Turbocharger wastegate operation will be disabled.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • One of the turbocharger wastegate motor circuits shorted to ground in the wastegate motor.
  • One of the turbocharger wastegate motor circuits shorted to ground in the harness.
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 3969.

Last Modified: 11-Dec-2015


Engine Turbocharger Wastegate Actuator 1 Position - Current Below Normal or Open Circuit

FAULT CODE 3971

Engine Turbocharger Wastegate Actuator 1 Position - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3971 PID: SPN: 1188 FMI: 5/5 LAMP: Amber SRT: | Engine Turbocharger Wastegate Actuator 1 Position - Current below normal or open circuit. Motor terminal or motor coil open circuit has been detected by the ECM. | Possible reduced engine performance.
Turbocharger Wastegate Circuit

Circuit Description

The turbocharger wastegate is controlled by an electric motor located on the wastegate valve. The turbocharger wastegate motor uses three different motor legs to move the valve through its range of motion. The ECM uses the turbocharger wastegate motor A, B, and C wires to command the turbocharger wastegate to the appropriate position in order to maintain appropriate intake manifold pressure and turbocharger speed. The turbocharger wastegate motor contains three position sensors that detect the location of the wastegate. These sensors report the position of the wastegate back to the ECM over the turbocharger wastegate position A, B, and C wires.

Component Location

Turbocharger wastegates are mounted on the outboard side of the exhaust outlet connections.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an open circuit in the engine wiring harness or turbocharger wastegate motor coil.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Turbocharger wastegate operation will be disabled.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Turbocharger wastegate motor open circuit.
  • Open circuit in the wiring harness
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 3971.

Last Modified: 11-Dec-2015


Engine Turbocharger Wastegate Actuator 2 Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3972

Engine Turbocharger Wastegate Actuator 2 Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3972 PID: SPN: 1189 FMI: 2/2 LAMP: Amber SRT: | Engine Turbocharger Wastegate Actuator 2 Position - Data Erratic, Intermittent, or Incorrect. An error has been detected in the turbocharger wastegate position sensor circuit. | Possible reduced engine performance.
Turbocharger Wastegate 2 Circuit

Circuit Description

The turbocharger wastegate is controlled by a brushless motor located on top of the wastegate valve. The turbocharger wastegate motor uses three different motor legs to move the valve through its range of motion. The ECM uses the turbocharger wastegate motor A, B, and C wires to command the turbocharger wastegate to the appropriate position in order to maintain appropriate intake manifold pressure and turbocharger speed. The turbocharger wastegate motor contains three position sensors that detect the location of the wastegate. These sensors report the position of the wastegate back to the ECM over the turbocharger wastegate position A, B, and C wires.

Component Location

Turbocharger wastegates are mounted on the outboard side of the exhaust outlet connections.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger wastegate position sensor signal voltage was higher or lower than expected.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Turbocharger wastegate operation will be disabled.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Turbocharger wastegate position sensor wiring shorted to ground, open circuit, or shorted to power supply.
Refer to Troubleshooting Fault Code 3972.

Last Modified: 11-Dec-2015


Engine Turbocharger Wastegate Actuator 2 Position Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 3973

Engine Turbocharger Wastegate Actuator 2 Position Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3973 PID: SPN: 1189 FMI: 6/6 LAMP: Amber SRT: | Engine Turbocharger Wastegate Actuator 2 Position - Current above normal or grounded circuit. A short circuit to ground has been detected in the turbocharger wastegate motor circuit. | Possible reduced engine performance.
Turbocharger Wastegate 2 Circuit

Circuit Description

The turbocharger wastegate is controlled by a brushless motor located on top of the wastegate valve. The turbocharger wastegate motor uses three different motor legs to move the valve through its range of motion. The ECM uses the turbocharger wastegate motor A, B, and C wires to command the turbocharger wastegate to the appropriate position in order to maintain appropriate intake manifold pressure and turbocharger speed. The turbocharger wastegate motor contains three position sensors that detect the location of the wastegate. These sensors report the position of the wastegate back to the ECM over the turbocharger wastegate position A, B, and C wires.

Component Location

Turbocharger wastegates are mounted on the outboard side of the exhaust outlet connections.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a short circuit to ground in the turbocharger wastegate motor signal circuits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Turbocharger wastegate operation will be disabled.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • One of the turbocharger wastegate motor circuits shorted to ground in the wastegate motor.
  • One of the turbocharger wastegate motor circuits shorted to ground in the harness.
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 3973.

Last Modified: 11-Dec-2015


Engine Turbocharger Wastegate Actuator 2 Position Circuit - Current Below Normal or Open Circuit

FAULT CODE 3974

Engine Turbocharger Wastegate Actuator 2 Position Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3974 PID: SPN: 1189 FMI: 5/5 LAMP: Amber SRT: | Engine Turbocharger Wastegate Actuator 2 Position - Current below normal or open circuit. Motor terminal or motor coil open circuit has been detected by the ECM. | Possible reduced engine performance.
Turbocharger Wastegate 2 Circuit

Circuit Description

The turbocharger wastegate is controlled by a brushless motor located on top of the wastegate valve. The turbocharger wastegate motor uses three different motor legs to move the valve through its range of motion. The ECM uses the turbocharger wastegate motor A, B, and C wires to command the turbocharger wastegate to the appropriate position in order to maintain appropriate intake manifold pressure and turbocharger speed. The turbocharger wastegate motor contains three position sensors that detect the location of the wastegate. These sensors report the position of the wastegate back to the ECM over the turbocharger wastegate position A, B, and C wires.

Component Location

Turbocharger wastegates are mounted on the outboard side of the exhaust outlet connections.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an open circuit in the engine wiring harness or turbocharger wastegate motor coil.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Turbocharger wastegate operation will be disabled.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Turbocharger wastegate motor open circuit.
  • Open circuit in the wiring harness
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 3974.

Last Modified: 11-Dec-2015


Aftertreatment 2 Intake NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3982

Aftertreatment 2 Intake NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3982 PID: SPN: 3255 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 2 Intake NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source. An internal circuit error has been detected by the aftertreatment intake NOx sensor. | None on performance.
Aftertreatment 2 Intake NOx Sensor Circuit

Circuit Description

The aftertreatment 2 intake NOx sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment 2 intake NOx sensor performs internal diagnostics and reports malfunctions back to ECM 2 using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment 2 intake NOx sensor is used to measure the NOx emissions at the engine exhaust outlet connection.

Component Location

The aftertreatment 2 intake NOx sensor is mounted on the right bank engine exhaust outlet connection.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment selective catalytic reduction intake temperature has reached a calibrated threshold.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment intake NOx sensor assembly.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • The aftertreatment intake NOx sensor has malfunctioned or is damaged
  • The aftertreatment intake NOx sensor internal heater has malfunctioned
  • The NOx sensor part number is incorrect.
Refer to Troubleshooting Fault Code 3982.

Last Modified: 03-May-2016


Aftertreatment 2 Intake NOx Sensor - Out of Calibration

FAULT CODE 3984

Aftertreatment 2 Intake NOx Sensor - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3984 PID: SPN: 3255 FMI: 13/13 LAMP: Amber SRT: | Aftertreatment 2 Intake NOx - Out of Calibration. A nominal system voltage mismatch has been detected by the aftertreatment intake NOx sensor. | None on performance.
Aftertreatment 2 Intake NOx Sensor Power Supply

Circuit Description

The aftertreatment 2 intake NOx sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment 2 intake NOx sensor performs internal diagnostics and reports malfunctions back to ECM 2 using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment 2 intake NOx sensor is used to measure the NOx emissions at the engine exhaust outlet connection.

Component Location

The aftertreatment 2 intake NOx sensor is mounted on the right bank engine exhaust outlet connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a mismatch between the engine's electrical system voltage and the NOx sensor voltage rating.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • System voltage is incorrect for the installed aftertreatment intake NOx sensor part number.
  • Incorrect aftertreatment intake NOx sensor is installed in exhaust system.
Refer to Troubleshooting Fault Code 3984.

Last Modified: 03-May-2016


Aftertreatment 2 Intake NOx Sensor - Abnormal Rate of Change

FAULT CODE 3985

Aftertreatment 2 Intake NOx Sensor - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3985 PID: SPN: 3255 FMI: 10/10 LAMP: Amber SRT: | Aftertreatment 2 Intake NOx Sensor - Abnormal Rate of Change. The aftertreatment intake NOx sensor reading is not valid. | None on performance.
Aftertreatment 2 Intake NOx Sensor Circuit

Circuit Description

The aftertreatment 2 intake NOx sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment 2 intake NOx sensor performs internal diagnostics and reports malfunctions back to ECM 2 using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment 2 intake NOx sensor is used to measure the NOx emissions at the engine exhaust outlet connection.

Component Location

The aftertreatment 2 intake NOx sensor is mounted on the right bank engine exhaust outlet connection.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment selective catalytic reduction intake temperature has reached a calibrated threshold.

Conditions for Setting the Fault Codes

The aftertreatment intake Nox sensor reading was not valid.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

  • This fault code sets when the aftertreatment intake NOx sensor indicates to the ECM that it is not providing valid data.
Refer to Troubleshooting Fault Code 3985.

Last Modified: 03-May-2016


Aftertreatment 2 Intake NOx Sensor - Data Not Rational - Drifted High

FAULT CODE 3986

Aftertreatment 2 Intake NOx Sensor - Data Not Rational - Drifted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3986 PID: SPN: 3255 FMI: 2/20 LAMP: Amber SRT: | Aftertreatment 2 Intake NOx Sensor - Data Not Rational - Drifted High. An offset in the intake NOx sensor reading has been detected. | None on performance.
Aftertreatment 2 Intake NOx Sensor Circuit

Circuit Description

The aftertreatment 2 intake NOx sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment 2 intake NOx sensor performs internal diagnostics and reports malfunctions back to ECM 2 using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment 2 intake NOx sensor is used to measure the NOx emissions at the engine exhaust outlet connection.

Component Location

The aftertreatment 2 intake NOx sensor is mounted on the right bank engine exhaust outlet connection.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment selective catalytic reduction intake temperature is above 150°C [302°F], and the engine is in a motoring condition.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment intake NOx sensor was not reading zero while in a motoring (non-fueling) condition.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The aftertreatment selective catalytic reduction intake temperature must be above 150° C [302° F] for 5 seconds before the aftertreatment intake NOx sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning aftertreatment intake NOx sensor
  • Improperly installed aftertreatment intake NOx sensor.
Refer to Troubleshooting Fault Code 3986.

Last Modified: 03-May-2016


Aftertreatment 2 Outlet NOx Sensor - Abnormal Update Rate

FAULT CODE 3988

Aftertreatment 2 Outlet NOx Sensor - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3988 PID: SPN: 3265 FMI: 9/9 LAMP: Amber SRT: | Aftertreatment 2 Outlet NOx Sensor - Abnormal Update Rate. No communication or an invalid data transfer rate detected on the J1939 data link between the ECM and the aftertreatment outlet NOx sensor. | None on performance.
Aftertreatment 2 Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment 2 outlet NOx sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment 2 outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to ECM 2 using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment 2 outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment 2 outlet NOx sensor is mounted in the aftertreatment 2 SCR outlet.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) lost communication with the aftertreatment outlet NOx sensor via the J1939 data link.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low supply voltage
  • Open return circuit.
  • Open or short circuit on the J1939 data link circuit between the engine ECM and aftertreatment outlet NOx sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3988.

Last Modified: 03-May-2016


Aftertreatment 2 Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3995

Aftertreatment 2 Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3995 PID: SPN: 3265 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 2 Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source. An internal circuit error has been detected by the aftertreatment outlet NOx sensor. | None on performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

The engine is running.

The aftertreatment SCR outlet temperature must be above 180C (356F) before the aftertreatment outlet NOx sensor can run its internal diagnostics.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment outlet NOx sensor assembly.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The aftertreatment SCR outlet temperature must be above 150Â° C [302Â° F] for 60 seconds before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

The aftertreatment outlet NOx sensor has malfunctioned or is damaged

The aftertreatment outlet NOx sensor internal heater has malfunctioned

The NOx sensor part number is incorrect.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3995.

Last Modified: 17-Jan-2018


Aftertreatment 2 SCR Catalyst Intake Gas Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3998

Aftertreatment 2 SCR Catalyst Intake Gas Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3998 PID: SPN: 4413 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment 2 SCR Catalyst Intake Gas Temperature - Data Erratic, Intermittent, or Incorrect. The SCR intake temperature sensor is not changing with engine operating conditions. | None on performance.
Aftertreatment 2 SCR Catalyst Temperature Sensor Module

Circuit Description

The aftertreatment 2 SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment 2 SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment 2 SCR temperature sensor module is used to measure the aftertreatment 2 SCR intake temperature and aftertreatment 2 SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment 2 SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment 2 SCR temperature module is mounted to the aftertreatment SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and exhaust flow is above a minimum level.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment SCR intake temperature sensor signal was irrational for more than 5 minutes.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

A default value for the SCR catalyst intake temperature is used.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR intake temperature sensor

Refer to Troubleshooting Fault Code 3998.

Last Modified: 30-Apr-2018


Aftertreatment 2 SCR Catalyst Intake Gas Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 3999

Aftertreatment 2 SCR Catalyst Intake Gas Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3999 PID: SPN: 4413 FMI: /15 LAMP: SRT: | Aftertreatment 2 SCR Catalyst Intake Gas Temperature - Data Valid But Above Normal Operational Range - Least Severe Level. The selective catalytic reduction (SCR) intake temperature sensor reading has exceeded the calibrated temperature limit. | None on performance.
Aftertreatment 2 SCR Catalyst Temperature Sensor Module

Circuit Description

The aftertreatment 2 SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment 2 SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment 2 SCR temperature sensor module is used to measure the aftertreatment 2 SCR intake temperature and aftertreatment 2 SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment 2 SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment 2 SCR temperature module is mounted to the aftertreatment SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the temperature at the SCR catalyst intake was greater than a calibrated value.

Action Taken When the Fault Code is Active

The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Operating the engine under heavy load especially in hot ambient conditions.

Malfunctioning in-range SCR intake temperature sensor

Refer to Troubleshooting Fault Code 3999.

Last Modified: 30-Apr-2018


Aftertreatment 2 SCR Catalyst Intake Gas Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 4111

Aftertreatment 2 SCR Catalyst Intake Gas Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4111 PID: SPN: 4413 FMI: /16 LAMP: Amber SRT: | Aftertreatment 2 SCR Catalyst Intake Gas Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. High selective catalytic reduction (SCR) intake temperature has been detected. | Engine power derate.
SCR Temperature Sensor Module

Circuit Description

The aftertreatment 2 SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment 2 SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment 2 SCR temperature sensor module is used to measure the aftertreatment 2 SCR intake temperature and aftertreatment 2 SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment 2 SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment 2 SCR temperature module is mounted to the aftertreatment SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the temperature at the SCR catalyst intake was greater than a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Malfunctioning turbocharger wastegate.

Contaminated diesel exhaust fluid

A malfunctioning aftertreatment SCR temperature sensor module

Leaking turbocharger oil seals

Leaks in the charge air system plumbing

Refer to Troubleshooting Fault Code 4111.

Last Modified: 30-Apr-2018


Aftertreatment 2 SCR Catalyst Intake Gas Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 4112

Aftertreatment 2 SCR Catalyst Intake Gas Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4112 PID: SPN: 4413 FMI: / LAMP: Red SRT: | Aftertreatment 2 SCR Catalyst Intake Gas Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. The selective catalytic reduction (SCR) intake temperature sensor reading has exceeded the maximum temperature limit. | Possible reduced engine performance.
SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the temperature at the SCR catalyst intake was greater than a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be severely reduced.

The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Malfunctioning turbocharger wastegate.

Leaks in the charge air system plumbing

Malfunctioning fuel injectors

Malfunctioning in-range SCR intake temperature sensor

Refer to Troubleshooting Fault Code 4112.

Last Modified: 30-Apr-2018


Aftertreatment 2 SCR Catalyst Intake Gas Temperature - Voltage Above Normal or Shorted to High Source

FAULT CODE 4113

Aftertreatment 2 SCR Catalyst Intake Gas Temperature - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4113 PID: SPN: 4413 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 2 SCR Catalyst Intake Gas Temperature - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the selective catalytic reduction (SCR) intake temperature sensor circuit. | None on performance.
Aftertreatment 2 Selective Catalytic Reduction Temperature Sensor Module

Circuit Description

The aftertreatment 2 SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment 2 SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment 2 SCR temperature sensor module is used to measure the aftertreatment 2 SCR intake temperature and aftertreatment 2 SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment 2 SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment 2 SCR temperature module is mounted to the aftertreatment SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported the aftertreatment SCR intake temperature signal was out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

A default value for the SCR catalyst intake temperature is used.

Aftertreatment DEF dosing system will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR intake temperature sensor

Refer to Troubleshooting Fault Code 4113.

Last Modified: 30-Apr-2018


Aftertreatment 2 SCR Catalyst Intake Gas Temperature - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4114

Aftertreatment 2 SCR Catalyst Intake Gas Temperature - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4114 PID: SPN: 4413 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 2 SCR Catalyst Intake Gas Temperature - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the selective catalytic reduction (SCR) intake temperature sensor circuit. | None on performance.
Aftertreatment Selective Catalytic Reduction Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted by the OEM near the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported the aftertreatment SCR intake temperature signal was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

A default value for the SCR catalyst intake temperature is used.

Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR intake temperature sensor

Refer to Troubleshooting Fault Code 4114.

Last Modified: 30-Apr-2018


Aftertreatment 2 SCR Catalyst Outlet Gas Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 4115

Aftertreatment 2 SCR Catalyst Outlet Gas Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4115 PID: SPN: 4415 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment 2 SCR Catalyst Outlet Gas Temperature - Data Erratic, Intermittent, or Incorrect. The selective catalytic reduction (SCR) outlet temperature sensor is not changing with engine operating conditions. | None on performance.
Aftertreatment 2 SCR Temperature Sensor Module

Circuit Description

The aftertreatment 2 SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment 2 SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment 2 SCR temperature sensor module is used to measure the aftertreatment 2 SCR intake temperature and aftertreatment 2 SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment 2 SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment 2 SCR temperature module is mounted to the aftertreatment SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and exhaust flow is above a minimum level.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment SCR outlet temperature sensor signal was irrational for more than 5 minutes.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

A default value for the SCR catalyst outlet temperature is used.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR outlet temperature sensor

Refer to Troubleshooting Fault Code 4115.

Last Modified: 30-Apr-2018


Aftertreatment 2 SCR Catalyst Outlet Gas Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 4117

Aftertreatment 2 SCR Catalyst Outlet Gas Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4117 PID: SPN: 4415 FMI: /16 LAMP: Red SRT: | Aftertreatment 2 SCR Catalyst Outlet Gas Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. High selective catalytic reduction (SCR) outlet temperature has been detected. | Possible reduced engine performance.
Aftertreatment 2 SCR Temperature Sensor Module

Circuit Description

The aftertreatment 2 SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment 2 SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment 2 SCR temperature sensor module is used to measure the aftertreatment 2 SCR intake temperature and aftertreatment 2 SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment 2 SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment 2 SCR temperature module is mounted to the aftertreatment SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the temperature at the SCR catalyst outlet was greater than a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault will go inactive immediately after the SCR outlet temperature drops below the warning limit, and will likely be inactive at the time of diagnosis. For these reasons this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

Malfunctioning turbocharger wastegate.

Degraded, diluted, or incorrect diesel exhaust fluid

Leaking turbocharger oil seals

Malfunctioning fuel injectors

Malfunctioning in-range SCR outlet temperature sensor.

Refer to Troubleshooting Fault Code 4117.

Last Modified: 30-Apr-2018


Aftertreatment 2 SCR Catalyst Outlet Gas Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 4118

Aftertreatment 2 SCR Catalyst Outlet Gas Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4118 PID: SPN: 4415 FMI: / LAMP: Red SRT: | Aftertreatment 2 SCR Catalyst Outlet Gas Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. The selective catalytic reduction (SCR) outlet temperature sensor reading has exceeded the maximum temperature limit. | None on performance.
SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the temperature at the SCR catalyst outlet was greater than a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Malfunctioning turbocharger wastegate.

Contaminated diesel exhaust fluid

Leaking turbocharger oil seals

Leaks in the charge air system plumbing

Malfunctioning fuel injectors

Malfunctioning in-range SCR outlet temperature sensor.

Refer to Troubleshooting Fault Code 4118.

Last Modified: 30-Apr-2018


Aftertreatment 2 SCR Catalyst Outlet Gas Temperature - Voltage Above Normal or Shorted to High Source

FAULT CODE 4119

Aftertreatment 2 SCR Catalyst Outlet Gas Temperature - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4119 PID: SPN: 4415 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 2 SCR Catalyst Outlet Gas Temperature - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the Selective Catalytic Reduction (SCR) outlet temperature sensor circuit. | None on performance.
Aftertreatment 2 SCR Catalyst Temperature Sensor Module

Circuit Description

The aftertreatment 2 SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment 2 SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment 2 SCR temperature sensor module is used to measure the aftertreatment 2 SCR intake temperature and aftertreatment 2 SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment 2 SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment 2 SCR temperature module is mounted to the aftertreatment SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported the aftertreatment SCR outlet temperature signal was out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

A default value for the SCR catalyst outlet temperature is used.

Aftertreatment DEF dosing system will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR outlet temperature sensor

Refer to Troubleshooting Fault Code 4119.

Last Modified: 30-Apr-2018


Aftertreatment 2 SCR Catalyst Outlet Gas Temperature - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4121

Aftertreatment 2 SCR Catalyst Outlet Gas Temperature - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4121 PID: SPN: 4415 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 2 SCR Catalyst Outlet Gas Temperature - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the selective catalytic reduction (SCR) outlet temperature sensor circuit. | None on performance.
Aftertreatment 2 SCR Temperature Sensor Module

Circuit Description

The aftertreatment 2 SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment 2 SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment 2 SCR temperature sensor module is used to measure the aftertreatment 2 SCR intake temperature and aftertreatment 2 SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment 2 SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment 2 SCR temperature module is mounted to the aftertreatment SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported the aftertreatment SCR outlet temperature signal was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

A default value for the SCR catalyst outlet temperature is used.

Aftertreatment DEF dosing system will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR outlet temperature sensor

Refer to Troubleshooting Fault Code 4121.

Last Modified: 30-Apr-2018


Aftertreatment 2 Intake NOx Sensor Heater - Abnormal Rate of Change

FAULT CODE 4122

Aftertreatment 2 Intake NOx Sensor Heater - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4122 PID: SPN: 5038 FMI: 10/10 LAMP: Amber SRT: | Aftertreatment 2 Intake NOx Sensor Heater - Abnormal Rate of Change. The aftertreatment intake NOx sensor heater is unable to maintain its normal operating temperature. | None on performance.
Aftertreatment 2 Intake NOx Sensor Circuit

Circuit Description

The aftertreatment 2 intake NOx sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment 2 intake NOx sensor performs internal diagnostics and reports malfunctions back to ECM 2 using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment 2 intake NOx sensor is used to measure the NOx emissions at the engine exhaust outlet connection.

Component Location

The aftertreatment 2 intake NOx sensor is mounted on the right bank engine exhaust outlet connection.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment selective catalytic reduction intake temperature has reached a calibrated threshold.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the NOx sensor heater was unable to maintain its normal operating temperature.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The NOx sensor heater is internal to the NOx sensor assembly, and can not be serviced separately.

Possible causes of this fault code include:

  • Damaged aftertreatment intake NOx sensor
  • Intermittent power connection to the aftertreatment intake NOx sensor.
Refer to Troubleshooting Fault Code 4122.

Last Modified: 03-May-2016


Aftertreatment 2 SCR Catalyst System Missing - Condition Exists

FAULT CODE 4124

Aftertreatment 2 SCR Catalyst System Missing - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4124 PID: SPN: 5744 FMI: 11/31 LAMP: Amber SRT: | Aftertreatment 2 SCR Catalyst System Missing - Condition Exists. The aftertreatment SCR catalyst in the exhaust system is not present. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) monitors the NOx concentration in the engine exhaust gases using an aftertreatment intake NOx sensor and an aftertreatment outlet NOx sensor. By comparing these two values, the ECM determines the conversion efficiency of the SCR catalyst and aftertreatment DEF dosing system.

Component Location

The SCR catalyst is located in the SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the NOx conversion efficiency of the SCR catalyst was critically low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

It is necessary to use the "Reset All Faults" command in INSITE™ electronic service tool to clear this fault and extinguish the amber CHECK ENGINE lamp.

Shop Talk

Troubleshoot all other active NOx sensor and SCR dosing system related fault codes before this fault.

Possible causes of this fault include:

  • Tampering with SCR catalyst system, removal of SCR catalyst from equipment, or malfunctioning SCR catalyst.
  • Malfunctioning aftertreatment diesel exhaust fluid dosing system.
  • Exhaust system leaks
  • Degraded, diluted, or incorrect diesel exhaust fluid
  • Diesel exhaust fluid crystallization or deposits
Refer to Troubleshooting Fault Code 4124.

Last Modified: 03-May-2016


Aftertreatment 2 Intake NOx Sensor - Abnormal Update Rate

FAULT CODE 4145

Aftertreatment 2 Intake NOx Sensor - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4145 PID: SPN: 3255 FMI: 9/9 LAMP: Amber SRT: | Aftertreatment 2 Intake Nox Sensor - Abnormal Update Rate. No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the aftertreatment intake NOx sensor. | None on performance.
Aftertreatment Intake NOx Sensor Power Supply

Circuit Description

The aftertreatment 1 intake NOx sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment 1 intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment 1 intake NOx sensor is used to measure the NOx emissions at the engine exhaust outlet connection.

Component Location

The aftertreatment 2 intake NOx sensor is mounted on the right bank engine exhaust outlet connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a mismatch between the engine's electrical system voltage and the NOx sensor voltage rating.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • System voltage is incorrect for the installed aftertreatment intake NOx sensor part number.
  • Incorrect aftertreatment intake NOx sensor is installed in exhaust system.
Refer to Troubleshooting Fault Code 4145.

Last Modified: 03-May-2016


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 415

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1/1 LAMP: Red SRT: | Engine Oil Rifle Pressure - Data Valid But Below Normal Operational Range - Most Severe Level. Oil pressure signal indicates oil pressure is below the engine protection critical limit. | Engine may be shut down.
Engine Oil Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located on the outlet of the oil filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure was below minimum operating limits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • High oil filter restriction.
  • Malfunctioning oil pump.
  • Blocked or restricted oil passage.
  • Incorrect oil level
  • Damaged oil pressure sensor

During active Red Lamp conditions the OEM may inhibit starting. See OEM Service Manual.

Refer to Troubleshooting Fault Code 415.

Last Modified: 12-Oct-2016


Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Abnormal Update Rate

FAULT CODE 4152

Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4152 PID: SPN: 5743 FMI: 9/9 LAMP: Amber SRT: | Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Abnormal update rate. No communication on the J1939 data link between the ECM and the aftertreatment SCR temperature sensor module. | None on performance.
Aftertreatment SCR Temperature Sensor Module Circuit

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of communication with the aftertreatment SCR temperature sensor module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Incorrect terminating resistance of the SAE J1939 datalink circuit
  • Incorrect sensor for the application (12 VDC versus 24 VDC)
Refer to Troubleshooting Fault Code 4152.

Last Modified: 10-May-2016


Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Bad Intelligent Device or Component

FAULT CODE 4159

Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4159 PID: SPN: 5743 FMI: 12/12 LAMP: Amber SRT: | Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Bad intelligent device or component. An internal error has been detected in the aftertreatment SCR temperature sensor module. | None on performance.
Aftertreatment SCR Temperature Sensor Module Circuit

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported an internal error.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment SCR temperature sensor module
Refer to Troubleshooting Fault Code 4159.

Last Modified: 10-May-2016


Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage Above Normal or Shorted to High Source

FAULT CODE 4164

Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4164 PID: SPN: 5743 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage Above Normal, or Shorted to High Source. High supply voltage detected at the aftertreatment SCR temperature sensor module. | None on performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported high supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Incorrect sensor for the application (12 VDC versus 24 VDC)
  • High power supply voltage.
Refer to Troubleshooting Fault Code 4164.

Last Modified: 10-May-2016


Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4165

Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4165 PID: SPN: 5743 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage below normal, or shorted to low source. Low supply voltage detected at the aftertreatment SCR temperature sensor module. | None on performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported low supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Incorrect sensor for the application (12 VDC versus 24 VDC)
  • Low supply voltage
Refer to Troubleshooting Fault Code 4165.

Last Modified: 10-May-2016


Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 4166

Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4166 PID: SPN: 5743 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level. High internal temperature detected in the aftertreatment SCR temperature sensor module. | None on performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported the internal circuit board temperature was too high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates the internal temperature of the aftertreatment SCR temperature sensor module was too high. Troubleshoot the exhaust system for leaks, missing heat shields, or dirt and debris that could lead to overheating of the aftertreatment SCR temperature sensor module.

Refer to Troubleshooting Fault Code 4166.

Last Modified: 10-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 4168

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4168 PID: SPN: 5745 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Heater - Voltage Above Normal, or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid dosing unit heater circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit heater is used to defrost and/or prevent freezing of the diesel exhaust fluid dosing unit.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit heater circuit is shorted to ECM supply voltage or open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to voltage source in the wiring harness
  • An open circuit in the harness
  • Malfunctioning diesel exhaust fluid dosing unit heater.
Refer to Troubleshooting Fault Code 4168.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4169

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4169 PID: SPN: 5745 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Heater - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel exhaust fluid dosing unit heater circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit heater is used to defrost and/or prevent freezing of the diesel exhaust fluid dosing unit.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low signal voltage or a short to ground at the diesel exhaust fluid dosing unit heater circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning diesel exhaust fluid dosing unit heater.
  • Signal circuit shorted to ground in the harness
Refer to Troubleshooting Fault Code 4169.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Dosing Temperature Sensor - Voltage Above Normal or Shorted to High Source

FAULT CODE 4174

Aftertreatment 1 Diesel Exhaust Fluid Dosing Temperature Sensor - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4174 PID: SPN: 4337 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Dosing Temperature Sensor - Voltage Above Normal, or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid dosing temperature sensor circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) dosing temperature sensor is a variable resistor sensor and is used to measure the temperature of the DEF in the dosing valve. The engine control module (ECM) supplies 5 volts to the aftertreatment DEF dosing temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the aftertreatment DEF dosing temperature.

Component Location

The aftertreatment diesel exhaust fluid dosing temperature sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing temperature sensor signal circuit was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit shorted to voltage source.
  • A malfunctioning aftertreatment diesel exhaust fluid dosing temperature sensor
Refer to Troubleshooting Fault Code 4174.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Dosing Temperature Sensor - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4175

Aftertreatment 1 Diesel Exhaust Fluid Dosing Temperature Sensor - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4175 PID: SPN: 4337 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Dosing Temperature Sensor - Voltage below normal, or shorted to low source. Low signal voltage detected at the aftertreatment diesel exhaust fluid dosing temperature sensor signal circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) dosing temperature sensor is a variable resistor sensor and is used to measure the temperature of the DEF in the dosing valve. The engine control module (ECM) supplies 5 volts to the aftertreatment DEF dosing temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the aftertreatment DEF dosing temperature.

Component Location

The aftertreatment diesel exhaust fluid dosing temperature sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing temperature sensor signal circuit was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground.
  • A malfunctioning aftertreatment diesel exhaust fluid dosing temperature sensor
Refer to Troubleshooting Fault Code 4175.

Last Modified: 03-May-2016


Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 421

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 421 PID: P175 SPN: 175 FMI: 0/16 LAMP: Amber SRT: | Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. Engine oil temperature signal indicates engine oil temperature above engine protection warning limit. | None on performance.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil pan.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that the engine oil temperature has exceeded the maximum engine protection limit for oil temperature. Troubleshoot the cause of high engine oil temperature.

Refer to Troubleshooting Fault Code 421.

Last Modified: 10-Aug-2015


Aftertreatment 1 Diesel Exhaust Fluid Property - Condition Exists

FAULT CODE 4235

Aftertreatment 1 Diesel Exhaust Fluid Property - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4235 PID: SPN: 3521 FMI: 11/31 LAMP: Red SRT: | Aftertreatment 1 Diesel Exhaust Fluid Property - Root Cause Not Known. Unknown fluid inside DEF tank. | Engine power derate.
Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment DEF sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment DEF sensor monitors the tank level, temperature and quality of the DEF fluid.

Component Location

The aftertreatment diesel exhaust fluid (DEF) sensor is located in the aftertreatment DEF tank. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid quality sensor reported an unknown error.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • Damaged sensor
  • Degraded, diluted, or incorrect diesel exhaust fluid
Refer to Troubleshooting Fault Code 4235.

Last Modified: 05-May-2017


Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 - Abnormal Rate of Change

FAULT CODE 4243

Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4243 PID: SPN: 3515 FMI: 10/10 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 - Abnormal Rate of Change | None on performance.
Aftertreatment Diesel Exhaust Fluid Temperature 2 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment DEF sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment DEF sensor monitors the tank level, temperature and quality of the DEF fluid.

Component Location

The aftertreatment diesel exhaust fluid (DEF) sensor is located in the aftertreatment DEF tank. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank temperature sensor reading was higher or lower than the other temperature sensors on the engine.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault include:

A damaged DEF smart sensor

Refer to Troubleshooting Fault Code 4243.

Last Modified: 03-May-2016


J1939 Network #1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 426

J1939 Network #1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 426 PID: S231 SPN: 639 FMI: 2/2 LAMP: None SRT: | J1939 Data Link - Data Erratic, Intermittent, or Incorrect. Communication between the engine control module (ECM) and another device on the SAE J1939 data link has been lost. | None on performance.
SAE J1939 Datalink 1 Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) electronic control unit (ECU). Then component values and states from components such as sensors, throttle input, and switches can be transmitted from the OEM ECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM ECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault can occur for the following reasons:

  • A multiplexed component is enabled in the ECM, but the OEM ECU source address of the ECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM ECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a damaged J1939 data link connection between the OEM ECU and Cummins® ECM, a damaged connection between the component and the OEM ECU, damaged OEM ECU or damaged Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 426.

Last Modified: 10-Aug-2015


Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Root Cause Not Known

FAULT CODE 4261

Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4261 PID: SPN: 5743 FMI: 11/11 LAMP: Amber SRT: | Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Root Cause Not Known. Intermittent supply voltage detected at the aftertreatment SCR temperature sensor module. | None on performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an intermittent supply voltage to the aftertreatment SCR temperature sensor module resulting in an internal reset of the module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code sets when the ECM detects an internal reset of the sensor. This internal reset is caused by an intermittent supply voltage. This fault code indicates that an intermittent wiring problem has been detected. All wiring and connectors should be closely inspected for intermittent connections.

Refer to Troubleshooting Fault Code 4261.

Last Modified: 10-May-2016


Aftertreatment Diesel Exhaust Fluid Quality - Abnormal Rate of Change

FAULT CODE 4277

Aftertreatment Diesel Exhaust Fluid Quality - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4277 PID: SPN: 3364 FMI: 10/10 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality - Abnormal Rate of Change. No communications or an invalid data transfer rate detected on the J1939 data link between the engine control module (ECM) and the aftertreatment DEF quality sensor. | None on performance.
Aftertreatment Diesel Exhaust Fluid Quality Circuit

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) lost communication with the aftertreatment DEF quality sensor via the J1939 data link.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with the recommended Cummins electronic service tool or equivalent.
  • Start and idle the engine for 15 minutes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

Shorted or open J1939 data link wiring.

Malfunctioning Aftertreatment DEF Quality Sensor.

Refer to Troubleshooting Fault Code 4277.

Last Modified: 14-Jan-2019


Accelerator Pedal or Lever Idle Validation Switch - Data Erratic, Intermittent, or Incorrect

FAULT CODE 431

Accelerator Pedal or Lever Idle Validation Switch - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 431 PID: S230 SPN: 558 FMI: 2/2 LAMP: Amber SRT: | Voltage detected simultaneously on both the on-idle signal and off-idle signal circuits. | Engine will only idle.
Accelerator Pedal or Lever Circuit

Circuit Description

The accelerator pedal or lever idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position. The idle validation switch return is a shared return with other original equipment manufacturer (OEM) cab switches.

Component Location

The idle validation switch is located on the accelerator pedal assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the on-idle and off-idle signal circuits are in the same state simultaneously.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The engine will only idle.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and operate at rated speed for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • An open circuit on the accelerator pedal or lever idle validation switch on signal
  • An open circuit on the accelerator pedal or lever idle validation switch off signal
  • An uncalibrated accelerator pedal assembly
Refer to Troubleshooting Fault Code 431.

Last Modified: 11-Dec-2015


Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 441

Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 SPN: 168 FMI: 1/18 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid But Below Normal Operational Range - Moderately Severe Level. ECM supply voltage is below the minimum system voltage level. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Unswitched Power Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from power supplies through the unswitched power supply circuit.

Component Location

The ECM is connected to the power supply by a combination of engine harness and OEM harness connected in series. This direct link provides a constant power supply for the ECM. The location of the power supply will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low power supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 441.

Last Modified: 10-May-2016


Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 442

Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 0/16 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid But Above Normal Operational Range - Moderately Severe Level. ECM supply voltage is above the maximum system voltage level. | None on performance.
Unswitched Power Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from power supplies through the unswitched power supply circuit.

Component Location

The ECM is connected to the power supply by a combination of engine harness and OEM harness connected in series. This direct link provides a constant power supply for the ECM. The location of the power supply will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected excessive power supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and run it at high idle for 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

  • Verify that the ECM unswitched power supply is coming from the OEM power supply and not the starter or other device.
  • Incorrect jump-starting procedure.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 442.

Last Modified: 10-May-2016


J1939 Network #4 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 4437

J1939 Network #4 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4437 PID: SPN: 1668 FMI: 2/2 LAMP: None SRT: | J1939 Network #4 - Data erratic, intermittent or incorrect. A circuit malfunction has been detected on J1939 network 4. | None on performance.
ECM 1 SAE J1939 Data Link 4 Circuit

Circuit Description

The SAE J1939 data link circuit consists of one positive and one negative wire. Two 120 ohm resistors are connected in parallel to terminate the ends of the backbone. Stubs connect the smart devices to the J1939 backbone.

The Engine Control Module (ECM) uses J1939 data link 4 to communicate with various aftertreatment sensors.

Component Location

The SAE J1939 data link 4 extends from the ECM to the aftertreatment. Specific data link 4 routing will vary by original equipment manufacturer (OEM) and equipment type.

Aftertreatment 1 components correspond with exhaust gas originating from the left bank of the engine.

Aftertreatment 2 components correspond with exhaust gas originating from the right bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has detected an open on the J1939 data link backbone or a short circuit.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Open or short circuit on J1939 data link
Refer to Troubleshooting Fault Code 4437.

Last Modified: 11-Dec-2015


Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists

FAULT CODE 4456

Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4456 PID: SPN: 4452 FMI: 11/31 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists. The diesel exhaust fluid dosing unit is unable to prime. | None on performance.
Diesel Exhaust Fluid Dosing Valve Circuit

Circuit Description

The diesel exhaust fluid dosing unit lines are responsible for transporting diesel exhaust fluid between the dosing unit, dosing valve, and diesel exhaust fluid tank.

Component Location

There are three diesel exhaust fluid lines. One line is between the diesel exhaust fluid tank and the dosing unit (suction line), one line is between the dosing unit and dosing valve (pressure line) and one line is between the dosing valve and the diesel exhaust fluid tank (return line). These lines can be partially hidden from view by the SCR system and other vehicle components. Line routing will vary, based on the aftertreatment architecture and the OEM.

Conditions for Running the Diagnostics

This diagnostic runs when the SCR system is trying to prime.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid dosing unit was unable to successfully prime after multiple attempts.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid System Leak Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low aftertreatment diesel exhaust fluid level in the diesel exhaust fluid tank
  • The line heaters are not successfully thawing the frozen diesel exhaust fluid
  • The diesel exhaust fluid pressure line between the dosing unit and dosing valve is kinked, broken, or disconnected
  • The diesel exhaust fluid suction line between the diesel exhaust fluid tank and the dosing unit is kinked, broken, or disconnected
  • Malfunctioning diesel exhaust fluid dosing unit
  • Debris from the diesel exhaust fluid tank. If debris is found in the diesel exhaust fluid tank, clean the diesel exhaust fluid tank thoroughly and fill with certified diesel exhaust fluid.
  • The diesel exhaust fluid pressure and return lines are reversed at the dosing valve
Refer to Troubleshooting Fault Code 4456.

Last Modified: 03-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit - Voltage Above Normal or Shorted to High Source

FAULT CODE 4457

Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4457 PID: SPN: 4451 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the diesel exhaust fluid dosing unit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit filters and pressurizes DEF for the DEF dosing valve. The ECM provides supply voltage and a ground to the diesel exhaust fluid dosing unit. The ECM also supplies a signal to the dosing unit to control the diesel exhaust fluid output. This signal changes, based on the diesel exhaust fluid pressure being commanded.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit signal voltage was greater than a calibrated value or the diesel exhaust fluid dosing unit supply was shorted to ECM supply voltage or open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • Perform a key cycle, and leave the key switch in the ON position for at least 2 minutes.
  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid System Leak Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A signal circuit shorted to sensor supply or ECM supply voltage.
  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 4457.

Last Modified: 03-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4458

Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4458 PID: SPN: 4451 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the diesel exhaust fluid dosing unit. | None on performance.
Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit filters and pressurizes DEF for the DEF dosing valve. The ECM provides supply voltage and a ground to the diesel exhaust fluid dosing unit. The ECM also supplies a signal to the dosing unit to control the diesel exhaust fluid output. This signal changes, based on the diesel exhaust fluid pressure being commanded.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit signal voltage or the aftertreatment diesel exhaust fluid dosing unit supply voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid System Leak Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Short to ground in the diesel exhaust fluid dosing unit
  • Supply wire shorted to ground.
  • Control signal wire shorted to ground or open.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 4458.

Last Modified: 03-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Line Heater Relay - Voltage Above Normal or Shorted to High Source

FAULT CODE 4459

Aftertreatment 2 Diesel Exhaust Fluid Line Heater Relay - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4459 PID: SPN: 5973 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Line Heater Relay - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the diesel exhaust fluid line heater relay. | None on performance.
Aftertreatment Diesel Exhaust Fluid Line Heater Relay Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater relay is used to provide power to the aftertreatment diesel exhaust fluid line heaters.

Component Location

The aftertreatment diesel exhaust fluid line heater relays are located in the aftertreatment junction box.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and line heating is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid line heater relay signal was open or shorted to high source.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A short circuit to voltage source in the wiring harness

An open circuit in the harness

Malfunctioning line heater relay

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 4459.

Last Modified: 20-Dec-2017


Aftertreatment 2 Diesel Exhaust Fluid Line Heater Relay - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4461

Aftertreatment 2 Diesel Exhaust Fluid Line Heater Relay - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4461 PID: SPN: 5973 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Line Heater Relay - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the diesel exhaust fluid line heater relay. | None on performance.
Aftertreatment Diesel Exhaust Fluid Line Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater relay is used to provide power to the aftertreatment diesel exhaust fluid line heaters.

Component Location

The aftertreatment diesel exhaust fluid line heater relays are located in the aftertreatment junction box.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid line heater relay control signal was shorted to ground.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITEâ„¢ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITEâ„¢ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITEâ„¢ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Signal circuit shorted to ground in the harness

Malfunctioning line heater relay

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 4461.

Last Modified: 27-Jul-2017


Aftertreatment 2 Diesel Exhaust Fluid Dosing Valve - Current Below Normal or Open Circuit

FAULT CODE 4462

Aftertreatment 2 Diesel Exhaust Fluid Dosing Valve - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4462 PID: SPN: 5974 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Dosing Valve - Current Below Normal or Open Circuit. A malfunction has been detected in the diesel exhaust fluid dosing valve circuit. | None on performance.
Diesel Exhaust Fluid Dosing Valve Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the ECM. When the engine control module (ECM) commands DEF dosing, the ECM sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing valve is being commanded on.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing valve circuit was shorted high, shorted low, or open.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, cycle the keyswitch from OFF to ON.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the diesel exhaust fluid dosing valve
  • Signal circuit open or shorted to ground.
  • Return circuit open or shorted.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 4462.

Last Modified: 18-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Dosing Valve 1 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 4463

Aftertreatment 2 Diesel Exhaust Fluid Dosing Valve 1 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4463 PID: SPN: 5974 FMI: 7/7 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Dosing Valve 1 - Mechanical System Not Responding or Out of Adjustment. A mechanical malfunction has been detected in the DEF dosing valve. | None on performance.
Aftertreatment Diesel Exhaust Fluid Dosing Valve Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the ECM. When the engine control module (ECM) commands DEF dosing, the ECM sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing valve is being commanded on.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing valve is mechanically stuck.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing valve

Contamination of the DEF can be a possible cause for this fault code.

Refer to Troubleshooting Fault Code 4463.

Last Modified: 03-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 4464

Aftertreatment 2 Diesel Exhaust Fluid Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4464 PID: SPN: 4387 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the diesel exhaust fluid pressure sensor circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal wire shorted to sensor supply or ECM supply voltage.
  • Open return circuit in the harness, connectors, or sensor.
  • A malfunctioning aftertreatment diesel exhaust fluid pressure sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 4464.

Last Modified: 03-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4465

Aftertreatment 2 Diesel Exhaust Fluid Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4465 PID: SPN: 4387 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the diesel exhaust fluid pressure sensor circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground.
  • Sensor supply wire open or shorted to ground
  • A malfunctioning aftertreatment diesel exhaust fluid pressure sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 4465.

Last Modified: 03-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Pressure 1 - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 4466

Aftertreatment 2 Diesel Exhaust Fluid Pressure 1 - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4466 PID: SPN: 4387 FMI: 1/18 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Pressure 1 - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low diesel exhaust fluid pressure has been detected in the dosing valve. | None on performance.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs after the diesel exhaust fluid dosing system has primed.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure was less than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low diesel exhaust fluid tank level
  • Blocked, restricted, or frozen diesel exhaust fluid dosing unit supply line
  • Blocked, restricted, or frozen diesel exhaust fluid dosing valve supply line
  • Blocked or restricted diesel exhaust fluid tank filter
  • Blocked or restricted diesel exhaust fluid dosing unit filter
  • Malfunctioning diesel exhaust fluid dosing unit
  • Blocked or restricted DEF dosing valve
  • Contaminated diesel exhaust fluid

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 4466.

Last Modified: 03-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Pressure 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 4467

Aftertreatment 2 Diesel Exhaust Fluid Pressure 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4467 PID: SPN: 4387 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Pressure 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level. The diesel exhaust fluid dosing valve has detected a blockage in the diesel exhaust fluid return flow. | None on performance.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs after the diesel exhaust fluid dosing system has primed.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure was greater than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Blocked, restricted, or frozen diesel exhaust fluid dosing valve return line or return line connector.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 4467.

Last Modified: 03-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Pressure 1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 4468

Aftertreatment 2 Diesel Exhaust Fluid Pressure 1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4468 PID: SPN: 4387 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Pressure 1 - Data Erratic, Intermittent, or Incorrect. The diesel exhaust fluid pressure sensor has reported a reading too high or low for the operating conditions. | None on performance.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs after the diesel exhaust fluid dosing system has primed.

Conditions for Setting the Fault Codes

The diesel exhaust fluid dosing unit was unable to maintain the commanded diesel exhaust fluid pressure.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Air in the DEF.
  • Leaking diesel exhaust fluid lines
  • Malfunctioning diesel exhaust fluid dosing unit
  • Blocked or restricted diesel exhaust fluid dosing unit supply line fitting
  • Blocked or restricted diesel exhaust fluid filters
  • Malfunctioning diesel exhaust fluid pressure sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 4468.

Last Modified: 03-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit 1 Heater - Voltage Above Normal or Shorted to High Source

FAULT CODE 4471

Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit 1 Heater - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4471 PID: SPN: 5971 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit Heater - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the diesel exhaust fluid dosing unit heater circuit. | None on performance.
Diesel Exhaust Fluid Dosing Unit Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit heater is used to defrost and/or prevent freezing of the diesel exhaust fluid dosing unit.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel exhaust fluid dosing unit heater is commanded OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit heater circuit is shorted to battery or open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to voltage source in the wiring harness
  • An open circuit in the harness
  • Malfunctioning diesel exhaust fluid dosing unit heater control valve.
Refer to Troubleshooting Fault Code 4471.

Last Modified: 15-Dec-2016


Aftertreatment 2 Diesel Exhaust Fluid Dosing Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 4474

Aftertreatment 2 Diesel Exhaust Fluid Dosing Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4474 PID: SPN: 4390 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Dosing Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the diesel exhaust fluid dosing temperature sensor circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) dosing temperature sensor is a variable resistor sensor and is used to measure the temperature of the DEF in the dosing valve. The engine control module (ECM) supplies 5 volts to the aftertreatment DEF dosing temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the aftertreatment DEF dosing temperature.

Component Location

The aftertreatment diesel exhaust fluid dosing temperature sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing temperature sensor signal circuit was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit shorted to voltage source.
  • A malfunctioning aftertreatment diesel exhaust fluid dosing temperature sensor
Refer to Troubleshooting Fault Code 4474.

Last Modified: 03-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Dosing Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4475

Aftertreatment 2 Diesel Exhaust Fluid Dosing Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4475 PID: SPN: 4390 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Dosing Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the diesel exhaust fluid dosing temperature sensor circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) dosing temperature sensor is a variable resistor sensor and is used to measure the temperature of the DEF in the dosing valve. The engine control module (ECM) supplies 5 volts to the aftertreatment DEF dosing temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the aftertreatment DEF dosing temperature.

Component Location

The aftertreatment diesel exhaust fluid dosing temperature sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing temperature sensor signal circuit was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground.
  • A malfunctioning aftertreatment diesel exhaust fluid dosing temperature sensor
Refer to Troubleshooting Fault Code 4475.

Last Modified: 03-May-2016


Turbocharger 3 Speed - Data Erratic, Intermittent, or Incorrect

FAULT CODE 4481

Turbocharger 3 Speed - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4481 PID: SPN: 1170 FMI: 2/2 LAMP: Maintenance SRT: | Turbocharger 3 Speed Sensor - Data Erratic, Intermittent, or Incorrect. An invalid turbocharger speed signal has been detected. | Possible reduced engine performance.
Turbocharger Speed Sensor Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The Engine Control Module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor 3 is located on the left bank rear turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic only runs when engine speed is greater than 1250 RPM and the ratio of boost pressure to barometric pressure is at or above 1.2.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger speed was less than 3000 RPM for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • The ECM will estimate the turbocharger speed.

Conditions for Clearing the Fault Code

  • To validate the repair, it will be necessary to operate the engine under load in order to get the intake manifold pressure high enough for the diagnostic to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Damaged turbocharger speed sensor
  • Damaged engine harness
Refer to Troubleshooting Fault Code 4481.

Last Modified: 03-Feb-2016


Turbocharger 4 Speed - Data Erratic, Intermittent, or Incorrect

FAULT CODE 4482

Turbocharger 4 Speed - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4482 PID: SPN: 1171 FMI: 2/2 LAMP: Maintenance SRT: | Turbocharger 4 Speed - Data Erratic, Intermittent, or Incorrect. An invalid turbocharger speed signal has been detected. | Possible reduced engine performance.
Turbocharger Speed Sensor Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The Engine Control Module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor 4 is located on the right bank rear turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic only runs when engine speed is greater than 1250 RPM and the ratio of boost pressure to barometric pressure is at or above 1.2.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger speed was less than 3000 RPM for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • The ECM will estimate the turbocharger speed.

Conditions for Clearing the Fault Code

  • To validate the repair, it will be necessary to operate the engine under load in order to get the intake manifold pressure high enough for the diagnostic to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Damaged turbocharger speed sensor
  • Damaged engine harness
Refer to Troubleshooting Fault Code 4482.

Last Modified: 03-Feb-2016


Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 449

Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 449 PID: P157 SPN: 157 FMI: 0/0 LAMP: Red SRT: | Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operational Range - Most Severe Level. The ECM has detected that fuel pressure in the fuel rail is higher than the normal operating fuel system pressure. | Engine may be shut down.
Fuel Rail Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) monitors engine operating conditions, including the reading of fuel rail pressure, and changes the flow command to either increase (OPEN the fuel metering valve) or decrease (CLOSE the fuel metering valve) the fuel supply to the high-pressure pump.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel metering valve, fuel rail pressure sensor, and fuel pressure relief valve are mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the measured fuel rail pressure was above the opening pressure of the fuel pressure relief valve.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Fault Code 449 is activated when the measured fuel rail pressure exceeds the normal operating fuel system pressure. It is used to indicate a fuel pressure relief valve which fails to open.

Possible causes of this fault code include:

  • A malfunctioning fuel pressure relief valve
  • A malfunctioning fuel rail pressure sensor
Refer to Troubleshooting Fault Code 449.

Last Modified: 11-Dec-2015


Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 451

Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 451 PID: P157 SPN: 157 FMI: 3/3 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the fuel rail pressure sensor circuit. | Possible reduced engine performance.
Fuel Rail Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor using a dedicated sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a fuel pressure signal to the ECM on the fuel rail pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the fuel rail. The ECM will detect a high signal voltage at high rail pressure conditions. The ECM will detect a low signal voltage during low rail pressure conditions.

Component Location

The fuel rail pressure sensor is located on the front of the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the fuel rail pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Causes for this fault code include:

  • Voltage (+5-VDC or higher shorted to the signal wire)
  • Open circuit on the signal wire
  • Open circuit on the 5 Volt supply wire
  • Open circuit on the return wire
  • A malfunctioning fuel rail pressure sensor
Refer to Troubleshooting Fault Code 451.

Last Modified: 11-Dec-2015


Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 452

Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 452 PID: P157 SPN: 157 FMI: 4/4 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the fuel rail pressure sensor circuit. | Possible reduced engine performance.
Fuel Rail Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor using a dedicated sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a fuel pressure signal to the ECM on the fuel rail pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the fuel rail. The ECM will detect a high signal voltage at high rail pressure conditions. The ECM will detect a low signal voltage during low rail pressure conditions.

Component Location

The fuel rail pressure sensor is located in the high pressure fuel rail near the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the fuel rail pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Causes for this fault code include:

  • Supply or signal wire is shorted to ground.
  • A malfunctioning fuel rail pressure sensor
Refer to Troubleshooting Fault Code 452.

Last Modified: 10-Aug-2015


Aftertreatment 2 Intake NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

FAULT CODE 4528

Aftertreatment 2 Intake NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4528 PID: SPN: 3257 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment 2 Intake NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect. The aftertreatment intake NOx sensor indicates that the power supply to the sensor is incorrect. | None on performance.
Aftertreatment 2 Intake NOx Sensor Circuit

Circuit Description

The aftertreatment 2 intake NOx sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment 2 intake NOx sensor performs internal diagnostics and reports malfunctions back to ECM 2 using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment 2 intake NOx sensor is used to measure the NOx emissions at the engine exhaust outlet connection.

Component Location

The aftertreatment 2 intake NOx sensor is mounted on the right bank engine exhaust outlet connection.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment selective catalytic reduction intake temperature has reached a calibrated threshold.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the power supply to the intake NOx sensor was above or below a calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open NOx sensor power supply circuit.
  • Supply wire shorted to ground.
  • Incorrect system voltage set-up in INSITE™ electronic service tool
  • Internal malfunction of the intake NOx sensor
  • The NOx sensor part number is incorrect.
Refer to Troubleshooting Fault Code 4528.

Last Modified: 03-May-2016


Aftertreatment 2 Outlet NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

FAULT CODE 4529

Aftertreatment 2 Outlet NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4529 PID: SPN: 3267 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment 2 Outlet NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect. The aftertreatment outlet NOx sensor indicates that the power supply to the sensor is incorrect. | None on performance.
Aftertreatment 2 Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment 2 outlet NOx sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment 2 outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to ECM 2 using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment 2 outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment 2 outlet NOx sensor is mounted in the aftertreatment 2 SCR outlet.

Conditions for Running the Diagnostics

The engine is running.

The aftertreatment SCR outlet temperature must be above 180C (356F) before the aftertreatment outlet NOx sensor can run its internal diagnostics.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the power supply to the outlet NOx sensor was above or below a calibrated threshold.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The aftertreatment SCR outlet temperature must be above 150Â° C [302Â° F] for 60 seconds before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Open NOx sensor power supply circuit.

Supply wire shorted to ground.

Internal malfunction of the outlet NOx sensor

The NOx sensor part number is incorrect.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 4529.

Last Modified: 17-Jan-2018


Aftertreatment 2 Outlet NOx Sensor Heater - Abnormal Rate of Change

FAULT CODE 4531

Aftertreatment 2 Outlet NOx Sensor Heater - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4531 PID: SPN: 5045 FMI: 10/10 LAMP: Amber SRT: | Aftertreatment 2 Outlet NOx Sensor Heater - Abnormal Rate of Change. The aftertreatment outlet NOx sensor heater is unable to maintain its normal operating temperature. | None on performance.
Aftertreatment 2 Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment 2 outlet NOx sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment 2 outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to ECM 2 using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment 2 outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment 2 outlet NOx sensor is mounted in the aftertreatment 2 SCR outlet.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature has been above 200°C [392° F] for a calibratible period of time while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the NOx sensor heater was unable to maintain its normal operating temperature.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The aftertreatment SCR outlet temperature must be above 200° C [392° F] for 60 seconds before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The NOx sensor heater is internal to the NOx sensor assembly, and can not be serviced separately.

Possible causes of this fault code include:

  • A damaged aftertreatment outlet NOx sensor
  • Intermittent power connection to the aftertreatment outlet NOx sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 4531.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Abnormal Update Rate

FAULT CODE 4572

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4572 PID: SPN: 3031 FMI: 9/9 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Temperature - Abnormal Update Rate. The ECM lost communication with the aftertreatment diesel exhaust fluid tank temperature sensor. | None on performance.
Aftertreatment Diesel Exhaust Fluid Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment DEF sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment DEF sensor monitors the tank level, temperature and quality of the DEF fluid.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of communication with the aftertreatment diesel exhaust fluid tank temperature sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Incorrect terminating resistance of the SAE J1939 datalink circuit
  • Intermittent communication from the aftertreatment diesel exhaust fluid tank temperature sensor
  • An open or short circuit in the SAE J1939 datalink circuit
Refer to Troubleshooting Fault Code 4572.

Last Modified: 03-May-2016


Aftertreatment 1 SCR Catalyst System - Special Instructions

FAULT CODE 4585

Aftertreatment 1 SCR Catalyst System - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4585 PID: SPN: 4792 FMI: 14/14 LAMP: Red SRT: | Aftertreatment 1 SCR Catalyst System - Special Instructions. An incorrect SCR system has been installed. | None on performance.
Engine Control Module (ECM)

Circuit Description

Because engines and aftertreatment components are manufactured in different locations, they are shipped to OEMs for final equipment assembly. The process involves both hardware and software elements in detecting the correct match of aftertreatment system to engine model during initial engine to machine integration.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic runs at key ON in the first 50 hours of engine run time.

Conditions for Setting the Fault Codes

The engine control module detects that the engine has been connected to an incorrect SCR.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The purpose of this fault code is to indicate when the wrong aftertreatment system has been mated to the engine during the equipment assembly process. This fault code uses the aftertreatment SCR temperature sensor modules to verify the correct aftertreatment.

If this fault code is active, the aftertreatment system and aftertreatment SCR temperature sensor module part numbers should be verified.

During active Red Lamp conditions the OEM may inhibit starting. See OEM Service Manual.

Refer to Troubleshooting Fault Code 4585.

Last Modified: 12-Oct-2016


Aftertreatment 1 Diesel Exhaust Fluid Dosing 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 4587

Aftertreatment 1 Diesel Exhaust Fluid Dosing 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4587 PID: SPN: 4337 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Dosing Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. Diesel exhaust fluid dosing temperature has exceeded the warning limit. | None on performance.
Diesel Exhaust Fluid Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the ECM. When the engine control module (ECM) commands DEF dosing, the ECM sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid dosing temperature sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing temperature was above the warning level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing valve temperature sensor.
Refer to Troubleshooting Fault Code 4587.

Last Modified: 03-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Dosing 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 4588

Aftertreatment 2 Diesel Exhaust Fluid Dosing 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4588 PID: SPN: 4390 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Dosing 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. Diesel exhaust fluid dosing temperature has exceeded the warning limit. | None on performance.
Diesel Exhaust Fluid Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the ECM. When the engine control module (ECM) commands DEF dosing, the ECM sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid dosing temperature sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing temperature was above the warning level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing valve temperature sensor.
Refer to Troubleshooting Fault Code 4588.

Last Modified: 03-May-2016


Engine Fuel Delivery Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 4615

Engine Fuel Delivery Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4615 PID: SPN: 94 FMI: 0/0 LAMP: Amber SRT: | Engine Fuel Delivery Pressure - Data Valid But Above Normal Operating Range - Most Severe Level. High fuel delivery pressure has been detected. | Possible reduced engine performance.
Fuel Delivery Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel delivery pressure sensor using a sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel delivery pressure sensor provides a fuel delivery pressure signal to the ECM on the fuel delivery pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the low pressure fuel delivery system. The ECM will detect a high signal voltage at high delivery pressure conditions. The ECM will detect a low signal voltage during low delivery pressure conditions.

Component Location

The fuel delivery pressure sensor is located on the outlet of the stage 2 fuel filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel delivery pressure was higher than normal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Fuel supply line pinched or damaged
  • High fuel drain line restriction
  • Malfunctioning fuel delivery pressure sensor.
  • Malfunctioning engine fuel supply pump.
Refer to Troubleshooting Fault Code 4615.

Last Modified: 03-May-2016


Injector Solenoid Driver Cylinder 7 - Out of Calibration

FAULT CODE 4643

Injector Solenoid Driver Cylinder 7 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4643 PID: SPN: 657 FMI: 13/13 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 7 - Out of Calibration. Invalid injector barcode information has been entered. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 7 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode needs to be entered into the ECM with INSITE™ electronic service tool. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector barcode values can be read directly off the top of each injector without the need of removing any additional parts. Use INSITE™ electronic service tool to enter the barcode values into the ECM for this fault code to go inactive.

Refer to Troubleshooting Fault Code 4643.

Last Modified: 10-Aug-2015


Injector Solenoid Driver Cylinder 8 - Out of Calibration

FAULT CODE 4644

Injector Solenoid Driver Cylinder 8 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4644 PID: SPN: 658 FMI: 13/13 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 8 - Out of Calibration. Invalid injector barcode information has been entered. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 8 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode needs to be entered into the ECM with INSITE™ electronic service tool. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector barcode values can be read directly off the top of each injector without the need of removing any additional parts. Use INSITE™ electronic service tool to enter the barcode values into the ECM for this fault code to go inactive.

Refer to Troubleshooting Fault Code 4644.

Last Modified: 10-Aug-2015


Injector Solenoid Driver Cylinder 9 - Out of Calibration

FAULT CODE 4645

Injector Solenoid Driver Cylinder 9 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4645 PID: SPN: 659 FMI: 13/13 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 9 - Out of Calibration. Invalid injector barcode information has been entered. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 9 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode needs to be entered into the ECM with INSITE™ electronic service tool. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector barcode values can be read directly off the top of each injector without the need of removing any additional parts. Use INSITE™ electronic service tool to enter the barcode values into the ECM for this fault code to go inactive.

Refer to Troubleshooting Fault Code 4645.

Last Modified: 10-Aug-2015


Injector Solenoid Driver Cylinder 10 - Out of Calibration

FAULT CODE 4646

Injector Solenoid Driver Cylinder 10 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4646 PID: SPN: 660 FMI: 13/13 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 10 - Out of Calibration. Invalid injector barcode information has been entered. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 10 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode needs to be entered into the ECM with INSITE™ electronic service tool. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector barcode values can be read directly off the top of each injector without the need of removing any additional parts. Use INSITE™ electronic service tool to enter the barcode values into the ECM for this fault code to go inactive.

Refer to Troubleshooting Fault Code 4646.

Last Modified: 10-Aug-2015


Injector Solenoid Driver Cylinder 11 - Out of Calibration

FAULT CODE 4647

Injector Solenoid Driver Cylinder 11 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4647 PID: SPN: 661 FMI: 13/13 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 11 - Out of Calibration. Invalid injector barcode information has been entered. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 11 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode needs to be entered into the ECM with INSITE™ electronic service tool. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector barcode values can be read directly off the top of each injector without the need of removing any additional parts. Use INSITE™ electronic service tool to enter the barcode values into the ECM for this fault code to go inactive.

Refer to Troubleshooting Fault Code 4647.

Last Modified: 10-Aug-2015


Injector Solenoid Driver Cylinder 12 - Out of Calibration

FAULT CODE 4648

Injector Solenoid Driver Cylinder 12 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4648 PID: SPN: 662 FMI: 13/13 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 12 - Out of Calibration. Invalid injector barcode information has been entered. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 12 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode needs to be entered into the ECM with INSITE™ electronic service tool. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector barcode values can be read directly off the top of each injector without the need of removing any additional parts. Use INSITE™ electronic service tool to enter the barcode values into the ECM for this fault code to go inactive.

Refer to Troubleshooting Fault Code 4648.

Last Modified: 10-Aug-2015


Injector Solenoid Driver Cylinder 13 - Out of Calibration

FAULT CODE 4649

Injector Solenoid Driver Cylinder 13 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4649 PID: SPN: 663 FMI: 13/13 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 13 - Out of Calibration. Invalid injector barcode information has been entered. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 13 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode needs to be entered into the ECM with INSITE™ electronic service tool. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector barcode values can be read directly off the top of each injector without the need of removing any additional parts. Use INSITE™ electronic service tool to enter the barcode values into the ECM for this fault code to go inactive.

Refer to Troubleshooting Fault Code 4649.

Last Modified: 10-Aug-2015


Injector Solenoid Driver Cylinder 14 - Out of Calibration

FAULT CODE 4651

Injector Solenoid Driver Cylinder 14 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4651 PID: SPN: 664 FMI: 13/13 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 14 - Out of Calibration. Invalid injector barcode information has been entered. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 14 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode needs to be entered into the ECM with INSITE™ electronic service tool. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector barcode values can be read directly off the top of each injector without the need of removing any additional parts. Use INSITE™ electronic service tool to enter the barcode values into the ECM for this fault code to go inactive.

Refer to Troubleshooting Fault Code 4651.

Last Modified: 10-Aug-2015


Injector Solenoid Driver Cylinder 15 - Out of Calibration

FAULT CODE 4652

Injector Solenoid Driver Cylinder 15 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4652 PID: SPN: 665 FMI: 13/13 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 15 - Out of Calibration. Invalid injector barcode information has been entered. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 15 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode needs to be entered into the ECM with INSITE™ electronic service tool. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector barcode values can be read directly off the top of each injector without the need of removing any additional parts. Use INSITE™ electronic service tool to enter the barcode values into the ECM for this fault code to go inactive.

Refer to Troubleshooting Fault Code 4652.

Last Modified: 10-Aug-2015


Injector Solenoid Driver Cylinder 16 - Out of Calibration

FAULT CODE 4653

Injector Solenoid Driver Cylinder 16 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4653 PID: SPN: 666 FMI: 13/13 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 16 - Out of Calibration. Invalid injector barcode information has been entered. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 16 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode needs to be entered into the ECM with INSITE™ electronic service tool. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector barcode values can be read directly off the top of each injector without the need of removing any additional parts. Use INSITE™ electronic service tool to enter the barcode values into the ECM for this fault code to go inactive.

Refer to Troubleshooting Fault Code 4653.

Last Modified: 10-Aug-2015


Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Abnormal Update Rate

FAULT CODE 4677

Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4677 PID: SPN: 1761 FMI: 9/9 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Abnormal Update Rate. The ECM lost communication with the aftertreatment diesel exhaust fluid tank level sensor. | None on performance.
Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid tank level sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment diesel exhaust fluid tank level sensor is used to measure the level of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of communication with the aftertreatment diesel exhaust fluid tank level sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Incorrect terminating resistance of the SAE J1939 datalink circuit
  • Intermittent communication from the aftertreatment diesel exhaust fluid tank level sensor.
  • An open or short circuit in the SAE J1939 datalink circuit
Refer to Troubleshooting Fault Code 4677.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Current Below Normal or Open Circuit

FAULT CODE 4679

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4679 PID: SPN: 1761 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Current Below Normal or Open Circuit. Low current or an open circuit has been detected at the diesel exhaust fluid tank level sensor. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid tank level sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment diesel exhaust fluid tank level sensor is used to measure the level of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment DEF tank level sensor detected an internal open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank level sensor
Refer to Troubleshooting Fault Code 4679.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor Circuit - Current Below Normal or Open Circuit

FAULT CODE 4682

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4682 PID: SPN: 3031 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor Circuit - Current Below Normal or Open Circuit. Low current or an open circuit has been detected at the diesel exhaust fluid tank temperature sensor. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid tank temperature sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment diesel exhaust fluid tank temperature sensor is used to measure the temperature of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment DEF tank temperature sensor detected an internal open circuit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor
Refer to Troubleshooting Fault Code 4682.

Last Modified: 10-May-2016


Water in Fuel Indicator 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 4688

Water in Fuel Indicator 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4688 PID: SPN: 6301 FMI: 3/3 LAMP: Amber SRT: | Water in Fuel Indicator 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the water in fuel circuit. | None on performance.
Water-in-Fuel Sensor Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

Each stage 1 fuel filter has a water in fuel sensor. The wiring harness is connected to two of the water in fuel sensors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the water in fuel sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

The ECM will illuminate the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

Open RETURN or SIGNAL circuit in the harness, connectors, or sensor

Signal wire shorted to sensor supply or ECM supply voltage.

Malfunctioning water in fuel sensor.

Refer to Troubleshooting Fault Code 4688.

Last Modified: 27-Sep-2017


Water in Fuel Indicator 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4689

Water in Fuel Indicator 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4689 PID: SPN: 6301 FMI: 4/4 LAMP: Amber SRT: | Water in Fuel Indicator 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the water in fuel circuit. | None on performance.
Water-in-Fuel Sensor Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

Each stage 1 fuel filter has a water in fuel sensor. The wiring harness is connected to two of the water in fuel sensors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the water in fuel sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

The ECM will illuminate the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

Signal circuit shorted to ground in the harness, sensor or connectors

Malfunctioning water in fuel sensor.

Refer to Troubleshooting Fault Code 4689.

Last Modified: 27-Sep-2017


Crankcase Pressure 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 4696

Crankcase Pressure 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4696 PID: SPN: 6302 FMI: 3/3 LAMP: Amber SRT: | Crankcase Pressure 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the crankcase pressure 2 circuit. | None on performance.
Crankcase Pressure 2 Sensor Circuit

Circuit Description

The crankcase pressure 2 sensor is used to determine the condition of the breather filter element. The engine control module (ECM) supplies the crankcase pressure 2 sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the breather tube prior to the breather filter element.

Component Location

The crankcase pressure 2 sensor is located in the breather tube before the breather filter element.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure 2 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the crankcase pressure 2 reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal wire shorted to sensor supply or ECM supply voltage.
  • Malfunctioning crankcase pressure 2 sensor.
Refer to Troubleshooting Fault Code 4696.

Last Modified: 16-Dec-2015


Crankcase Pressure 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4697

Crankcase Pressure 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4697 PID: SPN: 6302 FMI: 4/4 LAMP: Amber SRT: | Crankcase Pressure 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the crankcase pressure 2 circuit. | None on performance.
Crankcase Pressure 2 Sensor Circuit

Circuit Description

The crankcase pressure 2 sensor is used to determine the condition of the breather filter element. The engine control module (ECM) supplies the crankcase pressure 2 sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the breather tube prior to the breather filter element.

Component Location

The crankcase pressure 2 sensor is located in the breather tube before the breather filter element.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure 2 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the crankcase pressure 2 reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
  • Malfunctioning crankcase pressure 2 sensor.
Refer to Troubleshooting Fault Code 4697.

Last Modified: 16-Dec-2015


Crankcase Pressure 2 - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 4698

Crankcase Pressure 2 - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4698 PID: SPN: 6302 FMI: 0/15 LAMP: Maintenance SRT: | Crankcase Pressure 2 - Data Valid But Above Normal Operating Range - Least Severe Level. High crankcase pressure detected. | None on performance.
Crankcase Pressure 2 Sensor Circuit

Circuit Description

The crankcase pressure 2 sensor is used to determine the condition of the breather filter element. The engine control module (ECM) supplies the crankcase pressure 2 sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the breather tube prior to the breather filter element.

Component Location

The crankcase pressure 2 sensor is located in the breather tube before the breather filter element.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the crankcase pressure in the breather tube was greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Internal engine damage.
  • Crankcase breather filter needs to be replaced
  • Malfunctioning crankcase pressure 2 sensor.
  • Frozen, plugged, or restricted crankcase breather tube.
Refer to Troubleshooting Fault Code 4698.

Last Modified: 16-Dec-2015


Crankcase Pressure 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 4699

Crankcase Pressure 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4699 PID: SPN: 6302 FMI: 0/16 LAMP: Amber SRT: | Crankcase Pressure 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level. High crankcase pressure detected. | None on performance.
Crankcase Pressure 2 Sensor Circuit

Circuit Description

The crankcase pressure 2 sensor is used to determine the condition of the breather filter element. The engine control module (ECM) supplies the crankcase pressure 2 sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the breather tube prior to the breather filter element.

Component Location

The crankcase pressure 2 sensor is located in the breather tube before the breather filter element.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the crankcase pressure in the breather tube was greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Internal engine damage.
  • Crankcase breather filter needs to be replaced
  • Malfunctioning crankcase pressure 2 sensor.
  • Frozen, plugged, or restricted crankcase breather tube.
Refer to Troubleshooting Fault Code 4699.

Last Modified: 16-Dec-2015


Crankcase Pressure 2 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 4711

Crankcase Pressure 2 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4711 PID: SPN: 6302 FMI: 1/17 LAMP: Maintenance SRT: | Crankcase Pressure 2 - Data Valid But Below Normal Operating Range - Least Severe Level. Low crankcase pressure detected. | None on performance.
Crankcase Pressure 2 Sensor Circuit

Circuit Description

The crankcase pressure 2 sensor is used to determine the condition of the breather filter element. The engine control module (ECM) supplies the crankcase pressure 2 sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the breather tube prior to the breather filter element.

Component Location

The crankcase pressure 2 sensor is located in the breather tube before the breather filter element.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected pressure in the breather tube was less than expected.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Damaged or missing breather tube or hose.
  • Missing or damaged breather filter element
  • Restricted crankcase breather housing.
  • Malfunctioning crankcase pressure 2 sensor.
Refer to Troubleshooting Fault Code 4711.

Last Modified: 10-Aug-2015


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Out of Calibration

FAULT CODE 4731

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4731 PID: SPN: 3031 FMI: 13/13 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Out of Calibration. The received datalink message was not valid. | None on performance.
Aftertreatment Diesel Exhaust Fluid Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment DEF sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment DEF sensor monitors the tank level, temperature and quality of the DEF fluid.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the SAE J1939 datalink message received from the aftertreatment diesel exhaust fluid tank temperature sensor was NOT valid.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor
Refer to Troubleshooting Fault Code 4731.

Last Modified: 10-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Out of Calibration

FAULT CODE 4732

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4732 PID: SPN: 1761 FMI: 13/13 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level Sensor - Out of Calibration. The received datalink message was not valid. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid tank level sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment diesel exhaust fluid tank level sensor is used to measure the level of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the SAE J1939 datalink message received from the aftertreatment diesel exhaust fluid tank level sensor was NOT valid.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank level sensor
Refer to Troubleshooting Fault Code 4732.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 4736

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4736 PID: SPN: 3031 FMI: 6/6 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor Circuit - Current Above Normal or Grounded Circuit. High current or a grounded circuit has been detected at the diesel exhaust fluid tank temperature sensor. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid tank temperature sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment diesel exhaust fluid tank temperature sensor is used to measure the temperature of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment DEF tank temperature sensor detected excess current in an internal circuit.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE lamp immediately after the diagnostic runs and fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 4736.

Last Modified: 10-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Root Cause Not Known

FAULT CODE 4737

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4737 PID: SPN: 3031 FMI: 11/11 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Root Cause Not Known. An unknown error has been detected with the aftertreatment diesel exhaust fluid tank temperature sensor. | None on performance.
Aftertreatment Diesel Exhaust Fluid Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid tank temperature sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment diesel exhaust fluid tank temperature sensor is used to measure the temperature of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid tank level sensor reported an unknown error.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The ECM logs the fault code immediately when the diagnostic runs and fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor
Refer to Troubleshooting Fault Code 4737.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 4738

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4738 PID: SPN: 1761 FMI: 6/6 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Current Above Normal or Grounded Circuit. High current or a grounded circuit has been detected at the diesel exhaust fluid tank level sensor. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid tank level sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment diesel exhaust fluid tank level sensor is used to measure the level of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment DEF tank level sensor detected excess current in an internal circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank level sensor
Refer to Troubleshooting Fault Code 4738.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Root Cause Not Known

FAULT CODE 4739

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4739 PID: SPN: 1761 FMI: 11/11 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Root Cause Not Known. An unknown error has been detected with the aftertreatment diesel exhaust fluid tank level sensor. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid tank level sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment diesel exhaust fluid tank level sensor is used to measure the level of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid tank level sensor reported an unknown error.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank level sensor
Refer to Troubleshooting Fault Code 4739.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 - Root Cause Not Known

FAULT CODE 4745

Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4745 PID: SPN: 3515 FMI: 11/11 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 - Root Cause Not Known | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Level/Temperature Circuit

Circuit Description

The DEF quality sensor is a smart device and communicates with the engine electronic control module (ECM) via the J1939 data link. The DEF quality sensor receives power and ground directly from the battery. The sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM via the J1939 data link. The DEF quality sensor is used to measure the concentration of the DEF in the tank.

Component Location

The DEF quality sensor is typically mounted in the DEF tank or in-line with the DEF dosing unit supply line. Reference the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code is triggered when the DEF quality sensor detects that the internal temperature has exceeded 125°C.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • This fault code can not be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor
  • A malfunctioning aftertreatment diesel exhaust fluid tank level sensor
Refer to Troubleshooting Fault Code 4745.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Property - Root Cause Not Known

FAULT CODE 4768

Aftertreatment 1 Diesel Exhaust Fluid Property - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4768 PID: SPN: 3521 FMI: 11/11 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Property - Root Cause Not Known. Unknown fluid inside DEF tank. | None on performance.
Aftertreatment Diesel Exhaust Fluid Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The DEF quality sensor has detected that the DEF concentration has fallen below a critical threshold – The DEF quality sensor has detected the presence of an unknown fluid in the DEF tank.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

To Validate the repair, perform a key cycle, start the engine and let it idle for 10 minutes.

  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • Degraded, diluted, or incorrect diesel exhaust fluid
Refer to Troubleshooting Fault Code 4768.

Last Modified: 05-May-2017


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Abnormal Rate of Change

FAULT CODE 4769

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4769 PID: SPN: 1761 FMI: 10/10 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Abnormal Rate of Change. A valid diesel exhaust fluid tank level reading has NOT been received. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Level/Tank Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid tank level sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment diesel exhaust fluid tank level sensor is used to measure the level of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank level sensor reading was invalid for an extended period of time.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 hour.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid tank level sensor

Refer to Troubleshooting Fault Code 4769.

Last Modified: 17-May-2018


Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 4842

Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4842 PID: SPN: 3364 FMI: 0/15 LAMP: None SRT: | Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Above Normal Operating Range - Least Severe Level. The aftertreatment diesel exhaust fluid quality sensor has detected an in-range high condition. | None on performance.
Aftertreatment Diesel Fluid Quality Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The DEF quality sensor has detected that the DEF concentration has risen above a critical threshold.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault include:

  • Diesel exhaust fluid quality is not within specification
Refer to Troubleshooting Fault Code 4842.

Last Modified: 10-May-2016


Aftertreatment SCR Operator Inducement Active - Condition Exists

FAULT CODE 4863

Aftertreatment SCR Operator Inducement Active - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4863 PID: SPN: 5245 FMI: 11/31 LAMP: Amber SRT: | Aftertreatment SCR Operator Inducement Active - Condition Exists-Critical SCR related fault codes have been active for an extended period of time and require immediate attention. | None on performance.
Engine Control Module (ECM)

Circuit Description

The ECM continuously monitors the engine's fault code status to determine if any fault codes critical to successful engine operation are active.

Component Location

The Engine Control Modules (ECMs) are mounted at the front of the engine above the gear housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code is triggered when faults related to SCR have logged.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once all other active fault codes have been addressed. Refer to the appropriate fault code troubleshooting tree.

Shop Talk

This fault code is for information only, and indicates that an engine speed derate has been implemented in order to make sure that the critical SCR related fault codes that are presently active in the ECM are addressed as quickly as possible.

Refer to Troubleshooting Fault Code 4863.

Last Modified: 03-May-2016


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 488

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 488 PID: P105 SPN: 105 FMI: 0/16 LAMP: Amber SRT: | Intake Manifold 1 Temperature - Data Valid But Above Normal Operational Range - Moderately Severe Level. Intake manifold air temperature signal indicates intake manifold air temperature is above engine protection warning limit. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the low temperature air transfer connection on the left bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature was greater than a calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque may be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The intake manifold air temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Restricted air flow through the radiator.
  • Malfunctioning high temperature aftercooler element.
  • Malfunctioning low temperature aftercooler element.
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 488.

Last Modified: 11-Dec-2015


Engine Oil Priming State - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 4883

Engine Oil Priming State - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4883 PID: SPN: 3551 FMI: 7/7 LAMP: Amber SRT: | Engine Oil Priming State - Mechanical System Not Responding or Out of Adjustment. The engine could not reach pre-lube pressure. | Engine may not start.
Pre-lube Oil Pressure Switch
Engine Oil Pressure Sensor Circuit

Circuit Description

The pre-lube oil pressure switch is used by the engine control module (ECM) to determine when a successful pre-lube cycle has been achieved. The pre-lube pressure switch is normally closed when the engine and pre-lube pump are not running. The switch will open when pre-lube pressure is reached.

The engine can be configured to use either the pre-lube oil pressure switch, the engine oil pressure sensor, or both to make pre-lube cycle success determination. If both the switch and sensor are enabled in the engine calibration for pre-lube use, then both have to indicate pre-lube pressure is at the appropriate level before the cycle is considered successful.

Component Location

The pre-lube oil pressure switch is located on the fuel pump drive lubricating oil filter head.

Conditions for Running the Diagnostics

This diagnostic runs when the pre-lube cycle is active.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected pre-lube pressure was not reached before the pre-lube pump timer expired.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The pre-lube system can be configured to lock out pre-lube cycles once a calibratable maximum number of failed attempts has been reached. Once pre-lube has been locked out, the pre-lube pump override found INSITE™ electronic service tool must be used to command a pre-lube cycle. Once a successful pre-lube cycle is achieved the failed attempt counter will decrement by one and normal pre-lube operation will resume.
  • The engine can be configured to alllow or disable starting if the last pre-lube cycle failed.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a keycycle and start the engine. If the maximum number of failed pre-lube attempts has been reached, use INSITE™ electronic service tool to override the pre-lube pump using the Pre-lube Control feature found in the special feature section.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Pre-lube oil pressure switch signal shorted to ground or return.
  • Malfunctioning pre-lube oil pressure switch.
  • Malfunctioning engine oil pressure sensor.
  • Malfunctioning pre-lube pump relay.
  • Malfunctioning pre-lube pump.
  • Internal or external oil leak.

During active Fault Code conditions the OEM may inhibit starting. See OEM Service Manual.

Refer to Troubleshooting Fault Code 4883.

Last Modified: 12-Oct-2016


Engine Oil Priming Pump Control - Special Instructions

FAULT CODE 4884

Engine Oil Priming Pump Control - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4884 PID: SPN: 3589 FMI: 14/14 LAMP: Amber SRT: | Engine Oil Priming Pump Control - Special Instructions. A stuck ON pre-lube pump has been detected. | None on performance.
Pre-lube Oil Pressure Switch
Engine Oil Pressure Sensor Circuit

Circuit Description

The pre-lube oil pressure switch is used by the engine control module (ECM) to determine when a successful pre-lube cycle has been achieved. The pre-lube pressure switch is normally closed when the engine and pre-lube pump are not running. The switch will open when pre-lube pressure is reached.

The engine can be configured to use either the pre-lube oil pressure switch, the engine oil pressure sensor, or both to make pre-lube cycle success determination. If both the switch and sensor are enabled in the engine calibration for pre-lube use, then both have to indicate pre-lube pressure is at the appropriate level before the cycle is considered successful.

Component Location

The pre-lube oil pressure switch is located on the fuel pump drive lubricating oil filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected pre-lube pressure when the engine was not running and the pre-lube pump relay was commanded OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If inactive counts of this fault code are present, an intermittent malfunctioning pre-lube relay is likely the cause. Use INSITE™ electronic service tool to override the pre-lube pump using the Pre-lube Control feature found in the special feature section, and check if actuating the relay causes it to stick closed.

Possible causes of this fault code include:

  • Open pre-lube oil pressure switch signal or return.
  • Malfunctioning pre-lube oil pressure switch.
  • Malfunctioning pre-lube pump relay.
Refer to Troubleshooting Fault Code 4884.

Last Modified: 10-Aug-2015


Engine Fuel Supply Pump - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 4885

Engine Fuel Supply Pump - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4885 PID: SPN: 6323 FMI: 7/7 LAMP: Red SRT: | The engine fuel supply pump has seized. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Engine Fuel Supply Pump Circuit

Circuit Description

The engine fuel supply pump is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The engine fuel supply pump maintains appropriate supply fuel pressure, performs internal and system diagnostics and reports malfunctions back to the ECM. The ECM supplies 24-VDC to the supply pump control unit. The OEM provides supply voltage to the engine fuel supply pump motor. The fuel delivery pressure signal is wired in parallel between the ECM and engine fuel supply pump.

Component Location

The engine fuel supply pump is located on the left side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine fuel supply pump has detected motor current continuously above 70 amps while fuel delivery pressure zero.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Engine fuel supply pump motor locked.

Refer to Troubleshooting Fault Code 4885 .

Last Modified: 21-Aug-2019


Engine Fuel Supply Pump Supply Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 4886

Engine Fuel Supply Pump Supply Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4886 PID: SPN: 6323 FMI: 1/18 LAMP: Amber SRT: | Low voltage detected at the engine fuel supply pump motor circuit. | Possible reduced engine performance.
Engine Fuel Supply Pump Circuit

Circuit Description

The engine fuel supply pump is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The engine fuel supply pump maintains appropriate supply fuel pressure, performs internal and system diagnostics and reports malfunctions back to the ECM. The ECM supplies 24-VDC to the supply pump control unit. The OEM provides supply voltage to the engine fuel supply pump motor. The fuel delivery pressure signal is wired in parallel between the ECM and engine fuel supply pump.

Component Location

The engine fuel supply pump is located on the left side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine fuel supply pump has detected low supply voltage to the pump motor.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Low supply voltage or high resistance on the engine fuel supply pump motor circuit.

Refer to Troubleshooting Fault Code 4886 .

Last Modified: 21-Aug-2019


Engine Fuel Supply Pump Supply Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 4887

Engine Fuel Supply Pump Supply Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4887 PID: SPN: 6323 FMI: 1/1 LAMP: Red SRT: | Critically low or no voltage detected at the engine fuel supply pump motor circuit. | The engine will shut down or will not start.
Engine Fuel Supply Pump Circuit

Circuit Description

The engine fuel supply pump is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The engine fuel supply pump maintains appropriate supply fuel pressure, performs internal and system diagnostics and reports malfunctions back to the ECM. The ECM supplies 24-VDC to the supply pump control unit. The OEM provides supply voltage to the engine fuel supply pump motor. The fuel delivery pressure signal is wired in parallel between the ECM and engine fuel supply pump.

Component Location

The engine fuel supply pump is located on the left side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine fuel supply pump has detected very low or no supply voltage at the pump motor.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Low supply voltage or high resistance on the engine fuel supply pump motor circuit.

Short circuit to ground or tripped circuit breaker/blown fuse on the engine fuel supply pump motor circuit.

Refer to Troubleshooting Fault Code 4887 .

Last Modified: 21-Aug-2019


Engine Fuel Supply Pump Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 4888

Engine Fuel Supply Pump Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4888 PID: SPN: 6698 FMI: 0/16 LAMP: Amber SRT: | High internal temperature detected in the engine fuel supply pump. | Possible reduced engine performance.
Engine Fuel Supply Pump Circuit

Circuit Description

The engine fuel supply pump is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The engine fuel supply pump maintains appropriate supply fuel pressure, performs internal and system diagnostics and reports malfunctions back to the ECM. The ECM supplies 24-VDC to the supply pump control unit. The OEM provides supply voltage to the engine fuel supply pump motor. The fuel delivery pressure signal is wired in parallel between the ECM and engine fuel supply pump.

Component Location

The engine fuel supply pump is located on the left side of the engine.

The fuel supply pump temperature sensor is internal to the fuel supply pump and cannot be replaced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine fuel supply pump has detected internal temperature will pass the critical limit within 60 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Stage 2 fuel filter restriction excessive.

Abnormally hot supply fuel.

Malfunctioning engine fuel supply pump.

Refer to Troubleshooting Fault Code 4888 .

Last Modified: 21-Aug-2019


Engine Fuel Supply Pump Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 4889

Engine Fuel Supply Pump Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4889 PID: SPN: 6698 FMI: 0/0 LAMP: Amber SRT: | High internal temperature detected in the engine fuel supply pump. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Engine Fuel Supply Pump Circuit

Circuit Description

The engine fuel supply pump is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The engine fuel supply pump maintains appropriate supply fuel pressure, performs internal and system diagnostics and reports malfunctions back to the ECM. The ECM supplies 24-VDC to the supply pump control unit. The OEM provides supply voltage to the engine fuel supply pump motor. The fuel delivery pressure signal is wired in parallel between the ECM and engine fuel supply pump.

Component Location

The engine fuel supply pump is located on the left side of the engine.

The fuel supply pump temperature sensor is internal to the fuel supply pump and cannot be replaced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine fuel supply pump has detected internal temperature above the critical limit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Stage 2 fuel filter restriction excessive.

Abnormally hot supply fuel.

Malfunctioning engine fuel supply pump.

Refer to Troubleshooting Fault Code 4889 .

Last Modified: 21-Aug-2019


Engine Fuel Supply Pump - Root Cause Not Known

FAULT CODE 4891

Engine Fuel Supply Pump - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4891 PID: SPN: 6323 FMI: 11/11 LAMP: Amber SRT: | The engine fuel supply pump did not receive the initialization message from the ECM. | Possible reduced engine performance.
Engine Fuel Supply Pump Circuit

Circuit Description

The engine fuel supply pump is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The engine fuel supply pump maintains appropriate supply fuel pressure, performs internal and system diagnostics and reports malfunctions back to the ECM. The ECM supplies 24-VDC to the supply pump control unit. The OEM provides supply voltage to the engine fuel supply pump motor. The fuel delivery pressure signal is wired in parallel between the ECM and engine fuel supply pump.

Component Location

The engine fuel supply pump is located on the left side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs when the engine fuel supply pump is initially powered ON.

Conditions for Setting the Fault Codes

The engine fuel supply pump did not receive the initialization message from the ECM in a calibrated amount of time.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Intermittent power supply to the engine fuel supply pump.

Refer to Troubleshooting Fault Code 4891 .

Last Modified: 21-Aug-2019


Engine Fuel Supply Pump - Abnormal Update Rate

FAULT CODE 4892

Engine Fuel Supply Pump - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4892 PID: SPN: 6323 FMI: 9/9 LAMP: Amber SRT: | No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the engine fuel supply pump. | Possible reduced engine performance.
Engine Fuel Supply Pump Circuit

Circuit Description

The engine fuel supply pump is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The engine fuel supply pump maintains appropriate supply fuel pressure, performs internal and system diagnostics and reports malfunctions back to the ECM. The ECM supplies 24-VDC to the supply pump control unit. The OEM provides supply voltage to the engine fuel supply pump motor. The fuel delivery pressure signal is wired in parallel between the ECM and engine fuel supply pump.

Component Location

The engine fuel supply pump is located on the left side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) lost communication with the engine fuel supply pump.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

The engine fuel supply pump is not receiving power from the ECM.

Malfunctioning SAE J1939 data link 3 circuit.

Malfunctioning engine fuel supply pump.

Refer to Troubleshooting Fault Code 4892 .

Last Modified: 21-Aug-2019


Engine Fuel Filter (suction side) Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 4893

Engine Fuel Filter (suction side) Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4893 PID: SPN: 1382 FMI: 0/16 LAMP: Amber SRT: | The engine fuel supply pump has detected high fuel intake restriction. | Possible reduced engine performance.
Engine Fuel Supply Pump Circuit

Circuit Description

The engine fuel supply pump is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The engine fuel supply pump maintains appropriate supply fuel pressure, performs internal and system diagnostics and reports malfunctions back to the ECM. The ECM supplies 24-VDC to the supply pump control unit. The OEM provides supply voltage to the engine fuel supply pump motor. The fuel delivery pressure signal is wired in parallel between the ECM and engine fuel supply pump.

Component Location

The engine fuel supply pump is located on the left side of the engine.

The fuel supply pump intake pressure sensor is located on the inlet of the engine fuel supply pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine fuel supply pump detected that fuel intake restriction was above the calibrated threshold.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine at 75% of rated load or above for 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Stage 1 fuel filter restriction excessive.

Low fuel inlet pressure.

Malfunctioning fuel supply pump intake pressure sensor.

Refer to Troubleshooting Fault Code 4893 .

Last Modified: 21-Aug-2019


Engine Fuel Supply Pump - Out of Calibration

FAULT CODE 4894

Engine Fuel Supply Pump - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4894 PID: SPN: 6233 FMI: 13/13 LAMP: Amber SRT: | The engine fuel supply pump firmware version does not match the expected value. | Possible reduced engine performance.
Engine Fuel Supply Pump Circuit

Circuit Description

The engine fuel supply pump is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The engine fuel supply pump maintains appropriate supply fuel pressure, performs internal and system diagnostics and reports malfunctions back to the ECM. The ECM supplies 24-VDC to the supply pump control unit. The OEM provides supply voltage to the engine fuel supply pump motor. The fuel delivery pressure signal is wired in parallel between the ECM and engine fuel supply pump.

Component Location

The engine fuel supply pump is located on the left side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine fuel supply pump firmware version does not match the expected value in the ECM calibration.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Incorrect firmware version installed in the engine fuel supply pump.

Refer to Troubleshooting Fault Code 4894 .

Last Modified: 21-Aug-2019


Engine Diesel Fuel Metering Valve - Bad Intelligent Device or Component

FAULT CODE 4927

Engine Diesel Fuel Metering Valve - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4927 PID: SPN: 7026 FMI: 12/12 LAMP: Amber SRT: | Engine Diesel Fuel Metering Valve - Bad Intelligent Device or Component. An internal error has been detected in the fuel metering valve. | Possible reduced engine performance.
Fuel Metering Valve Circuit

Circuit Description

The fuel metering valve is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The ECM supplies 24-VDC to the fuel metering valve. The fuel metering valve controls fuel flow into the high pressure fuel pump by changing valve position based on ECM command. The primary position command is sent by the ECM over the J1939 data link. A PWM signal is used as the backup position command. The fuel metering valve performs internal diagnostics and reports malfunctions back to the ECM.

Component Location

The fuel metering valve is mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The fuel metering valve has reported an internal error.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning fuel metering valve.
Refer to Troubleshooting Fault Code 4927.

Last Modified: 03-May-2016


Engine Diesel Fuel Metering Valve Power Supply - Data Erratic, Intermittent, or Incorrect

FAULT CODE 4928

Engine Diesel Fuel Metering Valve Power Supply - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4928 PID: SPN: 7027 FMI: 2/2 LAMP: Amber SRT: | Engine Diesel Fuel Metering Valve Power Supply - Data Erratic, Intermittent, or Incorrect. Low voltage detected at the fuel metering valve. | Possible reduced engine performance.
Fuel Metering Valve Circuit

Circuit Description

The fuel metering valve is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The ECM supplies 24-VDC to the fuel metering valve. The fuel metering valve controls fuel flow into the high pressure fuel pump by changing valve position based on ECM command. The primary position command is sent by the ECM over the J1939 data link. A PWM signal is used as the backup position command. The fuel metering valve performs internal diagnostics and reports malfunctions back to the ECM.

Component Location

The fuel metering valve is mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The fuel metering valve has detected low supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • High resistance on the supply circuit.
  • A malfunctioning fuel metering valve.
Refer to Troubleshooting Fault Code 4928.

Last Modified: 03-May-2016


Engine Diesel Fuel Metering Valve Power Supply - Voltage Above Normal or Shorted to High Source

FAULT CODE 4929

Engine Diesel Fuel Metering Valve Power Supply - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4929 PID: SPN: 7027 FMI: 3/3 LAMP: Amber SRT: | Engine Diesel Fuel Metering Valve Power Supply - Voltage Above Normal or Shorted to High Source. High voltage detected on the engine fuel supply pump/fuel metering valve supply circuit. | Possible reduced engine performance.
Engine Fuel Supply Pump/Fuel Metering Valve Supply Circuit

Circuit Description

The engine control module (ECM) supplies 24-VDC to the engine fuel supply pump and fuel metering valve.

Component Location

The engine fuel supply pump is located on the left side of the engine.

The fuel metering valve is mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected an open or short circuit to voltage source on the engine fuel supply pump/fuel metering valve supply circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • An open or short circuit to ECM supply voltage in the engine harness.
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 4929.

Last Modified: 03-May-2016


Engine Diesel Fuel Metering Valve Power Supply - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4931

Engine Diesel Fuel Metering Valve Power Supply - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4931 PID: SPN: 7027 FMI: 4/4 LAMP: Amber SRT: | Engine Diesel Fuel Metering Valve Power Supply - Voltage Below Normal or Shorted to Low Source. Low voltage detected on the engine fuel supply pump/fuel metering valve supply circuit. | Possible reduced engine performance.
Engine Fuel Supply Pump and Fuel Metering Valve Supply Circuit

Circuit Description

The engine control module (ECM) supplies 24-VDC to the engine fuel supply pump and fuel metering valve.

Component Location

The engine fuel supply pump is located on the left side of the engine.

The fuel metering valve is mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected low voltage on the engine fuel supply pump/fuel metering valve supply circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to ground in the engine harness
  • A malfunctioning fuel metering valve.
  • Malfunctioning engine fuel supply pump.
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 4931.

Last Modified: 03-May-2016


Engine Diesel Fuel Metering Valve Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 4932

Engine Diesel Fuel Metering Valve Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4932 PID: SPN: 7028 FMI: 0/15 LAMP: None SRT: | Engine Diesel Fuel Metering Valve Temperature - Data Valid But Above Normal Operating Range - Least Severe Level. High temperature detected in the fuel metering valve. | None on performance.
Fuel Metering Valve Circuit

Circuit Description

The fuel metering valve is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The ECM supplies 24-VDC to the fuel metering valve. The fuel metering valve controls fuel flow into the high pressure fuel pump by changing valve position based on ECM command. The primary position command is sent by the ECM over the J1939 data link. A PWM signal is used as the backup position command. The fuel metering valve performs internal diagnostics and reports malfunctions back to the ECM.

Component Location

The fuel metering valve is mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The fuel metering valve has detected high internal temperature.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Abnormally hot supply fuel.
  • A malfunctioning fuel metering valve.
Refer to Troubleshooting Fault Code 4932.

Last Modified: 03-May-2016


Engine Diesel Fuel Metering Valve Position - Received Network Data in Error

FAULT CODE 4933

Engine Diesel Fuel Metering Valve Position - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4933 PID: SPN: 7029 FMI: 2/19 LAMP: None SRT: | Engine Diesel Fuel Metering Valve Position - Received Network Data in Error. A sticking fuel metering valve has been detected. | Possible reduced engine performance.
Fuel Metering Valve Circuit

Circuit Description

The fuel metering valve is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The ECM supplies 24-VDC to the fuel metering valve. The fuel metering valve controls fuel flow into the high pressure fuel pump by changing valve position based on ECM command. The primary position command is sent by the ECM over the J1939 data link. A PWM signal is used as the backup position command. The fuel metering valve performs internal diagnostics and reports malfunctions back to the ECM.

Component Location

The fuel metering valve is mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The fuel metering valve has detected the valve position does not match the commanded position.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning fuel metering valve.
Refer to Troubleshooting Fault Code 4933.

Last Modified: 03-May-2016


Engine Diesel Fuel Metering Valve - Voltage Above Normal or Shorted to High Source

FAULT CODE 4934

Engine Diesel Fuel Metering Valve - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4934 PID: SPN: 7026 FMI: 3/3 LAMP: Amber SRT: | Engine Diesel Fuel Metering Valve - Voltage Above Normal or Shorted to High Source. High voltage detected on the control signal circuit. | Possible reduced engine performance.
Fuel Metering Valve Circuit

Circuit Description

The fuel metering valve is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The ECM supplies 24-VDC to the fuel metering valve. The fuel metering valve controls fuel flow into the high pressure fuel pump by changing valve position based on ECM command. The primary position command is sent by the ECM over the J1939 data link. A PWM signal is used as the backup position command. The fuel metering valve performs internal diagnostics and reports malfunctions back to the ECM.

Component Location

The fuel metering valve is mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected high voltage on the control signal circuit while the PWM signal was OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Control signal wire shorted to voltage source or open.
  • Control return wire shorted to voltage source or open.
  • A malfunctioning fuel metering valve.
Refer to Troubleshooting Fault Code 4934.

Last Modified: 03-May-2016


Engine Diesel Fuel Metering Valve - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4935

Engine Diesel Fuel Metering Valve - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4935 PID: SPN: 7026 FMI: 4/4 LAMP: Amber SRT: | Engine Diesel Fuel Metering Valve - Voltage Below Normal or Shorted to Low Source. Low voltage detected on the control signal circuit. | Possible reduced engine performance.
Fuel Metering Valve Circuit

Circuit Description

The fuel metering valve is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The ECM supplies 24-VDC to the fuel metering valve. The fuel metering valve controls fuel flow into the high pressure fuel pump by changing valve position based on ECM command. The primary position command is sent by the ECM over the J1939 data link. A PWM signal is used as the backup position command. The fuel metering valve performs internal diagnostics and reports malfunctions back to the ECM.

Component Location

The fuel metering valve is mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected low voltage on the control signal circuit while the PWM signal was ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Control signal wire shorted to ground.
  • A malfunctioning fuel metering valve.
Refer to Troubleshooting Fault Code 4935.

Last Modified: 03-May-2016


Engine Diesel Fuel Metering Valve - Root Cause Not Known

FAULT CODE 4936

Engine Diesel Fuel Metering Valve - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4936 PID: SPN: 7026 FMI: 11/11 LAMP: Amber SRT: | Engine Diesel Fuel Metering Valve - Root Cause Not Known. The fuel metering valve firmware version does not match the expected value. | Possible reduced engine performance.
Fuel Metering Valve Circuit

Circuit Description

The fuel metering valve is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The ECM supplies 24-VDC to the fuel metering valve. The fuel metering valve controls fuel flow into the high pressure fuel pump by changing valve position based on ECM command. The primary position command is sent by the ECM over the J1939 data link. A PWM signal is used as the backup position command. The fuel metering valve performs internal diagnostics and reports malfunctions back to the ECM.

Component Location

The fuel metering valve is mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the fuel metering valve firmware version does not match the expected value in the ECM calibration.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Incorrect firmware version installed in the fuel metering valve.
Refer to Troubleshooting Fault Code 4936.

Last Modified: 03-May-2016


Engine Diesel Fuel Metering Valve - Out of Calibration

FAULT CODE 4937

Engine Diesel Fuel Metering Valve - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4937 PID: SPN: 7026 FMI: 13/13 LAMP: Amber SRT: | Engine Diesel Fuel Metering Valve - Out of Calibration. The fuel metering valve calibration version does not match the expected value. | Possible reduced engine performance.
Fuel Metering Valve Circuit

Circuit Description

The fuel metering valve is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The ECM supplies 24-VDC to the fuel metering valve. The fuel metering valve controls fuel flow into the high pressure fuel pump by changing valve position based on ECM command. The primary position command is sent by the ECM over the J1939 data link. A PWM signal is used as the backup position command. The fuel metering valve performs internal diagnostics and reports malfunctions back to the ECM.

Component Location

The fuel metering valve is mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the fuel metering valve calibration version does not match the expected value in the ECM calibration.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Incorrect calibration installed in the fuel metering valve.
Refer to Troubleshooting Fault Code 4937.

Last Modified: 03-May-2016


Engine Starter Control - Voltage Above Normal or Shorted to High Source

FAULT CODE 4941

Engine Starter Control - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4941 PID: SPN: 520744 FMI: 3/3 LAMP: Amber SRT: | Engine Starter Control - Voltage Above Normal or Shorted to High Source. The ECM has diagnose the voltage for the engine starter control circuit is above the normal operating range. | Engine may not start.
Starter Control Circuit

Circuit Description

The starting system consits of a starter motor, starter solenoid and starter motor relay. The engine control module (ECM) receives the start command from the start switch. The starter solenoid engages the starter motor when the ECM actuates the starter motor relay.

Component Location

The starter solenoid is mounted on the starter motor. The starter motor relay and diagnostic relay are located in the engine harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

ECM has diagnose the voltage for the engine starter control circuit is above the normal operating range.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes for this fault code include:

  • A short circuit to ECM supply voltage in the engine harness.
Refer to Troubleshooting Fault Code 4941.

Last Modified: 03-May-2016


Engine Starter Control - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4942

Engine Starter Control - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4942 PID: SPN: 520744 FMI: 4/4 LAMP: Amber SRT: | Engine Starter Control - Voltage Below Normal or Shorted to Low Source. The ECM has diagnose the voltage for the engine starter control circuit is below the normal operating range. | Engine may not start.
Starter Control Circuit

Circuit Description

The starting system consits of a starter motor, starter solenoid and starter motor relay. The engine control module (ECM) receives the start command from the start switch. The starter solenoid engages the starter motor when the ECM actuates the starter motor relay.

Component Location

The starter solenoid is mounted on the starter motor. The starter motor relay and diagnostic relay are located in the engine harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM has diagnose the voltage for the engine starter control circuit is below the normal operating range.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes for this fault code include:

  • A short circuit to ground in the engine harness
  • An open circuit in the engine harness
Refer to Troubleshooting Fault Code 4942.

Last Modified: 03-May-2016


Engine Failed to Crank - Condition Exists

FAULT CODE 4943

Engine Failed to Crank - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4943 PID: SPN: 520745 FMI: 11/31 LAMP: Amber SRT: | Engine Failed to Crank - Condition Exists. The engine control module (ECM) has diagnosed that the engine has failed to crank after three attempts. | Engine may not start.
Starter Motor Circuit

Circuit Description

The starter circuit contains magnetic switches to control the starter solenoid and electric starting motor circuits in response to a lower current signal from the engine control module (ECM) or original equipment manufacturer (OEM) electrical system. There are two switches in the system: one with a 24V coil for the starter solenoids, and one with a 64V coil for the starting motors.

Component Location

The starting motors are mounted on the left bank of the flywheel housing. The starter magnetic switch is remotely mounted by the OEM.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is attempting to start.

Conditions for Setting the Fault Codes

The engine control module (ECM) has diagnosed that the engine has failed to crank after three attempts.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes for this fault code include:

Refer to Troubleshooting Fault Code 4943.

Last Modified: 01-Jun-2016


Engine Failed to Start - Condition Exists

FAULT CODE 4944

Engine Failed to Start - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4944 PID: SPN: 520746 FMI: 11/31 LAMP: Amber SRT: | Engine Failed to Start - Condition Exists. The Engine Control Module (ECM) has diagnosed that the engine has failed to start. | Engine may not start.
Starter Motor Circuit

Circuit Description

The starter circuit contains magnetic switches to control the starter solenoid and electric starting motor circuits in response to a lower current signal from the engine control module (ECM) or original equipment manufacturer (OEM) electrical system. There are two switches in the system: one with a 24V coil for the starter solenoids, and one with a 64V coil for the starting motors.

Component Location

The starting motors are mounted on the left bank of the flywheel housing. The starter magnetic switch is remotely mounted by the OEM.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is attempting to start.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the engine has failed to start.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes for this fault code include:

Refer to Troubleshooting Fault Code 4944.

Last Modified: 01-Jun-2016


Engine Uncommanded Cranking - Condition Exists

FAULT CODE 4945

Engine Uncommanded Cranking - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4945 PID: SPN: 520747 FMI: 11/31 LAMP: Amber SRT: | Engine Uncommanded Cranking - Condition Exists. The ECM has diagnose the engine had a cranking event that was not commanded by the engine starter control circuit. | None on performance.
Starter Control Circuit

Circuit Description

The starting system consits of a starter motor, starter solenoid and starter motor relay. The engine control module (ECM) receives the start command from the start switch. The starter solenoid engages the starter motor when the ECM actuates the starter motor relay.

Component Location

The starter solenoid is mounted on the starter motor. The starter motor relay and diagnostic relay are located in the engine harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM has diagnose the engine had a cranking event that was not commanded by the engine starter control circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes for this fault code include:

  • Short to voltage source in the engine harness
Refer to Troubleshooting Fault Code 4945.

Last Modified: 03-May-2016


Engine Crank Without Prelube - Condition Exists

FAULT CODE 4946

Engine Crank Without Prelube - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4946 PID: SPN: 4209 FMI: 11/31 LAMP: None SRT: | Engine Crank Without Prelube - Condition Exists. The emergency start switch was used to bypass the pre-lube cycle. | None on performance.
Engine Control Module (ECM)

Circuit Description

The emergency start override switch is used to allow the operator to bypass the pre-lube cycle and start the engine immediately in an emergency.

Component Location

The emergency start override switch is mounted by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the emergency start switch was used to bypass the pre-lube cycle and start the engine.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code is for information only. It is intended to track engine starts where the pre-lube cycle was bypassed.

Refer to Troubleshooting Fault Code 4946.

Last Modified: 01-Sep-2015


Aftertreatment 1 Diesel Exhaust Fluid Doser Heating Mode Request - Condition Exists

FAULT CODE 4947

Aftertreatment 1 Diesel Exhaust Fluid Doser Heating Mode Request - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4947 PID: SPN: 4353 FMI: 11/31 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Doser Heating Mode Request - Condition Exists. The engine control module (ECM) has detected conditions that could overheat the dosing valve. | None on performance.
Engine Control Module (ECM)

Circuit Description

The ECM continuously monitors the engine's fault code status and other sensor inputs to determine if action needs to be taken to prevent aftertreatment diesel exhaust fluid dosing valve damage.

Component Location

The aftertreatment diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected conditions that could overheat the aftertreatment diesel exhaust fluid dosing valve.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once the DEF system is able to sucessfully prime or maintain operating pressure.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This fault code is information ONLY, make sure that critical dosing related fault codes that are presently active in the ECM are addressed as quickly as possible.

Refer to Troubleshooting Fault Code 4947.

Last Modified: 10-May-2016


Engine Diesel Fuel Metering Valve - Data Erratic, Intermittent, or Incorrect

FAULT CODE 4958

Engine Diesel Fuel Metering Valve - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4958 PID: SPN: 7026 FMI: 2/2 LAMP: Amber SRT: | Engine Diesel Fuel Metering Valve - Data Erratic, Intermittent or Incorrect. A malfunctioning control signal circuit has been detected. | Possible reduced engine performance.
Fuel Metering Valve Circuit

Circuit Description

The fuel metering valve is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The ECM supplies 24-VDC to the fuel metering valve. The fuel metering valve controls fuel flow into the high pressure fuel pump by changing valve position based on ECM command. The primary position command is sent by the ECM over the J1939 data link. A PWM signal is used as the backup position command. The fuel metering valve performs internal diagnostics and reports malfunctions back to the ECM.

Component Location

The fuel metering valve is mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The fuel metering valve has detected an out of range PWM control signal from the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Control signal wire shorted to voltage source or open.
  • Control signal wire shorted to ground.
  • Open control return wire.
  • A malfunctioning fuel metering valve.
  • A malfunctioning fuel metering valve resistor.

The replacement fuel metering valve resistor part number can be found on the Electrical Connector Database.

Refer to Troubleshooting Fault Code 4958.

Last Modified: 11-May-2017


Engine Diesel Fuel Metering Valve - Condition Exists

FAULT CODE 4959

Engine Diesel Fuel Metering Valve - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4959 PID: SPN: 7026 FMI: 11/31 LAMP: None SRT: | Engine Diesel Fuel Metering Valve - Condition Exists. A mismatch between the two control signals has been detected. | Possible reduced engine performance.
Fuel Metering Valve Circuit

Circuit Description

The fuel metering valve is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The ECM supplies 24-VDC to the fuel metering valve. The fuel metering valve controls fuel flow into the high pressure fuel pump by changing valve position based on ECM command. The primary position command is sent by the ECM over the J1939 data link. A PWM signal is used as the backup position command. The fuel metering valve performs internal diagnostics and reports malfunctions back to the ECM.

Component Location

The fuel metering valve is mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The fuel metering valve has detected a mismatch between the two control signals sent by the ECM.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Tampering with the control signal circuit.
  • A malfunctioning fuel metering valve.
Refer to Troubleshooting Fault Code 4959.

Last Modified: 03-May-2016


Engine Diesel Fuel Metering Valve - Abnormal Update Rate

FAULT CODE 4961

Engine Diesel Fuel Metering Valve - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4961 PID: SPN: 7026 FMI: 9/9 LAMP: None SRT: | Engine Diesel Fuel Metering Valve - Abnormal Update Rate. No communications or an invalid data transfer rate detected on the J1939 data link between the ECM and the fuel metering valve. | Possible reduced engine performance.
Fuel Metering Valve Circuit

Circuit Description

The fuel metering valve is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The ECM supplies 24-VDC to the fuel metering valve. The fuel metering valve controls fuel flow into the high pressure fuel pump by changing valve position based on ECM command. The primary position command is sent by the ECM over the J1939 data link. A PWM signal is used as the backup position command. The fuel metering valve performs internal diagnostics and reports malfunctions back to the ECM.

Component Location

The fuel metering valve is mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine control module (ECM) lost communication with the fuel metering valve.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The fuel metering valve will switch to the PWM control signal from the ECM as a backup for commanded positon.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include.

  • The fuel metering valve is not receiving power from the ECM.
  • Malfunctioning SAE J1939 data link 3 circuit.
  • A malfunctioning fuel metering valve.
Refer to Troubleshooting Fault Code 4961.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Line Heater Relay - Condition Exists

FAULT CODE 5115

Aftertreatment 1 Diesel Exhaust Fluid Line Heater Relay - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5115 PID: SPN: 5491 FMI: 11/31 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Line Heater Relay - Condition Exists. Low voltage detected on the aftertreatment diesel exhaust fluid line heater power supply circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Line Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater relay is used to provide power to the aftertreatment diesel exhaust fluid line heaters.

Component Location

The aftertreatment diesel exhaust fluid line heater relays are located in the aftertreatment junction box.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel exhaust fluid line heater relay is commanded ON.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the aftertreatment diesel exhaust fluid line heater relay supply voltage output was low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid line heating will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning line heater relay
  • Short to ground in the wiring harness
  • Supply wire open or shorted before the relay.
  • Malfunctioning aftertreatment junction box time delay relay.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5115.

Last Modified: 03-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Line Heater Relay - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 5116

Aftertreatment 2 Diesel Exhaust Fluid Line Heater Relay - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5116 PID: SPN: 5973 FMI: 7/7 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Line Heater Relay - Mechanical System Not Responding or Out of Adjustment. A short circuit to supply voltage has been detected on the diesel exhaust fluid line heater power supply circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Line Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater relay is used to provide power to the aftertreatment diesel exhaust fluid line heaters.

Component Location

The aftertreatment diesel exhaust fluid line heater relays are located in the aftertreatment junction box.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel exhaust fluid line heater relay is commanded OFF.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected voltage on the line heater relay diagnostic circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid line heating will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If the line heater relay diagnostic wire is open or its path to ground through the line heater is open, the ECM will see the 5-VDC pull-up voltage when the line heater relay is commanded off and this fault will become active.

Possible causes of this fault code include:

  • Switch side of line heater relay stuck closed
  • Open circuit in the wiring harness
  • Open circuit in one or more DEF line heaters.
  • Short to ECM power supply voltage in the wire between the relay and line heater elements.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5116.

Last Modified: 05-May-2017


Aftertreatment 2 Diesel Exhaust Fluid Line Heater Relay - Condition Exists

FAULT CODE 5117

Aftertreatment 2 Diesel Exhaust Fluid Line Heater Relay - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5117 PID: SPN: 5973 FMI: 11/31 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Line Heater Relay - Condition Exists. Low voltage detected on the aftertreatment diesel exhaust fluid line heater power supply circuit. | None on performance.
Diesel Exhaust Fluid Line Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater relay is used to provide power to the aftertreatment diesel exhaust fluid line heaters.

Component Location

The aftertreatment diesel exhaust fluid line heater relay location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel exhaust fluid line heater relay is commanded ON.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the aftertreatment diesel exhaust fluid line heater relay supply voltage output was low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid line heating will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning line heater relay
  • Short to ground in the wiring harness
  • Supply wire open or shorted before the relay.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5117.

Last Modified: 03-May-2016


Sensor Supply 6 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 515

Sensor Supply 6 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 515 PID: S232 SPN: 3514 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 6 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected on the +5 volt sensor supply circuit to the fuel rail pressure sensor. | Possible reduced engine performance.
Sensor Supply 6 Circuit

Circuit Description

The sensor supply 6 circuit of the engine control module (ECM) is a dedicated (+) 5-VDC supply for the fuel rail pressure sensor.

Component Location

Sensor Supply 6 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 6 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

High voltage on the +5 volt supply wire can be caused by a short to ECM supply voltage in the engine harness or connectors, or a damaged ECM.

Refer to Troubleshooting Fault Code 515.

Last Modified: 11-Dec-2015


Sensor Supply 6 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 516

Sensor Supply 6 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 516 PID: S232 SPN: 3514 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 6 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected on the +5 volt sensor supply circuit to the fuel rail pressure sensor. | Possible reduced engine performance.
Sensor Supply 6 Circuit

Circuit Description

The sensor supply 6 circuit of the engine control module (ECM) is a dedicated (+) 5-VDC supply for the fuel rail pressure sensor.

Component Location

Sensor Supply 6 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 6 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Low voltage on the 5 volt supply line can be caused by a short circuit to ground in the supply line, a short circuit between the supply line and a return line, a failed sensor, or a damaged ECM power supply.

Refer to Troubleshooting Fault Code 516.

Last Modified: 11-Dec-2015


Crankcase Pressure 2 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 5178

Crankcase Pressure 2 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5178 PID: SPN: 6302 FMI: 2/2 LAMP: Amber SRT: | Crankcase Pressure 2 – Data Erratic, Intermittent, or Incorrect. The crankcase pressure 2 reading is irrational. | None on performance.
Crankcase Pressure 2 Sensor Circuit

Circuit Description

The crankcase pressure 2 sensor is used to determine the condition of the breather filter element. The engine control module (ECM) supplies the crankcase pressure 2 sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the breather tube prior to the breather filter element.

Component Location

The crankcase pressure 2 sensor is located in the breather tube before the breather filter element.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the crankcase pressure 2 sensor reading did not match other pressure sensor readings at key ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning crankcase pressure 2 sensor.
  • High resistance in the engine harness.
Refer to Troubleshooting Fault Code 5178.

Last Modified: 05-May-2017


Aftertreatment 1 SCR Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 5247

Aftertreatment 1 SCR Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5247 PID: SPN: 4360 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment 1 SCR Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. High selective catalytic reduction (SCR) intake temperature has been detected. | Engine power derate.
SCR Temperature Sensor Module

Circuit Description

The aftertreatment 1 SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment 1 SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment 1 SCR temperature sensor module is used to measure the aftertreatment 1 SCR intake temperature and aftertreatment 1 SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment 1 SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment 1 SCR temperature module is mounted to the aftertreatment SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the temperature at the SCR catalyst intake was greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning turbocharger wastegate.
  • Contaminated diesel exhaust fluid
  • A malfunctioning aftertreatment SCR temperature sensor module
  • Leaking turbocharger oil seals
  • Leaks in the charge air system plumbing
Refer to Troubleshooting Fault Code 5247.

Last Modified: 03-May-2016


Aftertreatment 2 SCR Catalyst System - Special Instructions

FAULT CODE 5261

Aftertreatment 2 SCR Catalyst System - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5261 PID: SPN: 6801 FMI: 14/14 LAMP: Red SRT: | Aftertreatment 2 SCR Catalyst System - Special Instructions. The Incorrect SCR system has been Installed. | None on performance.
Engine Control Module (ECM)

Circuit Description

Because engines and aftertreatment components are manufactured in different locations, they are shipped to OEMs for final equipment assembly. The process involves both hardware and software elements in detecting the correct match of aftertreatment system to engine model during initial engine to machine integration.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic runs at key ON in the first 50 hours of engine run time.

Conditions for Setting the Fault Codes

The engine control module detects that the engine has been connected to an incorrect SCR.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The purpose of this fault code is to indicate when the wrong aftertreatment system has been mated to the engine during the equipment assembly process. This fault code uses the aftertreatment SCR temperature sensor modules to verify the correct aftertreatment.

If this fault code is active, the aftertreatment system and aftertreatment SCR temperature sensor module part numbers should be verified.

During active Red Lamp conditions the OEM may inhibit starting. See OEM Service Manual.

Refer to Troubleshooting Fault Code 5261.

Last Modified: 12-Oct-2016


Engine Turbocharger Wastegate Actuator 1 Position - Out of Calibration

FAULT CODE 5329

Engine Turbocharger Wastegate Actuator 1 Position - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5329 PID: SPN: 1188 FMI: 13/13 LAMP: Amber SRT: | Engine Turbocharger Wastegate Actuator 1 Position - Out of Calibration. The turbocharger wastegate has failed the automatic calibration procedure at initial key ON. | Possible reduced engine performance.
Turbocharger Wastegate Circuit

Circuit Description

The turbocharger wastegate is controlled by a brushless motor located on top of the wastegate valve. The turbocharger wastegate motor uses three different motor legs to move the valve through its range of motion. The ECM uses the turbocharger wastegate motor A, B, and C wires to command the turbocharger wastegate to the appropriate position in order to maintain appropriate intake manifold pressure and turbocharger speed. The turbocharger wastegate motor contains three position sensors that detect the location of the wastegate. These sensors report the position of the wastegate back to the ECM over the turbocharger wastegate position A, B, and C wires.

Component Location

Turbocharger wastegates are mounted on the outboard side of the exhaust outlet connections.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON and occasionally during engine operation.

Conditions for Setting the Fault Codes

The turbocharger wastegate failed the autozero span check.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning turbocharger wastegate.
Refer to Troubleshooting Fault Code 5329.

Last Modified: 03-Feb-2016


Engine Turbocharger Wastegate Actuator 1 Position - Condition Exists

FAULT CODE 5331

Engine Turbocharger Wastegate Actuator 1 Position - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5331 PID: SPN: 1188 FMI: 11/31 LAMP: None SRT: | Engine Turbocharger Wastegate Actuator 1 Position - Condition Exists. The turbocharger wastegate actuator has exceeded the duty cycle limit, indicating a stuck wastegate. | Possible reduced engine performance.
Turbocharger Wastegate Circuit

Circuit Description

The turbocharger wastegate is controlled by a brushless motor located on top of the wastegate valve. The turbocharger wastegate motor uses three different motor legs to move the valve through its range of motion. The ECM uses the turbocharger wastegate motor A, B, and C wires to command the turbocharger wastegate to the appropriate position in order to maintain appropriate intake manifold pressure and turbocharger speed. The turbocharger wastegate motor contains three position sensors that detect the location of the wastegate. These sensors report the position of the wastegate back to the ECM over the turbocharger wastegate position A, B, and C wires.

Component Location

Turbocharger wastegates are mounted on the outboard side of the exhaust outlet connections.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code is set when the duty cycle required to open the turbocharger wastegate is greater than 95 percent for 3 seconds. The fault code is triggered after two failed attempts. The fault code will be inactive at key ON. It will only become active if the turbocharger actuator is commanded open and the wastegate is unable to move to the commanded position.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Sticking turbocharger wastegate.
Refer to Troubleshooting Fault Code 5331.

Last Modified: 03-Feb-2016


Engine Turbocharger Wastegate Actuator 2 Position - Out of Calibration

FAULT CODE 5332

Engine Turbocharger Wastegate Actuator 2 Position - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5332 PID: SPN: 1189 FMI: 13/13 LAMP: Amber SRT: | Engine Turbocharger Wastegate Actuator 2 Position - Out of Calibration. The turbocharger wastegate has failed the automatic calibration procedure at initial key ON. | Possible reduced engine performance.
Turbocharger Wastegate Circuit

Circuit Description

The turbocharger wastegate is controlled by a brushless motor located on top of the wastegate valve. The turbocharger wastegate motor uses three different motor legs to move the valve through its range of motion. The ECM uses the turbocharger wastegate motor A, B, and C wires to command the turbocharger wastegate to the appropriate position in order to maintain appropriate intake manifold pressure and turbocharger speed. The turbocharger wastegate motor contains three position sensors that detect the location of the wastegate. These sensors report the position of the wastegate back to the ECM over the turbocharger wastegate position A, B, and C wires.

Component Location

Turbocharger wastegates are mounted on the outboard side of the exhaust outlet connections.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON and occasionally during engine operation.

Conditions for Setting the Fault Codes

The turbocharger wastegate failed the autozero span check.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning turbocharger wastegate.
Refer to Troubleshooting Fault Code 5332.

Last Modified: 03-Feb-2016


Engine Turbocharger Wastegate Actuator 2 Position - Condition Exists

FAULT CODE 5333

Engine Turbocharger Wastegate Actuator 2 Position - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5333 PID: SPN: 1189 FMI: 11/31 LAMP: None SRT: | Engine Turbocharger Wastegate Actuator 2 Position - Condition Exists. The turbocharger wastegate actuator has exceeded the duty cycle limit, indicating a stuck wastegate. | Possible reduced engine performance.
Turbocharger Wastegate Circuit

Circuit Description

The turbocharger wastegate is controlled by a brushless motor located on top of the wastegate valve. The turbocharger wastegate motor uses three different motor legs to move the valve through its range of motion. The ECM uses the turbocharger wastegate motor A, B, and C wires to command the turbocharger wastegate to the appropriate position in order to maintain appropriate intake manifold pressure and turbocharger speed. The turbocharger wastegate motor contains three position sensors that detect the location of the wastegate. These sensors report the position of the wastegate back to the ECM over the turbocharger wastegate position A, B, and C wires.

Component Location

Turbocharger wastegates are mounted on the outboard side of the exhaust outlet connections.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code is set when the duty cycle required to open the turbocharger wastegate is greater than 95 percent for 3 seconds. The fault code is triggered after two failed attempts. The fault code will be inactive at key ON. It will only become active if the turbocharger actuator is commanded open and the wastegate is unable to move to the commanded position.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Sticking turbocharger wastegate.
Refer to Troubleshooting Fault Code 5333.

Last Modified: 03-Feb-2016


Engine Turbocharger Wastegate Actuator 1 Position - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 545

Engine Turbocharger Wastegate Actuator 1 Position - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 545 PID: S32 SPN: 1188 FMI: 7/7 LAMP: Amber SRT: | Engine Turbocharger Wastegate Actuator 1 Position - Mechanical system not responding or out of adjustment. The turbocharger wastegate is unable to meet commanded position. | Possible reduced engine performance.
Turbocharger Wastegate Circuit

Circuit Description

The turbocharger wastegate is controlled by an electric motor located on the wastegate valve. The turbocharger wastegate motor uses three different motor legs to move the valve through its range of motion. The ECM uses the turbocharger wastegate motor A, B, and C wires to command the turbocharger wastegate to the appropriate position in order to maintain appropriate intake manifold pressure and turbocharger speed. The turbocharger wastegate motor contains three position sensors that detect the location of the wastegate. These sensors report the position of the wastegate back to the ECM over the turbocharger wastegate position A, B, and C wires.

Component Location

Turbocharger wastegates are mounted on the outboard side of the exhaust outlet connections.

The turbocharger wastegate position sensors are internal to the turbocharger wastegate assembly and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The turbocharger wastegate was unable to reach the commanded position for more than a calibrated amount of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque may be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Intermittent open or short in the wiring harness
  • Malfunctioning turbocharger wastegate
Refer to Troubleshooting Fault Code 545.

Last Modified: 11-Dec-2015


Fuel Delivery Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 546

Fuel Delivery Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 546 PID: P94 SPN: 94 FMI: 3/3 LAMP: Amber SRT: | Fuel Delivery Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the fuel delivery pressure sensor circuit. | None on performance.
Fuel Delivery Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel delivery pressure sensor using a sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel delivery pressure sensor provides a fuel delivery pressure signal to the ECM on the fuel delivery pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the low pressure fuel delivery system. The ECM will detect a high signal voltage at high delivery pressure conditions. The ECM will detect a low signal voltage during low delivery pressure conditions.

Component Location

The fuel delivery pressure sensor is located on the outlet of the stage 2 fuel filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel delivery pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the fuel delivery pressure reading is used.
  • If only the ECM loses the fuel delivery pressure signal then the engine fuel supply pump will continue to operate normally.
  • If only the engine fuel supply pump loses the fuel delivery pressure signal then the ECM will command the supply pump via the J1939 data link.
  • If the ECM and the engine fuel supply pump both lose the delivery pressure signal then the ECM will command the supply pump via the J1939 data link. This command is based on engine operating conditions and fuel demand.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This sensor shares supply and return wires in the engine harness with other sensors. An open or shorted supply or return can cause multiple fault codes to be active. Before troubleshooting this fault code, check for multiple fault codes.

If the engine fuel supply pump loses fuel delivery pressure signal, fluctuations in delivery pressure could affect rail pressure.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal wire shorted to sensor supply or ECM supply voltage.
Refer to Troubleshooting Fault Code 546.

Last Modified: 03-May-2016


Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 547

Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 547 PID: P94 SPN: 94 FMI: 4/4 LAMP: Amber SRT: | Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the fuel delivery pressure sensor circuit. | None on performance.
Fuel Delivery Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel delivery pressure sensor using a sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel delivery pressure sensor provides a fuel delivery pressure signal to the ECM on the fuel delivery pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the low pressure fuel delivery system. The ECM will detect a high signal voltage at high delivery pressure conditions. The ECM will detect a low signal voltage during low delivery pressure conditions.

Component Location

The fuel delivery pressure sensor is located on the outlet of the stage 2 fuel filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel delivery pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the fuel delivery pressure reading is used.
  • If only the ECM loses the fuel delivery pressure signal then the engine fuel supply pump will continue to operate normally.
  • If only the engine fuel supply pump loses the fuel delivery pressure signal then the ECM will command the supply pump via the J1939 data link.
  • If the ECM and the engine fuel supply pump both lose the delivery pressure signal then the ECM will command the supply pump via the J1939 data link. This command is based on engine operating conditions and fuel demand.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If the engine fuel supply pump loses fuel delivery pressure signal, fluctuations in delivery pressure could affect rail pressure.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor.
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 547.

Last Modified: 03-May-2016


Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 553

Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 553 PID: P157 SPN: 157 FMI: 0/16 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. The engine control module (ECM) has detected that fuel pressure is higher than the commanded pressure. | Possible reduced engine performance.
Fuel Rail Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) monitors engine operating conditions, including the reading of fuel rail pressure, and changes the flow command to either increase (OPEN the fuel metering valve) or decrease (CLOSE the fuel metering valve) the fuel supply to the high-pressure pump.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel metering valve, fuel rail pressure sensor, and fuel pressure relief valve are mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the measured fuel rail pressure was above the commanded fuel rail pressure by a calibrated limit.

Action Taken When the Fault Code is Active

The ECM will illuminate the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning fuel rail pressure sensor
  • A malfunctioning fuel metering valve.
  • Fuel leaking past the fuel metering valve.
  • High fuel drain line restriction
Refer to Troubleshooting Fault Code 553.

Last Modified: 11-Dec-2015


Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 555

Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 555 PID: P101 SPN: 101 FMI: 0/16 LAMP: Amber SRT: | Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. High crankcase pressure detected. | None on performance.
Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located in the oil fill hand hole cover on the left bank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure was greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Crankcase breather filter needs to be replaced
  • Malfunctioning crankcase pressure sensor.
  • Frozen, plugged, or restricted crankcase breather tube.
  • Seized crankcase breather variable impactor assembly.
  • Internal engine damage.
Refer to Troubleshooting Fault Code 555.

Last Modified: 11-Dec-2015


Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 556

Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 556 PID: P101 SPN: 101 FMI: 0/0 LAMP: Red SRT: | Crankcase Pressure - Data Valid but Above Normal Operational Range - Most Severe Level. High crankcase pressure detected. | Engine torque output will be reduced. Engine may be shut down.
Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located in the oil fill hand hole cover on the left bank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure was greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Internal engine damage.
  • Crankcase breather filter needs to be replaced
  • Malfunctioning crankcase pressure sensor.
  • Frozen, plugged, or restricted crankcase breather tube.
  • Seized crankcase breather variable impactor assembly.
Refer to Troubleshooting Fault Code 556.

Last Modified: 11-Dec-2015


Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 559

Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 559 PID: P157 SPN: 157 FMI: 1/18 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operational Range - Moderately Severe Level. The ECM has detected that fuel pressure is lower than commanded pressure. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Fuel Rail Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) monitors engine operating conditions, including the reading of fuel rail pressure, and changes the flow command to either increase (OPEN the fuel metering valve) or decrease (CLOSE the fuel metering valve) the fuel supply to the high-pressure pump.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel metering valve, fuel rail pressure sensor, and fuel pressure relief valve are mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the measured fuel rail pressure was below commanded fuel rail pressure by a calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • High fuel inlet restriction
  • Air in the fuel
  • Leaking fuel rail pressure relief valve
  • Malfunctioning high-pressure fuel pump
  • Leaking fuel injectors and or fuel injector connectors
  • Malfunctioning fuel delivery pressure sensor.
  • A malfunctioning fuel rail pressure sensor
Refer to Troubleshooting Fault Code 559.

Last Modified: 10-Aug-2015


Aftertreatment 2 Selective Catalytic Reduction Temperature Sensor Module - Abnormal Update Rate

FAULT CODE 5725

Aftertreatment 2 Selective Catalytic Reduction Temperature Sensor Module - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5725 PID: SPN: 7467 FMI: 9/9 LAMP: Amber SRT: | Aftertreatment 2 Selective Catalytic Reduction Temperature Sensor Module - Abnormal Update Rate. No communication on the J1939 data link between the ECM and the SCR temperature sensor module. | None on performance.
Aftertreatment SCR Temperature Sensor Module Circuit

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of communication with the aftertreatment SCR temperature sensor module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Incorrect terminating resistance of the SAE J1939 datalink circuit
  • Incorrect sensor for the application (12 VDC versus 24 VDC)
Refer to Troubleshooting Fault Code 5725.

Last Modified: 03-May-2016


Aftertreatment 2 Selective Catalytic Reduction Temperature Sensor Module - Bad Intelligent Device or Component

FAULT CODE 5726

Aftertreatment 2 Selective Catalytic Reduction Temperature Sensor Module - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5726 PID: SPN: 7467 FMI: 12/12 LAMP: Amber SRT: | Aftertreatment 2 Selective Catalytic Reduction Temperature Sensor Module - Bad Intelligent Device or Component. An internal error has been detected in the SCR temperature sensor module. | None on performance.
Aftertreatment SCR Temperature Sensor Module Circuit

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported an internal error.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment SCR temperature sensor module
Refer to Troubleshooting Fault Code 5726.

Last Modified: 03-May-2016


Aftertreatment 2 Selective Catalytic Reduction Temperature Sensor Module - Voltage Above Normal or Shorted to High Source

FAULT CODE 5727

Aftertreatment 2 Selective Catalytic Reduction Temperature Sensor Module - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5727 PID: SPN: 7467 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 2 Selective Catalytic Reduction Temperature Sensor Module - Voltage Above Normal or Shorted to High Source. High supply voltage detected at the SCR temperature sensor module. | None on performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported high battery supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Incorrect sensor for the application (12 VDC versus 24 VDC)
  • High power supply voltage.
Refer to Troubleshooting Fault Code 5727.

Last Modified: 03-May-2016


Aftertreatment 2 Selective Catalytic Reduction Temperature Sensor Module - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5728

Aftertreatment 2 Selective Catalytic Reduction Temperature Sensor Module - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5728 PID: SPN: 7467 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 2 Selective Catalytic Reduction Temperature Sensor Module - Voltage Below Normal or Shorted to Low Source. Low supply voltage detected at the SCR temperature sensor module. | None on performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported low supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Incorrect sensor for the application (12 VDC versus 24 VDC)
  • Low supply voltage
Refer to Troubleshooting Fault Code 5728.

Last Modified: 03-May-2016


Aftertreatment 2 Selective Catalytic Reduction Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 5729

Aftertreatment 2 Selective Catalytic Reduction Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5729 PID: SPN: 7467 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment 2 Selective Catalytic Reduction Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level. High internal temperature detected in the SCR temperature sensor module. | None on performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported the internal circuit board temperature was too high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates the internal temperature of the aftertreatment SCR temperature sensor module was too high. Troubleshoot the exhaust system for leaks, missing heat shields, or dirt and debris that could lead to overheating of the aftertreatment SCR temperature sensor module.

Refer to Troubleshooting Fault Code 5729.

Last Modified: 03-May-2016


Aftertreatment 2 Selective Catalytic Reduction Temperature Sensor Module - Root Cause Not Known

FAULT CODE 5731

Aftertreatment 2 Selective Catalytic Reduction Temperature Sensor Module - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5731 PID: SPN: 7467 FMI: 11/11 LAMP: Amber SRT: | Aftertreatment 2 Selective Catalytic Reduction Temperature Sensor Module - Root Cause Not Known. Intermittent supply voltage detected at the aftertreatment SCR temperature sensor module. | None on performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an intermittent supply voltage to the aftertreatment SCR temperature sensor module resulting in an internal reset of the module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code sets when the ECM detects an internal reset of the sensor. This internal reset is caused by an intermittent supply voltage. This fault code indicates that an intermittent wiring problem has been detected. All wiring and connectors should be closely inspected for intermittent connections.

Refer to Troubleshooting Fault Code 5731.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 2 Input Lines - Condition Exists

FAULT CODE 5747

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 2 Input Lines - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5747 PID: SPN: 7458 FMI: 11/31 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 2 Input Lines - Condition Exists. The aftertreatment diesel exhaust fluid dosing unit is unable to prime. | None on performance.
Aftertreatment Diesel Exhaust Fluid Dosing Valve Circuit

Circuit Description

The diesel exhaust fluid dosing unit lines are responsible for transporting diesel exhaust fluid between the dosing unit, dosing valve, and diesel exhaust fluid tank.

Component Location

There are three diesel exhaust fluid lines. One line is between the diesel exhaust fluid tank and the dosing unit (suction line), one line is between the dosing unit and dosing valve (pressure line) and one line is between the dosing valve and the diesel exhaust fluid tank (return line). These lines can be partially hidden from view by the SCR system and other vehicle components. Line routing will vary, based on the aftertreatment architecture and the OEM.

Conditions for Running the Diagnostics

This diagnostic runs when the SCR system is trying to prime.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid dosing unit was unable to successfully prime after multiple attempts.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid System Leak Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low aftertreatment diesel exhaust fluid level in the diesel exhaust fluid tank
  • The line heaters are not successfully thawing the frozen diesel exhaust fluid
  • The diesel exhaust fluid pressure line between the dosing unit and dosing valve is kinked, broken, or disconnected
  • The diesel exhaust fluid suction line between the diesel exhaust fluid tank and the dosing unit is kinked, broken, or disconnected
  • Malfunctioning diesel exhaust fluid dosing unit
  • Debris from the diesel exhaust fluid tank. If debris is found in the diesel exhaust fluid tank, clean the diesel exhaust fluid tank thoroughly and fill with certified diesel exhaust fluid.
  • The diesel exhaust fluid pressure and return lines are reversed at the dosing valve
Refer to Troubleshooting Fault Code 5747.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 5748

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5748 PID: SPN: 7457 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 2 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid dosing unit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit filters and pressurizes DEF for the DEF dosing valve. The ECM provides supply voltage and a ground to the diesel exhaust fluid dosing unit. The ECM also supplies a signal to the dosing unit to control the diesel exhaust fluid output. This signal changes, based on the diesel exhaust fluid pressure being commanded.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit signal voltage was greater than a calibrated value or the diesel exhaust fluid dosing unit supply was shorted to ECM supply voltage or open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • Perform a key cycle, and leave the key switch in the ON position for at least 2 minutes.
  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid System Leak Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A signal circuit shorted to sensor supply or ECM supply voltage.
  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5748.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5749

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5749 PID: SPN: 7457 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel exhaust fluid dosing unit. | None on performance.
Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit filters and pressurizes DEF for the DEF dosing valve. The ECM provides supply voltage and a ground to the diesel exhaust fluid dosing unit. The ECM also supplies a signal to the dosing unit to control the diesel exhaust fluid output. This signal changes, based on the diesel exhaust fluid pressure being commanded.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit signal voltage or the aftertreatment diesel exhaust fluid dosing unit supply voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid System Leak Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Short to ground in the diesel exhaust fluid dosing unit
  • Supply wire shorted to ground.
  • Control signal wire shorted to ground or open.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5749.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 2 Circuit - Current Below Normal or Open Circuit

FAULT CODE 5751

Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 2 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5751 PID: SPN: 6324 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 2 Circuit - Current Below Normal or Open Circuit. A circuit error has been detected in the aftertreatment diesel exhaust fluid dosing valve circuit. | None on performance.
Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 2 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the ECM. When the engine control module (ECM) commands DEF dosing, the ECM sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid dosing valve is installed in the exhaust system. It is mounted directly to the aftertreatment decomposition tube, before the selective catalytic reduction (SCR) catalyst. Installation position will vary, based on the aftertreatment architecture and the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing valve is being commanded on.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing valve circuit was shorted high, shorted low, or open.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the diesel exhaust fluid dosing valve
  • A short circuit to battery in the OEM harness
  • A short circuit to ground in the OEM harness
  • An open circuit in the OEM harness

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5751.

Last Modified: 18-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Pressure 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 5752

Aftertreatment 1 Diesel Exhaust Fluid Pressure 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5752 PID: SPN: 7459 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Pressure 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid pressure sensor circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal wire shorted to sensor supply or ECM supply voltage.
  • Open return circuit in the harness, connectors, or sensor.
  • A malfunctioning aftertreatment diesel exhaust fluid pressure sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5752.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Pressure 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5753

Aftertreatment 1 Diesel Exhaust Fluid Pressure 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5753 PID: SPN: 7459 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Pressure 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the diesel exhaust fluid pressure sensor circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground.
  • Sensor supply wire open or shorted to ground
  • A malfunctioning aftertreatment diesel exhaust fluid pressure sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5753.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Pressure 2 Sensor Circuit - Current Below Normal or Open Circuit

FAULT CODE 5754

Aftertreatment 1 Diesel Exhaust Fluid Pressure 2 Sensor Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5754 PID: SPN: 7459 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Pressure 2 Sensor Circuit - Current Below Normal or Open Circuit. A circuit error has been detected in the aftertreatment diesel exhaust fluid pressure sensor circuit. | None on performance.
Aftertreatment 1 Diesel Exhaust Fluid Pressure 2 Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the ECM. When the engine control module (ECM) commands DEF dosing, the ECM sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The aftertreatment diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure sensor circuit was shorted high, shorted low, or open.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes for this fault include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing valve
Refer to Troubleshooting Fault Code 5754.

Last Modified: 18-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Pressure 2 - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 5755

Aftertreatment 1 Diesel Exhaust Fluid Pressure 2 - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5755 PID: SPN: 7459 FMI: 1/18 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Pressure 2 - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low diesel exhaust fluid pressure has been detected in the dosing valve. | None on performance.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs after the diesel exhaust fluid dosing system has primed.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure was less than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low diesel exhaust fluid tank level
  • Blocked, restricted, or frozen diesel exhaust fluid dosing unit supply line
  • Blocked, restricted, or frozen diesel exhaust fluid dosing valve supply line
  • Blocked or restricted diesel exhaust fluid tank filter
  • Blocked or restricted diesel exhaust fluid dosing unit filter
  • Malfunctioning diesel exhaust fluid dosing unit
  • Blocked or restricted DEF dosing valve
  • Contaminated diesel exhaust fluid

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5755.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Pressure 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 5756

Aftertreatment 1 Diesel Exhaust Fluid Pressure 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5756 PID: SPN: 7459 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Pressure 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level. The diesel exhaust fluid dosing valve has detected a blockage in the diesel exhaust fluid return flow. | None on performance.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs after the diesel exhaust fluid dosing system has primed.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure was greater than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Blocked, restricted, or frozen diesel exhaust fluid dosing valve return line or return line connector.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5756.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Pressure 2 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 5757

Aftertreatment 1 Diesel Exhaust Fluid Pressure 2 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5757 PID: SPN: 7459 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Pressure 2 - Data Erratic, Intermittent, or Incorrect. The diesel exhaust fluid pressure sensor has reported a reading too high or low for the operating conditions. | None on performance.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs after the diesel exhaust fluid dosing system has primed.

Conditions for Setting the Fault Codes

The diesel exhaust fluid dosing unit was unable to maintain the commanded diesel exhaust fluid pressure.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Air in the DEF.
  • Leaking diesel exhaust fluid lines
  • Malfunctioning diesel exhaust fluid dosing unit
  • Blocked or restricted diesel exhaust fluid dosing unit supply line fitting
  • Blocked or restricted diesel exhaust fluid filters
  • Malfunctioning diesel exhaust fluid pressure sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5757.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Dosing 2 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 5758

Aftertreatment 1 Diesel Exhaust Fluid Dosing 2 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5758 PID: SPN: 7460 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Dosing 2 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid dosing temperature sensor circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) dosing temperature sensor is a variable resistor sensor and is used to measure the temperature of the DEF in the dosing valve. The engine control module (ECM) supplies 5 volts to the aftertreatment DEF dosing temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the aftertreatment DEF dosing temperature.

Component Location

The aftertreatment diesel exhaust fluid dosing temperature sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing temperature sensor signal circuit was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit shorted to voltage source.
  • A malfunctioning aftertreatment diesel exhaust fluid dosing temperature sensor
Refer to Troubleshooting Fault Code 5758.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Dosing 2 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5759

Aftertreatment 1 Diesel Exhaust Fluid Dosing 2 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5759 PID: SPN: 7460 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Dosing 2 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel exhaust fluid dosing temperature sensor signal circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) dosing temperature sensor is a variable resistor sensor and is used to measure the temperature of the DEF in the dosing valve. The engine control module (ECM) supplies 5 volts to the aftertreatment DEF dosing temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the aftertreatment DEF dosing temperature.

Component Location

The aftertreatment diesel exhaust fluid dosing temperature sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing temperature sensor signal circuit was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground.
  • A malfunctioning aftertreatment diesel exhaust fluid dosing temperature sensor
Refer to Troubleshooting Fault Code 5759.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Dosing 2 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 5764

Aftertreatment 1 Diesel Exhaust Fluid Dosing 2 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5764 PID: SPN: 7460 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Dosing 2 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. Diesel exhaust fluid dosing temperature has exceeded the warning limit. | None on performance.
Diesel Exhaust Fluid Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the ECM. When the engine control module (ECM) commands DEF dosing, the ECM sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid dosing temperature sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing temperature was above the warning level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing valve temperature sensor.
Refer to Troubleshooting Fault Code 5764.

Last Modified: 03-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit 2 Input Lines - Condition Exists

FAULT CODE 5767

Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit 2 Input Lines - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5767 PID: SPN: 7463 FMI: 11/31 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit 2 Input Lines - Condition Exists. The diesel exhaust fluid dosing unit is unable to prime. | None on performance.
Diesel Exhaust Fluid Dosing Valve Circuit

Circuit Description

The diesel exhaust fluid dosing unit lines are responsible for transporting diesel exhaust fluid between the dosing unit, dosing valve, and diesel exhaust fluid tank.

Component Location

There are three diesel exhaust fluid lines. One line is between the diesel exhaust fluid tank and the dosing unit (suction line), one line is between the dosing unit and dosing valve (pressure line) and one line is between the dosing valve and the diesel exhaust fluid tank (return line). These lines can be partially hidden from view by the SCR system and other vehicle components. Line routing will vary, based on the aftertreatment architecture and the OEM.

Conditions for Running the Diagnostics

This diagnostic runs when the SCR system is trying to prime.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid dosing unit was unable to successfully prime after multiple attempts.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid System Leak Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low aftertreatment diesel exhaust fluid level in the diesel exhaust fluid tank
  • The line heaters are not successfully thawing the frozen diesel exhaust fluid
  • The diesel exhaust fluid pressure line between the dosing unit and dosing valve is kinked, broken, or disconnected
  • The diesel exhaust fluid suction line between the diesel exhaust fluid tank and the dosing unit is kinked, broken, or disconnected
  • Malfunctioning diesel exhaust fluid dosing unit
  • Debris from the diesel exhaust fluid tank. If debris is found in the diesel exhaust fluid tank, clean the diesel exhaust fluid tank thoroughly and fill with certified diesel exhaust fluid.
  • The diesel exhaust fluid pressure and return lines are reversed at the dosing valve
Refer to Troubleshooting Fault Code 5767.

Last Modified: 03-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 5768

Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5768 PID: SPN: 7462 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit 2 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the diesel exhaust fluid dosing unit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit filters and pressurizes DEF for the DEF dosing valve. The ECM provides supply voltage and a ground to the diesel exhaust fluid dosing unit. The ECM also supplies a signal to the dosing unit to control the diesel exhaust fluid output. This signal changes, based on the diesel exhaust fluid pressure being commanded.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit signal voltage was greater than a calibrated value or the diesel exhaust fluid dosing unit supply was shorted to ECM supply voltage or open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • Perform a key cycle, and leave the key switch in the ON position for at least 2 minutes.
  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid System Leak Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A signal circuit shorted to sensor supply or ECM supply voltage.
  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5768.

Last Modified: 03-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5769

Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5769 PID: SPN: 7462 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the diesel exhaust fluid dosing unit. | None on performance.
Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit filters and pressurizes DEF for the DEF dosing valve. The ECM provides supply voltage and a ground to the diesel exhaust fluid dosing unit. The ECM also supplies a signal to the dosing unit to control the diesel exhaust fluid output. This signal changes, based on the diesel exhaust fluid pressure being commanded.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit signal voltage or the aftertreatment diesel exhaust fluid dosing unit supply voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid System Leak Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Short to ground in the diesel exhaust fluid dosing unit
  • Supply wire shorted to ground.
  • Control signal wire shorted to ground or open.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5769.

Last Modified: 03-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Dosing Valve 2 Circuit - Current Below Normal or Open Circuit

FAULT CODE 5771

Aftertreatment 2 Diesel Exhaust Fluid Dosing Valve 2 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5771 PID: SPN: 6325 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Dosing Valve 2 Circuit - Current Below Normal or Open Circuit. A malfunction has been detected in the diesel exhaust fluid dosing valve circuit. | None on performance.
Aftertreatment 2 Diesel Exhaust Fluid Dosing Valve 2 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the ECM. When the engine control module (ECM) commands DEF dosing, the ECM sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing valve is being commanded on.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing valve circuit was shorted high, shorted low, or open.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, cycle the keyswitch from OFF to ON.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the diesel exhaust fluid dosing valve
  • Signal circuit open or shorted to ground.
  • Return circuit open or shorted.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5771.

Last Modified: 18-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Pressure 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 5772

Aftertreatment 2 Diesel Exhaust Fluid Pressure 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5772 PID: SPN: 7464 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Pressure 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the diesel exhaust fluid pressure sensor circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal wire shorted to sensor supply or ECM supply voltage.
  • Open return circuit in the harness, connectors, or sensor.
  • A malfunctioning aftertreatment diesel exhaust fluid pressure sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5772.

Last Modified: 03-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Pressure 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5773

Aftertreatment 2 Diesel Exhaust Fluid Pressure 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5773 PID: SPN: 7464 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Pressure 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the diesel exhaust fluid pressure sensor circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground.
  • Sensor supply wire open or shorted to ground
  • A malfunctioning aftertreatment diesel exhaust fluid pressure sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5773.

Last Modified: 03-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Pressure 2 Sensor Circuit - Current Below Normal or Open Circuit

FAULT CODE 5774

Aftertreatment 2 Diesel Exhaust Fluid Pressure 2 Sensor Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5774 PID: SPN: 7464 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Pressure 2 Sensor Circuit - Current Below Normal or Open Circuit. A circuit error has been detected in the aftertreatment diesel exhaust fluid pressure sensor circuit. | None on performance.
Aftertreatment 2 Diesel Exhaust Fluid Pressure 2 Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the ECM. When the engine control module (ECM) commands DEF dosing, the ECM sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The aftertreatment diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure sensor circuit was shorted high, shorted low, or open.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes for this fault include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing valve
Refer to Troubleshooting Fault Code 5774.

Last Modified: 18-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Pressure 2 - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 5775

Aftertreatment 2 Diesel Exhaust Fluid Pressure 2 - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5775 PID: SPN: 7464 FMI: 1/18 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Pressure 2 - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low diesel exhaust fluid pressure has been detected in the dosing valve. | None on performance.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs after the diesel exhaust fluid dosing system has primed.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure was less than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low diesel exhaust fluid tank level
  • Blocked, restricted, or frozen diesel exhaust fluid dosing unit supply line
  • Blocked, restricted, or frozen diesel exhaust fluid dosing valve supply line
  • Blocked or restricted diesel exhaust fluid tank filter
  • Blocked or restricted diesel exhaust fluid dosing unit filter
  • Malfunctioning diesel exhaust fluid dosing unit
  • Blocked or restricted DEF dosing valve
  • Contaminated diesel exhaust fluid

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5775.

Last Modified: 03-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Pressure 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 5776

Aftertreatment 2 Diesel Exhaust Fluid Pressure 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5776 PID: SPN: 7464 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Pressure 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level. The diesel exhaust fluid dosing valve has detected a blockage in the diesel exhaust fluid return flow. | None on performance.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs after the diesel exhaust fluid dosing system has primed.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure was greater than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Blocked, restricted, or frozen diesel exhaust fluid dosing valve return line or return line connector.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5776.

Last Modified: 03-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Pressure 2 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 5777

Aftertreatment 2 Diesel Exhaust Fluid Pressure 2 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5777 PID: SPN: 7464 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Pressure 2 - Data Erratic, Intermittent, or Incorrect. The diesel exhaust fluid pressure sensor has reported a reading too high or low for the operating conditions. | None on performance.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs after the diesel exhaust fluid dosing system has primed.

Conditions for Setting the Fault Codes

The diesel exhaust fluid dosing unit was unable to maintain the commanded diesel exhaust fluid pressure.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Air in the DEF.
  • Leaking diesel exhaust fluid lines
  • Malfunctioning diesel exhaust fluid dosing unit
  • Blocked or restricted diesel exhaust fluid dosing unit supply line fitting
  • Blocked or restricted diesel exhaust fluid filters
  • Malfunctioning diesel exhaust fluid pressure sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5777.

Last Modified: 03-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Dosing 2 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 5778

Aftertreatment 2 Diesel Exhaust Fluid Dosing 2 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5778 PID: SPN: 7465 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Dosing 2 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the diesel exhaust fluid dosing temperature sensor circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) dosing temperature sensor is a variable resistor sensor and is used to measure the temperature of the DEF in the dosing valve. The engine control module (ECM) supplies 5 volts to the aftertreatment DEF dosing temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the aftertreatment DEF dosing temperature.

Component Location

The aftertreatment diesel exhaust fluid dosing temperature sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing temperature sensor signal circuit was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit shorted to voltage source.
  • A malfunctioning aftertreatment diesel exhaust fluid dosing temperature sensor
Refer to Troubleshooting Fault Code 5778.

Last Modified: 03-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Dosing 2 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5779

Aftertreatment 2 Diesel Exhaust Fluid Dosing 2 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5779 PID: SPN: 7465 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Dosing 2 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the diesel exhaust fluid dosing temperature sensor circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) dosing temperature sensor is a variable resistor sensor and is used to measure the temperature of the DEF in the dosing valve. The engine control module (ECM) supplies 5 volts to the aftertreatment DEF dosing temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the aftertreatment DEF dosing temperature.

Component Location

The aftertreatment diesel exhaust fluid dosing temperature sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing temperature sensor signal circuit was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground.
  • A malfunctioning aftertreatment diesel exhaust fluid dosing temperature sensor
Refer to Troubleshooting Fault Code 5779.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 3 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 5794

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 3 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5794 PID: SPN: 7483 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 3 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid dosing unit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit filters and pressurizes DEF for the DEF dosing valve. The ECM provides supply voltage and a ground to the diesel exhaust fluid dosing unit. The ECM also supplies a signal to the dosing unit to control the diesel exhaust fluid output. This signal changes, based on the diesel exhaust fluid pressure being commanded.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit signal voltage was greater than a calibrated value or the diesel exhaust fluid dosing unit supply was shorted to ECM supply voltage or open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • Perform a key cycle, and leave the key switch in the ON position for at least 2 minutes.
  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid System Leak Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A signal circuit shorted to sensor supply or ECM supply voltage.
  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5794.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 3 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5795

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 3 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5795 PID: SPN: 7483 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 3 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel exhaust fluid dosing unit. | None on performance.
Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit filters and pressurizes DEF for the DEF dosing valve. The ECM provides supply voltage and a ground to the diesel exhaust fluid dosing unit. The ECM also supplies a signal to the dosing unit to control the diesel exhaust fluid output. This signal changes, based on the diesel exhaust fluid pressure being commanded.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit signal voltage or the aftertreatment diesel exhaust fluid dosing unit supply voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid System Leak Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Short to ground in the diesel exhaust fluid dosing unit
  • Supply wire shorted to ground.
  • Control signal wire shorted to ground or open.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5795.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Doser 3 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 5796

Aftertreatment 1 Diesel Exhaust Fluid Doser 3 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5796 PID: SPN: 7486 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Doser 3 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid dosing temperature sensor circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) dosing temperature sensor is a variable resistor sensor and is used to measure the temperature of the DEF in the dosing valve. The engine control module (ECM) supplies 5 volts to the aftertreatment DEF dosing temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the aftertreatment DEF dosing temperature.

Component Location

The aftertreatment diesel exhaust fluid dosing temperature sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing temperature sensor signal circuit was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit shorted to voltage source.
  • A malfunctioning aftertreatment diesel exhaust fluid dosing temperature sensor
Refer to Troubleshooting Fault Code 5796.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Doser 3 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5797

Aftertreatment 1 Diesel Exhaust Fluid Doser 3 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5797 PID: SPN: 7486 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Doser 3 Temperature Sensor - Voltage below normal, or shorted to low source. Low signal voltage detected at the aftertreatment diesel exhaust fluid dosing temperature sensor signal circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) dosing temperature sensor is a variable resistor sensor and is used to measure the temperature of the DEF in the dosing valve. The engine control module (ECM) supplies 5 volts to the aftertreatment DEF dosing temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the aftertreatment DEF dosing temperature.

Component Location

The aftertreatment diesel exhaust fluid dosing temperature sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing temperature sensor signal circuit was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground.
  • A malfunctioning aftertreatment diesel exhaust fluid dosing temperature sensor
Refer to Troubleshooting Fault Code 5797.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Pressure 3 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 5798

Aftertreatment 1 Diesel Exhaust Fluid Pressure 3 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5798 PID: SPN: 7485 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Pressure 3 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid pressure sensor circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal wire shorted to sensor supply or ECM supply voltage.
  • Open return circuit in the harness, connectors, or sensor.
  • A malfunctioning aftertreatment diesel exhaust fluid pressure sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5798.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Pressure 3 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5799

Aftertreatment 1 Diesel Exhaust Fluid Pressure 3 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5799 PID: SPN: 7485 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Pressure 3 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected as the diesel exhaust fluid pressure sensor circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground.
  • Sensor supply wire open or shorted to ground
  • A malfunctioning aftertreatment diesel exhaust fluid pressure sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5799.

Last Modified: 03-May-2016


Fuel Supply Pump Intake Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 581

Fuel Supply Pump Intake Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 581 PID: P15 SPN: 1381 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the fuel supply pump intake pressure sensor circuit. | None on performance.
Engine Fuel Supply Pump Intake Pressure Sensor Circuit.

Circuit Description

The fuel supply pump intake pressure sensor measures the gauge pressure at the inlet of the engine fuel supply pump. The sensor is connected directly to the pump and the sensor value is communicated to the ECMs via the engine datalink.

The engine fuel supply pump provides a 5 volt supply to the fuel supply pump intake pressure sensor using a dedicated sensor supply circuit. The supply pump also provides a ground on the sensor return circuit. The fuel supply pump intake pressure sensor provides a pressure signal to the pump on the fuel supply pump intake pressure sensor signal circuit. This sensor signal voltage changes based on the pressure at the intake of the engine fuel supply pump.

Component Location

The engine fuel supply pump intake pressure sensor is located on the inlet of the fuel supply pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine fuel supply pump detected the fuel supply pump intake pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor

Signal wire shorted to sensor supply or ECM supply voltage.

Malfunctioning engine fuel supply pump intake pressure sensor.

Refer to Troubleshooting Fault Code 581 .

Last Modified: 21-Aug-2019


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 3 Input Lines - Condition Exists

FAULT CODE 5813

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 3 Input Lines - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5813 PID: SPN: 7484 FMI: 11/31 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 3 Input Lines - Condition Exists. The aftertreatment diesel exhaust fluid dosing unit is unable to prime. | None on performance.
Aftertreatment Diesel Exhaust Fluid Dosing Valve Circuit

Circuit Description

The diesel exhaust fluid dosing unit lines are responsible for transporting diesel exhaust fluid between the dosing unit, dosing valve, and diesel exhaust fluid tank.

Component Location

There are three diesel exhaust fluid lines. One line is between the diesel exhaust fluid tank and the dosing unit (suction line), one line is between the dosing unit and dosing valve (pressure line) and one line is between the dosing valve and the diesel exhaust fluid tank (return line). These lines can be partially hidden from view by the SCR system and other equipment components. Line routing will vary, based on the aftertreatment architecture and the OEM.

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing unit is in the priming or dosing state.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid dosing unit was unable to successfully prime after multiple attempts.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid System Leak Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low aftertreatment diesel exhaust fluid level in the diesel exhaust fluid tank
  • The line heaters are not successfully thawing the frozen diesel exhaust fluid
  • The diesel exhaust fluid pressure line between the dosing unit and dosing valve is kinked, broken, or disconnected
  • The diesel exhaust fluid suction line between the diesel exhaust fluid tank and the dosing unit is kinked, broken, or disconnected
  • Malfunctioning diesel exhaust fluid dosing unit
  • Debris from the diesel exhaust fluid tank. If debris is found in the diesel exhaust fluid tank, clean the diesel exhaust fluid tank thoroughly and fill with certified diesel exhaust fluid.
  • The diesel exhaust fluid lines are routed incorrectly. Ensure diesel exhaust fluid dosing unit is connected to the corresponding diesel exhaust fluid dosing valve.
Refer to Troubleshooting Fault Code 5813.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Pressure 3 - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 5814

Aftertreatment 1 Diesel Exhaust Fluid Pressure 3 - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5814 PID: SPN: 7485 FMI: 1/18 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Pressure 3 - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low diesel exhaust fluid pressure has been detected in the dosing valve. | None on performance.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs after the diesel exhaust fluid dosing system has primed.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure was less than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low diesel exhaust fluid tank level
  • Blocked, restricted, or frozen diesel exhaust fluid dosing unit supply line
  • Blocked, restricted, or frozen diesel exhaust fluid dosing valve supply line
  • Blocked or restricted diesel exhaust fluid tank filter
  • Blocked or restricted diesel exhaust fluid dosing unit filter
  • Malfunctioning diesel exhaust fluid dosing unit
  • Blocked or restricted DEF dosing valve
  • Contaminated diesel exhaust fluid

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5814.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Pressure 3 - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 5815

Aftertreatment 1 Diesel Exhaust Fluid Pressure 3 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5815 PID: SPN: 7485 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Pressure 3 - Data Valid But Above Normal Operating Range - Moderately Severe Level. The diesel exhaust fluid dosing valve has detected a blockage in the diesel exhaust fluid return flow. | None on performance.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs after the diesel exhaust fluid dosing system has primed.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure was greater than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Blocked, restricted, or frozen diesel exhaust fluid dosing valve return line or return line connector.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5815.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Pressure 3 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 5816

Aftertreatment 1 Diesel Exhaust Fluid Pressure 3 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5816 PID: SPN: 7485 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Pressure 3 - Data Erratic, Intermittent, or Incorrect. The diesel exhaust fluid pressure sensor has reported a reading too high or low for the operating conditions. | None on performance.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs after the diesel exhaust fluid dosing system has primed.

Conditions for Setting the Fault Codes

The diesel exhaust fluid dosing unit was unable to maintain the commanded diesel exhaust fluid pressure.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Air in the DEF.
  • Leaking diesel exhaust fluid lines
  • Malfunctioning diesel exhaust fluid dosing unit
  • Blocked or restricted diesel exhaust fluid dosing unit supply line fitting
  • Blocked or restricted diesel exhaust fluid filters
  • Malfunctioning diesel exhaust fluid pressure sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5816.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 3 - Current Below Normal or Open Circuit

FAULT CODE 5817

Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 3 - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5817 PID: SPN: 7488 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 3 - Current Below Normal or Open Circuit. A circuit error has been detected in the aftertreatment diesel exhaust fluid dosing valve circuit. | None on performance.
Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 3 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the ECM. When the engine control module (ECM) commands DEF dosing, the ECM sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid dosing valve is installed in the exhaust system. It is mounted directly to the aftertreatment decomposition tube, before the selective catalytic reduction (SCR) catalyst. Installation position will vary, based on the aftertreatment architecture and the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing valve is being commanded on.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing valve circuit was shorted high, shorted low, or open.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the diesel exhaust fluid dosing valve
  • A short circuit to battery in the OEM harness
  • A short circuit to ground in the OEM harness
  • An open circuit in the OEM harness

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5817.

Last Modified: 18-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Pressure 3 Sensor Circuit - Current Below Normal or Open Circuit

FAULT CODE 5818

Aftertreatment 1 Diesel Exhaust Fluid Pressure 3 Sensor Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5818 PID: SPN: 7485 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Pressure 3 Sensor Circuit - Current Below Normal or Open Circuit. A circuit error has been detected in the aftertreatment diesel exhaust fluid pressure sensor circuit. | None on performance.
Aftertreatment 1 Diesel Exhaust Fluid Pressure 3 Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the ECM. When the engine control module (ECM) commands DEF dosing, the ECM sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The aftertreatment diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure sensor circuit was shorted high, shorted low, or open.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes for this fault include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing valve
Refer to Troubleshooting Fault Code 5818.

Last Modified: 18-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit 3 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 5819

Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit 3 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5819 PID: SPN: 7489 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit 3 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid dosing unit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit filters and pressurizes DEF for the DEF dosing valve. The ECM provides supply voltage and a ground to the diesel exhaust fluid dosing unit. The ECM also supplies a signal to the dosing unit to control the diesel exhaust fluid output. This signal changes, based on the diesel exhaust fluid pressure being commanded.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit signal voltage was greater than a calibrated value or the diesel exhaust fluid dosing unit supply was shorted to ECM supply voltage or open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • Perform a key cycle, and leave the key switch in the ON position for at least 2 minutes.
  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid System Leak Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A signal circuit shorted to sensor supply or ECM supply voltage.
  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5819.

Last Modified: 03-May-2016


Fuel Supply Pump Intake Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 582

Fuel Supply Pump Intake Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 582 PID: P15 SPN: 1381 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the fuel supply pump intake pressure sensor circuit. | None on performance.
Engine Fuel Supply Pump Intake Pressure Sensor Circuit.

Circuit Description

The fuel supply pump intake pressure sensor measures the gauge pressure at the inlet of the engine fuel supply pump. The sensor is connected directly to the pump and the sensor value is communicated to the ECMs via the engine datalink.

The engine fuel supply pump provides a 5 volt supply to the fuel supply pump intake pressure sensor using a dedicated sensor supply circuit. The supply pump also provides a ground on the sensor return circuit. The fuel supply pump intake pressure sensor provides a pressure signal to the pump on the fuel supply pump intake pressure sensor signal circuit. This sensor signal voltage changes based on the pressure at the intake of the engine fuel supply pump.

Component Location

The engine fuel supply pump intake pressure sensor is located on the inlet of the fuel supply pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine fuel supply pump detected the fuel supply pump intake pressure sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Signal circuit shorted to ground in the harness, sensor, or connector.

  • Supply wire open or shorted to ground.

Malfunctioning engine fuel supply pump intake pressure sensor.

Refer to Troubleshooting Fault Code 582 .

Last Modified: 21-Aug-2019


Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit 3 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5821

Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit 3 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5821 PID: SPN: 7489 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit 3 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel exhaust fluid dosing unit. | None on performance.
Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit filters and pressurizes DEF for the DEF dosing valve. The ECM provides supply voltage and a ground to the diesel exhaust fluid dosing unit. The ECM also supplies a signal to the dosing unit to control the diesel exhaust fluid output. This signal changes, based on the diesel exhaust fluid pressure being commanded.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit signal voltage or the aftertreatment diesel exhaust fluid dosing unit supply voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid System Leak Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Short to ground in the diesel exhaust fluid dosing unit
  • Supply wire shorted to ground.
  • Control signal wire shorted to ground or open.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5821.

Last Modified: 03-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Doser 3 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 5822

Aftertreatment 2 Diesel Exhaust Fluid Doser 3 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5822 PID: SPN: 7492 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Doser 3 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid dosing temperature sensor circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) dosing temperature sensor is a variable resistor sensor and is used to measure the temperature of the DEF in the dosing valve. The engine control module (ECM) supplies 5 volts to the aftertreatment DEF dosing temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the aftertreatment DEF dosing temperature.

Component Location

The aftertreatment diesel exhaust fluid dosing temperature sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing temperature sensor signal circuit was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit shorted to voltage source.
  • A malfunctioning aftertreatment diesel exhaust fluid dosing temperature sensor
Refer to Troubleshooting Fault Code 5822.

Last Modified: 03-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Doser 3 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5823

Aftertreatment 2 Diesel Exhaust Fluid Doser 3 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5823 PID: SPN: 7492 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Doser 3 Temperature Sensor - Voltage below normal, or shorted to low source. Low signal voltage detected at the aftertreatment diesel exhaust fluid dosing temperature sensor signal circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) dosing temperature sensor is a variable resistor sensor and is used to measure the temperature of the DEF in the dosing valve. The engine control module (ECM) supplies 5 volts to the aftertreatment DEF dosing temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the aftertreatment DEF dosing temperature.

Component Location

The aftertreatment diesel exhaust fluid dosing temperature sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing temperature sensor signal circuit was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground.
  • A malfunctioning aftertreatment diesel exhaust fluid dosing temperature sensor
Refer to Troubleshooting Fault Code 5823.

Last Modified: 03-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Pressure 3 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 5824

Aftertreatment 2 Diesel Exhaust Fluid Pressure 3 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5824 PID: SPN: 7491 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Pressure 3 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid pressure sensor circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal wire shorted to sensor supply or ECM supply voltage.
  • Open return circuit in the harness, connectors, or sensor.
  • A malfunctioning aftertreatment diesel exhaust fluid pressure sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5824.

Last Modified: 03-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Pressure 3 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5825

Aftertreatment 2 Diesel Exhaust Fluid Pressure 3 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5825 PID: SPN: 7491 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Pressure 3 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected as the diesel exhaust fluid pressure sensor circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground.
  • Sensor supply wire open or shorted to ground
  • A malfunctioning aftertreatment diesel exhaust fluid pressure sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5825.

Last Modified: 03-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit 3 Input Lines - Condition Exists

FAULT CODE 5828

Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit 3 Input Lines - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5828 PID: SPN: 7490 FMI: 11/31 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit 3 Input Lines - Condition Exists. The aftertreatment diesel exhaust fluid dosing unit is unable to prime. | None on performance.
Aftertreatment Diesel Exhaust Fluid Dosing Valve Circuit

Circuit Description

The diesel exhaust fluid dosing unit lines are responsible for transporting diesel exhaust fluid between the dosing unit, dosing valve, and diesel exhaust fluid tank.

Component Location

There are three diesel exhaust fluid lines. One line is between the diesel exhaust fluid tank and the dosing unit (suction line), one line is between the dosing unit and dosing valve (pressure line) and one line is between the dosing valve and the diesel exhaust fluid tank (return line). These lines can be partially hidden from view by the SCR system and other equipment components. Line routing will vary, based on the aftertreatment architecture and the OEM.

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing unit is in the priming or dosing state.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid dosing unit was unable to successfully prime after multiple attempts.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid System Leak Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low aftertreatment diesel exhaust fluid level in the diesel exhaust fluid tank
  • The line heaters are not successfully thawing the frozen diesel exhaust fluid
  • The diesel exhaust fluid pressure line between the dosing unit and dosing valve is kinked, broken, or disconnected
  • The diesel exhaust fluid suction line between the diesel exhaust fluid tank and the dosing unit is kinked, broken, or disconnected
  • Malfunctioning diesel exhaust fluid dosing unit
  • Debris from the diesel exhaust fluid tank. If debris is found in the diesel exhaust fluid tank, clean the diesel exhaust fluid tank thoroughly and fill with certified diesel exhaust fluid.
  • The diesel exhaust fluid lines are routed incorrectly. Ensure diesel exhaust fluid dosing unit is connected to the corresponding diesel exhaust fluid dosing valve.
Refer to Troubleshooting Fault Code 5828.

Last Modified: 03-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Pressure 3 - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 5829

Aftertreatment 2 Diesel Exhaust Fluid Pressure 3 - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5829 PID: SPN: 7491 FMI: 1/18 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Pressure 3 - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low diesel exhaust fluid pressure has been detected in the dosing valve. | None on performance.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs after the diesel exhaust fluid dosing system has primed.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure was less than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low diesel exhaust fluid tank level
  • Blocked, restricted, or frozen diesel exhaust fluid dosing unit supply line
  • Blocked, restricted, or frozen diesel exhaust fluid dosing valve supply line
  • Blocked or restricted diesel exhaust fluid tank filter
  • Blocked or restricted diesel exhaust fluid dosing unit filter
  • Malfunctioning diesel exhaust fluid dosing unit
  • Blocked or restricted DEF dosing valve
  • Contaminated diesel exhaust fluid

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5829.

Last Modified: 03-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Pressure 3 - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 5831

Aftertreatment 2 Diesel Exhaust Fluid Pressure 3 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5831 PID: SPN: 7491 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Pressure 3 - Data Valid But Above Normal Operating Range - Moderately Severe Level. The diesel exhaust fluid dosing valve has detected a blockage in the diesel exhaust fluid return flow. | None on performance.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs after the diesel exhaust fluid dosing system has primed.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure was greater than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Blocked, restricted, or frozen diesel exhaust fluid dosing valve return line or return line connector.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5831.

Last Modified: 03-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Pressure 3 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 5832

Aftertreatment 2 Diesel Exhaust Fluid Pressure 3 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5832 PID: SPN: 7491 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Pressure 3 - Data Erratic, Intermittent, or Incorrect. The diesel exhaust fluid pressure sensor has reported a reading too high or low for the operating conditions. | None on performance.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs after the diesel exhaust fluid dosing system has primed.

Conditions for Setting the Fault Codes

The diesel exhaust fluid dosing unit was unable to maintain the commanded diesel exhaust fluid pressure.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Air in the DEF.
  • Leaking diesel exhaust fluid lines
  • Malfunctioning diesel exhaust fluid dosing unit
  • Blocked or restricted diesel exhaust fluid dosing unit supply line fitting
  • Blocked or restricted diesel exhaust fluid filters
  • Malfunctioning diesel exhaust fluid pressure sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5832.

Last Modified: 03-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Dosing Valve 3 Circuit - Current Below Normal or Open Circuit

FAULT CODE 5833

Aftertreatment 2 Diesel Exhaust Fluid Dosing Valve 3 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5833 PID: SPN: 7494 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Dosing Valve 3 - Current Below Normal or Open Circuit. A circuit error has been detected in the aftertreatment diesel exhaust fluid dosing valve circuit. | None on performance.
Aftertreatment 2 Diesel Exhaust Fluid Dosing Valve 3 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the ECM. When the engine control module (ECM) commands DEF dosing, the ECM sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing valve is being commanded on.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing valve circuit was shorted high, shorted low, or open.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, cycle the keyswitch from OFF to ON.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the diesel exhaust fluid dosing valve
  • Signal circuit open or shorted to ground.
  • Return circuit open or shorted.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5833.

Last Modified: 18-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Pressure 3 Sensor Circuit - Current Below Normal or Open Circuit

FAULT CODE 5834

Aftertreatment 2 Diesel Exhaust Fluid Pressure 3 Sensor Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5834 PID: SPN: 7491 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Pressure 3 Sensor Circuit - Current Below Normal or Open Circuit. A circuit error has been detected in the aftertreatment diesel exhaust fluid pressure sensor circuit. | None on performance.
Aftertreatment 2 Diesel Exhaust Fluid Pressure 3 Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the ECM. When the engine control module (ECM) commands DEF dosing, the ECM sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The aftertreatment diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure sensor circuit was shorted high, shorted low, or open.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes for this fault include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing valve
Refer to Troubleshooting Fault Code 5834.

Last Modified: 18-May-2016


Engine Diesel Fuel Metering Valve Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 5862

Engine Diesel Fuel Metering Valve Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5862 PID: SPN: 7029 FMI: 3/3 LAMP: Amber SRT: | Engine Diesel Fuel Metering Valve Position Sensor Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected on the position signal circuit. | Possible reduced engine performance.
Fuel Metering Valve Circuit

Circuit Description

The fuel metering valve is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The ECM supplies 24-VDC to the fuel metering valve. The fuel metering valve controls fuel flow into the high pressure fuel pump by changing valve position based on ECM command. The primary position command is sent by the ECM over the J1939 data link. A PWM signal is used as the backup position command. The fuel metering valve performs internal diagnostics and reports malfunctions back to the ECM.

Component Location

The fuel metering valve is mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the position signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Position signal circuit shorted to voltage source.
  • A malfunctioning fuel metering valve.
Refer to Troubleshooting Fault Code 5862.

Last Modified: 03-May-2016


Engine Diesel Fuel Metering Valve Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5863

Engine Diesel Fuel Metering Valve Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5863 PID: SPN: 7029 FMI: 4/4 LAMP: Amber SRT: | Engine Diesel Fuel Metering Valve Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected on the position signal circuit. | Possible reduced engine performance.
Fuel Metering Valve Circuit

Circuit Description

The fuel metering valve is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The ECM supplies 24-VDC to the fuel metering valve. The fuel metering valve controls fuel flow into the high pressure fuel pump by changing valve position based on ECM command. The primary position command is sent by the ECM over the J1939 data link. A PWM signal is used as the backup position command. The fuel metering valve performs internal diagnostics and reports malfunctions back to the ECM.

Component Location

The fuel metering valve is mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the position signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Position signal circuit open or shorted to ground.
  • A malfunctioning fuel metering valve.
Refer to Troubleshooting Fault Code 5863.

Last Modified: 03-May-2016


Other ECUs Have Reported Diagnostic Trouble Codes Affecting Operation - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 5875

Other ECUs Have Reported Diagnostic Trouble Codes Affecting Operation - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5875 PID: SPN: 1484 FMI: 0/0 LAMP: Red SRT: | Other ECUs Have Reported Diagnostic Trouble Codes Affecting Operation - Data Valid But Above Normal Operating Range - Most Severe Level. At least one secondary engine control module (ECM) has an active red lamp fault code. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine control modules use the J1939 data link 2 for communication between modules.

Component Location

The Engine Control Modules (ECMs) are mounted at the front of the engine above the gear housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The primary engine control module (ECM) detected at least one secondary ECM has an active red lamp fault code.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once all red lamp fault codes in secondary ECMs are inactive.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This is an information only fault code that will only become active if other fault codes are active in the secondary ECM(s).

Refer to Troubleshooting Fault Code 5875.

Last Modified: 16-Dec-2015


Other ECUs Have Reported Diagnostic Trouble Codes Affecting Operation - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 5876

Other ECUs Have Reported Diagnostic Trouble Codes Affecting Operation - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5876 PID: SPN: 1484 FMI: 0/16 LAMP: Amber SRT: | Other ECUs Have Reported Diagnostic Trouble Codes Affecting Operation - Data Valid But Above Normal Operating Range - Moderately Severe Level. At least one secondary engine control module (ECM) has an active amber lamp fault code. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine control modules use the J1939 data link 2 for communication between modules.

Component Location

The Engine Control Modules (ECMs) are mounted at the front of the engine above the gear housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The primary engine control module (ECM) detected at least one secondary ECM has an active amber lamp fault code.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once all amber lamp fault codes in secondary ECMs are inactive.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This is an information only fault code that will only become active if other fault codes are active in the secondary ECM(s).

Refer to Troubleshooting Fault Code 5876.

Last Modified: 16-Dec-2015


Other ECUs Have Reported Diagnostic Trouble Codes Affecting Operation - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 5877

Other ECUs Have Reported Diagnostic Trouble Codes Affecting Operation - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5877 PID: SPN: 1484 FMI: 0/15 LAMP: Maintenance SRT: | Other ECUs Have Reported Diagnostic Trouble Codes Affecting Operation - Data Valid But Above Normal Operating Range - Least Severe Level. At least one secondary engine control module (ECM) has an active maintenance severity fault code. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine control modules use the J1939 data link 2 for communication between modules.

Component Location

The Engine Control Modules (ECMs) are mounted at the front of the engine above the gear housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The primary engine control module (ECM) detected at least one secondary ECM has an active maintenance severity fault code.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once all maintenance severity fault codes in secondary ECMs are inactive.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This is an information only fault code that will only become active if other fault codes are active in the secondary ECM(s).

Refer to Troubleshooting Fault Code 5877.

Last Modified: 16-Dec-2015


Aftertreatment 1 SCR System Hydrocarbon - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 5887

Aftertreatment 1 SCR System Hydrocarbon - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5887 PID: SPN: 7934 FMI: 0/15 LAMP: Maintenance SRT: | Aftertreament 1 SCR System Hydrocarbon - Data Valid But Above Normal Operating Range - Least Severe Level. Aftertreatment selective catalyst reduction (SCR) system cleaning is required. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) monitors engine operating conditions and SCR temperature over time to determine the condition of the SCR catalyst.

Component Location

The SCR catalyst is located in the SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected high levels of unwanted hydrocarbon accumulation in the aftertreatment SCR catalyst.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once the accumulation estimates are below the calibrated limits.

Shop Talk

When hydrocarbon accumulation estimates are above a calibrated threshold indicating that an aftertreatment SCR system cleaning is necessary, the engine control module (ECM) will communicate the need to the original equipment manufacturer (OEM) controller, and the OEM controller will automatically command the load necessary to perform an SCR system cleaning. This fault code is an information only fault code indicating that the system was requesting an active aftertreatment SCR system cleaning, but automatic loading was not completed.

Refer to Troubleshooting Fault Code 5887.

Last Modified: 10-Nov-2016


Aftertreatment 1 SCR System Hydrocarbon - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 5888

Aftertreatment 1 SCR System Hydrocarbon - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5888 PID: SPN: 7934 FMI: 0/16 LAMP: Amber SRT: | Aftertreament 1 SCR System Hydrocarbon - Data Valid But Above Normal Operating Range - Moderately Severe Level. Aftertreatment selective catalytic reduction (SCR) system cleaning is required. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) monitors engine operating conditions and SCR temperature over time to determine the condition of the SCR catalyst.

Component Location

The SCR catalyst is located in the SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected high levels of unwanted hydrocarbon accumulation in the aftertreatment SCR catalyst.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once the accumulation estimates are below the calibrated limits.

Shop Talk

When hydrocarbon accumulation estimates are above a calibrated threshold indicating that an aftertreatment SCR system cleaning is necessary, the engine control module (ECM) will communicate the need to the original equipment manufacturer (OEM) controller, and the OEM controller will automatically command the load necessary to perform an SCR system cleaning. This fault code is an information only fault code indicating that the system was requesting an active aftertreatment SCR system cleaning, but automatic loading was not completed.

Refer to Troubleshooting Fault Code 5888.

Last Modified: 10-Nov-2016


Aftertreatment 1 SCR System Hydrocarbon - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 5889

Aftertreatment 1 SCR System Hydrocarbon - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5889 PID: SPN: 7934 FMI: 0/0 LAMP: Red SRT: | Aftertreatment selective catalytic reduction (SCR) system cleaning is required. | Engine power derate.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) monitors engine operating conditions and SCR temperature over time to determine the condition of the SCR catalyst.

Component Location

The SCR catalyst is located in the SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected high levels of unwanted hydrocarbon accumulation in the aftertreatment SCR catalyst.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Engine will automatically shut down after 1 hour of operation with this fault code active.

Engine starting will be prevented after 10 starts with this fault code active.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once the accumulation estimates are below the calibrated limits.

Shop Talk

When hydrocarbon accumulation estimates are above a calibrated threshold indicating that an aftertreatment SCR system cleaning is necessary, the engine control module (ECM) will communicate the need to the original equipment manufacturer (OEM) controller, and the OEM controller will automatically command the load necessary to perform an SCR system cleaning. This fault code is an information only fault code indicating that the system was requesting an active aftertreatment SCR system cleaning, but automatic loading was not completed.

Refer to Troubleshooting Fault Code 5889.

Last Modified: 23-Oct-2018


Aftertreatment 2 SCR System Hydrocarbon - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 5891

Aftertreatment 2 SCR System Hydrocarbon - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5891 PID: SPN: 7935 FMI: 0/15 LAMP: Maintenance SRT: | Aftertreatment 2 SCR System Hydrocarbon - Data Valid But Above Normal Operating Range - Least Severe Level. Aftertreatment selective catalyst reduction (SCR) system cleaning is required. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) monitors engine operating conditions and SCR temperature over time to determine the condition of the SCR catalyst.

Component Location

The SCR catalyst is located in the SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code can be activated for the following reasons:

  • The ECM detected high levels of hydrocarbon adsorption in the SCR catalyst.
  • The ECM detected high levels of coke accumulation in the SCR catalyst.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once the accumulation estimates are below the calibrated limits.

Shop Talk

When hydrocarbon accumulation estimates are above a calibrated threshold indicating that an aftertreatment SCR system cleaning is necessary, the engine control module (ECM) will communicate the need to the original equipment manufacturer (OEM) controller, and the OEM controller will automatically command the load necessary to perform an SCR system cleaning. This fault code is an information only fault code indicating that the system was requesting an active aftertreatment SCR system cleaning, but automatic loading was not completed.

Refer to Troubleshooting Fault Code 5891.

Last Modified: 10-Nov-2016


Aftertreatment 2 SCR System Hydrocarbon - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 5892

Aftertreatment 2 SCR System Hydrocarbon - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5892 PID: SPN: 7935 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment 2 SCR System Hydrocarbon - Data Valid But Above Normal Operating Range - Moderately Severe Level. Aftertreatment selective catalyst reduction (SCR) system cleaning is required. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) monitors engine operating conditions and SCR temperature over time to determine the condition of the SCR catalyst.

Component Location

The SCR catalyst is located in the exhaust system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code can be activated for the following reasons:

  • The ECM detected high levels of hydrocarbon adsorption in the SCR catalyst.
  • The ECM detected high levels of coke accumulation in the SCR catalyst.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once the accumulation estimates are below the calibrated limits.

Shop Talk

When hydrocarbon accumulation estimates are above a calibrated threshold indicating that an aftertreatment SCR system cleaning is necessary, the engine control module (ECM) will communicate the need to the original equipment manufacturer (OEM) controller, and the OEM controller will automatically command the load necessary to perform an SCR system cleaning. This fault code is an information only fault code indicating that the system was requesting an active aftertreatment SCR system cleaning, but automatic loading was not completed.

Refer to Troubleshooting Fault Code 5892.

Last Modified: 10-Nov-2016


Aftertreatment 2 SCR System Hydrocarbon - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 5893

Aftertreatment 2 SCR System Hydrocarbon - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5893 PID: SPN: 7935 FMI: 0/0 LAMP: Red SRT: | Aftertreatment 2 SCR System Hydrocarbon - Data Valid But Above Normal Operating Range - Most Severe Level. Aftertreatment selective catalyst reduction (SCR) system cleaning is required. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) monitors engine operating conditions and SCR temperature over time to determine the condition of the SCR catalyst.

Component Location

The SCR catalyst is located in the exhaust system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code can be activated for the following reasons:

  • The ECM detected high levels of hydrocarbon adsorption in the SCR catalyst.
  • The ECM detected high levels of coke accumulation in the SCR catalyst.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Engine will automatically shut down after 1 hour of operation with this fault code active.
  • Engine starting will be prevented after 10 starts with this fault code active.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once the accumulation estimates are below the calibrated limits.

Shop Talk

When hydrocarbon accumulation estimates are above a calibrated threshold indicating that an aftertreatment SCR system cleaning is necessary, the engine control module (ECM) will communicate the need to the original equipment manufacturer (OEM) controller, and the OEM controller will automatically command the load necessary to perform an SCR system cleaning. This fault code is an information only fault code indicating that the system was requesting an active aftertreatment SCR system cleaning, but automatic loading was not completed.

Refer to Troubleshooting Fault Code 5893.

Last Modified: 10-Nov-2016


SAE J1939 Data Link 2 Engine Network - Special Instructions

FAULT CODE 5949

SAE J1939 Data Link 2 Engine Network - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5949 PID: SPN: 1231 FMI: 14/14 LAMP: Red SRT: | SAE J1939 Data Link 2 Engine Network - Special Instructions. The ECM has diagnosed that it cannot communicate with the other ECMs for a prolonged period of time. | Engine will shut down.
J1939 Data Link 2 Circuit

Circuit Description

The engine control modules use the J1939 data link 2 for communication between modules.

Component Location

The SAE J1939 data link 2 is located in the engine harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM has diagnosed that it cannot communicate with the other ECMs for a prolonged period of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes for this fault code include:

  • Electrical problems with the SAE J1939 data link wiring such as grounded, shorted, or open circuits
Refer to Troubleshooting Fault Code 5949.

Last Modified: 03-May-2016


Engine Shut Down Hot - Condition Exists

FAULT CODE 611

Engine Shut Down Hot - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 611 PID: S116 SPN: 1383 FMI: 11/31 LAMP: None SRT: | Engine Shut Down Hot - Condition Exists. The engine was shut down with the keyswitch before proper engine cool down, resulting in a load factor above the maximum shut down threshold. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) uses inputs from the engine coolant temp sensor, engine speed sensor, keyswitch, and calculated engine torque for this diagnostic.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected engine speed is 0 within 15 seconds of the engine operating under a load.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Cycle the keyswitch to the ON position for 30 seconds, then cycle the keyswitch to the OFF position for 30 seconds. Start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This is an information only fault code that will only become active if the engine was shut down with the keyswitch before proper engine cooldown.

Refer to Troubleshooting Fault Code 611.

Last Modified: 05-May-2017


Exhaust Gas Temperature Deviation Low for Cylinder 1 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 621

Exhaust Gas Temperature Deviation Low for Cylinder 1 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 621 PID: SPN: 1323 FMI: 1/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 1 - Data Valid But Below Normal Operating Range - Least Severe Level. Exhaust gas temperature is lower than the engine average. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60C [140F].
  • Net engine torque is above a calibrated threshold.
  • The engine speed is greater than the calibrated threshold.
  • The exhaust gas temperature sensor reading is less than the engine average by a calibrated amount.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 621.

Last Modified: 11-Dec-2015


Exhaust Gas Temperature Deviation Low for Cylinder 3 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 622

Exhaust Gas Temperature Deviation Low for Cylinder 3 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 622 PID: SPN: 1325 FMI: 1/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 3 - Data Valid But Below Normal Operating Range - Least Severe Level. Exhaust gas temperature is lower than the engine average. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60C [140F].
  • Net engine torque is above a calibrated threshold.
  • The engine speed is greater than the calibrated threshold.
  • The exhaust gas temperature sensor reading is less than engine average by a calibrated amount continuously for a calibrated time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 622.

Last Modified: 11-Dec-2015


Exhaust Gas Temperature Deviation Low for Cylinder 5 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 623

Exhaust Gas Temperature Deviation Low for Cylinder 5 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 623 PID: SPN: 1327 FMI: 1/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 5 - Data Valid But Below Normal Operating Range - Least Severe Level. Exhaust gas temperature is lower than the engine average. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60C [140F].
  • Net engine torque is above a calibrated threshold.
  • The engine speed is greater than the calibrated threshold.
  • The exhaust gas temperature sensor reading is less than the engine average by a calibrated amount.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 623.

Last Modified: 11-Dec-2015


Exhaust Gas Temperature Deviation Low for Cylinder 7 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 624

Exhaust Gas Temperature Deviation Low for Cylinder 7 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 624 PID: SPN: 1329 FMI: 1/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 7 - Data Valid But Below Normal Operating Range - Least Severe Level. Exhaust gas temperature is lower than the engine average. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60C [140F].
  • Net engine torque is above a calibrated threshold.
  • The engine speed is greater than the calibrated threshold.
  • The exhaust gas temperature sensor reading is less than the engine average by a calibrated amount.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 624.

Last Modified: 11-Dec-2015


Exhaust Gas Temperature Deviation Low for Cylinder 9 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 625

Exhaust Gas Temperature Deviation Low for Cylinder 9 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 625 PID: SPN: 1331 FMI: 1/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 9 - Data Valid But Below Normal Operating Range - Least Severe Level. Exhaust gas temperature is lower than the engine average. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60C [140F].
  • Net engine torque is above a calibrated threshold.
  • The engine speed is greater than the calibrated threshold.
  • The exhaust gas temperature sensor reading is less than the engine average by a calibrated amount.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 625.

Last Modified: 11-Dec-2015


Fault Code Path Selection

FAULT CODE 6253
Fault Code Path Selection

Is the ECM source address 00? | Go to 402-fc6253sa00
Is the ECM source address 01? | Go to 402-fc6253sa01
Is the ECM source address 144? | Go to 402-fc6253sa144
Is the ECM source address 186? | Go to 402-fc6253sa186

Last Modified: 20-Apr-2016


Control Module Identification Input State Error - Special Instructions

FAULT CODE 6253 (sa00)

Control Module Identification Input State Error - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6253 (sa00) PID: SPN: 1563 FMI: 14/14 LAMP: Red SRT: | Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect. The control module identification input state is incorrect. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Control Module Identification Circuit

Circuit Description

The engine control module (ECM) uses the control module identification circuit to verify its location in the harness. The combination of control module identification signal pins that are connected to return allow the ECM to make this determination.

Component Location

The control module identification circuit is located in the harness.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

The ECM calibration does not match the control module identification input.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Injector fueling will be disabled for the affected ECMs.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Duplicate or incorrect ECM calibrations downloaded to the ECM(s).
  • Two or more ECMs installed in the wrong location.
Refer to Troubleshooting Fault Code 6253 (sa00).

Last Modified: 03-May-2016


Control Module Identification Input State Error - Special Instructions

FAULT CODE 6253 (sa01)

Control Module Identification Input State Error - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6253 (sa01) PID: SPN: 1563 FMI: 14/14 LAMP: Red SRT: | Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect. The control module identification input state is incorrect. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Control Module Identification Circuit

Circuit Description

The engine control module (ECM) uses the control module identification circuit to verify its location in the harness. The combination of control module identification signal pins that are connected to return allow the ECM to make this determination.

Component Location

The control module identification circuit is located in the harness.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

The ECM calibration does not match the control module identification input.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Injector fueling will be disabled for the affected ECMs.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Duplicate or incorrect ECM calibrations downloaded to the ECM(s).
  • Two or more ECMs installed in the wrong location.
Refer to Troubleshooting Fault Code 6253 (sa01).

Last Modified: 03-May-2016


Control Module Identification Input State Error - Special Instructions

FAULT CODE 6253 (sa144)

Control Module Identification Input State Error - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6253 (sa144) PID: SPN: 1563 FMI: 14/14 LAMP: Red SRT: | Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect. The control module identification input state is incorrect. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Control Module Identification Circuit

Circuit Description

The engine control module (ECM) uses the control module identification circuit to verify its location in the harness. The combination of control module identification signal pins that are connected to return allow the ECM to make this determination.

Component Location

The control module identification circuit is located in the harness.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

The ECM calibration does not match the control module identification input.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Injector fueling will be disabled for the affected ECMs.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Duplicate or incorrect ECM calibrations downloaded to the ECM(s).
  • Two or more ECMs installed in the wrong location.
Refer to Troubleshooting Fault Code 6253 (sa144).

Last Modified: 03-May-2016


Control Module Identification Input State Error - Special Instructions

FAULT CODE 6253 (sa186)

Control Module Identification Input State Error - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6253 (sa186) PID: SPN: 1563 FMI: 14/14 LAMP: Red SRT: | Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect. The control module identification input state is incorrect. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Control Module Identification Circuit

Circuit Description

The engine control module (ECM) uses the control module identification circuit to verify its location in the harness. The combination of control module identification signal pins that are connected to return allow the ECM to make this determination.

Component Location

The control module identification circuit is located in the harness.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

The ECM calibration does not match the control module identification input.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Injector fueling will be disabled for the affected ECMs.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Duplicate or incorrect ECM calibrations downloaded to the ECM(s).
  • Two or more ECMs installed in the wrong location.
Refer to Troubleshooting Fault Code 6253 (sa186).

Last Modified: 03-May-2016


Exhaust Gas Temperature Deviation Low for Cylinder 11 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 626

Exhaust Gas Temperature Deviation Low for Cylinder 11 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 626 PID: SPN: 1333 FMI: 1/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 11 - Data Valid But Below Normal Operating Range - Least Severe Level. Exhaust gas temperature is lower than the engine average. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60C [140F].
  • Net engine torque is above a calibrated threshold.
  • The engine speed is greater than the calibrated threshold.
  • The exhaust gas temperature sensor reading is less than the engine average by a calibrated amount.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 626.

Last Modified: 11-Dec-2015


Exhaust Gas Temperature Deviation Low for Cylinder 13 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 627

Exhaust Gas Temperature Deviation Low for Cylinder 13 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 627 PID: SPN: 1335 FMI: 1/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 13 - Data Valid But Below Normal Operating Range - Least Severe Level. Exhaust gas temperature is lower than the engine average. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60C [140F].
  • Net engine torque is above a calibrated threshold.
  • The engine speed is greater than the calibrated threshold.
  • The exhaust gas temperature sensor reading is less than the engine average by a calibrated amount.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 627.

Last Modified: 11-Dec-2015


Exhaust Gas Temperature Deviation Low for Cylinder 15 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 628

Exhaust Gas Temperature Deviation Low for Cylinder 15 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 628 PID: SPN: 1337 FMI: 1/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 15 - Data Valid But Below Normal Operating Range - Least Severe Level. Exhaust gas temperature is lower than the engine average. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60C [140F].
  • Net engine torque is above a calibrated threshold.
  • The engine speed is greater than the calibrated threshold.
  • The exhaust gas temperature sensor reading is less than the engine average by a calibrated amount.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 628.

Last Modified: 11-Dec-2015


Exhaust Gas Temperature Deviation Low for Cylinder 2 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 631

Exhaust Gas Temperature Deviation Low for Cylinder 2 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 631 PID: SPN: 1324 FMI: 1/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 2 - Data Valid But Below Normal Operating Range - Least Severe Level. Exhaust gas temperature is lower than the engine average. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60C [140F].
  • Net engine torque is above a calibrated threshold.
  • The engine speed is greater than the calibrated threshold.
  • The exhaust gas temperature sensor reading is less than the engine average by a calibrated amount.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 631.

Last Modified: 11-Dec-2015


Exhaust Gas Temperature Deviation Low for Cylinder 4 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 632

Exhaust Gas Temperature Deviation Low for Cylinder 4 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 632 PID: SPN: 1326 FMI: 1/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 4 - Data Valid But Below Normal Operating Range - Least Severe Level. Exhaust gas temperature is lower than the engine average. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60C [140F].
  • Net engine torque is above a calibrated threshold.
  • The engine speed is greater than the calibrated threshold.
  • The exhaust gas temperature sensor reading is less than the engine average by a calibrated amount.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 632.

Last Modified: 11-Dec-2015


Exhaust Gas Temperature Deviation Low for Cylinder 6 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 633

Exhaust Gas Temperature Deviation Low for Cylinder 6 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 633 PID: SPN: 1328 FMI: 1/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 6 - Data Valid But Below Normal Operating Range - Least Severe Level. Exhaust gas temperature is lower than the engine average. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60C [140F].
  • Net engine torque is above a calibrated threshold.
  • The engine speed is greater than the calibrated threshold.
  • The exhaust gas temperature sensor reading is less than the engine average by a calibrated amount.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 633.

Last Modified: 11-Dec-2015


Exhaust Gas Temperature Deviation Low for Cylinder 8 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 634

Exhaust Gas Temperature Deviation Low for Cylinder 8 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 634 PID: SPN: 1330 FMI: 1/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 8 - Data Valid But Below Normal Operating Range - Least Severe Level. Exhaust gas temperature is lower than the engine average. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60C [140F].
  • Net engine torque is above a calibrated threshold.
  • The engine speed is greater than the calibrated threshold.
  • The exhaust gas temperature sensor reading is less than the engine average by a calibrated amount.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 634.

Last Modified: 11-Dec-2015


Exhaust Gas Temperature Deviation Low for Cylinder 10 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 635

Exhaust Gas Temperature Deviation Low for Cylinder 10 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 635 PID: SPN: 1332 FMI: 1/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 10 - Data Valid But Below Normal Operating Range - Least Severe Level. Exhaust gas temperature is lower than the engine average. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60C [140F].
  • Net engine torque is above a calibrated threshold.
  • The engine speed is greater than the calibrated threshold.
  • The exhaust gas temperature sensor reading is less than the engine average by a calibrated amount.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 635.

Last Modified: 11-Dec-2015


Exhaust Gas Temperature Deviation Low for Cylinder 12 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 636

Exhaust Gas Temperature Deviation Low for Cylinder 12 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 636 PID: SPN: 1334 FMI: 1/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 12 - Data Valid But Below Normal Operating Range - Least Severe Level. Exhaust gas temperature is lower than the engine average. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60C [140F].
  • Net engine torque is above a calibrated threshold.
  • The engine speed is greater than the calibrated threshold.
  • The exhaust gas temperature sensor reading is less than the engine average by a calibrated amount.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 636.

Last Modified: 11-Dec-2015


Aftertreatment 2 Outlet NOx Sensor - Abnormal Rate of Change

FAULT CODE 6369

Aftertreatment 2 Outlet NOx Sensor - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6369 PID: SPN: 3265 FMI: 10/10 LAMP: Amber SRT: | Aftertreatment 2 Outlet NOx Sensor Circuit - Abnormal Rate of Change. The aftertreatment outlet NOx sensor reading is not valid. | None on performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment 2 outlet NOx sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment 2 outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to ECM 2 using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment 2 outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment 2 outlet NOx sensor is mounted in the aftertreatment 2 SCR outlet.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and the aftertreatment SCR outlet temperature is above a calibrated threshold for a calibrated period of time.

Conditions for Setting the Fault Codes

The aftertreatment outlet NOx sensor reading was not valid.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code sets when the aftertreatment outlet NOx sensor indicates to the ECM that it is not providing valid data.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 6369.

Last Modified: 03-May-2016


Exhaust Gas Temperature Deviation Low for Cylinder 14 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 637

Exhaust Gas Temperature Deviation Low for Cylinder 14 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 637 PID: SPN: 1336 FMI: 1/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 14 - Data Valid But Below Normal Operating Range - Least Severe Level. Exhaust gas temperature is lower than the engine average. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60C [140F].
  • Net engine torque is above a calibrated threshold.
  • The engine speed is greater than the calibrated threshold.
  • The exhaust gas temperature sensor reading is less than the engine average by a calibrated amount.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 637.

Last Modified: 11-Dec-2015


Aftertreatment 2 Diesel Exhaust Fluid Doser Heating Mode Request - Condition Exists

FAULT CODE 6373

Aftertreatment 2 Diesel Exhaust Fluid Doser Heating Mode Request - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6373 PID: SPN: 4406 FMI: 11/31 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Doser Heating Mode Request - Condition Exists. The engine control module (ECM) has detected conditions that could overheat the dosing valve. | None on performance.
Aftertreatment 2 Diesel Exhaust Fluid Valve

Circuit Description

The ECM continuously monitors the engine's fault code status and other sensor inputs to determine if action needs to be taken to prevent aftertreatment diesel exhaust fluid dosing valve damage.

Component Location

The aftertreatment diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected conditions that could overheat the aftertreatment diesel exhaust fluid dosing valve.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once the DEF system is able to sucessfully prime or maintain operating pressure.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This fault code is information ONLY, make sure that critical dosing related fault codes that are presently active in the ECM are addressed as quickly as possible.

Refer to Troubleshooting Fault Code 6373.

Last Modified: 10-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Pressure 1 Sensor Circuit - Current Below Normal or Open Circuit

FAULT CODE 6378

Aftertreatment 2 Diesel Exhaust Fluid Pressure 1 Sensor Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6378 PID: SPN: 4387 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Pressure 1 Sensor Circuit - Current Below Normal or Open Circuit. A circuit error has been detected in the aftertreatment diesel exhaust fluid pressure sensor circuit. | None on performance.
Aftertreatment 2 Diesel Exhaust Fluid Pressure 1 Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the ECM. When the engine control module (ECM) commands DEF dosing, the ECM sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The aftertreatment diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure sensor circuit was shorted high, shorted low, or open.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes for this fault include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing valve
Refer to Troubleshooting Fault Code 6378.

Last Modified: 18-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 2 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 6379

Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 2 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6379 PID: SPN: 6324 FMI: 7/7 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 2 - Mechanical System Not Responding or Out of Adjustment. A mechanical malfunction has been detected in the DEF dosing valve. | None on performance.
Aftertreatment Diesel Exhaust Fluid Dosing Valve Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the ECM. When the engine control module (ECM) commands DEF dosing, the ECM sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing valve is being commanded on.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing valve is mechanically stuck.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing valve

Contamination of the DEF can be a possible cause for this fault code.

Refer to Troubleshooting Fault Code 6379.

Last Modified: 03-May-2016


Exhaust Gas Temperature Deviation Low for Cylinder 16 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 638

Exhaust Gas Temperature Deviation Low for Cylinder 16 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 638 PID: SPN: 1338 FMI: 1/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 16 - Data Valid But Below Normal Operating Range - Least Severe Level. Exhaust gas temperature is lower than the engine average. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60C [140F].
  • Net engine torque is above a calibrated threshold.
  • The engine speed is greater than the calibrated threshold.
  • The exhaust gas temperature sensor reading is less than the engine average by a calibrated amount.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 638.

Last Modified: 11-Dec-2015


Aftertreatment 2 Diesel Exhaust Fluid Dosing Valve 2 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 6381

Aftertreatment 2 Diesel Exhaust Fluid Dosing Valve 2 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6381 PID: SPN: 6325 FMI: 7/7 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Dosing Valve 2 - Mechanical System Not Responding or Out of Adjustment. A mechanical malfunction has been detected in the DEF dosing valve. | None on performance.
Aftertreatment Diesel Exhaust Fluid Dosing Valve Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the ECM. When the engine control module (ECM) commands DEF dosing, the ECM sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing valve is being commanded on.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing valve is mechanically stuck.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing valve

Contamination of the DEF can be a possible cause for this fault code.

Refer to Troubleshooting Fault Code 3568.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 3 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 6382

Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 3 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6382 PID: SPN: 7488 FMI: 7/7 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 3 - Mechanical System Not Responding or Out of Adjustment. A mechanical malfunction has been detected in the DEF dosing valve. | None on performance.
Aftertreatment Diesel Exhaust Fluid Dosing Valve Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the ECM. When the engine control module (ECM) commands DEF dosing, the ECM sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing valve is being commanded on.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing valve is mechanically stuck.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing valve

Contamination of the DEF can be a possible cause for this fault code.

Refer to Troubleshooting Fault Code 6382.

Last Modified: 03-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Dosing Valve 3 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 6383

Aftertreatment 2 Diesel Exhaust Fluid Dosing Valve 3 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6383 PID: SPN: 7494 FMI: 7/7 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Dosing Valve 3 - Mechanical System Not Responding or Out of Adjustment. A mechanical malfunction has been detected in the DEF dosing valve. | None on performance.
Aftertreatment Diesel Exhaust Fluid Dosing Valve Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the ECM. When the engine control module (ECM) commands DEF dosing, the ECM sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing valve is being commanded on.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing valve is mechanically stuck.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid dosing unit and associated dosing valve are disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing valve

Contamination of the DEF can be a possible cause for this fault code.

Refer to Troubleshooting Fault Code 6383.

Last Modified: 03-May-2016


Aftertreatment 1 Diesel Exhaust Fluid Doser 3 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 6385

Aftertreatment 1 Diesel Exhaust Fluid Doser 3 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6385 PID: SPN: 7486 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Doser 3 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. Diesel exhaust fluid dosing temperature has exceeded the warning limit. | None on performance.
Diesel Exhaust Fluid Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the ECM. When the engine control module (ECM) commands DEF dosing, the ECM sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid dosing temperature sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing temperature was above the warning level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing valve temperature sensor.
Refer to Troubleshooting Fault Code 6385.

Last Modified: 03-May-2016


Aftertreatment 2 Diesel Exhaust Fluid Doser 3 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 6387

Aftertreatment 2 Diesel Exhaust Fluid Doser 3 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6387 PID: SPN: 7492 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment 2 Diesel Exhaust Fluid Doser 3 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. Diesel exhaust fluid dosing temperature has exceeded the warning limit. | None on performance.
Diesel Exhaust Fluid Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the ECM. When the engine control module (ECM) commands DEF dosing, the ECM sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid dosing temperature sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing temperature was above the warning level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing valve temperature sensor.
Refer to Troubleshooting Fault Code 6387.

Last Modified: 03-May-2016


Aftertreatment SCR Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 6517

Aftertreatment SCR Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6517 PID: SPN: 4364 FMI: 1/17 LAMP: None SRT: | Aftertreatment SCR Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Least Severe Level. NOx conversion across the SCR catalyst is too low. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) monitors the NOx concentration in the engine's exhaust gases using an aftertreatment intake NOx sensor and an aftertreatment outlet NOx sensor. By comparing these two values, the ECM is able to determine the conversion efficiency of the SCR catalyst and dosing system.

Component Location

The SCR catalyst is located in the SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the NOx conversion across the SCR catalyst was less than expected.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

It is necessary to use the "Reset All Faults" command in INSITE™ electronic service tool to clear this fault and extinguish the amber CHECK ENGINE lamp.

Shop Talk

Troubleshoot all other active NOx sensor and SCR dosing system related fault codes before this fault.

Possible causes of this fault code include:

  • Malfunctioning aftertreatment diesel exhaust fluid dosing system.
  • Exhaust system leaks
  • Malfunctioning SCR catalyst
  • Degraded, diluted, or incorrect diesel exhaust fluid
  • Diesel exhaust fluid deposits in the aftertreatment system.
Refer to Troubleshooting Fault Code 6517.

Last Modified: 18-May-2017


Engine Diesel Fuel Metering Valve Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 6573

Engine Diesel Fuel Metering Valve Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6573 PID: SPN: 7028 FMI: 0/16 LAMP: None SRT: | Engine Diesel Fuel Metering Valve Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. The Engine Control Module (ECM) has been alerted that the Fuel Metering Valve is above a calibrated temperature threshold. | Possible reduced engine performance.
Fuel Metering Valve

Circuit Description

The fuel metering valve is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The ECM supplies 24-VDC to the fuel metering valve. The fuel metering valve controls fuel flow into the high pressure fuel pump by changing valve position based on ECM command. The primary position command is sent by the ECM over the J1939 data link. A PWM signal is used as the backup position command. The fuel metering valve performs internal diagnostics and reports malfunctions back to the ECM.

Component Location

The fuel metering valve is located on the high pressure fuel pump.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in the ON position.

Conditions for Setting the Fault Codes

The fuel metering valve has diagnosed that the internal temperature is above a calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

Possible causes for this fault code include:

  • A malfunctioning fuel metering valve.
Refer to Troubleshooting Fault Code 6573.

Last Modified: 10-May-2016


Engine Diesel Fuel Metering Valve Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 6574

Engine Diesel Fuel Metering Valve Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6574 PID: SPN: 7028 FMI: 0/0 LAMP: Amber SRT: | Engine Diesel Fuel Metering Valve Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. The Engine Control Module (ECM) has been alerted that the Fuel Metering Valve is above a calibrated temperature threshold. | Possible reduced engine performance.
Fuel Metering Valve Circuit

Circuit Description

The fuel metering valve is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The ECM supplies 24-VDC to the fuel metering valve. The fuel metering valve controls fuel flow into the high pressure fuel pump by changing valve position based on ECM command. The primary position command is sent by the ECM over the J1939 data link. A PWM signal is used as the backup position command. The fuel metering valve performs internal diagnostics and reports malfunctions back to the ECM.

Component Location

The fuel metering valve is located on the high pressure fuel pump.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in the ON position.

Conditions for Setting the Fault Codes

The fuel metering valve has diagnosed that the internal temperature is above a calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes for this fault code include:

  • A malfunctioning fuel metering valve.
Refer to Troubleshooting Fault Code 6574.

Last Modified: 10-May-2016


Engine Fuel Leakage - Condition Exists

FAULT CODE 6594

Engine Fuel Leakage - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6594 PID: SPN: 1239 FMI: 11/31 LAMP: Amber SRT: | Engine Fuel Leakage - Condition Exists. The engine control module (ECM) has diagnosed a fuel leak indicator tank level switch has changed from closed to open, indicating a fuel leak is present. | None on performance.
Fuel Leak Indicator Tank Circuit

Circuit Description

The fuel leak indicator tank uses a float switch to measure the amount of fuel leaking from the injector supply lines.

Component Location

The fuel leak indicator tank is mounted to the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The engine control module (ECM) has diagnosed a fuel leak indicator tank level switch has changed from closed to open, indicating a fuel leak is present.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, cycle the keyswitch from OFF to ON.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes for this fault code include:

  • A leaking fuel injector supply line.
  • A leaking fuel rail pressure sensor.
Refer to Troubleshooting Fault Code 6594.

Last Modified: 19-May-2016


Engine Speed - Root Cause Not Known

FAULT CODE 6595

Engine Speed - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6595 PID: SPN: 190 FMI: 11/11 LAMP: None SRT: | Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect. At least one of the engine control modules has lost the camshaft and crankshaft position sensor signals. | Possible reduced engine performance.
Crankshaft Position Sensor Circuit
Camshaft Position Sensor Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply and a return circuit to the position sensors. As holes drilled in the flywheel or slots in the front of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM uses this signal to determine engine speed. Offset spacing of the drillings or slots indicate to the ECM the position of the engine.

Component Location

The camshaft position sensor is located in the gear cover.

The crankshaft position sensor is located on the left bank side of the engine in the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

At least one engine control module (ECM) has lost both the camshaft and crankshaft position sensor signals while another ECM is still detecting both signals.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open in both engine position sensor circuits to one ECM.
Refer to Troubleshooting Fault Code 6595.

Last Modified: 11-Dec-2015


Fuel Pump Priming Status - Special Instructions

FAULT CODE 6633

Fuel Pump Priming Status - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6633 PID: SPN: 4083 FMI: 14/14 LAMP: Amber SRT: | The ECM has diagnosed that the fuel supply pump failed to prime after a calibrated time limit. | Engine may not start.
Fuel Supply Pump Circuit

Circuit Description

The engine fuel supply pump is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The engine fuel supply pump maintains appropriate supply fuel pressure, performs internal and system diagnostics and reports malfunctions back to the ECM. The ECM supplies 24-VDC to the supply pump control unit. The OEM provides supply voltage to the engine fuel supply pump motor. The fuel delivery pressure signal is wired in parallel between the ECM and engine fuel supply pump.

Component Location

The engine fuel supply pump is located on the left side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM has diagnosed that the fuel supply pump failed to prime after a calibrated time limit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The engine will not start.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Low fuel level

A malfunctioning fuel lift pump

Stage 0 fuel filter restriction excessive.

Plugged or restricted fuel supply lines.

Refer to Troubleshooting Fault Code 6633 .

Last Modified: 21-Aug-2019


Aftertreatment 1 SCR System Soot - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 6692

Aftertreatment 1 SCR System Soot - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6692 PID: SPN: 7932 FMI: 0/15 LAMP: Maintenance SRT: | Aftertreatment selective catalyst reduction (SCR) system cleaning is required. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) monitors engine operating conditions and SCR temperature over time to determine the condition of the SCR catalyst.

Component Location

The SCR catalyst is located in the exhaust system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code can be activated for the following reasons:

The ECM detected high levels of hydrocarbon adsorption in the SCR catalyst.

The ECM detected high levels of coke accumulation in the SCR catalyst.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once the accumulation estimates are below the calibrated limits.

Shop Talk

This fault code is an information only fault code indicating that the system was requesting an active aftertreatment SCR system cleaning, but automatic loading was not completed.

Possible causes of this fault code include:

  • The OEM control module was not able to increase the load necessary to perform an SCR system cleaning.
Refer to Troubleshooting Fault Code 6692 .

Last Modified: 17-Mar-2020


Engine Electric Fuel Lift Pump Supply Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 6698

Engine Electric Fuel Lift Pump Supply Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6698 PID: SPN: 1075 FMI: 1/18 LAMP: Amber SRT: | The electronic lift pump controller has diagnosed that the pump motor is receiving low supply voltage, and is operating at a reduced level of performance. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Fuel Lift Pump Circuit

Circuit Description

The lift pump is a smart device and communicates with the ECM on the J1939 data link. The lift pump receives ECM supply voltage from the engine fuel supply pump for the pump controller. The lift pump motor power supply voltage is provided by the OEM.

Component Location

The electronic fuel lift pump is located between the Stage 0 fuel-water separators and Stage 0 fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The electronic lift pump controller has diagnosed that the pump motor is receiving low supply voltage, and is operating at a reduced level of performance.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A malfunctioning OEM power supply or power supply circuit.

Refer to Troubleshooting Fault Code 6698 .

Last Modified: 21-Aug-2019


Engine Electric Fuel Lift Pump Supply Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 6699

Engine Electric Fuel Lift Pump Supply Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6699 PID: SPN: 1075 FMI: 1/1 LAMP: Red SRT: | The electronic lift pump controller has diagnosed that the pump motor is receiving very low or no supply voltage. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Fuel Lift Pump Circuit

Circuit Description

The lift pump is a smart device and communicates with the ECM on the J1939 data link. The lift pump receives ECM supply voltage from the engine fuel supply pump for the pump controller. The lift pump motor power supply voltage is provided by the OEM.

Component Location

The electronic fuel lift pump is located between the Stage 0 fuel-water separators and Stage 0 fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The electronic lift pump controller has diagnosed that the pump motor is receiving very low or no supply voltage.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

A malfunctioning OEM power supply or power supply circuit.

Refer to Troubleshooting Fault Code 6699 .

Last Modified: 21-Aug-2019


Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 671

Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 671 PID: S129 SPN: 1137 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

Engine speed greater than 500 RPM.

Engine oil temperature greater than 60C [140F].

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Signal shorted to ground in the harness.

Signal shorted to return or ground in the sensor.

Refer to Troubleshooting Fault Code 671.

Last Modified: 25-Aug-2017


Engine Electric Fuel Lift Pump Fuel Supply - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 6711

Engine Electric Fuel Lift Pump Fuel Supply - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6711 PID: SPN: 1075 FMI: 0/16 LAMP: Amber SRT: | The electronic lift pump controller has diagnosed that the pump has high inlet restriction and has asked the ECM to shut the pump down. | Possible reduced engine performance.
Fuel Lift Pump Circuit

Circuit Description

The lift pump is a smart device and communicates with the ECM on the J1939 data link. The lift pump receives ECM supply voltage from the engine fuel supply pump for the pump controller. The lift pump motor power supply voltage is provided by the OEM.

Component Location

The electronic fuel lift pump is located between the Stage 0 fuel-water separators and Stage 0 fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

. The electronic lift pump controller has diagnosed that the pump has high inlet restriction and has asked the ECM to shut the pump down.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

Fuel below the suction line in the fuel tank

An obstructed suction tube in the fuel tank

Refer to Troubleshooting Fault Code 6711 .

Last Modified: 21-Aug-2019


Engine Electric Fuel Lift Pump Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 6714

Engine Electric Fuel Lift Pump Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6714 PID: SPN: 7937 FMI: 0/16 LAMP: Amber SRT: | The electronic lift pump controller has diagnosed that the internal temperature of the electronic lift pump controller is above a calibrated level. | None on performance.
Fuel Lift Pump Circuit

Circuit Description

The lift pump is a smart device and communicates with the ECM on the J1939 data link. The lift pump receives ECM supply voltage from the engine fuel supply pump for the pump controller. The lift pump motor power supply voltage is provided by the OEM.

Component Location

The electronic fuel lift pump is located between the Stage 0 fuel-water separators and Stage 0 fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The electronic lift pump controller has diagnosed that the internal temperature of the electronic lift pump controller is above a calibrated level.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

Abnormally hot supply fuel.

Stage 0 fuel filter restriction excessive.

Refer to Troubleshooting Fault Code 6714 .

Last Modified: 21-Aug-2019


Engine Electric Fuel Lift Pump Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 6715

Engine Electric Fuel Lift Pump Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6715 PID: SPN: 7937 FMI: 0/0 LAMP: Amber SRT: | The electronic lift pump controller has diagnosed that the internal temperature of the electronic lift pump controller is above a calibrated level. | None on performance.
Fuel Lift Pump Circuit

Circuit Description

The lift pump is a smart device and communicates with the ECM on the J1939 data link. The lift pump receives ECM supply voltage from the engine fuel supply pump for the pump controller. The lift pump motor power supply voltage is provided by the OEM.

Component Location

The electronic fuel lift pump is located between the Stage 0 fuel-water separators and Stage 0 fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The electronic lift pump controller has diagnosed that the internal temperature of the electronic lift pump controller is above a calibrated level.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

Abnormally hot supply fuel.

Stage 0 fuel filter restriction excessive.

Refer to Troubleshooting Fault Code 6715 .

Last Modified: 21-Aug-2019


Engine Electric Fuel Lift Pump - Abnormal Update Rate

FAULT CODE 6716

Engine Electric Fuel Lift Pump - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6716 PID: SPN: 1075 FMI: 9/9 LAMP: Amber SRT: | No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the engine fuel lift pump. | Possible reduced engine performance.
Fuel Lift Pump Circuit

Circuit Description

The lift pump is a smart device and communicates with the ECM on the J1939 data link. The lift pump receives ECM supply voltage from the engine fuel supply pump for the pump controller. The lift pump motor power supply voltage is provided by the OEM.

Component Location

The electronic fuel lift pump is located between the Stage 0 fuel-water separators and Stage 0 fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position until the electronic fuel lift pump is commanded off.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) lost communication with the electronic fuel lift pump.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

The electronic fuel lift pump is not receiving power from the ECM.

Malfunctioning SAE J1939 data link 3 circuit.

A malfunctioning fuel lift pump

Refer to Troubleshooting Fault Code 6716 .

Last Modified: 21-Aug-2019


Engine Electric Fuel Lift Pump - Out of Calibration

FAULT CODE 6717

Engine Electric Fuel Lift Pump - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6717 PID: SPN: 1075 FMI: 13/13 LAMP: Amber SRT: | The electronic fuel lift pump firmware version does not match the expected value. | Possible reduced engine performance.
Fuel Lift Pump Circuit

Circuit Description

The lift pump is a smart device and communicates with the ECM on the J1939 data link. The lift pump receives ECM supply voltage from the engine fuel supply pump for the pump controller. The lift pump motor power supply voltage is provided by the OEM.

Component Location

The electronic fuel lift pump is located between the Stage 0 fuel-water separators and Stage 0 fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the electronic fuel lift pump firmware version does not match the expected value in the ECM calibration.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Incorrect firmware version installed in the electronic fuel lift pump.

Refer to Troubleshooting Fault Code 6717 .

Last Modified: 21-Aug-2019


Engine Electric Fuel Lift Pump Supply - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 6718

Engine Electric Fuel Lift Pump Supply - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6718 PID: SPN: 1075 FMI: 7/7 LAMP: Red SRT: | The electronic fuel lift pump has seized. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Fuel Lift Pump Circuit

Circuit Description

The lift pump is a smart device and communicates with the ECM on the J1939 data link. The lift pump receives ECM supply voltage from the engine fuel supply pump for the pump controller. The lift pump motor power supply voltage is provided by the OEM.

Component Location

The electronic fuel lift pump is located between the Stage 0 fuel-water separators and Stage 0 fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The electronic lift pump controller has diagnosed that the pump can no longer run.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A malfunctioning fuel lift pump

Refer to Troubleshooting Fault Code 6718 .

Last Modified: 21-Aug-2019


Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 672

Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 672 PID: S131 SPN: 1139 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

Engine speed greater than 500 RPM.

Engine oil temperature greater than 60C [140F].

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Signal shorted to ground in the harness.

Signal shorted to return or ground in the sensor.

Refer to Troubleshooting Fault Code 672.

Last Modified: 25-Aug-2017


Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 673

Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 673 PID: S133 SPN: 1141 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

Engine speed greater than 500 RPM.

Engine oil temperature greater than 60C [140F].

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Signal shorted to ground in the harness.

Signal shorted to return or ground in the sensor.

Refer to Troubleshooting Fault Code 673.

Last Modified: 25-Aug-2017


Aftertreatment 2 SCR Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 6734

Aftertreatment 2 SCR Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6734 PID: SPN: 4419 FMI: 1/17 LAMP: None SRT: | Aftertreatment 2 SCR Conversion Efficiency - Data Valid But Below Normal Operating Range - Least Severe Level. NOx conversion across the SCR catalyst is too low. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) monitors the NOx concentration in the engine's exhaust gases using an aftertreatment intake NOx sensor and an aftertreatment outlet NOx sensor. By comparing these two values, the ECM is able to determine the conversion efficiency of the SCR catalyst and dosing system.

Component Location

The SCR catalyst is located in the SCR catalyst assembly.

Conditions for Running the Diagnostics

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the NOx conversion across the SCR catalyst was less than expected.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

It is necessary to use the "Reset All Faults" command in INSITE™ electronic service tool to clear this fault and extinguish the amber CHECK ENGINE lamp.

Shop Talk

Troubleshoot all other active NOx sensor and SCR dosing system related fault codes before this fault.

Possible causes of this fault code include:

  • Malfunctioning aftertreatment diesel exhaust fluid dosing system.
  • Exhaust system leaks
  • Malfunctioning SCR catalyst
  • Degraded, diluted, or incorrect diesel exhaust fluid
  • Diesel exhaust fluid deposits in the decomposition tube.
Refer to Troubleshooting Fault Code 6734.

Last Modified: 18-May-2017


Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 674

Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 674 PID: S135 SPN: 1143 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

Engine speed greater than 500 RPM.

Engine oil temperature greater than 60C [140F].

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Signal shorted to ground in the harness.

Signal shorted to return or ground in the sensor.

Refer to Troubleshooting Fault Code 674.

Last Modified: 25-Aug-2017


Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 675

Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 675 PID: S137 SPN: 1145 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

Engine speed greater than 500 RPM.

Engine oil temperature greater than 60C [140F].

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Signal shorted to ground in the harness.

Signal shorted to return or ground in the sensor.

Refer to Troubleshooting Fault Code 675.

Last Modified: 25-Aug-2017


Engine Electric Fuel Lift Pump Supply Voltage - Voltage Below Normal or Shorted to Low Source

FAULT CODE 6759

Engine Electric Fuel Lift Pump Supply Voltage - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6759 PID: SPN: 1075 FMI: 4/4 LAMP: Red SRT: | The engine fuel supply pump controller has diagnosed that the fuel lift pump controller is not receiving any supply voltage. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Fuel Lift Pump Circuit

Circuit Description

The lift pump is a smart device and communicates with the ECM on the J1939 data link. The lift pump receives ECM supply voltage from the engine fuel supply pump for the pump controller. The lift pump motor power supply voltage is provided by the OEM.

Component Location

The electronic fuel lift pump is located between the Stage 0 fuel-water separators and Stage 0 fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The engine fuel supply pump controller has diagnosed that the fuel lift pump controller is not receiving any supply voltage.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

An open or short circuit to a voltage source in the wiring harness.

An open or short circuit in the OEM harness.

Refer to Troubleshooting Fault Code 6759 .

Last Modified: 21-Aug-2019


Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 676

Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 676 PID: S139 SPN: 1147 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

Engine speed greater than 500 RPM.

Engine oil temperature greater than 60C [140F].

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Signal shorted to ground in the harness.

Signal shorted to return or ground in the sensor.

Refer to Troubleshooting Fault Code 676.

Last Modified: 25-Aug-2017


Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 677

Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 677 PID: S141 SPN: 1149 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

Engine speed greater than 500 RPM.

Engine oil temperature greater than 60C [140F].

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Signal shorted to ground in the harness.

Signal shorted to return or ground in the sensor.

Refer to Troubleshooting Fault Code 677.

Last Modified: 25-Aug-2017


Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 678

Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 678 PID: S143 SPN: 1151 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

Engine speed greater than 500 RPM.

Engine oil temperature greater than 60C [140F].

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Signal shorted to ground in the harness.

Signal shorted to return or ground in the sensor.

Refer to Troubleshooting Fault Code 678.

Last Modified: 25-Aug-2017


Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit 1 Heater Relay - Condition Exists

FAULT CODE 6853

Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit 1 Heater Relay - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6853 PID: SPN: 8309 FMI: 11/31 LAMP: Amber SRT: | The engine control module (ECM) detected low voltage on the aftertreatment diesel exhaust fluid dosing unit heater power supply circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit heater is used to defrost and/or prevent freezing of the diesel exhaust fluid dosing unit.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel exhaust fluid dosing unit heater is commanded ON.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected low voltage on the aftertreatment diesel exhaust fluid dosing unit heater power supply circuit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to inactive immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes for this fault include:

Open circuit in the wiring harness

  • A damaged aftertreatment junction box resistor.
Refer to Troubleshooting Fault Code 6853.

Last Modified: 18-Aug-2017


Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit 1 Heater Relay - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 6854

Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit 1 Heater Relay - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6854 PID: SPN: 8309 FMI: 7/7 LAMP: Amber SRT: | The engine control module (ECM) detected voltage on the diesel exhaust fluid dosing unit relay diagnostic circuit. | None on performance.
Diesel Exhaust Fluid Dosing Unit Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit heater is used to defrost and/or prevent freezing of the diesel exhaust fluid dosing unit.

Component Location

The aftertreatment diesel exhaust fluid dosing unit heater relay is an OEM component. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel exhaust fluid dosing unit heater is commanded OFF.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected voltage on the diesel exhaust fluid dosing unit relay diagnostic circuit.

Action Taken When the Fault Code is Active

The ECM will illuminate the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to inactive immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • An open in the diesel exhaust fluid dosing unit relay diagnostic circuit.
  • Dosing unit relay diagnostic circuit shorted to ECM power supply voltage.
  • A damaged aftertreatment junction box resistor.
Refer to Troubleshooting Fault Code 6854.

Last Modified: 18-Aug-2017


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Relay - Condition Exists

FAULT CODE 6855

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Relay - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6855 PID: SPN: 5746 FMI: 11/31 LAMP: Amber SRT: | The engine control module (ECM) detected low voltage on the aftertreatment diesel exhaust fluid dosing unit heater power supply circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit heater is used to defrost and/or prevent freezing of the diesel exhaust fluid dosing unit.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel exhaust fluid dosing unit heater is commanded ON.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected low voltage on the aftertreatment diesel exhaust fluid dosing unit heater power supply circuit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to inactive immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes for this fault include:

Open circuit in the wiring harness

  • A damaged aftertreatment junction box resistor.
Refer to Troubleshooting Fault Code 6855.

Last Modified: 18-Aug-2017


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Relay - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 6856

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Relay - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6856 PID: SPN: 5746 FMI: 7/7 LAMP: Amber SRT: | The engine control module (ECM) detected voltage on the diesel exhaust fluid dosing unit relay diagnostic circuit. | None on performance.
Diesel Exhaust Fluid Dosing Unit Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit heater is used to defrost and/or prevent freezing of the diesel exhaust fluid dosing unit.

Component Location

The aftertreatment diesel exhaust fluid dosing unit heater relay is an OEM component. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel exhaust fluid dosing unit heater is commanded OFF.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected voltage on the diesel exhaust fluid dosing unit relay diagnostic circuit.

Action Taken When the Fault Code is Active

The ECM will illuminate the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to inactive immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • An open in the diesel exhaust fluid dosing unit relay diagnostic circuit.
  • Dosing unit relay diagnostic circuit shorted to ECM power supply voltage.
  • A damaged aftertreatment junction box resistor.
Refer to Troubleshooting Fault Code 6856.

Last Modified: 18-Aug-2017


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 689

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: P190 SPN: 190 FMI: 2/2 LAMP: Amber SRT: | Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect. The ECM has detected an error in the engine speed signal. | Possible reduced engine performance.
Crankshaft Position Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5-VDC supply to the crankshaft position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. As holes drilled in the flywheel move past the position sensor, a signal is generated on the signal circuit. The ECM uses this signal to determine engine speed and position. Offset spacing of the drillings indicate to the ECM the engine position.

Component Location

The crankshaft position sensor is located on the left bank side of the engine in the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the crankshaft position sensor while the engine was running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The camshaft position sensor will be used by the ECM to determine engine speed and position.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and operate at rated speed for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Causes of this fault include:

  • Open or short circuit of the +5-VDC supply, signal, or return wire in the engine harness
  • Crankshaft position sensor malfunction
  • Sensor air gap that is too small or too large.
Refer to Troubleshooting Fault Code 689.

Last Modified: 16-Dec-2015


Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 691

Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 691 PID: P351 SPN: 1172 FMI: 3/3 LAMP: Amber SRT: | Turbocharger 1 Compressor Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the turbocharger compressor intake air temperature circuit. | Possible reduced engine performance.
Turbocharger Compressor Intake Temperature Sensor Circuit

Circuit Description

The compressor intake air temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the compressor intake of the turbocharger. The engine control module (ECM) supplies 5-VDC to the compressor intake temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the air temperature.

Component Location

The turbocharger compressor intake temperature sensor is located in the OEM intake air piping.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the compressor intake temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the compressor intake temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This sensor shares return wires in the engine harness with other sensors. An open or shorted return can cause multiple fault codes to be active. Before troubleshooting this fault code, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or short circuit to a voltage source
  • Damaged sensor.
Refer to Troubleshooting Fault Code 691.

Last Modified: 16-Dec-2015


Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 692

Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 692 PID: P351 SPN: 1172 FMI: 4/4 LAMP: Amber SRT: | Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at turbocharger compressor intake air temperature circuit. | Possible reduced engine performance.
Turbocharger Compressor Intake Temperature Sensor Circuit

Circuit Description

The turbocharger compressor intake temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the compressor intake of the turbocharger. The engine control module (ECM) supplies 5-VDC to the compressor intake temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the air temperature.

Component Location

The turbocharger compressor intake temperature sensor is located in the OEM intake air piping.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the compressor intake temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the compressor intake temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This sensor shares return wires in the engine harness with other sensors. An open or shorted return can cause multiple fault codes to be active. Before troubleshooting this fault code, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor
  • Damaged sensor.
Refer to Troubleshooting Fault Code 692.

Last Modified: 16-Dec-2015


Engine ECU Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 697

Engine ECU Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 697 PID: P21 SPN: 1136 FMI: 3/3 LAMP: Amber SRT: | Engine ECU Temperature Sensor Circuit - Voltage Above normal, or Shorted to High source. High signal voltage or open circuit detected at the internal ECM temperature sensor. | None on performance.
Engine Control Module

Circuit Description

The engine control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

The Engine Control Module (ECM) internal temperature sensor is located inside the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the internal temperature sensor circuit was shorted high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This sensor is located internally to the ECM. No troubleshooting is possible for this fault code. If the fault code is active, the ECM must be replaced.

Refer to Troubleshooting Fault Code 697.

Last Modified: 02-Dec-2015


Engine ECU Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 698

Engine ECU Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 698 PID: P21 SPN: 1136 FMI: 4/4 LAMP: Amber SRT: | Engine ECU Temperature Sensor Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at the internal ECM temperature sensor. | None on performance.
Engine Control Module

Circuit Description

The engine control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

The Engine Control Module (ECM) internal temperature sensor is located inside the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the internal temperature sensor circuit was shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This sensor is located internally to the ECM. No troubleshooting is possible for this fault code. If the fault code is active, the ECM must be replaced.

Refer to Troubleshooting Fault Code 698.

Last Modified: 02-Dec-2015


Fault Code Path Selection

FAULT CODE 699
Fault Code Path Selection

Is the ECM source address 00? | Go to 402-fc699sa00
Is the ECM source address 01? | Go to 402-fc699sa01
Is the ECM source address 144? | Go to 402-fc699sa144
Is the ECM source address 186? | Go to 402-fc699sa186

Last Modified: 16-May-2017


Engine ECU Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 699 (sa00)

Engine ECU Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 699 (sa00) PID: P21 SPN: 1136 FMI: 2/2 LAMP: Amber SRT: | Engine ECU Temperature - Data Erratic, Intermittent or Incorrect. An incorrect or inconsistent temperature reading has been detected internal to the ECM. | None on performance.
Engine Control Module

Circuit Description

The engine control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

The Engine Control Modules (ECMs) are mounted at the front of the engine above the gear housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the internal temperature sensor circuit was irrational.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This sensor is located internally to the ECM. No troubleshooting is possible for this fault code. If the fault code is active, the ECM must be replaced.

Refer to Troubleshooting Fault Code 699 (sa00).

Last Modified: 05-May-2017


Engine ECU Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 699 (sa01)

Engine ECU Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 699 (sa01) PID: P21 SPN: 1136 FMI: 2/2 LAMP: Amber SRT: | Engine ECU Temperature - Data Erratic, Intermittent or Incorrect. An incorrect or inconsistent temperature reading has been detected internal to the ECM. | None on performance.
Engine Control Module

Circuit Description

The engine control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

The Engine Control Modules (ECMs) are mounted at the front of the engine above the gear housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the internal temperature sensor circuit was irrational.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This sensor is located internally to the ECM. No troubleshooting is possible for this fault code. If the fault code is active, the ECM must be replaced.

Refer to Troubleshooting Fault Code 699 (sa01).

Last Modified: 05-May-2017


Engine ECU Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 699 (sa144)

Engine ECU Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 699 (sa144) PID: P21 SPN: 1136 FMI: 2/2 LAMP: Amber SRT: | Engine ECU Temperature - Data Erratic, Intermittent or Incorrect. An incorrect or inconsistent temperature reading has been detected internal to the ECM. | None on performance.
Engine Control Module

Circuit Description

The engine control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

The Engine Control Modules (ECMs) are mounted at the front of the engine above the gear housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the internal temperature sensor circuit was irrational.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This sensor is located internally to the ECM. No troubleshooting is possible for this fault code. If the fault code is active, the ECM must be replaced.

Refer to Troubleshooting Fault Code 699 (sa144).

Last Modified: 05-May-2017


Engine ECU Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 699 (sa186)

Engine ECU Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 699 (sa186) PID: P21 SPN: 1136 FMI: 2/2 LAMP: Amber SRT: | Engine ECU Temperature - Data Erratic, Intermittent or Incorrect. An incorrect or inconsistent temperature reading has been detected internal to the ECM. | None on performance.
Engine Control Module

Circuit Description

The engine control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

The Engine Control Modules (ECMs) are mounted at the front of the engine above the gear housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the internal temperature sensor circuit was irrational.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This sensor is located internally to the ECM. No troubleshooting is possible for this fault code. If the fault code is active, the ECM must be replaced.

Refer to Troubleshooting Fault Code 699 (sa186).

Last Modified: 05-May-2017


Aftertreatment 1 Diesel Exhaust Fluid Actual Dosing Quantity - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 7123

Aftertreatment 1 Diesel Exhaust Fluid Actual Dosing Quantity - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 7123 PID: SPN: 4331 FMI: 1/17 LAMP: Maintenance SRT: | Aftertreatment 1 Diesel Exhaust Fluid Actual Dosing Quantity - Data Valid But Below Normal Operating Range - Least Severe Level. The engine control module (ECM) has detected the DEF dosing quantity is less than the desired amount. | None on performance.
Aftertreatment Def Dosing Unit

Circuit Description

The Aftertreatment DEF Dosing controller unit activates priming, dosing and purging of the Diesel Exhaust Fluid. The DEF dosing unit pressure line is responsible for transporting diesel exhaust fluid between the dosing unit and the dosing valve. A restriction or damage to the pressure line or connections can cause DEF pressure to be erratic.

Component Location

The aftertreatment diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and diesel exhaust fluid dosing is being commanded.

Conditions for Setting the Fault Codes

The engine control module (ECM) has detected the DEF dosing quantity is less than the desired amount.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code usually occurs with other Aftertreatment DEF Dosing System fault codes. Troubleshoot other fault codes first.

This fault code occurs when the combination of the DEF dosing systems on the associated bank does not meet the desired dosing quantity.

Possible causes of this fault code include.

  • Air in any of the DEF dosing systems on the associated bank.
Refer to Troubleshooting Fault Code 7123.

Last Modified: 28-Apr-2017


Aftertreatment 2 Diesel Exhaust Fluid Actual Dosing Quantity - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 7124

Aftertreatment 2 Diesel Exhaust Fluid Actual Dosing Quantity - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 7124 PID: SPN: 4384 FMI: 1/17 LAMP: Maintenance SRT: | Aftertreatment 2 Diesel Exhaust Fluid Actual Dosing Quantity - Data Valid But Below Normal Operating Range - Least Severe Level. The engine control module (ECM) has detected the DEF dosing quantity is less than the desired amount. | None on performance.
Aftertreatment Def Dosing Unit

Circuit Description

The Aftertreatment DEF Dosing controller unit activates priming, dosing and purging of the Diesel Exhaust Fluid. The DEF dosing unit pressure line is responsible for transporting diesel exhaust fluid between the dosing unit and the dosing valve. A restriction or damage to the pressure line or connections can cause DEF pressure to be erratic.

Component Location

The aftertreatment diesel exhaust fluid (DEF) dosing valve is mounted on the decomposition reactor elbow.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and diesel exhaust fluid dosing is being commanded.

Conditions for Setting the Fault Codes

The engine control module (ECM) has detected the DEF dosing quantity is less than the desired amount.

Action Taken When the Fault Code is Active

  • The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code usually occurs with other Aftertreatment DEF Dosing System fault codes. Troubleshoot other fault codes first.

This fault code occurs when the combination of the DEF dosing systems on the associated bank does not meet the desired dosing quantity.

Possible causes of this fault code include.

  • Air in any of the DEF dosing systems on the associated bank.
Refer to Troubleshooting Fault Code 7124.

Last Modified: 28-Apr-2017


Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 721

Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 721 PID: S130 SPN: 1138 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

Engine speed greater than 500 RPM.

Engine oil temperature greater than 60C [140F].

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Signal shorted to ground in the harness.

Signal shorted to return or ground in the sensor.

Refer to Troubleshooting Fault Code 721.

Last Modified: 29-Aug-2017


Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 722

Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 722 PID: S132 SPN: 1140 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

Engine speed greater than 500 RPM.

The engine control module (ECM) has detected the gear oil temperature sensor indicates the gear oil temperature is above the protection limit set by the equipment manufacturer.

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Signal shorted to ground in the harness.

Signal shorted to return or ground in the sensor.

Refer to Troubleshooting Fault Code 722.

Last Modified: 29-Aug-2017


Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 723

Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 723 PID: S134 SPN: 1142 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

Engine speed greater than 500 RPM.

Engine oil temperature greater than 60C [140F].

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Signal shorted to ground in the harness.

Signal shorted to return or ground in the sensor.

Refer to Troubleshooting Fault Code 723.

Last Modified: 29-Aug-2017


Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 724

Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 724 PID: S136 SPN: 1144 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

Engine speed greater than 500 RPM.

Engine oil temperature greater than 60C [140F].

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Signal shorted to ground in the harness.

Signal shorted to return or ground in the sensor.

Refer to Troubleshooting Fault Code 724.

Last Modified: 29-Aug-2017


Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 725

Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 725 PID: S138 SPN: 1146 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

Engine speed greater than 500 RPM.

Engine oil temperature greater than 60C [140F].

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Signal shorted to ground in the harness.

Signal shorted to return or ground in the sensor.

Refer to Troubleshooting Fault Code 725.

Last Modified: 29-Aug-2017


Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 726

Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 726 PID: S140 SPN: 1148 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

Engine speed greater than 500 RPM.

Engine oil temperature greater than 60C [140F].

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Signal shorted to ground in the harness.

Signal shorted to return or ground in the sensor.

Refer to Troubleshooting Fault Code 726.

Last Modified: 29-Aug-2017


Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 727

Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 727 PID: S142 SPN: 1150 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

Engine speed greater than 500 RPM.

Engine oil temperature greater than 60C [140F].

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Signal shorted to ground in the harness.

Signal shorted to return or ground in the sensor.

Refer to Troubleshooting Fault Code 727.

Last Modified: 29-Aug-2017


Exhaust Gas Temperature Sensor Circuit Cylinder 16 (B8) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 728

Exhaust Gas Temperature Sensor Circuit Cylinder 16 (B8) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 728 PID: S144 SPN: 1152 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 16 (B8) - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

Engine speed greater than 500 RPM.

Engine oil temperature greater than 60C [140F].

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Signal shorted to ground in the harness.

Signal shorted to return or ground in the sensor.

Refer to Troubleshooting Fault Code 728.

Last Modified: 29-Aug-2017


Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 731

Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 731 PID: S64 SPN: 723 FMI: 7/7 LAMP: Amber SRT: | Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment. Engine position signal from the crankshaft position sensor and camshaft position sensor do not match. | Possible reduced engine performance.
Crankshaft Position Sensor Circuit
Camshaft Postiion Sensor Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply and a return circuit to the position sensors. As holes drilled in the flywheel or slots in the front of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM uses this signal to determine engine speed. Offset spacing of the drillings or slots indicate to the ECM the position of the engine.

Component Location

The crankshaft position sensor is located on the left bank side of the engine in the flywheel housing.

The camshaft position sensor is located in the gear cover.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankshaft position does not match the camshaft position signal input to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes for this fault code include:

  • Base engine timing is incorrect.
Refer to Troubleshooting Fault Code 731.

Last Modified: 10-Aug-2015


SAE J1939 Data Link 2 Engine Network No Data Received - Condition Exists

FAULT CODE 782

SAE J1939 Data Link 2 Engine Network No Data Received - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 782 PID: S206 SPN: 1231 FMI: 11/31 LAMP: Amber SRT: | SAE J1939 Data Link 2 Engine Network No Data Received - Condition Exists. No communication on the J1939 data link between the primary ECM and one or more of the secondary ECMs | Engine may run rough, may stop running, may not start, or may be difficult to start.
SAE J1939 Data Link 2 Circuit

Circuit Description

The SAE J1939 data link circuit consists of one positive and one negative wire. Two 120 ohm resistors are connected in parallel to terminate the ends of the backbone. Stubs connect the engine control modules (ECM) to the J1939 backbone.

The engine control modules use the J1939 data link 2 for communication between modules.

Component Location

The Engine Control Modules (ECMs) are mounted at the front of the engine above the gear housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The primary engine control module (ECM 1) lost communication with one or more secondary ECMs via the J1939 data link 2.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A secondary ECM is not receiving power from the ECM supply voltage circuit in the harness. This can be caused by an open circuit in the power supply wire, blown ECM fuse, or open return wire.
  • Tripped circuit breaker in the OEM power supply circuit.
  • An open or short circuit in the SAE J1939 datalink circuit
  • Intermittent communication between the ECMs.
Refer to Troubleshooting Fault Code 782.

Last Modified: 11-Dec-2015


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


FAULT CODE 111 (sa00) - Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 111 active?
 | STEP 1B. Check the inactive counts of Fault Code 111. | Less than three counts?
STEP 2. | Check ECM calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check the ECM.

Conditions

  • Connect all components.
  • Turn keyswitch OFF and wait 5 seconds.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 111 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the inactive counts of Fault Code 111.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the inactive counts of Fault Code 111.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 111.

Less than three counts?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 2B

Repair complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 19-May-2016


FAULT CODE 111 (sa01) - Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 111 active?
 | STEP 1B. Check the inactive counts of Fault Code 111. | Less than three counts?
STEP 2. | Check ECM calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check the ECM.

Conditions

  • Connect all components.
  • Turn keyswitch OFF and wait 5 seconds.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 111 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the inactive counts of Fault Code 111.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the inactive counts of Fault Code 111.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 111.

Less than three counts?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 2B

Repair complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 19-May-2016


FAULT CODE 111 (sa144) - Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 111 active?
 | STEP 1B. Check the inactive counts of Fault Code 111. | Less than three counts?
STEP 2. | Check ECM calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check the ECM.

Conditions

  • Connect all components.
  • Turn keyswitch OFF and wait 5 seconds.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 111 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the inactive counts of Fault Code 111.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the inactive counts of Fault Code 111.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 111.

Less than three counts?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 2B

Repair complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO
No Repair

Repair complete.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 1A

Last Modified: 20-May-2016


FAULT CODE 111 (sa186) - Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 111 active?
 | STEP 1B. Check the inactive counts of Fault Code 111. | Less than three counts?
STEP 2. | Check ECM calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check the ECM.

Conditions

  • Connect all components.
  • Turn keyswitch OFF and wait 5 seconds.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 111 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the inactive counts of Fault Code 111.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the inactive counts of Fault Code 111.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 111.

Less than three counts?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 2B

Repair complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 19-May-2016


FAULT CODE 115 - Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibilty of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 115 active?
STEP 2. | Check the engine position sensor signal circuits. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open crankshaft position sensor signal circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for an open camshaft position sensor signal circuit in the engine wiring harness. | Less than 10 ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 115 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine position sensor signal circuits.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connection.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open crankshaft position sensor signal circuit in the engine wiring harness.

Conditions

Perform this check on each ECM.

  • Turn keyswitch OFF.
  • Disconnect engine crankshaft position sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the crankshaft position sensor SIGNAL pin at the crankshaft position sensor engine harness connector to the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open camshaft position sensor signal circuit in the engine harness.

Conditions

Perform this check on each ECM.

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Disconnect the engine harness connector from the ECM.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the camshaft position sensor SIGNAL pin at the camshaft position sensor engine harness connector to the camshaft position sensor SIGNAL pin at the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 24-Mar-2016


FAULT CODE 122 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 122 active?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 123 active and Fault Code 122 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 122 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold pressure sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES NO

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the ECM engine connector.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES NO

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 123 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 123 active?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 122 active and Fault Code 123 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 123 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 123 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold pressure +5 volt SUPPLY pin and the intake manifold pressure SIGNAL pin at the intake manifold pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active and Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES NO

A damaged sensor has been detected.

Replace the sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the ECM engine connector.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES NO

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold pressure +5 volt SUPPLY pin and the intake manifold pressure SIGNAL pin at the engine control module engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active and Fault Code 123 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES NO

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 135 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 135 active?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 141 active and Fault Code 135 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 135 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES NO

A damaged sensor has been detected.

Replace the oil pressure sensor.

Refer to Procedure 019-066 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM engine connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 VDC and 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES NO

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 1A

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 141 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 141 active?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 135 active and Fault Code 141 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 141 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the oil pressure +5 volt SUPPLY pin and the oil pressure SIGNAL pin at the oil pressure sensor connector of the engine harness.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 135 active and Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO

A damaged sensor has been detected.

Replace the oil pressure sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the oil pressure +5 volt SUPPLY pin and the oil pressure SIGNAL pin at the ECM engine connector.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 135 active and Fault Code 141 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 143 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 143. | Active or inactive counts of Fault Code 143?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 143.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 143?
YES NO

Reference the Lubricating Oil Pressure Low or Lubricating Oil Pressure High troubleshooting symptom tree in Section TS.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 28-Mar-2016


FAULT CODE 144 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 144 active?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 144 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 145 active and Fault Code 144 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 144 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the coolant temperature sensor SIGNAL pin and coolant temperature sensor RETURN pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active and Fault Code 144 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant temperature sensor RETURN pin and the engine harness engine coolant temperature sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant temperature sensor SIGNAL pin and the engine harness engine coolant temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active?
YES NO

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

None. The removal and installation of the connector corrected the fault.

Go to 1A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 145 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 145 active?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 145 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 145 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and ECM power supply ground circuit.

Use the following procedures.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active?
YES NO

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

None. The removal and installation of the connector corrected the fault.

Go to 1A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 146 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor coolant temperature reading. |
 | STEP 1A. Monitor coolant temperature reading. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor coolant temperature reading.

Guided Step 1A - Monitor coolant temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the coolant temperature reading.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Reference the Engine Coolant Temperature Above Normal troubleshooting symptom tree in Section TS.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 151 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor coolant temperature reading. |
 | STEP 1A. Monitor coolant temperature reading. | Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Monitor coolant temperature reading.

Guided Step 1A - Monitor coolant temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the coolant temperature reading.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Refer to the Engine Coolant Temperature Above Normal troubleshooting symptom tree in Section TS.

Replace the coolant temperature sensor.

Refer to Procedure 019-019 in the Associated Procedures Table.

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 153 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 153 active?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 154 active and Fault Code 153 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 153 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 154 active and Fault Code 153 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 153 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the engine harness intake manifold air temperature sensor connector.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 154 active and Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active and Fault Code 153 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor RETURN pin and the engine harness intake manifold air temperature sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor SIGNAL pin and the engine harness intake manifold air temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active?
YES NO

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

None. The removal and installation of the connector corrected the fault.

Go to 1A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 154 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 154 active?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 154 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 154 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to
Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold air temperature sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine intake manifold temperature sensor from the engine harness.

Action

Check for a short circuit.

  • Measure the resistance between the intake manifold air temperature sensor SIGNAL pin in the ECM power supply ground circuit. Refer to Procedure 019-610 in the Associated Procedures Table.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ECM power supply ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active?
YES NO

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

The removal and installation of the connector corrected the fault.

Go to 1A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 155 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor intake manfiold air temperature reading. |
 | STEP 1A. Monitor intake manfiold air temperature reading. | Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Monitor intake manfiold air temperature reading.

Guided Step 1A - Monitor intake manfiold air temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the intake manifold temperature reading.

  • Use INSITE™ electronic service tool to monitor the intake manifold air temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Reference the Intake Manifold Air Temperature Above Specification troubleshooting symptom tree in Section TS.

Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in the Associated Procedures Table.

Appropriate troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 156 - Intake Manifold 2 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 156 active?
STEP 2. | Check the intake manifold 2 temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 2 temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 157 active and Fault Code 156 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 156 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 157 active and Fault Code 156 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 156 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 156 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the intake manifold 2 air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold 2 air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 air temperature sensor from the engin harness.

Action

Inspect the engine harness and intake manifold 2 temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Check all harnesses connected in series.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 temperature sensor connector from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold 2 air temperature sensor SIGNAL pin and intake manifold 2 air temperature sensor RETURN pin at the engine harness intake manifold 2 air temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 157 active and Fault Code 156 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold 2 air temperature sensor connector to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 156 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold 2 pressurre/temperature sensor.

Refer to Procedure 019-159 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine control module 60 pin connector.

Action

Inspect the engine harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold 2 air temperature sensor SIGNAL pin and the intake manifold 2 air temperature sensor RETURN pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 157 active and Fault Code 156 inactive?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the intake manifold 2 temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold 2 air temperature sensor RETURN pin and the engine harness connector intake manifold 2 air temperature RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open intake manifold 2 temperature RETURN circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold 2 air temperature sensor connector from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold 2 air temperature SIGNAL pin and the engine harness connector intake manifold 2 temperature SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold 2 air temperature sensor connector from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold 2 temperature SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the intake manifold 2 temperature SIGNAL wire has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the short circuit.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 157 - Intake Manifold 2 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 157 active?
STEP 2. | Check the intake manifold 2 temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 2 temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 156 active and Fault Code 157 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 157 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 156 active and Fault Code 157 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 157 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 157 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the intake manifold 2 temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold 2 temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 temperature sensor connector from the engine harness connector.

Action

Inspect the engine harness and temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.
  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Check all harnesses connected in series.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 temperature sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 156 active and Fault Code 157 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold 2 temperature sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 157 active?
YES NO

A damaged intake manifold 2 temperature sensor has been detected.

Replace the intake manifold 2 temperature sensor.

Refer to Procedure 019-159 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.
  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 156 active and Fault Code 157 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold 2 temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold 2 temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector and pin identification.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the intake manifold 2 temperature SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine intake manifold 2 temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between intake manifold 2 temperature SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector and pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the intake manifold 2 temperature SIGNAL wire has been detected in the engine harness.

Repair or replace the damaged section of the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 158 - Intake Manifold 2 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor intake manifold air temperature reading. |
 | STEP 1A. Monitor intake manifold air temperature reading. | Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Monitor intake manifold 2 air temperature reading.

Guided Step 1A - Monitor intake manifold 2 air temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the intake manifold temperature reading.

  • Use INSITE™ electronic service tool to monitor the intake manifold air temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Reference the Intake Manifold Air Temperature Above Specification troubleshooting symptom tree in Section TS.

Replace the intake manifold pressure/temperature sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

Appropriate troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 187 (sa00) - Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Barometric Air Temperature Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine conrol module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 187 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply 2 and return. |
 | STEP 2A. Inspect the barometric pressure sensor and circuit connected to the sensor supply 2 and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the intake manifold 1 pressure sensor and circuit connected to the sensor supply 2 and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the circuit response. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply 2 and return.

Guided Step 2A - Inspect the barometric pressure sensor and circuit connected to the sensor supply 2 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.

Action

Inspect the engine harness sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the barometric pressure sensor.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the intake manifold 1 pressure sensor and circuit connected to the sensor supply 2 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the intake manifold 1 pressure/temperature sensor.

  • Refer to Procedure 019-159 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

A short circuit to ground or return has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 187 (sa01) - Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 187 active?
STEP 2. | Check the sensors and circuits connected to the sensor number 2 supply and return. |
 | STEP 2A. Inspect the intake manifold 2 pressure sensor and circuit connected to the sensor number 2 supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 187 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor number 2 supply and return.

Guided Step 2A - Inspect the intake manifold 2 pressure sensor and circuit connected to the sensor number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the intake manifold 2 pressure/temperature sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

A short circuit to ground or return has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 195 (2-Wire Sensor) - Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 195 active?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 196 active and Fault Code 195 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 195 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 195 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and engine coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Conenct INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine coolant level sensor SIGNAL pin and the engine coolant level sensor RETURN pin at the engine coolant level sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active and Fault Code 195 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant level sensor. Refer to Procedure 019-017 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor RETURN pin and the OEM harness engine coolant level sensor connector RETURN pin.

Reference the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SIGNAL pin and the engine coolant level sensor connector SIGNAL pin.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness form the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant level SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 195 (3-Wire Sensor) - Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 195 active?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response | Fault Code 196 active and Fault Code 195 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 195 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Check for an active fault code. | Fault Code 195 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and engine coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine coolant level sensor SIGNAL pin and the engine coolant level sensor RETURN pin at the engine coolant level sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active and Fault Code 195 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor RETURN pin at the engine coolant level sensor connector of the OEM harness.

Reference the circuit or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant level sensor. Refer to Procedure 019-017 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SIGNAL pin and the OEM harness engine coolant level sensor connector SIGNAL pin.

Reference the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor RETURN pin and the OEM harness engine coolant level sensor connector RETURN pin.

Use a circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A open return circuit has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the damaged section of harness.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the short circuit.

Repair or replace the damaged section of harness.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin sort circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SUPPLY pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the supply line has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the short circuit.

Repair or replace the damaged section of harness.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active?
YES NO

Troubleshooting procedures need to be repeated from the beginning.

None. The removal and installation of the connector corrected the fault.

Go to 1A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 196 (2-Wire Sensor) - Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK19 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK19 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 196 active?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 195 active and Fault Code 196 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 196 active?
STEP 3. | Check the harness. |
 | STEP 3A. Inspect the ECM and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit to ground in the harness. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 196 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an appropriate ECM response after 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active and Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant level sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES NO

A damaged engine coolant level sensor has been detected.

Replace the engine coolant level sensor. Refer to Procedure 019-017 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the engine coolant level SIGNAL pin at the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit between pins has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance and check for a short circuit between the engine coolant level sensor SIGNAL pin at the OEM harness ECM connector and ECM power supply ground. Refer to Procedure 019-610 in the Associated Procedures Table.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit between pins has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID & Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 196 (3-Wire Sensor) - Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 196 active?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 195 active and Fault Code 196 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 196 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin to ECM power supply ground short circuit. | Greater than 100k ohms.
 | STEP 3F. Check for an active fault code. | Fault Code 196 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and engine coolant level sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine coolant level SUPPLY pin and the engine coolant level RETURN pin at the engine coolant level sensor connector of the OEM harness.

Reference a wiring diagram for connector in identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 4.75 and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor SIGNAL pin at the engine coolant level sensor connector of the OEM harness.

Reference a circuit diagram or wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active and Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant level sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant level sensor. Refer to Procedure 019-017 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SUPPLY pin and the OEM harness engine coolant level sensor connector SUPPLY pin.

Reference a circuit and wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SIGNAL pin and the OEM harness engine coolant level sensor connector SIGNAL pin.

Reference a circuit and wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference a circuit and wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the short circuit

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin to ECM power supply ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin to ECM power supply ground short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and ECM power supply ground. Refer to Procedure 019-610 in the Associated Procedures Table.

Reference a circuit and wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ECM power supply ground short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ECM power supply ground.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES NO

Troubleshooting procedures need to be repeated from the beginning.

None. The removal and installation of the connector corrected the fault.

Go to 1A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 197 - Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 197. | Active or inactive counts of Fault Code 197?
STEP 2. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 197.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 197?
YES NO

Add coolant to the engine. Refer to Procedure 008-018 in the Associated Procedures Table.

See the Coolant Loss troubleshooting symptom tree in Section TS.

If Fault Code 197 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. See the equipment manufacturer service information before replacing the coolant level sensor.

No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check the ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 212 - Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 212 active?
STEP 2. | Check the engine oil temperature sensor and circuit. |
 | STEP 2A. Inspect the engine oil temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Between 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 212 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 213 active and Fault Code 212 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 212 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent or inactive fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine oil temperature sensor and circuit.

Guided Step 2A - Inspect the engine oil temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin and the engine oil temperature sensor RETURN pin at the engine oil temperature sensor.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 180 ohms to 160k ohms?
YES NO
No Repair

Replace the engine oil temperature sensor. Refer to Procedure 019-067 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine oil temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine oil temperature sensor SIGNAL pin and the engine oil temperature sensor RETURN pin at the ECM connector.

See the circuit diagram or wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 active and Fault Code 212 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine oil temperature sensor RETURN pin and the engine harness engine oil temperature sensor connector RETURN pin.

Use a wiring diagram for pin identification and the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine oil temperature sensor SIGNAL pin and the engine harness engine oil temperature sensor connector SIGNAL pin.

Use a wiring diagram for pin identification and the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signalcircuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 1A

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 213 - Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 213 active?
STEP 2. | Check the engine oil temperature sensor and circuit. |
 | STEP 2A. Inspect the engine oil temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Fault Code 212 active and Fault Code 213 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 213 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 212 active and Fault Code 213 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin to ECM power supply ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 145 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent and inactive fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine oil temperature sensor and circuit.

Guided Step 2A - Inspect the engine oil temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Inspect the engine harness and engine oil temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active and Fault Code 213 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine oil temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant temperature sensor. Refer to Procedure 019-067 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active and Fault Code 213 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin to ECM power supply ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for a pin to ECM power supply ground short.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin in the engine harness ECM connector and ECM power supply ground. Refer to Procedure 019-610 in the Associated Procedures Table.

See the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ECM power supply ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 active?
YES NO

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 214 - Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 214. | Active or inactive counts of Fault Code 214?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 214.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 214?
YES | NO
No Repair | No Repair

Reference the Lubricating Oil Temperature Above Specification troubleshooting symptom tree in Section TS.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 221 - Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 221 active?
STEP 2. | Check the barometric pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 222 active and Fault Code 221 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 221 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the barometric air pressure sensor and circuit.

Guided Step 2A - Inspect the barometric air pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric air pressure sensor from the engine harness.

Action

Inspect the engine harness and barometric air pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure +5 volt SUPPLY pin to the barometric pressure RETURN pin at the sensor connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the barometric pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active?
YES NO

A damaged sensor has been detected.

Replace the barometric pressure sensor.

Refer to Procedure 019-004 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active?
YES NO

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure 5 volt SUPPLY pin to the barometric pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active?
YES NO

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 19-May-2016


FAULT CODE 222 - Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 222 active?
STEP 2. | Check the barometric air pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric air pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 221 active and Fault Code 222 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 222 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect engine control module ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate faullt code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the barometric pressure sensor and circuit.

Guided Step 2A - Inspect the barometric pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness.

Action

Inspect the engine harness connector and barometric pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure 5 volt SUPPLY pin to the barometric pressure RETURN (sensor RETURN 2) pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

Place a jumper wire between the barometric pressure +5 volt SUPPLY pin and the barometric air pressure SIGNAL pin at the barometric air pressure sensor connector of the engine harness.

Usethe circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active and Fault Code 222 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the barometric pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active?
YES NO

A damaged sensor has been detected.

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness connector and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure +5 volt SUPPLY pin to the barometric air pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 and 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active?
YES NO

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness connector and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Use the circuit diagram or wiring diagram for all harness interconnections. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

Place a jumper wire between the barometric pressure +5 volt SUPPLY (sensor SUPPLY 2) pin and the barometric pressure SIGNAL pin at the ECM engine connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active and Fault Code 222 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active?
YES NO

An open or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 05-Apr-2016


FAULT CODE 227 - Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 227 active?
STEP 2. | Check the ECM. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 227 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

There is a short circuit to a voltage source in the engine harness sensor supply 2 line.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 1A

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 228 - Coolant Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault code 228. | Active or inactive counts of Fault Code 228?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 228.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 228?
YES | NO
No Repair | No Repair

Reference the Coolant Pressure Low troubleshooting symptom tree in Section TS.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 19-May-2016


FAULT CODE 231 - Coolant Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Coolant Pressure Sensor | Refer to Procedure 019-016 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 231 active?
STEP 2. | Check the coolant pressure sensor and circuit. |
 | STEP 2A. Inspect the coolant pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 232 active and Fault Code 231 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 231 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 231 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the coolant pressure sensor and circuit.

Guided Step 2A - Inspect the coolant pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant pressure sensor from the engine harness.

Action

Inspect the engine harness and coolant pressure sensor pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the coolant pressure sensor or harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 232 active and Fault Code 231 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the coolant pressure 5 volt SUPPLY pin to the coolant pressure RETURN pin at the coolant pressure sensor connector of the engine harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the coolant pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 231 active?
YES NO

A damaged coolant pressure sensor has been detected.

Replace the coolant pressure sensor. Refer to Procedure 019-016 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropraite circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 232 active and Fault Code 231 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 231 active?
YES NO

A pin-to-pin short circuit has been detected on the coolant pressure SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the coolant pressure 5 volt SUPPLY pin to the coolant pressure RETURN pin at the ECM engine connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 231 active?
YES NO

An open coolant pressure RETURN circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 232 - Coolant Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Coolant Pressure Sensor | Refer to Procedure 019-016 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for active fault code. | Fault Code 232 active?
STEP 2. | Check the coolant pressure sensor and circuit. |
 | STEP 2A. Inspect the coolant pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 231 active and Fault Code 232 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 232 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 232 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the coolant pressure sensor and circuit.

Guided Step 2A - Inspect the coolant pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant pressure sensor from the engine harness.

Action

Inspect the engine harness and coolant pressure sensor pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the coolant pressure sensor harness connector.

Clean the connector and pins.

Repair the damaged harness,connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check supply voltage and return circuit.

  • Measure the voltage from the coolant pressure 5 volt SUPPLY (sensor supply 1) pin to the coolant pressure RETURN (sensor return 1) pin at the coolant pressure sensor connector of the engine harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant pressure sensor from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

Place a jumper wire between the coolant pressure 5 volt SUPPLY (sensor supply 1) pin and the coolant pressure SIGNAL pin at the coolant pressure sensor connector of the engine harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 231 active and Fault Code 232 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the coolant pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 232 active?
YES NO

A damaged coolant pressure sensor has been detected.

  • Replace the damaged coolant pressure sensor. Refer to Procedure 019-016 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60 pin connector
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the coolant pressure 5 volt SUPPLY (sensor supply 1) pin to the coolant pressure RETURN (sensor return 1) pin at the ECM 60 pin engine connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 232 active?
YES NO

An open or shorted coolant pressure SUPPLY (sensor supply 1) circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short or open circuit.

  • Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the coolant pressure 5 volt SUPPLY (sensor supply 1) pin and the coolant pressure SIGNAL pin at the ECM 60 pin engine connector.

Use the circuit diagram or wiring diagram for connector pin identification.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 231 active and Fault Code 232 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 232 active?
YES NO

An open circuit or a pin-to-pin short circuit has been detected on the coolant pressure SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series.

  • Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 234 - Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Module Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

WARNING

DO NOT OPERATE A DIESEL ENGINE WHERE THERE ARE OR CAN BE COMBUSTIBLE VAPORS. These vapors can be sucked through the air intake system and cause engine acceleration and overspeeding that can result in a fire, an explosion, and extensive property damage. Numerous safety devices are available, such as air intake shutoff devices, to minimize the risk of overspeeding where an engine, due to its application, might operate in a combustible environment, such as due to a fuel spill or gas leak. Remember, Cummins Inc. has no way of knowing the use you have for your engine. THE EQUIPMENT OWNER AND OPERATOR ARE RESPONSIBLE FOR SAFE OPERATION IN A HOSTILE ENVIRONMENT. CONSULT YOUR Cummins® AUTHORIZED REPAIR LOCATION FOR FURTHER INFORMATION.
CAUTION

If the engine speed exceeds 125 percent of rated speed, the engine must be shut off immediately or engine damage can occur.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for proper operating conditions. | Engine motoring down hill, if applicable?
 | STEP 1B. Check for an alternate fuel source. | Alternate fuel source?
 | STEP 1C. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 1D. Inspect the engine harness and engine crankshaft speed/position sensor connector pins. | Dirty or damaged pins?
 | STEP 1E. Check for an active fault at low engine rpm. | Active fault code at low rpm?
 | STEP 1F. Test the equipment. | Fault Code 234 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 234 active?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper operating conditions.

  • Check if the engine was motoring downhill when the fault was logged.

Engine motoring down hill, if applicable?
YES NO

Check for engine damage.

  • Electronics are OK.
  • Check the base engine for damage due to overspeed condition.

 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if the driver reported a uncommanded acceleration where the engine rapidly accelerated to or past 115 percent of rated rpm, followed by moderate deceleration to 115 percent of rated rpm.

Alternate fuel source?
YES NO

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine.

Action

Check the engine rpm with INSITE™ electronic service tool.

Compare the engine crankshaft speed/position sensor reading on INSITE™ electronic service tool to a mechanical tachometer or the dash tachometer.

Correct rpm reading?
YES NO
No Repair

Inspect the engine crankshaft engine speed sensor and engine camshaft speed/position sensor as outlined in Fault Codes 689 and 1376.

Go to 1D

Troubleshoot Fault Codes 689 and 1376.

Guided Step 1D - Inspect the engine harness and engine crankshaft speed/position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine crankshaft speed/position sensor connector.

Action

Inspect the engine harness and engine crankshaft speed/position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair the damaged engine crankshaft speed/position sensor.

No Repair

Go to 2A

Go to 1E

Guided Step 1E - Check for an active fault code at low engine rpm.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 234 when the engine is operating below rated rpm.

Active fault code at low rpm?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 2A

Go to 1F

Guided Step 1F - Test the equipment.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Test the equipment in a road test or if it stationary, operate under normal operating conditions, to determine if the overspeed condition is still present.

Fault Code 234 active?
YES NO

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 234 active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

No Repair

Go to 1A

Go to 2B

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting steps

Last Modified: 31-Mar-2016


FAULT CODE 235 - Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 235. | Active or inactive counts of Fault Code 235?
STEP 2. | Check the engine control module (ECM) calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 235.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 235?
YES NO

Add coolant to the engine. Refer to Procedure 008-018 in the Associated Procedures Table.

If Fault Code 235 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. See equipment manufacturer service information before replacing the coolant level sensor.

No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check the ECM calibration and clear the fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 1A

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 238 - Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 238 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Inspect the engine position sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 238 active?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 238 active?
STEP 4. | Check ECM calibration and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply and return.

Guided Step 2A - Inspect the engine position sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine position sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO
No Repair

Replace the crankshaft position sensor. Refer to Procedure 019-365 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 239 - Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 239 active?
STEP 2. | Check the engine control module (ECM). |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 239 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine control module (ECM).

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

There is a short circuit to a voltage source in the engine harness sensor SUPPLY 3 wire.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 28-Mar-2016


FAULT CODE 245 - Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 245 active?
STEP 2. | Check the fan control solenoid and circuit. |
 | STEP 2A. Inspect the fan control solenoid and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an internal short in the fan control solenoid. | Within the original equipment manufacturer (OEM) resistance specification?
 | STEP 2B-1. Check for a pin-to-ground short circuit in the fan control solenoid. |
 | STEP 2C. Check the fan control solenoid diagnostic supply voltage and SUPPLY wire. | Greater than 5 VDC?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 245 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 245 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fan control solenoid and circuit.

Guided Step 2A - Inspect the fan control solenoid and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the solenoid or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an internal short in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for low internal resistance of the fan control solenoid.

  • Use a multimeter to measure the resistance between the SIGNAL and RETURN pin of the fan control solenoid connector.

Refer to the wiring diagram for connector pin identification.

See equipment manufacturer service information.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Within the OEM resistance specification?
YES NO
No Repair

Replace the fan control solenoid. See equipment manufacturer service information.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a pin-to-ground short circuit in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-ground short circuit on one connector.

  • Measure the resistance and check for a short circuit between the fan control SIGNAL connector pin and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the fan control solenoid. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the fan control solenoid diagnostic supply voltage and SUPPLY wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and supply line.

  • Measure the voltage between the fan control SIGNAL pin and the fan control RETURN pin at the OEM harness actuator connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 5 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the solenoid or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the fan control SIGNAL pin of the OEM harness ECM connector and engine block ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the fan control SIGNAL pin of the OEM harness ECM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 245 active?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 249 - Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 249 active?
STEP 2. | Check the ambient air temperature sensor and circuit. |
 | STEP 2A. Inspect the ambient air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 256 active and Fault Code 249 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 249 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 249 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent or inactive fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ambient air temperature sensor and circuit.

Guided Step 2A - Inspect the ambient air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Inspect the OEM harness and the ambient air temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the ambient air temperature SIGNAL pin and the ambient air temperature RETURN pin at the sensor connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 256 active and Fault Code 249 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the ambient air temperature sensor to the OEM harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 active?
YES NO

A damaged ambient air temperature sensor has been detected.

Replace the ambient air temperature sensor. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector ambient air temperature sensor RETURN pin and the OEM harness ambient air temperature sensor connector RETURN pin.

Refer to the wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector ambient air temperature sensor SIGNAL pin and the OEM harness ambient air temperature sensor connector SIGNAL pin.

Refer to the wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 1A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 09-Aug-2016


FAULT CODE 251 - Engine Turbocharger Wastegate Actuator 2 Position Control - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Turbocharger Wastegate Assembly | Refer to Procedure 011-097 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3972, 3973, or 3974 active or inactive counts?
STEP 2. | Check the turbocharger wastegate 2 position sensor and circuit. |
 | STEP 2A. Inspect the turbocharger wastegate 2 motor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3972 active and Fault Code 251 inactive?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3972, 3973, or 3974 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check for turbocharger wastegate 2 position sensor and circuit.

Guided Step 2A - Inspect the turbocharger wastegate 2 motor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger wastegate 2 from the engine harness.

Action

Inspect the engine harness and turbocharger wastegate 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the turbocharger wastegate motor, whichever has the damaged pins.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger wastegate 2 from the engine harness.
  • Turn keyswitch ON.

Action

Check the appropriate circuit response.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3972 active and Fault Code 251 inactive?
YES NO

A malfunctioning turbocharger wastegate 2 has been detected. Replace the turbocharger wastegate 2.

  • Refer to Procedure 011-097 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 28-Mar-2016


FAULT CODE 256 - Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 256 active?
STEP 2. | Check the ambient air temperature sensor and circuit. |
 | STEP 2A. Inspect the ambient air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 249 active and Fault Code 256 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 256 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 256 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 256 active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for intermittent or inactive fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ambient air temperature sensor and circuit.

Guided Step 2A - Inspect the ambient air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Inspect the OEM harness and ambient air temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 active and Fault Code 256 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the ambient air temperature sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 256 active?
YES NO

Replace the ambient air temperature sensor.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the OEM harness ECM connector and ECM power supply ground.

Refer to the wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 256 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 1A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 31-Mar-2016


FAULT CODE 261 - Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine fuel temperature sensor accuracy. |
 | STEP 1A. Verify the engine fuel temperature sensor accuracy with a thermocouple or similar temperature probe. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or thermocouple reading?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the engine fuel temperature sensor accuracy.

Guided Step 1A - Verify the engine fuel temperature sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.

Action

Monitor the fuel temperature sensor reading.

  • Use INSITE™ electronic service tool to monitor the fuel temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a thermocouple reading or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or thermocouple reading?
YES NO
No Repair

Replace the engine fuel supply temperature sensor. Refer to Procedure 019-119 in the Associated Procedures Table.

Fuel Temperature Above Normal troubleshooting symptom tree in Section TS.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 28-Mar-2016


FAULT CODE 263 - Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the engine control module.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 263 active?
STEP 2. | Check the engine fuel temperature sensor and circuit. |
 | STEP 2A. Inspect the engine fuel temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 265 active and Fault Code 263 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 263 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 265 active and Fault Code 263 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 263 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine fuel temperature sensor and circuit.

Guided Step 2A - Inspect the engine fuel temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel temperature sensor 1 from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel temperature sensor 1 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the engine fuel temperature sensor 1 SIGNAL pin and engine fuel temperature sensor 1 RETURN pin at the engine harness engine fuel temperature sensor 1 connector.

Refer to the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 265 active and Fault Code 263 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine fuel temperature sensor 1 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 active?
YES NO

A damaged sensor has been detected.

Replace the engine fuel temperature sensor 1. Refer to Procedure 019-119 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the engine fuel temperature 1 SIGNAL pin and engine fuel temperature 1 RETURN pin at the ECM.

Refer to the wiring diagram for connector pin identification.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 265 active and Fault Code 263 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine fuel temperature sensor 1 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine fuel temperature sensor 1 RETURN pin and the engine harness engine fuel temperature sensor 1 connector RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine fuel temperature sensor 1 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine fuel temperature sensor 1 SIGNAL pin and the engine harness engine fuel temperature sensor 1 connector SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL wire has been detected in the engine harness.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine fuel temperature sensor 1 from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine fuel temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 active?
YES NO

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

None. The removal and installation of the connector corrected the fault.

Go to 1A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 28-Mar-2016


FAULT CODE 265 - Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 265 active?
STEP 2. | Check the engine fuel temperature sensor and circuit. |
 | STEP 2A. Inspect the engine fuel temperature sensor 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 263 active and Fault Code 265 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 265 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 263 active and Fault Code 265 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ECM power supply ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 265 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 265 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine fuel temperature sensor and circuit.

Guided Step 2A - Inspect the engine fuel temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel temperature sensor 1 from the engine harness.

Action

Inspect the engine harness and engine fuel temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-119 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel temperature sensor 1 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 active and Fault Code 265 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check for fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine fuel temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 265 active?
YES NO

A damaged sensor has been detected.

  • Replace the engine fuel temperature sensor 1. Refer to Procedure 019-119 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 active and Fault Code 265 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine fuel temperature sensor 1 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine fuel temperature sensor 1 SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected on the SIGNAL wire in the engine harness.

  • Repair or replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ECM power supply ground short in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM connector.
  • Disconnect the engine fuel temperature sensor from the engine harness.

Action

Check for a pin-to-ECM power supply ground short.

  • Measure the resistance between the engine fuel temperature sensor 1 SIGNAL pin in the engine harness ECM connector and ECM power supply ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Refer to Procedure 019-610 in the Associated Procedures Table.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short on the SIGNAL wire has been detected in the engine harness.

Repair or replace the harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 265 active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

None. The removal and installation of the connector corrected the fault.

Go to 1A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 06-Apr-2016


FAULT CODE 266 - Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Name | Procedure Number | Service Model Name | Bulletin Number
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine fuel temperature sensor 1 accuracy. |
 | STEP 1A. Verify the engine fuel temperature sensor 1 accuracy with a thermocouple or similar temperature probe. | Readings correct?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the engine fuel temperature sensor 1 accuracy.

Guided Step 1A - Verify the engine fuel temperature sensor 1 accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.

Action

Verify the engine fuel temperature sensor 1 accuracy with a thermocouple or similar temperature probe.

  • Connect the temperature probe to the engine near the fuel temperature sensor.
  • Connect INSITE™ electronic service tool.
  • Compare the engine fuel temperature sensor 1 reading on the service tool monitor screen to the reading from the temperature probe.

If no temperature measuring device is available, answer Yes to this step.

Readings will possibly need to be checked while engine is operating at normal temperature conditions 82°C [180°F].

Readings correct?
YES NO
No Repair

Sensor reading incorrect. Replace the fuel supply temperature sensor.

  • Refer to Procedure 019-119 in the Associated Procedures Table.

Refer to Fuel Temperature Above Normal Operating Range troubleshooting symptom tree in Section TS

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 31-Mar-2016


FAULT CODE 285 - SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Is communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 285 active?
STEP 3. | Check the equipment manufacturer service information, vehicle electronic control unit (VECU), and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for ECM communication with the INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with the INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Is communication between INSITE™ electronic service tool and the ECM possible?
YES NO
No Repair

A communication issue between the ECM and the data link, a damaged ECM, or an incorrect calibration is causing the fault code.

Reference the appropriate ECM - No Communication troubleshooting symptom tree in Section TT.

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 285 active?
YES | NO
No Repair | No Repair

Go to 3A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the equipment manufacturer service information, vehicle electronic control unit (VECU), and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper original equipment manufacturer (OEM) VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault. If the status column indicates " Active" for a multiplexed component, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Refer to Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the equipment manufacturer service information. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 31-Mar-2016


FAULT CODE 286 - SAE J1939 Multiplexing Configuration Error - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 286 active?
STEP 2. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the ECM and compare to the ECM configuration. | ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286 active?
YES NO
No Repair

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

Go to 2A

Repair Complete

Guided Step 2 - Check the OEM VECU and ECM for proper multiplexing configuration.

Guided Step 2A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the ECM and compare to the ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault. If the status column indicates " Active" for a multiplexed component, check that the ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Reference the Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 31-Mar-2016


FAULT CODE 319 - Real Time Clock - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Real-Time Clock Battery | Refer to Procedure 019-311 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the real-time clock battery voltage. |
 | STEP 1A. Check the real-time clock battery voltage at the battery module connector. | Between 3.3 and 3.6 VDC?
STEP 2. | Check the battery module harness. |
 | STEP 2A. Inspect the real-time clock battery and engine wire harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ECM power supply ground. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the real-time clock battery and connections.

Guided Step 1A - Check the real-time clock battery voltage at the battery module connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the real-time clock battery from the engine harness.

Action

Check the real-time clock battery voltage.

  • Measure the voltage between the real-time clock battery SUPPLY pin and the real-time clock battery RETURN (-) pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 3.3 and 3.6 VDC?
YES NO
No Repair

Replace the real-time clock battery. Refer to Procedure 019-311 in the Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 2 - Check the battery module harness.

Guided Step 2A - Inspect the real-time clock battery and engine wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the real-time clock battery from the engine harness.

Action

Inspect the real-time clock battery and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the module or harness connector.

Repair or replace the real-time clock battery or engine harness.

Repair or replace the real-time clock battery. Refer to Procedure 019-311 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the module harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only when there is damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for an open circuit in the engine harness

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Measure the following resistance:

  • The resistance between the real-time clock battery SUPPLY pin at the battery connector of the engine harness to the real-time clock battery SUPPLY pin at the ECM harness connector.
  • The resistance between the real-time clock battery RETURN (-) pin at the battery connector of the engine harness to the real-time clock battery RETURN (-) pin at the ECM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the real-time clock battery from the engine harness.

Action

Check for a short circuit.

  • Use a multimeter to measure the resistance from the real-time clock battery SUPPLY pin at the ECM connector of the engine harness to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit to ECM power supply ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the real-time clock battery from the engine harness.

Action

Check for a short circuit.

  • Use a multimeter to measure the resistance from the real-time clock battery SUPPLY pin at the ECM connector of the engine harness to ECM power supply ground. Refer to Procedure 019-610 in the Associated Procedures Table.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 05-Apr-2016


FAULT CODE 322 - Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 322 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1556 also active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the injector wiring harness and connector pins. |
 | STEP 2B. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2C. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2E. Read the fault codes. | Fault Code 322 the only active fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector 1 connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-power supply ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins or damaged wire insulation?
 | STEP 3D. Check for a pin-to-power supply ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3E. Check the engine harness for pin-to-pin short circuits. | Greater than 100k ohms?
 | STEP 3F. Read the fault codes. | Fault Codes 322 and 1556 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1556 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 1 connector.

Action

Inspect the engine wiring harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the injector wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 1 connector.

Action

  • Inspect injector 1 wiring harness. Refer to Procedure 006-026 in the Associated Procedures Table.

Damaged injector wiring harness or connector?
YES NO

Repair or replace the injector wiring harness, if possible. Refer to Procedure 006-026 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 1 connector.

Action

Check the resistance of the injector circuit.

  • Measure the resistance between the injector 1 SIGNAL pin and the injector 1 RETURN pin at the injector connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Check the continuity in the injector circuit.

  • Measure the resistance between the injector 1 SIGNAL pin and the injector 1 RETURN pin at the ECM connector of the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

An open or pin-to-pin short circuit has been detected on the injector 1 circuit.

Troubleshoot each section of the circuit to determine which one contains the open or short.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322 is the only active fault code?

YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector 1 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the injector 1 and injector 15 connectors.

Action

Inspect the engine wiring harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-power supply ground short circuit in the harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness from the injectors being tested.

Action

Check for a pin-to-power supply ground short circuit.

  • Measure the resistance between the injector 1 SIGNAL pin and ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.
  • Measure the resistance between the injector 15 SIGNAL pin and ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the shorted injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check for a pin-to-power supply ground short circuit in the harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the injector 1 and injector 15 connectors.

Action

Check for a pin-to-power supply ground short circuit.

  • Measure the resistance from the injector 1 SIGNAL pin at the ECM connector of the engine harness to ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table. Repeat the check at the injector 15 SIGNAL pin.
  • Measure the resistance from the injector 1 RETURN pin at the ECM connector of the engine harness to ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table. Repeat the check for the injector 15 RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-power supply ground short circuit has been detected in the wiring harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the injector 1 and injector 15 connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector 1 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector 15 SIGNAL pin.
  • Measure the resistance from the injector 1 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector 15 RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 322 and 1556 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process.

Repair complete.

Last Modified: 06-Mar-2017


FAULT CODE 323 - Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 323 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1552 also active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the injector wiring harness and connector pins. | Damaged injector wiring harness or connector?
 | STEP 2C. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2D. Inspect the engine wiring harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2E. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2F. Read the fault codes. | Fault Code 323 the only active fault code?
STEP 3. | Check the engine wiring harness. |
 | STEP 3A. Inspect the engine wiring harness and injector 5 connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-power supply ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine wiring harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3D. Check the engine wiring harness for a short circuit to ECM power supply ground. | Greater than 100k ohms?
 | STEP 3E. Check the engine wiring harness for pin-to-pin short circuits. | Greater than 100k ohms?
 | STEP 3F. Read the fault codes. | Fault Codes 323 and 1552 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 323 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1552 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 5 connector.

Action

Inspect the engine wiring harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the injector wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 5 connector.

Action

  • Inspect the injector 5 wiring harness. Refer to Procedure 006-026 in the Associated Procedures Table.

Damaged injector wiring harness or connector?
YES NO

Repair or replace the injector wiring harness, if possible. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 5 connector.

Action

Check the resistance of the injector circuit.

  • Measure the resistance between the injector 5 SIGNAL pin and the injector 5 RETURN pin at the injector connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine wiring harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine wiring harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Check the continuity in the injector circuit.

  • Measure the resistance between the injector 5 SIGNAL pin and the injector 5 RETURN pin at the ECM connector of the engine wiring harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

An open or pin-to-pin short circuit has been detected on the injector 5 circuit.

Troubleshoot each section of the circuit to determine which one contains the open or short.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 323 is the only active fault code?

YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine wiring harness.

Guided Step 3A - Inspect the engine wiring harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the injector 5 and injector 11 connectors.

Action

Inspect the engine wiring harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-power supply ground short circuit in the harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness from the injectors being tested.

Action

Check for a pin-to-power supply ground short circuit.

  • Measure the resistance between the injector 5 SIGNAL pin and ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.
  • Measure the resistance between the injector 11 SIGNAL pin and ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Refer to Procedure 019-610 in the Associated Procedures Table.

Greater than 100k ohms?
YES NO
No Repair

Replace the shorted injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

A damaged connection has been detected in the ECM or engine wiring harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check for a pin-to-power supply ground short circuit in the harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the injector 5 and injector 11 connectors.

Action

Check for a pin-to-power supply ground short circuit.

  • Measure the resistance from the injector 5 SIGNAL pin at the ECM connector of the engine wiring harness to ECM power supply ground. Refer to Procedure 019-610 in the Associated Procedures Table.
  • Repeat the check at the injector 11 SIGNAL pin.
  • Measure the resistance from the injector 5 RETURN pin at the ECM connector of the engine wiring harness to ECM power supply ground. Refer to Procedure 019-610 in the Associated Procedures Table.
  • Repeat the check for the injector 11 RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-power supply ground short circuit has been detected in the wiring harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine wiring harness for pin-to-pin short circuits.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the injector 5 and injector 11 connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector 5 SIGNAL pin at the ECM connector of the engine wiring harness to all other pins in the connector. Repeat the check at the injector 11 SIGNAL pin.
  • Measure the resistance from the injector 5 RETURN pin at the ECM connector of the engine wiring harness to all other pins in the connector. Repeat the check for the injector 11 RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 323 and 1552 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process.

Repair complete.

Last Modified: 06-Mar-2017


FAULT CODE 324 - Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 324 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1554 also active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the injector wiring harness and connector pins. | Damaged injector wiring harness or connector?
 | STEP 2C. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2D. Inspect the engine wiring harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2E. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2F. Read the fault codes. | Fault Code 324 the only active fault code?
STEP 3. | Check the engine wiring harness. |
 | STEP 3A. Inspect the engine wiring harness and injector 3 connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-power supply ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine wiring harness. | Dirty or damaged pins or damaged wire insulation?
 | STEP 3D. Check for a pin-to-power supply ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3E. Check the engine wiring harness for pin-to-pin short circuits. | Greater than 100k ohms?
 | STEP 3F. Read the fault codes. | Fault Codes 324 and 1554 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 324 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1554 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 3 connector.

Action

Inspect the engine wiring harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine wiring harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the injector wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 3 connector.

Action

  • Inspect the injector 3 wiring harness. Refer to Procedure 006-026 in the Associated Procedures Table.

Damaged injector wiring harness or connector?
YES NO

Repair or replace the injector wiring harness, if possible. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 3 connector.

Action

Check the resistance of the injector circuit.

  • Measure the resistance between the injector 3 SIGNAL pin and the injector 3 RETURN pin at the injector connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine wiring harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine wiring harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Check the continuity in the injector circuit.

  • Measure the resistance between the injector 3 SIGNAL pin and the injector 3 RETURN pin at the ECM connector of the engine wiring harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

An open or pin-to-pin short circuit has been detected on the injector 3 circuit.

Troubleshoot each section of the circuit to determine which one contains the open or short.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 324 is the only active fault code?

YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine wiring harness.

Guided Step 3A - Inspect the engine wiring harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the injector 3 and injector 13 connectors.

Action

Inspect the engine wiring harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-power supply ground short circuit in the harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness from the injectors being tested.

Action

Check for a pin-to-power supply ground short circuit.

  • Measure the resistance between the injector 3 SIGNAL pin and ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.
  • Measure the resistance between the injector 13 SIGNAL pin and ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the shorted injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

A damaged connection has been detected in the ECM or engine wiring harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check for a pin-to-power supply ground short circuit in the harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the injector 3 and injector 13 connectors.

Action

Check for a pin-to-power supply ground short circuit.

  • Measure the resistance from the injector 3 SIGNAL pin at the ECM connector of the engine wiring harness to ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.
  • Repeat the check at the injector 13 SIGNAL pin.
  • Measure the resistance from the injector 3 RETURN pin at the ECM connector of the engine wiring harness to ECM power supply ground at the 16-pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.
  • Repeat the check for the injector 13 RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-power supply ground short circuit has been detected in the wiring harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine wiring harness for pin-to-pin short circuits.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the injector 3 and injector 13 connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector 3 SIGNAL pin at the ECM connector of the engine wiring harness to all other pins in the connector. Repeat the check at the injector 13 SIGNAL pin.
  • Measure the resistance from the injector 3 RETURN pin at the ECM connector of the engine wiring harness to all other pins in the connector. Repeat the check for the injector 13 RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 324 and 1554 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process

Repair complete

Last Modified: 06-Mar-2017


FAULT CODE 325 - Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 325 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1553 also active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the injector wiring harness and connector pins. | Damaged injector wiring harness or connector?
 | STEP 2C. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2D. Inspect the engine wiring harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2E. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2F. Read the fault codes. | Fault Code 325 the only active fault code?
STEP 3. | Check the engine wiring harness. |
 | STEP 3A. Inspect the engine wiring harness and injector 6 connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-power supply ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine wiring harness. | Dirty or damaged pins or damaged wire insulation?
 | STEP 3D. Check for a pin-to-power supply ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3E. Check the engine wiring harness for pin-to-pin short circuits. | Greater than 100k ohms?
 | STEP 3F. Read the fault codes. | Fault Codes 325 and 1553 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 325 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1553 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 6 connector.

Action

Inspect the engine wiring harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine wiring harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the injector wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 6 connector.

Action

  • Inspect the injector 6 wiring harness. Refer to Procedure 006-026 in Associated Procedures Table.

Damaged injector wiring harness or connector?
YES NO

Repair or replace the injector wiring harness, if possible. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 6 connector.

Action

Check the resistance of the injector circuit.

  • Measure the resistance between the injector 6 SIGNAL pin and the injector 6 RETURN pin at the injector connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine wiring harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine wiring harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Check the continuity in the injector circuit.

  • Measure the resistance between the injector 6 SIGNAL pin and the injector 6 RETURN pin at the ECM connector of the engine wiring harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

An open or pin-to-pin short circuit has been detected on the injector 6 circuit.

Troubleshoot each section of the circuit to determine which one contains the open or short.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 325 is the only active fault code?

YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine wiring harness.

Guided Step 3A - Inspect the engine wiring harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the injector 6 and injector 12 connectors.

Action

Inspect the engine wiring harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-power supply ground short circuit in the harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness from the injectors being tested.

Action

Check for a pin-to-power supply ground short circuit.

  • Measure the resistance between the injector 6 SIGNAL pin and ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.
  • Measure the resistance between the injector 12 SIGNAL pin and ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the shorted injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

A damaged connection has been detected in the ECM or engine wiring harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check for a pin-to-power supply ground short circuit in the harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the injector 6 and injector 12 connectors.

Action

Check for a pin-to-power supply ground short circuit.

  • Measure the resistance from the injector 6 SIGNAL pin at the ECM connector of the engine wiring harness to ECM power supply ground at the 16-pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.
  • Repeat the check at the injector 12 SIGNAL pin.
  • Measure the resistance from the injector 6 RETURN pin at the ECM connector of the engine wiring harness to ECM power supply ground at the 16-pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.
  • Repeat the check for the injector 12 RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-power supply ground short circuit has been detected in the wiring harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine wiring harness for pin-to-pin short circuits.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the injector 6 and injector 12 connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector 6 SIGNAL pin at the ECM connector of the engine wiring harness to all other pins in the connector. Repeat the check at the injector 12 SIGNAL pin.
  • Measure the resistance from the injector 6 RETURN pin at the ECM connector of the engine wiring harness to all other pins in the connector. Repeat the check for the injector 12 RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 325 and 1553 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process

Repair complete

Last Modified: 06-Mar-2017


FAULT CODE 331 - Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 331 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1557 also active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the injector wiring harness and connector pins. | Damaged injector wiring harness or connector?
 | STEP 2C. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2D. Inspect the engine wiring harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2E. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2F. Read the fault codes. | Fault Code 331 the only active fault code?
STEP 3. | Check the engine wiring harness. |
 | STEP 3A. Inspect the engine wiring harness and injector 2 connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-power supply ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine wiring harness. | Dirty or damaged pins or damaged wire insulation?
 | STEP 3D. Check for a pin-to-power supply ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3E. Check the engine wiring harness for pin-to-pin short circuits. | Greater than 100k ohms?
 | STEP 3F. Read the fault codes. | Fault Codes 331 and 1557 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 331 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1557 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 2 connector.

Action

Inspect the engine wiring harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine wiring harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the injector wiring harness and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 2 connector.

Action

  • Inspect the injector 2 wiring harness. Refer to Procedure 006-026 in the Associated Procedure Table.

Damaged injector wiring harness or connector?
YES NO

Repair or replace the injector wiring harness, if possible. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 2 connector.

Action

Check the resistance of the injector circuit.

  • Measure the resistance between the injector 2 SIGNAL pin and the injector 2 RETURN pin at the injector connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine wiring harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine wiring harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Check the continuity in the injector circuit.

  • Measure the resistance between the injector 2 SIGNAL pin and the injector 2 RETURN pin at the ECM connector of the engine wiring harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

An open or pin-to-pin short circuit has been detected on the injector 2 circuit.

Troubleshoot each section of the circuit to determine which one contains the open or short.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 331 is the only active fault code?

YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine wiring harness.

Guided Step 3A - Inspect the engine wiring harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the injector 2 and injector 16 connectors.

Action

Inspect the engine wiring harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-power supply ground short circuit in the harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness from the injectors being tested.

Action

Check for a pin-to-power supply ground short circuit.

  • Measure the resistance between the injector 2 SIGNAL pin and ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.
  • Measure the resistance between the injector 16 SIGNAL pin and ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the shorted injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

A damaged connection has been detected in the ECM or engine wiring harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check for a pin-to-power supply ground short circuit in the harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the injector 2 and injector 16 connectors.

Action

Check for a pin-to-power supply ground short circuit.

  • Measure the resistance from the injector 2 SIGNAL pin at the ECM connector of the engine wiring harness to ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.
  • Repeat the check at the injector 16 SIGNAL pin.
  • Measure the resistance from the injector 2 RETURN pin at the ECM connector of the engine wiring harness to ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.
  • Repeat the check for the injector 16 RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-power supply ground short circuit has been detected in the wiring harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine wiring harness for pin-to-pin short circuits.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the injector 2 and injector 16 connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector 2 SIGNAL pin at the ECM connector of the engine wiring harness to all other pins in the connector. Repeat the check at the injector 16 SIGNAL pin.
  • Measure the resistance from the injector 2 RETURN pin at the ECM connector of the engine wiring harness to all other pins in the connector. Repeat the check for the injector 16 RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 331 and 1557 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process.

Repair complete.

Last Modified: 06-Mar-2017


FAULT CODE 332 - Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 332 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1555 also active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the injector wiring harness and connector pins. | Damaged injector wiring harness or connector?
 | STEP 2C. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2D. Inspect the engine wiring harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2E. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2F. Read the fault codes. | Fault Code 332 the only active fault code?
STEP 3. | Check the engine wiring harness. |
 | STEP 3A. Inspect the engine wiring harness and injector 4 connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-power supply ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine wiring harness. | Dirty or damaged pins or damaged wire insulation?
 | STEP 3D. Check for a pin-to-power supply ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3E. Check the engine wiring harness for pin-to-pin short circuits. | Greater than 100k ohms?
 | STEP 3F. Read the fault codes. | Fault Codes 332 and 1555 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 332 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1555 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 4 connector.

Action

Inspect the engine wiring harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine wiring harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the injector wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 4 connector.

Action

  • Inspect the injector 4 wiring harness. Refer to Procedure 006-026 in the Associated Procedures Table.

Damaged injector wiring harness or connector?
YES NO

Repair or replace the injector wiring harness, if possible. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 4 connector.

Action

Check the resistance of the injector circuit.

  • Measure the resistance between the injector 4 SIGNAL pin and the injector 4 RETURN pin at the injector connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine wiring harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine wiring harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Check the continuity in the injector circuit.

  • Measure the resistance between the injector 4 SIGNAL pin and the injector 4 RETURN pin at the ECM connector of the engine wiring harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

An open or pin-to-pin short circuit has been detected on the injector 4 circuit.

Troubleshoot each section of the circuit to determine which one contains the open or short.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 332 is the only active fault code?

YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine wiring harness.

Guided Step 3A - Inspect the engine wiring harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the injector 4 and injector 14 connectors.

Action

Inspect the engine wiring harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-power supply ground short circuit in the harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness from the injectors being tested.

Action

Check for a pin-to-power supply ground short circuit.

  • Measure the resistance between the injector 4 SIGNAL pin and ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.
  • Measure the resistance between the injector 14 SIGNAL pin and ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the shorted injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

A damaged connection has been detected in the ECM or engine wiring harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check for a pin-to-power supply ground short circuit in the harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the injector 4 and injector 14 connectors.

Action

Check for a pin-to-power supply ground short circuit.

  • Measure the resistance from the injector 4 SIGNAL pin at the ECM connector of the engine wiring harness to ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.
  • Repeat the check at the injector 14 SIGNAL pin.
  • Measure the resistance from the injector 4 RETURN pin at the ECM connector of the engine wiring harness to ECM power supply ground at the 16 pin power connector.
  • Refer to Procedure 019-610 in the Associated Procedures Table. Repeat the check for the injector 14 RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-power supply ground short circuit has been detected in the wiring harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine wiring harness for pin-to-pin short circuits.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the injector 4 and injector 14 connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector 4 SIGNAL pin at the ECM connector of the engine wiring harness to all other pins in the connector. Repeat the check at the injector 14 SIGNAL pin.
  • Measure the resistance from the injector 4 RETURN pin at the ECM connector of the engine wiring harness to all other pins in the connector. Repeat the check for the injector 14 RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 332 and 1555 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process.

Repair complete.

Last Modified: 06-Mar-2017


FAULT CODE 342 - Electronic Calibration Code Incompatibility - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Control Module ROM Boot | Refer to Procedure 019-427 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2727 or 3329 active?
STEP 2. | Calibrate the engine control modules (ECM)s. |
 | STEP 2A. Calibrate the ECMs. | ECMs accepted calibration?
 | STEP 2B. ROM boot the ECMs. | ROM boot procedure successful?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2727 or 3329 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Calibrate the ECMs

Guided Step 2A - Calibrate the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Calibrate the ECMs.

  • Refer to Procedure 019-032 in Section 19.

ECMs accepted calibration?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2B

Guided Step 2B - ROM boot the ECMs.

Conditions

  • Turn keyswitch OFF.

Action

ROM boot any ECMs that were not successfully calibrated.

  • Refer Procedure 019-427 in the Associated Procedures Table.

ROM boot procedure successful?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 31-Mar-2016


FAULT CODE 344 - Engine Fuel Filter (Suction Side) Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | QSK95 CM2350 K113 | 4388663
Air in Fuel | Refer to Procedure 006-003 | QSK95 CM2350 K113 | 4388663
Fuel Supply Lines | Refer to Procedure 006-024 | QSK95 CM2350 K131 | 4388663
Fuel Filter (Stage 1) | Refer to Procedure 006-075 | QSK95 CM2350 K131 | 4388663
Fuel Inlet Pressure | Refer to Procedure 006-104 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Fuel Supply Pump Intake Pressure Sensor | Refer to Procedure 019-549 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 344 active or inactive counts?
STEP 2. | Check the low-pressure fuel system. |
 | STEP 2A. Check for adequate fuel supply. | Equipment has adequate fuel supply?
 | STEP 2B. Check the fuel lines. | Kinked or damaged fuel lines?
STEP 3. | Check the low-pressure fuel system operation. |
 | STEP 3A. Check fuel inlet pressure. | Fuel inlet pressure within specification?
 | STEP 3B. Check Stage 1 fuel filter restriction. | Stage 1 fuel filter restriction within the specifications found in Procedure 005-236?
 | STEP 3C. Check the fuel supply pump intake pressure sensor. | Fuel supply pump intake pressure sensor meets specifications found in Procedure 019-549?
 | STEP 3D. Check for air in the fuel system. | Air in the fuel?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 344 active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the low-pressure fuel system.

Guided Step 2A - Check for adequate fuel supply.

Conditions

  • Turn keyswitch ON.
  • Turn engine OFF.

Action

Check for adequate fuel supply.

  • Do not rely on the equipment fuel gauge.
  • Verify there is fuel in the tank.

Equipment has adequate fuel supply?
YES NO
No Repair

Perform repairs to the equipment's tank or fuel gauge.

Add fuel to the fuel tank.

Go to 2B

Go to 4A

Guided Step 2B - Check the fuel lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the suction fuel lines for kinks or damage.

.

Kinked or damaged fuel lines?
YES NO

Replace the damaged fuel line(s). Refer to Procedure 006-024 in the Associated Procedures Table or equipment manufacturer service information.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the low-pressure fuel system operation.

Guided Step 3A - Check fuel inlet pressure.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel inlet pressure.

  • Refer to Procedure 006-104 in the Associated Procedures Table.

Fuel inlet pressure within specification?
YES NO
No Repair

If the fuel inlet gauge pressure is not within specification, inspect the following:

  • Customer fuel supply system
  • Original equipment manufacturer (OEM) fuel supply system.

If engine is equipped with multiple Stage 0 fuel-water separators, repeat fuel inlet gauge pressure measurement on each Stage 0 fuel-water separator.

Go to 3C

Go to 3B

Guided Step 3B - Check Stage 1 fuel filter restriction.

Conditions

  • Turn keyswitch ON.

Action

Check the Stage 1 fuel filter restriction.

Refer to Procedure 005-236 in the Associated Procedures Table.

Stage 1 fuel filter restriction within the specifications found in Procedure 005-236?
YES NO

High restriction in the fuel supply lines or fuel supply tank has been detected. Continue troubleshooting to determine the cause of the high restriction.

Replace any damaged or malfunctioning components. See equipment manufacturer service information.

Replace the Stage 1 fuel filters. Refer to Procedure 006-075 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3C - Check the fuel supply pump intake pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel supply pump intake pressure sensor accuracy.

Refer to Procedure 019-549 in the Associated Procedures Table.

Fuel supply pump intake pressure sensor meets specifications found in Procedure 019-549?
YES NO
No Repair

Replace the fuel supply pump intake pressure sensor. Refer to Procedure 019-549 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for air in the fuel system.

Conditions

  • Turn keyswitch ON.

Action

Check for air in the fuel.

Refer to Procedure 006-003 in the Associated Procedures Table.

Air in the fuel?
YES NO

Investigate the cause of air in fuel. Check for loose Stage 1 filters, loose fuel line fittings, and fuel line punctures. Repair or replace the malfunctioning component(s).

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 19-May-2016


FAULT CODE 349 - Transmission Output Shaft Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check external speed command input signal sending unit. |
 | STEP 1A. Check the engine control module (ECM) for active fault codes. | Fault Code 349 present?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check external speed command input signal sending unit.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • All components connected.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to view the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 349 present?
YES | NO
No Repair | No Repair

See equipment manufacturer service information.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 31-Mar-2016


FAULT CODE 351 - Injector Power Supply - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | Fault Code 441 active or inactive?
 | STEP 1B. Read the fault codes. | Fault Code 351 active?
 | STEP 1C. Read the fault codes. | Fault Code 351 present in multiple ECMs?
STEP 2. | Check the ECM power supplies. |
 | STEP 2A. Check the ECM power supply connections. | Connections tight and corrosion-free?
 | STEP 2B. Load test the ECM power supplies. | ECM power supply voltage acceptable in normal and cranking conditions?
STEP 3. | Check the ECM power supply. |
 | STEP 3A. Inspect the ECM power supply connectors and fuses. | Dirty or damaged pins?
 | STEP 3B. Check for high resistance. | Less than 0.5 ohms?
 | STEP 3C. Check for an open circuit in the ECM power return circuit. | Less than 0.5 ohms?
 | STEP 3D. Operate the engine and determine if fault code condition exists. | Fault Code 351 occurs during engine operation?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 active or inactive?
YES NO

Troubleshoot Fault Code 441 first.

 No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Operate the engine at high idle, no load,
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 active?
YES | NO
No Repair | No Repair

Go to 1C

Go to 4A

Guided Step 1C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 present in multiple ECMs?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the ECM power supplies.

Guided Step 2A - Check the ECM power supply connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the ECM power supply terminal connections on both positive (+) and negative (-) terminals for the following.

  • Looseness
  • Dirt or corrosion.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections and clean the terminals.

  • Refer to Procedure 013-007 in Section 13.
  • Refer to Procedure 013-009 in Section 13.

See equipment manufacturer service information.

Go to 2B

Go to 4A

Guided Step 2B - Load test the ECM power supplies.

Conditions

  • Turn keyswitch ON.

Action

  • Measure the voltage from the positive (+) ECM power supply terminal to the negative (-) ECM power supply terminal while trying to start the engine or use a carbon pile load tester. Refer to Procedure 013-007 in Section 13.
  • See equipment manufacturer service information.

Normal conditions:

  • At least +24 VDC.

Cranking conditions:

  • At least +18 VDC.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

ECM power supply voltage acceptable in normal and cranking conditions?
YES NO

Perform all checks in Step 3 on each ECM that has Fault Code 351 present.

Refer to Procedure 013-007 in Section 13.

See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM power supply.

Guided Step 3A - Inspect the ECM power supply connectors and fuses.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the original equipment manufacturer (OEM) harness connector from the ECM.

Action

Inspect the ECM power supply pins and fuses for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected.

Repair or replace the damaged harness, pins, fuses, or connectors.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for high resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the ECM power supply.

Action

Check for high resistance.

  • Measure the resistance between the ECM power SUPPLY (+) pins at the OEM harness connector of the ECM and the ECM power supply positive (+) connector at the ECM power supply.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 0.5 ohms?
YES NO
No Repair

High resistance has been detected in the ECM power supply circuit.

Troubleshoot all harnesses connected in series to determine which one contains the high resistance.

Repair or replace the ECM power supply harness, fuses, or fuse holders.

Use the following procedure for OEM harness repair.

Refer to Procedure 019-071 in Section 19.

Use the following procedure for engine harness repair. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the ECM power return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the ECM power supply.

Action

Check for high resistance in the ECM return circuit.

  • Measure the resistance between the ECM power supply negative (-) pins at the OEM harness connector of the ECM and the ECM power supply negative (-) connector at the battery.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 0.5 ohms?
YES NO
No Repair

High resistance has been detected in the ECM power return circuit.

Troubleshoot all harnesses connected in series to determine which one contains the high resistance.

Repair or replace the harness.Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.

Use the following procedure for engine harness repair. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Operate the engine and determine if fault code condition exists.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and determine whether the fault code condition still exists.

  • Operate the engine at high idle, no load.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 occurs during engine operation?
YES NO

Replace the ECMs that have Fault Code 351 active. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connectors corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision numbers are found in the Calibration Information section of System ID and Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 352 (Source Address 00) - Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Coolant Pressure Sensor | Refer to Procedure 019-016 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK95 CM2350 K113 | 4388663
Camshaft Position Sensor | Refer to Procedure 019-363 | QSK95 CM2350 K113 | 4388663
Crankshaft Pressure Sensor | Refer to Procedure 019-445 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 352 active?
STEP 2. | Check the sensors and circuits connected to the sensor number 1 supply and return. |
 | STEP 2A. Inspect the camshaft position sensor and circuits connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the engine oil pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Inspect the engine coolant pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2D. Inspect the engine fuel delivery pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2D-1. Check the circuit response. |
 | STEP 2E. Check the engine crankcase pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2E-1. Check the circuit response. |
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 352 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor number 1 supply and return.

Guided Step 2A - Inspect the camshaft position sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Inspect the engine harness and camshaft position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure Refer to 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the camshaft position sensor.

Refer to Procedure 019-363 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the engine oil pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Inspect the engine harness and the engine oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the engine oil pressure sensor.

Refer to Procedure 019-066 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the engine coolant pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant pressure sensor from the engine harness.

Action

Inspect the engine harness and engine coolant pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the engine coolant pressure sensor.

Refer to Procedure 019-016 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine fuel delivery pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel delivery pressure sensor from the engine harness.

Action

Inspect the engine harness and engine fuel delivery pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D-1

Guided Step 2D-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel delivery pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the engine fuel delivery pressure sensor.

Go to 2E

Go to 4A

Guided Step 2E - Check the engine crankcase pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine crankcase pressure sensor from the engine harness.

Action

Inspect the engine harness and aftertreatment fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E-1

Guided Step 2E-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the engine crankcase pressure sensor.

Refer to Procedure 019-445 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

A short circuit has been dectected in the engine harness.

Troubleshoot all harnesses connected in the series.

Repair or replace the damaged section of the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 31-Mar-2016


FAULT CODE 352 (Source Address 01) - Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Pre-Filter Oil Pressure Sensor | Refer to Procedure 019-126 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 352 active?
STEP 2. | Check the sensors and circuits connected to the sensor number 1 supply and return. |
 | STEP 2A. Inspect the engine pre-oil filter pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the engine post-oil filter pressure sensor, if equipped, and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 352 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the sensors and circuits connected to the sensor number 1 supply and return.

Guided Step 2A - Inspect the engine pre-oil filter pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine pre-oil filter pressure sensor from the engine harness.

Action

Inspect the engine harness and engine pre-oil filter pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure Refer to 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine pre-oil filter pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO

Replace the engine pre-oil filter pressure sensor.

Refer to Procedure 019-126 in the Associated Procedures Table.

 No Repair

Go to 2B

Go to 4A

Guided Step 2B - Inspect the engine post-oil filter pressure sensor, if equipped, and circuit connected to the sensor number 1 supply and return.

Conditions

  • If the engine is not equipped with a post-oil filter pressure sensor skip to step 3A.
  • Turn the keyswitch OFF.
  • Disconnect the engine post-oil filter pressure sensor from the engine harness.

Action

Inspect the engine harness and the engine post-oil filter pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine post-oil filter pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO

Replace the engine post-oil filter pressure sensor.

Refer to Procedure 019-447 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO

Replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

A short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 06-Apr-2016


FAULT CODE 386 - Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 386 active?
STEP 2. | Check the engine control module (ECM) and engine harness. |
 | STEP 2A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 386 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 386 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins. Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

There is a short circuit to a voltage source in the engine harness sensor SUPPLY 1 wire.

Replace the damaged section of the wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 06-Apr-2016


FAULT CODE 415 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 415?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine running at idle speed.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 415?
YES NO

Low engine oil pressure has been detected.

Refer to the Lubricating Oil Pressure Low troubleshooting symptom tree in Section TS.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 31-Mar-2016


FAULT CODE 421 - Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 421. | Active or inactive counts of Fault Code 421?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 421.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 421?
YES | NO
No Repair | No Repair

Refer to the Lubricating Oil Temperature Above Specification troubleshooting symptom tree in Section TS.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 31-Mar-2016


FAULT CODE 426 - J1939 Network #1 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following service tools when taking a measurement: Part Number 3163151 - ECM Bench Top Calibration Harness and Part Number 3164185 - ECM Bench Calibration Adapter Cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the SAE J1939 data link communication. |
 | STEP 1A. Check for engine control module (ECM) communication with INSITE™ electronic service tool. | INSITE™ electronic service tool communicate with the ECM?
 | STEP 1B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1C. Check ECM communication with the ECM bench calibration harness. | INSITE™ electronic service tool communicate with the ECM?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the SAE J1939 data link communication.

Guided Step 1A - Check for ECM communication with the INSITE™ electronic service tool.

Conditions

  • Connect the INLINE™ 5 data link adapter to the vehicle SAE J1939 data link diagnostic connector.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to communicate with the ECM.

  • Use an INLINE™ (J1939) ECM connection to start INSITE™ electronic service tool and connect to the ECM.

INSITE™ electronic service tool communicate with the ECM?
YES NO

The ECM SAE J1939 data link circuit is functioning properly.

 No Repair

See equipment manufacturer service information for information on troubleshooting and vehicle SAE J1939 data link network.

Go to 1B

Guided Step 1B - Inspect the OEM engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connectors and pins.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check ECM communication with the ECM bench calibration harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Connect the ECM bench calibration harness to the ECM connector.
  • Connect the INLINE™ data link adapter.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to attempt to communicate with the ECM.

  • Start INSITE™ electronic service tool and connect to the ECM using an INLINE™ (J1939) ECM connection.

INSITE™ electronic service tool communicate with the ECM?
YES NO

The INSITE™ electronic service tool is able to communicate with the ECM. This indicates that the ECM data link circuit is functioning properly.

See equipment manufacturer service information on troubleshooting the vehicle SAE J1939 data link network.

 No Repair

See equipment manufacturer service information.

Reference the Communication Error - Electronic Service Tool or Control Device troubleshooting symptom tree in Section TT.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 31-Mar-2016


FAULT CODE 431 - Accelerator Pedal or Lever Idle Validation Circuit - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the integrated sensor switch. |
 | STEP 1A. Verify the integrated sensor switch is connected to the original equipment manufacturer (OEM) harness. | Integrated sensor switch connected to the OEM harness?
 | STEP 1B. Inspect the integrated sensor switch and connector pins. | Dirty or damaged pins?
 | STEP 1C. Check the integrated sensor switch for an open circuit. | Less than 125 ohms?
 | STEP 1D. Check the integrated sensor switch for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Check the OEM harness for an open circuit. | Greater than 4.0 VDC?
 | STEP 2B. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the OEM harness for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check the OEM harness switch return circuit. | Less than 10 ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2F. Check for a short circuit in the OEM harness ECM power supply (+) circuit. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable and clear the fault code. | Fault code active?

Guided Step 1 - Check the integrated sensor switch.

Guided Step 1A - Verify the integrated sensor switch is connected to the original equipment manufacturer (OEM) harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the integrated sensor switch is connected to the harness.

Verify the integrated sensor switch is connected to the OEM harness.

Integrated sensor switch connected to the OEM harness?
YES NO
No Repair

Connect the integrated sensor switch to the OEM harness. See equipment manufacturer service information.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the integrated sensor switch connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the integrated sensor switch from the OEM harness.

Action

Inspect the OEM harness and integrated sensor switch connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Mintegrated sensor switching or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 1C

Guided Step 1C - Check the integrated sensor switch for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the integrated sensor switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the idle validation on-idle SIGNAL pin and switch RETURN pin of the integrated sensor switch connector with the pedal or lever released.
  • Measure the resistance between the idle validation off-idle SIGNAL pin and switch RETURN pin of the integrated sensor switch connector with the pedal or lever depressed.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement technique. Refer to Procedure 019-360 in Section 19.

Less than 125 ohms?
YES NO
No Repair

Replace the integrated sensor switch. See equipment manufacturer service information.

Go to 1D

Go to 3A

Guided Step 1D - Check the integrated sensor switch for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the integrated sensor switch from the OEM harness.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the idle validation on-idle SIGNAL pin and idle validation off-idle SIGNAL pin of the integrated sensor switch connector with the pedal or lever released and depressed.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement technique. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the integrated sensor switch. See equipment manufacturer service information.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Check the OEM harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the integrated sensor switch from the OEM harness.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure the voltage from the idle validation on-idle SIGNAL pin in the integrated sensor switch connector of the OEM harness to the switch RETURN pin in the integrated sensor switch connector of the OEM harness.
  • Measure the voltage from the idle validation off-idle SIGNAL pin in the integrated sensor switch connector of the OEM harness to the switch RETURN pin in the integrated sensor switch connector of the OEM harness.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 4.0 VDC?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2B

Guided Step 2B - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Mintegrated sensor switching or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the OEM harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the integrated sensor switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance of the idle validation on-idle SIGNAL wire in the OEM harness between the ECM connector and the integrated sensor switch connector.
  • Measure the resistance of the idle validation off-idle SIGNAL wire in the OEM harness between the ECM connector and the integrated sensor switch connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement technique. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the OEM harness switch return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the integrated sensor switch from the OEM harness.

Action

Check for an open switch return circuit.

  • Measure the resistance of the switch RETURN wire in the OEM harness between the ECM connector and the integrated sensor switch connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement technique. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the integrated sensor switch from the OEM harness.

Action

Check for an open switch return circuit.

  • Measure the resistance between the idle validation on-idle SIGNAL pin of the OEM harness ECM connector and all other pins in the connector.
  • Measure the resistance between the idle validation off-idle SIGNAL pin of the OEM harness ECM connector and all other pins in the connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement technique. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check for a short circuit in the OEM harness ECM power supply (+) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the integrated sensor switch from the OEM harness.

Action

Short circuit on two connectors - pin-to-pin check.

  • Measure the resistance between the idle validation on-idle SIGNAL pin in the OEM harness ECM connector and the ECM power supply (+) pins in the OEM harness ECM connector.
  • Measure the resistance between the idle validation off-idle SIGNAL pin in the OEM harness ECM connector and the ECM power supply (+) pins in the OEM harness ECM connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement technique. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair complete.

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 05-Apr-2016


FAULT CODE 441 - Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

WARNING

Lifting the engine improperly can cause equipment damage, severe personnel injury, or death. Lifting must be completed by trained, experienced technicians in accordance with instructions in this manual.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 441 present in all engine control modules (ECMs)?
STEP 2. | Check the ECM power supplies. |
 | STEP 2A. Check the ECM power supply connections. | Connections tight and corrosion-free?
 | STEP 2B. Load test the ECM power supplies. | ECM power supply voltage acceptable in normal and cranking conditions?
 | STEP 2C. Attempt to start the engine. | Engine starts and runs normally?
 | STEP 2D. Check the alternator. | Voltage greater than 26 VDC?
STEP 3. | Check the harness. |
 | STEP 3A. Inspect the original equipment manufacturer (OEM) harness connector and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for high resistance in the ECM power supply and return circuit. | Less than 1 ohm?
 | STEP 3C. Check for a short circuit in the harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 present in all ECMs?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the ECM power supplies.

Guided Step 2A - Check the ECM power supply connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the ECM power supply terminal connections on both positive (+) and negative (-) terminals for the following:

  • Looseness
  • Dirt or corrosion
  • Check for add-on or accessory wiring that could be damaged and shorting out the ECM supply circuit.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections, and clean the terminals.

See equipment manufacturer service information.

Go to 2B

Go to 4A

Guided Step 2B - Load the test ECM power supplies.

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the positive (+) ECM power supply terminal to the negative (-) ECM power supply terminal while trying to start engine or use a carbon pile load tester.

See equipment manufacturer service information.

Normal conditions:

  • At least +24 VDC.

Cranking conditions:

  • At least +18 VDC.

ECM power supply voltage acceptable in normal and cranking conditions?
YES NO

Perform all checks in Step 3 on each ECM that has Fault Code 441 present.

See equipment manufacturer service information.

Go to 3A

Go to 2C

Guided Step 2C - Attempt to start the engine.

Conditions

  • Turn keyswitch ON.

Action

Start the engine.

Engine starts and runs normally?
YES NO
No Repair

Perform all checks in step 3 on each ECM that has Fault Code 441 present.

Go to 2D

Go to 3A

Guided Step 2D - Check the alternator.

Conditions

  • Operate the engine at idle.

Action

Measure the voltage from the positive (+) to the negative (-) terminal at the alternator.

Voltage greater than 26 VDC?
YES NO
No Repair

Replace the alternator. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the harness.

Guided Step 3A - Inspect the OEM harness connector and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for high resistance in the ECM power supply and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the ECM power supplies.

Action

Check for high resistance.

  • Measure the resistance between the ECM power SUPPLY (+) pins at the OEM harness connector of the ECM and the ECM power supply positive (+) connector at the ECM power supply.
  • Measure the resistance between the ECM power supply RETURN (-) pins at the OEM harness connector of the ECM and the battery negative (-) connector at the ECM power supply.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1 ohm?
YES NO
No Repair

High resistance has been detected in the ECM power supply circuit.

Troubleshoot all harnesses connected in series to determine which one contains the high resistance.

Repair or replace the harness, fuses, or fuse holders.

For OEM harness repair:

Refer to Procedure 019-071 in Section 19.

For engine harness repair:

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the ECM power supplies.

Action

Check for a short circuit in the harness.

  • Measure the resistance from the ECM power supply SUPPLY (+) pins in the OEM harness ECM connector to all other pins in the connector (except the other ECM power supply SUPPLY (+) pins).

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

Repair or replace the damaged section of harness.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the battery.

Action

Check for a short circuit to ground.

  • Measure the resistance from the ECM power SUPPLY (+) pins in the OEM harness ECM connector to ECM power supply ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

Repair or replace the damaged section of harness.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 442 - Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 442 active?
STEP 2. | Check the ECM power supply system. |
 | STEP 2A. Check the ECM power supply connection. | ECM power supplies connected properly for the system voltage required?
 | STEP 2B. Check the alternator. | Alternator charging within equipment manufacturers specifications?
STEP 3. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 442 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3B

Guided Step 2 - Check the ECM power supply system.

Guided Step 2A - Check the ECM power supply connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the ECM power supply connections.

  • Check to make sure ECM power supplies are installed correctly.

ECM power supplies connected properly for the system voltage required?
YES NO
No Repair

Install the ECM power supply system correctly. See equipment manufacturer service information.

Go to 2B

Go to 3A

Guided Step 2B - Check the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use an original equipment manufacturer (OEM) ammeter or install an ammeter between the alternator and the battery.

Action

Check the alternator.

  • Start the engine and check the alternator charging rate (amperes).

Place a load on the batteries, if necessary, to measure the alternator output properly.

Alternator charging within equipment manufacturers specifications?
YES NO
No Repair

Repair or replace the alternator, regulator, and/or the equipment manufacturers wiring to the alternator.

See equipment manufacturer service information.

Go to 3A

Go to 3A

Guided Step 3 - Check the ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 06-Apr-2016


FAULT CODE 449 - Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Pump Pressure Relief Valve | Refer to Procedure 005-256 | QSK95 CM2350 K113 | 4388663
Air in Fuel | Refer to Procedure 006-003 | QSK95 CM2350 K113 | 4388663
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSK95 CM2350 K113 | 4388663
Fuel Rail Pressure Sensor | Refer to Procedure 019-115 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 449 active or high inactive counts?
 | STEP 1B. Check for active fault codes. | Fault Code 2215, 2261, 2262, 2343, 2372, 4615, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, or 4961 active or inactive counts?
STEP 2. | Check the rail fuel pressure sensor. |
 | STEP 2A. Verify fuel rail pressure sensor part number. | Correct fuel rail pressure sensor installed for the engine control parts list (CPL)?
 | STEP 2B. Check the fuel rail pressure sensor. | Fuel rail pressure sensor meets specifications found in Procedure 019-115 in the Associated Procedures Table?
STEP 3. | Check for fuel return drain line restriction. |
 | STEP 3A. Check drain line restriction. | Fuel drain line restriction within the specifications outlined in Procedure 006-012 in the Associated Procedures Table?
STEP 4. | Check for air in the fuel. |
 | STEP 4A. Check for air in the fuel system. | Air in the fuel?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 449 active or high inactive counts?
YES NO

A malfunctioning fuel pressure relief valve has been detected.

Replace the fuel pump pressure relief valve. Refer to Procedure 005-256 in the Associated Procedures Table.

 No Repair

Go to 1B

Go to 5A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2215, 2261, 2262, 2343, 2372, 4615, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, or 4961 active or inactive counts?

YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the fuel rail pressure sensor.

Guided Step 2A - Verify fuel rail pressure sensor part number.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel rail pressure sensor and make sure it is correct for the engine CPL.

Correct fuel rail pressure sensor installed for the engine CPL?
YES NO
No Repair

Replace the fuel rail pressure sensor.

Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Check the fuel rail pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel rail pressure sensor accuracy.

Refer to Procedure 019-115 in the Associated Procedures Table.

Fuel rail pressure sensor meets specifications found in Procedure 019-115 in the Associated Procedures Table?
YES NO
No Repair

Replace the fuel rail pressure sensor.

Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check for fuel return drain line restriction.

Guided Step 3A - Check drain line restriction.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Check for excessive fuel drain line restriction.

  • Refer to Procedure 006-012 in the Associated Procedures Table.

Fuel drain line restriction within the specifications outlined in Procedure 006-012 in the Associated Procedures Table?
YES NO
No Repair

Repair the source of the high fuel drain line restriction.

Refer to Procedure 006-012 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check for air in the fuel.

Guided Step 4A - Check for air in the fuel system.

Conditions

  • Turn keyswitch ON.

Action

Check for air in the fuel.

Refer to Procedure 006-003 in the Associated Procedures Table.

Air in fuel?
YES NO

Investigate the cause of the air in fuel. Check for loose Stage 1 filters, loose fuel line fittings, and fuel line punctures. Repair or replace the malfunctioning component(s).

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-Dec-2017


FAULT CODE 451 - Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164111 - male Bosch™ test leadPart Number 3164110 - female Bosch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 or 515 active?
 | STEP 1B. Check for an active fault code. | Fault Code 451 active?
STEP 2. | Check the fuel rail pressure sensor and circuit. |
 | STEP 2A. Inspect the fuel rail pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 452 active and Fault Code 451 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 451 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 or 515 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel rail pressure sensor and circuit.

Guided Step 2A - Inspect the fuel rail pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.

Action

Inspect the engine harness and rail fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to Procedure 019-115 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the fuel rail pressure RETURN pin and the fuel rail pressure SIGNAL pin at the rail fuel pressure sensor connector of the engine harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Use the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 452 active and Fault Code 451 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the fuel rail pressure 5 volt SUPPLY pin to the fuel rail pressure RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel rail pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active?
YES NO

A damaged sensor has been detected.

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the rail fuel pressure RETURN pin and the rail fuel pressure SIGNAL pin at the ECM engine connector.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Fault Code 452 active and Fault Code 451 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active?
YES NO

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the rail fuel pressure 5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the ECM engine harness connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active?
YES NO

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 31-Mar-2016


FAULT CODE 452 - Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164111 - male Bosch™ test lead, Part Number 3164110 - female Bosch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 or 516 active?
 | STEP 1B. Check for an active fault code. | Fault Code 452 active?
STEP 2. | Check the rail fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the rail fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 451 active and Fault Code 452 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 452 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 or 516 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the rail fuel pressure sensor and circuit.

Guided Step 2A - Inspect the rail fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and rail fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the rail fuel pressure 5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the sensor connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active and Fault Code 452 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the rail fuel pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 active?
YES NO

A damaged sensor has been detected.

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the rail fuel pressure 5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the ECM engine connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 active?
YES NO

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active and Fault Code 452 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 active?
YES NO

An open return circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 488 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor intake manifold air temperature reading. |
 | STEP 1A. Monitor intake manifold air temperature reading. | Temperature sensor reading with INSITE™ electronic service tool correlates to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Monitor intake manifold air temperature reading.

Guided Step 1A - Monitor intake manifold air temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor intake manifold temperature reading.

  • Use INSITE™ electronic service tool to monitor the intake manifold air temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlates to a known value or a mechanical gauge?
YES NO

See the Intake Manifold Air Temperature Above Specification troubleshooting symptom tree in Section TS.

Replace the intake manifold 1 temperature sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

Go to the appropriate troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 31-Mar-2016


FAULT CODE 515 - Sensor Supply 6 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3823996 - female Weather-Pack™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 515 active?
STEP 2. | Check the ECM. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 515 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 515 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 515 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

There is a short circuit to a voltage source in the engine harness sensor supply 6 wire.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 31-Mar-2016


FAULT CODE 516 - Sensor Supply 6 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3823995 - male WeatherPack™ test lead, Part Number 3823996 - female WeatherPack™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 516 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Inspect the fuel rail pressure sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 516 active?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 516 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 516 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply and return.

Guided Step 2A - Inspect the fuel rail pressure sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 516 active?
YES NO
No Repair

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 516 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 31-Mar-2016


FAULT CODE 545 - Engine Turbocharger Wastegate Actuator 1 Position - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Turbocharger Wastegate Assembly | Refer to Procedure 011-097 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3925, 3971, or 3969 active or inactive counts?
STEP 2. | Check the turbocharger wastegate position sensor and circuit. |
 | STEP 2A. Inspect the turbocharger wastegate motor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3925 active and 545 inactive?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3925, 3971, or 3969 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the turbocharger wastegate motor position sensor and circuit.

Guided Step 2A - Inspect the turbocharger wastegate motor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger wastegate from the engine harness.

Action

Inspect the engine harness and turbocharger wastegate connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the turbocharger wastegate motor, whichever has the damaged pins.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger wastegate from the engine harness.
  • Turn keyswitch ON.

Action

Check the appropriate circuit response.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3925 active and 545 inactive?
YES NO

A malfunctioning turbocharger wastegate has been detected. Replace the turbocharger wastegate. Refer to Procedure 011-097 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 546 - Fuel Delivery Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Fuel Supply Pump | Refer to Procedure 005-241 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Fuel Delivery Pressure Sensor | Refer to Procedure 019-548 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault code active?
 | STEP 1B. Check for active fault codes. | Fault Code 4892 active?
 | STEP 1C. Check for an active fault code. | Fault Code 546 active?
STEP 2. | Check the fuel delivery pressure sensor and circuit. |
 | STEP 2A. Inspect the fuel delivery pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 547 active and Fault Code 546 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 546 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Inspect the engine fuel supply pump and connector pins. |
 | STEP 3A-3. Check the ECM response. |
 | STEP 3A-4. Check for an active fault code. |
 | STEP 3A-5. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4892 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 active?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel delivery pressure sensor and circuit.

Guided Step 2A - Inspect the fuel delivery pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor from the engine harness.

Action

Inspect the engine harness and fuel delivery pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken.
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 active and Fault Code 546 iactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the voltage supply and return circuit.

Measure the voltage from the fuel delivery pressure 5 volt SUPPLY pin to the fuel delivery pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel delivery pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 active?
YES NO

A damaged fuel delivery pressure sensor has been detected.

Replace the fuel delivery pressure sensor. Refer to Procedure 019-548 in the Associated Procedures Table.

An intermittent circuit malfunction has been detected. Refer to Procedure 019-362 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Inspect the engine fuel supply pump and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel supply pump from the engine harness.

Action

Inspect the engine harness and device connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the device or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3A-3

Guided Step 3A-3 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness connector to the ECM.
  • Disconnect the engine fuel supply pump from the engine harness.
  • Disconnect the fuel delivery pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 active?
YES | NO
No Repair | No Repair

Go to 3A-5

Go to 3A-4

Guided Step 3A-4 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 active?
YES NO

An intermittent circuit malfunction has been detected. Refer to Procedure 019-362 in Section 19.

A pin-to-pin short circuit has been detected on the fuel delivery pressure SIGNAL wire of the engine harness.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3A-5 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 active?
YES NO

An intermittent circuit malfunction has been detected. Refer to Procedure 019-362 in Section 19.

Replace the engine fuel supply pump. Refer to Procedure 005-241 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector pins.

Replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the voltage supply and return circuit.

  • Measure the voltage from the fuel delivery pressure 5 volt SUPPLY pin to the fuel delivery pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 active?
YES NO

  • An intermittent circuit malfunction has been detected. Refer to Procedure 019-362 in Section 19.

An open fuel delivery pressure return circuit has been detected in the engine harness.

Repair or replace the damaged section of harness. Refer to 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 547 - Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Fuel Supply Pump | Refer to Procedure 005-241 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault code active?
 | STEP 1B. Check for active fault codes. | Fault Code 4892 active?
 | STEP 1C. Check for an inactive fault code. | Fault Code 546 active?
STEP 2. | Check the fuel delivery pressure sensor and circuit. |
 | STEP 2A. Inspect the fuel delivery pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 546 active and Fault Code 547 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 547 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor voltage and return circuit. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Inspect the engine fuel supply pump and connector pins. |
 | STEP 3B-3. Check the ECM response. |
 | STEP 3B-4. Check for an active fault code. |
 | STEP 3B-5. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4892 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 active?
YES | NO
No Repair | No Repair

Use the following procedure for an active or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel delivery pressure sensor and circuit.

Guided Step 2A - Inspect the fuel delivery pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor from the engine harness.

Action

Inspect the engine harness and fuel delivery pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken.
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the voltage supply and return circuit.

  • Measure the voltage from the fuel delivery pressure 5 volt SUPPLY pin to the fuel delivery pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the fuel delivery pressure 5 volt SUPPY pin and the fuel delivery pressure SIGNAL pin at the fuel delivery pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Check for the circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 active and Fault Code 547 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel delivery pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 active?
YES NO

A damaged fuel delivery pressure sensor has been detected.

Replace the fuel delivery pressure sensor.

An intermittent circuit malfunction has been detected. Refer to Procedure 019-362 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the voltage supply and return circuit.

  • Measure the voltage from the fuel delivery pressure 5 volt SUPPLY pin to the fuel delivery pressure RETURN pin at the engine harness connector port of the ECM.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

4.75 to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 active?
YES NO

An open or shorted fuel delivery pressure 5 volt supply circuit has been detected in the engine harness.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

An intermittent circuit malfunction has been detected. Refer to Procedure 019-362 in Section 19.

An intermittent circuit malfunction has been detected. Refer to Procedure 019-362 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected at the ECM or engine harness connector.

Clean the connector pins.

Replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

Place a jumper wire between the fuel delivery pressure 5 volt SUPPLY pin and the fuel delivery pressure SIGNAL pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the circuit response at 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Inspect the engine fuel supply pump and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel supply pump from the engine harness.

Action

Inspect the engine harness and device connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the device or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3B-3

Guided Step 3B-3 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness connector to the ECM.
  • Disconnect the engine fuel supply pump from the engine harness.
  • Disconnect the fuel delivery pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

Place a jumper wire between the fuel delivery pressure 5 volt SUPPLY pin and the fuel delivery pressure SIGNAL pin at the fuel delivery pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 active?
YES | NO
No Repair | No Repair

Go to 3B-5

Go to 3B-4

Guided Step 3B-4 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 inactive?
YES NO

An intermittent circuit malfunction has been detected. Refer to Procedure 019-362 in Section 19.

An open fuel delivery pressure signal circuit or pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the damaged section of harness. Refer to 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3A-5 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 inactive?
YES NO

An intermittent circuit malfunction has been detected. Refer to Procedure 019-362 in Section 19.

Replace the engine fuel supply pump. Refer to Procedure 005-241 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 553 - Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Pump | Refer to Procedure 005-016 | QSK95 CM2350 K113 | 4388663
Air in Fuel | Refer to Procedure 006-003 | QSK95 CM2350 K113 | 4388663
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSK95 CM2350 K113 | 4388663
Fuel Rail Pressure Sensor | Refer to Procedure 019-115 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2215, 2261, 2262, 2343, 2372, 4615, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, or 4961 active or inactive counts?
STEP 2. | Check the rail fuel pressure sensor. |
 | STEP 2A. Verify fuel rail pressure sensor part number. | Correct fuel rail pressure sensor installed for the engine control parts list (CPL)?
 | STEP 2B. Check the fuel rail pressure sensor. | Fuel rail pressure sensor meets specifications found in Procedure 019-115?
STEP 3. | Check for fuel return drain line restriction. |
 | STEP 3A. Check drain line restriction. | Fuel drain line restriction within the specifications outlined in Procedure 006-012?
STEP 4. | Check for air in fuel. |
 | STEP 4A. Check for air in fuel system. | Air in fuel?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2215, 2261, 2262, 2343, 2372, 4615, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, or 4961 active or inactive counts?

YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the fuel rail pressure sensor.

Guided Step 2A - Verify fuel rail pressure sensor part number.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel rail pressure sensor and make sure it is correct for the engine CPL.

Correct fuel rail pressure sensor installed for the engine CPL?
YES NO
No Repair

Replace the fuel rail pressure sensor.

Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Check the fuel rail pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel rail pressure sensor accuracy.

Refer to Procedure 019-115 in the Associated Procedures Table.

Fuel rail pressure sensor meets specifications found in Procedure 019-115?
YES NO
No Repair

Replace the fuel rail pressure sensor.

Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check for fuel return drain line restriction.

Guided Step 3A - Check drain line restriction.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Check for excessive fuel drain line restriction.

  • Refer to Procedure 006-012 in the Associated Procedures Table.

Fuel drain line restriction within the specifications outlined in Procedure 006-012?
YES NO
No Repair

Repair the source of the high fuel drain line restriction.

Refer to Procedure 006-012 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check for air in the fuel.

Guided Step 4A - Check for air in the fuel system.

Conditions

  • Turn keyswitch ON.

Action

Check for air in the fuel.

Refer to Procedure 006-003 in the Associated Procedures Table.

Air in fuel?
YES NO

Investigate the cause of the air in fuel. Check for loose Stage 1 filters, loose fuel line fittings, and fuel line punctures. Repair or replace the malfunctioning component(s).

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 555 - Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures Table
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check sensor accuracy. |
 | STEP 1A. Verify pressure sensor accuracy. | Pressure reading 0 ± 0.25 kPa – g (0 ± 1 in H2O)?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Do not operate the engine.

Action

Use INSITE™ electronic service tool "Data Monitor/Logger" feature to verify crankcase pressure sensor accuracy.

  • Make sure the correct sensor part number is installed.
  • When checking the pressure sensor accuracy, make sure the engine is not operating.
  • Use INSITE™ electronic service tool to monitor crankcase pressure.

Pressure reading 0 ± 0.25 kPa – g (0 ± 1 in H2O)?
YES NO
No Repair

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

Refer to the Crankcase Gasses (Blowby) Excessive troubleshooting symptom tree in Section TS.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 556 - Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy, |
 | STEP 1A. Verify pressure sensor accuracy. | Pressure reading 0 ± 0.25 kPa – g (0 ± 1 in H2O)?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Do not operate the engine.

Action

Use INSITE™ electronic service tool “Data Monitor/Logger” feature to verify crankcase pressure sensor accuracy.

  • Make sure the correct sensor part number is installed.
  • When checking the pressure sensor accuracy, make sure the engine is not operating.
  • Use INSITE™ electronic service tool to monitor "Crankcase Pressure".

Pressure reading 0 ± 0.25 kPa – g (0 ± 1 in H2O)?
YES NO
No Repair

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

Reference the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree in Section TS.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 559 - Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Pump | Refer to Procedure 005-016 | QSK95 CM2350 K113 | 4388663
Air in Fuel | Refer to Procedure 006-003 | QSK95 CM2350 K113 | 4388663
Injector Supply Lines (High Pressure) | Refer to Procedure 006-051 | QSK95 CM2350 K113 | 4388663
Fuel Rail Pressure Sensor | Refer to Procedure 019-115 | QSK95 CM2350 K113 | 4388663
Fuel Delivery Pressure Sensor | Refer to Procedure 019-548 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for active fault codes. | Fault Code 2215, 2262, 2343, 2372, 4885, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, or 4961 active or inactive with more than one count in the last 25 engine hours?
STEP 2. | Check the operation of the fuel system. |
 | STEP 2A. Check for external fuel leaks. | High-pressure fuel line leaks or damage?
 | STEP 2B. Check for air in the fuel system. | Air in the fuel?
 | STEP 2C. Check the fuel delivery pressure sensor. | Fuel delivery pressure sensor meets specifications found in Procedure 019-548?
 | STEP 2D. Check the fuel rail pressure sensor. | Fuel rail pressure sensor meets specifications found in Procedure 019-115?
 | STEP 2E. Check the operation of the high-pressure fuel pump. | Fault Code 559 become active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.

Action

Check the fault codes.

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2215, 2262, 2343, 2372, 4885, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, or 4961 active or inactive with more than one count in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the operation of the fuel system.

Guided Step 2A - Check for external fuel leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the high-pressure fuel system for fuel leaking at the outer wall fuel drain hose.

  • Turn keyswitch ON.
  • Operate the engine at idle.
  • Check the high-pressure fuel system for fuel leaking at the outer wall fuel drain hose.

High-pressure fuel line leaks or damage?
YES NO

Replace any damaged high-pressure fuel supply lines. Refer to Procedure 006-051 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for air in the fuel system.

Conditions

  • Turn keyswitch OFF.

Action

Check for air in the fuel.

  • Turn keyswitch OFF.
  • Check for air in the fuel. Refer to Procedure 006-003 in the Associated Procedures Table.

Air in fuel?
YES NO

  • Investigate the cause of the air in fuel. Check for loose Stage 1 filters, loose fuel line fittings, and fuel line punctures. Repair or replace the malfunctioning component(s).

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the fuel delivery pressure sensor.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel delivery pressure sensor accuracy.

  • Install a pressure gauge onto the Compuchek™ fitting at the outlet of the Stage 2 fuel filter head.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Check the fuel delivery pressure sensor accuracy. Refer to Procedure 019-548 in the Associated Procedures Table.

Fuel delivery pressure sensor meets specifications found in Procedure 019-548?
YES NO
No Repair

  • Replace the fuel delivery pressure sensor. Refer to Procedure 019-548 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check the fuel rail pressure sensor.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel rail pressure sensor accuracy.

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Check the fuel rail pressure sensor accuracy. Refer to Procedure 019-115 in the Associated Procedures Table.

Fuel rail pressure sensor meets specifications found in Procedure 019-115?
YES NO
No Repair

  • Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check the operation of the high-pressure fuel pump.

Conditions

  • Turn keyswitch OFF.

Action

Use INSITE™ electronic service tool to verify the fault codes.

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine at rated RPM and load.
  • Use INSITE™ electronic service tool to verify the fault codes.
  • Use INSITE™ electronic service tool High-Pressure Common Rail Pressure Test to raise the rail pressure.

Fault Code 559 become active?
YES NO

  • Replace the high-pressure fuel pump assembly. Refer to Procedure 005-016 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

  • Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Escalate or call for assistance.

Last Modified: 08-Jan-2019


FAULT CODE 581 - Fuel Supply Pump Intake Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Fuel Supply Pump | Refer to Procedure 005-241 | QSK95 CM2350 K113 | 4388663
Fuel Supply Pump Intake Pressure Sensor | Refer to Procedure 019-549 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | Fault Code 4892, 4929, or 4931 active or inactive counts?
 | STEP 1B. Check for an active fault code. | Fault Code 581 active?
STEP 2. | Check the fuel supply pump intake pressure sensor and circuit. |
 | STEP 2A. Inspect the fuel supply pump intake pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 582 active and Fault Code 581 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 581 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4892, 4929, or 4931 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 581 active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for an active or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel supply pump intake pressure sensor and circuit.

Guided Step 2A - Inspect the fuel supply pump intake pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel supply pump intake pressure sensor from the fuel supply pump pigtail.

Action

Inspect the fuel supply pump pigtail and fuel supply pump intake pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damage connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or pigtail.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel supply pump intake pressure sensor from the fuel supply pump pigtail.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 582 active and Fault Code 581 inactive?
YES NO
No Repair

Replace the fuel supply pump. Refer to Procedure 005-241 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel supply pump intake pressure sensor connector from the fuel supply pump pigtail.
  • Turn keyswitch ON.

Action

Check the voltage supply and return circuit.

  • Measure the voltage from the fuel supply pump intake pressure 5 volt SUPPLY pin to the fuel supply pump intake pressure RETURN pin at the sensor connector of the pigtail.

Refer to the circuit diagram or wiring diagram for connector pin identifciation.

4.75 to 5.25 VDC?
YES NO
No Repair

Replace the fuel supply pump. Refer to Procedure 005-241 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel supply pump intake pressure sensor to the fuel supply pump pigtail.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 581 active?
YES NO

A damaged fuel supply pump intake pressure sensor has been detected.

Replace the fuel supply pump intake pressure sensor. Refer to Procedure 019-549 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 582 - Fuel Supply Pump Intake Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Fuel Supply Pump | Refer to Procedure 005-241 | QSK95 CM2350 K113 | 4388663
Fuel Inlet Pressure Measurement | Refer to Procedure 006-104 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Fuel Supply Pump Intake Pressure Sensor | Refer to Procedure 019-549 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | Fault Code 4892, 4893, 4929, or 4931 active or inactive counts?
 | STEP 1B. Check for an active fault code. | Fault Code 582 active?
STEP 2. | Check fuel inlet pressure. |
 | STEP 2A. Check fuel inlet pressure. | Fuel inlet pressure within specification?
STEP 3. | Check the fuel supply pump intake pressure sensor and circuit. |
 | STEP 3A. Inspect the fuel supply pump intake pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 3C. Check the circuit response. | Fault Code 581 active and Fault Code 582 inactive?
 | STEP 3D. Check the fault codes and verify sensor condition. | Fault Code 582 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4892, 4893, 4929, or 4931 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 582 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an active or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check fuel inlet pressure.

Guided Step 2A - Check fuel inlet pressure.

Conditions

  • Turn keyswitch ON.

Action

  • Refer to Procedure 006-104 in the Associated Procedures Table.

Fuel inlet pressure within specification?
YES NO
No Repair

If the fuel inlet gauge pressure is not within specification, inspect the following:

  • Customer fuel supply system
  • Original equipment manufacturer (OEM) fuel supply system.

If engine is equipped with multiple Stage 0 fuel-water separators, repeat fuel inlet gauge pressure measurement on each Stage 0 fuel-water separator.

Go to 3A

Go to 4A

Guided Step 3 - Check the fuel supply pump intake pressure sensor and circuit.

Guided Step 3A - Inspect the fuel supply pump intake pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel supply pump intake pressure sensor from the fuel supply pump pigtail.

Action

Inspect the fuel supply pump pigtail and fuel supply pump intake pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damage connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or pigtail.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel supply pump intake pressure sensor connector from the fuel supply pump pigtail.
  • Turn keyswitch ON.

Action

Check the voltage supply and return circuit.

  • Measure the voltage from the fuel supply pump intake pressure 5 volt SUPPLY pin to the fuel supply pump intake pressure RETURN pin at the sensor connector of the pigtail.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

Replace the fuel supply pump. Refer to Procedure 005-241 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel supply pump intake pressure sensor from the fuel supply pump pigtail.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the fuel supply pump intake pressure 5 volt SUPPLY pin and the fuel supply pump intake pressure SIGNAL pin at the fuel supply pump intake pressure sensor connector of the supply pump pigtail.

Refer to the wiring diagram for connector pin identification.

  • Check for the circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 581 active and Fault Code 582 inactive?
YES NO
No Repair

Replace the fuel supply pump. Refer to Procedure 005-241 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel supply pump intake pressure sensor to the fuel supply pump pigtail.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 582 active?
YES NO

A damaged fuel supply pump intake pressure sensor has been detected.

Replace the fuel supply pump intake pressure sensor. Refer to Procedure 019-549 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process.

Repair complete

Last Modified: 03-May-2017


FAULT CODE 611 - Engine Shut Down Hot - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 611 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault codes is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 611 active?
YES NO

This is an information only fault code that will only become active if the engine was shut down with the keyswitch before proper engine cooldown, resulting in a load factor above the maximum shut down threshold.

Troubleshoot any other fault codes or engine performance symptoms.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process

Repair complete

Last Modified: 12-May-2017


FAULT CODE 621 - Exhaust Gas Temperature Deviation Low for Cylinder 1 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K113 | 4388663
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K113 | 4388663
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K113 | 4388663
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for injector fault codes. | Fault Code 322 active or inactive counts?
 | STEP 1B. Check for crankcase pressure fault codes. | Fault Code 556 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature cylinder 1 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
 | STEP 2D. Check the overhead set. | Damaged overhead components or valve lash severely out of adjustment?
STEP 3. | Check the ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for injector fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322 active or inactive counts?
YES NO

If there are active or inactive counts of Fault Code 322, a malfunction of the injector solenoid circuit could have caused cylinder 1 exhaust gas temperature to be colder than the engine average.

No Repair

Fault Code 322 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for crankcase pressure fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Connect INSITE™ electronic service tool.

Fault Code 556 active?
YES | NO
No Repair | No Repair

Fault Code 556 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only when there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor connector from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Verify the exhaust gas temperature cylinder 1 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 1 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 1 sensor reading on INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature cylinder 1 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 1 rocker lever cover. Refer to procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 1 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash severely out of adjustment.

Damaged overhead components or valve lash severely out of adjustment?
YES NO

Adjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

Replace the cylinder 1 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check the ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 622 - Exhaust Gas Temperature Deviation Low for Cylinder 3 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K113 | 4388663
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K113 | 4388663
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K113 | 4388663
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for injector fault codes. | Fault Code 324 active or inactive counts?
 | STEP 1B. Check for crankcase pressure fault codes. | Fault Code 556 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature cylinder 3 sensor accuracy. | Exhaust gas temperature sensor reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
 | STEP 2D. Check the overhead set. | Damaged overhead components or valve lash severely out of adjustment?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for injector fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 324 active or inactive counts?
YES NO

If there are active or inactive counts of Fault Code 324, a malfunction of the injector solenoid circuit could have caused cylinder 3 exhaust gas temperature to be colder than the engine average.

No Repair

Fault Code 324 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for crankcase pressure fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 556 active?
YES | NO
No Repair | No Repair

Fault Code 556 troubleshooting tree.

Go to 1C

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only if there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor connector from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Verify the exhaust gas temperature cylinder 3 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 3 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port-side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 3 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature cylinder 3 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 3 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 3 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash severely out of adjustment.

Damaged overhead components or valve lash severely out of adjustment?
YES NO

Readjust the valve lash, if necessary. Refer to procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

Replace the cylinder 3 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 31-Mar-2016


FAULT CODE 623 - Exhaust Gas Temperature Deviation Low for Cylinder 5 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K113 | 4388663
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K113 | 4388663
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K113 | 4388663
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for injector fault codes. | Fault Code 323 active or inactive counts?
 | STEP 1B. Check for crankcase pressure fault codes. | Fault Code 556 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature cylinder 5 sensor accuracy. | Exhaust gas temperature sensor reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
 | STEP 2D. Check the overhead set. | Damaged overhead components or valve lash severely out of adjustment?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for injector fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 323 active or inactive counts?
YES NO

If there are active or inactive counts of Fault Code 323, a malfunction of the injector solenoid circuit could have caused cylinder 5 exhaust gas temperature to be colder than the engine average.

No Repair

Fault Code 323 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for crankcase pressure fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 556 active?
YES | NO
No Repair | No Repair

Fault Code 556 troubleshooting tree.

Go to 1C

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only if there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor connector from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Verify the exhaust gas temperature cylinder 5 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 5 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port-side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 5 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature cylinder 5 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 5 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 5 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash severely out of adjustment.

Damaged overhead components or valve lash severely out of adjustment?
YES NO

Readjust the valve lash, if necessary. Refer to procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

Replace the cylinder 5 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 31-Mar-2016


FAULT CODE 624 - Exhaust Gas Temperature Deviation Low for Cylinder 7 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K113 | 4388663
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K113 | 4388663
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K113 | 4388663
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for injector fault codes. | Fault Code 1548 active or inactive counts?
 | STEP 1B. Check for crankcase pressure fault codes. | Fault Code 556 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature cylinder 7 sensor accuracy. | Exhaust gas temperature sensor reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
 | STEP 2D. Check the overhead set. | Damaged overhead components or valve lash severely out of adjustment?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for injector fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1548 active or inactive counts?
YES NO

If there are active or inactive counts of Fault Code 1548, a malfunction of the injector solenoid circuit could have caused cylinder 7 exhaust gas temperature to be colder than the engine average.

No Repair

Fault Code 1548 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for crankcase pressure fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 556 active?
YES | NO
No Repair | No Repair

Fault Code 556 troubleshooting tree.

Go to 1C

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only if there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor connector from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Verify the exhaust gas temperature cylinder 7 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 7 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port-side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 7 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature cylinder 7 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 7 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 7 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash severely out of adjustment.

Damaged overhead components or valve lash severely out of adjustment?
YES NO

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

Replace the cylinder 7 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 31-Mar-2016


FAULT CODE 625 - Exhaust Gas Temperature Deviation Low for Cylinder 9 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K113 | 4388663
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K113 | 4388663
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K113 | 4388663
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for injector fault codes. | Fault Code 1622 active or inactive counts?
 | STEP 1B. Check for crankcase pressure fault codes. | Fault Code 556 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature cylinder 9 sensor accuracy. | Exhaust gas temperature sensor reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
 | STEP 2D. Check the overhead set. | Damaged overhead components or valve lash severely out of adjustment?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for injector fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1622 active or inactive counts?
YES NO

If there are active or inactive counts of Fault Code 1622, a malfunction of the injector solenoid circuit could have caused cylinder 9 exhaust gas temperature to be colder than the engine average.

No Repair

Fault Code 1622 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for crankcase pressure fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 556 active?
YES | NO
No Repair | No Repair

Fault Code 556 troubleshooting tree.

Go to 1C

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only if there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor connector from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Verify the exhaust gas temperature cylinder 9 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 9 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port-side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 9 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature cylinder 9 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 9 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 9 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash severely out of adjustment.

Damaged overhead components or valve lash severely out of adjustment?
YES NO

Readjust the valve lash, if necessary. Refer to procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

Replace the cylinder 9 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 31-Mar-2016


FAULT CODE 626 - Exhaust Gas Temperature Deviation Low for Cylinder 11 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K113 | 4388663
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K113 | 4388663
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K113 | 4388663
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for injector fault codes. | Fault Code 1552 active or inactive counts?
 | STEP 1B. Check for crankcase pressure fault codes. | Fault Code 556 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature cylinder 11 sensor accuracy. | Exhaust gas temperature sensor reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
 | STEP 2D. Check the overhead set. | Damaged overhead components or valve lash severely out of adjustment?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for injector fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1552 active or inactive counts?
YES NO

If there are active or inactive counts of Fault Code 1552, a malfunction of the injector solenoid circuit could have caused cylinder 11 exhaust gas temperature to be colder than the engine average.

No Repair

Fault Code 1552 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for crankcase pressure fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 556 active?
YES | NO
No Repair | No Repair

Fault Code 556 troubleshooting tree.

Go to 1C

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only if there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor connector from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Verify the exhaust gas temperature cylinder 11 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 11 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port-side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 11 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature cylinder 11 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 11 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 11 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash severely out of adjustment.

Damaged overhead components or valve lash severely out of adjustment?
YES NO

Readjust the valve lash, if necessary. Refer to procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

Replace the cylinder 11 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 31-Mar-2016


FAULT CODE 627 - Exhaust Gas Temperature Deviation Low for Cylinder 13 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K113 | 4388663
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K113 | 4388663
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K113 | 4388663
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for injector fault codes. | Fault Code 1554 active or inactive counts?
 | STEP 1B. Check for crankcase pressure fault codes. | Fault Code 556 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature cylinder 13 sensor accuracy. | Exhaust gas temperature sensor reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
 | STEP 2D. Check the overhead set. | Damaged overhead components or valve lash severely out of adjustment?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for injector fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1554 active or inactive counts?
YES NO

If there are active or inactive counts of Fault Code 1554, a malfunction of the injector solenoid circuit could have caused cylinder 13 exhaust gas temperature to be colder than the engine average.

No Repair

Fault Code 1554 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for crankcase pressure fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 556 active?
YES | NO
No Repair | No Repair

Fault Code 556 troubleshooting tree.

Go to 1C

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only if there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor connector from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Verify the exhaust gas temperature cylinder 13 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 13 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port-side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 13 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature cylinder 13 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 13 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 13 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash severely out of adjustment.

Damaged overhead components or valve lash severely out of adjustment?
YES NO

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

Replace the cylinder 13 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 01-Apr-2016


FAULT CODE 628 - Exhaust Gas Temperature Deviation Low for Cylinder 15 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K113 | 4388663
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K113 | 4388663
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K113 | 4388663
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for injector fault codes. | Fault Code 1556 active or inactive counts?
 | STEP 1B. Check for crankcase pressure fault codes. | Fault Code 556 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature cylinder 15 sensor accuracy. | Exhaust gas temperature sensor reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
 | STEP 2D. Check the overhead set. | Damaged overhead components or valve lash severely out of adjustment?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for injector fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1556 active or inactive counts?
YES NO

If there are active or inactive counts of Fault Code 1556, a malfunction of the injector solenoid circuit could have caused cylinder 15 exhaust gas temperature to be colder than the engine average.

No Repair

Fault Code 1556 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for crankcase pressure fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 556 active?
YES | NO
No Repair | No Repair

Fault Code 556 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only if there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor connector from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Verify the exhaust gas temperature cylinder 15 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 15 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port-side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 15 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature cylinder 15 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 15 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 15 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash severely out of adjustment.

Damaged overhead components or valve lash severely out of adjustment?
YES NO

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

Replace the cylinder 15 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 05-Apr-2016


FAULT CODE 631 - Exhaust Gas Temperature Deviation Low for Cylinder 2 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K113 | 4388663
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K113 | 4388663
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K113 | 4388663
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for injector fault codes. | Fault Code 331 active or inactive counts?
 | STEP 1B. Check for crankcase pressure fault codes. | Fault Code 556 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature cylinder 2 sensor accuracy. | Exhaust gas temperature sensor reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
 | STEP 2D. Check the overhead set. | Damaged overhead components or valve lash severely out of adjustment?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for injector fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 331 active or inactive counts?
YES NO

If there are active or inactive counts of Fault Code 331, a malfunction of the injector solenoid circuit could have caused cylinder 2 exhaust gas temperature to be colder than the engine average.

No Repair

Fault Code 331 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for crankcase pressure fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 556 active?
YES | NO
No Repair | No Repair

Fault Code 556 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only if there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor connector from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Verify the exhaust gas temperature cylinder 2 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 2 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port-side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 2 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature cylinder 2 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 2 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 2 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash severely out of adjustment.

Damaged overhead components or valve lash severely out of adjustment?
YES NO

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

Replace the cylinder 2 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 05-Apr-2016


FAULT CODE 632 - Exhaust Gas Temperature Deviation Low for Cylinder 4 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K113 | 4388663
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K113 | 4388663
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K113 | 4388663
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for injector fault codes. | Fault Code 332 active or inactive counts?
 | STEP 1B. Check for crankcase pressure fault codes. | Fault Code 556 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature cylinder 4 sensor accuracy. | Exhaust gas temperature sensor reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
 | STEP 2D. Check the overhead set. | Damaged overhead components or valve lash severely out of adjustment?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for injector fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 332 active or inactive counts?
YES NO

If there are active or inactive counts of Fault Code 332, a malfunction of the injector solenoid circuit could have caused cylinder 4 exhaust gas temperature to be colder than the engine average.

No Repair

Fault Code 332 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for crankcase pressure fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 556 active?
YES | NO
No Repair | No Repair

Fault Code 556 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only if there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor connector from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Verify the exhaust gas temperature cylinder 4 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 4 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port-side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 4 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature cylinder 4 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 4 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 4 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash severely out of adjustment.

Damaged overhead components or valve lash severely out of adjustment?
YES NO

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

Replace the cylinder 4 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 05-Apr-2016


FAULT CODE 633 - Exhaust Gas Temperature Deviation Low for Cylinder 6 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K113 | 4388663
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K113 | 4388663
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K113 | 4388663
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for injector fault codes. | Fault Code 325 active or inactive counts?
 | STEP 1B. Check for crankcase pressure fault codes. | Fault Code 556 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature cylinder 6 sensor accuracy. | Exhaust gas temperature sensor reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
 | STEP 2D. Check the overhead set. | Damaged overhead components or valve lash severely out of adjustment?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for injector fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 325 active or inactive counts?
YES NO

If there are active or inactive counts of Fault Code 325, a malfunction of the injector solenoid circuit could have caused cylinder 6 exhaust gas temperature to be colder than the engine average.

No Repair

Fault Code 325 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for crankcase pressure fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 556 active?
YES | NO
No Repair | No Repair

Fault Code 556 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only if there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor connector from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Verify the exhaust gas temperature cylinder 6 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 6 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port-side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 6 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature cylinder 6 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 6 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 6 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash severely out of adjustment.

Damaged overhead components or valve lash severely out of adjustment?
YES NO

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

Replace the cylinder 6 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 05-Apr-2016


FAULT CODE 634 - Exhaust Gas Temperature Deviation Low for Cylinder 8 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K113 | 4388663
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K113 | 4388663
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K113 | 4388663
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for injector fault codes. | Fault Code 1549 active or inactive counts?
 | STEP 1B. Check for crankcase pressure fault codes. | Fault Code 556 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature cylinder 8 sensor accuracy. | Exhaust gas temperature sensor reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
 | STEP 2D. Check the overhead set. | Damaged overhead components or valve lash severely out of adjustment?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for injector fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1549 active or inactive counts?
YES NO

If there are active or inactive counts of Fault Code 1549, a malfunction of the injector solenoid circuit could have caused cylinder 8 exhaust gas temperature to be colder than the engine average.

No Repair

Fault Code 1549 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for crankcase pressure fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 556 active?
YES | NO
No Repair | No Repair

Fault Code 556 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only if there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor connector from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Verify the exhaust gas temperature cylinder 8 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 8 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port-side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 8 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature cylinder 8 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 8 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 8 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash severely out of adjustment.

Damaged overhead components or valve lash severely out of adjustment?
YES NO

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

Replace the cylinder 8 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 05-Apr-2016


FAULT CODE 635 - Exhaust Gas Temperature Deviation Low for Cylinder 10 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K113 | 4388663
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K113 | 4388663
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K113 | 4388663
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for injector fault codes. | Fault Code 1551 active or inactive counts?
 | STEP 1B. Check for crankcase pressure fault codes. | Fault Code 556 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature cylinder 10 sensor accuracy. | Exhaust gas temperature sensor reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
 | STEP 2D. Check the overhead set. | Damaged overhead components or valve lash severely out of adjustment?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for injector fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1551 active or inactive counts?
YES NO

If there are active or inactive counts of Fault Code 1551, a malfunction of the injector solenoid circuit could have caused cylinder 10 exhaust gas temperature to be colder than the engine average.

No Repair

Fault Code 1551 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for crankcase pressure fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 556 active?
YES | NO
No Repair | No Repair

Fault Code 556 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only if there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor connector from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Verify the exhaust gas temperature cylinder 10 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 10 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port-side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 10 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature cylinder 10 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 10 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 10 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash severely out of adjustment.

Damaged overhead components or valve lash severely out of adjustment?
YES NO

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

Replace the cylinder 10 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 05-Apr-2016


FAULT CODE 636 - Exhaust Gas Temperature Deviation Low for Cylinder 12 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K113 | 4388663
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K113 | 4388663
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K113 | 4388663
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for injector fault codes. | Fault Code 1553 active or inactive counts?
 | STEP 1B. Check for crankcase pressure fault codes. | Fault Code 556 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature cylinder 12 sensor accuracy. | Exhaust gas temperature sensor reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
 | STEP 2D. Check the overhead set. | Damaged overhead components or valve lash severely out of adjustment?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for injector fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1553 active or inactive counts?
YES NO

If there are active or inactive counts of Fault Code 1553, a malfunction of the injector solenoid circuit could have caused cylinder 12 exhaust gas temperature to be colder than the engine average.

No Repair

Fault Code 1553 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for crankcase pressure fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 556 active?
YES | NO
No Repair | No Repair

Fault Code 556 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only if there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor connector from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Verify the exhaust gas temperature cylinder 12 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 12 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port-side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 12 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature cylinder 12 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 12 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 12 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash severely out of adjustment.

Damaged overhead components or valve lash severely out of adjustment?
YES NO

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

Replace the cylinder 12 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 05-Apr-2016


FAULT CODE 637 - Exhaust Gas Temperature Deviation Low for Cylinder 14 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K113 | 4388663
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K113 | 4388663
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K113 | 4388663
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for injector fault codes. | Fault Code 1555 active or inactive counts?
 | STEP 1B. Check for crankcase pressure fault codes. | Fault Code 556 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature cylinder 14 sensor accuracy. | Exhaust gas temperature sensor reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
 | STEP 2D. Check the overhead set. | Damaged overhead components or valve lash severely out of adjustment?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for injector fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1555 active or inactive counts?
YES NO

If there are active or inactive counts of Fault Code 1555, a malfunction of the injector solenoid circuit could have caused cylinder 14 exhaust gas temperature to be colder than the engine average.

No Repair

Fault Code 1555 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for crankcase pressure fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 556 active?
YES | NO
No Repair | No Repair

Fault Code 556 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only if there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor connector from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Verify the exhaust gas temperature cylinder 14 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 14 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port-side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 14 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature cylinder 14 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 14 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 14 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash severely out of adjustment.

Damaged overhead components or valve lash severely out of adjustment?
YES NO

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

Replace the cylinder 14 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 05-Apr-2016


FAULT CODE 638 - Exhaust Gas Temperature Deviation Low for Cylinder 16 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K113 | 4388663
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K113 | 4388663
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K113 | 4388663
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for injector fault codes. | Fault Code 1557 active or inactive counts?
 | STEP 1B. Check for crankcase pressure fault codes. | Fault Code 556 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature cylinder 16 sensor accuracy. | Exhaust gas temperature sensor reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
 | STEP 2D. Check the overhead set. | Damaged overhead components or valve lash severely out of adjustment?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for injector fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1557 active or inactive counts?
YES NO

If there are active or inactive counts of Fault Code 1557, a malfunction of the injector solenoid circuit could have caused cylinder 16 exhaust gas temperature to be colder than the engine average.

No Repair

Fault Code 1557 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for crankcase pressure fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 556 active?
YES | NO
No Repair | No Repair

Fault Code 556 troubleshooting tree.

Go to 1C

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only if there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor connector from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Verify the exhaust gas temperature cylinder 16 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 16 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port-side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 16 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature cylinder 16 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 16 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 16 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash severely out of adjustment.

Damaged overhead components or valve lash severely out of adjustment?
YES NO

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

Replace the cylinder 16 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 05-Apr-2016


FAULT CODE 671 - Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 671 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1618 active and Fault Code 671 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 671 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ECM power supply ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 671 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 671 active?
YES | NO
No Repair | No Repair

Use the following procedure for an active or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 1 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 1 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1618 active and Fault Code 671 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 1 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 671 active?
YES NO

Replace the exhaust gas temperature sensor 1.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 1 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 1 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ECM power supply ground short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 1 from the engine harness.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 1 SIGNAL pin in the engine harness ECM connector and ECM power supply ground.

Repair complete.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground.

Repair complete.

short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 671 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 672 - Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 672 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1521 active and Fault Code 672 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 672 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ECM power supply ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 672 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 672 active?
YES | NO
No Repair | No Repair

Use the following procedure for an active or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 3 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 3 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 3 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1521 active and Fault Code 672 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 3 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Replace the exhaust gas temperature sensor 3.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

Fault Code 672 active?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the exhaust gas temperature sensor 3.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 3 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 3 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ECM power supply ground short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 3 from the engine harness.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 3 SIGNAL pin in the engine harness ECM connector and engine block ECM power supply ground.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 672 active?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 673 - Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 673 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1522 active and Fault Code 673 active?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 673 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ECM power supply short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 672 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 673 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an active or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 5 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 5 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 5 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine unil the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1522 active and Fault Code 673 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhuast gas temperature sensor 5 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 673 active?
YES NO

Replace the exhaust gas temperature sensor 5.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhuast gas temperature sensor 5 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 5 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ECM power supply short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 5 from the engine harness.

Action

Check for a pin-to-ECM power supply short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 5 SIGNAL pin in the engine harness ECM connector and engine block ECM power supply.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 673 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to
Repair complete.

Last Modified: 20-May-2016


FAULT CODE 674 - Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 674 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1523 active and Fault Code 674 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 674 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ECM power supply short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 674 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 674 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an active or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 7 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 7 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 7 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verity the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1523 active and Fault Code 674 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 7 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 674 active?
YES NO

Replace the exhaust gas temperature sensor 7.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the original equipment manufacturer (OEM) connector from the ECM.
  • Disconnect the exhuast gas temperature sensor 7 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 7 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ECM power supply short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 7 from the engine harness.

Action

Check for a pin-to-ECM power supply short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 7 SIGNAL pin in the engine harness ECM connector and engine block ECM power supply.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 674 active ?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 675 - Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 675 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1524 active and Fault Code 675 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 675 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ECM power supply short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 675 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 675 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an active or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 9 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 9 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhuast gas temperature sensor 9 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with and idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1524 active and Fault Code 675 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 9 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 675 active?
YES NO

Replace the exhaust gas temperature sensor 9.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 9 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 9 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ECM power supply short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gast temperature sensor 9 from the engine harness.

Action

Check for a pin-to-ECM power supply short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 9 SIGNAL pin in the engine harness ECM connector and engine block ECM power supply.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 675 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A.

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 676 - Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 676 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1525 active and Fault Code 676 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 676 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ECM power supply short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 676 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 676 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an active or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 11 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 11 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 11 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service to to verify the oil temperature.
  • Operate the engine with and idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1525 active and Fault Code 676 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhuast gas temperature sensor 11 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 676 active?
YES NO

Replace the exhaust gas temperature sensor 11.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 11 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 11 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ECM power supply short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 11 from the engine harness.

Action

Check for a pin-to-ECM power supply short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 11 SIGNAL pin in the engine harness ECM connector and engine block ECM power supply.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Refer to Procedure 019-610 in the Associated Procedures Table.

Greater than 100k ohms?
YES NO
No Repair

A pin to ECM power supply short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 676 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 677 - Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 677 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1526 active and Fault Code 677 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 677 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ECM power supply short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 677 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 677 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an active or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 13 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 13 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 13 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1526 active and Fault Code 677 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 13 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 677 active?
YES NO

Replace the exhaust gas temperature sensor 13.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the exhuast gas temperature sensor 13 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 13 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ECM power supply short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 13 from the engine harness.

Action

Check for a pin-to-ECM power supply short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 13 SIGNAL pin in the engine harness ECM connector and engine block ECM power supply.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Refer to Procedure 019-610 in the Associated Procedures Table.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 677 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 678 - Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 678 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1527 active and Fault Code 678 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 678 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ECM power supply short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 678 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 678 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 15 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 15 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 15 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with and idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1527 active and Fault Code 678 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 15 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 678 active?
YES NO

Replace the exhaust gas temperature sensor 15.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the original equipment manufacturer (OEM) connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 15 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 15 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ECM power supply short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 15 from the engine harness.

Action

Check for a pin-to-ECM power supply short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 15 SIGNAL pin in the engine harness ECM connector and engine block ECM power supply.
  • Refer to Procedure 019-610 in the Associated Procedures Table.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 678 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 689 - Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 238 or 239 active?
 | STEP 1B. Check for an active fault code. | Fault Code 689 active?
STEP 2. | Check the engine speed sensor and connector. |
 | STEP 2A. Inspect the crankshaft position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the crankshaft position sensor for damage. | Damaged sensor?
STEP 3. | Check the crankshaft position sensor circuit. |
 | STEP 3A. Check the crankshaft position sensor supply voltage and return circuit. | Between 4.75 VDC to 5.25 VDC?
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check for an open crankshaft position sensor signal circuit in the engine wiring harness. |
 | STEP 3B-2. Check the crankshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness. |
 | STEP 3B-3. Inspect the air gap and target wheel. |
 | STEP 3B-4. Check the fault code and verify the crankshaft position sensor condition. |
 | STEP 3C. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3C-1. Check the sensor supply voltage and return circuit. |
 | STEP 3C-2. Check the fault code and verify crankshaft position sensor condition. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 or 239 active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an active or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine speed sensor and connector.

Guided Step 2A - Inspect the crankshaft position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Inspect the engine harness and crankshaft position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine speed sensor connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the crankshaft position sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Remove the crankshaft position sensor from the gear housing. Refer to Procedure 019-365 in the Associated Procedures Table.
  • Some natural gas engines are referenced as the engine speed sensor. Refer to Proceduere 019-365 in the Associated Procedures Table.

Action

Inspect the engine position sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by camshaft gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damaged sensor?
YES NO

A damaged sensor or mechanical damage has been detected.

Replace the sensor. If mechanical damage was observed, inspect the crankshaft gear and related components.

  • Refer to Procedure 019-365 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the crankshaft position sensor circuit.

Guided Step 3A - Check the crankshaft position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the crankshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the crankshaft position sensor +5 volt SUPPLY pin and the crankshaft position sensor 1 RETURN pin at the crankshaft position sensor connector of the engine wiring harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3C

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check for an open crankshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the crankshaft position sensor SIGNAL pin at the crankshaft position sensor engine harness connector to the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms ?
YES NO
No Repair

An open circuit in the engine harness has been detected.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check the crankshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the crankshaft position sensor SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-3

  • 4A

Guided Step 3B-3 - Inspect the air gap and target wheel.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Inspect the air gap and target wheel.

  • Remove the crankshaft position sensor from the engine block and measure the air gap at several points in the crankshaft's revolution.
  • Refer to Procedure 019-365 in the Associated Procedures Table.

Air gap within specifications?

  • Minimum Air Gap: 0.25 mm [0.009 in]
  • Maximum Air Gap: 2.25 mm [0.089 in]
  • Maximum Target Runout: 0.5 mm [0.02 in]
YES NO
No Repair

Replace or shim the sensor if air gap is out of specification. If the target runout is excessive, replace the target.

Go to 3B-4

  • 4A

Guided Step 3B-4 - Check the fault code and verify the crankshaft position sensor condition.

Conditions

  • Connect all components in the correct positions.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO

A damaged crankshaft position sensor has been detected.

Replace the crankshaft position sensor.

  • Refer to Procedure 019-365 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3C - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check for an open crankshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the crankshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the crankshaft position sensor +5 volt SUPPLY pin and the crankshaft position sensor RETURN pin at the ECM.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC to 5.25 VDC?
YES NO

A damaged connection has been detected in the engine harness.

Repair or replace the damaged harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-2

Guided Step 3C-2 - Check the fault code and verify crankshaft position sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to
Repair complete

Last Modified: 20-May-2016


FAULT CODE 691 - Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 691 active?
STEP 2. | Check the turbocharger compressor intake air temperature sensor and circuit. |
 | STEP 2A. Inspect the turbocharger compressor intake air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 692 active and Fault Code 691 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 691 active?
STEP 3. | Check the engine control module (ECM), engine harness, and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 692 active and Fault Code 691 inactive?
 | STEP 3C. Check for an open circuit in the engine harness or OEM harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness or OEM harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness or OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 691 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the turbocharger compressor intake air temperature sensor and circuit.

Guided Step 2A - Inspect the turbocharger compressor intake air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged harness, connector, or pins, if possible.

Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3854510.

Install the appropriate connector seal if it is damaged or missing.

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

Place a jumper wire between the turbocharger compressor intake temperature SIGNAL pin and the turbocharger compressor intake temperature RETURN pin at the turbocharger compressor intake temperature connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate ECM response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 active and Fault Code 691 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger compressor intake air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 active?

YES NO

A damaged sensor has been detected.

Replace the turbocharger compressor intake air temperature sensor.

  • For engines equipped with a turbocharger compressor intake air temperature sensor: Refer to Procedure 019-395 in the Associated Procedures Table.
  • For engines equipped with a turbocharger compressor intake pressure/temperature sensor: Refer to Procedure 019-466 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module (ECM), engine harness, and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM, engine harness, or OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM, engine harness, or OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM, engine harness, or OEM harness connector.

Repair the damaged harness, connector, or pins, if possible.

Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3854510.

Install the appropriate connector seal if it is damaged or missing.

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the turbocharger compressor intake air temperature sensor SIGNAL pin and the turbocharger compressor intake air temperature sensor RETURN pin at the ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 active and Fault Code 691 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness or OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness or OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector turbocharger compressor intake air temperature sensor RETURN pin and the engine harness turbocharger compressor intake air temperature sensor connector RETURN pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness or OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness or OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness or OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector turbocharger compressor intake air temperature sensor SIGNAL pin and the engine harness turbocharger compressor intake air temperature sensor connector SIGNAL pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness or OEM harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness or OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness or OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the turbocharger compressor intake air temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness or OEM harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the engine harness or OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 active?
YES NO

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

None. The removal and installation of the connector corrected the fault.

Go to 1A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 692 - Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388666
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388666
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSK95 CM2350 K113 | 4388666
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388666

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 692 active?
STEP 2. | Check the turbocharger compressor intake air temperature sensor and circuit. |
 | STEP 2A. Inspect the turbocharger compressor intake air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 691 active and Fault Code 692 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 692 active?
STEP 3. | Check the engine control module (ECM), engine harness, or original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 691 active and Fault Code 692 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness or OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ECM power supply short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 692 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for active or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the turbocharger compressor intake air temperature sensor and circuit.

Guided Step 2A - Inspect the turbocharger compressor intake air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 active and Fault Code 692 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger compressor intake air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 active?
YES NO

A damaged sensor has been detected.

Replace the turbocharger compressor intake air temperature sensor.

  • For engines equipped with a turbocharger compresssor intake air temperature sensor: Refer to Procedure 019-395 in the Associated Procedures Table.
  • For engines equipped with a turbocharger compressor intake pressure/temperature sensor: Refer to Procedure 019-466 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module (ECM), engine harness, or original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM and engine harness, and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness, OEM harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Multiple unrelated faults will become active at this time as well. These can be temporarily ignored.

Fault Code 691 active and Fault Code 692 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness or OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine turbocharger compressor intake temperature sensor from the engine harness or OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the turbocharger compressor intake air temperature SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness or OEM harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ECM power supply short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness or OEM harness.

Action

Check for a pin-to-ECM power supplyefer to Procedure 019-610 in the Associated Procedures Table.

  • Measure the resistance between the turbocharger compressor intake air temperature sensor SIGNAL pin in the engine harness ECM connector and ECM power supply ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply short circuit on the SIGNAL wire has been detected in the engine harness or OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ECM power supply circuit. Refer to Procedure 019-610 in the Associated Procedures Table.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 active?
YES NO

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

No Repair

Go to 1A

Repair Complete

Last Modified: 20-May-2016


FAULT CODE 697 - ECM Internal Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 697 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Operate engine for more than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 697 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Repair complete.

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

If Fault Code 697 does not clear, return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again. If Fault Code 697 clears, troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 02-May-2016


FAULT CODE 698 - ECM Internal Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 698 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Operate engine for more than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 698 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Repair complete.

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

If Fault Code 698 does not clear, return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again. If Fault Code 698 clears, troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 05-Apr-2016


FAULT CODE 699 (sa00) - Engine ECU Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388666

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 699 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 699 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process

Repair complete

Last Modified: 15-May-2017


FAULT CODE 699 (sa01) - Engine ECU Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388666

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 699 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 699 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process

Repair complete

Last Modified: 15-May-2017


FAULT CODE 699 (sa144) - Engine ECU Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388666

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 699 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 699 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process

Repair complete

Last Modified: 15-May-2017


FAULT CODE 699 (sa186) - Engine ECU Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388666

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 699 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 699 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process

Repair complete

Last Modified: 15-May-2017


FAULT CODE 721 - Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | BulletinNumber
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 721 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1529 active and Fault Code 721 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 721 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ECM power supply short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for active fault code. | Fault Code 721 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 721 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an active or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 2 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 2 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1529 active and Fault Code 721 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 2 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 721 active?
YES NO

Replace the exhaust gas temperature sensor 2.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 2 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 2 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ECM power supply short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 2 from the engine harness.

Action

Check for a pin-to-ECM power supply short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 2 SIGNAL pin in the engine harness ECM connector and ECM power supply circuit.

Refer to Procedure 019-610 in the Associated Procedures Table.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for active fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 721 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 722 - Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388666
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388666
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388666
ECM Power Supply Ground | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388666

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 722 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1619 active and Fault Code 722 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 722 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ECM power supply short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 722 inactive?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 722 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an active or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 4 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 4 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 4 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verigy the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1619 active and Fault Code 722 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 4 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 722 active?
YES NO

Replace the exhaust gas temperature sensor 4.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 4 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 4 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin indentification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ECM power supply short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 4 from the engine harness.

Action

Check for a pin-to-ECM power supply short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 4 SIGNAL pin in the engine harness ECM connector and ECM power supply ground circuit.

Refer to Procedure 019-610 in the Associated Procedures Table.

  • Refer to the circuit diagram or wiring diagram for connector pin indentification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 722 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to ?B

Go to ?B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 723 - Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
ECM Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 723 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1531 active and Fault Code 723 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 723 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ECM power supply short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 723 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 723 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an active or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 6 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 6 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 6 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1531 active and Fault Code 723 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 6 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 723 active?
YES NO

Replace the exhaust gas temperature sensor 6.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 6 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 6 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin indentification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ECM power supply short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 6 from the engine harness.

Action

Check for a pin-to-ECM power supply short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 6 SIGNAL pin in the engine harness ECM connector and ECM power supply ground.

Refer to Procedure 019-610 in the Associated Procedures Table.

Refer to the circuit diagram or wiring diagram for connector pin indentification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 723 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 724 - Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 724 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1532 active and Fault Code 724 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 724 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ECM power supply ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 724 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 724 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an active or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 8 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 8 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 8 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1532 active and Fault Code 724 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 8 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 724 active?
YES NO

Replace the exhaust gas temperature sensor 8.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the original equipment manufacturer (OEM) connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 8 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 8 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ECM power supply ground short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 8 from the engine harness.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 8 SIGNAL pin in the engine harness ECM connector and ECM power supply ground circuit.

Refer to Procedure 019-610 in the Associated Procedures Table.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 724 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 725 - Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
ECM Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 725 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1533 active and Fault Code 725 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 725 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ECM power supply ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 725 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 725 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an active or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 10 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 10 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 10 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1533 active and Fault Code 725 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 10 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 725 active?
YES NO

Replace the exhaust gas temperature sensor 10.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 10 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 10 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ECM power supply short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 10 from the engine harness.

Action

Check for a pin-to-ECM power supply short circuit.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

  • Measure the resistance between the exhaust gas temperature sensor 10 SIGNAL pin in the engine harness ECM connector and ECM power supply ground circuit.

Refer to Procedure 019-610 in the Associated Procedures Table.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

A pin-to-ECM power supply ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 725 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 726 - Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
ECM Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 726 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1534 active and Fault Code 726 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 726 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ECM power supply ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 726 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 726 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an active or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 12 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 12 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 12 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1534 active and Fault Code 726 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 12 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 726 active?
YES NO

Replace the exhaust gas temperature sensor 12.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 12 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 12 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ECM power supply ground short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 12 from the engine harness.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 12 SIGNAL pin in the engine harness ECM power supply ground circuit.

Refer to Procedure 019-610 in the Associated Procedures Table.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 726 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 727 - Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 727 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1535 active and Fault Code 727 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 727 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ECM power supply ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 727 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 727 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an active or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 14 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 14 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 14 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1535 active and Fault Code 727 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 14 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 727 active?
YES NO

Replace the exhaust gas temperature sensor 14.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 14 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 14 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ECM power supply ground short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the original equipment manufacturer (OEM) connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 14 from the engine harness.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 14 SIGNAL pin in the engine harness ECM power supply ground circuit.

Refer to Procedure 019-610 in the Associated Procedures Table.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 727 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 728 - Exhaust Gas Temperature Sensor Circuit Cylinder 16 (B8) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 728 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1536 active and Fault Code 728 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 728 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ECM power supply ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 728 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 728 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an active or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 16 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 16 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 16 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1536 active and Fault Code 728 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 16 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 728 active?
YES NO

Replace the exhaust gas temperature sensor 16.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the original equipment manufacturer (OEM) connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 16 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 16 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ECM power supply ground short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 16 from the engine harness.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 16 SIGNAL pin in the engine harness ECM power supply ground circuit.

Refer to Procedure 019-610 in the Associated Procedures Table.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 728 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 731 - Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Camshaft Gear, Front | Refer to Procedure 001-084 | QSK95 CM2350 K113 | 4388663
Camshaft Position Sensor | Refer to Procedure 019-363 | QSK95 CM2350 K113 | 4388663
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 731 the only active fault code?
STEP 2. | Inspect positions sensors. |
 | STEP 2A. Inspect the position sensors for damage. | Damage found?
 | STEP 2B. Inspect camshaft gear for damage. | Damage found?
STEP 3. | Inspect engine control module (ECM) power supply ground reference. |
 | STEP 3A. Inspect ECM power supply ground reference. | ECM power supply ground circuit properly grounded, free of corrosion, and tight?
STEP 4. | Check static timing. |
 | STEP 4A. Check static timing. | Timing marks properly aligned?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read fault codes.

Fault Code 731 the only active fault code?

YES NO
No Repair

Troubleshoot any other active fault codes before continuing with this tree.

Go to 2A

Go to the appropriate fault code troubleshooting tree.

Guided Step 2 - Inspect position sensors.

Guided Step 2A - Inspect position sensors for damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect crankshaft and camshaft position sensors for damage.

Damage found?
YES NO

Replace position sensor.

  • Refer to Procedure 019-363 in the Associated Procedures Table.
  • Refer to Procedure 019-365 in the Associated Procedures Table.

If camshaft position sensor is damage:

  • Inspect camshaft gear. Refer to Procedure 001-084 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Inspect camshaft gear for damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect camshaft gear for damage.

  • Refer to Procedure 001-084 in the Associated Procedures Table.

Damage found?
YES NO

Replace camshaft gear. Refer to Procedure 001-084 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Inspect ECM power supply ground reference.

Guided Step 3A - Inspect ECM power supply ground reference.

Conditions

  • Turn keyswitch OFF.

Action

Inspect ECM power supply ground reference.

  • Verify all connection at ECM power supply ground reference on original equipment manufacturer (OEM) equipment are free from corrosion and tight.

See equipment manufacturer service information.

ECM power supply ground circuit properly grounded, free of corrosion, and tight?
YES NO
No Repair

Replace, tighten, or clean ECM power supply ground wires or connections.

Go to 4A

Go to 4A

Guided Step 4 - Check static timing.

Guided Step 4A - Check static timing.

Conditions

  • Turn keyswitch OFF.

Action

Inspect timing.

  • Remove gear cover.
  • Rotate engine until right bank number 1 cylinder is at top dead center.
  • Install camshaft timing pin.
  • Confirm timing marks on camshaft compound idler gear and crankshaft gear are aligned.

Refer to Procedure 001-084 in the Associated Procedures Table.

Timing marks properly aligned?
YES NO
No Repair

Remove and install camshaft compound idler gear. Properly align timing marks.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 21-Jun-2016


FAULT CODE 782 - SAE J1939 Data Link 2 Engine Network - No Data Received - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an active fault code. | Fault Code 782 active?
 | STEP 1B. Check for related fault codes. | Fault Code 3329 active?
STEP 2. | Check the secondary engine control module (ECM) supply voltage circuits. |
 | STEP 2A. Inspect the ECM and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for correct ECM supply voltage. | Between 21 and 27 VDC?
 | STEP 2C. Check the keyswitch signal circuit. | Less than 5 ohms?
STEP 3. | Check the Society of Automotive Engineers (SAE) J1939 data link 2 circuit. |
 | STEP 3A. Inspect the engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the SAE J1939 data link 2 resistance in the engine harness. | Between 50 and 70 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE electronic service tool to read the fault codes.

Fault Code 782 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE electronic service tool to read the fault codes.

Fault Code 3329 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the secondary ECM supply voltage circuits.

Guided Step 2A - Inspect the ECM and OEM harness connector pins.

Conditions

Perform this check on ECM 2, 3, and 4.

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only if there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for correct ECM supply voltage.

Conditions

Perform this check of ECM 2, 3, and 4.

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for correct ECM supply voltage.

  • Measure the voltage between the ECM power supply voltage SUPPLY pins and the ECM power supply voltage RETURN pins in the OEM harness connector.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 21 and 27 VDC?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the keyswitch signal circuit.

Conditions

Perform this check on ECM 2, 3, and 4.

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the 16 pin power connector.

Action

Check for an open keyswitch signal circuit.

  • Measure the resistance of the keyswitch SIGNAL wire between the 16 pin power connector and the OEM harness connector at the ECM.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the SAE J1939 data link 2 circuit.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

Perform this check on each ECM.

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only if there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the SAE J1939 data link 2 resistance in the engine harness.

Conditions

Perform this check on each ECM.

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Check the SAE J1939 data link 2 engine network resistance.

  • Measure the resistance between the SAE J1939 data link 2 SUPPLY pin and the SAE J1939 data link 2 RETURN pin in the ECM engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 50 and 70 ohms?
YES NO

The SAE J1939 data link 2 resistance is within specification.

There is a problem in the calibration.

Check to make sure the appropriate calibrations are installed in the ECMs.

An open or shorted SAE J1939 data link 2 circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which one contains the open or short circuit.

Repair or replace the damaged section of engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

No Repair

Go to 1A

Repair complete.

Last Modified: 05-Apr-2016


FAULT CODE 1117 - Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 1117 present in all ECMs?
STEP 2. | Check the ECM power supply. |
 | STEP 2A. Check the ECM power supply connections. | Connections tight and corrosion-free?
 | STEP 2B. Check the power supply circuit. | Power supply harness or connectors damaged?
STEP 3. | Check the ECM and harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM power supply fuse. | Fuse damaged, corroded, or loose?
 | STEP 3C. Check the ECM power supply circuit. | Power supply harness or connectors damaged?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for fault codse.

Conditions

  • Connect components.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1117 present in all ECMs?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the ECM power supply.

Guided Step 2A - Check the ECM power supply connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the ECM power supply connections.

  • Check the ECM power supply terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections, and clean the terminals. See equipment manufacturer service information.

Go to 2B

Go to 4A

Guided Step 2B - Check the power supply circuit.

Conditions

  • Turn keyswitch ON.

Action

Inspect the power supply circuit.

  • Check for loose or corroded connectors.
  • Wiring insulation that is damaged or rubbed through.
  • Wiggle the power supply harness and check for ECMs that are intermittently losing power.

Power supply harness or connectors damaged?
YES NO

Repair or replace the damaged section of harness. See equipment manufacturer service information.

Improper use of the original equipment manufacturer (OEM) ECM power supply shut-off switches will cause Fault Code 1117 to become active.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab .

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM power supply fuse.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the ECM power supply fuse and fuse holder for the following:

  • Incorrect installation
  • Corroded or damaged connection
  • Loose connection.

Fuse damaged, corroded, or loose?
YES NO

Replace the fuse.

Repair or replace the engine harness, if necessary. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the ECM power supply circuit.

Conditions

  • Turn keyswitch ON.

Action

Inspect the power supply circuit.

  • Check for loose or corroded connectors.
  • Check for wiring insulation that is damaged or rubbed through.
  • Wiggle the power supply harness and check for ECM(s) that are intermittently losing power.

Power supply harness or connectors damaged?
YES NO

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 1135 - SAE J1939 Data Link 2 Engine Network - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an active fault code. | Fault Code 1135 active?
 | STEP 1B. Check for related fault codes. | Fault Code 3329 active?
STEP 2. | Check the secondary engine control module (ECM) supply voltage circuits. |
 | STEP 2A. Inspect the ECM and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for correct ECM supply voltage. | Between 21 and 27 VDC?
 | STEP 2C. Check the keyswitch signal circuit. | Less than 5 ohms?
STEP 3. | Check the SAE J1939 data link 2 circuit. |
 | STEP 3A. Inspect the engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the SAE J1939 data link 2 resistance in the engine harness. | Between 50 and 70 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE electronic service tool to read the fault codes.

Fault Code 1135 active?
YES | NO
No Repair | No Repair

Go to 1B
Go to

Use the following procedure for active or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE electronic service tool to read the fault codes.

Fault Code 3329 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the secondary ECM supply voltage circuits.

Guided Step 2A - Inspect the ECM and OEM harness connector pins.

Conditions

Perform this check on ECM 2, 3, and 4.

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for correct ECM supply voltage.

Conditions

Perform this check of ECM 2, 3, and 4.

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for correct ECM supply voltage.

  • Measure the voltage between the battery voltage SUPPLY pins and the battery voltage RETURN pins in the OEM harness connector.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 21 and 27 VDC?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Repair or replace the damaged section of the harness.

  • Use the following procedure for engine harness repair. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the keyswitch signal circuit.

Conditions

Perform this check on ECM 2, 3, and 4.

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the 16 pin power connector.

Action

Check for an open keyswitch signal circuit.

  • Measure the resistance of the keyswitch SIGNAL wire between the 16 pin power connector and the OEM harness connector at the ECM.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Repair or replace the damaged section of the engine harness.

Go to 3A

Go to 4A

Guided Step 3 - Check the SAE J1939 data link 2 circuit.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

Perform this check on each ECM.

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the SAE J1939 data link 2 resistance in the engine harness.

Conditions

Perform this check on each ECM.

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Check the SAE J1939 data link 2 engine network resistance.

  • Measure the resistance between the SAE J1939 data link 2 SUPPLY pin and the SAE J1939 data link 2 RETURN pin in the ECM engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 50 and 70 ohms?
YES NO

The SAE J1939 data link 2 resistance is within specification.

There is a problem in the calibration.

Check to make sure the appropriate calibrations are installed in the ECMs.

An open or shorted SAE J1939 data link 2 circuit has been detected in the engine harness.

For QSK95 CM2350 engines, check the terminating resistors and their connectors.

Troubleshoot each harness connected in series to determine which one contains the open or short circuit.

Repair or replace the damaged section of engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

No Repair

Go to 1A

Repair complete
Go to

Last Modified: 20-May-2016


FAULT CODE 1256 (Source Address 00) - Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module ( ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1256 active?
STEP 2. | Check for the correct calibration |
 | STEP 2A. Check for the correct calibration on the ECM. | Does the calibration correspond with the ECM source address and location of the ECM in the harness?
STEP 3. | Check the engine harness |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault code. | Fault Code 1256 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1256 active?
YES | NO
No Repair | No Repair

Use the following procedure for active or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check for the correct calibration

Guided Step 2A - Check for the correct calibration on the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct calibration.

  • Use INSITE™ electronic service tool to check the calibration installed on the ECM.

Does the calibration correspond with the ECM source address and location of the ECM in the harness?
YES NO
No Repair

The ECM has the wrong calibration or the ECM has been installed in the wrong location.

Download the correct calibration to the ECM or install the ECM in the correct location.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit on the connected harness keying pins.

  • Measure the resistance between the control module identification SIGNAL 1 pin and the control module identification RETURN pin in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the control module identification circuit in the harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM harness ECM connector control module identification SIGNAL 1 pin and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

A pin-to-pin short circuit has been detected in the control module identification circuit in the harness.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Repair complete.

Go to 1A

Last Modified: 20-May-2016


FAULT CODE 1256 (Source Address 01) - Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1256 active?
STEP 2. | Check for the correct calibration |
 | STEP 2A. Check for the correct calibration on the ECM. | Does the calibration correspond with the ECM source address and location of the ECM in the harness?
STEP 3. | Check the harness |
 | STEP 3A. Inspect the harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1256 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for active or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check for the correct calibration

Guided Step 2A - Check for the correct calibration on the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct calibration.

  • Use INSITE™ electronic service tool to check the calibration installed on the ECM.

Does the calibration correspond with the ECM source address and location of the ECM in the harness?
YES NO
No Repair

The ECM has the wrong calibration or the ECM has been installed in the wrong location.

Download the correct calibration to the ECM or install the ECM in the correct location.

Go to 3A

Go to 4A

Guided Step 3 - Check the harness

Guided Step 3A - Inspect the harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the original equipment manufacturer (OEM) connector minus the OEM connector from the ECM.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit on the connected harness keying pins.

  • Measure the resistance between the control module identification SIGNAL 2 pin and the control module identification RETURN pin in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the control module identification circuit in the harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM harness ECM connector control module identification SIGNAL 2 pin and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

A pin-to-pin short circuit has been detected in the control module identification circuit in the harness.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 1256 (Source Address 144) - Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an active fault code. | Fault Code 1256 active?
STEP 2. | Check for the correct calibration |
 | STEP 2A. Check for the correct calibration on the ECM. | Does the calibration correspond with the ECM source address and location of the ECM in the harness?
STEP 3. | Check the engine harness |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault code. | Fault Code 1256 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1256 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for active or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check for the correct calibration

Guided Step 2A - Check for the correct calibration on the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct calibration.

  • Use INSITE™ electronic service tool to check the calibration installed on the ECM.

Does the calibration correspond with the ECM source address and location of the ECM in the harness?
YES NO
No Repair

The ECM has the wrong calibration or the ECM has been installed in the wrong location.

Download the correct calibration to the ECM or install the ECM in the correct location.

Go to 3A

Go to 4A

Guided Step 3 - Check the harness.

Guided Step 3A - Inspect the harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the ECM and original equipment manufacturer (OEM) harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit on the connected harness keying pins.

  • Measure the resistance between the control module identification SIGNAL 3 pin and the control module identification RETURN pin in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the control module identification circuit in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM harness ECM connector control module identification SIGNAL 3 and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

A pin-to-pin short circuit has been detected in the control module identification circuit in the harness.

Replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete
Go to

Last Modified: 05-Apr-2016


FAULT CODE 1256 (Source Address 186) - Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1256 active?
STEP 2. | Check for the correct calibration. |
 | STEP 2A. Check for the correct calibration on the ECM. | Does the calibration correspond with the ECM source address and location of the ECM in the harness?
STEP 3. | Check the harness. |
 | STEP 3A. Inspect the harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin to pin short circuit in the harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1256 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for active or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check for the correct calibration.

Guided Step 2A - Check for the correct calibration on the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct calibration.

  • Use INSITE™ electronic service tool to check the calibration installed on the ECM.

Does the calibration correspond with the ECM source address and location of the ECM in the harness?
YES NO
No Repair

The ECM has the wrong calibration or the ECM has been installed in the wrong location.

Download the correct calibration to the ECM or install the ECM in the correct location.

Go to 3A

Go to 4A

Guided Step 3 - Check the harness.

Guided Step 3A - Inspect the harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the original equipment manufacturer (OEM) harness connector from the ECM.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit on the connected harness keying pins.

  • Measure the resistance between the control module identification SIGNAL 1 pin and the control module identification RETURN pin in the OEM harness ECM connector.
  • Measure the resistance between the control module identification SIGNAL 2 pin and the control module identification RETURN pin in the OEM harness ECM connector.
  • Measure the resistance between the control module identification SIGNAL 3 pin and the control module identification RETURN pin in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the control module identification circuit in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin to pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin to pin short.

  • Measure the resistance between the OEM harness ECM connector control module identification SIGNAL 1 and all other pins in the connector (except for the other ID SIGNAL pins).
  • Measure the resistance between the OEM harness ECM connector control module identification SIGNAL 2 and all other pins in the connector (except for the other ID SIGNAL pins).
  • Measure the resistance between the OEM harness ECM connector control module identification SIGNAL 3 and all other pins in the connector (except for the other ID SIGNAL pins).

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

A pin-to-pin short circuit has been detected in the control module identification circuit in the harness.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete
Go to

Last Modified: 25-Apr-2016


FAULT CODE 1358 - Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 1358 active?
STEP 2. | Check the accelerator pedal or lever position sensor circuit. |
 | STEP 2A. Inspect the accelerator pedal or lever position sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1359 active and Fault Code 1358 inactive?
 | STEP 2C. Check the accelerator pedal or lever position supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2D. Check the fault codes and verify accelerator pedal condition. | Fault Code 1358 active?
STEP 3. | Check the ECM and harness. |
 | STEP 3A. Inspect ECM and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 1358 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contrain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1358 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the accelerator pedal or lever position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Check for an active fault code.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Secction 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1359 active and Fault Code 1358 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the accelerator pedal or lever position supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.
  • Turn keyswitch ON.

Action

Check the accelerator pedal or lever position supply voltage and return circuit.

Measure the voltage from the accelerator pedal or lever position SUPPLY pin to the accelerator pedal or lever position RETURN pin at the sensor connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal or lever position sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal or lever position sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1358 active?
YES NO

A damaged accelerator pedal or lever position sensor has been detected.

Replace accelerator pedal or lever position sensor. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect ECM and original equipment manufacturer (OEM) harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the OEM.

Action

Inspect the OEM harness and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broke
  • Wire or insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the accelerator pedal or lever position or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal RETURN pin and the OEM harness accelerator pedal RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Troubleshoot all harnesses connected in series to detemine which one contains the open circuit.

Repair or replace the damaged section of the harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the rsistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Refer to the wiring diagran for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the harness.

Troubleshoot all harnesses connected in series to detemine which one contains the short circuit.

Repair or replace the damaged section of the harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1358 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 28-Mar-2016


FAULT CODE 1359 - Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 1359 active?
STEP 2. | Check the accelerator pedal or lever position sensor and circuit. |
 | STEP 2A. Inspect the accelerator pedal or lever position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal or lever position sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1358 active and Fault Code 1359 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal condition. | Fault Code 1359 active?
STEP 3. | Check the engine harness and harness. |
 | STEP 3A. Inspect the engine harness and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin to ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3F. Check for an active fault code. | Fault Code 1359 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1359 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the accelerator pedal or lever position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness.

Action

Inspect the OEM harness connector and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the accelerator pedal or lever position sensor or harness connector.

Clean the connector pins.

  • Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal or lever position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.
  • Turn keyswitch ON.

Action

Check the accelerator pedal or lever position sensor supply voltage and return circuit.

Measure the voltage from the accelerator pedal or lever position 5 volt SUPPLY pin to the accelerator pedal or lever position RETURN pin at the sensor connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the accelerator pedal or lever position 5 volt SUPPLY pin and the accelerator pedal or lever position SIGNAL pin at the sensor connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

  • Check for the appropriate ECM response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1358 active and Fault Code 1359 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1359 active?
YES NO

A damaged accelerator pedal has been detected.

Replace the accelerator pedal. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect the engine harness and original equipment manufacturer (OEM) harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell damage
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal or lever SUPPLY pin and the OEM harness accelerator pedal or lever connector SUPPLY pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of the harness.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal or lever SIGNAL pin and the OEM harness accelerator pedal connector SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains an open circuit.

Repair or replace the damaged section of the harness.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

Repair or replace the damaged section of the harness.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin to ground short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the signal line has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

Repair or replace the damaged section of the harness.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1359 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 1362 - Engine Oil Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Lubricating Oil Filter (Spin-On) | Refer to Procedure 007-013 | QSK95 CM2350 K113 | 4388663
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK95 CM2350 K113 | 4388663
Pre-Filter Oil Pressure Sensor | Refer to Procedure 019-126 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active or inactive fault codes. |
 | STEP 1A. Check for related fault codes. | Active or inactive counts of Fault Codes 135, 141, 1367, and 1368?
 | STEP 1B. Check for an active fault code. | Active or inactive counts of Fault Code 1362?
STEP 2. | Check the lubricating oil pressure sensors. |
 | STEP 2A. Check the pre- and post- filter lubricating oil pressure sensors. | Pressure sensor readings in INSITE™ electronic service tool correlate with the mechanical gauge or multimeter pressure transducer reading?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active or inactive fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Codes 135, 141, 1367, and 1368?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

Active or inactive counts of Fault Code 1362?
YES | NO
No Repair | No Repair

Go to 2A

Repair complete

Guided Step 2 - Check the lubricating oil pressure sensors.

Guided Step 2A - Check the pre- and post- filter lubricating oil pressure sensors.

Conditions

  • Turn keyswitch OFF.

Action

Check operation and range of the oil filter intake pressure sensor and the lubricating oil pressure sensors.

  • Refer to Procedure 019-126 in the Associated Procedures Table.
  • Refer to Procedure 019-066 in the Associated Procedures Table.

Pressure sensor readings in INSITE™ electronic service tool correlate with the mechanical gauge or multimeter pressure transducer reading?

YES NO

Replace the lubricating oil filters. Refer to Procedure 007-013 in the Associated Procedures Table.

If the oil filters are plugging before the maintenance interval it could be an indication of a serious engine problem or that maintenance intervals should be adjusted. For more information about oil filter contamination and maintenance intervals refer to Cummins® Engine Oil and Oil Analysis Recommendations, Bulletin 3810340.

Replace the faulty pressure sensor(s).

  • Refer to Procedure 019-126 in the Associated Procedures Table.
  • Refer to Procedure 019-066 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Mar-2016


FAULT CODE 1367 - Pre-Oil Filter Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Pre-Filter Oil Pressure Sensor | Refer to Procedure 019-126 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 1367 active?
STEP 2. | Check the pre-oil filter pressure sensor and circuit. |
 | STEP 2A. Inspect the pre-oil filter pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1368 active and Fault Code 1367 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1367 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for pre-oil filter pressure sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1367 active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the pre-oil filter pressure sensor and circuit.

Guided Step 2A - Inspect the pre-oil filter pressure sensor and engine harness connector pins.

Conditions

  • Turn the keyswitch OFF
  • Disconnect the pre-oil filter pressure sensor from the engine harness.

Action

Inspect the engine harness and pre-oil filter pressure sensor connector pin for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector or shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19, for general inspection techniques.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the pre-oil filter pressure sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the pre-oil filter pressure sensor from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1368 active and Fault Code 1367 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the pre-oil filter pressure sensor from the engine harness.
  • Turn the keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the pre-oil filter pressure 5 volt SUPPLY pin to the pre-oil filter pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the pre-oil filter pressure sensor to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1367 active?
YES NO

A damaged pre-oil filter pressure sensor has been detected.

Replace the pre-oil filter pressure sensor.

  • Refer to Procedure 019-126 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropraite circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1368 active and Fault Code 1367 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1367 active?
YES NO

A pin-to-pin short circuit has been detected on the pre-oil filter pressure SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in the series to determine which contains the pin-to-pin short.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn the keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the pre-oil filter pressure 5 volt SUPPLY pin to the pre-oil filter pressure RETURN pin at the ECM.

Refer to the wiring diagram for connector pin identification.

Refer to Procedure 019-359 in Section 19.

4.75 to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1367 active?
YES NO

An open pre-oil filter pressure return circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Mar-2016


FAULT CODE 1368 - Pre-Oil Filter Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Pre-Filter Oil Pressure Sensor | Refer to Procedure 019-126 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 1368 active?
STEP 2. | Check the pre-oil filter pressure sensor and circuit. |
 | STEP 2A. Inspect the pre-oil filter pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1367 active and Fault Code 1368 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1368 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1368 active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the pre-oil filter pressure sensor and circuit.

Guided Step 2A - Inspect the pre-oil filter pressure sensor and engine harness connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the pre-oil filter pressure sensor from the engine harness.

Action

Inspect the engine harness and pre-oil filter pressure sensor connector pin for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector or shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the pre-oil filter pressure sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the pre-oil filter pressure sensor from the engine harness.
  • Turn the keyswitch ON.

Action

Check supply voltage and return circuit.

  • Measure the voltage from the pre-oil filter pressure 5 volt SUPPLY pin to the pre-oil filter pressure RETURN pin at the pre-oil filter pressure sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques.

Refer to Procedure 019-359 in Section 19.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the pre-oil filter pressure sensor from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the pre-oil filter pressure 5 volt SUPPLY pin and the pre-oil filter pressure SIGNAL pin at the pre-oil filter pressure sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1367 active and Fault Code 1368 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the pre-oil filter pressure sensor to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1368 active?
YES NO

A damaged pre-oil filter pressure sensor has been detected.

Replace the pre-oil filter pressure sensor.

  • Refer to Procedure 019-126 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn the keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the pre-oil filter pressure 5 volt SUPPLY pin to the pre-oil filter pressure RETURN pin at the ECM.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1368 active?
YES NO

An open or shorted pre-oil filter pressure supply circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in the series to determine which contains the open circuit.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the pre-oil filter pressure 5 volt SUPPLY pin and the pre-oil filter pressure SIGNAL pin at the ECM.

Refer to the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1367 active and Fault Code 1368 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1368 active?
YES NO

An open circuit or a pin-to-pin short circuit has been detected on the pre-oil filter pressure SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in the series to determine which contains the open or pin-to-pin circuit.

Replace the damaged section of engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Repair complete.

Go to 1A

Last Modified: 28-Mar-2016


FAULT CODE 1376 - Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Camshaft Position Sensor | Refer to Procedure 019-363 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 1376 active?
STEP 2. | Check the camshaft position sensor and connector. |
 | STEP 2A. Inspect the camshaft position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the camshaft position sensor for damage. | Damaged sensor?
STEP 3. | Check the camshaft position sensor circuit. |
 | STEP 3A. Check the camshaft position sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 3B. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check for an open camshaft position sensor signal circuit in the engine wiring harness. |
 | STEP 3B-2. Check the camshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness. |
 | STEP 3B-3. Check the fault code and verify the camshaft position sensor condition. |
 | STEP 3C. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3C-1. Check the sensor supply voltage and return circuit. |
 | STEP 3C-2. Check for an open circuit in the camshaft position sensor return. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1376 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the camshaft position sensor and connector.

Guided Step 2A - Inspect the camshaft position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Inspect the engine harness and camshaft position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the camshaft position sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Remove the camshaft position sensor from the gear cover. Refer to Procedure 019-363 in the Associated Procedures Table.

Action

Inspect the engine position sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by camshaft gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damaged sensor?
YES NO

A damaged sensor or mechanical damage has been detected.

Replace the sensor. If mechanical damage was observed, then inspect the camshaft gear and related components. Refer to Procedure 019-363 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the camshaft position sensor circuit.

Guided Step 3A - Check the camshaft position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the camshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the camshaft position sensor +5 volt SUPPLY pin and the camshaft position sensor 1 RETURN pin at the camshaft position sensor connector of the engine wiring harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3C

Guided Step 3B - Inspect the engine control module (ECM) and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check for an open camshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Disconnect the engine harness connector from the ECM.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the camshaft position sensor SIGNAL pin at the camshaft position sensor engine harness connector to the camshaft position sensor SIGNAL pin at the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms ?
YES NO
No Repair

An open circuit in the engine harness has been detected.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check the camshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the camshaft position sensor SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-3

Go to 4A

Guided Step 3B-3 - Check the fault code and verify the camshaft position sensor condition.

Conditions

  • Connect all components in the correct positions.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1376 active?
YES NO

A damaged camshaft position sensor has been detected.

Replace the camshaft position sensor. Refer to Procedure 019-363 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3C - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the camshaft position sensor supply voltage and return circuit

  • Measure the sensor supply voltage between the camshaft position sensor +5 volt SUPPLY pin and the camshaft position sensor RETURN pin at the ECM.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check for an open circuit in the camshaft position sensor return.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness connector to the ECM.
  • Disconnect the camshaft position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the camshaft position sensor supply voltage.

  • Measure the sensor supply voltage between the camshaft sensor +5 SUPPLY pin and engine ground.

Refer to the wiring diagram for connector pin identification.

Between 4.75 VDC to 5.25 VDC?
YES NO

An open return circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

An open supply circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 28-Mar-2016


FAULT CODE 1379 - Fuel Supply Pump Intake Pressure - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | QSK95 CM2350 K113 | 4388663
Fuel Supply Pump | Refer to Procedure 005-241 | QSK95 CM2350 K113 | 4388663
Air in Fuel | Refer to Procedure 006-003 | QSK95 CM2350 K113 | 4388663
Fuel Supply Lines | Refer to Procedure 006-024 | QSK95 CM2350 K113 | 4388663
Fuel Filter (Stage 1) | Refer to Procedure 006-075 | QSK95 CM2350 K113 | 4388663
Stage 0 Fuel Filter | Refer to Procedure 006-093 | QSK95 CM2350 K113 | 4388663
Fuel Inlet Pressure Measurement | Refer to Procedure 006-104 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Fuel Delivery Pressure Sensor | Refer to Procedure 019-548 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated before replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2343, 2372, 4885, 4886, 4887, 4892, 4893, 4894, or 6711 active or inactive with more than one count in the last 25 engine hours?
STEP 2. | Check the low-pressure fuel system. |
 | STEP 2A. Check for adequate fuel supply. | Equipment has an adequate fuel supply?
 | STEP 2B. Check the fuel lines. | Kinked, restricted, or damaged fuel lines?
 | STEP 2C. Check the fuel supply pump intake pressure sensor. | Fuel supply pump intake pressure sensor meets specifications found in Procedure 019-548 in the Associated Procedures Table?
STEP 3. | Check the low-pressure fuel system operation. |
 | STEP 3A. Check for air in the fuel system. | Air in the fuel?
 | STEP 3B. Check fuel inlet restriction. | Fuel inlet restriction within the specifications found in Procedure 006-104 in the Associated Procedure Table?
 | STEP 3C. Check Stage 0 fuel filter restriction. | Stage 0 fuel filter restriction within the specifications found in Procedure 005-236 in the Associated Procedures Table?
 | STEP 3D. Check Stage 1 fuel filter restriction. | Stage 1 fuel filter restriction within the specifications found in Procedure 005-236 in the Associated Procedures Table?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Check the fault codes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2343, 2372, 4885, 4886, 4887, 4892, 4893, 4894, or 6711 active or inactive with more than one count in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the low-pressure fuel system.

Guided Step 2A - Check for adequate fuel supply.

Conditions

  • Turn keyswitch ON.
  • Turn engine OFF.

Action

  • Check for adequate fuel supply.
  • Do not rely on the equipment fuel gauge.
  • Verify there is fuel in the tank.

Equipment has an adequate fuel supply?
YES NO
No Repair

If necessary, repair:

  • Equipment fuel tank
  • Fuel gauge.

Add fuel to the equipment fuel tank.

Go to 2B

Go to 4A

Guided Step 2B - Check the fuel lines.

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the suction and low-pressure fuel lines for kinks or damage.

Kinked, restricted, or damaged fuel lines?
YES NO

Replace the damaged fuel line(s). Refer to Procedure 006-024 in the Associated Procedures Table or the equipment manufacturer service information.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the fuel supply pump intake pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Install a pressure gauge onto the Compuchek™ fitting at the outlet of the Stage 1 fuel filter head.

Action

  • Check the fuel supply pump intake pressure sensor accuracy.
  • Refer to Procedure 019-548 in the Associated Procedures Table.

Fuel supply pump intake pressure sensor meets specifications found in Procedure 019-548 in the Associated Procedures Table?
YES NO
No Repair

Replace the fuel supply pump intake pressure sensor. Refer to Procedure 019-548 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the low-pressure fuel system operation.

Guided Step 3A - Check for air in the fuel system.

Conditions

  • Turn keyswitch ON.

Action

  • Check for air in the fuel.
  • Refer to Procedure 006-003 in the Associated Procedures Table.

Air in the fuel?
YES NO

Repair or replace the malfunctioning component(s).

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check fuel inlet restriction.

Conditions

  • Turn keyswitch ON.

Action

  • Check the fuel inlet restriction.
  • Refer to Procedure 006-104 in the Associated Procedures Table.

Fuel inlet restriction within the specifications found in Procedure 006-104 in the Associated Procedures Table?
YES NO
No Repair

High restriction in the fuel supply lines or fuel supply tank has been detected. Continue troubleshooting to determine the cause of the high restriction.

Replace any damaged or malfunctioning components. See equipment manufacturer service information.

Go to 3C

Go to 4A

Guided Step 3C - Check Stage 0 fuel filter restriction.

Conditions

  • Turn keyswitch ON.

Action

  • Check the Stage 0 fuel filter restriction.
  • Refer to Procedure 005-236 in the Associated Procedures Table.

Stage 0 fuel filter restriction within the specifications found in Procedure 005-236 in the Associated Procedures Table?
YES NO
No Repair

Replace the Stage 0 fuel filters. Refer to Procedure 006-093 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check Stage 1 fuel filter restriction.

Conditions

  • Turn keyswitch ON.

Action

  • Check the Stage 1 fuel filter restriction.
  • Refer to Procedure 005-236 in the Associated Procedures Table.

Stage 1 fuel filter restriction within the specifications found in Procedure 005-236 in the Associated Procedures Table?
YES NO

Replace the engine fuel supply pump. Refer to Procedure 005-241 in the Associated Procedures Table

Replace the Stage 1 fuel filters. Refer to Procedure 006-075 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.
  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Disable and clear the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance.

Repair complete.

Last Modified: 04-Dec-2019


FAULT CODE 1383 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 1383 active?
STEP 2. | Check the intake manifold 1 pressure sensor circuit. |
 | STEP 2A. Inspect the intake manifold 1 pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1384 active and Fault Code 1383 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1383 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1383 active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the intake manifold 1 pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold 1 pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure sensor connector from the engine harness.

Action

Inspect the engine harness and intake manifold 1 pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the intake manifold 1 pressure sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure sensor connector from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1384 active and Fault Code 1383 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure sensor connector from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1383 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold 1 pressure sensor.

Refer to Procedure 019-061 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1384 active and Fault Code 1383 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1383 active?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the ECM engine connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1383 active?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 28-Mar-2016


FAULT CODE 1384 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 1384 active?
STEP 2. | Check the intake manifold 1 pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 1 pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1383 active and Fault Code 1384 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1384 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness control pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1384 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the intake manifold 1 pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold 1 pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor connector from the engine harness.

Action

Inspect the engine harness and intake manifold 1 pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure sensor connector from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-361 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure sensor connector from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold pressure +5 volt SUPPLY pin and the intake manifold pressure SIGNAL pin at the intake manifold pressure sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Check for the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1383 active and Fault Code 1384 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold 1 pressure sensor connector to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1384 active?
YES NO

A damaged sensor has been detected.

Replace the sensor.

Refer to Procedure 019-159 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the ECM engine connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1384 active?
YES NO

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold pressure +5 volt SUPPLY pin and the intake manifold pressure SIGNAL pin at the ECM engine connector.

Refer to the wiring diagram for connector pin identification.

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1383 active and Fault Code 1384 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1384 active?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 18-Jan-2017


FAULT CODE 1385 - Intake Manifold 2 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 1385 active?
STEP 2. | Check the intake manifold 2 pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 2 pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1386 active and Fault Code 1385 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1385 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1385 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the intake manifold 2 pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold 2 pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure sensor connector from the engine harness.

Action

Inspect the engine harness and intake manifold 2 pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the intake manifold 2 pressure sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure sensor connector from the engine harness.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1386 active and Fault Code 1385 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure sensor connector from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold 2 pressure sensor connector to the engine harness.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 1385 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold 2 pressure sensor.

Refer to Procedure 019-159 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1386 active and Fault Code 1385 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1385 active?
YES NO

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the ECM engine connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1385 active?
YES NO

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 29-Mar-2016


FAULT CODE 1386 - Intake Manifold 2 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1386 active?
STEP 2. | Check the intake manifold 2 pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 2 pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1385 active and Fault Code 1386 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1386 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1386 active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for intermittent or inactive fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the intake manifold 2 pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold 2 pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure sensor connector from the engine harness.

Action

Inspect the engine harness and intake manifold 2 pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure sensor connector from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold 2 pressure +5 volt SUPPLY pin to the intake manifold 2 pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure sensor connector from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold 2 pressure +5 volt SUPPLY pin and the intake manifold 2 pressure SIGNAL pin at the intake manifold pressure sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Check for the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1385 active and Fault Code 1386 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold 2 pressure sensor connector to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1386 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold 2 pressure sensor.

Refer to Procedure 019-159 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold 2 pressure +5 volt SUPPLY pin to the intake manifold 2 pressure RETURN pin at the ECM engine connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1386 active?
YES NO

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold 2 pressure +5 volt SUPPLY pin and the intake manifold 2 pressure SIGNAL pin at the engine control module engine connector.

Refer to the wiring diagram for connector pin identification.

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1385 active and Fault Code 1386 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1386 active?
YES NO

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connected corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 29-Mar-2016


FAULT CODE 1389 - Fuel Supply Pump Intake Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Filter Head (Stage 1) | Refer to Procedure 006-079 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Fuel Supply Pump Intake Pressure Sensor | Refer to Procedure 019-549 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2343, 2372, 4885, 4886, 4887, 4892, 4893, 4894 active?
STEP 2. | Check the fuel supply system. |
 | STEP 2A. Check the fuel supply pump intake pressure sensor. | Fuel supply pump intake pressure sensor meets specifications found in Procedure 019-549?
STEP 3. | Check for fuel recirculation line restriction. |
 | STEP 3A. Check fuel recirculation line restriction. | Kinked, restricted, or damaged fuel lines?
 | STEP 3B. Check pressure regulator valve restriction. | Pressure regulator valve damaged or restricted?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2343, 2372, 4885, 4886, 4887, 4892, 4893, 4894 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the fuel supply system.

Guided Step 2A - Check the fuel supply pump intake pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Install a pressure gauge onto the Compuchek™ fitting at the outlet of the Stage 2 fuel filter head.

Action

Check the fuel supply pump intake pressure sensor accuracy.

  • Refer to Procedure 019-549 in the Associated Procedures Table.

Fuel supply pump intake pressure sensor meets specifications found in Procedure 019-549?
YES NO
No Repair

Replace the fuel supply pump intake pressure sensor. Refer to Procedure 019-549 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check for fuel recirculation line restriction.

Guided Step 3A - Check fuel recirculation line restriction.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Inspect the fuel recirculation line for kinks or damage.

  • See equipment manufacturer service information.

Kinked, restricted, or damaged fuel lines?
YES NO
No Repair

Replace the source of the high fuel drain line restriction. See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Check pressure regulator valve restriction.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Inspect the condition of the pressure regulator valve at the Stage 1 fuel filter.

  • Refer to Procedure 006-079 in the Associated Procedures Table.

Pressure regulator valve damaged or restricted?
YES NO

Repair or replace the pressure regulator valve. Refer to Procedure 006-079 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 1521 - Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1521 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 672 active and Fault Code 1521 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1521 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 1521 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1521 active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 3 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 3 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the exhaust gas temperature sensor 3 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 3 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas temperature sensor 3 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Refer to the wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 672 active and Fault Code 1521 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor 3 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1521 active?
YES NO

Replace the exhaust gas temperature sensor 3. Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 3 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 3 RETURN pin in the engine harness ECM connector and the exhaust gas temperature sensor 3 RETURN pin in the engine harness sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 3 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 3 SIGNAL pin in the engine harness ECM connector and the exhaust gas temperature sensor 3 SIGNAL pin in the engine harness sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 3 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 3 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greate than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1521 active?
YES NO

Replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 29-Mar-2016


FAULT CODE 1522 - Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1522 active?
STEP 2. | Check the exhaust gas temperature sensor circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 673 active and Fault Code 1522 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1522 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for an pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 1522 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1522 active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas temperature sensor circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 5 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 5 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the exhaust gas temperature sensor 5 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 5 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas temperature sensor 5 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Refer to the wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 673 active and Fault Code 1522 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor 5 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1522 active?
YES NO

Replace the exhaust gas temperature sensor 5. Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 5 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 5 RETURN pin in the engine harness ECM connector and the exhaust gas temperature sensor 5 RETURN pin in the engine harness sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 5 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 5 SIGNAL pin in the engine harness ECM connector and the exhaust gas temperature sensor 5 SIGNAL pin in the engine harness sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 5 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 5 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1522 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 29-Mar-2016


FAULT CODE 1523 - Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1523 active?
STEP 2. | Check the exhaust gas temperature sensor circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 674 active and Fault Code 1523 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1523 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for an pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 1523 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1523 active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas temperature sensor circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 7 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 7 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the exhaust gas temperature sensor 7 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 7 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas temperature sensor 7 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Refer to the wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 674 active and Fault Code 1523 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor 7 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1523 active?
YES NO

Replace the exhaust gas temperature sensor 7. Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 7 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 7 RETURN pin in the engine harness ECM connector and the exhaust gas temperature sensor 7 RETURN pin in the engine harness sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 7 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 7 SIGNAL pin in the engine harness ECM connector and the exhaust gas temperature sensor 7 SIGNAL pin in the engine harness sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 7 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 7 SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1523 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 29-Mar-2016


FAULT CODE 1524 - Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1524 active?
STEP 2. | Check the exhaust gas temperature sensor circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 675 active and Fault Code 1524 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1524 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for an pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 1524 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1524 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas temperature sensor circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 9 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 9 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the exhaust gas temperature sensor 9 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 9 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas temperature sensor 9 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Refer to the wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 675 active and Fault Code 1524 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor 9 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1524 active?
YES NO

Replace the exhaust gas temperature sensor 9. Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 9 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 9 RETURN pin in the engine harness ECM connector and the exhaust gas temperature sensor 9 RETURN pin in the engine harness sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 9 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 9 SIGNAL pin in the engine harness ECM connector and the exhaust gas temperature sensor 9 SIGNAL pin in the engine harness sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 9 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 9 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1524 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 29-Mar-2016


FAULT CODE 1525 - Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1525 active?
STEP 2. | Check the exhaust gas temperature sensor circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 676 active and Fault Code 1525 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1525 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for an pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 1525 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1525 active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas temperature sensor circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 11 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 11 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the exhaust gas temperature sensor 11 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 11 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas temperature sensor 11 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Refer to the wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 676 active and Fault Code 1525 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor 11 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1525 active?
YES NO

Replace the exhaust gas temperature sensor 11. Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 11 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 11 RETURN pin in the engine harness ECM connector and the exhaust gas temperature sensor 11 RETURN pin in the engine harness sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 11 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 11 SIGNAL pin in the engine harness ECM connector and the exhaust gas temperature sensor 11 SIGNAL pin in the engine harness sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 11 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 11 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1525 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 29-Mar-2016


FAULT CODE 1526 - Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1526 active?
STEP 2. | Check the exhaust gas temperature sensor circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 677 active and Fault Code 1526 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1526 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and original equipment manufacturer (OEM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for an pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 1526 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1526 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas temperature sensor circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 13 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 13 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the exhaust gas temperature sensor 13 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 13 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas temperature sensor 13 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Refer to the wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 677 active and Fault Code 1526 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor 13 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1526 active?
YES NO

Replace the exhaust gas temperature sensor 13. Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 13 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 13 RETURN pin in the OEM harness ECM connector and the exhaust gas temperature sensor 13 RETURN pin in the engine harness sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 13 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 13 SIGNAL pin in the OEM harness ECM connector and the exhaust gas temperature sensor 13 SIGNAL pin in the engine harness sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 13 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 13 SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1526 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 30-Mar-2016


FAULT CODE 1527 - Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1527 active?
STEP 2. | Check the exhaust gas temperature sensor circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 677 active and Fault Code 1527 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1527 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and original equipment manufacturer (OEM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for an pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 1527 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1527 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas temperature sensor circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 15 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 15 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the exhaust gas temperature sensor 15 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 15 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas temperature sensor 15 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Refer to the wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 678 active and Fault Code 1527 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor 15 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1527 active?
YES NO

Replace the exhaust gas temperature sensor 15. Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and original equipment manufacturer (OEM) connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 15 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 15 RETURN pin in the OEM harness ECM connector and the exhaust gas temperature sensor 15 RETURN pin in the engine harness sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 15 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 15 SIGNAL pin in the OEM harness ECM connector and the exhaust gas temperature sensor 15 SIGNAL pin in the engine harness sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 15 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 15 SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1527 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 30-Mar-2016


FAULT CODE 1529 - Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1529 active?
STEP 2. | Check the exhaust gas temperature sensor circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 721 active and Fault Code 1529 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1529 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for an pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 1529 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1529 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas temperature sensor circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 2 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the exhaust gas temperature sensor 2 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 2 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas temperature sensor 2 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Refer to the wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 721 active and Fault Code 1529 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor 2 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1529 active?
YES NO

Replace the exhaust gas temperature sensor 2. Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 2 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 2 RETURN pin in the engine harness ECM connector and the exhaust gas temperature sensor 2 RETURN pin in the engine harness sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 2 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 2 SIGNAL pin in the engine harness ECM connector and the exhaust gas temperature sensor 2 SIGNAL pin in the engine harness sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 2 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 2 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1529 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 30-Mar-2016


FAULT CODE 1531 - Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1531 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 723 active and Fault Code 1531 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 1531 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 1531 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1531 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 6 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 6 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the exhaust gas temperature sensor 6 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 6 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas temperature sensor 6 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Refer to the wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 723 active and Fault Code 1531 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 6 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1531 active?
YES NO

Replace the exhaust gas temperature sensor 6.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 6 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 6 RETURN pin in the engine harness ECM connector and the exhaust gas temperature sensor 6 RETURN pin in the engine harness sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 6 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 6 SIGNAL pin in the engine harness ECM connector and the exhaust gas temperature sensor 6 SIGNAL pin in the engine harness sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 6 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 6 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1531 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 30-Mar-2016


FAULT CODE 1532 - Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1532 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 724 active and Fault Code 1532 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 1532 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 1532 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1532 active?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 8 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 8 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the exhaust gas temperature sensor 8 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 8 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas temperature sensor 8 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Refer to the wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 724 active and Fault Code 1532 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 8 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1532 active?
YES NO

Replace the exhaust gas temperature sensor 8.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 8 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 8 RETURN pin in the engine harness ECM connector and the exhaust gas temperature sensor 8 RETURN pin in the engine harness sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 8 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 8 SIGNAL pin in the engine harness ECM connector and the exhaust gas temperature sensor 8 SIGNAL pin in the engine harness sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 8 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 8 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1532 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 30-Mar-2016


FAULT CODE 1533 - Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1533 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 725 active and Fault Code 1533 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 1533 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 1533 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1533 active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 10 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 10 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the exhaust gas temperature sensor 10 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 10 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas temperature sensor 10 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Refer to the wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 725 active and Fault Code 1533 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 10 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1533 active?
YES NO

Replace the exhaust gas temperature sensor 10.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 10 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 10 RETURN pin in the engine harness ECM connector and the exhaust gas temperature sensor 10 RETURN pin in the engine harness sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 10 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 10 SIGNAL pin in the engine harness ECM connector and the exhaust gas temperature sensor 10 SIGNAL pin in the engine harness sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 10 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 10 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1533 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 30-Mar-2016


FAULT CODE 1534 - Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1534 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 726 active and Fault Code 1534 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 1534 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 1534 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1534 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 12 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 12 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the exhaust gas temperature sensor 12 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 12 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas temperature sensor 12 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Refer to the wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 726 active and Fault Code 1534 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 12 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1534 active?
YES NO

Replace the exhaust gas temperature sensor 12.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 12 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 12 RETURN pin in the engine harness ECM connector and the exhaust gas temperature sensor 12 RETURN pin in the engine harness sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 12 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 12 SIGNAL pin in the engine harness ECM connector and the exhaust gas temperature sensor 12 SIGNAL pin in the engine harness sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 12 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 12 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1534 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 30-Mar-2016


FAULT CODE 1535 - Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1535 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 727 active and Fault Code 1535 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 1535 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 1535 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1535 active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 14 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 14 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the exhaust gas temperature sensor 14 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 14 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas temperature sensor 14 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Refer to the wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 727 active and Fault Code 1535 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 14 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1535 active?
YES NO

Replace the exhaust gas temperature sensor 14.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 14 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 14 RETURN pin in the engine harness ECM connector and the exhaust gas temperature sensor 14 RETURN pin in the engine harness sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 14 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 14 SIGNAL pin in the engine harness ECM connector and the exhaust gas temperature sensor 14 SIGNAL pin in the engine harness sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 14 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 14 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1535 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 30-Mar-2016


FAULT CODE 1536 - Exhaust Gas Temperature Sensor Circuit Cylinder 16 (B8) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1536nactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 728 active and Fault Code 1536 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 1536 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 1536 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1536 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 16 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 16 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the exhaust gas temperature sensor 16 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 16 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas temperature sensor 16 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Refer to the wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 728 active and Fault Code 1536 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 16 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1536 active?
YES NO

Replace the exhaust gas temperature sensor 16.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 16 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 16 RETURN pin in the engine harness ECM connector and the exhaust gas temperature sensor 16 RETURN pin in the engine harness sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 16 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 16 SIGNAL pin in the engine harness ECM connector and the exhaust gas temperature sensor 16 SIGNAL pin in the engine harness sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 16 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 16 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1536 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 1A

Repair complete

Last Modified: 30-Mar-2016


FAULT CODE 1548 - Injector Solenoid Driver Cylinder 7 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1548 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1622 also active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the injector wiring harness and connector pins. |
 | STEP 2C. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2D. Inspect the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2E. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2F. Read the fault codes. | Fault Code 1548 the only active injector fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-power supply ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins or damaged wire insulation?
 | STEP 3D. Check for a pin-to-power supply ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3E. Check the engine harness for pin-to-pin short circuits. | Greater than 100k ohms?
 | STEP 3F. Read the fault codes. | Fault Codes 1548 and 1622 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1548 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1622 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 7 connector.

Action

Inspect the engine wiring harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the injector wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 7 connector.

Action

  • Inspect injector 7 wiring harness. Refer to Procedure 006-026 in the Associated Procedures Table.

Damaged injector wiring harness or connector?
YES NO

Repair or replace the injector wiring harness, if possible. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 7 connector.

Action

Check the resistance of the injector solenoid.

  • Measure the resistance between the injector 7 SIGNAL pin and the injector 7 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the engine wiring harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Check the continuity in the injector circuit.

  • Measure the resistance between the injector 7 SIGNAL pin and the injector 7 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

An open or pin-to-pin short circuit has been detected on the injector 7 circuit.

Troubleshoot each section of the circuit to determine which one contains the open or short.

Repair or repace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1548 is the only active injector fault code?

YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the injector 7 and injector 9 connectors.

Action

Inspect the engine wiring harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-power supply ground short circuit in the harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness from the injectors being tested.

Action

Check for a pin-to-power supply ground short circuit.

  • Measure the resistance between the injector 7 SIGNAL pin and ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.
  • Measure the resistance between the injector 9 SIGNAL pin and ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the shorted injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check for a pin-to-power supply ground short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the injector 7 and injector 9 connectors.

Action

Check for a pin-to-power supply ground short circuit.

  • Measure the resistance from the injector 7 SIGNAL pin at the ECM connector of the engine harness to ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table. Repeat the check at the injector 9 SIGNAL pin.
  • Measure the resistance from the injector 7 RETURN pin at the ECM connector of the engine harness to ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table. Repeat the check for the injector 9 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-power supply ground short circuit has been detected in the wiring harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the injector 7 and injector 9 connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector 7 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector 9 SIGNAL pin.
  • Measure the resistance from the injector 7 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector 9 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1548 and 1622 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process.

Repair complete.

Last Modified: 06-Mar-2017


FAULT CODE 1549 - Injector Solenoid Driver Cylinder 8 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1549 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1551 also active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the injector wiring harness and connector pins. |
 | STEP 2C. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2D. Inspect the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2E. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2F. Read the fault codes. | Fault Code 1549 the only active injector fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-power supply ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins or damaged wire insulation?
 | STEP 3D. Check for a pin-to-power supply ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3E. Check the engine harness for pin-to-pin short circuits. | Greater than 100k ohms?
 | STEP 3F. Read the fault codes. | Fault Codes 1549 and 1551 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1549 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1551 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 8 connector.

Action

Inspect the engine wiring harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the injector wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 8 connector.

Action

  • Inspect injector 8 wiring harness. Refer to Procedure 006-026 in the Associated Procedures Table.

Damaged injector wiring harness or connector?
YES NO

Repair or replace the injector wiring harness, if possible. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 8 connector.

Action

Check the resistance of the injector solenoid.

  • Measure the resistance between the injector 8 SIGNAL pin and the injector 8 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Check for continuity in the injector circuit.

  • Measure the resistance between the injector 8 SIGNAL pin and the injector 8 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

An open or pin-to-pin short circuit has been detected on the injector 8 circuit.

Troubleshoot each section of the circuit to determine which one contains the open or short.

Repair or repace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1549 is the only active injector fault code?

YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the injector 8 and injector 10 connectors.

Action

Inspect the engine wiring harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-power supply ground short circuit in the harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness from the injectors being tested.

Action

Check for a pin-to-power supply ground short circuit.

  • Measure the resistance between the injector 8 SIGNAL pin and ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.
  • Measure the resistance between the injector 10 SIGNAL pin and ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the shorted injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

A damaged connection has been detected inthe ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Repair the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check for a pin-to-power supply ground short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the injector 8 and injector 10 connectors.

Action

Check for a pin-to-power supply ground short circuit.

  • Measure the resistance from the injector 8 SIGNAL pin at the ECM connector of the engine harness to ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table. Repeat the check at the injector 10 SIGNAL pin.
  • Measure the resistance from the injector 8 RETURN pin at the ECM connector of the engine harness to ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table. Repeat the check for the injector 10 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-power supply ground short circuit has been detected in the wiring harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the injector 8 and injector 10 connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector 8 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector 10 SIGNAL pin.
  • Measure the resistance from the injector 8 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector 10 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1549 and 1551 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process.

Repair complete.

Last Modified: 06-Mar-2017


FAULT CODE 1551 - Injector Solenoid Driver Cylinder 10 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1551 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1549 also active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the injector wiring harness and connector pins. |
 | STEP 2C. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2D. Inspect the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2E. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2F. Read the fault codes. | Fault Code 1551 the only active injector fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-power supply ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins or damaged wire insulation?
 | STEP 3D. Check for a pin-to-power supply ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3E. Check the engine harness for pin-to-pin short circuits. | Greater than 100k ohms?
 | STEP 3F. Read the fault codes. | Fault Codes 1549 and 1551 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1551 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1549 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 10 connector.

Action

Inspect the engine wiring harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the injector wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 10 connector.

Action

  • Inspect injector 10 wiring harness. Refer to Procedure 006-026 in the Associated Procedures Table.

Damaged injector wiring harness or connector?
YES NO

Repair or replace the injector wiring harness, if possible. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 10 connector.

Action

Check the resistance of the injector solenoid.

  • Measure the resistance between the injector 10 SIGNAL pin and the injector 10 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the engine wiring harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Check the continuity in the injector circuit.

  • Measure the resistance between the injector 10 SIGNAL pin and the injector 10 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

An open or pin-to-pin short circuit has been detected on the injector 10 circuit.

Troubleshoot each section of the circuit to determine which one contains the open or short.

Repair or repace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1551 is the only active injector fault code?

YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the injector 8 and injector 10 connectors.

Action

Inspect the engine wiring harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-power supply ground short circuit in the harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness from the injectors being tested.

Action

Check for a pin-to-power supply ground short circuit.

  • Measure the resistance between the injector 8 SIGNAL pin and ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.
  • Measure the resistance between the injector 10 SIGNAL pin and ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the shorted injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check for a pin-to-power supply ground short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the injector 8 and injector 10 connectors.

Action

Check for a pin-to-power supply ground short circuit.

  • Measure the resistance from the injector 8 SIGNAL pin at the ECM connector of the engine harness to ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table. Repeat the check at the injector 10 SIGNAL pin.
  • Measure the resistance from the injector 8 RETURN pin at the ECM connector of the engine harness to ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table. Repeat the check for the injector 10 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-power supply ground short circuit has been detected in the wiring harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the injector 8 and injector 10 connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector 8 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector 10 SIGNAL pin.
  • Measure the resistance from the injector 8 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector 10 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1549 and 1551 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process.

Repair complete.

Last Modified: 06-Mar-2017


FAULT CODE 1552 - Injector Solenoid Driver Cylinder 11 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1552 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 323 also active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the injector wiring harness and connector pins. |
 | STEP 2C. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2D. Inspect the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2E. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2F. Read the fault codes. | Fault Code 1552 the only active injector fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-power supply ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins or damaged wire insulation?
 | STEP 3D. Check for a pin-to-power supply ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3E. Check the engine harness for pin-to-pin short circuits. | Greater than 100k ohms?
 | STEP 3F. Read the fault codes. | Fault Codes 323 and 1552 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1552 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 323 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 11 connector.

Action

Inspect the engine wiring harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the injector wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 11 connector.

Action

  • Inspect injector 11 wiring harness. Refer to Procedure 006-026 in the Associated Procedures Table.

Damaged injector wiring harness or connector?
YES NO

Repair or replace the injector wiring harness, if possible. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the injector 11 connector.

Action

Check the resistance of the injector solenoid.

  • Measure the resistance between the injector 11 SIGNAL pin and the injector 11 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the engine wiring harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Check the continuity in the injector circuit.

  • Measure the resistance between the injector 11 SIGNAL pin and the injector 11 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

An open or pin-to-pin short circuit has been detected on the injector 11 circuit.

Troubleshoot each section of the circuit to determine which one contains the open or short.

Repair or repace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1552 is the only active injector fault code?

YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the injector 5 and injector 11 connectors.

Action

Inspect the engine wiring harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-power supply ground short circuit in the harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness from the injectors being tested.

Action

Check for a pin-to-power supply ground short circuit.

  • Measure the resistance between the injector 5 SIGNAL pin and ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.
  • Measure the resistance between the injector 11 SIGNAL pin and ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the shorted injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check for a pin-to-power supply ground short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the injector 5 and injector 11 connectors.

Action

Check for a pin-to-power supply ground short circuit.

  • Measure the resistance from the injector 5 SIGNAL pin at the ECM connector of the engine harness to ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table. Repeat the check at the injector 11 SIGNAL pin.
  • Measure the resistance from the injector 5 RETURN pin at the ECM connector of the engine harness to ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table. Repeat the check for the injector 11 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-power supply ground short circuit has been detected in the wiring harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the injector 5 and injector 11 connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector 5 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector 11 SIGNAL pin.
  • Measure the resistance from the injector 5 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector 11 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 323 and 1552 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process.

Repair complete.

Last Modified: 06-Mar-2017


FAULT CODE 1553 - Injector Solenoid Driver Cylinder 12 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1553 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 325 also active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the injector wiring harness and connector pins. |
 | STEP 2C. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2D. Inspect the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2E. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2F. Read the fault codes. | Fault Code 1553 the only active injector fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-power supply ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins or damaged wire insulation?
 | STEP 3D. Check for a pin-to-power supply ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3E. Check the engine harness for pin-to-pin short circuits. | Greater than 100k ohms?
 | STEP 3F. Read the fault codes. | Fault Codes 325 and 1553 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1553 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 325 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 12 connector.

Action

Inspect the engine wiring harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the injector wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 12 connector.

Action

  • Inspect injector 12 wiring harness. Refer to Procedure 006-026 in the Associated Procedures Table.

Damaged injector wiring harness or connector?
YES NO

Repair or replace the injector wiring harness, if possible. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 12 connector.

Action

Check the resistance of the injector solenoid.

  • Measure the resistance between the injector 12 SIGNAL pin and the injector 12 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the engine wiring harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Check the continuity in the injector circuit.

  • Measure the resistance between the injector 12 SIGNAL pin and the injector 12 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

An open or pin-to-pin short circuit has been detected on the injector 12 circuit.

Troubleshoot each section of the circuit to determine which one contains the open or short.

Repair or repace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1553 is the only active injector fault code?

YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the injector 6 and injector 12 connectors.

Action

Inspect the engine wiring harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-power supply ground short circuit in the harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness from the injectors being tested.

Action

Check for a pin-to-power supply ground short circuit.

  • Measure the resistance between the injector 6 SIGNAL pin and ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.
  • Measure the resistance between the injector 12 SIGNAL pin and ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the shorted injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check for a pin-to-power supply ground short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the injector 6 and injector 12 connectors.

Action

Check for a pin-to-power supply ground short circuit.

  • Measure the resistance from the injector 6 SIGNAL pin at the ECM connector of the engine harness to ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table. Repeat the check at the injector 12 SIGNAL pin.
  • Measure the resistance from the injector 6 RETURN pin at the ECM connector of the engine harness to ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table. Repeat the check for the injector 12 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-power supply ground short circuit has been detected in the wiring harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the injector 6 and injector 12 connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector 6 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector 12 SIGNAL pin.
  • Measure the resistance from the injector 6 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector 12 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 325 and 1553 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process.

Repair complete.

Last Modified: 06-Mar-2017


FAULT CODE 1554 - Injector Solenoid Driver Cylinder 13 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1554 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 324 also active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the injector wiring harness and connector pins. | Damaged injector wiring harness or connector?
 | STEP 2C. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2D. Inspect the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2E. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2F. Read the fault codes | Fault Code 1554 is the only active injector fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-power supply ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3D. Check for a pin-to-power supply ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3E. Check the engine harness for pin-to-pin short circuits. | Greater than 100k ohms?
 | STEP 3F. Read the fault codes. | Fault Codes 324 and 1554 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1554 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 324 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 13 connector.

Action

Inspect the engine wiring harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the injector wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 13 connector.

Action

  • Inspect injector 13 wiring harness. Refer to Procedure 006-026 in the Associated Procedures Table.

Damaged injector wiring harness or connector?
YES NO

Repair or replace the injector wiring harness, if possible. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 13 connector.

Action

Check the resistance of the injector solenoid.

  • Measure the resistance between the injector 13 SIGNAL pin and the injector 13 RETURN pin at the injector connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the engine wiring harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Check the continuity in the injector circuit.

  • Measure the resistance between the injector 13 SIGNAL pin and the injector 13 RETURN pin at the ECM connector of the engine harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

An open or pin-to-pin short circuit has been detected on the injector 13 circuit.

Troubleshoot each section of the circuit to determine which one contains the open or short.

Repair or repace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1554 is the only active injector fault code?

YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the injector 3 and injector 13 connectors.

Action

Inspect the engine wiring harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-power supply ground short circuit in the harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness from the injectors being tested.

Action

Check for a pin-to-power supply ground short circuit.

  • Measure the resistance between the injector 3 SIGNAL pin and ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.
  • Measure the resistance between the injector 13 SIGNAL pin and ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the shorted injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

A damaged connection has been detected inthe ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check for a pin-to-power supply ground short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the injector 3 and injector 13 connectors.

Action

Check for a pin-to-power supply ground short circuit.

  • Measure the resistance from the injector 3 SIGNAL pin at the ECM connector of the engine harness to ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table. Repeat the check at the injector 13 SIGNAL pin.
  • Measure the resistance from the injector 3 RETURN pin at the ECM connector of the engine harness to ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table. Repeat the check for the injector 13 RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-power supply ground short circuit has been detected in the wiring harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the injector 3 and injector 13 connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector 3 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector 13 SIGNAL pin.
  • Measure the resistance from the injector 3 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector 13 RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 324 and 1554 active?
YES NO

The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process.

Repair complete.

Last Modified: 06-Mar-2017


FAULT CODE 1555 - Injector Solenoid Driver Cylinder 14 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1555 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 332 also active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the injector wiring harness and connector pins. |
 | STEP 2C. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2D. Inspect the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2E. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2F. Read the fault codes. | Fault Code 1555 the only active injector fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-power supply ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins or damaged wire insulation?
 | STEP 3D. Check for a pin-to-power supply ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3E. Check the engine harness for pin-to-pin short circuits. | Greater than 100k ohms?
 | STEP 3F. Read the fault codes. | Fault Codes 332 and 1555 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1555 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 332 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 14 connector.

Action

Inspect the engine wiring harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the injector wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 14 connector.

Action

  • Inspect injector 14 wiring harness. Refer to Procedure 006-026 in the Associated Procedures Table.

Damaged injector wiring harness or connector?
YES NO

Repair or replace the injector wiring harness, if possible. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 14 connector.

Action

Check the resistance of the injector solenoid.

  • Measure the resistance between the injector 14 SIGNAL pin and the injector 14 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the engine wiring harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Check the continuity in the injector circuit.

  • Measure the resistance between the injector 14 SIGNAL pin and the injector 14 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

An open or pin-to-pin short circuit has been detected on the injector 14 circuit.

Troubleshoot each section of the circuit to determine which one contains the open or short.

Repair or repace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1555 is the only active injector fault code?

YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the injector 4 and injector 14 connectors.

Action

Inspect the engine wiring harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-power supply ground short circuit in the harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness from the injectors being tested.

Action

Check for a pin-to-power supply ground short circuit.

  • Measure the resistance between the injector 4 SIGNAL pin and ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.
  • Measure the resistance between the injector 14 SIGNAL pin and ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the shorted injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Repair the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check for a pin-to-power supply ground short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the injector 4 and injector 14 connectors.

Action

Check for a pin-to-power supply ground short circuit.

  • Measure the resistance from the injector 4 SIGNAL pin at the ECM connector of the engine harness to ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table. Repeat the check at the injector 14 SIGNAL pin.
  • Measure the resistance from the injector 4 RETURN pin at the ECM connector of the engine harness to ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table. Repeat the check for the injector 14 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-power supply ground short circuit has been detected in the wiring harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the injector 4 and injector 14 connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector 4 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector 14 SIGNAL pin.
  • Measure the resistance from the injector 4 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector 14 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 332 and 1555 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process.

Repair complete.

Last Modified: 06-Mar-2017


FAULT CODE 1556 - Injector Solenoid Driver Cylinder 15 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1556 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 322 also active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the injector wiring harness and connector pins. |
 | STEP 2C. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2D. Inspect the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2E. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2F. Read the fault codes. | Fault Code 1556 the only active injector fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-power supply ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins or damaged wire insulation?
 | STEP 3D. Check for a pin-to-power supply ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3E. Check the engine harness for pin-to-pin short circuits. | Greater than 100k ohms?
 | STEP 3F. Read the fault codes. | Fault Codes 232 and 1556 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1556 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 15 connector.

Action

Inspect the engine wiring harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the injector wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 15 connector.

Action

  • Inspect injector 15 wiring harness. Refer to Procedure 006-026 in the Associated Procedures Table.

Damaged injector wiring harness or connector?
YES NO

Repair or replace the injector wiring harness, if possible. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 15 connector.

Action

Check the resistance of the injector solenoid.

  • Measure the resistance between the injector 15 SIGNAL pin and the injector 15 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the engine wiring harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Check the continuity in the injector circuit.

  • Measure the resistance between the injector 15 SIGNAL pin and the injector 15 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

An open or pin-to-pin short circuit has been detected on the injector 15 circuit.

Troubleshoot each section of the circuit to determine which one contains the open or short.

Repair or repace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1556 is the only active injector fault code?

YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the injector 1 and injector 15 connectors.

Action

Inspect the engine wiring harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-power supply ground short circuit in the harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness from the injectors being tested.

Action

Check for a pin-to-power supply ground short circuit.

  • Measure the resistance between the injector 1 SIGNAL pin and ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.
  • Measure the resistance between the injector 15 SIGNAL pin and ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the shorted injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check for a pin-to-power supply ground short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the injector 1 and injector 15 connectors.

Action

Check for a pin-to-power supply ground short circuit.

  • Measure the resistance from the injector 1 SIGNAL pin at the ECM connector of the engine harness to ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table. Repeat the check at the injector 15 SIGNAL pin.
  • Measure the resistance from the injector 1 RETURN pin at the ECM connector of the engine harness to ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table. Repeat the check for the injector 15 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-power supply ground short circuit has been detected in the wiring harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the injector 1 and injector 15 connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector 1 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector 15 SIGNAL pin.
  • Measure the resistance from the injector 1 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector 15 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 322 and 1556 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process.

Repair complete.

Last Modified: 06-Mar-2017


FAULT CODE 1557 - Injector Solenoid Driver Cylinder 16 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1557 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 331 also active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the injector wiring harness and connector pins. |
 | STEP 2c. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2D. Inspect the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2E. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2F. Read the fault codes. | Fault Code 1557 the only active injector fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-power supply ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins or damaged wire insulation?
 | STEP 3D. Check for a pin-to-power supply ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3E. Check the engine harness for pin-to-pin short circuits. | Greater than 100k ohms?
 | STEP 3F. Read the fault codes. | Fault Codes 331 and 1557 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1557 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 331 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 16 connector.

Action

Inspect the engine wiring harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the injector wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 16 connector.

Action

  • Inspect injector 16 wiring harness. Refer to Procedure 006-026 in the Associated Procedures Table.

Damaged injector wiring harness or connector?
YES NO

Repair or replace the injector wiring harness, if possible. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 16 connector.

Action

Check the resistance of the injector solenoid.

  • Measure the resistance between the injector 16 SIGNAL pin and the injector 16 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the engine wiring harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Check the continuity in the injector circuit.

  • Measure the resistance between the injector 16 SIGNAL pin and the injector 16 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

An open or pin-to-pin short circuit has been detected on the injector 16 circuit.

Troubleshoot each section of the circuit to determine which one contains the open or short.

Repair or repace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1557 is the only active injector fault code?

YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the injector 2 and injector 16 connectors.

Action

Inspect the engine wiring harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-power supply ground short circuit in the harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness from the injectors being tested.

Action

Check for a pin-to-power supply ground short circuit.

  • Measure the resistance between the injector 2 SIGNAL pin and ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.
  • Measure the resistance between the injector 16 SIGNAL pin and ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the shorted injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

A damaged connection has been detected inthe ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check for a pin-to-power supply ground short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the injector 2 and injector 16 connectors.

Action

Check for apin-to-power supply ground short circuit.

  • Measure the resistance from the injector 2 SIGNAL pin at the ECM connector of the engine harness to ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table. Repeat the check at the injector 16 SIGNAL pin.
  • Measure the resistance from the injector 2 RETURN pin at the ECM connector of the engine harness to ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table. Repeat the check for the injector 16 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-power supply ground short circuit has been detected in the wiring harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the injector 2 and injector 16 connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector 2 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector 16 SIGNAL pin.
  • Measure the resistance from the injector 2 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector 16 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 331 and 1557 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process.

Repair complete.

Last Modified: 06-Mar-2017


FAULT CODE 1618 - Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1618 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 671 active and Fault Code 1618 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1618 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1618 inactive?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1618 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 1 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the exhaust gas temperature sensor 1 or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 1 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas temperature sensor 1 SIGNAL and RETURN pins at the sensor connector of the engine harness.
  • Use the circuit diagram or wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 671 active and Fault Code 1618 inactive?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor 1 to the engine harness.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Run the engine until the engine oil temperature is above 60° C [140° F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1618 active?
YES NO

Replace the exhaust gas temperature sensor 1.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or the engine harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 1 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 1 RETURN pin in the engine harness ECM connector and the exhaust gas temperature sensor 1 RETURN pin in the engine harness sensor connector.

Use the circuit diagram or wiring diagram connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 1 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 1 SIGNAL pin in the engine harness ECM connector and the exhaust gas temperature sensor 1 SIGNAL pin in the engine harness sensor connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 1 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 1 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60° C [140° F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1618 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 24-Mar-2016


FAULT CODE 1619 - Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1619 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 722 active and Fault Code 1619 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1619 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1619 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1619 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 4 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 4 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the exhaust gas temperature sensor 4 or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 4 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas temperature sensor 4 SIGNAL and RETURN pins at the sensor connector of the engine harness.
  • Use the circuit diagram or wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 722 active and Fault Code 1619 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor 4 to the engine harness.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1619 active?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the exhaust gas temperature sensor 4.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or the engine harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 4 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 4 RETURN pin in the engine harness ECM connector and the exhaust gas temperature sensor 4 RETURN pin in the engine harness sensor connector.

Use the circuit diagram or wiring diagram connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 4 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 4 SIGNAL pin in the engine harness ECM connector and the exhaust gas temperature sensor 4 SIGNAL pin in the engine harness sensor connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 4 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 4 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1619 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 1622 - Injector Solenoid Driver Cylinder 9 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1662 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1548 also active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the injector wiring harness and connector pins. |
 | STEP 2C. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2D. Inspect the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2E. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2F. Read the fault codes. | Fault Code 1622 the only active injector fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-power supply ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins or damaged wire insulation?
 | STEP 3D. Check for a pin-to-power supply ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3E. Check the engine harness for pin-to-pin short circuits. | Greater than 100k ohms?
 | STEP 3F. Read the fault codes. | Fault Codes 1548 and 1622 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1662 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1548 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 9 connector.

Action

Inspect the engine wiring harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the injector wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 9 connector.

Action

  • Inspect injector 9 wiring harness. Refer to Procedure 006-026 in the Associated Procedures Table.

Damaged injector wiring harness or connector?
YES NO

Repair or replace the injector wiring harness, if possible. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injector 9 connector.

Action

Check the resistance of the injector solenoid.

  • Measure the resistance between the injector 9 SIGNAL pin and the injector 9 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the engine wiring harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Check the continuity in the injector.

  • Measure the resistance between the injector 9 SIGNAL pin and the injector 9 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

An open or pin-to-pin short circuit has been detected on the injector 9 circuit.

Troubleshoot each section of the circuit to determine which one contains the open or short.

Repair or repace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1622 is the only active injector fault code?

YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the injector 7 and injector 9 connectors.

Action

Inspect the engine wiring harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-power supply ground short circuit in the harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine wiring harness from the injectors being tested.

Action

Check for a pin-to-power supply ground short circuit.

  • Measure the resistance between the injector 7 SIGNAL pin and ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.
  • Measure the resistance between the injector 9 SIGNAL pin and ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the shorted injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

A damaged connection has been detected inthe ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check for a pin-to-power supply ground short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the injector 7 and injector 9 connectors.

Action

Check for a pin-to-power supply ground short circuit.

  • Measure the resistance from the injector 7 SIGNAL pin at the ECM connector of the engine harness to ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table. Repeat the check at the injector 9 SIGNAL pin.
  • Measure the resistance from the injector 7 RETURN pin at the ECM connector of the engine harness to ECM power supply ground at the 16 pin power connector. Refer to Procedure 019-610 in the Associated Procedures Table. Repeat the check for the injector 9 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-power supply ground short circuit has been detected in the wiring harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the injector 7 and injector 9 connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector 7 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector 9 SIGNAL pin.
  • Measure the resistance from the injector 7 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector 9 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1548 and 1622 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process.

Repair complete.

Last Modified: 06-Mar-2017


FAULT CODE 1636 - Intake Manifold 2 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 1636 active?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1637 active and Fault Code 1636 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1636 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1636 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1637 active and Fault Code 1636 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold 2 pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1636 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold pressure sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1637 active and Fault Code 1636 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1636 active?
YES NO

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the ECM engine connector.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 and 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1636 active?
YES NO

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 23-Mar-2016


FAULT CODE 1637 - Intake Manifold 2 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1637 active?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1636 active and Fault Code 1637 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1637 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 1637 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold 2 pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold 2 pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold 2 pressure +5 volt SUPPLY pin and the intake manifold pressure SIGNAL pin at the intake manifold pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1636 active and Fault Code 1637 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold 2 pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1637 active?
YES NO

None. The removal and installation of the connector corrected the fault.

A damaged sensor has been detected.

Replace the sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the ECM engine connector.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 and 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1637 active?
YES NO

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold pressure +5 volt SUPPLY pin and the intake manifold pressure SIGNAL pin at the engine control module engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1636 active and Fault Code 1637 inactive?
YES NO
No Repair

Replace the ECM. Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1637 active?
YES NO

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 25-Mar-2016


FAULT CODE 1668 (2-Wire Sensor) - Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Electrical Connector Replacement | Refer to Procedure 019-559 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1668 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid tank level sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid (DEF) tank level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1669 active and Fault Code 1668 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1668 active?
STEP 3. | Check the harness. |
 | STEP 3A. Inspect the original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Inspect the ECM connector pins in the engine harness. | Dirty or damaged pins?
 | STEP 3E. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3F. Check for a pin to ECM power supply ground short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3G. Check for an active fault code. | Fault Code 1668 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF tank level sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DEF tank level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank level sensor from the OEM harness.

Action

Inspect the aftertreatment DEF tank level sensor and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

Repair or replace the DEF tank level sensor connector. Refer to Procedure 019-559 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an appropriate ECM response after 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 active and Fault Code 1668 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF tank level sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668 active?
YES NO

A damaged aftertreatment DEF tank level sensor has been detected.

Replace the aftertreatment DEF tank level sensor. See equipment manufacturer.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the harness.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the aftertreatment 1 connector.

Action

Inspect the OEM harness and aftertreatment 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment 1 connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the aftertreatment 1 connector.
  • Disconnect the aftertreatment DEF tank level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF tank level SIGNAL pin at the OEM harness aftertreatment 1 connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit between pins has been detected in the harness

Troubleshoot all harnesses connected in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of the harness.

Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin to ECM power supply ground short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the aftertreatment 1 connector.
  • Disconnect the aftertreatment DEF tank level sensor from the OEM harness.

Action

Check for a pin short to ECM power supply ground.

Refer to Procedure 019-610 in the Associated Procedures Table.

  • Measure the resistance and check for a short circuit between the aftertreatment DEF tank level sensor SIGNAL pin at the OEM harness aftertreatment 1 connector and ECM power supply ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ECM power supply ground has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of the harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Inspect the ECM connector pins in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the OEM and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only if there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3E

Guided Step 3F - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness from the engine aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF tank level SIGNAL pin at the OEM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit between pins has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for a pin to ECM power supply ground short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the aftertreatment DEF sensor from the OEM harness.

Action

Check for a pin to ECM power supply ground short.

Refer to Procedure 019-610 in the Associated Procedures Table.

  • Measure the resistance between the aftertreatment DEF tank level sensor SIGNAL pin at the OEM connector and ECM power supply ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ECM power supply ground has been detected in the harness.

Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3G

Go to 4A

Guided Step 3G - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668 active?
YES NO

A damaged ECM has been detected.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 12-Apr-2016


FAULT CODE 1668 (3-Wire Sensor) - Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Electrical Connector Replacement | Refer to Procedure 019-559 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 1668 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) tank level sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF tank level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1669 active and Fault Code 1668 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1668 active?
STEP 3. | Check the harness. |
 | STEP 3A. Inspect the original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin to ECM power supply ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Inspect the ECM connector pins in the engine harness. | Dirty or damaged pins?
 | STEP 3F. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3G. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3H. Check for a pin to ECM power supply ground short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3I. Check for an active fault code. | Fault Code 1668 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF tank level sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DEF tank level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank level sensor from the OEM harness.

Action

Inspect the aftertreatment DEF tank level sensor and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

Repair or replace the DEF tank level sensor connector. Refer to Procedure 019-559 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the aftertreatment DEF tank level SUPPLY pin and the aftertreatment DEF tank level RETURN pin at the aftertreatment DEF level sensor connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 active and Fault Code 1668 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF tank level sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668 active?
YES NO

A damaged aftertreatment DEF tank level sensor has been detected.

Replace the aftertreatment DEF tank level sensor. See equipment manufacturer.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the harness.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the aftertreatment 1 connector.

Action

Inspect the OEM harness and aftertreatment 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness or aftertreatment 1 connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the aftertreatment 1 connector.
  • Disconnect the aftertreatment DEF tank level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness aftertreatment 1 connector DEF tank level sensor SUPPLY pin and the OEM harness aftertreatment DEF tank level sensor connector SUPPLY pin.
  • Measure the resistance between the OEM harness aftertreatment 1 connector DEF tank level sensor SIGNAL pin and the OEM harness aftertreatment DEF tank level sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of the harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the aftertreatment 1 connector.
  • Disconnect the aftertreatment DEF tank level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF tank level sensor SIGNAL pin at the OEM harness aftertreatment 1 connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit between pins has been detected in the harness

Troubleshoot all harnesses connected in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of the harness.

Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin to ECM power supply ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the aftertreatment 1 connector.
  • Disconnect the aftertreatment DEF tank level sensor from the OEM harness.

Action

Check for a pin short to ECM power supply ground.

Refer to Procedure 019-610 in the Associated Procedures Table.

  • Measure the resistance and check for a short circuit between the aftertreatment DEF tank level sensor SIGNAL pin at the OEM harness aftertreatment 1 connector and ECM power supply ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ECM power supply ground has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of the harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3E - Inspect the ECM connector pins in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the OEM and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only if there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3F

Guided Step 3F - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness from the engine aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the OEM connector aftertreatment DEF tank level sensor SUPPLY pin and the aftertreatment 1 connector DEF tank level sensor SUPPLY pin.
  • Measure the resistance between the OEM connector aftertreatment DEF tank level sensor SIGNAL pin and the aftertreatment 1 connector DEF tank level sensor SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the harness.

Repair or replace the damaged section of the harness.

Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3G

Go to 4A

Guided Step 3G - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness from the engine aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF tank level SIGNAL pin at the OEM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal wire has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3H

Go to 4A

Guided Step 3H - Check for a pin to ECM power supply ground short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness from the engine aftertreatment 1 connector.

Action

Check for a pin to ECM power supply ground short.

Refer to Procedure 019-610 in the Associated Procedures Table.

  • Measure the resistance between the aftertreatment DEF tank level sensor SIGNAL pin at the OEM connector and ECM power supply ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ECM power supply ground short circuit on the signal wire has been detected in the harness.

Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3I

Go to 4A

Guided Step 3I - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668 active?
YES NO

A damaged ECM has been detected.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 25-Apr-2016


FAULT CODE 1669 (2-Wire Sensor) - Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Electrical Connector Replacement | Refer to Procedure 019-559 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1669 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) tank level sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF tank level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1668 active and Fault Code 1669 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1669 active?
STEP 3. | Check the harness. |
 | STEP 3A. Inspect the original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Inspect the ECM harness connector pins. | Dirty or damaged pins?
 | STEP 3E. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3F. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 3G. Check for an active fault code. | Fault Code 1669 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF tank level sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DEF tank level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank level sensor from the OEM harness.

Action

Inspect the aftertreatment DEF tank level sensor and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

Use the following procedure for DEF tank level sensor connector repair or replacement. Refer to Procedure 019-559 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the aftertreatment DEF tank level sensor SIGNAL pin and aftertreatment DEF tank level sensor RETURN pin at the aftertreatment DEF tank level sensor wiring harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668 active and Fault Code 1669 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF tank level sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 is active?
YES NO

A damaged aftertreatment DEF tank level sensor has been detected.

Replace the aftertreatment DEF tank level sensor.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the harness

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the aftertreatment 1 connector.

Action

Inspect the OEM harness and aftertreatment 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment 1 connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the aftertreatment 1 connector.
  • Disconnect the aftertreatment DEF tank level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness aftertreatment 1 connector aftertreatment DEF tank level sensor RETURN pin and the OEM harness aftertreatment DEF tank level sensor connector RETURN pin.
  • Measure the resistance between the OEM harness aftertreatment 1 connector aftertreatment DEF tank level sensor SIGNAL pin and the aftertreatment DEF tank level sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit in the aftertreatment junction box, if equipped.

  • Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the aftertreatment 1 connector.
  • Disconnect the aftertreatment DEF tank level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the aftertreatment DEF tank level SIGNAL pin at the OEM harness aftertreatment 1 connector and all other pins in the OEM harness aftertreatment 1 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit in the aftertreatment junction box, if equipped. Refer to Procedure 019-598 in the Associated Procedures Table.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the OEM and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace ECM only when there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3E

Guided Step 3E - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness from the aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the OEM connector DEF tank level sensor RETURN pin and the aftertreatment 1 connector DEF tank level sensor connector RETURN pin.
  • Measure the resistance between the OEM connector DEF tank level sensor SIGNAL pin and the aftertreatment 1 connector DEF tank level sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Repair or replace the damaged section of harness.

  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness from the engine aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the aftertreatment DEF tank level SIGNAL pin at the OEM connector and all other pins in the OEM connector

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Repair or replace the damaged section of harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3G

Go to 4A

Guided Step 3G - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 31-Mar-2016


FAULT CODE 1669 (3-Wire Sensor) - Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Electrical Connector Replacement | Refer to Procedure 019-559 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 1669 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) tank level sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF tank level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1668 active and Fault Code 1669 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. |
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1669 active?
STEP 3. | Check the ECM and harness. |
 | STEP 3A. Inspect the original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Inspect the ECM connector pins. | Dirty or damaged pins?
 | STEP 3F. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3G. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3H. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3I. Check for an active fault code. | Fault Code 1669 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF tank level sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DEF tank level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank level sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DEF tank level sensor and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

Use the following procedure for DEF tank level sensor connector repair or replacement. Refer to Procedure 019-559 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response after 30 seconds.

  • Place a jumper wire between the aftertreatment DEF tank level sensor SIGNAL pin and the aftertreatment DEF tank level sensor RETURN pin at the aftertreatment DEF tank level sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668 active and Fault Code 1669 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit

  • Measure the voltage between the aftertreatment DEF tank level SUPPLY pin and the aftertreatment DEF tank level RETURN pin at the aftertreatment DEF tank level sensor connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF tank level sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 is active?
YES NO

A damaged sensor has been detected.

Replace the aftertreatment DEF tank level sensor.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and harness

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the aftertreatment 1 connector.

Action

Inspect the OEM harness and aftertreatment 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment 1 connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the aftertreatment 1 connector.
  • Disconnect the aftertreatment DEF tank level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness aftertreatment 1 connector aftertreatment DEF tank level sensor RETURN pin and the OEM harness aftertreatment DEF tank level sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit in the aftertreatment junction box, if equipped.

  • Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the aftertreatment 1 connector.
  • Disconnect the aftertreatment DEF tank level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the aftertreatment DEF tank level SIGNAL pin at the OEM harness aftertreatment 1 connector and all other pins in the OEM harness aftertreatment 1 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit in the aftertreatment junction box, if equipped. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the aftertreatment 1 connector.
  • Disconnect the aftertreatment DEF tank level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the aftertreatment DEF tank level SIGNAL pin at the OEM harness aftertreatment 1 connector and all other pins in the OEM harness aftertreatment 1 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit in the aftertreatment junction box, if equipped. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the OEM and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-031 in the Associated Procedures Table.
  • Replace ECM only when there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3F

Guided Step 3F - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the aftertreatment DEF tank level sensor from the OEM harness

Action

Check for an open circuit.

  • Measure the resistance between the OEM connector aftertreatment DEF tank level sensor RETURN pin and the aftertreatment 1 connector DEF tank level sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Repair or replace the damaged section of harness.

  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3G

Go to 4A

Guided Step 3G - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness from the engine aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the aftertreatment DEF tank level SIGNAL pin at the OEM connector and all other pins in the OEM connector

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Repair or replace the damaged section of harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3H

Go to 4A

Guided Step 3H - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness from the engine aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the aftertreatment DEF tank level SUPPLY pin at the OEM connector and all other pins in the OEM connector

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the harness.

Repair or replace the damaged section of harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3I

Go to 4A

Guided Step 3I - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 23-Mar-2016


FAULT CODE 1673 - Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1673 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1673 active?
YES NO

A low aftertreatment diesel exhaust fluid (DEF) level has been detected.

Fill the DEF tank completely full.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 31-Mar-2016


FAULT CODE 1677 - Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 1677 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) tank temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF tank temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1678 active and Fault Code 1677 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1677 active?
STEP 3. | Check the original equipment manufacturer (OEM) and engine control module (ECM) harnesses. |
 | STEP 3A. Inspect the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ECM power supply ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Inspect the ECM harness connector pins. | Dirty or damaged pins?
 | STEP 3E. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3F. Check for a pin-to-ECM power supply ground short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3G. Check fault codes. | Fault Code 1677 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent or inactive fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF tank temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DEF tank temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DEF tank temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1678 active and Fault Code 1677 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF tank temperature sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 active?
YES NO

Replace the aftertreatment DEF tank temperature sensor.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM and ECM harnesses.

Guided Step 3A - Inspect the aftertreatment and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine aftertreatment 1 connector.

Action

Inspect the OEM harness and aftertreatment 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine aftertreatment 1 connector.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF tank temperature sensor SIGNAL pin in the OEM harness aftertreatment 1 connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair, or replace the damaged section of harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ECM power supply ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine aftertreatment 1 connector.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment DEF tank temperature sensor SIGNAL pin in the OEM harness aftertreatment 1 connector and ECM power supply ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Refer to Procedure 019-610 in the Associated Procedures Table.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the OEM connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

Replace ECM only when there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3E

Guided Step 3E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness from the engine aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF tank temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for a pin-to-ECM power supply ground short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness from the engine aftertreatment 1 connector.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment DEF tank temperature sensor SIGNAL pin in the OEM connector and ECM power supply ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Refer to Procedure 019-610 in the Associated Procedures Table.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin ECM power supply ground short circuit on the SIGNAL wire has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3G

Go to 4A

Guided Step 3G - Check fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 31-Mar-2016


FAULT CODE 1678 - Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 1677 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) tank temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF tank temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1677 active and Fault Code 1678 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1678 active?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harnesses. |
 | STEP 3A. Inspect the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Inspect the ECM pins in the engine harness. | Dirty or damaged pins?
 | STEP 3E. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3F. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3G. Check active fault codes. | Fault Code 1677 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1678 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent or inactive fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF tank temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DEF tank temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DEF tank temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19 or see equipment manufacturer service information.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the circuit response.

  • Place a jumper wire between the aftertreatment DEF tank temperature SIGNAL pin and the aftertreatment DEF tank temperature RETURN pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1678 active and Fault Code 1677 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF tank temperature sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1678 active?
YES NO

A damaged aftertreatment DEF tank temperature sensor has been detected.

Replace the aftertreatment DEF tank temperature sensor.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harnesses.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine aftertreatment 1 connector.

Action

Inspect the OEM harness and aftertreatment 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine aftertreatment 1 connector.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF tank temperature sensor RETURN pin at the OEM harness aftertreatment 1 connector and the aftertreatment DEF tank temperature sensor RETURN pin at the OEM wiring harness temperature sensor connector.
  • Measure the resistance between the aftertreatment DEF tank temperature sensor SIGNAL pin at the OEM harness aftertreatment 1 connector and the aftertreatment DEF tank temperature sensor SIGNAL pin at the OEM wiring harness temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair, or replace the damaged section of harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine aftertreatment 1 connector.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF tank temperature sensor SIGNAL pin in the OEM harness aftertreatment 1 connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Inspect the ECM connector pins in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the ECM and OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

Replace ECM only when there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3E

Guided Step 3E - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness from the engine aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF tank temperature sensor RETURN pin at the OEM connector and the aftertreatment DEF tank temperature sensor RETURN pin at the aftertreatment 1 connector.
  • Measure the resistance between the aftertreatment DEF tank temperature sensor SIGNAL pin at the OEM connector and the aftertreatment DEF tank temperature sensor SIGNAL pin at the aftertreatment 1 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness from the engine aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF tank temperature sensor SIGNAL pin in the OEM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3G

Go to 4A

Guided Step 3G - Check active fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1678 active?
YES NO

A malfunctioning ECM has been detected.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 31-Mar-2016


FAULT CODE 1679 - Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1677 or 1678 active?
STEP 2. | Verify the aftertreatment diesel exhaust fluid (DEF) tank temperature sensor. |
 | STEP 2A. Verify the aftertreatment DEF tank temperature sensor accuracy. | INSITE™ electronic service tool aftertreatment DEF tank temperature reading within 5.6°C or 10°F of the measured value?
STEP 3. | Check the aftertreatment DEF tank temperature sensor and circuit. |
 | STEP 3A. Inspect the aftertreatment DEF tank temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1678 active?
 | STEP 3C. Check the circuit response. | Fault Code 1677 active?
STEP 4. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 4A. Inspect the aftertreatment and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 4C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 4D. Inspect the ECM harness connector pins in the engine harness. | Dirty or damaged pins?
 | STEP 4E. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 4F. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 or 1678 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Verify the aftertreatment DEF tank temperature sensor.

Guided Step 2A - Verify the aftertreatment DEF tank temperature sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the accuracy of the aftertreatment DEF tank temperature sensor.

  • Measure the temperature of the aftertreatment DEF in the tank with an infrared thermometer or thermocouple.
  • Start INSITE™ electronic service tool Data Monitor/Logger.
  • Compare the INSITE™ electronic service tool reading for the aftertreatment DEF tank temperature to the value measured with the infrared thermometer or thermocouple.

INSITE™ electronic service tool aftertreatment DEF tank temperature reading within 5.6°C or 10°F of the measured value?
YES NO
No Repair

Replace the aftertreatment DEF tank temperature sensor. See equipment manufacturer service information.

Go to 3A

Go to 5A

Guided Step 3 - Check the aftertreatment DEF tank temperature sensor and circuit.

Guided Step 3A - Inspect the aftertreatment DEF tank temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DEF tank temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1678 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the aftertreatment DEF tank temperature SIGNAL pin and the aftertreatment DEF tank temperature RETURN pin at the aftertreatment DEF tank temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

Fault Code 1677 active?
YES NO

Replace the aftertreatment DEF tank temperature sensor. See equipment manufacturer service information.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and OEM harness.

Guided Step 4A - Inspect the aftertreatment and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine aftertreatment 1 connector.

Action

Inspect the OEM harness and aftertreatment 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment 1 connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the aftertreatment 1 connector.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF tank temperature sensor RETURN pin at the OEM harness aftertreatment 1 connector and the aftertreatment DEF tank temperature sensor RETURN pin at the OEM wiring harness temperature sensor connector.
  • Measure the resistance between the aftertreatment DEF tank temperature sensor SIGNAL pin at the OEM harness aftertreatment 1 connector and the aftertreatment DEF tank temperature sensor SIGNAL pin at the OEM wiring harness temperature sensor connector.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Troubleshoot each harness connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine aftertreatment 1 connector.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF tank temperature sensor SIGNAL pin in the OEM harness aftertreatment 1 connector and all other pins in the connector.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot each harness connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, Repair or replace the damaged section of harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Inspect the ECM harness connector pins in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the OEM harness connector and ECM pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM connector or ECM.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only when there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4E

Guided Step 4E - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the engine aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF tank temperature sensor RETURN pin at the OEM harness ECM connector and the aftertreatment DEF tank temperature sensor RETURN pin at the aftertreatment 1 connector.
  • Measure the resistance between the aftertreatment DEF tank temperature sensor SIGNAL pin at the OEM harness ECM connector and the aftertreatment DEF tank temperature sensor SIGNAL pin at the aftertreatment 1 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4F

Go to 5A

Guided Step 4F - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Diconnect the OEM harness from the engine aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF tank temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A malfunctioning ECM has been detected.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 31-Mar-2016


FAULT CODE 1682 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSK95 CM2350 K113 | 4388663
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Heater | Refer to Procedure 011-112 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Line Heater Relay | Refer to Procedure 019-600 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Heater Relay | Refer to Procedure 019-620 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1682 active or more than two inactive counts?
 | STEP 1B. Check for aftertreatment diesel exhaust fluid (DEF) related fault codes. | Fault Code 1712 active or more than two inactive counts?
 | STEP 1C. Check for low aftertreatment DEF tank level. | DEF tank empty and/or Fault Code 1673, 3497, or 3498 active?
 | STEP 1D. Check the DEF tank for debris. | DEF tank and vent clean and free of debris?
 | STEP 1E. Check ambient operating temperatures. | Equipment operating in ambient temperatures below -5°C [23°F] at the time the fault set?
STEP 2. | Check the aftertreatment 1 dosing system DEF line heaters. |
 | STEP 2A. Test the aftertreatment 1 DEF line heater relays. | Aftertreatment 1 line heater relays within specification?
 | STEP 2B. Check DEF line heater functionality. | All line heaters functioning correctly?
 | STEP 2C. Inspect the original equipment manufacturer (OEM) harness and line heater connections. | Dirty or damaged pins?
 | STEP 2D. Check line heater supply voltage and return circuits. | All measurements within 1 VDC of ECM power supply voltage?
 | STEP 2E. Check line heater supply voltage to the engine control module (ECM) power supply ground. | All measurements within 1 VDC of ECM power supply voltage?
STEP 3. | Check the aftertreatment DEF dosing unit heating system. |
 | STEP 3A. Check the aftertreatment 1 DEF dosing unit heater relay. | Aftertreatment 1 DEF dosing unit heater relay within specifications?
 | STEP 3B. Inspect the aftertreatment 1 DEF dosing unit 1 heater and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check heater circuit resistance in the aftertreatment 1 DEF dosing unit 1 heater. | Resistance at 5.4 ohms ± 2.0 ohms?
 | STEP 3D. Check for an open circuit in the aftertreatment 1 DEF dosing unit 1 heater supply circuit. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3E. Check aftertreatment 1 DEF dosing unit 1 heater supply voltage to ECM power supply ground. | Measurements within 1 VDC of ECM power supply voltage?
STEP 4. | Check the aftertreatment DEF lines and fittings. |
 | STEP 4A. Inspect the aftertreatment DEF lines and fittings. | Any reversed, damaged, leaking, or restricted connections found?
 | STEP 4B. Check for pressure at the aftertreatment 1 DEF dosing valve 1. | DEF pressure greater than 1000 kPa [145 psi]?
 | STEP 4C. Check the aftertreatment 1 DEF dosing unit 1 supply line. | DEF dosing unit supply line blocked or restricted?
 | STEP 4D. Check the aftertreatment 1 DEF dosing valve 1 pressure line. | DEF pressure line blocked or restricted?
STEP 5. | Check the aftertreatment 1 DEF dosing valve 1 system return. |
 | STEP 5A. Check for a blocked aftertreatment 1 DEF dosing valve 1. | DEF pressure greater than 700 kPa [102 psi]?
 | STEP 5B. Check the aftertreatment 1 DEF dosing valve 1 return line. | DEF return line blocked or restricted?
STEP 6. | Check the aftertreatment 1 DEF suction line. |
 | STEP 6A. Check for air in the DEF. | Air in DEF detected?
 | STEP 6B. Check for an intermittent aftertreatment 1 DEF dosing unit 1 suction line leak. | Does wiggling DEF suction line connections affect system pressure?
 | STEP 6C. Check the aftertreatment 1 DEF pressure. | DEF pressure greater than 750 kPa [109 psi]?
STEP 7. | Check the aftertreatment 1 DEF dosing valve 1 operation. |
 | STEP 7A. Check the aftertreatment DEF dosing system operation. | Dosing volume within specifications in Procedure 011-063 in the Associated Procedures Table?
 | STEP 7B. Check the results of the doser override test. | DEF pressure at the service tool gauge above 700 kPa [102 psi] for duration of test?
STEP 8. | Check ECM calibration and clear fault codes. |
 | STEP 8A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 8B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1682 active or more than two inactive counts?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for DEF related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1712 active or more than two inactive counts?
YES NO

Fault Code 1712 indicates the aftertreatment DEF tank is frozen. Troubleshoot occurrences of Fault Code 1712 before troubleshooting Fault Code 1682.

No Repair

Reference the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for low DEF tank level.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Make sure the DEF tank is not empty, and the tank level gauge is accurate.

Use INSITE™ electronic service tool to read the fault codes.

  • Check for the following active Fault Codes: 1673, 3497, and 3498.

DEF tank empty and/or Fault Codes 1673, 3497, or 3498 active?
YES NO

Fill the DEF tank.

 No Repair

Go to 8A

Go to 1D

Guided Step 1D - Check DEF tank for debris.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF tank.

  • Check the DEF tank for debris or foreign particles.
  • Check the DEF tank vent for crystallization buildup and clogging.
  • Use the Diesel Exhaust Fluid Refractometer, Part Number 4919554, to test the DEF concentration.

DEF tank and vent clean and free of debris?
YES NO
No Repair

Clean the DEF tank and tank filter thoroughly. Replace the tank filter if necessary. See equipment manufacturer service information.

Fill tank with certified DEF.

If the DEF in the tank is found to be dirty replace the DEF dosing unit filter and inlet screen. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 1E

Go to 8A

Guided Step 1E - Check ambient operating temperatures.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Check if the equipment was operating in a cold ambient environment, temperature below -5°C [23°F], at the time the fault logged.

Use INSITE™ electronic service tool to read the fault code snapshot and check the ambient air temperature sensor reading to verify.

Equipment operating in ambient temperatures below -5°C [23°F] at the time the fault set?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the aftertreatment 1 dosing system 1 DEF line heaters.

Guided Step 2A - Test the aftertreatment 1 DEF line heater relays.

Conditions

  • Turn keyswitch OFF.

Action

Test the aftertreatment 1 DEF line heater relays (K9).

  • Refer to Procedure 019-600 in the Associated Procedures Table.

Aftertreatment 1 line heater relays within specification?
YES | NO
No Repair | No Repair

Go to 2B

Go to 2B

Guided Step 2B - Check DEF line heater functionality.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test.

Use an infrared thermometer to measure the surface temperature at the ends of each of the three aftertreatment 1 unit 1 DEF lines.

Look for the following:

  • Surface temperature should be above 10C [50F].
  • Temperature uniformity across the length of the individual lines.
  • Temperature uniformity between the lines.

If the lines were not at operating temperature when the test was started a temperature rise will be noticeable

All line heaters functioning correctly?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2C

Guided Step 2C - Inspect the OEM harness and line heater connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the three line heaters (suction, pressure, and return) from the OEM harness.

Action

Inspect the OEM harness and line heater connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the line heater or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 8A

Go to 2D

Guided Step 2D - Check line heater supply voltage and return circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the three line heaters (suction, pressure, and return) from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuits.

  • Measure the voltage from the line heater +24 volt SUPPLY pin to the line heater RETURN pin at the heater connector of the OEM harness.

Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

All measurements within 1 VDC of ECM power supply voltage?
YES NO

Replace the malfunctioning line heater(s). See equipment manufacturer service information.

 No Repair

Go to 8A

Go to 2E

Guided Step 2E - Check line heater supply voltage to ECM power supply ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the three line heaters (suction, pressure, and return) from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuits.

  • Measure the voltage from the line heater +24 volt SUPPLY pin to the ECM power supply ground.

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

All measurements within 1 VDC of ECM power supply voltage?
YES NO

An open has been detected in the line heater return circuit.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of the harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Troubleshoot the return circuit in the aftertreatment junction box, if equipped. Refer to Procedure 019-598 in the Associated Procedures Table.

An open has been detected between the line heater relay and the line heater.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of the harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Troubleshoot the return circuit in the aftertreatment junction box, if equipped. Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 8A

Go to 8A

Guided Step 3 - Check the aftertreatment 1 DEF dosing unit 1 heating system.

Guided Step 3A - Check the aftertreatment 1 diesel exhaust fluid (DEF) dosing unit heater relay.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment 1 DEF dosing unit heater relay (K1) from the aftertreatment junction box. Refer to Procedure 019-620 in the Associated Procedures Table.

Action

Test aftertreatment 1 DEF dosing unit heater relay.

  • Refer to Procedure 019-620 in the Associated Procedures Table.

Refer to the appropriate wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Aftertreatment 1 DEF dosing unit heater relay within specifications?
YES NO
No Repair

Replace the aftertreatment 1 DEF dosing unit heater relay (K1). Refer to Procedure 019-620 in the Associated Procedures Table.

Go to 8A

Go to 3B

Guided Step 3B - Inspect the aftertreatment 1 DEF dosing unit 1 heater and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 1 heater from the OEM harness.

Action

Inspect the DEF dosing unit heater and OEM harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment DEF dosing unit heater or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the dosing unit heater only if there are damaged pins. Refer to Procedure 011-112 in the Associated Procedures Table.

 No Repair

Go to 8A

Go to 3C

Guided Step 3C - Check heater circuit resistance in the aftertreatment 1 DEF dosing unit 1 heater.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check resistance at the dosing unit heater.

  • Measure the resistance across heater at the aftertreatment DEF dosing unit heater supply and the aftertreatment DEF dosing unit heater return at the DEF dosing unit.

Use the following procedure for general voltage measurement techniques. Refer to Procedure 019-359 in Section 19.

Resistance at 5.4 ohms ± 2.0 ohms?
YES NO
No Repair

A malfunctioning aftertreatment DEF dosing unit heater has been detected.

Replace the aftertreatment DEF dosing unit heater. Refer to Procedure 011-112 in the Associated Procedures Table.

Go to 3D

Go to 8A

Guided Step 3D - Check for an open circuit in the aftertreatment 1 DEF dosing unit 1 heater supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 1 heater from the OEM harness.
  • Turn keyswitch ON.

Action

Perform the Aftertreatment Diesel Exhaust Fluid Doser System Heater Test found under "ECM Diagnostic Tests" in INSITE™ electronic service tool.

  • Measure the voltage between aftertreatment 1 DEF dosing unit 1 heater SUPPLY pin at the aftertreatment 1 DEF dosing unit 1 heater connector and ECM power supply ground.

Refer to Procedure 019-610 in the Associated Procedures Table.

Voltage within 1 VDC of ECM power supply voltage?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DEF dosing unit heater supply circuit.

Check the aftertreatment DEF dosing unit heater circuit breaker. Refer to Procedure 019-598 in the Associated Procedures Table.

Troubleshoot all harness connections in series to determine which one contains the open circuit.

If an open circuit is isolated to a damaged harness, Repair or replace the damaged section of harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 8A

Guided Step 3E - Check aftertreatment 1 DEF dosing unit 1 heater supply voltage to ECM power supply ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 1 heater from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuits.

  • Measure the voltage from the line heater +24 volt SUPPLY pin to ECM power supply ground.

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-360 in Section 19.

Measurement within 1 VDC of ECM power supply voltage?
YES NO

An open has been detected in the heater return circuit.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Troubleshoot return circuit in the aftertreatment junction box, if equipped. Refer to Procedure 019-598 in the Associated Procedures Table.

An open has been detected in the heater relay and the heater.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Troubleshoot return circuit in the aftertreatment junction box, if equipped. Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 8A

Go to 8A

Guided Step 4 - Check the aftertreatment DEF lines and fittings.

Guided Step 4A - Inspect the aftertreatment DEF lines and fittings.

Conditions

  • Turn keyswitch OFF.

Action

There are three DEF lines on the SCR dosing system:

  • Dosing unit supply line between the tank and the dosing unit (suction line)
  • Dosing valve supply line between the dosing unit and the dosing valve (pressure line)
  • Return line between the dosing valve and the tank (return line).

Inspect all three DEF lines and associated fittings/connectors:

  • Inspect the dosing unit for a plugged inlet filter in the inlet fitting. Refer to Procedure 011-058 in the Associated Procedures Table.
  • Inspect the dosing unit DEF filter. Refer to Procedure 011-060 in the Associated Procedures Table.
  • Verify the DEF line connections are not swapped at the dosing unit, dosing valve or DEF tank. Reversed DEF lines can cause the dosing system to fail to prime.
  • Check the DEF tank connections (suction and return lines) for cracks and pitting.
  • Check both dosing unit connections and fittings for loose, leaking, or damaged connections.
  • Check the suction line for signs of leakage or openings which will allow the dosing unit to suck in air with the DEF.
  • Check the pressure line for signs of leakage or rupture.
  • Disconnect the suction line, pressure line, and return line connectors and look for signs of buildup or blockage.
  • Verify proper sealing at all connection points and check for damaged or missing o-rings.

Any reversed, damaged, leaking, or restricted connections found?
YES NO

Replace the DEF line(s), fittings, and filters, as necessary. If the DEF dosing unit inlet filter screen is plugged, replace the tank filter. See equipment manufacturer service information.

Use the following procedure for the DEF dosing unit inlet filter screen. Refer to Procedure 011-058 in the Associated Procedures Table.

Use the following procedure for the DEF dosing unit filter. Refer to Procedure 011-060 in the Associated Procedures Table.

Use the following procedure for the DEF dosing unit connections. Refer to Procedure 011-058 in the Associated Procedures Table.

Repair or replace the aftertreatment DEF dosing unit, as necessary. Refer to Procedure 011-058 in the Associated Procedures Table.

Replace the DEF dosing unit inlet filter screen and dosing unit DEF filter. These filters cannot be reused and must be changed upon removal. Refer to Procedure 011-060 in the Associated Procedures Table.

Go to 8A

Go to 4B

Guided Step 4B - Check for pressure at the aftertreatment 1 DEF dosing valve 1.

Conditions

  • Turn keyswitch OFF
  • Install the DEF pressure gauge between the inlet of the dosing valve and the pressure line. Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

Attempt to prime the DEF system.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhuast Fluid System Leak Test, under ECM Diagnostics Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure greater than 1000 kPa [145 psi]?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check the aftertreatment 1 DEF dosing unit 1 supply line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 1 supply line from the dosing unit (this is the suction line between the dosing unit and the DEF tank).
  • Disconnect the aftertreatment 1 DEF dosing unit 1 supply line from the DEF tank.

Action

Check the DEF dosing unit 1 supply line for blockage.

  • Check both ends of the dosing unit supply line for signs of build-up or blockage.
  • Blow compressed shop air through the dosing unit supply line to make sure of free flow.

DEF dosing unit supply line blocked or restricted?
YES NO

Try to clean the dosing unit supply line with shop air. If necessary, replace the dosing unit supply line. See equipment manufacturer service information.

No Repair

Go to 8A

Go to 4D

Guided Step 4D - Check the aftertreatment 1 DEF dosing valve 1 pressure line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 1 pressure line from the dosing valve (pressure line runs between the dosing unit and dosing valve).
  • Disconnect the aftertreatment 1 DEF dosing valve 1 pressure line from the DEF dosing unit.

Action

Check the aftertreatment 1 DEF pressure line for blockage.

  • Visually check both ends of the line for signs of buildup or blockage.
  • Blow compressed shop air through the pressure line to make sure of free flow.

DEF pressure line blocked or restricted?
YES NO

Try to clean the pressure line using shop air. If necessary, replace the pressure line. See equipment manufacturer service information.

No Repair

Go to 8A

Go to 6A

Guided Step 5 - Check the aftertreatment 1 DEF dosing valve 1 system return.

Guided Step 5A - Check for a blocked aftertreatment 1 DEF dosing valve 1.

Conditions

  • Turn the keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the outlet of the dosing valve and the return line. Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn the keyswitch ON.

Action

Attempt to prime the DEF system.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostics Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure greater than 700 kPa [102 psi]?
YES NO
No Repair

Replace the DEF dosing valve 1. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 5B

Go to 8A

Guided Step 5B - Check the aftertreatment 1 DEF dosing valve 1 return line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 1 return line from the dosing valve.
  • Disconnect the aftertreatment 1 DEF dosing valve 1 return line from the DEF tank.

Action

Check the aftertreatment 1 DEF dosing valve 1 return line for blockage.

  • Visually check both ends of the line for signs of buildup or blockage.
  • Blow compressed shop air through the return line to make sure of free flow.

DEF return line blocked or restricted?
YES NO

Try to clean the return line using shop air. If necessary, replace the return line. See equipment manufacturer service information.

A blocked or restricted return has been detected in the DEF tank head. Clean or replace the tank head as necessary. See equipment manufacturer service information.

Go to 8A

Go to 8A

Guided Step 6 - Check the aftertreatment DEF suction line.

Guided Step 6A - Check for air in the DEF.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for air in the DEF.

  • Refer to Procedure 011-075 in the Associated Procedures Table.

Air in DEF detected?
YES NO

Check the following components for damage/leaks and repair as necessary:

  • Aftertreatment 1 DEF dosing unit 1 fittings
  • Aftertreatment 1 DEF dosing unit 1 supply line
  • Aftertreatment 1 DEF tank fittings
  • Aftertreatment 1 DEF tank filter.

Refer to Procedure 011-075 in the Associated Procedures Table.

 No Repair

Go to 8A

Go to 6B

Guided Step 6B - Check for an intermittent aftertreatment 1 DEF dosing unit 1 suction line leak.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.

Action

Attempt to prime the DEF system. Use INSITE™ electronic service tool to perform the Aftertreatment DEF System Leak Test, under ECM Diagnostics Tests.

As the DEF system is trying to prime, wiggle the suction line connections at the dosing unit 1 and tank. Monitor the DEF pressure sensor reading in INSITE™ electronic service tool data monitor/logger section.

  • Check if wiggling the suction line connections causes the system to either build pressure or lose prime.
  • Listen for audible indication from the pump that wiggling the suction line is causing air to enter the system.

Does wiggling DEF suction line connections affect system pressure?
YES NO

Replace the DEF suction line. See equipment manufacturer service information.

 No Repair

Go to 8A

Go to 6C

Guided Step 6C - Check the aftertreatment 1 DEF pressure.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.

Action

Attempt to prime the DEF system.

Use INSITE™ electronic service tool to perform the Aftertreatment DEF System Leak Test, under ECM Diagnostics Tests.

  • Monitor the DEF pressure sensor reading in INSITE™ electronic service tool data monitor/logger section.

DEF pressure greater than 750 kPa [109 psi]?
YES NO
No Repair

Replace the DEF dosing unit 1. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 7A

Go to 8A

Guided Step 7 - Check the aftertreatment DEF dosing valve 1 operation.

Guided Step 7A - Check the aftertreatment 1 DEF dosing system operation.

Conditions

  • Connect the DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove the aftertreatment 1 DEF dosing valve 1 from the decomposition chamber.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test, under ECM Diagnostics Tests.

  • Use the following procedure for instructions and specifications. Refer to Procedure 011-063 in the Associated Procedures Table.

The aftertreatment 1 DEF dosing valve 1 must be removed and placed in a measuring container having greater than a 1.5 liter [50 oz] capacity to run the Aftertreatment DEF Doser Pump Override Test.

Dosing volume within the specifications in Procedure 011-063 in the Associated Procedures Table?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7B

Guided Step 7B - Check the results of the doser override test.

Conditions

  • Turn the keyswitch OFF.

Action

Check the service pressure tool reading recorded during the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

DEF pressure at the service tool gauge reading above 700 kPa [102 psi] for duration of test?
YES NO

Replace the aftertreatment 1 DEF dosing valve 1. Refer to Procedure 011-059 in the Associated Procedures Table.

Replace the aftertreatment 1 DEF dosing unit 1. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 8A

Go to 8A

Guided Step 8 - Check ECM calibration and clear fault codes.

Guided Step 8A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 8B

Go to 8B

Guided Step 8B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process

Repair complete.

Last Modified: 03-May-2017


FAULT CODE 1683 - Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Electrical Connector Replacement | Refer to Procedure 019-559 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault code. | Fault Code 1683 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) tank heater control valve and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF tank heater control valve and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1684 active?
 | STEP 2C. Check the fault codes and verify the aftertreatment DEF tank heater control valve condition. | Fault Code 1683 active?
STEP 3. | Check the engine control module (ECM) and harness. |
 | STEP 3A. Inspect the original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3D. Inspect the ECM connector. | Dirty or damaged pins?
 | STEP 3E. Check for an open circuit. | Less than 10 ohms?
 | STEP 3F. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1683 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF tank heater control valve and circuit.

Guided Step 2A - Inspect the aftertreatment DEF tank heater control valve and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank heater control valve from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DEF tank heater control valve connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

Use the following procedure for DEF tank heater control valve connector repair or replacement. Refer to Procedure 019-559 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank heater control valve from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment DEF tank heater control valve SIGNAL pin and the aftertreatment DEF tank heater control valve RETURN pin at the aftertreatment DEF tank heater control valve OEM harness connector.
  • Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test under ECM Diagnostics Tests.
  • Command the aftertreatment DEF tank heater control valve ON with the Diesel Exhaust Fluid Tank Heater Override.
  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 1684 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the aftertreatment DEF tank heater control valve condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF tank heater control valve to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test under ECM Diagnostics Tests.
  • Command the aftertreatment DEF tank heater control valve ON using the Diesel Exhaust Fluid Tank Heater Override.
  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 1683 active?
YES NO

A malfunctioning aftertreatment DEF tank heater control valve has been detected.

Replace the aftertreatment DEF tank heater control valve. Refer to the OEM service manual.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the aftertreatment 1 connector.

Action

Inspect the OEM harness and aftertreatment 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment 1 connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from th aftertreatment 1 connector.
  • Disconnect the aftertreatment DEF tank heater control valve from the OEM harness.

Action

Check for an open supply circuit.

  • Measure the resistance between the aftertreatment DEF tank heater control valve SIGNAL pin at the tank heater control valve wiring harness connector and the aftertreament DEF tank heater control valve SIGNAL pin at the OEM harness aftertreatment 1 connector.
  • Measure the resistance between the aftertreatment DEF tank heater control valve RETURN pin at the tank heater control valve wiring harness connector and the aftertreatment DEF tank heater control valve RETURN pin at the OEM harness aftertreatment 1 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the aftertreatment 1 connector.
  • Disconnect the aftertreatment DEF tank heater control valve from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF tank heater control valve SIGNAL pin at the OEM harness aftertreatment 1 connector and all other pins in the connector.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness

Troubleshoot all harnesses connected in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Inspect the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the OEM and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace ECM only when there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3E

Guided Step 3E - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness aftertreatment 1 connector.

Action

Check for an open supply circuit.

  • Measure the resistance between the aftertreatment DEF tank heater control valve SIGNAL pin at the aftertreatment 1 connector and the aftertreament DEF tank heater control valve SIGNAL pin at the OEM harness ECM connector.
  • Measure the resistance between the aftertreatment DEF tank heater control valve RETURN pin at the aftertreatment 1 connector and the aftertreatment DEF tank heater control valve RETURN pin at the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF tank heater control valve SIGNAL pin at the OEM harness ECM connector and all other pins in the connector.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 1684 - Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Electrical Connector Replacement | Refer to Procedure 019-559 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the appropriate test lead for the connector. Reference the service tools listing or the appropriate wiring repair kit.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault code. | Fault Code 1684 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) tank heater control valve and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF tank heater control valve and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1683 active?
 | STEP 2C. Check the fault codes and verify the aftertreatment DEF tank heater control valve condition. | Fault Code 1684 active?
STEP 3. | Check the engine control module (ECM) and harness. |
 | STEP 3A. Inspect the original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ECM power supply ground. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3D. Inspect the ECM connector. | Dirty or damaged pins?
 | STEP 3E. Check for a short circuit to ECM power supply ground. | Greater than 100k ohms?
 | STEP 3F. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1684 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF tank heater control valve and circuit.

Guided Step 2A - Inspect the aftertreatment DEF tank heater control valve and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank heater control valve from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DEF tank heater control valve connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

Use the following procedure for DEF tank heater control valve connector repair or replacement. Refer to Procedure 019-559 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank heater control valve from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 1683 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the aftertreatment DEF tank heater control valve condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF tank heater control valve to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test under ECM Diagnostics Tests.
  • Command the aftertreatment DEF tank heater control valve ON using the DEF Tank Heater Override.
  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 1684 active?
YES NO

A malfunctioning aftertreatment DEF tank heater control valve has been detected.

Replace the aftertreatment DEF tank heater control valve. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the aftertreatment 1 connector.

Action

Inspect the OEM harness and aftertreatment 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment 1 connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ECM power supply ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from th aftertreatment 1 connector.
  • Disconnect the aftertreatment DEF tank heater control valve from the OEM harness.

Action

Check for a short circuit to ECM power supply ground.

  • Measure the resistance between the aftertreatment DEF tank heater control valve SIGNAL pin at the OEM harness aftertreatment 1 connector and ECM power supply ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Refer to Procedure 019-610 in the Associated Procedures Table.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ECM power supply ground has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the aftertreatment 1 connector.
  • Disconnect the aftertreatment DEF tank heater control valve from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF tank heater control valve SIGNAL pin at the OEM harness aftertreatment 1 connector and all other pins in the connector.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness

Troubleshoot all harnesses connected in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Inspect the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the OEM and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace ECM only when there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3E

Guided Step 3E - Check for a short circuit to ECM power supply ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness aftertreatment 1 connector.

Action

Check for a short circuit to ECM power supply ground.

  • Measure the resistance between the aftertreatment DEF tank heater control valve SIGNAL pin at the OEM connector and ECM power supply ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Refer to Procedure 019-610 in the Associated Procedures Table.

Less than 10 ohms?
YES NO
No Repair

An short circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF tank heater control valve SIGNAL pin at the OEM harness ECM connector and all other pins in the connector.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 31-Mar-2016


FAULT CODE 1685 - Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3868 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3868 active?
YES NO
No Repair

A circuit malfunction has been detected in the aftertreatment diesel exhaust fluid quality sensor.

Replace the aftertreatment diesel exhaust fluid quality sensor.

See equipment manufacturer service information.

Fault Code 3868 troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 23-Mar-2016


FAULT CODE 1686 - Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3868 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3868 active?
YES NO
No Repair

A circuit malfunction has been detected in the aftertreatment diesel exhaust fluid quality sensor.

Replace the aftertreatment diesel exhaust fluid quality sensor.

See equipment manufacturer service information.

Fault Code 3868 troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 31-Mar-2016


FAULT CODE 1695 (Source Address 00) - Sensor Supply 5 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1695 active?
STEP 2. | Check the ECM and harness. |
 | STEP 2A. Inspect the ECM and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit to ECM battery (+) in the harness. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for active or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM and harness.

Guided Step 2A - Inspect the ECM and original equipment manufacturer (OEM) harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the engine high temperature coolant level sensor from the OEM harness.
  • Disconnect the crankcase pressure 2 sensor from the engine harness

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the sensor SUPPLY 5 pin at the OEM harness ECM connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

Repair or replace the damaged section of the harness.

  • For the OEM harness. Refer to Procedure 019-071 in Section 19.
  • For the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 1695 (Source Address 144) - Sensor Supply 5 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1695 active?
STEP 2. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 2A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for active or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM and OEM harness.

Guided Step 2A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the engine low temperature coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the sensor supply 5 pin at the OEM harness ECM connector to all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

Repair or replace the damaged section of the harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 1696 (Source Address 00) - Sensor Supply 5 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1696 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply return. |
 | STEP 2A. Inspect the high temperature coolant level sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the crankcase pressure 2 sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
STEP 3. | Check the ECM and harness. |
 | STEP 3A. Inspect the ECM and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ECM power supply ground short circuit in the harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply return.

Guided Step 2A - Inspect the high temperature coolant level sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the high temperature coolant level sensor from the OEM harness.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the high temperature coolant level sensor from the OEM harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO

Replace the high temperature coolant level sensor.

Refer to Procedure 019-017 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 2B - Inspect the crankcase pressure 2 sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure 2 sensor from the engine harness.

Action

Inspect the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure 2 sensor from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO

Replace the crankcase pressure 2 sensor.

Refer to Procedure 019-445 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect the ECM and original equipment manufacturer (OEM) harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the high temperature coolant level sensor from the OEM harness.
  • Disconnect the crankcase pressure 2 sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the sensor supply 5 pin in the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

Repair or replace the damaged section of the harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.
  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 3C

Guided Step 3C - Check for a pin-to-ECM power supply ground short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the high temperature coolant level sensor from the OEM harness.
  • Disconnect the crankcase pressure 2 sensor from the OEM harness.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance and check for a short circuit between the sensor supply 5 pin in the OEM harness ECM connector and ECM power supply ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit has been detected.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

Repair or replace the damaged section of the harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.
  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 1696 (Source Address 144) - Sensor Supply 5 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1696 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply return. |
 | STEP 2A. Inspect the low temperature coolant level sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ECM power supply ground short circuit in the harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply return.

Guided Step 2A - Inspect the low temperature coolant level sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the low temperature coolant level sensor from the OEM harness.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the low temperature coolant level sensor from the OEM harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO

Replace the low temperature coolant level sensor.

Refer to Procedure 019-017 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the low temperature coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the sensor supply 5 pin in the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

Repair or replace the damaged section of the harness.

  • For the OEM harness. Refer to Procedure 019-071 in Section 19.
  • For the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ECM power supply ground short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the low temperature coolant level sensor from the OEM harness.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance and check for a short circuit between the sensor supply 5 pin in the OEM harness ECM connector and ECM power supply ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit has been detected.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

Repair or replace the damaged section of the harness.

  • For the OEM harness. Refer to Procedure 019-071 in Section 19.
  • For the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 1712 - Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1677, 1678, 1679, 1683, or 1684 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) tank heating system. |
 | STEP 2A. Inspect the DEF tank heater coolant lines. | Leaks or damage found in tank heater coolant plumbing?
STEP 3. | Check the aftertreatment DEF tank heater operation. |
 | STEP 3A. Verify proper operation of the aftertreatment DEF tank heater control valve. | DEF tank heater control valve operating correctly?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for DEF tank heater or DEF tank temperature sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677, 1678, 1679, 1683, or 1684 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment DEF tank heating system.

Guided Step 2A - Inspect the DEF tank heater coolant lines.

Conditions

  • Turn keyswitch OFF.
  • Verify that the engine coolant level is within normal operating range.

Action

Inspect the aftertreatment DEF tank heater coolant lines and connectors for the following:

  • Leaking or damaged coolant lines
  • Kinked, restricted, or blocked coolant lines (including the original equipment manufacturer (OEM) in-line shutoff valve, if equipped)
  • Loose connections
  • Leaking seals or gaskets.

See equipment manufacturer service information for details on coolant line routing and flow.

Leaks or damage found in tank heater coolant plumbing?
YES NO

Repair or replace the leaking or damaged coolant lines, fittings, or seals.

Verify that the engine coolant level is within normal operating range before returning to service. Add coolant as necessary.

See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the aftertreatment DEF tank heater operation.

Guided Step 3A - Verify proper operation of the aftertreatment DEF tank heater control valve.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the “DEF Doser System Heater Test” under the “ECM Diagnostic Tests” menu.

  • Make sure the tank heater control valve is operating correctly, not stuck closed or slow to respond, and able to fully open.
  • See equipment manufacturer service information for details on the tank heater control valve.

DEF tank heater control valve operating correctly?
YES NO
No Repair

Repair or replace the DEF tank heater control valve.

See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 31-Mar-2016


FAULT CODE 1713 - Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM) all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1713 active?
 | STEP 1B. Read the fault codes. | Fault Code 1677, 1678, 1683, or 1684 active or high inactive counts?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) tank temperature sensor. |
 | STEP 2A. Check the aftertreatment DEF tank temperature sensor. | INSITE™ electronic service tool reading within 10°C or 18°F of infared thermometer reading?
STEP 3. | Check the aftertreatment DEF tank heater operation. |
 | STEP 3A. Verify that the aftertreatment DEF tank heater control valve is installed correctly. | DEF tank heater control valve installed correctly?
 | STEP 3B. Verify proper operation of the aftertreatment DEF tank heater control valve. | DEF tank heater control valve operating correctly?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for DEF tank heater or DEF tank temperature sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1713 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for DEF tank heater or DEF tank temperature sensor fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677, 1678, 1683, or 1684 active or high inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment DEF tank temperature sensor.

Guided Step 2A - Check the aftertreatment DEF tank temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Measure the temperature of the DEF in the DEF tank with an infrared thermometer.

  • Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for the aftertreatment DEF tank temperature sensor to the infrared thermometer.

INSITE™ electronic service tool reading within 10°C [18°F] of infrared thermometer reading?
YES NO
No Repair

Replace the DEF tank temperature sensor.

  • See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF tank heater operation.

Guided Step 3A - Verify that the aftertreatment DEF tank heater control valve is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the installation of the tank heater control valve.

  • Make sure that the tank heater control valve is installed correctly, and not reversed.

See equipment manufacturer service information for details on the tank heater control valve.

DEF tank heater control valve installed correctly?
YES NO
No Repair

Remove the DEF tank heater control valve, and install it in the correct position. Make sure the valve is not reversed according to the coolant flow direction, where applicable.

See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Verify proper operation of the aftertreatment DEF tank heater control valve.

Conditions

  • Turn keyswitch ON.
  • Start and idle the engine.
  • Connect INSITE™ electronic service tool.

Action

Verify the proper operation of the aftertreatment DEF tank heater control valve.

  • Use INSITE™ electronic service tool to perform the “Diesel Exhaust Fluid Doser System Heater Test” under the “ECM Diagnostic Tests” menu.
  • Use the Diesel Exhaust Fluid Tank Heater option in the test menu to override the tank heater control valve to ON.
  • Make sure the tank heater control valve is operating correctly, not stuck closed or slow to respond, and able to fully open.
  • Make sure the tank heater control valve is installed correctly, and not reversed.

See equipment manufacturer service information. for details on the tank heater control valve.

Note: The Diesel Exhaust Fluid Doser System Heater Test allows the technician to override the tank heater control valve to on. It does not test if the tank heater control valve is operating correctly. With the tank heater control valve commanded on, a temperature rise may be felt on the coolant hose to the DEF tank.

DEF tank heater control valve operating correctly?
YES NO
No Repair

Repair or replace the DEF tank heater control valve.

See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 31-Mar-2016


FAULT CODE 1714 - Aftertreatment Diesel Exhaust Fluid Quality - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes | Fault Code 3868 or 1714 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3868 active?
YES NO

A malfunctioning aftertreatment diesel exhaust fluid quality sensor has been detected.

Replace the aftertreatment diesel exhaust fluid quality sensor.

See equipment manufacturer service information.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 06-Apr-2016


FAULT CODE 1715 - Aftertreatment Diesel Exhaust Fluid Quality - Root Cause Not Known

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3868 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3868 active?
YES NO
No Repair

An internal malfunction has been detected in the aftertreatment diesel exhaust fluid (DEF) quality sensor.

Replace the aftertreatment DEF quality sensor. See equipment manufacturer service information.

Fault Code 3868 troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 01-Apr-2016


FAULT CODE 1774 - Engine Oil Priming Pump Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1774 active?
STEP 2. | Check the original equipment manufacturer (OEM) switch and circuit. |
 | STEP 2A. Inspect the OEM switch and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the OEM switch resistance. | Less than 10 ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1774 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent or inactive fault code troubleshooting. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the OEM switch and circuit.

Guided Step 2A - Inspect the OEM switch and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM switch from the OEM harness.

Action

Inspect the OEM harness and switch connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the switch or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the OEM switch resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM switch from the OEM harness.
  • Remove the OEM switch from the oil passage.

Action

Check the switch resistance.

  • Measure the resistance of the OEM switch.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

An open or short circuit has been detected in the OEM switch circuit. The OEM can configure the OEM switch SIGNAL circuit to be switched to ground or voltage source. See equipment manufacturer service information on the engine’s configuration.

Replace the OEM switch. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to clear the fault codes. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 25-Mar-2016


FAULT CODE 1775 - Engine Oil Priming Pump Control Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1775 active?
STEP 2. | Check the relay and circuit. |
 | STEP 2A. Inspect the relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the relay for an open circuit. | Greater than 100k ohms?
 | STEP 2C. Check for an open circuit in the relay return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1775 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1775 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent or inactive fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the relay and circuit.

Guided Step 2A - Inspect the relay and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the relay from the original equipment manufacturer (OEM) harness.

Action

Inspect the OEM harness and relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the relay or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the relay for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the relay from the OEM harness.

Action

Check the relay resistance.

  • Measure the resistance between the relay SIGNAL pin and the relay RETURN pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the relay. See equipment manufacturer service information.

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit in the relay return circuit.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the relay from the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the relay RETURN pin at the relay connector to ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected. Refer to the OEM wiring diagram for RETURN wire configuration.

If the return is wired to the ECM, repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the damaged connection.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Energize keyswitch circuit.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Energize keyswitch circuit.
  • Disconnect the OEM harness from the ECM connector. Disconnect the relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector relay RETURN pin and the OEM harness relay connector RETURN pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Go to 3C

Less than 10 ohms?

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the relay from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the relay SIGNAL pin in the OEM ECM connector and all other pins in the OEM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the output device driver SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1775 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 25-Mar-2016


FAULT CODE 1843 - Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check for active fault code. | Fault Code 1843 active?
STEP 2. | Check the crankcase pressure sensor and circuit |
 | STEP 2A. Inspect the crankcase pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1844 active and Fault Code 1843 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1843 active?
STEP 3. | Check the ECM and engine harness |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Go to 1B

Reference Fault Code 386

Guided Step 1B - Check for active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the crankcase pressure sensor and circuit.

Guided Step 2A - Inspect the crankcase pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor connector from the engine harness.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor connector from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active and Fault Code 1843 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor connector from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure 5 volt SUPPLY (sensor supply 1) pin to the crankcase pressure RETURN (sensor return 1) pin at the crankcase pressure sensor connector of the engine harness.

Use the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the crankcase pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 active?
YES NO

A damaged sensor has been detected. Replace the crankcase pressure sensor.

  • Refer to Procedure 019-445 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage
  • Damaged locking tab connector

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active and Fault Code 1843 inactive?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 active?
YES NO

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage
  • Damaged locking tab connector

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure 5 volt SUPPLY (sensor supply 1) pin to the crankcase pressure RETURN (sensor supply 1) pin at the ECM engine connector.

Use the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 active?
YES NO

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear fault code.

  • Operate the engine within the ”Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 25-Mar-2016


FAULT CODE 1844 - Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
 | STEP 1B. Check for active fault code. | Fault Code 1844 active?
STEP 2. | Check the crankcase pressure sensor and circuit. |
 | STEP 2A. Inspect the crankcase pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1843 active and Fault Code 1844 inactive?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 1844 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to Fault Code 352

Guided Step 1B - Check for active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 1844 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the crankcase pressure sensor and circuit.

Guided Step 2A - Inspect the crankcase pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure sensor SUPPLY pin to the crankcase pressure sensor RETURN pin at the sensor connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the crankcase pressure sensor SUPPLY pin and the crankcase pressure sensor SIGNAL pin at the crankcase pressure sensor connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 active and Fault Code 1844 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the crankcase pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active?
YES NO

None. The removal and installation of the connector corrected the fault.

A damaged sensor has been detected.

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure sensor SUPPLY pin to the crankcase pressure sensor RETURN pin at the engine harness ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active?
YES NO

An open or shorted circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the crankcase pressure sensor SUPPLY pin and the crankcase pressure sensor SIGNAL pin at the engine harness ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 active and Fault Code 1844 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active?
YES NO

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Datapate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 25-Mar-2016


FAULT CODE 1845 - Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Water In Fuel Sensor | Refer to Procedure 019-127 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1845 active?
STEP 2. | Check the water in fuel sensor and circuit. |
 | STEP 2A. Inspect the water in fuel sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1846 active and Fault Code 1845 inactive?
 | STEP 2C. Check the fault codes and verify water in fuel sensor condition. | Fault Code 1845 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and equipment manufacturer service information (OEM) engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for active fault code. | Fault Code 1845 active?
STEP 4. | ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1845 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the water in fuel sensor and circuit.

Guided Step 2A - Inspect the engine harness and the water in fuel sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor connector from the engine harness connector.

Action

Inspect the engine harness and water in fuel sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the water in fuel sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor from the engine harness.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the water in fuel SIGNAL pin and the water in fuel RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1846 active and Fault Code 1845 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the water in fuel sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1845 active?
YES NO

None. The removal and installation of the connector corrected the fault.

A damaged water in fuel sensor has been detected.

Replace the water in fuel sensor. Refer to Procedure 019-127 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and equipment manufacturer service information (OEM) engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the water in fuel sensor connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector water in fuel sensor RETURN pin and the engine harness water in fuel sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the water in fuel sensor connector from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the sensor harness ECM connector water in fuel indicator SIGNAL pin and the engine harness water in fuel sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM engine harness connector from the ECM.
  • Disconnect the water in fuel indicator sensor connector from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the water in fuel sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the short circuit.

  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1845 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table. The cause of the malfunction should have been detected.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 1846 - Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Water In Fuel Sensor | Refer to Procedure 019-127 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the engine control module.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1846 active?
STEP 2. | Check the water in fuel sensor and circuit. |
 | STEP 2A. Inspect the water in fuel sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1845 active and Fault Code 1846 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1846 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) engine harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ECM power supply ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for active fault code. | Fault Code 1846 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1846 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent or inactive fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the water in fuel sensor and circuit.

Guided Step 2A - Inspect the water in fuel sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor from the engine harness.

Action

Inspect the engine harness, and water in fuel sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 1845 active and Fault Code 1846 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the water in fuel sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1846 active?
YES NO

A damaged water in fuel sensor has been detected.

Replace the water in fuel sensor.

Refer to Procedure 019-127 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM engine harness.

Guided Step 3A - Inspect the ECM and OEM engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the water in fuel sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the water in fuel SIGNAL pin in the connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the short circuit.

Use the circuit diagram or wiring diagram for all harness interconnections.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ECM power supply ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the water in fuel sensor from the engine harness.

Action

Check for a pin-to-ECM power supply ground short.

  • Measure the resistance between the water in fuel sensor SIGNAL pin in the OEM harness ECM connector and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the short circuit.

Use the circuit diagram or wiring diagram for all harness interconnections.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1846 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Repair complete.

Go to 1A

Last Modified: 20-May-2016


FAULT CODE 1847 - Engine Coolant Temperature - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor coolant temperature reading. |
 | STEP 1A. Monitor coolant temperature reading. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical guage?
STEP 2. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Monitor coolant temperature reading.

Guided Step 1A - Monitor coolant temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the coolant temperature reading.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical guage or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical guage?
YES NO

Use the following troubleshooting symptom tree, Engine Coolant Temperature Above Normal, in Section TS of the appropriate service manual.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to fin the present ECM code and revision number in the ECM. The ECM code and revision numbers are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found the the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Last Modified: 25-Mar-2016


FAULT CODE 1852 - Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 1852?
STEP 2. | Check the engine control module (ECM) calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 1852.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1852?
YES NO

Drain water from the fuel filter(s).

If the fault code persists, check the sensor and harness connector for water intrusion. Clean or replace the connector or sensor, as necessary.

No Repair

Go to 2A

Repair complete

Guided Step 2 - Check the engine control module (ECM) calibration and clear the fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 1885 - Aftertreatment 1 Intake NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3232 or 3682 active?
 | STEP 1B. Check for active and inactive fault codes. | Fault Code 1885 active or inactive with more than one count?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3232 or 3682 is active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for active and inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1885 active or inactive with more than one count?
YES NO

An internal error has been detected in the aftertreatment intake nitrogen oxides (NOx) sensor.

Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 01-Apr-2016


FAULT CODE 1887 - Aftertreatment 1 Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active outlet nitrogen oxides (NOx) fault codes. | Fault Code 2771 or 3681 is active?
 | STEP 1B. Check for active fault codes. | Fault Code 1887 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active outlet NOx fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2771 or 3681 active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1887 active?
YES NO

An internal error has been detected in the aftertreatment outlet NOx sensor.

Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 01-Apr-2016


FAULT CODE 1984 - Intake Manifold 2 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor the intake manifold air temperature reading. |
 | STEP 1A. Monitor the intake manifold air temperature reading. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Monitor the intake manifold air temperature reading.

Guided Step 1A - Monitor the intake manifold air temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor intake manifold temperature reading.

  • Use INSITE™ electronic service tool to monitor the intake manifold air temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical guage or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

See the Intake Manifold Air Temperature Above Specification troubleshooting symptom tree in Section TS of the appropriate service manual.

Replace the intake manifold 2 temperature sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

Appropriate troubleshooting symptom tree

Go to 2A

Guided Step 2 - Check the ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronics service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronics service tool.

Action

Disable and clear fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 25-Mar-2016


FAULT CODE 2121 - Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K113 | 4388663
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K113 | 4388663
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K113 | 4388663
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K113 | 4388663
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K113 | 4388663
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K113 | 4388663
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K113 | 4388663
Turbocharger Turbine Outlet Bellows | Refer to Procedure 011-116 | QSK95 CM2350 K113 | 4388663
Engine Compression | Refer to Procedure 014-012 | QSK95 CM2350 K113 | 4388663
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for high intake manifold temperature fault codes. | Fault code 155 or 488 active or inactive counts?
 | STEP 1B. Check for engine speed fault codes. | Fault Code 731 active?
 | STEP 1C. Check for multiple fault codes. | Exhaust gas temperature high fault codes for 2122, 2123, 2124, 2125, 2126, 2127, 2128, 2131, 2132, 2133, 2134, 2135, 2136, 2137, 2138, or 2144 also active or inactive counts?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature cylinder 1 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
STEP 3. | Check the air handling system. |
 | STEP 3A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table?
 | STEP 3B. Check air intake restriction. | Air intake restriction within specifications found in Procedure 010-031 in the Associated Procedures Table?
 | STEP 3C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 3D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 4. | Check the power cylinder. |
 | STEP 4A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 4B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for high intake manifold temperature fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 155 or 488 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for engine speed fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for 2122, 2123, 2124, 2125, 2126, 2127, 2128, 2131, 2132, 2133, 2134, 2135, 2136, 2137, 2138, or 2144 also active or inactive counts?

YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace ECM only when there are damaged pins. Refer to Procedure 019-031 in Section 19 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor connector from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 5A

Guided Step 2C - Verify the exhaust gas temperature cylinder 1 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 1 sensor accuracy using and infrared thermometer.

  • Start the engine.
  • Connect INSITE electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 1 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature cylinder 1 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the air handling system.

Guided Step 3A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES NO
No Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 3B

Go to 5A

Guided Step 3B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications found in Procedure 010-031 in the Associated Procedures Table?
YES NO
No Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 3C

Go to 5A

Guided Step 3C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the folowing:

  • Bent, damaged, or missing fins.

Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3D

Guided Step 3D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Replace any malfunctioning seals or damaged components. See the appropriate procedures in Sections 10 and 11 in the appropriate service manual.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the power cylinder.

Guided Step 4A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 1 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 1 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch OFF.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-116 in the Associated Procedures Table.

Action

Perform the Cylinder Compression Test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders.

  • Once the cylinder is pressurized, listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Remove the cylinder head and inspect the exhaust valves and seat for damage. Replace any damaged components.

Refer to Procedure 002-004 in the Associated Procedures Table.

Replace the cylinder 1 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

No Repair

Go to 1A

Repair complete

Last Modified: 29-Mar-2017


FAULT CODE 2122 - Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K113 | 4388663
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K113 | 4388663
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K113 | 4388663
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K113 | 4388663
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K113 | 4388663
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K113 | 4388663
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K113 | 4388663
Turbocharger Turbine Outlet Bellows | Refer to Procedure 011-116 | QSK95 CM2350 K113 | 4388663
Engine Compression | Refer to Procedure 014-012 | QSK95 CM2350 K113 | 4388663
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for high intake manifold temperature fault codes. | Fault code 155 or 488 active or inactive counts?
 | STEP 1B. Check for engine speed fault codes. | Fault Code 731 active?
 | STEP 1C. Check for multiple fault codes. | Exhaust gas temperature high fault codes for 2121, 2123, 2124, 2125, 2126, 2127, 2128, 2131, 2132, 2133, 2134, 2135, 2136, 2137, 2138, or 2144 also active or inactive counts?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature cylinder 3 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
STEP 3. | Check the air handling system. |
 | STEP 3A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table?
 | STEP 3B. Check air intake restriction. | Air intake restriction within specifications found in Procedure 010-031 in the Associated Procedures Table?
 | STEP 3C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 3D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 4. | Check the power cylinder. |
 | STEP 4A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 4B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for high intake manifold temperature fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 155 or 488 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for engine speed fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for 2121, 2123, 2124, 2125, 2126, 2127, 2128, 2131, 2132, 2133, 2134, 2135, 2136, 2137, 2138, or 2144 also active or inactive counts?

YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace ECM only when there are damaged pins. Refer to Procedure 019-031 in Section 19 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor connector from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 5A

Guided Step 2C - Verify the exhaust gas temperature cylinder 3 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 3 sensor accuracy using and infrared thermometer.

  • Start the engine.
  • Connect INSITE electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 3 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature cylinder 3 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the air handling system.

Guided Step 3A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES NO
No Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 3B

Go to 5A

Guided Step 3B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications found in Procedure 010-031 in the Associated Procedures Table?
YES NO
No Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 3C

Go to 5A

Guided Step 3C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the folowing:

  • Bent, damaged, or missing fins.

Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3D

Guided Step 3D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Replace any malfunctioning seals or damaged components. See the appropriate procedures in Sections 10 and 11 in the appropriate service manual.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the power cylinder.

Guided Step 4A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 1 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 3 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch OFF.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-116 in the Associated Procedures Table.

Action

Perform the Cylinder Compression Test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders.

  • Once the cylinder is pressurized, listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Remove the cylinder head and inspect the exhaust valves and seat for damage. Replace any damaged components.

Refer to Procedure 002-004 in the Associated Procedures Table.

Replace the cylinder 1 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

No Repair

Go to 1A

Repair complete

Last Modified: 29-Mar-2017


FAULT CODE 2123 - Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K113 | 4388663
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K113 | 4388663
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K113 | 4388663
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K113 | 4388663
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K113 | 4388663
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K113 | 4388663
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K113 | 4388663
Turbocharger Turbine Outlet Bellows | Refer to Procedure 011-116 | QSK95 CM2350 K113 | 4388663
Engine Compression | Refer to Procedure 014-012 | QSK95 CM2350 K113 | 4388663
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for high intake manifold temperature fault codes. | Fault code 155 or 488 active or inactive counts?
 | STEP 1B. Check for engine speed fault codes. | Fault Code 731 active?
 | STEP 1C. Check for multiple fault codes. | Exhaust gas temperature high fault codes for other cylinders 2121, 2122, 2124, 2125, 2126, 2127, 2128, 2131, 2132, 2133, 2134, 2135, 2136, 2137, 2138, or 2144 also active or inactive counts?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature cylinder 5 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
STEP 3. | Check the air handling system. |
 | STEP 3A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table?
 | STEP 3B. Check air intake restriction. | Air intake restriction within specifications found in Procedure 010-031 in the Associated Procedures Table?
 | STEP 3C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 3D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 4. | Check the power cylinder. |
 | STEP 4A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 4B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for high intake manifold temperature fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 155 or 488 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for engine speed fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders 2121, 2122, 2124, 2125, 2126, 2127, 2128, 2131, 2132, 2133, 2134, 2135, 2136, 2137, 2138, or 2144 also active or inactive counts?

YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace ECM only when there are damaged pins. Refer to Procedure 019-031 in Section 19 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor connector from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 5A

Guided Step 2C - Verify the exhaust gas temperature cylinder 5 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 5 sensor accuracy using and infrared thermometer.

  • Start the engine.
  • Connect INSITE electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 5 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature cylinder 5 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the air handling system.

Guided Step 3A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES NO
No Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 3B

Go to 5A

Guided Step 3B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications found in Procedure 010-031 in the Associated Procedures Table?
YES NO
No Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 3C

Go to 5A

Guided Step 3C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the folowing:

  • Bent, damaged, or missing fins.

Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3D

Guided Step 3D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Replace any malfunctioning seals or damaged components. See the appropriate procedures in Sections 10 and 11 in the appropriate service manual.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the power cylinder.

Guided Step 4A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 1 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 1 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch OFF.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-116 in the Associated Procedures Table.

Action

Perform the Cylinder Compression Test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders.

  • Once the cylinder is pressurized, listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Remove the cylinder head and inspect the exhaust valves and seat for damage. Replace any damaged components.

Refer to Procedure 002-004 in the Associated Procedures Table.

Replace the cylinder 1 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

No Repair

Go to 1A

Repair complete

Last Modified: 29-Mar-2017


FAULT CODE 2124 - Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K113 | 4388663
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K113 | 4388663
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K113 | 4388663
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K113 | 4388663
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K113 | 4388663
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K113 | 4388663
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K113 | 4388663
Turbocharger Turbine Outlet Bellows | Refer to Procedure 011-116 | QSK95 CM2350 K113 | 4388663
Engine Compression | Refer to Procedure 014-012 | QSK95 CM2350 K113 | 4388663
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for high intake manifold temperature fault codes. | Fault code 155 or 488 active or inactive counts?
 | STEP 1B. Check for engine speed fault codes. | Fault Code 731 active?
 | STEP 1C. Check for multiple fault codes. | Exhaust gas temperature high fault codes for other cylinders 2121, 2122, 2123, 2125, 2126, 2127, 2128, 2131, 2132, 2133, 2134, 2135, 2136, 2137, 2138, or 2144 also active or inactive counts?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature cylinder 7 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
STEP 3. | Check the air handling system. |
 | STEP 3A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table?
 | STEP 3B. Check air intake restriction. | Air intake restriction within specifications found in Procedure 010-031 in the Associated Procedures Table?
 | STEP 3C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 3D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 4. | Check the power cylinder. |
 | STEP 4A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 4B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for high intake manifold temperature fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 155 or 488 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for engine speed fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders 2121, 2122, 2123, , 2125, 2126, 2127, 2128, 2131, 2132, 2133, 2134, 2135, 2136, 2137, 2138, or 2144 also active or inactive counts?

YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace ECM only when there are damaged pins. Refer to Procedure 019-031 in Section 19 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor connector from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 5A

Guided Step 2C - Verify the exhaust gas temperature cylinder 7 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 7 sensor accuracy using and infrared thermometer.

  • Start the engine.
  • Connect INSITE electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 7 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature cylinder 7 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the air handling system.

Guided Step 3A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES NO
No Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 3B

Go to 5A

Guided Step 3B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications found in Procedure 010-031 in the Associated Procedures Table?
YES NO
No Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 3C

Go to 5A

Guided Step 3C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the folowing:

  • Bent, damaged, or missing fins.

Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3D

Guided Step 3D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Replace any malfunctioning seals or damaged components. See the appropriate procedures in Sections 10 and 11 in the appropriate service manual.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the power cylinder.

Guided Step 4A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 1 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 1 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch OFF.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-116 in the Associated Procedures Table.

Action

Perform the Cylinder Compression Test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders.

  • Once the cylinder is pressurized, listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Remove the cylinder head and inspect the exhaust valves and seat for damage. Replace any damaged components.

Refer to Procedure 002-004 in the Associated Procedures Table.

Replace the cylinder 1 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

No Repair

Go to 1A

Repair complete

Last Modified: 29-Mar-2017


FAULT CODE 2125 - Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K113 | 4388663
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K113 | 4388663
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K113 | 4388663
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K113 | 4388663
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K113 | 4388663
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K113 | 4388663
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K113 | 4388663
Turbocharger Turbine Outlet Bellows | Refer to Procedure 011-116 | QSK95 CM2350 K113 | 4388663
Engine Compression | Refer to Procedure 014-012 | QSK95 CM2350 K113 | 4388663
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for high intake manifold temperature fault codes. | Fault code 155 or 488 active or inactive counts?
 | STEP 1B. Check for engine speed fault codes. | Fault Code 731 active?
 | STEP 1C. Check for multiple fault codes. | Exhaust gas temperature high fault codes for other cylinders 2121, 2122, 2123, 2124, 2126, 2127, 2128, 2131, 2132, 2133, 2134, 2135, 2136, 2137, 2138, or 2144 also active or inactive counts?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature cylinder 9 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
STEP 3. | Check the air handling system. |
 | STEP 3A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table?
 | STEP 3B. Check air intake restriction. | Air intake restriction within specifications found in Procedure 010-031 in the Associated Procedures Table?
 | STEP 3C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 3D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 4. | Check the power cylinder. |
 | STEP 4A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 4B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for high intake manifold temperature fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 155 or 488 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for engine speed fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders 2121, 2122, 2123, 2124, 2126, 2127, 2128, 2131, 2132, 2133, 2134, 2135, 2136, 2137, 2138, or 2144 also active or inactive counts?

YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace ECM only when there are damaged pins. Refer to Procedure 019-031 in Section 19 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor connector from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 5A

Guided Step 2C - Verify the exhaust gas temperature cylinder 9 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 9 sensor accuracy using and infrared thermometer.

  • Start the engine.
  • Connect INSITE electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 9 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature cylinder 9 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the air handling system.

Guided Step 3A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES NO
No Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 3B

Go to 5A

Guided Step 3B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications found in Procedure 010-031 in the Associated Procedures Table?
YES NO
No Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 3C

Go to 5A

Guided Step 3C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the folowing:

  • Bent, damaged, or missing fins.

Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3D

Guided Step 3D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Replace any malfunctioning seals or damaged components. See the appropriate procedures in Sections 10 and 11 in the appropriate service manual.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the power cylinder.

Guided Step 4A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 1 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 1 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch OFF.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-116 in the Associated Procedures Table.

Action

Perform the Cylinder Compression Test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders.

  • Once the cylinder is pressurized, listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Remove the cylinder head and inspect the exhaust valves and seat for damage. Replace any damaged components.

Refer to Procedure 002-004 in the Associated Procedures Table.

Replace the cylinder 1 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

No Repair

Go to 1A

Repair complete

Last Modified: 29-Mar-2017


FAULT CODE 2126 - Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K113 | 4388663
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K113 | 4388663
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K113 | 4388663
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K113 | 4388663
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K113 | 4388663
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K113 | 4388663
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K113 | 4388663
Turbocharger Turbine Outlet Bellows | Refer to Procedure 011-116 | QSK95 CM2350 K113 | 4388663
Engine Compression | Refer to Procedure 014-012 | QSK95 CM2350 K113 | 4388663
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for high intake manifold temperature fault codes. | Fault code 155 or 488 active or inactive counts?
 | STEP 1B. Check for engine speed fault codes. | Fault Code 731 active?
 | STEP 1C. Check for multiple fault codes. | Exhaust gas temperature high fault codes for other cylinders 2121, 2122, 2123, 2124, 2125, 2127, 2128, 2131, 2132, 2133, 2134, 2135, 2136, 2137, 2138, or 2144 also active or inactive counts?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the ECM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature cylinder 11 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
STEP 3. | Check the air handling system. |
 | STEP 3A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table?
 | STEP 3B. Check air intake restriction. | Air intake restriction within specifications found in Procedure 010-031 in the Associated Procedures Table?
 | STEP 3C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 3D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 4. | Check the power cylinder. |
 | STEP 4A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 4B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for high intake manifold temperature fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 155 or 488 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for engine speed fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders 2121, 2122, 2123, 2124, 2125, 2127, 2128, 2131, 2132, 2133, 2134, 2135, 2136, 2137, 2138, or 2144 also active or inactive counts?

YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace ECM only when there are damaged pins. Refer to Procedure 019-031 in Section 19 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor connector from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 5A

Guided Step 2C - Verify the exhaust gas temperature cylinder 11 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 11 sensor accuracy using and infrared thermometer.

  • Start the engine.
  • Connect INSITE electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 11 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature cylinder 11 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the air handling system.

Guided Step 3A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES NO
No Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 3B

Go to 5A

Guided Step 3B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications found in Procedure 010-031 in the Associated Procedures Table?
YES NO
No Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 3C

Go to 5A

Guided Step 3C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the folowing:

  • Bent, damaged, or missing fins.

Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3D

Guided Step 3D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Replace any malfunctioning seals or damaged components. See the appropriate procedures in Sections 10 and 11 in the appropriate service manual.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the power cylinder.

Guided Step 4A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 1 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 1 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch OFF.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-116 in the Associated Procedures Table.

Action

Perform the Cylinder Compression Test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders.

  • Once the cylinder is pressurized, listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Remove the cylinder head and inspect the exhaust valves and seat for damage. Replace any damaged components.

Refer to Procedure 002-004 in the Associated Procedures Table.

Replace the cylinder 1 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

No Repair

Go to 1A

Repair complete

Last Modified: 29-Mar-2017


FAULT CODE 2127 - Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K113 | 4388663
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K113 | 4388663
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K113 | 4388663
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K113 | 4388663
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K113 | 4388663
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K113 | 4388663
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K113 | 4388663
Turbocharger Turbine Outlet Bellows | Refer to Procedure 011-116 | QSK95 CM2350 K113 | 4388663
Engine Compression | Refer to Procedure 014-012 | QSK95 CM2350 K113 | 4388663
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for high intake manifold temperature fault codes. | Fault Code 155 or 488 active or inactive counts?
 | STEP 1B. Check for engine speed fault codes. | Fault Code 731 active?
 | STEP 1C. Check for multiple fault codes. | Exhaust gas temperature high fault codes for other cylinders 2121, 2122, 2123, 2124, 2125, 2126, 2128, 2131, 2132, 2133, 2134, 2135, 2136, 2137, 2138, or 2144 also active or inactive counts?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature cylinder 13 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
STEP 3. | Check the air handling system. |
 | STEP 3A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table?
 | STEP 3B. Check air intake restriction. | Air intake restriction within specifications found in Procedure 010-031 in the Associated Procedures Table?
 | STEP 3C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 3D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 4. | Check the power cylinder. |
 | STEP 4A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 4B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for high intake manifold temperature fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 155 or 488 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for engine speed fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders 2121, 2122, 2123, 2124, 2125, 2126, 2128, 2131, 2132, 2133, 2134, 2135, 2136, 2137, 2138, or 2144 also active or inactive counts?

YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace ECM only when there are damaged pins. Refer to Procedure 019-031 in Section 19 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor connector from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 5A

Guided Step 2C - Verify the exhaust gas temperature cylinder 13 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 13 sensor accuracy using and infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 13 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature cylinder 13 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the air handling system.

Guided Step 3A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table?
YES NO
No Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 3B

Go to 5A

Guided Step 3B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications found in Procedure 010-031 in the Associated Procedures Table?
YES NO
No Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 3C

Go to 5A

Guided Step 3C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the folowing:

  • Bent, damaged, or missing fins.

Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3D

Guided Step 3D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Replace any malfunctioning seals or damaged components. See the appropriate procedures in Sections 10 and 11 in the appropriate service manual.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the power cylinder.

Guided Step 4A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 1 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 1 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch OFF.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-116 in the Associated Procedures Table.

Action

Perform the Cylinder Compression Test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders.

  • Once the cylinder is pressurized, listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Remove the cylinder head and inspect the exhaust valves and seat for damage. Replace any damaged components.

Refer to Procedure 002-004 in the Associated Procedures Table.

Replace the cylinder 1 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

No Repair

Go to 1A

Repair complete

Last Modified: 29-Mar-2017


FAULT CODE 2128 - Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K113 | 4388663
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K113 | 4388663
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K113 | 4388663
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K113 | 4388663
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K113 | 4388663
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K113 | 4388663
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K113 | 4388663
Turbocharger Turbine Outlet Bellows | Refer to Procedure 011-116 | QSK95 CM2350 K113 | 4388663
Engine Compression | Refer to Procedure 014-012 | QSK95 CM2350 K113 | 4388663
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for high intake manifold temperature fault codes. | Fault Code 155 or 488 active or inactive counts?
 | STEP 1B. Check for engine speed fault codes. | Fault Code 731 active?
 | STEP 1C. Check for multiple fault codes. | Exhaust gas temperature high fault codes for other cylinders 2121, 2122, 2123, 2124, 2125, 2126, 2127, 2131, 2132, 2133, 2134, 2135, 2136, 2137, 2138, or 2144 also active or inactive counts?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature cylinder 15 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
STEP 3. | Check the air handling system. |
 | STEP 3A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table?
 | STEP 3B. Check air intake restriction. | Air intake restriction within specifications found in Procedure 010-031 in the Associated Procedures Table?
 | STEP 3C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 3D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 4. | Check the power cylinder. |
 | STEP 4A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 4B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for high intake manifold temperature fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 155 or 488 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for engine speed fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders 2121, 2122, 2123, 2124, 2125, 2126, 2127, 2131, 2132, 2133, 2134, 2135, 2136, 2137, 2138, or 2144 also active or inactive counts?

YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace ECM only when there are damaged pins. Refer to Procedure 019-031 in Section 19 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor connector from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 5A

Guided Step 2C - Verify the exhaust gas temperature cylinder 15 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 15 sensor accuracy using and infrared thermometer.

  • Start the engine.
  • Connect INSITE electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 15 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature cylinder 15 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the air handling system.

Guided Step 3A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table?
YES NO
No Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 3B

Go to 5A

Guided Step 3B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications found in Procedure 010-031 in the Associated Procedures Table?
YES NO
No Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 3C

Go to 5A

Guided Step 3C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the folowing:

  • Bent, damaged, or missing fins.

Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3D

Guided Step 3D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Replace any malfunctioning seals or damaged components. See the appropriate procedures in Sections 10 and 11 in the appropriate service manual.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the power cylinder.

Guided Step 4A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 1 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 1 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch OFF.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-116 in the Associated Procedures Table.

Action

Perform the Cylinder Compression Test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders.

  • Once the cylinder is pressurized, listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Remove the cylinder head and inspect the exhaust valves and seat for damage. Replace any damaged components.

Refer to Procedure 002-004 in the Associated Procedures Table.

Replace the cylinder 1 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

No Repair

Go to 1A

Repair complete

Last Modified: 29-Mar-2017


FAULT CODE 2131 - Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K113 | 4388663
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K113 | 4388663
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K113 | 4388663
Air Intake Manifold | Refer to Procedure 010-031 | QSK95 CM2350 K113 | 4388663
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K113 | 4388663
Turbocharger Turbine Outlet Bellows | Refer to Procedure 011-116 | QSK95 CM2350 K113 | 4388663
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for high intake manifold temperature fault codes. | Fault Code 158 or 1984 active or inactive counts?
 | STEP 1B. Check for engine speed fault codes. | Fault Code 731 active?
 | STEP 1C. Check for multiple fault codes. | Exhaust gas temperature high fault codes for 2121, 2122, 2124, 2125, 2126, 2127, 2128, 2132, 2133, 2134, 2135,2136, 2137, 2138, 2144 and also active or inactive counts?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature cylinder 2 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
STEP 3. | Check the air handling system. |
 | STEP 3A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004?
 | STEP 3B. Check air intake restriction. | Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
 | STEP 3C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 3D. Check for air handling leaks. |
STEP 4. | Check the power cylinders. |
 | STEP 4A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 4B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 5. | Check ECM calibration and clear fault codes, |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for high intake manifold temperature .

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 158 or 1984 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for engine speed fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for 2121, 2122, 2124, 2125, 2126, 2127, 2128, 2132, 2133, 2134, 2135,2136, 2137, 2138, 2144 and also active or inactive counts?

YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace ECM only when there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor connector from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 5A

Guided Step 2C - Verify the exhaust gas temperature cylinder 2 sensor accuracy.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 2 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 2 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature cylinder 2 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the air handling system.

Guided Step 3A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table?
YES NO
No Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 3B

Go to 5A

Guided Step 3B - Check the air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
YES NO
No Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 3C

Go to 5A

Guided Step 3C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following:

  • Bent, damaged or missing fins.
  • Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3D

Guided Step 3D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Replace any malfunctioning seals or damaged components. Reference the appropriate procedures in sections 10 and 11 of the Service Manual.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the power cylinder.

Guided Step 4A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 2 rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the cylinder 2 overhead set for the following conditions.

  • Damage to the rocker levers or crossheads.
  • Damage to the valves or valve springs.
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Readjust the valve lash if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch ON.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-116 in the Associated Procedures Table.

Action

Perform the cylinder compression test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders. Once the cylinder is pressurized, listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Remove cylinder head and inspect exhaust valves and seats for damage. Replace any damaged components. Refer to Procedure 002-004 in the Associated Procedures Table.

Replace the cylinder 2 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 28-Mar-2017


FAULT CODE 2132 - Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K113 | 4388663
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K113 | 4388663
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K113 | 4388663
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K113 | 4388663
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K113 | 4388663
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K113 | 4388663
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K113 | 4388663
Turbocharger Turbine Outlet Bellows | Refer to Procedure 011-116 | QSK95 CM2350 K113 | 4388663
Engine Compression | Refer to Procedure 014-012 | QSK95 CM2350 K113 | 4388663
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for high intake manifold temperature fault codes. | Fault Code 158 or 1984 active or inactive counts?
 | STEP 1B. Check for engine speed fault codes. | Fault Code 731 active?
 | STEP 1C. Check for multiple fault codes. | Exhaust gas temperature high fault codes for 2121, 2122, 2123, 2124, 2125, 2126, 2127, 2128, 2131, 2133, 2134, 2135, 2136, 2137, 2138, 2144 also active or inactive counts?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the ECM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature cylinder 4 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
STEP 3. | Check the air handling system. |
 | STEP 3A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004 found in the Associated Procedures Table?
 | STEP 3B. Check air intake restriction. | Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
 | STEP 3C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 3D. Check for air handling leaks. |
STEP 4. | Check the power cylinders. |
 | STEP 4A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 4B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes, |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for high intake manifold temperature fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 158 or 1984 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for engine speed fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 4 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 4 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 4 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature cylinder 4 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 1D

Go to 4A

Guided Step 1C - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for 2121, 2122, 2123, 2124, 2125, 2126, 2127, 2128, 2131, 2133, 2134, 2135, 2136, 2137, 2138, 2144 also active or inactive counts?

YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace ECM only when there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor connector from the engine harness.

Action

Check the the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 5A

Guided Step 2C - Verify the exhaust gas temperature cylinder 4 sensor accuracy.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 4 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 4 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature cylinder 4 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the air handling system.

Guided Step 3A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table?
YES NO
No Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 3B

Go to 5A

Guided Step 3B - Check the air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
YES NO
No Repair

Replace the air filter or repair any damaged, collapsed or restricted intake piping. See equipment manufacturer service information.

Go to 3C

Go to 5A

Guided Step 3C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following.

  • Bent, damaged, or missing fins.
  • Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3D

Guided Step 3D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Replace any malfunctioning seals or damaged components. Reference the appropriate procedures in sections 10 and 11 of the Service Manual.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the power cylinder.

Guided Step 4A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 4 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 4 overhead set for the following conditions.

  • Damage to the rocker levers or crossheads.
  • Damage to the valves or valve springs.
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch ON.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-018 in the Associated Procedures Table.

Action

Perform the cylinder compression test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders. Once the cylinder is pressurized, listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Remove cylinder head and inspect exhaust valves and seats for damage. Replace any damaged components. Refer to Procedure 002-004 in the Associated Procedures Table.

Replace the cylinder 4 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 28-Mar-2017


FAULT CODE 2133 - Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K113 | 4388663
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K113 | 4388663
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K113 | 4388663
Air Intake Manifold | Refer to Procedure 010-031 | QSK95 CM2350 K113 | 4388663
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K113 | 4388663
Turbocharger Turbine Outlet Bellows | Refer to Procedure 011-116 | QSK95 CM2350 K113 | 4388663
Engine Compression | Refer to Procedure 014-012 | QSK95 CM2350 K113 | 4388663
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for high intake manifold temperature fault codes. | Fault code 158 or 1984 active or inactive counts?
 | STEP 1B. Check for engine speed fault codes. | Fault Code 731 active?
 | STEP 1C. Check for multiple fault codes. | Exhaust gas temperature high fault codes for 2121, 2122, 2123, 2124, 2125, 2126, 2127, 2128, 2131, 2132, 2134, 2135,2136, 2137, 2138, 2144 also active or inactive counts?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature cylinder 6 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
STEP 3. | Check the air handling system. |
 | STEP 3A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table?
 | STEP 3B. Check air intake restriction. | Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
 | STEP 3C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 3D. Check for air handling leaks. |
STEP 4. | Check the power cylinders. |
 | STEP 4A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 4B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes, |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for high intake manifold temperature .

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 158 or 1984 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for engine speed fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for 2121, 2122, 2123, 2124, 2125, 2126, 2127, 2128, 2131, 2132, 2134, 2135,2136, 2137, 2138, 2144 also active or inactive counts?

YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace ECM only when there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor connector from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 5A

Guided Step 2C - Verify the exhaust gas temperature cylinder 6 sensor accuracy.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 6 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 6 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature cylinder 6 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the air handling system.

Guided Step 3A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table?
YES NO
No Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 3B - Check the air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
YES NO
No Repair

Replace the air filter or repair any damaged, collapsed or restricted intake piping. See equipment manufacturer service information.

Go to 3C

Go to 5A

Guided Step 3C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following:

  • Bent, damaged or missing fins.
  • Refer to Procedure 010-033 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 3D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Replace any malfunctioning seals or damaged components. Reference the appropriate procedures in sections 10 and 11 of the Service Manual.

No Repair

Go to 5A

Go to 4B

Guided Step 4 - Check the power cylinder.

Guided Step 4A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 6 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 6 overhead set for the following conditions.

  • Damage to the rocker levers or crossheads.
  • Damage to the valves or valve springs.
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Readjust the valve lash if necessary. Refer to Procedure 003-006 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch ON.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-116 in the Associated Procedures Table.

Action

Perform the cylinder compression test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders. Once the cylinder is pressurized, listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Remove cylinder head and inspect exhaust valves and seats for damage. Replace any damaged components. Refer to Procedure 002-004 in the Associated Procedures Table.

Replace the cylinder 6 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair Complete

Last Modified: 28-Mar-2017


FAULT CODE 2134 - Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K113 | 4388663
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K113 | 4388663
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K113 | 4388663
Air Intake Manifold | Refer to Procedure 010-031 | QSK95 CM2350 K113 | 4388663
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K113 | 4388663
Turbocharger Turbine Outlet Bellows | Refer to Procedure 011-116 | QSK95 CM2350 K113 | 4388663
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for high intake manifold temperature fault codes. | Fault Code 158 or 1984 active or inactive counts?
 | STEP 1B. Check for engine speed fault codes. | Fault Code 731 active?
 | STEP 1C. Check for multiple fault codes. | Exhaust gas temperature high fault codes for 2121, 2122, 2123, 2124, 2125, 2126, 2127, 2128, 2131, 2132, 2133, 2135, 2136, 2137, 2138, 2144, and also active or inactive counts?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the ECM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature cylinder 8 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
STEP 3. | Check the air handling system. |
 | STEP 3A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table.?
 | STEP 3B. Check air intake restriction. | Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
 | STEP 3C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 3D. Check for air handling leaks. |
STEP 4. | Check the power cylinders. |
 | STEP 4A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 4B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes, |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for high intake manifold temperature.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 158 or 1984 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for engine speed fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for 2121, 2122, 2123, 2124, 2125, 2126, 2127, 2128, 2131, 2132, 2133, 2135, 2136, 2137, 2138, 2144, and also active or inactive counts?

YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace ECM only when there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor connector from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 5A

Guided Step 2C - Verify the exhaust gas temperature cylinder 8 sensor accuracy.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 8 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 8 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature cylinder 8 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the air handling system.

Guided Step 3A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table.?
YES NO
No Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 3B

Go to 5A

Guided Step 3B - Check the air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
YES NO
No Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 3C

Go to 5A

Guided Step 3C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following.

  • Bent, damaged, or missing fins.
  • Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3D

Guided Step 3D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Replace any malfunctioning seals or damaged components. Reference the appropriate procedures in sections 10 and 11 of the Service Manual.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the power cylinder.

Guided Step 4A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 8 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 8 overhead set for the following conditions.

  • Damage to the rocker levers or crossheads.
  • Damage to the valves or valve springs.
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Readjust the valve lash if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch ON.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-116 in the Associated Procedures Table.

Action

Perform the cylinder compression test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders. Once the cylinder is pressurized listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Remove cylinder head and inspect exhaust valves and seats for damage. Replace any damaged components. Refer to Procedure 002-004 in the Associated Procedures Table.

Replace the cylinder 8 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 5 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 28-Mar-2017


FAULT CODE 2135 - Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K113 | 4388663
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K113 | 4388663
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K113 | 4388663
Air Intake Manifold | Refer to Procedure 010-031 | QSK95 CM2350 K113 | 4388663
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K113 | 4388663
Turbocharger Turbine Outlet Bellows | Refer to Procedure 011-116 | QSK95 CM2350 K113 | 4388663
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for high intake manifold temperature fault codes. | Fault Code 158 or 1984 active or inactive counts?
 | STEP 1B. Check for engine speed fault codes. | Fault Code 731 active?
 | STEP 1C. Check for multiple fault codes. | Exhaust gas temperature high fault codes for 2121, 2122, 2123, 2124, 2125, 2126, 2127,` 2128, 2131, 2132, 2133, 2135, 2136, 2137, 2138, 2144 and also active or inactive counts?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature cylinder 10 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
STEP 3. | Check the air handling system. |
 | STEP 3A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004?
 | STEP 3B. Check air intake restriction. | Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
 | STEP 3C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 3D. Check for air handling leaks. |
STEP 4. | Check the power cylinders. |
 | STEP 4A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 4B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes, |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for high intake manifold temperature.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 158 or 1984 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for engine speed fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for 2121, 2122, 2123, 2124, 2125, 2126, 2127,` 2128, 2131, 2132, 2133, 2135, 2136, 2137, 2138, 2144 and also active or inactive counts?

YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace ECM only when there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor connector from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 5A

Guided Step 2C - Verify the exhaust gas temperature cylinder 10 sensor accuracy.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 10 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 10 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature cylinder 10 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the air handling system.

Guided Step 3A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table?
YES NO
No Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 3B

Go to 5A

Guided Step 3B - Check the air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
YES NO
No Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 3C

Go to 5A

Guided Step 3C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following.

  • Bent, damaged, or missing fins.
  • Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3D

Guided Step 3D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Replace any malfunctioning seals or damaged components. Reference the appropriate procedures in sections 10 and 11 of the Service Manual.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the power cylinder.

Guided Step 4A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 10 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 10 overhead set for the following conditions.

  • Damage to the rocker levers or crossheads.
  • Damage to the valves or valve springs.
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch ON.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-116 in the Associated Procedures Table.

Action

Perform the cylinder compression test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders. Once the cylinder is pressurized, listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Remove cylinder head and inspect exhaust valves and seats for damage. Replace any damaged components. Refer to Procedure 002-004 in the Associated Procedures Table.

Replace the cylinder 10 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete
Go to

Last Modified: 28-Mar-2017


FAULT CODE 2136 - Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K113 | 4388663
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K113 | 4388663
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K113 | 4388663
Air Intake Manifold | Refer to Procedure 010-031 | QSK95 CM2350 K113 | 4388663
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K113 | 4388663
Turbocharger Turbine Outlet Bellows | Refer to Procedure 011-116 | QSK95 CM2350 K1131 | 4388663
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for high intake manifold temperature fault codes. | Fault Code 158 or 1984 active or inactive counts?
 | STEP 1B. Check for engine speed fault codes. | Fault Code 731 active?
 | STEP 1C. Check for multiple fault codes. | Exhaust gas temperature high fault codes for 2121, 2122, 2123, 2124, 2125, 2126, 2127, 2128, 2131, 2132, 2133, 2135, 2136, 2137, 2138, 2144 and also active or inactive counts?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature cylinder 12 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
STEP 3. | Check the air handling system. |
 | STEP 3A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table?
 | STEP 3B. Check air intake restriction. | Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
 | STEP 3C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 3D. Check for air handling leaks. |
STEP 4. | Check the power cylinders. |
 | STEP 4A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 4B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes, |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for high intake manifold temperature.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 158 or 1984 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for engine speed fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for 2121, 2122, 2123, 2124, 2125, 2126, 2127, 2128, 2131, 2132, 2133, 2135, 2136, 2137, 2138, 2144 and also active or inactive counts?

YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace ECM only when there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor connector from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 5A

Guided Step 2C - Verify the exhaust gas temperature cylinder 12 sensor accuracy.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 12 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 12 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature cylinder 12 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the air handling system.

Guided Step 3A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004in the Associated Procedures Table.

?
YES NO
No Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 3B

Go to 5A

Guided Step 3B - Check the air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
YES NO
No Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 3C

Go to 5A

Guided Step 3C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following.

  • Bent, damaged, or missing fins.
  • Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3D

Guided Step 3D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Replace any malfunctioning seals or damaged components. Reference the appropriate procedures in sections 10 and 11 of the Service Manual.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the power cylinder.

Guided Step 4A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 12 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 12 overhead set for the following conditions.

  • Damage to the rocker levers or crossheads.
  • Damage to the valves or valve springs.
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch ON.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-116 in the Associated Procedures Table.

Action

Perform the cylinder compression test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders. Once the cylinder is pressurized, listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Remove cylinder head and inspect exhaust valves and seats for damage. Replace any damaged components. Refer to Procedure 002-004 in the Associated Procedures Table.

Replace the cylinder 12 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete
Go to

Last Modified: 28-Mar-2017


FAULT CODE 2137 - Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K113 | 4388663
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K113 | 4388663
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K113 | 4388663
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K113 | 4388663
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K113 | 4388663
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K113 | 4388663
turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K113 | 4388663
Turbocharger Turbine Outlet Bellows | Refer to Procedure 011-116 | QSK95 CM2350 K113 | 4388663
Engine Compression | Refer to Procedure 014-012 | QSK95 CM2350 K113 | 4388663
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for high intake manifold temperature fault codes. | Fault Code 158 or 1984 active or inactive counts?
 | STEP 1B. Check for engine speed fault codes. | Fault Code 731 active?
 | STEP 1C. Check for multiple fault codes. | Exhaust gas temperature high fault codes for 2121, 2122, 2123, 2124, 2125, 2126, 2127, 2128, 2131, 2132, 2133, 2135, 2136, 2138, 2144 also active or inactive counts?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the ECM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature cylinder 16 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
STEP 3. | Check the air handling system. |
 | STEP 3A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table?
 | STEP 3B. Check air intake restriction. | Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
 | STEP 3C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 3D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 4. | Check the power cylinder. |
 | STEP 4A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 4B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for high intake manifold temperature.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 158 or 1984 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for engine speed fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for 2121, 2122, 2123, 2124, 2125, 2126, 2127, 2128, 2131, 2132, 2133, 2135, 2136, 2138, 2144 also active or inactive counts?

YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace ECM only when there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor connector from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 5A

Guided Step 2C - Verify the exhaust gas temperature cylinder 16 sensor accuracy.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 16 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 16 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature cylinder 16 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the air handling system.

Guided Step 3A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES NO
No Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 3B

Go to 5A

Guided Step 3B - Check the air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
YES NO
No Repair

Replace the air filter or repair any damaged, collapsed or restricted intake piping. See equipment manufacturer service information.

Go to 3C

Go to 5A

Guided Step 3C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following.

  • Bent, damaged, or missing fins.
  • Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3D

Guided Step 3D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Replace any malfunctioning seals or damaged components. Reference the appropriate procedures in sections 10 and 11 of the Service Manual.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the power cylinder.

Guided Step 4A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 16 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 16 overhead set for the following conditions.

  • Damage to the rocker levers or crossheads.
  • Damage to the valves or valve springs.
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Readjust the valve lash if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch ON.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-116 in the Associated Procedures Table.

Action

Perform THE cylinder compression test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders. Once the cylinder is pressurized listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Remove cylinder head and inspect exhaust valves and seats for damage. Replace any damaged components. Refer to Procedure 002-004 in the Associated Procedures Table.

Replace the cylinder 16 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete
Go to

Last Modified: 28-Mar-2017


FAULT CODE 2138 - Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K113 | 4388663
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K113 | 4388663
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K113 | 4388663
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K113 | 4388663
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K113 | 4388663
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K113 | 4388663
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K113 | 4388663
Turbocharger Turbine Outlet Bellows | Refer to Procedure 011-116 | QSK95 CM2350 K113 | 4388663
Engine Compression | Refer to Procedure 014-012 | QSK95 CM2350 K113 | 4388663
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for high intake manifold temperature fault codes. | Fault Code 158 or 1984 active or inactive counts?
 | STEP 1B. Check for engine speed fault codes. | Fault Code 731 active?
 | STEP 1C. Check for multiple fault codes. | Exhaust gas temperature high fault codes for 2121, 2122, 2123, 2124, 2125, 2126, 2127, 2128, 2131, 2132, 2133, 2135, 2136, 2137, 2144 also active or inactive counts?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature cylinder 16 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
STEP 3. | Check the air handling system. |
 | STEP 3A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table?
 | STEP 3B. Check air intake restriction. | Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
 | STEP 3C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 3D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 4. | Check the power cylinder. |
 | STEP 4A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 4B. Check for damaged exhaust valves. | High intake manifold temperature fault codes active or inactive counts?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for high intake manifold temperature.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 158 or 1984 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for engine speed fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for 2121, 2122, 2123, 2124, 2125, 2126, 2127, 2128, 2131, 2132, 2133, 2135, 2136, 2137, 2144 also active or inactive counts?

YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace ECM only when there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor connector from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 5A

Guided Step 2C - Verify the exhaust gas temperature cylinder 16 sensor accuracy.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 16 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 16 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature cylinder 16 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the air handling system.

Guided Step 3A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES NO
No Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 3B

Go to 5A

Guided Step 3B - Check the air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
YES NO
No Repair

Replace the air filter or repair any damaged, collapsed or restricted intake piping. See equipment manufacturer service information.

Go to 3C

Go to 5A

Guided Step 3C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following.

  • Bent, damaged, or missing fins.
  • Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3D

Guided Step 3D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Replace any malfunctioning seals or damaged components. Reference the appropriate procedures in sections 10 and 11 of the Service Manual.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the power cylinder.

Guided Step 4A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 16 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 16 overhead set for the following conditions.

  • Damage to the rocker levers or crossheads.
  • Damage to the valves or valve springs.
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Readjust the valve lash if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch ON.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-116 in the Associated Procedures Table.

Action

Perform THE cylinder compression test.

  • Refer to Procedure 016-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders. Once the cylinder is pressurized listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Remove cylinder head and inspect exhaust valves and seats for damage. Replace any damaged components. Refer to Procedure 002-004 in the Associated Procedures Table.

Replace the cylinder 16 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete
Go to

Last Modified: 20-May-2016


FAULT CODE 2185 - Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2185 active?
STEP 2. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 2A. Check for a short circuit to battery in the OEM harness. | Greater than 100k ohms?
 | STEP 2B. Check for a short circuit to keyswitch power in the OEM harness. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault codes active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ Electronic Service Tool.

Action

Check for an active fault code.

  • Use INSITE™ Electronic Service Tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM and original equipment manufacturer (OEM) harness.

Guided Step 2A - Check for a short circuit to battery in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check the OEM harness for a short circuit to battery.

  • Measure the resistance and check for a short circuit between the accelerator pedal position +5 volt SUPPLY pin and the ECM battery SUPPLY (+) pins in the OEM harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit to keyswitch power in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check the OEM harness for a short circuit to keyswitch power.

  • Check for a short circuit between the accelerator pedal position +5 volt SUPPLY pin and the ECM keyswitch SIGNAL pin in the OEM harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ Electronic Service Tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ Electronic Service Tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ Electronic Service Tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 25-Mar-2016


FAULT CODE 2186 - Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ and test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2186 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Inspect the accelerator pedal/lever position sensor and circuit connected to the sensor supply and return | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2186 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3B-1. Check for a pin-to-ECM power supply ground short circuit in the OEM harness. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply and return.

Guided Step 2A - Inspect the accelerator pedal/lever position sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES NO

Replace the accelerator pedal/lever position sensor.

See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector or ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the accelerator pedal +5 volt supply and all other pins in the OEM harness ECM connector.

Use the circuit art or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for a pin-to-ECM power supply ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance and check for a short circuit between the accelerator +5 volt SUPPLY pin and ECM power supply ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ Electronic Service Tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 25-Mar-2016


FAULT CODE 2196- Engine Oil Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Cold Weather Starting | Refer to Procedure 101-004 | QSK95 CM2350 K113 | 4388665

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine control module (ECM). |
 | STEP 1A. Read the fault codes. | Fault Code 2196 active or inactive counts?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the engine control module (ECM).

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2196 active or inactive counts?
YES NO

No troubleshooting is necessary for this fault code. This is an information only fault code that will become active if normal starting is attempted while lubricating oil temperature is below a calibrated threshold.

The oil must be warmed to raise the temperature above the calibrated threshold to complete a pre-lubricating oil cycle before starting the engine. Reference the Cold Weather Starting procedure in Section 1 of the QSK95 CM2350 K113 Owners Manual, Bulletin 4388665. Refer to Procedure 101-004 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ Electronic Service Tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process.

Repair complete

Last Modified: 04-Apr-2017


FAULT CODE 2215 - Fuel Pump Delivery Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | QSK95 CM2350 K113 | 4388663
Engine Fuel Supply Pump | Refer to Procedure 005-241 | QSK95 CM2350 K113 | 4388663
Air in Fuel | Refer to Procedure 006-003 | QSK95 CM2350 K113 | 4388663
Fuel Supply Lines | Refer to Procedure 006-024 | QSK95 CM2350 K113 | 4388663
Fuel Pump Air Bleed Line | Refer to Procedure 006-056 | QSK95 CM2350 K113 | 4388663
Fuel Filter (Stage 1) | Refer to Procedure 006-075 | QSK95 CM2350 K113 | 4388663
Fuel Filter (Stage 2) | Refer to Procedure 006-076 | QSK95 CM2350 K113 | 4388663
Fuel Inlet Pressure Measurement | Refer to Procedure 006-104 | QSK95 CM2350 K113 | 4388663
Fuel Delivery Pressure Sensor | Refer to Procedure 019-548 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated before replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2343, 2372, 4885, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, or 4961 active or inactive with more than one count in the last 25 engine hours?
STEP 2. | Check the low-pressure fuel system. |
 | STEP 2A. Check for adequate fuel supply. | Equipment has an adequate fuel supply?
 | STEP 2B. Check the fuel lines. | Kinked or damaged fuel lines?
 | STEP 2C. Check the fuel delivery pressure sensor. | Fuel delivery pressure sensor meets specifications found in Procedure 019-548 in the Associated Procedures Table?
STEP 3. | Check the low-pressure fuel system operation. |
 | STEP 3A. Check for air in the fuel system. | Air in the fuel?
 | STEP 3B. Check fuel inlet pressure. | Fuel inlet pressure within the specifications found in Procedure 006-104 in the Associated Procedures Table?
 | STEP 3C. Check the Stage 1 fuel filter restriction. | Stage 1 fuel filter restriction within the specifications found in Procedure 005-236 in the Associated Procedures Table?
 | STEP 3D. Check the Stage 2 fuel filter restriction. | Stage 2 fuel filter restriction within the specifications found in Procedure 005-236 in the Associated Procedures Table?
 | STEP 3E. Check air bleed line check valve operation. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2343, 2372, 4885, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, or 4961 active or inactive with more than one count in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the low-pressure fuel system.

Guided Step 2A - Check for adequate fuel supply.

Conditions

  • Turn keyswitch ON.
  • Start the engine.

Action

Check for adequate fuel supply.

  • Do not rely on the vehicle's fuel gauge.
  • Verify there is fuel in the tank.

Equipment has an adequate fuel supply?
YES NO
No Repair

Add fuel to the fuel tank or perform repairs to the vehicle's tank or fuel gauge.

Go to 2B

Go to 4A

Guided Step 2B - Check the fuel lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the suction and low-pressure fuel lines for kinks or damage.

Kinked or damaged fuel lines?
YES NO

Replace the damaged fuel line(s). Refer to Procedure 006-024 in the Associated Procedures Table or the equipment manufacturer service information.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the fuel delivery pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Install a pressure gauge onto the Compuchek™ fitting at the outlet of the stage 2 fuel filter head.

Action

Check the fuel delivery pressure sensor accuracy.

  • Refer to Procedure 019-548 in the Associated Procedures Table.

Fuel delivery pressure sensor meets specifications found in Procedure 019-548 in the Associated Procedures Table?
YES NO
No Repair

Replace the fuel delivery pressure sensor

Refer to Procedure 019-548 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the low-pressure fuel system operation.

Guided Step 3A - Check for air in the fuel system.

Conditions

  • Turn keyswitch ON.

Action

Check for air in the fuel.

  • Refer to Procedure 006-003 in the Associated Procedures Table.

Air in the fuel?
YES NO

Investigate the cause of the air in fuel. Check for loose Stage 1 filters, loose fuel line fittings and fuel line punctures. Repair or replace the malfunctioning component(s).

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check fuel inlet pressure.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel inlet pressure.

  • Refer to Procedure 006-104 in the Associated Procedures Table.

Fuel inlet pressure within the specifications found in Procedure 006-104 in the Associated Procedures Table?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3C

Guided Step 3C - Check Stage 1 fuel filter restriction.

Conditions

  • Turn keyswitch ON.

Action

Check the Stage 1 fuel filter restriction.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Stage 1 fuel filter restriction within the specifications found in Procedure 005-236 in the Associated Procedures Table?
YES NO

High restriction in the fuel supply lines or fuel supply tank has been detected. Continue troubleshooting to determine the cause of the high restriction.

Replace any damaged or malfunctioning components. See equipment manufacturer service information.

Replace the Stage 1 fuel filters. Refer to Procedure 006-075 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3D - Check stage 2 fuel filter restriction.

Conditions

  • Turn keyswitch ON.

Action

Check the stage 2 fuel filter restriction.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Stage 2 fuel filter restriction within the specifications found in Procedure 005-236 in the Associated Procedures Table?
YES NO
No Repair

Replace the stage 2 fuel filters. Refer to Procedure 006-076 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check air bleed line check valve operation.

Conditions

  • Remove the check valve from the fuel drain manifold and route into a graduated cylinder.
  • Operate the engine.

Action

Check the fuel flow through the air bleed line check valve from the high-pressure fuel pump.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Fuel flow from the fuel pump air bleed line within the specifications found in Refer to Procedure 005-236 in the Associated Procedures Table?

YES NO

Replace the engine fuel supply pump. Refer to Procedure 005-241 in the Associated Procedures Table.

Replace the air bleed check valve. Refer to Procedure 006-056 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

No Repair

Go to 1A

Escalate or call for assistance

Last Modified: 19-Oct-2018


FAULT CODE 2249 - Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Pump | Refer to Procedure 005-016 | QSK95 CM2350 K113 | 4388663
Fuel System Diagnostics | Refer to Procedure 005-236 | QSK95 CM2350 K113 | 4388663
Air in Fuel | Refer to Procedure 006-003 | QSK95 CM2350 K113 | 4388663
Injector Supply Lines (High Pressure) | Refer to Procedure 006-051 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK95 CM2350 K113 | 4388663
Fuel Delivery Pressure Sensor | Refer to Procedure 019-548 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fuel delivery pressure sensor, engine fuel supply pump, fuel filter differential pressure, fuel metering valve, or fuel leak indicator tank fault codes. | Fault Code 2215, 2262, 2343, 2372, 4885, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, 4961, 6594 active or inactive counts?
STEP 2. | Check the operation of the fuel system. |
 | STEP 2A. Check for external fuel leaks. | High-pressure fuel line leaks or damage?
 | STEP 2B. Check for air in the fuel system. | Air in fuel system?
 | STEP 2C. Check the fuel delivery pressure sensor. | Fuel delivery pressure sensor meets specifications found in Procedure 019-548?
 | STEP 2D. Check the fuel rail pressure sensor. | Fuel rail pressure sensor meets specifications found in Procedure 019-115?
 | STEP 2E. Check the operation of the high-pressure fuel pump. | Fault Code 559 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fuel delivery pressure sensor, engine fuel supply pump, fuel filter differential pressure, fuel metering valve, or fuel leak indicator tank fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2215, 2262, 2343, 2372, 4885, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, 4961, 6594 active or inactive counts?

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the operation of the fuel system.

Guided Step 2A - Check for external fuel leaks.

Conditions

  • Operate engine.

Action

Check for external fuel leaks.

  • Perform the High-Pressure Fuel System Leak Test. Refer to Procedure 005-236 in the Associated Procedures Table.

High-pressure fuel line leaks or damage?
YES NO

Replace any damaged high-pressure fuel supply lines. Refer to Procedure 006-051 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for air in the fuel system.

Conditions

  • Turn keyswitch ON.

Action

Check for air in the fuel.

  • Refer to Procedure 006-003 in the Associated Procedures Table.

Air in fuel system?
YES NO

Repair or replace the malfunctioning component(s).

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the fuel delivery pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Install a pressure gauge onto the Compuchek™ fitting at the outlet of the Stage 2 fuel filter head.

Action

Check the fuel delivery pressure sensor accuracy.

  • Refer to Procedure 019-548 in the Associated Procedures Table.

Fuel delivery pressure sensor meets specifications found in Procedure 019-548?
YES NO
No Repair

Replace the fuel delivery pressure sensor. Refer to Procedure 019-548 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the fuel rail pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel rail pressure sensor accuracy.

  • Refer to Procedure 019-115 in the Associated Procedures Table.

Fuel rail pressure sensor meets specifications found in Procedure 019-115?
YES NO
No Repair

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check the operation of the high-pressure fuel pump.

Conditions

  • Turn keyswitch ON.
  • Operate the engine at idle.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to verify the fault codes.

  • Use INSITE™ electronic service tool Fuel System Leakage Test to raise the fuel rail pressure.

Fault Code 559 active?
YES NO

Replace the high-pressure fuel pump assembly. Refer to Procedure 005-016 in the Associated Procedure.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 25-Apr-2016


FAULT CODE 2261 - Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSK95 CM2350 K113 | 4388663
Fuel Delivery Pressure Sensor | Refer to Procedure 019-548 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 546, 547, 2343, 2372, 4885, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, or 4961 active?
STEP 2. | Check the fuel supply system. |
 | STEP 2A. Check the fuel lines. | Kinked or damaged fuel lines?
 | STEP 2B. Check the fuel delivery pressure sensor. | Fuel delivery pressure sensor meets specifications found in Procedure 019-548 in the Associated Procedures Table?
STEP 3. | Check for fuel return drain line restriction. |
 | STEP 3A. Check drian line restriction. | Fuel drain line restriction within the specifications outlined in Procedure 006-012 in the Associated Procedures Table?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546, 547, 2343, 2372, 4885, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, or 4961 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the fuel supply system.

Guided Step 2A - Check the fuel lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the low-pressure fuel lines for kinks or damage.

Kinked or damaged fuel lines?
YES NO

Replace the damaged fuel line(s). Refer to Procedure 006-024 in the Associated Procedures Table or see equipment manufacturer service information.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fuel delivery pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Install a pressure gauge onto the Compuchek™ fitting at the outlet of the Stage 2 fuel filter head.

Action

Check the fuel delivery pressure sensor accuracy.

  • Refer to Procedure 019-548 in the Associated Procedures Table.

Fuel delivery pressure sensor meets specifications found in Procedure 019-548 in the Associated Procedures Table?
YES NO
No Repair

Replace the fuel delivery pressure sensor. Refer to Procedure 019-548 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check for fuel return drain line restriction.

Guided Step 3A - Check drain line restriction.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Check for excessive fuel drain line restriction.

  • Refer to Procedure 006-012 in the Associated Procedures Table.

Fuel drain line restriction within the specifications outlined in Procedure 006-012 in the Associated Procedures Table?
YES NO
No Repair

Replace the source of the high fuel drain line restriction. Refer to Procedure 006-012 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 25-Mar-2016


FAULT CODE 2262 - Fuel Pump Delivery Pressure - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | QSK95 CM2350 K113 | 4388663
Engine Fuel Supply Pump | Refer to Procedure 005-241 | QSK95 CM2350 K113 | 4388663
Air in Fuel | Refer to Procedure 006-003 | QSK95 CM2350 K113 | 4388663
Fuel Supply Lines | Refer to Procedure 006-024 | QSK95 CM2350 K113 | 4388663
Fuel Pump Air Bleed Line | Refer to Procedure 006-056 | QSK95 CM2350 K113 | 4388663
Fuel Filter (Stage 1) | Refer to Procedure 006-075 | QSK95 CM2350 K113 | 4388663
Fuel Filter (Stage 2) | Refer to Procedure 006-076 | QSK95 CM2350 K113 | 4388663
Fuel Inlet Pressure Measurement | Refer to Procedure 006-104 | QSK95 CM2350 K113 | 4388663
Fuel Delivery Pressure Sensor | Refer to Procedure 019-548 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated before replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2343, 2372, 4885, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, or 4961 active or inactive with more than 1 count in the last 25 engine hours?
STEP 2. | Check the low-pressure fuel system. |
 | STEP 2A. Check for adequate fuel supply. | Equipment has an adequate fuel supply?
 | STEP 2B. Check the fuel lines. | Kinked or damaged fuel lines?
 | STEP 2C. Check the fuel delivery pressure sensor. | Fuel delivery pressure sensor meets specifications found in Procedure 019-548 in the Associated Procedures Table?
STEP 3. | Check the low-pressure fuel system operation. |
 | STEP 3A. Check for air in the fuel system. | Air in the fuel?
 | STEP 3B. Check fuel inlet pressure. | Fuel supply pump inlet restriction within the specifications found in Procedure 006-104 in the Associated Procedure Table?
 | STEP 3C. Check stage 1 fuel filter restriction. | Stage 1 fuel filter restriction within the specifications found in Procedure 005-236 in the Associated Procedures Table?
 | STEP 3D. Check the stage 2 fuel filter restriction. | Stage 2 fuel filter restriction within the specifications found in Procedure 005-236 in the Associated Procedures Table?
 | STEP 3E. Check air bleed line check valve operation. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2343, 2372, 4885, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, or 4961 active or inactive with more than one count in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the low-pressure fuel system.

Guided Step 2A - Check for adequate fuel supply.

Conditions

  • Turn keyswitch ON.
  • Turn engine OFF.

Action

Check for adequate fuel supply.

  • Do not rely on the vehicle's fuel gauge.
  • Verify there is fuel in the tank.

Equipment has an adequate fuel supply?
YES NO
No Repair

Add fuel to the fuel tank or perform repairs to the vehicle's tank or fuel gauge.

Go to 2B

Go to 4A

Guided Step 2B - Check the fuel lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the suction and low-pressure fuel lines for kinks or damage.

Kinked or damaged fuel lines?
YES NO

Replace the damaged fuel line(s). Refer to Procedure 006-024 in the Associated Procedures Table or the equipment manufacturer service information.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the fuel delivery pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Install a pressure gauge onto the Compuchek™ fitting at the outlet of the Stage 2 fuel filter head.

Action

Check the fuel delivery pressure sensor accuracy.

  • Refer to Procedure 019-548 in the Associated Procedures Table.

Fuel delivery pressure sensor meets specifications found in Procedure 019-548 in the Associated Procedures Table?
YES NO
No Repair

Replace the fuel delivery pressure sensor

Refer to Procedure 019-548 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the low-pressure fuel system operation.

Guided Step 3A - Check for air in the fuel system.

Conditions

  • Turn keyswitch ON.

Action

Check for air in the fuel.

  • Refer to Procedure 006-003 in the Associated Procedures Table.

Air in the fuel?
YES NO

Investigate the cause of the air in fuel. Check for loose Stage 1 filters, loose fuel line fittings, and fuel line punctures. Repair or replace the malfunctioning component(s).

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check fuel inlet pressure

Conditions

  • Turn keyswitch ON.

Action

Check the fuel inlet pressure.

  • Refer to Procedure 006-104 in the Associated Procedures Table.

Fuel inlet pressure within the specifications found in Procedure 006-104 in the Associated Procedures Table?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3C

Guided Step 3C - Check Stage 1 fuel filter restriction.

Conditions

  • Turn keyswitch ON.

Action

Check the Stage 1 fuel filter restriction.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Stage 1 fuel filter restriction within the specifications found in Procedure 005-236 in the Associated Procedures Table?
YES NO

High restriction in the fuel supply lines or fuel supply tank has been detected. Continue troubleshooting to determine the cause of the high restriction.

Replace any damaged or malfunctioning components. See equipment manufacturer service information.

Replace the Stage 1 fuel filters. Refer to Procedure 006-075 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3D - Check Stage 2 fuel filter restriction.

Conditions

  • Turn keyswitch ON.

Action

Check the Stage 2 fuel filter restriction.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Stage 2 fuel filter restriction within the specifications found in Procedure 005-236 in the Associated Procedures Table?
YES NO
No Repair

Replace the Stage 2 fuel filters. Refer to Procedure 006-076 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check air bleed line check valve operation.

Conditions

  • Turn keyswitch ON.

Action

Check air bleed line check valve operation.

  • Remove the check valve from the fuel drain manifold and route into a graduated cylinder.
  • Operate the engine.

Fuel flow from the fuel pump air bleed line within the specifications found in Procedure 005-236 in the Associated Procedures Table?

YES NO

Replace the engine fuel supply pump. Refer to Procedure 005-241 in the Associated Procedures Table.

Replace the air bleed check valve. Refer to Procedure 006-056 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

No Repair

Go to 1A

Escalate or call for assistance

Last Modified: 19-Oct-2018


FAULT CODE 2288 - Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 2288. | Active or inactive counts of Fault Code 2288?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 2288.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive counts of Fault Code 2288.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 2288?
YES NO

The engine has been derated due to turbocharger high speed conditions. This is normal operation, but a torque derate was used to protect the engine from exceeding turbocharger high speed limits.

No repair action is necessary.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 25-Apr-2016


FAULT CODE 2343 - Fuel Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Supply Lines | Refer to Procedure 006-024 | QSK95 CM2350 K113 | 4388663
Fuel Filter (Stage 2) | Refer to Procedure 006-076 | QSK95 CM2350 K113 | 4388663
Fuel Delivery Pressure Sensor | Refer to Procedure 019-548 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2343 active or counts of inactive?
 | STEP 1B. Check for active fault codes. | Fault Code 2372 active or counts of inactive?
STEP 2. | Inspect the fuel delivery line. |
 | STEP 2A. Check the Stage 2 fuel filter intake line. | Kinks or damage found?
STEP 3. | Check the fuel delivery pressure sensor. |
 | STEP 3A. Verify fuel delivery pressure sensor accuracy. | Fuel delivery pressure sensor within specification found in Procedure 019-548 in the Associated Procedures Table?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2343 active or counts of inactive?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2372 active or counts of inactive?
YES | NO
No Repair | No Repair

Appropriate troubleshooting symptom tree

Go to 2A

Guided Step 2 - Inspect the fuel delivery line.

Guided Step 2A - Check the Stage 2 fuel filter intake line.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the Stage 2 fuel filter intake line for kinks or damage.

Kinks or damage found?
YES NO

Replace the Stage 2 fuel filter intake line. Refer to Procedure 006-024 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the fuel delivery pressure sensor.

Guided Step 3A - Verify fuel delivery pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel delivery pressure sensor accuracy.

Refer to Procedure 019-548 in the Associated Procedures Table.

Fuel delivery pressure sensor within specification found in Procedure 019-548 in the Associated Procedures Table?
YES NO

Stage 2 fuel filter restriction is greater than a calibrateable threshold. See equipment manufacturer service information.

Replace the Stage 2 fuel filters, if necessary. Refer to Procedure 006-076 in the Associated Procedures Table.

Replace the fuel delivery pressure sensor. Refer to Procedure 019-548 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 2372 - Fuel Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Supply Lines | Refer to Procedure 006-024 | QSK95 CM2350 K113 | 4388663
Fuel Filter (Stage 2) | Refer to Procedure 006-076 | QSK95 CM2350 K113 | 4388663
Fuel Delivery Pressure Sensor | Refer to Procedure 019-548 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2372 active or inactive counts?
STEP 2. | Inspect the fuel delivery line. |
 | STEP 2A. Check the Stage 2 fuel filter intake line. | Kinks or damage found?
STEP 3. | Check the fuel delivery pressure sensor. |
 | STEP 3A. Verify fuel delivery pressure sensor accuracy. | Fuel delivery pressure sensor within specification found in Procedure 019-548 in the Associated Procedures Table?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2372 active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Inspect the fuel delivery line.

Guided Step 2A - Check the Stage 2 fuel filter intake line.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the Stage 2 fuel filter intake line for kinks or damage.

Kinks or damage found?
YES NO

Replace the Stage 2 fuel filter intake line. Refer to Procedure 006-024 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the fuel delivery pressure sensor.

Guided Step 3A - Verify fuel delivery pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel delivery pressure sensor accuracy.

Refer to Procedure 019-548 in the Associated Procedures Table.

Fuel delivery pressure sensor within specification found in Procedure 019-548 in the Associated Procedures Table?
YES NO

Replace the Stage 2 fuel filters. Refer to Procedure 006-076 in the Associated Procedures Table.

Replace the fuel delivery pressure sensor. Refer to Procedure 019-548 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 28-Mar-2016


FAULT CODE 2377 - Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault code. | Fault Code 2377 active?
STEP 2. | Check the fan control solenoid and circuit. |
 | STEP 2A. Inspect the fan control solenoid and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the fan control solenoid . | Less than 10k ohms?
 | STEP 2C. Check the fan control solenoid diagnostic supply voltage, supply wire, and return circuit. | Greater than 5.0 VDC?
 | STEP 2D. Check for an open circuit in the fan control return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM/original equipment manufacturer (OEM) harness and engine harness. |
 | STEP 3A. Inspect all OEM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in fan control signal circuit. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness or engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for active fault code. | Fault Code 2377 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2377 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fan control solenoid and circuit.

Guided Step 2A - Inspect the fan control solenoid and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan solenoid from the OEM harness connector.

Action

Inspect the OEM and engine harnesses and fan solenoid connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the solenoid or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness connector.

Action

Check fan control resistance.

  • Measure the resistance between the fan control solenoid SIGNAL and fan control solenoid RETURN pin at the fan control solenoid connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

An open circuit in the fan control has been detected.

Replace the fan control.

See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the fan control solenoid diagnostic supply voltage, SUPPLY wire, and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.
  • Turn keyswitch ON.

Action

Check the fan control diagnostic supply voltage and return circuit.

  • Measure the voltage between the fan control solenoid SIGNAL pin and the fan control solenoid RETURN pin at the fan control connector of the OEM harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 5 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the fan control return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control connector from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the fan control solenoid RETURN pin in the OEM harness and ECM power supply ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected. Refer to the OEM wiring diagram for RETURN wire configuration.

If the return is wired to the ECM, repair or replace the damaged section of harness.

  • For the OEM harness. Refer to Procedure 019-071 in Section 19.
  • For the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

If the RETURN wire is grounded to the chassis or ECM power supply ground, repair the source of the damaged connection.

Clean, repair, or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Check the ECM/original equipment manufacturer (OEM) harness and engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM or engine harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Use the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the fan control signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector fan control solenoid SIGNAL pin and the OEM harness fan control solenoid connector fan control solenoid SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open fan control signal circuit has been detected in the harness.

Troubleshoot harnesses connected in series to determine which contains the open circuit.

Repair or replace the damaged section of harness.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the fan control solenoid SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Reference the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the fan control SIGNAL wire has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Repair or replace the damaged section of harness.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2377 active?
YES NO

  • Replace the ECM.
  • Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 28-Mar-2016


FAULT CODE 2442 - Injector Solenoid Driver Cylinder 1 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2442 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2442.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 2442 active?
YES NO

The injector bar code adjustable parameter for cylinder 1 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 28-Mar-2016


FAULT CODE 2443 - Injector Solenoid Driver Cylinder 2 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2443 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2443.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 2443 active?
YES NO

The injector bar code adjustable parameter for cylinder 2 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Data Plate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 28-Mar-2016


FAULT CODE 2444 - Injector Solenoid Driver Cylinder 3 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2444 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2444.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 2444 active?
YES NO

The injector bar code adjustable parameter for cylinder 3 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Data Plate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 28-Mar-2016


FAULT CODE 2445 - Injector Solenoid Driver Cylinder 4 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2445 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2445.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 2445 active?
YES NO

The injector bar code adjustable parameter for cylinder 4 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found on QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Data Plate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 28-Mar-2016


FAULT CODE 2446 - Injector Solenoid Driver Cylinder 5 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2446 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2446.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 2446 active?
YES NO

The injector bar code adjustable parameter for cylinder 5 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Data Plate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an engine control module (ECM) calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 28-Mar-2016


FAULT CODE 2447 - Injector Solenoid Driver Cylinder 6 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2447 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2447.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 2447 active?
YES NO

The injector bar code adjustable parameter for cylinder 6 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Data Plate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 28-Mar-2016


FAULT CODE 2474 - Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for an intermittent fault condition. |
 | STEP 1A. Check for an active fault code. | Fault Code 2474 active?
STEP 2. | Check for a malfunctioning turbocharger speed sensor. |
 | STEP 2A. Inspect the engine harness connector to the turbocharger speed sensor. | Connector or pigtail harness damaged?
 | STEP 2B. Measure the turbocharger speed sensor resistance. | Between 600 and 1600 ohms?
 | STEP 2C. Check for a short circuit to ground in the turbocharger speed sensor. | Greater than 100k ohms?
STEP 3. | Check the engine harness |
 | STEP 3A. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the turbocharger speed sensor circuit continuity. | Resistance within 10 ohms of the sensor resistance?
 | STEP 3C. Check for a short circuit to the ECM power supply ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for an intermittent fault condition.

Guided Step 1A - Check for active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2474 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check for a malfunctioning turbocharger speed sensor.

Guided Step 2A - Inspect the engine harness connector to the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the turbocharger speed sensor.

Action

Inspect the turbocharger speed sensor connector, the engine harness connector, and the turbocharger speed sensor pigtail harness for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Connector or pigtail harness damaged?
YES NO

Repair or replace the damaged connector, or turbocharger speed sensor. Refer to Procedure 019-390 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Measure the turbocharger speed sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Check the sensor resistance.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin to the turbocharger speed RETURN (-) pin at the sensor.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 600 and 1600 ohms?
YES NO
No Repair

The turbocharger speed sensor has malfunctioned.

Replace the turbocharger speed sensor. Refer to Procedure 019-390 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ECM power supply ground in the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Check for a short circuit to ground.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin on the sensor to the ECM power supply ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

The turbocharger speed sensor is shorted to the ECM power supply ground.

Replace the turbocharger speed sensor. Refer to Procedure 019-390 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine control module (ECM) and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the turbocharger speed sensor circuit continuity.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Connect the turbocharger speed sensor to the engine harness.

Action

Check the sensor continuity

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the engine harness ECM connector to the turbocharger speed RETURN (-) pin at the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

The resistance of the turbocharger speed sensor circuit must not be more than 10 ohms greater than the resistance of the turbocharger speed sensor. The turbocharger speed sensor resistance value was read in Step 2B.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance within 10 ohms of the sensor resistance?
YES NO
No Repair

There is high resistance or an open circuit in the engine harness or turbocharger speed sensor connector. Otherwise, there is a low resistance (short) across the sensor input pins.

Repair or replace the engine harness or connector(s). Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to the ECM power supply ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Connect the turbocharger speed sensor to the engine harness.

Action

Check for a short to ground.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the engine harness ECM connector to the ECM power supply ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a short to ground in the turbocharger speed sensor circuit. Inspect the engine harness for a short to the ECM power supply ground.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a pin-to-pin short.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to all other pins in the connector except the turbocharger speed RETURN (-) pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a short between pins of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 28-Mar-2016


FAULT CODE 2544 - Engine ECU Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the active fault codes. | Fault Code 2544 active or inactive counts?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2544 active or inactive counts?
YES NO

The fault code indicating high internal ECM temperature has been detected. Check the low temperature coolant system for malfunctioning components.

This fault code could be caused by operation in a hot ambient environment. Inspect the original equipment manufacturer or customer engine ventilation devices for proper operation. Check air flow over the engine is not blocked or restricted.

Repair any damaged components. Remove any debris or air restriction.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 28-Mar-2016


FAULT CODE 2651 - Engine Exhaust Gas Temperature - Bank 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault code. | Fault Code 2651 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2652 active and Fault Code 2651 in active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 2651 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for active fault code. | Fault Code 2651 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2651 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the bank 2 exhaust gas temperature sensor from the engine harness.

Action

Inspect the engine harness and bank 2 exhaust gas temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or on the connector
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the bank 2 exhaust gas temperature sensor connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the bank 2 exhaust gas temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the bank 2 exhaust gas temperature sensor SIGNAL and RETURN pins at the sensor connector of the engine harness.
  • See the circuit diagram or wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2652 active and Fault Code 2651 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes are verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the bank 2 exhaust gas temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2651 active?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the bank 2 exhaust gas temperature sensor.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed bank or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the bank 2 exhaust gas temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the bank 2 exhaust gas temperature sensor RETURN pin in the engine harness ECM connector and the bank 2 exhaust gas temperature sensor RETURN pin in the engine harness sensor connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the bank 2 exhaust gas temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the bank 2 exhaust gas temperature sensor SIGNAL pin in the engine harness ECM connector and the bank 2 exhaust gas temperature SIGNAL pin in the engine harness sensor connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the bank 2 exhaust gas temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the bank 2 exhaust gas temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for active fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2651 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear all fault codes.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 2652 - Engine Exhaust Gas Temperature - Bank 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2652 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2651 active and Fault Code 2652 in active?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 2652 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 2652 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2652 active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the bank 2 exhaust gas temperature sensor from the engine harness.

Action

Inspect the engine harness and bank 2 exhaust gas temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the bank 2 exhaust gas temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2651 active and Fault Code 2652 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the bank 2 exhaust gas temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2652 active?
YES NO

Replace the bank 2 exhaust gas temperature sensor.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed bank or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the bank 2 exhaust gas temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the bank 2 exhaust gas temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater thank 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the bank 2 exhaust gas temperature sensor from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the bank 2 exhaust gas temperature sensor SIGNAL pin in the engine harness ECM connector and ECM power supply ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2652 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear all fault codes.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-May-2016


FAULT CODE 2653 - Engine Exhaust Gas Temperature - Bank 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Leaks, Air Intake, and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K113 | 4388663
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K113 | 4388663
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K113 | 4388663
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | Fault Code 1984 or 158 active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the ECM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature bank 2 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
STEP 3. | Check the air handling system. |
 | STEP 3A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004?
 | STEP 3B. Check air intake restriction. | Air intake restriction within specifications found in Procedure 010-031?
 | STEP 3C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 3D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1984 or 158 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate troubleshooting fault code tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only if there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the damaged section of the harness. Use the following procedure for engine harness repair. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Verify the exhaust gas temperature bank 2 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature bank 2 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port-side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature bank 2 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature sensor reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature bank 2 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the air handling system.

Guided Step 3A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES NO
No Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications found in Procedure 010-031?
YES NO
No Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for bent, damaged, or missing fins.

Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Replace any malfunctioning seals or damaged components. See the appropriate procedures in Sections 10 and 11 of the service manual.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 2654 - Engine Exhaust Gas Temperature - Bank 2 - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Leaks, Air Intake, and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K113 | 4388663
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K113 | 4388663
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K113 | 4388663
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | Fault Code 1984 or 158 active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the ECM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature bank 2 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
STEP 3. | Check the air handling system. |
 | STEP 3A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004?
 | STEP 3B. Check air intake restriction. | Air intake restriction within specifications found in Procedure 010-031?
 | STEP 3C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 3D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1984 or 158 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate troubleshooting fault code tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only if there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the damaged section of the harness. Use the following procedure for engine harness repair. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Verify the exhaust gas temperature bank 2 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature bank 2 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port-side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature bank 2 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature sensor reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature bank 2 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the air handling system.

Guided Step 3A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES NO
No Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications found in Procedure 010-031?
YES NO
No Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for bent, damaged, or missing fins.

Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Replace any malfunctioning seals or damaged components. See the appropriate procedures in Sections 10 and 11 of the service manual.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 2655 - Engine Exhaust Gas Temperature - Bank 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2655 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2656 active and Fault Code 2655 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 2655 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 2655 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2655 active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the bank 1 exhaust gas temperature sensor from the engine harness.

Action

Inspect the engine harness and bank 1 exhaust gas temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the bank 1 exhaust gas temperature sensor connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the bank 1 exhaust gas temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the bank 1 exhaust gas temperature sensor SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Refer to the wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2656 active and Fault Code 2655 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the bank 1 exhaust gas temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2655 active?
YES NO

Replace the bank 1 exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

None. the removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the bank 1 exhaust gas temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the bank 1 exhaust gas temperature sensor RETURN pin in the engine harness ECM connector and the bank 1 exhaust gas temperature sensor RETURN pin in the engine harness sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the bank 1 exhaust gas temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the bank 1 exhaust gas temperature sensor SIGNAL pin in the engine harness ECM connector and the bank 1 exhaust gas temperature sensor SIGNAL pin in the engine harness sensor connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the bank 1 exhaust gas temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the bank 1 exhaust gas temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F].
  • Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2655 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault codes.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 05-Nov-2017


FAULT CODE 2656 - Engine Exhaust Gas Temperature - Bank 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2655 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2655 active and Fault Code 2656 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 2656 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 2656 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2656 active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the bank 1 exhaust gas temperature sensor from the engine harness.

Action

Inspect the engine harness and bank 1 exhaust gas temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the bank 1 exhaust gas temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2655 active and Fault Code 2656 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the bank 1 exhaust gas temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2656 active?
YES NO

Replace the bank 1 exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the bank 1 exhaust gas temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the bank 1 exhaust gas temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the bank 1 exhaust gas temperature sensor from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the bank 1 exhaust gas temperature sensor SIGNAL pin in the engine harness ECM connector and engine block ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2656 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault codes.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 06-Apr-2016


FAULT CODE 2657 - Engine Exhaust Gas Temperature - Bank 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Leaks, Air Intake, and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K113 | 4388663
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K113 | 4388663
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K113 | 4388663
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | Fault Code 488 or 155 active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the ECM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature bank 1 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
STEP 3. | Check the air handling system. |
 | STEP 3A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004?
 | STEP 3B. Check air intake restriction. | Air intake restriction within specifications found in Procedure 010-031?
 | STEP 3C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 3D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 488 or 155 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate troubleshooting fault code tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only if there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the damaged section of the harness. Use the following procedure for engine harness repair. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Verify the exhaust gas temperature bank 1 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature bank 1 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port-side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature bank 1 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature sensor reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature bank 1 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the air handling system.

Guided Step 3A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES NO
No Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications found in Procedure 010-031?
YES NO
No Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for bent, damaged, or missing fins.

Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Replace any malfunctioning seals or damaged components. See the appropriate procedures in Sections 10 and 11 of the service manual.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 2658 - Engine Exhaust Gas Temperature - Bank 1 - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K113 | 4388663
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K113 | 4388663
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K113 | 4388663
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K113 | 4388663
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for high intake manifold temperature fault codes. | High intake manifold temperature Fault Code 488 or 155 active or inactive counts?
 | STEP 1B. Check for engine speed related fault codes. | Fault Code 731 active?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor signal and return circuit. | Less than 10 ohms?
 | STEP 2C. Verify the exhaust gas temperature bank 1 sensor accuracy. | Exhaust gas temperature sensor reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
STEP 3. | Check the air handling system. |
 | STEP 3A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table?
 | STEP 3B. Check air intake restriction. | Air intake restriction within specifications found in Procedure 010-031 in the Associated Procedures Table?
 | STEP 3C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 3D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for high intake manifold temperature fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature Fault Code 488 or 155 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for engine speed related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the engine control module (ECM) harness connector pins.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace ECM only when there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the exhaust gas temperature sensor signal and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor connector from the engine harness.

Action

Check the exhaust gas temperature sensor signal and return circuit.

  • Measure the resistance from the engine harness ECM connector sensor SIGNAL pin to the exhaust gas temperature sensor SIGNAL pin.
  • Measure the resistance from the engine harness ECM connector sensor RETURN pin to the exhaust gas temperature sensor RETURN pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Verify the exhaust gas temperature bank 1 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature bank 1 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool. Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature bank 1 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature sensor reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature bank 1 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the air handling system.

Guided Step 3A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table?
YES NO
No Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications found in Procedure 010-031 in the Associated Procedures Table?
YES NO
No Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following:

  • Bent, damaged, or missing fins.

Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Replace any malfunctioning seals or damaged components. See the appropriate procedures in Sections 10 and 11 of the service manual.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 2727 - SAE J1939 Data Link 2 Engine Network - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2727 active?
 | STEP 1B. Check for related fault codes. | Fault Code 3329 active?
STEP 2. | Check the secondary engine control module (ECM) supply voltage circuits. |
 | STEP 2A. Inspect the ECM and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for correct ECM supply voltage. | Voltage between 21 and 27 VDC?
 | STEP 2C. Check the keyswitch signal circuit. | Less than 5 ohms?
STEP 3. | Check the Society of Automotive Engineers (SAE) J1939 data link 2 circuit. |
 | STEP 3A. Inspect all engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the SAE J1939 data link 2 resistance in the engine harness. | Between 50 and 70 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2727 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3329 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the secondary ECM supply voltage circuits.

Guided Step 2A - Inspect the ECM and OEM harness connector pins.

Conditions

Perform this check on ECM 2, 3 and 4.

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for correct ECM supply voltage.

Conditions

Perform this check on ECM 2, 3 and 4.

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for correct ECM supply voltage.

  • Measure the voltage between the battery voltage SUPPLY pins and battery voltage RETURN pins in the OEM harness connector.

Refer to the wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Voltage between 21 and 27 VDC ?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Repair or replace the damaged section of the harness.

  • Use the following procedure for engine harness repair. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the keyswitch signal circuit.

Conditions

Perform this check on ECM 2, 3 and 4.

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the 16-pin power connector.

Action

Check for an open keyswitch signal circuit.

  • Measure the resistance of the keyswitch SIGNAL wire between the 16-pin power connector and the OEM harness connector at the ECM.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Repair or replace the damaged section of the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the SAE J1939 data link 2 circuit.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

Perform this check on each ECM.

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the SAE J1939 data link 2 resistance in the engine harness.

Conditions

Perform this check on each ECM.

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM .

Action

Check the SAE J1939 data link 2 resistance.

  • Measure the resistance between the SAE J1939 data link 2 SUPPLY pin and the SAE J1939 data link 2 RETURN pin in the ECM engine harness connector.

Refer to the wiring diagram for connector pin for identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 50 and 70 ohms?
YES NO

The SAE J1939 data link 2 resistance is within specification.

There may be a problem with the ECM calibrations.

Check to make sure the appropriate calibrations are installed in the ECMs.

An open or shorted engine SAE J1939 data link 2 circuit has been detected in the engine harness

Troubleshoot each harness connected in series to determine which one contains the open or short circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 06-Apr-2016


FAULT CODE 2771 - Aftertreatment 1 Outlet NOx Sensor - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Aftertreatment Sensor Power Relay | Refer to Procedure 019-607 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes | Fault Code 2771 active?
 | STEP 1B. Check for active J1939 Network #4 fault codes. | Fault Code 4437 active?
 | STEP 1C. Check for active outlet Nox sensor fault codes. | Fault Code 3681 active?
 | STEP 1D. Check for active intake Nox sensor or selective catalytic reduction (SCR) temperature sensor fault codes. | Fault Code 3232 and 4152 active?
STEP 2. | Check the aftertreatment 1 outlet NOx sensor circuit. |
 | STEP 2A. Inspect the aftertreatment 1 outlet NOx sensor and connector pins. | Damaged or dirty pins?
 | STEP 2B. Check the voltage to the aftertreatment 1 outlet NOx sensor. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 2C. Check the J1939 terminating resistance. | 50 to 70 ohms?
 | STEP 2D. Check for an open circuit in the aftertreatment 1 outlet NOx sensor ECM power supply voltage supply. | Voltage within 1 VDC of ECM power supply voltage?
STEP 3. | Check the harness. |
 | STEP 3A. Inspect the aftertreatment 1 outlet NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the voltage to the aftertreatment 1outlet NOx sensor. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3C. Check the voltage to the aftertreatment 1 outlet NOx sensor. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3D. Inspect aftertreatment power relay and connector pins. | Dirty or damaged pins?
 | STEP 3E. Check the voltage to the aftertreatment power relay. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3F. Check the aftertreatment power relay. | Connections tight and corrosion-free?
STEP 4. | Check the J1939 data link 4. |
 | STEP 4A. Check the J1939 terminating resistance on the original equipment manufacturer (OEM) harness. | 110 to 130 ohms?
 | STEP 4B. Check the J1939 terminating resistance on the engine harness. | 110 to 130 ohms?
 | STEP 4C. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 4D. Check for an open circuit in the J1939 data link harness. | All measurements less than 10 ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2771 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active J1939 Network #4 fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4437 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for active outlet Nox sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3681 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1D

Guided Step 1D - Check for active intake Nox sensor or selective catalytic reduction (SCR) temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3232 and 4152 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the aftertreatment 1 outlet NOx sensor circuit.

Guided Step 2A - Inspect the aftertreatment 1 outlet NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 outlet NOx sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment 1 outlet NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged OEM harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

Replace the aftertreatment outlet NOx sensor only when there are damaged pins. Refer to Procedure 019-451 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment 1 outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment 1 outlet NOx sensor.

  • Measure the voltage between the aftertreatment 1 outlet NOx sensor ECM power supply voltage supply circuit and the aftertreatment outlet NOx sensor return circuit at the NOx sensor wiring harness connector.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of ECM power supply voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2D

Guided Step 2C - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 outlet NOx sensor from the OEM harness.

Action

Measure the terminating resistance of the Society of Automotive Engineers (SAE) J1939 data link.

  • Measure the resistance between the SAE J1939 data link (+) wire and the J1939 data link (-) wire at the aftertreatment 1 outlet NOx sensor OEM harness connector.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 to 70 ohms?
YES NO

Replace the aftertreatment 1 outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

An open circuit has been detected on the SAE J1939 data link (+) or (-) wire between the outlet NOx sensor and the data link backbone connection.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 5A

Guided Step 2D - Check for an open circuit in the aftertreatment 1 outlet NOx sensor ECM power supply voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure the voltage from the aftertreatment 1 outlet NOx sensor ECM power supply voltage SUPPLY pin of the OEM harness to ECM power supply ground.

Voltage within 1 VDC of ECM power supply voltage?
YES NO

An open circuit has been detected in the aftertreatment 1 outlet NOx sensor ECM power supply voltage return circuit.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.
  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

An open circuit has been detected in the aftertreatment 1 outlet NOx sensor ECM power supply voltage supply circuit between the aftertreatment 1 power relay and the outlet NOx sensor.

Check for a blown or missing fuse in the aftertreatment 1 outlet NOx sensor ECM power supply voltage supply circuit.

Troubleshoot all harnesses connected in series to determine which one contains the open. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness. Refer to Procedure 019-071 in Section 19.
  • For the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 3 - Check the harness.

Guided Step 3A - Inspect the aftertreatment 1 outlet NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 outlet NOx sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment 1 outlet NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged OEM harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

Replace the aftertreatment outlet NOx sensor only when there are damaged pins. Refer to Procedure 019-451 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the voltage to the aftertreatment 1 outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment 1 outlet NOx sensor.

  • Measure the voltage between the aftertreatment 1 outlet NOx sensor ECM power supply voltage supply circuit and the aftertreatment outlet NOx sensor return circuit at the NOx sensor wiring harness connector.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of ECM power supply voltage?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the voltage to the aftertreatment 1 outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment 1 outlet NOx sensor.

  • Measure the voltage from the aftertreatment 1 outlet NOx sensor ECM power supply voltage SUPPLY pin of the OEM harness outlet NOx sensor connector to ECM power supply ground.

Voltage is within 1 VDC of ECM power supply voltage?
YES NO

An open circuit has been detected in the aftertreatment outlet NOx sensor ECM power supply voltage return circuit.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.
  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3D

Guided Step 3D - Inspect aftertreatment power relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.

Action

Inspect the engine harness and aftertreatment power relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the relay or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace aftertreatment power relay only when there are damaged pins. Refer to Procedure 019-607 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3E

Guided Step 3E - Check the voltage to the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment power relay.

  • Measure the voltage between the aftertreatment power relay ECM power supply voltage SUPPLY pin in the aftertreatment power relay connector of the engine harness and ECM power supply ground.

Voltage is within 1 VDC of ECM power supply voltage?
YES NO
No Repair

An open circuit has been detected in the aftertreatment power ECM power supply voltage supply circuit before the power relay.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.
  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 5A

Guided Step 3F - Check the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.

Action

Check for a damaged aftertreatment power relay.

  • Install a jumper wire from pin 85 on the aftertreatment power relay to ECM power supply + and connect a jumper wire from pin 86 on the aftertreatment power relay to ECM power supply ground.
  • Measure the resistance between pin 30 and pin 87 on the aftertreatment power relay.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Connections tight and corrosion-free?
YES NO
No Repair

An open circuit or short circuit to ECM power supply ground has been detected in the aftertreatment outlet NOx sensor power supply circuit.

This could be caused by:

  • Blown in-line fuse on the outlet NOx sensor power supply circuit.
  • Open circuit or short to ECM power supply ground in the outlet NOx sensor power supply circuit.

Replace the inline fuse, if it is blown out.

Troubleshoot all harnesses connected in series to determine which one contains the open or shorted circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.
  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Check the J1939 data link 4.

Guided Step 4A - Check the J1939 terminating resistance on the original equipment manufacturer (OEM) harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness at the 47 pin aftertreatment 1 connector.

Action

Measure the terminating resistance of the SAE J1939 data link 4.

  • Measure the resistance between the SAE J1939 data link 4 (+) wire and the J1939 data link 4 (-) wire at the 47 pin aftertreatment 1 OEM harness connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

110 to 130 ohms?
YES NO
No Repair

Incorrect terminating resistance or an open circuit has been detected on the SAE J1939 data link 4 circuit in the OEM harness.

  • Remove excess terminating resistors. Replace any damaged or missing terminating resistor.

Troubleshoot all harnesses connected in series to determine which one contains the open or shorted circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the damaged section of the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check the J1939 terminating resistance on the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness at the 47 pin aftertreatment 1 connector.

Action

Measure the terminating resistance of the SAE J1939 data link 4.

  • Measure the resistance between the SAE J1939 data link 4 (+) wire and the J1939 data link 4 (-) wire at the engine side 47 pin aftertreatment 1 connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

110 to 130 ohms?
YES NO
No Repair

Incorrect terminating resistance or an open circuit has been detected on the SAE J1939 data link 4 circuit in the engine harness.

  • Remove excess terminating resistors. Replace any damaged or missing terminating resistor.
  • Troubleshoot all harnesses connected in series to determine which one contains the open circuit.
  • Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the OEM and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace ECM only when there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 4D

Guided Step 4D - Check for an open circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness and engine harness at the 47 pin aftertreatment 1 connector.
  • Disconnect the OEM connector from the ECM.

Action

Check for an open circuit in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link 4 (+) wire at the engine harness 47 pin aftertreatment 1 connector and the SAE J1939 data link 4 (+) wire at the ECM OEM connector. Measure the resistance between the SAE J1939 data link 4 (−) wire at the engine harness 47 pin aftertreatment 1 connector and the SAE J1939 data link 4 (−) wire at the ECM OEM connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

All measurements less than 10 ohms?
YES NO

An open circuit has been detected in the J1939 data link 4.

Troubleshoot all harnesses connected in series to determine which one contains the open or shorted circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 19-May-2016


FAULT CODE 2963 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor coolant temperature reading. |
 | STEP 1A. Monitor coolant temperature reading . | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or an infrared thermometer?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor coolant temperature reading.

Guided Step 1A - Monitor coolant temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the coolant temperature reading.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a an infrared thermometer or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or an infrared thermometer?
YES NO

Reference the Engine Coolant Temperature Above Normal troubleshooting symptom tree in Section TS.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Appropriate troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 02-May-2016


FAULT CODE 3142 - Aftertreatment 1 SCR Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active selective catalytic reduction (SCR) temperature sensor fault codes. | Fault Code 4152, 4164, 4165, 4166, or 4261 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active selective catalytic reduction (SCR) temperature sensor fault codes.

Conditions

  • Turn keyswitch ON

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4152, 4164, 4165, 4166, or 4261 active?
YES NO
No Repair

A malfunctioning aftertreatment SCR temperature sensor module has been detected.

Replace the aftertreatment SCR temperature sensor module. Refer to procedure 019-449 in the Associated Procedures Table.

Go to appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 13-Apr-2016


FAULT CODE 3143 - Aftertreatment 1 SCR Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active selective catalytic reduction (SCR) temperature sensor fault codes. | Fault Code 4152, 4164, 4165, 4166, or 4261 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active selective catalytic reduction (SCR) temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4152, 4164, 4165, 4166, or 4261 active?
YES NO
No Repair

A malfunctioning aftertreatment 1 SCR temperature sensor module has been detected.

Replace the aftertreatment SCR temperature sensor module. Refer to procedure 019-449 in the Associated Procedures Table.

Go to appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 13-Apr-2016


FAULT CODE 3144 - Aftertreatment 1 SCR Intake Temperature Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active selective catalytic reduction (SCR) temperature sensor fault codes. | Fault Code 4152, 4164, 4165, 4166, or 4261 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active selective catalytic reduction (SCR) temperature sensor fault codes.

Conditions

  • Turn keyswitch ON

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4152, 4164, 4165, 4166, or 4261 active?
YES NO
No Repair

A malfunctioning aftertreatment 1 SCR temperature sensor module has been detected.

Replace the aftertreatment 1 SCR temperature sensor module. Refer to procedure 019-449 in the Associated Procedures Table.

Go to appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 13-Apr-2016


FAULT CODE 3146 - Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active selective catalytic reduction (SCR) temperature sensor fault codes. | Fault Codes 4152, 4164, 4165, 4166, or 4261 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active selective catalytic reduction (SCR) temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 4152, 4164, 4165, 4166, or 4261 active?
YES NO
No Repair

A malfunctioning aftertreatment 1 SCR temperature sensor module has been detected.

Replace the aftertreatment 1 SCR temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Go to appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 13-Apr-2016


FAULT CODE 3147 - Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active selective catalytic reduction (SCR)fault codes. | Fault Code 4152, 4164, 4165, 4166, or 4261 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active selective catalytic reduction (SCR)fault codes.

Conditions

  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 4152, 4164, 4165, 4166, or 4261 active?
YES NO
No Repair

A malfunctioning aftertreatment 1 SCR temperature sensor module has been detected.

Replace the aftertreatment 1 SCR temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Go to appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 13-Apr-2016


FAULT CODE 3148 - Aftertreatment 1 SCR Outlet Temperature Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Servcie Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active selective catalytic reduction (SCR) temperature sensor fault codes. | Fault Code 4152, 4164, 4165, 4166, or 4261 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active selective catalytic reduction (SCR) temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4152, 4164, 4165, 4166, or 4261 active?
YES NO
No Repair

A malfunctioning aftertreatment 1 SCR temperature sensor module has been detected.

  • Replace the aftertreatment 1 SCR temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 12-Apr-2016


FAULT CODE 3151 - Aftertreatment 1 SCR Catalyst System Missing - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSK95 CM2350 K113 | 4388663
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid System Leak Test | Refer to Procedure 011-080 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3151 active?
 | STEP 1B. Check for active aftertreatment 1 nitrogen oxides (NOx) sensor fault codes. | Fault Codes 1885, 1887, 2771, 3232, 3545, 3545, 3583, 3649, 3681, 3682, 3718, 3725, 3726, 3748 active?
 | STEP 1C. Check for active aftertreatment 1 selective catalytic reduction (SCR) temperature sensor fault codes. | Fault Codes 3142, 3143, 3144, 3146, 3147, 3148, 3164, 3165, 3229, 3231, 3235, 4152, 4159, 4164, 4166, 4261 active?
 | STEP 1D. Check for active diesel exhaust fluid (DEF) aftertreatment 1 dosing system fault codes. | Fault Codes 3559, 3567, 3568,3571, 3572, 3573, 3574, 3575, 3596, 4174, 4175, 4244, 5748, 5749, 5751, 5752, 5753, 5754, 5757,5758, 5759, 5794, 5795, 5796, 5797, 5798, 5799, 5814, 5815, 5816, 5817, 5818, 5819, 6379, 6382, 6384, 3558 active?
STEP 2. | Check the DEF dosing system and catalyst. |
 | STEP 2A. Check the exhaust system and aftertreatment 1. | Aftertreatment 1 SCR catalyst missing or not connected to the exhaust system properly?
 | STEP 2B. Check the DEF quality. | DEF free from contamination and within the specifications outlined in Procedure 011-056?
 | STEP 2C. Check the aftertreatment 1 DEF dosing valves for leaks. | DEF leaking from the aftertreatment 1 DEF dosing valve(s) during the system leak test?
 | STEP 2D. Check the aftertreatment 1 DEF dosing system operation. | Dosing volume within the specifications in Procedure 011-063 and DEF spray pattern correct for each of the three dosing systems?
 | STEP 2E. Check for deposits in the aftertreatment 1 decomposition chamber. | Excessive DEF deposits found inside the aftertreatment 1 decomposition chamber?
STEP 3. | Check the aftertreatment 1 NOx sensors. |
 | STEP 3A. Check the aftertreatment 1 NOx sensor readings. | Are the aftertreatment 1 NOx sensor readings within specifications found in Procedure 014-013?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3151 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for active aftertreatment 1 NOx sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1885, 1887, 2771, 3232, 3545, 3545, 3583, 3649, 3681, 3682, 3718, 3725, 3726, 3748 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for active aftertreatment 1 SCR temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3142, 3143, 3144, 3146, 3147, 3148, 3164, 3165, 3229, 3231, 3235, 4152, 4159, 4164, 4166, 4261 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1D

Guided Step 1D - Check for active DEF aftertreatment 1 dosing system fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes relating to the aftertreatment 1 DEF dosing system.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3559, 3567, 3568,3571, 3572, 3573, 3574, 3575, 3596, 4174, 4175, 4244, 5748, 5749, 5751, 5752, 5753, 5754, 5757,5758, 5759, 5794, 5795, 5796, 5797, 5798, 5799, 5814, 5815, 5816, 5817, 5818, 5819, 6379, 6382, 6384, 3558 active?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the DEF dosing system and catalyst.

Guided Step 2A - Check the exhaust system and aftertreatment 1.

Conditions

  • Turn keyswitch OFF.

Action

Check the exhaust system and aftertreatment 1 SCR catalyst for damaged or missing components.

  • Check to make sure the aftertreatment 1 SCR catalyst is not missing and that it is connected properly. Refer to Procedure 011-036 in the Associated Procedures Table.
  • Inspect the entire aftertreatment 1 exhaust system between the turbocharger outlet and the SCR outlet. Inspect for loose connections, leaking connections, and broken exhaust system components.

Aftertreatment 1 SCR catalyst missing or not connected to the exhaust system properly?

YES NO

Replace the missing SCR catalyst. Refer to Procedure 011-036 in the Associated Procedures Table.

Repair or replace any damaged, missing, or misconnected exhaust piping.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the DEF quality.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF quality.

  • Use the DEF Refractometer, Part Number 4919554, to test the DEF concentration. Refer to Procedure 011-056 in the Associated Procedures Table.

DEF free from contamination and within the specifications outlined in Procedure 011-056?

YES NO
No Repair

The fluid in the DEF tank is not pure DEF, or the DEF is diluted or degraded.

Completely drain the DEF tank and rinse the tank with water.

Fill the DEF tank with pure DEF.

Refer to Procedure 011-056 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the aftertreatment 1 DEF dosing valves for leaks.

Conditions

  • Connect all DEF lines and electrical connectors.
  • Remove the aftertreatment 1 DEF dosing valves from the decomposition chamber.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Inspect the DEF dosing valve(s) for a leaking nozzle(s).

  • Use INSITE™ electronic service tool to perform the DEF System Leak Test found under ECM Diagnostic Tests. Refer to Procedure 011-080 in the Associated Procedures Table.

DEF leaking from the aftertreatment 1 DEF dosing valve(s) during the system leak test?
YES NO

A leaking aftertreatment 1 DEF dosing valve(s) has been detected.

Replace the aftertreatment 1 DEF dosing valve or valves affected. Refer to Procedure 011-059 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check the aftertreatment 1 DEF dosing system operation.

Conditions

  • Remove the aftertreatment 1 DEF dosing valve(s) from the decomposition chamber.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the DEF Doser Pump Override Test found under ECM Diagnostic Tests for each of the three dosing systems.

  • Use the following procedure for instructions and specifications. Refer to Procedure 011-063 in the Associated Procedures Table.
  • Make sure the DEF dosing valve(s) is not plugged and the spray pattern is correct.

Each DEF dosing valve must be removed and placed in a measuring container in order to perform the DEF Doser Pump Override Test.

Dosing volume within the specifications in Procedure 011-063 in the Associated Procedures Table and DEF spray pattern correct for each of the three dosing systems?

YES NO
No Repair

Replace the aftertreatment DEF dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Check for deposits in the aftertreatment 1 decomposition chamber.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the aftertreatment 1 decomposition chamber for deposits.

  • Remove the inspection cover from the aftertreatment 1 SCR catalyst.
  • Inspect for DEF deposits. Refer to Procedure 011-036 in the Associated Procedures Table.

Excessive DEF deposits found inside the aftertreatment 1 decomposition chamber?
YES NO

Clean the decomposition chamber. Refer to Procedure 011-036 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the aftertreatment 1 NOx sensors.

Guided Step 3A - Check the aftertreatment 1 NOx sensor readings.

Conditions

  • Turn keyswitch ON.

Action

Perform the Aftertreatment NOx Sensor Rationality Test.

Refer to Procedure 019-451 in the Associated Procedures Table.

Are the aftertreatment 1 NOx sensor readings within the specifications found in Procedure 019-451?
YES NO

Replace the aftertreatment SCR catalyst. Refer to Procedure 011-036 in the Associated Procedures Table.

Replace the aftertreatment intake and outlet NOx sensors.

  • Use the following procedure for the intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.
  • Use the following procedure for the outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 13-Apr-2016


FAULT CODE 3164 - Aftertreatment 1 SCR Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Turbocharger Turbine Seal Leaks | Refer to Procedure 010-049 | QSK95 CM2350 K113 | 4388663
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active selective catalytic reduction (SCR) temperature sensor fault codes. | Fault Code 4152, 4159, 4164, 4165, or 4261 active or inactive counts?
STEP 2. | Check the diesel exhaust fluid (DEF) for contamination. |
 | STEP 2A. Check the DEF for contamination. | DEF contaminated?
STEP 3. | Check the fuel system. |
 | STEP 3A. Check for an injector misfire. | Engine misfire detected?
STEP 4. | Check the turbine outlet. |
 | STEP 4A. Inspect the turbine outlet for oil or fuel. | Engine oil or fuel contamination found in the turbine outlet?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active selective catalytic reduction (SCR) temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4152, 4159, 4164, 4165, or 4261 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the diesel exhaust fluid (DEF) for contamination.

Guided Step 2A - Check the DEF for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF for contamination.

  • Refer to Procedure 011-056 in the Associated Procedures Table.

DEF contaminated?
YES NO

Drain the DEF tank and follow the appropriate steps in the service manual. Refer to Procedure 011-056 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the fuel system.

Guided Step 3A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is operating at low idle.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to check for a cylinder misfire.

Engine misfire detected?
YES NO
No Repair

Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector. Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 4A

Guided Step 4 - Check the turbine outlet.

Guided Step 4A - Inspect the turbine outlet for oil or fuel.

Conditions

  • Remove the turbine outlet bellows one at a time.

Action

Check for signs of moisture in the turbine outlet. Be sure to inspect all 4.

  • Inspect the turbine outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine. Refer to Procedure 010-049 in the Associated Procedures Table.

Engine oil or fuel contamination found in the turbine outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 12-Apr-2016


FAULT CODE 3165 - Aftertreatment 1 SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Turbocharger Turbine Seal Leaks | Refer to Procedure 010-049 | QSK95 CM2350 K113 | 4388663
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active selective catalytic reduction (SCR) temperature sensor fault codes. | Fault Code 4152, 4159, 4164, 4165, or 4261 active or inactive counts?
STEP 2. | Check the diesel exhaust fluid (DEF) for contamination. |
 | STEP 2A. Check the DEF for contamination. | DEF contaminated?
STEP 3. | Check the fuel system. |
 | STEP 3A. Check for an injector misfire. | Engine misfire detected?
STEP 4. | Check the turbine outlet. |
 | STEP 4A. Inspect the turbine outlet for oil or fuel. | Engine oil or fuel contamination found in the turbine outlet?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active selective catalytic reduction (SCR) temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4152, 4159, 4164, 4165, or 4261 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the diesel exhaust fluid (DEF) for contamination.

Guided Step 2A - Check the DEF for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF for contamination.

  • Refer to Procedure 011-056 in the Associated Procedures Table.

DEF contaminated?
YES NO

Drain the DEF tank and follow the appropriate steps in the service manual. Refer to Procedure 011-056 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the fuel system.

Guided Step 3A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is operating at low idle.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to check for a cylinder misfire.

Engine misfire detected?
YES NO
No Repair

Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector. Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 4A

Guided Step 4 - Check the turbine outlet.

Guided Step 4A - Inspect the turbine outlet for oil or fuel.

Conditions

  • Remove the turbine outlet bellows one at a time.

Action

Check for signs of moisture in the turbine outlet. Be sure to inspect all 4.

  • Inspect the turbine outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine. Refer to Procedure 010-049 in the Associated Procedures Table.

Engine oil or fuel contamination found in the turbine outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 3229 - Aftertreatment 1 SCR Intake Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Turbocharger Turbine Seal Leaks | Refer to Procedure 010-049 | QSK95 CM2350 K113 | 4388663
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active selective catalytic reduction (SCR) temperature sensor fault codes. | Fault Code 4152, 4159, 4164, 4165, or 4261 active or inactive counts?
STEP 2. | Check the diesel exhaust fluid (DEF) for contamination. |
 | STEP 2A. Check the DEF for contamination. | DEF contaminated?
STEP 3. | Check the fuel system. |
 | STEP 3A. Check for an injector misfire. | Engine misfire detected?
STEP 4. | Check the turbine outlet. |
 | STEP 4A. Inspect the turbine exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active selective catalytic reduction (SCR) temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4152, 4159, 4164, 4165, or 4261 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the diesel exhaust fluid (DEF) for contamination.

Guided Step 2A - Check the DEF for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF for contamination.

  • Refer to Procedure 011-056 in the Associated Procedures Table.

DEF contaminated?
YES NO

Drain the DEF tank. Refer to Procedure 011-056 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the fuel system.

Guided Step 3A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is operating at low idle.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to check for a cylinder misfire.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

  • Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the turbine outlet.

Guided Step 4A - Inspect the turbine outlet for oil or fuel.

Conditions

  • Remove the turbine outlet bellows one at a time.

Action

Check for signs of moisture in the turbine outlet. Be sure to inspect all four.

  • Inspect the turbine outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine. Refer to Procedure 010-049 in the Associated Procedures Table.

Engine oil or fuel contamination found in the turbine outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 3231 - Aftertreatment 1 SCR Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Turbocharger Turbine Seal Leaks | Refer to Procedure 010-049 | QSK95 CM2350 K113 | 4388663
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSK95 CM2350 K113 | 4388663
Turbocharger Turbine Outlet Bellows | Refer to Procedure 011-116 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active selective catalytic reduction (SCR) temperature sensor fault codes. | Fault Codes 4152, 4159, 4164, 4165, or 4261 active or inactive counts?
STEP 2. | Check the diesel exhaust fluid (DEF) for contamination. |
 | STEP 2A. Check the DEF for contamination. | DEF contaminated?
STEP 3. | Check the fuel system. |
 | STEP 3A. Check for an injector misfire. | Engine misfire detected?
STEP 4. | Check the turbine outlet. |
 | STEP 4A. Inspect the turbine outlet for oil or fuel. | Engine oil or fuel contamination found in the turbine outlet?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active SCR temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 4152, 4159, 4164, 4165, or 4261 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the DEF for contamination.

Guided Step 2A - Check the DEF for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF for contamination.

  • Refer to Procedure 011-056 in the Associated Procedures Table.

DEF contaminated?
YES NO

Drain the DEF tank. Refer to Procedure 011-056 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the fuel system.

Guided Step 3A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is operating at low idle.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to check for a cylinder misfire.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

  • Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the turbine outlet.

Guided Step 4A - Inspect the turbine outlet for oil or fuel.

Conditions

  • Remove the turbine outlet bellows one at a time. Refer to Procedure 011-116 in the Associated Procedures Table.

Action

Look for signs of moisture in the turbine outlet. Make sure to inspect all four.

  • Inspect the turbine outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine. Refer to Procedure 010-049 in the Associated Procedures Table.

Engine oil or fuel contamination found in the turbine outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 3232- Aftertreatment 1 Intake NOx Sensor - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK95 CM2350 K113 | 4388663
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Aftertreatment Sensor Power Relay | Refer to Procedure 019-607 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes | Fault Code 3232 active?
 | STEP 1B. Check for active intake NOx sensor fault codes. | Fault Code 3682 or 3718 active?
 | STEP 1C. Check for active outlet NOx sensor or selective catalytic reduction (SCR) temperature sensor fault codes. | Fault Codes 2771 and 4152 are both active?
STEP 2. | Check the aftertreatment 1 intake NOx sensor circuit. |
 | STEP 2A. Inspect aftertreatment 1 intake NOx sensor and connector pins. | Damaged or dirty pins?
 | STEP 2B. Check the voltage to the aftertreatment 1 intake NOx sensor. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 2C. Check the J1939 terminating resistance. | 50 to 70 ohms?
 | STEP 2D. Check for an open circuit in the aftertreatment 1 intake NOx sensor ECM power supply voltage supply. | Voltage within 1 VDC of ECM power supply voltage?
STEP 3. | Check the harness. |
 | STEP 3A. Inspect the aftertreatment 1 intake NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the voltage to the aftertreatment 1 intake NOx sensor. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3C. Check the voltage to the aftertreatment 1 intake NOx sensor. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3D. Inspect aftertreatment power relay and connector pins. | Dirty or damaged pins?
 | STEP 3E. Check the voltage to the aftertreatment power relay. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3F. Check the aftertreatment power relay. | Less than 10 ohms?
STEP 4. | Check the J1939 data link 4. |
 | STEP 4A. Check the J1939 terminating resistance on the original equipment manufacturer (OEM) harness. | 110 to 130 ohms?
 | STEP 4B. Check the J1939 terminating resistance on the engine harness. | 110 to 130 ohms?
 | STEP 4C. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 4D. Check for an open circuit in the J1939 data link harness. | All measurements less than 10 ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3232 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active intake NOx sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3682 or 3718 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for active outlet NOx sensor or selective catalytic reduction (SCR) temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2771 and 4152 are both active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the aftertreatment 1 intake NOx sensor circuit.

Guided Step 2A - Inspect the aftertreatment 1 intake NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 intake NOx sensor from the engine harness.

Action

Inspect the OEM harness and aftertreatment 1 intake NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged OEM harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the aftertreatment intake NOx sensor only when there are damaged pins. Refer to Procedure 019-463 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment 1 intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 intake NOx sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment 1 intake NOx sensor.

  • Measure the voltage between the aftertreatment 1 intake NOx sensor ECM power supply voltage supply circuit and the aftertreatment intake NOx sensor return circuit at the NOx sensor engine wiring harness connector.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of ECM power supply voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2D

Guided Step 2C - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 intake NOx sensor from the engine harness.

Action

Measure the terminating resistance of the Society of Automotive Engineers (SAE) J1939 data link.

  • Measure the resistance between the SAE J1939 data link (+) wire and the J1939 data link (-) wire at the aftertreatment 1 intake NOx sensor engine harness connector.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 to 70 ohms?
YES NO

Replace the aftertreatment 1 intake NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

An open circuit has been detected on the SAE J1939 data link (+) or (-) wire between the intake NOx sensor and the data link backbone connection.

Repair or replace the OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 2D - Check for an open circuit in the aftertreatment 1 intake NOx sensor ECM power supply voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure the voltage from the aftertreatment 1 intake NOx sensor ECM power supply voltage SUPPLY pin of the engine harness to ECM power supply ground.

Voltage within 1 VDC of ECM power supply voltage?
YES NO

An open circuit has been detected in the aftertreatment 1 intake NOx sensor ECM power supply voltage return circuit.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

  • Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

An open circuit has been detected in the aftertreatment 1 intake NOx sensor ECM power supply voltage supply circuit between the aftertreatment 1 power relay and the intake NOx sensor.

Check for a blown or missing fuse in the aftertreatment 1 intake NOx sensor battery voltage supply circuit. Troubleshoot all harnesses connected in series to determine which one contains the open. Repair or replace the damaged component(s), as necessary. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 3 - Check the harness.

Guided Step 3A - Inspect the aftertreatment 1 intake NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 intake NOx sensor from the engine harness.

Action

Inspect the engine harness and aftertreatment 1 intake NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the aftertreatment intake NOx sensor only when there are damaged pins. Refer to Procedure 019-463 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the voltage to the aftertreatment 1 intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 intake NOx sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment 1 intake NOx sensor.

  • Measure the voltage between the aftertreatment 1 intake NOx sensor ECM power supply voltage supply circuit and the aftertreatment 1 intake NOx sensor ECM power supply voltage return circuit at the aftertreatment 1 intake NOx sensor engine wiring harness connector.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of ECM power supply voltage?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the voltage to the aftertreatment 1 intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 intake NOx sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment 1 intake NOx sensor.

  • Measure the voltage from the aftertreatment 1 intake NOx sensor ECM power supply voltage SUPPLY pin of the OEM harness connector to ECM power supply ground.

Voltage is within 1 VDC of ECM power supply voltage?
YES NO

An open circuit has been detected in the aftertreatment 1 intake NOx sensor ECM power supply voltage return circuit.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

  • Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3D

Guided Step 3D - Inspect aftertreatment power relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.

Action

Inspect the engine harness and aftertreatment power relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the relay or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace aftertreatment power relay only when there are damaged pins. Refer to Procedure 019-607 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3E

Guided Step 3E - Check the voltage to the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment power relay.

  • Measure the voltage between the aftertreatment power relay ECM power supply voltage SUPPLY pin in the aftertreatment power relay connector of the engine harness and ECM power supply ground.

Voltage is within 1 VDC of ECM power supply voltage?
YES NO
No Repair

An open circuit has been detected in the aftertreatment power ECM power supply voltage supply circuit before the power relay.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 5A

Guided Step 3F - Check the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.

Action

Check for a damaged aftertreatment power relay.

  • Install a jumper wire from pin 85 on the aftertreatment power relay to ECM power supply + and connect a jumper wire from pin 86 on the aftertreatment power relay to ECM power supply ground.
  • Measure the resistance between pin 30 and pin 87 on the aftertreatment power relay.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

An open circuit or short circuit to ECM power supply ground has been detected in the aftertreatment intake NOx sensor power supply circuit.

This could be caused by:

  • Blown in-line fuse on the intake NOx sensor power supply circuit.
  • Open circuit or short to ECM power supply ground in the intake NOx sensor power supply circuit.

Replace the inline fuse, if it is blown.

Troubleshoot all harnesses connected in series to determine which one contains the open or shorted circuit.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the aftertreatment power relay.

Go to 5A

Go to 5A

Guided Step 4 - Check the J1939 data link 4.

Guided Step 4A - Check the J1939 terminating resistance on the original equipment manufacturer (OEM) harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness at the 47 pin aftertreatment 1 connector.

Action

Measure the terminating resistance of the SAE J1939 data link 4.

  • Measure the resistance between the SAE J1939 data link 4 (+) wire and the J1939 data link 4 (-) wire at the 47 pin aftertreatment 1 OEM harness connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

110 to 130 ohms?
YES NO
No Repair

Incorrect terminating resistance or an open circuit has been detected on the SAE J1939 data link 4 circuit in the OEM harness.

  • Remove excess terminating resistors. Replace any damaged or missing terminating resistor.

Troubleshoot all harnesses connected in series to determine which one contains the open or shorted circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the damaged section of the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check the J1939 terminating resistance on the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness at the 47 pin aftertreatment 1 connector.

Action

Measure the terminating resistance of the SAE J1939 data link 4.

  • Measure the resistance between the SAE J1939 data link 4 (+) wire and the J1939 data link 4 (-) wire at the engine side 47 pin aftertreatment 1 connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

110 to 130 ohms?
YES NO
No Repair

Incorrect terminating resistance or an open circuit has been detected on the SAE J1939 data link 4 circuit in the engine harness.

  • Remove excess terminating resistors. Replace any damaged or missing terminating resistor.
  • Troubleshoot all harnesses connected in series to determine which one contains the open circuit.
  • Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Inspect ECM and OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the OEM and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace ECM only when there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 4D

Guided Step 4D - Check for an open circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness and engine harness at the 47 pin aftertreatment 1 connector.
  • Disconnect the OEM connector from the ECM.

Action

Check for an open circuit in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link 4 (+) wire at the engine harness 47 pin aftertreatment 1 connector and the SAE J1939 data link 4 (+) wire at the ECM OEM connector.
  • Measure the resistance between the SAE J1939 data link 4 (−) wire at the engine harness 47 pin aftertreatment 1 connector and the SAE J1939 data link 4 (−) wire at the ECM OEM connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

All measurements less than 10 ohms?
YES NO

An open circuit has been detected in the J1939 data link 4.

Troubleshoot all harnesses connected in series to determine which one contains the open or shorted circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 3235 - Aftertreatment 1 SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Turbocharger Turbine Seal Leaks | Refer to Procedure 010-049 | QSK95 CM2350 K113 | 4388663
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active selective catalytic reduction (SCR) temperature sensor fault codes. | Fault Code 4152, 4159, 4164, 4165, or 4261 active or inactive counts?
STEP 2. | Check the diesel exhaust fluid (DEF) for contamination. |
 | STEP 2A. Check the DEF for contamination. | DEF contaminated?
STEP 3. | Check the fuel system. |
 | STEP 3A. Check for an injector misfire. | Engine misfire detected?
STEP 4. | Check the turbocharger outlet. |
 | STEP 4A. Inspect the turbine outlet. | Engine oil or fuel contamination found in the turbine outlet?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active selective catalytic reduction (SCR) temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4152, 4159, 4164, 4165, or 4261 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the diesel exhaust fluid (DEF) for contamination.

Guided Step 2A - Check the DEF for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF for contamination.

  • Refer to Procedure 011-056 in the Associated Procedures Table.

DEF contaminated?
YES NO

Drain the DEF tank. Refer to Procedure 011-056 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the fuel system.

Guided Step 3A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is operating at low idle.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to check for a cylinder misfire.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

  • Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the turbine outlet.

Guided Step 4A - Inspect the turbine outlet for oil or fuel.

Conditions

  • Remove the turbine outlet bellows one at a time.

Action

Check for signs of moisture in the turbine outlet. Be sure to inspect all four outlets.

  • Inspect the turbine outlets for signs of oil or fuel being introduced into the aftertreatment system from the engine. Refer to Procedure 010-049 in the Associated Procedures Table.

Engine oil or fuel contamination found in the turbine outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 3242 - Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1677, 1678, 1679, 1683, 1684, 4168, or 4169 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) tank heating system. |
 | STEP 2A. Inspect the DEF tank heater coolant lines. | Leaks or damage found in tank heater coolant plumbing?
STEP 3. | Check the aftertreatment DEF tank heater operation. |
 | STEP 3A. Verify proper operation of the aftertreatment DEF tank heater control valve. | DEF tank heater control valve operating correctly?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for DEF tank heater or DEF tank temperature sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677, 1678, 1679, 1683, 1684, 4168, or 4169 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid (DEF) tank heating system.

Guided Step 2A - Inspect the DEF tank heater coolant lines.

Conditions

  • Turn keyswitch OFF.
  • Verify that the engine coolant level is within normal operating range.

Action

Inspect the aftertreatment DEF tank heater coolant lines and connectors for the following:

  • Leaking or damaged coolant lines
  • Kinked, restricted, or blocked coolant lines (including the original equipment manufacturer (OEM) in-line shutoff valve, if equipped)
  • Loose connections
  • Leaking seals or gaskets.

See equipment manufacturer service information for details on coolant line routing and flow.

Leaks or damage found in tank heater coolant plumbing?
YES NO

Repair or replace the leaking or damaged coolant lines, fittings, or seals.

Verify that the engine coolant level is within normal operating range before returning to service. Add coolant as necessary.

See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the aftertreatment DEF tank heater operation.

Guided Step 3A - Verify proper operation of the aftertreatment DEF tank heater control valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test under the ECM Diagnostic Tests menu.

  • Make sure that the tank heater control valve is operating correctly, not stuck closed or slow to respond, and able to fully open.
  • See equipment manufacturer service information for details on the tank heater control valve.

DEF tank heater control valve operating correctly?
YES NO
No Repair

Repair or replace the DEF tank heater control valve.

See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 3329 - J1939 Network #2 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3329 active?
STEP 2. | Check the J1939 data link 2. |
 | STEP 2A. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the J1939 data link 2 harness. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit to ground in the J1939 data link 2 harness. | Greater than 100k ohms?
 | STEP 2D. Check for an open circuit in the J1939 data link 2 harness. | All measurements less than 10 ohms?
 | STEP 2E. Check the J1939 data link 2 terminating resistance. | 110 to 130 ohms?
 | STEP 2F. Check the J1939 data link 2 terminating resistance. | 110 to 130 ohms?
 | STEP 2G. Check the fault codes. | Fault Code 3329 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3329 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the J1939 data link 2.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

Perform this check on each ECM.

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit in the J1939 data link 2 harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from each ECM.

Action

Check for a short circuit in the J1939 data link 2 harness.

  • Measure the resistance between the SAE J1939 data link 2 (+) wire at the ECM 1 engine harness connector and all other pins in the connector.
  • Measure the resistance between the SAE J1939 data link 2 (-) wire at the ECM 1 engine harness connector and all other pins in the connector.

Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link 2 (+) and the SAE J1939 data link 2 (-) pins.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the J1939 data link 2 harness.

Troubleshoot each harness connected in series to determine which one contains the short circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ECM power supply ground in the J1939 data link 2 harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from each ECM.

Action

Check for a short circuit to ground in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link 2 (+) wire at the ECM 1 engine harness connector and ECM power supply ground.
  • Measure the resistance between the SAE J1939 data link 2 (-) wire at the ECM 1 engine harness connector and ECM power supply ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

  • A short circuit to ECM power supply ground has been detected in the J1939 data link 2 harness.
  • Troubleshoot each harness connected in series to determine which one contains the short circuit.
  • Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check for an open circuit in the J1939 data link 2 harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness at the crossover connector.
  • Disconnect the engine harness connector from ECM 1.

Action

Check for an open circuit in the J1939 data link 2.

  • Measure the resistance between the SAE J1939 data link 2 (+) wire at the left bank engine harness crossover connector and the SAE J1939 data link 2 (+) wire at the ECM 1 engine harness connector.
  • Measure the resistance between the SAE J1939 data link 2 (-) wire at the left bank engine harness crossover connector and the SAE J1939 data link 2 (-) wire at the ECM 1 engine harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

All measurements less than 10 ohms?
YES NO
No Repair

  • An open circuit has been detected in the J1939 data link 2.
  • Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check the J1939 data link 2 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from ECM 1.
  • Disconnect the engine harness at the crossover connector.

Action

Measure the left bank engine harness terminating resistance of the SAE J1939 data link 2.

  • Measure the resistance between the SAE J1939 data link 2 (+) wire and the J1939 data link 2 (-) wire at the engine harness ECM connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

110 to 130 ohms?
YES NO
No Repair

Incorrect terminating resistance or a short circuit has been detected on the SAE J1939 data link 2 circuit in the left bank engine harness.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2F

Go to 3A

Guided Step 2F - Check the J1939 data link 2 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness at the crossover connector.

Action

Measure the right bank engine harness terminating resistance of the SAE J1939 data link 2.

  • Measure the resistance between the SAE J1939 data link 2 (+) wire and the J1939 data link 2 (-) wire at the right bank engine harness crossover connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

110 to 130 ohms?
YES NO
No Repair

Incorrect terminating resistance or a short circuit has been detected on the SAE J1939 data link 2 circuit in the right bank engine harness.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2G

Go to 3A

Guided Step 2G - Check the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3329 active?
YES NO
No Repair

An intermittent short circuit has been detected in the engine harness or connector. Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 3331 - J1939 Network #3 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Fuel Supply Pump | Refer to Procedure 005-241 | QSK95 CM2350 K113 | 4388663
Fuel Metering Valve | Refer to Procedure 005-242 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes | Fault Code 3331 active?
STEP 2. | Check the J1939 data link #3 devices. |
 | STEP 2A. Inspect the engine fuel supply pump and connector pins. | Damaged or dirty pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2A-2. Check the fault codes. |
 | STEP 2B. Inspect the fuel metering valve and connector pins. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2B-1. Check the fault codes. |
STEP 3. | Check the J1939 data link #3. |
 | STEP 3A. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the J1939 terminating resistance. | Both between 110 to 130 ohms?
 | STEP 3C. Check for a short circuit in the J1939 data link 3 harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground in the J1939 data link 3 harness. | Greater than 100k ohms?
 | STEP 3E. Check the J1939 data link 3 terminating resistance. | 50 to 70 ohms?
 | STEP 3F. Check the fault codes. | Fault Code 3331 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3331 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the J1939 data link #3 devices.

Guided Step 2A - Inspect the engine fuel supply pump and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel supply pump from the engine harness.

Action

Inspect the engine harness and engine fuel supply pump connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the fuel supply pump or harness connector.

Clean the connector and pins.

Repair the damaged engine harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel supply pump from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3331 active?
YES | NO
No Repair | No Repair

Go to 2B

Go to 2A-2

Guided Step 2A-2 - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine fuel supply pump to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3331 active?
YES NO

Replace the engine fuel supply pump.

Refer to Procedure 005-241 in the Associated Procedures Table.

An intermittent short circuit has been detected in the engine harness or connector. Refer to Procedure 019-362 in Section 19.

Go to 4A

Go to 4A

Guided Step 2B - Inspect the fuel metering valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.

Action

Inspect the engine harness and fuel metering valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the fuel metering valve or harness connector.

Clean the connector and pins.

Repair the damaged engine harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel supply pump from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3331 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2B-2

Guided Step 2B-2 - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel metering valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3331 active?
YES NO

Replace the fuel metering valve.

Refer to Procedure 005-242 in the Associated Procedures Table.

An intermittent short circuit has been detected in the engine harness or connector. Refer to Procedure 019-362 in Section 19.

Repair the damaged engine harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3 - Check the J1939 data link #3.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect both terminating resistors from the J1939 data link 3.

Action

Measure the resistance of the SAE J1939 data link 3 terminating resistors.

  • Measure the resistance between the SAE J1939 data link (+) wire and the J1939 data link (-) pins at both of the SAE J1939 data link 3 terminating resistors.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Both between 110 to 130 ohms?
YES NO
No Repair

Replace the damaged terminating resistor(s).

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the J1939 data link 3 harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Connect both terminating resistors to the J1939 data link 3.

Action

Check for a short circuit in the J1939 data link 3 harness.

  • Measure the resistance between the SAE J1939 data link 3 (+) wire at the ECM engine harness connector and all other pins in the connector.
  • Measure the resistance between the SAE J1939 data link 3 (-) wire at the ECM engine harness connector and all other pins in the connector.

Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link 3 (+) and the SAE J1939 data link 3 (-) pins.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the J1939 data link 3 harness.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ECM power supply ground in the J1939 data link 3 harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Check for a short circuit to ECM power supply ground in the J1939 data link harness.

  • Refer to Procedure 019-610 in the Associated Procedures Table.
  • Measure the resistance between the SAE J1939 data link 3 (+) wire at the ECM engine harness connector and ECM power supply ground.
  • Measure the resistance between the SAE J1939 data link 3 (-) wire at the ECM engine harness connector and ECM power supply ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

  • A short circuit to ECM power supply ground has been detected in the J1939 data link 3 harness.
  • Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the J1939 data link 3 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Measure the engine harness terminating resistance of the SAE J1939 data link 3.

  • Measure the resistance between the SAE J1939 data link 3 (+) wire and the J1939 data link 3 (-) wire at the engine harness ECM connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 to 70 ohms?
YES NO
No Repair

An open or short circuit has been detected on the SAE J1939 data link 3 circuit in the engine harness.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 3A

Guided Step 3F - Check the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3331 active?
YES NO

Replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

An intermittent short circuit has been detected in the engine harness or connectors. Refer to Procedure 019-362 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 13-Apr-2016


FAULT CODE 3379 - Engine ECU Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 3379 active or inactive counts?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3379 active or inactive counts?
YES NO

This fault code indicates high internal ECM temperature has been detected. Check the low temperature coolant system for malfunctioning components.

This fault code could be caused by operation in a hot ambient environment. Inspect original equipment manufacturer or customer engine ventilation devices for proper operation. Check that proper air flow over the engine is not blocked or restricted.

Repair any damaged components. Remove any debris or air restriction.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 1A

Repair complete

Last Modified: 06-Apr-2016


FAULT CODE 3497 - Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3497 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3497 active?
YES NO

Low diesel exhaust fluid (DEF) level has been detected in the DEF tank.

Add DEF to the DEF tank.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 3498 - Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3498 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3498 active?
YES NO

Low diesel exhaust fluid (DEF) level has been detected in the DEF tank.

Add DEF to the DEF tank.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 3543 - NOx Limits Exceeded Due to Insufficient Reagent Quality - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Pump Override Test | Refer to Procedure 011-063 | QSK95 CM2350 K113 | 4388663
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK95 CM2350 K113 | 4388663
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3543 active?
 | STEP 1B. Check for active aftertreatment nitrogen oxides (NOx) sensor fault codes. | Fault Codes 1885, 1887, 2771, 3228, 3232, 3543, 3545, 3583, 3632, 3649, 3681, 3682, 3717, 3718, 3725, 3726, and 3748 related to the aftertreatment 1 intake NOx sensor and aftertreatment 1 outlet NOx sensor active?
 | STEP 1C. Check for active aftertreatment 1 selective catalytic reduction (SCR) temperature sensor fault codes. | Fault Codes 3142, 3143, 3144, 3164, 3229, 3231, and 5247 related to the aftertreatment 1 SCR temperature sensors active?
 | STEP 1D. Check for active diesel exhaust fluid (DEF) dosing system fault codes. | DEF dosing system related Fault Codes 1682, 3558, 3559, 3568, 4168, 4169, 4174, 4175, 4244, 4587, 5747, 5748, 5749, 5758, 5759, 5764, 5794, 5795, 5813, 5817, 6379, and 6382 active?
STEP 2. | Check the DEF dosing system. |
 | STEP 2A. Check the DEF quality. | DEF free from contamination and within the specifications?
 | STEP 2B. Check the aftertreatment DEF dosing system operation. | Dosing volume within the specifications in Procedure 011-063 in the Associated Procedures Table and DEF spray pattern correct?
STEP 3. | Check the aftertreatment NOx sensors. |
 | STEP 3A. Check the aftertreatment NOx sensor readings. | Aftertreatment NOx sensor readings within specifications found in Procedure 019-451 in the Associated Procedures Table?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3543 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for active aftertreatment NOx sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1885, 1887, 2771, 3228, 3232, 3543, 3545, 3583, 3632, 3649, 3681, 3682, 3717, 3718, 3725, 3726, and 3748 related to the aftertreatment 1 intake NOx sensor and aftertreatment 1 outlet NOx sensor active?

YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1C

Guided Step 1C - Check for active aftertreatment selective catalytic reduction (SCR) temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3142, 3143, 3144, 3164, 3229, 3231, and 5247 related to the aftertreatment 1 SCR temperature sensors active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1D

Guided Step 1D - Check for active diesel exhaust fluid (DEF) dosing system fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes relating to the DEF dosing system.

  • Use INSITE™ electronic service tool to read the fault codes.

DEF dosing system related Fault Codes 1682, 3558, 3559, 3568, 4168, 4169, 4174, 4175, 4244, 4587, 5747, 5748, 5749, 5758, 5759, 5764, 5794, 5795, 5813, 5817, 6379, and 6382 active?

YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 2A

Guided Step 2 - Check the DEF dosing system.

Guided Step 2A - Check the DEF quality.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF quality.

  • Inspect the DEF in the tank for signs of debris or contamination.
  • Use the Cummins® DEF Refractometer Service Tool, Part Number 4919554, to test the DEF concentration. Refer to Procedure 011-056 in the Associated Procedures Table.

DEF free from contamination and within the specifications?
YES NO
No Repair

Completely drain the DEF tank and rinse the tank with water.

Refill the DEF tank with certified DEF. Refer to Procedure 011-056 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check the aftertreatment DEF dosing system operation.

Conditions

  • Remove aftertreatment DEF dosing valve from decomposition chamber.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the DEF Doser Pump Override Test found under ECM Diagnostic Tests.

  • Use the following procedure for instructions and specifications. Refer to Procedure 011-063 in the Associated Procedures Table.
  • Make sure the DEF dosing valve is not plugged and the spray pattern is correct.

The DEF dosing valve must be removed and placed in a measuring container in order to perform the DEF Doser Pump Override Test.

Dosing volume within the specifications in Procedure 011-063 in the Associated Procedures Table and DEF spray pattern correct?
YES NO
No Repair

Replace the aftertreatment DEF dosing valve.

Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment NOx sensors.

Guided Step 3A - Check the aftertreatment NOx sensor readings.

Conditions

  • Turn keyswitch ON.

Action

Perform the Aftertreatment NOx Sensor Rationality Test.

  • Refer to Procedure 014-451 in the Associated Procedures Table.

Aftertreatment NOx sensor readings within specifications found in Procedure 014-451 in the Associated Procedures Table?
YES NO
No Repair

Replace the Aftertreatment intake and outlet NOx sensors.

  • For the intake NOx sensor use the following procedure. Refer to Procedure 019-463 in the Associated Procedures Table.
  • For the outlet NOx sensor use the following procedure. Refer to Procedure 019-451 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 3545 - Aftertreatment 1 Outlet NOx Sensor - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1887, 2771, or 3681 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3545 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1887, 2771 or 3681 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3545 active?
YES NO

An internal error has been detected in the aftertreatment outlet nitrogen oxides (NOx) sensor.

Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451 in the Associated Procedures Table.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 3547 - Aftertreatment Diesel Exhaust Fluid Tank Empty - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3547 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3547 active?
YES NO

Diesel exhaust fluid (DEF) has not been detected in the DEF tank.

Add DEF to the DEF tank.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 13-Apr-2016


FAULT CODE 3558 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3558 active?
STEP 2. | Check the aftertreatment 1 diesel exhaust fluid (DEF) dosing unit 1 and circuit. |
 | STEP 2A. Inspect the aftertreatment 1 DEF dosing unit 1 and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit on the aftertreatment 1 DEF dosing unit 1 supply in the original equipment manufacturer (OEM) harness. | Less than 10 ohms?
 | STEP 2C. Check for an open circuit on the aftertreatment 1 DEF dosing unit 1 supply in the OEM harness. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-ground short circuit on the aftertreatment 1 DEF dosing unit 1 signal in the OEM harness. | Greater than 100K ohms?
 | STEP 2E. Check for a pin-to-ground short circuit on the aftertreatment 1 DEF dosing unit 1 supply in the OEM harness. | Greater than 100k ohms?
 | STEP 2F. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 2G. Check for an open circuit on the aftertreatment 1 DEF dosing unit 1 signal circuit in the engine harness. | Less than 10 ohms?
 | STEP 2H. Check for an open circuit on the aftertreatment 1 DEF dosing unit 1 supply in the engine harness. | Less than 10 ohms?
 | STEP 2I. Check for a pin-to-ground short circuit on the aftertreatment 1 DEF dosing unit 1 signal in the engine harness. | Greater than 100K ohms?
 | STEP 2J. Check for a pin-to-ground short circuit on the aftertreatment 1 DEF dosing unit 1 supply in the engine harness. | Greater than 100K ohms?
 | STEP 2K. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100K ohms?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3559 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 1 diesel exhaust fluid (DEF) dosing unit 1 and circuit.

Guided Step 2A - Inspect the aftertreatment 1 DEF dosing unit 1 and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 1 from the OEM harness.

Action

Inspect the harness and aftertreatment 1 DEF dosing unit 1 connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit on the aftertreatment 1 DEF dosing unit 1 supply in the original equipment manufacturer (OEM) harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 1 from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness aftertreatment 1 DEF dosing unit 1 SUPPLY pin and OEM harness aftertreatment 1 connector DEF dosing unit 1 SUPPLY pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit on the aftertreatment 1 DEF dosing unit 1 supply in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 1 from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness aftertreatment 1 DEF dosing unit 1 SUPPLY pin and OEM harness aftertreatment 1 connector DEF dosing unit 1 SUPPLY pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2D - Check for an open circuit on the aftertreatment 1 DEF dosing unit 1 supply in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 1 from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness aftertreatment 1 DEF dosing unit 1 SUPPLY pin and OEM harness aftertreatment 1 connector DEF dosing unit 1 SUPPLY pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2E - Check for an open circuit on the aftertreatment 1 DEF dosing unit 1 supply in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 1 from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness aftertreatment 1 DEF dosing unit 1 SUPPLY pin and OEM harness aftertreatment 1 connector DEF dosing unit 1 SUPPLY pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2F - Check for a pin-to-pin short circuit on the aftertreatment 1 DEF dosing unit 1 supply in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 1 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 1 SUPPLY pin of the OEM harness aftertreatment 1 connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2G - Check for a pin-to-pin short circuit on the aftertreatment 1 DEF dosing unit 1 signal in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 1 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 1 command SIGNAL pin of the OEM harness aftertreatment 1 connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2H - Check for an open circuit on the aftertreatment 1 DEF dosing unit 1 supply in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness aftertreatment 1 connector DEF dosing unit 1 SUPPLY pin and OEM harness ECM connector aftertreatment 1 DEF dosing unit 1 SUPPLY pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected.

Repair or replace the damaged section of harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2F

Go to 3A

Guided Step 2I - Check for a pin-to-pin short circuit on the aftertreatment 1 DEF dosing unit 1 supply in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing 2 unit SUPPLY pin of the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness.

Repair or replace the damaged section of harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2G

Go to 3A

Guided Step 2J - Check for a pin-to-pin short circuit on the aftertreatment 1 DEF dosing unit 1 signal in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 1 command SIGNAL pin of the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO

Replace the aftertreatment 1 DEF dosing unit 1. Refer to Procedure 011-058 in the Associated Procedures Table.

A pin-to-pin short circuit has been detected.

Repair or replace the damaged section of harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 2K - Check for a pin-to-pin short circuit on the aftertreatment 1 DEF dosing unit 1 signal in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 1 command SIGNAL pin of the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO

Replace the aftertreatment 1 DEF dosing unit 1. Refer to Procedure 011-058 in the Associated Procedures Table.

A pin-to-pin short circuit has been detected.

Repair or replace the damaged section of harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 3559 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3559 active?
STEP 2. | Check the aftertreatment 1 diesel exhaust fluid (DEF) dosing unit1 and circuit. |
 | STEP 2A. Inspect the aftertreatment 1 DEF dosing unit and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit on the aftertreatment 1 DEF dosing unit 1 signal in the original equipment manufacturer (OEM) harness. | Less than 10 ohms?
 | STEP 2C. Check for an open circuit on the aftertreatment 1 DEF dosing unit 1 supply in the OEM harness. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-ground short circuit on the aftertreatment 1 DEF dosing unit 1 signal in the OEM harness. | Greater than 100K ohms?
 | STEP 2E. Check for a pin-to-ground short circuit on the aftertreatment 1 DEF dosing unit 1 supply in the OEM harness. | Greater than 100K ohms?
 | STEP 2F. Check for a pin-to-pin short circuit in the in the OEM harness. | Greater than 100K ohms?
 | STEP 2G. Check for an open circuit on the aftertreatment 1 DEF dosing unit 1 signal circuit in the engine harness. | Greater than 100K ohms?
 | STEP 2H. Check for an open circuit on the aftertreatment 1 DEF dosing unit 1 supply in the engine harness. | Less than 10 ohms?
 | STEP 2I. Check for a pin-to-ground short circuit on the aftertreatment 1 DEF dosing unit 1 signal in the engine harness. | Greater than 100k ohms?
 | STEP 2J. Check for a pin-to-ground short circuit on the aftertreatment 1 DEF dosing unit 1 supply in the engine harness. | Greater than 100k ohms?
 | STEP 2K. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3559 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 1 diesel exhaust fluid (DEF) dosing unit 1 and circuit.

Guided Step 2A - Inspect the aftertreatment 1 DEF dosing unit 1 and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 1 from the OEM harness.

Action

Inspect the harness and aftertreatment 1 DEF dosing unit 1 connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit on the aftertreatment 1 DEF dosing unit 1 signal in the original equipment manufacturer (OEM) harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 1 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 1 command SIGNAL pin at the dosing unit wiring harness connector and aftertreatment 1 DEF dosing unit 1 command SIGNAL pin in the OEM harness aftertreatment 1 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit on the aftertreatment 1 DEF dosing unit 1 supply in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 1 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 1 SUPPLY pin at the dosing unit wiring harness connector and aftertreatment 1 DEF dosing unit 1 SUPPLY pin in the OEM harness aftertreatment 1 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-ECM power supply ground short circuit on the aftertreatment 1 DEF dosing unit 1 signal in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 1 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 1 command SIGNAL pin of the OEM harness aftertreatment 1 connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Refer to Procedure 019-610 in the Associated Procedures Table.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit has been detected.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a pin-to-ECM power supply ground short circuit on the aftertreatment 1 DEF dosing unit 1 supply in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 1 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 1 SUPPLY pin of the OEM harness aftertreatment 1 connector and ECM power supply ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Refer to Procedure 019-610 in the Associated Procedures Table.

Less than 10 ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit has been detected.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check for a pin-to-pin short circuit in the in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 1 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 1 SIGNAL pin of the OEM harness aftertreatment 1 connector and all other pins in the OEM harness ECM connector.
  • Measure the resistance between the aftertreatment 1 DEF dosing unit 1 SUPPLY pin of the OEM harness aftertreatment 1 connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 2G

Go to 3A

Guided Step 2G - Check for an open circuit on the aftertreatment 1 DEF dosing unit 1 signal circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness aftertreatment 1 connector DEF dosing unit 1 command SIGNAL pin and the aftertreatment 1 DEF dosing unit 1 command SIGNAL pin in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

An open signal circuit has been detected.

Repair or replace the damaged section of harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2H

Go to 3A

Guided Step 2H - Check for an open circuit on the aftertreatment 1 DEF dosing unit 1 supply in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness aftertreatment 1 connector DEF dosing unit 1 SUPPLY and the aftertreatment 1 DEF dosing unit 1 SUPPLY pin in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

An open supply circuit has been detected.

Repair or replace the damaged section of harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2I

Go to 3A

Guided Step 2I - Check for a pin-to-ECM power supply ground short circuit on the aftertreatment 1 DEF dosing unit 1 signal in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 1 command SIGNAL pin of the OEM harness ECM connector and ECM power supply ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Refer to Procedure 019-610 in the Associated Procedures Table.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit has been detected.

Repair or replace the damaged section of harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2J

Go to 3A

Guided Step 2J - Check for a pin-to-ECM power supply ground short circuit on the aftertreatment 1 DEF dosing unit 1 supply in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 1 SUPPLY pin of the OEM harness ECM connector and ECM power supply ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Refer to Procedure 019-610 in the Associated Procedures Table.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit has been detected.

Repair or replace the damaged section of harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2K

Go to 3A

Guided Step 2K - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 1 SIGNAL pin of the OEM harness ECM connector and all other pins in the OEM harness ECM connector.
  • Measure the resistance between the aftertreatment 1 DEF dosing unit 1 SUPPLY pin of the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO

Replace the aftertreatment 1 DEF dosing unit 1. Refer to Procedure 011-058 in the Associated Procedure Table.

A pin-to-pin short circuit has been detected.

Repair or replace the damaged section of harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 3562 - Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Delphi® 96 Way Engine Control Module Connector | Refer to Procedure 019-505 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Line Heater Relay | Refer to Procedure 019-600 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box Resistor | Refer to Procedure 019-625 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3562 active?
STEP 2. | Check the aftertreatment 1 diesel exhaust fluid (DEF) line heater relay and resistor. |
 | STEP 2A. Check the aftertreatment 1 DEF line heater relay. | Aftertreatment 1 DEF line heater relay within specifications?
 | STEP 2B. Check the aftertreatment 1 DEF line heater resistor. | Aftertreatment 1 DEF line heater resistor within specifications?
STEP 3. | Check the aftertreatment 1 harness. |
 | STEP 3A. Inspect the aftertreatment 1 connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for open signal circuit. | Less than 10 ohms?
 | STEP 3C. Check for open return circuit. | Less than 10 ohms?
 | STEP 3D. Check for open return circuit. | Less than 10 ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
STEP 4. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 4A. Inspect the Aftertreatment 1 connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit. | Less than 10 ohms?
 | STEP 4C. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 4D. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 4E. Check for an open circuit. | Less than 10 ohms?
 | STEP 4F. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3562 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 1 diesel exhaust fluid (DEF) line heater relay and resistor.

Guided Step 2A - Check the aftertreatment 1 DEF line heater relay.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment 1 DEF line heater relay (K9) from the Aftertreatment Junction Box. Refer to Procedure 019-600 in the Associated Procedures Table.

Action

Test aftertreatment 1 DEF line heater relay. Refer to Procedure 019-600 in the Associated Procedures Table.

Reference the wiring diagram for connector pin identification.

Use the following procedure for the general inspection techniques. Refer to Procedure 019-360 in Section 19.

Aftertreatment 1 DEF line heater relay within specifications?
YES NO
No Repair

Replace the aftertreatment 1 DEF line heater relay (K9). Refer to Procedure 019-600 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Check the aftertreatment 1 DEF line heater resistor.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment 1 DEF line heater resistor (R6) from the aftertreatment junction box. Refer to Procedure 019-625 in the Associated Procedures Table.

Action

Test aftertreatment 1 DEF line heater resistor. Refer to Procedure 019-625 in the Associated Procedures Table.

Reference the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Aftertreatment 1 DEF line heater resistor within specifications?
YES NO
No Repair

Replace the aftertreatment 1 DEF line heater resistor (R6). Refer to Procedure 019-625 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the aftertreatment 1 harness.

Guided Step 3A - Inspect the aftertreatment 1 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater relay from the aftertreatment junction box.

Action

Inspect the connector(s) for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for the general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the C5 connector.

Repair the damaged harness, connector, or pins, if possible.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.
  • For the Aftertreatment Junction Box: Refer to Procedure 019-598 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for open signal circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.

Action

  • Measure the resistance between the aftertreatment 1 DEF line heater SIGNAL pin at the aftertreatment junction box C5 connector and the aftertreatment 1 DEF line heater relay (K9) terminal A1.
  • Measure the resistance between the aftertreatment 1 DEF line heater SIGNAL pin at the aftertreatment junction box C5 connector and the aftertreatment 1 DEF line heater relay (K11) terminal 7.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

An open signal circuit has been detected in the aftertreatment junction box.

Troubleshoot all wires connected in series to determine which one contains the open circuit.

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 5A

Guided Step 3C - Check for open return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.

Action

  • Measure the resistance between the aftertreatment 1 DEF dosing unit heater RETURN pin at the aftertreatment junction box C5 connector and the aftertreatment 1 DEF line heater resistor (R6) terminal A.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Troubleshoot all wires connected in series to determine which one contains the open circuit.

Repair or replace damaged section of wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check for open return circuit.

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the resistance between the aftertreatment 1 DEF line heater resistor (R6) terminal C and the aftertreatment 1 DEF line heater relay (K9) terminal A1.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Troubleshoot all wires connected in series to determine which one contains the open circuit.

Repair or replace damaged section of wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3E

Go to 5A

Guided Step 3E - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.
  • Remove the aftertreatment 1 DEF line heater relay resistor (R6) from the aftertreatment junction box. Refer to Procedure 019-625 in the Associated Procedures Table.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF line heater SIGNAL pin in the aftertreatment junction box C5 connector and all other pins in the connector.

Use a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in aftertreatment junction box.

Troubleshoot all wire(s) in series to determine which one contains the short circuit.

Repair or replace the damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine control module (ECM) and original equipment manufacturer (OEM) harness.

Guided Step 4A - Inspect the aftertreatment 1 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness at the aftertreatment 1 connector.

Action

Inspect the connector(s) for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.
  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.
  • Disconnect the OEM harness at the aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF line heater SIGNAL pin in the aftertreatment junction box C5 connector and the aftertreatment 1 DEF line heater SIGNAL pin in the aftertreatment 1 connector.
  • Measure the resistance between the aftertreatment 1 DEF line heater RETURN pin in the aftertreatment junction box C5 connector and the aftertreatment 1 DEF line heater RETURN pin in the aftertreatment 1 connector.

Use a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all harness connections in series to determine which one contains open circuit.

Repair or replace damaged section of harness. Refer to Procedure 019-071 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.
  • Disconnect the OEM harness at the aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF line heater SIGNAL pin in the aftertreatment 1 connector and all other pins in the connector.

Use a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harness connections in series to determine which one contains open circuit.

Repair or replace damaged section of harness. Refer to Procedure 019-071 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector (J2) from ECM (1).

Action

Inspect the connector(s) for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-505 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4E

Guided Step 4E - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector (J2) from ECM (1).
  • Disconnect the OEM harness at the aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF line heater SIGNAL pin in the OEM connector (J2) from ECM (1) and the aftertreatment 1 DEF line heater SIGNAL pin in the aftertreatment 1 connector.
  • Measure the resistance between the aftertreatment 1 DEF line heater RETURN pin in the OEM connector (J2) from ECM (1) and the aftertreatment 1 DEF line heater RETURN pin in the aftertreatment 1 connector.

Use a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all harness connections in series to determine which one contains open circuit.

If an open circuit is isolated to damaged harness, Repair or replace damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4F

Go to 5A

Guided Step 4F - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector (J2) from ECM (1).
  • Disconnect the OEM harness at the aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF line heater SIGNAL pin in the OEM connector (J2) from ECM (1) and all other pins in the connector.

Use a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harness connections in series to determine which one contains short circuit.

Repair or replace damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process.

Repair complete.

Last Modified: 26-Jul-2017


FAULT CODE 3563 - Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Line Heater Relay | Refer to Procedure 019-600 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Heater Relay | Refer to Procedure 019-620 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box Resistor | Refer to Procedure 019-625 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3563 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) line heater resistor and relays. |
 | STEP 2A. Check the aftertreatment 1 DEF line heater relays. | Aftertreatment 1 DEF line heater relays within specifications?
 | STEP 2B. Check the aftertreatment 1 DEF line heater resistor. | Greater than 100k ohms?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3B. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3563 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment diesel exhaust fluid (DEF) line heater resistor and relays.

Guided Step 2A - Check the aftertreatment 1 DEF line heater relays.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment 1 DEF line heater relays (K9 and K11) from the aftertreatment junction box. Refer to Procedure 019-620 in the Associated Procedures Table.

Action

Test aftertreatment 1 DEF line heater relays. Refer to Procedure 019-600 in the Associated Procedures Table.

Reference the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Replace the aftertreatment 1 DEF line heater relay (K9 or K11). Refer to Procedure 019-600 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check the aftertreatment 1 DEF line heater resistor.

Conditions

  • Turn the keyswitch OFF.
  • Remove the aftertreatment 1 DEF line heater resistor (R6) from the aftertreatment junction box. Refer to Procedure 019-625 in the Associated Procedures Table.

Action

Test aftertreatment 1 DEF line heater resistor. Refer to Procedure 019-625 in the Associated Procedures Table.

Reference the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Aftertreatment 1 DEF line heater resistor within specifications?
YES NO
No Repair

Replace the aftertreatment 1 DEF line heater resistor (R6). Refer to Procedure 019-625 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and original equipment manufacturer (OEM) harness.

Guided Step 3A - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment 1 DEF line heater relays (K9 and K11).
  • Disconnect the aftertreatment 1 DEF line heater resistor (R6).

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Measure the resistance between the aftertreatment 1 DEF line 1 heater relay SIGNAL pin terminal A1 and the G2 ground connector in the aftertreatment junction box.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment 1 DEF line heater relays (K9 and K11).
  • Disconnect the aftertreatment 1 DEF line heater resistor (R6).

Action

  • Measure the resistance between the aftertreatment 1 DEF line 1 heater relay SIGNAL pin at the OEM harness ECM connector and all other pins

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the OEM harness.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process.

Repair complete.

Last Modified: 26-Jul-2017


FAULT CODE 3567 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 1 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for aftertreatment 1 diesel exhaust fluid (DEF) dosing valve 1 fault codes. | Fault Code 3567 active?
STEP 2. | Check the aftertreatment 1 DEF dosing valve 1 and circuit. |
 | STEP 2A. Inspect the aftertreatment 1 DEF dosing valve 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the aftertreatment 1 DEF dosing valve 1 resistance. | Between 10 and 17 ohms?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the aftertreatment 1 DEF dosing valve 1 signal circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check the aftertreatment 1 DEF dosing valve 1 return circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Inspect the ECM harness connector pins. | Dirty or damaged pins?
 | STEP 3G. Check the aftertreatment 1 DEF dosing valve 1 signal circuit. | Less than 10 ohms?
 | STEP 3H. Check the aftertreatment 1 DEF dosing valve 1 return circuit. | Less than 10 ohms?
 | STEP 3I. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3J. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for aftertreatment 1 diesel exhaust fluid (DEF) dosing valve 1 fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3567 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the aftertreatment 1 DEF dosing valve 1 and circuit.

Guided Step 2A - Inspect the aftertreatment 1 DEF dosing valve 1 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 1 from the OEM harness.

Action

Inspect the OEM harness and aftertreatment 1 DEF dosing valve 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing valve or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the aftertreatment 1 DEF dosing valve 1 resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 1 from the OEM harness.

Action

Check for an internal short or open circuit in the aftertreatment 1 DEF dosing valve 1 by measuring the internal resistance.

  • Measure the resistance between the aftertreatment 1 DEF dosing valve 1 SIGNAL pin to the aftertreatment 1 DEF dosing valve 1 RETURN pin at the aftertreatment 1 DEF dosing valve 1 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 10 and 17 ohms?
YES NO
No Repair

An internal short or open has been detected in the aftertreatment 1 DEF dosing valve 1.

Replace the aftertreatment 1 DEF dosing valve 1. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Inspect the OEM harness aftertreatment 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness aftertreatment 1 connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedure Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the aftertreatment 1 DEF dosing valve 1 signal circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 1 from the OEM harness.

Action

Check the dosing valve signal circuit.

  • Measure the resistance between the OEM harness aftertreatment 1 DEF dosing valve 1 connector SIGNAL pin and to the OEM harness aftertreatment 1 connector DEF dosing valve 1 SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

For OEM harness repair: Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the aftertreatment 1 DEF dosing valve 1 return circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 1 from the OEM harness.

Action

Check the dosing valve return circuit.

  • Measure the resistance between the OEM harness aftertreatment 1 DEF dosing valve 1 connector RETURN pin to the OEM aftertreatment 1 connector DEF dosing valve 1 RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

For OEM harness repair: Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ECM power supply ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 1 from the OEM harness.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing valve 1 SIGNAL pin in the OEM harness aftertreatment 1 connector and ECM power supply ground.
  • Measure the resistance between the aftertreatment 1 DEF dosing valve 1 RETURN pin in the OEM harness aftertreatment 1 connector and ECM power supply ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Refer to Procedure 019-610 in the Associated Procedures Table.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

For OEM harness repair: Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit in the in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 1 from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing valve 2 SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

For OEM harness repair: Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 3F - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedure Table.

Go to 4A

Go to 3G

Guided Step 3G - Check the aftertreatment 1 DEF dosing valve 1 signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check the dosing valve signal circuit.

  • Measure the resistance between the OEM harness aftertreatment 1 connector DEF dosing valve 1 connector SIGNAL pin and to the ECM connector aftertreatment 1 DEF dosing valve 1 SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedure Table.

Go to 3H

Go to 4A

Guided Step 3H - Check the aftertreatment 1 DEF dosing valve 1 return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check the dosing valve return circuit.

  • Measure the resistance between the OEM harness aftertreatment 1 connector DEF dosing valve 1 RETURN pin to the ECM connector aftertreatment 1 DEF dosing valve 1 RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Repair or replace the damaged section of harness

For engine harness repair: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3I

Go to 4A

Guided Step 3I - Check for a pin-to-ECM power supply ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing valve 1 SIGNAL pin in the OEM harness ECM connector and ECM power supply ground.
  • Measure the resistance between the aftertreatment 1 DEF dosing valve 1 RETURN pin in the OEM harness ECM connector and ECM power supply ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Refer to Procedure 019-610 in the Associated Procedures Table.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit has been detected in the harness.

Repair or replace the damaged section of harness.

For engine harness repair: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3J - Check for a pin-to-pin short circuit in the in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing valve 2 SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness.

Repair or replace the damaged section of harness.

For engine harness repair: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 3571 - Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 3571 active?
STEP 2. | Check the aftertreatment 1 diesel exhaust fluid (DEF) pressure sensor 1 and circuit. |
 | STEP 2A. Inspect the aftertreatment 1 DEF pressure sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3572 active and Fault Code 3571 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 3571 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 3571 active?
 | STEP 3F. Inspect the ECM harness connector pins. | Dirty or damaged pins?
 | STEP 3G. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3H. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3I. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3J. Check for an active fault code. | Fault Code 3571 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Refer to appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3571 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 1 DEF pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment 1 DEF pressure sensor 1 and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 1 from the OEM harness.

Action

Inspect the OEM harness and aftertreatment 1 DEF pressure sensor 1 connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 1 from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Other aftertreatment 1 DEF dosing unit 1 fault codes will be active.

Fault Code 3572 active and Fault Code 3571 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 1 from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the aftertreatment 1 DEF pressure 1 +5 volt SUPPLY pin to the aftertreatment 1 DEF pressure 1 RETURN pin at the dosing valve connector of the OEM harness.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 1 DEF dosing valve 1 to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3571 active?
YES NO

A malfunctioning aftertreatment DEF pressure sensor has been detected inside the aftertreatment 1 DEF dosing valve 1.

Replace the aftertreatment diesel exhaust dosing unit 1. Refer to Procedure 011-059 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect the harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness from the ECM.

Action

Inspect the harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedure Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness connector from the ECM.
  • Disconnect the aftertreatment 1 DEF dosing valve 1 from the harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 1 RETURN pin in the harness ECM connector and the aftertreatment 1 DEF pressure sensor 1 RETURN pin in the harness dosing valve connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Troubleshoot each section of harness connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of the harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness from the ECM.
  • Disconnect the aftertreatment 1 DEF dosing valve 1 from the harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 1 SIGNAL pin in the ECM connector and all other pins in the OEM harness aftertreatment 1 connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot each section of harness connected in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If a short circuit is isolated to damaged harness, repair or replace the damaged section of the harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness from the ECM.
  • Disconnect the aftertreatment 1 DEF dosing valve 1 from the harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 1 SUPPLY pin in the harness aftertreatment 1 connector and all other pins in the ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the harness.

Troubleshoot each section of harness connected in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If a short circuit is isolated to damaged harness, repair or replace the damaged section of the harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3571 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault code.

Go to 3F

Go to 4A

Guided Step 3F - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the ECM connector or the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedure Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3G - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 1 RETURN pin in the OEM harness ECM connector and the aftertreatment 1 DEF pressure sensor 1 RETURN pin from the engine harness aftertreatment 1 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3H

Go to 4A

Guided Step 3H - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 1 SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3I

Go to 4A

Guided Step 3I - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 1 SUPPLY pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the harness.

Troubleshoot each section of harness connected in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3J

Go to 4A

Guided Step 3J - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3571 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault code.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 3572 - Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 3572 active?
STEP 2. | Check the aftertreatment 1 diesel exhaust fluid (DEF) pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment 1 DEF pressure sensor 1 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 3571 active and Fault Code 3573 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 3572 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM aftertreatment 1 harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin to ECM power supply ground short OEM circuit. | Greater than 100k ohms?
 | STEP 3F. Inspect the ECM OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3G. Check for open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3H. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3I. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3J. Check for a pin to ECM power supply ground short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3K. Check for an active fault code. | Fault Code 3572 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Refer to appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3572 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 1 DEF pressure sensor 1 and circuit.

Guided Step 2A - Inspect the aftertreatment 1 DEF pressure sensor 1 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve from the OEM harness.

Action

Inspect the OEM harness and aftertreatment 1 DEF dosing valve 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 1 from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the aftertreatment 1 DEF pressure sensor 1 +5 volt SUPPLY pin to the aftertreatment 1 DEF pressure sensor 1 RETURN pin at the aftertreatment 1 DEF dosing valve 1 connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 1 from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment 1 DEF pressure sensor 1 +5 volt SUPPLY pin and the aftertreatment 1 DEF pressure sensor 1 SIGNAL pin at the aftertreatment 1 DEF dosing valve 1 connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Other DEF dosing valve fault codes will be active.

Fault Code 3571 active and Fault Code 3573 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 1 DEF dosing valve 1 to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3572 active?
YES NO

A damaged aftertreatment 1 DEF pressure sensor has been detected inside the aftertreatment 1 DEF dosing valve 1.

Replace the aftertreatment 1 DEF dosing valve 1. Refer to Procedure 011-059 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the OEM aftertreatment 1 harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Inspect the OEM harness aftertreatment 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM aftertreatment 1 harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 1 from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 1 SUPPLY pin in the OEM harness aftertreatment 1 connector and the aftertreatment 1 DEF pressure sensor 1 SUPPLY pin in the OEM harness aftertreatment 1 DEF dosing valve 1 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the harness.

Troubleshoot each section of harness connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of the harness.

  • For the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 1 from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 1 SIGNAL pin in the OEM harness aftertreatment 1 connector and the aftertreatment 1 DEF pressure sensor 1 SIGNAL pin in the OEM harness aftertreatment 1 DEF dosing valve 1 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Troubleshoot each section of harness connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of the harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 1 from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 1 SIGNAL pin in the OEM harness aftertreatment 1 connector and all other pins in the OEM harness aftertreatment 1 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal wire has been detected in the OEM harness.

Troubleshoot each section of harness connected in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If a short circuit is isolated to a damaged section of the harness, repair or replace the damaged section of the harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin to ECM power supply ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 1 from the OEM harness.

Action

Check for a pin to ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 1 SIGNAL pin in the OEM harness aftertreatment 1 connector and ECM power supply ground. Refer to Procedure 019-610 in the Associated Procedures Table.

Refer to a wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ECM power supply ground short circuit on the signal wire has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

Repair or replace the damaged section of the harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3G

Go to 4A

Guided Step 3G - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM harness from the engine harness aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 1 SUPPLY pin in the OEM harness ECM connector and the aftertreatment 1 DEF pressure sensor 1 SUPPLY pin in the OEM harness aftertreatment 1 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3H

Go to 4A

Guided Step 3H - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 1 SIGNAL pin in the OEM harness ECM connector and the aftertreatment 1 DEF pressure sensor 1 SIGNAL pin in the OEM harness aftertreatment 1 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3I

Go to 4A

Guided Step 3I - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 1 SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal wire has been detected in the OEM harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3J

Go to 4A

Guided Step 3J - Check for a pin to ECM power supply ground short circuit in engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin to ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 1 SIGNAL pin in the OEM harness ECM connector and ECM power supply ground. Refer to Procedure 019-610 in the Associated Procedures Table.

Use a wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the signal wire has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3K

Go to 4A

Guided Step 3K - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3572 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault code.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 25-Apr-2016


FAULT CODE 3573 - Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for aftertreatment 1 diesel exhaust fluid (DEF) dosing valve 1 fault codes. | Fault Code 3573 active?
STEP 2. | Check the aftertreatment 1 DEF dosing valve 1 and circuit. |
 | STEP 2A. Inspect the original equipment manufacturer (OEM) aftertreatment 1 harness and aftertreatment 1 DEF dosing valve 1 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the OEM harness aftertreatment 1 DEF dosing valve 1 return circuit. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the OEM aftertreatment 1 harness. | Greater than 100k ohms?
 | STEP 2D. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 2E. Check the aftertreatment 1 engine harness DEF dosing valve 1 return circuit. | Less than 10 ohms?
 | STEP 2F. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for aftertreatment 1 diesel exhaust fluid (DEF) dosing valve 1 fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3573 active?
YES NO
No Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the aftertreatment 1 DEF dosing valve 1 and circuit.

Guided Step 2A - Inspect the original equipment manufacturer (OEM) aftertreatment 1 harness and aftertreatment 1 DEF dosing valve 1 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Inspect the OEM harness, ECM and aftertreatment 1 DEF dosing valve 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the OEM harness aftertreatment 1 DEF dosing valve 1 return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 1 from the OEM harness.

Action

Check the dosing valve sensor return circuit.

  • Measure the resistance from the OEM harness aftertreatment 1 DEF dosing valve connector sensor RETURN pin to the OEM harness aftertreatment 1 connector DEF dosing valve 1 sensor RETURN pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the open circuit. Refer to Procedure 019-598, if equipped, in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For OEM harness repair: Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the OEM aftertreatment 1 harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 1 from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment 1 DEF dosing valve 1 sensor RETURN pin in the OEM harness aftertreatment 1 connector and all other pins in the connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the open circuit. Refer to Procedure 019-598, if equipped, in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For OEM harness repair: Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO

A damaged connection has been detected in the OEM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2E

Guided Step 2E - Check the aftertreatment 1 engine harness DEF dosing valve 1 return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness from the engine harness aftertreatment 1 connector.

Action

Check the dosing valve sensor return circuit.

  • Measure the resistance from the engine harness aftertreatment 1 connector sensor RETURN pin to the ECM connector aftertreatment 1 DEF dosing valve 1 sensor RETURN pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Repair or replace the damaged section of the harness.

  • For engine harness repair: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2F

Go to 3A

Guided Step 2F - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment 1 DEF dosing valve 1 sensor RETURN pin in the OEM connector and all other pins in the connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the aftertreatment 1 DEF dosing valve 1. Refer to Procedure 011-059 in the Associated Procedures Table.

A pin-to-pin short circuit has been detected in the harness.

Repair or replace the damaged section of the harness.

  • For engine harness repair: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 3574 - Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSK95 CM2350 K113 | 4388663
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Line Restriction | Refer to Procedure 011-086 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Suction Test | Refer to Procedure 011-121 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Manual Purge | Refer to Procedure 011-143 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing System Pressure Test | Refer to Procedure 011-144 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3574 active inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for related fault codes. | Fault Code 1712 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1C. Check for low diesel exhaust fluid (DEF) tank level. | DEF tank empty and/or Fault Code 1673, 3497, or 3498 active?
 | STEP 1D. Check for active fault codes. | Fault Code 1683, 1684, 1712, 1713, 3237, 3239, 3242, 3258, 3261, 3422, 3425, 3426, 3429, 3559, 3558, 3562, 3563, 3564, 3571, 3572, 3575, 3576, 3596, 3713, 4167, 5278, or 5935 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment DEF lines and fittings. |
 | STEP 2A. Inspect the aftertreatment DEF lines and fittings. | Any reversed, damaged, leaking, or restricted connections founds?
 | STEP 2B. Check the DEF tank. | DEF tank and vent clean and free of debris?
STEP 3. | Check the aftertreatment DEF dosing unit. |
 | STEP 3A. Check the aftertreatment DEF dosing unit. | Vacuum in diagnostic line greater than -203 mm-hg [-8.0 in-hg]?
 | STEP 3B. Check the aftertreatment DEF dosing unit. | DEF dosing unit operating?
 | STEP 3C. Inspect the ECM and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 3D. Checor an open return circuit in the harness. | Less than 10 ohms?
STEP 4. | Check the aftertreatment DEF intake system. |
 | STEP 4A. Check the DEF dosing unit intake restriction. | Restriction less than -152 mm-hg [-6.0 in-hg]?
STEP 5. | Check for air in the aftertreatment DEF. |
 | STEP 5A. Check for air in the DEF. | Air in the DEF detected?
STEP 6. | Check the aftertreatment DEF pressure sensor. |
 | STEP 6A. Inspect the aftertreatment DEF pressure sensor. | Aftertreatment DEF pressure reading in INSITE™ electronic service tool equal to 0 ±69 kPa [0 ±10 psi]?
 | STEP 6B. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 6C. Check for an open circuit in the harness. | Less than 10 ohms?
STEP 7. | Check the aftertreatment DEF lines and fittings. |
 | STEP 7A. Check for pressure at the aftertreatment DEF dosing valve. | DEF pressure less than 950 kPa [137 psi]?
 | STEP 7A-1. Check for pressure at the aftertreatment DEF dosing valve. |
 | STEP 7B. Check for pressure out of the aftertreatment DEF dosing unit. | DEF pressure less than 950 kPa [137 psi]?
 | STEP 7C. Check for pressure out of the aftertreatment DEF dosing unit. | DEF pressure greater than 750 kPa [108 psi]?
 | STEP 7D. Check the aftertreatment DEF dosing unit for blockage. | DEF dosing unit blocked or restricted?
STEP 8. | Check the aftertreatment DEF dosing unit operation. |
 | STEP 8A. Check the aftertreatment DEF dosing system operation. | Dosing volume within the specifications in Procedure 011-063 in the Associated Procedures Table?
STEP 9. | Check ECM calibration and clear fault codes. |
 | STEP 9A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 9B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3574 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1712 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

Fault Code 1712 indicates the aftertreatment DEF tank is frozen. Troubleshoot occurrences of Fault Code 1712 before troubleshooting Fault Code 3574.

No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for low DEF tank level.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Make sure the DEF tank is not empty and the tank level gauge is accurate.

Use INSITE™ electronic service tool to read the fault codes.

  • Check for the following active Fault Codes: 1673, 3497, and 3498.

DEF tank empty and/or Fault Code 1673, 3497, or 3498 active?
YES NO

Fill the DEF tank.

 No Repair

Go to 9A

Go to 1D

Guided Step 1D - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1683, 1684, 1712, 1713, 3237, 3239, 3242, 3258, 3261, 3422, 3425, 3426, 3429, 3559, 3558, 3562, 3563, 3564, 3571, 3572, 3575, 3576, 3596, 3713, 4167, 5278, or 5935 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

See the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF lines and fittings.

Guided Step 2A - Inspect the aftertreatment DEF lines and fittings.

Conditions

  • Turn keyswitch OFF.

Action

There are three DEF lines on the selective catalytic reduction (SCR) dosing system:

  • Dosing unit supply line between the tank and the dosing unit (suction line)
  • Dosing valve supply line between the dosing unit and the dosing valve (pressure line)
  • Return line between the dosing valve and the tank (return line).

Inspect all three DEF lines and associated fittings/connectors:

  • Verify the lines are not swapped at the dosing unit, dosing valve, or DEF tank connections. Reversed DEF line connectors cause the dosing system to fail to prime.
  • Check the DEF tank connections (suction and return lines) for cracks and pitting.
  • Check both dosing unit connections and fittings for loose, leaking, or damaged connections.
  • Disconnect the suction line and pressure line dosing unit connectors and look for signs of build-up or blockage.
  • Check the suction line for signs of leakage or openings which will allow the dosing unit to suck in air with the DEF.
  • Check the pressure line for signs of leakage or rupture.
  • Verify proper sealing at all connection points, including DEF tank (two connections), dosing unit (two connections), and dosing valve (two connections).

Refer to Procedure 011-058 in the Associated Procedures Table.

Any reversed, damaged, leaking, or restricted connections found?
YES NO

Replace the leaking DEF line, as necessary. See equipment manufacturer service information.

 No Repair

Go to 9A

Go to 2B

Guided Step 2B - Check the DEF tank.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF tank from the fill port.

  • Check the DEF tank for contamination or debris. Refer to Procedure 011-056 in the Associated Procedures Table.
  • Check the DEF tank vent for crystallization, buildup, and clogging.

DEF tank and vent clean and free of debris?
YES NO
No Repair

Flush the DEF system. Refer to Procedure 011-056 in the Associated Procedures Table.

  • Drain the DEF tank. Thoroughly flush with distilled water.
  • Clean and flush the DEF tank head and filter. Replace the DEF tank filter, as necessary.
  • Remove the and flush the dosing unit intake and return lines.
  • Makes sure the DEF dosing unit intake fitting and filter are new. Refer to Procedure 011-058 in the Associated Procedures Table.
  • Fill the DEF tank with clean, certified DEF.

Go to 3A

Go to 9A

Guided Step 3 - Check the aftertreatment DEF dosing unit.

Guided Step 3A - Check the aftertreatment DEF dosing unit.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the aftertreatment diesel exhaust fluid dosing unit suction test.

  • Refer to Procedure 011-121 in the Associated Procedures Table.

Vacuum in diagnostic line greater than -203 mm-hg [-8.0 in-hg]?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the aftertreatment DEF dosing unit.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the aftertreatment DEF dosing unit motor was running during the test done in Step 3A.

  • Dosing unit was making sound and/or vibration.

DEF unit operating?
YES NO

Remove the dosing unit intake screen and main filter.

Remove the dosing unit pressure relief valve. Refer to Procedure 011-151 in the Associated Procedures Table.

Inspect the intake screen and the DEF in the main filter well for debris.

If any debris is visible, the system is contaminated with debris and must be flushed. Refer to Procedure 011-056 in the Associated Procedures Table.

  • Drain the DEF tank. Thoroughly flush with distilled water.
  • Clean and flush the DEF tank head and filter. Replace the DEF tank filter, as necessary.
  • Remove and flush the dosing unit intake line.
  • Fill the DEF tank with clean, certified DEF.

Perform the manual purge liquid assist. Refer to Procedure 011-143 in the Associated Procedures Table.

Run the DEF dosing unit suction test again. Refer to Procedure 011-121 in the Associated Procedures Table.

If vacuum is not greater than -203 mm-hg [-8.0 in-hg] gauge when retested, replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

If the vacuum is greater than -203 mm-hg [-8.0 in-hg] gauge when retested, the dosing unit should be reused.

  • Make sure the DEF dosing unit intake screen and main filter are new. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 3C

Guided Step 3C - Inspect the ECM and original equipment manufacturer (OEM) harness connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness, aftertreatment D dosing unit, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor, ECM engine connector, or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 3D

Guided Step 3D - Check for an open return circuit in the harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF dosing unit RETURN pin in the OEM harness ECM connector and the aftertreatment DEF dosing unit RETURN pin in the OEM harness dosing valve connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

A malfunctioning DEF dosing unit has been detected.

Replace the aftertreatment DEF dosing unit. Refer to Procedure 019-058 in the Associated Procedures Table.

An open return circuit has been detected in the harness.

Repair or replace the damaged section of the harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 9A

Go to 9A

Guided Step 4 - Check the aftertreatment DEF intake system.

Guided Step 4A - Check the DEF dosing unit intake restriction.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Refer to Procedure 011-086 in the Associated Procedures Table.

Restriction less than -152 mm-hg [-6.0 in-hg]?
YES NO
No Repair

Clean or replace the DEF tank filter, DEF tank vent filter, and DEF suction line, as necessary.

Drain the DEF tank. Flush with distilled water. Fill the DEF tank with clean, certified DEF.

See equipment manufacturer service information.

Go to 5A

Go to 9A

Guided Step 5 - Check for air in the aftertreatment DEF.

Guided Step 5A - Check for air in the DEF.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for air in the DEF.

  • Refer to Procedure 011-075 in the Associated Procedures Table.

Air in the DEF detected?
YES NO

Check the following components for damage/leaks. Repair, as necessary.

  • Aftertreatment DEF dosing unit supply line
  • Aftertreatment DEF tank fittings
  • Aftertreatment DEF tank stand pipe.

Refer to Procedure 011-075 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 6A

Guided Step 6 - Check the aftertreatment DEF pressure sensor.

Guided Step 6A - Inspect the aftertreatment DEF pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Disconnect the aftertreatment DEF dosing valve pressure line (this is the supply line between the dosing unit and dosing valve).
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Inspect the aftertreatment DEF pressure sensor.

  • Use INSITE™ electronic service tool to monitor the aftertreatment DEF pressure.

Aftertreatment DEF pressure reading in INSITE™ electronic service tool equal to 0 ±69 kPa [0 ±10 psi]?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6B

Guided Step 6B - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness, aftertreatment 1 DEF dosing valve, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor, ECM engine connector, or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedure Table.

 No Repair

Go to 9A

Go to 6C

Guided Step 6C - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the aftertreatment 1 DEF dosing valve from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor SUPPLY pin in the OEM harness ECM connector and the aftertreatment 1 DEF pressure sensor SUPPLY pin in the OEM harness aftertreatment 1 DEF dosing valve connector.
  • Measure the resistance between the aftertreatment 1 DEF pressure sensor SIGNAL pin in the OEM harness ECM connector and the aftertreatment 1 DEF pressure sensor SIGNAL pin in the OEM harness aftertreatment 1 DEF dosing valve connector.
  • Measure the resistance between the aftertreatment 1 DEF pressure sensor RETURN pin in the OEM harness ECM connector and the aftertreatment 1 DEF pressure sensor RETURN pin in the OEM harness dosing valve connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

A damaged aftertreatment DEF pressure sensor has been detected.

Replace the aftertreatment DEF dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

An open circuit has been detected in the harness.

Repair or replace the damaged section of the harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 7A

Go to 9A

Guided Step 7 - Check the aftertreatment DEF lines and fittings.

Guided Step 7A - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the inlet of the dosing valve and the pressure line (this is the supply line between the dosing unit and the dosing valve). Use Diesel Exhaust Fluid Pressure Gauge Kit 5394562 or 5299005. Refer to Procedure 011-144 in the Associated Procedures Table.
  • Turn keyswitch ON.

Action

Attempt to prime the DEF system.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostics Tests.
  • Read the DEF pressure from the service tool gauge.

Diesel exhaust fluid pressure less than 950 kPa [137 psi]?
YES | NO
No Repair | No Repair

Go to 7B

Go to 7A-1

Guided Step 7A-1 - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the outlet of the dosing valve and the return line (this is the return line between the dosing valve and the tank). Use Diesel Exhaust Fluid Pressure Gauge Kit 5394562 or 5299005. Refer to Procedure 011-144 in the Associated Procedures Table.
  • Connect the DEF pressure line to the inlet of the dosing valve.
  • Turn keyswitch ON.

Action

Attempt to prime the diesel exhaust fluid system.

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostics Tests.

Read the DEF pressure from the service tool gauge.

DEF pressure less than 70 kPa [10 psi]?
YES NO
No Repair

A blocked or restricted return line and/or tank head has been detected. Clean or replace the return line and/or tank head, as necessary.

See equipment manufacturer service information.

Go to 7A-2

Go to 7B

Guided Step 7A-2 - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Install the DEF pressure gauge between the inlet of the dosing valve and the pressure line. Use Diesel Exhaust Fluid Pressure Gauge Kit 5394562 or 5299005. Refer to Procedure 011-144 in the Associated Procedures Table.
  • Turn keyswitch ON.

Action

Check for pressure at the aftertreatment DEF dosing valve.

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostics Tests.

Read the DEF pressure from INSITE™ electronic service tool.

DEF pressure reading ± 70 kPa [10 psi] of gauge reading?
YES NO
No Repair

Replace inlet screen per 011-059 and perform this step again.

If still out of spec then replace dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 7B

Go to 9A

Guided Step 7B - Check for pressure out of the aftertreatment DEF dosing unit.

Conditions

  • Turn keyswitch OFF.
  • Connect the DEF pressure line to the inlet of the dosing valve.
  • Install the DEF pressure gauge between the outlet of the dosing unit and the pressure line (this is the supply line between the dosing unit and the dosing valve). Use Diesel Exhaust Fluid Pressure Gauge Kit 5394562 or 5299005. Refer to Procedure 011-144 in the Associated Procedures Table.
  • Turn keyswitch ON.

Action

Attempt to prime the DEF system.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostics Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 950 kPa [137 psi]?
YES NO
No Repair

A restricted pressure line has been detected. Clean or replace the pressure line, as necessary.

See equipment manufacturer service information.

Go to 7C

Go to 9A

Guided Step 7C - Check for pressure out of the aftertreatment DEF dosing unit.

Conditions

  • Turn keyswitch OFF.
  • Install the DEF pressure gauge between the outlet of the dosing unit and the pressure line (this is the supply line between the dosing unit and the dosing valve). Use Diesel Exhaust Fluid Pressure Gauge Kit 5394562 or 5299005. Refer to Procedure 011-144 in the Associated Procedures Table.
  • Turn keyswitch ON.

Action

Attempt to prime the DEF system.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostics Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 750 kPa [108 psi]?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7D

Guided Step 7D - Check the aftertreatment DEF dosing unit for blockage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve pressure line from the dosing valve (pressure line runs between the dosing unit and dosing valve).
  • Disconnect the aftertreatment DEF dosing valve pressure line from the DEF dosing unit.

Action

Check the aftertreatment diesel exhaust fluid dosing unit for blockage.

  • Inspect the outlet fitting for signs of buildup or blockage.
  • Inspect the dosing unit filter for signs of buildup or blockage.
  • Inspect the inlet fitting screen for signs of buildup or blockage.

DEF dosing unit blocked or restricted?
YES NO

Clean the aftertreatment DEF dosing unit outlet or inlet fitting if needed.

Replace the aftertreatment DEF dosing unit filter if needed. Refer to Procedure 011-060 in the Associated Procedures Table.

A malfunctioning DEF dosing unit has been detected.

Replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 9A

Go to 9A

Guided Step 8 - Check the aftertreatment DEF dosing unit operation.

Guided Step 8A - Check the aftertreatment DEF dosing system operation.

Conditions

  • Connect all DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove aftertreatment DEF dosing valve from decomposition chamber.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test, under ECM Diagnostics Tests.

  • Use the following procedure for instructions and specifications. Refer to Procedure 011-063 in the Associated Procedures Table.

The aftertreatment DEF dosing valve must be removed and placed in a measuring container having greater than a 1.5 liter [50 oz] capacity to run the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Dosing volume within the specifications in Procedure 011-063 in the Associated Procedures Table?
YES NO
No Repair

Refer to Procedure 011-063 in the Associated Procedures Table for repair instructions.

Go to 9A

Go to 9A

Guided Step 9 - Check ECM calibration and clear fault codes.

Guided Step 9A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 9B

Go to 9B

Guided Step 9B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Oct-2017


FAULT CODE 3575 - Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3575 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3596, 3571, 3572, 5278, 5935, 5936, 5864, or 5865 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) lines and fittings. |
 | STEP 2A. Check for pressure at the aftertreatment DEF dosing valve. | DEF pressure less than 70 kPa [10 psi]?
 | STEP 2B. Check for pressure at the aftertreatment DEF tank head. | DEF pressure less than 70 kPa [10 psi]?
 | STEP 2C. Check for pressure at the aftertreatment DEF dosing valve. |
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3575 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3596, 3571, 3572, 5278, 5935, 5936, 5864, or 5865 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF lines and fittings

Guided Step 2A - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the outlet of the dosing valve and the return line (this is the return line between the dosing valve and tank). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

Attempt to prime the DEF system.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostics Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure greater than 70 kPa [10 psi]?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2B

Guided Step 2B - Check for pressure at the aftertreatment DEF tank head.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the inlet of the tank head and return line (this is the return line between the dosing valve and tank). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

Attempt to prime the DEF system.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 70 kPa [10 psi]?
YES NO

A blocked or restricted return line has been detected.

Clean or replace the return line, as necessary.

See equipment manufacturer service information.

A blocked or restricted tank head has been detected.

Clean or replace the tank head, as necessary.

See equipment manufacturer service information.

Go to 3A

Go to 3A

Guided Step 2C - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Install the DEF pressure gauge between the inlet of the dosing valve and the pressure line. Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

Check for pressure at the aftertreatment DEF dosing valve.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure reading ± 70 kPa [10 psi] of gauge reading?
YES NO
No Repair

Replace inlet screen per Procedure 011-059 and perform this step again.

If still out of spec then replace dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 03-Nov-2016


FAULT CODE 3583 - Aftertreatment 1 Outlet NOx Sensor Heater - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Aftertreatment Sensor Power Relay | Refer to Procedure 019-607 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3583 active?
 | STEP 1B. Check for other active outlet NOx sensor fault codes. | Active or inactive counts of Fault Code 1887, 2771, or 3681?
 | STEP 1C. Check for active selective catalytic reduction (SCR) temperature sensor fault codes. | Fault Code 3144 or 3148 active?
STEP 2. | Check the aftertreatment 1 outlet nitrogen oxides (NOx) sensor circuit. |
 | STEP 2A. Inspect the aftertreatment 1 outlet NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment 1 outlet NOx sensor. | Voltage within 1 VDC of ECM power supply voltage?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the voltage to the aftertreatment outlet NOx sensor. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3B. Inspect aftertreatment 1 power relay and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the voltage to the aftertreatment 1 power relay. | Voltage within 1 VDC of power supply voltage?
 | STEP 3D. Check the aftertreatment 1 power relay. | Less than 10 ohms?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3583 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for other active outlet NOx sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1887, 2771, or 3681?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1C

Guided Step 1C - Check for active SCR temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3144 or 3148 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment 1 outlet NOx sensor circuit.

Guided Step 2A - Inspect the aftertreatment 1 outlet NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 outlet NOx sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment 1 outlet NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Replace the aftertreatment intake NOx sensor only when there are damaged pins. Refer to Procedure 019-451 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment 1 outlet NOx sensor.

Conditions

  • Disconnect the sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreament 1 outlet NOx sensor.

  • Measure the voltage between the aftertreatment 1 outlet NOx sensor ECM power supply voltage supply circuit and the aftertreatment 1 outlet NOx sensor ECM power supply voltage return circuit at the NOx sensor wiring harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of ECM power supply voltage?
YES NO

A damaged aftertreatment 1 outlet NOx sensor heater has been detected.

Replace the aftertreatment 1 outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the voltage to the aftertreatment 1 outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment 1 outlet NOx sensor.

  • Measure the voltage from the aftertreatment 1 outlet NOx sensor ECM power supply voltage SUPPLY pin of the OEM harness outlet NOx sensor connector to ECM power supply ground.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Refer to Procedure 019-610 in the Associated Procedures Table.

Voltage within 1 VDC of ECM power supply voltage?
YES NO

An open circuit has been detected in the aftertreatment 1 outlet NOx sensor ECM power supply voltage return circuit.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, Repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.
  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Inspect aftertreatment 1 power relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 power relay from the harness.

Action

Inspect the harness and aftertreatment 1 power relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the relay or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace aftertreatment 1 power relay only when there are damaged pins. Refer to Procedure 019-607 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the voltage to the aftertreatment 1 power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 power relay from the engine harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment 1 power relay.

  • Measure the voltage between the aftertreatment 1 power relay ECM power supply voltage SUPPLY pin in the aftertreatment 1 power relay connector of the engine harness and ECM power supply ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Refer to Procedure 019-610 in the Associated Procedures Table.

Voltage within 1 VDC of ECM power supply voltage?
YES NO
No Repair

An open circuit has been detected in the aftertreatment 1 power ECM power supply voltage supply circuit before the power relay.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.
  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check the aftertreatment 1 power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 power relay from the engine harness.

Action

Check for a damaged aftertreatment 1 power relay.

  • Install a jumper wire from pin 85 on the aftertreatment 1 power relay to ECM power supply + and connect a jumper wire from pin 86 on the aftertreatment 1 power relay to ECM power supply. Measure the resistance between pin 30 and pin 87 on the aftertreatment 1 power relay.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Refer to Procedure 019-610 in the Associated Procedures Table.

Less than 10 ohms?
YES NO

An open circuit or short circuit to ground has been detected in the aftertreatment outlet NOx sensor power supply circuit.

This could be caused by:

  • Blown in-line fuse on the outlet NOx sensor power supply circuit.
  • Open circuit or short to ECM power supply ground in the outlet NOx sensor power supply circuit.

Replace the inline fuse if it is blown.

Troubleshoot all harnesses connected in series to determine which one contains the open or shorted circuit.

Repair or replace the damaged section of harness.

Repair or replace the OEM harness.

  • For the OEM harness. Refer to Procedure 019-071 in Section 19.
  • For the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the aftertreatment 1 power relay.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 02-May-2016


FAULT CODE 3596 - Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3596 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3571, 3572, 5278, 5935, 5936, 5864, or 5865 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) pressure sensor. |
 | STEP 2A. Inspect the aftertreatment DEF pressure sensor. | Aftertreatment DEF pressure reading in INSITE™ electronic service tool equal to 0 ±69 kPa [0 ±10 psi]?
STEP 3. | Check the aftertreatment DEF lines and fittings. |
 | STEP 3A. Check for pressure at the aftertreatment DEF dosing valve. | DEF pressure less than 70 kPa [10 psi]?
 | STEP 3B. Check for pressure at the aftertreatment DEF tank head. | DEF pressure less than 70 kPa [10 psi]?
 | STEP 3C. Check for pressure at the aftertreatment DEF dosing valve. | DEF pressure reading ± 70 kPa [10 psi] of gauge reading?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3596 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3571, 3572, 5278, 5935, 5936, 5864, or 5865 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid (DEF) pressure sensor.

Guided Step 2A - Inspect the aftertreatment DEF pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve supply line.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Inspect the aftertreatment DEF pressure sensor.

  • Use INSITE™ electronic service tool to monitor the aftertreatment DEF pressure.

Aftertreatment DEF pressure reading in INSITE™ electronic service tool equal to 0 ±69 kPa [0 ±10 psi]?
YES NO
No Repair

A damaged aftertreatment DEF pressure sensor has been detected.

Replace the aftertreatment DEF dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF lines and fittings.

Guided Step 3A - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the outlet of the dosing valve and return line (this is the return line between the dosing valve and tank). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

Attempt to prime the DEF system.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 70 kPa [10 psi]?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B

Guided Step 3B - Check for pressure at the aftertreatment DEF tank head.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for diesel exhaust fluid system pressure to leak down.
  • Install the DEF pressure gauge between the inlet of the tank head and the return line (this is the return line between the dosing valve and the tank). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

Attempt to prime the DEF system.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 70 kPa [10 psi]?
YES NO

A blocked or restricted return line has been detected.

Clean or replace the return line, as necessary.

See equipment manufacturer service information.

A blocked or restricted tank head has been detected.

Clean or replace the tank head, as necessary.

See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 3C - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Install the DEF pressure gauge between the inlet of the dosing valve and the pressure line. Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

Check for pressure at the aftertreatment DEF dosing valve.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure reading ± 70 kPa [10 psi] of gauge reading?
YES NO
No Repair

Replace inlet screen per Procedure 011-059 and perform this step again.

If still out of spec then replace dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jan-2017


FAULT CODE 3613 - Coolant Level Sensor - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 3613 active?
STEP 3. | Check the original equipment manufacturer (OEM) equipment electronic control unit and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which equipment electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | ECM multiplexing configuration match the OEM equipment electronic control unit multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | 50 ohms to 70 ohms?
STEP 5. | Check the engine harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | 50 ohms to 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3613 active?
YES | NO
No Repair | No Repair

Go to 3A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM equipment electronic control unit and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which equipment electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM equipment electronic control unit multiplexing configuration component enables and OEM equipment electronic control unit source addresses from the appropriate OEM information or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM equipment electronic control unit multiplexed component enables and source addresses.

Reference the Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration match the OEM equipment electronic control unit multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a equipment electronic control unit, equipment electronic control unit setup, or equipment electronic control unit to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM equipment electronic control unit source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check the engine harness

Guided Step 5A - Check the ECM and OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM from the ECM connector.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM ECM connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link 1 (+) wire and the SAE J1939 data link 1 (-) wire at the OEM ECM harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected in the engine harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the OEM ECM connector to all other pins in the ECM connector.

Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A communication issue between the ECM and the data link, a damaged ECM, or an incorrect calibration is causing the fault code.

A short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

The appropriate ECM - No Communication troubleshooting symptom tree in Section TT

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Repair complete

Go to 1A

Last Modified: 06-Apr-2016


FAULT CODE 3622 - Turbocharger 2 Speed Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for barometric pressure or intake manifold pressure sensor faults. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 221, 222, 1385, 1386, 1636, or 1637 active?
STEP 2. | Check for a malfunction in the turbocharger speed sensor 2. |
 | STEP 2A. Inspect the engine harness connector to the turbocharger speed sensor 2. | Dirty or damaged pins?
 | STEP 2B. Measure the turbocharger speed sensor 2 resistance. | Resistance between 600 and 1600 ohms?
 | STEP 2C. Check for a short circuit to ground in the turbocharger speed sensor 2. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check the turbocharger. |
 | STEP 4A. Inspect the turbocharger. | Turbocharger seized or fins damaged or missing?
STEP 5. | Check the ECM calibration and clear the fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disabel the fault code. | Fault code inactive?

Guided Step 1 - Check for barometric pressure or intake manifold pressure sensor faults.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Read the fault codes with INSITE™ electronic service tool.

Fault Code 221, 222, 1385, 1386, 1636, or 1637 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check for a malfunction in the turbocharger speed sensor 2.

Guided Step 2A - Inspect the engine harness connector to the turbocharger speed sensor 2.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor 2 from the engine harness.

Action

Inspect the turbocharger speed sensor 2 connector, the engine harness connector, and the turbocharger speed sensor 2 pigtail harness, for signs of the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the turbocharger speed sensor 2 connector or speed sensor.

Repair or replace the damaged connector or turbocharger speed sensor. Refer to Procedure 019-390 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Measure the turbocharger speed sensor 2 resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor 2 from the engine harness.

Action

Measure the resistance.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL pin to the turbocharger speed RETURN pin at the sensor.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 600 and 1600 ohms?
YES NO
No Repair

The turbocharger speed sensor 2 has malfunctioned.

Replace the turbocharger speed sensor 2. Refer to Procedure 019-390 in the Associated Procedures Table.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to ECM power supply ground in the turbocharger speed sensor 2.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor 2 from the engine harness.

Action

Check for a short circuit to ECM power supply ground.

  • Refer to Procedure 019-610 in the Associated Procedures Table.
  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL pin at the sensor to ECM power supply ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

The turbocharger speed sensor is shorted to ECM power supply ground.

Replace the turbocharger speed sensor. Refer to Procedure 019-390 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness ECM connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor 2 from the engine harness.
  • Disconnect the engine harness connector from the ECM.

Action

Check for an open circuit in the harness.

  • Use a multimeter to measure the resistance of the turbocharger speed SIGNAL wire between the engine harness ECM connector and the turbocharger speed sensor connector.
  • Use a multimeter to measure the resistance from the turbocharger speed RETURN wire between the engine harness ECM connector and the turbocharger speed sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

High resistance or an open circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to ECM power supply ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor 2 from the engine harness.
  • Disconnect the engine harness connector from the ECM.

Action

Check for a short to ECM power supply ground.

  • Refer to Procedure 019-610 in the Associated Procedures Table.
  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL pin of the engine harness ECM connector to ECM power supply ground.
  • Use a multimeter to measure the resistance from the turbocharger speed RETURN pin of the engine harness ECM connector to ECM power supply ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ECM power supply ground has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the short circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check for a pin-to-pin short in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor 2 from the engine harness.
  • Disconnect the engine harness connector from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL pin of the engine harness ECM connector to all other pins in the connector.
  • Use a multimeter to measure the resistance from the turbocharger speed RETURN pin of the engine harness ECM connector to all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the short circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the turbocharger.

Guided Step 4A - Inspect the turbocharger.

Conditions

  • This step only applies to 2 stage engines. For single stage engines go to Step 5.
  • Turn keyswitch OFF.

Action

Inspect the turbocharger for the following:

  • Seized turbocharger shaft.
  • Damaged or missing fins.

Use the following procedure for turbocharger inspection. Refer to Procedure 010-033 in the Associated Procedures Table.

Turbocharger seized or fins damaged or missing?
YES NO

Repair or replace the damaged turbocharger(s). Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check the ECM calibration and clear the fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 3649 - Aftertreatment 1 Intake NOx Sensor Heater - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK95 CM2350 K113 | 4388663
Aftertreatment Sensor Power Relay | Refer to Procedure 019-607 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3649 active?
 | STEP 1B. Check for active nitrogen oxides (NOx) sensor related fault codes. | Fault Code 1885, 3232, or 3682 active?
 | STEP 1C. Check for active selective catalytic reduction (SCR) intake temperature sensor fault codes. | Fault Code 3144 active?
STEP 2. | Check the aftertreatment 1 intake NOx sensor circuit. |
 | STEP 2A. Inspect the aftertreatment 1 intake NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment 1 intake NOx sensor. | Voltage within 1 VDC of ECM power supply voltage?
STEP 3. | Check the engine harness. |
 | STEP 3A. Check the voltage to the aftertreatment intake NOx sensor. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3B. Inspect the aftertreatment power relay and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the voltage to the aftertreatment power relay. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3D. Check the aftertreatment power relay. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3649 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for active nitrogen oxides (NOx) sensor related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1885, 3232, or 3682 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for active selective catalytic reduction (SCR) intake temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3144 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment 1 intake NOx sensor circuit.

Guided Step 2A - Inspect the aftertreatment 1 intake NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 intake NOx sensor from the engine harness.

Action

Inspect the engine harness and aftertreatment 1 intake NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment 1 intake NOx sensor.

Conditions

  • Disconnect the sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment 1 intake NOx sensor.

  • Measure the voltage between the aftertreatment 1 intake NOx sensor ECM power supply circuit and the aftertreatment 1 intake NOx sensor ECM power supply voltage return circuit at the NOx sensor wiring harness connector.

Use the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of ECM power supply voltage?
YES NO

A damaged aftertreatment 1 intake NOx sensor heater has been detected.

Replace the aftertreatment 1 intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Check the voltage to the aftertreatment 1 intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 intake NOx sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment 1 intake NOx sensor.

  • Measure the voltage from the aftertreatment 1 intake NOx sensor ECM power SUPPLY pin of the engine harness intake NOx sensor connector to ECM power supply ground.

Refer to Procedure 019-610 in the Associated Procedures Table.

Connections tight and corrosion-free?
YES NO

An open circuit has been detected in the aftertreatment 1 intake NOx sensor ECM power supply voltage return circuit.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Inspect the aftertreatment power relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the harness.

Action

Inspect the harness and aftertreatment power relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the relay or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table. Replace aftertreatment power relay only when there are damaged pins.

Refer to Procedure 019-607 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the voltage to the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment power relay.

  • Measure the voltage between the aftertreatment power relay ECM power supply voltage SUPPLY pin in the aftertreatment power relay connector of the engine harness and ECM power supply ground.

Refer to Procedure 019-610 in the Associated Procedures Table.

Voltage within 1 VDC of ECM power supply voltage?
YES NO
No Repair

An open circuit has been detected in the aftertreatment power battery voltage supply circuit before the power relay.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 3D

Guided Step 3D - Check the voltage to the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.

Action

Check for a damaged aftertreatment power relay.

  • Install a jumper wire from pin 85 on the aftertreatment power relay to ECM power supply positive and connect a jumper wire from pin 86 on the aftertreatment power relay to the ECM power supply ground.
  • Measure the resistance between pin 30 and pin 87 on the aftertreatment power relay.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Refer to Procedure 019-610 in the Associated Procedures Table.

Less than 10 ohms?
YES NO

An open circuit or short circuit to ground has been detected in the aftertreatment intake NOx sensor power supply circuit.

This could be caused by:

  • Blown in-line fuse on the intake NOx sensor power supply circuit.
  • Open circuit or short to ground in the intake NOx sensor power supply circuit.

Replace the inline fuse, if needed.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 3681 - Aftertreatment 1 Outlet NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 3681 active?
 | STEP 1B. Check for active fault codes. | Battery voltage Fault Code 441 or 442 active?
STEP 2. | Check the aftertreatment outlet sensor circuit. |
 | STEP 2A. Inspect aftertreatment outlet nitrogen oxides (NOx) sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment outlet NOx sensor. | Voltage within 1-VDC of ECM power supply voltage?
 | STEP 2C. Check for correct adjustable parameter settings. | Electrical System Voltage parameter correct for the engine configuration?
 | STEP 2D. Check for the correct aftertreatment outlet NOx sensor. | Aftertreatment outlet NOx sensor correct for the engine configuration?
 | STEP 2E. Check the condition of the aftertreatment outlet NOx sensor. | Fault Code 3681 active?
STEP 3. | Check the harness. |
 | STEP 3A. Check the voltage to the aftertreatment outlet NOx sensor. | Voltage within 1-VDC of ECM power supply voltage?
 | STEP 3B. Inspect aftertreatment power relay and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the voltage to the aftertreatment power relay. | Voltage within 1-VDC of ECM power supply voltage?
 | STEP 3D. Check the aftertreatment power relay. | Less than 10 ohms?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3681 active?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Battery voltage Fault Code 441 or 442 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment outlet sensor circuit.

Guided Step 2A - Inspect aftertreatment outlet NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the original equipment manufacturer (OEM) harness.

Action

Inspect the OEM harness and aftertreatment outlet NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment outlet NOx sensor.

  • Measure the voltage between the aftertreatment outlet NOx sensor ECM power supply voltage supply circuit and the aftertreatment outlet NOx sensor ECM power supply voltage return circuit at the NOx sensor wiring harness connector.

Note: Check the voltage at keyswitch ON while cranking the engine, and with the engine at idle.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage within 1 VDC of ECM power supply voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine configuration.

Note: To check the voltage configuration of the engine, disconnect the OEM connector from the ECM and measure the voltage from the ECM power supply SUPPLY (+) pin of the OEM harness ECM connector to block ground.

Electrical System Voltage parameter correct for the engine configuration?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine configuration.

Go to 2D

Go to 4A

Guided Step 2D - Check for correct aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove aftertreatment outlet NOx sensor.

Action

Verify aftertreatment outlet NOx sensor is the correct sensor for the engine configuration.

Note: The aftertreatment outlet NOx sensor is available in 12 volt or 24 volt versions.

Aftertreatment outlet NOx sensor is the correct sensor for the engine configuration?
YES NO
No Repair

Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Check the condition of the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment outlet NOx sensor.
  • Start and idle the engine.
  • Operate the engine until the aftertreatment SCR catalyst outlet temperature is above 150°C [302°F].

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

Note: The exhaust gas temperature at the aftertreatment outlet NOx sensor must be above 150°C [302°F] before the sensor can run its internal diagnostics.

Fault Code 3681 active?
YES NO

Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the harness.

Guided Step 3A - Check the voltage to the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the voltage to the aftertreatment outlet NOx sensor.

  • Measure the voltage from the aftertreatment outlet NOx sensor connector SUPPLY pin of the OEM harness to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of ECM power supply voltage?
YES NO

An open circuit has been detected in the aftertreatment outlet NOx sensor ECM power supply voltage return circuit.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Inspect the aftertreatment power relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the harness.

Action

Inspect the harness and aftertreatment smart sensor relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the relay or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the voltage to the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment power relay.

  • Measure the voltage between the aftertreatment power relay ECM power supply voltage SUPPLY pin in the aftertreatment power relay connector of the engine harness and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of ECM power supply voltage?
YES NO
No Repair

An open circuit has been detected in the aftertreatment power ECM power supply voltage supply circuit before the aftertreatment power relay.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Go to 3D

Go to 4A

Guided Step 3D - Check the aftreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.

Action

Check for a damaged aftertreatment power relay.

  • Install a jumper wire from pin 85 on the aftertreatment power relay to ECM power supply + and connect a jumper wire from pin 86 on the aftertreatment power relay to chassis ground.
  • Measure the resistance between pin 30 and pin 87 on the aftertreatment power relay.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

An open circuit or short circuit to ground has been detected in the aftertreatment outlet NOx sensor power supply circuit.

This could be caused by:

  • Blown inline fuse on the outlet NOx sensor power supply circuit.
  • Open circuit or short to ground in the outlet NOx sensor power supply circuit.

Replace the inline fuse if it is blown.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Replace the aftertreatment power relay.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair Complete

Last Modified: 20-May-2016


FAULT CODE 3682 - Aftertreatment 1 Intake NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3682 active?
 | STEP 1B. Check for active fault codes. | Battery Voltage Fault Code 441 or 442 active?
STEP 2. | Check the aftertreatment 1 intake nitrogen oxides (NOx) sensor circuit. |
 | STEP 2A. Inspect aftertreatment 1 intake NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment 1 intake NOx sensor. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 2C. Check for correct adjustable parameter settings. | Electrical System Voltage parameter correct for the engine configuration?
 | STEP 2D. Check for correct aftertreatment intake NOx sensor. | Aftertreatment intake NOx sensor is the correct sensor for the engine configuration?
 | STEP 2E. Check the condition of the aftertreatment 1 intake NOx sensor. | Fault Code 3682 active?
STEP 3. | Check the harness. |
 | STEP 3A. Check the voltage to the aftertreatment 1 intake NOx sensor. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3B. Inspect the aftertreatment power relay and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the voltage to the aftertreatment power relay. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3D. Check the aftertreatment power relay. | Less than 10 ohms?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3682 is active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine and let it idle for one minute.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Battery Voltage Fault Code 441 or 442 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment 1 intake NOx sensor circuit.

Guided Step 2A - Inspect aftertreatment 1 intake nitrogen oxides (NOx) sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 intake NOx sensor from the engine harness.

Action

Inspect the engine harness and aftertreatment 1 intake NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the aftertreatment intake NOx sensor only when there are damaged pins. Refer to Procedure 019-463 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment 1 intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 intake NOx sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment 1 intake NOx sensor.

  • Measure the voltage between the aftertreatment 1 intake NOx sensor ECM power supply voltage supply circuit and the aftertreatment intake NOx sensor ECM power supply voltage return circuit at the NOx sensor wiring harness connector.

Check the voltage at keyswitch ON while cranking the engine, and with the engine at idle.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage within 1 VDC of ECM power supply voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine configuration.

Electrical System Voltage parameter correct for the engine configuration?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine configuration.

Go to 2D

Go to 4A

Guided Step 2D - Check for correct aftertreatment 1 intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove aftertreatment 1 intake NOx sensor.

Action

Verify aftertreatment 1 intake NOx sensor is the correct sensor for the engine configuration.

The aftertreatment 1 intake NOx sensor is available in 12 volt or 24 volt versions.

Aftertreatment 1 intake NOx sensor is the correct sensor for the engine configuration?
YES NO
No Repair

Replace the aftertreatment 1 intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Check the condition of the aftertreatment 1 inlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 1 intake NOx sensor.
  • Operate the engine and let it idle.
  • Operate the engine until the exhaust stack temperature 1 sensor temperature is above 150°C [302°F].

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

The exhaust gas temperature at the aftertreatment 1 intake NOx sensor must be above 150°C [302°F] before the sensor can run its internal diagnostics.

Fault Code 3682 active?
YES NO

Replace the aftertreatment 1 intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the harness.

Guided Step 3A - Check the voltage to the aftertreatment 1 intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 intake NOx sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment 1 intake NOx sensor.

  • Measure the voltage from the aftertreatment 1 intake NOx sensor ECM power supply voltage SUPPLY pin of the engine harness intake NOx sensor connector to engine block ground

Voltage within 1 VDC of ECM power supply voltage?
YES NO

An open circuit has been detected in the aftertreatment 1 intake NOx sensor ECM power supply voltage return circuit.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Inspect the aftertreatment power relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the harness.

Action

Inspect the harness and aftertreatment smart sensor relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the relay or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the voltage to the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.
  • Turn keyswitch ON.

Action

Check the voltage to the aftertreatment power relay.

  • Measure the voltage between the aftertreatment power relay ECM power supply voltage SUPPLY pin in the aftertreatment power relay connector of the engine harness and engine block ground.

Voltage is within 1 VDC of ECM power supply voltage?
YES NO
No Repair

An open circuit has been detected in the aftertreatment power ECM power supply voltage supply circuit before the power relay.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.

Action

Check for a damaged aftertreatment power relay.

  • Install a jumper wire from pin 85 on the aftertreatment power relay to Battery + and connect a jumper wire from pin 86 on the aftertreatment power relay to chassis ground. Measure the resistance between pin 30 and pin 87 on the aftertreatment power relay.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

An open circuit or short to ground has been detected in the aftertreatment 1 intake NOx sensor power supply circuit.

This could be caused by:

  • Blown inline fuse on the intake NOx sensor power supply circuit.
  • Open circuit or short to ground in the intake NOx sensor power supply circuit.

Replace the inline fuse if needed.

Troubleshoot all harnesses connected in series to determine which one contains the open or shorted circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the aftertreatment power relay.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 13-Apr-2016


FAULT CODE 3697 - Engine Control Module Calibration Memory - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 111 active?
STEP 2. | Calibrate the engine control module (ECM). |
 | STEP 2A. Calibrate the ECM. | Fault Code 3697 active after calibrating the ECM?
 | STEP 2B. Disable and clear the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 111 active?
YES | NO
No Repair | No Repair

Fault Code 111 troubleshooting tree.

Go to 2A

Guided Step 2 - Calibrate the ECM.

Guided Step 2A - Calibrate the ECM.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to calibrate the ECM with the latest engine calibration. Refer to the calibration revisions listed in the ECM Calibration Revision History to find the latest calibration available for the engine being serviced.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

Fault Code 3697 active after calibrating the ECM?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 2B

Go to 2B

Guided Step 2B - Disable and clear the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Go to

Repair complete.

Last Modified: 25-Jan-2017


FAULT CODE 3712 - Aftertreatment SCR Operator Inducement - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3712 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for other active selective catalyst reduction (SCR) related fault codes.

Fault Code 3712 active?
YES NO

This is an information only fault code that will only become active if other SCR related fault codes are active for an extended period of time.

Troubleshoot all other active SCR related fault codes.

This fault code will become inactive when all other active SCR related fault codes are resolved.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 13-Apr-2016


FAULT CODE 3713 - Aftertreatment 1 Diesel Exhaust Fluid Line Heater Relay - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Delphi® 96 Way Engine Control Module Connector | Refer to Procedure 019-505 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Line Heater Relay | Refer to Procedure 019-600 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box Resistor | Refer to Procedure 019-625 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3713 active?
 | STEP 1B. Check for aftertreatment 1 diesel exhaust fluid (DEF) line heater relay fault codes. | Fault Code 3562 or 3563 active?
STEP 2. | Check the aftertreatment 1 DEF line heater relays. |
 | STEP 2A. Check the aftertreatment 1 DEF line heater relay. | Aftertreatment 1 DEF line heater relay within specifications?
 | STEP 2B. Check the aftertreatment 1 DEF line heater resistor. | Aftertreatment 1 DEF line heater resistor within specifications?
STEP 3. | Check the aftertreatment 1 harness. |
 | STEP 3A. Inspect the aftertreatment 1 connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
 | STEP 3E. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 4A. Inspect the aftertreatment 1 connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 4C. Check for an open circuit. | Less than 10 ohms?
 | STEP 4D. Inspect the OEM harness ECM connector pins. | Dirty or damaged pins?
 | STEP 4E. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 4F. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3713 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for aftertreatment 1 diesel exhaust fluid (DEF) line heater relay fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3562 or 3563 active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 2A

Guided Step 2 - Check the aftertreatment 1 DEF line heater relays.

Guided Step 2A - Inspect aftertreatment 1 DEF line heater relay.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment 1 DEF line heater relay (K11) from the aftertreatment junction box. Refer to Procedure 019-600 in Section 19.

Action

  • Test aftertreatment 1 DEF line heater relay. Refer to Procedure 019-600 in Section 19.

Use the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Aftertreatment 1 DEF line heater relay within specifications?
YES NO
No Repair

Replace the aftertreatment 1 DEF line heater relay (K11). Refer to Procedure 019-600 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Check the aftertreatment 1 DEF line heater resistor.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment 1 DEF line heater resistor (R6) from the aftertreatment junction box. Refer to Procedure 019-625 in Section 19.

Action

  • Test aftertreatment 1 DEF line heater resistor. Refer to Procedure 019-625 in Section 19.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Aftertreatment 1 DEF line heater resistor within specifications?
YES NO
No Repair

Replace the aftertreatment 1 DEF line heater resistor (R6). Refer to Procedure 019-625 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the aftertreatment 1 harness.

Guided Step 3A - Inspect the aftertreatment 1 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.

Action

Inspect the connector(s) for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.
  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.
  • Remove the aftertreatment 1 DEF line heater relay resistor (R6) from the aftertreatment junction box. Refer to Procedure 019-625 in the Associated Procedures Table.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF line heater diagnostic SIGNAL pin in the aftertreatment junction box C5 connector and all other pins in the connector.

Use a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in aftertreatment junction box.

Troubleshoot all wire(s) in series to determine which one contains the short circuit.

Repair or replace the damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF line heater diagnostic SIGNAL pin in the aftertreatment junction box C5 connector and terminal 8 of the aftertreatment 1 DEF line heater relay (K11).

Use a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all wire(s) in series to determine which one contains open circuit. Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Install the aftertreatment 1 DEF line heater relay resistor (R6) in the aftertreatment junction box. Refer to Procedure 019-625 in the Associated Procedures Table.
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF line heater relay RETURN pin in the aftertreatment junction box connector C5 connector and aftertreatment 1 DEF line heater resistor (R6) terminal A.

Use a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all wires in series to determine which one contains open circuit.

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3E

Go to 5A

Guided Step 3E - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF line heater resistor (R6) terminal C and terminal 8 of the aftertreatment 1 DEF line heater relay (K11).

Use a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all wires in series to determine which one contains open circuit.

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine control module (ECM) and original equipment manufacturer (OEM) harness.

Guided Step 4A - Inspect the aftertreatment 1 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness at the aftertreatment 1 connector.

Action

Inspect the connector(s) for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.
  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.
  • Disconnect the OEM harness at the aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF line heater diagnostic SIGNAL pin in the aftertreatment 1 connector and all other pins in the connector.

Use a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harness connections in series to determine which one contains the short circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-071 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.
  • Disconnect the OEM harness at the aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF line heater relay diagnostic SIGNAL pin in the aftertreatment junction box C5 connector and the aftertreatment 1 DEF line heater relay diagnostic SIGNAL pin in the aftertreatment 1 connector.
  • Measure the resistance between the aftertreatment 1 DEF line heater relay RETURN pin in the aftertreatment junction box C5 connector and the aftertreatment 1 DEF line heater relay RETURN pin in the aftertreatment 1 connector.

Use a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all harness connections in series to determine which one contains the open circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-071 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Inspect the OEM harness ECM connector pins.

Conditions

  • Turn keyswitch OFF.D
  • isconnect the OEM connector (J2) from ECM (1).

Action

Inspect the connector(s) for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use a wiring diagram for pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-505 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4E

Guided Step 4E - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector (J2) from ECM (1).
  • Disconnect the OEM harness at the Aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF line heater DIAGNOSTIC SIGNAL pin in the OEM connector (J2) from ECM (1) and all other pins in the connector.

Use a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harness connections in series to determine which one contains the short circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4F

Go to 5A

Guided Step 4F - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector (J2) from ECM (1).
  • Disconnect the OEM harness at the aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF line heater diagnostic SIGNAL pin in the OEM connector (J2) from ECM (1) and the aftertreatment 1 DEF line heater diagnostic SIGNAL pin in the 47 Pin aftertreatment 1 connector.
  • Measure the resistance between the aftertreatment 1 DEF line heater RETURN pin in the OEM connector (J2) from ECM (1) and the aftertreatment 1 DEF line heater RETURN pin in the aftertreatment 1 connector.

Use a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all harness connections in series to determine which one contains open circuit.

Repair or replace damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process.

Repair complete

Last Modified: 04-Apr-2017


FAULT CODE 3714 - Engine Protection Torque Derate - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3714 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 3714

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for other active fault codes.

Fault Code 3714 active?
YES NO

This is an information-only fault code that will only become active if other critical engine performance fault codes are active for an extended period of time.

Troubleshoot all other active fault codes.

This fault code will become inactive when all other active fault codes are resolved.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 06-Apr-2016


FAULT CODE 3718 - Aftertreatment 1 Intake NOx - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3718 active?
STEP 2. | Check the aftertreatment 1 intake nitrogen oxides (NOx) sensor. |
 | STEP 2A. Check for correct adjustable parameter settings. | Electrical system voltage parameter correct for the engine?
 | STEP 2B. Check for correct aftertreatment 1 intake NOx sensor. | Aftertreatment 1 intake NOx sensor the correct sensor for the engine?
 | STEP 2C. Check the condition of the aftertreatment intake NOx sensor. | Fault Code 3718 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3718 active?
YES NO

No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 1 intake nitrogen oxides (NOx) sensor.

Guided Step 2A - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Use INSITE™ electronic service tool "Features and Parameters" feature to determine electrical system voltage.
  • Make sure the electrical system voltage setting in INSITE™ electronic service tool is correct for the engine.

Electrical system voltage parameter correct for the engine?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine.

Go to 2B

Go to 3A

Guided Step 2B - Check for correct aftertreatment 1 intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment 1 intake NOx sensor

Action

Verify aftertreatment 1 intake NOx sensor is the correct sensor for the engine.

The aftertreatment 1 intake NOx sensor is available in 12 volt or 24 volt versions.

Aftertreatment 1 intake NOx sensor is the correct sensor for the engine?
YES NO
No Repair

An incorrect aftertreatment 1 intake NOx sensor for the voltage application has been detected.

Replace the aftertreatment 1 intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check the condition of the aftertreatment 1 intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 1 intake NOx sensor.
  • Start and idle the engine.

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

Fault Code 3718 active?
YES NO

Replace the aftertreatment 1 intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the ”Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 3725 - Aftertreatment 1 Intake NOx Sensor - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active intake nitrogen oxides (NOx) fault codes. | Fault Code 1885, 3232, or 3682 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3725 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active intake nitrogen oxides (NOx) fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1885, 3232 or 3682 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting symptom tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3725 active?
YES NO

An internal error has been detected in the aftertreatment intake NOx sensor.

Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463 in the Associated Procedures Table.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 3727 - High-Pressure Common Rail Fuel Pressure Relief Valve - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | QSK95 CM2350 K113 | 4388663
Injector Supply Line (High Pressure) | Refer to Procedure 006-051 | QSK95 CM2350 K113 | 4388663
Fuel Leak Indicator Tank | Refer to Procedure 006-095 | QSK95 CM2350 K113 | 4388663
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the high-pressure fuel system. |
 | STEP 1A. Check for external fuel leak indicator tank. | Fuel leak indicator tank equipped?
 | STEP 1B. Check for an active fault code. | Active or inactive counts of Fault Code 6594?
 | STEP 1C. Check for external fuel leaks. | High-pressure fuel leaks or damage?
 | STEP 1D. Check the fuel rail pressure sensor. | Fuel rail pressure sensor meets specifications found in Procedure 019-115?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the high-pressure fuel system.

Guided Step 1A - Check for external fuel leak indicator tank.

Conditions

  • Keyswitch OFF.

Action

Check for external fuel leak indicator tank.

  • Verify engine is equipped with fuel leak indicator tank. Refer to Procedure 006-095 in the Associated Procedures Table.

Fuel leak indicator tank equipped?
YES | NO
No Repair | No Repair

Go to 1B

Go to 1C

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 6594?
YES | NO
No Repair | No Repair

Refer to appropriate fault code troubleshooting tree.

Go to 1D

Guided Step 1C - Check for external fuel leaks.

Conditions

  • Operate engine.

Action

Check for external fuel leaks.

Check for fuel leaking from injector supply line outer tube drain plumbing.

High-pressure fuel leaks or damage?
YES NO

Replace any damaged high-pressure fuel system components. Refer to Procedure 006-051 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 1D

Guided Step 1D - Check the fuel rail pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel rail pressure sensor accuracy.

Refer to Procedure 019-115 in the Associated Procedures Table.

Fuel rail pressure sensor meets specifications found in procedure 019-115?
YES NO

Replace the pressure relief valve. Refer to Procedure 005-236 in the Associated Procedures Table.

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process.

Repair complete

Last Modified: 02-Jan-2017


FAULT CODE 3741 - Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSK95 CM2350 K113 | 4388663
Injector Supply Lines (High-Pressure) | Refer to Procedure 006-051 | QSK95 CM2350 K113 | 4388663
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2215, 2261, 2262, 2343, 2372, 4615, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, or 4961 active or inactive counts?
STEP 2. | Check the high-pressure fuel system. |
 | STEP 2A. Check for external fuel leaks. | High-pressure fuel line leaks or damage?
 | STEP 2B. Check the fuel rail pressure sensor. | Sensor reading drops out or is erratic?
 | STEP 2C. Check the fuel rail pressure sensor. | Fuel rail pressure sensor meets specifications found in Procedure 019-115?
STEP 3. | Check the fuel return drain line restriction. |
 | STEP 3A. Check drain line restriction. | Fuel drain line restriction is within the specifications outlined in Procedure 006-012?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2215, 2261, 2262, 2343, 2372, 4615, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, or 4961 active or inactive counts?

YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the high-pressure fuel system.

Guided Step 2A - Check the fuel rail pressure sensor.

Conditions

  • Perform a key cycle.
  • Start the engine and let it idle.

Action

Check the fuel rail pressure sensor for an erratic reading.

  • Monitor the fuel rail pressure sensor reading in INSITE™ electronic service tool.
  • Look for a rail pressure reading that changes sharply or drops out intermittently.

Sensor reading drops out or is erratic?
YES NO

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fuel rail pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel rail pressure sensor.

Check the fuel rail pressure sensor accuracy. Refer to Procedure 019-115 in the Associated Procedures Table.

Fuel rail pressure sensor meets specifications found in Procedure 019-115?
YES NO
No Repair

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the fuel return drain line restriction.

Guided Step 3A - Check the drain line restriction.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Check the drain line restriction.

  • Check for excessive fuel drain line restriction. Refer to Procedure 006-012 in the Associated Procedures Table.

Fuel drain line restriction is within the specifications outlined in Procedure 006-012?
YES NO
No Repair

Repair the source of the high fuel drain line restriction. Refer to Procedure 006-012 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES | NO
No Repair | No Repair

Follow the technical escalation process

Repair complete

Last Modified: 02-Jan-2017


FAULT CODE 3748 - Aftertreatment 1 Intake NOx Sensor - Data Not Rational - Drifted High

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3748 active?
 | STEP 1B. Check for active fault codes. | Fault Codes 3652, 3725, 3682, or 3649 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3748 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3652, 3725, 3682, or 3649 active?
YES NO
No Repair

Verify the aftertreatment 1 intake nitrogen oxides (NOx) sensor is present and has been installed properly.

If the aftertreatment 1 intake NOx sensor is present and installed properly, a damaged aftertreatment intake NOx sensor is a possible cause.

Replace the aftertreatment 1 intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 13-Apr-2016


FAULT CODE 3866 - Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 3866. | Fault Code 3866 active?
STEP 2. | Check the diesel exhaust fluid (DEF) concentration. |
 | STEP 2A. Check the DEF tank for contamination. | Diesel fuel detected in the DEF tank?
 | STEP 2B. Check the aftertreatment DEF concentration. | DEF concentration within 32.5 ± 1.25 percent?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 3866.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3866 active?
YES | NO
No Repair | No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check the diesel exhaust fluid (DEF) concentration.

Guided Step 2A - Check the DEF tank for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF for contamination.

  • Inspect the DEF tank for diesel fuel.

Diesel fuel detected in the DEF tank?
YES NO

Drain the DEF tank. Flush and clean the DEF tank with distilled water.

Fill the tank with fresh DEF.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the DEF concentration.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF concentration.

  • Use DEF refractometer, Part Number 4919318, to measure the concentration of the DEF in the tank.

DEF concentration within 32.5 ± 1.5 percent?
YES NO

A malfunctioning DEF quality sensor has been detected.

See equipment manufacturer service information.

Drain the DEF tank and fill with new DEF.

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 3867 - Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 3867. | Fault Code 3867 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) concentration. |
 | STEP 2A. Check the DEF concentration. | DEF concentration within 32.5 ± 1.5 percent?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 3867.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3867 active?
YES | NO
No Repair | No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check the aftertreatment diesel exhaust fluid (DEF) concentration.

Guided Step 2A - Check the DEF concentration.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF concentration.

  • Use DEF refractometer, Part Number 4919318, to measure the concentration of the DEF in the tank.

DEF concentration within 32.5 ± 1.5 percent?
YES NO

A malfunctioning DEF quality sensor has been detected.

Drain the DEF fluid tank and fill with new DEF.

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 3868 - Aftertreatment Diesel Exhaust Fluid Quality - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3868 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) level/temperature/quality sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF level/temperature/quality sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment DEF level/temperature/quality sensor. | Voltage within 1 VDC of ECM power supply voltage?
STEP 3. | Check the original equipment manufacturer (OEM) wiring harness. |
 | STEP 3A. Check the ECM power supply and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check for an open circuit in the aftertreatment DEF level/temperature/quality sensor voltage supply. | Voltage within 1 VDC of ECM power supply voltage?
STEP 4. | Check the J1939 data link harness. |
 | STEP 4A. Check the J1939 data link circuit. | Open or short detected in harness?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3868 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment diesel exhaust fluid (DEF) level/temperature/quality sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DEF level/temperature/quality sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank level/temperature/quality sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment DEF level/temperature/quality sensor

Conditions

  • Turn keyswitch OFF.
  • Disconnect the DEF level/temperature/quality sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment DEF level/temperature/quality sensor.

  • Measure the voltage between the aftertreatment DEF level/temperature/quality sensor battery voltage supply circuit and the aftertreatment DEF level/temperature/quality sensor ECM power supply voltage return circuit at the sensor wiring harness connector.

Check the voltage at key ON, while cranking the engine and with the engine at idle.

Use the wiring diagram for connector pin identification.

Use the following procedure for general measurement techniques. Refer to Procedure 019-360 in Section 19.

Voltage within 1 VDC of ECM power supply voltage?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the original equipment manufacturer (OEM) wiring harness.

Guided Step 3A - Check the ECM power supply and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the ECM power supply connections.

  • Check the ECM power supply terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections and clean the terminals. See equipment manufacturer service information.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit in the aftertreatment DEF level/temperature/quality sensor voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF level/temperature/quality sensor from the OEM wiring harness.

Action

Check for an open circuit.

  • Measure the voltage from the aftertreatment DEF level/temperature/quality sensor ECM power supply voltage SUPPLY pin of the OEM wiring harness connector to ECM power supply ground.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Refer to Procedure 019-610 in the Associated Procedures Table.

Voltage within 1 VDC of ECM power supply voltage?
YES NO

An open circuit has been detected in the aftertreatment DEF level/temperature/quality sensor ECM power supply voltage return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

An open circuit has been detected in the DEF quality sensor ECM power supply voltage.

Troubleshoot the OEM harness, any fuses, and/or relays in the supply circuit.

Repair or replace the necessary components.

Go to 5A

Go to 5A

Guided Step 4 - Check the J1939 data link harness.

Guided Step 4A - Check the J1939 data link circuit.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the Society of Automotive Engineers (SAE) J1939 data link 4 circuit.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Open or short detected in harness?
YES NO

A damaged J1939 data link has been detected in the harness.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 3878 - Aftertreatment Diesel Exhaust Fluid Quality - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 3878. | Fault Code 3878 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) concentration. |
 | STEP 2A. Check the aftertreatment DEF concentration. | Aftertreatment DEF concentration within 32.5 ± 1.5 percent?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 3878.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3878 active?
YES | NO
No Repair | No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check the aftertreatment diesel exhaust fluid (DEF) concentration.

Guided Step 2A - Check the DEF concentration.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF concentration.

  • Use a DEF refractometer, Part Number 4919318, to measure the concentration of the DEF in the tank.

DEF concentration within 32.5 ± 1.5 percent?
YES NO

A malfunctioning aftertreatment DEF quality sensor has been detected.

  • Replace the aftertreatment DEF quality sensor.

Drain the DEF tank and fill with new DEF.

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 3925 - Engine Turbocharger Wastegate Actuator 1 Position - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Turbocharger Wastegate Assembly | Refer to Procedure 011-097 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 active?
STEP 2. | Check the turbocharger wastegate 1 motor and circuit. |
 | STEP 2A. Inspect the turbocharger wastegate 1 motor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 3925 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check for an open circuit in the engine harness. |
 | STEP 3A-2. Check for a short circuit in the engine harness. |
 | STEP 3A-3. Check for a short circuit to ground. |
 | STEP 3A-4. Check the fault codes. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Fault Code 187 troubleshooting tree

Go to 2A

Guided Step 2 - Check the turbocharger wastegate 1 motor and circuit.

Guided Step 2A - Inspect the turbocharger wastegate 1 motor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger wastegate 1 from the engine harness.

Action

Inspect the engine harness and the turbocharger wastegate 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the wastegate connector or engine harness connector.

Clean the connector and pins.

Repair the damaged pins. Repair or replace the engine harness, or replace the wastegate motor, whichever has the damaged pins.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger wastegate 1 from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the turbocharger wastegate 1 position +5 volt SUPPLY pin to the turbocharger wastegate 1 position RETURN pin at the turbocharger wastegate 1 connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3B

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger wastegate 1 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3925 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged pins. Repair or replace the engine harness, or replace the wastegate motor, whichever has the damaged pins.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the turbocharger wastegate 1.

Action

Check for an open circuit in the turbocharger wastegate 1 position circuit.

  • Measure the resistance between the turbocharger wastegate 1 position SIGNAL A pin at the turbocharger wastegate 1 engine harness connector and the turbocharger wastegate 1 position SIGNAL A pin at the ECM engine harness connector.
  • Measure the resistance between the turbocharger wastegate 1 position SIGNAL B pin at the turbocharger wastegate 1 engine harness connector and the turbocharger wastegate 1 position SIGNAL B pin at the ECM engine harness connector.
  • Measure the resistance between the turbocharger wastegate 1 position SIGNAL C pin at the turbocharger wastegate 1 engine harness connector and the turbocharger wastegate 1 position SIGNAL C pin at the ECM engine harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the turbocharger wastegate 1.

Action

Check for a short circuit in the turbocharger wastegate 1 position circuit.

  • Measure the resistance between the turbocharger wastegate 1 position SIGNAL A pin at the ECM engine harness connector and all other pins in the ECM connector.
  • Measure the resistance between the turbocharger wastegate 1 position SIGNAL B pin at the ECM engine harness connector and all other pins in the ECM connector.
  • Measure the resistance between the turbocharger wastegate 1 position SIGNAL C pin at the ECM engine harness connector and all other pins in the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which one contains the short circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A-3

Go to 4A

Guided Step 3A-3 - Check for a short circuit to ECM power supply ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the turbocharger wastegate 1.

Action

Check for a short circuit to ECM power supply ground.

  • Refer to Procedure 019-610 in the Associated Procedures Table.
  • Measure the resistance between the turbocharger wastegate 1 position SIGNAL A pin at the ECM engine harness connector and ECM power supply ground.
  • Measure the resistance between the turbocharger wastegate 1 position SIGNAL B pin at the ECM engine harness connector and ECM power supply ground.
  • Measure the resistance between the turbocharger wastegate 1 position SIGNAL C pin at the ECM engine harness connector and ECM power supply ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ECM power supply ground has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which one contains the short circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A-4

Go to 4A

Guided Step 3A-4 - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the ECM.
  • Connect the turbocharger wastegate 1 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3925 active?
YES NO

Replace the turbocharger wastegate. Refer to Procedure 011-097 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged pins. Repair or replace the engine harness, or replace the wastegate motor, whichever has the damaged pins.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the turbocharger wastegate 1 position +5 volt SUPPLY pin to the turbocharger wastegate 1 position RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3925 active?
YES NO

An open wastegate position supply or return circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which one contains the short circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 13-Apr-2016


FAULT CODE 3969 - Engine Turbocharger Wastegate Actuator 1 Position - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Turbocharger Wastegate Assembly | Refer to Procedure 011-097 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for turbocharger wastegate 1 motor circuit fault codes. | Fault Code 3969 active?
STEP 2. | Check the turbocharger wastegate 1 motor and circuit. |
 | STEP 2A. Inspect the turbocharger wastegate 1 valve motor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the turbocharger wastegate 1 motor. | Greater than 100k ohms?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 3696 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for turbocharger wastegate 1 motor circuit fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3969 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the turbocharger wastegate 1 motor and circuit.

Guided Step 2A - Inspect the turbocharger wastegate 1 motor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger wastegate 1 motor from the engine harness.

Action

Inspect the engine harness and turbocharger wastegate 1 motor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the motor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the turbocharger wastegate 1 motor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger wastegate 1 motor from the engine harness.
  • Turn keyswitch ON.

Action

Check the turbocharger wastegate 1 motor.

  • Measure the resistance from the turbocharger wastegate 1 motor SIGNAL A pin at the turbocharger wastegate 1 motor connector to ECM power supply ground.
  • Measure the resistance from the turbocharger wastegate 1 motor SIGNAL B pin at the turbocharger wastegate 1 motor connector to ECM power supply ground.
  • Measure the resistance from the turbocharger wastegate 1 motor SIGNAL C pin at the turbocharger wastegate 1 motor connector to ECM power supply ground.

Refer to the the wiring diagram for connector pin identification.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the turbocharger wastegate 1 motor.

  • Replace the turbocharger wastegate 1 motor. Refer to Procedure 011-097 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the turbocharger wastegate 1 motor from the engine harness.

Action

Check the turbocharger wastegate 1 motor SIGNAL pins for a short circuit to ground.

  • Measure the resistance from the turbocharger wastegate 1 motor SIGNAL A pin at the turbocharger wastegate 1 motor engine harness connector to ECM power supply ground.
  • Measure the resistance from the turbocharger wastegate 1 motor SIGNAL B pin at the turbocharger wastegate 1 motor engine harness connector to ECM power supply ground.
  • Measure the resistance from the turbocharger wastegate 1 motor SIGNAL C pin at the turbocharger wastegate 1 motor engine harness connector to ECM power supply ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the turbocharger wastegate 1 motor from the engine harness.

Action

Check the turbocharger wastegate 1 motor SIGNAL pins for a pin-to-pin short circuit.

  • Measure the resistance from the turbocharger wastegate 1 motor SIGNAL A pin at the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from the turbocharger wastegate 1 motor SIGNAL B pin at the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from the turbocharger wastegate 1 motor SIGNAL C pin at the engine harness ECM connector to all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3696 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 3971 - Engine Turbocharger Wastegate Actuator 1 Position - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Turbocharger Wastegate Assembly | Refer to Procedure 011-097 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for turbocharger wastegate 1 motor circuit fault codes. | Fault Code 3971 active?
STEP 2. | Check the turbocharger wastegate 1 motor and circuit. |
 | STEP 2A. Inspect the turbocharger wastegate 1 motor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the turbocharger wastegate 1 motor. | Greater than 5 ohms?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the turbocharger wastegate 1 motor supply and return circuit. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for the turbocharger wastegate 1 motor circuit fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3971 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the turbocharger wastegate 1 motor and circuit.

Guided Step 2A - Inspect the turbocharger wastegate 1 motor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger wastegate 1 motor from the engine harness.

Action

Inspect the engine harness and turbocharger wastegate 1 motor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the motor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the turbocharger wastegate 1 motor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger wastegate 1 motor from the engine harness.

Action

Check the turbocharger wastegate 1 motor supply and return circuit.

  • Measure the resistance from the turbocharger wastegate 1 motor SIGNAL A pin to the turbocharger wastegate 1 motor SIGNAL B pin at the turbocharger wastegate 1 motor connector.
  • Measure the resistance from the turbocharger wastegate 1 motor SIGNAL A pin to the turbocharger wastegate 1 motor SIGNAL C pin at the turbocharger wastegate 1 motor connector.
  • Measure the resistance from the turbocharger wastegate 1 motor SIGNAL B pin to the turbocharger wastegate 1 motor SIGNAL C pin at the turbocharger wastegate 1 motor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 5 ohms?
YES NO

An open circuit has been detected in the turbocharger wastegate 1 motor. Replace the turbocharger wastegate 1. Refer to Procedure 011-097 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine control module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the turbocharger wastegate 1 motor supply and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the turbocharger wastegate 1 motor from the engine harness.

Action

Check the turbocharger wastegate 1 motor supply and return circuit.

  • Measure the resistance from the turbocharger wastegate 1 motor SIGNAL A pin at the turbocharger wastegate 1 motor engine harness connector to the turbocharger wastegate 1 motor SIGNAL A pin at the ECM connector.
  • Measure the resistance from the turbocharger wastegate 1 motor SIGNAL B pin at the EGR motor engine harness connector to the turbocharger wastegate 1 motor SIGNAL B pin at the ECM connector.
  • Measure the resistance from the turbocharger wastegate 1 motor SIGNAL C pin at the turbocharger wastegate 1 motor engine harness connector to the turbocharger wastegate 1 motor SIGNAL C pin at the ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which one contains the open circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 06-Apr-2016


FAULT CODE 3972 - Engine Turbocharger Wastegate Actuator 2 Position - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Turbocharger Wastegate Assembly | Refer to Procedure 011-097 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 active?
STEP 2. | Check the turbocharger wastegate 2 motor and circuit. |
 | STEP 2A. Inspect the turbocharger wastegate 2 motor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 3972 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check for an open circuit in the engine harness. |
 | STEP 3A-2. Check for a short circuit in the engine harness. |
 | STEP 3A-3. Check for a short circuit to ground. |
 | STEP 3A-4. Check the fault codes. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Fault Code 187 troubleshooting tree

Go to 2A

Guided Step 2 - Check the turbocharger wastegate 2 motor and circuit.

Guided Step 2A - Inspect the turbocharger wastegate 2 motor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger wastegate 2 from the engine harness.

Action

Inspect the engine harness and turbocharger wastegate 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the wastegate connector or engine harness connector.

Clean the connector and pins, if possible.

Repair or replace the engine harness or replace the wastegate motor, whichever has the damaged pins.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger wastegate 2 from the engine harness
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the turbocharger wastegate 2 position +5 volt SUPPLY pin to the turbocharger wastegate 2 position RETURN pin at the turbocharger wastegate 2 connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3B

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger wastegate 2 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3972 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair or replace the engine harness or replace the wastegate motor, whichever has the damaged pins.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the turbocharger wastegate 2.

Action

Check for an open circuit in the wastegate position circuit.

  • Measure the resistance between the turbocharger wastegate 2 position SIGNAL A pin at the turbocharger wastegate 2 engine harness connector and the turbocharger wastegate 2 position SIGNAL A pin at the ECM engine harness connector.
  • Measure the resistance between the turbocharger wastegate 2 position SIGNAL B pin at the turbocharger wastegate 2 engine harness connector and the turbocharger wastegate 2 position SIGNAL B pin at the ECM engine harness connector.
  • Measure the resistance between the turbocharger wastegate 2 position SIGNAL C pin at the turbocharger wastegate 2 engine harness connector and the turbocharger wastegate 2 position SIGNAL C pin at the ECM engine harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the turbocharger wastegate 2.

Action

Check for a short circuit in the wastegate position circuit.

  • Measure the resistance between the turbocharger wastegate 2 position SIGNAL A pin at the ECM engine harness connector and all other pins in the ECM connector.
  • Measure the resistance between the turbocharger wastegate 2 position SIGNAL B pin at the ECM engine harness connector and all other pins in the ECM connector.
  • Measure the resistance between the turbocharger wastegate 2 position SIGNAL C pin at the ECM engine harness connector and all other pins in the ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which one contains the short circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A-3

Go to 4A

Guided Step 3A-3 - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the turbocharger wastegate 2.

Action

Check for a short circuit to ground.

  • Measure the resistance between the turbocharger wastegate 2 position SIGNAL A pin at the ECM engine harness connector and ECM power supply ground.
  • Measure the resistance between the turbocharger wastegate 2 position SIGNAL B pin at the ECM engine harness connector and ECM power supply ground.
  • Measure the resistance between the turbocharger wastegate 2 position SIGNAL C pin at the ECM engine harness connector and ECM power supply ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which one contains the short circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A-4

Go to 4A

Guided Step 3A-4 - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the ECM.
  • Connect the turbocharger wastegate 2 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3972 active?
YES NO

Replace the turbocharger wastegate.

  • Refer to Procedure 011-097 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair or replace the engine harness or replace the wastegate motor, whichever has the damaged pins.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the turbocharger wastegate 2 position +5 volt SUPPLY pin to turbocharger wastegate 2 position RETURN pin at the ECM.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3972 active?
YES NO

An open turbocharger wastegate position supply or return circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 06-Apr-2016


FAULT CODE 3973 - Engine Turbocharger Wastegate Actuator 2 Position Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Turbocharger Wastegate Assembly | Refer to Procedure 011-097 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for turbocharger wastegate 2 motor circuit fault codes. | Fault Code 3973 active?
STEP 2. | Check the turbocharger wastegate 2 motor and circuit. |
 | STEP 2A. Inspect the turbocharger wastegate 2 motor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the turbocharger wastegate 2 motor. | Greater than 100k ohms?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 3973 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for turbocharger wastegate 2 motor circuit fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3973 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the turbocharger wastegate 2 motor and circuit.

Guided Step 2A - Inspect the turbocharger wastegate 2 motor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger wastegate 2 from the engine harness.

Action

Inspect the engine harness and turbocharger wastegate 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the motor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the turbocharger wastegate 2 motor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger wastegate 2 from the engine harness.
  • Turn keyswitch ON.

Action

Check the turbocharger wastegate 2 motor.

  • Measure the resistance from the turbocharger wastegate 2 SIGNAL A pin at the turbocharger wastegate 2 motor connector to ECM power supply ground.
  • Measure the resistance from the turbocharger wastegate 2 SIGNAL B pin at the turbocharger wastegate 2 motor connector to ECM power supply ground.
  • Measure the resistance from the turbocharger wastegate 2 SIGNAL C pin at the turbocharger wastegate 2 motor connector to ECM power supply ground.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the turbocharger wastegate 2 motor.

  • Replace the turbocharger wastegate 2. Refer to Procedure 011-097 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the turbocharger wastegate 2 from the engine harness.

Action

Check the turbocharger wastegate 2 SIGNAL pins for a short circuit to ground.

  • Measure the resistance from the turbocharger wastegate 2 SIGNAL A pin at the turbocharger wastegate 2 motor engine harness connector to ECM power supply ground.
  • Measure the resistance from the turbocharger wastegate 2 SIGNAL B pin at the turbocharger wastegate 2 motor engine harness connector to ECM power supply ground.
  • Measure the resistance from the turbocharger wastegate 2 SIGNAL C pin at the turbocharger wastegate 2 motor engine harness connector to ECM power supply ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which one contains the short circuit.

  • Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the turbocharger wastegate 2 from the engine harness.

Action

Check the turbocharger wastegate 2 motor SIGNAL pins for a pin-to-pin short.

  • Measure the resistance from the turbocharger wastegate 2 motor SIGNAL A pin at the ECM connector to all other pins in the ECM connector.
  • Measure the resistance from the turbocharger wastegate 2 motor SIGNAL B pin at the ECM connector to all other pins in the ECM connector.
  • Measure the resistance from the turbocharger wastegate 2 motor SIGNAL C pin at the ECM connector to all other pins in the ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which one contains the short circuit.

  • Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3973 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 06-Apr-2016


FAULT CODE 3974 - Engine Turbocharger Wastegate Actuator 2 Position Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Turbocharger Wastegate Assembly | Refer to Procedure 011-097 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for turbocharger wastegate 2 motor circuit fault codes. | Fault Code 3974 active?
STEP 2. | Check the turbocharger wastegate 2 motor and circuit. |
 | STEP 2A. Inspect the turbocharger wastegate 2 motor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the turbocharger wastegate 2 motor. | Greater than 5 ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 3974 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the turbocharger wastegate 2 motor signal and return circuit. | Less than 10 ohms?
 | STEP 3C. Check for an active fault code. | Fault Code 3974 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for turbocharger wastegate 2 motor circuit fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3974 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the turbocharger wastegate 2 motor and circuit.

Guided Step 2A - Inspect the turbocharger wastegate 2 motor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger wastegate 2 from the engine harness.

Action

Inspect the engine harness and turbocharger wastegate 2 motor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the motor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the turbocharger wastegate 2 motor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger wastegate 2 from the engine harness.

Action

Check the turbocharger wastegate 2 motor signal and return circuit.

  • Measure the resistance from the turbocharger wastegate 2 motor SIGNAL A pin to the turbocharger wastegate 2 motor SIGNAL B pin at the turbocharger wastegate 2 connector.
  • Measure the resistance from the turbocharger wastegate 2 motor SIGNAL A pin to the turbocharger wastegate 2 motor SIGNAL C pin at the turbocharger wastegate 2 connector.
  • Measure the resistance from the turbocharger wastegate 2 motor SIGNAL B pin to the turbocharger wastegate 2 motor SIGNAL C pin at the turbocharger wastegate 2 connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 5 ohms?
YES NO

An open circuit has been detected in the turbocharger wastegate 2 motor.

Replace the turbocharger wastegate 2. Refer to Procedure 011-097 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine control module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the turbocharger wastegate 2 motor signal and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the turbocharger wastegate 2 from the engine harness.

Action

Check the turbocharger wastegate 2 motor signal and return circuit.

  • Measure the resistance from the turbocharger wastegate 2 motor SIGNAL A pin at the turbocharger wastegate 2 engine harness connector to the turbocharger wastegate 2 motor SIGNAL A pin at the engine harness ECM connector.
  • Measure the resistance from the turbocharger wastegate 2 motor SIGNAL B pin at the turbocharger wastegate 2 engine harness connector to the turbocharger wastegate 2 motor SIGNAL B pin at the engine harness ECM connector.
  • Measure the resistance from the turbocharger wastegate 2 motor SIGNAL C pin at the turbocharger wastegate 2 engine harness connector to the turbocharger wastegate 2 motor SIGNAL C pin at the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 13-Apr-2016


FAULT CODE 3982 - Aftertreatment 2 Intake NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4145 Intake Nitrogen Oxides (NOx) Sensor - Abnormal Update Rate or Fault Code 4528 Intake NOx Sensor Power Supply - Data Erratic active?
 | STEP 1B. Check for active fault codes. | Fault Code 3982 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4145 Intake Nitrogen Oxides (NOx) Sensor - Abnormal Update Rate or Fault Code 4528 Intake NOx Sensor Power Supply - Data Erratic active?

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3982 active?
YES NO

An internal error has been detected in the aftertreatment 2 intake NOx sensor.

Replace the aftertreatment 2 intake NOx sensor.

Refer to Procedure 019-463 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 3984 - Aftertreatment 2 Intake NOx Sensor - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3984 active?
STEP 2. | Check the aftertreatment 2 intake nitrogen oxides (NOx) sensor. |
 | STEP 2A. Check for correct adjustable parameter settings. | Electrical system voltage parameter correct for the engine control parts list (CPL)?
 | STEP 2B. Check for correct aftertreatment 2 intake NOx sensor. | Aftertreatment 2 intake NOx sensor is the correct sensor for the engine?
 | STEP 2C. Check the condition of the aftertreatment 2 intake NOx sensor. | Fault Code 3984 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3984 active?
YES NO

No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 2 intake nitrogen oxides (NOx) sensor.

Guided Step 2A - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Use INSITE™ electronic service tool "Features and Parameters" feature to determine electrical system voltage.
  • Verify the electrical system voltage setting in INSITE™ electronic service tool.

Electrical system voltage parameter correct for the engine control parts list (CPL)?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage.

Go to 2B

Go to 3A

Guided Step 2B - Check for correct aftertreatment 2 intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment intake NOx sensor.

Action

Verify aftertreatment 2 intake NOx sensor is the correct sensor.

  • The aftertreatment 2 intake NOx sensor is available in 12 volt or 24 volt versions.

Aftertreatment 2 intake NOx sensor is the correct sensor for the engine?
YES NO
No Repair

An incorrect aftertreatment 2 intake NOx sensor for the voltage application has been detected.

  • Replace the aftertreatment 2 intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check the condition of the aftertreatment 2 intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 2 intake NOx sensor.
  • Start and idle the engine.

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

Fault Code 3984 active?
YES NO

  • Replace the aftertreatment 2 intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 3985 - Aftertreatment 2 Intake NOx Sensor - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3982, 4145, or 4528 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3985 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3982, 4145, or 4528 active?
YES | NO
No Repair | No Repair

Go to the appropriate Fault Code troubleshooting symptom tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3985 active?
YES NO

An internal error has been detected in the aftertreatment 2 intake mono-nitrogen oxide (NOx) sensor.

Replace the aftertreatment 2 intake NOx sensor.

Refer to Procedure 019-463 in the Associated Procedures Table.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Go to

Repair complete.

Last Modified: 25-Jan-2017


FAULT CODE 3986 - Aftertreatment 2 Intake NOx Sensor - Data Not Rational - Drifted High

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3986 active?
 | STEP 1B. Check for active fault codes. | Fault Codes 3982 Intake NOx Sensor Circuit - Voltage Below Normal, 4145 Intake Nox Sensor - Abnormal Update Rate, or 4528 Intake NOx Sensor Power Supply - Data Erratic, 4122 Intake NOx Sensor Heater - Abnormal Rate of Change active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3986 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3982 Intake NOx Sensor Circuit - Voltage Below Normal, 4145 Intake Nox Sensor - Abnormal Update Rate, or 4528 Intake NOx Sensor Power Supply - Data Erratic, 4122 Intake NOx Sensor Heater - Abnormal Rate of Change active?

YES NO
No Repair

Verify the aftertreatment 2 intake nitrogen oxides (NOx) sensor is present and has been installed properly.

If the aftertreatment 2 intake NOx sensor is present and installed properly, a damaged aftertreatment 2 intake NOx sensor is a possible cause.

Replace the aftertreatment 2 intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 3988 - Aftertreatment 2 Outlet NOx Sensor - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Aftertreatment Sensor Power Relay | Refer to Procedure 019-607 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes | Fault Code 3988 active?
 | STEP 1B. Check for active J1939 Network number 4 fault codes. | Fault Code 4437 active?
 | STEP 1C. Check for active outlet NOx sensor fault codes. | Fault Code 4529 active?
 | STEP 1D. Check for active intake NOx sensor or selective catalytic reduction (SCR) temperature sensor fault codes. | Fault Codes 4145 and 5725 active?
STEP 2. | Check the aftertreatment 2 outlet NOx sensor circuit. |
 | STEP 2A. Inspect the aftertreatment 2 outlet NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment 2 outlet NOx sensor. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 2C. Check the J1939 terminating resistance. | 50 to 70 ohms?
 | STEP 2D. Check for an open circuit in the aftertreatment 2 outlet NOx sensor ECM power supply voltage supply. | Voltage within 1 VDC of ECM power supply voltage?
STEP 3. | Check the harness. |
 | STEP 3A. Inspect the aftertreatment 2 outlet NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the voltage to the aftertreatment 2 outlet NOx sensor. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3C. Check the voltage to the aftertreatment 2 outlet NOx sensor. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3D. Inspect aftertreatment 2 power relay and connector pins. | Dirty or damaged pins?
 | STEP 3E. Check the voltage to the aftertreatment power relay. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3F. Check the aftertreatment power relay. | Connections tight and corrosion-free?
STEP 4. | Check the J1939 data link 4. |
 | STEP 4A. Check the J1939 terminating resistance on the OEM harness. | 110 to 130 ohms?
 | STEP 4B. Check the J1939 terminating resistance on the engine harness. | 110 to 130 ohms?
 | STEP 4C. Inspect ECM and original equipment manufacturer (OEM) connector pins. | Dirty or damaged pins?
 | STEP 4D. Check for an open circuit in the J1939 data link harness. | All measurements less than 10 ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3988 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active J1939 Network number 4 fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4437 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for active outl NOx sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4529 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1D

Guided Step 1D - Check for active intake NOx sensor or SCR temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 4145 and 5725 both active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the aftertreatment 2 outlet NOx sensor circuit.

Guided Step 2A - Inspect the aftertreatment 2 outlet NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 outlet NOx sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment 2 outlet NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged OEM harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

Replace the aftertreatment outlet NOx sensor only when there are damaged pins. Refer to Procedure 019-451 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment 2 outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment 2 outlet NOx sensor.

  • Measure the voltage between the aftertreatment 2 outlet NOx sensor ECM power supply voltage supply circuit and the aftertreatment 2 outlet NOx sensor return circuit at the NOx sensor wiring harness connector.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of ECM power supply voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2D

Guided Step 2C - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Measure the terminating resistance of the Society of Automotive Engineers (SAE) J1939 data link.

  • Measure the resistance between the SAE J1939 data link (+) wire and the J1939 data link (-) wire at the aftertreatment 2 outlet NOx sensor OEM harness connector.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 to 70 ohms?
YES NO

  • Replace the aftertreatment 2 outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

An open circuit has been detected on the SAE J1939 data link (+) or (-) wire between the outlet NOx sensor and the data link backbone connection.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 5A

Guided Step 2D - Check for an open circuit in the aftertreatment 2 outlet NOx sensor ECM power supply voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure the voltage from the aftertreatment 2 outlet NOx sensor ECM power supply voltage SUPPLY pin of the OEM harness to ECM power supply ground.

Voltage within 1 VDC of ECM power supply voltage?
YES NO

An open circuit has been detected in the aftertreatment 2 outlet NOx sensor ECM power supply voltage return circuit.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For OEM harness: Refer to Procedure 019-071 in Section 19.
  • For engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

An open circuit has been detected in the aftertreatment 2 outlet NOx sensor ECM power supply voltage supply circuit between the aftertreatment 2 power relay and the outlet NOx sensor.

Check for a blown or missing fuse in the aftertreatment 2 outlet NOx sensor ECM power supply voltage supply circuit. Troubleshoot all harnesses connected in series to determine which one contains the open. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For OEM harness: Refer to Procedure 019-071 in Section 19.
  • For engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 3 - Check the harness.

Guided Step 3A - Inspect the aftertreatment 2 outlet NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 outlet NOx sensor from the OEM harness

Action

Inspect the OEM harness and aftertreatment 2 outlet NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged OEM harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

Replace the aftertreatment outlet NOx sensor only when there are damaged pins. Refer to Procedure 019-451 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the voltage to the aftertreatment 2 outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment 2 outlet NOx sensor.

  • Measure the voltage between the aftertreatment 2 outlet NOx sensor ECM power supply voltage supply circuit and the aftertreatment 2 outlet NOx sensor return circuit at the NOx sensor wiring harness connector.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of ECM power supply voltage?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the voltage to the aftertreatment 2 outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment 2 outlet NOx sensor.

  • Measure the voltage from the aftertreatment 2 outlet NOx sensor ECM power supply voltage SUPPLY pin of the OEM harness outlet NOx sensor connector to ECM power supply ground.

Voltage within 1 VDC of ECM power supply voltage?
YES NO

An open circuit has been detected in the aftertreatment 2 outlet NOx sensor ECM power supply voltage return circuit.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For OEM harness: Refer to Procedure 019-071 in Section 19.
  • For engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3D

Guided Step 3D - Inspect aftertreatment 2 power relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.

Action

Inspect the engine harness and aftertreatment power relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the relay or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace aftertreatment power relay only when there are damaged pins. Refer to Procedure 019-607 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3E

Guided Step 3E - Check the voltage to the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 power relay from the engine harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment power relay.

  • Measure the voltage between the aftertreatment power relay ECM power supply voltage SUPPLY pin in the aftertreatment power relay connector of the engine harness and ECM power supply ground.

Voltage within 1 VDC of ECM power supply voltage?
YES NO
No Repair

An open circuit has been detected in the aftertreatment power ECM power supply voltage supply circuit before the power relay.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of harness.

  • For OEM harness: Refer to Procedure 019-071 in Section 19.
  • For engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 5A

Guided Step 3F - Check the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.

Action

Check for a damaged aftertreatment power relay.

  • Install a jumper wire from pin 85 on the aftertreatment power relay to ECM power supply + and connect a jumper wire from pin 86 on the aftertreatment power relay to chassis ground.
  • Measure the resistance between pin 30 and pin 87 on the aftertreatment power relay.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Connections tight and corrosion-free?
YES NO
No Repair

An open circuit or short circuit to ECM power supply ground has been detected in the aftertreatment 2 outlet NOx sensor power supply circuit.

This could be caused by:

  • Blown in-line fuse on the outlet NOx sensor power supply circuit.
  • Open circuit or short to ECM power supply ground in the outlet NOx sensor power supply circuit.

Replace the inline fuse, if it is blown.

Troubleshoot all harnesses connected in series to determine which one contains the open or shorted circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For OEM harness: Refer to Procedure 019-071 in Section 19.
  • For engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Check the J1939 data link 4.

Guided Step 4A - Check the J1939 terminating resistance on the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness at the 47 pin aftertreatment 2 connector.

Action

Measure the terminating resistance of the SAE J1939 data link 4.

  • Measure the resistance between the SAE J1939 data link 4 (+) wire and the J1939 data link 4 (-) wire at the 47 pin aftertreatment 2 OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

110 to 130 ohms?
YES NO
No Repair

Incorrect terminating resistance or an open circuit has been detected on the SAE J1939 data link 4 circuit in the OEM harness.

  • Remove excess terminating resistors. Replace any damaged or missing terminating resistor.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

Repair or replace the damaged section of the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check the J1939 terminating resistance on the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness at the 47 pin aftertreatment 2 connector.

Action

Measure the terminating resistance of the SAE J1939 data link 4.

  • Measure the resistance between the SAE J1939 data link 4 (+) wire and the J1939 data link 4 (-) wire at the 47 pin aftertreatment 2 OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

110 to 130 ohms?
YES NO
No Repair

Incorrect terminating resistance or an open circuit has been detected on the SAE J1939 data link 4 circuit in the engine harness.

  • Remove excess terminating resistors. Replace any damaged or missing terminating resistor.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the OEM and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only when there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4D

Guided Step 4D - Check for an open circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness and engine harness at the aftertreatment 2 connector.
  • Disconnect the OEM connector from the ECM.

Action

Check for an open circuit in the J1939 data link 4.

  • Measure the resistance between the SAE J1939 data link 4 (+) wire at the engine harness aftertreatment 2 connector and the SAE J1939 data link 4 (+) wire at the ECM OEM harness connector.
  • Measure the resistance between the SAE J1939 data link 4 (−) wire at the engine harness aftertreatment 2 connector and the SAE J1939 data link 4 (−) wire at the ECM OEM harness connector

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the J1939 data link 4.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 06-Apr-2016


FAULT CODE 3995 - Aftertreatment 2 Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active outlet nitrogen oxides (NOx) fault codes. | Fault Code 3988 or 4529 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3995 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active outlet nitrogen oxides (NOx) fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3988 or 4529 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3995 active?
YES NO

An internal error has been detected in the aftertreatment 2 outlet NOx sensor.

Replace the aftertreatment 2 outlet NOx sensor.

Refer to Procedure 019-451 in the Assoicated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 3998 - Aftertreatment 2 SCR Catalyst Intake Gas Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active selective catalytic reduction (SCR) temperature sensor fault codes. | Fault Code 5725, 5727, 5728, 5729, or 5731 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active SCR temperature sensor fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect NSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 5725, 5727, 5728, 5729, or 5731 active?
YES NO
No Repair

A malfunctioning aftertreatment 2 SCR temperature sensor module has been detected.

Replace the aftertreatment 2 SCR temperature sensor module. Refer to procedure 019-449 in the Associated Procedures Table.

Go to appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Go to 1A

Repair complete

Last Modified: 29-Dec-2016


FAULT CODE 3999 - Aftertreatment 2 SCR Catalyst Intake Gas Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Turbocharger Turbine Seal Leaks | Refer to Procedure 010-049 | QSK95 CM2350 K113 | 4388663
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active selective catalytic reduction (SCR) temperature sensor fault codes. | Fault Code 5725, 5726, 5727, 5728, or 5731 active or inactive counts?
STEP 2. | Check the diesel exhaust fluid (DEF) for contamination. |
 | STEP 2A. Check the DEF for contamination. | DEF contaminated?
STEP 3. | Check the fuel system. |
 | STEP 3A. Check for an injector misfire. | Engine misfire detected?
STEP 4. | Check the turbine outlet. |
 | STEP 4A. Inspect the turbine outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active SCR temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5725, 5726, 5727, 5728, or 5731 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the DEF for contamination.

Guided Step 2A - Check the DEF for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF for contamination.

  • Refer to Procedure 011-056 in the Associated Procedures Table.

DEF contaminated?
YES NO

Drain the DEF tank and follow the appropriate steps in the service manual. Refer to Procedure 011-056 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the fuel system.

Guided Step 3A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is operating at low idle.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to check for a cylinder misfire.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector. Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the turbine outlet.

Guided Step 4A - Inspect the turbine outlet for oil or fuel.

Conditions

  • Remove the turbine outlet bellows one at a time.

Action

Check for signs of moisture in the turbine outlet. Make sure to inspect all four .

  • Inspect the turbine outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine. Refer to Procedure 010-049 in the Associated Procedures Table.

Engine oil or fuel contamination found in the turbine outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 06-Apr-2016


FAULT CODE 4111 - Aftertreatment 2 SCR Catalyst Intake Gas Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active selective catalytic reduction (SCR) temperature sensor fault codes. | Fault Code 5725, 5726, 5727, 5728, or 5731 active or inactive counts?
STEP 2. | Check the diesel exhaust fluid (DEF) for contamination. |
 | STEP 2A. Check the DEF for contamination. | DEF contaminated?
STEP 3. | Check the fuel system. |
 | STEP 3A. Check for an injector misfire. | Engine misfire detected?
STEP 4. | Check the turbine outlet. |
 | STEP 4A. Inspect the turbine outlet for oil or fuel. | Engine oil or fuel contamination found in the turbine outlet?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active selective catalytic reduction (SCR) temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5725, 5726, 5727, 5728, or 5731 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the diesel exhaust fluid (DEF) for contamination.

Guided Step 2A - Check the DEF for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF for contamination.

  • Refer to Procedure 011-056 in the Associated Procedures Table.

DEF contaminated?
YES NO

Drain the DEF tank. Refer to Procedure 011-056 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the fuel system.

Guided Step 3A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is operating at low idle.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to check for a cylinder misfire.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire.

Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

  • Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the turbine outlet.

Guided Step 4A - Inspect the turbine outlet for oil or fuel.

Conditions

  • Remove the turbine outlet bellows one at a time.

Action

Check for signs of moisture in the turbine outlet. Be sure to inspect all four.

  • Inspect the turbine outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine. Refer to Procedure 010-049 in the Associated Procedures Table.

Engine oil or fuel contamination found in the turbine outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 4112 - Aftertreatment 2 SCR Catalyst Intake Gas Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Turbocharger Turbine Seal Leaks | Refer to Procedure 010-049 | QSK95 CM2350 K113 | 4388663
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active selective catalytic reduction (SCR) temperature sensor fault codes. | Fault Codes 5725, 5726, 5727, 5728, or 5731 active or inactive counts?
STEP 2. | Check the diesel exhaust fluid (DEF) for contamination. |
 | STEP 2A. Check the DEF for contamination. | DEF contaminated?
STEP 3. | Check the fuel system. |
 | STEP 3A. Check for an injector misfire. | Engine misfire detected?
STEP 4. | Check the turbine outlet. |
 | STEP 4A. Inspect the turbine outlet for oil or fuel. | Engine oil or fuel contamination found in the turbine outlet ?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active selective catalytic reduction (SCR) temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 5725, 5726, 5727, 5728, or 5731 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the diesel exhaust fluid (DEF) for contamination.

Guided Step 2A - Check the DEF for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF for contamination.

  • Refer to Procedure 011-056 in the Associated Procedures Table.

DEF contaminated?
YES NO

Drain the DEF tank and follow the appropriate steps in the service manual. Refer to Procedure 011-056 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the fuel system.

Guided Step 3A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is operating at low idle.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to check for a cylinder misfire.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector. Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the turbine outlet.

Guided Step 4A - Inspect the turbine outlet for oil or fuel.

Conditions

  • Remove the turbine outlet bellows one at a time.

Action

Check for signs of moisture in the turbine outlet. Be sure to inspect all four.

  • Inspect the turbine outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Refer to Procedure 010-049 in the Associated Procedures Table.

Engine oil or fuel contamination found in the turbine outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 4113 - Aftertreatment 2 SCR Catalyst Intake Gas Temperature - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active selective catalytic reduction (SCR) temperature sensor fault codes. | Fault Code 5725, 5727, 5728, 5729, or 5731 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active SCR temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 5725, 5727, 5728, 5729, or 5731 active?
YES NO
No Repair

A malfunctioning aftertreatment 2 SCR temperature sensor module has been detected.

Replace the aftertreatment 2 SCR temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 4114 - Aftertreatment 2 SCR Catalyst Intake Gas Temperature - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active selective catalytic reduction (SCR) temperature sensor fault codes. | Fault Code 5725, 5727, 5728, 5729, or 5731 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active SCR temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 5725, 5727, 5728, 5729, or 5731 active?
YES NO
No Repair

A malfunctioning aftertreatment 2 SCR temperature sensor module has been detected.

Replace the aftertreatment 2 SCR temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 4115 - Aftertreatment 2 SCR Catalyst Outlet Gas Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active selective catalytic reduction (SCR) temperature sensor fault codes. | Fault Code 5725, 5727, 5728, 5729, or 5731 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active SCR temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 5725, 5727, 5728, 5729, or 5731 active?
YES NO
No Repair

A malfunctioning aftertreatment 2 SCR temperature sensor module has been detected.

Replace the aftertreatment 2 SCR temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 4117 - Aftertreatment 2 SCR Catalyst Outlet Gas Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active selective catalytic reduction (SCR) temperature sensor fault codes. | Fault Code 5725, 5726, 5727, 5728, or 5731 active or inactive counts?
STEP 2. | Check the diesel exhaust fluid (DEF) for contamination. |
 | STEP 2A. Check the DEF for contamination. | DEF contaminated?
STEP 3. | Check the fuel system. |
 | STEP 3A. Check for an injector misfire. | Engine misfire detected?
STEP 4. | Check the turbine outlet. |
 | STEP 4A. Check for signs of moisture in all four turbine outlets. | Engine oil or fuel contamination found in the turbine outlets?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active SCR temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5725, 5726, 5727, 5728, or 5731 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the DEF for contamination.

Guided Step 2A - Check the DEF for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF for contamination.

  • Refer to Procedure 011-056 in the Associated Procedures Table.

DEF contaminated?
YES NO

Drain the DEF tank. Refer to Procedure 011-056 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the fuel system.

Guided Step 3A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is operating at low idle.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to check for a cylinder misfire.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

  • Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the turbine outlet.

Guided Step 4A - Inspect the turbine outlet for oil or fuel.

Conditions

  • Remove the turbine outlet bellows one at a time.

Action

Check for signs of moisture in all four turbine outlets.

  • Inspect all four turbine outlets for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbine outlets?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 4118 - Aftertreatment 2 SCR Catalyst Outlet Gas Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active selective catalytic reduction (SCR) temperature sensor fault codes. | Fault Code 5725, 5726, 5727, 5728, or 5731 active or inactive counts?
STEP 2. | Check the diesel exhaust fluid (DEF) for contamination. |
 | STEP 2A. Check the DEF for contamination. | DEF contaminated?
STEP 3. | Check the fuel system. |
 | STEP 3A. Check for an injector misfire. | Engine misfire detected?
STEP 4. | Check the turbine outlet. |
 | STEP 4A. Check for signs of moisture in all four turbine outlets. | Engine oil or fuel contamination found in the turbine outlets?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active SCR temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5725, 5726, 5727, 5728, or 5731 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the DEF for contamination.

Guided Step 2A - Check the DEF for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF for contamination.

  • Refer to Procedure 011-056 in the Associated Procedures Table.

DEF contaminated?
YES NO

Drain the DEF tank. Refer to Procedure 011-056 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the fuel system.

Guided Step 3A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is operating at low idle.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to check for a cylinder misfire.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

  • Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the turbine outlet.

Guided Step 4A - Inspect the turbine outlet for oil or fuel.

Conditions

  • Remove the turbine outlet bellows one at a time.

Action

Check for signs of moisture in all four turbine outlets.

  • Inspect all four turbine outlets for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbine outlets?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 4119 - Aftertreatment 2 SCR Catalyst Outlet Gas Temperature - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active selective catalytic reduction (SCR) temperature sensor fault codes. | Fault Codes 5725, 5727, 5728, 5729, or 5731 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active SCR temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 5725, 5727, 5728, 5729, or 5731 active?
YES NO
No Repair

A malfunctioning aftertreatment 2 SCR temperature sensor module has been detected.

Replace the aftertreatment 2 SCR temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 4121 - Aftertreatment 2 SCR Catalyst Outlet Gas Temperature - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active selective catalytic reduction (SCR) temperature sensor fault codes. | Fault Codes 5725, 5727, 5728, 5729, or 5731 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active SCR temperature sensor fault codes.

Conditions

  • Turn the keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 5725, 5727, 5728, 5729, or 5731 active?
YES NO
No Repair

A malfunctioning aftertreatment 2 SCR temperature sensor module has been detected.

Replace the aftertreatment 2 SCR temperature sensor module.

Refer to Procedure 019-449 in the Associated Procedures Table.

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 4122 - Aftertreatment 2 Intake NOx Sensor Heater - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4122 active?
 | STEP 1B. Check for active intake nitrogen oxides (NOx) sensor related fault codes. | Fault Codes 3982, 4145, or 4528 active?
 | STEP 1C. Check for active selective catalytic reduction (SCR) intake temperature fault codes. | Fault Code 3998 active?
STEP 2. | Check the aftertreatment 2 intake NOx sensor circuit. |
 | STEP 2A. Inspect the aftertreatment 2 intake NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment 2 intake NOx sensor. | Voltage within 1 VDC of ECM power supply voltage?
STEP 3. | Check the engine harness. |
 | STEP 3A. Check the voltage to the aftertreatment 2 intake NOx sensor. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3B. Inspect aftertreatment power relay and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the voltage to the aftertreatment power relay. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3D. Check the aftertreatment power relay. | Less than 10 ohms?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4122 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for active intake NOx sensor related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3982, 4145, or 4528 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for active SCR intake temperature fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3998 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment 2 intake NOx sensor circuit.

Guided Step 2A - Inspect the aftertreatment 2 intake NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 intake NOx sensor from the harness.

Action

Inspect the engine harness and aftertreatment 2 intake NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the aftertreatment intake NOx sensor only when there are damaged pins. Refer to Procedure 019-463 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment 2 intake NOx sensor.

Conditions

  • Disconnect the sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment 2 intake NOx sensor.

  • Measure the voltage between the aftertreatment 2 intake NOx sensor ECM power supply voltage supply circuit and the aftertreatment 2 intake NOx sensor ECM power supply voltage return circuit at the NOx sensor wiring harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of ECM power supply voltage?
YES NO

A damaged aftertreatment 2 intake NOx sensor heater has been detected.

Replace the aftertreatment 2 intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Check the voltage to the aftertreatment 2 intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 intake NOx sensor from the engine harness.
  • Turn keyswitch ON

Action

Check for voltage to the aftertreatment 2 intake NOx sensor.

  • Measure the voltage from the aftertreatment 2 intake NOx sensor ECM power supply voltage SUPPLY pin of the engine harness intake NOx sensor connector to ECM power supply ground.

Voltage within 1 VDC of ECM power supply voltage?
YES NO

An open circuit has been detected in the aftertreatment intake NOx sensor ECM power supply voltage return circuit.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Inspect aftertreatment power relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the harness.

Action

Inspect the harness and aftertreatment power relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the relay or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the voltage to the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment power relay.

  • Measure the voltage between the aftertreatment power relay ECM power supply voltage SUPPLY pin in the aftertreatment power relay connector of the engine harness and ECM power supply ground.

Voltage within 1 VDC of ECM power supply voltage?
YES NO
No Repair

An open circuit has been detected in the aftertreatment power ECM power supply voltage supply circuit before the power relay.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.

Action

Check for a damaged aftertreatment power relay.

  • Install a jumper wire from pin 85 on the aftertreatment power relay to ECM power supply (+ ) and connect a jumper wire from pin 86 on the aftertreatment power relay to ECM power supply ground.
  • Measure the resistance between pin 30 and pin 87 on the aftertreatment power relay.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

An open circuit or short circuit to ECM power supply ground has been detected in the aftertreatment intake NOx sensor power supply circuit.

This could be caused by:

  • Blown in-line fuse on the intake NOx sensor power supply circuit.
  • Open circuit or short to ECM power supply ground in the intake NOx sensor power supply circuit.

Replace the inline fuse, if it is blown.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the aftertreatment power relay.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 4124 - Aftertreatment 2 SCR Catalyst System Missing - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSK95 CM2350 K113 | 4388663
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid System Leak Test | Refer to Procedure 011-080 | QSK95 CM2350 K113 | 4388663
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK95 CM2350 K113 | 4388663
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4124 active?
 | STEP 1B. Check for active aftertreatment 2 NOx sensor fault codes. | Fault Codes 3982, 3984, 3985, 3986, 3988, 3995, 4122, 4145, 4528, 4529, 4531 active?
 | STEP 1C. Check for active aftertreatment 2 selective catalytic reduction (SCR) temperature sensor fault codes. | Fault Codes 3998, 3999, 4111, 4112, 4113, 4114, 4115, 4117, 4119, 5725, 5726, 5727, 5729, 5731 active?
 | STEP 1D. Check for active diesel exhaust fluid (DEF) aftertreatment 2 dosing system fault codes. | Fault Codes 4457, 4458, 4463, 4464, 4465, 4466, 4467, 4468, 4474, 4474, 4475, 4476, 4712, 5768, 5769, 5771, 5772, 5773, 5774, 5777, 5778, 5779, 5781, 5821, 5822, 5823, 5824, 5825, 5832, 5833, 5834, 6378, 6381, 6383, 6386 active?
STEP 2. | Check the DEF dosing system and catalyst. |
 | STEP 2A. Check the exhaust system and aftertreatment 2. | Aftertreatment 2 SCR catalyst missing or not connected to the exhaust system properly?
 | STEP 2B. Check the DEF quality. | DEF free from contamination and within the specifications outlined in Procedure 011-056 in the Associated Procedures Table?
 | STEP 2C. Check the aftertreatment 2 DEF dosing valve for leaks. | DEF leaking from the aftertreatment 2 DEF dosing valve or valves during the system leak test?
 | STEP 2D. Check the aftertreatment 2 DEF dosing system operation. | Dosing volume within the specifications in Procedure 011-063 in the Associated Procedures Table and DEF spray pattern correct for each of the three dosing systems?
 | STEP 2E. Check for deposits in the aftertreatment 2 decomposition chamber. | Excessive DEF deposits found inside the aftertreatment 2 decomposition chamber?
STEP 3. | Check the aftertreatment NOx sensors. |
 | STEP 3A. Check the aftertreatment 2 NOx sensor readings. | Aftertreatment NOx sensor readings within the specifications found in Procedure 014-013 in the Associated Procedures Table?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4124 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for active aftertreatment 2 NOx sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3982, 3984, 3985, 3986, 3988, 3995, 4122, 4145, 4528, 4529, 4531 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for active aftertreatment 2 selective catalytic reduction (SCR) temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes 3998, 3999, 4111, 4112, 4113, 4114, 4115, 4117, 4119, 5725, 5726, 5727, 5729, 5731 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1D

Guided Step 1D - Check for active diesel exhaust fluid (DEF) aftertreatment 2 dosing system fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes relating to the aftertreatment 2 DEF dosing system.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes 4457, 4458, 4463, 4464, 4465, 4466, 4467, 4468, 4474, 4474, 4475, 4476, 4712, 5768, 5769, 5771, 5772, 5773, 5774, 5777, 5778, 5779, 5781, 5821, 5822, 5823, 5824, 5825, 5832, 5833, 5834, 6378, 6381, 6383, 6386 active?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the DEF dosing system and catalyst.

Guided Step 2A - Check the exhaust system and aftertreatment 2.

Conditions

  • Turn keyswitch OFF.

Action

Check the exhaust system and aftertreatment 2 SCR catalyst for damaged or missing components.

  • Check to make sure the aftertreatment 2 SCR catalyst is not missing and that it is connected properly. Refer to Procedure 011-036 in the Associated Procedures Table.
  • Inspect the entire aftertreatment 2 exhaust system between the turbocharger outlet and the SCR outlet. Inspect for loose connections, leaking connections, and broken exhaust system components.

Aftertreatment 2 SCR catalyst missing or not connected to the exhaust system properly?

YES NO

Replace the missing SCR catalyst. Refer to Procedure 011-036 in the Associated Procedures Table.

Repair or replace any damaged, missing, or misconnected exhaust piping.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the DEF quality.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF quality.

  • Inspect the DEF in the tank for signs of debris or contamination
  • Use the Cummins® DEF Refractometer Service Tool, Part Number 4919554, to test the DEF concentration. Refer to Procedure 011-056 in the Associated Procedures Table.

DEF free from contamination and within the specifications outlined in Procedure 011-056 in the Associated Procedures Table?

YES NO
No Repair

The fluid in the DEF tank is not pure DEF, or the DEF is diluted or degraded.

Completely drain the DEF tank and rinse the tank with water.

Fill the DEF tank with pure DEF.

Refer to Procedure 011-056 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the aftertreatment 2 DEF dosing valves for leaks.

Conditions

  • Connect all DEF lines and electrical connectors.
  • Remove the aftertreatment 2 DEF dosing valves from the decomposition chamber.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Inspect the DEF dosing valves for a leaking nozzles.

  • Use INSITE™ electronic service tool to perform the DEF System Leak Test found under ECM Diagnostic Tests. Refer to Procedure 011-080 in the Associated Procedures Table.

DEF leaking from the aftertreatment 2 DEF dosing valve or valves during the system leak test?
YES NO

A leaking aftertreatment DEF dosing valve or valves has been detected.

Replace the aftertreatment DEF dosing valve or valves affected. Refer to Procedure 011-059 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check the aftertreatment 2 DEF dosing system operation.

Conditions

  • Remove the aftertreatment 2 DEF dosing valves from the decomposition chamber.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the DEF Doser Pump Override Test found under ECM Diagnostic Tests for each of the three dosing systems.

  • Use the following procedure for instructions and specifications. Refer to Procedure 011-063 in the Associated Procedures Table.
  • Make sure the DEF dosing valves is not plugged and the spray pattern is correct.

Each DEF dosing valve must be removed and placed in a measuring container in order to perform the DEF Doser Pump Override Test.

Dosing volume within the specifications in Procedure 011-063 in the Associated Procedures Table and DEF spray pattern correct for each of the three dosing systems?

YES NO
No Repair

Replace the aftertreatment 2 DEF dosing valve or valves that are not within specifications. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Check for deposits in the aftertreatment 2 decomposition chamber.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the aftertreatment 2 decomposition chamber for deposits.

  • Remove the inspection cover from the aftertreatment 2 SCR catalyst.
  • Inspect for DEF deposits. Refer to Procedure 011-036 in the Associated Procedures Table.

Excessive DEF deposits found inside the aftertreatment 2 decomposition chamber?
YES NO

Clean the decomposition chamber. Refer to Procedure 011-036 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the aftertreatment 2 NOx sensors.

Guided Step 3A - Check the aftertreatment 2 NOx sensor readings.

Conditions

  • Turn keyswitch ON.

Action

Perform the Aftertreatment NOx Sensor Rationality Test.

Refer to Procedure 019-451 in the Associated Procedures Table.

Aftertreatment NOx sensor readings within the specifications found in Procedure 019-451?
YES NO

Replace the aftertreatment SCR catalyst. Refer to Procedure 011-036 in the Associated Procedures Table.

Replace the aftertreatment intake and outlet NOx sensors.

  • Use the following procedure for the intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.
  • Use the following procedure for the outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 05-Apr-2016


FAULT CODE 4145 - Aftertreatment 2 Intake NOx Sensor - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK95 CM2350 K113 | 4388663
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Aftertreatment Sensor Power Relay | Refer to Procedure 019-607 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4145 active?
 | STEP 1B. Check for active intake NOx sensor fault codes. | Fault Code 4528 or 3984 active?
 | STEP 1C. Check for active outlet NOx sensor or selective catalytic reduction (SCR) temperature sensor fault codes. | Fault Codes 3998 and 5725 are both active?
STEP 2. | Check the aftertreatment 2 intake NOx sensor circuit. |
 | STEP 2A. Inspect aftertreatment 2 intake NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment 2 intake NOx sensor. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 2C. Check the J1939 terminating resistance. | 50 to 70 ohms?
 | STEP 2D. Check for an open circuit in the aftertreatment 2 intake NOx sensor ECM power supply voltage supply. | Voltage within 1 VDC of ECM power supply voltage?
STEP 3. | Check the harness. |
 | STEP 3A. Inspect the aftertreatment 2 intake NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the voltage to the aftertreatment 2 intake NOx sensor. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3C. Check the voltage to the aftertreatment 2 intake NOx sensor. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3D. Inspect aftertreatment power relay and connector pins. | Dirty or damaged pins?
 | STEP 3E. Check the voltage to the aftertreatment power relay. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3F. Check the aftertreatment power relay. | Less than 10 ohms?
STEP 4. | Check the J1939 data link 4. |
 | STEP 4A. Check the J1939 terminating resistance on the original equipment manufacturer (OEM) harness. | 110 to 130 ohms?
 | STEP 4B. Check the J1939 terminating resistance on the engine harness. | 110 to 130 ohms?
 | STEP 4C. Inspect engine control module (ECM) and OEM connector pins. | Dirty or damaged pins?
 | STEP 4D. Check for an open circuit in the J1939 data link harness. | All measurements less than 10 ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4145 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active intake NOx sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4528 or 3984 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for active outlet NOx sensor or SCR temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3988 and 5725 are both active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the aftertreatment 2 intake NOx sensor circuit.

Guided Step 2A - Inspect aftertreatment 2 intake NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 intake NOx sensor from the engine harness.

Action

Inspect the engine harness and aftertreatment 2 intake NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the aftertreatment intake NOx sensor only when there are damaged pins. Refer to Procedure 019-463 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment 2 intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 intake NOx sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment 2 intake NOx sensor.

  • Measure the voltage between the aftertreatment 2 intake NOx sensor ECM power supply voltage supply circuit and the aftertreatment 2 intake NOx sensor ECM power supply voltage return circuit at the intake NOx sensor wiring harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of ECM power supply voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2D

Guided Step 2C - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 intake NOx sensor from the engine harness.

Action

Measure the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE 1939 data link (+) wire and the SAE J1939 data link (-) wire at the aftertreatment 2 intake NOx sensor engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 to 70 ohms?
YES NO

Replace the aftertreatment 2 intake NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

An open circuit has been detected on the SAE J1939 data link (+) or (-) wire between the intake NOx sensor and the data link backbone connection.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 2D - Check for an open circuit in the aftertreatment 2 intake NOx sensor ECM power supply voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 intake NOx sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure the voltage from the aftertreatment 2 intake NOx sensor ECM power supply voltage SUPPLY pin of the engine harness connector to ECM power supply ground.

Voltage within 1 VDC of ECM power supply voltage?
YES NO

An open circuit has been detected in the aftertreatment 2 intake NOx sensor ECM power supply voltage return circuit.

  • Troubleshoot all harnesses connected in series to determine which one contains the open circuit.
  • Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

An open circuit has been detected in the aftertreatment 2 intake NOx sensor ECM power supply voltage supply circuit between the aftertreatment power relay and the intake NOx sensor.

  • Check for a blown or missing fuse in the aftertreatment 2 intake NOx sensor ECM power supply voltage SUPPLY circuit. Troubleshoot all harnesses connected in series to determine which one contains the open. Repair or replace the damaged component(s) as necessary. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 3 - Check the harness.

Guided Step 3A - Inspect aftertreatment 2 intake NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 intake NOx sensor from the engine harness.

Action

Inspect the engine harness and aftertreatment 2 intake NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the aftertreatment intake NOx sensor only when there are damaged pins. Refer to Procedure 019-463 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the voltage to the aftertreatment 2 intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 intake NOx sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment intake NOx sensor.

  • Measure the voltage between the aftertreatment 2 intake NOx sensor ECM power supply voltage supply circuit and the aftertreatment 2 intake NOx sensor ECM power supply voltage return circuit at the intake NOx sensor engine wiring harness connector.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of ECM power supply voltage?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the voltage to the aftertreatment 2 intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 intake NOx sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment 2 intake NOx sensor.

  • Measure the voltage from the aftertreatment 2 intake NOx sensor ECM power supply voltage SUPPLY pin of the harness connector to ECM power supply ground.

Voltage within 1 VDC of ECM power supply voltage?
YES NO

An open circuit has been detected in the aftertreatment 2 intake NOx sensor battery voltage RETURN circuit.

  • Troubleshoot all harnesses connected in series to determine which one contains the open circuit.
  • Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3D

Guided Step 3D - Inspect aftertreatment power relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.

Action

Inspect the harness and aftertreatment power relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the relay or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace aftertreatment power relay only when there are damaged pins. Refer to Procedure 019-607 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3E

Guided Step 3E - Check the voltage to the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment power relay.

  • Measure the voltage between the aftertreatment power relay ECM power supply voltage SUPPLY pin in the aftertreatment power relay connector of the engine harness and ECM power supply ground.

Voltage within 1 VDC of ECM power supply voltage?
YES NO
No Repair

An open circuit has been detected in the aftertreatment power ECM power supply voltage SUPPLY circuit before the power relay.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 5A

Guided Step 3F - Check the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.

Action

Check for a damaged aftertreatment power relay

  • Install a jumper wire from pin 85 on the aftertreatment power relay to Battery + and connect a jumper wire from pin 86 on the aftertreatment power relay to chassis ground.
  • Measure the resistance between pin 30 and pin 87 on the aftertreatment power relay.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

An open circuit or short circuit to ground has been detected in the aftertreatment intake NOx sensor power supply circuit.

This could be caused by:

  • Burned out in-line fuse on the intake NOx sensor power supply circuit.
  • Open circuit or short to ground in the intake NOx sensor power supply circuit.

Replace the inline fuse if it is burned out.

Troubleshoot all harnesses connected in series to determine which one contains the open or shorted circuit. Repair or replace the damaged section of harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the aftertreatment power relay.

Go to 5A

Go to 5A

Guided Step 4 - Check the J1939 data link 4.

Guided Step 4A - Check the J1939 terminating resistance on the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness and engine harness at the 47 pin aftertreatment 2 connector.

Action

Measure the terminating resistance of the SAE J1939 data link 4.

  • Measure the resistance between the SAE J1939 data link 4 (+) wire and the J1939 data link 4 (-) wire at the 47 pin aftertreatment 2 OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

110 to 130 ohms?
YES NO
No Repair

Incorrect terminating resistance or an open circuit has been detected on the SAE J1939 data link 4 circuit in the OEM harness.

  • Remove excess terminating resistors. Replace any damaged or missing terminating resistor.
  • Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • Repair or replace the damaged section of the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check the J1939 terminating resistance on the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness and engine harness at the 47 pin aftertreatment 2 connector.

Action

Measure the terminating resistance of the SAE J1939 data link 4.

  • Measure the resistance between the SAE J1939 data link 4 (+) wire and the J1939 data link 4 (-) wire at the 47 pin aftertreatment 2 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

110 to 130 ohms?
YES NO
No Repair

Incorrect terminating resistance or an open circuit has been detected on the SAE J1939 data link 4 circuit in the engine harness.

  • Remove excess terminating resistors. Replace any damaged or missing terminating resistor.
  • Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Inspect ECM and OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the OEM and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only when there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4D

Guided Step 4D - Check for an open circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness and engine harness at the 47-pin aftertreatment 2 connector.
  • Disconnect the OEM connector from the ECM.

Action

Check for an open circuit in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link 4 (+) wire at the engine harness 47-pin aftertreatment 2 connector and the SAE J1939 data link 4 (+) wire at the ECM OEM connector.
  • Measure the resistance between the SAE J1939 data link 4 (−) wire at the engine harness 47-pin aftertreatment 2 connector and the SAE J1939 data link 4 (−) wire at the ECM OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

All measurements less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the J1939 data link 4.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 06-Apr-2016


FAULT CODE 4152 - Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Aftertreatment Sensor Power Relay | Refer to Procedure 019-607 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4152 active?
 | STEP 1B. Check for active J1939 Network number 4 fault codes. | Fault Code 4437 active?
 | STEP 1C. Check for active NOx sensor fault codes. | Fault Codes 2771 and 3232 active?
STEP 2. | Check the aftertreatment 1 selective catalytic reduction ( SCR) temperature sensor module and circuit. |
 | STEP 2A. Inspect the aftertreatment 1 SCR temperature sensor module and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment 1 SCR temperature sensor module. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 2C. Check the J1939 terminating resistance. | 50 to 70 ohms?
 | STEP 2D. Check for an open circuit in the aftertreatment 1 SCR temperature sensor module ECM power supply voltage supply. | Voltage within 1 VDC of ECM power supply voltage?
STEP 3. | Check the harness. |
 | STEP 3A. Inspect the aftertreatment 1 SCR temperature sensor module and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the voltage to the aftertreatment 1 SCR temperature sensor module. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3C. Check the voltage to the aftertreatment 1 SCR temperature sensor module. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3D. Inspect aftertreatment power relay and connector pins. | Dirty or damaged pins?
 | STEP 3E. Check the voltage to the aftertreatment power relay. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3F. Check the aftertreatment power relay. | Less than 10 ohms?
STEP 4. | Check the J1939 data link 4. |
 | STEP 4A. Check the J1939 terminating resistance on the OEM harness. | 110 to 130 ohms?
 | STEP 4B. Check the J1939 terminating resistance on the engine harness. | 110 to 130 ohms?
 | STEP 4C. Inspect the engine control module (ECM) and original equipment manufacturer (OEM) connector pins. | Dirty or damaged pins?
 | STEP 4D. Check for an open circuit in the J1939 data link harness. | All measurements less than 10 ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4152 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active J1939 Network number 4 fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4437 active?
YES | NO
No Repair | No Repair

Go to Appropriate Fault Code Troubleshooting Tree.

Go to 1C

Guided Step 1C - Check for active NOx sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2771 and 3232 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the aftertreatment 1 SCR temperature sensor module and circuit.

Guided Step 2A - Inspect the aftertreatment 1 SCR temperature sensor module and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 SCR temperature sensor module from the OEM harness.

Action

Inspect the OEM harness and aftertreatment 1 SCR temperature sensor module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged OEM harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

Replace aftertreatment 1 SCR temperature sensor module only when there are damaged pins. Refer to Procedure 019-449 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment 1 SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 SCR temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment 1 SCR temperature sensor module.

  • Measure the voltage between the aftertreatment 1 SCR temperature sensor module ECM power supply voltage supply circuit and the aftertreatment 1 SCR temperature sensor module return circuit at the wiring harness sensor connector.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of ECM power supply voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2D

Guided Step 2C - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 SCR temperature sensor module from the OEM harness.

Action

Measure the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE J1939 data link (+) wire and the J1939 data link (-) wire at the aftertreatment 1 SCR temperature sensor module OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 to 70 ohms?
YES NO

Replace the aftertreatment 1 SCR temperature sensor module.

Refer to Procedure 019-449 in the Associated Procedures Table.

An open circuit has been detected on the SAE J1939 data link (+) or (-) wire between the SCR temperature sensor module and the data link backbone connection.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Go to 5A

Go to 5A

Guided Step 2D - Check for an open circuit in the aftertreatment 1 SCR temperature sensor module ECM power supply voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 SCR temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure the voltage from the aftertreatment 1 SCR temperature sensor module ECM power supply voltage SUPPLY pin of the OEM harness to ECM power supply ground.

Voltage within 1 VDC of ECM power supply voltage?
YES NO

An open circuit has been detected in the aftertreatment 1 SCR temperature sensor module ECM power supply voltage return circuit.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

Repair or replace the damaged section of harness.

  • Use the following procedurefor the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

An open circuit has been detected in the aftertreatment 1 SCR temperature sensor module ECM power supply voltage supply circuit between the aftertreatment smart sensor relay and the SCR temperature sensor module.

Check for a blown or missing fuse in the aftertreatment 1 SCR temperature sensor module ECM power supply voltage supply circuit.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 3 - Check the harness.

Guided Step 3A - Inspect the aftertreatment 1 SCR temperature sensor module and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 SCR temperature sensor module from the OEM harness.

Action

Inspect the OEM harness and aftertreatment 1 SCR temperature sensor module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged OEM harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

Replace aftertreatment SCR temperature sensor module only when there are damaged pins. Refer to Procedure 019-449 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the voltage to the aftertreatment 1 SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 SCR temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment 1 SCR temperature sensor module.

  • Measure the voltage between the aftertreatment 1 SCR temperature sensor module ECM power supply voltage supply circuit and the aftertreatment 1 SCR temperature sensor module return circuit at the wiring harness sensor connector.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of ECM power supply voltage?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the voltage to the aftertreatment 1 SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 SCR temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment 1 SCR temperature sensor module.

  • Measure the voltage from the aftertreatment 1 SCR temperature sensor module ECM power supply voltage SUPPLY pin of the OEM harness SCR temperature sensor module connector to ECM power supply ground.

Voltage within 1 VDC of ECM power supply voltage?
YES NO

An open circuit has been detected in the aftertreatment 1 SCR temperature sensor module ECM power supply voltage RETURN circuit.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair, or replace the damaged section of harness.

Repair or replace the damaged section of harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3D

Guided Step 3D - Inspect aftertreatment power relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the harness.

Action

Inspect the harness and aftertreatment power relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the relay or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace aftertreatment power relay only when there are damaged pins. Refer to Procedure 019-607 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3E

Guided Step 3E - Check the voltage to the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment power relay.

  • Measure the voltage between the aftertreatment power relay ECM power supply voltage SUPPLY pin in the aftertreatment power relay connector of the engine harness and ECM power supply ground.

Voltage is within 1 VDC of ECM power supply voltage?
YES NO
No Repair

An open circuit has been detected in the aftertreatment power ECM power supply voltage supply circuit before the power relay.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of harness.

  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 5A

Guided Step 3F - Check the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.

Action

Check for a damaged aftertreatment power relay.

  • Install a jumper wire from pin number 85 on the aftertreatment power relay to ECM power supply + and connect a jumper wire from pin number 86 on the aftertreatment power relay to ECM power supply ground.
  • Measure the resistance between pin number 30 and pin number 87 on the aftertreatment power relay.

Refer to the wiring diagram for connector pin identification. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

An open circuit or short circuit to ECM power supply ground has been detected in the aftertreatment SCR temperature sensor module power supply circuit.

This could be caused by:

  • Blown inline fuse on the SCR temperature sensor module power supply circuit.
  • Open circuit or short to ground in the SCR temperature sensor module power supply circuit.

Replace the inline fuse, if it is blown.

Troubleshoot all harnesses connected in series to determine which one contains the open or shorted circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the damaged section of harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the aftertreatment power relay.

Go to 5A

Go to 5A

Guided Step 4 - Check the J1939 data link 4.

Guided Step 4A - Check the J1939 terminating resistance on the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness and engine harness at the 47-pin aftertreatment 1 connector.

Action

Measure the terminating resistance of the SAE J1939 data link 4.

  • Measure the resistance between the SAE J1939 data link 4 (+) wire and the J1939 data link 4 (-) wire at the 47 pin aftertreatment 1 OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

110 to 130 ohms?
YES NO
No Repair

Incorrect terminating resistance or an open circuit has been detected on the SAE J1939 data link 4 circuit in the OEM harness.

  • Remove excess terminating resistors. Replace any damaged or missing terminating resistor.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the damaged section of the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check the J1939 terminating resistance on the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness and engine harness at the 47-pin aftertreatment 1 connector.

Action

Measure the terminating resistance of the SAE J1939 data link 4.

  • Measure the resistance between the SAE J1939 data link 4 (+) wire and the J1939 data link 4 (-) wire at the 47 pin aftertreatment 1 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

110 to 130 ohms?
YES NO
No Repair

Incorrect terminating resistance or an open circuit has been detected on the SAE J1939 data link 4 circuit in the engine harness.

  • Remove excess terminating resistors. Replace any damaged or missing terminating resistor.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the OEM and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only when there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4D

Guided Step 4D - Check for an open circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM and engine harness at the 47-pin aftertreatment 1 connector.
  • Disconnect the OEM connector from the ECM.

Action

Check for an open circuit in the J1939 data link harness 4.

  • Measure the resistance between the SAE J1939 data link 2 (+) wire at the engine harness 47-pin aftertreatment 1 connector and the SAE J1939 data link 4 (+) wire at the ECM OEM connector.
  • Measure the resistance between the SAE J1939 data link 2 (−) wire at the engine harness 47 pin aftertreatment 1 connector and the SAE J1939 data link 4 (−) wire at the ECM OEM connector.
  • Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

All measurements less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the J1939 data link 4.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 4159 - Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active selective catalytic reduction (SCR) temperature sensor fault codes. | Fault Code 4152, 4164, 4165, 4166, or 4261 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active SCR temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 4152, 4164, 4165, 4166, or 4261 active?
YES NO
No Repair

A malfunctioning aftertreatment 1 SCR temperature sensor module has been detected.

Replace the aftertreatment 1 SCR temperature sensor module. Refer to procedure 019-449 in the Associated Procedures Table.

Go to appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Repair complete

Go to 1A

Last Modified: 20-May-2016


FAULT CODE 4164 - Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4164 active?
 | STEP 1B. Check for active engine control module (ECM) power supply voltage fault codes. | Fault Code 441 or 442 active?
STEP 2. | Check the aftertreatment 1 selective catalytic reduction (SCR) temperature sensor module circuit. |
 | STEP 2A. Inspect aftertreatment 1 SCR temperature sensor module and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment 1 SCR temperature sensor module. | Voltage greater than 30 VDC?
 | STEP 2C. Check for correct adjustable parameter settings. | Electrical System Voltage parameter correct for the engine configuration?
 | STEP 2D. Check for correct aftertreatment 1 SCR temperature sensor module. | Aftertreatment 1 SCR temperature sensor module the correct sensor for the engine configuration?
 | STEP 2E. Check the condition of the aftertreatment 1 SCR temperature sensor module. | Fault Code 4164 active?
STEP 3. | Check the voltage. |
 | STEP 3A. Check the voltage. | Voltage greater than 30 VDC?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4164 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active ECM power supply voltage fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start engine. Let it idle for 1 minute.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 or 442 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check the aftertreatment 1 SCR temperature sensor module circuit.

Guided Step 2A - Inspect aftertreatment 1 SCR temperature sensor module and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 SCR temperature sensor module from the original equipment manufacturer (OEM) harness.

Action

Inspect the OEM harness and aftertreatment 1 SCR temperature sensor module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

Replace the aftertreatment SCR temperature sensor module only when there are damaged. Refer to Procedure 019-449 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment 1 SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 SCR temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment 1 SCR temperature sensor module.

  • Measure the voltage between the aftertreatment 1 SCR temperature sensor module ECM power supply voltage supply circuit and the aftertreatment 1 SCR temperature sensor module ECM power supply voltage return circuit at the aftertreatment 1 SCR temperature sensor module wiring harness connector.

Use the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage greater than 30 VDC?

YES | NO
No Repair | No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine configuration.

To check the voltage configuration of the engine, disconnect the OEM connector from the ECM and measure the voltage from the ECM power supply SUPPLY (+) pin of the OEM harness ECM connector to ECM power supply ground circuit.

  • Refer to Procedure 019-610 in the Associated Procedures Table.

Electrical System Voltage parameter correct for the engine configuration?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine configuration.

Go to 2D

Go to 4A

Guided Step 2D - Check for correct aftertreatment 1 SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Remove aftertreatment 1 SCR temperature sensor module.

Action

Verify the aftertreatment 1 SCR temperature sensor module is correct for the engine configuration.

The aftertreatment 1 SCR temperature sensor module is available in 12 volt or 24 volt versions.

Aftertreatment 1 SCR temperature sensor module is the correct sensor for the engine configuration?
YES NO
No Repair

Replace the aftertreatment 1 SCR temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Check the condition of the aftertreatment 1 SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 1 SCR temperature sensor module.
  • Start and idle the engine.

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

Fault Code 4164 active?
YES NO

A malfunctioning aftertreatment 1 SCR temperature sensor module has been detected.

Replace the aftertreatment 1 SCR temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the voltage.

Guided Step 3A - Check the voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the ECM power supply voltage.

  • Measure the voltage of the ECM power supply or power source.

Voltage greater than 30 VDC?
YES NO

An incorrect voltage configuration has been detected.

  • Consult the OEM manual for correct voltage configurations.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 06-Apr-2016


FAULT CODE 4165 - Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Aftertreatment Sensor Power Relay | Refer to Procedure 019-607 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4165 active?
 | STEP 1B. Check for active engine control module (ECM) power supply voltage fault codes. | Fault Code 441 or 442 active?
STEP 2. | Check the aftertreatment 1 selective catalytic reduction (SCR) temperature sensor module circuit. |
 | STEP 2A. Inspect aftertreatment 1 SCR temperature sensor module and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment 1 SCR temperature sensor module. | Voltage less than 18 VDC?
 | STEP 2C. Check for correct adjustable parameter settings. | Electrical System Voltage parameter correct for the engine configuration?
 | STEP 2D. Check for correct aftertreatment 1 SCR temperature sensor module. | Aftertreatment 1 SCR temperature sensor module correct sensor for the engine configuration?
 | STEP 2E. Check the condition of the aftertreatment 1 SCR temperature sensor module. | Fault Code 4165 active?
STEP 3. | Check the power connections. |
 | STEP 3A. Check the connections. | Connections tight and corrosion-free?
 | STEP 3B. Check the voltage to the aftertreatment 1 SCR temperature sensor module. | Voltage less than 18 VDC?
 | STEP 3C. Inspect aftertreatment power relay and connector pins. | Dirty or damaged pins?
 | STEP 3D. Check the voltage to the aftertreatment power relay. | Voltage less than 18 VDC?
 | STEP 3E. Check the aftertreatment power relay. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4165 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active ECM power supply voltage fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start engine. Let it idle for 1 minute.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 or 442 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check the aftertreatment 1 SCR temperature sensor module circuit.

Guided Step 2A - Inspect aftertreatment 1 SCR temperature sensor module and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 SCR temperature sensor module from the original equipment manufacturer (OEM) harness.

Action

Inspect the OEM harness and aftertreatment 1 SCR temperature sensor module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment 1 SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 SCR temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment 1 SCR temperature sensor module.

  • Measure the voltage between the aftertreatment 1 SCR temperature sensor module ECM power supply voltage supply circuit and the aftertreatment 1 SCR temperature sensor module ECM power supply voltage return circuit at the aftertreatment 1 SCR temperature sensor module wiring harness connector.

Use the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage less than 18 VDC?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine configuration.

To check the voltage configuration of the engine, disconnect the OEM connector from the ECM and measure the voltage from the ECM battery SUPPLY (+) pin of the OEM harness ECM connector to ECM power supply ground circuit.

Refer to Procedure 019-610 in the Associated Procedures Table.

Electrical System Voltage parameter correct for the engine configuration?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine configuration.

Go to 2D

Go to 4A

Guided Step 2D - Check for correct aftertreatment 1 SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Remove aftertreatment 1 SCR temperature sensor module.

Action

Verify the aftertreatment 1 SCR temperature sensor module is correct for the engine configuration.

The aftertreatment 1 SCR temperature sensor module is available in 12 volt or 24 volt versions.

Aftertreatment 1 SCR temperature sensor module correct sensor for the engine configuration?
YES NO
No Repair

Replace the aftertreatment 1 SCR temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Check the condition of the aftertreatment 1 SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 1 SCR temperature sensor module.
  • Start and idle the engine.

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

Fault Code 4165 active?
YES NO

A malfunctioning aftertreatment 1 SCR temperature sensor module has been detected.

Replace the aftertreatment 1 SCR temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the power connections.

Guided Step 3A - Check the connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery or power connections.

  • Check the battery or power source terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten any loose connections and clean the terminals. See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Check the voltage to the aftertreatment 1 SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 SCR temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment 1 SCR temperature sensor module.

  • Measure the voltage from the aftertreatment 1 SCR temperature sensor module ECM power supply voltage SUPPLY pin of the OEM harness SCR temperature sensor module connector to ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Voltage less than 18 VDC?
YES NO
No Repair

An open circuit has been detected in the aftertreatment 1 SCR temperature sensor module ECM power supply voltage return circuit.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the damaged section of harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect aftertreatment power relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the harness.

Action

Inspect the harness and aftertreatment power relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the relay or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace aftertreatment power relay only when there are damaged pins.

  • Refer to Procedure 019-607 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check the voltage to the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment power relay.

  • Measure the voltage between the aftertreatment power relay ECM power supply voltage SUPPLY pin in the aftertreatment power relay connector of the engine harness and ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Voltage less than 18 VDC?
YES NO

An open circuit has been detected in the aftertreatment power ECM power supply voltage supply circuit before the power relay.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3E

Guided Step 3E - Check the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.

Action

Check for a damaged aftertreatment power relay.

  • Install a jumper wire from pin 85 on the aftertreatment power relay to ECM power supply (+) and connect a jumper wire from pin 86 on the aftertreatment power relay to ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.
  • Measure the resistance between pin 30 and pin 87 on the aftertreatment power relay.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

An open circuit or short circuit to ECM power supply ground has been detected in the aftertreatment SCR temperature sensor module power supply circuit.

This could be caused by:

  • Blown in-line fuse on the SCR temperature sensor module power supply circuit.
  • Open circuit or short to ECM power supply ground in the SCR temperature sensor module power supply circuit.

Replace the inline fuse if it is blown.

Troubleshoot all harnesses connected in series to determine which one contains the open or shorted circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the damaged section of harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the aftertreatment power relay.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 05-Apr-2016


FAULT CODE 4166 - Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 4166 active or more than three inactive counts?
STEP 2. | Check the aftertreatment 1 selective catalytic reduction (SCR) temperature sensor module. |
 | STEP 2A. Make sure the aftertreatment 1 SCR temperature sensor module is properly mounted. | Aftertreatment 1 SCR temperature sensor module properly installed?
 | STEP 2B. Check for obstructed or restricted air flow to the aftertreatment 1 SCR temperature sensor module. | Signs of air flow restriction or excessive heat to temperature sensor module?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4166 active or more than three inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the aftertreatment 1 SCR temperature sensor module.

Guided Step 2A - Make sure the aftertreatment 1 SCR temperature sensor module is properly mounted.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Verify the aftertreatment 1 SCR temperature sensor module is properly mounted.

  • Verify the module is mounted correctly. Refer to Procedure 019-449 in the Associated Procedures Table.

Aftertreatment 1 SCR temperature sensor module properly installed?
YES NO
No Repair

Relocate and/or secure the aftertreatment 1 SCR temperature sensor module at the correct mounting location. Refer to Procedure 019-449 in the Associated Procedures Table.

Go to 2B

Go to 3A

Guided Step 2B - Check for obstructed or restricted air flow to the aftertreatment 1 SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Check the aftertreatment 1 SCR temperature sensor module mounting area for air flow obstructions. Restrictions or blockage of the air flow could cause the temperature sensor module to overheat. Check for the following:

  • Debris on or around the temperature sensor module.
  • Aftermarket shields, flaps, or brackets mounted too close to the module.
  • Exhaust leaks allowing exhaust to overheat the temperature sensor module.

Signs of air flow restriction or excessive heat to temperature sensor module?
YES NO

Repair the cause of the restricted air flow. Remove any debris accumulated near the temperature sensor module. Relocate any aftermarket accessories that might be restricting air flow. Repair any causes of excessive heat to the temperature sensor module.

No Repair

Go to 3A

Repair complete

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process.

Repair complete.

Last Modified: 04-Apr-2017


FAULT CODE 4168 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Delphi® 96 Way Engine Control Module Connector | Refer to Procedure 019-505 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Heater Relay | Refer to Procedure 019-620 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box Resistor | Refer to Procedure 019-625 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4168 active?
STEP 2. | Check the aftertreatment 1 diesel exhaust fluid (DEF) dosing unit heater relay and resistor. |
 | STEP 2A. Check the aftertreatment 1 DEF dosing unit heater relay. | Aftertreatment 1 DEF dosing unit heater relay within specifications?
 | STEP 2B. Check the aftertreatment 1 DEF dosing unit heater resistor. | Aftertreatment 1 DEF dosing unit heater resistor within specifications?
STEP 3. | Check the aftertreatment 1 harness. |
 | STEP 3A. Inspect the aftertreatment 1 connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for open signal circuit. | Less than 10 ohms?
 | STEP 3C. Check for open return circuit. | Less than 10 ohms?
 | STEP 3D. Check for open return circuit. | Less than 10 ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
STEP 4. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 4A. Inspect the aftertreatment 1 connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open signal circuit. | Less than 10 ohms?
 | STEP 4C. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 4D. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 4E. Check for an open circuit. | Less than 10 ohms?
 | STEP 4F. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4168 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 1 DEF dosing unit heater relay and resistor.

Guided Step 2A - Check the aftertreatment 1 DEF dosing unit heater relay.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment 1 DEF dosing unit heater relay (K1) from the aftertreatment junction box. Refer to Procedure 019-620 in the Associated Procedures Table.

Action

Check the aftertreatment 1 DEF dosing unit heater relay.

  • Test aftertreatment 1 DEF dosing unit heater relay. Refer to Procedure 019-620 in the Associated Procedures Table.
  • Refer to the wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Aftertreatment 1 DEF dosing unit heater relay within specifications?
YES NO
No Repair

Replace the aftertreatment 1 DEF dosing unit heater relay (K1). Refer to Procedure 019-620 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Check the aftertreatment 1 DEF dosing unit heater resistor.

Conditions

  • Turn the keyswitch OFF.
  • Remove the aftertreatment 1 DEF dosing unit heater resistor (R1) from the aftertreatment junction box. Refer to Procedure 019-625 in the Associated Procedures Table.

Action

Check the aftertreatment 1 DEF dosing unit heater resistor.

  • Test aftertreatment 1 DEF dosing unit heater resistor. Refer to Procedure 019-625 in the Associated Procedures Table.
  • Refer to the wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Aftertreatment 1 DEF dosing unit heater resistor within specifications?
YES NO
No Repair

Replace the aftertreatment 1 DEF dosing unit heater resistor (R1). Refer to Procedure 019-625 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the aftertreatment 1 harness.

Guided Step 3A - Inspect the aftertreatment 1 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.

Action

Inspect the connector(s) for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the C5 connector.

Repair the damaged harness, connector, or pins, if possible.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the aftertratment junction box. Refer to Procedure 019-598 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for open signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.

Action

Check for open signal circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit heater SIGNAL pin at the aftertreatment junction box C5 connector and the aftertreatment 1 DEF dosing unit heater relay (K1) terminal 7 and A1.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the aftertreatment junction box.

Troubleshoot all wires connected in series to determine which one contains the open circuit.

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for open return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.

Action

Check for open return circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit heater RETURN pin at the aftertreatment junction box C5 connector and the aftertreatment 1 DEF dosing unit heater resistor (R1) terminal A.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Troubleshoot all wires connected in series to determine which one contains the open circuit.

Repair or replace damaged section of wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check for open return circuit.

Conditions

  • Turn keyswitch OFF.

Action

Turn keyswitch OFF.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit heater resistor (R1) terminal C and the aftertreatment 1 DEF dosing unit heater relay (K1) terminal 7 and A1.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Troubleshoot all wires connected in series to determine which one contains the open circuit.

Repair or replace damaged section of wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3E

Go to 5A

Guided Step 3E - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.
  • Remove the aftertreatment 1 DEF line heater relay resistor (R1) from the aftertreatment junction box. Refer to Procedure 019-625 in the Associated Procedures Table.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit heater SIGNAL pin in the aftertreatment junction box C5 connector and all other pins in the connector.

Use a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in aftertreatment junction box.

Troubleshoot all wire(s) in series to determine which one contains the short circuit.

Repair or replace the damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM and OEM harness.

Guided Step 4A - Inspect the aftertreatment 1 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness at the aftertreatment 1 connector.

Action

Inspect the connector(s) for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.
  • Disconnect the OEM harness at the aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit heater SIGNAL pin in the aftertreatment junction box C5 connector and the aftertreatment 1 DEF dosing unit heater SIGNAL pin in the aftertreatment 1 connector.
  • Measure the resistance between the aftertreatment 1 DEF dosing unit heater RETURN pin in the aftertreatment junction box C5 connector and the aftertreatment 1 DEF dosing unit heater RETURN pin in the aftertreatment 1 connector.

Use a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all harness connections in series to determine which one contains open circuit.

Repair or replace damaged section of harness. Refer to Procedure 019-071 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.
  • Disconnect the OEM harness at the aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit heater SIGNAL pin in the aftertreatment 1 connector and all other pins in the connector.

Use a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harness connections in series to determine which one contains the short circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-071 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector (J2) from ECM (1).

Action

Inspect the connector(s) for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-505 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4E

Guided Step 4E - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector (J2) from ECM (1).
  • Disconnect the OEM harness at the aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit heater SIGNAL pin in the OEM connector (J2) from ECM (1) and the aftertreatment 1 DEF dosing unit heater SIGNAL pin in the aftertreatment 1 connector.
  • Measure the resistance between the aftertreatment 1 DEF dosing unit heater RETURN pin in the OEM connector (J2) from ECM (1) and the aftertreatment 1 DEF dosing unit heater RETURN pin in the aftertreatment 1 connector.

Use a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all harness connections in series to determine which one contains open circuit.

If an open circuit is isolated to damaged harness, Repair or replace damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4F

Go to 5A

Guided Step 4F - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector (J2) from ECM (1).
  • Disconnect the OEM harness at the aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit heater SIGNAL pin in the OEM connector (J2) from ECM (1) and all other pins in the connector.

Use a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check if an ECM calibration update is available.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters section.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Go to

Repair complete.

Last Modified: 27-Jan-2017


FAULT CODE 4169 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Heater - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Heater Relay | Refer to Procedure 019-620 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box Resistor | Refer to Procedure 019-625 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4169 active or more than one inactive count within the last 25 engine hours?
STEP 2. | Check the aftertreatment 1 diesel exhaust fluid (DEF) dosing unit 1 heater relay circuit. |
 | STEP 2A. Check the aftertreatment 1 DEF dosing unit heater relay. | Aftertreatment 1 DEF dosing unit heater relay within specifications?
 | STEP 2B. Check the aftertreatment 1 DEF dosing unit heater resistor. | Aftertreatment 1 DEF dosing unit heater resistor within specifications?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3B. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?
 | STEP . |

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4169 active or more than one inactive count within the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 1 diesel exhaust fluid (DEF) dosing unit 1 heater relay and resistor.

Guided Step 2A - Check the aftertreatment 1 DEF dosing unit heater relay.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment 1 DEF dosing unit heater relay (K1) from the aftertreatment junction box. Refer to Procedure 019-620 in the Associated Procedures Table.

Action

Test aftertreatment 1 DEF dosing unit heater relay. Refer to Procedure 019-620 in the Associated Procedures Table.

Reference the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Aftertreatment 1 DEF dosing unit heater relay within specifications?
YES NO
No Repair

Replace the aftertreatment 1 DEF dosing unit heater relay (K1). Refer to Procedure 019-620 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Check the aftertreatment 1 DEF dosing unit heater resistor.

Conditions

  • Turn the keyswitch OFF.
  • Remove the aftertreatment 1 DEF dosing unit heater resistor (R1) from the aftertreatment junction box. Refer to Procedure 019-625 in the Associated Procedures Table.

Action

Test aftertreatment 1 DEF dosing unit heater resistor. Refer to Procedure 019-625 in the Associated Procedures Table.

Reference the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Aftertreatment 1 DEF dosing unit heater resistor within specifications?
YES NO
No Repair

Replace the aftertreatment 1 DEF dosing unit heater resistor (R1). Refer to Procedure 019-625 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine control module (ECM) and original equipment manufacturer (OEM) harness.

Guided Step 3A - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment 1 DEF dosing unit heater relay (K1).
  • Disconnect the aftertreatment 1 DEF dosing unit resistor (R1).

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Measure the resistance between the aftertreatment 1 DEF dosing unit 1 heater relay SIGNAL pin terminal A1 and the G2 ground connector in the aftertreatment junction box.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment 1 DEF dosing unit heater relay (K1).
  • Disconnect the aftertreatment 1 DEF dosing unit resistor (R1).

Action

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 1 heater relay SIGNAL pin at the OEM harness ECM connector and all other pins.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the OEM harness.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process.

Repair complete.

Last Modified: 26-Jul-2017


FAULT CODE 4174 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Temperature Sensor - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault code. | Fault Code 4174 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) pressure sensor 1 and circuit. |
 | STEP 2A. Inspect the aftertreatment 1 DEF dosing temperature sensor 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 4175 active and Fault Code 4174 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 4174 active?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for an active fault code. | Fault Code 4174 active?
 | STEP 3D. Inspect the ECM harness connector pins in the engine harness. | Dirty or damaged pins?
 | STEP 3E. Check for pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3F. Check for an active fault code. | Fault Code 4174 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4174 active?
YES | NO
No Repair | No Repair

2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 1 diesel exhaust fluid (DEF) dosing temperature sensor 1 and circuit.

Guided Step 2A - Inspect the aftertreatment 1 DEF dosing temperature sensor 1 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 1 from the OEM harness.

Action

Inspect the OEM harness and the aftertreatment 1 DEF dosing valve 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 1 from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Use the circuit diagram or wiring diagram for connector pin identification.

Fault Code 4175 active and Fault Code 4174 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 1 DEF dosing valve 1 to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4174 active?
YES NO

A damaged temperature sensor has been detected in the aftertreatment 1 DEF dosing valve 1.

Replace the aftertreatment 1 DEF dosing valve 1.

Refer to Procedure 011-059 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 1 from the OEM harness.

Action

Check for a pin-to-pin short circuit in the harness.

  • Measure the resistance between the aftertreatment 1 DEF dosing temperature sensor 1 SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 Aftertreatment Junction Box in Section 19, if equipped.

If a short circuit is isolated to damaged harness, repair or replace the damaged section of harness.

For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4174 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3D

Go to 4A

Guided Step 3D - Inspect the ECM harness connector pins in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3E

Guided Step 3E - Check for pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit in the harness.

  • Measure the resistance between the aftertreatment 1 DEF dosing temperature sensor 1 SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the damaged section of the harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4174 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 4175 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Temperature Sensor - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault code. | Fault Code 4175 active?
STEP 2. | Check the aftertreatment 1 diesel exhaust fluid (DEF) dosing temperature sensor 1 and circuit. |
 | STEP 2A. Inspect the aftertreatment 1 DEF dosing temperature sensor 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 4174 active and Fault Code 4175 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 4175 active?
STEP 3. | Check the original equipment manufacturer (OEM) and engine control module (ECM) harness. |
 | STEP 3A. Inspect the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ECM power supply ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3E. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3F. Check for an active fault code. | Fault Code 4175 active?
 | STEP 3G. Inspect the ECM harness connector pins. | Dirty or damaged pins?
 | STEP 3H. Check for a pin-to-pin short circuit in the Engine harness. | Greater than 100k ohms?
 | STEP 3I. Check for a pin-to-ECM power supply ground short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3J. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3K. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3L. Check for an active fault code. | Fault Code 4175 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4175 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent or inactive fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 1 diesel exhaust fluid (DEF) dosing temperature sensor 1 and circuit.

Guided Step 2A - Inspect the aftertreatment 1 DEF dosing temperature sensor 1 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 1 from the OEM harness.

Action

Inspect the OEM harness and aftertreatment 1 DEF dosing valve 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing valve or the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 1 from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the aftertreatment 1 DEF dosing valve 1, 5V SUPPLY pin and the aftertreatment 1 DEF dosing temperature 1 SIGNAL pin at the aftertreatment 1 DEF dosing valve connector of the OEM harness.

Use the circuit diagram or wiring diagram for connector pin identification.

  • Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4174 active and Fault Code 4175 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 1 DEF dosing valve 1 to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4175 active?
YES NO

None. The removal and installation of the connector corrected the fault.

A damaged sensor has been detected in the aftertreatment 1 DEF dosing valve 1.

Replace the aftertreatment 1 DEF dosing valve 1. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 4A

4A

Guided Step 3 - Check the original equipment manufacturer (OEM) and engine control module (ECM) harness.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 1 from the OEM harness

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing temperature sensor 1 SIGNAL pin in the OEM harness aftertreatment 1 connector and all other pins in the OEM harness aftertreatment 1 connector.

Use a wiring diagram for pin identification the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If a short circuit is isolated to damaged harness, repair or replace the damaged section of harness.

For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ECM power supply ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 1 from the OEM harness.

Action

Check for a pin-to-pin short circuit

  • Measure the resistance between the aftertreatment 1 diesel exhaust fluid dosing temperature sensor 1 SIGNAL pin in the OEM harness aftertreatment 1 connector and ECM power supply ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Refer to Procedure 019-610in the Associated Procedures Table.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If a short circuit is isolated to damaged harness, repair or replace the damaged section of harness.

For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 1 from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness aftertreatment 1 connector DEF dosing temperature sensor 1 RETURN pin and the OEM harness aftertreatment 1 connector DEF dosing valve 1 connector DEF dosing temperature sensor RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 1 from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness aftertreatment 1 connector DEF dosing temperature sensor 1 SIGNAL pin and the OEM harness aftertreatment 1 connector DEF dosing valve 1 connector DEF dosing temperature sensor SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in Section 19, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4175 active?
YES NO

None. The removal and installation of the connector corrected the fault.

 No Repair

Go to 4A

Go to 4A

Guided Step 3G - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3H

Guided Step 3H - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing temperature sensor 1 SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Repair or replace the damaged section of the harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3I

Go to 4A

Guided Step 3I - Check for a pin-to-ECM power supply ground short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing temperature sensor 1 SIGNAL pin in the OEM harness ECM connector and ECM power supply ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Refer to Procedure 019-610 in the Associated Procedures Table.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit on the SIGNAL wire has been detected in the harness.

Repair or replace the damaged section of the harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3J

Go to 4A

Guided Step 3J - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment 1 DEF dosing temperature sensor 1 RETURN pin and the OEM harness aftertreatment 1 connector DEF dosing valve 1 DEF dosing temperature sensor RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Repair or replace the damaged section of the harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3K

Go to 4A

Guided Step 3K - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment 1 DEF dosing temperature sensor 1 SIGNAL pin and the OEM harness aftertreatment 1 connector DEF dosing valve 1 DEF dosing temperature sensor SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Repair or replace the damaged section of the harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3L

Go to 4A

Guided Step 3L - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4175 active?
YES NO

None. The removal and installation of the connector corrected the fault.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 4235 - Aftertreatment 1 Diesel Exhaust Fluid Property - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Tank Level/Temperature/Quality Sensor | Refer to Procedure 019-608 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 4235. | Fault Code 4235 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) concentration. |
 | STEP 2A. Check the DEF tank for contamination. | Diesel fuel detected in the DEF tank?
 | STEP 2B. Check the DEF concentration. | DEF concentration meets specification in Procedure 011-056 in the Associated Procedures Table?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 4235.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4235 active?
YES | NO
No Repair | No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check the aftertreatment diesel exhaust fluid (DEF) concentration.

Guided Step 2A - Check the DEF tank for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF for contamination.

  • Inspect the DEF tank for diesel fuel.

Diesel fuel detected in the DEF tank?
YES NO

Drain the DEF tank. Flush and clean the DEF tank with distilled water.

Fill the tank with fresh DEF.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the DEF concentration.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF concentration.

  • Check the concentration of the DEF in the tank. Refer to Procedure 011-056 in the Associated Procedures Table.

DEF concentration meets specification in Procedure 011-056 in the Associated Procedures Table?
YES NO

Replace the DEF quality sensor. Refer to Procedure 019-608 in the Associated Procedures Table.

Drain the DEF tank and fill with new DEF.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process

Repair complete

Last Modified: 12-May-2017


FAULT CODE 4243 - Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment DEF Tank Level/Temperature/Quality Sensor | Refer to Procedure 019-608 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4243 active?
STEP 2. | Verify the aftertreatment diesel exhaust fluid (DEF) tank temperature sensor. |
 | STEP 2A. Verify the aftertreatment DEF tank temperature sensor accuracy. | INSITE™ electronic service tool aftertreatment DEF tank temperature reading within 5.6°C or 10°F of the measured value?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4243 active?
YES | NO
No Repair | No Repair

Go to 2A

Repair complete.

Guided Step 2 - Verify the aftertreatment diesel exhaust fluid (DEF) tank temperature sensor.

Guided Step 2A - Verify the aftertreatment DEF tank temperature sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the accuracy of the aftertreatment DEF tank temperature sensor.

  • Measure the temperature of the aftertreatment DEF in the tank with an infrared thermometer or thermocouple.
  • Start INSITE™ electronic service tool Data Monitor/Logger.
  • Compare the INSITE™ electronic service tool reading for the aftertreatment DEF tank temperature to the value measured with the infrared thermometer or thermocouple.

INSITE™ electronic service tool aftertreatment DEF tank temperature reading within 5.6°C or 10°F of the measured value?
YES NO
No Repair

Replace the aftertreatment DEF tank level/temperature/quality sensor. Refer to Procedure 019-608 in the Associated Procedures Table or the equipment manufacturer service information.

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 4261 - Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Aftertreatment Sensor Power Relay | Refer to Procedure 019-607 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4261 active?
 | STEP 1B. Check for active engine control module (ECM) power supply voltage fault codes. | Fault Code 441 or 442 active?
 | STEP 1C. Check for active selective catalytic reduction (SCR) temperature sensor fault codes. | Fault Code 4152 or 4165 active?
STEP 2. | Check the aftertreatment 1 SCR temperature sensor module circuit. |
 | STEP 2A. Inspect aftertreatment 1 SCR temperature sensor module and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment 1 SCR temperature sensor module. | Voltage within 1 VDC of ECM power supply voltage?
STEP 3. | Check the power connections. |
 | STEP 3A. Check the ECM power supply and the power connections. | Connections tight and corrosion-free?
 | STEP 3B. Check the voltage to the aftertreatment 1 SCR temperature sensor module. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3C. Inspect the aftertreatment power relay and connector pins. | Dirty or damaged pins?
 | STEP 3D. Check the voltage to the aftertreatment power relay. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3E. Check the aftertreatment power relay. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4261 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active ECM power supply voltage fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start engine. Let it idle for 1 minute.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 or 442 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for active SCR temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4152 or 4165 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment 1 SCR temperature sensor module circuit.

Guided Step 2A - Inspect the aftertreatment 1 SCR temperature sensor module and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 SCR temperature sensor module from the original equipment manufacturer (OEM) harness.

Action

Inspect the OEM harness and aftertreatment 1 SCR temperature sensor module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

Replace the aftertreatment SCR temperature sensor module only when there are damaged pins. Refer to Procedure 019-449 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment 1 SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 SCR temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment 1 SCR temperature sensor module.

  • Measure the voltage between the aftertreatment 1 SCR temperature sensor module ECM power supply voltage supply circuit and the aftertreatment 1 SCR temperature sensor module ECM power supply voltage return circuit at the aftertreatment 1 SCR temperature sensor module wiring harness connector.

Use the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage within 1 VDC of ECM power supply voltage?
YES NO
No Repair

An intermittent connection has been detected at the aftertreatment 1 SCR temperature sensor module.

Troubleshoot the connector and OEM harness for intermittent short circuits and/or open circuits. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair or replace the damaged component.

Go to 3A

Go to 4A

Guided Step 3 - Check the power connections.

Guided Step 3A - Check the ECM power supply and the power connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the ECM power supply or power source connections.

  • Check the ECM power supply terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten any loose connections and clean the terminals. See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Check the voltage to the aftertreatment 1 SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 SCR temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check the voltage to the aftertreatment 1 SCR temperature sensor module.

  • Measure the voltage from the aftertreatment 1 SCR temperature sensor module ECM power supply voltage SUPPLY pin of the OEM harness SCR temperature sensor module connector to engine block ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Voltage within 1 VDC of ECM power supply voltage?
YES NO
No Repair

An open circuit has been detected in the aftertreatment 1 SCR temperature sensor module ECM power supply voltage return circuit.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the damaged section of harness.

  • Use the following procedure for the OEM harness: Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the aftertreatment power relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the harness.

Action

Inspect the harness and aftertreatment power relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the relay or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the aftertreatment power relay only when there are damaged pins. Refer to Procedure 019-607 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check the voltage to the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment power relay.

  • Measure the voltage between the aftertreatment power relay ECM power supply voltage SUPPLY pin in the aftertreatment power relay connector of the engine harness and engine block ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Voltage within 1 VDC of ECM power supply voltage?
YES NO

An open circuit has been detected in the aftertreatment power ECM power supply voltage supply circuit before the power relay.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of harness.

  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3E

Guided Step 3E - Check the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.

Action

Check for a damaged aftertreatment power relay.

  • Install a jumper wire from pin 85 on the aftertreatment power relay to ECM power supply (+) and connect a jumper wire from pin 86 on the aftertreatment power relay to ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.
  • Measure the resistance between pin 30 and pin 87 on the aftertreatment power relay.

Use to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

An open circuit or short circuit to ground has been detected in the aftertreatment SCR temperature sensor module power supply circuit.

This could be caused by:

  • Blown inline fuse on the SCR temperature sensor module power supply circuit.
  • Open circuit or short circuit to ECM power supply ground circuit in the SCR temperature sensor module power supply circuit.

Replace the inline fuse if it is blown.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.
  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the aftertreatment power relay.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 4277 - Aftertreatment Diesel Exhaust Fluid Quality - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment DEF Tank Level/Temperature/Quality Sensor | Refer to Procedure 019-608 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 4277. | Fault Code 4277 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) concentration. |
 | STEP 2A. Check the DEF tank for contamination. | Foreign objects or debris detected in the DEF tank?
 | STEP 2B. Check the DEF concentration. | DEF concentration within 32.5 ± 1.5 percent?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 4277.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4277 active?
YES | NO
No Repair | No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check the aftertreatment diesel exhaust fluid (DEF) concentration.

Guided Step 2A - Check the DEF tank for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF for contamination.

  • Inspect the DEF tank for foreign objects or debris.

Foreign objects or debris detected in the DEF tank?
YES NO

Drain the DEF tank. Flush and clean the DEF tank with distilled water.

Fill the tank with fresh DEF.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the DEF concentration.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF concentration.

  • Use a DEF Cummins® refractometer, Part Number 4919318, to measure the concentration of the DEF in the tank.

DEF concentration within 32.5 ± 1.5 percent?
YES NO
No Repair

Drain the DEF tank and fill with new DEF.

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 4437 - J1939 Network #4 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSK95 CM2350 K113 | 4388663
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes | Fault Code 4437 active?
STEP 2. | Check the J1939 Data Link Number 4 Devices. |
 | STEP 2A. Inspect the aftertreatment intake (nitrogen oxides) NOx sensor and connector pins. | Damaged or dirty pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2A-2. Check the fault codes. |
 | STEP 2B. Inspect the aftertreatment outlet NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2B-2. Check the fault codes. |
 | STEP 2C. Inspect the aftertreatment selective catalytic reduction (SCR) temperature sensor module and connector pins. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2C-2. Check the fault codes. |
STEP 3. | Check the J1939 Data Link Number 4. |
 | STEP 3A. Inspect the engine control module (ECM) and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the J1939 terminating resistance. | 110 to 130 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4437 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the J1939 Data Link Number 4 Devices.

Guided Step 2A - Inspect the aftertreatment intake NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the engine harness.

Action

Inspect the engine harness and aftertreatment intake NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged engine harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4437 active?
YES | NO
No Repair | No Repair

Go to 2B

Go to 2A-2

Guided Step 2A-2 - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment intake NOx sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4437 active?
YES NO

Replace the aftertreatment intake NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

An intermittent short circuit has been detected in the engine harness or connector. Refer to Procedure 019-362 in Section 19.

Go to 4A

Go to 4A

Guided Step 2B - Inspect the aftertreatment outlet NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment outlet NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged engine harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4437 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2B-2

Guided Step 2B-2 - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment outlet NOx sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4437 active?
YES NO

Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

An intermittent short circuit has been detected in the engine harness or connector. Refer to Procedure 019-362 in Section 19.

Repair the damaged engine harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 2C - Inspect the aftertreatment selective catalytic reduction (SCR) temperature sensor module and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM harness.

Action

Inspect the engine harness and aftertreatment SCR temperature sensor module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the aftertreatment SCR temperature sensor module or harness connector.

Clean the connector and pins.

Repair the damaged engine harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4437 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2C-2

Guided Step 2C-2 - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment SCR temperature sensor module to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4437 active?
YES NO

Replace the aftertreatment SCR temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

An intermittent short circuit has been detected in the engine harness or connector. Refer to Procedure 019-362 in Section 19.

Repair the damaged engine harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3 - Check the J1939 Data Link Number 4.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the aftertreatment intake NOx sensor from the engine harness.
  • Disconnect the OEM harness and engine harness at the 47 pin aftertreatment connector.

Action

Measure the terminating resistance of the Society of Automotive Engineers (SAE) J1939 data link number 4.

  • Measure the resistance between the SAE J1939 data link number 4 (+) wire and the J1939 data link 4 (-) wire at the OEM harness ECM connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

110 to 130 ohms?
YES NO

Incorrect terminating resistance or a short circuit has been detected on the SAE J1939 data link 4 circuit in the OEM harness.

Remove excess terminating resistors. Replace any damaged or missing terminating resistor.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

  • Repair or replace the damaged section of the OEM harness. Refer to Procedure 019-071 in Section 19.

Incorrect terminating resistance or a short circuit has been detected on the SAE J1939 data link 4 circuit in the engine harness.

Remove excess terminating resistors. Replace any damaged or missing terminating resistor.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

  • Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 4456 - Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSK95 CM2350 K113 | 4388663
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Heater | Refer to Procedure 011-112 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Line Heater Relay | Refer to Procedure 019-600 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Heater Relay | Refer to Procedure 019-620 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4456 active or more than two inactive counts?
 | STEP 1B. Check for diesel exhaust fluid (DEF) related fault codes. | Fault Code 1712 active or more than two inactive counts?
 | STEP 1C. Check for low DEF tank level. | DEF tank empty and/or Fault Code 1673, 3497, or 3498 active?
 | STEP 1D. Check DEF tank for debris. | DEF tank and vent clean and free of debris?
 | STEP 1E. Check ambient operating temperatures. | Equipment operating in ambient temperatures below -5°C [23°F] at the time the fault set?
STEP 2. | Check the aftertreatment 1 dosing system 1 DEF line heaters. |
 | STEP 2A. Test the aftertreatment 1 DEF line heater relays. | Aftertreatment 1 line heater relays within specification?
 | STEP 2B. Check DEF line heater functionality. | All line heaters functioning correctly?
 | STEP 2C. Inspect the original equipment manufacturer (OEM) harness and line heater connections. | Dirty or damaged pins?
 | STEP 2D. Check line heater supply voltage and return circuits. | All measurements within 1 VDC of engine control module (ECM) power supply voltage?
 | STEP 2E. Check line heater supply voltage to the ECM power supply ground. | All measurements within 1 VDC of ECM power supply voltage?
STEP 3. | Check the aftertreatment 1 DEF dosing unit 1 heating system. |
 | STEP 3A. Check the aftertreatment 1 diesel exhaust fluid (DEF) dosing unit heater relay. | Aftertreatment 1 DEF dosing unit heater relay within specifications?
 | STEP 3B. Inspect the aftertreatment 1 DEF dosing unit 1 heater and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check heater circuit resistance in the aftertreatment 1 DEF dosing unit 1 heater. | Resistance at 5.4 ohms ± 2.0 ohm?
 | STEP 3D. Check for an open circuit in the aftertreatment 1 DEF dosing unit 1 heater supply circuit. | Voltage within 1 VDC of power supply voltage?
 | STEP 3E. Check aftertreatment 1 DEF dosing unit 1 heater supply voltage to the ECM power supply ground. | All measurements within 1 VDC of power supply voltage?
STEP 4. | Check the aftertreatment 1 DEF dosing unit 1 lines and fittings. |
 | STEP 4A. Inspect the aftertreatment 1 DEF dosing unit 1 lines and fittings. | Any reversed, damaged, leaking, or restricted connections found?
 | STEP 4B. Check for pressure at the aftertreatment 1 DEF dosing valve 1. | DEF pressure greater than 1000 kPa [145 psi]?
 | STEP 4C. Check the aftertreatment 1 DEF dosing unit 1 supply line. | DEF dosing unit supply line blocked or restricted?
 | STEP 4D. Check the aftertreatment 1 DEF dosing valve 1 pressure line. | DEF pressure line blocked or restricted?
STEP 5. | Check the aftertreatment 1 DEF dosing valve 1 system return. |
 | STEP 5A. Check for a blocked aftertreatment 1 DEF dosing valve 1. | DEF pressure greater than 700 kPa [102 psi]?
 | STEP 5B. Check the aftertreatment 1 DEF dosing valve 1 return line. | DEF return line blocked or restricted?
STEP 6. | Check the aftertreatment 1 unit 1 DEF suction line. |
 | STEP 6A. Check for air in the DEF. | Air in the DEF detected?
 | STEP 6B. Check for an intermittent aftertreatment 1 DEF dosing unit 1 suction line leak. | Wiggling the DEF suction line connections affects the system pressure?
 | STEP 6C. Check the aftertreatment 1 DEF pressure. | DEF pressure greater than 750 kPa [109 psi]?
STEP 7. | Check the aftertreatment DEF dosing valve 1 operation. |
 | STEP 7A. Check the aftertreatment DEF dosing system operation. | Dosing volume within the specifications in Procedure 011-063 in the Associated Procedures Table?
 | STEP 7B. Check the results of the doser override test. | DEF pressure at the service tool gauge above 700 kPa [102 psi] for the duration of the test?
STEP 8. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 8A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 8B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4456 active or more than two inactive counts?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for diesel exhaust fluid (DEF) related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1712 active or more than two inactive counts?
YES NO

Fault code 1712 indicates the aftertreatment DEF tank is frozen. Troubleshoot occurrences of Fault Code 1712 before troubleshooting Fault Code 4456.

No Repair

Appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for low DEF tank level.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Make sure the DEF tank is not empty and the tank level gauge is accurate.

Use INSITE™ electronic service tool to read the fault codes.

  • Check for the following active Fault Codes: 1673, 3497, and 3498.

DEF tank empty and/or Fault Code 1673, 3497, or 3498 active?
YES NO

Fill the DEF tank.

 No Repair

Go to 8A

Go to 1D

Guided Step 1D - Check DEF tank for debris.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF tank.

  • Check the DEF tank for debris or foreign particles.
  • Check the DEF tank vent for crystallization buildup and clogging.
  • Use the Cummins® DEF Refractometer Service Tool, Part Number 4919554, to test the DEF concentration.

DEF tank and vent clean and free of debris?
YES NO
No Repair

Clean the DEF tank and tank filter thoroughly. Replace the tank filter, if necessary. See equipment manufacturer service information.

Fill tank with certified DEF.

If the DEF in the tank is found to be dirty, replace the DEF dosing unit filter and inlet screen. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 1E

Go to 8A

Guided Step 1E - Check ambient operating temperatures.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Check if the equipment was operating in a cold ambient environment, temperature below -5°C [23°F], at the time the fault logged.

Use INSITE™ electronic service tool to read the fault code snapshot and check the ambient air temperature sensor reading to verify.

Equipment operating in ambient temperatures below -5°C [23°F] at the time the fault set?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the aftertreatment 2 dosing system 1 DEF line heaters.

Guided Step 2A - Test the aftertreatment 2 DEF line heater relays.

Conditions

  • Turn keyswitch OFF.

Action

Test the aftertreatment 1 DEF line heater relays (K12).

  • Refer to Procedure 019-600 in the Associated Procedures Table.

Aftertreatment 2 line heater relays within specification?
YES NO
No Repair

A damaged line heater relay has been detected. Replace damaged relay. Refer to Procedure 019-600 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Check DEF line heater functionality.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test.

Use an infrared thermometer to measure the surface temperature at the ends of each of the 3 aftertreatment 1 unit 1 DEF lines.

Look for the following:

  • Surface temperature should be above 10°C [50°F].
  • Temperature uniformity across the length of the individual lines.
  • Temperature uniformity between the lines.

If the lines were not at operating temperature when the test was started, a temperature rise will be noticeable

All line heaters functioning correctly?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2C

Guided Step 2C - Inspect the original equipment manufacturer (OEM) harness and line heater connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the three line heaters (suction, pressure, and return) from the OEM harness.

Action

Inspect the OEM harness and line heater connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the line heater or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 8A

Go to 2D

Guided Step 2D - Check line heater supply voltage and return circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the three line heaters (suction, pressure, and return) from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuits.

  • Measure the voltage from the line heater +24 volt SUPPLY pin to the line heater RETURN pin at the heater connector of the OEM harness.

Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

All measurements within 1 VDC of ECM power supply voltage?
YES NO

Replace the malfunctioning line heater(s).

See equipment manufacturer service information.

 No Repair

Go to 8A

Go to 2E

Guided Step 2E - Check line heater supply voltage to the ECM power supply ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the three line heaters (suction, pressure, and return) from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuits.

  • Measure the voltage from the line heater +24 volt SUPPLY pin to ECM power supply ground.

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Refer to Procedure 019-610 in the Associated Procedures Table.

All measurements within 1 VDC of ECM power supply voltage?
YES NO

An open has been detected in the line heater supply circuit.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, Repair or replace the damaged section of harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Troubleshoot return circuit in aftertreatment junction box, if equipped. Refer to Procedure 019-598 in the Associated Procedures Table.

An open has been detected in the line heater return circuit.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, Repair or replace the damaged section of harness.

Troubleshoot return circuit in aftertreatment junction box, if equipped. Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 8A

Go to 8A

Guided Step 3 - Check the aftertreatment 2 DEF dosing unit 1 heating system.

Guided Step 3A - Check the aftertreatment 2 diesel exhaust fluid (DEF) dosing unit heater relay.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment 2 DEF dosing unit heater relay (K2) from the aftertreatment junction box. Refer to Procedure 019-620 in the Associated Procedures Table.

Action

Test aftertreatment 2 DEF dosing unit heater relay.

  • Refer to Procedure 019-620 in the Associated Procedures Table.

Refer to the appropriate wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Aftertreatment 2 DEF dosing unit heater relay within specifications?
YES NO
No Repair

Replace the aftertreatment 2 DEF dosing unit heater relay (K2). Refer to Procedure 019-620 in the Associated Procedures Table.

Go to 8A

Go to 3B

Guided Step 3B - Inspect the aftertreatment 2 DEF dosing unit 1 heater and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 1 heater from the OEM harness.

Action

Inspect the DEF dosing unit heater and OEM harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the Aftertreatment DEF dosing unit heater or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace dosing unit heater only when there are damaged pins. Refer to Procedure 011-112 in the Associated Procedures Table.

 No Repair

Go to 8A

Go to 3C

Guided Step 3C - Check heater circuit resistance in the aftertreatment 2 DEF dosing unit 1 heater.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check resistance at the dosing unit heater.

  • Measure the resistance across heater at the aftertreatment DEF dosing unit heater supply and the aftertreatment DEF dosing unit heater return at the DEF dosing unit.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Resistance at 5.4 ohms ± 2.0 ohm?

YES NO
No Repair

Replace the aftertreatment DEF dosing unit heater. Refer to Procedure 011-112 in the Associated Procedures Table.

Go to 3D

Go to 8A

Guided Step 3D - Check for an open circuit in the aftertreatment 2 DEF dosing unit 1 heater supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 1 heater from the OEM harness.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Perform the Aftertreatment Diesel Exhaust Fluid Doser System Heater Test found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool.
  • Measure the voltage between aftertreatment 2 DEF dosing unit 1 heater supply pin at the aftertreatment 2 DEF dosing unit 1 heater connector and ECM power supply ground.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of ECM power supply voltage?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DEF dosing unit heater supply circuit.

Check the aftertreatment DEF dosing unit heater circuit breaker. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 8A

Guided Step 3E - Check aftertreatment 2 DEF dosing unit 1 heater supply voltage to the ECM power supply ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 1 heater from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuits.

  • Measure the voltage from the line heater +24 volt SUPPLY pin to the ECM power supply ground.

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Refer to Procedure 019-610 in the Associated Procedures Table.

All measurements within 1 VDC of ECM power supply voltage?
YES NO

An open has been detected in the heater return circuit. Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, Repair or replace the damaged section of harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19. Troubleshoot return circuit in aftertreatment junction box, if equipped. Refer to Procedure 019-598 in the Associated Procedures Table.

An open has been detected in the heater return circuit. Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, Repair or replace the damaged section of harness.

Troubleshoot return circuit in aftertreatment junction box, if equipped. Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 8A

Go to 8A

Guided Step 4 - Check the aftertreatment 2 DEF dosing unit 1 lines and fittings.

Guided Step 4A - Inspect the aftertreatment 2 DEF dosing unit 1 lines and fittings.

Conditions

  • Turn keyswitch OFF.

Action

There are three DEF lines on the SCR dosing system:

  • Dosing unit supply line between the tank and the dosing unit (suction line)
  • Dosing valve supply line between the dosing unit and the dosing valve (pressure line)
  • Return line between the dosing valve and the tank (return line).

Inspect all three DEF lines and associated fittings/connectors:

  • Inspect the dosing unit for a plugged inlet filter in the inlet fitting. Refer to procedure 011-058 in the Associated Procedures Table.
  • Inspect the dosing unit DEF filter. Refer to procedure 011-060 in the Associated Procedures Table.
  • Verify the DEF line connections are not swapped at the dosing unit, dosing valve or DEF tank. Reversed DEF lines can cause the dosing system to fail to prime.
  • Check the DEF tank connections (suction and return lines) for cracks and pitting.
  • Check both dosing unit connections and fittings for loose, leaking, or damaged connections.
  • Check the suction line for signs of leakage or openings which will allow the dosing unit to suck in air with the DEF.
  • Check the pressure line for signs of leakage or rupture.
  • Disconnect the suction line, pressure line, and return line connectors and look for signs of buildup or blockage.
  • Verify proper sealing at all connection points and check for damaged or missing o-rings.

Any reversed, damaged, leaking, or restricted connections found?
YES NO

Replace the DEF line(s), fittings, and filters, as necessary.

See equipment manufacturer service information.

For DEF dosing unit inlet filter screen. Refer to Procedure 011-058 in the Associated Procedures Table.

For DEF dosing unit filter. Refer to Procedure 011-060 in the Associated Procedures Table.

For Dosing unit connections. Refer to Procedure 011-058 in the Associated Procedures Table.

Repair or replace the aftertreatment DEF dosing unit as necessary.

Refer to Procedure 011-058 in the Associated Procedures Table.

Replace DEF dosing unit inlet filter screen and dosing unit DEF filter. These filters can not be reused and must be changed upon removal.

Refer to Procedure 011-060 in the Associated Procedures Table.

Go to 8A

Go to 4B

Guided Step 4B - Check for pressure at the aftertreatment 2 DEF dosing valve 1.

Conditions

  • Turn keyswitch OFF
  • Install the DEF pressure gauge between the inlet of the dosing valve and the pressure line. Use DEF pressure gauge kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

Attempt to prime the DEF system.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostics Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure greater than 1000 kPa [145 psi]?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check the aftertreatment 2 DEF dosing unit 1 supply line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 1 supply line from the dosing unit (this is the suction line between the dosing unit and the DEF tank).
  • Disconnect the aftertreatment 2 DEF dosing unit 1 supply line from the DEF tank.

Action

Check the DEF dosing unit 1 supply line for blockage.

  • Check both ends of the dosing unit supply line for signs of buildup or blockage.
  • Blow compressed shop air through the dosing unit supply line to make sure of free flow.

DEF dosing unit supply line blocked or restricted?
YES NO

Try to clean the dosing unit supply line with shop air. If necessary, replace the dosing unit supply line.

See equipment manufacturer service information.

 No Repair

Go to 8A

Go to 4D

Guided Step 4D - Check the aftertreatment 2 DEF dosing valve 1 pressure line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 1 pressure line from the dosing valve (pressure line runs between the dosing unit and dosing valve).
  • Disconnect the aftertreatment 2 DEF dosing valve 1 pressure line from the DEF dosing unit.

Action

Check the aftertreatment 2 DEF pressure line for blockage.

  • Check both ends of the line for signs of buildup or blockage.
  • Blow compressed shop air through the pressure line to make sure of free flow.

DEF pressure line blocked or restricted?
YES NO

Try to clean the pressure line using shop air. If necessary, replace the pressure line.

See equipment manufacturer service information.

 No Repair

Go to 8A

Go to 6A

Guided Step 5 - Check the aftertreatment 2 DEF dosing valve 1 system return.

Guided Step 5A - Check for a blocked aftertreatment 2 DEF dosing valve 1.

Conditions

  • Turn the keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the outlet of the dosing valve and the return line. Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn the keyswitch ON.

Action

Attempt to prime the DEF system.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostics Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure greater than 700 kPa [102 psi]?
YES NO
No Repair

Replace the DEF dosing valve 1.

Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 5B

Go to 8A

Guided Step 5B - Check the aftertreatment 2 DEF dosing valve 1 return line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 1 return line from the dosing valve.
  • Disconnect the aftertreatment 2 DEF dosing valve 1 return line from the DEF tank.

Action

Check the aftertreatment 2 DEF dosing valve 1 return line for blockage.

  • Check both ends of the line for signs of buildup or blockage.
  • Blow compressed shop air through the return line to make sure of free flow.

DEF return line blocked or restricted?
YES NO

Try to clean the return line using shop air. If necessary, replace the return line.

See equipment manufacturer service information.

A blocked or restricted return has been detected in the DEF tank head. Clean or replace the tank head, as necessary.

See equipment manufacturer service information.

Go to 8A

Go to 8A

Guided Step 6 - Check the aftertreatment 2 unit 1 DEF suction line.

Guided Step 6A - Check for air in the DEF.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for air in the DEF.

  • Refer to Procedure 011-075 in the Associated Procedures Table.

Air in the DEF detected?
YES NO

Check the following components for damage/leaks and repair, as necessary:

  • Aftertreatment 2 DEF dosing unit 1 fittings
  • Aftertreatment 2 DEF dosing unit 1 supply line
  • Aftertreatment 2 DEF tank fittings
  • Aftertreatment 2 DEF tank filter.

Refer to Procedure 011-075 in the Associated Procedures Table.

 No Repair

Go to 8A

Go to 6B

Guided Step 6B - Check for an intermittent aftertreatment 2 DEF dosing unit 1 suction line leak.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.

Action

Attempt to prime the DEF system. Use INSITE™ electronic service tool to perform the Aftertreatment DEF System Leak Test, under ECM Diagnostics Tests.

As the DEF system is trying to prime, wiggle the suction line connections at the dosing unit 1 and tank. Monitor the DEF pressure sensor reading in INSITE™ electronic service tool data monitor/logger section.

  • Check if wiggling the suction line connections causes the system to either build pressure or lose prime.
  • Listen for audible indication from the pump that wiggling the suction line is causing air to enter the system.

Wiggling the DEF suction line connections affects the system pressure?
YES NO

Replace the DEF suction line. See equipment manufacturer service information.

 No Repair

Go to 8A

Go to 6C

Guided Step 6C - Check the aftertreatment 2 DEF pressure.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.

Action

Attempt to prime the DEF system.

Use INSITE™ electronic service tool to perform the Aftertreatment DEF System Leak Test, under ECM Diagnostics Tests.

  • Monitor the DEF pressure sensor reading in INSITE™ electronic service tool Data Monitor/Logger section.

DEF pressure greater than 750 kPa [109 psi]?
YES NO
No Repair

Replace the DEF dosing unit 1.

Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 7A

Go to 8A

Guided Step 7 - Check the aftertreatment 2 DEF dosing valve 1 operation.

Guided Step 7A - Check the aftertreatment 2 DEF dosing system operation.

Conditions

  • Connect the DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove the aftertreatment 2 DEF dosing valve 1 from the decomposition chamber.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test, under ECM Diagnostics Tests.

  • Use the following procedure for instructions and specifications. Refer to Procedure 011-063 in the Associated Procedures Table.

The aftertreatment 2 DEF dosing valve 1 must be removed and placed in a measuring container having greater than a 1.5 liter [50 oz] capacity to run the Aftertreatment DEF Doser Pump Override Test.

Dosing volume within the specifications in Procedure 011-063 in the Associated Procedures Table?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7B

Guided Step 7B - Check the results of the doser override test.

Conditions

  • Turn the keyswitch OFF.

Action

Check the results of the doser override test.

Check the service pressure tool reading recorded during the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

DEF pressure at the service tool gauge reading above 700 kPa [102 psi] for the duration of the test?
YES NO

Replace the aftertreatment 2 DEF dosing valve 1.

Refer to Procedure 011-059 in the Associated Procedures Table.

Replace the aftertreatment 2 DEF dosing unit 1. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 8A

Go to 8A

Guided Step 8 - Check ECM calibration and clear fault codes.

Guided Step 8A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in Section 19.

Go to 8B

Go to 8B

Guided Step 8B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process

Repair complete

Last Modified: 03-May-2017


FAULT CODE 4457 - Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4457 active?
STEP 2. | Check the aftertreatment 2 diesel exhaust fluid (DEF) dosing unit 1 and circuit. |
 | STEP 2A. Inspect the aftertreatment 2 DEF dosing unit 1 and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit on the aftertreatment 2 DEF dosing unit 1 supply in the original equipment manufacturer (OEM) harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit on the aftertreatment 2 DEF dosing unit 1 supply in the OEM harness. | Greater than 100k ohms?
 | STEP 2D. Check for a pin-to-pin short circuit on the aftertreatment 2 DEF dosing unit 1 signal in the OEM harness. | Greater than 100k ohms?
 | STEP 2E. Check for an open circuit on the aftertreatment 2 DEF dosing unit 1 supply in the engine harness. | Less than 10 ohms?
 | STEP 2F. Check for a pin-to-pin short circuit on the aftertreatment 2 DEF dosing unit 1 supply in the engine harness. | Greater than 100k ohms?
 | STEP 2G. Check for a pin-to-pin short circuit on the aftertreatment 2 DEF doing unit 1 signal in the engine harness. |
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4457 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 2 DEF dosing unit 1 and circuit.

Guided Step 2A - Inspect the aftertreatment 2 DEF dosing unit 1 and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 1 from the OEM harness.

Action

Inspect the harness and aftertreatment 2 DEF dosing unit 1 connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit on the aftertreatment 2 DEF dosing unit 1 supply in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 1 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness aftertreatment 2 DEF dosing unit 1 SUPPLY pin and OEM harness aftertreatment 2 connector DEF dosing unit 1 SUPPLY pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • Refer to Procedure 019-071 in Section 19 for the OEM harness.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit on the aftertreatment 2 DEF dosing unit 1 supply in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 1 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit 1 SUPPLY pin of the OEM harness aftertreatment 2 connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the damaged section of harness.

  • Refer to Procedure 019-071 in Section 19 for the OEM harness.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-pin short circuit on the aftertreatment 2 DEF dosing unit 1 signal in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 1 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit 1 command SIGNAL pin of the OEM harness aftertreatment 2 connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • Refer to Procedure 019-071 in Section 19 for the OEM harness.

Go to 2E

Go to 3A

Guided Step 2E - Check for an open circuit on the aftertreatment 2 DEF dosing unit 1 supply in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness aftertreatment 2 connector DEF dosing unit 1 SUPPLY pin and OEM harness ECM connector aftertreatment 2 DEF dosing unit 1 SUPPLY pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected.

Repair or replace the damaged section of harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table for the engine harness.

Go to 2F

Go to 3A

Guided Step 2F - Check for a pin-to-pin short circuit on the aftertreatment 2 DEF dosing unit 1 supply in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing 2 unit SUPPLY pin of the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected.

Repair or replace the damaged section of harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table for the engine harness.

Go to 2G

Go to 3A

Guided Step 2G - Check for a pin-to-pin short circuit on the aftertreatment 2 DEF dosing unit 1 signal in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit 1 command SIGNAL pin of the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the aftertreatment 2 DEF dosing unit 1. Refer to Procedure 011-058 in the Associated Procedure Table.

A pin-to-pin short circuit has been detected.

Repair or replace the damaged section of harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table for the engine harness.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 4458 - Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4458 active?
STEP 2. | Check the aftertreatment 2 diesel exhaust fluid (DEF) dosing unit 1 and circuit. |
 | STEP 2A. Inspect the aftertreatment 2 DEF dosing unit 1 and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit on the aftertreatment 2 DEF dosing unit 1 signal circuit in the original equipment manufacturer (OEM) harness. | Less than 10 ohms?
 | STEP 2C. Check for an open circuit on the aftertreatment 2 DEF dosing unit 1 supply in the OEM harness. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-engine control module (ECM) power supply ground short circuit on the aftertreatment 2 DEF dosing unit 1 signal in the OEM harness. | Greater than 100k ohms?
 | STEP 2E. Check for a pin-to-ECM power supply ground short circuit on the aftertreatment 2 DEF dosing unit 1 supply in the OEM harness. | Greater than 100k ohms?
 | STEP 2F. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2G. Check for an open circuit on the aftertreatment 2 DEF dosing unit 1 signal circuit in the engine harness. | Less than 10 ohms?
 | STEP 2H. Check for an open circuit on the aftertreatment 2 DEF dosing unit 1 supply in the engine harness. | Less than 10 ohms?
 | STEP 2I. Check for a pin-to-ECM power supply ground short circuit on the aftertreatment 2 DEF dosing unit 1 signal in the engine harness. | Greater than 100k ohms?
 | STEP 2J. Check for a pin-to-ECM power supply ground short circuit on the aftertreatment 2 DEF dosing unit 1 supply in the engine harness. | Greater than 100k ohms?
 | STEP 2K. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4458 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 2 DEF dosing unit 1 and circuit.

Guided Step 2A - Inspect the aftertreatment 2 DEF dosing unit 1 and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 1 from the OEM harness.

Action

Inspect the harness and aftertreatment 2 DEF dosing unit 1 connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit on the aftertreatment 2 DEF dosing unit 1 signal circuit on the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 1 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit 1 command SIGNAL pin at the dosing unit wiring harness connector and aftertreatment 2 DEF dosing unit 1 command SIGNAL pin in the OEM harness aftertreatment 2 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped with an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit on the aftertreatment 2 DEF dosing unit 1 supply in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 1 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit 1 SUPPLY pin at the dosing unit wiring harness connector and aftertreatment 2 DEF dosing unit 1 SUPPLY pin in the OEM harness aftertreatment 2 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped with an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-ECM power supply ground short circuit on the aftertreatment 2 DEF dosing unit 1 signal in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 1 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit 1 command SIGNAL pin of the OEM harness aftertreatment 2 connector and ECM power supply ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit has been detected.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped with an aftertreatment junction box.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a pin-to-ECM power supply ground short circuit on the aftertreatment 2 DEF dosing unit 1 supply in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 1 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit 1 SUPPLY pin of the OEM harness aftertreatment 2 connector and ECM power supply ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit has been detected.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped with an aftertreatment junction box.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 1 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit 1 SIGNAL pin of the OEM harness aftertreatment 2 connector and all other pins in the OEM harness ECM connector.
  • Measure the resistance between the aftertreatment 2 DEF dosing unit 1 SUPPLY pin of the OEM harness aftertreatment 2 connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped with an aftertreatment junction box.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 2G

Go to 3A

Guided Step 2G - Check for an open circuit on the aftertreatment 2 DEF dosing unit 1 signal circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness aftertreatment 2 connector DEF dosing unit 1 command SIGNAL pin and the aftertreatment 2 DEF dosing unit 1 command SIGNAL pin in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected.

Repair or replace the damaged section of the harness.

  • For the engine harness: Refer to procedure 019-043 in the Associated Procedures Table.

Go to 2H

Go to 3A

Guided Step 2H - Check for an open circuit on the aftertreatment 2 DEF dosing unit 1 supply in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness aftertreatment 2 connector DEF dosing unit 1 SUPPLY pin and the aftertreatment 2 DEF dosing unit 1 command SUPPLY pin in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected.

Repair or replace the damaged section of the harness.

  • For the engine harness: Refer to procedure 019-043 in the Associated Procedures Table.

Go to 2I

Go to 3A

Guided Step 2I - Check for a pin-to-ECM power supply ground short circuit on the aftertreatment 2 DEF dosing unit 1 signal in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit 1 command SIGNAL pin of the OEM harness ECM connector and ECM power supply ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit has been detected.

Repair or replace the damaged section of the harness.

  • For the engine harness: Refer to procedure 019-043 in the Associated Procedures Table.

Go to 2J

Go to 3A

Guided Step 2J - Check for a pin-to-ECM power supply ground short circuit on the aftertreatment 2 DEF dosing unit 1 supply in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit 1 SUPPLY pin of the OEM harness ECM connector and ECM power supply ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit has been detected.

Repair or replace the damaged section of the harness.

  • For the engine harness: Refer to procedure 019-043 in the Associated Procedures Table.

Go to 2K

Go to 3A

Guided Step 2K - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit 1 SIGNAL pin of the OEM harness ECM connector and all other pins in the OEM harness ECM connector.
  • Measure the resistance between the aftertreatment 2 DEF dosing unit 1 SUPPLY pin of the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the aftertreatment 2 DEF dosing unit 1. Refer to procedure 011-058 in the Associated Procedures Table.

A pin-to-pin short circuit has been detected.

Repair or replace the damaged section of the harness.

  • For the engine harness: Refer to procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 05-Apr-2016


FAULT CODE 4459 - Aftertreatment 2 Diesel Exhaust Fluid Line Heater Relay - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Delphi® 96 Way Engine Control Module Connector | Refer to Procedure 019-505 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Line Heater Relay | Refer to Procedure 019-600 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box Resistor | Refer to Procedure 019-625 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault codes. | Fault Code 4459 active?
STEP 2. | Check the aftertreatment 2 diesel exhaust fluid (DEF) line heater relay and resistor. |
 | STEP 2A. Check the aftertreatment 2 DEF line heater relay. | Aftertreatment 2 DEF line heater relay within specifications?
 | STEP 2B. Check the aftertreatment 2 DEF line heater resistor. | Aftertreatment 2 DEF line heater resistor within specifications?
STEP 3. | Check the aftertreatment 1 harness. |
 | STEP 3A. Inspect the aftertreatment 2 connector pins. | Dirty or damaged pins.
 | STEP 3B. Check for open signal circuit. | Less than 10 ohms?
 | STEP 3C. Check for open return circuit. | Less than 10 ohms?
 | STEP 3D. Check for signal return circuit. | Less than 10 ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
STEP 4. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 4A. Inspect the aftertreatment 2 connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit. | Less than 10 ohms?
 | STEP 4C. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 4D. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 4E. Check for an open circuit. | Less than 10 ohms?
 | STEP 4F. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4459 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent or inactive fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 2 diesel exhaust fluid (DEF) line heater relay and resistor.

Guided Step 2A - Check the aftertreatment 2 DEF line heater relay.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment 1 DEF line heater relay (K12) from the aftertreatment junction box. Refer to Procedure 019-600 in the Associated Procedures Table.

Action

Test aftertreatment 2 DEF line heater relay. Refer to Procedure 019-600 in the Associated Procedures Table.

Reference the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Aftertreatment 2 DEF line heater relay within specifications?
YES NO
No Repair

Replace the aftertreatment 2 DEF line heater relay (K12). Refer to Procedure 019-600 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Check the aftertreatment 2 DEF line heater resistor.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment 2 DEF line heater resistor (R7) from the aftertreatment junction box. Refer to Procedure 019-625 in the Associated Procedures Table.

Action

Check the resistance of the aftertreatment 2 DEF line heater relay coil.

Test aftertreatment 2 DEF line heater resistor. Refer to Procedure 019-625 in the Associated Procedures Table.

Reference the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Aftertreatment 2 DEF line heater resistor within specifications?
YES NO
No Repair

Replace the aftertreatment 2 DEF line heater resistor (R7). Refer to Procedure 019-625 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the aftertreatment 1 harness.

Guided Step 3A - Inspect the aftertreatment 2 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.

Action

Inspect the connector(s) for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the C5 connector.

Repair the damaged harness, connector, or pins, if possible.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.
  • For the aftertreatment junction box: Refer to Procedure 019-598 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for open signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.

Action

  • Measure the resistance between the aftertreatment 2 DEF line heater SIGNAL pin at the aftertreatment junction box C1 connector and the aftertreatment 2 DEF line heater relay (K12) terminal A1.
  • Measure the resistance between the aftertreatment 2 DEF line heater SIGNAL pin at the aftertreatment junction box C1 connector and the aftertreatment 2 DEF line heater relay (K14) terminal 7.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the aftertreatment junction box.

Troubleshoot all wires connected in series to determine which one contains the open circuit.

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for open return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.

Action

  • Measure the resistance between the aftertreatment 2 DEF dosing unit heater RETURN pin at the Aftertreatment Junction Box C1 connector and the aftertreatment 2 DEF line heater resistor (R7) terminal A.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Troubleshoot all wires connected in series to determine which one contains the open circuit.

Repair or replace damaged section of wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check for signal return circuit.

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the resistance between the aftertreatment 2 DEF line heater resistor (R7) terminal C and the aftertreatment 1 DEF line heater relay (K12) terminal A1.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Troubleshoot all wires connected in series to determine which one contains the open circuit.

Repair or replace damaged section of wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3E

Go to 5A

Guided Step 3E - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.
  • Remove the aftertreatment 2 DEF line heater relay resistor (R7) from the aftertreatment junction box. Refer to Procedure 019-625 in the Associated Procedures Table.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF line heater SIGNAL pin in the aftertreatment junction box C1 connector and all other pins in the connector.

Reference the wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in aftertreatment junction box.

Troubleshoot all wire(s) in series to determine which one contains the short circuit.

Repair or replace the damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine control module (ECM) and original equipment manufacturer (OEM) harness.

Guided Step 4A - Inspect the aftertreatment 2 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness at the aftertreatment 2 connector.

Action

Inspect the connector(s) for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.
  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.
  • Disconnect the OEM harness at the aftertreatment 2 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF line heater SIGNAL pin in the aftertreatment junction box C1 connector and the aftertreatment 2 DEF line heater SIGNAL pin in the aftertreatment 2 connector.
  • Measure the resistance between the aftertreatment 2 DEF line heater RETURN pin in the aftertreatment junction box C1 connector and the aftertreatment 2 DEF line heater RETURN pin in the aftertreatment 2 connector.

Reference the wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all harness connections in series to determine which one contains open circuit.

Repair or replace damaged section of harness. Refer to Procedure 019-071 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.
  • Disconnect the OEM harness at the aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF line heater SIGNAL pin in the aftertreatment 2 connector and all other pins in the connector.

Reference the wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harness connections in series to determine which one contains the short circuit.

Repair or replace damaged section of harness. Refer to Procedure 019-071 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector (J2) from ECM (2).

Action

Inspect the connector(s) for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-505 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4E

Guided Step 4E - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector (J2) from ECM (2).
  • Disconnect the OEM harness at the aftertreatment 2 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF line heater SIGNAL pin in the OEM connector (J2) from ECM (2) and the aftertreatment 2 DEF line heater SIGNAL pin in the aftertreatment 2 connector.
  • Measure the resistance between the aftertreatment 2 DEF line heater RETURN pin in the OEM connector (J2) from ECM (2) and the aftertreatment 2 DEF line heater RETURN pin in the aftertreatment 2 connector.

Use a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all harness connections in series to determine which one contains open circuit.

If an open circuit is isolated to damaged harness, Repair or replace damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4F

Go to 5A

Guided Step 4F - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector (J2) from ECM (2).
  • Disconnect the OEM harness at the aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF line heater SIGNAL pin in the OEM connector (J2) from ECM (2) and all other pins in the connector.

Use a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harness connections in series to determine which one contains the short circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process.

Repair complete.

Last Modified: 26-Jul-2017


FAULT CODE 4461 - Aftertreatment 2 Diesel Exhaust Fluid Line Heater Relay - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Line Heater Relay | Refer to Procedure 019-600 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box Resistor | Refer to Procedure 019-625 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault codes. | Fault Code 4461 active?
STEP 2. | Check the aftertreatment 2 diesel exhaust fluid (DEF) line heater relay resistor. |
 | STEP 2A. Check the aftertreatment 2 DEF line heater relays. | Aftertreatment 2 DEF line heater relays within specifications?
 | STEP 2B. Check the aftertreatment 2 DEF line heater resistor. | Aftertreatment 2 DEF line heater resistor within specifications?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3B. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4461 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent or inactive fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 2 diesel exhaust fluid (DEF) line heater relay resistor.

Guided Step 2A - Check the aftertreatment 2 DEF line heater relays.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment 2 DEF line heater relays (K12 and K14) from the aftertreatment junction box. Refer to Procedure 019-620 in the Associated Procedures Table.

Action

Test aftertreatment 2 DEF line heater relays. Refer to Procedure 019-600 in the Associated Procedures Table.

Reference the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Aftertreatment 2 DEF line heater relays within specifications?
YES NO
No Repair

Replace the aftertreatment 2 DEF line heater relay (K12 or K14). Refer to Procedure 019-620 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check the aftertreatment 2 DEF line heater resistor.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment 2 DEF line heater resistor (R7) from the aftertreatment junction box. Refer to Procedure 019-625 in the Associated Procedures Table.

Action

Test aftertreatment 2 DEF line heater resistor. Refer to Procedure 019-625 in the Associated Procedures Table.

Reference the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Aftertreatment 2 DEF line heater resistor within specifications?
YES NO
No Repair

Replace the aftertreatment 2 DEF line heater resistor (R7). Refer to Procedure 019-625 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and original equipment manufacturer (OEM) harness.

Guided Step 3A - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment 2 DEF line heater relays (K12 and K14).
  • Disconnect the aftertreatment 2 DEF line heater resistor (R7).

Action

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Measure the resistance between the aftertreatment 2 DEF line heater relay SIGNAL pin terminal A1 and the G2 ground connector in the aftertreatment junction box.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment 2 DEF line heater relays (K12 and K14).
  • Disconnect the aftertreatment 2 DEF line heater resistor (R7).

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF line heater relay SIGNAL pin at the OEM harness ECM connector and all other pins.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the OEM harness.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process.

Repair complete

Last Modified: 26-Jul-2017


FAULT CODE 4462 - Aftertreatment 2 Diesel Exhaust Fluid Dosing Valve - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for aftertreatment 2 diesel exhaust fluid (DEF) dosing valve 1 fault codes. | Fault Code 5771 active?
STEP 2. | Check the aftertreatment 2 DEF dosing valve 1 and circuit. |
 | STEP 2A. Inspect the aftertreatment 2 DEF dosing valve 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the aftertreatment 2 DEF dosing valve 1 resistance. | Between 10 and 17 ohms?
STEP 3. | Check the engine and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the aftertreatment 2 DEF dosing valve 1 signal circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check the aftertreatment 2 DEF dosing valve 1 return circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-engine control module (ECM) power supply ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Inspect the ECM harness connector pins. | Dirty or damaged pins?
 | STEP 3G. Check the aftertreatment 2 DEF dosing valve 1 signal circuit. | Less than 10 ohms?
 | STEP 3H. Check the aftertreatment 2 DEF dosing valve 1 return circuit. | Les than 10 ohms?
 | STEP 3I. Check for a pin-to-ECM power supply ground short circuit. | Greater than 100k ohms?
 | STEP 3J. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for aftertreatment 2 DEF dosing valve 1 fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5771 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the aftertreatment 2 DEF dosing valve 1 and circuit.

Guided Step 2A - Inspect the aftertreatment 2 DEF dosing valve 1 and connectors pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve from the OEM harness.

Action

Inspect the OEM harness and aftertreatment 2 DEF dosing valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing valve or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the aftertreatment 2 DEF dosing valve 1 resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 1 from the OEM harness.

Action

Check for an internal short or open circuit in the aftertreatment 2 DEF dosing valve 1 by measuring the internal resistance.

  • Measure the resistance from the aftertreatment 2 DEF dosing valve 1 SIGNAL pin to the aftertreatment 2 DEF dosing valve 1 RETURN pin at the aftertreatment 2 DEF dosing valve 1 connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 10 and 17 ohms?
YES NO
No Repair

An internal short or open circuit has been detected in the aftertreatment 2 DEF dosing valve 1.

Replace the aftertreatment 2 DEF dosing valve 1.

Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine and OEM harness.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Inspect the OEM harness aftertreatment 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the OEM harness aftertreatment 2 connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the aftertreatment 2 DEF dosing valve 1 signal circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 1 from the OEM harness.

Action

Check the dosing valve signal circuit.

  • Measure the resistance from the OEM harness aftertreatment 2 DEF dosing valve 1 connector SIGNAL pin to the OEM harness aftertreatment 2 connector DEF dosing valve 1 SIGNAL pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped with an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For OEM harness repair: Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the aftertreatment 2 DEF dosing valve 1 return circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 1 from the OEM harness.

Action

Check the dosing valve return circuit.

  • Measure the resistance between the OEM harness aftertreatment 2 DEF dosing valve 1 connector RETURN pin to the OEM aftertreatment 2 connector DEF dosing valve 1 RETURN pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped with an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For OEM harness repair: Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ECM power supply ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 1 from the OEM harness.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing valve 1 SIGNAL pin in the OEM harness aftertreatment 2 connector and ECM power supply ground.
  • Measure the resistance between the aftertreatment 2 DEF dosing valve 1 RETURN pin in the OEM harness aftertreatment 2 connector and ECM power supply ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped with an aftertreatment junction box.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For OEM harness repair: Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 1 from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing valve 1 SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped with an aftertreatment junction box.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For OEM harness repair: Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 3F - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the ECM connecter.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3G

Guided Step 3G - Check the aftertreatment 2 DEF dosing valve 1 signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check the dosing valve signal circuit.

  • Measure the resistance between the OEM harness aftertreatment 2 connector DEF dosing valve 1 connector SIGNAL pin and the ECM connector aftertreatment 2 DEF dosing valve 1 SIGNAL pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Repair or replace the damaged section of harness.

For engine harness repair: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3H

Go to 4A

Guided Step 3H - Check the aftertreatment 2 DEF dosing valve 1 return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check the dosing valve return circuit.

  • Measure the resistance between the OEM harness aftertreatment 2 connector DEF dosing valve 1 connector RETURN pin and the ECM connector aftertreatment 2 DEF dosing valve 1 RETURN pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Repair or replace the damaged section of harness.

For engine harness repair: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3I

Go to 4A

Guided Step 3I - Check for a pin-to-ECM power supply ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing valve 1 SIGNAL pin in the OEM harness ECM connector and ECM power supply ground.
  • Measure the resistance between the aftertreatment 2 DEF dosing valve 1 RETURN pin in the OEM harness ECM connector and ECM power supply ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit has been detected in the harness.

Repair or replace the damaged section of harness.

For engine harness repair: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3J

Go to 4A

Guided Step 3J - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing valve 2 SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness.

Repair or replace the damaged section of harness.

For engine harness repair: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 05-Apr-2016


FAULT CODE 4463 - Aftertreatment 2 Diesel Exhaust Fluid Dosing Valve 1 - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4463 active?
STEP 2. | Check the aftertreatment 2 diesel exhaust fluid (DEF) dosing valve 1. |
 | STEP 2A. Check for a stuck closed aftertreatment 2 DEF dosing valve 1. | Dosing valve meets the specification outline in Procedure 011-063 in the Associated Procedures Table?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes..

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4463 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the aftertreatment 2 diesel exhaust fluid (DEF) dosing valve 1.

Guided Step 2A - Check for a stuck closed aftertreatment 2 DEF dosing valve 1.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment 2 DEF dosing valve 1. Refer to Procedure 011-059 in the Associated Procedures Table.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a stuck closed or low flowing aftertreatment 2 DEF dosing valve 1.

  • Perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Override test. Refer to Procedure 011-063 in the Associated Procedures Table.

Dosing valve meets the specification outline in Procedure 011-0633 in the Associated Procedures Table?
YES NO
No Repair

A damaged aftertreatment DEF dosing valve has been detected.

Inspect and Clean the aftertreatment DEF dosing valve.

  • Refer to Procedure 011-059 in the Associated Procedures Table.

After cleaning, perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Override test again. If the Dosing valve does not meet the specification outlined in Procedure 011-063 in the Associated Procedures Table, replace the aftertreatment DEF dosing valve.

  • Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Codes" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair Complete.

Last Modified: 20-May-2016


FAULT CODE 4464 - Aftertreatment 2 Diesel Exhaust Fluid Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for active fault code. | Fault Code 4464 active?
STEP 2. | Check the aftertreatment 2 diesel exhaust fluid (DEF) pressure sensor 1 and circuit. |
 | STEP 2A. Inspect the aftertreatment 2 DEF pressure sensor 1 and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 4465 active and Fault Code 4464 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 4464 active?
STEP 3. | Check the engine control, module (ECM) and original equipment manufacturer (OEM) harness connector. |
 | STEP 3A. Inspect the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the harness in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the harness in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the harness in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 4464 active?
 | STEP 3F. Inspect the ECM harness connector pins. | Dirty or damaged pins?
 | STEP 3G. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3H. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3I. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3J. Check for an active fault code. | Fault Code 4464 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4464 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 2 diesel exhaust fluid (DEF) pressure sensor 1 and circuit.

Guided Step 2A - Inspect the aftertreatment 2 DEF pressure sensor 1 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 1 from the OEM harness.

Action

Inspect the OEM harness and aftertreatment 2 DEF dosing valve 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 1 from the OEM harness
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Other aftertreatment 2 DEF dosing unit 1 fault codes will be active.

Fault Code 4465 active and Fault Code 4464 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 1 from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the aftertreatment 2 DEF pressure 1 +5 volt SUPPLY pin to the aftertreatment 2 DEF pressure 1 RETURN pin at the dosing valve connector of the OEM harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 2 DEF dosing valve 1 to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4464 active?
YES NO

A damaged DEF pressure sensor has been detected inside the aftertreatment 2 DEF dosing valve.

Replace the aftertreatment 2 DEF dosing valve 1. Refer to Procedure 011-059 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control, module (ECM) and original equipment manufacturer (OEM) harness connector.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the harness in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 1 from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 1 RETURN pin in the OEM harness aftertreatment 2 connector and the aftertreatment 2 DEF pressure sensor 1 RETURN pin in the OEM harness dosing valve connector.

Use a the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the harness in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 1 from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 1 SIGNAL pin in the OEM harness aftertreatment 2 connector and all other pins in the OEM harness aftertreatment 2 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If a short circuit is isolated to damaged harness, repair or replace the damaged section of harness.

  • For OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the harness in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 1 from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 1 SUPPLY pin in the OEM harness aftertreatment 2 connector and all other pins in the OEM harness aftertreatment 2 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If a short circuit is isolated to damaged harness, repair or replace the damaged section of harness.

  • For OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault codes.

Conditions

  • Connect all components.
  • Trun keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4464 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3F - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedure Table.

 No Repair

Go to 4A

Go to 3G

Guided Step 3G - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness Aftertreatment 2 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 1 RETURN pin in the OEM harness ECM connector and the aftertreatment 2 DEF pressure sensor 1 RETURN pin in the OEM harness connector from the engine harness Aftertreatment 2 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Repair or replace the damaged section of harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3H

Go to 4A

Guided Step 3H - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness Aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 1 SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the damaged section of harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3I

Go to 4A

Guided Step 3I - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness Aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 1 SUPPLY pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the short circuit.

Repair or replace the damaged section of harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3J

Go to 4A

Guided Step 3J - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4464 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault code.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 4465 - Aftertreatment 2 Diesel Exhaust Fluid Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 4465 active?
STEP 2. | Check the aftertreatment 2 diesel exhaust fluid (DEF) pressure sensor 1 and circuit. |
 | STEP 2A. Inspect the aftertreatment 2 DEF pressure sensor 1 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 4464 active and Fault Code 4465 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 4465 active?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM aftertreatment 2 harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check of a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ECM power supply ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Inspect the ECM OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3G. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3H. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3I. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3J. Check for a pin-to-ECM power supply ground short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3K. Check for an active fault code. | Fault Code 4465 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4465 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 2 diesel exhaust fluid (DEF) pressure sensor 1 and circuit.

Guided Step 2A - Inspect the aftertreatment 2 DEF pressure sensor 1 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 1 from the OEM harness.

Action

Inspect the OEM harness and aftertreatment 2 DEF dosing valve 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Repair or replace the engine harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 1 from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the aftertreatment 2 DEF pressure sensor 1 +5 volt SUPPLY pin to the aftertreatment 2 DEF pressure sensor 1 RETURN pin at the aftertreatment 2 DEF dosing valve 1 connector of the OEM harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 1 from the OEM harness
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment 2 DEF pressure sensor 1 +5 volt SUPPLY pin and the aftertreatment 2 DEF pressure sensor 1 SIGNAL pin at the aftertreatment 1 DEF dosing valve 2 connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Other DEF dosing valve fault codes will be active.

Fault Code 4464 active and Fault Code 4465 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 2 DEF dosing valve 1 to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4465 active?
YES NO

A damaged aftertreatment 2 DEF pressure sensor has been detected inside the aftertreatment 1 DEF dosing valve 1.

Replace the aftertreatment 2 DEF dosing valve 1. Refer to Procedure 011-059 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the OEM aftertreatment 2 harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Inspect the OEM harness aftertreatment 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM aftertreatment 2 harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 1 from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 1 SUPPLY pin in the OEM harness aftertreatment 2 connector and the aftertreatment 2 DEF pressure sensor 1 SUPPLY pin in the OEM harness aftertreatment 2 DEF dosing valve 1 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, Repair or replace the damaged section of harness.

  • For OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 1 from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 1 SIGNAL pin in the OEM harness aftertreatment 2 connector and the aftertreatment 2 DEF pressure sensor 1 SIGNAL pin in the OEM harness aftertreatment 2 DEF dosing valve 1 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, Repair or replace the damaged section of harness.

  • For OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 1 SIGNAL pin in the OEM harness aftertreatment 2 connector and all other pins in the OEM harness aftertreatment 2 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal wire has been detected in the OEM harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, Repair or replace the damaged section of harness.

  • For OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ECM power supply ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve from the OEM harness.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 1 SIGNAL pin in the OEM harness aftertreatment 2 connector and ECM power supply ground.

Use a wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Refer to Procedure 019-610 in the Associated Procedures Table.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, Repair or replace the damaged section of harness.

  • For OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Inspect the ECM OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the ECM OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM OEM connector.

  • Clean the connector and pins. Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3G

Guided Step 3G - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for an open circuit

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 1 SUPPLY pin in the OEM harness ECM connector and the aftertreatment 2 DEF pressure sensor 1 SUPPLY pin in the OEM harness aftertreatment 2 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the harness.

Repair or replace the damaged section of the harness.

  • For the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3H

Go to 4A

Guided Step 3H - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 1 SIGNAL pin in the OEM harness ECM connector and the aftertreatment 2 DEF pressure sensor 1 SIGNAL pin in the OEM harness aftertreatment 2 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Repair or replace the damaged section of the harness.

  • For the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3I

Go to 4A

Guided Step 3I - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 1 SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal wire has been detected in the OEM harness.

Repair or replace the damaged section of the harness.

  • For the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3J

Go to 4A

Guided Step 3J - Check for a pin-to-ECM power supply ground short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness Aftertreatment 2 connector.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 1 SIGNAL pin in the OEM harness ECM connector and ECM power supply ground.

Use a wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Refer to Procedure 019-610 in the Associated Procedures Table.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit on the signal wire has been detected in the harness.

Repair or replace the damaged section of the harness.

  • For the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3K

Go to 4A

Guided Step 3K - Check for an active fault codes.

Conditions

  • Connect all components.
  • Trun keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4465 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 4466 - Aftertreatment 2 Diesel Exhaust Fluid Pressure 1 - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSK95 CM2350 K113 | 4388663
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Line Restriction Test | Refer to Procedure 011-086 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid System Connection Test | Refer to Procedure 011-107 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Suction Test | Refer to Procedure 011-121 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4456 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for related fault codes. | Fault Code 1712 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1C. Check for low diesel exhaust fluid (DEF) tank level. | DEF tank empty and/or Fault Code 1673, 3497, or 3498 active?
 | STEP 1D. Check for active fault codes. | Fault Code 1683, 1684, 1712, 1713, 3237, 3239, 3242, 3258, 3261, 3422, 3425, 3426, 3429, 3559, 3558, 3562, 3563, 3564, 3571, 3572, 3575, 3576, 3596, 3713, 4167, 5278, or 5935 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1E. Check for crossed connections. | Any crossed per Procedure 011-107?
STEP 2. | Check the aftertreatment DEF lines and fittings. |
 | STEP 2A. Inspect the aftertreatment DEF lines and fittings. | Any reversed, damaged, leaking, or restricted connections found?
 | STEP 2B. Check the DEF tank. | DEF tank and vent clean and free of debris?
STEP 3. | Check the aftertreatment DEF dosing unit. |
 | STEP 3A. Check the aftertreatment DEF dosing unit. | Vacuum in diagnostic line greater than -203.2 mm-Hg [-8.0 in-Hg]?
 | STEP 3B. Check the aftertreatment DEF dosing unit. | DEF unit operating?
 | STEP 3C. Inspect the ECM and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 3D. Check for an open return circuit in the harness. | Less than 10 ohms?
STEP 4. | Check the aftertreatment DEF intake system. |
 | STEP 4A. Check the DEF dosing unit intake restriction. | Restriction less than -150 mm-Hg [-6 in-Hg]?
STEP 5. | Check for air in the aftertreatment DEF. |
 | STEP 5A. Check for air in the DEF. | Air in the DEF detected?
STEP 6. | Check the aftertreatment DEF pressure sensor. |
 | STEP 6A. Inspect the aftertreatment DEF pressure sensor. | Aftertreatment DEF pressure reading in INSITE™ electronic service tool equal to 0 ±69 kPa [0 ±10 psi]?
 | STEP 6B. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 6C. Check for an open circuit in the harness. | Less than 10 ohms?
STEP 7. | Check the aftertreatment DEF lines and fittings. |
 | STEP 7A. Check for pressure at the aftertreatment DEF dosing valve. | DEF pressure less than 950 kPa [137 psi]?
 | STEP 7A-1. Check for pressure at the aftertreatment DEF dosing valve. |
 | STEP 7A-2. Check for pressure at the aftertreatment DEF dosing valve. |
 | STEP 7B. Check for pressure out of the aftertreatment DEF dosing unit. | DEF pressure less than 950 kPa [137 psi]?
 | STEP 7C. Check for pressure out of the aftertreatment DEF dosing unit. | DEF pressure less than 750 kPa [108 psi]?
 | STEP 7D. Check the aftertreatment DEF dosing unit for blockage. | DEF dosing unit blocked or restricted?
STEP 8. | Check the aftertreatment DEF dosing unit operation. |
 | STEP 8A. Check the aftertreatment DEF dosing unit system operation. | Dosing volume within the specifications in Procedure 011-063?
STEP 9. | Check ECM calibration and clear fault codes. |
 | STEP 9A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 9B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4456 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1712 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for low DEF tank level.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

  • Check for the following active Fault Codes: 1673, 3497, and 3498.

DEF tank empty and/or Fault Code 1673, 3497, or 3498 active?
YES NO

Fill the DEF tank.

 No Repair

Go to 9A

Go to 1D

Guided Step 1D - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1683, 1684, 1712, 1713, 3237, 3239, 3242, 3258, 3261, 3422, 3425, 3426, 3429, 3559, 3558, 3562, 3563, 3564, 3571, 3572, 3575, 3576, 3596, 3713, 4167, 5278, or 5935 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

See the appropriate fault code troubleshooting tree.

Go to 1E

Guided Step 1E - Check for crossed connections.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to check for cross-connection of components. Refer to Procedure 011-107 in the Associated Procedures Table.
  • Trace the DEF pressure line from the DEF dosing unit. Verify it is connected to the correct DEF dosing valve, by component location, on the aftertreatment.

Any crossed systems found per Procedure 011-107?
YES NO

Correct the crossed systems. Refer to Procedure 011-107 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 2A

Guided Step 2 - Check the aftertreatment DEF lines and fittings.

Guided Step 2A - Inspect the aftertreatment DEF lines and fittings.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the following aftertreatment DEF fittings and lines.

  • Dosing unit supply line between the tank and dosing unit (suction line)
  • Dosing valve supply line between the dosing unit and dosing valve (pressure line)
  • Return line between the dosing valve and tank (return line).

Inspect all three DEF lines and associated fittings/connectors:

  • Verify the lines are not swapped at the dosing unit, dosing valve, or DEF tank connections. Reversed DEF line connectors cause the dosing system to fail to prime.
  • Check the DEF tank connections (suction and return lines) for cracks and pitting.
  • Check both dosing unit connections and fittings for loose, leaking, or damaged connections.
  • Disconnect the suction line and pressure line dosing unit connectors. Look for signs of buildup or blockage.
  • Check the suction line for signs of leakage or openings which will allow the dosing unit to suck in air with the DEF.
  • Check the pressure line for sings of leakage or rupture.
  • Verify proper sealing at all connection points, including DEF tank (two connections), dosing unit (two connections), and dosing valve (two connections).

Refer to Procedure 011-058 in the Associated Procedures Table.

Any reversed, damaged, leaking, or restricted connections found?
YES NO

Replace the leaking DEF line, as necessary. See equipment manufacturer service information.

 No Repair

Go to 9A

Go to 2B

Guided Step 2B - Check the DEF tank.

Conditions

  • Turn keyswitch OFF.

Action

  • Check the DEF tank for contamination or debris. Refer to Procedure 011-056 in the Associated Procedures Table.
  • Check the DEF tank vent for crystallization, buildup, and clogging.

DEF tank and vent clean and free of debris?
YES NO
No Repair

Flush the DEF system. Refer to Procedure 011-056 in the Associated Procedures Table.

  • Drain the DEF tank. Thoroughly flush with distilled water.
  • Clean and flush the DEF tank head and filter. Replace the DEF tank filter, as necessary.
  • Remove and flush the dosing unit intake and return lines.
  • Make sure the DEF dosing unit intake and fitting and filter are new. Refer to Procedure 011-058 in the Associated Procedures Table.
  • Fill the DEF tank with clean, certified DEF.

Go to 3A

Go to 9A

Guided Step 3 - Check the aftertreatment DEF dosing unit.

Guided Step 3A - Check the aftertreatment DEF dosing unit.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Refer to Procedure 011-121 in the Associated Procedures Table.

Vacuum in diagnostic line greater than -203.2 mm-Hg [-8.0 in-Hg]?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the aftertreatment DEF dosing unit.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Verify dosing unit was making sound or vibration.

DEF unit operating?
YES NO

Remove the dosing unit intake screen and main filter.

Inspect the intake screen and DEF in the main filter well for debris.

If any debris is visible, the system is contaminated with debris and must be flushed. Refer to Procedure 011-056 in the Associated Procedures Table.

  • Drain the DEF tank. Thoroughly flush with distilled water.
  • Clean and flush the DEF tank head and filter. Replace the DEF tank filter, as necessary.
  • Remove and flush the dosing unit intake line.
  • Fill the DEF tank with clean, certified DEF.

Perform the airless flush. Refer to Procedure 011-058 in the Associated Procedures Table.

Run the DEF Dosing Unit Suction Test. Refer to Procedure 011-121 in the Associated Procedures Table.

If vacuum is not greater than -203.2 mm-Hg [-8.0 in-Hg] gauge when tested, replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

If vacuum is greater than -203.2 mm-Hg [-8.0 in-Hg] gauge when tested, the dosing unit should be reused.

  • DEF dosing unit intake screen and main filter are new. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 3C

Guided Step 3C - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor, ECM engine connector, or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 3D

Guided Step 3D - Check for an open return circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

  • Measure the resistance between the aftertreatment DEF dosing unit RETURN pin in the OEM harness ECM connector and the aftertreatment DEF dosing unit RETURN pin in the OEM harness dosing valve connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

A malfunctioning DEF dosing unit has been detected.

Replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 9A

Guided Step 4 - Check the aftertreatment DEF intake system.

Guided Step 4A - Check the DEF dosing unit intake restriction.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Refer to Procedure 011-086 in the Associated Procedures Table.

Restriction less than -150 mm-Hg [-6 in-Hg]?
YES NO
No Repair

Clean or replace the DEF tank filter, DEF tank vent filter, and DEF suction line, as necessary.

Drain the DEF tank. Flush with distilled water. Fill the DEF tank with clean, certified DEF.

See equipment manufacturer service information.

Go to 5A

Go to 9A

Guided Step 5 - Check for air in the aftertreatment DEF.

Guided Step 5A - Check for air in the DEF.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Refer to Procedure 011-075 in the Associated Procedures Table.

Air in the DEF detected?
YES NO

Check the following components for damage/leaks. Repair, as necessary.

  • Aftertreatment DEF dosing unit supply line
  • Aftertreatment DEF tank fittings
  • Aftertreatment DEF tank stand pipe.

Refer to Procedure 011-075 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 6A

Guided Step 6 - Check the aftertreatment DEF pressure sensor.

Guided Step 6A - Inspect the aftertreatment DEF pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Disconnect the aftertreatment DEF dosing valve pressure line (this is the supply line between the dosing unit and dosing valve).
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to monitor the aftertreatment DEF pressure.

Aftertreatment DEF pressure reading in INSITE™ electronic service tool equal to 0 ±69 kPa [0 ±10 psi]?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6B

Guided Step 6B - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor, ECM engine connector, or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 6C

Guided Step 6C - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the aftertreatment 1 DEF dosing unit from the OEM harness.

Action

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor SUPPLY pin in the OEM harness ECM connector and the aftertreatment 1 DEF pressure sensor SUPPLY pin in the OEM harness aftertreatment 1 DEF dosing valve connector.
  • Measure the resistance between the aftertreatment 1 DEF pressure sensor SIGNAL pin in the OEM harness ECM connector and the aftertreatment 1 DEF pressure sensor SIGNAL pin in the OEM harness aftertreatment 1 DEF dosing valve connector.
  • Measure the resistance between the aftertreatment 1 DEF pressure sensor RETURN pin in the OEM harness ECM connector and the aftertreatment 1 DEF pressure sensor RETURN pin in the OEM harness dosing valve connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

A damaged aftertreatment DEF pressure sensor has been detected.

Replace the aftertreatment DEF dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

An open circuit has been detected in the harness.

Repair or replace the damaged section of the harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 7A

Go to 9A

Guided Step 7 - Check the aftertreatment DEF lines and fittings.

Guided Step 7A - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the inlet of the dosing valve and pressure line (this is the supply line between the dosing unit and dosing valve). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Test.
  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 950 kPa [137 psi]?
YES | NO
No Repair | No Repair

Go to 7B

Go to 7A-1

Guided Step 7A-1 - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the outlet of the dosing valve and return line (this is the return line between the dosing valve and tank). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Connect the DEF pressure line to the inlet of the dosing valve.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.

Read the DEF pressure from the service tool gauge.

DEF pressure less than 70 kPa [10 psi]?
YES NO
No Repair

A blocked or restricted return line and/or tank head has been detected. Clean or replace the return line and/or tank head, as necessary.

See equipment manufacturer service information.

Go to 7A-2

Go to 7B

Guided Step 7A-2 - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Install the DEF pressure gauge between the inlet of the dosing valve and pressure line. Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.

Read the DEF pressure from the service tool gauge.

DEF pressure reading ±70 kPa [±10 psi] of gauge reading?
YES NO
No Repair

Replace the inlet screen per Procedure 011-059. Perform this step again.

If still out of specification, replace the dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 7B

Go to 9A

Guided Step 7B - Check for pressure out of the aftertreatment DEF dosing unit.

Conditions

  • Turn keyswitch OFF.
  • Connect the DEF pressure line to the inlet of the dosing valve.
  • Install the DEF pressure gauge between the outlet of the dosing unit and pressure line (this is the supply line between the dosing unit and dosing valve). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 950 kPa [137 psi]?
YES NO
No Repair

A restricted pressure line has been detected. Clean or replace the pressure line, as necessary.

See equipment manufacturer service information.

Go to 7C

Go to 9A

Guided Step 7C - Check for pressure out of the aftertreatment DEF dosing unit.

Conditions

  • Turn keyswitch OFF.
  • Install the DEF pressure gauge between the outlet of the dosing unit and pressure line (this is the supply line between the dosing unit and dosing valve). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 750 kPa [108 psi]?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7D

Guided Step 7D - Check the aftertreatment DEF dosing unit for blockage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve pressure line from the dosing valve (pressure line runs between the dosing unit and dosing valve).
  • Disconnect the aftertreatment DEF dosing valve pressure line from the DEF dosing unit.

Action

  • Inspect the outlet fitting for signs of buildup or blockage.
  • Inspect the dosing unit filter for signs of buildup or blockage.
  • Inspect the inlet fitting screen for signs of buildup or blockage.

DEF dosing unit blocked or restricted?
YES NO

Clean the aftertreatment DEF dosing unit outlet or inlet fitting if needed.

Replace the aftertreatment DEF dosing unit filter if needed. Refer to Procedure 011-060 in the Associated Procedures Table.

A malfunctioning DEF dosing unit has been detected.

Replace the aftertreatment DEF dosing unit. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 9A

Go to 9A

Guided Step 8 - Check the aftertreatment DEF dosing unit operation.

Guided Step 8A - Check the aftertreatment DEF dosing system operation.

Conditions

  • Connect all DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove aftertreatment DEF dosing valve from decomposition chamber.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use the following procedure for instructions and specifications. Refer to Procedure 011-063 in the Associated Procedures Table.

The aftertreatment DEF dosing valve must be removed and placed in a measuring container having greater than a 1.5 liter [50 oz] capacity to run the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Dosing volume within the specifications in Procedure 011-063?
YES NO
No Repair

Refer to Procedure 011-063 in the Associated Procedures Table for repair instructions.

Go to 9A

Go to 9A

Guided Step 9 - Check ECM calibration and clear fault codes.

Guided Step 9A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 9B

Go to 9B

Guided Step 9B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 29-Mar-2017


FAULT CODE 4467 - Aftertreatment 2 Diesel Exhaust Fluid Pressure 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid System Connection Test | Refer to Procedure 011-107 | QSK96 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4467 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3596, 3571, 3572, 5278, 5935, 5936, 5864, or 5865 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1C. Check for crossed connections. | Any crossed system found per Procedure 011-107?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) lines and fittings. |
 | STEP 2A. Check for pressure at the aftertreatment DEF dosing valve. | DEF pressure greater than 70 kPa [10 psi]?
 | STEP 2B. Check for pressure at the aftertreatment DEF tank head. | DEF pressure less than 70 kPa [10 psi]?
 | STEP 2C. Check for pressure at the aftertreatment DEF dosing valve. | DEF pressure reading ±70 kPa [±10 psi] of gauge reading?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4467 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3596, 3571, 3572, 5278, 5935, 5936, 5864, or 5865 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for crossed connections.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to check for cross-connection of components. Refer to Procedure 011-107 in the Associated Procedures Table.
  • Trace the DEF pressure line from the DEF dosing unit. Verify it is connected to the correct DEF dosing valve, by component location, on the aftertreatment.

Any crossed systems found per Procedure 011-107?
YES NO

Correct the crossed systems. Refer to Procedure 011-107 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the aftertreatment DEF lines and fittings.

Guided Step 2A - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the outlet of the dosing valve and return line (this is the return line between the dosing valve and tank). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure greater than 70 kPa [10 psi]?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2B

Guided Step 2B - Check for pressure at the aftertreatment DEF tank head.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the inlet of the tank head and return line (this is the return line between the dosing valve and tank). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 70 kPa [10 psi]?
YES NO

A blocked or restricted return line has been detected.

Clean or replace the return line, as necessary.

See equipment manufacturer service information.

A blocked or restricted tank head has been detected.

Clean or replace the tank head, a necessary.

See equipment manufacturer service information.

Go to 3A

Go to 3A

Guided Step 2C - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Install the DEF pressure gauge between the inlet of the dosing valve and pressure line. Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure reading ±70 kPa [±10 psi] or gauge reading?
YES NO
No Repair

Replace the inlet screen. Refer to Procedure 011-059 in the Associated Procedures Table. Perform this step again.

If still out of specification, replace the dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 22-Mar-2017


FAULT CODE 4468 - Aftertreatment 2 Diesel Exhaust Fluid Pressure 1 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid System Connection Test | Refer to Procedure 011-107 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4468 active?
 | STEP 1B. Check active fault codes. | Fault Code 3571, 3572, 5278, 5935, 5936, 5864, or 5865 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1C. Check for crossed connections. | Any crossed systems found per Procedure 011-107?
STEP 2. | Check the aftertreatment diesel exhaust (DEF) pressure sensor. |
 | STEP 2A. Inspect the aftertreatment DEF pressure sensor. | Aftertreatment DEF pressure reading in INSITE™ electronic service tool equal to 0 ±69 kPa [0 ±10 psi]?
STEP 3. | Check the aftertreatment DEF lines and fittings. |
 | STEP 3A. Check for pressure at the aftertreatment DEF dosing valve. | DEF pressure less than 70 kPa [10 psi]?
 | STEP 3B. Check for pressure at the aftertreatment DEF tank head. | DEF pressure less than 70 kPa [10 psi]?
 | STEP 3C. Check for pressure at the aftertreatment DEF dosing valve. | DEF pressure reading ±70 kPa [±10 psi] of gauge reading?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4468 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Checked for crossed connections.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to check for cross-connection of components. Refer to Procedure 011-107 in the Associated Procedures Table.
  • Trace the DEF pressure line from the DEF dosing unit. Verify it is connected to the correct DEF dosing valve, by component location, on the aftertreatment.

Any crossed systems found per Procedure 011-107?
YES NO

Correct the crossed systems. Refer to Procedure 011-107 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the aftertreatment DEF pressure sensor.

Guided Step 2A - Inspect the aftertreatment DEF pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve supply line.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to monitor the aftertreatment DEF pressure.

Aftertreatment DEF pressure reading in INSITE™ electronic service tool equal to 0 ±69 kPa [0 ±10 psi]?
YES NO
No Repair

A damaged aftertreatment DEF pressure sensor has been detected.

Replace the aftertreatment DEF dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF lines and fittings.

Guided Step 3A - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the outlet of the dosing valve and return line (this is the return line between the dosing valve and tank). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 70 kPa [10 psi]?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B

Guided Step 3B - Check for pressure at the aftertreatment DEF tank head.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the inlet of the tank head and return line (this is the return line between the dosing valve and tank). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 70 kPa [10 psi]?
YES NO

A blocked or restricted return line has been detected.

Clean or replace the return line, as necessary.

See equipment manufacturer service information.

A blocked or restricted tank head has been detected.

Clean or replace the tank head, as necessary.

See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 3C - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Install the DEF pressure gauge between the inlet of the dosing valve and pressure line. Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure reading ±70 kPa [±10 psi] or gauge reading?
YES NO
No Repair

Replace the inlet screen. Refer to Procedure 011-059 in the Associated Procedures Table. Perform this step again.

If still out of specification, replace the dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM Code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 22-Mar-2017


FAULT CODE 4471 - Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit 1 Heater - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Delphi® 96 Way Engine Control Module Connector | Refer to Procedure 019-505 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Heater Relay | Refer to Procedure 019-620 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box Resistor | Refer to Procedure 019-625 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4471 active?
STEP 2. | Check the aftertreatment 2 diesel exhaust fluid (DEF) dosing unit heater relay and resistor. |
 | STEP 2A. Check the aftertreatment 2 DEF dosing unit heater relay. | Aftertreatment 2 DEF dosing unit heater relay within specifications?
 | STEP 2B. Check the aftertreatment 2 DEF dosing unit heater resistor. | Aftertreatment 2 DEF dosing unit heater resistor within specifications?
STEP 3. | Check the aftertreatment 2 harness. |
 | STEP 3A. Inspect the aftertreatment 2 connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for open signal circuit. | Less than 10 ohms?
 | STEP 3C. Check for open return circuit. | Less than 10 ohms?
 | STEP 3D. Check for open return circuit. | Less than 10 ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
STEP 4. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 4A. Inspect the aftertreatment 2 connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open signal circuit. | Less than 10 ohms?
 | STEP 4C. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 4D. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 4E. Check for an open circuit. | Less than 10 ohms?
 | STEP 4F. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4471 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 2 DEF dosing unit heater relay and resistor.

Guided Step 2A - Check the aftertreatment 2 DEF dosing unit heater relay.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment 2 DEF dosing unit heater relay (K2) from the aftertreatment junction box. Refer to Procedure 019-620 in the Associated Procedures Table.

Action

Check the aftertreatment 2 DEF dosing unit heater relay.

  • Test aftertreatment 2 DEF dosing unit heater relay. Refer to Procedure 019-620 in the Associated Procedures Table.
  • Refer to the wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Aftertreatment 2 DEF dosing unit heater relay within specifications?
YES NO
No Repair

Replace the aftertreatment 2 DEF dosing unit heater relay (K2). Refer to Procedure 019-620 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Check the aftertreatment 2 DEF dosing unit heater resistor.

Conditions

  • Turn the keyswitch OFF.
  • Remove the aftertreatment 2 DEF dosing unit heater resistor (R4) from the aftertreatment junction box. Refer to Procedure 019-625 in the Associated Procedures Table.

Action

Check the aftertreatment 2 DEF dosing unit heater resistor.

  • Test aftertreatment 2 DEF dosing unit heater resistor. Refer to Procedure 019-625 in the Associated Procedures Table.
  • Refer to the wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Aftertreatment 2 DEF dosing unit heater resistor within specifications?
YES NO
No Repair

Replace the aftertreatment 2 DEF dosing unit heater resistor (R4). Refer to Procedure 019-625 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the aftertreatment 2 harness.

Guided Step 3A - Inspect the aftertreatment 2 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.

Action

Inspect the connector(s) for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the C1 connector.

Repair the damaged harness, connector, or pins, if possible.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the aftertratment junction box. Refer to Procedure 019-598 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for open signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.

Action

Check for open signal circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit heater SIGNAL pin at the aftertreatment junction box C1 connector and the aftertreatment 2 DEF dosing unit heater relay (K2) terminal 7 and A1.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the aftertreatment junction box.

Troubleshoot all wires connected in series to determine which one contains the open circuit.

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for open return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.

Action

Check for open return circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit heater RETURN pin at the aftertreatment junction box C1 connector and the aftertreatment 2 DEF dosing unit heater resistor (R4) terminal A.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Troubleshoot all wires connected in series to determine which one contains the open circuit.

Repair or replace damaged section of wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check for open return circuit.

Conditions

  • Turn keyswitch OFF.

Action

Turn keyswitch OFF.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit heater resistor (R4) terminal C and the aftertreatment 2 DEF dosing unit heater relay (K2) terminal 7 and A1.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Troubleshoot all wires connected in series to determine which one contains the open circuit.

Repair or replace damaged section of wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3E

Go to 5A

Guided Step 3E - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.
  • Remove the aftertreatment 2 DEF line heater relay resistor (R4) from the aftertreatment junction box. Refer to Procedure 019-625 in the Associated Procedures Table.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit heater SIGNAL pin in the aftertreatment junction box C1 connector and all other pins in the connector.

Use a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in aftertreatment junction box.

Troubleshoot all wire(s) in series to determine which one contains the short circuit.

Repair or replace the damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM and OEM harness.

Guided Step 4A - Inspect the aftertreatment 2 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness at the aftertreatment 2 connector.

Action

Inspect the connector(s) for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.
  • Disconnect the OEM harness at the aftertreatment 2 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit heater SIGNAL pin in the aftertreatment junction box C1 connector and the aftertreatment 2 DEF dosing unit heater SIGNAL pin in the aftertreatment 2 connector.
  • Measure the resistance between the aftertreatment 2 DEF dosing unit heater RETURN pin in the aftertreatment junction box C1 connector and the aftertreatment 2 DEF dosing unit heater RETURN pin in the aftertreatment 2 connector.

Use a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all harness connections in series to determine which one contains open circuit.

Repair or replace damaged section of harness. Refer to Procedure 019-071 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.
  • Disconnect the OEM harness at the aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit heater SIGNAL pin in the aftertreatment 2 connector and all other pins in the connector.

Use a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harness connections in series to determine which one contains the short circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-071 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector (J2) from ECM (2).

Action

Inspect the connector(s) for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-505 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4E

Guided Step 4E - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector (J2) from ECM (2).
  • Disconnect the OEM harness at the aftertreatment 2 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit heater SIGNAL pin in the OEM connector (J2) from ECM (2) and the aftertreatment 2 DEF dosing unit heater SIGNAL pin in the aftertreatment 2 connector.
  • Measure the resistance between the aftertreatment 2 DEF dosing unit heater RETURN pin in the OEM connector (J2) from ECM (2) and the aftertreatment 2 DEF dosing unit heater RETURN pin in the aftertreatment 2 connector.

Use a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all harness connections in series to determine which one contains the open circuit.

If an open circuit is isolated to damaged harness, repair or replace damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4F

Go to 5A

Guided Step 4F - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector (J2) from ECM (2).
  • Disconnect the OEM harness at the aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit heater SIGNAL pin in the OEM connector (J2) from ECM (2) and all other pins in the connector.

Use a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check if an ECM calibration update is available.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters section.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Go to

Repair complete.

Last Modified: 27-Jan-2017


FAULT CODE 4474 - Aftertreatment 2 Diesel Exhaust Fluid Dosing Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4474 active?
STEP 2. | Check the aftertreatment 2 diesel exhaust fluid (DEF) dosing temperature sensor 1 and circuit. |
 | STEP 2A. Inspect the aftertreatment 2 DEF dosing temperature sensor 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 4475 active and Fault Code 4474 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 4474 active?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for an active fault code. | Fault Code 4474 active?
 | STEP 3D. Inspect the ECM harness connector pins in the engine harness. | Dirty or damaged pins?
 | STEP 3E. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3F. Check for an active fault code. | Fault Code 4474 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4474 active?
YES | NO
No Repair | No Repair

Use the following procedure for intermittent or inactive fault codes. Refer to Procedure 019-362 in Section 19.

2A

Guided Step 2 - Check the aftertreatment 2 DEF dosing temperature sensor 1 and circuit.

Guided Step 2A - Inspect the aftertreatment 2 DEF dosing temperature sensor 1 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 1 from the OEM harness.

Action

Inspect the OEM harness and aftertreatment 2 DEF dosing valve 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 1 from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Use the circuit diagram or wiring diagram for connector pin identification.

Fault Code 4475 active and Fault Code 4474 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 2 DEF dosing valve 1 to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4474 active?
YES NO

A damaged temperature sensor has been detected in the aftertreatment 2 DEF dosing valve 1.

Replace the aftertreatment 2 DEF dosing valve 1.

Refer to Procedure 011-059 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 1 from the OEM harness.

Action

Check for a pin-to-pin short circuit in the harness.

  • Measure the resistance between the aftertreatment 2 DEF dosing temperature sensor 1 SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4474 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Inspect the ECM harness connector pins in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3E

Guided Step 3E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit in the harness.

  • Measure the resistance between the aftertreatment 2 DEF dosing temperature sensor 1 SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4474 active?
YES NO

None. The removal and installation of the connector corrected the fault.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 05-Apr-2016


FAULT CODE 4475 - Aftertreatment 2 Diesel Exhaust Fluid Dosing Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4475 active?
STEP 2. | Check the aftertreatment 2 diesel exhaust fluid (DEF) dosing temperature sensor 1 and circuit. |
 | STEP 2A. Inspect the aftertreatment 2 DEF dosing temperature sensor 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 4474 active and Fault Code 4475 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 4475 active?
STEP 3. | Check the original equipment manufacturer (OEM) and engine control module (ECM) harness. |
 | STEP 3A. Inspect the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ECM power supply ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3E. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3F. Check for an active fault code. | Fault Code 4475 active?
 | STEP 3G. Inspect the ECM harness connector pins. | Dirty or damaged pins?
 | STEP 3H. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3I. Check for a pin-to-ECM power supply ground short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3J. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3K. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3L. Check for an active fault code. | Fault Code 4475 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4475 active?
YES | NO
No Repair | No Repair

Use the following procedure for intermittent or inactive fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment 2 DEF dosing temperature sensor 1 and circuit.

Guided Step 2A - Inspect the aftertreatment 2 DEF dosing temperature sensor 1 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 1 from the OEM harness.

Action

Inspect the OEM harness and aftertreatment 2 DEF dosing valve 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing valve or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 1 from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Place a jumper wire between the aftertreatment 2 DEF dosing valve 1 5V SUPPLY pin and the aftertreatment 2 DEF dosing temperature 1 SIGNAL pin at the aftertreatment 2 DEF dosing valve connector of the OEM harness.

Use the circuit diagram or wiring diagram for connector pin identification.

  • Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4474 active and Fault Code 4475 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 2 DEF dosing valve 1 to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4475 active?
YES NO

A damaged sensor has been detected in the aftertreatment 2 DEF dosing valve 1. Replace the aftertreatment 2 DEF dosing valve 1. Refer to Procedure 011-059 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

4A

Guided Step 3 - Check the OEM and ECM harness.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 1 from the OEM harness

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing temperature sensor 1 SIGNAL pin in the OEM harness aftertreatment 2 connect and all other pins in the OEM harness aftertreatment 1 connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ECM power supply ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 1 from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing temperature sensor 1 SIGNAL pin in the OEM harness aftertreatment 2 connector and ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2.
  • Disconnect the aftertreatment 2 DEF dosing valve 1 from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness aftertreatment 2 connector DEF dosing temperature sensor 1 RETURN pin and the OEM harness aftertreatment 2 connector DEF dosing valve 1 connector DEF dosing temperature sensor RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 1 from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness aftertreatment 2 connector DEF dosing temperature sensor 1 SIGNAL pin and the OEM harness aftertreatment 2 connector DEF dosing valve 1 connector DEF dosing temperature sensor SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4475 active?
YES NO

None. The removal and installation of the connector corrected the fault.

 No Repair

Go to 4A

Go to 4A

Guided Step 3G - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the ECM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3H

Guided Step 3H - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing temperature sensor 1 SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3I

Go to 4A

Guided Step 3I - Check for a pin-to-ECM power supply ground short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing temperature sensor 1 SIGNAL pin in the OEM harness ECM connector and ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit on the SIGNAL wire has been detected in the harness.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3J

Go to 4A

Guided Step 3J - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment 2 DEF dosing temperature sensor 1 RETURN pin and the OEM harness aftertreatment 2 connector DEF dosing valve 1 DEF dosing temperature sensor RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3K

Go to 4A

Guided Step 3K - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment 2 DEF dosing temperature sensor 1 SIGNAL pin and the OEM harness aftertreatment 2 connector DEF dosing valve 1 DEF dosing temperature sensor SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3L

Go to 4A

Guided Step 3L - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4475 active?
YES NO

None. The removal and installation of the connector corrected the fault.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 04-Apr-2016


FAULT CODE 4481 - Turbocharger 3 Speed - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Cannon™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Cannon™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for barometric pressure or intake manifold pressure sensor faults. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 122, 123, 221, or 222 active?
STEP 2. | Check for a malfunctioning turbocharger speed sensor. |
 | STEP 2A. Inspect the engine harness connector to the turbocharger speed sensor. | Dirty or damaged pins?
 | STEP 2B. Measure the turbocharger speed sensor resistance. | Resistance between 600 and 1600 ohms?
 | STEP 2C. Check for a short circuit to ground in the turbocharger speed sensor. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the turbocharger speed sensor circuit continuity. | Continuity within 10 ohms of the sensor resistance?
 | STEP 3C. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check the ECM calibration and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disabel the fault code. | Fault code active?

Guided Step 1 - Check for barometric pressure or intake manifold pressure sensor faults.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Read the fault codes with INSITE™ electronic service tool.

Fault Code 122, 123, 221, or 222 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check for a malfunction in the turbocharger speed sensor.

Guided Step 2A - Inspect the engine harness connector to the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Inspect the turbocharger speed sensor connector, the engine harness connector, and the turbocharger speed sensor pigtail harness for signs of the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the turbocharger speed sensor connector or speed sensor.

Repair or replace the damaged connector or turbocharger speed sensor. Refer to Procedure 019-390 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Measure the turbocharger speed sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Measure the resistance.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin to the turbocharger speed SIGNAL (-) pin at the sensor.

Refer to the wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 600 and 1600 ohms?
YES NO
No Repair

The turbocharger speed sensor has malfunctioned.

Replace the turbocharger speed sensor. Refer to Procedure 019-390 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ECM power supply ECM power supply ground in the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Check for a short circuit to ECM power supply ground.

  • Refer to Procedure 019-610 in the Associated Procedures Table.
  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the sensor to ECM power supply ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

The turbocharger speed sensor is shorted to ECM power supply ground.

Replace the turbocharger speed sensor. Refer to Procedure 019-390 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness ECM connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the turbocharger speed sensor circuit continuity.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check the sensor continuity.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to the turbocharger speed SIGNAL (-) pin of the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

The resistance of the turbocharger speed sensor circuit resistance should be no more than 10 ohms greater than the resistance of the turbocharger speed sensor. The turbocharger speed sensor resistance value was read in Step 2B.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Continuity within 10 ohms of sensor resistance?
YES NO
No Repair

There is high resistance or an open circuit in the engine harness or turbocharger speed sensor connector.

Repair or replace the engine harness or connector(s). Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ECM power supply ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a short to ECM power supply ground.

  • Refer to Procedure 019-610 in the Associated Procedures Table.
  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to ECM power supply ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a short to ECM power supply ground in the turbocharger speed sensor circuit. Inspect the engine harness for a short to ground.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to all other pins in the connector except the turbocharger speed SIGNAL (-) pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

The turbocharger speed sensor has malfunctioned.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Replace the turbocharger speed sensor. Refer to Procedure 019-030 in the Associated Procedures Table.

A short has been detected in the engine harness.

Inspect the engine harness for a short between two pins.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 4482 - Turbocharger 4 Speed - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Cannon™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Cannon™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for barometric pressure or intake manifold pressure sensor faults. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 122, 123, 221, or 222 active?
STEP 2. | Check for a malfunctioning turbocharger speed sensor. |
 | STEP 2A. Inspect the engine harness connector to the turbocharger speed sensor. | Dirty or damaged pins?
 | STEP 2B. Measure the turbocharger speed sensor resistance. | Resistance between 600 and 1600 ohms?
 | STEP 2C. Check for a short circuit to ground in the turbocharger speed sensor. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the turbocharger speed sensor circuit continuity. | Continuity within 10 ohms of the sensor resistance?
 | STEP 3C. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check the ECM calibration and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disabel the fault code. | Fault code active?

Guided Step 1 - Check for barometric pressure or intake manifold pressure sensor faults.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Read the fault codes with INSITE™ electronic service tool.

Fault Code 122, 123, 221, or 222 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check for a malfunction in the turbocharger speed sensor.

Guided Step 2A - Inspect the engine harness connector to the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Inspect the turbocharger speed sensor connector, the engine harness connector, and the turbocharger speed sensor pigtail harness for signs of the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the turbocharger speed sensor connector or speed sensor.

Repair or replace the damaged connector or turbocharger speed sensor. Refer to Procedure 019-390 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Measure the turbocharger speed sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Measure the resistance.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin to the turbocharger speed SIGNAL (-) pin at the sensor.

Refer to the wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 600 and 1600 ohms?
YES NO
No Repair

The turbocharger speed sensor has malfunctioned.

Replace the turbocharger speed sensor. Refer to Procedure 019-390 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ECM power supply ground in the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Check for a short circuit to ECM power supply ground.

  • Refer to Procedure 019-610 in the Associated Procedures Table.
  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the sensor to ECM power supply ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

The turbocharger speed sensor is shorted to ECM power supply ground.

Replace the turbocharger speed sensor. Refer to Procedure 019-390 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness ECM connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the turbocharger speed sensor circuit continuity.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check the sensor continuity.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to the turbocharger speed SIGNAL (-) pin of the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

The resistance of the turbocharger speed sensor circuit resistance should be no more than 10 ohms greater than the resistance of the turbocharger speed sensor. The turbocharger speed sensor resistance value was read in Step 2B.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Continuity within 10 ohms of sensor resistance?
YES NO
No Repair

There is high resistance or an open circuit in the engine harness or turbocharger speed sensor connector.

Repair or replace the engine harness or connector(s). Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ECM power supply ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a short to ECM power supply ground.

  • Refer to Procedure 019-610 in the Associates Procedure Table.
  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to ECM power supply ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a short to ECM power supply ground in the turbocharger speed sensor circuit. Inspect the engine harness for a short to ground.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to all other pins in the connector except the turbocharger speed SIGNAL (-) pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

The turbocharger speed sensor has malfunctioned.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Replace the turbocharger speed sensor. Refer to Procedure 019-030 in the Associated Procedures Table.

A short has been detected in the engine harness.

Inspect the engine harness for a short between two pins.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 13-Apr-2016


FAULT CODE 4528 - Aftertreatment 2 Intake NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4528 active?
 | STEP 1B. Check for active engine control module (ECM) power supply voltage fault codes. | Fault Code 441 or 442 active?
STEP 2. | Check the aftertreatment 2 intake NOx sensor circuit. |
 | STEP 2A. Inspect aftertreatment 2 intake NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment 2 intake NOx sensor. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 2C. Check for correct adjustable parameter settings. | Electrical System Voltage parameter correct for the engine configuration?
 | STEP 2D. Check for correct aftertreatment 2 intake NOx sensor. | Aftertreatment 2 intake NOx sensor the correct sensor for the engine configuration?
 | STEP 2E. Check the condition of the aftertreatment 2 intake NOx sensor. | Fault Code 4528 active?
STEP 3. | Check the harness. |
 | STEP 3A. Check the voltage to the aftertreatment 2 intake NOx sensor. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3B. Inspect aftertreatment power relay and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the voltage to the aftertreatment power relay. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3D. Check the aftertreatment power relay. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4528 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active battery voltage fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate engine. Let it idle for one minute.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 or 442 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment 2 intake NOx sensor circuit.

Guided Step 2A - Inspect aftertreatment 2 intake NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 intake NOx sensor from the engine harness.

Action

Inspect the engine harness and aftertreatment 2 intake NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Use the following procedure for NOx sensor connector repair or replacement. Refer to Procedure 019-463 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment 2 intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 intake NOx sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment 2 intake NOx sensor.

  • Measure the voltage between the aftertreatment 2 intake NOx sensor ECM power supply voltage supply circuit and the aftertreatment 2 intake NOx sensor ECM power supply voltage return circuit at the NOx sensor wiring harness connector.

Check the voltage at keyswitch ON while cranking the engine and with the engine at idle.

Use the wiring diagram for connector pin identification.

Use the general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage within 1 VDC of ECM power supply voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine configuration.

Electrical System Voltage parameter correct for the engine configuration?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine configuration.

Go to 2D

Go to 4A

Guided Step 2D - Check for correct aftertreatment 2 intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove aftertreatment 2 intake NOx sensor.

Action

Verify aftertreatment 2 intake NOx sensor is the correct sensor for the engine configuration.

The aftertreatment 2 intake NOx sensor is available in 12 volt or 24 volt versions.

Aftertreatment 2 intake NOx sensor the correct sensor for the engine configuration?
YES NO
No Repair

Replace the aftertreatment 2 intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Check the condition of the aftertreatment 2 intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Connect aftertreatment 2 intake NOx sensor.
  • Operate engine. Let it idle.
  • Operate the engine until the exhaust gas temperature 2 sensor temperature is above 150°C [302°F].

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

The exhaust gas temperature at the aftertreatment 2 intake NOx sensor must be above 150°C [302°F] before the sensor can run its internal diagnostics.

Fault Code 4528 active?
YES NO

Replace the aftertreatment 2 intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the harness.

Guided Step 3A - Check the voltage to the aftertreatment 2 intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 intake NOx sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment 2 intake NOx sensor.

  • Measure the voltage from the aftertreatment 2 intake NOx sensor ECM power supply voltage SUPPLY pin of the engine harness intake NOx sensor connector to the engine block ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Voltage within 1 VDC of ECM power supply voltage?
YES NO

An open circuit has been detected in the aftertreatment 2 intake NOx sensor ECM power supply voltage return circuit.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of engine harness.Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Inspect aftertreatment power relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the harness.

Action

Inspect the harness and aftertreatment smart sensor relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the relay or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the voltage to the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment power relay.

  • Measure the voltage between the aftertreatment power relay ECM power supply voltage SUPPLY pin in the aftertreatment power relay connector of the engine harness and engine block ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Voltage within 1 VDC of ECM power supply voltage?
YES NO
No Repair

An open circuit has been detected in the aftertreatment power ECM power supply voltage supply circuit before the power relay.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of harness.

  • For engine harness repair, use the following procedure. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the harness.

Action

Check for a damaged aftertreatment power relay.

  • Install a jumper wire from pin 85 on the aftertreatment power relay to ECM power supply (+). Connect a jumper wire from pin 86 on the aftertreatment power relay to ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.
  • Measure the resistance between pin 30 and pin 87 on the aftertreatment power relay.

Use the wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

An open circuit or short circuit to ECM power supply ground has been detected in the aftertreatment 2 intake NOx sensor power supply circuit.

This could be cause by:

  • Blown in-line fuse on the intake NOx sensor power supply circuit.
  • Open circuit or short to ECM power supply ground in the intake NOx sensor power supply circuit.

Replace the inline fuse if needed.

Troubleshoot all harnesses connected in series to determine which one contains the open or shorted circuit.

Repair or replace the damaged section of engine harness.

Replace the aftertreatment power relay.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 04-Apr-2016


FAULT CODE 4529 - Aftertreatment 2 Outlet NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4529 active?
 | STEP 1B. Check for active batter voltage fault codes. | Fault Code 441 or 442 active?
STEP 2. | Check the aftertreatment outlet sensor circuit. |
 | STEP 2A. Inspect aftertreatment outlet NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment outlet NOx sensor. | Voltage within 1 VDC of engine control module (ECM) power supply voltage?
 | STEP 2C. Check for correct adjustable parameter settings. | Electrical System Voltage parameter correct for the engine configuration?
 | STEP 2D. Check for correct aftertreatment outlet NOx sensor. | Aftertreatment outlet NOx sensor the correct sensor for the engine configuration?
 | STEP 2E. Check the condition of the aftertreatment outlet NOx sensor. | Fault Code 3681 active?
STEP 3. | Check the harness. |
 | STEP 3A. Check the voltage to the aftertreatment outlet NOx sensor. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3B. Inspect aftertreatment power relay and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the voltage to the aftertreatment power relay. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3D. Check the aftertreatment power relay. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4529 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for batter voltage fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 or 442 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment outlet sensor circuit.

Guided Step 2A - Inspect aftertreatment outlet NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the original equipment manufacturer (OEM) harness.

Action

Inspect the OEM harness and aftertreatment outlet NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment outlet NOx sensor.

  • Measure the voltage between the aftertreatment outlet NOx sensor ECM power supply voltage supply circuit and the aftertreatment outlet NOx sensor ECM power supply voltage return circuit at the NOx sensor wiring harness connector.

Check the voltage at keyswitch ON while cranking the engine and with the engine at idle.

Use the wiring diagram for connector pin identification.

Use the general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage within 1 VDC of ECM power supply voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine configuration.

To check the voltage configuration of the engine, disconnect the OEM connector from the ECM and measure the voltage from the ECM battery SUPPLY (+) pin of the OEM harness ECM connector to ECM power supply ground circuit.

  • Refer to Procedure 019-610 in the Associated Procedures Table.

Electrical System Voltage parameter correct for the engine configuration?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine configuration.

Go to 2D

Go to 4A

Guided Step 2D - Check for correct aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove aftertreatment outlet NOx sensor.

Action

Verify aftertreatment outlet NOx sensor is the correct sensor for the engine configuration.

The aftertreatment outlet NOx sensor is available in 12 volt or 24 volt versions.

Aftertreatment outlet NOx sensor the correct sensor for the engine configuration?
YES NO
No Repair

Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Check the condition of the aftertreatment 2 outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment outlet NOx sensor.
  • Start and idle the engine.
  • Operate the engine until the aftertreatment selective catalytic reduction (SCR) catalyst outlet temperature is above 150°C [302°F].

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

The exhaust gas temperature at the aftertreatment outlet NOx sensor must be above 150°C [302°F] before the sensor can run its internal diagnostics.

Fault Code 3681 active?
YES NO

Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the harness.

Guided Step 3A - Check the voltage to the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment outlet NOx sensor.

  • Measure the voltage from the aftertreatment outlet NOx sensor ECM power supply voltage SUPPLY pin of the OEM harness outlet NOx sensor connector to the engine block ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Voltage within 1 VDC of ECM power supply voltage?
YES NO

An open circuit has been detected in the aftertreatment outlet NOx sensor ECM power supply voltage return circuit.

Troubleshoot all harnesses connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Inspect aftertreatment power relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the harness.

Action

Inspect the harness and aftertreatment power relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the relay or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the voltage to the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment power relay.

  • Measure the voltage between the aftertreatment power relay ECM power supply voltage SUPPLY pin in the aftertreatment power relay connector of the engine harness and engine block ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Voltage within 1 VDC of ECM power supply voltage?
YES NO
No Repair

An open circuit has been detected in the aftertreatment power ECM power supply voltage supply circuit before the power relay.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table. if equipped if an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Go to 3D

Go to 4A

Guided Step 3D - Check the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the harness.

Action

Check for a damaged aftertreatment power relay.

  • Install a jumper wire from pin 85 on the aftertreatment power relay to ECM power supply (+). Connect a jumper wire from pin 86 on the aftertreatment power relay to chassis ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.
  • Measure the resistance between pin 30 and pin 87 on the aftertreatment power relay.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

An open circuit or short circuit has been detected in the aftertreatment outlet NOx sensor power supply circuit.

This could be cause by:

  • Blown in-line fuse on the outlet NOx sensor power supply circuit.
  • Open circuit or short to ECM power supply ground in the outlet NOx sensor power supply circuit.

Replace the in-line fuse if it is blown.

Troubleshoot all harnesses connected in series to determine which one contains the open or shorted circuit. Refer to Procedure 019-598 in the Associated Procedures Table. if equipped with an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Replace the aftertreatment power relay.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 04-Apr-2016


FAULT CODE 4531 - Aftertreatment 2 Outlet NOx Sensor Heater - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Aftertreatment Sensor Power Relay | Refer to Procedure 019-607 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4531 active?
 | STEP 1B. Check for other active outlet NOx sensor fault codes. | Active or inactive counts of Fault Code 1887, 2771, or 3681?
 | STEP 1C. Check for active selective catalytic reduction (SCR) temperature sensor fault codes. | Fault Code 3144 or 3148 active?
STEP 2. | Check the aftertreatment 2 outlet NOx sensor circuit. |
 | STEP 2A. Inspect the aftertreatment 2 outlet NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment 2 outlet NOx sensor. | Voltage within 1 VDC of engine control module (ECM) power supply voltage?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the voltage to the aftertreatment 2 outlet NOx sensor. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3B. Inspect aftertreatment 2 power relay and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the voltage to the aftertreatment 2 power relay. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3D. Check the aftertreatment 2 power relay. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4531 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for other active outlet NOx sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1887, 2771, or 3681?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1C

Guided Step 1C - Check for active SCR temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3144 or 3148 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment 2 outlet NOx sensor circuit.

Guided Step 2A - Inspect the aftertreatment 2 outlet NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 outlet NOx sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment 2 outlet NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Replace the aftertreatment intake NOx sensor only when there are damaged pins. Refer to Procedure 019-451 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment 2 outlet NOx sensor.

Conditions

  • Disconnect the sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment 2 outlet NOx sensor.

  • Measure the voltage between the aftertreatment 2 outlet NOx sensor ECM power supply voltage supply circuit and the aftertreatment 2 outlet NOx sensor ECM power supply voltage return circuit at the NOx sensor wiring harness connector.

Use the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of ECM power supply voltage?
YES NO

A damaged aftertreatment 2 outlet NOx sensor heater has been detected.

Replace the aftertreatment 2 outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the voltage to the aftertreatment 2 outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment 2 outlet NOx sensor.

  • Measure the voltage from the aftertreatment 2 outlet NOx sensor ECM power supply voltage SUPPLY pin of the OEM harness outlet NOx sensor connector to the ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of ECM power supply voltage?
YES NO

An open circuit has been detected in the aftertreatment 2 outlet NOx sensor ECM power supply voltage return circuit.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For OEM harness repair use the following procedure. Refer to Procedure 019-071 in Section 19.
  • For engine harness repair use the following procedure. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Inspect aftertreatment 2 power relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 power relay from the harness.

Action

Inspect the harness and aftertreatment 2 power relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the relay or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the aftertreatment power relay only when there are damaged pins. Refer to Procedure 019-607 in the Associated Procedure Table.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the voltage to the aftertreatment 2 power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 power relay from the harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment 2 power relay.

  • Measure the voltage between the aftertreatment 2 power relay ECM power supply voltage SUPPLY pin in the aftertreatment 2 power relay connector of the engine harness and ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Voltage within 1 VDC of ECM power supply voltage?
YES NO
No Repair

An open circuit has been detected in the aftertreatment 2 power ECM power supply voltage supply circuit before the power relay.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of harness.

  • For OEM harness repair use the following procedure. Refer to Procedure 019-071 in Section 19.
  • For engine harness repair use the following procedure. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check the aftertreatment 2 power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 power relay from the harness.

Action

Check for a damaged aftertreatment 2 power relay.

  • Install a jumper wire from pin 85 on the aftertreatment 2 power relay to ECM power supply (+). Connect a jumper wire from pin 86 on the aftertreatment 2 power relay to ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.
  • Measure the resistance between pin 30 and pin 87 on the aftertreatment 2 power relay.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

An open circuit or short circuit has been detected in the aftertreatment 2 outlet NOx sensor power supply circuit.

This could be caused by:

  • Blown inline fuse on the outlet NOx sensor power supply circuit
  • Open circuit or short to ground in the outlet NOx sensor power supply circuit.

Replace the inline fuse if it is blown.

Troubleshoot all harnesses connected in series to determine which one contains the open or shorted circuit.

Repair or replace the damaged section of harness.

  • For OEM harness repair use the following procedure. Refer to Procedure 019-071 in Section 19.
  • For engine harness repair use the following procedure. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the aftertreatment 2 power relay.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 04-Apr-2016


FAULT CODE 4572 - Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Electrical Connector Replacement | Refer to Procedure 019-559 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes | Fault Code 4572 active?
 | STEP 1B. Check for active fault codes. | Fault Code 4437 active?
 | STEP 1C. Check for active fault codes. | Fault Codes 2771, 3232, and 4152 all active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) tank temperature sensor circuit. |
 | STEP 2A. Inspect the aftertreatment DEF tank temperature sensor and connector pins. | Damaged or dirty pins?
 | STEP 2B. Check the voltage to the aftertreatment DEF tank temperature sensor. | Voltage within 1 VDC of engine control module (ECM) power supply voltage?
 | STEP 2C. Check the J1939 terminating resistance. | 50 to 70 ohms?
 | STEP 2D. Check for an open circuit in the aftertreatment DEF tank temperature sensor ECM power supply voltage supply. | Voltage within 1 VDC of ECM power supply voltage?
STEP 3. | Check the harness. |
 | STEP 3A. Inspect the aftertreatment DEF tank temperature sensor and connector pins | Dirty or damaged pins?
 | STEP 3B. Check the voltage to the aftertreatment DEF tank temperature sensor. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3C. Check the voltage to the aftertreatment DEF tank temperature sensor. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3D. Inspect aftertreatment power relay and connector pins. | Dirty or damaged pins?
 | STEP 3E. Check the voltage to the aftertreatment power relay. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3F. Check the aftertreatment power relay. | Less than 10 ohms?
STEP 4. | Check the J1939 data link 4. |
 | STEP 4A. Inspect the ECM and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the J1939 data link harness. | Less than 10 ohms?
 | STEP 4C. Check the J1939 terminating resistance. | 110 to 130 ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4572 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4437 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2771, 3232, and 4152 all active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the aftertreatment DEF tank temperature sensor circuit.

Guided Step 2A - Inspect the aftertreatment DEF tank temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DEF tank temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged OEM harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

Use the following procedure for DEF tank level/temperature sensor connector repair or replacement. Refer to Procedure 019-559 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment DEF tank temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment DEF tank temperature sensor.

  • Measure the voltage between the aftertreatment DEF tank temperature sensor ECM power supply voltage supply circuit and the aftertreatment DEF tank temperature sensor return circuit at the DEF tank temperature sensor wiring harness connector.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage within 1 VDC of ECM power supply voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2D

Guided Step 2C - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power supply.

Action

Measure the terminating resistance of the Society of Automotive Engineers (SAE) J1939 data link.

Use the circuit diagram or wiring diagram for connector pin identification.

50 to 70 ohms?
YES NO

Replace the aftertreatment DEF tank temperature sensor.

See equipment manufacturer service information.

An open circuit has been detected on the SAE J1939 data link (+) or (-) wire between the DEF tank temperature sensor and the data link backbone connection.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 5A

Guided Step 2D - Check for an open circuit in the aftertreatment DEF tank temperature sensor ECM power supply voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure the voltage from the aftertreatment DEF tank temperature sensor ECM power supply voltage SUPPLY pin of the OEM harness to ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Voltage within 1 VDC of ECM power supply voltage?
YES NO

An open circuit has been detected in the aftertreatment DEF tank temperature sensor ECM power supply voltage return circuit.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the damaged section of harness. Refer to Procedure 019-071 in Section 19.

An open circuit has been detected in the aftertreatment DEF tank temperature sensor ECM power supply voltage supply circuit between the aftertreatment power relay and the DEF tank temperature sensor.

Check for a blown or missing fuse in the aftertreatment DEF tank temperature sensor ECM power supply voltage supply circuit. Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 5A

Guided Step 3 - Check the harness.

Guided Step 3A - Inspect the aftertreatment DEF tank temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DEF tank temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged OEM harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

Use the following procedure for DEF tank level sensor connector repair or replacement. Refer to Procedure 019-559 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the voltage to the aftertreatment DEF tank temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment DEF tank temperature sensor.

  • Measure the voltage between the aftertreatment DEF tank temperature sensor ECM power supply voltage supply circuit and the aftertreatment DEF tank temperature sensor return circuit at the wiring harness sensor connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of ECM power supply voltage?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the voltage to the aftertreatment DEF tank temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment DEF tank temperature sensor.

  • Measure the voltage from the aftertreatment DEF tank temperature sensor ECM power supply voltage SUPPLY pin of the OEM harness DEF tank temperature sensor connector to ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Voltage within 1 VDC of ECM power supply voltage?
YES NO

An open circuit has been detected in the aftertreatment DEF tank temperature sensor ECM power supply voltage return circuit.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the damaged section of harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3D

Guided Step 3D - Inspect aftertreatment power relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the harness.

Action

Inspect the harness and aftertreatment power relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the relay or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3E

Guided Step 3E - Check the voltage to the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment power relay.

  • Measure the voltage between the aftertreatment power relay ECM power supply voltage SUPPLY pin in the aftertreatment power relay connector of the engine harness and ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Voltage is within 1 VDC of ECM power supply voltage?
YES NO
No Repair

An open circuit has been detected in the aftertreatment power ECM power supply voltage supply circuit before the power relay.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 5A

Guided Step 3F - Check the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.

Action

Check for a damaged aftertreatment power relay.

  • Install a jumper wire from pin 85 on the aftertreatment power relay to battery (+). Connect a jumper wire from pin 86 on the aftertreatment power relay to ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.
  • Measure the resistance between pin 30 and pin 87 on the aftertreatment power relay.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

An open circuit or short circuit to ground has been detected in the aftertreatment DEF tank temperature sensor power supply circuit.

This could be caused by:

  • Blown inline fuse on the DEF tank temperature sensor power supply circuit
  • Open circuit or short to ground in the DEF tank temperature sensor power supply circuit.

Replace the inline fuse if it is blown.

Troubleshoot all harnesses connected in series to determine which one contains the open or shorted circuit.

Refer to Procedure 019-598 in the Associated Procedure Table if equipped with an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness. Refer to Procedure 019-071 in Section 19.

Replace the aftertreatment power relay.

Go to 5A

Go to 5A

Guided Step 4 - Check the J1939 data link 4.

Guided Step 4A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only when there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the aftertreatment 1 connector.
  • Disconnect the OEM connector from the ECM.

Action

Check for an open circuit in the J1939 data link harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the J1939 data link 4.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the aftertreatment 1 connector.

Action

Measure the terminating resistance of the SAE J1939 data link 4.

110 to 130 ohms?
YES NO
No Repair

Incorrect terminating resistance or an open circuit has been detected on the SAE J1939 data link 4 circuit in the engine harness.

Remove excess terminating resistors. Replace any damaged or missing terminating resistor.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 04-Apr-2016


FAULT CODE 4585 - Aftertreatment 1 SCR Catalyst System - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Active or inactive counts of Fault Code 4152?
 | STEP 1B. Check for active fault codes. | Fault Code 4585 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 4152?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 4152.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4585 active?
YES NO

This fault code indicates the incorrect aftertreatment SCR system has been installed with the engine.

Verify the correct aftertreatment temperature sensor module and aftertreatment SCR system has been installed with the engine.

If the incorrect aftertreatment SCR system has been installed, replace it with the correct aftertreatment SCR system. Refer to Procedure 011-036 in the Associated Procedures Table.

 No Repair

Repair complete.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Go to

Repair complete.

Last Modified: 27-Jan-2017


FAULT CODE 4587 - Aftertreatment 1 Diesel Exhaust Fluid Dosing 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid System Leak Test | Refer to Procedure 011-080 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active diesel exhaust fluid (DEF) dosing system fault codes. | Fault Code 4244 active?
STEP 2. | Check the DEF dosing system. |
 | STEP 2A. Inspect the aftertreatment 1 DEF dosing valve 1 and connectors. | Damage to the DEF dosing valve or DEF line connectors detected?
 | STEP 2B. Inspect the aftertreatment 1 DEF dosing valve 1 for leaks. | DEF leaking from the aftertreatment 1 DEF dosing valve 1 during the system leak test?
 | STEP 2C. Check the aftertreatment 1 DEF dosing valve 1 for proper operation. | Aftertreatment 1 DEF dosing valve 1 operates according to the specifications in Procedure 011-063?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active DEF dosing system fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4244 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the DEF dosing system.

Guided Step 2A - Inspect the aftertreatment 1 DEF dosing valve 1 and connectors.

Conditions

  • Turn keyswitch ON.

Action

Check the aftertreatment 1 DEF dosing valve 1, DEF line, and connectors at the dosing valve for the following:

  • Loose or leaking connections
  • Damage from overheating or melted connectors.

Damage to the DEF dosing valve or DEF line connector detected?
YES NO

Replace any damaged components.

  • Replace the aftertreatment 1 DEF dosing valve1 . Refer to Procedure 011-059 in the Associated Procedures Table.
  • Replace the aftertreatment 1 DEF line(s). See equipment manufacturer service information.

 No Repair

Go to 2B

Go to 2B

Guided Step 2B - Inspect the aftertreatment 1 DEF dosing valve 1 for leaks.

Conditions

  • Connect all DEF lines and electrical connectors.
  • Remove the aftertreatment 1 DEF dosing valve 1 from the decomposition reactor tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the aftertreatment 1 DEF dosing valve 1 for proper operation.

  • Use INSITE™ electronic service tool to perform the DEF System Leak Test found under ECM Diagnostic Tests. Refer to Procedure 011-080 in the Associated Procedures Table.

The DEF dosing valve must be removed and placed in a measuring container in order to leak check the DEF valve.

DEF leaking from the aftertreatment 1 DEF dosing valve 1 during the system leak test?
YES NO

A leaking aftertreatment DEF 1 dosing valve 1 has been detected. Replace the aftertreatment 1 DEF dosing valve 1. Refer to Procedure 011-059 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the aftertreatment 1 DEF dosing valve 1 for proper operation.

Conditions

  • Make sure all DEF lines and electrical connectors are connected appropriately.
  • Remove the aftertreatment 1 DEF dosing valve 1 from the decomposition reactor tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the DEF Doser Pump Override Test found under ECM Diagnostic Tests.

  • Refer to Procedure 011-063 in the Associated Procedures Table.

The DEF dosing valve must be removed and placed in a measuring container in order to perform the DEF Doser Pump Override Test. Make sure the DEF dosing valve is not plugged and the DEF spray pattern is correct.

Aftertreatment 1 DEF dosing valve 1 operates according to the specifications in Procedure 011-063?
YES NO
No Repair

Replace the aftertreatment 1 DEF dosing valve 1.

Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 04-Apr-2016


FAULT CODE 4588 - Aftertreatment 2 Diesel Exhaust Fluid Dosing 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid System Leak Test | Refer to Procedure 011-080 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active diesel exhaust fluid (DEF) dosing system fault codes. | Fault Code 4476 active?
STEP 2. | Check the DEF dosing system. |
 | STEP 2A. Inspect the aftertreatment 2 DEF dosing valve 1 and connectors. | Damage to the DEF dosing valve or DEF line connector detected?
 | STEP 2B. Inspect the aftertreatment 2 DEF dosing valve 1 for leaks. | DEF leaking from the aftertreatment 2 DEF dosing valve 1 during the system leak test?
 | STEP 2C. Check the aftertreatment 2 DEF dosing valve 1 for proper operation. | Aftertreatment 2 DEF dosing valve 1 operates according to specifications in Procedure 011-063?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active DEF dosing system fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4476 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the DEF dosing system.

Guided Step 2A - Inspect the aftertreatment 2 DEF dosing valve 1 and connectors.

Conditions

  • Turn keyswitch ON.

Action

Inspect the aftertreatment 2 DEF dosing valve 1, DEF line, and connectors at the dosing valve for the following:

  • Loose or leaking connections
  • Damage from overheating or melted connectors.

Damage to the DEF dosing valve or DEF line connector detected?
YES NO

Replace any damaged components.

  • Replace the aftertreatment 2 DEF dosing valve 1. Refer to Procedure 011-059 in the Associated Procedures Table.
  • Replace the aftertreatment 2 DEF line(s). See equipment manufacturer service information.

 No Repair

Go to 2B

Go to 2B

Guided Step 2B - Check the aftertreatment 2 DEF dosing valve 1 for leaks.

Conditions

  • Connect all DEF lines and electrical connectors.
  • Remove the aftertreatment 2 DEF dosing valve 1 from the decomposition reactor tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the aftertreatment 2 DEF dosing valve 1 for proper operation.

  • Use INSITE™ electronic service tool to perform the DEF System Leak Test found under ECM Diagnostic Tests. Refer to Procedure 011-080 in the Associated Procedures Table.

The DEF dosing valve must be removed and placed in a measuring container in order to leak check the DEF valve.

DEF leaking from the aftertreatment 2 DEF dosing valve during system leak test?
YES NO

A leaking aftertreatment 2 DEF dosing valve 1 has been detected.

Replace the aftertreatment 2 DEF dosing valve 1. Refer to Procedure 011-059 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the aftertreatment 2 DEF dosing valve 1 for proper operation.

Conditions

  • Make sure all DEF line and electrical connectors are connected appropriately.
  • Remove the aftertreatment 2 DEF dosing valve 1 from the decomposition reactor tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the DEF Doser Pump Override Test found under ECM Diagnostic Tests.

Refer to Procedure 011-063 in the Associated Procedures Table.

The DEF dosing valve must be removed and placed in a measuring container in order to perform the DEF Doser Pump Override Test. Make sure the DEF dosing valve is not plugged and the DEF spray pattern is correct.

Aftertreatment 2 DEF dosing valve 1 operates according to the specifications in Procedure 011-063?
YES NO
No Repair

Replace the aftertreatment 2 DEF dosing valve 1. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 01-Apr-2016


FAULT CODE 4615 - Engine Fuel Delivery Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSK95 CM2350 K113 | 4388663
Fuel Supply Lines | Refer to Procedure 006-024 | QSK95 CM2350 K113 | 4388663
Fuel Delivery Pressure Sensor | Refer to Procedure 019-548 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 546, 547, 2343, 2372, 4885, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, or 4961 active?
STEP 2. | Check the fuel supply system. |
 | STEP 2A. Check the fuel lines. | Kinked or damaged fuel lines?
 | STEP 2B. Check the fuel delivery pressure sensor. | Fuel delivery pressure sensor meets specifications found in Procedure 019-548?
STEP 3. | Check for fuel return drain line restriction. |
 | STEP 3A. Check drain line restriction. | Fuel drain line restriction within the specifications outlines in Procedure 006-012?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546, 547, 2343, 2372, 4885, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, or 4961 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the fuel supply system.

Guided Step 2A - Check the fuel lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the low-pressure fuel lines for kinks or damage.

Kinked or damaged fuel lines?
YES NO

Replace the damaged fuel line(s). Refer to Procedure 006-024 in the Associated Procedures Table or see equipment manufacturer service information.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fuel delivery pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Install a pressure gauge onto the Compuchek™ fitting at the outlet of the Stage 2 fuel filter head.

Action

Check the fuel delivery pressure sensor accuracy.

Refer to Procedure 019-548 in the Associated Procedures Table.

Fuel delivery pressure sensor meets specifications found in Procedure 019-548?
YES NO
No Repair

Replace the fuel delivery pressure sensor. Refer to Procedure 019-548 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check for fuel return drain line restriction.

Guided Step 3A - Check drain line restriction.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

Check for excessive fuel drain line restriction.

  • Refer to Procedure 006-012 in the Associated Procedures Table.

Fuel drain line restriction within the specifications outlined in Procedure 006-012?
YES | NO
No Repair | No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 25-Apr-2016


FAULT CODE 4643 - Injector Solenoid Driver Cylinder 7 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4643 active?
STEP 2. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 4643.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 4643 active?
YES NO

The injector bar code adjustable parameter for cylinder 7 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Data Plate. The correct injector bar code values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 13-Apr-2016


FAULT CODE 4644 - Injector Solenoid Driver Cylinder 8 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4644 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 4644.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 4644 active?
YES NO

The injector bar code adjustable parameter for cylinder 8 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector bar code values for that ESN are contained in the Engine Dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 25-Apr-2016


FAULT CODE 4645 - Injector Solenoid Driver Cylinder 9 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4645 active?
STEP 2. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 4645.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 4645 active?
YES NO

The injector bar code adjustable parameter for cylinder 9 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 25-Apr-2016


FAULT CODE 4646 - Injector Solenoid Driver Cylinder 10 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4646 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 4646.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 4646 active?
YES NO

The injector bar code adjustable parameter for cylinder 10 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 13-Apr-2016


FAULT CODE 4647 - Injector Solenoid Driver Cylinder 11 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4647 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 4647.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 4647 active?
YES NO

The injector bar code adjustable parameter for cylinder 11 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 25-Apr-2016


FAULT CODE 4648 - Injector Solenoid Driver Cylinder 12 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4648 active?
STEP 2. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 4648.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 4645 active?
YES NO

The injector bar code adjustable parameter for cylinder 12 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 20-May-2016


FAULT CODE 4649 - Injector Solenoid Driver Cylinder 13 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4649 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 4649.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 4649 active?
YES NO

The injector bar code adjustable parameter for cylinder 13 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe® Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector bar code values for that ESN are contained in the Engine Dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 13-Apr-2016


FAULT CODE 4651 - Injector Solenoid Driver Cylinder 14 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4651 active?
STEP 2. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 4651.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 4651 active?
YES NO

The injector bar code adjustable parameter for cylinder 14 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector bar code values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 25-Apr-2016


FAULT CODE 4652 - Injector Solenoid Driver Cylinder 15 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4652 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 4652.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 4652 active?
YES NO

The injector bar code adjustable parameter for cylinder 15 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector bar code values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 13-Apr-2016


FAULT CODE 4653 - Injector Solenoid Driver Cylinder 16 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4653 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 4653.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 4653 active?
YES NO

The injector bar code adjustable parameter for cylinder 16 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector bar code values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 13-Apr-2016


FAULT CODE 4677 - Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Electrical Connector Replacement | Refer to Procedure 019-559 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes | Fault Code 4677 active?
 | STEP 1B. Check for active fault codes. | Fault Codes 4437 active?
 | STEP 1C. Check for active fault codes. | Fault Codes 2771, 3232, and 4152 all active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) tank level sensor circuit. |
 | STEP 2A. Inspect the aftertreatment DEF tank level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment DEF tank level sensor. | Voltage within 1 VDC of engine control module (ECM) power supply voltage?
 | STEP 2C. Check the J1939 terminating resistance. | 50 to 70 ohms?
 | STEP 2D. Check for an open circuit in the aftertreatment DEF tank level sensor ECM power supply voltage supply. | Voltage within 1 VDC of ECM power supply voltage?
STEP 3. | Check the harness. |
 | STEP 3A. Inspect the aftertreatment DEF tank level sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the voltage to the aftertreatment DEF tank level sensor. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3C. Check the voltage to the aftertreatment DEF tank level sensor. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3D. Inspect the aftertreatment power relay and connector pins. | Dirty or damaged pins?
 | STEP 3E. Check the voltage to the aftertreatment power relay. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3F. Check the aftertreatment power relay. | Less than 10 ohms?
STEP 4. | Check the J1939 data link 4. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the J1939 data link harness. | Less than 10 ohms?
 | STEP 4C. Check the J1939 terminating resistance. | 110 to 130 ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4677 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4437 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2771, 3232, and 4152 all active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the aftertreatment DEF tank level sensor circuit.

Guided Step 2A - Inspect the aftertreatment DEF tank level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank level sensor from the original equipment manufacturer (OEM) harness.

Action

Inspect the OEM harness and aftertreatment DEF tank level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged OEM harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

Use the following procedure for DEF tank level sensor connector repair or replacement. Refer to Procedure 019-559 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment DEF tank level sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment DEF tank level sensor.

  • Measure the voltage between the aftertreatment DEF tank level sensor ECM power supply voltage supply circuit and the aftertreatment DEF tank level sensor return circuit at the DEF tank level sensor wiring harness connector.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage within 1 VDC of ECM power supply voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2D

Guided Step 2C - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the batteries.

Action

Measure the terminating resistance of the Society of Automotive Engineers (SAE) J1939 data link 4.

Use the circuit diagram or wiring diagram for connector pin identification.

50 to 70 ohms?
YES NO

Replace the aftertreatment DEF tank level sensor. See equipment manufacturer service information.

An open circuit or improper terminating resistance has been detected on the SAE J1939 data link 4 (+) or (-) wire between the DEF tank level sensor and data link backbone connection.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 5A

Guided Step 2D - Check for an open circuit in the aftertreatment DEF tank level sensor ECM power supply voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure the voltage from the aftertreatment DEF tank level sensor ECM power supply voltage SUPPLY pin of the OEM harness to ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Voltage within 1 VDC of ECM power supply voltage?
YES NO

An open circuit has been detected in the aftertreatment DEF tank level sensor ECM power supply voltage return circuit.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness. Refer to Procedure 019-071 in Section 19.

An open circuit has been detected in the aftertreatment DEF tank level sensor ECM power supply voltage supply circuit between the aftertreatment power relay and DEF tank level sensor.

Check for a blown or missing fuse in the aftertreatment DEF tank level sensor ECM power supply voltage supply circuit.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

]If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 5A

Guided Step 3 - Check the harness.

Guided Step 3A - Inspect the aftertreatment DEF tank level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank level sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DEF tank level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged OEM harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

Use the following procedure for DEF tank level sensor connector repair or replacement. Refer to Procedure 019-559 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the voltage to the aftertreatment DEF tank level sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment DEF tank level sensor.

  • Measure the voltage between the aftertreatment DEF tank level sensor ECM power supply voltage supply circuit and the aftertreatment DEF tank level sensor return circuit at the wiring harness sensor connector.

Check the voltage at keyswitch ON.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of ECM power supply voltage?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the voltage to the aftertreatment DEF tank level sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment DEF tank level sensor.

  • Measure the voltage from the aftertreatment DEF tank level sensor ECM power supply voltage SUPPLY pin of the OEM harness DEF tank level sensor connector to ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Voltage within 1 VDC of ECM power supply voltage?
YES NO

An open circuit has been detected in the aftertreatment DEF tank level sensor ECM power supply voltage return circuit.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3D

Guided Step 3D - Inspect aftertreatment power relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the harness.

Action

Inspect the harness and aftertreatment power relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the relay or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3E

Guided Step 3E - Check the voltage to the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment power relay.

  • Measure the voltage between the aftertreatment power relay ECM power supply voltage SUPPLY pin in the aftertreatment power relay connector of the engine harness and ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Voltage within 1 VDC of ECM power supply voltage?
YES NO
No Repair

An open circuit has been detected in the aftertreatment power ECM power supply voltage supply circuit before the power relay.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 5A

Guided Step 3F - Check the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.

Action

Check for a damaged aftertreatment power relay.

  • Install a jumper wire from pin 85 on the aftertreatment power relay to battery (+). Connect a jumper wire from pin 86 on the aftertreatment power relay to ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.
  • Measure the resistance between pin 30 and pin 87 on the aftertreatment power relay.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

An open circuit or short circuit to ground has been detected in the aftertreatment DEF tank level sensor power supply circuit.

This could be cause by:

  • Blown inline fuse on the DEF tank level sensor power supply circuit
  • Open circuit or short to ground in the DEF tank level sensor power supply circuit.

Replace the inline fuse if it is blown.

Troubleshoot all harnesses connected in series to determine which on contains the open or shorted circuit. Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness. Refer to Procedure 019-071 in Section 19.

Replace the aftertreatment power relay.

Go to 5A

Go to 5A

Guided Step 4 - Check the J1939 data link 4.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the OEM and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only when there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness and engine harness at the aftertreatment 1 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit in the J1939 data link 4.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the J1939 data link 4.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness at the aftertreatment 1 connector.

Action

Measure the terminating resistance of the SAE J1939 data link 4.

110 to 130 ohms?
YES NO
No Repair

Incorrect terminating resistance or an open circuit has been detected on the SAE J1939 data link 4 circuit in the engine harness.

Remove excess terminating resistors. Replace any damaged or missing terminating resistor.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness. Refer to procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 01-Apr-2016


FAULT CODE 4679 - Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Current Below Normal or Open Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3868 or 4572 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3868 or 4572 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

A circuit malfunction has been detected in the aftertreatment diesel exhaust fluid (DEF) tank level sensor.
Replace the aftertreatment DEF tank level sensor. See equipment manufacturer service information.
The aftertreatment DEF tank level sensor can be a combination type sensor that measures tank level, temperature, and quality. See equipment manufacturer service information for details.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 01-Apr-2016


FAULT CODE 4682 - Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor Circuit - Current Below Normal or Open Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4682 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4682 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

A damaged aftertreatment diesel exhaust fluid (DEF) tank level/temperature/quality sensor has been detected.

Replace the aftertreatment DEF tank level/temperature/quality sensor.

See equipment manufacturer service information.

 No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 01-Apr-2016


FAULT CODE 4688 - Water in Fuel Indicator 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Water in Fuel Sensor | Refer to Procedure 019-127 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4688 active?
STEP 2. | Check the water in fuel sensor 2 and circuit. |
 | STEP 2A. Inspect the engine harness and water in fuel sensor 2 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 4689 active and Fault Code 4688 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 4688 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 4688 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4688 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the water in fuel sensor 2 and circuit.

Guided Step 2A - Inspect the engine harness and water in fuel sensor 2 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor 2 from the engine harness connector.

Action

Inspect the engine harness and water in fuel sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the water in fuel sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor 2 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the water in fuel sensor 2 SIGNAL pin and the water in fuel sensor 2 RETURN pin at the sensor connector of the engine harness.

Use the circuit diagram or wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4689 active and Fault Code 4688 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor 2 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4688 active?
YES NO

A damaged water in fuel sensor has been detected.

Replace the water in fuel sensor 2. Refer to Procedure 019-127 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the original equipment manufacturer (OEM) harness connector from the ECM.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the water in fuel sensor 2 connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the OEM connector water in fuel sensor 2 RETURN pin and the engine harness water in fuel sensor 2 connector RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the water in fuel sensor 2 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM connector water in fuel sensor 2 SIGNAL pin and the engine harness water in fuel sensor 2 connector SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the water in fuel sensor 2 connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the water in fuel sensor 2 SIGNAL pin in the OEM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the short circuit.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4688 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 01-Apr-2016


FAULT CODE 4689 - Water in Fuel Indicator 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Water in Fuel Sensor | Refer to Procedure 019-127 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4689 active?
STEP 2. | Check the water in fuel sensor 2 and circuit. |
 | STEP 2A. Inspect the water in fuel sensor 2 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 4688 active and Fault Code 4689 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 4689 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) engine harness. |
 | STEP 3A. Inspect the ECM and OEM engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ECM power supply ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 4688 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4689 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the water in fuel sensor 2 and circuit.

Guided Step 2A - Inspect the water in fuel sensor 2 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor 2 from the engine harness.

Action

Inspect the engine harness and water in fuel sensor 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor 2 from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4688 active and Fault Code 4689 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the water in fuel sensor 2 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4689 active?
YES NO

A damaged water in fuel sensor has been detected.

Replace the water in fuel sensor 2. Refer to Procedure 019-127 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM engine harness.

Guided Step 3A - Inspect the ECM and OEM engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the water in fuel sensor 2 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the water in fuel sensor 2 SIGNAL pin in the connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the short circuit.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ECM power supply ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the water in fuel sensor 2 from the engine harness connector.

Action

Check for a pin-to-ECM power supply ground short.

  • Measure the resistance between the water in fuel sensor 2 SIGNAL pin in the OEM harness ECM connector and ECM power supply ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the short circuit.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4688 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 01-Apr-2016


FAULT CODE 4696 - Crankcase Pressure 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility or damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replace the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 4696 active?
STEP 2. | Check the crankcase pressure 2 sensor and circuit. |
 | STEP 2A. Inspect the crankcase pressure 2 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 4697 active and Fault Code 4696 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 4696 active?
STEP 3. | Check the ECM and harness. |
 | STEP 3A. Inspect the ECM and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 4696 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4696 active?
YES | NO
No Repair | No Repair

Go to 1A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the crankcase pressure 2 sensor and circuit.

Guided Step 2A - Inspect the crankcase pressure 2 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure 2 sensor from the engine harness.

Action

Inspect the harness and crankcase pressure 2 sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure 2 sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4697 active and Fault Code 4696 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure 2 sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the crankcase pressure 2 sensor SUPPLY pin and the crankcase pressure 2 sensor RETURN pin at the crankcase pressure 2 sensor connector of the engine harness.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the crankcase pressure 2 sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4696 active?
YES NO

A damaged sensor has been detected.

Replace the crankcase pressure 2 sensor.

  • Refer to Procedure 019-445 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect the ECM and OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness connector and ECM pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the crankcase pressure 2 sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector crankcase pressure 2 sensor RETURN pin and the engine harness crankcase pressure 2 sensor connector RETURN pin.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the crankcase pressure 2 sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the crankcase pressure 2 sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the short circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4696 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 25-Apr-2016


FAULT CODE 4697 - Crankcase Pressure 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 4697 active?
STEP 2. | Check the crankcase pressure 2 sensor and circuit. |
 | STEP 2A. Inspect the crankcase pressure 2 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 4696 active and Fault Code 4697 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 4697 active?
STEP 3. | Check the ECM and harness. |
 | STEP 3A. Inspect the ECM and original equipment manufacturer (OEM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3F. Check for an active fault code. | Fault Code 4697 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4697 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the crankcase pressure 2 sensor and circuit.

Guided Step 2A - Inspect the crankcase pressure 2 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure 2 sensor from the engine harness.

Action

Inspect the engine harness and crankcase pressure 2 sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure 2 sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the crankcase pressure 2 SUPPLY pin and the crankcase pressure 2 RETURN pin at the crankcase pressure 2 sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-360 in Section 19.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure 2 sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the crankcase pressure 2 sensor SUPPLY pin and the crankcase pressure 2 sensor SIGNAL pin at the crankcase pressure 2 sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4696 active and Fault Code 4697 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the crankcase pressure 2 sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4697 active?
YES NO

A damaged sensor has been detected.

Replace the crankcase pressure 2 sensor.

  • Refer to Procedure 019-445 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect the ECM and OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the OEM and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM
  • Disconnect the crankcase pressure 2 sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM ECM connector crankcase pressure 2 sensor SUPPLY pin and the engine harness crankcase pressure 2 sensor connector SUPPLY pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM
  • Disconnect the crankcase pressure 2 sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM ECM connector crankcase pressure 2 sensor SIGNAL pin and the engine harness crankcase pressure 2 sensor connector SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the crankcase pressure 2 sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the crankcase pressure 2 sensor SIGNAL pin in the OEM ECM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the crankcase pressure 2 sensor from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the crankcase pressure 2 sensor SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the short circuit to ground.

Repair or replace the OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4697 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID & Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 27-Apr-2016


FAULT CODE 4698 - Crankcase Pressure 2 - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankcase Breather Filter Element | Refer to Procedure 001-125 | QSK95 CM2350 K113 | 4388663
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify pressure sensor accuracy. | Pressure sensor reading within specification found in Procedure 019-445?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the crankcase pressure 2 sensor accuracy.

  • Refer to Procedure 019-445 in the Associated Procedures Table.

Pressure sensor reading within specification found in Procedure 019-445?
YES NO

Replace the breather filter element. Refer to Procedure 001-125 in the Associated Procedures Table.

Replace the crankcase pressure 2 sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 13-Apr-2016


FAULT CODE 4699 - Crankcase Pressure 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankcase Breather Filter Element | Refer to Procedure 001-125 | QSK95 CM2350 K113 | 4388663
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify pressure sensor accuracy. | Pressure sensor reading within specification found in Procedure 019-445?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the crankcase pressure 2 sensor accuracy.

  • Refer to Procedure 019-445 in the Associated Procedures Table.

Pressure sensor reading within specification found in Procedure 019-445?
YES NO

Replace the breather filter element. Refer to Procedure 001-125 in the Associated Procedures Table.

Replace the crankcase pressure 2 sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 13-Apr-2016


FAULT CODE 4711 - Crankcase Pressure 2 - Data Valid But Bleow Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankcase Breather System - With Filter Assembly | Refer to Procedure 001-122 | QSK95 CM2350 K113 | 4388663
Crankcase Breather Filter Element | Refer to Procedure 001-125 | QSK95 CM2350 K113 | 4388663
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify pressure sensor accuracy. | Pressure sensor reading within specification found in Procedure 019-445 in the Associated Procedures Table?
 | STEP 1B. Check the breather tube. | Damaged or missing breather tube or hose?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the crankcase pressure 2 sensor accuracy.

  • Refer to Procedure 019-445 in the Associated Procedures Table.

Pressure sensor reading within specification found in Procedure 019-445 in the Associated Procedures Table?
YES NO
No Repair

Replace the crankcase pressure 2 sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

Go to 1B

Go to 2A

Guided Step 1B - Check the breather tube.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the breather tube and hoses for the following:

  • Damaged or missing breather tube
  • Damaged or missing breather tube hoses
  • Missing or loose breather tube hose clamps.

Refer to Procedure 001-122 in the Associated Procedures Table.

Damaged or missing breather tube or hose?
YES NO

Replace the damaged components. Refer to Procedure 001-122 in the Associated Procedures Table.

A missing or damaged breather filter element has been detected. Replace the breather filter element. Refer to Procedure 001-125 in the Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 28-Mar-2016


FAULT CODE 4731 - Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 4731 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4731 active?
YES NO

A malfunctioning aftertreatment diesel exhaust fluid (DEF) tank temperature sensor has been detected.

Replace the aftertreatment DEF tank temperature sensor. See equipment manufacturer service information.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 01-Apr-2016


FAULT CODE 4732 - Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 4732 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4732 active?
YES NO

A malfunctioning aftertreatment diesel exhaust fluid (DEF) tank level sensor has been detected.

Replace the aftertreatment DEF tank level sensor. See equipment manufacturer service information.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 01-Apr-2016


FAULT CODE 4736 - Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4736 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4736 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

A damaged aftertreatment diesel exhaust fluid (DEF) tank level/temperature/quality sensor has been detected.

Replace the aftertreatment DEF tank level/temperature/quality sensor. See equipment manufacturer service information.

 No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 01-Apr-2016


FAULT CODE 4737 - Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Root Cause Not Known

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4737 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4737 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

A damaged aftertreatment diesel exhaust fluid (DEF) tank level/temperature/quality sensor has been detected.

Replace the aftertreatment DEF tank level/temperature/quality sensor. See equipment manufacturer service information.

 No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 01-Apr-2016


FAULT CODE 4738 - Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for diesel exhaust fluid (DEF) quality or DEF temperature fault codes. | Fault Code 3868 or 4572 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for DEF quality or DEF temperature fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3868 or 4572 active?
YES NO
No Repair

A circuit malfunction has been detected in the aftertreatment DEF tank level sensor.

Replace the aftertreatment DEF tank level sensor. See equipment manufacturer service information.

The aftertreatment DEF tank temperature sensor can be a combination type sensor that measures tank level, temperature, and quality. See original equipment manufacturer for details.

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Reapir complete.

Last Modified: 01-Apr-2016


FAULT CODE 4739 - Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Root Cause Not Known

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3868 or 4572 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3868 or 4572 active?
YES NO
No Repair

An internal malfunction has been detected in the aftertreatment diesel exhaust fluid (DEF) tank level sensor.

Replace the aftertreatment DEF tank level sensor.

See equipment manufacturer service information.

The aftertreatment DEF tank temperature sensor can be a combination type sensor that measures tank level, temperature, and quality.

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 01-Apr-2016


FAULT CODE 4745 - Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 - Root Cause Not Known

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for diesel exhaust fluid (DEF) quality or DEF tank temperature related fault codes. | Fault Code 3868 or 4572 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for DEF quality or DEF tank temperature related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3868 or 4572 active?
YES NO
No Repair

An internal malfunction has been detected in the aftertreatment DEF tank level sensor.

Replace the aftertreatment DEF tank level sensor. See equipment manufacturer service information.

The aftertreatment DEF tank temperature sensor can be a combination type sensor that measures tank level, temperature, and quality. See equipment manufacturer service information.

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 01-Apr-2016


FAULT CODE 4768 - Aftertreatment 1 Diesel Exhaust Fluid Property - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Tank | Refer to Procedure 011-081 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 4768. | Fault Code 4768 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) for contamination and concentration. |
 | STEP 2A. Check the DEF tank for contamination. | Diesel fuel detected in the DEF tank?
 | STEP 2B. Check the DEF concentration. | DEF concentration within 32.5 ±1.5 percent?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 4768.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4768 active?
YES | NO
No Repair | No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check the aftertreatment DEF for contamination and concentration.

Guided Step 2A - Check the DEF tank for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF for contamination.

  • Inspect the DEF tank for diesel fuel. Refer to Procedure 011-081 in the Associated Procedures Table.

Diesel fuel detected in the DEF tank?
YES NO

Drain the DEF tank. Flush and clean the DEF tank with water.

Refer to Procedure 011-081 in the Associated Procedures Table.

Fill the tank with fresh DEF.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the DEF concentration.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF concentration.

  • Use DEF refractometer, Part Number 4919554, to measure the concentration of the DEF in the tank.

DEF concentration within 32.5 ±1.5 percent?
YES NO

A malfunctioning DEF quality sensor has been detected. See equipment manufacturer service information.

Drain the DEF tank and fill with new DEF.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 01-Apr-2016


FAULT CODE 4769 - Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Abnormal Rate of Change

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1668, 1669, 4679, 4732, 4738, or 4739 active?
 | STEP 1B. Check for active fault codes. | Fault Code 4769 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668, 1669, 4679, 4732, 4738, or 4739 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4769 active?
YES NO

An internal error has been detected in the aftertreatment diesel exhaust fluid (DEF) tank level sensor.

Replace the aftertreatment DEF tank level sensor.

See equipment manufacturer service information.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 01-Apr-2016


FAULT CODE 4842 - Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 4842. | Fault Code 4842 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) concentration. |
 | STEP 2A. Check the DEF tank for contamination. | Diesel fuel detected in the DEF tank?
 | STEP 2B. Check the DEF concentration. | DEF concentration within 32.5 ±1.5 percent?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 4842.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4842 active?
YES | NO
No Repair | No Repair

Go to 2A

Repair complete

Guided Step 2 - Check the aftertreatment DEF concentration.

Guided Step 2A - Check the DEF tank for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF for contamination.

  • Inspect the DEF tank for diesel fuel.

Diesel fuel detected in the DEF tank?
YES NO

Drain the DEF tank. Flush and clean the DEF tank with distilled water.

Fill the tank with fresh DEF

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the DEF concentration.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF concentration.

  • Use DEF refractometer, Part Number 4919554, to measure the concentration of the DEF in the tank.

DEF concentration within 32.5 ±1.5 percent?
YES NO

A malfunctioning DEF quality sensor has been detected. See equipment manufacturer service information.

Drain the DEF fluid tank and fill with new DEF.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 20-May-2016


FAULT CODE 4863 - Aftertreatment SCR Operator Inducement Active - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 4863 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 4863.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for other active fault codes.

Fault Code 4863 active?
YES NO

This is an information-only fault code that will only become active if other critical selective catalytic reduction (SCR) fault codes are active for an extended period of time.

Troubleshoot all other active fault codes.

This fault code will become inactive when all other active fault codes are resolved.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 01-Apr-2016


FAULT CODE 4883 - Engine Oil Priming State - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Hand Hole Cover | Refer to Procedure 001-035 | QSK95 CM2350 K113 | 4388663
Pre-Lubricating Oil Pump | Refer to Procedure 007-063 | QSK95 CM2350 K113 | 4388663
Lubricating Oil Pressure Switch, Prelubrication System | Refer to Procedure 007-086 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4883 active?
 | STEP 1B. Check for active fault codes. | Fault Code 1774 or 1775 active?
STEP 2. | Check the prelubrication system. |
 | STEP 2A. Check engine oil level. | Oil level on the dipstick?
 | STEP 2B. Inspect the prelubrication system. | Damaged or leaking components?
STEP 3. | Check the prelubrication pump supply voltage. |
 | STEP 3A. Check the prelubrication pump supply voltage. | Voltage within 1 VDC of battery voltage?
 | STEP 3B. Check for an open prelubrication pump supply circuit. | Voltage within 1 VDC of battery voltage?
STEP 4. | Check the prelubrication system sensors. |
 | STEP 4A. Check the prelubrication system pressure. | Pressure greater than 83 kPa [12 psi]?
 | STEP 4B. Check for a malfunctioning prelubrication pressure switch. | Greater than 100k ohms?
 | STEP 4C. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 4D. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 4E. Check the oil pressure sensor reading. | Oil pressure sensor reading within specification found in Procedure 019-066 in the Associated Procedures Table?
STEP 5. | Check the prelubrication pump. |
 | STEP 5A. Check the prelubrication pump. | Prelubrication pump operating correctly?
STEP 6. | Check the engine crankcase components. |
 | STEP 6A. Check for an internal prelubricating oil leak. | Malfunctioning or damaged engine components?
STEP 7. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 4883 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1774 or 1775 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the prelubrication system.

Guided Step 2A - Check engine oil level.

Conditions

  • Turn keyswitch OFF.

Action

Check the engine oil level.

Oil level on the dipstick?
YES NO
No Repair

Add oil to the engine.

Go to 2B

Go to 7A

Guided Step 2B - Inspect the prelubrication system.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the prelubrication pump and external engine oil lines for damage or leaks.

Damaged or leaking components?
YES NO

Repair or replace the damaged or leaking component(s).

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the prelubrication pump supply voltage.

Guided Step 3A - Check the prelubrication pump supply voltage.

Conditions

  • Turn keyswitch ON.
  • Disconnect the harness from the prelubrication pump.

Action

Use INSITE™ electronic service tool to override the prelubrication pump using the Prelubrication Control feature found in the Special Features section.

  • Measure the voltage from the prelubrication pump SUPPLY pin to the prelubrication pump RETURN pin at the harness prelubrication connector.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open prelubrication pump supply circuit.

Conditions

  • Turn keyswitch ON.
  • Disconnect the harness from the prelubrication pump.

Action

Use INSITE™ electronic service tool to override the prelubrication pump using the Prelubrication Control feature found in the Special Features sections.

  • Measure the voltage from the prelubrication pump SUPPLY pin in the harness prelubrication pump connector to the engine block ground.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of battery voltage?
YES NO

An open circuit has been detected in the prelubrication pump supply circuit.

Repair or replace the original equipment manufacturer (OEM) harness.

See equipment manufacturer service information.

An open circuit has been detected in the prelubrication pump supply circuit.

Check for a malfunctioning or missing relay. Troubleshoot all harnesses in the circuit. Repair or replace the damaged component(s), as necessary.

See equipment manufacturer service information.

Go to 7A

Go to 7A

Guided Step 4 - Check the prelubrication sensors.

Guided Step 4A - Check the prelubrication system pressure.

Conditions

  • Turn keyswitch ON.
  • Install a pressure gauge in the engine oil system near the prelubrication pressure switch.

Action

Use INSITE™ electronic service tool to override the prelubrication pump using the Prelubrication Control feature found in the Special Features section.

  • Monitor the prelubrication oil pressure with the gauge.

Pressure greater than 83 kPa [12 psi]?
YES | NO
No Repair | No Repair

Go to 4B

Go to 5A

Guided Step 4B - Check for a malfunctioning prelubrication pressure switch.

Conditions

  • Turn keyswitch ON.
  • Disconnect the prelubrication pressure switch from the engine harness.

Action

Use INSITE™ electronic service tool to override the prelubrication pump using the Prelubrication Control feature found in the Special Features sections.

Check for a stuck closed prelubrication pressure switch.

  • Measure the resistance between the prelubrication pressure switch SIGNAL and RETURN pins on the switch.

Use the circuit diagram or wiring harness for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A stuck closed prelubrication pressure switch has been detected.

Replace the prelubrication pressure switch.

Refer to Procedure 007-086 in the Associated Procedures Table.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the prelubrication pressure switch from the engine harness.

Action

Check for a pin-to-pin short circuit on the prelubrication pressure switch SIGNAL wire.

  • Measure the resistance between the engine harness ECM connector prelubrication pressure switch SIGNAL pin and all other pins in the connector.

Use the circuit diagram or wiring harness for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected on the prelubrication pressure switch SIGNAL wire.

Repair or replace the damaged section of the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the pre-lubrication pressure switch from the engine harness.

Action

Check for a pin-to-ground short circuit on the prelubrication pressure switch SIGNAL wire.

  • Measure the resistance between the engine harness ECM connector pre-lubrication pressure switch SIGNAL pin and ECM power supply ground.

Use the circuit diagram or wiring harness for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit has been detected on the pre-lubrication pressure switch SIGNAL wire.

Repair or replace the damaged section of the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 7A

Guided Step 4E - Check the oil pressure sensor reading.

Conditions

  • Turn keyswitch ON.
  • Install a pressure gauge in the engine oil system near the oil pressure sensor.

Action

Check the oil pressure sensor accuracy.

Refer to Procedure 019-066 in the Associated Procedures Table.

Oil pressure sensor reading within specification found in procedure 019-066 in the Associated Procedures Table?
YES NO
No Repair

Replace the oil pressure sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 5 - Check the prelubrication pump.

Guided Step 5A - Check the prelubrication pump.

Conditions

  • Turn keyswitch ON.

Action

Verify prelubrication pump is functioning properly.

Refer to Procedure 007-063 in the Associated Procedures Table.

Prelubrication pump operating correctly?
YES NO
No Repair

Replace the prelubrication pump. Refer to Procedure 007-063 in the Associated Procedures Table.

Go to 6A

Go to 7A

Guided Step 6 - Check the engine crankcase components.

Guided Step 6A - Check for an internal prelubricating oil leak.

Conditions

  • Remove the hand hole covers from the engine. Refer to Procedure 001-035 in the Associated Procedures Table.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to override the prelubrication pump using the Prelubrication Control feature found in the Special Feature section.

Inspect the internal engine for unintended oil leaks at prelubrication pressure.

  • Check for damaged or missing piston cooling nozzles. Oil should not leak from the piston cooling nozzles during the prelubrication cycle.
  • Check for a leaking or damaged prelubrication oil crossover line in the crankcase.

Malfunctioning or damaged engine components?
YES NO

Tighten any loose piston cooling nozzles.

Repair or replace any malfunctioning components. See equipment manufacturer service information.

No Repair

Go to 7A

Go to 7A

Guided Step 7 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 29-Mar-2016


FAULT CODE 4884 - Engine Oil Priming Pump Control - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Lubricating Oil Pressure Switch, Prelubrication System | Refer to Procedure 007-086 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4884 active?
STEP 2. | Check the prelubrication pump. |
 | STEP 2A. Check the prelubrication pump supply voltage. | Voltage greater than 5 VDC?
STEP 3. | Check the prelubrication pressure sensor and circuit. |
 | STEP 3A. Inspect the prelubrication pressure switch and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a malfunctioning prelubrication pressure switch. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for an open circuit in the engine harness. | Less than 10 ohms?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 4884 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the prelubrication pump.

Guided Step 2A - Check the prelubrication pump supply voltage.

Conditions

  • Turn keyswitch ON.
  • Disconnect the harness from the prelubrication pump.

Action

Check for a short circuit in the prelubrication pump supply circuit.

  • Measure the voltage from the prelubrication pump SUPPLY pin to the prelubrication pump RETURN pin at the harness prelubrication pump connector.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Voltage greater than 5 VDC?
YES NO

A stuck on prelubrication pump relay or short circuit on the prelubrication pump supply circuit has been detected.

Replace the relay if damaged. Repair or replace the damaged section of harness.

See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the prelubrication sensor and circuit.

Guided Step 3A - Inspect the prelubrication pressure switch and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the prelubrication pressure switch from the engine harness.

Action

Inspect the engine harness and prelubrication pressure switch connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the switch or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a malfunctioning prelubrication pressure switch.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the prelubrication pressure switch from the engine harness.

Action

Check for an open prelubrication pressure switch.

  • Measure the resistance between the prelubrication pressure switch SIGNAL and RETURN pins on the switch.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A stuck open prelubrication pressure switch has been detected.

Replace the prelubrication pressure switch.

Refer to Procedure 007-086 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the prelubrication pressure switch from the engine harness.

Action

Check for an open prelubrication pressure switch SIGNAL wire.

  • Measure the resistance between the engine harness prelubrication pressure switch connector SIGNAL pin and the engine harness ECM connector prelubrication pressure switch SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open prelubrication pressure switch SIGNAL wire has been detected.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the prelubrication pressure switch from the engine harness.

Action

Check for an open prelubrication pressure switch RETURN wire.

  • Measure the resistance between the engine harness prelubrication pressure switch connector RETURN pin and the engine harness ECM connector prelubrication pressure switch RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open prelubrication pressure switch RETURN wire has been detected.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 29-Mar-2016


FAULT CODE 4885 - Engine Fuel Supply Pump - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Fuel Supply Pump | Refer to Procedure 005-241 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4886, 4887, or 4892 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 4886, 4887, or 4892 active?
YES NO
No Repair

A malfunctioning engine fuel supply pump has been detected.

Replace the engine fuel supply pump. Refer to Procedure 005-241 in the Associated Procedures Table.

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 29-Mar-2016


FAULT CODE 4886 - Engine Fuel Supply Pump Supply Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Fuel Supply Pump | Refer to Procedure 005-241 | QSK95 CM2350 K113 | 4388663
Electrical System | Refer to Procedure 018-021 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4886 active?
STEP 2. | Check engine fuel supply pump. |
 | STEP 2A. Check for correct battery or power supply. | Correct battery or power supply?
 | STEP 2B. Check for a tripped or malfunctioning circuit breaker. | Circuit breaker operational?
 | STEP 2C. Inspect the engine fuel supply pump and connector pins. | Dirty or damaged pins?
 | STEP 2D. Measure resistance in the engine fuel supply pump motor. | Measurement between 10K-2M ohms?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electroinc service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4886 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check engine fuel supply pump.

Guided Step 2A - Check for correct battery or power supply.

Conditions

  • Turn the keyswitch OFF.

Action

Verify the correct battery or power supply is installed and in proper operating condition.

  • Refer to Procedure 018-021 in the Associated Procedures Table.

Correct battery or power supply?
YES NO
No Repair

Replace the battery or power supply. See equipment manufacturer service information.

Go to 2B

Go to 3A

Guided Step 2B - Check for a tripped or malfunctioning circuit breaker.

Conditions

  • Turn the keyswitch OFF.

Action

Check circuit breaker.

  • Check for a tripped or malfunctioning circuit breaker. See equipment manufacturer service information.

Circuit breaker operational?
YES NO
No Repair

Replace or reset the circuit breaker. See equipment manufacturer service information.

Go to 2C

Go to 2C

Guided Step 2C - Inspect the engine fuel supply pump and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect OEM wiring harness power connector(s) from the engine fuel supply pump.

Action

Inspect the connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the appropriate wiring diagram for pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace and damaged or malfunctioning components. See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 2D

Guided Step 2D - Measure resistance in the engine fuel supply pump motor.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect OEM wiring harness power connector(s) from the engine fuel supply pump.

Action

Measure the resistance of the fuel pump motor.

  • Place the positive lead on the fuel pump motor SUPPLY pin.
  • Place the negative lead on the fuel pump motor RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Measurement between 10K-2M ohms?
YES NO

Check the voltage source for proper operation. Inspect the OEM harness for damage and dirty, corroded, or loose connection between the engine fuel supply pump motor and the voltage source.

A damaged engine fuel supply pump has been detected.

  • Replace the engine fuel supply pump. Refer to Procedure 005-241 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process

Repair complete.

Last Modified: 14-Jun-2017


FAULT CODE 4887 - Engine Fuel Supply Pump Supply Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault code. | Fault Code 4887 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electroinc service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4887 active?
YES NO

Low voltage has been detected at the engine fuel supply pump motor.

Check for a tripped or malfunctioning circuit breaker. Inspect the original equipment manufacturer (OEM) harness for damage and dirty, corroded, or loose connection between the engine fuel supply pump motor and the voltage source.

Repair or replace any damaged or malfunctioning components. See equipment manufacturer service information.

Intermittent low voltage has been detected at the engine fuel supply pump motor.

Troubleshoot the OEM harness for an intermittent voltage malfunction.

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 29-Mar-2016


FAULT CODE 4888 - Engine Fuel Supply Pump Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | QSK95 CM2350 K113 | 4388663
Engine Fuel Supply Pump | Refer to Procedure 005-241 | QSK95 CM2350 K113 | 4388663
Fuel Filter (Stage 2) | Refer to Procedure 006-076 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes and low-pressure fuel system. |
 | STEP 1A. Check the fault codes. | Fault Code 2372, 4886, or 4887 active or inactive counts?
 | STEP 1B. Check the fault codes. | Active or inactive counts of high fuel delivery temperature fault codes?
 | STEP 1C. Check the stage 2 fuel filter restriction. | Stage 2 fuel filter restriction within the specifications found in Procedure 005-236 in the Associated Procedures Table?
 | STEP 1D. Check the fault codes. | Fault Code 4888 active or inactive counts?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes and low pressure fuel system.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2372, 4886, or 4887 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of high fuel delivery temperature fault codes?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1C - Check the Stage 2 fuel filter restriction.

Conditions

  • Turn keyswitch ON.

Action

Check the Stage 2 fuel filter restriction.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Stage 2 fuel filter restriction within the specifications found in Procedure 005-236 in the Associated Procedures Table?
YES | NO
No Repair | No Repair

Go to 1C

Go to 2A

Guided Step 1D - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4888 active or inactive counts?
YES NO

  • Replace the fuel supply pump. Refer to Procedure 005-241 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 29-Mar-2016


FAULT CODE 4889 - Engine Fuel Supply Pump Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | QSK95 CM2350 K113 | 4388663
Engine Fuel Supply Pump | Refer to Procedure 005-241 | QSK95 CM2350 K113 | 4388663
Fuel Filter (Stage 2) | Refer to Procedure 006-076 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes and low pressure fuel system. |
 | STEP 1A. Check the fault codes. | Fault Code 2372, 4886, or 4887 active or inactive counts?
 | STEP 1B. Check the fault codes. | Active or inactive counts of high fuel delivery temperature fault codes?
 | STEP 1C. Check the Stage 2 fuel filter restriction. | Stage 2 fuel filter restriction within the specifications found in Procedure 005-236 in the Associated Procedures Table?
 | STEP 1D. Check the fault codes. | Fault Code 4888 active or inactive counts?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes and low pressure fuel system.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2372, 4886, or 4887 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of high fuel delivery temperature fault codes?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check the Stage 2 fuel filter restriction.

Conditions

  • Turn keyswitch ON.

Action

Check the Stage 2 fuel filter restriction.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Stage 2 fuel filter restriction within the specifications found in Procedure 005-236 in the Associated Procedures Table?
YES NO
No Repair

Replace the Stage 2 fuel filters. Refer to Procedure 006-076 in the Associated Procedures Table.

Go to 1D

Go to 2A

Guided Step 1D - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4889 active or inactive counts?
YES NO

  • Replace the fuel supply pump. Refer to Procedure 005-241 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 29-Mar-2016


FAULT CODE 4891 - Engine Fuel Supply Pump - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes | Fault Code 4891 active?
 | STEP 1B. Check for active fault codes. | Fault Code 4892, 4929, or 4931 active?
STEP 2. | Check the engine fuel supply pump circuit. |
 | STEP 2A. Inspect the engine fuel supply pump and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine fuel supply pump harness. | Tampering or intermittent malfunctions detected?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4891 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4892, 4929, or 4931 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the engine fuel supply pump circuit.

Guided Step 2A - Inspect the engine fuel supply pump and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel supply pump from the engine harness.

Action

Inspect the engine harness and engine fuel supply pump connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the fuel supply pump or harness connector.

Clean the connector and pins.

Repair the damaged OEM harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the engine fuel supply pump harness.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine fuel supply pump SUPPLY and RETURN wires for the following:

  • Tampering or add on wires
  • Wiggle the engine harness and check for counts of Fault Code 4892, 4929, or 4931, indicating an intermittent supply or data link 3 connection.

Tampering or intermittent malfunctions detected?
YES NO

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 29-Mar-2016


FAULT CODE 4892 - Engine Fuel Supply Pump - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Fuel Supply Pump | Refer to Procedure 005-241 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes | Fault Code 4892 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3331 active?
 | STEP 1C. Check for active fault codes. | Fault Code 4929 or 4931 active?
 | STEP 1D. Check for active fault codes. | Fault Code 4961 also active?
STEP 2. | Check the engine fuel supply pump circuit. |
 | STEP 2A. Inspect the engine fuel supply pump and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the engine fuel supply pump. | Voltage within 1 VDC of battery voltage?
 | STEP 2C. Check the J1939 terminating resistance. | 50 to 70 ohms?
 | STEP 2D. Check for an open circuit in the engine fuel supply pump battery voltage supply. | Voltage within 1 VDC of battery voltage?
STEP 3. | Check the power supply circuit. |
 | STEP 3A. Inspect the fuel metering valve and engine fuel supply pump connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the battery supply voltage. | Voltage within 1 VDC of battery voltage?
 | STEP 3C. Check for an open battery voltage supply circuit. | Voltage within 1 VDC of battery voltage?
 | STEP 3D. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3E. Check the battery supply voltage. | Voltage within 1 VDC of battery voltage?
STEP 4. | Check the data link 3 circuit. |
 | STEP 4A. Inspect the engine fuel supply pump and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the J1939 terminating resistance. | 50 to 70 ohms?
 | STEP 4C. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the J1939 terminating resistance | 50 to 70 ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4892 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3331 active?
YES | NO
No Repair | No Repair

Go to 1C

Appropriate troubleshooting tree

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4929 or 4931 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1D

Guided Step 1D - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4691 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the engine fuel supply pump circuit.

Guided Step 2A - Inspect the engine fuel supply pump and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel supply pump from the engine harness.

Action

Inspect the engine harness and engine fuel supply pump connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the fuel supply pump or harness connector.

Clean the connector and pins.

Repair the damaged engine harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the voltage to the engine fuel supply pump.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel supply pump from the engine harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the engine fuel supply pump.

  • Measure the voltage between the engine fuel supply pump supply circuit and the engine fuel supply pump return circuit at the fuel supply pump engine harness connector.

Check the voltage at keyswitch ON and with the engine at idle.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2D

Guided Step 2C - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel supply pump from the engine harness.

Action

Measure the terminating resistance of the SAE J1939 data link 3.

  • Measure the resistance between the SAE J1939 data link 3 (+) wire and the J1939 data link 3 (-) wire at the engine fuel supply pump engine harness connector.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 to 70 ohms?
YES NO

Replace the engine fuel supply pump.

Refer to Procedure 005-241 in the Associated Procedures Table.

An open circuit has been detected on the SAE J1939 data link 3 (+) or (-) wire between the engine fuel supply pump and the data link 3 backbone connection.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 2D - Check for an open circuit in the engine fuel supply pump battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel supply pump from the engine harness.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure the voltage from the engine fuel supply pump battery voltage SUPPLY pin of the engine harness to engine block ground.

Voltage within 1 VDC of battery voltage?
YES NO

An open circuit has been detected in the engine fuel supply pump battery voltage return circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

An open circuit has been detected in the engine fuel supply pump battery voltage supply circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 3 - Check the power supply circuit.

Guided Step 3A - Inspect the fuel metering valve and engine fuel supply pump connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.
  • Disconnect the engine fuel supply pump from the engine harness.

Action

Inspect the engine harness and device connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the device or harness connector.

Clean the connector and pins.

Repair the damaged engine harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the battery supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.
  • Disconnect the engine fuel supply pump from the engine harness.
  • Turn keyswitch ON.

Action

Check the battery supply voltage at each component.

  • Measure the voltage between the fuel metering valve connector battery voltage SUPPLY pin and the fuel metering valve connector battery voltage RETURN pin.
  • Measure the voltage between the engine fuel supply pump connector battery voltage SUPPLY pin and the engine fuel supply pump connector battery voltage RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Voltage within 1 VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check for an open battery voltage supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.
  • Disconnect the engine fuel supply pump from the engine harness.
  • Turn keyswitch ON.

Action

Check for an open circuit at each component.

  • Measure the voltage between the fuel metering valve connector battery voltage SUPPLY pin and ECM power supply ground.
  • Measure the voltage between the engine fuel supply pump connector battery voltage SUPPLY pin and ECM power supply ground.

Use the wiring diagram or wiring diagram for connector pin identification.

Voltage within 1 VDC of battery voltage?
YES NO

An open circuit has been detected in the fuel metering valve and/or engine fuel supply pump battery voltage return circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3D

Guided Step 3D - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damage pins?
YES NO

A damage connection has been detected in the ECM or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3E

Guided Step 3E - Check the battery supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the battery supply voltage.

  • Measure the voltage between the fuel metering valve/engine fuel supply pump battery voltage SUPPLY pin and RETURN pin at the ECM.

Use the circuit diagram or wiring diagram for connector pin identification.

Voltage within 1 VDC of battery voltage?
YES NO

An open circuit has been detected in the fuel metering valve and/or engine fuel supply pump battery voltage supply circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Check the data link 3 circuit.

Guided Step 4A - Inspect the engine fuel supply pump and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel supply pump from the engine harness.

Action

Inspect the engine harness and engine fuel supply pump connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the fuel supply pump or harness connector.

Clean the connector and pins.

Repair the damaged engine harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel supply pump from the engine harness.

Action

Measure the terminating resistance of the SAE J1939 data link 3.

  • Measure the resistance between the SAE J1939 data link 3 (+) wire and the J1939 data link 3 (-) wire at the engine fuel supply pump engine harness connector.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 to 70 ohms?
YES NO

An open circuit has been detected on the SAE J1939 data link 3 (+) or (-) wire between the ECM and the data link 3 backbone connection.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4C

Guided Step 4C - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4D

Guided Step 4D - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Measure the terminating resistance of the SAE J1939 data link 3.

  • Measure the resistance between the SAE J1939 data link 3 (+) wire and the J1939 data link 3 (-) wire at the ECM engine harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 to 70 ohms?
YES NO
No Repair

Incorrect terminating resistance or an open circuit has been detected on the SAE J1939 data link 3 backbone connection.

Remove excess terminating resistors. Replace any damaged or missing terminating resistors.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 29-Mar-2016


FAULT CODE 4893 - Engine Fuel Filter (suction side) Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | QSK95 CM2350 K113 | 4388663
Air in Fuel | Refer to Procedure 006-003 | QSK95 CM2350 K113 | 4388663
Fuel Supply Lines | Refer to Procedure 006-024 | QSK95 CM2350 K113 | 4388663
Fuel Filter (Stage 1) | Refer to Procedure 006-075 | QSK95 CM2350 K113 | 4388663
Fuel Inlet Pressure Measurement | Refer to Procedure 006-104 | QSK95 CM2350 K113 | 4388663
Fuel Supply Pump Intake Pressure Sensor | Refer to Procedure 019-549 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4893 active or inactive counts?
STEP 2. | Check the low-pressure fuel system. |
 | STEP 2A. Check for adequate fuel supply. | Equipment has adequate fuel supply?
 | STEP 2B. Check the fuel lines. | Kinked or damaged fuel lines?
STEP 3. | Check the low-pressure fuel system operation. |
 | STEP 3A. Check fuel supply pump inlet restriction. | Fuel supply pump inlet restriction within the specifications found in Procedure 006-104 in the Associated Procedures Table?
 | STEP 3B. Check Stage 1 fuel filter restriction. | Stage 1 fuel filter restriction within the specifications found in Procedure 005-236 in the Associated Procedures Table?
 | STEP 3C. Check the fuel supply pump intake pressure sensor. | Fuel supply pump intake pressure sensor meets specifications found in Procedure 019-549 in the Associated Procedures Table?
 | STEP 3D. Check for air in the fuel system. | Air in the fuel?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4893 active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the low-pressure fuel system.

Guided Step 2A - Check for adequate fuel supply.

Conditions

  • Turn keyswitch ON.
  • Turn engine OFF.

Action

Check for adequate fuel supply.

  • Do not rely on the vehicle's fuel gauge.
  • Verify there is fuel in the tank.

Equipment has adequate fuel supply?
YES NO
No Repair

Add fuel to the fuel tank or perform repairs to the vehicle's tank or fuel gauge.

Go to 2B

Go to 4A

Guided Step 2B - Check the fuel lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the suction fuel lines for kinks or damage.

Kinked or damaged fuel lines?
YES NO

Replace the damaged fuel line(s). Refer to Procedure 006-024 in the Associated Procedures Table or equipment manufacturer service information

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the low-pressure fuel system operation.

Guided Step 3A - Check fuel supply pump inlet restriction.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel supply pump inlet restriction.

  • Refer to Procedure 006-104 in the Associated Procedures Table.

Fuel supply pump inlet restriction within the specifications found in Procedure 006-104 in the Associated Procedures Table?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B

Guided Step 3B - Check Stage 1 fuel filter restriction.

Conditions

  • Turn keyswitch ON.

Action

Check the Stage 1 fuel filter restriction.

Refer to Procedure 005-236 in the Associated Procedures Table.

Stage 1 fuel filter restriction within the specifications found in Procedure 005-236 in the Associated Procedures Table?
YES NO

High restriction in the fuel supply lines or fuel supply tank has been detected. Continue troubleshooting to determine the cause of the high restriction.

Replace any damaged or malfunctioning components. See equipment manufacturer service information.

Replace the Stage 1 fuel filters. Refer to Procedure 006-075 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3C - Check the fuel supply pump intake pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel supply pump intake pressure sensor accuracy.

Refer to Procedure 019-549 in the Associated Procedures Table.

Fuel supply pump intake pressure sensor meets specifications found in Procedure 019-549 in the Associated Procedures Table?
YES NO
No Repair

Replace the fuel supply pump intake pressure sensor. Refer to Procedure 019-549 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for air in the fuel system.

Conditions

  • Turn keyswitch ON.

Action

Check for air in the fuel.

Refer to Procedure 006-003 in the Associated Procedures Table.

Air in the fuel?
YES NO

Investigate the cause of air in fuel. Check for loose Stage 1 filters, loose fuel line fittings, and fuel line punctures. Repair or replace the malfunctioning component(s).

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 19-May-2016


FAULT CODE 4894 - Engine Fuel Supply Pump - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Fuel Supply Pump | Refer to Procedure 005-241 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check fault codes. |
 | STEP 1A. Check fault codes. | Fault Code 4894 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4894 active?
YES NO

The firmware version in the engine fuel supply pump is not compatible with the ECM software.

Download the correct firmware to the engine fuel supply pump. Refer to Procedure 005-242 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 29-Mar-2016


FAULT CODE 4927 - Engine Diesel Fuel Metering Valve - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault code 4928, 4929, 4931, or 4961 active?
 | STEP 1B. Check for active fault codes. | Fault Code 4927 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 4928, 4929, 4931, or 4961 active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4927 active?
YES NO

An internal error has been detected in the fuel metering valve.

Replace the fuel metering valve.

Refer to Procedure 005-242 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 29-Mar-2016


FAULT CODE 4928 - Engine Diesel Fuel Metering Valve Power Supply - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 4982 active?
 | STEP 1B. Check for related fault codes. | Fault Code 441 or 442 active?
 | STEP 1C. Check for related fault codes. | Fault Code 4929 or 4931 active?
STEP 2. | Check the fuel metering valve and circuit. |
 | STEP 2A. Inspect the fuel metering valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fuel metering valve battery supply voltage. | Voltage within 1 VDC of battery voltage?
 | STEP 2C. Check for an open battery voltage supply circuit. | Voltage within 1 VDC of battery voltage?
 | STEP 2D. Check for an inactive fault code. | Fault Code 4928 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the battery supply voltage. | Voltage within 1 VDC of battery voltage.
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4928 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 or 442 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4929 or 4931 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the fuel metering valve and circuit.

Guided Step 2A - Inspect the fuel metering valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.

Action

Inspect the engine harness and device connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the device or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fuel metering valve battery supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.
  • Turn keyswitch ON.

Action

Check the battery supply voltage.

  • Measure the voltage between the fuel metering valve connector battery voltage SUPPLY pin and the fuel metering valve connector battery voltage RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Voltage within 1 VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C

Guided Step 2C - Check for an open battery voltage supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.
  • Turn keyswitch ON.

Action

Check for an open circuit at each component.

  • Measure the voltage between the fuel metering valve connector battery voltage SUPPLY pin and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Voltage within 1 VDC of battery voltage?
YES NO

An open circuit or high resistance has been detected in the fuel metering valve battery voltage return circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 2D - Check for an inactive fault code.

Conditions

  • Connect the fuel metering valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4928 active?
YES NO

An intermittent malfunction of the battery voltage supply circuit has been detected in the fuel metering valve connector or engine harness.

Use the following procedure for intermittent fault code troubleshooting. Refer to Procedure 019-362 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the batter supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the battery supply voltage.

  • Measure the voltage between the fuel metering valve battery voltage SUPPLY pin and RETURN pin at the ECM.

Use the circuit diagram or wiring diagram for connector pin identification.

Voltage within 1 VDC of battery voltage?
YES NO

An open or high resistance has been detected in the fuel metering valve battery voltage supply circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 29-Mar-2016


FAULT CODE 4929 - Engine Diesel Fuel Metering Valve Power Supply - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 4929 active?
STEP 2. | Check the ECM. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the battery supply voltage. | Voltage within 1 VDC of battery voltage?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine fuel valve and engine fuel supply pump connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the battery supply voltage. | Voltage within 1 VDC of battery voltage?
 | STEP 3C. Check for an open battery voltage supply circuit. | Voltage within 1 VDC of battery voltage?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4929 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the battery supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the battery supply voltage.

  • Measure the voltage between the engine fuel metering valve/engine fuel supply pump battery voltage SUPPLY pin and RETURN pin at the ECM.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of battery voltage?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the fuel metering valve and engine fuel supply pump connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.
  • Diconnect the engine fuel supply pump from the engine harness.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the device or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the battery supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel metering valve from the engine harness.
  • Disconnect the engine fuel supply pump from the engine harness.
  • Turn keyswitch ON.

Action

Check the battery supply voltage at each component.

  • Measure the voltage between the engine fuel metering valve connector battery voltage SUPPLY pin and the engine fuel metering valve connector battery voltage RETURN pin.
  • Measure the voltage between the engine fuel supply pump connector battery voltage SUPPLY pin and the engine fuel supply pump connector battery voltage RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3C

Guided Step 3C - Check for an open battery voltage supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel metering valve from the engine harness.
  • Disconnect the engine fuel supply pump from the engine harness.
  • Turn keyswitch ON.

Action

Check for an open circuit at each component.

  • Measure the voltage between the engine fuel metering valve connector battery voltage SUPPLY pin and ECM power supply ground.
  • Measure the voltage between the engine fuel supply pump connector battery voltage SUPPLY pin and ECM power supply ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of battery voltage?
YES NO

An open circuit has been detected in the engine fuel metering valve and/or engine fuel supply pump battery voltage return circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

An open circuit has been detected in the engine fuel metering valve and/or engine fuel supply pump battery voltage supply circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine fuel metering valve from the engine harness.
  • Disconnect the engine fuel supply pump from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine fuel metering valve/engine fuel supply pump battery voltage SUPPLY pin in the engine harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the battery voltage supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 19-May-2016


FAULT CODE 4931 - Engine Diesel Fuel Metering Valve Power Supply - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Fuel Supply Pump | Refer to Procedure 005-241 | QSK95 CM2350 K113 | 4388663
Fuel Metering Valve | Refer to Procedure 005-242 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 4931 active?
STEP 2. | Check the fuel system data link devices and circuits. |
 | STEP 2A. Inspect the fuel metering valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 4931 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 4931 active?
 | STEP 2D. Inspect the engine fuel supply pump and connector pins. | Dirty or damaged pins?
 | STEP 2E. Check the circuit response. | Fault Code 4931 active?
 | STEP 2F. Check the fault codes and verify sensor condition. | Fault Code 4931 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 4929 active and Fault Code 4931 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4931 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel system data link devices and circuits.

Guided Step 2A - Inspect the fuel metering valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.

Action

Inspect the engine harness and actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Disconnect the fuel metering valve from the engine harness.
  • Turn keyswitch OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4931 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel metering valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4931 active?
YES NO

The removal and installation of the connector corrected the fault.

A damaged actuator has been detected.

Replace the fuel metering valve.

  • Refer to Procedure 005-242 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 2D - Inspect the engine fuel supply pump and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel supply pump from the engine harness.

Action

Inspect the engine harness and supply pump connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the pump or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check the circuit response.

Conditions

  • Disconnect the engine fuel supply pump from the engine harness.
  • Turn keyswitch OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4931 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2F

Guided Step 2F - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine fuel supply pump to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4931 active?
YES NO

A damaged fuel supply pump has been detected.

Replace the engine fuel supply pump.

  • Refer to Procedure 005-241 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4929 active and Fault Code 4931 inactive?
YES NO

A pin-to-ground or pin-to-pin short circuit on the supply circuit has been detected in the engine harness.

Repair or replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 30-Mar-2016


FAULT CODE 4932 - Engine Diesel Fuel Metering Valve Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 261, 266, 4927 or 4933 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 261, 266, 4927 or 4933 active?
YES NO

The fuel metering valve internal temperature has exceeded the maximum limit. No repair is necessary. This fault code is for information only.

No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 30-Mar-2016


FAULT CODE 4933 - Engine Diesel Fuel Metering Valve Position - Received Network Data in Error

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4928, 4929, 4931, or 4961 active or inactive counts?
 | STEP 1B. Check for active fault codes. | Fault Code 4933 active?
 | STEP 1C. Check for inactive fault codes. | Fault Code 4933 multiple inactive counts related to other fuel system pressure fault codes?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4928, 4929, 4931, or 4961 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Operate the engine at idle.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4933 active?
YES NO
No Repair

A malfunctioning fuel metering valve has been detected.

Replace the fuel metering valve. Refer to Procedure 005-242 in the Associated Procedures Table.

Go to 1C

Go to 2A

Guided Step 1C - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • If multiple inactive counts of Fault Code 4933 are present and are associated with other fuel system pressure fault codes, an intermittently malfunctioning fuel metering valve has been detected.

Fault Code 4933 multiple inactive counts related to other fuel system pressure fault codes?
YES NO

A malfunctioning fuel metering valve has been detected.

Replace the fuel metering valve. Refer to Procedure 005-242 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 30-Mar-2016


FAULT CODE 4934 - Engine Diesel Fuel Metering Valve - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4934 active?
STEP 2. | Check the fuel metering valve harness. |
 | STEP 2A. Inspect the engine harness and fuel metering valve connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2E. Check for an open circuit in the engine harness. | Less than 10 ohms?
STEP 3. | Check the fuel metering valve. |
 | STEP 3A. Check the fuel metering valve resistance. | Between 9k ohms and 110k ohms?
 | STEP 3B. Check for an inactive fault code. | Fault Code 4858 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4934 inactive?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel metering valve harness.

Guided Step 2A - Inspect the engine harness and fuel metering valve connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.

Action

Inspect the engine harness and device connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel metering valve connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the engine control module (ECM) and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel metering valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the fuel metering valve control SIGNAL pin at the ECM connector of the engine harness and the fuel metering valve control SIGNAL pin at the fuel metering valve connector of the engine harness.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel metering valve from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the fuel metering valve control SIGNAL pin in the engine harness ECM connector and all other pins in the connector.
  • Measure the resistance between the fuel metering valve control RETURN pin in the engine harness ECM connector and all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel metering valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector fuel metering valve control RETURN pin and the engine harness fuel metering valve connector control RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the fuel metering valve.

Guided Step 3A - Check the fuel metering valve resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.

Action

Check for correct resistance on the fuel metering valve control SIGNAL circuit.

  • Measure the resistance between the fuel metering valve control SIGNAL and RETURN pins at the fuel metering valve.

Between 9k ohms and 110k ohms?
YES NO
No Repair

A damaged fuel metering valve has been detected.

Replace the fuel metering valve. Refer to Procedure 005-242 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Check for an active fault code.

Conditions

  • Connect all components.
  • Perform a keycycle.
  • Start the engine.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4958 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

An intermittent circuit malfunction has been detected in the harness. Refer to Procedure 019-362 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 30-Mar-2016


FAULT CODE 4935 - Engine Diesel Fuel Metering Valve - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4935 active?
STEP 2. | Check the fuel metering valve harness. |
 | STEP 2A. Inspect the engine harness and fuel metering valve connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2D. Check for a pin-to-ECM power supply ground short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Check the fuel metering valve. |
 | STEP 3A. Check the fuel metering valve resistance. | Between 9k ohms and 110k ohms?
 | STEP 3B. Check for an inactive fault code. | Fault Code 4935 active?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4935 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel metering valve harness.

Guided Step 2A - Inspect the engine harness and fuel metering valve connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.

Action

Inspect the engine harness and device connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel metering valve connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel metering valve from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the fuel metering valve control SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check for a pin-to-ECM power supply ground short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel metering valve from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the fuel metering valve control SIGNAL pin in the engine harness ECM connector and ECM power supply ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the fuel metering valve.

Guided Step 3A - Check the fuel metering valve resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.

Action

Check for correct resistance on the fuel metering valve control signal circuit.

  • Measure the resistance between the fuel metering valve control SIGNAL and RETURN pins at the fuel metering valve.

Between 9k ohms and 110k ohms?
YES NO
No Repair

A damaged fuel metering valve has been detected.

Replace the fuel metering valve. Refer to Procedure 005-242 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Check for an active fault code.

Conditions

  • Connect all components.
  • Perform a keycycle.
  • Start the engine.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4935 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

An intermittent circuit malfunction has been detected in the harness. Refer to Procedure 019-362 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 30-Mar-2016


FAULT CODE 4936 - Engine Diesel Fuel Metering Valve - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check fault codes. |
 | STEP 1A. Check fault codes. | Fault Code 4936 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4936 active?
YES NO

The firmware in the fuel metering valve is not compatible with the ECM software.

Download the correct firmware to the fuel metering valve. Refer to Procedure 005-242 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 29-Mar-2016


FAULT CODE 4937 - Engine Diesel Fuel Metering Valve - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check fault codes. |
 | STEP 1A. Check fault codes. | Fault Code 4937 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4937 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO

Replace the fuel metering valve. Refer to Procedure 05-242 in the Associated Procedures Table.

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process.

Repair complete.

Last Modified: 04-Apr-2017


FAULT CODE 4941 - Engine Starter Control - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Starter Magnetic Switch | Refer to Procedure 013-017 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4941 active?
STEP 2. | Check the starter motor magnetic switches circuit. |
 | STEP 2A. Inspect the 24V magnetic switch and connector terminals. | Dirty or damaged terminals?
 | STEP 2B. Check the resistance of the 24V coil magnetic switch. | Within 13.4 to 14.7 ohms?
STEP 3. | Check the harness. |
 | STEP 3A. Inspect the original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM extension harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the 24V coil magnetic switch return circuit. | Less than 10 ohms?
 | STEP 3D. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3E. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3F. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3G. Check for an active fault code. | Fault Code 4941 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4941 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the starter motor magnetic switches circuit.

Guided Step 2A - Inspect the 24V magnetic switch and connector terminals.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 24 V coil magnetic switch from the OEM extension harness.

Action

Inspect the 24V coil magnetic switch and terminals.

  • Loose connector
  • Corroded terminals
  • Bent or broken terminals
  • Pushed back or expanded terminals
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector terminals
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged terminals?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the terminals.

Repair the damaged harness, connector, or terminals, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the 24V coil magnetic switch.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 24V coil magnetic switch from the OEM extension harness.

Action

Check the 24 V coil magnetic switch resistance.

  • Measure the resistance between the 24V coil magnetic switch signal terminal and the 24V coil magnetic switch return terminal.

Use the wiring diagram for terminal identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Within 13.4 to 14.7 ohms?
YES NO
No Repair

Replace the 24V coil magnetic switch Refer to Procedure 013-017 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the harness.

Guided Step 3A - Inspect the OEM extension harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM extension harness from the engine harness.

Action

Inspect the OEM extension harness and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM extension harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM extension harness from the engine harness.
  • Disconnect the starter motor magnetic switch from the OEM extension harness.

Action

Check for an open circuit.

  • Measure the resistance between the 24V coil magnetic switch signal terminal at the 24V coil magnetic switch connector and the 24V coil magnetic switch signal terminal at the OEM extension connector on the OEM extension harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open 24V coil magnetic switch SIGNAL wire has been detected in the OEM extension engine harness.

Repair or replace the OEM extension harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the 24V coil magnetic switch return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM extension harness connector from the engine harness.
  • Disconnect the 24V magnetic switch from the OEM extension harness.

Action

Check for an open circuit.

  • Measure the resistance between the 24V coil magnetic switch return terminal at the 24V coil magnetic switch terminal and the 24V coil magnetic switch return terminal at the OEM extension harness connector on the OEM extension harness.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open 24V coil magnetic switch RETURN wire has been detected in the OEM extension harness.

Repair or replace the OEM extension harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the ECM connector and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3E

Guided Step 3E - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM extension connector from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the 24V coil magnetic switch signal terminal at the 24V coil magnetic switch connector and the 24V coil magnetic switch signal terminal at the OEM extension connector on the engine harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open 24V coil magnetic switch SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM extension connector from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the 24V coil magnetic switch return terminal at the 24V coil magnetic switch connector and the 24V coil magnetic switch return terminal at the OEM extension connector on the engine harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open 24V coil magnetic switch RETURN wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3G

Go to 4A

Guided Step 3G - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool.

Fault Code 4941 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Reapir complete.

Last Modified: 03-May-2016


FAULT CODE 4942 - Engine Starter Control - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Starter Magnetic Switch | Refer to Procedure 013-017 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4942 active?
STEP 2. | Check the starter motor magnetic switches and circuit. |
 | STEP 2A. Inspect the starter motor magnetic switches and connector terminals. | Dirty or damaged terminals?
 | STEP 2B. Check the starter motor magnetic switches resistance. | Greater than 6 ohms?
 | STEP 2C. Check for a terminal-to-engine control module (ECM) power supply ground short circuit in the starter motor magnetic switches. | Greater than 100k ohms?
STEP 3. | Check the harness. |
 | STEP 3A. Inspect the original equipment manufacturer (OEM) extension harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit-to-ECM power supply ground in the OEM extension harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Inspect the engine control module (ECM) and OEM extension harness connector pins. | Dirty or damaged pins?
 | STEP 3E. Check for a short circuit-to-ECM power supply ground in the engine harness. | Greater than 100k ohms?
 | STEP 3F. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3G. Check for an active fault code. | Fault Code 4942 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4942 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the starter motor magnetic switches and circuit.

Guided Step 2A - Inspect the starter motor magnetic switches and connector terminals.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the two starter magnetic switches from the OEM extension harness.

Action

Inspect teach engine starter magnetic switch and connector terminals.

  • Loose connector
  • Corroded terminals
  • Bent or broken terminals
  • Pushed back or expanded terminals
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector terminals
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged terminals?
YES NO

A damaged connection has been detected in the magnetic switches or harness connector.

Clean the terminals.

Repair the damaged harness, connector, or terminals, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the starter motor magnetic switches resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the two starter motor magnetic switches from the OEM extension harness.

Action

Check each magnetic switch resistance.

  • Measure the resistance of the magnetic switches coil and check for low resistance between the starter motor magnetic switch signal terminal and the magnetic switch return terminal.

Use the wiring diagram for terminal identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 6 ohms?
YES NO
No Repair

Replace the starter motor magnetic switch. Refer to Procedure 013-017 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a terminal-to-ECM power supply ground short circuit in the starter motor magnetic switches.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the two starter motor magnetic switches from the OEM extension harness.

Action

Check for a short circuit-to-ECM power supply ground.

  • Measure the resistance and check for a short circuit between the starter motor magnetic switches signal terminal at the magnetic switches and ECM power supply ground circuit.

Use the wiring diagram for terminal identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the starter motor magnetic switch. Refer to Procedure 013-017 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the harness.

Guided Step 3A - Inspect the OEM extension harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM extension connector from the engine harness.

Action

Inspect the OEM extension harness and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit-to-ECM power supply ground in the OEM extension harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter motor magnetic switches from the OEM extension harness.
  • Disconnect the OEM extension connector from the engine harness.

Action

Check for a short circuit to ground in the OEM extension harness.

  • Measure the resistance between the starter motor magnetic switches signal terminal in the OEM extension harness connector and ECM power supply ground circuit

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the starter motor magnetic switches SIGNAL wire in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM extension harness from the engine harness.
  • Disconnect the starter motor magnetic switches from the OEM extension harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the starter motor magnetic switches signal terminal and all other pins in the OEM extension harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected on the starter motor magnetic switches SIGNAL wire in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Inspect the ECM and OEM extension harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the OEM extension harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3E

Guided Step 3E - Check for a short circuit-to-ECM power supply ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter motor magnetic switches from the engine harness.
  • Disconnect the OEM connector from the ECM.

Action

Check for a short circuit to ground in the engine harness.

  • Measure the resistance between the starter motor magnetic switches signal terminal in the OEM harness ECM connector and ECM power supply ground circuit.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the starter motor magnetic switches SIGNAL wire in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the starter motor magnetic switches from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the starter motor magnetic switches s terminal and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected on the starter motor magnetic switches s wire in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3G

Go to 4A

Guided Step 3G - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine. Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool.

Fault Code 4942 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Reapir complete.

Last Modified: 03-May-2016


FAULT CODE 4943 - Engine Failed to Crank - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Electrical System Diagnostics | Refer to Procedure 013-082 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4943 active?
 | STEP 1B. Check for related fault codes. | Fault Code 4941 or 4942 active?
 | STEP 1C. Check the starting system functionality. | Engine cranks normally?
STEP 2. | Check the starting motor batteries. |
 | STEP 2A. Check the starting motor battery terminals. | Terminals tight and corrosion-free?
 | STEP 2B. Check the starting motor batteries. | Within original equipment manufacturer (OEM) specification?
 | STEP 2C. Check the voltage at the OEM extension harness. | Within 1 VDC of engine control module (ECM) power supply voltage?
STEP 3. | Check the starting system. |
 | STEP 3A. Inspect the starting system. | Any damaged, malfunctioning, or out of specification components?
STEP 4. | Check the starter magnetic switches and circuit. |
 | STEP 4A. Check for an open circuit in the OEM extension harness. | Less than 10 ohms?
 | STEP 4B. Check for an open circuit in the OEM extension harness. | Less than 10 ohms?
 | STEP 4C. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4D. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 4E. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 4F. Check for an inactive fault code. | Fault Code 4943 active?
STEP 5. | Check the ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4943 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4941 or 4942 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check the starting system functionality.

Conditions

  • Turn keyswitch ON.

Action

Attempt to start the engine.

Engine cranks normally?
YES | NO
No Repair | No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the starting motor batteries.

Guided Step 2A - Check the starting motor battery terminals.

Conditions

  • Turn keyswitch OFF.

Action

Check the starting motor battery terminal connections.

See equipment manufacturer service information.

Terminals tight and corrosion-free?
YES NO
No Repair

Clean the terminals and tighten loose connections. See equipment manufacturer service information.

Go to 2B

Go to 5A

Guided Step 2B - Check the starting motor batteries.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starting motor battery positive and negative terminals.

Action

Check for Voltage between the positive and negative starting motor battery terminals.

  • Measure the voltage between the positive and negative terminals.

See equipment manufacturer service information.

Some OEM's lockout starters under a specified battery voltage.

Within OEM specification?
YES NO
No Repair

Inspect power supply. See equipment manufacturer service information.

Go to 2C

Go to 5A

Guided Step 2C - Check the voltage at the OEM extension harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 24V coil magnetic switches from the OEM extension harness.
  • Turn key to start position.

Action

Check for Voltage between the signal and return terminals.

  • Measure the voltage between the signal and return terminals on the OEM extension harness.

Within 1 VDC of ECM power supply voltage?
YES NO
No Repair

Inspect power supply. See equipment manufacturer service information.

Go to 3A

Go to 5A

Guided Step 3 - Check the starting system.

Guided Step 3A - Inspect the starting system.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the starting system wiring and components.

  • Refer to Procedure 013-082 in the Associated Procedures Table.

Any damaged, malfunctioning, or out of specification components?
YES NO

Repair or replace components, as necessary. Refer to Procedure 013-082 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the starter magnetic switches and circuit.

Guided Step 4A - Check for an open circuit in the OEM extension harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter magnetic switches SUPPLY terminal from the starter motor.
  • Disconnect the starter magnetic switches from the OEM extension.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the starter diagnostic relay SUPPLY pin in the engine harness starter diagnostic relay connector and the starter diagnostic relay SUPPLY pin at the starter motor terminal.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the starter diagnostic relay SUPPLY wire in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4B

Go to 5A

Guided Step 4B - Check for an open circuit in the OEM extension harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter magnetic switches RETURN terminal from the starter motor.
  • Disconnect the starter magnetic switches from the OEM extension harness.

Action

Check for an open circuit in the OEM extension harness.

  • Measure the resistance between the starter diagnostic relay RETURN pin in the engine harness starter diagnostic relay connector and the starter diagnostic relay RETURN pin at the starter motor terminal.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the starter magnetic switch RETURN wire in the harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4D

Guided Step 4D - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter magnetic switches from the engine harness.
  • Disconnect the engine harness connector from the ECM.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the starter magnetic switches feedback SIGNAL pin in the engine harness starter magnetic switches connector and the starter magnetic switches feedback SIGNAL pin in the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the starter magnetic switches feedback SIGNAL wire in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 5A

Guided Step 4E - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the starter magnetic switches from the engine harness.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the starter magnetic switches feedback RETURN pin in the engine harness starter magnetic switches connector and the starter magnetic switches feedback RETURN pin in the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the starter magnetic switches feedback RETURN wire in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4F

Go to 5A

Guided Step 4F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4943 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the malfunction.

Go to 5A

Go to 5A

Guided Step 5 - Check the ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 27-Apr-2016


FAULT CODE 4944 - Engine Failed to Start - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 4944. | Fault Code 4944 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 4944.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 4944.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4944 active?
YES NO

The maximum number of start attempts has been reached.

See the Engine Difficult To Start or Will Not Start troubleshooting symptom tree in Section TS of the QSK95 CM2350 K113 Service Manual, Bulletin 4388663.

No Repair

Go the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 01-Apr-2016


FAULT CODE 4945 - Engine Uncommanded Cranking - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Starting Motor | Refer to Procedure 013-020 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4945 active?
 | STEP 1B. Check for related fault codes. | Fault Code 4942 active?
 | STEP 1C. Review starting symptoms. | Uncommanded or uncontrolled cranking of the engine occurred?
STEP 2. | Check starter motor relay and circuit. |
 | STEP 2A. Inspect the starter solenoid terminals. | Loose or corroded/dirty connections?
 | STEP 2B. Check for a short circuit in the engine harness. | Greater than 1 VDC?
 | STEP 2C. Check the starter solenoid. | Greater than 100k ohms?
STEP 3. | Check the starter solenoid diagnostic relay and circuit. |
 | STEP 3A. Inspect the starter solenoid diagnostic relay and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the starter solenoid diagnostic relay. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3D. Check for a short circuit to ECM power supply ground in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 4945 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4945 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4942 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Review starting symptoms.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Review available information to determine if uncommanded or uncontrolled cranking of the engine occurred.

  • Talk to the operator.
  • Use the fault code snapshot in INSITE™ electronic service tool and check the engine speed monitor parameter.

Uncommanded or uncontrolled cranking of the engine occurred?
YES | NO
No Repair | No Repair

Go to 2A

3A

Guided Step 2 - Check starter motor relay and circuit.

Guided Step 2A - Inspect the starter solenoid terminals.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine starter solenoid connections.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Loose or corroded/dirty connections?
YES NO

A damaged connection has been detected in the solenoid or harness connector.

Clean the connectors.

Repair the damaged harness or connectors, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all starter solenoid connections.
  • Turn keyswitch ON.

Action

Check for a short circuit in the engine harness.

  • Measure the voltage between the starter motor relay output SUPPLY wire at the starter solenoid and chassis ECM power supply ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 1 VDC?
YES NO

A short circuit to voltage source has been detected in the starter motor relay output SUPPLY wire in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the starter solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all starter solenoid connections.

Action

Check for a stuck ON starter solenoid.

  • Measure the resistance between the battery voltage input and output supply (high current) posts on the starter solenoid.

Use the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 100k ohms?
YES NO

An intermittent malfunction has been detected. Use the following procedure for an intermittent fault code. Refer to Procedure 019-362 in Section 19.

Replace the starter. Refer to Procedure 013-020 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3 - Check the starter solenoid diagnostic relay and circuit.

Guided Step 3A - Inspect the starter solenoid diagnostic relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter solenoid diagnostic relay from the engine harness.

Action

Inspect the diagnostic relay and connector pins:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the relay or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the starter solenoid diagnostic relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter solenoid diagnostic relay from the engine harness.

Action

Check for a malfunctioning starter diagnostic relay.

  • Measure the resistance between pin 30 and pin 87 on the starter solenoid diagnostic relay.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the starter solenoid diagnostic relay.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check for a short circuit to ECM power supply ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter solenoid diagnostic relay from the engine harness.
  • Disconnect the engine harness connector from the ECM.

Action

Check for a short circuit to ECM power supply ground in the engine harness.

  • Measure the resistance between the starter solenoid diagnostic relay feedback SIGNAL pin in the engine harness ECM connector and ECM power supply ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ECM power supply ground has been detected in the starter solenoid diagnostic relay feedback SIGNAL wire in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the starter solenoid diagnostic relay from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the starter solenoid diagnostic relay control SIGNAL pin and all other pins in the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected on the starter solenoid diagnostic relay feedback SIGNAL wire in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4942 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 31-Mar-2016


FAULT CODE 4946 - Engine Crank Without Prelube - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 4946 active or inactive counts?
STEP 2. | Check engine control module (ECM) calibration update is available. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active.

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4946 active or inactive counts?
YES NO

This is an information only fault code that will become active if the engine start override switch is used and the engine was allowed to crank before the normal prelubrication cycle completed.

No troubleshooting is necessary for this fault code.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 19-May-2016


FAULT CODE 4947 - Aftertreatment 1 Diesel Exhaust Fluid Doser Heating Mode Request - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 4947 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for other active aftertreatment diesel exhaust fluid (DEF) related fault codes.

Fault Code 4947 active?
YES NO

This is an information only fault code that will only become active if other aftertreatment DEF system related fault codes are active or it the DEF system is currently in thawing mode.

Troubleshoot all other active DEF system related fault codes.

This fault code will become inactive when the system has successfully primed.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 31-Mar-2016


FAULT CODE 4958 - Engine Diesel Fuel Metering Valve - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4958 active?
STEP 2. | Check the fuel metering valve harness. |
 | STEP 2A. Inspect the engine harness and fuel metering valve connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2C. Inspect the fuel metering valve resistor connector pins. | Dirty or damaged pins?
 | STEP 2D. Check the fuel metering valve resistor. | Between 1.7k ohms and 2k ohms?
 | STEP 2E. Check the fuel metering valve resistor. | Between 1.7k ohms and 2k ohms?
 | STEP 2F. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2G. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2H. Check for a pin-to-ECM power supply ground short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2I. Check for an open circuit in the engine harness. | Less than 10 ohms?
STEP 3. | Check the fuel metering valve. |
 | STEP 3A. Check the fuel metering valve resistance. | Between 9k ohms and 110k ohms?
 | STEP 3B. Check for an inactive fault code. | Fault Code 4958 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4958 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel metering valve harness.

Guided Step 2A - Inspect the engine harness and fuel metering valve connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.

Action

Inspect the engine harness and fuel metering valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel metering valve connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Inspect the fuel metering valve resistor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check the fuel metering valve resistor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel metering valve from the engine harness.

Action

Measure resistance.

  • Measure the resistance between the fuel metering valve control SIGNAL pin in the engine harness ECM connector and fuel metering valve control RETURN pin in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 1.7k ohms and 2k ohms?
YES | NO
No Repair | No Repair

Go to 2F

Go to 2E

Guided Step 2E - Check the fuel metering valve resistor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.

Action

Measure resistance.

  • Measure the resistance of the fuel metering valve resistor.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 1.7k ohms and 2k ohms?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace to fuel metering valve resistor.

Go to 4A

Go to 4A

Guided Step 2F - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel metering valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the fuel metering valve control SIGNAL pin at the ECM connector of the engine harness and the fuel metering valve control SIGNAL pin at the fuel metering valve connector of the engine harness.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2G

Go to 4A

Guided Step 2G - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel metering valve from the engine harness.
  • Disconnect the fuel metering valve resistor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the fuel metering valve control SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2H

Go to 4A

Guided Step 2H - Check for a pin-to-ground short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel metering valve from the engine harness.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the fuel metering valve control SIGNAL pin in the engine harness ECM connector and engine block ECM power supply ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2I

Go to 4A

Guided Step 2I - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel metering valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector fuel metering valve control RETURN pin and the engine harness fuel metering valve connector control RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the fuel metering valve.

Guided Step 3A - Check the fuel metering valve resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.

Action

Check for correct resistance on the fuel metering valve control signal circuit.

  • Measure the resistance between the fuel metering valve control SIGNAL and RETURN pins at the fuel metering valve.

Between 9k ohms and 110k ohms?
YES NO
No Repair

A damaged fuel metering valve has been detected.

Replace the fuel metering valve. Refer to Procedure 005-242 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4958 inactive?
YES NO

An intermittent circuit malfunction has been detected in the harness. Refer to Procedure 019-362 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 31-May-2017


FAULT CODE 4959 - Engine Diesel Fuel Metering Valve - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4958 active?
STEP 2. | Check the fuel metering valve harness. |
 | STEP 2A. Inspect the engine harness. | Altered or tampered wiring detected?
 | STEP 2B. Inspect the engine harness and fuel metering valve connector pins. | Dirty or damaged pins?
 | STEP 2C. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2F. Check for a pin-to-ECM power supply ground short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2G. Check for an open circuit in the engine harness. | Less than 10 ohms?
STEP 3. | Check the fuel metering valve. |
 | STEP 3A. Check the fuel metering valve resistance. | Between 9k ohms and 110k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4958 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel metering valve harness.

Guided Step 2A - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine harness from the ECM to the fuel metering valve for the following:

  • Add on wiring to the fuel metering valve control SIGNAL or RETURN wires.
  • Wiring to the fuel metering valve that has been altered or other signs of tampering.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Altered or tampered wiring detected?
YES NO

Repair or replace the damaged harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the engine harness and fuel metering valve connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.

Action

Inspect the engine harness and fuel metering valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel metering valve connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel metering valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the fuel metering valve control SIGNAL pin at the ECM connector of the engine harness and the fuel metering valve control SIGNAL pin at the fuel metering valve connector of the engine harness.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel metering valve from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the fuel metering valve control SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2F

Go to 4A

Guided Step 2F - Check for a pin-to-ECM power supply ground short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel metering valve from the engine harness.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the fuel metering valve control SIGNAL pin in the engine harness ECM connector and engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2G

Go to 4A

Guided Step 2G - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel metering valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector fuel metering valve control RETURN pin and the engine harness fuel metering valve connector control RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the fuel metering valve.

Guided Step 3A - Check the fuel metering valve resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.

Action

Check for correct resistance on the fuel metering valve control signal circuit.

  • Measure the resistance between the fuel metering valve control SIGNAL and RETURN pins at the fuel metering valve.

Between 9k ohms and 110k ohms?
YES NO
No Repair

A damaged fuel metering valve has been detected.

Replace the fuel metering valve. Refer to Procedure 005-242 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 29-Mar-2016


FAULT CODE 4961 - Engine Diesel Fuel Metering Valve - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes | Fault Code 4961 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3331 active?
 | STEP 1C. Check for active fault codes. | Fault Code 4929 or 4931 active?
 | STEP 1D. Check for active fault codes. | Fault Code 4892 also active?
STEP 2. | Check the fuel metering valve circuit. |
 | STEP 2A. Inspect the fuel metering valve and connector pins. | Damaged or dirty pins?
 | STEP 2B. Check the voltage to the fuel metering valve. | Voltage within 1 VDC of battery voltage?
 | STEP 2C. Check the J1939 terminating resistance. | 50 to 70 ohms?
 | STEP 2D. Check for an open circuit in the fuel metering valve battery voltage supply. | Voltage within 1 VDC of battery voltage?
STEP 3. | Check the power supply circuit. |
 | STEP 3A. Inspect the fuel metering valve and engine fuel supply pump connector pins. | Damaged or dirty pins?
 | STEP 3B. Check the battery supply voltage. | Voltage within 1 VDC of battery voltage?
 | STEP 3C. Check for an open battery voltage supply circuit. | Voltage within 1 VDC of battery voltage?
 | STEP 3D. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3E. Check the battery supply voltage. | Voltage within 1 VDC of battery voltage?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the fuel metering valve and connector pins. | Damaged or dirty pins?
 | STEP 4B. Check the J1939 terminating resistance. | 50 to 70 ohms?
 | STEP 4C. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the J1939 terminating resistance | 50 to 70 ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4961 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3331 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4929 or 4931 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1D

Guided Step 1D - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4892 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the fuel metering valve circuit.

Guided Step 2A - Inspect the fuel metering valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.

Action

Inspect the engine harness and fuel metering valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the fuel metering valve or harness connector.

Clean the connector and pins.

Repair the damaged engine harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the voltage to the fuel metering valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the fuel metering valve.

  • Measure the voltage between the fuel metering valve battery voltage supply circuit and the fuel metering valve return circuit at the fuel valve engine harness connector.

Check the voltage at keyswitch ON and with the engine at idle.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2D

Guided Step 2C - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel supply pump from the engine harness.

Action

Measure the terminating resistance of the SAE J1939 data link 3.

  • Measure the resistance between the SAE J1939 data link 3 (+) wire and the J1939 data link 3 (-) wire at the fuel metering valve engine harness connector.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 to 70 ohms?
YES NO

Replace the fuel metering valve.

Refer to Procedure 005-242 in the Associated Procedures Table.

An open circuit has been detected on the SAE J1939 data link 3 (+) or (-) wire between the fuel metering valve and the data link 3 backbone connection.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 2D - Check for an open circuit in the fuel metering valve battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure the voltage from the fuel metering valve battery voltage SUPPLY pin of the engine harness to engine block ground.

Voltage within 1 VDC of battery voltage?
YES NO

An open circuit has been detected in the fuel metering valve battery voltage return circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

An open circuit has been detected in the fuel metering valve battery voltage supply circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 3 - Check the power supply circuit.

Guided Step 3A - Inspect the fuel metering valve and engine fuel supply pump connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.
  • Disconnect the engine fuel supply pump from the engine harness.

Action

Inspect the engine harness and device connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the device or harness connector.

Clean the connector and pins.

Repair the damaged engine harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the battery supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.
  • Disconnect the engine fuel supply pump from the engine harness.
  • Turn keyswitch ON.

Action

Check the battery supply voltage at each component.

  • Measure the voltage between the fuel metering valve connector battery voltage SUPPLY pin and the fuel metering valve connector battery voltage RETURN pin.
  • Measure the voltage between the engine fuel supply pump connector battery voltage SUPPLY pin and the engine fuel supply pump connector battery voltage RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Voltage within 1 VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check for an open battery voltage supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.
  • Disconnect the engine fuel supply pump from the engine harness.
  • Turn keyswitch ON.

Action

Check for an open circuit at each component.

  • Measure the voltage between the fuel metering valve connector battery voltage SUPPLY pin and engine block ground.
  • Measure the voltage between the engine fuel supply pump connector battery voltage SUPPLY pin and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Voltage within 1 VDC of battery voltage?
YES NO

An open circuit has been detected in the fuel metering valve and/or engine fuel supply pump battery voltage return circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3D

Guided Step 3D - Inspect the ECM and engine harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspec the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3E

Guided Step 3E - Check the battery supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the battery supply voltage.

  • Measure the voltage between the fuel metering valve/engine fuel supply pump battery voltage SUPPLY in and RETURN pin at the ECM.

Use the circuit diagram or wiring diagram for connector pin identification.

Voltage within 1 VDC of battery voltage?
YES NO

An open circuit has been detected in the fuel metering valve and/or engine fuel supply pump battery voltage supply circuit.

Repair or replace the damage section of engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Check the data link 3 circuit.

Guided Step 4A - Inspect the engine fuel supply pump and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.

Action

Inspect the engine harness and fuel metering valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the fuel valve or harness connector.

Clean the connector and pins.

Repair the damaged engine harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.

Action

Measure the terminating resistance of the SAE J1939 data link 3.

  • Measure the resistance between the SAE J1939 data link 3 (+) wire and the J1939 data link 3 (-) wire at the fuel metering valve engine harness connector.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 to 70 ohms?
YES NO

An open circuit has been detected on the SAE J1939 data link 3 (+) or (-) wire between the ECM and the data link 3 backbone connection.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4C

Guided Step 4C - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4D

Guided Step 4D - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.

Action

Measure the terminating resistance of the SAE J1939 data link 3.

  • Measure the resistance between the SAE J1939 data link 3 (+) wire and the J1939 data link 3 (-) wire at the ECM engine harness connector.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 to 70 ohms?
YES NO
No Repair

Incorrect terminating resistance or an open circuit has been detected on the SAE J1939 data link 3 backbone connection.

Remove excess terminating resistors. Replace any damaged or missing terminating resistors.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the damage section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 29-Mar-2016


FAULT CODE 5115 - Aftertreatment 1 Diesel Exhaust Fluid Line Heater Relay - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Delphi® 96 Way Engine Control Module Connector | Refer to Procedure 019-505 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Line Heater Relay | Refer to Procedure 019-600 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Line Heater Time Delay Relay | Refer to Procedure 019-619 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box Circuit Breaker | Refer to Procedure 019-623 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box Resistor | Refer to Procedure 019-625 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5115 active?
 | STEP 1B. Check for diesel exhaust fluid (DEF) line heater relay fault codes. | Fault Code 3562, 3563 and 3713 active?
STEP 2. | Check the aftertreatment 1 DEF line heater circuit breakers and relays. |
 | STEP 2A. Test the aftertreatment 1 DEF line heater circuit breakers. | Circuit breakers within specifications?
 | STEP 2B. Test the aftertreatment 1 DEF line heater relays. | Aftertreatment 1 line heater relays within specification?
 | STEP 2C. Test the aftertreatment 1 DEF line heater time delay relays. | Aftertreatment 1 line heater time delay relays within specification?
STEP 3. | Check the harness. |
 | STEP 3A. Inspect the aftertreatment 1 connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
 | STEP 3E. Check for an open circuit. | Less than 10 ohms?
 | STEP 3F. Check for an open circuit. | Less than 10 ohms?
 | STEP 3G. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 3H. Check for a short to ground in the harness. | Greater than 100k ohms?
STEP 4. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 4A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault Code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5115 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for diesel exhaust fluid (DEF) line heater relay fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3562, 3563 and 3713 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment 1 DEF line heater circuit breakers and relays.

Guided Step 2A - Test the aftertreatment 1 DEF line heater circuit breakers.

Conditions

  • Turn keyswitch OFF.

Action

  • Test the aftertreatment 1 DEF line heater circuit breakers. Refer to Procedure 019-623 in the Associated Procedures Table.

Circuit breakers within specifications?
YES NO
No Repair

A damaged circuit breaker or harness has been detected. Replace circuit breaker or repair harness. Refer to Procedure 019-623 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Test the aftertreatment 1 DEF line heater relays.

Conditions

  • Turn keyswitch OFF.

Action

  • Test the aftertreatment 1 DEF line heater relays (K9, K10, and K11). Refer to Procedure 019-600 in the Associated Procedures Table.

Aftertreatment 1 line heater relays within specification?
YES NO
No Repair

A damaged line heater relay has been detected. Replace damaged relay. Refer to Procedure 019-600 in the Associated Procedures Table.

Go to 2C

Go to 5A

Guided Step 2C - Test the aftertreatment 1 DEF line heater time delay relays.

Conditions

  • Turn keyswitch OFF.

Action

  • Test the aftertreatment 1 DEF line heater time delay relays (K15 and K16). Refer to Procedure 019-619 in the Associated Procedures Table.

Aftertreatment 1 line heater time delay relays within specification?
YES NO
No Repair

A damaged line heater time delay relay has been detected. Replace damaged relay. Refer to Procedure 019-619 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the harness.

Guided Step 3A - Check the engine control module (ECM) and original equipment manufacturer (OEM) harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.

Action

Inspect the connector(s) for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.
  • For the aftertreatment junction box: Refer to Procedure 019-598 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF line heater RETURN pin in the aftertreatment junction box C5 connector and terminal A2 of the aftertreatment 1 DEF line heater relay (K9).

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all wire(s) in series to determine which one contains open circuit.

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF line heater SIGNAL pin in the aftertreatment junction box C5 connector and terminal 7 of the aftertreatment 1 DEF line heater relay (K11).
  • Measure the resistance between the aftertreatment 1 DEF line heater diagnostic SIGNAL pin in the aftertreatment junction box C5 connector and terminal 8 of the aftertreatment 1 DEF line heater relay (K11).

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all wire(s) in series to determine which one contains open circuit.

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.

Action

Check for an open circuit.

  • Measure the resistance between the G2 ground pin in the aftertreatment junction box to terminal A2 of the aftertreatment 1 DEF line heater relay (K10, K11, K15, and K16).

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all wire(s) in series to determine which one contains open circuit.

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3E

Go to 5A

Guided Step 3E - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.

Action

  • Measure the resistance between aftertreatment 1 line heater relay (K9) terminal 8 and the aftertreatment 1 line heater time delay relay (K15) terminal A1.
  • Measure the resistance between aftertreatment 1 line heater relay (K10) terminal 8 and the aftertreatment 1 line heater time delay relay (K16) terminal A1.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3F

Go to 5A

Guided Step 3F - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.

Action

  • Measure the resistance between aftertreatment 1 line heater time delay relay (K15) terminal 14 and the aftertreatment 1 line heater relay (K10) terminal A1.
  • Measure the resistance between aftertreatment 1 line heater time delay relay (K16) terminal 14 and the aftertreatment 1 line heater relay (K11) terminal A1.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3G

Go to 5A

Guided Step 3G - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.
  • Remove the aftertreatment 1 DEF line heater relay resistor (R1) from the aftertreatment junction box. Refer to Procedure 019-625 in the Associated Procedures Table.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit heater diagnostic SIGNAL pin in the Aftertreatment junction box C5 connector and all other pins in the connector.

Use a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all wire(s) in series to determine which one contains the short circuit.

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3H

Go to 5A

Guided Step 3H - Check for a short to ground in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit heater diagnostic SIGNAL pin in the aftertreatment junction box C5 connector to the G2 connector.

Use a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all wire(s) in series to determine which one contains the short circuit.

Repair or replace the damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine control module (ECM) and original equipment manufacturer (OEM) harness.

Guided Step 4A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector (J2) from ECM (1).

Action

Inspect the connector(s) for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-505 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector (J2) from ECM (1).
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit heater diagnostic SIGNAL pin in the OEM connector (J2) from ECM (1) and all other pins in the connector.

Use a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harness connections in series to determine which one contains the short circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process.

Repair complete

Last Modified: 05-Apr-2017


FAULT CODE 5116 - Aftertreatment 2 Diesel Exhaust Fluid Line Heater Relay - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Delphi® 96 Way Engine Control Module Connector | Refer to Procedure 019-505 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Line Heater Relay | Refer to Procedure 019-600 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box Resistor | Refer to Procedure 019-625 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 5116 inactive?
 | STEP 1B. Check for aftertreatment 2 diesel exhaust fluid (DEF) line heater relay fault codes. | Fault Code 4459 or 4461 active?
STEP 2. | Check the aftertreatment 2 DEF line heater relays. |
 | STEP 2A. Check the aftertreatment 2 DEF line heater relay. | Aftertreatment 2 DEF line heater relay within specifications?
 | STEP 2B. Check the aftertreatment 2 DEF line heater resistor. | Aftertreatment 2 DEF line heater resistor within specifications?
STEP 3. | Check the aftertreatment 2 harness. |
 | STEP 3A. Inspect the aftertreatment 2 connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
 | STEP 3E. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 4A. Inspect the aftertreatment 2 connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 4C. Check for an open circuit. | Less than 10 ohms?
 | STEP 4D. Inspect the OEM harness ECM connector pins. | Dirty or damaged pins?
 | STEP 4E. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 4F. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5116 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 1B

Guided Step 1B - Check for aftertreatment 2 DEF line heater relay fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4459 or 4461 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment 2 DEF line heater relays.

Guided Step 2A - Check the aftertreatment 2 DEF line heater relay.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment 2 DEF line heater relay (K14) from the aftertreatment junction box. Refer to Procedure 019-600 in the Associated Procedures Table.

Action

Test aftertreatment 2 DEF line heater relay.

Refer to Procedure 019-600 in the Associated Procedures Table.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure Refer to Procedure 019-360 in Section 19.

Aftertreatment 2 DEF line heater relay within specifications?
YES NO
No Repair

Replace the aftertreatment 2 DEF line heater relay (K14). Refer to Procedure 019-600 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Check the aftertreatment 2 DEF line heater resistor.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment 2 DEF line heater resistor (R9) from the aftertreatment junction box. Refer to Procedure 019-625 in the Associated Procedures Table.

Action

Check the aftertreatment 2 DEF line heater resistor.

  • Test aftertreatment 2 DEF line heater resistor. Refer to Procedure 019-625 in the Associated Procedures Table.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Aftertreatment 2 DEF line heater resistor within specifications?
YES NO
No Repair

Replace the aftertreatment 2 DEF line heater resistor (R9). Refer to Procedure 019-625 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the aftertreatment 2 harness.

Guided Step 3A - Inspect the aftertreatment 2 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.

Action

Inspect the connector(s) for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.
  • Remove the aftertreatment 2 DEF line heater relay resistor (R9) from the aftertreatment junction box. Refer to Procedure 019-625 in the Associated Procedures Table.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF line heater DIAGNOSTIC SIGNAL pin in the aftertreatment junction box C1 connector and all other pins in the connector.

Refer wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in aftertreatment junction box.

Troubleshoot all wire(s) in series to determine which one contains the short circuit.

Repair or replace the damaged section of harness.

Repair or replace the damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF line heater DIAGNOSTIC SIGNAL pin in the aftertreatment junction box C1 connector and terminal 8 of the aftertreatment 2 DEF line heater relay (K14).

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all wire(s) in series to determine which one contains open circuit.

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Install the aftertreatment 2 DEF line heater relay resistor (R9) in the aftertreatment junction box. Refer to Procedure 019-625 in the Associated Procedures Table.
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF line heater relay RETURN pin in the aftertreatment junction box connector C1 connector and aftertreatment 2 DEF line heater resistor (R9) terminal C.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all wires in series to determine which one contains open circuit.

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3E

Go to 5A

Guided Step 3E - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF line heater resistor (R9) terminal A and terminal 8 of the aftertreatment 2 DEF line heater relay (K14).

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all wires in series to determine which one contains open circuit.

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 -

Guided Step 4A - Inspect the aftertreatment 2 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness at the aftertreatment 2 connector.

Action

Inspect the connector(s) for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.
  • Disconnect the OEM harness at the aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF line heater DIAGNOSTIC SIGNAL pin in the aftertreatment 2 connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harness connections in series to determine which one contains the short circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-071 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.
  • Disconnect the OEM harness at the aftertreatment 2 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF line heater relay DIAGNOSTIC SIGNAL pin in the aftertreatment junction box C1 connector and the aftertreatment 2 DEF line heater relay DIAGNOSTIC SIGNAL pin in the aftertreatment 2 connector.
  • Measure the resistance between the aftertreatment 2 DEF line heater relay RETURN pin in the aftertreatment junction box C1 connector and the aftertreatment 2 DEF line heater relay RETURN pin in the aftertreatment 2 connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all harness connections in series to determine which one contains the open circuit.

Repair or replace damaged section of harness. Refer to Procedure 019-071 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Inspect the OEM harness ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector (J2) from ECM (2).

Action

Inspect the connector(s) for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-505 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4E

Guided Step 4E - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector (J2) from ECM (2).
  • Disconnect the OEM harness at the aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF line heater DIAGNOSTIC SIGNAL pin in the OEM connector (J2) from ECM (2) and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harness connections in series to determine which one contains the short circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4F

Go to 5A

Guided Step 4F - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector (J2) from ECM (2).
  • Disconnect the OEM harness at the aftertreatment 2 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF line heater DIAGNOSTIC SIGNAL pin in the OEM connector (J2) from ECM (2) and the aftertreatment 2 DEF line heater DIAGNOSTIC SIGNAL pin in the 47 Pin aftertreatment 2 connector.
  • Measure the resistance between the aftertreatment 2 DEF line heater RETURN pin in the OEM connector (J2) from ECM (2) and the aftertreatment 2 DEF line heater RETURN pin in the aftertreatment 2 connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all harness connections in series to determine which one contains open circuit.

Repair or replace damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Go to

Repair complete.

Last Modified: 27-Jan-2017


FAULT CODE 5117 - Aftertreatment 2 Diesel Exhaust Fluid Line Heater Relay - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Delphi® 96 Way Engine Control Module Connector | Refer to Procedure 019-505 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Line Heater Relay | Refer to Procedure 019-600 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Line Heater Time Delay Relay | Refer to Procedure 019-619 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box Circuit Breaker | Refer to Procedure 019-623 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box Resistor | Refer to Procedure 019-625 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5117 active?
 | STEP 1B. Check for diesel exhaust fluid (DEF) line heater relay fault codes. | Fault Code 4459, 4461 and 5116 active?
STEP 2. | Check the aftertreatment 2 DEF line heater circuit breakers and relays. |
 | STEP 2A. Test the aftertreatment 2 DEF line heater circuit breakers. | Circuit breakers within specifications?
 | STEP 2B. Test the aftertreatment 2 DEF line heater relays. | Aftertreatment 2 line heater relays within specification?
 | STEP 2C. Test the aftertreatment 2 DEF line heater time delay relays. | Aftertreatment 2 line heater time delay relays within specification?
STEP 3. | Check the harness. |
 | STEP 3A. Inspect the aftertreatment 2 connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
 | STEP 3E. Check for an open circuit. | Less than 10 ohms?
 | STEP 3F. Check for an open circuit. | Less than 10 ohms?
 | STEP 3G. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 3H. Check for a short to ground in the harness. | Greater than 100k ohms?
STEP 4. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 4A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault Code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5117 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for diesel exhaust fluid (DEF) line heater relay fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4459, 4461 and 5116 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment 2 DEF line heater circuit breakers and relays.

Guided Step 2A - Test the aftertreatment 2 DEF line heater circuit breakers.

Conditions

  • Turn keyswitch OFF.

Action

  • Test the aftertreatment 2 DEF line heater circuit breakers. Refer to Procedure 019-623 in the Associated Procedures Table.

Circuit breakers within specifications?
YES NO
No Repair

A damaged circuit breaker or harness has been detected. Replace circuit breaker or repair harness. Refer to Procedure 019-623 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Test the aftertreatment 2 DEF line heater relays.

Conditions

  • Turn keyswitch OFF.

Action

  • Test the aftertreatment 2 DEF line heater relays (K12, K13, and K14). Refer to Procedure 019-600 in the Associated Procedures Table.

Aftertreatment 2 line heater relays within specification?
YES NO
No Repair

A damaged line heater relay has been detected. Replace damaged relay. Refer to Procedure 019-600 in the Associated Procedures Table.

Go to 2C

Go to 5A

Guided Step 2C - Test the aftertreatment 2 DEF line heater time delay relays.

Conditions

  • Turn keyswitch OFF.

Action

  • Test the aftertreatment 2 DEF line heater time delay relays (K17 and K18). Refer to Procedure 019-619 in the Associated Procedures Table.

Aftertreatment 2 line heater time delay relays within specification?
YES NO
No Repair

A damaged line heater time delay relay has been detected. Replace damaged relay. Refer to Procedure 019-619 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the harness.

Guided Step 3A - Inspect the aftertreatment 2 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.

Action

Inspect the connector(s) for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.
  • For the aftertreatment junction box: Refer to Procedure 019-598 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF line heater RETURN pin in the aftertreatment junction box C1 connector and terminal A2 of the aftertreatment 2 DEF line heater relay (K12).

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all wire(s) in series to determine which one contains open circuit.

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF line heater SIGNAL pin in the aftertreatment junction box C1 connector and terminal 7 of the aftertreatment 2 DEF line heater relay (K14).
  • Measure the resistance between the aftertreatment 2 DEF line heater diagnostic SIGNAL pin in the aftertreatment junction box C1 connector and terminal 8 of the aftertreatment 2 DEF line heater relay (K14).

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all wire(s) in series to determine which one contains open circuit.

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.

Action

Check for an open circuit.

  • Measure the resistance between the G2 ground pin in the aftertreatment junction box to terminal A2 of the aftertreatment 2 DEF line heater relay (K13, K14, K17, and K18).

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all wire(s) in series to determine which one contains open circuit.

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3E

Go to 5A

Guided Step 3E - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.

Action

  • Measure the resistance between aftertreatment 2 line heater relay (K12) terminal 8 and the aftertreatment 2 line heater time delay relay (K17) terminal A1.
  • Measure the resistance between aftertreatment 2 line heater relay (K13) terminal 8 and the aftertreatment 2 line heater time delay relay (K18) terminal A1.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3F

Go to 5A

Guided Step 3F - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.

Action

  • Measure the resistance between aftertreatment 2 line heater time delay relay (K17) terminal 14 and the aftertreatment2 line heater relay (K13) terminal A1.
  • Measure the resistance between aftertreatment 2 line heater time delay relay (K18) terminal 14 and the aftertreatment 2 line heater relay (K14) terminal A1.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3G

Go to 5A

Guided Step 3G - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.
  • Remove the aftertreatment 2 DEF line heater relay resistor (R9) from the aftertreatment junction box. Refer to Procedure 019-625 in the Associated Procedures Table.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit heater diagnostic SIGNAL pin in the aftertreatment junction box C1 connector and all other pins in the connector.

Use a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all wire(s) in series to determine which one contains the short circuit.

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3H

Go to 5A

Guided Step 3H - Check for a short to ground in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit heater diagnostic SIGNAL pin in the aftertreatment junction box C1 connector to the G2 connector.

Use a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all wire(s) in series to determine which one contains the short circuit.

Repair or replace the damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine control module (ECM) and original equipment manufacturer (OEM) harness.

Guided Step 4A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector (J2) from ECM (2).

Action

Inspect the connector(s) for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-505 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector (J2) from ECM (2).
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit heater diagnostic SIGNAL pin in the OEM connector (J2) from ECM (2) and all other pins in the connector.

Use a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harness connections in series to determine which one contains the short circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process.

Repair complete

Last Modified: 05-Apr-2017


FAULT CODE 5178 - Crankcase Pressure 2 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Codes 4696 and 4697. | Fault Code 4696 or 4697 active?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the crankcase pressure 2 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the engine control module (ECM) and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the engine harness. | Less than 5 ohms?
 | STEP 2D. Check the sensor accuracy. | Crankcase pressure 2 sensor within specifications found in Procedure 019-445 in the Associated Procedures Table?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Codes 4696 and 4697.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4696 or 4697 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the crankcase pressure 2 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure 2 sensor from the engine harness.

Action

Inspect the engine harness and crankcase pressure 2 sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness connector and ECM pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the crankcase pressure 2 sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector crankcase pressure 2 sensor SIGNAL pin and the engine harness crankcase pressure 2 sensor connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

High resistance has been detected on the crankcase pressure 2 sensor signal circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the sensor accuracy.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the crankcase pressure 2 sensor accuracy.

Refer to Procedure 019-445 in the Associated Procedures Table.

Crankcase pressure 2 sensor within specifications found in Procedure 019-445 in the Associated Procedures Table?
YES NO
No Repair

Replace the crankcase pressure 2 sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process.

Repair complete.

Last Modified: 12-May-2017


FAULT CODE 5247 - Aftertreatment 1 SCR Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K113 | 4388663
Turbocharger Turbine Seal Leaks | Refer to Procedure 010-049 | QSK95 CM2350 K113 | 4388663
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active selective catalytic reduction (SCR) temperature sensor fault codes. | Fault Code 4152, 4159, 4164, 4165, or 4261 active or inactive counts?
STEP 2. | Check the diesel exhaust fluid (DEF) for contamination. |
 | STEP 2A. Check the DEF for contamination. | DEF contaminated?
STEP 3. | Check the fuel system. |
 | STEP 3A. Check for an injector misfire. | Engine misfire detected?
STEP 4. | Check the turbine outlet. |
 | STEP 4A. Inspect the turbine outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active SCR temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4152, 4159, 4164, 4165, or 4261 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the DEF for contamination.

Guided Step 2A - Check the DEF for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF for contamination.

  • Refer to Procedure 011-056 in the Associated Procedures Table.

DEF contaminated?
YES NO

Drain the DEF tank. Refer to Procedure 011-056 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the fuel system.

Guided Step 3A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine. Operate at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is operating at low idle.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to check for a cylinder misfire.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

  • Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the turbine outlet.

Guided Step 4A - Inspect the turbine outlet for oil or fuel.

Conditions

  • Remove the turbine outlet bellows one at a time.

Action

Check for signs of moisture in the turbine outlet. Be sure to inspect all four.

  • Inspect the turbine outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine. Refer to Procedure 010-049 in the Associated Procedures Table.

Engine oil or fuel contamination found in the turbine outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 31-Mar-2016


FAULT CODE 5261 - Aftertreatment 2 SCR Catalyst System - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Active or inactive counts of Fault Code 5725?
 | STEP 1B. Check for active fault codes. | Fault Code 5261 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 5725?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 5725.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5261 active?
YES NO

This fault code indicates the incorrect aftertreatment SCR system has been installed with the engine.

Verify the correct aftertreatment temperature sensor module and aftertreatment SCR system has been installed with the engine.

If the incorrect aftertreatment SCR system has been installed, replace it with the correct aftertreatment SCR system. Refer to Procedure 011-036 in the Associated Procedures Table.

 No Repair

Repair complete.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Go to

Repair complete.

Last Modified: 27-Jan-2017


FAULT CODE 5329 - Engine Turbocharger Wastegate Actuator 1 Position - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Turbocharger Wastegate Assembly | Refer to Procedure 011-097 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5329 active?
STEP 2. | Check the turbocharger wastegate 1 motor and circuit. |
 | STEP 2A. Inspect the turbocharger wastegate 1 motor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the turbocharger wastegate 1 motor. | Greater than 5 ohms?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the turbocharger wastegate 1 motor signal and return circuit. | Less than 10 ohms?
 | STEP 3C. Check for an active fault code. | Fault Code 5329 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | Dirty or damaged pins?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5329 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the turbocharger wastegate 1 motor and circuit.

Guided Step 2A - Inspect the turbocharger wastegate 1 motor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger wastegate 1 from the engine harness.

Action

Inspect the engine harness and turbocharger wastegate 1 motor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the motor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the turbocharger wastegate 1 motor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger wastegate 1 from the engine harness.

Action

Check the turbocharger wastegate 1 signal and return circuit.

  • Measure the resistance from the turbocharger wastegate 1 motor SIGNAL A pin to the turbocharger wastegate 1 motor SIGNAL B pin at the turbocharger wastegate 1 connector.
  • Measure the resistance from the turbocharger wastegate 1 motor SIGNAL A pin to the turbocharger wastegate 1 motor SIGNAL C pin at the turbocharger wastegate 1 connector.
  • Measure the resistance from the turbocharger wastegate 1 motor SIGNAL B pin to the turbocharger wastegate 1 motor SIGNAL C pin at the turbocharger wastegate 1 connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 5 ohms?
YES NO

An open circuit has been detected in the turbocharger wastegate 1 motor.

Replace the turbocharger wastegate 1.

Refer to Procedure 011-097 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the turbocharger wastegate 1 motor signal and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the turbocharger wastegate 1 motor from the engine harness.

Action

Check the turbocharger wastegate 1 motor signal and return circuit.

  • Measure the resistance from the turbocharger wastegate 1 SIGNAL A pin at the turbocharger wastegate 1 motor engine harness connector to the turbocharger wastegate 1 motor SIGNAL A pin at the engine harness ECM connector.
  • Measure the resistance from the turbocharger wastegate 1 SIGNAL B pin at the turbocharger wastegate 1 motor engine harness connector to the turbocharger wastegate 1 motor SIGNAL B pin at the engine harness ECM connector.
  • Measure the resistance from the turbocharger wastegate 1 SIGNAL C pin at the turbocharger wastegate 1 motor engine harness connector to the turbocharger wastegate 1 motor SIGNAL C pin at the engine harness ECM connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Turn the keyswitch OFF for 1 minute and then turn the keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 5329 active?
YES NO

A stuck open turbocharger wastegate 1 has been detected.

Replace the turbocharger wastegate.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 29-Mar-2016


FAULT CODE 5331 - Engine Turbocharger Wastegate Actuator 1 Position - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Turbocharger Wastegate Assembly | Refer to Procedure 011-097 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for turbocharger wastegate position sensor fault codes. | Fault Code 545, 3925, 3969, or 3971 active or inactive counts?
STEP 2. | Check the turbocharger wastegate circuit. |
 | STEP 2A. Inspect the turbocharger wastegate and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for active fault codes. | Fault Code 5329 active?
STEP 3. | Check the turbocharger wastegate operation. |
 | STEP 3A. Monitor the turbocharger wastegate position. | Fault Code 5331 becomes active after 1 minute?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for turbocharger wastegate position sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 545, 3925, 3969, or 3971 active or inactive counts?
YES | NO
No Repair | No Repair

Go to Fault Code 3925 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the turbocharger wastegate circuit.

Guided Step 2A - Inspect the turbocharger wastegate and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger wastegate from the engine harness.

Action

Inspect the engine harness and turbocharger wastegate connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for active fault codes.

Conditions

  • Turn keyswitch OFF for 10 seconds.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5329 active?
YES NO

A stuck open turbocharger wastegate has been detected.

Replace the turbocharger wastegate.

  • Refer to Procedure 011-097 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the turbocharger wastegate operation.

Guided Step 3A - Monitor the turbocharger wastegate position.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the turrbocharger wastegate position.

  • Leave the keyswitch in the ON position for 2 minutes.
  • Do not start the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5331 becomes active after 1 minute?
YES NO

Replace the turbocharger wastegate assembly.

  • Refer to Procedure 011-097 in the Associated Procedures Table.

The restriction in the turbocharger wastegate has been removed. No repair is necessary.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 29-Mar-2016


FAULT CODE 5332 - Engine Turbocharger Wastegate Actuator 2 Position - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Turbocharger Wastegate Assembly | Refer to Procedure 011-097 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5332 active?
STEP 2. | Check the turbocharger wastegate 2 motor and circuit. |
 | STEP 2A. Inspect the turbocharger wastegate 2 motor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the turbocharger wastegate 2 motor. | Any measurements greater than 5 ohms?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the turbocharger wastegate 2 motor signal and return circuit. | Less than 10 ohms?
 | STEP 3C. Check for an active fault code. | Fault Code 5332 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5332 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the turbocharger wastegate 2 motor and circuit.

Guided Step 2A - Inspect the turbocharger wastegate 2 motor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger wastegate 2 from the engine harness.

Action

Inspect the engine harness and turbocharger wastegate 2 motor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the motor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the turbocharger wastegate 2 motor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger wastegate 2 from the engine harness.

Action

Check the turbocharger wastegate 2 motor signal and return circuit.

  • Measure the resistance from the turbocharger wastegate 2 motor SIGNAL A pin to the turbocharger wastegate 2 motor SIGNAL B pin at the turbocharger wastegate 2 connector.
  • Measure the resistance from the turbocharger wastegate 2 motor SIGNAL pin A to the turbocharger wastegate 2 motor SIGNAL C pin at the turbocharger wastegate 2 connector.
  • Measure the resistance from the turbocharger wastegate 2 motor SIGNAL B pin to the turbocharger wastegate 2 motor SIGNAL C pin at the turbocharger wastegate 2 connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Any measurements greater than 5 ohms?
YES NO

An open circuit has been detected in the turbocharger wastegate 2 motor.

Replace the turbocharger wastegate 2. Refer to Procedure 011-097 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the turbocharger wastegate 2 motor signal and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the turbocharger wastegate 2 from the engine harness.

Action

Check the turbocharger wastegate 2 motor signal and return circuit.

  • Measure the resistance from the turbocharger 2 motor SIGNAL A pin at the turbocharger wastegate 2 engine harness connector to the turbocharger wastegate 2 motor SIGNAL A pin at the engine harness ECM connector.
  • Measure the resistance from the turbocharger 2 motor SIGNAL B pin at the turbocharger wastegate 2 engine harness connector to the turbocharger wastegate 2 motor SIGNAL B pin at the engine harness ECM connector.
  • Measure the resistance from the turbocharger 2 motor SIGNAL C pin at the turbocharger wastegate 2 engine harness connector to the turbocharger wastegate 2 motor SIGNAL C pin at the engine harness ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Turn keyswitch OFF for 1 minute. Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5332 active?
YES NO

A stuck open turbocharger wastegate 2 has been detected.

Replace the turbocharger wastegate. Refer to Procedure 011-097 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 29-Mar-2016


FAULT CODE 5333 - Engine Turbocharger Wastegate Actuator 2 Position - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Turbocharger Wastegate Assembly | Refer to Procedure 011-097 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for turbocharger wastegate 1 position sensor fault codes. | Fault Code 251, 3972, 3973 or 3974 active or inactive counts?
STEP 2. | Check the turbocharger wastegate circuit. |
 | STEP 2A. Inspect the turbocharger wastegate and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for active fault codes. | Fault Code 5332 active?
STEP 3. | Check the turbocharger wastegate operation. |
 | STEP 3A. Monitor the turbocharger wastegate position. | Fault Code 5333 becomes active after 1 minute?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for turbocharger wastegate 2 position sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 251, 3972, 3973 or 3974 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the turbocharger wastegate circuit.

Guided Step 2A - Inspect the turbocharger wastegate and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger wastegate 2 from the engine harness.

Action

Inspect the engine harness and turbocharger wastegate 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for active fault codes.

Conditions

  • Turn keyswitch OFF for 10 seconds.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5332 active?
YES NO

A stuck open turbocharger wastegate 2 has been detected.

Replace the turbocharger wastegate assembly.

  • Refer to Procedure 011-097 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the turbocharger wastegate operation.

Guided Step 3A - Monitor the turbocharger wastegate position.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Leave the keyswitch in the ON position for 2 minutes.

  • Do not start the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5333 becomes active after 1 minute?
YES NO

Replace the turbocharger wastegate 2 assembly.

  • Refer to Procedure 011-097 in the Associated Procedures Table.

The restriction in the turbocharger wastegate has been removed. No repair is necessary.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 29-Mar-2016


FAULT CODE 5725 - Aftertreatment 2 Selective Catalytic Reduction Temperature Sensor Module - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Aftertreatment Sensor Power Relay | Refer to Procedure 019-607 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5725 active?
 | STEP 1B. Check for active J1939 network 4 fault codes. | Fault Code 4437 active?
 | STEP 1C. Check for active NOx fault codes. | Fault Codes 3988 and 4145 both active?
STEP 2. | Check the aftertreatment 2 selective catalytic reduction (SCR) temperature sensor module and circuit. |
 | STEP 2A. Inspect the aftertreatment 2 SCR temperature sensor module and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment 2 SCR temperature sensor module. | Voltage within 1 VDC of engine control module (ECM) supply voltage?
 | STEP 2C. Check the J1939 terminating resistance. | 50 to 70 ohms?
 | STEP 2D. Check for an open circuit in the aftertreatment 2 SCR temperature sensor module voltage supply. | Voltage within 1 VDC of supply voltage?
STEP 3. | Check the harness. |
 | STEP 3A. Inspect the aftertreatment 2 SCR temperature sensor module and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the voltage to the aftertreatment 2 SCR temperature sensor module. | Voltage within 1 VDC of supply voltage?
 | STEP 3C. Check the voltage to the aftertreatment 2 SCR temperature sensor module. | Voltage within 1 VDC of supply voltage?
 | STEP 3D. Inspect aftertreatment power relay and connector pins. | Dirty or damaged pins?
 | STEP 3E. Check the voltage to the aftertreatment power relay. | Voltage within 1 VDC of supply voltage?
 | STEP 3F. Check the aftertreatment power relay. | Less than 10 ohms?
STEP 4. | Check the J1939 data link 4. |
 | STEP 4A. Check the J1939 terminating resistance on the original equipment manufacturer (OEM) harness. | 110 to 130 ohms?
 | STEP 4B. Check the J1939 terminating resistance on the engine harness. | 110 to 130 ohms?
 | STEP 4C. Inspect the engine control module (ECM) and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 4D. Check for an open circuit in the J1939 data link harness. | All measurements less than 10 ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5725 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active J1939 network 4 fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4437 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for active NOx sensor fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3988 and 4145 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the aftertreatment 2 SCR temperature sensor module and circuit.

Guided Step 2A - Inspect the aftertreatment 2 SCR temperature sensor module and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 SCR temperature sensor module from the OEM harness.

Action

Inspect the OEM harness and aftertreatment 2 SCR temperature sensor module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged OEM harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

Replace the aftertreatment SCR temperature sensor module only when there are damaged pins. Refer to Procedure 019-449 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment 2 SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 SCR temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment 2 SCR temperature sensor module.

  • Measure the voltage between the aftertreatment 2 SCR temperature sensor module ECM supply voltage supply circuit and the aftertreatment 2 SCR temperature sensor module return circuit at the wiring harness sensor connector.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of ECM supply voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2D

Guided Step 2C - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 SCR temperature sensor module from the OEM harness.

Action

Measure the terminating resistance of the Society of Automotive Engineers (SAE) J1939 data link.

  • Measure the resistance between the SAE J1939 data link (+) wire and the J1939 data link (-) wire at the aftertreatment 2 SCR temperature sensor module OEM harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 to 70 ohms?
YES NO

Replace the aftertreatment 2 SCR temperature sensor module.

Refer to Procedure 019-449 in the Associated Procedures Table.

An open circuit has been detected on the SAE J1939 data link (+) or (-) wire between the SCR temperature sensor module and the data link backbone connection.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Go to 5A

Go to 5A

Guided Step 2D - Check for an open circuit in the aftertreatment 2 SCR temperature sensor module voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 SCR temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure the voltage from the aftertreatment 2 SCR temperature sensor module supply voltage SUPPLY pin of the OEM harness to the engine block ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Voltage within 1 VDC of supply voltage?
YES NO

An open circuit has been detected in the aftertreatment 2 SCR temperature sensor module supply voltage return circuit.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the damaged section of harness.

  • Refer to Procedure 019-071 in Section 19 for the OEM harness.
  • Refer to Procedure 019-043 in the Associated Procedures Table for the engine harness.

An open circuit has been detected in the aftertreatment 2 SCR temperature sensor module supply voltage supply circuit between the aftertreatment power relay and the SCR temperature sensor module.

Check for a blown or missing fuse in the aftertreatment 2 SCR temperature sensor module supply voltage supply circuit.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • Refer to Procedure 019-071 in Section 19 for the OEM harness.
  • Refer to Procedure 019-043 in the Associated Procedures Table for the engine harness.

Go to 5A

Go to 5A

Guided Step 3 - Check the harness.

Guided Step 3A - Inspect the aftertreatment 2 SCR temperature sensor module and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM harness.

Action

Inspect the OEM harness and aftertreatment 2 SCR temperature sensor module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged OEM harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

Replace aftertreatment SCR temperature sensor module only when there are damaged pins. Refer to Procedure 019-449 in Section 19.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the voltage to the aftertreatment 2 SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 SCR temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment 2 SCR temperature sensor module.

  • Measure the voltage between the aftertreatment 2 SCR temperature sensor module supply voltage supply circuit and the aftertreatment 2 SCR temperature sensor module return circuit at the wiring harness connector.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of supply voltage?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the voltage to the aftertreatment 2 SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 SCR temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment 2 SCR temperature sensor module.

  • Measure the voltage from the aftertreatment 2 SCR temperature sensor module supply voltage SUPPLY pin of the OEM harness SCR temperature sensor module connector to the ECM power supply ground circuit.

Voltage within 1 VDC of supply voltage?
YES NO

An open circuit has been detected in the aftertreatment 2 SCR temperature sensor module supply voltage return circuit.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the damaged section of harness.

  • Refer to Procedure 019-071 in Section 19 for the OEM harness.
  • Refer to Procedure 019-043 in the Associated Procedures Table for the engine harness.

No Repair

Go to 5A

Go to 3D

Guided Step 3D - Inspect the aftertreatment power relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the harness.

Action

Inspect the harness and aftertreatment power relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the relay or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace aftertreatment power relay only when there are damaged pins.

Refer to Procedure 019-607 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3E

Guided Step 3E - Check the voltage to the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment power relay.

  • Measure the voltage between the aftertreatment power relay supply voltage SUPPLY pin in the aftertreatment power relay connector of the engine harness and the ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Voltage within 1 VDC of supply voltage?
YES NO
No Repair

An open circuit has been detected in the aftertreatment power supply voltage supply circuit before the power relay.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table for the engine harness.

Go to 3F

Go to 5A

Guided Step 3F - Check the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.

Action

Check for a damaged aftertreatment power relay.

  • Install a jumper wire from pin 85 on the aftertreatment power relay to supply voltage + and connect a jumper wire from pin 86 on the aftertreatment power relay to ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.
  • Measure the resistance between pin 30 and pin 87 on the aftertreatment power relay.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

An open circuit or short circuit-to-ground has been detected in the aftertreatment 2 SCR temperature sensor module power supply circuit.

This could be caused by:

  • Blown in-line fuse on the SCR temperature sensor module power supply circuit.
  • Open circuit or short-to-ground in the SCR temperature sensor module power supply circuit.

Replace the in-line fuse if it is blown.

Troubleshoot all harnesses connected in series to determine which one contains the open or shorted circuit. Refer to Procedure 019-598in the Associated Procedures Table if equipped with an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the damaged section of harness.

  • Refer to Procedure 019-071 in Section 19 for the OEM harness.
  • Refer to Procedure 019-043 in the Associated Procedures Table for the engine harness.

Replace the aftertreatment power relay.

Go to 5A

Go to 5A

Guided Step 4 - Check the J1939 data link 4.

Guided Step 4A - Check the J1939 terminating resistance on the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness at the 47 pin aftertreatment 2 connector.

Action

Measure the terminating resistance of the SAE J1939 data link 4.

  • Measure the resistance between the SAE J1939 data link 4 (+) wire and the J1939 data link 4 (-) wire at the 47 pin aftertreatment 2 OEM harness connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

110 to 130 ohms?
YES NO
No Repair

Incorrect terminating resistance or an open circuit has been detected on the SAE J1939 data link 4 circuit in the OEM harness.

  • Remove excess terminating resistors. Replace any damaged or missing terminating resistor.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the damaged section of the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check the J1939 terminating resistance on the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness at the 47 pin aftertreatment 2 connector.

Action

Measure the terminating resistance of the SAE J1939 data link 4.

  • Measure the resistance between the SAE J1939 data link 4 (+) wire and the J1939 data link 4 (-) wire at the engine side 47 pin aftertreatment 2 connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

110 to 130 ohms?
YES NO
No Repair

Incorrect terminating resistance or an open circuit has been detected on the SAE J1939 data link 4 circuit in the engine harness.

  • Remove excess terminating resistors. Replace any damaged or missing terminating resistor.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of the OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace ECM only when there are damaged pins. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 5A

Go to 4D

Guided Step 4D - Check for an open circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness and engine harness at the aftertreatment 2 connector.
  • Disconnect the OEM connector from the ECM.

Action

Check for an open circuit in the J1939 data link 4.

  • Measure the resistance between the SAE J1939 data link 4 (+) wire at the engine harness aftertreatment 2 connector and the SAE J1939 data link 4 (+) wire at the ECM OEM connector.
  • Measure the resistance between the SAE J1939 data link 4 (−) wire at the engine harness aftertreatment 2 connector and the SAE J1939 data link 4 (−) wire at the ECM OEM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

All measurements less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the J1939 data link 4.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 31-Mar-2016


FAULT CODE 5726 - Aftertreatment 2 Selective Catalytic Reduction Temperature Sensor Module - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active selective catalytic reduction (SCR) temperature sensor fault codes. | Fault Code 5725, 5727, 5728 or 5731 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active selective catalytic reduction (SCR) temperature sensor fault codes.

Conditions

  • Turn the keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 5725, 5727, 5728 or 5731 active?
YES NO
No Repair

A malfunctioning aftertreatment 2 SCR temperature sensor module has been detected.

Replace the aftertreatment 2 SCR temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 13-Apr-2016


FAULT CODE 5727 - Aftertreatment 2 Selective Catalytic Reduction Temperature Sensor Module - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5727 active?
 | STEP 1B. Check for active ECM power supply voltage fault codes. | Fault Code 441 or 442 active?
STEP 2. | Check the aftertreatment 2 selective catalytic reduction (SCR) temperature sensor module circuit. |
 | STEP 2A. Inspect aftertreatment 2 SCR temperature sensor module and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment 2 SCR temperature sensor module. | Voltage greater than 30 VDC?
 | STEP 2C. Check for correct adjustable parameter settings. | Electrical System Voltage parameter correct for the engine configuration?
 | STEP 2D. Check for correct aftertreatment 2 SCR temperature sensor module. | Aftertreatment 2 SCR temperature sensor module is the correct sensor for the engine configuration?
 | STEP 2E. Check the condition of the aftertreatment 2 SCR temperature sensor module. | Fault Code 5727 active?
STEP 3. | Check the voltage. |
 | STEP 3A. Check the voltage. | Voltage greater than 30 VDC?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5727 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active ECM power supply voltage fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and let it idle for 1 minute.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 or 442 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment 2 selective catalytic reduction (SCR) temperature sensor module circuit.

Guided Step 2A - Inspect the aftertreatment SCR temperature sensor module and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 SCR temperature sensor module from the OEM harness.

Action

Inspect the OEM harness and aftertreatment 2 SCR temperature sensor module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

Replace the aftertreatment 2 SCR temperature sensor module only when there are damaged pins. Refer to Procedure 019-449 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment 2 SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 SCR temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment 2 SCR temperature sensor module.

  • Measure the voltage between the aftertreatment 2 SCR temperature sensor module ECM power supply voltage supply circuit and the aftertreatment 2 SCR temperature sensor module ECM power supply voltage return circuit at the aftertreatment 2 SCR temperature sensor module wiring harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage greater than 30 VDC?

YES | NO
No Repair | No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine configuration.
  • To check the voltage configuration of the engine, disconnect the OEM connector from the ECM and measure the voltage from the ECM voltage SUPPLY (+) pin of the OEM harness ECM connector to ECM power supply ground. Refer to Procedure 019-610 in the Associated Procedures Table.

Electrical System Voltage parameter correct for the engine configuration?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine configuration.

Go to 2D

Go to 4A

Guided Step 2D - Check for correct aftertreatment 2 SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Remove aftertreatment 2 SCR temperature sensor module.

Action

Verify the aftertreatment 2 SCR temperature sensor module is correct for the engine configuration.

The aftertreatment 2 SCR temperature sensor module is available in 12 volt or 24 volt versions.

Aftertreatment 2 SCR temperature sensor module is the correct sensor for the engine configuration?
YES NO
No Repair

Replace the aftertreatment 2 SCR temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Check the condition of the aftertreatment 2 SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 2 SCR temperature sensor module.
  • Start and idle the engine.

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

Fault Code 5727 active?
YES NO

A malfunctioning aftertreatment 2 SCR temperature sensor module has been detected.

Replace the aftertreatment 2 SCR temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the voltage.

Guided Step 3A - Check the voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the voltage of the ECM power supply or power source.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage greater than 30 VDC?
YES NO

Incorrect voltage configuration has been detected.

  • See equipment manufacturer service information for correct voltage configurations.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 13-Apr-2016


FAULT CODE 5728 - Aftertreatment 2 Selective Catalytic Reduction Temperature Sensor Module - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5728 active?
 | STEP 1B. Check for active ECM power supply voltage fault codes. | Fault Code 441 or 442 active?
STEP 2. | Check the aftertreatment 2 selective catalytic reduction (SCR) temperature sensor module circuit. |
 | STEP 2A. Inspect aftertreatment 2 SCR temperature sensor module and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment SCR temperature sensor module. | Voltage within 1 VDC of supply voltage?
 | STEP 2C. Check for correct adjustable parameter settings. | Electrical System Voltage parameter correct for the engine configuration?
 | STEP 2D. Check for correct aftertreatment SCR temperature sensor module. | Aftertreatment 2 SCR temperature sensor module is the correct sensor for the engine configuration?
 | STEP 2E. Check the condition of the aftertreatment 2 SCR temperature sensor module. | Fault Code 5728 active?
STEP 3. | Check the harness. |
 | STEP 3A. Check the connections. | Connections tight and corrosion-free?
 | STEP 3B. Check the voltage to the aftertreatment 2 SCR temperature sensor module. | Voltage within 1 VDC of supply voltage?
 | STEP 3C. Inspect aftertreatment power relay and connector pins. | Dirty or damaged pins?
 | STEP 3D. Check the voltage to the aftertreatment power relay. | Voltage within 1 VDC of supply voltage?
 | STEP 3E. Check the aftertreatment power relay. | Less than 10 ohms?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5728 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active ECM power supply voltage fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and let it idle for 1 minute.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 or 442 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment 2 SCR temperature sensor module circuit.

Guided Step 2A - Inspect aftertreatment 2 SCR temperature sensor module and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 SCR temperature sensor module from the original equipment manufacturer (OEM) harness.

Action

Inspect the OEM harness and aftertreatment 2 SCR temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

Replace aftertreatment SCR temperature sensor module only when there are damaged pins. Refer to Procedure 019-449 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment 2 SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 SCR temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment 2 SCR temperature sensor module.

  • Measure the voltage between the aftertreatment 2 SCR temperature sensor module ECM power supply voltage supply circuit and the aftertreatment 2 SCR temperature sensor module ECM power supply voltage return circuit at the aftertreatment 2 SCR temperature sensor module wiring harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of supply voltage?

YES | NO
No Repair | No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine configuration.

To check the voltage configuration of the engine, disconnect the OEM connector from the ECM and measure the voltage from the ECM power supply voltage SUPPLY (+) pin of the OEM harness ECM connector to ECM power supply ground. Refer to Procedure 019-610 in the Associated Procedures Table.

Electrical System Voltage parameter correct for the engine configuration?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine configuration.

Go to 2D

Go to 4A

Guided Step 2D - Check for correct aftertreatment 2 SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Remove aftertreatment 2 SCR temperature sensor module.

Action

Verify the aftertreatment 2 SCR temperature sensor module is correct for the engine configuration.

The aftertreatment 2 SCR temperature sensor module is available in 12 volt or 24 volt versions.

Aftertreatment 2 SCR temperature sensor module is the correct sensor for the engine configuration?
YES NO
No Repair

Replace the aftertreatment 2 SCR temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Check the condition of the aftertreatment 2 SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 2 SCR temperature sensor module.
  • Start and idle the engine.

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

Fault Code 5728 active?
YES NO

A malfunctioning aftertreatment 2 SCR temperature sensor module has been detected.

Replace the aftertreatment 2 SCR temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the harness.

Guided Step 3A - Check the connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the ECM power supply or power connections.

  • Check the ECM power supply or power source terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten any loose connections and clean the terminals. See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Check the voltage to the aftertreatment 2 SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 SCR temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment 2 SCR temperature sensor module.

  • Measure the voltage from the aftertreatment 2 SCR temperature sensor module ECM power supply voltage SUPPLY pin of the OEM harness SCR temperature sensor module connector to ECM power supply ground.

Voltage within 1 VDC of supply voltage?
YES NO
No Repair

An open circuit has been detected in the aftertreatment 2 SCR temperature sensor module ECM power supply voltage return circuit.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.
  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect aftertreatment power relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the harness.

Action

Inspect the harness and aftertreatment power relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the relay or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the aftertreatment power relay only when there are damaged pins. Refer to Procedure 019-598 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check the voltage to the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment power relay.

  • Measure the voltage between the aftertreatment power relay ECM power supply voltage SUPPLY pin in the aftertreatment power relay connector of the engine harness and ECM power supply ground.

Voltage within 1 VDC of supply voltage?
YES NO

An open circuit has been detected in the aftertreatment power ECM power supply voltage supply circuit before the power relay.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of harness.

  • For the OEM harness. Refer to Procedure 019-071 in Section 19.
  • For the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3E

Guided Step 3E - Check the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.

Action

Check for a damaged aftertreatment power relay.

  • Install a jumper wire from pin 85 on the aftertreatment power relay to ECM power supply + and connect a jumper wire from pin 86 on the aftertreatment power relay to ECM power supply ground. Refer to Procedure 019-610 in the Associated Procedures Table.
  • Measure the resistance between pin 30 and pin 87 on the aftertreatment power relay.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

An open circuit or short circuit to ground has been detected in the aftertreatment power ECM power supply voltage supply circuit before the power relay.

Possible causes include:

  • Blown in-line fuse on the aftertreatment power relay.
  • Open circuit or short circuit to ground in the aftertreatment power relay.

Replace the in-line fuse, if it is blown.

Troubleshoot all harnesses connected in series to determine which one contains the open or short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, epair or replace the damaged section of harness.

Repair or replace the damaged section of harness.

  • For the OEM harness. Refer to Procedure 019-071 in Section 19.
  • For the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the aftertreatment power relay.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 13-Apr-2016


FAULT CODE 5729 - Aftertreatment 2 Selective Catalytic Reduction Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 5729 active or more than three inactive counts?
STEP 2. | Check the aftertreatment 2 selective catalytic reduction (SCR) temperature sensor module. |
 | STEP 2A. Make sure that the aftertreatment 2 SCR temperature sensor module is properly mounted. | Aftertreatment 2 SCR temperature sensor module properly installed?
 | STEP 2B. Check for obstructed or restricted air flow to the aftertreatment 2 SCR temperature sensor module. | Signs of air flow restriction or excessive heat to temperature sensor module?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5729 active or more than three inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the aftertreatment 2 SCR temperature sensor module.

Guided Step 2A - Make sure that the aftertreatment 2 SCR temperature sensor module is properly mounted.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Verify the aftertreatment 2 SCR temperature sensor module is properly mounted.

  • Verify the module is mounted correctly. Refer to Procedure 019-449 in the Associated Procedures Table.

Aftertreatment 2 SCR temperature sensor module properly installed?
YES NO
No Repair

Relocate and/or secure the aftertreatment 2 SCR temperature sensor module at the correct mounting location. Refer to Procedure 019-449 in the Associated Procedures Table.

Go to 2B

Go to 3A

Guided Step 2B - Check for obstructed or restricted air flow to the aftertreatment 2 SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Check the aftertreatment 2 SCR temperature sensor module mounting area for air flow obstructions. Restrictions or blockage of the air flow could cause the temperature sensor module to overheat. Check for the following:

  • Debris on or around the temperature sensor module.
  • Aftermarket shields, flaps, or brackets mounted too close to the module.
  • Exhaust leaks allowing exhaust to overheat the temperature sensor module.

Signs of air flow restriction or excessive heat to temperature sensor module?
YES NO

Repair the cause of the restricted air flow. Remove any debris accumulated near the temperature sensor module. Relocate any aftermarket accessories that might be restricting air flow. Repair any causes of excessive heat to the temperature sensor module.

No Repair

Go to 3A

Repair complete

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 13-Apr-2016


FAULT CODE 5731 - Aftertreatment 2 Selective Catalytic Reduction Temperature Sensor Module - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Aftertreatment Sensor Power Relay | Refer to Procedure 019-607 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5731 active?
 | STEP 1B. Check for active supply voltage fault codes. | Fault Code 441 or 442 active?
 | STEP 1C. Check for active selective catalytic reduction (SCR) fault codes. | Fault Code 5725 or 5728 active?
STEP 2. | Check the aftertreatment 2 SCR temperature sensor module circuit. |
 | STEP 2A. Inspect aftertreatment 2 SCR temperature sensor module and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment 2 SCR temperature sensor module. | Voltage within 1 VDC of supply voltage?
STEP 3. | Check the power connections. |
 | STEP 3A. Check the power supply and power connections. | Connections tight and corrosion-free?
 | STEP 3B. Check the voltage to the aftertreatment 2 SCR temperature sensor module. | Voltage within 1 VDC of supply voltage?
 | STEP 3C. Inspect the aftertreatment power relay and connector pins. | Dirty or damaged pins?
 | STEP 3D. Check the voltage to the aftertreatment power relay. | Voltage within 1 VDC of supply voltage?
 | STEP 3E. Check the aftertreatment power relay. | Less than 10 ohms?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5731 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active supply voltage fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine. Let it idle for 1 minute.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 or 442 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for active SCR temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5725 or 5728 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment 2 SCR temperature sensor module circuit.

Guided Step 2A - Inspect the aftertreatment 2 SCR temperature sensor module and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 SCR temperature sensor module from the original equipment manufacturer (OEM) harness.

Action

Inspect the OEM harness and aftertreatment 2 temperature sensor module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

Replace the aftertreatment 2 SCR temperature sensor module only when there are damaged pins. Refer to Procedure 019-449 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment 2 SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 SCR temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment 2 SCR temperature sensor module.

  • Measure the voltage between the aftertreatment 2 SCR temperature sensor module supply voltage supply circuit and the aftertreatment 2 SCR temperature sensor module supply voltage return circuit at the aftertreatment 2 SCR temperature sensor module wiring harness connector.

Use the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage within 1 VDC of supply voltage?
YES NO
No Repair

An intermittent connection has been detected at the aftertreatment 2 SCR temperature sensor module.

Troubleshoot the connector and harness for intermittent shorts and/or opens. Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.
  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Repair or replace the damaged component.

Go to 3A

Go to 4A

Guided Step 3 - Check the power connections.

Guided Step 3A - Check the power supply and the power connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery or power source connections.

  • Check the power supply connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten any loose connections and clean the terminals. See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Check the voltage to the aftertreatment 2 SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 SCR temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check the voltage to the aftertreatment 2 SCR temperature sensor module.

  • Measure the voltage from the aftertreatment 2 SCR temperature sensor module supply voltage SUPPLY pin of the OEM harness SCR temperature sensor module connector to ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Voltage within 1 VDC of supply voltage?
YES NO
No Repair

An open circuit has been detected in the aftertreatment 2 SCR temperature sensor module supply voltage return circuit.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the damaged section of harness.

  • For OEM harness: Refer to Procedure 019-071 in Section 19.
  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the aftertreatment power relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the harness.

Action

Inspect the harness and aftertreatment power relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspect techniques. Refer to Procedure 019-360 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the relay or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace aftertreatment power relay only when there are damaged pins.

Refer to Procedure 019-607 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check the voltage to the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment power relay.

  • Measure the voltage between the aftertreatment power relay supply voltage SUPPLY pin in the aftertreatment power relay connector of the engine harness and ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Voltage within 1 VDC of supply voltage?
YES NO

An open circuit has been detected in the aftertreatment power supply voltage supply circuit before the power relay.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of harness.

Refer to Procedure 019-043 in the Associated Procedures Table for the engine harness.

No Repair

Go to 4A

Go to 3E

Guided Step 3E - Check the aftertreatment power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the engine harness.

Action

Check for a damaged aftertreatment power relay.

  • Install a jumper wire from pin 85 on the aftertreatment power relay to supply voltage (+) and connect a jumper wire from pin 86 on the aftertreatment power relay to ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.
  • Measure the resistance between pin 30 and pin 87 on the aftertreatment power relay.

Use the wiring diagram for connector pin identification.

Use the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

An open circuit or short circuit to ECM power supply ground has been detected in the aftertreatment SCR temperature sensor module power supply circuit.

This could be caused by:

  • Blown in-line fuse on the SCR temperature sensor module power supply circuit.
  • Open circuit or short circuit to ECM power supply ground in the SCR temperature sensor module power supply circuit.

Replace the in-line fuse if it is blown.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.
  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table

Replace the aftertreatment power relay.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 31-Mar-2016


FAULT CODE 5747 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 2 Input Lines - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSK95 CM2350 K113 | 4388663
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Heater | Refer to Procedure 011-112 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Line Heater Relay | Refer to Procedure 019-600 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Heater Relay | Refer to Procedure 019-620 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 5747 active or more than two inactive counts?
 | STEP 1B. Check for diesel exhaust fluid (DEF) related fault codes. | Fault Code 1712 active or more than two inactive counts?
 | STEP 1C. Check for low aftertreatment DEF tank level. | DEF tank empty and/or Fault Code 1673, 3497, or 3498 active?
 | STEP 1D. Check DEF tank for debris. | DEF tank and vent clean and free of debris?
 | STEP 1E. Check ambient operating temperatures. | Equipment operating in ambient temperatures below -5°C [23°F] at the time the fault set?
STEP 2. | Check the aftertreatment 1 dosing system 2 DEF line heaters. |
 | STEP 2A. Test the aftertreatment 1 DEF line heater relays. | Aftertreatment 1 line heater relays within specification?
 | STEP 2B. Check aftertreatment 1 dosing system 2 DEF line heater functionality. | All line heaters functioning correctly?
 | STEP 2C. Inspect the original equipment manufacturer (OEM) harness and line heater connections. | Dirty or damaged pins?
 | STEP 2D. Check line heater supply voltage and return circuits. | All measurements within 1 VDC of engine control module (ECM) power supply voltage?
 | STEP 2E. Check line heater supply voltage to the ECM power supply ground. | All measurements within 1 VDC of ECM power supply voltage?
STEP 3. | Check the aftertreatment 1 DEF dosing unit 2 heating system. |
 | STEP 3A. Check the aftertreatment 1 DEF dosing unit heater relay. | Aftertreatment 1 DEF dosing unit heater relay within specifications?
 | STEP 3B. Inspect the aftertreatment 1 DEF dosing unit 2 heater and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check heater circuit resistance in the aftertreatment 1 DEF dosing unit 2 heater. | Resistance at 5.4 ohms ± 2.0 ohm?
 | STEP 3D. Check for an open circuit in the aftertreatment 1 DEF dosing unit 2 heater supply circuit. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3E. Check aftertreatment 1 DEF dosing unit 2 heater supply voltage to chassis ground. | All measurements within 1 VDC of ECM power supply voltage?
STEP 4. | Check the aftertreatment 1 DEF dosing unit 2 lines and fittings. |
 | STEP 4A. Inspect the aftertreatment 1 DEF dosing unit 2 lines and fittings. | Any reversed, damaged, leaking, or restricted connections found?
 | STEP 4B. Check for pressure at the aftertreatment 1 DEF dosing valve 2. | DEF pressure greater than 1000 kPa [145 psi]?
 | STEP 4C. Check the aftertreatment 1 DEF dosing unit 2 supply line. | DEF dosing unit supply line blocked or restricted?
 | STEP 4D. Check the aftertreatment 1 DEF dosing valve 2 pressure line. | DEF pressure line blocked or restricted?
STEP 5. | Check the aftertreatment 1 DEF dosing valve 2 system return. |
 | STEP 5A. Check for a blocked aftertreatment 1 DEF dosing valve 2. | DEF pressure greater than 700 kPa [102 psi]?
 | STEP 5B. Check the aftertreatment 1 DEF dosing valve 2 return line. | DEF return line blocked or restricted?
STEP 6. | Check the aftertreatment 1 unit 2 DEF suction line. |
 | STEP 6A. Check for air in the DEF. | Air in the DEF detected?
 | STEP 6B. Check for an intermittent aftertreatment 1 DEF dosing unit 2 suction line leak. | Wiggling the DEF suction line connections affect the system pressure?
 | STEP 6C. Check the aftertreatment 1 DEF pressure. | DEF pressure greater than 750 kPa [109 psi]?
STEP 7. | Check the aftertreatment DEF dosing valve 2 operation. |
 | STEP 7A. Check the aftertreatment DEF dosing system operation. | Dosing volume within the specifications in Procedure 011-063 in the Associated Procedures Table?
 | STEP 7B. Check the results of the doser override test. | DEF pressure at the service tool gauge above 700 kPa [102 psi] for the duration of the test?
STEP 8. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 8A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 8B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5747 active or more than two inactive counts?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for diesel exhaust fluid (DEF) related fault codes.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1712 active or more than two inactive counts?
YES NO

Fault code 1712 indicates the aftertreatment DEF tank is frozen. Troubleshoot occurrences of Fault Code 1712 before troubleshooting Fault Code 5747.

No Repair

Refer to the appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for low DEF tank level.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Make sure the DEF tank is not empty and the tank level gauge is accurate.

Use INSITE™ electronic service tool to read the fault codes.

  • Check for the following active Fault Codes: 1673, 3497, and 3498.

DEF tank empty and/or Fault Code 1673, 3497, or 3498 active?
YES NO

Fill the DEF tank.

 No Repair

Go to 8A

Go to 1D

Guided Step 1D - Check DEF tank for debris.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF tank.

  • Check the DEF tank for debris or foreign particles.
  • Check the DEF tank vent for crystallization buildup and clogging.
  • Use the Cummins® DEF Refractometer Service Tool, Part Number 4919554, to test the DEF concentration.

DEF tank and vent clean and free of debris?
YES NO
No Repair

Clean the DEF tank and tank filter thoroughly. Replace the tank filter, if necessary. See equipment manufacturer service information.

Fill tank with certified DEF.

If the DEF in the tank is found to be dirty, replace the DEF dosing unit filter and inlet screen. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 1E

Go to 8A

Guided Step 1E - Check ambient operating temperatures.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check if the equipment was operating in a cold ambient environment, temperature below -5°C [23°F], at the time the fault logged.

Use INSITE™ electronic service tool to read the fault code snapshot and check the ambient air temperature sensor reading to verify.

Equipment operating in ambient temperatures below -5°C [23°F] at the time the fault set?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the aftertreatment 1 dosing system 2 DEF line heaters.

Guided Step 2A - Test the aftertreatment 1 DEF line heater relays.

Conditions

  • Turn keyswitch OFF.

Action

Test the aftertreatment 1 DEF line heater relays (K11).

  • Refer to Procedure 019-600 in the Associated Procedures Table.

Aftertreatment 1 line heater relays within specification?
YES NO
No Repair

A damaged line heater relay has been detected. Replace damaged relay. Refer to Procedure 019-600 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Check DEF line heater functionality.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test.

Use an infrared thermometer to measure the surface temperature of each of the 3 aftertreatment DEF lines.

Look for the following:

  • Surface temperature should be above 10°C [50°F].
  • Temperature uniformity across the length of the individual lines.
  • Temperature uniformity between the lines.

If the lines were not at operating temperature when the test was started, a temperature rise will be noticeable.

All line heaters functioning correctly?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the original equipment manufacturer (OEM) harness and line heater connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the three line heaters (suction, pressure, and return) from the OEM harness.

Action

Inspect the OEM harness and line heater connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the line heater or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 8A

Go to 2C

Guided Step 2C - Check line heater supply voltage and return circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the three line heaters (suction, pressure, and return) from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuits.

  • Measure the voltage from the line heater +24 volt SUPPLY pin to the line heater RETURN pin at the heater connector of the OEM harness.

Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

All measurements within 1 VDC of engine control module (ECM) power supply voltage?
YES NO

Replace the malfunctioning line heater(s).

See equipment manufacturer service information.

 No Repair

Go to 8A

Go to 2D

Guided Step 2D - Check line heater supply voltage to the ECM power supply ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the three line heaters (suction, pressure, and return) from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuits.

  • Measure the voltage from the line heater +24 volt SUPPLY pin to ECM power supply ground.

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Refer to Procedure 019-610 in the Associated Procedures Table.

All measurements within 1 VDC of ECM power supply voltage?
YES NO

An open circuit has been detected in the line heater return circuit.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Troubleshoot the return circuit in aftertreatment junction box, if equipped. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

An open has been detected between the line heater relay and the line heater.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, Repair or replace the damaged section of harness.

Troubleshoot the return circuit in aftertreatment junction box, if equipped. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

Go to 8A

Go to 8A

Guided Step 3 - Check the aftertreatment 1 DEF dosing unit 2 heating system.

Guided Step 3A - Check the aftertreatment 1 diesel exhaust fluid (DEF) dosing unit heater relay.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment 1 DEF dosing unit heater relay (K1) from the aftertreatment junction box. Refer to Procedure 019-620 in the Associated Procedures Table.

Action

Test aftertreatment 1 DEF dosing unit heater relay.

  • Refer to Procedure 019-620 in the Associated Procedures Table.

Refer to the appropriate wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Aftertreatment 1 DEF dosing unit heater relay within specifications?
YES NO
No Repair

Replace the aftertreatment 1 DEF dosing unit heater relay (K1). Refer to Procedure 019-620 in the Associated Procedures Table.

Go to 8A

Go to 3B

Guided Step 3B - Inspect the aftertreatment 1 DEF dosing unit 2 heater and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 2 heater from the OEM harness.

Action

Inspect the DEF dosing unit heater and OEM harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the Aftertreatment DEF dosing unit heater or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace dosing unit heater only when there are damaged pins. Refer to Procedure 011-112 in the Associated Procedures Table.

 No Repair

Go to 8A

Go to 3C

Guided Step 3C - Check heater circuit resistance in the aftertreatment 1 DEF dosing unit 2 heater.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check resistance at the dosing unit heater.

  • Measure the resistance across heater at the aftertreatment DEF dosing unit heater supply and the aftertreatment DEF dosing unit heater return at the DEF dosing unit.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Resistance at 5.4 ohms ± 2.0 ohm?

YES NO
No Repair

A malfunctioning aftertreatment DEF dosing unit heater has been detected.

Replace the aftertreatment DEF dosing unit heater. Refer to Procedure 011-112 in the Associated Procedures Table.

Go to 3D

Go to 8A

Guided Step 3D - Check for an open circuit in the aftertreatment 1 DEF dosing unit 2 heater supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 2 heater from the OEM harness.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Perform the Aftertreatment Diesel Exhaust Fluid Doser System Heater Test found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool.
  • Measure the voltage between aftertreatment 1 DEF dosing unit 2 heater SUPPLY pin at the aftertreatment 1 DEF dosing unit 2 heater connector and the ECM power supply ground.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Refer to Procedure 019-610 in the Associated Procedures Table.

Voltage within 1 VDC of ECM power supply voltage?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DEF dosing unit heater supply circuit.

Check the aftertreatment DEF dosing unit heater circuit breaker. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 8A

Guided Step 3E - Check aftertreatment 1 DEF dosing unit 2 heater supply voltage to ECM power supply ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 2 heater from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuits.

  • Measure the voltage from the line heater +24 volt SUPPLY pin to the ECM power supply ground.

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.

Use the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-610 in the Associated Procedures Table.

All measurements within 1 VDC of ECM power supply voltage?
YES NO

An open has been detected in the heater return circuit.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Troubleshoot return circuit in aftertreatment junction box, if equipped. Refer to Procedure 019-598 in the Associated Procedures Table.

An open has been detected between the heater relay and the heater.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Troubleshoot return circuit in aftertreatment junction box, if equipped. Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 8A

Go to 8A

Guided Step 4 - Check the aftertreatment 1 DEF dosing unit 2 lines and fittings.

Guided Step 4A - Inspect the aftertreatment 1 DEF dosing unit 2 lines and fittings.

Conditions

  • Turn keyswitch OFF.

Action

There are three DEF lines on the selective catalytic reduction (SCR) dosing system:

  • Dosing unit supply line between the tank and the dosing unit (suction line)
  • Dosing valve supply line between the dosing unit and the dosing valve (pressure line)
  • Return line between the dosing valve and the tank (return line).

Inspect all three DEF lines and associated fittings/connectors:

  • Inspect the dosing unit for a plugged inlet filter in the inlet fitting. Refer to Procedure 011-058 in the Associated Procedures Table.
  • Inspect the dosing unit DEF filter. Refer to Procedure 011-060 in the Associated Procedures Table.
  • Verify the DEF line connections are not swapped at the dosing unit, dosing valve, or DEF tank. Reversed DEF lines can cause the dosing system to fail to prime.
  • Check the DEF tank connections (suction and return lines) for cracks and pitting.
  • Check both dosing unit connections and fittings for loose, leaking, or damaged connections.
  • Check the suction line for signs of leakage or openings which will allow the dosing unit to suck in air with the DEF.
  • Check the pressure line for signs of leakage or rupture.
  • Disconnect the suction line, pressure line, and return line connectors and look for signs of buildup or blockage.
  • Verify proper sealing at all connection points and check for damaged or missing o-rings.

Any reversed, damaged, leaking, or restricted connections found?
YES NO

Replace the DEF line(s), fittings, and filters, as necessary.

See equipment manufacturer service information.

For DEF dosing unit inlet filter screen: Refer to Procedure 011-058 in the Associated Procedures Table.

For DEF dosing unit filter: Refer to Procedure 011-060 in the Associated Procedures Table.

For Dosing unit connections: Refer to Procedure 011-058 in the Associated Procedures Table.

Repair or replace the aftertreatment DEF dosing unit, as necessary.

Refer to Procedure 011-058 in the Associated Procedures Table.

Replace the DEF dosing unit inlet filter screen and dosing unit DEF filter. These filters can not be reused and must be changed upon removal.

Refer to Procedure 011-060 in the Associated Procedures Table.

Go to 8A

Go to 4B

Guided Step 4B - Check for pressure at the aftertreatment 1 DEF dosing valve 2.

Conditions

  • Turn keyswitch OFF
  • Install the DEF pressure gauge between the inlet of the dosing valve and the pressure line. Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

Attempt to prime the DEF system.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostics Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure greater than 1000 kPa [145 psi]?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check the aftertreatment 1 DEF dosing unit 2 supply line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 2 supply line from the dosing unit (this is the suction line between the dosing unit and the DEF tank).
  • Disconnect the aftertreatment 1 DEF dosing unit 2 supply line from the DEF tank.

Action

Check the DEF dosing unit 2 supply line for blockage.

  • Check both ends of the dosing unit supply line for signs of build-up or blockage.
  • Blow compressed shop air through the dosing unit supply line to make sure of free flow.

DEF dosing unit supply line blocked or restricted?
YES NO

Try to clean the dosing unit supply line with shop air. If necessary, replace the dosing unit supply line.

See equipment manufacturer service information.

 No Repair

Go to 8A

Go to 4D

Guided Step 4D - Check the aftertreatment 1 DEF dosing valve 2 pressure line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 2 pressure line from the dosing valve (pressure line runs between the dosing unit and dosing valve).
  • Disconnect the aftertreatment 1 DEF dosing valve 2 pressure line from the DEF dosing unit.

Action

Check the aftertreatment 1 DEF pressure line for blockage.

  • Check both ends of the line for signs of buildup or blockage.
  • Blow compressed shop air through the pressure line to make sure of free flow.

DEF pressure line blocked or restricted?
YES NO

Try to clean the pressure line using shop air. If necessary, replace the pressure line.

See equipment manufacturer service information.

 No Repair

Go to 8A

Go to 6A

Guided Step 5 - Check the aftertreatment 1 DEF dosing valve 2 system return.

Guided Step 5A - Check for a blocked aftertreatment 1 DEF dosing valve 2.

Conditions

  • Turn the keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the outlet of the dosing valve and the return line. Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn the keyswitch ON.

Action

Attempt to prime the DEF system.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostics Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure greater than 700 kPa [102 psi]?
YES NO
No Repair

Replace the DEF dosing valve.

Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 5B

Go to 8A

Guided Step 5B - Check the aftertreatment 1 DEF dosing valve 2 return line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 2 return line from the dosing valve.
  • Disconnect the aftertreatment 1 DEF dosing valve 2 return line from the DEF tank.

Action

Check the aftertreatment 1 DEF dosing valve 2 return line for blockage.

  • Check both ends of the line for signs of buildup or blockage.
  • Blow compressed shop air through the return line to make sure of free flow.

DEF return line blocked or restricted?
YES NO

Try to clean the return line using shop air. If necessary, replace the return line.

See equipment manufacturer service information.

A blocked or restricted return has been detected in the DEF tank head. Clean or replace the tank head as necessary.

See equipment manufacturer service information.

Go to 8A

Go to 8A

Guided Step 6 - Check the aftertreatment 1 unit 2 DEF suction line.

Guided Step 6A - Check for air in the DEF.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for air in the DEF.

  • Refer to Procedure 011-075 in the Associated Procedures Table.

Air in the DEF detected?
YES NO

Check the following components for damage/leaks and repair as necessary:

  • Aftertreatment 1 DEF dosing unit 2 fittings
  • Aftertreatment 1 DEF dosing unit 2 supply line
  • Aftertreatment 1 DEF tank fittings
  • Aftertreatment 1 DEF tank filter.

Refer to Procedure 011-075 in the Associated Procedures Table.

 No Repair

Go to 8A

Go to 6B

Guided Step 6B - Check for an intermittent aftertreatment 1 DEF dosing unit 2 suction line leak.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.

Action

Attempt to prime the DEF system. Use INSITE™ electronic service tool to perform the Aftertreatment DEF System Leak Test, under ECM Diagnostics Tests.

As the DEF system is trying to prime, wiggle the suction line connections at the dosing unit 2 and tank. Monitor the DEF pressure sensor reading in INSITE™ electronic service tool data monitor/logger section.

  • Check if wiggling the suction line connections causes the system to either build pressure or lose prime.
  • Listen for audible indication from the pump that wiggling the suction line is causing air to enter the system.

Wiggling the DEF suction line connections affect the system pressure?
YES NO

Replace the DEF suction line. See equipment manufacturer service information.

 No Repair

Go to 8A

Go to 6C

Guided Step 6C - Check the aftertreatment 1 DEF pressure.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.

Action

Attempt to prime the DEF system.

Use INSITE™ electronic service tool to perform the Aftertreatment DEF System Leak Test, under ECM Diagnostics Tests.

  • Monitor the DEF pressure sensor reading in INSITE™ electronic service tool data monitor/logger section.

DEF pressure greater than 750 kPa [109 psi]?
YES NO
No Repair

Replace the DEF dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 7A

Go to 8A

Guided Step 7 - Check the aftertreatment DEF dosing valve 2 operation.

Guided Step 7A - Check the aftertreatment DEF dosing system operation.

Conditions

  • Connect the DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove the aftertreatment 1 DEF dosing valve 2 from the decomposition chamber.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test, under ECM Diagnostics Tests.

  • Use the following procedure for instructions and specifications. Refer to Procedure 011-063 in the Associated Procedures Table.

The aftertreatment 1 DEF dosing valve 2 must be removed and placed in a measuring container having greater than a 1.5 liter [50 oz] capacity to run the Aftertreatment DEF Doser Pump Override Test.

Dosing volume within the specifications in Procedure 011-063 in the Associated Procedures Table?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7B

Guided Step 7B - Check the results of the doser override test.

Conditions

  • Turn the keyswitch OFF.

Action

Check the service pressure tool reading recorded during the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

DEF pressure at the service tool gauge reading above 700 kPa [102 psi] for the duration of the test?
YES NO

Replace the aftertreatment 1 DEF dosing valve 2.

Refer to Procedure 011-059 in the Associated Procedures Table.

Replace the aftertreatment 1 DEF dosing unit 2. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 8A

Go to 8A

Guided Step 8 - Check ECM calibration and clear fault codes.

Guided Step 8A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in Section 19.

Go to 8B

Go to 8B

Guided Step 8B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process

Repair complete

Last Modified: 03-May-2017


FAULT CODE 5748 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 5748 active?
STEP 2. | Check the aftertreatment 1 diesel exhaust fluid (DEF) dosing unit 2 and circuit. |
 | STEP 2A. Inspect the aftertreatment 1 DEF dosing unit 2 and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit on the aftertreatment 1 DEF dosing unit 2 supply in the OEM harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit on the aftertreatment 1 DEF dosing unit 2 supply in the OEM harness. | Greater than 100k ohms?
 | STEP 2D. Check for a pin-to-pin short circuit on the aftertreatment 1 DEF dosing unit 2 signal in the OEM harness. | Greater than 100k ohms?
 | STEP 2E. Check for an open circuit on the aftertreatment 1 DEF dosing unit 2 supply in the engine harness. | Less than 10 ohms?
 | STEP 2F. Check for a pin-to-pin short circuit on the aftertreatment 1 DEF dosing unit 2 supply in the engine harness. | Greater than 100k ohms?
 | STEP 2G. Check for a pin-to-pin short circuit on the aftertreatment 1 DEF dosing unit 2 signal in the engine harness. | Greater than 100k ohms?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5748 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 1 DEF dosing unit 2 and circuit.

Guided Step 2A - Inspect the aftertreatment 1 DEF dosing unit 2 and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 2 from the original equipment manufacturer (OEM) harness.

Action

Inspect the harness and aftertreatment 1 DEF dosing unit 2 connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit 2 or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit on the aftertreatment 1 DEF dosing unit 2 supply in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 2 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness aftertreatment 1 DEF dosing unit 2 SUPPLY pin and OEM harness aftertreatment 1 connector DEF dosing unit 2 SUPPLY pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness. Refer to Procedure 019-071 in Section 19.
  • For the engine harness.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit on the aftertreatment 1 DEF dosing unit 2 supply in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 2 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 2 SUPPLY pin of the OEM harness ECM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If a short circuit is isolated to the damaged harness, repair or replace the damaged section of the engine wiring harness.

  • For the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-pin short circuit on the aftertreatment 1 DEF dosing unit 2 signal in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 2 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 2 command SIGNAL pin of the OEM harness aftertreatment 1 connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If a short circuit is isolated to damaged harness, repair or replace the damaged section of the engine wiring harness.

  • For the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for an open circuit on the aftertreatment 1 DEF dosing unit 2 supply in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness aftertreatment 1 connector DEF dosing unit 2 SUPPLY pin and OEM harness ECM connector aftertreatment 1 DEF dosing unit 2 SUPPLY pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected.

Repair or replace the damaged section of harness.

  • For the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2F

Go to 3A

Guided Step 2F - Check for a pin-to-pin short circuit on the aftertreatment 1 DEF dosing unit 2 supply in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing 2 unit SUPPLY pin of the OEM harness ECM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness.

Repair or replace the damaged section of harness.

  • For the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2G

Go to 3A

Guided Step 2G - Check for a pin-to-pin short circuit on the aftertreatment 1 DEF dosing unit 2 signal in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 2 SIGNAL pin of the OEM harnesss ECM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the aftertreatment 1 DEF dosing unit 2. Refer to Procedure 011-058 in the Associated Procedures Table.

A pin-to-pin short circuit has been detected.

Repair or replace the damaged section of harness.

  • For the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 19-May-2016


FAULT CODE 5749 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 5749 active?
STEP 2. | Check the aftertreatment 1 diesel exhaust fluid (DEF) dosing unit 2 and circuit. |
 | STEP 2A. Inspect the aftertreatment 1 DEF dosing unit 2 and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit on the aftertreatment 1 DEF dosing unit 2 signal circuit in the OEM harness. | Less than 10 ohms?
 | STEP 2C. Check for an open circuit on the aftertreatment 1 DEF dosing unit 2 supply circuit in the OEM harness. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-ECM power supply ground short circuit on the aftertreatment 1 DEF dosing unit 2 signal circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2E. Check for a pin-to-ECM power supply ground short circuit on the aftertreatment 1 DEF dosing unit 2 supply circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2F. Check for a pin-to-pin short circuit in the original equipment manufacturer (OEM) harness. | Greater than 100k ohms?
 | STEP 2G. Check for an open circuit on the aftertreatment 1 DEF dosing unit 2 signal circuit in the engine harness. | Less than 10 ohms?
 | STEP 2H. Check for an open circuit on the aftertreatment 1 DEF dosing unit 2 supply in the engine harness. | Less than 10 ohms?
 | STEP 2I. Check for a pin-to-ECM power supply ground short circuit on the aftertreatment 1 DEF dosing unit 2 signal circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2J. Check for a pin-to-ECM power supply ground short circuit on the aftertreatment 1 DEF dosing unit 2 supply circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2K. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5749 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 1 DEF dosing unit 2 and circuit.

Guided Step 2A - Inspect the aftertreatment 1 DEF dosing unit 2 and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 2 from the original equipment manufacturer (OEM) harness.

Action

Inspect the harness and aftertreatment 1 DEF dosing unit 2 connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit 2 or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit on the aftertreatment 1 DEF dosing unit 2 signal circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 2 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector\.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 2 command SIGNAL pin at the dosing unit wiring harness connector and aftertreatment 1 DEF dosing unit 2 command SIGNAL pin in the OEM harness aftertreatment 1 connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit on the aftertreatment 1 DEF dosing unit 2 supply in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 2 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 2 SUPPLY pin at the dosing unit wiring harness connector and aftertreatment 1 DEF dosing unit 2 SUPPLY pin in the OEM harness aftertreatment 1 connector.

Refer to the or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-ECM power supply ground short circuit on the aftertreatment 1 DEF dosing unit 2 signal in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 2 from the OEM harness.
  • Disconnect the OEM harness from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 2 command SIGNAL pin of the OEM harness aftertreatment 1 connector and ECM power supply ground.

Refer to the or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If a short circuit is isolated to damaged harness, repair or replace the damaged section of the engine wiring harness.

  • For the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a pin-to-ECM power supply ground short circuit on the aftertreatment 1 DEF dosing unit 2 supply in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 2 from the OEM harness.
  • Disconnect the OEM harness from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 2 SUPPLY pin of the OEM harness aftertreatment 1 connector and ECM power supply ground.

Refer to the or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If a short circuit is isolated to damaged harness, repair or replace the damaged section of the engine wiring harness.

  • For the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 2 from the OEM harness.
  • Disconnect the OEM harness from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 2 SIGNAL pin of the OEM harness aftertreatment 1 connector and all other pins in the OEM harness ECM connector.
  • Measure the resistance between the aftertreatment 1 DEF dosing unit 2 SUPPLY pin of the OEM harness aftertreatment 1 connector and all other pins in the OEM harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If a short circuit is isolated to damaged harness, repair or replace the damaged section of the engine wiring harness.

  • For the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2G

Go to 3A

Guided Step 2G - Check for an open circuit on the aftertreatment 1 DEF dosing unit 2 signal circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness aftertreatment 1 connector DEF dosing unit 2 command SIGNAL pin and the aftertreatment 1 DEF dosing unit 2 command SIGNAL pin in the OEM harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected.

Repair or replace the damaged section of the engine wiring harness.

  • For the engine harness. Refer to Procedure 019-043 in the Associated procedures Table.

Go to 2H

Go to 3A

Guided Step 2H - Check for an open circuit on the aftertreatment 1 DEF dosing unit 2 supply circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness aftertreatment 1 connector DEF dosing unit 2 SUPPLY and the aftertreatment 1 DEF dosing unit 2 SUPPLY pin in the OEM harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected.

Repair or replace the damaged section of the engine wiring harness.

  • For the engine harness. Refer to Procedure 019-043 in the Associated procedures Table.

Go to 2I

Go to 3A

Guided Step 2I - Check for a pin-to-ground short circuit on the aftertreatment 1 DEF dosing unit 2 supply circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 2 command SIGNAL pin of the OEM harness ECM connector and ECM power supply ground. Refer to Procedure 019-610 in the Associated Procedures Table.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected.

Repair or replace the damaged section of the engine wiring harness.

  • For the engine harness. Refer to Procedure 019-043 in the Associated procedures Table.

Go to 2J

Go to 3A

Guided Step 2J - Check for a pin-to-ground short circuit on the aftertreatment 1 DEF dosing unit 2 supply circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 2 command SIGNAL pin of the OEM harness ECM connector and ECM power supply ground. Refer to Procedure 019-610 in the Associated Procedures Table.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected.

Repair or replace the damaged section of the engine wiring harness.

  • For the engine harness. Refer to Procedure 019-043 in the Associated procedures Table.

Go to 2K

Go to 3A

Guided Step 2K - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 2 SIGNAL pin of the OEM harness ECM connector and all other pins in the OEM harness ECM connector.
  • Measure the resistance between the aftertreatment 1 DEF dosing unit 2 SUPPLY pin of the OEM harness ECM connector and all other pins in the OEM harness ECM connector

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the aftertreatment 1 DEF dosing unit 2. Refer to Procedure 019-598 in the Associated Procedures Table.

A pin-to-pin short circuit has been detected.

Repair or replace the damaged section of the engine wiring harness.

  • For the engine harness. Refer to Procedure 019-043 in the Associated procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 13-Apr-2016


FAULT CODE 5751 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 2 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for aftertreatment 1 diesel exhaust fluid (DEF) dosing valve 2 fault codes. | Fault Code 5751 active?
STEP 2. | Check the aftertreatment 1 DEF dosing valve 2 and circuit. |
 | STEP 2A. Inspect the aftertreatment 1 DEF dosing valve 2 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the aftertreatment 1 DEF dosing valve 2 resistance. | Between 10 and 17 ohms?
STEP 3. | Check the engine and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the aftertreatment 1 DEF dosing valve 2 signal circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check the aftertreatment 1 DEF dosing valve 2 return circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Inspect the engine control module (ECM) harness connector pins. | Dirty or damaged pins?
 | STEP 3G. Check the aftertreatment 1 DEF dosing valve 2 signal circuit. | Less than 10 ohms?
 | STEP 3H. Check the aftertreatment 1 DEF dosing valve 2 return circuit. | Less than 10 ohms?
 | STEP 3I. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3J. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for aftertreatment 1 DEF dosing valve 2 fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5751 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the aftertreatment 1 DEF dosing valve 2 and circuit.

Guided Step 2A - Inspect the aftertreatment 1 DEF dosing valve 2 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 2 from the OEM harness.

Action

Inspect the OEM harness and aftertreatment 1 DEF dosing valve 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing valve or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the aftertreatment 1 DEF dosing valve 2 resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 2 from the OEM harness.

Action

Check for an internal short or open circuit in the aftertreatment 1 DEF dosing valve 2 by measuring the internal resistance.

  • Measure the resistance between the aftertreatment 1 DEF dosing valve 2 SIGNAL pin to the aftertreatment 1 DEF dosing valve 2 RETURN pin at the aftertreatment 1 DEF dosing valve 2 connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 10 and 17 ohms?
YES NO
No Repair

An internal short or open has been detected in the aftertreatment 1 DEF dosing valve 2.

Replace the aftertreatment 1 DEF dosing valve 2. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine and OEM harness.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Inspect the OEM harness aftertreatment 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness aftertreatment 1 connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the aftertreatment 1 DEF dosing valve 2 signal circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 2 from the OEM harness.

Action

Check the dosing valve signal circuit.

  • Measure the resistance between the OEM harness aftertreatment 1 DEF dosing valve 2 connector SIGNAL pin and the OEM harness aftertreatment 1 connector DEF dosing valve 2 SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the aftertreatment 1 DEF dosing valve 2 return circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 2 from the OEM harness.

Action

Check the dosing valve 2 return circuit.

  • Measure the resistance between the OEM harness aftertreatment 1 DEF dosing valve 2 connector RETURN pin to the OEM aftertreatment 1 connector DEF dosing valve 2 RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 2 from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing valve 2 SIGNAL pin in the OEM harness aftertreatment 1 connector and ground.
  • Measure the resistance between the aftertreatment 1 DEF dosing valve 2 RETURN pin in the OEM harness aftertreatment 1 connector and ECM power supply ground. Refer to Procedure 019-610 in the Associated Procedures Table.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 2 from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing valve 2 SIGNAL pin in the OEM harness connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3G

Guided Step 3G - Check the aftertreatment 1 DEF dosing valve 2 signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check the dosing valve signal circuit.

  • Measure the resistance between the OEM harness aftertreatment 1 connector DEF dosing valve 2 connector SIGNAL pin and to the ECM connector aftertreatment 1 DEF dosing valve 2 SIGNAL pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3H

Go to 4A

Guided Step 3H - Check the aftertreatment 1 DEF dosing valve 2 return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM connector from the engine harness aftertreatment 1 connector.

Action

Check the dosing valve return circuit.

  • Measure the resistance between the OEM harness aftertreatment 1 connector DEF dosing valve 2 RETURN pin to the ECM connector aftertreatment 1 DEF dosing valve 2 RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3I

Go to 4A

Guided Step 3I - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing valve 2 SIGNAL pin in the OEM harness ECM connector and ground.
  • Measure the resistance between the aftertreatment 1 DEF dosing valve 2 RETURN pin in the OEM harness ECM connector and ECM power supply ground. Refer to Procedure 019-610 in the Associated Procedures Table.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3J

Go to 4A

Guided Step 3J - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing valve 2 SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 19-May-2016


FAULT CODE 5752 - Aftertreatment 1 Diesel Exhaust Fluid Pressure 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for active fault code. | Fault Code 5752 active?
STEP 2. | Check the aftertreatment 1 diesel exhaust fluid (DEF) pressure 2 sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment 1 DEF pressure 2 sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 5753 active and Fault Code 5752 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 5752 active?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the harness in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the harness in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the harness in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 5752 active?
 | STEP 3F. Inspect the ECM harness connector pins. | Dirty or damaged pins?
 | STEP 3G. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3H. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3I. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3J. Check for an active fault code. | Fault Code 5752 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Refer to appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5752 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 1 diesel exhaust fluid (DEF) pressure sensor 2 and circuit.

Guided Step 2A - Inspect the aftertreatment 1 DEF pressure 2 sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 2 from the OEM harness.

Action

Inspect the OEM harness and aftertreatment 1 DEF pressure 2 sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 2 from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Other aftertreatment 1 DEF dosing unit 2 fault codes will be active.

Fault Code 5753 active and Fault Code 5752 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 2 from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the aftertreatment 1 DEF pressure 2 +5 volt SUPPLY pin to the aftertreatment 1 DEF pressure 2 RETURN pin at the dosing valve connector of the OEM harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 1 DEF dosing valve 2 to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5752 active?
YES NO

A malfunctioning aftertreatment DEF pressure sensor has been detected inside the aftertreatment 1 DEF dosing valve 2.

Replace the aftertreatment diesel exhaust dosing unit 2. Refer to Procedure 011-059 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the harness in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 2 from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 2 RETURN pin in the OEM harness aftertreatment 1 connector and the aftertreatment 1 DEF pressure sensor 2 RETURN pin in the OEM harness dosing valve connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedure Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the harness in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 2 from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 2 SIGNAL pin in the OEM harness aftertreatment 1 connector and all other pins in the OEM harness aftertreatment 1 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedure Table.

If a short circuit is isolated to damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the harness in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 2 from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 2 SUPPLY pin in the OEM harness aftertreatment 1 connector and all other pins in the OEM harness aftertreatment 1 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedure Table.

If a short circuit is isolated to damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5752 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault code.

Go to 4A

Go to 4A

Guided Step 3F - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3G

Guided Step 3G - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 2 RETURN pin in the OEM harness ECM connector and the aftertreatment 1 DEF pressure sensor 2 RETURN pin in the OEM harness connector from the engine harness aftertreatment 1 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Repair or replace the damaged section of harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3H

Go to 4A

Guided Step 3H - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 2 SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the damaged section of harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3I

Go to 4A

Guided Step 3I - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 2 SUPPLY pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

Repair or replace the damaged section of the harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3J

Go to 4A

Guided Step 3J - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5752 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault code.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the ”Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 27-Apr-2016


FAULT CODE 5753 - Aftertreatment 1 Diesel Exhaust Fluid Pressure 2 Sensor Circuit - Voltage Above Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for active fault code. | Fault Code 5753 active?
STEP 2. | Check the aftertreatment 1 diesel exhaust fluid (DEF) pressure 2 sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment 1 DEF pressure 2 sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 5752 active and Fault Code 5753 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 5753 active?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM aftertreatment 1 harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the harness in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the harness in the OEM harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the harness in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Inspect the ECM OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3G. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3H. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3I. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3J. Check for a pin-to-ground short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3K. Check for active fault code. | Fault Code 5753 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Refer to appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5753 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 1 diesel exhaust fluid (DEF) pressure sensor 2 and circuit.

Guided Step 2A - Inspect the aftertreatment 1 DEF pressure 2 sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 2 from the OEM harness.

Action

Inspect the OEM harness and aftertreatment 1 DEF pressure 2 sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 2 from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the aftertreatment 1 DEF pressure sensor 2 +5 volt SUPPLY pin to the aftertreatment 1 DEF pressure sensor 2 RETURN pin at the dosing valve connector of the OEM harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 2 from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment 1 DEF pressure sensor 2 +5 volt SUPPLY pin and the aftertreatment 1 DEF pressure sensor 2 SIGNAL pin at the aftertreatment 1 DEF dosing valve 2 connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5752 active and Fault Code 5753 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 1 DEF dosing valve 2 to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5753 active?
YES NO

A malfunctioning aftertreatment DEF pressure sensor has been detected inside the aftertreatment 1 DEF dosing valve 2.

Replace the aftertreatment diesel exhaust dosing valve 2. Refer to Procedure 011-059 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the OEM aftertreatment 1 harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Inspect the OEM harness aftertreatment 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the OEM aftertreatment 1 harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the harness in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 2 from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 2 SUPPLY pin in the OEM harness aftertreatment 1 connector and the aftertreatment 1 DEF pressure sensor 2 SUPPLY pin in the OEM harness aftertreatment 1 DEF dosing valve 2 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedure Table.

If an open circuit is isolated to a damaged harness, Repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the harness in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 2 from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 2 SIGNAL pin in the OEM harness aftertreatment 1 connector and the aftertreatment 1 DEF pressure sensor 2 SIGNAL pin in the OEM harness aftertreatment 1 DEF dosing valve 2 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedure Table.

If an open circuit is isolated to a damaged harness, Repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the harness in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 2 from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 2 SIGNAL pin in the OEM harness aftertreatment 1 connector and all other pins in the OEM harness aftertreatment 1 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedure Table.

If a short circuit is isolated to damaged harness, Repair or replace the damaged section of harness.

  • For the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ECM power supply ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 2 from the OEM harness.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 2 SIGNAL pin in the OEM harness aftertreatment 1 connector and ECM power supply ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Refer to Procedure 019-610 in the Associated Procedure Table.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedure Table.

If a short circuit is isolated to damaged harness, Repair or replace the damaged section of harness.

  • For the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Inspect the ECM OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the ECM OEM connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3G

Go to 4A

Guided Step 3G - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 2 SUPPLY pin in the OEM harness ECM connector and the aftertreatment 1 DEF pressure sensor 2 SUPPLY pin in the OEM harness aftertreatment 1 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Repair or replace the damaged section of harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3H

Go to 4A

Guided Step 3H - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 2 SIGNAL pin in the OEM harness ECM connector and the aftertreatment 1 DEF pressure sensor 2 SIGNAL pin in the OEM harness aftertreatment 1 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Repair or replace the damaged section of harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3I

Go to 4A

Guided Step 3I - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 2 SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Repair or replace the damaged section of the harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3J

Go to 4A

Guided Step 3J - Check for a pin-to-ECM power supply ground short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 2 SIGNAL pin in the OEM harness ECM connector and ECM power supply ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Refer to Procedure 019-610 in the Associated Procedure Table.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit on the SIGNAL wire has been detected in the harness.

Repair or replace the damaged section of harness.

  • For the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3K

Go to 4A

Guided Step 3K - Check for active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5753 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault code.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the ”Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 27-Apr-2016


FAULT CODE 5754 - Aftertreatment 1 Diesel Exhaust Fluid Pressure 2 Sensor Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for aftertreatment 1 diesel exhaust fluid (DEF) dosing valve 2 fault codes. | Fault Code 5754 active?
STEP 2. | Check the aftertreatment 1 DEF dosing valve 2 and circuit. |
 | STEP 2A. Inspect the original equipment manufacturer (OEM) aftertreatment 1 harness and aftertreatment 1 DEF dosing valve 2 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the OEM harness aftertreatment 1 DEF dosing valve 2 return circuit. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the OEM aftertreatment 1 harness. | Greater than 100k ohms?
 | STEP 2D. Inspect the OEM connector pins. |
 | STEP 2E. Check the aftertreatment 1 engine harness DEF dosing valve 2 return circuit. |
 | STEP 2F. Check for a pin-to-pin short circuit in the engine harness. |
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for aftertreatment 1 diesel exhaust fluid (DEF) dosing valve 2 fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5754 active?
YES NO
No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the aftertreatment 1 DEF dosing valve 2 and circuit.

Guided Step 2A - Inspect the original equipment manufacturer (OEM) aftertreatment 1 harness and aftertreatment 1 DEF dosing valve 2 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 2 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Inspect the OEM harness, aftertreatment 1 connector and DEF dosing valve 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the valve or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the OEM harness aftertreatment 1 DEF dosing valve 2 return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 2 from the OEM harness.

Action

Check the dosing valve sensor return circuit.

  • Measure the resistance from the OEM harness aftertreatment 1 DEF dosing valve 2 connector sensor RETURN pin to the OEM harness aftertreatment 1 connector DEF dosing valve 2 sensor RETURN pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For OEM harness repair. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the OEM aftertreatment 1 harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 2 from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment 1 DEF dosing valve 2 sensor RETURN pin in the OEM harness aftertreatment 1 connector and all other pins in the connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Fault Code 2349 active?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For OEM harness repair. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM OEM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2E

Guided Step 2E - Check the aftertreatment 1 engine harness DEF dosing valve 2 return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness from the engine harness aftertreatment 1 connector.

Action

Check the dosing valve sensor return circuit.

  • Measure the resistance from the engine harness aftertreatment 1 connector sensor RETURN pin to the ECM connector aftertreatment 1 DEF dosing valve 2 sensor RETURN pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the harness.

Repair or replace the damaged section of the harness.

For engine harness repair. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2F

Go to 3A

Guided Step 2F - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment 1 DEF dosing valve 2 sensor RETURN pin in the OEM connector and all other pins in the connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the aftertreatment 1 DEF dosing valve 2. Refer to Procedure 011-059 in the Associated Procedures Table.

A pin-to-pin short circuit has been detected in the harness. Repair or replace the damaged section of the harness.

  • For engine harness repair. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 19-May-2016


FAULT CODE 5755 - Aftertreatment 1 Diesel Exhaust Fluid Pressure 2 - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSK95 CM2350 K113 | 4388663
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Line Restriction Test | Refer to Procedure 011-086 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid System Connection Test | Refer to Procedure 011-107 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Suction Test | Refer to Procedure 011-121 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 5755 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for related fault codes. | Fault Code 1712 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1C. Check for low diesel exhaust fluid (DEF) tank level. | DEF tank empty and/or Fault Code 1673, 3497, or 3498 active?
 | STEP 1D. Check for active fault codes. | Fault Code 1683, 1684, 1712, 1713, 3237, 3239, 3242, 3258, 3261, 3422, 3425, 3426, 3429, 3559, 3558, 3562, 3563, 3564, 3571, 3572, 3575, 3576, 3596, 3713, 4167, 5278, or 5935 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1E. Check for crossed connections. | Any crossed systems found per Procedure 011-107?
STEP 2. | Check the aftertreatment DEF lines and fittings. |
 | STEP 2A. Inspect the aftertreatment DEF lines and fittings. | Any reversed, damaged, leaking, or restricted connections found?
 | STEP 2B. Check the DEF tank. | DEF tank and vent clean and free of debris?
STEP 3. | Check the aftertreatment DEF dosing unit. |
 | STEP 3A. Check the aftertreatment DEF dosing unit. | Vacuum in diagnostic line greater than -203.2 mm-Hg [-8.0 in-Hg]?
 | STEP 3B. Check the aftertreatment DEF dosing unit. | DEF unit operating?
 | STEP 3C. Inspect the ECM and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 3D. Check for an open return circuit in the harness. | Less than 10 ohms?
STEP 4. | Check the aftertreatment DEF intake system. |
 | STEP 4A. Check the DEF dosing unit intake restriction. | Restriction less than -150 mm-Hg [-6 in-Hg]?
STEP 5. | Check for air in the aftertreatment DEF. |
 | STEP 5A. Check for air in the DEF. | Air in the DEF detected?
STEP 6. | Check the aftertreatment DEF pressure sensor. |
 | STEP 6A. Inspect the aftertreatment DEF pressure sensor. | Aftertreatment DEF pressure reading in INSITE™ electronic service tool equal to 0 ±69 kPa [0 ±10 psi]?
 | STEP 6B. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 6C. Check for an open circuit in the harness. | Less than 10 ohms?
STEP 7. | Check the aftertreatment DEF lines and fittings. |
 | STEP 7A. Check for pressure at the aftertreatment DEF dosing valve. | DEF pressure less than 950 kPa [137 psi]?
 | STEP 7A-1. Check for pressure at the aftertreatment DEF dosing valve. |
 | STEP 7A-2. Check for pressure at the aftertreatment DEF dosing valve. |
 | STEP 7B. Check for pressure out of the aftertreatment DEF dosing unit. | DEF pressure less than 950 kPa [137 psi]?
 | STEP 7C. Check for pressure out of the aftertreatment DEF dosing unit. | DEF pressure less than 750 kPa [108 psi]?
 | STEP 7D. Check the aftertreatment DEF dosing unit for blockage. | DEF dosing unit blocked or restricted?
STEP 8. | Check the aftertreatment DEF dosing unit operation. |
 | STEP 8A. Check the aftertreatment DEF dosing system operation. | Dosing volume within the specifications in Procedure 011-063?
STEP 9. | Check ECM calibration and clear fault codes. |
 | STEP 9A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 9B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5755 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1712 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

Fault Code 1712 indicates the aftertreatment DEF tank is frozen.

Troubleshoot occurrences of Fault Code 1712 before troubleshooting Fault Code 5755.

 No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for low DEF tank level.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

  • Check for the following active Fault Codes: 1673, 3497, and 3498.

DEF tank empty and/or Fault Code 1673, 3497, or 3498 active?
YES NO

Fill the DEF tank.

 No Repair

Go to 9A

Go to 1D

Guided Step 1D - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1683, 1684, 1712, 1713, 3237, 3239, 3242, 3258, 3261, 3422, 3425, 3426, 3429, 3559, 3558, 3562, 3563, 3564, 3571, 3572, 3575, 3576, 3596, 3713, 4167, 5278, or 5935 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

See the appropriate fault code troubleshooting tree.

Go to 1E

Guided Step 1E - Check for crossed connections.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to check for cross-connection of components. Refer to Procedure 011-107 in the Associated Procedures Table.
  • Trace the DEF pressure line from the DEF dosing unit. Verify it is connected to the correct DEF dosing valve, by component location, on the aftertreatment.

Any crossed systems found per Procedure 011-107?
YES NO

Correct the crossed systems. Refer to Procedure 011-107 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 2A

Guided Step 2 - Check the aftertreatment DEF lines and fittings.

Guided Step 2A - Inspect the aftertreatment DEF lines and fittings.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the following aftertreatment DEF fittings and lines.

  • Dosing unit supply line between the tank and dosing unit (suction line)
  • Dosing valve supply line between the dosing unit and dosing valve (pressure line)
  • Return line between the dosing valve and tank (return line).

Inspect all three DEF lines and associated fittings/connectors:

  • Verify the lines are not swapped at the dosing unit, dosing valve, or DEF tank connections. Reversed DEF line connectors cause the dosing system to fail to prime.
  • Check the DEF tank connections (suction and return lines) for cracks and pitting.
  • Check both dosing unit connections and fittings for loose, leaking, or damaged connections.
  • Disconnect the suction line and pressure line dosing unit connectors. Look for signs of buildup or blockage.
  • Check the suction line for signs of leakage or openings which will allow the dosing unit to suck in air with the DEF.
  • Check the pressure line for signs of leakage or rupture.
  • Verify proper sealing at all connection points, including DEF tank (two connections), dosing unit (two connections), and dosing valve (two connections).

Refer to Procedure 011-058 in the Associated Procedures Table.

Any reversed, damaged, leaking, or restricted connections found?
YES NO

Replace the leaking DEF line, as necessary. See equipment manufacturer service information.

 No Repair

Go to 9A

Go to 2B

Guided Step 2B - Check the DEF tank.

Conditions

  • Turn keyswitch OFF.

Action

  • Check the DEF tank for contamination or debris. Refer to Procedure 011-056 in the Associated Procedures Table.
  • Check the DEF tank vent for crystallization, buildup, and clogging.

DEF tank and vent clean and free of debris?
YES NO
No Repair

Flush the DEF system. Refer to Procedure 011-056 in the Associated Procedures Table.

  • Drain the DEF tank. Thoroughly flush with distilled water.
  • Clean and flush the DEF tank head and filter. Replace the DEF tank filter, as necessary.
  • Remove and flush the dosing unit intake and return lines.
  • Make sure the DEF dosing unit intake and fitting and filter are new. Refer to Procedure 011-058 in the Associated Procedures Table.
  • Fill the DEF tank with clean, certified DEF.

Go to 3A

Go to 9A

Guided Step 3 - Check the aftertreatment DEF dosing unit.

Guided Step 3A - Check the aftertreatment DEF dosing unit.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Refer to Procedure 011-121 in the Associated Procedures Table.

Vacuum in diagnostic line greater than -203.2 mm-Hg [-8.0 in-Hg]?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the aftertreatment DEF dosing unit.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Verify dosing unit was making sound or vibration.

DEF unit operating?
YES NO

Remove the dosing unit intake screen and main filter.

Inspect the intake screen and DEF in the main filter well for debris.

If any debris is visible, the system is contaminated with debris and must be flushed. Refer to Procedure 011-056 in the Associated Procedures Table.

  • Drain the DEF tank. Thoroughly flush with distilled water.
  • Clean and flush the DEF tank head and filter. Replace the DEF tank filter, as necessary.
  • Remove and flush the dosing unit intake line.
  • Fill the DEF tank with clean, certified DEF.

Perform the airless flush. Refer to Procedure 011-058 in the Associated Procedures Table.

Run the DEF Dosing Unit Suction Test. Refer to Procedure 011-121 in the Associated Procedures Table.

If vacuum is not greater than -203.2 mm-Hg [-8.0 in-Hg] gauge when tested, replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

If vacuum is greater than -203.2 mm-Hg [-8.0 in-Hg] gauge when tested, the dosing unit should be reused.

  • Make sure the DEF dosing unit intake screen and main filter are new. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 3C

Guided Step 3C - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor, ECM engine connector, or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 3D

Guided Step 3D - Check for an open return circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

  • Measure the resistance between the aftertreatment DEF dosing unit RETURN pin in the OEM harness ECM connector and the aftertreatment DEF dosing unit RETURN pin in the OEM harness dosing valve connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

A malfunctioning DEF dosing unit has been detected.

Replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

An open return circuit has been detected in the harness.

Repair or replace the damaged section of the harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 9A

Go to 9A

Guided Step 4 - Check the aftertreatment DEF intake system.

Guided Step 4A - Check the DEF dosing unit intake restriction.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Refer to Procedure 011-086 in the Associated Procedures Table.

Restriction less than -150 mm-Hg [-6 in-Hg]?
YES NO
No Repair

Clean or replace the DEF tank filter, DEF tank vent filter, and DEF suction line, as necessary.

Drain the DEF tank. Flush with distilled water. Fill the DEF tank with clean, certified DEF.

See equipment manufacturer service information.

Go to 5A

Go to 9A

Guided Step 5 - Check for air in the aftertreatment DEF.

Guided Step 5A - Check for air in the DEF.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Refer to Procedure 011-075 in the Associated Procedures Table.

Air in the DEF detected?
YES NO

Check the following components for damage/leaks. Repair, as necessary.

  • Aftertreatment DEF dosing unit supply line
  • Aftertreatment DEF tank fittings
  • Aftertreatment DEF tank stand pipe.

Refer to Procedure 011-075 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 6A

Guided Step 6 - Check the aftertreatment DEF pressure sensor.

Guided Step 6A - Inspect the aftertreatment DEF pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Disconnect the aftertreatment DEF dosing valve pressure line (this is the supply line between the dosing unit and dosing valve).
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to monitor the aftertreatment DEF pressure.

Aftertreatment DEF pressure reading in INSITE™ electronic service tool equal to 0 ±69 kPa [0 ±10 psi]?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6B

Guided Step 6B - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor, ECM engine connector, or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 6C

Guided Step 6C - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the aftertreatment 1 DEF dosing unit from the OEM harness.

Action

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor SUPPLY pin in the OEM harness ECM connector and the aftertreatment 1 DEF pressure sensor SUPPLY pin in the OEM harness aftertreatment 1 DEF dosing valve connector.
  • Measure the resistance between the aftertreatment 1 DEF pressure sensor SIGNAL pin in the OEM harness ECM connector and the aftertreatment 1 DEF pressure sensor SIGNAL pin in the OEM harness aftertreatment 1 DEF dosing valve connector.
  • Measure the resistance between the aftertreatment 1 DEF pressure sensor RETURN pin in the OEM harness ECM connector and the aftertreatment 1 DEF pressure sensor RETURN pin in the OEM harness dosing valve connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

A damaged aftertreatment DEF pressure sensor has been detected.

Replace the aftertreatment DEF dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

An open circuit has been detected in the harness.

Repair or replace the damaged section of the harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 7A

Go to 9A

Guided Step 7 - Check the aftertreatment DEF lines and fittings.

Guided Step 7A - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the inlet of the dosing valve and pressure line (this is the supply line between the dosing unit and dosing valve). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Test.
  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 950 kPa [137 psi]?
YES | NO
No Repair | No Repair

Go to 7B

Go to 7A-1

Guided Step 7A-1 - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the outlet of the dosing valve and return line (this is the return line between the dosing valve and tank). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Connect the DEF pressure line to the inlet of the dosing valve.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.

Read the DEF pressure from the service tool gauge.

DEF pressure less than 70 kPa [10 psi]?
YES NO
No Repair

A blocked or restricted return line and/or tank head has been detected. Clean or replace the return line and/or tank head, as necessary.

See equipment manufacturer service information.

Go to 7A-2

Go to 7B

Guided Step 7A-2 - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Install the DEF pressure gauge between the inlet of the dosing valve and pressure line. Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.

Read the DEF pressure from the service tool gauge.

DEF pressure reading ±70 kPa [±10 psi] of gauge reading?
YES NO
No Repair

Replace the inlet screen per Procedure 011-059. Perform this step again.

If still out of specification, replace the dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 7B

Go to 9A

Guided Step 7B - Check for pressure out of the aftertreatment DEF dosing unit.

Conditions

  • Turn keyswitch OFF.
  • Connect the DEF pressure line to the inlet of the dosing valve.
  • Install the DEF pressure gauge between the outlet of the dosing unit and pressure line (this is the supply line between the dosing unit and dosing valve). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 950 kPa [137 psi]?
YES NO
No Repair

A restricted pressure line has been detected. Clean or replace the pressure line, as necessary.

See equipment manufacturer service information.

Go to 7C

Go to 9A

Guided Step 7C - Check for pressure out of the aftertreatment DEF dosing unit.

Conditions

  • Turn keyswitch OFF.
  • Install the DEF pressure gauge between the outlet of the dosing unit and pressure line (this is the supply line between the dosing unit and dosing valve). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 750 kPa [108 psi]?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7D

Guided Step 7D - Check the aftertreatment DEF dosing unit for blockage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve pressure line from the dosing valve (pressure line runs between the dosing unit and dosing valve).
  • Disconnect the aftertreatment DEF dosing valve pressure line from the DEF dosing unit.

Action

  • Inspect the outlet fitting for signs of buildup or blockage.
  • Inspect the dosing unit filter for signs of buildup or blockage.
  • Inspect the inlet fitting screen for signs of buildup or blockage.

DEF dosing unit blocked or restricted?
YES NO

Clean the aftertreatment DEF dosing unit outlet or inlet fitting if needed.

Replace the aftertreatment DEF dosing unit filter if needed. Refer to Procedure 011-060 in the Associated Procedures Table.

A malfunctioning DEF dosing unit has been detected.

Replace the aftertreatment DEF dosing unit. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 9A

Go to 9A

Guided Step 8 - Check the aftertreatment DEF dosing unit operation.

Guided Step 8A - Check the aftertreatment DEF dosing system operation.

Conditions

  • Connect all DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove aftertreatment DEF dosing valve from decomposition chamber.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use the following procedure for instructions and specifications. Refer to Procedure 011-063 in the Associated Procedures Table.

The aftertreatment DEF dosing valve must be removed and placed in a measuring container having greater than a 1.5 liter [50 oz] capacity to run the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Dosing volume within the specifications in Procedure 011-063?
YES NO
No Repair

Refer to Procedure 011-063 in the Associated Procedures Table for repair instructions.

Go to 9A

Go to 9A

Guided Step 9 - Check ECM calibration and clear fault codes.

Guided Step 9A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 9B

Go to 9B

Guided Step 9B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Mar-2017


FAULT CODE 5756 - Aftertreatment 1 Diesel Exhaust Fluid Pressure 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid System Connection Test | Refer to Procedure 011-107 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5756 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3596, 3571, 3572, 5278, 5935, 5936, 5864, or 5865 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1C. Check for crossed connections. | Any crossed connections per Procedure 011-107?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) lines and fittings. |
 | STEP 2A. Check for pressure at the aftertreatment DEF dosing valve. | DEF pressure greater than 70 kPa [10 psi]?
 | STEP 2B. Check for pressure at the aftertreatment DEF tank head. | DEF pressure less than 70 kPa [10 psi]?
 | STEP 2C. Check for pressure at the aftertreatment DEF dosing valve. | DEF pressure reading ±70 kPa [±10 psi] for gauge reading?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5756 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3596, 3571, 3572, 5278, 5935, 5936, 5864, or 5865 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for crossed connections.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to check for cross-connection of components. Refer to Procedure 011-107 in the Associated Procedures Table.

Any crossed system found per Procedure 011-107?
YES NO

Correct the crossed systems. Refer to Procedure 011-107 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the aftertreatment DEF lines and fittings.

Guided Step 2A - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the inlet of the dosing valve and return line (this is the return line between the dosing valve and tank). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, located under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure greater than 70 kPa [10 psi]?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2B

Guided Step 2B - Check for pressure at the aftertreatment DEF tank head.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the inlet of the tank head and return line (this is the return line between the dosing valve and tank). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 70 kPa [10 psi]?
YES NO

A blocked or restricted return line has been detected.

Clean or replace the return line, as necessary.

See equipment manufacturer service information.

A blocked or restricted tank head has been detected.

Clean or replace the tank head, as necessary.

See equipment manufacturer service information.

Go to 3A

Go to 3A

Guided Step 2C - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Install the DEF pressure gauge between the inlet of the dosing valve and pressure line. Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure reading ±70 kPa [±10 psi] of gauge reading?
YES NO
No Repair

Replace the inlet screen. Refer to Procedure 011-059 in the Associated Procedures Table. Perform this step again.

If still out of specification, replace the dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 22-Mar-2017


FAULT CODE 5757 - Aftertreatment 1 Diesel Exhaust Fluid Pressure 2 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid System Connection Test | Refer to Procedure 011-107 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5757 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3571, 3572, 5278, 5935, 5936, 5864, or 5865 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) pressure sensor. |
 | STEP 2A. Inspect the aftertreatment DEF pressure sensor. | Aftertreatment DEF pressure reading in INSITE™ electronic service tool equal to 0 ±69 kPa [0 ±10 psi]?
STEP 3. | Check the aftertreatment DEF lines and fittings. |
 | STEP 3A. Check for pressure at the aftertreatment DEF dosing valve. | DEF pressure less than 70 kPa [10 psi]?
 | STEP 3B. Check for pressure at the aftertreatment DEF tank head. | DEF pressure less than 70 kPa [10 psi]?
 | STEP 3C. Check for pressure at the aftertreatment DEF dosing valve. | DEF pressure reading ± 70 kPa [10 psi] of gauge reading?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5757 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3571, 3572, 5278, 5935, 5936, 5864, or 5865 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for crossed connections.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for crossed connections.

  • Use INSITE™ electronic service tool to check for cross-connection of components. Refer to Procedure 011-107 in the Associated Procedures Table.
  • Trace the DEF pressure line from the DEF dosing unit and verify it is connected to the correct DEF dosing valve, by component location, on the aftertreatment.

Any crossed systems found per 011-107?
YES NO

Correct the crossed systems. Refer to Procedure 011-107 in the Associated Procedures Table.

No Repair

4A

Go to 2A

Guided Step 2 - Check the aftertreatment DEF pressure sensor.

Guided Step 2A - Inspect the aftertreatment DEF pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve supply line.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Inspect the aftertreatment DEF pressure sensor.

  • Use INSITE™ electronic service tool to monitor the aftertreatment DEF pressure.

Aftertreatment DEF pressure reading in INSITE™ electronic service tool equal to 0 ±69 kPa [0 ±10 psi]?
YES NO
No Repair

A damaged aftertreatment DEF pressure sensor has been detected.

Replace the aftertreatment DEF dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF lines and fittings.

Guided Step 3A - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the outlet of the dosing valve and return line (this is the return line between the dosing valve and tank). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

Attempt to prime the DEF system.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 70 kPa [10 psi]?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B

Guided Step 3B - Check for pressure at the aftertreatment DEF tank head.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the inlet of the tank head and the return line (this is the return line between the dosing valve and the tank). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

Attempt to prime the DEF system.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 70 kPa [10 psi]?
YES NO

A blocked or restricted return line has been detected.

Clean or replace the return line, as necessary.

See equipment manufacturer service information.

A blocked or restricted tank head has been detected.

Clean or replace the tank head, as necessary.

See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 3C - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • turn keyswitch OFF.
  • Install the DEF pressure gauge between the inlet of the dosing valve and the pressure line. Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

Check for pressure at the aftertreatment DEF dosing valve.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure reading ± 70 kPa [10 psi] of gauge reading?
YES NO
No Repair

Replace inlet screen per Procedure 011-059 and perform this step again.

If still out of spec then replace dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 22-Mar-2017


FAULT CODE 5758 - Aftertreatment 1 Diesel Exhaust Fluid Dosing 2 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Interface Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 5758 active?
STEP 2. | Check the aftertreatment 1 diesel exhaust fluid (DEF) dosing temperature sensor 2 and circuit. |
 | STEP 2A. Inspect the aftertreatment 1 DEF dosing temperature sensor 2 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 5759 active and Fault Code 5758 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 5758 active?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for an active fault code. | Fault Code 5758 active?
 | STEP 3D. Inspect the ECM harness connector pins in the engine harness. |
 | STEP 3E. Check for pin-to-pin short circuit in the engine harness. |
 | STEP 3F. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5758 active?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment 1 diesel exhaust fluid (DEF) dosing temperature sensor 2 and circuit.

Guided Step 2A - Inspect the aftertreatment 1 DEF dosing temperature sensor 2 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 2 from the OEM harness.

Action

Inspect the OEM harness and the aftertreatment 1 DEF dosing valve 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the sensor or harness connection.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 2 from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

See the circuit diagram or wiring diagram for connector pin identification.

Fault Code 5759 active and Fault Code 5758 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 1 DEF dosing valve 2 to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5758 active?
YES NO

A damaged temperature sensor has been detected in the aftertreatment 1 DEF dosing valve 2.

Replace the aftertreatment 1 DEF dosing valve 2. Refer to Procedure 011-059 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malunctioning connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 2 from the OEM harness.

Action

Check for a pin-to-pin short circuit in the harness.

  • Measure the resistance between the aftertreatment 1 DEF dosing temperature sensor 2 SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot each section of harness connected in series to determine which one contains the short circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-598 in the Associated Procedures Table.

  • Use the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5758 active?
YES NO

None. The removal and installation of the connector corrected the fault.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Inspect the ECM harness connector pins in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the ECM harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3E

Guided Step 3E - Check for pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit in the harness.

  • Measure the resistance between the aftertreatment 1 DEF dosing temperature sensor 2 SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5758 active?
YES NO

None. The removal and installation of the connector corrected the fault.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the ”Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 27-Apr-2016


FAULT CODE 5759 - Aftertreatment 1 Diesel Exhaust Fluid Dosing 2 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Interface Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5759 active?
STEP 2. | Check the aftertreatment 1 diesel exhaust fluid (DEF) dosing temperature sensor 2 and circuit. |
 | STEP 2A. Inspect the aftertreatment 1 DEF dosing temperature sensor 2 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 5758 active and Fault Code 5759 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 5759 active?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ECM power supply ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3E. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3F. Check for an active fault code. | Fault Code 5759 active?
 | STEP 3G. Inspect the ECM harness connector pins. | Dirty or damaged pins?
 | STEP 3H. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3I. Check for a pin-to-ECM power supply ground short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3J. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3K. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3L. Check for an active fault code. | Fault Code 5759 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5759 active?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment 1 diesel exhaust fluid (DEF) dosing temperature sensor 2 and circuit.

Guided Step 2A - Inspect the aftertreatment 1 DEF dosing temperature sensor 2 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 2 from the OEM harness.

Action

Inspect the OEM harness and the aftertreatment 1 DEF dosing valve 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the sensor or harness connection.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 2 from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the aftertreatment 1 DEF dosing valve 2 5V SUPPLY pin and the aftertreatment 1 DEF dosing temperature 2 SIGNAL pin at the aftertreatment 1 DEF dosing valve connector of the OEM harness.

See the circuit diagram or wiring diagram for connector pin identification.

  • Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5758 active and Fault Code 5759 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 1 DEF dosing valve 2 to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5759 active?
YES NO

A malfunctioning sensor has been detected in the aftertreatment 1 DEF dosing valve 2.

Replace the aftertreatment 1 DEF dosing valve 2. Refer to Procedure 011-059 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 2 from the OEM harness

Action

Check for a pin-to-pin short circuit in the harness.

  • Measure the resistance between the aftertreatment 1 DEF dosing temperature sensor 2 SIGNAL pin in the OEM harness aftertreatment 1 connector and all other pins in the OEM harness aftertreatment 1 connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot each section of harness connected in series to determine which one contains the short circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-598 in the Associated Procedures Table.

If a short circuit is isolated to damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ECM power supply ground short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 2 from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing temperature sensor 2 SIGNAL pin in the OEM harness aftertreatment 1 connector and ECM power supply ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Refer to Procedure 019-610 in the Associated Procedures Table.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot each section of harness connected in series to determine which one contains the short circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-598 in the Associated Procedures Table.

If a short circuit is isolated to damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 2 from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness aftertreatment 1 connector DEF dosing temperature sensor 2 RETURN pin and the OEM harness aftertreatment 1 connector DEF dosing valve 2 connector DEF dosing temperature sensor RETURN pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Troubleshoot each section of harness connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 2 from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness aftertreatment 1 connector DEF dosing temperature sensor 2 SIGNAL pin and the OEM harness aftertreatment 1 connector DEF dosing valve 2 connector DEF dosing temperature sensor SIGNAL pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Troubleshoot each section of harness connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5759 active?
YES NO

None. The removal and installation of the connector corrected the fault.

 No Repair

Go to 4A

Go to 4A

Guided Step 3G - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the ECM harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3H

Guided Step 3H - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector

Action

Check for a pin-to-pin short circuit in the harness.

  • Measure the resistance between the aftertreatment 1 DEF dosing temperature sensor 2 SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Repair or replace the damaged section of harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3I

Go to 4A

Guided Step 3I - Check for a pin-to-ECM power supply ground short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing temperature sensor 2 SIGNAL pin in the OEM harness ECM connector and ECM power supply ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit on the SIGNAL wire has been detected in the harness.

Repair or replace the damaged section of harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3J

Go to 4A

Guided Step 3J - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment 1 DEF dosing temperature sensor 2 RETURN pin and the OEM harness aftertreatment 1 connector DEF dosing valve 2 DEF dosing temperature sensor RETURN pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Repair or replace the damaged section of harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3K

Go to 4A

Guided Step 3K - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment 1 DEF dosing temperature sensor 2 SIGNAL pin and the OEM harness aftertreatment 1 connector DEF dosing valve 2 DEF dosing temperature sensor SIGNAL pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Repair or replace the damaged section of the harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3L

Go to 4A

Guided Step 3L - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5759 active?
YES NO

None. The removal and installation of the connector corrected the fault.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the ”Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 27-Apr-2016


FAULT CODE 5764 - Aftertreatment 1 Diesel Exhaust Fluid Dosing 2 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid System Leak Test | Refer to Procedure 011-080 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active diesel exhaust fluid (DEF) dosing system fault codes. | Fault Code 4242 active?
STEP 2. | Check the DEF dosing system. |
 | STEP 2A. Inspect the aftertreatment 1 DEF dosing valve 2 and connectors. | Damage to the DEF dosing valve or DEF line connector detected?
 | STEP 2B. Inspect the aftertreatment 1 DEF dosing valve 2 for leaks. | DEF leaking from the aftertreatment 1 DEF dosing valve 2 during system leak test?
 | STEP 2C. Check the aftertreatment 1 DEF dosing valve 2 for proper operation. | Aftertreatment 1 DEF dosing valve 2 operates according to the specifications in Procedure 011-063 in the Associated Procedures Table?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1B - Check for active diesel exhaust fluid (DEF) dosing system fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4242 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the DEF dosing system.

Guided Step 2A - Inspect the aftertreatment 1 DEF dosing valve 2 and connectors.

Conditions

  • Turn keyswitch ON.

Action

Check the aftertreatment 1 DEF dosing valve 2, DEF line, and connectors at the dosing valve 2 for the following:

  • Loose or leaking connections
  • Damage from overheating or melted connectors.

Damage to the DEF dosing valve or DEF line connector detected?
YES NO

Replace any damaged components.

  • Replace the aftertreatment 1 DEF dosing valve 2. Refer to Procedure 011-059 in the Associated Procedures Table.
  • Replace the aftertreatment 1 DEF line(s). See equipment manufacturer service information.

 No Repair

Go to 2B

Go to 2B

Guided Step 2B - Inspect the aftertreatment 1 DEF dosing valve 2 for leaks.

Conditions

  • Connect all DEF lines and electrical connectors.
  • Remove the aftertreatment 1 DEF dosing valve 2 from the decomposition reactor tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the aftertreatment 1 DEF dosing valve 2 for proper operation.

  • Use INSITE™ electronic service tool to perform the DEF System Leak Test found under ECM Diagnostic Tests. Refer to Procedure 011-080 in the Associated Procedures Table.

The DEF dosing valve must be removed and placed in a measuring container in order to leak check the DEF valve.

DEF leaking from the aftertreatment 1 DEF dosing valve 2 during the system leak test?
YES NO

A leaking aftertreatment DEF1 dosing valve 2 has been detected.

Replace the aftertreatment 1 DEF dosing valve 2. Refer to Procedure 011-059 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the aftertreatment 1 DEF dosing valve 2 for proper operation.

Conditions

  • Make sure all DEF lines and electrical connectors are connected appropriately.
  • Remove the aftertreatment 1 DEF dosing valve 2 from the decomposition reactor tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the DEF Doser Pump Override Test found under ECM Diagnostic Tests.

  • Refer to Procedure 011-063 in the Associated Procedures Table.

The DEF dosing valve must be removed and placed in a measuring container in order to perform the DEF Doser Pump Override Test. Make sure the DEF dosing valve is not plugged and the DEF spray pattern is correct.

Aftertreatment 1 DEF dosing valve 2 operates according to the specifications in Procedure 011-063 in the Associated Procedures Table?

YES NO
No Repair

Replace the aftertreatment 1 DEF 2 dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the ”Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 25-Apr-2016


FAULT CODE 5767 - Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit 2 Input Lines - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSK95 CM2350 K113 | 4388663
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Heater | Refer to Procedure 011-112 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Line Heater Relay | Refer to Procedure 019-600 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Heater Relay | Refer to Procedure 019-620 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 5767 active or more than two inactive counts?
 | STEP 1B. Check for diesel exhaust fluid (DEF) related fault codes. | Fault Code 1712 active or more than two inactive counts?
 | STEP 1C. Check for low DEF tank level. | DEF tank empty and/or Fault Code 1673, 3497, or 3498 active?
 | STEP 1D. Check DEF tank for debris. | DEF tank and vent clean and free of debris?
 | STEP 1E. Check ambient operating temperatures. | Equipment operating in ambient temperatures below -5°C [23°F] at the time of the fault set?
STEP 2. | Check the aftertreatment 2 dosing system 2 DEF line heaters. |
 | STEP 2A. Test the aftertreatment 1 DEF line heater relays. | Aftertreatment 1 line heater relays within specification?
 | STEP 2B. Check the DEF line heater functionality. | All line heaters functioning correctly?
 | STEP 2C. Inspect the original equipment manufacturer (OEM) harness and line heater connections. | Dirty or damaged pins?
 | STEP 2D. Check line heater supply voltage and return circuits. | All measurements within 1 VDC of engine control module (ECM) power supply voltage?
 | STEP 2E. Check line heater supply voltage to the ECM power supply ground. | All measurements within 1 VDC of ECM power supply voltage?
STEP 3. | Check the aftertreatment 2 DEF dosing unit 1 heating system. |
 | STEP 3A. Check the aftertreatment 1 DEF dosing unit heater relay. | Aftertreatment 1 DEF dosing unit heater relay within specifications?
 | STEP 3B. Inspect the aftertreatment 2 DEF dosing unit 2 heater and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check heater circuit resistance in the aftertreatment 2 DEF dosing unit 2 heater. | Resistance at 5.4 ohms ± 2.0 ohm?
 | STEP 3D. Check for an open circuit in the aftertreatment 2 DEF dosing unit 2 heater supply circuit. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 3E. Check aftertreatment 2 DEF dosing unit 2 heater supply voltage to ECM power supply ground. | All measurements within 1 VDC of ECM power supply voltage?
STEP 4. | Check the aftertreatment 2 DEF dosing unit 2 lines and fittings. |
 | STEP 4A. Inspect the aftertreatment 2 DEF dosing unit 2 lines and fittings. | Reversed, damaged, leaking, or restricted connections found?
 | STEP 4B. Check for pressure at the aftertreatment 2 DEF dosing valve 2. | DEF pressure greater than 1000 kPa [145 psi]?
 | STEP 4C. Check the aftertreatment 2 DEF dosing unit 2 supply line. | DEF dosing unit supply line blocked or restricted?
 | STEP 4D. Check the aftertreatment 2 DEF dosing valve 2 pressure line. | DEF pressure line blocked or restricted?
STEP 5. | Check the aftertreatment 2 DEF dosing valve 2 system return. |
 | STEP 5A. Check for a blocked aftertreatment 2 DEF dosing valve 2. | DEF pressure greater than 700 kPa [102 psi]?
 | STEP 5B. Check the aftertreatment 2 DEF dosing valve 2 return line. | DEF return line blocked or restricted?
STEP 6. | Check the aftertreatment 2 unit 2 DEF suction line. |
 | STEP 6A. Chec for air in the DEF. | Air in the DEF detected?
 | STEP 6B. Check for an intermittent aftertreatment 2 DEF dosing unit 2 suction line leak. | Wiggling the DEF suction line connections affects the system pressure?
 | STEP 6C. Check the aftertreatment 2 DEF pressure. | DEF pressure greater than 750 kPa [109 psi]?
STEP 7. | Check the aftertreatment DEF dosing valve 2 operation. |
 | STEP 7A. Check the aftertreatment DEF dosing system operation. | Dosing volume within the specifications in Procedure 011-063 in the Associated Procedures Table?
 | STEP 7B. Check the results of the doser override test. | DEF pressure at the service tool gauge reading above 700 kPa [102 psi] for the duration of the test?
STEP 8. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 8A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 8B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5767 active or more than two inactive counts?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for diesel exhaust fluid (DEF) related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1712 active or more than two inactive counts?
YES NO

Fault Code 1712 indicates the aftertreatment DEF tank is frozen. Troubleshoot occurrences of Fault Code 1712 before troubleshooting Fault Code 5767.

No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for low DEF tank level.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Make sure the DEF tank is not empty and the tank level gauge is accurate.

Use INSITE™ electronic service tool to read the fault codes.

  • Check for the following active Fault Codes: 1673, 3497, and 3498.

DEF tank empty and/or Fault Code 1673, 3497, or 3498 active?
YES NO

Fill the DEF tank.

 No Repair

Go to 8A

Go to 1D

Guided Step 1D - Check DEF tank for debris.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF tank.

  • Check the DEF tank for debris or foreign particles.
  • Check the DEF tank vent for crystallization buildup and clogging.
  • Use the Cummins® DEF Refractometer Service Tool, Part Number 4919554, to test the DEF concentration.

DEF tank and vent clean and free of debris?
YES NO
No Repair

Clean the DEF tank and tank filter thoroughly. Replace the tank filter, if necessary. See equipment manufacturer service information.

Fill the tank with certified DEF.

If the DEF in the tank is dirty, replace the DEF dosing unit 2 filter and inlet screen. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 1E

Go to 8A

Guided Step 1E - Check ambient operating temperatures.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check if the equipment was operating in a cold ambient environment (below -5°C [23°F]) at the time the fault logged.

Use INSITE™ electronic service tool to read the fault code snapshot and check the ambient air temperature sensor to verify.

Equipment operating in ambient temperatures below -5°C [23°F] at the time the fault set?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the aftertreatment 2 dosing system 2 DEF line heaters.

Guided Step 2A - Test the aftertreatment 2 DEF line heater relays.

Conditions

  • Turn keyswitch OFF.

Action

Test the aftertreatment 1 DEF line heater relays (K14).

  • Refer to Procedure 019-600 in the Associated Procedures Table.

Aftertreatment 2 line heater relays within specification?
YES NO
No Repair

A damaged line heater relay has been detected. Replace damaged relay. Refer to Procedure 019-600 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Check DEF line heater functionality.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the DEF Doser System Heater Test.

Use an infrared thermometer to measure the surface temperature at the ends of each of the three aftertreatment 2 unit 2 DEF lines.

Look for the following:

  • Surface temperature above 10°C [50°F]
  • Temperature uniformity across the length of individual lines
  • Temperature uniformity between lines.

If the lines were not at operating temperature when the test was started, a temperature rise will be noticeable.

All lines heaters functioning correctly?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2C

Guided Step 2C - Inspect the OEM harness and line heater connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the three line heaters (suction, pressure, and return) from the OEM harness.

Action

Inspect the OEM harness and line heater connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the line heater or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 8A

Go to 2D

Guided Step 2D - Check line heater supply voltage and return circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the three line heaters (suction, pressure, and return) from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuits.

  • Measure the voltage from the line heater +24 volt SUPPLY pin to the line heater RETURN pin at the heater connector of the OEM harness.

Use INSITE™ electronic service tool to perform the DEF Doser System Heater Test found under ECM Diagnostic Tests.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

All measurements within 1 VDC of ECM power supply voltage?
YES NO

Replace the malfunctioning line heater(s). See equipment manufacturer service information.

 No Repair

Go to 8A

Go to 2E

Guided Step 2E - Check line heater supply voltage to ECM power supply ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the three line heaters (suction, pressure, and return) from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuits.

  • Measure the voltage from the line heater +24 volt SUPPLY pin to ECM power supply ground.

Use INSITE™ electronic service tool to perform the Aftertreatment DEF Doser System Heater Test found under ECM Diagnostic Tests.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Refer to Procedure 019-610 in the Associated Procedures Table.

All measurements within 1 VDC of ECM power supply voltage?
YES NO

An open has been detected in the line heater return circuit.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness,

Repair or replace the damaged section of harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Troubleshoot return circuit in Refer to Procedure 019-598 in the Associated Procedures Table.

An open has been detected between the line heater relay and the line heater.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Troubleshoot return circuit in. Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 8A

Go to 8A

Guided Step 3 - Check the aftertreatment 2 DEF dosing unit 2 heating system.

Guided Step 3A - Check the aftertreatment 2 diesel exhaust fluid (DEF) dosing unit heater relay.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment 2 DEF dosing unit heater relay (K2) from the aftertreatment junction box. Refer to Procedure 019-620 in the Associated Procedures Table.

Action

Test aftertreatment 2 DEF dosing unit heater relay.

  • Refer to Procedure 019-620 in the Associated Procedures Table.

Refer to the appropriate wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Aftertreatment 2 DEF dosing unit heater relay within specifications?
YES NO
No Repair

Replace the aftertreatment 2 DEF dosing unit heater relay (K2). Refer to Procedure 019-620 in the Associated Procedures Table.

Go to 8A

Go to 3B

Guided Step 3B - Inspect the aftertreatment 2 DEF dosing unit 2 heater and connector pins.

Conditions

  • Operate the engine.
  • Disconnect the aftertreatment 2 DEF dosing unit 2 heater from the OEM harness.

Action

Inspect the DEF dosing unit heater and OEM harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment DEF dosing unit heater or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace dosing unit heater only when there are damaged pins. Refer to Procedure 011-112 in the Associated Procedures Table.

 No Repair

Go to 8A

Go to 3C

Guided Step 3C - Check heater circuit resistance in the aftertreatment 2 DEF dosing unit 2 heater.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check resistance at the dosing unit heater.

  • Measure the resistance across heater at the aftertreatment DEF dosing unit heater supply and the aftertreatment DEF dosing unit heater return at the DEF dosing unit.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Resistance at 5.4 ohms ± 2.0 ohm?

YES NO
No Repair

A malfunctioning aftertreatment DEF dosing unit heater has been detected.

Replace the aftertreatment DEF dosing unit heater. Refer to Procedure 011-112 in the Associated Procedures Table.

Go to 3D

Go to 8A

Guided Step 3D - Check for an open circuit in the aftertreatment 2 DEF dosing unit 2 heater supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 2 heater from the OEM harness.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Perform the Aftertreatment Diesel Exhaust Fluid Doser System Heater Test found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool.
  • Measure the voltage between aftertreatment 2 DEF dosing unit 2 heater supply pin at the aftertreatment 2 DEF dosing unit 2 heater connector and ECM power supply ground.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Refer to Procedure 019-610 in the Associated Procedures Table.

Voltage within 1 VDC of ECM power supply voltage?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DEF dosing unit heater supply circuit.

Check the aftertreatment DEF dosing unit heater circuit breaker. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, Repair or replace the damaged section of harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 8A

Guided Step 3E - Check aftertreatment 2 DEF dosing unit 2 heater supply voltage to the ECM power supply ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 2 heater from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuits.

  • Measure the voltage from the line heater +24 volt SUPPLY pin to ECM power supply ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Refer to Procedure 019-610 in the Associated Procedures Table.

All measurements within 1 VDC of ECM power supply voltage?
YES NO

An open has been detected in the heater return circuit.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, Repair or replace the damaged section of harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Troubleshoot return circuit in. Refer to Procedure 019-598 in the Associated Procedures Table.

An open has been detected between the heater relay and the heater.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, Repair or replace the damaged section of harness.

Troubleshoot return circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 8A

Go to 8A

Guided Step 4 - Check the aftertreatment 2 DEF dosing unit 2 lines and fittings.

Guided Step 4A - Inspect the aftertreatment 2 DEF dosing unit 2 lines and fittings.

Conditions

  • Turn keyswitch OFF.

Action

There are three DEF lines on the selective catalytic reduction dosing system:

  • Dosing unit 2 supply line between the tank and the dosing unit (suction line)
  • Dosing valve 2 supply line between the dosing unit and the dosing valve (pressure line)
  • Return line between the dosing valve 2 and the tank (return line).

Inspect all three DEF lines and associated fittings/connectors:

  • Inspect the dosing unit for a plugged inlet filter in the inlet fitting. Refer to Procedure 011-058 in the Associated Procedures Table.
  • Inspect the dosing unit DEF filter. Refer to procedure 011-060 in the Associated Procedures Table.
  • Verify the DEF line connections are not swapped at the dosing unit, dosing valve or DEF tank. Reversed DEF lines can cause the dosing system to fail to prime.
  • Check the DEF tank connections (suction and return lines) for cracks and pitting.
  • Check both dosing unit connections and fittings for loose, leaking, or damaged connections.
  • Check the suction line for signs of leakage or openings which will allow the dosing unit to suck in air with the DEF.
  • Check the pressure line for signs of leakage or rupture.
  • Disconnect the suction line, pressure line, and return line connectors. Look for signs of buildup or blockage.
  • Verify proper sealing at all connection points and check for damaged or missing o-rings.

Reversed, damaged, leaking, or restricted connections found?
YES NO

Replace the DEF line(s) and fittings and filters as necessary. If DEF dosing unit inlet filter screen is plugged replace tank filter.

See equipment manufacturer service information.

For DEF dosing unit inlet filter screen. Refer to Procedure 011-058 in the Associated Procedures Table.

For DEF dosing unit filter: Refer to Procedure 011-060 in the Associated Procedures Table.

For Dosing unit connections: Refer to Procedure 011-058 in the Associated Procedures Table.

Repair or replace the aftertreatment DEF dosing unit, as necessary.

Refer to Procedure 011-058 in the Associated Procedures Table.

Replace DEF dosing unit inlet filter screen and dosing unit DEF filter. These filters can not be reused and must be changed upon removal.

Refer to Procedure 011-060 in the Associated Procedures Table.

Go to 8A

Go to 4B

Guided Step 4B - Check for pressure at the aftertreatment 2 DEF dosing valve 2.

Conditions

  • Turn keyswitch OFF.
  • Install the DEF pressure gauge between the inlet of the dosing valve 2 and the pressure line. Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

Attempt to prime the DEF system.

  • Use INSITE™ electronic service tool to perform the Aftertreatment DEF System Leak Test, located under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure greater than 1000 kPa [145 psi]?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check the aftertreatment 2 DEF dosing unit 2 supply line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 2 supply line from the dosing unit (this is the suction line between the dosing unit and the DEF tank).
  • Disconnect the aftertreatment 2 DEF dosing unit 2 supply line from the DEF tank.

Action

Check the DEF dosing unit 2 supply line for blockage.

  • Check both ends of the dosing unit 2 supply line for signs of buildup or blockage.
  • Blow compressed shop air through the dosing unit 2 supply line to make sure of free flow.

DEF dosing unit 2 supply line blocked or restricted?
YES NO

Try to clean the dosing unit supply line with shop air. If necessary, replace the dosing unit supply line.

See equipment manufacturer service information.

 No Repair

Go to 8A

Go to 4D

Guided Step 4D - Check the aftertreatment 2 DEF dosing valve 2 pressure line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 2 pressure line from the dosing valve (pressure line runs between the dosing unit and dosing valve).
  • Disconnect the aftertreatment 2 DEF dosing valve 2 pressure line from the DEF dosing unit.

Action

Check the aftertreatment 2 DEF pressure line for blockage.

  • Check both ends of the line for signs of buildup or blockage.
  • Blow compressed shop air through the pressure line to make sure of free flow.

DEF pressure line blocked or restricted?
YES NO

Try to clean the pressure line using shop air. If necessary, replace the pressure line.

See equipment manufacturer service information.

 No Repair

Go to 8A

Go to 6A

Guided Step 5 - Check the aftertreatment 2 DEF dosing valve 2 system return.

Guided Step 5A - Check for a blocked aftertreatment 2 DEF dosing valve 2.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the outlet of the dosing valve and the return line. Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

Attempt to prime the DEF system.

  • Use INSITE™ electronic service tool to perform the Aftertreatment DEF System Leak Test, located under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure greater than 700 kPa [102 psi]?
YES NO
No Repair

Replace the DEF dosing valve 2. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 5B

Go to 8A

Guided Step 5B - Check the aftertreatment 2 DEF dosing valve 2 return line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 2 return line from the dosing valve 2.
  • Disconnect the aftertreatment 2 DEF dosing valve 2 return line from the DEF tank.

Action

Check the aftertreatment 2 DEF return line for blockage.

  • Check both ends of the line for signs of buildup or blockage.
  • Blow compressed shop air through the return line to make sure of free flow.

DEF return line blocked or restricted?
YES NO

Try to clean the return line using shop air. If necessary, replace the return line.

See equipment manufacturer service information.

A blocked or restricted return has been detected in the DEF tank head. Clean or replace the tank head, as necessary.

See equipment manufacturer service information.

Go to 8A

Go to 8A

Guided Step 6 - Check the aftertreatment 2 unit 2 DEF suction line.

Guided Step 6A - Check for air in the DEF.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for air in the DEF.

  • Refer to Procedure 011-075 in the Associated Procedures Table.

Air in the DEF detected?
YES NO

Check the following components for damage/leaks. Repair, as necessary.

  • Aftertreatment 2 DEF dosing unit 2 fittings
  • Aftertreatment 2 DEF dosing unit 2 supply line
  • Aftertreatment DEF tank fittings
  • Aftertreatment DEF tank filter.

Refer to Procedure 011-075 in the Associated Procedures Table.

 No Repair

Go to 8A

Go to 6B

Guided Step 6B - Check for an intermittent aftertreatment 2 DEF dosing unit 2 suction line leak.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.

Action

Attempt to prime the DEF system. Use INSITE™ electronic service tool to perform the Aftertreatment DEF System Leak Test, located under ECM Diagnostic Tests.

As the DEF system is trying to prime, wiggle the suction line connections at the dosing unit and tank. Monitor the DEF pressure sensor reading in INSITE™ electronic service tool data monitor/logger section.

  • Check if wiggling the suction line connections causes the system to either build pressure or lose prime.
  • Listen for audible indication from the pump that wiggling the suction line is causing air to enter the system.

Wiggling the DEF suction line connections affects the system pressure?
YES NO

Replace the DEF suction line. See equipment manufacturer service information.

 No Repair

Go to 8A

Go to 6C

Guided Step 6C - Check the aftertreatment 2 DEF pressure.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.

Action

Attempt to prime the DEF system.

Use INSITE™ electronic service tool to perform the Aftertreatment DEF System Leak Test, located under ECM Diagnostic Tests.

  • Monitor the DEF pressure sensor reading in the INSITE™ electronic service tool Data Monitor/Logger section.

DEF pressure greater than 750 kPa [109 psi]?
YES NO
No Repair

Replace the DEF dosing unit 2. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 7A

Go to 8A

Guided Step 7 - Check the aftertreatment 2 DEF dosing valve 2 operation.

Guided Step 7A - Check the aftertreatment 2 DEF dosing system operation.

Conditions

  • Connect the DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove the aftertreatment 2 DEF dosing valve 2 from the decomposition chamber.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment DEF Doser Pump Override Test, located under ECM Diagnostic Tests.

  • Use the following procedure for instructions and specifications. Refer to Procedure 011-063 in the Associated Procedures Table.

The aftertreatment dosing valve must be removed and placed in a measuring container having greater than a 1.5 liter [50 oz] capacity to run the Aftertreatment DEF Doser Pump Override Test.

Dosing volume within the specifications in Procedure 011-063 in the Associated Procedures Table?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7B

Guided Step 7B - Check the results of the doser override test.

Conditions

  • Turn keyswitch OFF.

Action

Check the doser override test results.

  • Check the service pressure tool reading recoded during the Aftertreatment DEF Doser Pump Override Test.

DEF pressure at the service tool gauge reading above 700 kPa [102 psi] for the duration of the test?
YES NO

Replace the aftertreatment 2 DEF dosing valve 2. Refer to Procedure 011-059 in the Associated Procedures Table.

Replace the aftertreatment 2 DEF dosing unit 2. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 8A

Go to 8A

Guided Step 8 - Check ECM calibration and clear fault codes.

Guided Step 8A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 8B

Go to 8B

Guided Step 8B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the ”Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process

Repair complete.

Last Modified: 03-May-2017


FAULT CODE 5768 - Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Interface Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 5768 active?
STEP 2. | Check the aftertreatment 2 diesel exhaust fluid (DEF) dosing unit 2 and circuit. |
 | STEP 2A. Inspect the aftertreatment 2 DEF dosing unit 2 and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit on the aftertreatment 2 DEF dosing unit 2 supply in the original equipment manufacturer (OEM) harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit on the aftertreatment 2 DEF dosing unit 2 supply in the OEM harness. | Greater than 100k ohms?
 | STEP 2D. Check for a pin-to-pin short circuit on the aftertreatment 2 DEF dosing unit 2 signal in the OEM harness. | Greater than 100k ohms?
 | STEP 2E. Check for an open circuit on the aftertreatment 2 DEF dosing unit 2 supply in the engine harness. | Less than 10 ohms?
 | STEP 2F. Check for a pin-to-pin short circuit on the aftertreatment 2 DEF dosing unit 2 supply in the engine harness. | Greater than 100K ohms?
 | STEP 2G. Check for a pin-to-pin short circuit on the aftertreatment 2 DEF dosing unit 2 signal in the engine harness. | Greater than 100K ohms?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5768 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 2 diesel exhaust fluid (DEF) dosing unit 2 and circuit.

Guided Step 2A - Inspect the aftertreatment 2 DEF dosing unit 2 and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 2 from the OEM harness.

Action

Inspect the harness and aftertreatment 2 DEF dosing unit 2 connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit on the aftertreatment 2 DEF dosing unit 2 supply in the original equipment manufacturer (OEM) harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 2 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness aftertreatment 2 DEF dosing unit 2 SUPPLY pin and OEM harness aftertreatment 2 connector DEF dosing unit 2 SUPPLY pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit on the aftertreatment 2 DEF dosing unit 2 supply in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 2 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit 2 SUPPLY pin of the OEM harness aftertreatment 2 connector and all other pins in the connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If a short circuit is isolated to damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-pin short circuit on the aftertreatment 2 DEF dosing unit 2 signal in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 2 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit 2 command SIGNAL pin of the OEM harness aftertreatment 2 connector and all other pins in the connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If a short circuit is isolated to damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for an open circuit on the aftertreatment 2 DEF dosing unit 2 supply in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the OEM connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness aftertreatment 2 connector DEF dosing unit 2 SUPPLY pin and OEM harness ECM connector aftertreatment 2 DEF dosing unit 2 SUPPLY pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected.

Repair or replace the damaged section of harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2F

Go to 3A

Guided Step 2F - Check for a pin-to-pin short circuit on the aftertreatment 2 DEF dosing unit 2 supply in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the OEM connector from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing 2 unit SUPPLY pin of the OEM harness ECM connector and all other pins in the connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected.

Repair or replace the damaged section of harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2G

Go to 3A

Guided Step 2G - Check for a pin-to-pin short circuit on the aftertreatment 2 DEF dosing unit 2 signal in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the OEM connector from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit 2 command SIGNAL pin of the OEM harness ECM connector and all other pins in the connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the aftertreatment 2 DEF dosing unit 2. Refer to Procedure 011-058 in the Associated Procedures Table.

A pin-to-pin short circuit has been detected.

Repair or replace the damaged section of harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the ”Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 27-Apr-2016


FAULT CODE 5769 - Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit 2 Circuit - Voltage Above Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Interface Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 5769 active?
STEP 2. | Check the aftertreatment 2 diesel exhaust fluid (DEF) dosing unit 2 and circuit. |
 | STEP 2A. Inspect the aftertreatment 2 DEF dosing unit 2 and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit on the aftertreatment 1 DEF dosing unit 2 signal circuit in the original equipment manufacturer (OEM) harness. | Less than 10 ohms?
 | STEP 2C. Check for an open circuit on the aftertreatment 2 DEF dosing unit 2 supply in the engine harness. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-engine control module (ECM) power supply ground short circuit on the aftertreatment 2 DEF dosing unit 2 signal in the OEM harness. | Greater than 100k ohms?
 | STEP 2E. Check for a pin-to-ground short circuit on the aftertreatment 2 DEF dosing unit 2 supply in the OEM harness. | Greater than 100k ohms?
 | STEP 2F. Check for a pin-to-pin short circuit in the in the OEM harness. | Greater than 100K ohms?
 | STEP 2G. Check for an open circuit on the aftertreatment 2 DEF dosing unit 2 signal circuit in the engine harness. | Less than 10 ohms?
 | STEP 2H. Check for an open circuit on the aftertreatment 2 DEF dosing unit 2 supply in the engine harness. | Less than 10 ohms?
 | STEP 2I. Check for a pin-to-ground short circuit on the aftertreatment 2 DEF dosing unit 2 signal in the engine harness. | Greater than 100k ohms?
 | STEP 2J. Check for a pin-to-ground short circuit on the aftertreatment 2 DEF dosing unit 2 supply in the engine harness. | Greater than 100k ohms?
 | STEP 2K. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5769 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 2 diesel exhaust fluid (DEF) dosing unit 2 and circuit.

Guided Step 2A - Inspect the aftertreatment 2 DEF dosing unit 2 and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 2 from the OEM harness.

Action

Inspect the harness and aftertreatment 2 DEF dosing unit 2 connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit on the aftertreatment 1 DEF dosing unit 2 signal circuit in the original equipment manufacturer (OEM) harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 2 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit 2 command SIGNAL pin at the dosing unit wiring harness connector and aftertreatment 2 DEF dosing unit 2 command SIGNAL pin in the OEM harness Aftertreatment 2 connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit on the aftertreatment 2 DEF dosing unit 2 supply in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 2 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit 2 SUPPLY pin at the dosing unit wiring harness connector and aftertreatment 2 DEF dosing unit 2 SUPPLY pin in the OEM harness aftertreatment 2 connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the associated Procedures Table, if equipped.

If a short circuit is isolated to damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-engine control module (ECM) power supply ground short circuit on the aftertreatment 2 DEF dosing unit 2 signal in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 2 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit 2 command SIGNAL pin of the OEM harness aftertreatment 2 connector and ECM power supply ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Refer to Procedure 019-610 in the Associated Procedures Table.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit has been detected.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If a short circuit is isolated to damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a pin-to-ECM power supply ground short circuit on the aftertreatment 2 DEF dosing unit 2 supply in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 2 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit 2 SUPPLY pin of the OEM harness Aftertreatment 2 connector and ECM power supply ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Refer to Procedure 019-610 in the Associated Procedures Table.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit has been detected.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If a short circuit is isolated to damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check for a pin-to-pin short circuit in the in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 2 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit 2 SIGNAL pin of the OEM harness aftertreatment 2 connector and all other pins in the OEM harness ECM connector.
  • Measure the resistance between the aftertreatment 2 DEF dosing unit 2 SUPPLY pin of the OEM harness aftertreatment 2 connector and all other pins in the OEM harness ECM connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If a short circuit is isolated to damaged harness, repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 2G

Go to 3A

Guided Step 2G - Check for an open circuit on the aftertreatment 2 DEF dosing unit 2 signal circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the OEM connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness aftertreatment 2 connector DEF dosing unit 2 command SIGNAL pin and the aftertreatment 2 DEF dosing unit 2 command SIGNAL pin in the OEM harness ECM connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected.

Repair or replace the damaged section of harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2H

Go to 3A

Guided Step 2H - Check for an open circuit on the aftertreatment 2 DEF dosing unit 2 supply in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the OEM connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness aftertreatment 2 connector DEF dosing unit 2 SUPPLY and the aftertreatment 2 DEF dosing unit 2 SUPPLY pin in the OEM harness ECM connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected.

Repair or replace the damaged section of harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2I

Go to 3A

Guided Step 2I - Check for a pin-to-ECM power supply ground short circuit on the aftertreatment 2 DEF dosing unit 2 signal in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the OEM connector from the ECM.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit 2 command SIGNAL pin of the OEM harness ECM connector and ECM power supply ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Refer to Procedure 019-610 in the Associated Procedures Table.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit has been detected.

Repair or replace the damaged section of harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2J

Go to 3A

Guided Step 2J - Check for a pin-to-ECM power supply ground short circuit on the aftertreatment 2 DEF dosing unit 2 supply in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the OEM connector from the ECM.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit 2 SUPPLY pin of the OEM harness ECM connector and ECM power supply ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Refer to Procedure 019-610 in the Associated Procedures Table.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit has been detected.

Repair or replace the damaged section of harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2K

Go to 3A

Guided Step 2K - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the OEM connector from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit 2 SIGNAL pin of the OEM harness ECM connector and all other pins in the OEM harness ECM connector.
  • Measure the resistance between the aftertreatment 2 DEF dosing unit 2 SUPPLY pin of the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the aftertreatment 2 DEF dosing unit 2. Refer to Procedure 011-058 in the Associated Procedures Table.

A pin-to-pin short circuit has been detected.

Repair or replace the damaged section of harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the ”Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 27-Apr-2016


FAULT CODE 5771 - Aftertreatment 2 Diesel Exhaust Fluid Dosing Valve 2 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for aftertreatment 2 diesel exhaust fluid (DEF) dosing valve 2 fault codes. | Fault Code 5771 active?
STEP 2. | Check the aftertreatment 2 DEF dosing valve 2 and circuit. |
 | STEP 2A. Inspect the aftertreatment 2 DEF dosing valve 2 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the aftertreatment 2 DEF dosing valve 2 resistance. | Resistance between 10 and 17 ohms?
STEP 3. | Check the engine and original equipment manufacture (OEM) harness. |
 | STEP 3A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the aftertreatment 2 DEF dosing valve 2 signal circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check the aftertreatment 2 DEF dosing valve 2 return circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Inspect the ECM harness connector pins. | Dirty or damaged pins?
 | STEP 3G. Check the aftertreatment 2 DEF dosing valve 2 signal circuit. | Less than 10 ohms?
 | STEP 3H. Check the aftertreatment 2 DEF dosing valve 2 return circuit. | Less than 10 ohms?
 | STEP 3I. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3J. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1B - Check for aftertreatment 2 DEF dosing valve 2 fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5771 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the aftertreatment 2 DEF dosing valve 2 and circuit.

Guided Step 2A - Inspect the aftertreatment 2 DEF dosing valve 2 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 2 from the OEM harness.

Action

Inspect the OEM harness and aftertreatment 2 DEF dosing valve 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing valve or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the aftertreatment 2 DEF dosing valve 2 resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 2 from the OEM harness.

Action

Check for an internal short or open circuit in the aftertreatment 2 DEF dosing valve 2 by measuring the internal resistance.

  • Measure the resistance between the aftertreatment 2 DEF dosing valve 2 SIGNAL pin to the aftertreatment 2 DEF dosing valve 2 RETURN pin at the aftertreatment 2 DEF dosing valve 2 connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 10 and 17 ohms?
YES NO
No Repair

An internal short or open circuit has been detected in the aftertreatment 2 DEF dosing valve 2.

Replace the aftertreatment 2 DEF dosing valve 2. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine and OEM harness.

Guided Step 3A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the engine harness aftertreatment 2 connector.

Action

Inspect the OEM harness aftertreatment 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness aftertreatment 2 connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the aftertreatment 2 DEF dosing valve 2 signal circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 2 from the OEM harness.

Action

Check the dosing valve signal circuit.

  • Measure the resistance between the OEM harness aftertreatment 2 DEF dosing valve 2 connector SIGNAL pin and to the OEM harness aftertreatment 2 connector DEF dosing valve 2 SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the aftertreatment 2 DEF dosing valve 2 return circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 2 from the OEM harness.

Action

Check the dosing valve return circuit.

  • Measure the resistance between the OEM harness aftertreatment 2 DEF dosing valve 2 connector RETURN pin to the OEM aftertreatment 2 connector DEF dosing valve 2 RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 2 from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing valve 2 SIGNAL pin in the OEM harness aftertreatment 2 connector and ground.
  • Measure the resistance between the aftertreatment 2 DEF dosing valve 2 RETURN pin in the OEM harness aftertreatment 2 connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If a short circuit is isolated to damaged harness, repair or replace the damaged section of harness.

  • Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 2 from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing valve 2 SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If a short circuit is isolated to the damaged harness, repair or replace the damaged section of harness.

  • Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 3F - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3G

Guided Step 3G - Check the aftertreatment 2 DEF dosing valve 2 signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM connector from the engine harness aftertreatment 2 connector.

Action

Check the dosing valve signal circuit.

  • Measure the resistance between the OEM harness aftertreatment 2 connector DEF dosing valve 2 connector SIGNAL pin and to the ECM connector aftertreatment 2 DEF dosing valve 2 SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Repair or replace the damaged section of the harness.

For engine harness repair: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3H

Go to 4A

Guided Step 3H - Check the aftertreatment 2 DEF dosing valve 2 return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM connector from the engine harness aftertreatment 2 connector.

Action

Check the dosing valve signal circuit.

  • Measure the resistance between the OEM harness aftertreatment 2 connector DEF dosing valve 2 connector SIGNAL pin and to the ECM connector aftertreatment 2 DEF dosing valve 2 SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Repair or replace the damaged section of the harness.

For engine harness repair: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3I

Go to 4A

Guided Step 3I - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing valve 2 SIGNAL pin in the OEM harness ECM connector and ground.
  • Measure the resistance between the aftertreatment 2 DEF dosing valve 2 RETURN pin in the OEM harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the harness.

Repair or replace the damaged section of the harness.

For engine harness repair: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3J

Go to 4A

Guided Step 3J - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing valve 2 SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness.

Repair or replace the damaged section of the harness.

For engine harness repair: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 02-May-2016


FAULT CODE 5772 - Aftertreatment 2 Diesel Exhaust Fluid Pressure 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 5772 active?
STEP 2. | Check the aftertreatment 2 diesel exhaust fluid (DEF) pressure 2 sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment 2 DEF pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 5773 active and Fault Code 5772 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 5772 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness connector. |
 | STEP 3A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 5772 active?
 | STEP 3F. Inspect the ECM harness connector pins. | Dirty or damaged pins?
 | STEP 3G. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3H. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3I. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3J. Check for an active fault code. | Fault Code 5772 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5772 active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 2 DEF pressure sensor 2 and circuit.

Guided Step 2A - Inspect the aftertreatment 2 DEF pressure sensor 2 and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 2 from the OEM harness.

Action

Inspect the OEM harness and aftertreatment 2 DEF pressure sensor 2 connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 2 from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Other aftertreatment 2 DEF dosing unit 2 fault codes will be active.

Fault Code 5773 active and Fault Code 5772 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 2 from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the aftertreatment 2 DEF pressure 2 +5 volt SUPPLY pin to the aftertreatment 2 DEF pressure 2 RETURN pin at the dosing valve connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 2 DEF dosing valve 2 to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5772 active?
YES NO

A malfunctioning aftertreatment DEF pressure sensor has been detected inside the aftertreatment 2 DEF dosing valve 2.

Replace the aftertreatment 2 DEF dosing valve 2. Refer to Procedure 011-059 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM connector.

Guided Step 3A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the engine harness aftertreatment 2 connector.

Action

Inspect the OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the OEM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the harness in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM from the ECM connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 2 from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure 2 sensor RETURN pin in the OEM harness ECM connector and the aftertreatment 2 DEF pressure 2 sensor RETURN pin in the OEM harness dosing valve connector.

Refer to the wiring diagram for connector pin identification and the following procedure for general inspection techniques techniques. Refer to Procedure 019-361 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Troubleshoot each section of harness connected in series to determine which one contains the open return circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of the harness.

  • Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for engine harness repair. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 2 from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 2 SIGNAL pin in the OEM harness aftertreatment 2 connector and all other pins in the OEM harness aftertreatment 2 connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each section of harness connected in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If a short circuit is isolated to damaged harness, repair or replace the damaged section of the harness.

  • Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for engine harness repair. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 2 from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 2 SUPPLY pin in the OEM harness aftertreatment 2 connector and all other pins in the OEM harness aftertreatment 2 connector.

Refer to the wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the harness.

Troubleshoot each section of harness connected in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If a short circuit is isolated to damaged harness, repair or replace the damaged section of the harness.

  • Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5772 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3F

Go to 4A

Guided Step 3F - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM from the ECM.

Action

Inspect the OEM ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the ECM connector or the OEM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3G

Guided Step 3G - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM connector from the engine harness aftertreatment 2 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 2 RETURN pin in the OEM ECM connector and the aftertreatment 2 DEF pressure sensor 2 RETURN pin in the OEM harness connector from the engine harness aftertreatment 2 connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

An open return circuit has been detected in the harness.

Repair or replace the damaged section of engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3H

Go to 4A

Guided Step 3H - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 2 SIGNAL pin in the OEM ECM connector and all other pins in the OEM ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the damaged section of engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3I

Go to 4A

Guided Step 3I - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 2 SUPPLY pin in the OEM ECM connector and all other pins in the OEM ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the OEM harness.

Repair or replace the damaged section of engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3J

Go to 4A

Guided Step 3J - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5772 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault code.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 27-Apr-2016


FAULT CODE 5773 - Aftertreatment 2 Diesel Exhaust Fluid Pressure 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 5773 active?
STEP 2. | Check the aftertreatment 2 diesel exhaust fluid (DEF) pressure 2 sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment 2 DEF pressure sensor 2 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 5772 active and Fault Code 5773 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 5773 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the OEM aftertreatment 2 harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Inspect the ECM OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3G. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3H. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3I. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3J. Check for a pin-to-ground short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3K. Check for an active fault code. | Fault Code 5773 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5773 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 2 DEF pressure sensor 2 and circuit.

Guided Step 2A - Inspect the aftertreatment 2 DEF pressure sensor 2 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 2 from the OEM harness.

Action

Inspect the OEM harness and aftertreatment 2 DEF dosing valve 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 2 from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the aftertreatment 2 DEF pressure sensor 2 +5 volt SUPPLY pin to the aftertreatment 2 DEF pressure sensor 2 RETURN pin at the aftertreatment 2 DEF dosing valve 2 connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 2 from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment 2 DEF pressure sensor 2 +5 volt SUPPLY pin and the aftertreatment 2 DEF pressure sensor 2 SIGNAL pin at the aftertreatment 2 DEF dosing valve 2 connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Other DEF dosing valve fault codes will be active.

Fault Code 5772 active and Fault Code 5773 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 2 DEF dosing valve 2 to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5773 active?
YES NO

A damaged aftertreatment 2 DEF pressure sensor has been detected inside the aftertreatment 2 DEF dosing valve 2.

Replace the aftertreatment 2 DEF dosing valve 2. Refer to Procedure 011-059 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the OEM aftertreatment 2 harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the engine harness aftertreatment 2 connector.

Action

Inspect the OEM harness aftertreatment 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM aftertreatment 2 harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 2 from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 2 SUPPLY pin in the OEM harness aftertreatment 2 connector and the aftertreatment 2 DEF pressure sensor 2 SUPPLY pin in the OEM harness aftertreatment 2 DEF dosing valve 2 connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the harness.

Troubleshoot each section of harness connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of the harness.

  • Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 2 from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 2 SIGNAL pin in the OEM harness aftertreatment 2 connector and the aftertreatment 2 DEF pressure sensor 2 SIGNAL pin in the OEM harness aftertreatment 2 DEF dosing valve 2 connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Troubleshoot each section of harness connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of the harness.

  • Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 2 SIGNAL pin in the OEM harness aftertreatment 2 connector and all other pins in the OEM harness aftertreatment 2 connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each section of harness connected in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If a short circuit is isolated to damaged harness, repair or replace the damaged section of the harness.

  • Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 2 SIGNAL pin in the OEM harness aftertreatment 2 connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot each section of harness connected in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If a short circuit is isolated to damaged harness, repair or replace the damaged section of the harness.

  • Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Inspect the ECM OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the ECM OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot each section of harness connected in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If a short circuit is isolated to damaged harness, repair or replace the damaged section of the harness.

  • Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.

Go to 3G

Go to 4A

Guided Step 3G - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM connector from the engine harness aftertreatment 2 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 2 SUPPLY pin in the OEM harness ECM connector and the aftertreatment 2 DEF pressure sensor 2 SUPPLY pin in the OEM harness aftertreatment 2 connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the harness.

Repair or replace the damaged section of the harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3H

Go to 4A

Guided Step 3H - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM connector from the engine harness aftertreatment 2 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 2 SUPPLY pin in the OEM ECM connector and the aftertreatment 2 DEF pressure sensor 2 SUPPLY pin in the OEM harness aftertreatment 2 connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Repair or replace the damaged section of the harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3I

Go to 4A

Guided Step 3I - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 2 SIGNAL pin in the OEM ECM connector and all other pins in the OEM harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the damaged section of the harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3J

Go to 4A

Guided Step 3J - Check for a pin-to-ground short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 2 SIGNAL pin in the OEM ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the damaged section of the harness.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3K

Go to 4A

Guided Step 3K - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5773 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 27-Apr-2016


FAULT CODE 5774 - Aftertreatment 2 Diesel Exhaust Fluid Pressure 2 Sensor Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for aftertreatment 2 DEF dosing valve 2 fault codes. | Fault Code 5774 active?
STEP 2. | Check the aftertreatment 2 DEF dosing valve 2 and circuit. |
 | STEP 2A. Inspect the OEM aftertreatment 2 harness and aftertreatment 2 diesel exhaust fluid (DEF) dosing valve 2 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the OEM harness aftertreatment 2 DEF dosing valve 2 return circuit. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the OEM aftertreatment 2 harness. | Greater than 100k ohms?
 | STEP 2D. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 2E. Check the aftertreatment 2 engine harness DEF dosing valve 2 return circuit. | Less than 10 ohms?
 | STEP 2F. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for aftertreatment 2 DEF dosing valve 2 fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5774 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 2 DEF dosing valve 2 and circuit.

Guided Step 2A - Inspect the OEM aftertreatment 2 harness and aftertreatment 2 (DEF) dosing valve 2 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 2 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Inspect the OEM harness, aftertreatment 2 connector, and DEF dosing valve2r connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the valve or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the OEM harness aftertreatment 2 DEF dosing valve 2 return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 2 from the OEM harness.

Action

Check the dosing valve sensor return circuit.

  • Measure the resistance from the OEM harness aftertreatment 2 DEF dosing valve 2 connector sensor RETURN pin to the OEM harness aftertreatment 2 connector DEF dosing valve 2 sensor RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit isolated to a damaged harness, repair or replace the damaged section of harness.

  • For OEM harness repair: Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the OEM aftertreatment 2 harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 2 from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment 2 DEF dosing valve 2 sensor RETURN pin in the OEM harness aftertreatment 2 connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit isolated to a damaged harness, repair or replace the damaged section of harness.

  • For OEM harness repair: Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2E

Guided Step 2E - Check the aftertreatment 2 engine harness DEF dosing valve 2 return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness from the engine harness aftertreatment 2 connector.

Action

Check the dosing valve sensor return circuit.

  • Measure the resistance from the engine harness aftertreatment 2 connector sensor RETURN pin to the ECM connector aftertreatment 2 DEF dosing valve 2 sensor RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the harness.

Repair or replace the damaged section of the harness.

  • For engine harness repair: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2F

Go to 3A

Guided Step 2F - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment 2 DEF dosing valve 2 sensor RETURN pin in the OEM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the aftertreatment 2 DEF dosing valve 2. Refer to Procedure 011-059 in the Associated Procedures Table.

A pin-to-pin short circuit has been detected in the harness.

Repair or replace the damaged section of the harness.

  • For engine harness repair: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 25-Apr-2016


FAULT CODE 5775 - Aftertreatment 2 Diesel Exhaust Fluid Pressure 2 - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSK95 CM2350 K113 | 4388663
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Line Restriction Test | Refer to Procedure 011-086 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid System Connection Test | Refer to Procedure 011-107 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Suction Test | Refer to Procedure 011-121 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 5775 active inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for related fault codes. | Fault Code 1712 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1C. Check for low diesel exhaust fluid (DEF) tank level. | DEF tank empty and/or Fault Code 1673, 3497, or 3498 active?
 | STEP 1D. Check for active fault codes. | Fault Code 1683, 1684, 1712, 1713, 3237, 3239, 3242, 3258, 3261, 3422, 3425, 3426, 3429, 3559, 3558, 3562, 3563, 3564, 3571, 3572, 3575, 3576, 3596, 3713, 4167, 5278, or 5935 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1E. Check for crossed connections. | Any crossed systems found per 011-107 in the Associated Procedures Table?
STEP 2. | Check the aftertreatment DEF lines and fittings. |
 | STEP 2A. Inspect the aftertreatment DEF lines and fittings. | Any reversed, damaged, leaking, or restricted connections found?
 | STEP 2B. Check the DEF tank. | DEF tank and vent clean and free of debris?
STEP 3. | Check the aftertreatment DEF dosing unit. |
 | STEP 3A. Check the aftertreatment DEF dosing unit. | Vacuum in diagnostic line greater than -216 mm-Hg [-8 in-Hg]?
 | STEP 3B. Check the aftertreatment DEF dosing unit. | DEF unit operating?
 | STEP 3C. Inspect the ECM and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 3D. Check for an open return circuit in the harness. | Less than 10 ohms?
STEP 4. | Check the aftertreatment DEF intake system. |
 | STEP 4A. Check the DEF dosing unit intake restriction. | Restriction less than -254 mm-Hg [-6 in-Hg]?
STEP 5. | Check for air in the aftertreatment DEF. |
 | STEP 5A. Check for air in the DEF. | Air in the DEF detected?
STEP 6. | Check the aftertreatment DEF pressure sensor. |
 | STEP 6A. Inspect the aftertreatment DEF pressure sensor. | Aftertreatment DEF pressure reading in INSITE™ electronic service tool equal to 0 ±69 kPa [0 ±10 psi]?
 | STEP 6B. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 6C. Check for an open circuit in the harness. | Less than 10 ohms?
STEP 7. | Check the aftertreatment DEF lines and fittings. |
 | STEP 7A. Check for pressure at the aftertreatment DEF dosing valve. | DEF pressure less than 950 kPa [137 psi]?
 | STEP 7A-1. Check for pressure at the aftertreatment DEF dosing valve. |
 | STEP 7A-2. Check for pressure at the aftertreatment DEF dosing valve. |
 | STEP 7B. Check for pressure out of the aftertreatment DEF dosing unit. | DEF pressure less than 950 kPa [137 psi]?
 | STEP 7C. Check for pressure out of the aftertreatment DEF dosing unit. | DEF pressure less than 750 kPa [108 psi]?
 | STEP 7D. Check the aftertreatment DEF dosing unit for blockage. | DEF dosing unit blocked or restricted?
STEP 8. | Check the aftertreatment DEF dosing unit operation. |
 | STEP 8A. Check the aftertreatment DEF dosing unit system operation. | Dosing volume within the specifications in Procedure 011-063 in the Associated Procedures Table?
STEP 9. | Check ECM calibration and clear fault codes. |
 | STEP 9A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 9B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5775 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1712 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

Fault Code 1712 indicates the aftertreatment DEF tank is frozen. Troubleshoot occurrences of Fault Code 1712 before troubleshooting Fault Code 5775.

No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for low DEF tank level.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

  • Check for the following active Fault Codes: 1673, 3497, and 3498.

DEF tank empty and/or Fault Code 1673, 3497, or 3498 active?
YES NO

Fill the DEF tank.

 No Repair

Go to 9A

Go to 1D

Guided Step 1D - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1683, 1684, 1712, 1713, 3237, 3239, 3242, 3258, 3261, 3422, 3425, 3426, 3429, 3559, 3558, 3562, 3563, 3564, 3571, 3572, 3575, 3576, 3596, 3713, 4167, 5278, or 5935 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

See the appropriate fault code troubleshooting tree.

Go to 1E

Guided Step 1E - Check for crossed connections.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to check for cross-connection of components. Refer to Procedure 011-107 in the Associated Procedures Table.
  • Trace the DEF pressure line from the DEF dosing unit. Verify it is connected to the correct DEF dosing valve, by component location, on the aftertreatment.

Any crossed systems found per Procedure 011-107 in the Associated Procedures Table?
YES NO

Correct the crossed systems. Refer to Procedure 011-107 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 2A

Guided Step 2 - Check the aftertreatment DEF lines and fittings.

Guided Step 2A - Inspect the aftertreatment DEF lines and fittings.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the following aftertreatment DEF fittings and lines.

  • Dosing unit supply line between the tank and dosing unit (suction line)
  • Dosing valve supply line between the dosing unit and dosing valve (pressure line)
  • Return line between the dosing valve and tank (return line).

Inspect all three DEF lines and associated fittings/connectors:

  • Verify the lines are not swapped at the dosing unit, dosing valve, or DEF tank connections. Reversed DEF line connectors cause the dosing system to fail to prime.
  • Check the DEF tank connections (suction and return lines) for cracks and pitting.
  • Check both dosing unit connections and fittings for loose, leaking, or damaged connections.
  • Disconnect the suction line and pressure line dosing unit connectors. Look for signs of buildup or blockage.
  • Check the suction line for signs of leakage or openings which will allow the dosing unit to suck in air with the DEF.
  • Check the pressure line for sings of leakage or rupture.
  • Verify proper sealing at all connection points, including DEF tank (two connections), dosing unit (two connections), and dosing valve (two connections).

Refer to Procedure 011-058 in the Associated Procedures Table.

Any reversed, damaged, leaking, or restricted connections found?
YES NO

Replace the leaking DEF line, as necessary. See equipment manufacturer service information.

 No Repair

Go to 9A

Go to 2B

Guided Step 2B - Check the DEF tank.

Conditions

  • Turn keyswitch OFF.

Action

  • Check the DEF tank for contamination or debris. Refer to Procedure 011-056 in the Associated Procedures Table.
  • Check the DEF tank vent for crystallization, buildup, and clogging.

DEF tank and vent clean and free of debris?
YES NO
No Repair

Flush the DEF system. Refer to Procedure 011-056 in the Associated Procedures Table.

  • Drain the DEF tank. Thoroughly flush with distilled water.
  • Clean and flush the DEF tank head and filter. Replace the DEF tank filter, as necessary.
  • Remove and flush the dosing unit intake and return lines.
  • Make sure the DEF dosing unit intake and fitting and filter are new. Refer to Procedure 011-058 in the Associated Procedures Table.
  • Fill the DEF tank with clean, certified DEF.

Go to 3A

Go to 9A

Guided Step 3 - Check the aftertreatment DEF dosing unit.

Guided Step 3A - Check the aftertreatment DEF dosing unit.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Refer to Procedure 011-121 in the Associated Procedures Table.

Vacuum in diagnostic line greater than -203 mm-Hg [-8 in-Hg]?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the aftertreatment DEF dosing unit.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Dosing unit was making sound and/or vibration.

DEF unit operating?
YES NO

Remove the dosing unit intake screen and main filter.

Inspect the intake screen and DEF in the main filter well for debris.

If any debris is visible, the system is contaminated with debris and must be flushed. Refer to Procedure 011-056 in the Associated Procedures Table.

  • Drain the DEF tank. Thoroughly flush with distilled water.
  • Clean and flush the DEF tank head and filter. Replace the DEF tank filter, as necessary.
  • Remove and flush the dosing unit intake line.
  • Fill the DEF tank with clean, certified DEF.

Perform the airless flush. Refer to Procedure 011-058 in the Associated Procedures Table.

Run the DEF Dosing Unit Suction Test. Refer to Procedure 011-121 in the Associated Procedures Table.

If vacuum is not greater than -216 mm-Hg [-8 in-Hg] gauge when tested, replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

If vacuum is greater than -216 mm-Hg [-8 in-Hg] gauge when tested, the dosing unit should be reused.

  • DEF dosing unit intake screen and main filter are new. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 3C

Guided Step 3C - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor, ECM engine connector, or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 3D

Guided Step 3D - Check for an open return circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

  • Measure the resistance between the aftertreatment DEF dosing unit RETURN pin in the OEM harness ECM connector and the aftertreatment DEF dosing unit RETURN pin in the OEM harness dosing valve connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

A malfunctioning DEF dosing unit has been detected.

Replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 9A

Guided Step 4 - Check the aftertreatment DEF intake system.

Guided Step 4A - Check the DEF dosing unit intake restriction.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Refer to Procedure 011-086 in the Associated Procedures Table.

Restriction less than -150 mm-Hg [-6 in-Hg]?
YES NO
No Repair

Clean or replace the DEF tank filter, DEF tank vent filter, and DEF suction line, as necessary.

Drain the DEF tank. Flush with distilled water. Fill the DEF tank with clean, certified DEF.

See equipment manufacturer service information.

Go to 5A

Go to 9A

Guided Step 5 - Check for air in the aftertreatment DEF.

Guided Step 5A - Check for air in the DEF.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Refer to Procedure 011-075 in the Associated Procedures Table.

Air in the DEF detected?
YES NO

Check the following components for damage/leaks. Repair, as necessary.

  • Aftertreatment DEF dosing unit supply line
  • Aftertreatment DEF tank fittings
  • Aftertreatment DEF tank stand pipe.

Refer to Procedure 011-075 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 6A

Guided Step 6 - Check the aftertreatment DEF pressure sensor.

Guided Step 6A - Inspect the aftertreatment DEF pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Disconnect the aftertreatment DEF dosing valve pressure line (this is the supply line between the dosing unit and dosing valve).
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to monitor the aftertreatment DEF pressure.

Aftertreatment DEF pressure reading in INSITE™ electronic service tool equal to 0 ±69 kPa [0 ±10 psi]?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6B

Guided Step 6B - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor, ECM engine connector, or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 6C

Guided Step 6C - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the aftertreatment 1 DEF dosing unit from the OEM harness.

Action

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor SUPPLY pin in the OEM harness ECM connector and the aftertreatment 1 DEF pressure sensor SUPPLY pin in the OEM harness aftertreatment 1 DEF dosing valve connector.
  • Measure the resistance between the aftertreatment 1 DEF pressure sensor SIGNAL pin in the OEM harness ECM connector and the aftertreatment 1 DEF pressure sensor SIGNAL pin in the OEM harness aftertreatment 1 DEF dosing valve connector.
  • Measure the resistance between the aftertreatment 1 DEF pressure sensor RETURN pin in the OEM harness ECM connector and the aftertreatment 1 DEF pressure sensor RETURN pin in the OEM harness dosing valve connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

A damaged aftertreatment DEF pressure sensor has been detected.

Replace the aftertreatment DEF dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

An open circuit has been detected in the harness.

Repair or replace the damaged section of the harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 7A

Go to 9A

Guided Step 7 - Check the aftertreatment DEF lines and fittings.

Guided Step 7A - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the inlet of the dosing valve and pressure line (this is the supply line between the dosing unit and dosing valve). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Test.
  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 950 kPa [137 psi]?
YES | NO
No Repair | No Repair

Go to 7B

Go to 7A-1

Guided Step 7A-1 - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the outlet of the dosing valve and return line (this is the return line between the dosing valve and tank). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Connect the DEF pressure line to the inlet of the dosing valve.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.

Read the DEF pressure from the service tool gauge.

DEF pressure less than 70 kPa [10 psi]?
YES NO
No Repair

A blocked or restricted return line and/or tank head has been detected. Clean or replace the return line and/or tank head, as necessary.

See equipment manufacturer service information.

Go to 7A-2

Go to 7B

Guided Step 7A-2 - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Install the DEF pressure gauge between the inlet of the dosing valve and pressure line. Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.

Read the DEF pressure from the service tool gauge.

DEF pressure reading ±70 kPa [±10 psi] of gauge reading?
YES NO
No Repair

Replace the inlet screen per Procedure 011-059. Perform this step again.

If still out of specification, replace the dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 7B

Go to 9A

Guided Step 7B - Check for pressure out of the aftertreatment DEF dosing unit.

Conditions

  • Turn keyswitch OFF.
  • Connect the DEF pressure line to the inlet of the dosing valve.
  • Install the DEF pressure gauge between the outlet of the dosing unit and pressure line (this is the supply line between the dosing unit and dosing valve). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 950 kPa [137 psi]?
YES NO
No Repair

A restricted pressure line has been detected. Clean or replace the pressure line, as necessary.

See equipment manufacturer service information.

Go to 7C

Go to 9A

Guided Step 7C - Check for pressure out of the aftertreatment DEF dosing unit.

Conditions

  • Turn keyswitch OFF.
  • Install the DEF pressure gauge between the outlet of the dosing unit and pressure line (this is the supply line between the dosing unit and dosing valve). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 750 kPa [108 psi]?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7D

Guided Step 7D - Check the aftertreatment DEF dosing unit for blockage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve pressure line from the dosing valve (pressure line runs between the dosing unit and dosing valve).
  • Disconnect the aftertreatment DEF dosing valve pressure line from the DEF dosing unit.

Action

  • Inspect the outlet fitting for signs of buildup or blockage.
  • Inspect the dosing unit filter for signs of buildup or blockage.
  • Inspect the inlet fitting screen for signs of buildup or blockage.

DEF dosing unit blocked or restricted?
YES NO

Clean the aftertreatment DEF dosing unit outlet or inlet fitting if needed.

Replace the aftertreatment DEF dosing unit filter if needed. Refer to Procedure 011-060 in the Associated Procedures Table.

A malfunctioning DEF dosing unit has been detected.

Replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 9A

Go to 9A

Guided Step 8 - Check the aftertreatment DEF dosing unit operation.

Guided Step 8A - Check the aftertreatment DEF dosing system operation.

Conditions

  • Connect all DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove aftertreatment DEF dosing valve from decomposition chamber.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use the following procedure for instructions and specifications. Refer to Procedure 011-063 in the Associated Procedures Table.

The aftertreatment DEF dosing valve must be removed and placed in a measuring container having greater than a 1.5 liter [50 oz] capacity to run the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Dosing volume within the specifications in Procedure 011-063 in the Associated Procedures Table?
YES NO
No Repair

Refer to Procedure 011-063 in the Associated Procedures Table for repair instructions.

Go to 9A

Go to 9A

Guided Step 9 - Check ECM calibration and clear fault codes.

Guided Step 9A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 9B

Go to 9B

Guided Step 9B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-Apr-2017


FAULT CODE 5776 - Aftertreatment 2 Diesel Exhaust Fluid Pressure 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid System Connection Test | Refer to Procedure 011-107 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5776 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3596, 3571, 3572, 5278, 5935, 5936, 5864, or 5865 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1C. Check for crossed connections. | Any crossed system found per Procedure 011-107?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) lines and fittings. |
 | STEP 2A. Check for pressure at the aftertreatment DEF dosing valve. | DEF pressure greater than 70 kPa [10 psi]?
 | STEP 2B. Check for pressure at the aftertreatment DEF tank head. | DEF pressure less than 70 kPa [10 psi]?
 | STEP 2C. Check for pressure at the aftertreatment DEF dosing valve. | DEF pressure reading ±70 kPa [±10 psi] of gauge reading?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5776 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3596, 3571, 3572, 5278, 5935, 5936, 5864, or 5865 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for crossed connections.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to check for cross-connection of components. Refer to Procedure 011-107 in the Associated Procedures Table.
  • Trace the DEF pressure line from the DEF dosing unit. Verify it is connected to the correct DEF dosing valve, by component location, on the aftertreatment.

Any crossed system found per Procedure 011-107?
YES NO

Correct the crossed systems. Refer to Procedure 011-107 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the aftertreatment DEF lines and fittings.

Guided Step 2A - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the inlet of the dosing valve and return line (this is the return line between the dosing valve and tank). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, located under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure greater than 70 kPa [10 psi]?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2B

Guided Step 2B - Check for pressure at the aftertreatment DEF tank head.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the inlet of the tank head and return line (this is the return line between the dosing valve and tank). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 70 kPa [10 psi]?
YES NO

A blocked or restricted return line has been detected.

Clean or replace the return line, as necessary.

See equipment manufacturer service information.

A blocked or restricted tank head has been detected.

Clean or replace the tank head, as necessary.

See equipment manufacturer service information.

Go to 3A

Go to 3A

Guided Step 2C - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Install the DEF pressure gauge between the inlet of the dosing valve and pressure line. Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure reading ±70 kPa [±10 psi] of gauge reading?
YES NO
No Repair

Replace the inlet screen. Refer to Procedure 011-059 in the Associated Procedures Table. Perform this step again.

If still out of specification, replace the dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 22-Mar-2017


FAULT CODE 5777 - Aftertreatment 2 Diesel Exhaust Fluid Pressure 2 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSK95 CM2350 K1113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSK95 CM2350 K113 | 4388663
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5777 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3571, 3572, 5278, 5935, 5936, 5864, or 5865 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) pressure sensor. |
 | STEP 2A. Inspect the aftertreatment DEF pressure sensor. | Aftertreatment DEF pressure reading in INSITE™ electronic service tool equal to 0 ±69 kPa [0 ±10 psi]?
STEP 3. | Check the aftertreatment DEF lines and fittings. |
 | STEP 3A. Check for pressure at the aftertreatment DEF dosing valve. | DEF pressure less than 70 kPa [10 psi]?
 | STEP 3B. Check for pressure at the aftertreatment DEF tank head. | DEF pressure greater than 70 kPa [10 psi]?
 | STEP 3C. Check for pressure at the aftertreatment DEF dosing valve. | DEF pressure reading ± 70 kPa [10 psi] of gauge reading?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5777 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3571, 3572, 5278, 5935, 5936, 5864, or 5865 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for crossed connections.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to check for cross-connection of components refer to Procedure 011-107
  • Trace the DEF pressure line from the DEF dosing unit and verify it is connected to the correct DEF dosing valve, by component location, on the aftertreatment.

Any crossed systems found per 011-107?
YES NO

Correct the crossed systems.

Refer to Procedure 011-107 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the aftertreatment DEF pressure sensor.

Guided Step 2A - Inspect the aftertreatment DEF pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve supply line.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Inspect the aftertreatment DEF pressure sensor.

  • Use INSITE™ electronic service tool to monitor the aftertreatment DEF pressure.

Aftertreatment DEF pressure reading in INSITE™ electronic service tool equal to 0 ±69 kPa [0 ±10 psi]?
YES NO
No Repair

A damaged aftertreatment DEF pressure sensor has been detected.

Replace the aftertreatment DEF dosing valve 2. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF lines and fittings.

Guided Step 3A - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the outlet of the dosing valve and return line (this is the return line between the dosing valve and tank). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

Check for pressure at the aftertreatment DEF dosing valve.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

Refer to Procedure 011-058 in the Associated Procedures Table.

DEF pressure less than 70 kPa [10 psi]?
YES NO

No Repair

Go to 3C

Go to 3B

Guided Step 3B - Check for pressure at the aftertreatment DEF tank head.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for diesel exhaust fluid system pressure to leak down.
  • Install the DEF pressure gauge between the inlet of the tank head and the return line (this is the return line between the dosing valve and the tank). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

Attempt to prime the DEF system.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 70 kPa [10 psi]?
YES NO

A blocked or restricted return line has been detected.

Clean or replace the return line, as necessary.

See equipment manufacturer service information.

A blocked or restricted tank head has been detected.

Clean or replace the tank head, as necessary.

See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 3C - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Install the DEF pressure gauge between the inlet of the dosing valve and the pressure line. Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

Check for pressure at the aftertreatment DEF dosing valve.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure reading ± 70 kPa [10 psi] of gauge reading?
YES NO
No Repair

Replace inlet screen per Procedure 011-059 and perform this step again.

If still out of specification then replace dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 22-Mar-2017


FAULT CODE 5778 - Aftertreatment 2 Diesel Exhaust Fluid Dosing 2 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5778 active?
STEP 2. | Check the aftertreatment 2 diesel exhaust fluid (DEF) dosing 2 temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment 2 DEF dosing 2 temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 5779 active and Fault Code 5778 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 5778 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for an active fault code. | Fault Code 5778 active?
 | STEP 3D. Inspect the ECM harness connector pins in the engine harness. | Dirty or damaged pins?
 | STEP 3E. Check for pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3F. Check for an active fault code. | Fault Code 5778 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5778 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 2 DEF dosing temperature sensor 2 and circuit.

Guided Step 2A - Inspect the aftertreatment 2 DEF dosing temperature sensor 2 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 2 from the OEM harness.

Action

Inspect the OEM harness and the aftertreatment 2 DEF dosing valve 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 2 from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram for connector pin identification.

Fault Code 5779 active and Fault Code 5778 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 2 DEF dosing valve 2 to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5778 active?
YES NO

A damaged temperature sensor has been detected in the aftertreatment 2 DEF dosing valve 2.

Replace the aftertreatment 2 DEF dosing valve 2. Refer to Procedure 011-059 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 2 from the OEM harness.

Action

Check for a pin-to-pin short circuit in the harness.

  • Measure the resistance between the aftertreatment 2 DEF dosing temperature sensor 2 SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table , if equipped.

Repair or replace the damaged section of harness.

  • If a short circuit is isolated to damaged harness, repair or replace the damaged section of harness. Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5778 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3D

Go to 4A

Guided Step 3D - Inspect the ECM harness connector pins in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3E

Guided Step 3E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness connector from engine harness aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit in the harness.

  • Measure the resistance between the aftertreatment 2 DEF dosing temperature sensor 2 SIGNAL pin in the OEM ECM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5778 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 19-May-2016


FAULT CODE 5779 - Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit 2 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5779 active?
STEP 2. | Check the aftertreatment 2 diesel exhaust fluid (DEF) dosing temperature sensor 2 and circuit. |
 | STEP 2A. Inspect the aftertreatment 2 DEF dosing valve temperature sensor 2 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 5778 active and Fault Code 5779 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 5779 active?
STEP 3. | Check the original equipment manufacturer (OEM) and the engine control module (ECM) harness. |
 | STEP 3A. Inspect the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3E. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3F. Check for an active fault code. | Fault Code 5779 active?
 | STEP 3G. Inspect the ECM harness connector pins. | Dirty or damaged pins?
 | STEP 3H. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3I. Check for a pin-to-ground short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3J. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3K. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3L. Check for an active fault code. | Fault Code 5779 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5779 active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 2 DEF dosing valve temperature sensor 2 and circuit.

Guided Step 2A - Inspect the aftertreatment 2 DEF dosing valve temperature sensor2 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 2 from the OEM harness.

Action

Inspect the OEM harness and the aftertreatment 2 DEF dosing valve 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 2 from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the aftertreatment 2 DEF dosing valve 2 5V SUPPLY pin and the aftertreatment 2 DEF dosing 2 temperature SIGNAL pin at the aftertreatment 2 DEF dosing valve 2 connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

  • Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5778 active and Fault Code 5779 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 2 DEF dosing 2 to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5779 active?
YES NO

A damaged sensor has been detected in the aftertreatment 2 DEF dosing valve 2.

Replace the aftertreatment 2 DEF dosing valve 2. Refer to Procedure 011-059 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the original equipment manufacturer (OEM) and the engine control module (ECM) harness.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 2 from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing temperature sensor 2 SIGNAL pin in the OEM harness aftertreatment 2 connector and all other pins in the OEM harness aftertreatment 2 connector

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot each section of harness connected in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If a short circuit is isolated to the damaged harness. Repair or replace the damaged section of harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 2 from the OEM harness.

Action

Check for a pin-to-ground short circuit in the harness.

  • Measure the resistance between the aftertreatment 2 DEF dosing temperature sensor 2 SIGNAL pin in the OEM harness aftertreatment 2 connector and ECM power supply ground circuit. Refer to Procedure 019-610 in the Associated Procedures Table.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot each section of harness connected in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If a short circuit is isolated to damaged harness, repair or replace the damaged section of harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 2 from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness aftertreatment 2 connector DEF dosing temperature sensor 2 RETURN pin and the OEM harness aftertreatment 2 connector DEF dosing valve 2 connector DEF dosing temperature sensor RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Troubleshoot each section of harness connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 2 from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness aftertreatment 2 connector DEF dosing temperature sensor 2 SIGNAL pin and the OEM harness aftertreatment 2 connector DEF dosing valve 2 connector DEF dosing temperature sensor SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Troubleshoot each section of harness connected in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

Repair or replace the damaged section of harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5779 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3G

Go to 4A

Guided Step 3G - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3H

Guided Step 3H - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing temperature sensor 2 SIGNAL pin in the OEM ECM connector and all other pins in the OEM harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Repair or replace the damaged section of harness.

  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3I

Go to 4A

Guided Step 3I - Check for a pin-to-ground short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing temperature sensor 2 SIGNAL pin in the OEM ECM connector and ECM power supply ground. Refer to Procedure 019-610 in the Associated Procedures Table.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the harness.

Repair or replace the damaged section of harness.

  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3J

Go to 4A

Guided Step 3J - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for an open circuit.

  • Measure the resistance between the OEM ECM connector aftertreatment 2 DEF dosing temperature sensor 2 RETURN pin and the OEM harness aftertreatment 2 connector DEF dosing valve 2 DEF dosing temperature sensor RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Repair or replace the damaged section of harness.

  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3K

Go to 4A

Guided Step 3K - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for an open circuit.

  • Measure the resistance between the OEM ECM connector aftertreatment 2 DEF dosing temperature sensor 2 SIGNAL pin and the OEM harness aftertreatment 2 connector DEF dosing valve 2 DEF dosing temperature sensor SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Repair or replace the damaged section of harness.

  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3L

Go to 4A

Guided Step 3L - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5779 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 27-Apr-2016


FAULT CODE 5794 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 3 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 5794 active?
STEP 2. | Check the aftertreatment 1 diesel exhaust fluid (DEF) dosing unit 3 and circuit. |
 | STEP 2A. Inspect the aftertreatment 1 DEF dosing unit 3 and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit on the aftertreatment 1 DEF dosing unit 3 supply circuit in the original equipment manufacturer (OEM) harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit on the aftertreatment 1 DEF dosing unit 3 supply circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2D. Check for a pin-to-pin short circuit on the aftertreatment 1 DEF dosing unit 3 signal circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2E. Check for an open circuit on the aftertreatment 1 DEF dosing unit 3 supply circuit in the engine harness. | Less than 10 ohms?
 | STEP 2F. Check for a pin-to-pin short circuit on the aftertreatment 1 DEF dosing unit 3 supply circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2G. Check for a pin-to-pin short circuit on the aftertreatment 1 DEF dosing unit 3 signal circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 5794 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 1 DEF dosing unit 3 and circuit.

Guided Step 2A - Inspect the aftertreatment 1 DEF dosing unit 3 and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 3 from the OEM harness.

Action

Inspect the harness and aftertreatment 1 DEF dosing unit 3 connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins.

Repair the damage harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit on the aftertreatment 1 DEF dosing unit 3 supply circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 3 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness aftertreatment 1 DEF dosing unit 3 SUPPLY pin and OEM harness aftertreatment 1 connector DEF dosing unit 3 SUPPLY pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit on the aftertreatment 1 DEF dosing unit 3 supply circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 3 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 3 SUPPLY pin of the OEM harness aftertreatment 1 connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598, if equipped.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-pin short circuit on the aftertreatment 1 DEF dosing unit 3 signal circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 3 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 3 command SIGNAL pin of the OEM harness aftertreatment 1 connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for an open circuit on the aftertreatment 1 DEF dosing unit 3 supply circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness aftertreatment 1 connector DEF dosing unit 3 SUPPLY pin and the OEM harness ECM connector aftertreatment 1 DEF dosing unit 3 SUPPLY pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected.

Repair or replace the damaged section of harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2F

Go to 3A

Guided Step 2F - Check for a pin-to-pin short circuit on the aftertreatment 1 DEF dosing unit 3 supply circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 3 command SUPPLY pin of the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness.

Repair or replace the damaged section of harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2G

Go to 3A

Guided Step 2G - Check for a pin-to-pin short circuit on the aftertreatment 1 DEF dosing unit 3 signal circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 3 command SIGNAL pin of the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the aftertreatment 1 DEF dosing unit 3. Refer to Procedure 011-058 in the Associated Procedures Table.

A pin-to-pin short circuit has been detected in the harness.

Repair or replace the damaged section of harness.

  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 31-Mar-2016


FAULT CODE 5795 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 3 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 5795 active?
STEP 2. | Check the aftertreatment 1 diesel exhaust fluid (DEF) dosing unit 3 and circuit. |
 | STEP 2A. Inspect the aftertreatment 1 DEF dosing unit 3 and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit on the aftertreatment 1 DEF dosing unit 3 signal circuit in the original equipment manufacturer (OEM) harness. | Less than 10 ohms?
 | STEP 2C. Check for an open circuit on the aftertreatment 1 DEF dosing unit 3 supply circuit in the OEM harness. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-engine control module (ECM) power supply ground short circuit on the aftertreatment 1 DEF dosing unit 3 signal circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2E. Check for a pin-to-ground short circuit on the aftertreatment 1 DEF dosing unit 3 supply circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2F. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2G. Check for an open circuit on the aftertreatment 1 DEF dosing unit 3 signal circuit in the engine harness. | Less than 10 ohms?
 | STEP 2H. Check for an open circuit on the aftertreatment 1 DEF dosing unit 3 supply circuit in the engine harness. | Less than 10 ohms?
 | STEP 2I. Check for a pin-to-ECM power supply ground short circuit on the aftertreatment 1 DEF dosing unit 3 signal in the engine harness. | Greater than 100k ohms?
 | STEP 2J. Check for a pin-to-ECM power supply ground short circuit on the aftertreatment 1 DEF dosing unit 3 supply circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2K. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 5795 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 1 DEF dosing unit 3 and circuit.

Guided Step 2A - Inspect the aftertreatment 1 DEF dosing unit 3 and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 3 from the OEM harness.

Action

Inspect the harness and aftertreatment 1 DEF dosing unit 3 connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins.

Repair the damage harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit on the aftertreatment 1 DEF dosing unit 3 signal circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 3 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 3 command SIGNAL pin at the dosing unit wiring harness connector and the aftertreatment 1 DEF dosing unit 3 command SIGNAL pin in the OEM harness aftertreatment 1 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit on the aftertreatment 1 DEF dosing unit 3 supply in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 3 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 3 SUPPLY pin at the dosing unit wiring harness connector and aftertreatment 1 DEF dosing unit 3 SUPPLY pin in the OEM harness aftertreatment 1 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-ECM power supply ground short circuit on the aftertreatment 1 DEF dosing unit 3 signal circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 3 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 3 command SIGNAL pin of the OEM harness aftertreatment 1 connector and ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit has been detected.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a pin-to-ECM power supply ground short circuit on the aftertreatment 1 DEF dosing unit 3 supply circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 3 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 3 SUPPLY pin of the OEM harness aftertreatment 1 connector and ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit has been detected.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 3 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 3 SIGNAL pin of the OEM harness aftertreatment 1 connector and all other pins in the OEM harness ECM connector.
  • Measure the resistance between the aftertreatment 1 DEF dosing unit 3 SUPPLY pin of the OEM harness aftertreatment 1 connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2G

Go to 3A

Guided Step 2G - Check for an open circuit on the aftertreatment 1 DEF dosing unit 3 signal circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness aftertreatment 1 connector DEF dosing unit 3 command SIGNAL pin and the aftertreatment 1 DEF dosing unit 3 command SIGNAL pin in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected.

Repair or replace the damaged section of harness.

  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2H

Go to 3A

Guided Step 2H - Check for an open circuit on the aftertreatment 1 DEF dosing unit 3 supply circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness aftertreatment 1 connector DEF dosing unit 3 SUPPLY pin and the aftertreatment 1 DEF dosing unit 3 SUPPLY pin in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected.

Repair or replace the damaged section of harness.

  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2I

Go to 3A

Guided Step 2I - Check for a pin-to-ECM power supply ground short circuit on the aftertreatment 1 DEF dosing unit 3 signal circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 3 command SIGNAL pin of the OEM harness ECM connector and ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit has been detected.

Repair or replace the damaged section of harness.

  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2J

Go to 3A

Guided Step 2J - Check for a pin-to-ECM power supply ground short circuit on the aftertreatment 1 DEF dosing unit 3 supply circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 3 SUPPLY pin of the OEM harness ECM connector and ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit has been detected.

Repair or replace the damaged section of harness.

  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2K

Go to 3A

Guided Step 2K - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit 3 SIGNAL pin of the OEM harness ECM connector and all other pins in the OEM harness ECM connector.
  • Measure the resistance between the aftertreatment 1 DEF dosing unit 3 SUPPLY pin of the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected.

Repair or replace the damaged section of harness.

  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 31-Mar-2016


FAULT CODE 5796 - Aftertreatment 1 Diesel Exhaust Fluid Doser 3 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 5796 active?
STEP 2. | Check the aftertreatment 1 diesel exhaust fluid (DEF) dosing temperature sensor 3 and circuit. |
 | STEP 2A. Inspect the aftertreatment 1 DEF dosing temperature sensor 3 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 5797 active and Fault Code 5796 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 5796 active?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness connector pins. | Dirty or damaged pins.
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for an active fault code. | Fault Code 5796 active?
 | STEP 3D. Inspect the ECM harness connector pins in the engine harness. | Dirty or damaged pins?
 | STEP 3E. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3F. Check for an active fault code. | Fault Code 5796 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 5796 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 1 DEF dosing temperature sensor 3 and circuit.

Guided Step 2A - Inspect the aftertreatment 1 DEF dosing temperature sensor 3 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 3 from the OEM harness.

Action

Inspect the harness and aftertreatment 1 DEF dosing valve 3 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damage harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 3 from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Use the circuit diagram or wiring diagram for connector pin identification.

Fault Code 5797 active and Fault Code 5796 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 1 DEF dosing valve 3 to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5796 active?
YES NO

A damaged temperature sensor has been detected in the aftertreatment 1 DEF dosing valve 3.

Replace the aftertreatment 1 DEF dosing valve 3.

Refer to Procedure 011-059 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damage pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 3 from the OEM harness.

Action

Check for a pin-to-pin short circuit in the harness.

  • Measure the resistance between the aftertreatment DEF dosing temperature sensor 3 SIGNAL pin in the OEM harness connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5796 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3D

Go to 4A

Guided Step 3D - Inspect the ECM harness connector pins in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damage pins?
YES NO

A damaged connection has been detected in the ECM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3E

Guided Step 3E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit in the harness.

  • Measure the resistance between the aftertreatment 1 DEF dosing temperature sensor 3 SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5796 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 19-May-2016


FAULT CODE 5797 - Aftertreatment 1 Diesel Exhaust Fluid Doser 3 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 5797 active?
STEP 2. | Check the aftertreatment 1 diesel exhaust fluid (DEF) dosing temperature sensor 3 and circuit. |
 | STEP 2A. Inspect the aftertreatment 1 DEF dosing temperature sensor 3 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 5796 active and Fault Code 5797 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 5797 active?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness connector pins. | Dirty or damaged pins.
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ECM power supply ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3E. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3F. Check for an active fault code. | Fault Code 5797 active?
 | STEP 3G. Inspect the ECM harness connector pins. | Dirty or damaged pins?
 | STEP 3H. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3I. Check for a pin-to-ECM power supply ground short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3J. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3K. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3L. Check for an active fault code. | Fault Code 5797 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 5797 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 1 DEF dosing temperature sensor 3 and circuit.

Guided Step 2A - Inspect the aftertreatment 1 DEF dosing temperature sensor 3 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 3 from the OEM harness.

Action

Inspect the harness and aftertreatment 1 DEF dosing valve 3 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing valve or harness connector.

Clean the connector and pins.

Repair the damage harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 3 from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the aftertreatment 1 DEF dosing valve 3 5 volt supply pin and the aftertreatment 1 DEF dosing temperature 3 SIGNAL pin at the aftertreatment 1 DEF dosing valve connector of the OEM harness.

Use the circuit diagram or wiring diagram for connector pin identification.

  • Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5796 active and Fault Code 5797 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 1 DEF dosing valve 3 to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5797 active?
YES NO

A damaged temperature sensor has been detected in the aftertreatment 1 DEF dosing valve 3.

Replace the aftertreatment 1 DEF dosing valve 3.

Refer to Procedure 011-059 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damage pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damage harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 3 from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing temperature sensor 3 SIGNAL pin in the OEM harness aftertreatment 1 connector and all other pins in the OEM harness aftertreatment 1 connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ECM power supply ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 3 from the OEM harness.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing temperature sensor 3 SIGNAL pin in the OEM harness aftertreatment 1 connector and ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 3 from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness aftertreatment 1 connector DEF dosing temperature sensor 3 RETURN pin and the OEM harness aftertreatment 1 connector DEF dosing valve 3 connector DEF dosing temperature sensor RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 3 from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness aftertreatment 1 connector DEF dosing temperature sensor 3 SIGNAL pin and the OEM harness aftertreatment 1 connector DEF dosing valve 3 connector DEF dosing temperature sensor SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5797 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3G

Go to 4A

Guided Step 3G - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damage pins?
YES NO

A damaged connection has been detected in the ECM harness connector.

Clean the connector and pins.

Repair the damage harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3H

Guided Step 3H - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing temperature sensor 3 SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the damage section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3I

Go to 4A

Guided Step 3I - Check for a pin-to-ECM power supply ground short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing temperature sensor 3 SIGNAL pin in the OEM harness ECM connector and ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the damage section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3I

Go to 4A

Guided Step 3J - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment 1 DEF dosing temperature sensor 3 RETURN pin and the OEM harness aftertreatment 1 connector DEF dosing valve 3 DEF dosing temperature sensor RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Repair or replace the damage section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3K

Go to 4A

Guided Step 3K - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment 1 DEF dosing temperature sensor 3 SIGNAL pin and the OEM harness aftertreatment 1 connector DEF dosing valve 3 DEF dosing temperature sensor SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Repair or replace the damage section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3L

Go to 4A

Guided Step 3L - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5797 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 19-May-2016


FAULT CODE 5798 - Aftertreatment 1 Diesel Exhaust Fluid Pressure 3 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 5798 active?
STEP 2. | Check the aftertreatment 1 diesel exhaust fluid (DEF) pressure sensor 3 and circuit. |
 | STEP 2A. Inspect the aftertreatment 1 DEF pressure sensor 3 and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 5799 active and Fault Code 5798 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 5798 active?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness connector pins. | Dirty or damaged pins.
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the harness in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the harness in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 5798 active?
 | STEP 3F. Inspect the ECM harness connector pins. | Dirty or damaged pins?
 | STEP 3G. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3H. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3I. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3J. Check for an active fault code. | Fault Code 5798 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 5798 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 1 DEF pressure sensor 3 and circuit.

Guided Step 2A - Inspect the aftertreatment 1 DEF dosing temperature sensor 3 and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 3 from the OEM harness.

Action

Inspect the OEM harness and aftertreatment 1 DEF pressure sensor 3 connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 3 from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Other aftertreatment 1 DEF dosing unit 3 fault codes will be active.

Fault Code 5799 active and Fault Code 5798 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 3 from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the aftertreatment 1 DEF pressure 3 +5 volt SUPPLY pin to the aftertreatment 1 DEF pressure 3 RETURN pin at the dosing valve connector of the OEM harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 1 DEF dosing valve 3 to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5798 active?
YES NO

A malfunctioning aftertreatment DEF pressure sensor has been detected inside the aftertreatment 1 DEF dosing valve 3.

Replace the aftertreatment 1 DEF dosing valve 3.

Refer to Procedure 011-059 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damage pins?
YES NO

A malfunctioning connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 3 from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 3 RETURN pin in the OEM harness aftertreatment 1 connector and the aftertreatment 1 DEF pressure sensor 3 RETURN pin in the OEM harness dosing valve connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 3 from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 3 SIGNAL pin in the OEM harness aftertreatment 1 connector and all other pins in the OEM harness aftertreatment 1 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 3 from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 3 SUPPLY pin in the OEM harness aftertreatment 1 connector and all other pins in the OEM harness aftertreatment 1 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5798 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3F

Go to 4A

Guided Step 3F - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damage pins?
YES NO

A malfunctioning connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damage harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3G

Guided Step 3G - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 3 RETURN pin in the OEM harness ECM connector and the aftertreatment 1 DEF pressure sensor 3 RETURN pin in the OEM harness connector from the engine harness aftertreatment 1 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Repair or replace the damage section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3H

Go to 4A

Guided Step 3H - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 3 SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3I

Go to 4A

Guided Step 3I - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 3 SUPPLY pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the harness.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3J

Go to 4A

Guided Step 3J - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5798 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 19-May-2016


FAULT CODE 5799 - Aftertreatment 1 Diesel Exhaust Fluid Pressure 3 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 5799 active?
STEP 2. | Check the aftertreatment 1 diesel exhaust fluid (DEF) pressure sensor 3 and circuit. |
 | STEP 2A. Inspect the aftertreatment 1 DEF pressure sensor 3 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 5798 active and Fault Code 5799 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 5799 active?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM aftertreatment 1 harness connector pins. | Dirty or damaged pins.
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the harness in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ECM power supply ground short circuit in the harness in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Inspect the ECM OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3G. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3H. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3I. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3J. Check for a pin-to-ECM power supply ground short circuit in the harness in the engine harness. | Greater than 100k ohms?
 | STEP 3K. Check for an active fault code. | Fault Code 5799 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 5799 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 1 DEF pressure sensor 3 and circuit.

Guided Step 2A - Inspect the aftertreatment 1 DEF dosing temperature sensor 3 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 3 from the OEM harness.

Action

Inspect the OEM harness and aftertreatment 1 DEF dosing valve 3 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 3 from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the aftertreatment 1 DEF pressure sensor 3 +5 volt SUPPLY pin to the aftertreatment 1 DEF pressure sensor 3 RETURN pin at the aftertreatment 1 DEF dosing valve 3 connector of the OEM harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 3 from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment 1 DEF pressure sensor 3 +5 volt SUPPLY pin and the aftertreatment 1 DEF pressure sensor 3 SIGNAL pin at the aftertreatment 1 DEF dosing valve 3 connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Other aftertreatment 1 DEF dosing unit 3 fault codes will be active.

Fault Code 5798 active and Fault Code 5799 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 1 DEF dosing valve 3 to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5799 active?
YES NO

A damaged aftertreatment 1 DEF pressure sensor has been detected inside the aftertreatment 1 DEF dosing valve 3.

Replace the aftertreatment 1 DEF dosing valve 3.

Refer to Procedure 011-059 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the OEM aftertreatment 1 harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Inspect the OEM harness aftertreatment 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM aftertreatment 1 harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 3 from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 3 SUPPLY pin in the OEM harness aftertreatment 1 connector and the aftertreatment 1 DEF pressure sensor 3 SUPPLY pin in the OEM harness aftertreatment 1 dosing valve 3 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 3 from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 3 SIGNAL pin in the OEM harness aftertreatment 1 connector and the aftertreatment 1 DEF pressure sensor 3 SIGNAL pin in the OEM harness aftertreatment 1 dosing valve 3 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 3 SIGNAL pin in the OEM harness aftertreatment 1 connector and all other pins in the OEM harness aftertreatment 1 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ECM power supply ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 3 SIGNAL pin in the OEM harness aftertreatment 1 connector and ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Inspect the ECM OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the ECM OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM OEM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3G

Go to 4A

Guided Step 3G - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 3 SUPPLY pin in the OEM harness ECM connector and the aftertreatment 1 DEF pressure sensor 3 SUPPLY pin in the OEM harness aftertreatment 1 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the harness.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3H

Go to 4A

Guided Step 3H - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 3 SIGNAL pin in the OEM harness ECM connector and the aftertreatment 1 DEF pressure sensor 3 SIGNAL pin in the OEM harness aftertreatment 1 connector..

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3I

Go to 4A

Guided Step 3I - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 3 SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3J

Go to 4A

Guided Step 3J - Check for a pin-to-ECM power supply ground short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor 3 SIGNAL pin in the OEM harness ECM connector and ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the harness.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3K

Go to 4A

Guided Step 3K - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5799 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 19-May-2016


FAULT CODE 5813 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 3 Input Lines - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSK95 CM2350 K113 | 4388663
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Heater | Refer to Procedure 011-112 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Line Heater Relay | Refer to Procedure 019-600 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Heater Relay | Refer to Procedure 019-620 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 5813 active or more than two inactive counts?
 | STEP 1B. Check for diesel exhaust fluid (DEF) related fault codes. | Fault Code 1712 active or more than two inactive counts?
 | STEP 1C. Check for low DEF tank level. | DEF tank empty and/or Fault Code 1673, 3497, or 3498 active?
 | STEP 1D. Check the DEF tank for debris. | DEF tank and vent clean and free of debris?
 | STEP 1E. Check ambient operating temperatures. | Equipment operating in ambient temperatures below -5°C [23°F] at the time the fault set?
STEP 2. | Check the aftertreatment 1 dosing system 3 DEF line heaters. |
 | STEP 2A. Test the aftertreatment 1 dosing system 3 DEF line heater relays. | Aftertreatment 1 line heater relays within specification?
 | STEP 2B. Check DEF line heater functionality. | All line heaters functioning correctly?
 | STEP 2C. Inspect the original equipment manufacturer (OEM) harness and line heater connections. | Dirty or damaged pins?
 | STEP 2D. Check line heater supply voltage and return circuits. | All measurements within 1-VDC of ECM power supply voltage?
 | STEP 2E. Check line heater supply voltage to chassis ground. | All measurements within 1-VDC of ECM power supply voltage?
STEP 3. | Check the aftertreatment 1 DEF dosing unit 3 heating system. |
 | STEP 3A. Check the aftertreatment 1 diesel exhaust fluid (DEF) dosing unit heater relay. | Aftertreatment 1 DEF dosing unit heater relay within specifications?
 | STEP 3B. Inspect the aftertreatment 1 DEF dosing unit 3 heater and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check heater circuit resistance in the aftertreatment 1 DEF dosing unit 3 heater. | Resistance at 5.4 ohms ± 2.0 ohm?
 | STEP 3D. Check for an open circuit in the aftertreatment 1 DEF dosing unit 3 heater supply circuit. | Voltage within 1 VDC of power supply voltage?
 | STEP 3E. Check aftertreatment 1 DEF dosing unit 3 heater supply voltage to chassis ground. | All measurements within 1-VDC of ECM power supply voltage?
STEP 4. | Check the aftertreatment 1 DEF dosing unit 3 lines and fittings. |
 | STEP 4A. Inspect the aftertreatment 1 DEF dosing unit 3 lines and fittings. | Any reversed, damaged, leaking, or restricted connections found?
 | STEP 4B. Check for pressure at the aftertreatment 1 DEF dosing valve 3. | DEF pressure greater than 1000 kPa [145 psi]?
 | STEP 4C. Check the aftertreatment 1 DEF dosing unit 3 supply line. | DEF dosing unit supply line blocked or restricted?
 | STEP 4D. Check the aftertreatment 1 DEF dosing valve 3 pressure line. | DEF pressure line blocked or restricted?
STEP 5. | Check the aftertreatment 1 DEF dosing valve 3 system return. |
 | STEP 5A. Check for a blocked aftertreatment 1 DEF dosing valve 3. | DEF pressure greater than 700 kPa [102 psi]?
 | STEP 5B. Check the aftertreatment 1 DEF dosing valve 3 return line. | DEF return line blocked or restricted?
STEP 6. | Check the aftertreatment 1 unit 3 DEF suction line. |
 | STEP 6A. Check for air in the DEF. | Air in the DEF detected?
 | STEP 6B. Check for an intermittent aftertreatment 1 DEF dosing unit 3 suction line leak. | Wiggling the DEF suction line connections affect the system pressure?
 | STEP 6C. Check the aftertreatment 1 DEF pressure. | DEF pressure greater than 750 kPa [109 psi]?
STEP 7. | Check the aftertreatment DEF dosing valve 3 operation. |
 | STEP 7A. Check the aftertreatment DEF dosing system operation. | Dosing volume within the specifications in Procedure 011-063 in the Associated Procedures Table?
 | STEP 7B. Check the results of the doser override test. | DEF pressure at the service tool gauge above 700 kPa [102 psi] for the duration of the test?
STEP 8. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 8A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 8B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5813 active or more than two inactive counts?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for DEF related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1712 active or more than two inactive counts?
YES NO

Fault code 1712 indicates the aftertreatment DEF tank is frozen. Troubleshoot occurrences of Fault Code 1712 before troubleshooting Fault Code 1682.

No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for low DEF tank level.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Make sure the DEF tank is not empty, and the tank level gauge is accurate.

Use INSITE™ electronic service tool to read the fault codes.

  • Check for the following active Fault Codes: 1673, 3497, and 3498.

DEF tank empty and/or Fault Codes 1673, 3497, or 3498 active?
YES NO

Fill the DEF tank.

 No Repair

Go to 8A

Go to 1D

Guided Step 1D - Check DEF tank for debris.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF tank.

  • Check the DEF tank for debris or foreign particles.
  • Check the DEF tank vent for crystallization buildup and clogging.
  • Use the Cummins® DEF Refractometer Service Tool, Part Number 4919554, to test the DEF concentration.

DEF tank and vent clean and free of debris?
YES NO
No Repair

Clean the DEF tank and tank filter thoroughly. Replace the tank filter if necessary. See equipment manufacturer service information.

Fill tank with certified DEF.

If the DEF in the tank is found to be dirty, replace the DEF dosing unit filter and inlet screen. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 1E

Go to 8A

Guided Step 1E - Check ambient operating temperatures.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Check if the equipment was operating in a cold ambient environment, temperature below -5°C [23°F], at the time the fault logged.

Use INSITE™ electronic service tool to read the fault code snapshot and check the ambient air temperature sensor reading to verify.

Equipment operating in ambient temperatures below -5°C [23°F] at the time the fault set?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the aftertreatment 1 dosing system 3 DEF line heaters.

Guided Step 2A - Test the aftertreatment 1 dosing system 3 DEF line heater relays.

Conditions

  • Turn keyswitch OFF.

Action

Test the aftertreatment 1 dosing system 3 DEF line heater relays (K10).

  • Refer to Procedure 019-600 in the Associated Procedures Table.

Aftertreatment 1 line heater relays within specification?
YES NO
No Repair

A damaged line heater relay has been detected. Replace damaged relay. Refer to Procedure 019-600 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Check DEF line heater functionality.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test.

Use an infrared thermometer to measure the surface temperature at the ends of each of the three aftertreatment 1 unit 3 DEF lines. Take temperature measurements in increments of 1 meter or less.

Look for the following:

  • Surface temperature should be above 10C [50F].
  • Temperature uniformity across the length of the individual lines.
  • Temperature uniformity between the lines.

If the lines were not at operating temperature when the test was started a temperature rise will be noticeable

All line heaters functioning correctly?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2C

Guided Step 2C - Inspect the OEM harness and line heater connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the three line heaters (suction, pressure, and return) from the OEM harness.

Action

Inspect the OEM harness and line heater connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the line heater or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 8A

Go to 2D

Guided Step 2D - Check line heater supply voltage and return circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the three line heaters (suction, pressure, and return) from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuits.

  • Measure the voltage from the line heater +24 volt SUPPLY pin to the line heater RETURN pin at the heater connector of the OEM harness.

Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

All measurements within 1-VDC of ECM power supply voltage?
YES NO

Replace the malfunctioning line heater(s).

See equipment manufacturer service information.

 No Repair

Go to 8A

Go to 2E

Guided Step 2E - Check line heater supply voltage to chassis ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the three line heaters (suction, pressure, and return) from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuits.

  • Measure the voltage from the line heater +24 volt SUPPLY pin to ECM power supply ground.

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

All measurements within 1-VDC of ECM power supply voltage?
YES NO

An open has been detected in the line heater return circuit.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Troubleshoot return circuit in aftertreatment junction box, if equipped. Refer to Procedure 019-598 in the Associated Procedures Table.

An open has been detected between the line heater relay and the line heater.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Troubleshoot return circuit in aftertreatment junction box, if equipped. Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 8A

Go to 8A

Guided Step 3 - Check the aftertreatment 1 DEF dosing unit 3 heating system.

Guided Step 3A - Check the aftertreatment 1 diesel exhaust fluid (DEF) dosing unit heater relay.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment 1 DEF dosing unit heater relay (K1) from the aftertreatment junction box. Refer to Procedure 019-620 in the Associated Procedures Table.

Action

Test aftertreatment 1 DEF dosing unit heater relay.

  • Refer to Procedure 019-620 in the Associated Procedures Table.

Refer to the appropriate wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Aftertreatment 1 DEF dosing unit heater relay within specifications?
YES NO
No Repair

Replace the aftertreatment 1 DEF dosing unit heater relay (K1). Refer to Procedure 019-620 in the Associated Procedures Table.

Go to 8A

Go to 3B

Guided Step 3B - Inspect the aftertreatment 1 DEF dosing unit 3 heater and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 3 heater from the OEM harness.

Action

Inspect the DEF dosing unit heater and OEM harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment DEF dosing unit heater or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace dosing unit heater only when there are damaged pins. Refer to Procedure 011-112 in the Associated Procedure Table.

 No Repair

Go to 8A

Go to 3C

Guided Step 3C - Check heater circuit resistance in the aftertreatment 1 DEF dosing unit 3 heater.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check resistance at the dosing unit heater.

  • Measure the resistance across heater at the aftertreatment DEF dosing unit heater supply and the aftertreatment DEF dosing unit heater return at the DEF dosing unit.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Resistance at 5.4 ohms ± 2.0 ohm?
YES NO
No Repair

A malfunctioning aftertreatment DEF dosing unit heater has been detected.

Replace the aftertreatment DEF dosing unit heater. Refer to Procedure 011-112 in the Associated Procedure Table.

Go to 3D

Go to 8A

Guided Step 3D - Check for an open circuit in the aftertreatment 1 DEF dosing unit 3 heater supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 3 heater from the OEM harness.
  • Turn keyswitch ON

Action

Check for an open circuit.

  • Perform the Aftertreatment Diesel Exhaust Fluid Doser System Heater Test found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool.
  • Measure the voltage between aftertreatment 1 DEF dosing unit 3 heater supply pin at the aftertreatment 1 DEF dosing unit 3 heater connector and ECM power supply ground.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of ECM power supply voltage?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DEF dosing unit heater supply circuit.

Check the aftertreatment DEF dosing unit heater circuit breaker. Refer to Procedure 019-598 in the Associated Procedure Table.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedure Table. If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 8A

Guided Step 3E - Check aftertreatment 1 DEF dosing unit 3 heater supply voltage to chassis ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 3 heater from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuits.

  • Measure the voltage from the line heater +24 volt SUPPLY pin to ECM power supply ground.

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

All measurements within 1-VDC of ECM power supply voltage?
YES NO

An open circuit has been detected in the heater return circuit.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedure Table. If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Troubleshoot return circuit in aftertreatment junction box, if equipped. Refer to Procedure 019-598 in the Associated Procedure Table.

An open circuit has been detected between the heater relay and the heater.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedure Table. If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Troubleshoot return circuit in aftertreatment junction box, if equipped. Refer to Procedure 019-598 in the Associated Procedure Table.

Go to 8A

Go to 8A

Guided Step 4 - Check the aftertreatment 1 DEF dosing unit 3 lines and fittings.

Guided Step 4A - Inspect the aftertreatment 1 DEF dosing unit 3 lines and fittings.

Conditions

  • Turn keyswitch OFF.

Action

There are three DEF lines on the SCR dosing system:

  • Dosing unit supply line between the tank and the dosing unit (suction line)
  • Dosing valve supply line between the dosing unit and the dosing valve (pressure line)
  • Return line between the dosing valve and the tank (return line).

Inspect all three DEF lines and associated fittings/connectors:

  • Inspect the dosing unit for a plugged inlet filter in the inlet fitting. Refer to Procedure 011-058 in the Associated Procedures Table.
  • Inspect the dosing unit DEF filter. Refer to Procedure 011-060 in the Associated Procedures Table.
  • Verify the DEF line connections are not swapped at the dosing unit, dosing valve or DEF tank. Reversed DEF lines can cause the dosing system to fail to prime.
  • Check the DEF tank connections (suction and return lines) for cracks and pitting.
  • Check both dosing unit connections and fittings for loose, leaking, or damaged connections.
  • Check the suction line for signs of leakage or openings which will allow the dosing unit to suck in air with the DEF.
  • Check the pressure line for signs of leakage or rupture.
  • Disconnect the suction line, pressure line, and return line connectors and look for signs of buildup or blockage.
  • Verify proper sealing at all connection points and check for damaged or missing o-rings.

Any reversed, damaged, leaking, or restricted connections found?
YES NO

Replace the DEF line(s), fittings, and filters, as necessary.

See equipment manufacturer service information.

Repair or replace the DEF dosing unit inlet filter screen, as necessary.

Refer to Procedure 011-058 in the Associated Procedures Table.

Repair or replace the DEF dosing unit, as necessary. Refer to Procedure 011-060 in the Associated Procedures Table.

Repair or replace the dosing unit connections, as necessary. Refer to Procedure 011-058 in the Associated Procedures Table.

Repair or replace the aftertreatment DEF dosing unit, as necessary. Refer to Procedure 011-058 in the Associated Procedures Table.

Replace the DEF dosing unit inlet filter screen and dosing unit DEF filter. These filters can not be reused and must be changed upon removal. Refer to Procedure 011-060 in the Associated Procedures Table.

Go to 8A

Go to 4B

Guided Step 4B - Check for pressure at the aftertreatment 1 DEF dosing valve 3.

Conditions

  • Turn keyswitch OFF
  • Install the DEF pressure gauge between the inlet of the dosing valve and the pressure line. Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

Attempt to prime the DEF system.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhuast Fluid System Leak Test, under ECM Diagnostics Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure greater than 1000 kPa [145 psi]?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check the aftertreatment 1 DEF dosing unit 3 supply line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit 3 supply line from the dosing unit (this is the suction line between the dosing unit and the DEF tank).
  • Disconnect the aftertreatment 1 DEF dosing unit 3 supply line from the DEF tank.

Action

Check the DEF dosing unit 3 supply line for blockage.

  • Check both ends of the dosing unit supply line for signs of buildup or blockage.
  • Blow compressed shop air through the dosing unit supply line to make sure of free flow.

DEF dosing unit supply line blocked or restricted?
YES NO

Try to clean the dosing unit supply line with shop air. If necessary, replace the dosing unit supply line.

See equipment manufacturer service information.

 No Repair

Go to 8A

Go to 4D

Guided Step 4D - Check the aftertreatment DEF dosing valve pressure line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 3 pressure line from the dosing valve (pressure line runs between the dosing unit and dosing valve).
  • Disconnect the aftertreatment 1 DEF dosing valve 3 pressure line from the DEF dosing unit.

Action

Check the aftertreatment 1 DEF pressure line for blockage.

  • Visually check both ends of the line for signs of buildup or blockage.
  • Blow compressed shop air through the pressure line to make sure of free flow.

DEF pressure line blocked or restricted?
YES NO

Try to clean the pressure line using shop air. If necessary, replace the pressure line.

See equipment manufacturer service information.

 No Repair

Go to 8A

Go to 6A

Guided Step 5 - Check the aftertreatment 1 DEF dosing valve 3 system return.

Guided Step 5A - Check for a blocked aftertreatment 1 DEF dosing valve 3.

Conditions

  • Turn the keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the outlet of the dosing valve and the return line. Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn the keyswitch ON.

Action

Attempt to prime the DEF system.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostics Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure greater than 700 kPa [102 psi]?
YES NO
No Repair

Replace the DEF dosing valve.

Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 5B

Go to 8A

Guided Step 5B - Check the aftertreatment 1 DEF dosing valve 3 return line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 3 return line from the dosing valve.
  • Disconnect the aftertreatment 1 DEF dosing valve 3 return line from the DEF tank.

Action

Check the aftertreatment 1 DEF 3 return line for blockage.

  • Visually check both ends of the line for signs of buildup or blockage.
  • Blow compressed shop air through the return line to make sure of free flow.

DEF return line blocked or restricted?
YES NO

Try to clean the return line using shop air. If necessary, replace the return line.

See equipment manufacturer service information.

A blocked or restricted return has been detected in the DEF tank head. Clean or replace the tank head as necessary.

See equipment manufacturer service information.

Go to 8A

Go to 8A

Guided Step 6 - Check the aftertreatment 1 unit 3 DEF suction line.

Guided Step 6A - Check for air in the DEF.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for air in the DEF.

  • Refer to Procedure 011-075 in the Associated Procedures Table.

Air in the DEF detected?
YES NO

Check the following components for damage/leaks and repair as necessary:

  • Aftertreatment 1 DEF dosing unit 3 fittings
  • Aftertreatment 1 DEF dosing unit 3 supply line
  • Aftertreatment 1 DEF tank fittings
  • Aftertreatment 1 DEF tank filter.

Refer to Procedure 011-075 in the Associated Procedures Table.

 No Repair

Go to 8A

Go to 6B

Guided Step 6B - Check for an intermittent aftertreatment 1 DEF dosing unit 3 suction line leak.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.

Action

Attempt to prime the DEF system. Use INSITE™ electronic service tool to perform the Aftertreatment DEF System Leak Test, under ECM Diagnostics Tests.

As the DEF system is trying to prime, wiggle the suction line connections at the dosing unit 3 and tank. Monitor the DEF pressure sensor reading in INSITE™ electronic service tool data monitor/logger section.

  • Check if wiggling the suction line connections causes the system to either build pressure or lose prime.
  • Listen for audible indication from the pump that wiggling the suction line is causing air to enter the system.

Wiggling the DEF suction line connections affect the system pressure?
YES NO

Replace the DEF suction line. See equipment manufacturer service information.

 No Repair

Go to 8A

Go to 6C

Guided Step 6C - Check the aftertreatment 1 DEF pressure.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.

Action

Attempt to prime the DEF system.

Use INSITE™ electronic service tool to perform the Aftertreatment DEF System Leak Test, under ECM Diagnostics Tests.

  • Monitor the DEF pressure sensor reading in INSITE™ electronic service tool data monitor/logger section.

DEF pressure greater than 750 kPa [109 psi]?
YES NO
No Repair

Replace the DEF dosing unit 3.

Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 7A

Go to 8A

Guided Step 7 - Check the aftertreatment DEF dosing valve 3 operation.

Guided Step 7A - Check the aftertreatment DEF dosing system operation.

Conditions

  • Connect the DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove the aftertreatment 1 DEF dosing valve from the decomposition chamber.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test, under ECM Diagnostics Tests.

  • Use the following procedure for instructions and specifications. Refer to Procedure 011-063 in the Associated Procedures Table.

The aftertreatment 1 DEF dosing valve 3 must be removed and placed in a measuring container having greater than a 1.5 liter [50 oz] capacity to run the Aftertreatment DEF Doser Pump Override Test.

Dosing volume within the specifications in Procedure 011-063 in the Associated Procedures Table?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7B

Guided Step 7B - Check the results of the doser override test.

Conditions

  • Turn the keyswitch OFF.

Action

Check the service pressure tool reading recorded during the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

DEF pressure at the service tool gauge reading above 700 kPa [102 psi] for the duration of the test?
YES NO

Replace the aftertreatment 1 DEF dosing valve 3.

Refer to Procedure 011-059 in the Associated Procedures Table.

Replace the aftertreatment 1 DEF dosing unit 3. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 8A

Go to 8A

Guided Step 8 - Check ECM calibration and clear fault codes.

Guided Step 8A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in Section 19.

Go to 8B

Go to 8B

Guided Step 8B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process

Repair complete

Last Modified: 03-May-2017


FAULT CODE 5814 - Aftertreatment 1 Diesel Exhaust Fluid Pressure 3 - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSK95 CM2350 K113 | 4388663
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Line Restriction Test | Refer to Procedure 011-086 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid System Connection Test | Refer to Procedure 011-107 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Suction Test | Refer to Procedure 011-121 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 5814 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for related fault codes. | Fault Code 1712 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1C. Check for low diesel exhaust fluid (DEF) tank level. | DEF tank empty and/or Fault Code 1673, 3497, or 3498 active?
 | STEP 1D. Check for active fault codes. | Fault Code 1683, 1684, 1712, 1713, 3237, 3239, 3242, 3258, 3261, 3422, 3425, 3426, 3429, 3559, 3558, 3562, 3563, 3564, 3571, 3572, 3575, 3576, 3596, 3713, 4167, 5278, or 5935 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1E. Check for crossed connections. | Any crossed systems found per Procedure 011-107?
STEP 2. | Check the aftertreatment DEF lines and fittings. |
 | STEP 2A. Inspect the aftertreatment DEF lines and fittings. | Any reversed, damaged, leaking, or restricted connections found?
 | STEP 2B. Check the DEF tank. | DEF tank and vent clean and free of debris?
STEP 3. | Check the aftertreatment DEF dosing unit. |
 | STEP 3A. Check the aftertreatment DEF dosing unit. | Vacuum in diagnostic line greater than -203.2 mm-Hg [-8.0 in-Hg]?
 | STEP 3B. Check the aftertreatment DEF dosing unit. | DEF unit operating?
 | STEP 3C. Inspect the ECM and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 3D. Check for an open return circuit in the harness. | Less than 10 ohms?
STEP 4. | Check the aftertreatment DEF intake system. |
 | STEP 4A. Check the DEF dosing unit intake restriction. | Restriction less than -150 mm-Hg [-6 in-Hg]?
STEP 5. | Check for air in the aftertreatment DEF. |
 | STEP 5A. Check for air in the DEF. | Air in the DEF detected?
STEP 6. | Check the aftertreatment DEF pressure sensor. |
 | STEP 6A. Inspect the aftertreatment DEF pressure sensor. | Aftertreatment DEF pressure reading in INSITE™ electronic service tool equal to 0 ±69 kPa [0 ±10 psi]?
 | STEP 6B. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 6C. Check for an open circuit in the harness. | Less than 10 ohms?
STEP 7. | Check the aftertreatment DEF lines and fittings. |
 | STEP 7A. Check for pressure at the aftertreatment DEF dosing valve. | DEF pressure less than 950 kPa [137 psi]?
 | STEP 7A-1. Check for pressure at the aftertreatment DEF dosing valve. |
 | STEP 7A-2. Check for pressure at the aftertreatment DEF dosing valve. |
 | STEP 7B. Check for pressure out of the aftertreatment DEF dosing unit. | DEF pressure less than 950 kPa [137 psi]?
 | STEP 7C. Check for pressure out of the aftertreatment DEF dosing unit. | DEF pressure less than 750 kPa [108 psi]?
 | STEP 7D. Check the aftertreatment DEF dosing unit for blockage. | DEF dosing unit blocked or restricted?
STEP 8. | Check the aftertreatment DEF dosing unit operation. |
 | STEP 8A. Check the aftertreatment DEF dosing unit system operation. | Dosing volume within the specifications in Procedure 011-063?
STEP 9. | Check ECM calibration and clear fault codes. |
 | STEP 9A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 9B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5814 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1712 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

Fault Code 1712 indicates the aftertreatment DEF tank is frozen.

Troubleshoot occurrences of Fault Code 1712 before troubleshooting Fault Code 5814.

 No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for low DEF tank level.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

  • Check for the following active Fault Codes: 1673, 3497, and 3498.

DEF tank empty and/or Fault Code 1673, 3497, or 3498 active?
YES NO

Fill the DEF tank.

 No Repair

Go to 9A

Go to 1D

Guided Step 1D - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1683, 1684, 1712, 1713, 3237, 3239, 3242, 3258, 3261, 3422, 3425, 3426, 3429, 3559, 3558, 3562, 3563, 3564, 3571, 3572, 3575, 3576, 3596, 3713, 4167, 5278, or 5935 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

See the appropriate fault code troubleshooting tree.

Go to 1E

Guided Step 1E - Check for crossed connections.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to check for cross-connection of components. Refer to Procedure 011-107 in the Associated Procedures Table.
  • Trace the DEF pressure line from the DEF dosing unit. Verify it is connected to the correct DEF dosing valve, by component location, on the aftertreatment.

Any crossed systems found per Procedure 011-107?
YES NO

Correct the crossed systems. Refer to Procedure 011-107 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 2A

Guided Step 2 - Check the aftertreatment DEF lines and fittings.

Guided Step 2A - Inspect the aftertreatment DEF lines and fittings.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the following aftertreatment DEF fittings and lines.

  • Dosing unit supply line between the tank and dosing unit (suction line)
  • Dosing valve supply line between the dosing unit and dosing valve (pressure line)
  • Return line between the dosing valve and tank (return line).

Inspect all three DEF lines and associated fittings/connectors:

  • Verify the lines are not swapped at the dosing unit, dosing valve, or DEF tank connections. Reversed DEF line connectors cause the dosing system to fail to prime.
  • Check the DEF tank connections (suction and return lines) for cracks and pitting.
  • Check both dosing unit connections and fittings for loose, leaking, or damaged connections.
  • Disconnect the suction line and pressure line dosing unit connectors. Look for signs of buildup or blockage.
  • Check the suction line for signs of leakage or openings which will allow the dosing unit to suck in air with the DEF.
  • Check the pressure line for sings of leakage or rupture.
  • Verify proper sealing at all connection points, including DEF tank (two connections), dosing unit (two connections), and dosing valve (two connections).

Refer to Procedure 011-058 in the Associated Procedures Table.

Any reversed, damaged, leaking, or restricted connections found?
YES NO

Replace the leaking DEF line, as necessary. See equipment manufacturer service information.

 No Repair

Go to 9A

Go to 2B

Guided Step 2B - Check the DEF tank.

Conditions

  • Turn keyswitch OFF.

Action

  • Check the DEF tank for contamination or debris. Refer to Procedure 011-056 in the Associated Procedures Table.
  • Check the DEF tank vent for crystallization, buildup, and clogging.

DEF tank and vent clean and free of debris?
YES NO
No Repair

Flush the DEF system. Refer to Procedure 011-056 in the Associated Procedures Table.

  • Drain the DEF tank. Thoroughly flush with distilled water.
  • Clean and flush the DEF tank head and filter. Replace the DEF tank filter, as necessary.
  • Remove and flush the dosing unit intake and return lines.
  • Make sure the DEF dosing unit intake and fitting and filter are new. Refer to Procedure 011-058 in the Associated Procedures Table.
  • Fill the DEF tank with clean, certified DEF.

Go to 3A

Go to 9A

Guided Step 3 - Check the aftertreatment DEF dosing unit.

Guided Step 3A - Check the aftertreatment DEF dosing unit.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Refer to Procedure 011-121 in the Associated Procedures Table.

Vacuum in diagnostic line greater than -203.2 mm-Hg [-8.0 in-Hg]?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the aftertreatment DEF dosing unit.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Verify dosing unit was making sound or vibration.

DEF unit operating?
YES NO

Remove the dosing unit intake screen and main filter.

Inspect the intake screen and DEF in the main filter well for debris.

If any debris is visible, the system is contaminated with debris and must be flushed. Refer to Procedure 011-056 in the Associated Procedures Table.

  • Drain the DEF tank. Thoroughly flush with distilled water.
  • Clean and flush the DEF tank head and filter. Replace the DEF tank filter, as necessary.
  • Remove and flush the dosing unit intake line.
  • Fill the DEF tank with clean, certified DEF.

Perform the airless flush. Refer to Procedure 011-058 in the Associated Procedures Table.

Run the DEF Dosing Unit Suction Test. Refer to Procedure 011-121 in the Associated Procedures Table.

If vacuum is not greater than -203.2 mm-Hg [-8.0 in-Hg] gauge when tested, replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

If vacuum is greater than -203.2 mm-Hg [-8.0 in-Hg] gauge when tested, the dosing unit should be reused.

  • Make sure the DEF dosing unit intake screen and main filter are new. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 3C

Guided Step 3C - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor, ECM engine connector, or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 3D

Guided Step 3D - Check for an open return circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

  • Measure the resistance between the aftertreatment DEF dosing unit RETURN pin in the OEM harness ECM connector and the aftertreatment DEF dosing unit RETURN pin in the OEM harness dosing valve connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

A malfunctioning DEF dosing unit has been detected.

Replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

An open return circuit has been detected in the harness.

Repair or replace the damaged section of harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 9A

Go to 9A

Guided Step 4 - Check the aftertreatment DEF intake system.

Guided Step 4A - Check the DEF dosing unit intake restriction.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Refer to Procedure 011-086 in the Associated Procedures Table.

Restriction less than -150 mm-Hg [-6 in-Hg]?
YES NO
No Repair

Clean or replace the DEF tank filter, DEF tank vent filter, and DEF suction line, as necessary.

Drain the DEF tank. Flush with distilled water. Fill the DEF tank with clean, certified DEF.

See equipment manufacturer service information.

Go to 5A

Go to 9A

Guided Step 5 - Check for air in the aftertreatment DEF.

Guided Step 5A - Check for air in the DEF.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Refer to Procedure 011-075 in the Associated Procedures Table.

Air in the DEF detected?
YES NO

Check the following components for damage/leaks. Repair, as necessary.

  • Aftertreatment DEF dosing unit supply line
  • Aftertreatment DEF tank fittings
  • Aftertreatment DEF tank stand pipe.

Refer to Procedure 011-075 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 6A

Guided Step 6 - Check the aftertreatment DEF pressure sensor.

Guided Step 6A - Inspect the aftertreatment DEF pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Disconnect the aftertreatment DEF dosing valve pressure line (this is the supply line between the dosing unit and dosing valve).
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to monitor the aftertreatment DEF pressure.

Aftertreatment DEF pressure reading in INSITE™ electronic service tool equal to 0 ±69 kPa [0 ±10 psi]?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6B

Guided Step 6B - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor, ECM engine connector, or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 6C

Guided Step 6C - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the aftertreatment 1 DEF dosing unit from the OEM harness.

Action

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor SUPPLY pin in the OEM harness ECM connector and the aftertreatment 1 DEF pressure sensor SUPPLY pin in the OEM harness aftertreatment 1 DEF dosing valve connector.
  • Measure the resistance between the aftertreatment 1 DEF pressure sensor SIGNAL pin in the OEM harness ECM connector and the aftertreatment 1 DEF pressure sensor SIGNAL pin in the OEM harness aftertreatment 1 DEF dosing valve connector.
  • Measure the resistance between the aftertreatment 1 DEF pressure sensor RETURN pin in the OEM harness ECM connector and the aftertreatment 1 DEF pressure sensor RETURN pin in the OEM harness dosing valve connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

A damaged aftertreatment DEF pressure sensor has been detected.

Replace the aftertreatment DEF dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

An open circuit has been detected in the harness.

Repair or replace the damaged section of the harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 7A

Go to 9A

Guided Step 7 - Check the aftertreatment DEF lines and fittings.

Guided Step 7A - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the inlet of the dosing valve and pressure line (this is the supply line between the dosing unit and dosing valve). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Test.
  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 950 kPa [137 psi]?
YES | NO
No Repair | No Repair

Go to 7B

Go to 7A-1

Guided Step 7A-1 - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the outlet of the dosing valve and return line (this is the return line between the dosing valve and tank). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Connect the DEF pressure line to the inlet of the dosing valve.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.

Read the DEF pressure from the service tool gauge.

DEF pressure less than 70 kPa [10 psi]?
YES NO
No Repair

A blocked or restricted return line and/or tank head has been detected. Clean or replace the return line and/or tank head, as necessary.

See equipment manufacturer service information.

Go to 7A-2

Go to 7B

Guided Step 7A-2 - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Install the DEF pressure gauge between the inlet of the dosing valve and pressure line. Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.

Read the DEF pressure from the service tool gauge.

DEF pressure reading ±70 kPa [±10 psi] of gauge reading?
YES NO
No Repair

Replace the inlet screen. Refer to Procedure 011-059 in the Associated Procedures Table. Perform this step again.

If still out of specification, replace the dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 7B

Go to 9A

Guided Step 7B - Check for pressure out of the aftertreatment DEF dosing unit.

Conditions

  • Turn keyswitch OFF.
  • Connect the DEF pressure line to the inlet of the dosing valve.
  • Install the DEF pressure gauge between the outlet of the dosing unit and pressure line (this is the supply line between the dosing unit and dosing valve). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 950 kPa [137 psi]?
YES NO
No Repair

A restricted pressure line has been detected. Clean or replace the pressure line, as necessary.

See equipment manufacturer service information.

Go to 7C

Go to 9A

Guided Step 7C - Check for pressure out of the aftertreatment DEF dosing unit.

Conditions

  • Turn keyswitch OFF.
  • Install the DEF pressure gauge between the outlet of the dosing unit and pressure line (this is the supply line between the dosing unit and dosing valve). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 750 kPa [108 psi]?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7D

Guided Step 7D - Check the aftertreatment DEF dosing unit for blockage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve pressure line from the dosing valve (pressure line runs between the dosing unit and dosing valve).
  • Disconnect the aftertreatment DEF dosing valve pressure line from the DEF dosing unit.

Action

  • Inspect the outlet fitting for signs of buildup or blockage.
  • Inspect the dosing unit filter for signs of buildup or blockage.
  • Inspect the inlet fitting screen for signs of buildup or blockage.

DEF dosing unit blocked or restricted?
YES NO

Clean the aftertreatment DEF dosing unit outlet or inlet fitting if needed.

Replace the aftertreatment DEF dosing unit filter if needed. Refer to Procedure 011-060 in the Associated Procedures Table.

A malfunctioning DEF dosing unit has been detected.

Replace the aftertreatment DEF dosing unit. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 9A

Go to 9A

Guided Step 8 - Check the aftertreatment DEF dosing unit operation.

Guided Step 8A - Check the aftertreatment DEF dosing system operation.

Conditions

  • Connect all DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove aftertreatment DEF dosing valve from decomposition chamber.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use the following procedure for instructions and specifications. Refer to Procedure 011-063 in the Associated Procedures Table.

The aftertreatment DEF dosing valve must be removed and placed in a measuring container having greater than a 1.5 liter [50 oz] capacity to run the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Dosing volume within the specifications in Procedure 011-063?
YES NO
No Repair

Refer to Procedure 011-063 in the Associated Procedures Table for repair instructions.

Go to 9A

Go to 9A

Guided Step 9 - Check ECM calibration and clear fault codes.

Guided Step 9A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 9B

Go to 9B

Guided Step 9B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Mar-2017


FAULT CODE 5815 - Aftertreatment 1 Diesel Exhaust Fluid Pressure 3 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid System Connection Test | Refer to Procedure 011-107 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5815 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3596, 3571, 3572, 5278, 5935, 5936, 5864, or 5865 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1C. Check for crossed connections. | Any crossed systems found per Procedure 011-107?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) lines and fittings. |
 | STEP 2A. Check for pressure at the aftertreatment DEF dosing valve. | DEF pressure greater than 70 kPa [10 psi]?
 | STEP 2B. Check for pressure at the aftertreatment DEF tank head. | DEF pressure less than 70 kPa [10 psi]?
 | STEP 2C. Check for pressure at the aftertreatment DEF dosing valve. | DEF pressure reading ±70 kPa [±10 psi] of gauge reading?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5815 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3596, 3571, 3572, 5278, 5935, 5936, 5864, or 5865 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for crossed connections.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to check for cross-connection of components. Refer to Procedure 011-107 in the Associated Procedures Table.
  • Trace the DEF pressure line from the DEF dosing unit. Verify it is connected to the correct DEF dosing valve, by component location, on the aftertreatment.

Any crossed systems found per Procedure 011-107?
YES NO

Correct the crossed systems. Refer to Procedure 011-107 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the aftertreatment DEF lines and fittings.

Guided Step 2A - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the inlet of the dosing valve and return line (this is the return line between the dosing valve and tank). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, located under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure greater than 70 kPa [10 psi]?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2B

Guided Step 2B - Check for pressure at the aftertreatment DEF tank head.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the inlet of the tank head and return line (this is the return line between the dosing valve and tank). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 70 kPa [10 psi]?
YES NO

A blocked or restricted return line has been detected.

Clean or replace the return line, as necessary.

See equipment manufacturer service information.

A blocked or restricted tank head has been detected.

Clean or replace the tank head, as necessary.

See equipment manufacturer service information.

Go to 3A

Go to 3A

Guided Step 2C - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Install the DEF pressure gauge between the inlet of the dosing valve and pressure line. Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure reading ±70 kPa [±10 psi] of gauge reading?
YES NO
No Repair

Replace the inlet screen. Refer to Procedure 011-059 in the Associated Procedures Table. Perform this step again.

If still out of specification, replace the dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 22-Mar-2017


FAULT CODE 5816 - Aftertreatment 1 Diesel Exhaust Fluid Pressure 3 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid System Connection Test | Refer to Procedure 011-107 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5816 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3571, 3572, 5278, 5935, 5936, 5864, or 5865 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1C. Check for crossed connections. | Any crossed systems found. Refer to procedure 011-107 in the Associated Procedures Table?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) pressure sensor. |
 | STEP 2A. Inspect the aftertreatment DEF pressure sensor. | Aftertreatment DEF pressure reading in INSITE™ electronic service tool equal to 0 ±69 kPa [0 ±10 psi]?
STEP 3. | Check the aftertreatment DEF lines and fittings. |
 | STEP 3A. Check for pressure at the aftertreatment DEF dosing valve. | DEF pressure less than 70 kPa [10 psi]?
 | STEP 3B. Check for pressure at the aftertreatment DEF tank head. | DEF pressure less than 70 kPa [10 psi]?
 | STEP 3C. Check for pressure at the aftertreatment DEF dosing valve. | DEF pressure reading ± 70 kPa [10 psi] of gauge reading?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 5816 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 3571, 3572, 5278, 5935, 5936, 5864, or 5865 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for crossed connections.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for crossed connections.

  • Use INSITE™ electronic service tool to check for cross-connection of components. Refer to Procedure 011-107 in the Associated Procedures Table.
  • Trace the DEF pressure line from the DEF dosing unit and verify it is connected to the correct DEF dosing valve, by component location, on the aftertreatment.

Any crossed systems found. Refer to Procedure 011-107 in the Associated Procedures Table?
YES | NO
No Repair | No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the aftertreatment DEF pressure sensor.

Guided Step 2A - Check the aftertreatment DEF pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve supply line.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor aftertreatment DEF pressure.

  • Use INSITE™ electronic service tool to monitor the aftertreatment DEF pressure.

Aftertreatment DEF pressure reading in INSITE™ electronic service tool equal to 0 ±69 kPa [0 ±10 psi]?
YES NO
No Repair

A damaged aftertreatment DEF pressure sensor has been detected.

Replace the aftertreatment DEF dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF dosing lines and fittings.

Guided Step 3A - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the outlet of the dosing valve and return line (this is the return line between the dosing valve and tank). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

Attempt to prime the DEF system.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 70 kPa [10 psi]?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B

Guided Step 3B - Check for pressure at the aftertreatment DEF tank head.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for diesel exhaust fluid system pressure to leak down.
  • Install the DEF pressure gauge between the inlet of the tank head and the return line (this is the return line between the dosing valve and the tank). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

Attempt to prime the DEF system.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 70 kPa [10 psi]?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Install the DEF pressure gauge between the inlet of the dosing valve and the pressure line. Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

Attempt to prime the DEF system.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure reading ± 70 kPa [10 psi] of gauge reading?
YES NO

Try to clean the dosing unit 3 supply line. Use shop air. If necessary, replace the dosing valve 3 supply line.

See equipment manufacturer service information.

Replace inlet screen per Procedure 011-059 and perform this step again.

If still out of specification, then replace dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Apr-2017


FAULT CODE 5817 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 3 - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for aftertreatment 1 diesel exhaust fluid (DEF) dosing valve 3 fault codes. | Fault Code 5817 active?
STEP 2. | Check the aftertreatment 1 DEF dosing valve 3 and circuit. |
 | STEP 2A. Inspect the aftertreatment 1 DEF dosing valve 3 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the aftertreatment 1 DEF dosing valve 3 resistance. | Between 10 and 17 ohms?
STEP 3. | Check the engine and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the aftertreatment 1 DEF dosing valve 3 signal circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check the aftertreatment 1 DEF dosing valve 3 return circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-engine control module (ECM) power supply ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Inspect the ECM harness connector pins. | Dirty or damaged pins?
 | STEP 3G. Check the aftertreatment 1 DEF dosing valve 3 signal circuit. | Less than 10 ohms?
 | STEP 3H. Check the aftertreatment 1 DEF dosing valve 3 return circuit. | Less than 10 ohms?
 | STEP 3I. Check for a pin-to-ECM power supply ground short circuit. | Greater than 100k ohms?
 | STEP 3J. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for aftertreatment DEF dosing valve 3 fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 5817 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the aftertreatment 1 DEF dosing valve 3 and circuit.

Guided Step 2A - Inspect the aftertreatment 1 DEF dosing valve 3 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 3 from the OEM harness.

Action

Inspect the OEM harness and aftertreatment 1 DEF dosing valve 3 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing valve or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the aftertreatment 1 DEF dosing valve 3 resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 3 from the OEM harness.

Action

Check for an internal short or open circuit in the aftertreatment 1 DEF dosing valve 3 by measuring the internal resistance.

  • Measure the resistance between the aftertreatment 1 DEF dosing valve 3 SIGNAL pin to the aftertreatment 1 DEF dosing valve 3 RETURN pin at the aftertreatment 1 DEF dosing valve 3 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 10 and 17 ohms?
YES NO
No Repair

An internal short or open circuit has been detected in the aftertreatment 1 DEF dosing valve 3.

Replace the aftertreatment 1 DEF dosing valve 3. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine and OEM harness.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Inspect the OEM harness aftertreatment 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness aftertreatment 1 connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the aftertreatment 1 DEF dosing valve 3 signal circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 3 from the OEM harness.

Action

Check the dosing valve signal circuit.

  • Measure the resistance between the OEM harness aftertreatment 1 DEF dosing valve 3 connector SIGNAL pin and the OEM harness aftertreatment 1 connector DEF dosing valve 3 SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the aftertreatment 1 DEF dosing valve 3 return circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 3 from the OEM harness.

Action

Check the dosing valve return circuit.

  • Measure the resistance between the OEM harness aftertreatment 1 DEF dosing valve 3 connector RETURN pin and the OEM harness aftertreatment 1 connector DEF dosing valve 3 RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ECM power supply ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 3 from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing valve 3 SIGNAL pin in the OEM harness aftertreatment 1 connector and ECM power supply ground circuit.
  • Measure the resistance between the aftertreatment 1 DEF dosing valve 3 RETURN pin in the OEM harness aftertreatment 1 connector and ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 3 from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing valve 2 SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the ECM connector.

Clean the connector and pins.

Repair the damage harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3G

Guided Step 3G - Check the aftertreatment 1 DEF dosing valve 3 signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check the dosing valve signal circuit.

  • Measure the resistance between the OEM harness aftertreatment 1 connector DEF dosing valve 3 connector SIGNAL pin and the ECM connector aftertreatment 1 DEF dosing valve 3 SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Repair or replace the damaged section of harness.

Use the following procedure for engine harness repair. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3H

Go to 4A

Guided Step 3H - Check the aftertreatment 1 DEF dosing valve 3 return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check the dosing valve return circuit.

  • Measure the resistance between the OEM harness aftertreatment 1 connector DEF dosing valve 3 RETURN pin and the ECM connector aftertreatment 1 DEF dosing valve 3 RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Repair or replace the damaged section of harness.

Use the following procedure for engine harness repair. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3I

Go to 4A

Guided Step 3I - Check for a pin-to-ECM power supply ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing valve 3 SIGNAL pin in the OEM harness ECM connector and ECM power supply ground circuit.
  • Measure the resistance between the aftertreatment 1 DEF dosing valve 3 RETURN pin in the OEM harness ECM connector and ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit has been detected in the harness.

Repair or replace the damaged section of harness.

Use the following procedure for engine harness repair. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3J

Go to 4A

Guided Step 3J - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing valve 3 SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness.

Repair or replace the damaged section of harness.

Use the following procedure for engine harness repair. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 19-May-2016


FAULT CODE 5818 - Aftertreatment 1 Diesel Exhaust Fluid Pressure 3 Sensor Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for aftertreatment 1 DEF dosing valve 3 fault codes. | Fault Code 5818 active?
STEP 2. | Check the aftertreatment 1 DEF dosing valve 3 and circuit. |
 | STEP 2A. Inspect the OEM aftertreatment 1 harness and aftertreatment 1 diesel exhaust fluid (DEF) dosing valve 3 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the OEM harness aftertreatment 1 DEF dosing valve 3 return circuit. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the OEM aftertreatment 1 harness. | Greater than 100k ohms?
 | STEP 2D. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 2E. Check the aftertreatment 1 engine harness DEF dosing valve 3 return circuit. | Less than 10 ohms?
 | STEP 2F. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for aftertreatment 1 DEF dosing valve 3 fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5818 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the aftertreatment 1 DEF dosing valve 3 and circuit.

Guided Step 2A - Inspect the OEM aftertreatment 1 harness and aftertreatment 1 (DEF) dosing valve 3 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing valve 3 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Inspect the OEM harness, aftertreatment 1 connector and DEF dosing valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the valve or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the OEM harness aftertreatment 1 DEF dosing valve 3 return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 3 from the OEM harness.

Action

Check the dosing valve sensor return circuit.

  • Measure the resistance from the OEM harness aftertreatment 1 DEF dosing valve 3 connector sensor RETURN pin to the OEM harness aftertreatment 1 connector DEF dosing valve 3 sensor RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For OEM harness repair: Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the OEM aftertreatment 1 harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.
  • Disconnect the aftertreatment 1 DEF dosing valve 3 from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment 1 DEF dosing valve 3 sensor RETURN pin in the OEM harness aftertreatment 1 connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For OEM harness repair: Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2E

Guided Step 2E - Check the aftertreatment 1 engine harness DEF dosing valve 3 return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Check the dosing valve sensor return circuit.

  • Measure the resistance from the engine harness aftertreatment 1 connector sensor RETURN pin to the ECM connector aftertreatment 1 DEF dosing valve 3 sensor RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2F

Go to 3A

Guided Step 2F - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 1 connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment 1 DEF dosing valve 3 sensor RETURN pin in the OEM harness ECM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the aftertreatment 1 DEF dosing valve 2. Refer to Procedure 011-059 in the Associated Procedures Table.

A pin-to-pin short circuit has been detected in the harness.

Repair or replace the damaged section of harness.

  • For engine harness repair: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 25-Apr-2016


FAULT CODE 5819 - Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit 3 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 5819 active?
STEP 2. | Check the aftertreatment 2 diesel exhaust fluid (DEF) dosing unit 3 and circuit. |
 | STEP 2A. Inspect the aftertreatment 2 DEF dosing unit 3 and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit on the aftertreatment 2 DEF dosing unit 3 supply circuit in the original equipment manufacturer (OEM) harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit on the aftertreatment 2 DEF dosing unit 3 supply circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2D. Check for a pin-to-pin short circuit on the aftertreatment 2 DEF dosing unit 3 signal circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2E. Check for an open circuit on the aftertreatment 2 DEF dosing unit 3 supply in the engine harness. | Less than 10 ohms?
 | STEP 2F. Check for a pin-to-pin short circuit on the aftertreatment 2 DEF dosing unit 3 supply circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2G. Check for a pin-to-pin short circuit on the aftertreatment 2 DEF dosing unit 3 signal circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 5819 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 2 DEF dosing unit 3 and circuit.

Guided Step 2A - Inspect the aftertreatment 2 DEF dosing unit 3 and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 3 from the OEM harness.

Action

Inspect the harness and aftertreatment 2 DEF dosing unit 3 connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit on the aftertreatment 2 DEF dosing unit 3 supply circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 3 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness aftertreatment 2 DEF dosing unit 3 SUPPLY pin and the OEM harness aftertreatment 2 connector DEF dosing unit 3 SUPPLY pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit on the aftertreatment 2 DEF dosing unit 3 supply circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 3 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit 3 SUPPLY pin of the OEM harness aftertreatment 2 connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-pin short circuit on the aftertreatment 2 DEF dosing unit 3 signal circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 3 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit 3 command SIGNAL pin of the OEM harness aftertreatment 2 connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for an open circuit on the aftertreatment 2 DEF dosing unit 3 supply circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness aftertreatment 2 connector DEF dosing unit 3 SUPPLY pin and OEM harness ECM connector aftertreatment 2 DEF dosing unit 3 SUPPLY pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected.

Repair or replace the damaged section of harness.

Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2F

Go to 3A

Guided Step 2F - Check for a pin-to-pin short circuit on the aftertreatment 2 DEF dosing unit 3 supply circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit 3 SUPPLY pin of the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness.

Repair or replace the damaged section of harness.

Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2G

Go to 3A

Guided Step 2G - Check for a pin-to-pin short circuit on the aftertreatment 2 DEF dosing unit 3 signal circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit 3 command SIGNAL pin of the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the aftertreatment 2 DEF dosing unit 3. Refer to Procedure 011-058 in the Associated Procedures Table.

A pin-to-pin short circuit has been detected.

Repair or replace the damaged section of harness.

Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 30-Mar-2016


FAULT CODE 5821 - Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit 3 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 5821 active?
STEP 2. | Check the aftertreatment 2 diesel exhaust fluid (DEF) dosing unit 3 and circuit. |
 | STEP 2A. Inspect the aftertreatment 2 DEF dosing unit 3 and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit on the aftertreatment 2 DEF dosing unit 3 signal circuit in the original equipment manufacturer (OEM) harness. | Less than 10 ohms?
 | STEP 2C. Check for an open circuit on the aftertreatment 2 DEF dosing unit 3 supply circuit in the OEM harness. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-engine control module (ECM) power supply ground short circuit on the aftertreatment 2 DEF dosing unit 3 signal circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2E. Check for a pin-to-ECM power supply ground short circuit on the aftertreatment 2 DEF dosing unit 3 supply circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2F. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2G. Check for an open circuit on the aftertreatment 2 DEF dosing unit 3 signal circuit in the engine harness. | Less than 10 ohms?
 | STEP 2H. Check for an open circuit on the aftertreatment 2 DEF dosing unit 3 supply circuit in the engine harness. | Less than 10 ohms?
 | STEP 2I. Check for a pin-to-ECM power supply ground short circuit on the aftertreatment 2 DEF dosing unit 3 signal circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2J. Check for a pin-to-ECM power supply ground short circuit on the aftertreatment 2 DEF dosing unit 3 supply circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2K. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 5821 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 2 DEF dosing unit 3 and circuit.

Guided Step 2A - Inspect the aftertreatment 2 DEF dosing unit 3 and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 3 from the OEM harness.

Action

Inspect the harness and aftertreatment 2 DEF dosing unit 3 connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit on the aftertreatment 2 DEF dosing unit 3 supply circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 3 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit 3 command SIGNAL pin at the dosing unit wiring harness connector and aftertreatment 2 DEF dosing unit 3 command SIGNAL pin in the OEM harness aftertreatment 2 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit on the aftertreatment 2 DEF dosing unit 3 supply circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 3 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit 3 SUPPLY pin at the dosing unit wiring harness connector and aftertreatment 2 DEF dosing unit 3 SUPPLY pin in the OEM harness aftertreatment 2 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-ECM power supply ground short circuit on the aftertreatment 2 DEF dosing unit 3 signal circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 3 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit 3 command SIGNAL pin of the OEM harness aftertreatment 2 connector and ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit has been detected.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a pin-to-ECM power supply ground short circuit on the aftertreatment 2 DEF dosing unit 3 supply circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 3 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit 3 SUPPLY pin of the OEM harness aftertreatment 2 connector and ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 3 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit 3 SIGNAL pin of the OEM harness aftertreatment 2 connector and all other pins in the OEM harness ECM connector.
  • Measure the resistance between the aftertreatment 2 DEF dosing unit 3 SUPPLY pin of the OEM harness aftertreatment 2 connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2G

Go to 3A

Guided Step 2G - Check for an open circuit on the aftertreatment 2 DEF dosing unit 3 signal circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness aftertreatment 2 connector DEF dosing unit 3 command SIGNAL pin and the aftertreatment 2 DEF dosing unit 3 command SIGNAL pin in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected.

Repair or replace the damaged section of harness.

Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2H

Go to 3A

Guided Step 2H - Check for an open circuit on the aftertreatment 2 DEF dosing unit 3 supply circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness aftertreatment 2 connector DEF dosing unit 3 SUPPLY pin and the aftertreatment 2 DEF dosing unit 3 SUPPLY pin in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected.

Repair or replace the damaged section of harness.

Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2I

Go to 3A

Guided Step 2I - Check for a pin-to-ECM power supply ground short circuit on the aftertreatment 2 DEF dosing unit 3 signal circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit 3 command SIGNAL pin of the OEM harness ECM connector and ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected.

Repair or replace the damaged section of harness.

Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2J

Go to 3A

Guided Step 2J - Check for a pin-to-ECM power supply ground short circuit on the aftertreatment 2 DEF dosing unit 3 supply circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit 3 command SUPPLY pin of the OEM harness ECM connector and ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected.

Repair or replace the damaged section of harness.

Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2K

Go to 3A

Guided Step 2K - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit 3 SIGNAL pin of the OEM harness ECM connector and all other pins in the OEM harness ECM connector.
  • Measure the resistance between the aftertreatment 2 DEF dosing unit 3 SUPPLY pin of the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the aftertreatment 2 DEF dosing unit 3. Refer to Procedure 011-058 in the Associated Procedures Table.

A pin-to-pin short circuit has been detected.

Repair or replace the damaged section of harness.

Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 30-Mar-2016


FAULT CODE 5822 - Aftertreatment 2 Diesel Exhaust Fluid Doser 3 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5822 active?
STEP 2. | Check the aftertreatment 2 diesel exhaust fluid (DEF) dosing temperature sensor 3 and circuit. |
 | STEP 2A. Inspect the aftertreatment 2 DEF dosing temperature sensor 3 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 5823 active and Fault Code 5822 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 5822 active?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for an active fault code. | Fault Code 5822 active?
 | STEP 3D. Inspect the ECM harness connection pins in the engine harness. | Dirty or damaged pins?
 | STEP 3E. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3F. Check for an active fault code. | Fault Code 5822 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 5822 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 2 DEF dosing temperature sensor 3 and circuit.

Guided Step 2A - Inspect the aftertreatment 2 DEF dosing temperature sensor 3 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 3 from the OEM harness.

Action

Inspect the OEM harness and aftertreatment 2 DEF dosing valve 3 connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 3 from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Use the circuit diagram or wiring diagram for connector pin identification.

Fault Code 5823 active and Fault Code 5822 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 2 DEF dosing valve 3 to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5822 active?
YES NO

A damaged temperature sensor has been detected in the aftertreatment 2 DEF dosing valve 3.

Replace the aftertreatment 2 DEF dosing valve 3. Refer to Procedure 011-059 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 3 from the OEM harness.

Action

Check for a pin-to-pin short circuit in the harness.

  • Measure the resistance between the aftertreatment 2 DEF dosing temperature sensor 3 SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5822 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3D

Go to 4A

Guided Step 3D - Inspect the ECM harness connector pins in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3E

Guided Step 3E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit in the harness.

  • Measure the resistance between the aftertreatment 2 DEF dosing temperature sensor 3 SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Repair or replace the damaged section of harness.

Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5822 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 19-May-2016


FAULT CODE 5823 - Aftertreatment 2 Diesel Exhaust Fluid Doser 3 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5823 active?
STEP 2. | Check the aftertreatment 2 diesel exhaust fluid (DEF) dosing temperature sensor 3 and circuit. |
 | STEP 2A. Inspect the aftertreatment 2 DEF dosing temperature sensor 3 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 5822 active and Fault Code 5823 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 5823 active?
STEP 3. | Check the original equipment manufacturer (OEM) and engine control module (ECM) harness. |
 | STEP 3A. Inspect the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ECM power supply ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3E. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3F. Check for an active fault code. | Fault Code 5823 active?
 | STEP 3G. Inspect the ECM harness connector pins. | Dirty or damaged pins?
 | STEP 3H. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3I. Check for a pin-to-ECM power supply ground short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3J. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3K. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3L. Check for an active fault code. | Fault Code 5823 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 5823 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 2 DEF dosing temperature sensor 3 and circuit.

Guided Step 2A - Inspect the aftertreatment 2 DEF dosing temperature sensor 3 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 3 from the OEM harness.

Action

Inspect the OEM harness and aftertreatment 2 DEF dosing valve 3 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing valve or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 3 from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the aftertreatment 2 DEF dosing valve 3 5 volt SUPPLY pin and the aftertreatment 2 DEF dosing temperature 3 SIGNAL pin at the aftertreatment 2 DEF dosing valve connector of the OEM harness.

Use the circuit diagram or wiring diagram for connector pin identification.

  • Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5822 active and Fault Code 5823 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 2 DEF dosing valve 3 to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5823 active?
YES NO

A damaged temperature sensor has been detected in the aftertreatment 2 DEF dosing valve 3.

Replace the aftertreatment 2 DEF dosing valve 3. Refer to Procedure 011-059 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM and ECM harness.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 3 from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing temperature sensor 3 SIGNAL pin in the OEM harness aftertreatment 2 connector and all other pins in the OEM harness aftertreatment 2 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ECM power supply ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 3 from the OEM harness.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing temperature sensor 3 SIGNAL pin in the OEM harness aftertreatment 2 connector and ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 3 from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness aftertreatment 2 connector DEF dosing temperature sensor 3 RETURN pin and the OEM harness aftertreatment 2 connector DEF dosing valve 3 connector DEF dosing temperature sensor RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 3 from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness aftertreatment 2 connector DEF dosing temperature sensor 3 SIGNAL pin and the OEM harness aftertreatment 2 connector DEF dosing valve 3 connector DEF dosing temperature sensor SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5823 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3G - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3H

Guided Step 3H - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing temperature sensor 3 SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Repair or replace the damaged section of harness.

Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3I

Go to 4A

Guided Step 3I - Check for a pin-to-ECM power supply ground short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing temperature sensor 3 SIGNAL pin in the OEM harness ECM connector and ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the harness.

Repair or replace the damaged section of harness.

Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3J

Go to 4A

Guided Step 3J - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment 2 DEF dosing temperature sensor 3 RETURN pin and the OEM harness aftertreatment 2 connector DEF dosing valve 3 DEF dosing temperature sensor RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Repair or replace the damaged section of harness.

Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3K

Go to 4A

Guided Step 3K - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment 2 DEF dosing temperature sensor 3 SIGNAL pin and the OEM harness aftertreatment 2 connector DEF dosing valve 3 DEF dosing temperature sensor SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Repair or replace the damaged section of harness.

Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3L

Go to 4A

Guided Step 3L - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5823 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 19-May-2016


FAULT CODE 5824 - Aftertreatment 2 Diesel Exhaust Fluid Pressure 3 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 5824 active?
STEP 2. | Check the aftertreatment 2 diesel exhaust fluid (DEF) pressure sensor 3 and circuit. |
 | STEP 2A. Inspect the aftertreatment 2 DEF pressure sensor 3 and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 5824 active and Fault Code 5825 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25 volts of direct current (VDC)?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 5824 active?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 5824 active?
 | STEP 3F. Inspect the ECM harness connector pins. | Dirty or damaged pins?
 | STEP 3G. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3H. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3I. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3J. Check for an active fault code. | Fault Code 5824 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 5824 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 2 DEF pressure sensor 3 and circuit.

Guided Step 2A - Inspect the aftertreatment 2 DEF pressure sensor 3 and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 3 from the OEM harness.

Action

Inspect the OEM harness and aftertreatment 2 DEF pressure sensor 3 connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 3 from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Other aftertreatment 2 DEF dosing unit 3 fault codes will be active.

Fault Code 5824 active and Fault Code 5825 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 3 from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the aftertreatment 2 DEF pressure 3 +5 volt SUPPLY pin to the aftertreatment 2 DEF pressure 3 RETURN pin at the dosing valve connector of the OEM harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 2 DEF dosing valve 3 to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5824 active?
YES NO

A malfunctioning aftertreatment DEF pressure sensor has been detected in the aftertreatment 2 DEF dosing valve 3.

Replace the aftertreatment 2 DEF dosing unit 3. Refer to Procedure 011-059 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 3 from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 3 RETURN pin in the OEM harness aftertreatment 2 connector and the aftertreatment 2 DEF pressure sensor 3 RETURN pin in the OEM harness dosing valve connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 3 from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 3 SIGNAL pin in the OEM harness aftertreatment 2 connector and all other pins in the OEM harness aftertreatment 2 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 3 from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 3 SUPPLY pin in the OEM harness aftertreatment 2 connector and all other pins in the OEM harness aftertreatment 2 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5824 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3F - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3G

Guided Step 3G - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 3 RETURN pin in the OEM harness ECM connector and the aftertreatment 2 DEF pressure sensor 3 RETURN pin in the OEM harness connector from the engine harness aftertreatment 2 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Repair or replace the damaged section of harness.

Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3H

Go to 4A

Guided Step 3H - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 3 SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Repair or replace the damaged section of harness.

Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3I

Go to 4A

Guided Step 3I - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 3 SUPPLY pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the harness.

Repair or replace the damaged section of harness.

Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3J

Go to 4A

Guided Step 3J - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5824 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 19-May-2016


FAULT CODE 5825 - Aftertreatment 2 Diesel Exhaust Fluid Pressure 3 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 5825 active?
STEP 2. | Check the aftertreatment 2 diesel exhaust fluid (DEF) pressure sensor 3 and circuit. |
 | STEP 2A. Inspect the aftertreatment 2 DEF pressure sensor 3 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25 volts of direct current (VDC)?
 | STEP 2C. Check the circuit response. | Fault Code 5824 active and Fault Code 5825 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 5825 active?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM aftertreatment 2 harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ECM power supply ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Inspect the ECM OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3G. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3H. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3I. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3I. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3J. Check for a pin-to-ECM power supply ground short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3K. Check for an active fault code. | Fault Code 5825 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 5825 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment 2 DEF pressure sensor 3 and circuit.

Guided Step 2A - Inspect the aftertreatment 2 DEF pressure sensor 3 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 3 from the OEM harness.

Action

Inspect the OEM harness and aftertreatment 2 DEF dosing valve 3 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 3 from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the aftertreatment 2 DEF pressure sensor 3 +5 volt SUPPLY pin to the aftertreatment 2 DEF pressure 3 RETURN pin at the aftertreatment 2 DEF dosing valve 3 connector of the OEM harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 3 from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment 2 DEF pressure sensor 3 +5 volt SUPPLY pin and the aftertreatment 2 DEF pressure sensor 3 SIGNAL pin at the aftertreatment 2 DEF dosing valve 3 connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Other DEF dosing unit fault codes will be active.

Fault Code 5824 active and Fault Code 5825 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 2 DEF dosing valve 3 to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5825 active?
YES NO

A damaged aftertreatment 2 DEF pressure sensor has been detected in the aftertreatment 2 DEF dosing valve 3.

Replace the aftertreatment 2 DEF dosing unit 3. Refer to Procedure 011-059 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the OEM aftertreatment 2 harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Inspect the OEM harness aftertreatment 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM aftertreatment 2 harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 3 from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 3 SUPPLY pin in the OEM harness aftertreatment 2 connector and the aftertreatment 2 DEF pressure sensor 3 SUPPLY pin in the OEM harness aftertreatment 2 dosing valve 3 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 3 from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 3 SIGNAL pin in the OEM harness aftertreatment 2 connector and the aftertreatment 2 DEF pressure sensor 3 SIGNAL pin in the OEM harness aftertreatment 2 dosing valve 3 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 3 from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 3 SIGNAL pin in the OEM harness aftertreatment 2 connector and all other pins in the OEM harness aftertreatment 2 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ECM power supply ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 3 from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 3 SIGNAL pin in the OEM harness aftertreatment 2 connector and ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table if equipped with an aftertreatment junction box.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Inspect the ECM OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the ECM OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM OEM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3G

Guided Step 3G - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 3 SUPPLY pin in the OEM harness ECM connector and the aftertreatment 2 DEF pressure sensor 3 SUPPLY pin in the OEM harness aftertreatment 2 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the harness.

Repair or replace the damaged section of harness.

Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3H

Go to 4A

Guided Step 3H - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 3 SIGNAL pin in the OEM harness ECM connector and the aftertreatment 2 DEF pressure sensor 3 SIGNAL pin in the OEM harness aftertreatment 2 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Repair or replace the damaged section of harness.

Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3I

Go to 4A

Guided Step 3I - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 3 SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the damaged section of harness.

Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3J

Go to 4A

Guided Step 3J - Check for a pin-to-ECM power supply ground short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 2 DEF pressure sensor 3 SIGNAL pin in the OEM harness ECM connector and ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ECM power supply ground short circuit on the SIGNAL wire has been detected in the harness.

Repair or replace the damaged section of harness.

Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3K

Go to 4A

Guided Step 3K - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5825 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 19-May-2016


FAULT CODE 5828 - Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit 3 Input Lines - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSK95 CM2350 K113 | 4388663
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Heater | Refer to Procedure 011-112 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Line Heater Relay | Refer to Procedure 019-600 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Heater Relay | Refer to Procedure 019-620 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 5828 active or more than two inactive counts?
 | STEP 1B. Check for diesel exhaust fluid (DEF) related fault codes. | Fault Code 1712 active or more than two inactive counts?
 | STEP 1C. Check for low DEF tank level. | DEF tank empty and/or Fault Code 1673, 3497, or 3498 active?
 | STEP 1D. Check the DEF tank for debris. | DEF tank and vent clean and free of debris?
 | STEP 1E. Check ambient operating temperatures. | Equipment operating in ambient temperatures below -5°C [23°F] at the time the fault set?
STEP 2. | Check the aftertreatment 2 dosing system 3 DEF line heaters. |
 | STEP 2A. Test the aftertreatment 2 dosing system 3 DEF line heater relays | Aftertreatment 2 dosing system 3 line heater relays within specification?
 | STEP 2B. Check DEF line heater functionality. | All line heaters functioning correctly?
 | STEP 2C. Inspect the original equipment manufacturer (OEM) harness and line heater connections. | Dirty or damaged pins?
 | STEP 2D. Check line heater supply voltage and return circuits. | All measurements within 1-VDC of engine control module (ECM) power supply voltage?
 | STEP 2E. Check line heater supply voltage to chassis ground. | All measurements within 1-VDC of ECM power supply voltage?
STEP 3. | Check the aftertreatment 2 DEF dosing unit 3 heating system. |
 | STEP 3A. Check the aftertreatment 2 diesel exhaust fluid (DEF) dosing unit heater relay. | Aftertreatment 1 DEF dosing unit heater relay within specifications?
 | STEP 3B. Inspect the aftertreatment 2 DEF dosing unit 3 heater and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check heater circuit resistance in the aftertreatment 2 DEF dosing unit 3 heater. | Resistance at 5.4 ohms ± 2.0 ohm?
 | STEP 3D. Check for an open circuit in the aftertreatment 2 DEF dosing unit 3 heater supply circuit. | Voltage within 1 VDC of power supply voltage?
 | STEP 3E. Check aftertreatment 2 DEF dosing unit 3 heater supply voltage to chassis ground. | All measurements within 1-VDC of power supply voltage?
STEP 4. | Check the aftertreatment 2 DEF dosing unit 3 lines and fittings. |
 | STEP 4A. Inspect the aftertreatment 2 DEF dosing unit 3 lines and fittings. | Any reversed, damaged, leaking, or restricted connections found?
 | STEP 4B. Check for pressure at the aftertreatment 2 DEF dosing valve 3. | DEF pressure greater than 1000 kPa [145 psi]?
 | STEP 4C. Check the aftertreatment 2 DEF dosing unit 3 supply line. | DEF dosing unit supply line blocked or restricted?
 | STEP 4D. Check the aftertreatment 2 DEF dosing valve 3 pressure line. | DEF pressure line blocked or restricted?
STEP 5. | Check the aftertreatment 2 DEF dosing valve 3 system return. |
 | STEP 5A. Check for a blocked aftertreatment 2 DEF dosing valve 3. | DEF pressure greater than 700 kPa [102 psi]?
 | STEP 5B. Check the aftertreatment 2 DEF dosing valve 3 return line. | DEF return line blocked or restricted?
STEP 6. | Check the aftertreatment 2 unit 3 DEF suction line. |
 | STEP 6A. Check for air in the DEF. | Air in the DEF detected?
 | STEP 6B. Check for an intermittent aftertreatment 2 DEF dosign unit 3 suction line leak. | Wiggling the DEF suction line connections affect the system pressure?
 | STEP 6C. Check the aftertreatment 2 DEF pressure. | DEF pressure greater than 750 kPa [109 psi]?
STEP 7. | Check the aftertreatment DEF dosing valve 3 operation. |
 | STEP 7A. Check the aftertreatment 2 DEF dosing system 3 operation. | Dosing volume within the specifications in Procedure 011-063 in the Associated Procedures Table?
 | STEP 7B. Check the results of the doser override test. | DEF pressure at the service tool gauge above 700 kPa [102 psi] for the duration of the test?
STEP 8. | Check ECM calibration and clear fault codes. |
 | STEP 8A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 8B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5828 active or more than two inactive counts?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for DEF related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1712 active or more than two inactive counts?
YES NO

Fault code 1712 indicates the aftertreatment DEF tank is frozen. Troubleshoot occurrences of Fault Code 1712 before troubleshooting Fault Code 5828.

No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for low DEF tank level.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Make sure the DEF tank is not empty, and the tank level gauge is accurate.

Use INSITE™ electronic service tool to read the fault codes.

  • Check for the following active Fault Codes: 1673, 3497, and 3498.

DEF tank empty and/or Fault Codes 1673, 3497, or 3498 active?
YES NO

Fill the DEF tank.

 No Repair

Go to 8A

Go to 1D

Guided Step 1D - Check DEF tank for debris.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF tank.

  • Check the DEF tank for debris or foreign particles.
  • Check the DEF tank vent for crystallization buildup and clogging.
  • Use the Cummins® DEF Refractometer Service Tool, Part Number 4919554, to test the DEF concentration.

DEF tank and vent clean and free of debris?
YES NO
No Repair

Clean the DEF tank and tank filter thoroughly. Replace the tank filter if necessary. See equipment manufacturer service information.

Fill tank with certified DEF.

If the DEF in the tank is found to be dirty replace the DEF dosing unit filter and inlet screen. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 1E

Go to 8A

Guided Step 1E - Check ambient operating temperatures.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Check if the equipment was operating in a cold ambient environment, temperature below -5°C [23°F], at the time the fault logged.

Use INSITE™ electronic service tool to read the fault code snapshot and check the ambient air temperature sensor reading to verify.

Equipment operating in ambient temperatures below -5°C [23°F] at the time the fault set?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the aftertreatment 2 dosing system 3 DEF line heaters.

Guided Step 2A - Test the aftertreatment 2 dosing system 3 DEF line heater relays.

Conditions

  • Turn keyswitch OFF.

Action

Test the aftertreatment 1 dosing system 3 DEF line heater relays (K13).

  • Refer to Procedure 019-600 in the Associated Procedures Table.

Aftertreatment 2 dosing system 3 line heater relays within specification?
YES NO
No Repair

A damaged line heater relay has been detected. Replace damaged relay. Refer to Procedure 019-600 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Check DEF line heater functionality.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test.

Use an infrared thermometer to measure the surface temperature at the ends of each of the three aftertreatment 2 unit 3 DEF lines..

Look for the following:

  • Surface temperature should be above 10C [50F].
  • Temperature uniformity across the length of the individual lines.
  • Temperature uniformity between the lines.

If the lines were not at operating temperature when the test was started a temperature rise will be noticeable

All line heaters functioning correctly?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2C

Guided Step 2C - Inspect the OEM harness and line heater connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the three line heaters (suction, pressure, and return) from the OEM harness.

Action

Inspect the OEM harness and line heater connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the line heater or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 8A

Go to 2D

Guided Step 2D - Check line heater supply voltage and return circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the three line heaters (suction, pressure, and return) from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuits.

  • Measure the voltage from the line heater +24 volt SUPPLY pin to the line heater RETURN pin at the heater connector of the OEM harness.

Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

All measurements within 1-VDC of ECM power supply voltage?
YES NO

Replace the malfunctioning line heater(s).

See equipment manufacturer service information.

 No Repair

Go to 8A

Go to 2E

Guided Step 2E - Check line heater supply voltage to chassis ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the three line heaters (suction, pressure, and return) from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuits.

  • Measure the voltage from the line heater +24 volt SUPPLY pin to ECM power supply ground.

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

All measurements within 1-VDC of ECM power supply voltage?
YES NO

An open has been detected in the line heater return circuit.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Troubleshoot return circuit in aftertreatment junction box, if equipped. Refer to Procedure 019-598 in the Associated Procedures Table.

An open has been detected between the line heater relay and the line heater.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Troubleshoot return circuit in aftertreatment junction box, if equipped. Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 8A

Go to 8A

Guided Step 3 - Check the aftertreatment 2 DEF dosing unit 3 heating system.

Guided Step 3A - Check the aftertreatment 2 diesel exhaust fluid (DEF) dosing unit heater relay.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment 2 DEF dosing unit heater relay (K2) from the aftertreatment junction box. Refer to Procedure 019-620 in the Associated Procedures Table.

Action

Test aftertreatment 2 DEF dosing unit heater relay.

  • Refer to Procedure 019-620 in the Associated Procedures Table.

Refer to the appropriate wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Aftertreatment 2 DEF dosing unit heater relay within specifications?
YES NO
No Repair

Replace the aftertreatment 2 DEF dosing unit heater relay (K2). Refer to Procedure 019-620 in the Associated Procedures Table.

Go to 8A

Go to 3B

Guided Step 3B - Inspect the aftertreatment 2 DEF dosing unit 3 heater and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 3 heater from the OEM harness.

Action

Inspect the DEF dosing unit heater and OEM harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment DEF dosing unit heater or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace dosing unit heater only when there are damaged pins. Refer to Procedure 011-112 in the Associated Procedures Table.

 No Repair

Go to 8A

Go to 3C

Guided Step 3C - Check heater circuit resistance in the aftertreatment 2 DEF dosing unit 3 heater.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check resistance at the dosing unit heater:

  • Measure the resistance across heater at the aftertreatment DEF dosing unit heater supply and the aftertreatment DEF dosing unit heater return at the DEF dosing unit.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Resistance at 5.4 ohms ± 2.0 ohm?

YES NO
No Repair

A malfunctioning aftertreatment DEF dosing unit heater has been detected.

Replace the aftertreatment DEF dosing unit heater. Refer to Procedure 011-112 in the Associated Procedures Table.

Go to 3D

Go to 8A

Guided Step 3D - Check for an open circuit in the aftertreatment 2 DEF dosing unit 3 heater supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 3 heater from the OEM harness.
  • Turn keyswitch ON.

Action

Perform the Aftertreatment Diesel Exhaust Fluid Doser System Heater Test found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool.

  • Measure the voltage between aftertreatment 2 DEF dosing unit 3 heater supply pin at the aftertreatment 2 DEF dosing unit 3 heater connector and ground.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of power supply voltage?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DEF dosing unit heater supply circuit.

Check the aftertreatment DEF dosing unit heater circuit breaker. Refer to Procedure 019-598 in the Associated Procedures Table.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 8A

Guided Step 3E - Check aftertreatment 2 DEF dosing unit 3 heater supply voltage to chassis ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 3 heater from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuits.

  • Measure the voltage from the line heater +24 volt SUPPLY pin to engine block ground.

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

All measurements within 1-VDC of power supply voltage?
YES NO

An open circuit has been detected in the aftertreatment DEF dosing unit heater supply circuit.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Troubleshoot return circuit in aftertreatment junction box, if equipped. Refer to Procedure 019-598 in the Associated Procedures Table.

An open circuit has been detected between the heater relay and the heater.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Troubleshoot return circuit in aftertreatment junction box, if equipped. Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 8A

Go to 8A

Guided Step 4 - Check the aftertreatment 2 DEF dosing unit 3 lines and fittings.

Guided Step 4A - Inspect the aftertreatment 2 DEF dosing unit 3 lines and fittings.

Conditions

  • Turn keyswitch OFF.

Action

There are three DEF lines on the SCR dosing system:

  • Dosing unit supply line between the tank and the dosing unit (suction line)
  • Dosing valve supply line between the dosing unit and the dosing valve (pressure line)
  • Return line between the dosing valve and the tank (return line).

Inspect all three DEF lines and associated fittings/connectors:

  • Inspect the dosing unit for a plugged inlet filter in the inlet fitting. Refer to Procedure 011-058 in the Associated Procedures Table.
  • Inspect the dosing unit DEF filter. Refer to Procedure 011-060 in the Associated Procedures Table.
  • Verify the DEF line connections are not swapped at the dosing unit, dosing valve or DEF tank. Reversed DEF lines can cause the dosing system to fail to prime.
  • Check the DEF tank connections (suction and return lines) for cracks and pitting.
  • Check both dosing unit connections and fittings for loose, leaking, or damaged connections.
  • Check the suction line for signs of leakage or openings which will allow the dosing unit to suck in air with the DEF.
  • Check the pressure line for signs of leakage or rupture.
  • Disconnect the suction line, pressure line, and return line connectors and look for signs of buildup or blockage.
  • Verify proper sealing at all connection points and check for damaged or missing o-rings.

Any reversed, damaged, leaking, or restricted connections found?
YES NO

Replace the DEF line(s), fittings, and filters, as necessary.

See equipment manufacturer service information.

Use the following procedure for DEF dosing unit inlet filter screen. Refer to Procedure 011-058 in the Associated Procedures Table.

Use the following procedure for DEF dosing unit filter. Refer to Procedure 011-060 in the Associated Procedures Table.

Use the following procedure for dosing unit connections. Refer to Procedure 011-058 in the Associated Procedures Table.

Repair or replace the aftertreatment DEF dosing unit, as necessary. Refer to Procedure 011-058 in the Associated Procedures Table.

Replace the DEF dosing unit inlet filter screen and dosing unit DEF filter. These filters can not be reused and must be changed upon removal. Refer to Procedure 011-060 in the Associated Procedures Table.

Go to 8A

Go to 4B

Guided Step 4B - Check for pressure at the aftertreatment 2 DEF dosing valve 3.

Conditions

  • Turn keyswitch OFF
  • Install the DEF pressure gauge between the inlet of the dosing valve and the pressure line. Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

Attempt to prime the DEF system.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhuast Fluid System Leak Test, under ECM Diagnostics Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure greater than 1000 kPa [145 psi]?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check the aftertreatment DEF dosing unit supply line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing unit 3 supply line from the dosing unit (this is the suction line between the dosing unit and the DEF tank).
  • Disconnect the aftertreatment 2 DEF dosing unit 3 supply line from the DEF tank.

Action

Check the DEF dosing unit 3 supply line for blockage.

  • Check both ends of the dosing unit supply line for signs of build-up or blockage.
  • Blow compressed shop air through the dosing unit supply line to make sure of free flow.

DEF dosing unit supply line blocked or restricted?
YES NO

Try to clean the dosing unit supply line with shop air. If necessary, replace the dosing unit supply line.

See equipment manufacturer service information.

 No Repair

Go to 8A

Go to 4D

Guided Step 4D - Check the aftertreatment 2 DEF dosing valve 3 pressure line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 3 pressure line from the dosing valve (pressure line runs between the dosing unit and dosing valve).
  • Disconnect the aftertreatment 2 DEF dosing valve 3 pressure line from the DEF dosing unit

Action

Check the aftertreatment 2 DEF pressure line for blockage.

  • Visually check both ends of the line for signs of buildup or blockage.
  • Blow compressed shop air through the pressure line to make sure of free flow.

DEF pressure line blocked or restricted?
YES NO

Try to clean the pressure line using shop air. If necessary, replace the pressure line.

See equipment manufacturer service information.

 No Repair

Go to 8A

Go to 6A

Guided Step 5 - Check the aftertreatment 2 DEF dosing valve 3 system return.

Guided Step 5A - Check for a blocked aftertreatment 2 DEF dosing valve 3.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the outlet of the dosing valve and the return line. Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

Attempt to prime the DEF system.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostics Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure greater than 700 kPa [102 psi]?
YES NO
No Repair

Replace the DEF dosing valve.

Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 5B

Go to 8A

Guided Step 5B - Check the aftertreatment DEF dosing valve return line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 3 return line from the dosing valve.
  • Disconnect the aftertreatment 2 DEF dosing valve 3 return line from the DEF tank.

Action

Check the aftertreatment 2 DEF dosing valve 3 return line for blockage.

  • Visually check both ends of the line for signs of buildup or blockage.
  • Blow compressed shop air through the return line to make sure of free flow.

DEF return line blocked or restricted?
YES NO

Try to clean the return line using shop air. If necessary, replace the return line.

See equipment manufacturer service information.

A blocked or restricted return has been detected in the DEF tank head. Clean or replace the tank head as necessary.

See equipment manufacturer service information.

Go to 8A

Go to 8A

Guided Step 6 - Check the aftertreatment 2 unit 3 DEF suction line.

Guided Step 6A - Check for air in the DEF.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for air in the DEF.

  • Refer to Procedure 011-075 in the Associated Procedures Table.

Air in the DEF detected?
YES NO

Check the following components for damage/leaks and repair as necessary:

  • Aftertreatment 2 DEF dosing unit 3 fittings
  • Aftertreatment 2 DEF dosing unit 3 supply line
  • Aftertreatment 2 DEF tank fittings
  • Aftertreatment 2 DEF tank filter.

Refer to Procedure 011-075 in the Associated Procedures Table.

 No Repair

Go to 8A

Go to 6B

Guided Step 6B - Check for an intermittent aftertreatment 2 DEF dosing unit 3 suction line leak.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.

Action

Attempt to prime the DEF system. Use INSITE™ electronic service tool to perform the Aftertreatment DEF System Leak Test, under ECM Diagnostics Tests.

As the DEF system is trying to prime, wiggle the suction line connections at the dosing unit 3 and tank. Monitor the DEF pressure sensor reading in INSITE™ electronic service tool data monitor/logger section.

  • Check if wiggling the suction line connections causes the system to either build pressure or lose prime.
  • Listen for audible indication from the pump that wiggling the suction line is causing air to enter the system.

Wiggling the DEF suction line connections affect the system pressure?
YES NO

Replace the DEF suction line. See equipment manufacturer service information.

 No Repair

Go to 8A

Go to 6C

Guided Step 6C - Check the aftertreatment 2 DEF pressure.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.

Action

Attempt to prime the DEF system.

Use INSITE™ electronic service tool to perform the Aftertreatment DEF System Leak Test, under ECM Diagnostics Tests.

  • Monitor the DEF pressure sensor reading in INSITE™ electronic service tool data monitor/logger section.

DEF pressure greater than 750 kPa [109 psi]?
YES NO
No Repair

Replace the DEF dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 7A

Go to 8A

Guided Step 7 - Check the aftertreatment DEF dosing valve 3 operation.

Guided Step 7A - Check the aftertreatment 2 DEF dosing system 3 operation.

Conditions

  • Connect the DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove the aftertreatment 2 DEF dosing valve 3 from the decomposition chamber.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test, under ECM Diagnostics Tests.

  • Use the following procedure for instructions and specifications. Refer to Procedure 011-063 in the Associated Procedures Table.

The aftertreatment 2 DEF dosing valve 3 must be removed and placed in a measuring container having greater than a 1.5 liter [50 oz] capacity to run the Aftertreatment DEF Doser Pump Override Test.

Dosing volume within the specifications in Procedure 011-063 in the Associated Procedures Table?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7B

Guided Step 7B - Check the results of the doser override test.

Conditions

  • Turn the keyswitch OFF.

Action

Check the service pressure tool reading recorded during the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

DEF pressure at the service tool gauge reading above 700 kPa [102 psi] for the duration of the test?
YES NO

Replace the aftertreatment 2 DEF dosing valve 3.

Refer to Procedure 011-059 in the Associated Procedures Table.

Replace the aftertreatment 2 DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 8A

Go to 8A

Guided Step 8 - Check ECM calibration and clear fault codes.

Guided Step 8A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in Section 19.

Go to 8B

Go to 8B

Guided Step 8B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process

Repair complete

Last Modified: 03-May-2017


FAULT CODE 5829 - Aftertreatment 2 Diesel Exhaust Fluid Pressure 3 - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSK95 CM2350 K113 | 4388663
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Line Restriction Test | Refer to Procedure 011-086 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid System Connection Test | Refer to Procedure 011-107 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Suction Test | Refer to Procedure 011-121 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 5829 active inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for related fault codes. | Fault Code 1712 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1C. Check for low diesel exhaust fluid (DEF) tank level. | DEF tank empty and/or Fault Code 1673, 3497, or 3498 active?
 | STEP 1D. Check for active fault codes. | Fault Code 1683, 1684, 1712, 1713, 3237, 3239, 3242, 3258, 3261, 3422, 3425, 3426, 3429, 3559, 3558, 3562, 3563, 3564, 3571, 3572, 3575, 3576, 3596, 3713, 4167, 5278, or 5935 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1E. Check for crossed connections. | Any crossed systems found per 011-107 in the Associated Procedures Table?
STEP 2. | Check the aftertreatment DEF lines and fittings. |
 | STEP 2A. Inspect the aftertreatment DEF lines and fittings. | Any reversed, damaged, leaking, or restricted connections found?
 | STEP 2B. Check the DEF tank. | DEF tank and vent clean and free of debris?
STEP 3. | Check the aftertreatment DEF dosing unit. |
 | STEP 3A. Check the aftertreatment DEF dosing unit. | Vacuum in diagnostic line greater than -216 mm-Hg [-8 in-Hg]?
 | STEP 3B. Check the aftertreatment DEF dosing unit. | DEF unit operating?
 | STEP 3C. Inspect the ECM and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 3D. Check for an open return circuit in the harness. | Less than 10 ohms?
STEP 4. | Check the aftertreatment DEF intake system. |
 | STEP 4A. Check the DEF dosing unit intake restriction. | Restriction less than -254 mm-Hg [-6 in-Hg]?
STEP 5. | Check for air in the aftertreatment DEF. |
 | STEP 5A. Check for air in the DEF. | Air in the DEF detected?
STEP 6. | Check the aftertreatment DEF pressure sensor. |
 | STEP 6A. Inspect the aftertreatment DEF pressure sensor. | Aftertreatment DEF pressure reading in INSITE™ electronic service tool equal to 0 ±69 kPa [0 ±10 psi]?
 | STEP 6B. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 6C. Check for an open circuit in the harness. | Less than 10 ohms?
STEP 7. | Check the aftertreatment DEF lines and fittings. |
 | STEP 7A. Check for pressure at the aftertreatment DEF dosing valve. | DEF pressure less than 950 kPa [137 psi]?
 | STEP 7A-1. Check for pressure at the aftertreatment DEF dosing valve. |
 | STEP 7A-2. Check for pressure at the aftertreatment DEF dosing valve. |
 | STEP 7B. Check for pressure out of the aftertreatment DEF dosing unit. | DEF pressure less than 950 kPa [137 psi]?
 | STEP 7C. Check for pressure out of the aftertreatment DEF dosing unit. | DEF pressure less than 750 kPa [108 psi]?
 | STEP 7D. Check the aftertreatment DEF dosing unit for blockage. | DEF dosing unit blocked or restricted?
STEP 8. | Check the aftertreatment DEF dosing unit operation. |
 | STEP 8A. Check the aftertreatment DEF dosing unit system operation. | Dosing volume within the specifications in Procedure 011-063 in the Associated Procedures Table?
STEP 9. | Check ECM calibration and clear fault codes. |
 | STEP 9A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 9B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5829 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1712 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

Fault Code 1712 indicates the aftertreatment DEF tank is frozen. Troubleshoot occurrences of Fault Code 1712 before troubleshooting Fault Code 5829.

No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for low DEF tank level.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

  • Check for the following active Fault Codes: 1673, 3497, and 3498.

DEF tank empty and/or Fault Code 1673, 3497, or 3498 active?
YES NO

Fill the DEF tank.

 No Repair

Go to 9A

Go to 1D

Guided Step 1D - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1683, 1684, 1712, 1713, 3237, 3239, 3242, 3258, 3261, 3422, 3425, 3426, 3429, 3559, 3558, 3562, 3563, 3564, 3571, 3572, 3575, 3576, 3596, 3713, 4167, 5278, or 5935 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

See the appropriate fault code troubleshooting tree.

Go to 1E

Guided Step 1E - Check for crossed connections.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to check for cross-connection of components. Refer to Procedure 011-107 in the Associated Procedures Table.
  • Trace the DEF pressure line from the DEF dosing unit. Verify it is connected to the correct DEF dosing valve, by component location, on the aftertreatment.

Any crossed systems found per Procedure 011-107 in the Associated Procedures Table?
YES NO

Correct the crossed systems. Refer to Procedure 011-107 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 2A

Guided Step 2 - Check the aftertreatment DEF lines and fittings.

Guided Step 2A - Inspect the aftertreatment DEF lines and fittings.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the following aftertreatment DEF fittings and lines.

  • Dosing unit supply line between the tank and dosing unit (suction line)
  • Dosing valve supply line between the dosing unit and dosing valve (pressure line)
  • Return line between the dosing valve and tank (return line).

Inspect all three DEF lines and associated fittings/connectors:

  • Verify the lines are not swapped at the dosing unit, dosing valve, or DEF tank connections. Reversed DEF line connectors cause the dosing system to fail to prime.
  • Check the DEF tank connections (suction and return lines) for cracks and pitting.
  • Check both dosing unit connections and fittings for loose, leaking, or damaged connections.
  • Disconnect the suction line and pressure line dosing unit connectors. Look for signs of buildup or blockage.
  • Check the suction line for signs of leakage or openings which will allow the dosing unit to suck in air with the DEF.
  • Check the pressure line for sings of leakage or rupture.
  • Verify proper sealing at all connection points, including DEF tank (two connections), dosing unit (two connections), and dosing valve (two connections).

Refer to Procedure 011-058 in the Associated Procedures Table.

Any reversed, damaged, leaking, or restricted connections found?
YES NO

Replace the leaking DEF line, as necessary. See equipment manufacturer service information.

 No Repair

Go to 9A

Go to 2B

Guided Step 2B - Check the DEF tank.

Conditions

  • Turn keyswitch OFF.

Action

  • Check the DEF tank for contamination or debris. Refer to Procedure 011-056 in the Associated Procedures Table.
  • Check the DEF tank vent for crystallization, buildup, and clogging.

DEF tank and vent clean and free of debris?
YES NO
No Repair

Flush the DEF system. Refer to Procedure 011-056 in the Associated Procedures Table.

  • Drain the DEF tank. Thoroughly flush with distilled water.
  • Clean and flush the DEF tank head and filter. Replace the DEF tank filter, as necessary.
  • Remove and flush the dosing unit intake and return lines.
  • Make sure the DEF dosing unit intake and fitting and filter are new. Refer to Procedure 011-058 in the Associated Procedures Table.
  • Fill the DEF tank with clean, certified DEF.

Go to 3A

Go to 9A

Guided Step 3 - Check the aftertreatment DEF dosing unit.

Guided Step 3A - Check the aftertreatment DEF dosing unit.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Refer to Procedure 011-121 in the Associated Procedures Table.

Vacuum in diagnostic line greater than -216 mm-Hg [-8 in-Hg]?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the aftertreatment DEF dosing unit.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Dosing unit was making sound and/or vibration.

DEF unit operating?
YES NO

Remove the dosing unit intake screen and main filter.

Inspect the intake screen and DEF in the main filter well for debris.

If any debris is visible, the system is contaminated with debris and must be flushed. Refer to Procedure 011-056 in the Associated Procedures Table.

  • Drain the DEF tank. Thoroughly flush with distilled water.
  • Clean and flush the DEF tank head and filter. Replace the DEF tank filter, as necessary.
  • Remove and flush the dosing unit intake line.
  • Fill the DEF tank with clean, certified DEF.

Perform the airless flush. Refer to Procedure 011-058 in the Associated Procedures Table.

Run the DEF Dosing Unit Suction Test. Refer to Procedure 011-121 in the Associated Procedures Table.

If vacuum is not greater than -216 mm-Hg [-8 in-Hg] gauge when tested, replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

If vacuum is greater than -216 mm-Hg [-8 in-Hg] gauge when tested, the dosing unit should be reused.

  • DEF dosing unit intake screen and main filter are new. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 3C

Guided Step 3C - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor, ECM engine connector, or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 3D

Guided Step 3D - Check for an open return circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

  • Measure the resistance between the aftertreatment DEF dosing unit RETURN pin in the OEM harness ECM connector and the aftertreatment DEF dosing unit RETURN pin in the OEM harness dosing valve connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

A malfunctioning DEF dosing unit has been detected.

Replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 9A

Guided Step 4 - Check the aftertreatment DEF intake system.

Guided Step 4A - Check the DEF dosing unit intake restriction.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Refer to Procedure 011-086 in the Associated Procedures Table.

Restriction less than -254 mm-Hg [-6 in-Hg]?
YES NO
No Repair

Clean or replace the DEF tank filter, DEF tank vent filter, and DEF suction line, as necessary.

Drain the DEF tank. Flush with distilled water. Fill the DEF tank with clean, certified DEF.

See equipment manufacturer service information.

Go to 5A

Go to 9A

Guided Step 5 - Check for air in the aftertreatment DEF.

Guided Step 5A - Check for air in the DEF.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Refer to Procedure 011-075 in the Associated Procedures Table.

Air in the DEF detected?
YES NO

Check the following components for damage/leaks. Repair, as necessary.

  • Aftertreatment DEF dosing unit supply line
  • Aftertreatment DEF tank fittings
  • Aftertreatment DEF tank stand pipe.

Refer to Procedure 011-075 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 6A

Guided Step 6 - Check the aftertreatment DEF pressure sensor.

Guided Step 6A - Inspect the aftertreatment DEF pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Disconnect the aftertreatment DEF dosing valve pressure line (this is the supply line between the dosing unit and dosing valve).
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to monitor the aftertreatment DEF pressure.

Aftertreatment DEF pressure reading in INSITE™ electronic service tool equal to 0 ±69 kPa [0 ±10 psi]?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6B

Guided Step 6B - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor, ECM engine connector, or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 6C

Guided Step 6C - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the aftertreatment 1 DEF dosing unit from the OEM harness.

Action

  • Measure the resistance between the aftertreatment 1 DEF pressure sensor SUPPLY pin in the OEM harness ECM connector and the aftertreatment 1 DEF pressure sensor SUPPLY pin in the OEM harness aftertreatment 1 DEF dosing valve connector.
  • Measure the resistance between the aftertreatment 1 DEF pressure sensor SIGNAL pin in the OEM harness ECM connector and the aftertreatment 1 DEF pressure sensor SIGNAL pin in the OEM harness aftertreatment 1 DEF dosing valve connector.
  • Measure the resistance between the aftertreatment 1 DEF pressure sensor RETURN pin in the OEM harness ECM connector and the aftertreatment 1 DEF pressure sensor RETURN pin in the OEM harness dosing valve connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

A damaged aftertreatment DEF pressure sensor has been detected.

Replace the aftertreatment DEF dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

An open circuit has been detected in the harness.

Repair or replace the damaged section of the harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.

Go to 7A

Go to 9A

Guided Step 7 - Check the aftertreatment DEF lines and fittings.

Guided Step 7A - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the inlet of the dosing valve and pressure line (this is the supply line between the dosing unit and dosing valve). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Test.
  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 950 kPa [137 psi]?
YES | NO
No Repair | No Repair

Go to 7B

Go to 7A-1

Guided Step 7A-1 - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the outlet of the dosing valve and return line (this is the return line between the dosing valve and tank). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Connect the DEF pressure line to the inlet of the dosing valve.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.

Read the DEF pressure from the service tool gauge.

DEF pressure less than 70 kPa [10 psi]?
YES NO
No Repair

A blocked or restricted return line and/or tank head has been detected. Clean or replace the return line and/or tank head, as necessary.

See equipment manufacturer service information.

Go to 7A-2

Go to 7B

Guided Step 7A-2 - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Install the DEF pressure gauge between the inlet of the dosing valve and pressure line. Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.

Read the DEF pressure from the service tool gauge.

DEF pressure reading ±70 kPa [±10 psi] of gauge reading?
YES NO
No Repair

Replace the inlet screen per Procedure 011-059. Perform this step again.

If still out of specification, replace the dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 7B

Go to 9A

Guided Step 7B - Check for pressure out of the aftertreatment DEF dosing unit.

Conditions

  • Turn keyswitch OFF.
  • Connect the DEF pressure line to the inlet of the dosing valve.
  • Install the DEF pressure gauge between the outlet of the dosing unit and pressure line (this is the supply line between the dosing unit and dosing valve). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 950 kPa [137 psi]?
YES NO
No Repair

A restricted pressure line has been detected. Clean or replace the pressure line, as necessary.

See equipment manufacturer service information.

Go to 7C

Go to 9A

Guided Step 7C - Check for pressure out of the aftertreatment DEF dosing unit.

Conditions

  • Turn keyswitch OFF.
  • Install the DEF pressure gauge between the outlet of the dosing unit and pressure line (this is the supply line between the dosing unit and dosing valve). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under Diagnostic Tests.
  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 750 kPa [108 psi]?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7D

Guided Step 7D - Check the aftertreatment DEF dosing unit for blockage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve pressure line from the dosing valve (pressure line runs between the dosing unit and dosing valve).
  • Disconnect the aftertreatment DEF dosing valve pressure line from the DEF dosing unit.

Action

  • Inspect the outlet fitting for signs of buildup or blockage.
  • Inspect the dosing unit filter for signs of buildup or blockage.
  • Inspect the inlet fitting screen for signs of buildup or blockage.

DEF dosing unit blocked or restricted?
YES NO

Clean the aftertreatment DEF dosing unit outlet or inlet fitting if needed.

Replace the aftertreatment DEF dosing unit filter if needed. Refer to Procedure 011-060 in the Associated Procedures Table.

A malfunctioning DEF dosing unit has been detected.

Replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 9A

Go to 9A

Guided Step 8 - Check the aftertreatment DEF dosing unit operation.

Guided Step 8A - Check the aftertreatment DEF dosing system operation.

Conditions

  • Connect all DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove aftertreatment DEF dosing valve from decomposition chamber.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use the following procedure for instructions and specifications. Refer to Procedure 011-063 in the Associated Procedures Table.

The aftertreatment DEF dosing valve must be removed and placed in a measuring container having greater than a 1.5 liter [50 oz] capacity to run the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Dosing volume within the specifications in Procedure 011-063 in the Associated Procedures Table?
YES NO
No Repair

Refer to Procedure 011-063 in the Associated Procedures Table for repair instructions.

Go to 9A

Go to 9A

Guided Step 9 - Check ECM calibration and clear fault codes.

Guided Step 9A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 9B

Go to 9B

Guided Step 9B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-Apr-2017


FAULT CODE 5831 - Aftertreatment 2 Diesel Exhaust Fluid Pressure 3 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid System Connection Test | Refer to Procedure 011-107 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5831 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3596, 3571, 3572, 5278, 5935, 5936, 5864, or 5865 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1C. Check for crossed connections. | Any crossed systems found per procedure 011-107 in the Associated Procedures Table?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) lines and fittings. |
 | STEP 2A. Check for pressure at the aftertreatment DEF dosing valve. | DEF pressure less than 70 kPa [10 psi]?
 | STEP 2B. Check for pressure at the aftertreatment DEF tank head. | DEF pressure less than 70 kPa [10 psi]?
 | STEP 2C. Check for pressure at the aftertreatment DEF dosing valve. | DEF pressure reading ± 70 kPa [10 psi] of gauge reading?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 5831 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3596, 3571, 3572, 5278, 5935, 5936, 5864, or 5865 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for crossed connections.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to check for cross-connection of components. Refer to Procedure 011-107 in the Associated Procedures Table.
  • Trace the DEF pressure line from the DEF dosing unit and verify it is connected to the correct DEF dosing valve, by component location, on the aftertreatment.

Any crossed systems found per procedure 011-107 in the Associated Procedures Table?
YES NO
No Repair

Correct the crossed systems. Refer to Procedure 011-107 in the Associated Procedures Table.

Go to 3A

Go to 2A

Guided Step 2 - Check the aftertreatment DEF lines and fittings.

Guided Step 2A - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the outlet of the dosing valve and return line (this is the return line between the dosing valve and tank). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.

  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 70 kPa [10 psi]?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2B

Guided Step 2B - Check for pressure at the aftertreatment DEF tank head.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for diesel exhaust fluid system pressure to leak down.
  • Install the DEF pressure gauge between the inlet of the tank head and the return line (this is the return line between the dosing valve and the tank). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.

  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 70 kPa [10 psi]?
YES NO

A blocked or restricted return line has been detected.

Clean or replace the return line, as necessary.

See equipment manufacturer service information.

A blocked or restricted tank head has been detected.

Clean or replace the tank head, as necessary.

See equipment manufacturer service information.

Go to 3A

Go to 2D

Guided Step 2C - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Install the DEF pressure gauge between the inlet of the dosing valve and the pressure line. Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.

  • Read the DEF pressure from the service tool gauge.

DEF pressure reading ± 70 kPa [10 psi] of gauge reading?
YES NO
No Repair

Replace inlet screen per Procedure 011-059 in the Associated Procedures Table and perform this step again.

If still out of specification, then replace dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Repair complete

Go to 1A

Last Modified: 22-Mar-2017


FAULT CODE 5832 - Aftertreatment 2 Diesel Exhaust Fluid Pressure 3 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid System Connection Test | Refer to Procedure 011-107 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5832 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3571, 3572, 5278, 5935, 5936, 5864, or 5865 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1C. Check for active fault codes. | Any crossed systems found per procedure 011-107 in the Associated Procedures Table?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) pressure sensor. |
 | STEP 2A. Inspect the aftertreatment DEF pressure sensor. | Aftertreatment DEF pressure reading in INSITE™ electronic service tool equal to 0 ±69 kPa [0 ±10 psi]?
STEP 3. | Check the aftertreatment DEF lines and fittings. |
 | STEP 3A. Check for pressure at the aftertreatment DEF dosing valve. | DEF pressure less than 70 kPa [10 psi]?
 | STEP 3B. Check for pressure at the aftertreatment DEF tank head. | DEF pressure less than 70 kPa [10 psi]?
 | STEP 3C. Check for pressure at the aftertreatment DEF dosing valve. | DEF pressure reading ± 70 kPa [10 psi] of gauge reading?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 5832 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3571, 3572, 5278, 5935, 5936, 5864, or 5865 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Any crossed systems found per procedure 011-107 in the Associated Procedures Table?
YES NO
No Repair

Correct the crossed systems. Refer to Procedure 011-107 in the Associated Procedures Table.

Go to 4A

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid (DEF) pressure sensor.

Guided Step 2A - Inspect the aftertreatment DEF pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve supply line.
  • Turn keyswitch ON.
  • Connection INSITE™ electronic service tool.

Action

Inspect the aftertreatment DEF pressure sensor.

  • Use INSITE™ electronic service tool to monitor the aftertreatment DEF pressure.

Aftertreatment DEF pressure reading in INSITE™ electronic service tool equal to 0 ±69 kPa [0 ±10 psi]?
YES NO
No Repair

A damaged aftertreatment DEF pressure sensor has been detected. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF lines and fittings.

Guided Step 3A - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for DEF system pressure to leak down.
  • Install the DEF pressure gauge between the outlet of the dosing valve and return line (this is the return line between the dosing valve and tank). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.

  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 70 kPa [10 psi]?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B

Guided Step 3B - Check for pressure at the aftertreatment DEF tank head.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds for diesel exhaust fluid system pressure to leak down.
  • Install the DEF pressure gauge between the inlet of the tank head and the return line (this is the return line between the dosing valve and the tank). Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.

  • Read the DEF pressure from the service tool gauge.

DEF pressure less than 70 kPa [10 psi]?
YES NO

A blocked or restricted return line has been detected.

Clean or replace the return line, as necessary.

See equipment manufacturer service information.

A blocked or restricted tank head has been detected.

Clean or replace the tank head, as necessary.

See equipment manufacturer service information.

Go to 4A

Go to 3D

Guided Step 3C - Check for pressure at the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Install the DEF pressure gauge between the inlet of the dosing valve and the pressure line. Use DEF Pressure Gauge Kit, Part Number 5299005.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test, under ECM Diagnostic Tests.

  • Read the DEF pressure from the service tool gauge.

DEF pressure reading ± 70 kPa [10 psi] of gauge reading?
YES NO
No Repair

Replace inlet screen per Procedure 011-059 in the Associated Procedures Table and perform this step again.

If still out of specification, then replace dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 4A

Go to 4D

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Repair complete

Go to 1A

Last Modified: 22-Mar-2017


FAULT CODE 5833 - Aftertreatment 2 Diesel Exhaust Fluid Dosing Valve 3 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Engine Control Module Power Supply Ground Circuit | Refer to Procedure 019-610 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for aftertreatment 2 diesel exhaust fluid (DEF) dosing valve 3 fault codes. | Fault Code 5833 active?
STEP 2. | Check the aftertreatment 2 DEF dosing valve 3 and circuit. |
 | STEP 2A. Inspect the aftertreatment 2 DEF dosing valve 3 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the aftertreatment 2 DEF dosing valve 3 resistance. | Between 10 and 17 ohms?
STEP 3. | Check the engine and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the aftertreatment 2 DEF dosing valve 3 signal circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check the aftertreatment 2 DEF dosing valve 3 return circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-ECM power supply ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Inspect the engine control module (ECM) harness connector pins. | Dirty or damaged pins?
 | STEP 3G. Check the aftertreatment 2 DEF dosing valve 3 signal circuit. | Less than 10 ohms?
 | STEP 3H. Check the aftertreatment 2 DEF dosing valve 3 return circuit. | Less than 10 ohms?
 | STEP 3G. Check for a pin-to-ECM power supply ground short circuit. | Greater than 100k ohms?
 | STEP 3J. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for aftertreatment 2 DEF dosing valve 3 fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 5833 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the aftertreatment 2 DEF dosing valve 3 and circuit.

Guided Step 2A - Inspect the aftertreatment 2 DEF dosing valve 3 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 3 from the OEM harness.

Action

Inspect the OEM harness and aftertreatment 2 DEF dosing valve 3 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirty or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing valve or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the aftertreatment 2 DEF dosing valve 3 resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 3 from the OEM harness.

Action

Check for an internal short or open circuit in the aftertreatment 2 DEF dosing valve 3 by measuring internal resistance.

  • Measure the resistance between the aftertreatment 2 DEF dosing valve 3 SIGNAL pin and the aftertreatment 2 DEF dosing valve 3 RETURN pin at the aftertreatment 2 DEF dosing valve 3 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 10 and 17 ohms?
YES NO
No Repair

An internal short or open circuit has been detected in the aftertreatment 2 DEF dosing valve 3.

Replace the aftertreatment 2 DEF dosing valve 3. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine and OEM harness.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Inspect the OEM harness aftertreatment 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness aftertreatment 2 connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the aftertreatment 2 DEF dosing valve 3 signal circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 3 from the OEM harness.

Action

Check the dosing valve signal circuit.

  • Measure the resistance between the OEM harness aftertreatment 2 DEF dosing valve 3 connector SIGNAL pin and the OEM harness aftertreatment 2 connector DEF dosing valve 3 SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the aftertreatment 2 DEF dosing valve 3 return circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 3 from the OEM harness.

Action

Check the dosing valve return circuit.

  • Measure the resistance between the OEM harness aftertreatment 2 DEF dosing valve 3 connector RETURN pin and the OEM harness aftertreatment 2 connector DEF dosing valve 3 RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ECM power supply ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 3 from the OEM harness.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing valve 3 SIGNAL pin in the OEM harness aftertreatment 2 connector and ECM power supply ground circuit.
  • Measure the resistance between the aftertreatment 2 DEF dosing valve 3 RETURN pin in the OEM harness aftertreatment 2 connector and ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 3 from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing valve 2 SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the short circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If a short circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3G

Guided Step 3G - Check the aftertreatment 2 DEF dosing valve 3 signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check the dosing valve signal circuit.

  • Measure the resistance between the OEM harness aftertreatment 2 connector DEF dosing valve 3 connector SIGNAL pin and the ECM connector aftertreatment 2 DEF dosing valve 3 SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Repair or replace the damaged section of harness.

Use the following procedure for engine harness repair. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3H

Go to 4A

Guided Step 3H - Check the aftertreatment 2 DEF dosing valve 3 return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check the dosing valve return circuit.

  • Measure the resistance between the OEM harness aftertreatment 2 connector DEF dosing valve 3 RETURN pin and the ECM connector aftertreatment 2 DEF dosing valve 3 RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Repair or replace the damaged section of harness.

Use the following procedure for engine harness repair. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3I

Go to 4A

Guided Step 3I - Check for a pin-to-ECM power supply ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-ECM power supply ground short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing valve 3 SIGNAL pin in the OEM harness ECM connector and ECM power supply ground circuit.
  • Measure the resistance between the aftertreatment 2 DEF dosing valve 3 RETURN pin in the OEM harness ECM connector and ECM power supply ground circuit.
  • Refer to Procedure 019-610 in the Associated Procedures Table.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the harness.

Repair or replace the damaged section of harness.

Use the following procedure for engine harness repair. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3J

Go to 4A

Guided Step 3J - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing valve 3 SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness.

Repair or replace the damaged section of harness.

Use the following procedure for engine harness repair. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 19-May-2016


FAULT CODE 5834 - Aftertreatment 2 Diesel Exhaust Fluid Pressure 3 Sensor Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for aftertreatment 2 diesel exhaust fluid (DEF) dosing valve 3 fault codes. | Fault Code 5834 active?
STEP 2. | Check the aftertreatment 2 DEF dosing valve 3 and circuit. |
 | STEP 2A. Inspect the OEM aftertreatment 2 harness and aftertreatment 2 DEF dosing valve 3 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the OEM harness aftertreatment 2 DEF dosing valve 3 return circuit. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the OEM aftertreatment 2 harness. | Greater than 100k ohms?
 | STEP 2D. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 2E. Check the aftertreatment 2 engine harness DEF dosing valve 3 return circuit. | Less than 10 ohms?
 | STEP 2F. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for aftertreatment 2 DEF dosing valve 3 fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5834 active?
YES NO
No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the aftertreatment 2 DEF dosing valve 3 and circuit.

Guided Step 2A - Inspect the OEM aftertreatment 2 harness and aftertreatment 2 DEF dosing valve 3 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 3 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Inspect the OEM harness connector and DEF dosing valve 3 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the OEM harness aftertreatment 2 DEF dosing valve 3 return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 3 from the OEM harness.

Action

Check the dosing valve sensor return circuit.

  • Measure the resistance from the OEM harness aftertreatment 2 DEF dosing valve 3 connector sensor RETURN pin to the OEM harness aftertreatment 2 connector DEF dosing valve 3 sensor RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For OEM harness repair. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the OEM aftertreatment 2 harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 3 from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment 2 DEF dosing valve 3 sensor RETURN pin in the OEM harness aftertreatment 2 connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness.

  • For OEM harness repair. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2E

Guided Step 2E - Check the aftertreatment 2 engine harness DEF dosing valve 3 return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness from the engine harness aftertreatment 2 connector

Action

Check the dosing valve sensor return circuit.

  • Measure the resistance from the engine harness aftertreatment 2 connector sensor RETURN pin to the ECM connector aftertreatment 2 DEF dosing valve 3 sensor RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Repair or replace the damaged section of the harness.

  • For engine harness repair. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2F

Go to 3A

Guided Step 2F - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness from the engine harness aftertreatment 2 connector

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment 2 DEF dosing valve 3 sensor RETURN pin in the OEM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the aftertreatment 2 DEF dosing valve 2. Refer to Procedure 011-059 in the Associated Procedures Table.

A pin-to-pin short circuit has been detected in the harness.

Repair or replace the damaged section of the harness.

  • For engine harness repair. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 19-May-2016


FAULT CODE 5862 - Engine Diesel Fuel Metering Valve Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 5682 inactive?
STEP 2. | Check the fuel metering valve and circuit. |
 | STEP 2A. Inspect the fuel metering valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 5863 active and Fault Code 5862 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 5862 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an inactive fault code. | Fault Code 5862 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5862 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel metering valve and circuit.

Guided Step 2A - Inspect the fuel metering valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5863 active and Fault Code 5862 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel metering valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5862 active?
YES NO

A damaged fuel metering valve has been detected.

Repair or replace the fuel metering valve. Refer to Procedure 005-242 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the OEM connector and ECM pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or the OEM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5862 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the fuel metering valve position SIGNAL wire.

Repair or replace the damaged section of engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 29-Mar-2016


FAULT CODE 5863 - Engine Diesel Fuel Metering Valve Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 5863 inactive?
STEP 2. | Check the engine fuel valve and circuit. |
 | STEP 2A. Inspect the engine fuel valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 5862 active and Fault Code 5863 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 5863 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and original equipment manufacturer (OEM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 5863 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5863 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine fuel valve and circuit.

Guided Step 2A - Inspect the engine fuel valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel valve from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel valve from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the engine fuel valve SUPPLY pin and the engine fuel valve position SIGNAL pin at the engine fuel valve connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5862 active and Fault Code 5863 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine fule valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5863 active?
YES NO

A damaged fuel metering valve has been detected.

Repair or replace the engine fuel valve. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the OEM connector and ECM pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or the OEM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the engine fuel valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine fuel valve position SIGNAL pin at the ECM connector and the engine fuel valve position SIGNAL pin at the engine fuel valve connector of the engine harness.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the damaged section of engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the engine fuel valve from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine fuel valve position SIGNAL pin in the ECM OEM harness connector and all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the damaged section of engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the engine fuel valve from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine fuel valve position SIGNAL pin in the engine fuel valve connector and engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the engine harness.

Repair or replace the damaged section of engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5863 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the fuel metering valve position SIGNAL wire.

Repair or replace the damaged section of engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 29-Mar-2016


FAULT CODE 5875 - Other ECUs Have Reported Diagnostic Trouble Codes Affecting Operation - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 5875 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 5875 active?
YES NO

This is an information only fault code that will only become active if other fault codes are active in the secondary module(s).

Troubleshoot all other active fault codes.

This fault code will become inactive when all other active red lamp fault codes in the secondary module(s) are resolved.

 No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 19-May-2016


FAULT CODE 5876 - Other ECUs Have Reported Diagnostic Trouble Codes Affecting Operation - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 5876 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 5876 active?
YES NO

This is an information only fault code that will only become active if other fault codes are active in the secondary module(s).

Troubleshoot all other active fault codes.

This fault code will become inactive when all other active amber lamp fault codes in the secondary module(s) are resolved.

 No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 19-May-2016


FAULT CODE 5877 - Other ECUs Have Reported Diagnostic Trouble Codes Affecting Operation - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 5877 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 5877 active?
YES NO

This is an information only fault code that will only become active if other fault codes are active in the secondary module(s).

Troubleshoot all other active fault codes.

This fault code will become inactive when all other active maintenance lamp fault codes in the secondary module(s) are resolved.

 No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 19-May-2016


FAULT CODE 5887 - Aftertreament 1 SCR System Hydrocarbon - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Selective Catalytic Reduction (SCR) System Cleaning | Refer to Procedure 011-109 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibilty of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check INSITE™ electronic service tool software revision level. | INSITE™ electronic service tool version 8.1.1 or higher?
 | STEP 1B. Check for active aftertreatment 1 SCR intake temperature sensor fault codes. | Fault Code 3142, 3143, 3144, 3164, 3229, 3231, 4152, 4164, 4165, 4166, or 4261 active?
 | STEP 1C. Read the fault codes. | Fault Code 5887 active?
 | STEP 1D. Perform aftertreatment SCR system cleaning. | Aftertreatment SCR system cleaning complete?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check INSITE™ electronic service tool software revision level.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Troubleshooting this fault code requires INSITE™ electronic service tool version 8.1.1 or higher.

Check INSITE™ electronic service tool software revision level.

  • Select "Help".
  • Select "About INSITE™ Electronic Service Tool".
  • Verify the INSITE™ electronic service tool version is 8.1.1 or higher

INSITE™ electronic service tool version 8.1.1 or higher?
YES NO
No Repair

Update INSITE™ electronic service tool to version 8.1.1 or higher.

Go to 1B

1B

Guided Step 1B - Check for active aftertreatment 1 SCR intake temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142, 3143, 3144, 3164, 3229, 3231, 4152, 4164, 4165, 4166, or 4261 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5887 active?
YES NO

This fault code indicates that an aftertreatment SCR system cleaning has been unable to be completed. An aftertreatment SCR system cleaning should be automatically initiated by the original equipment manufacturer (OEM) equipment when requested by the ECM. Troubleshoot OEM hardware to determine cause of auto-load functionality issue.

No Repair

Go to 1D

Go to 2A

Guided Step 1D - Perform aftertreatment SCR system cleaning.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform aftertreatment SCR system cleaning.

Refer to Procedure 011-109 in the Associated Procedures Table.

  • With Fault Code 5887 active, operation time will be limited to 1 hour. If aftertreatment SCR system cleaning is not completed within 1 hour, restart engine and load engine again to complete.

Aftertreatment SCR system cleaning complete?
YES NO
No Repair

See equipment manufacturer service information if loading could not be initiated.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 25-Feb-2019


FAULT CODE 5888 - Aftertreatment 1 SCR System Hydrocarbon - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Selective Catalytic Reduction (SCR) System Cleaning | Refer to Procedure 011-109 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibilty of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check INSITE™ electronic service tool software revision level. | INSITE™ electronic service tool version 8.1.1 or higher?
 | STEP 1B. Check for active aftertreatment 1 SCR intake temperature sensor fault codes. | Fault Code 3142, 3143, 3144, 3164, 3229, 3231, 4152, 4164, 4165, 4166, or 4261 active?
 | STEP 1C. Read the fault codes. | Fault Code 5888 active?
 | STEP 1D. Perform aftertreatment SCR system cleaning. | Aftertreatment SCR system cleaning complete?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check INSITE™ electronic service tool software revision level.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Troubleshooting this fault code requires INSITE™ electronic service tool version 8.1.1 or higher.

Check INSITE™ electronic service tool software revision level.

  • Select "Help".
  • Select "About INSITE™ Electronic Service Tool".
  • Verify the INSITE™ electronic service tool version is 8.1.1 or higher

INSITE™ electronic service tool version 8.1.1 or higher?
YES NO
No Repair

Update INSITE™ electronic service tool to version 8.1.1 or higher.

Go to 1B

1B

Guided Step 1B - Check for active aftertreatment 1 SCR intake temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142, 3143, 3144, 3164, 3229, 3231, 4152, 4164, 4165, 4166, or 4261 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5888 active?
YES NO

This fault code indicates that an aftertreatment SCR system cleaning has been unable to be completed. An aftertreatment SCR system cleaning should be automatically initiated by the original equipment manufacturer (OEM) equipment when requested by the ECM. Troubleshoot OEM hardware to determine cause of auto-load functionality issue.

No Repair

Go to 1D

Go to 2A

Guided Step 1D - Perform aftertreatment SCR system cleaning.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform aftertreatment SCR system cleaning.

Refer to Procedure 011-109 in the Associated Procedures Table.

  • With Fault Code 5888 active, operation time will be limited to 1 hour. If aftertreatment SCR system cleaning is not completed within 1 hour, restart engine and load engine again to complete.

Aftertreatment SCR system cleaning complete?
YES NO
No Repair

See equipment manufacturer service information if loading could not be initiated.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 19-Feb-2018


FAULT CODE 5889 - Aftertreatment 1 SCR System Hydrocarbon - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Selective Catalytic Reduction (SCR) System Cleaning | Refer to Procedure 011-109 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibilty of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check INSITE™ electronic service tool software revision level. | INSITE™ electronic service tool version 8.1.1 or higher?
 | STEP 1B. Check for active aftertreatment 1 SCR intake temperature sensor fault codes. | Fault Code 3142, 3143, 3144, 3164, 3229, 3231, 4152, 4164, 4165, 4166, or 4261 active?
 | STEP 1C. Read the fault codes. | Fault Code 5889 active?
 | STEP 1D. Perform aftertreatment SCR system cleaning. | Aftertreatment SCR system cleaning complete?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check INSITE™ electronic service tool software revision level.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Troubleshooting this fault code requires INSITE™ electronic service tool version 8.1.1 or higher.

Check INSITE™ electronic service tool software revision level.

  • Select "Help".
  • Select "About INSITE™ Electronic Service Tool".
  • Verify the INSITE™ electronic service tool version is 8.1.1 or higher

INSITE™ electronic service tool version 8.1.1 or higher?
YES NO
No Repair

Update INSITE™ electronic service tool to version 8.1.1 or higher.

Go to 1B

1B

Guided Step 1B - Check for active aftertreatment 1 SCR intake temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142, 3143, 3144, 3164, 3229, 3231, 4152, 4164, 4165, 4166, or 4261 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5889 active?
YES NO

This fault code indicates that an aftertreatment SCR system cleaning has been unable to be completed. An aftertreatment SCR system cleaning should be automatically initiated by the original equipment manufacturer (OEM) equipment when requested by the ECM. Troubleshoot OEM hardware to determine cause of auto-load functionality issue.

No Repair

Go to 1D

Go to 2A

Guided Step 1D - Perform aftertreatment SCR system cleaning.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform aftertreatment SCR system cleaning.

Refer to Procedure 011-109 in the Associated Procedures Table.

  • With Fault Code 5889 active, operation time will be limited to 1 hour. If aftertreatment SCR system cleaning is not completed within 1 hour, restart engine and load engine again to complete.

Aftertreatment SCR system cleaning complete?
YES NO
No Repair

See equipment manufacturer service information if loading could not be initiated.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 15-Feb-2018


FAULT CODE 5891 - Aftertreatment 2 SCR System Hydrocarbon - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Selective Catalytic Reduction (SCR) System Cleaning | Refer to Procedure 011-109 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibilty of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check INSITE™ electronic service tool software revision level. | INSITE™ electronic service tool version 8.1.1 or higher?
 | STEP 1B. Check for active aftertreatment 1 SCR intake temperature sensor fault codes. | Fault Code 5725, 5726, 5727, 5728, 5729, 5731, 3998, 3999, 4111, 4112, 4113, or 4114 active?
 | STEP 1C. Read the fault codes. | Fault Code 5891 active?
 | STEP 1D. Perform aftertreatment SCR system cleaning. | Aftertreatment SCR system cleaning complete?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check INSITE™ electronic service tool software revision level.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Troubleshooting this fault code requires INSITE™ electronic service tool version 8.1.1 or higher.

Check INSITE™ electronic service tool software revision level.

  • Select "Help".
  • Select "About INSITE™ Electronic Service Tool".
  • Verify the INSITE™ electronic service tool version is 8.1.1 or higher.

INSITE™ electronic service tool version 8.1.1 or higher?
YES NO
No Repair

Update INSITE™ electronic service tool to version 8.1.1 or higher.

Go to 1B

1B

Guided Step 1B - Check for active aftertreatment 1 SCR intake temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5725, 5726, 5727, 5728, 5729, 5731, 3998, 3999, 4111, 4112, 4113, or 4114 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5891 active?
YES NO

This fault code indicates that an aftertreatment SCR system cleaning has been unable to be completed. An aftertreatment SCR system cleaning should be automatically initiated by the original equipment manufacturer (OEM) equipment when requested by the ECM. Troubleshoot OEM hardware to determine cause of auto-load functionality issue.

No Repair

Go to 1D

Go to 2A

Guided Step 1D - Perform aftertreatment SCR system cleaning.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform aftertreatment SCR system cleaning.

Refer to Procedure 011-109 in the Associated Procedures Table.

  • With Fault Code 5891 active, operation time will be limited to 1 hour. If aftertreatment SCR system cleaning is not completed within 1 hour, restart engine and load engine again to complete.

Aftertreatment SCR system cleaning complete?
YES NO
No Repair

See equipment manufacturer service information if loading could not be initiated.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 27-Feb-2019


FAULT CODE 5892 - Aftertreatment 2 SCR System Hydrocarbon - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Selective Catalytic Reduction (SCR) System Cleaning | Refer to Procedure 011-109 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibilty of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check INSITE™ electronic service tool software revision level. | INSITE™ electronic service tool version 8.1.1 or higher?
 | STEP 1B. Check for active aftertreatment 1 SCR intake temperature sensor fault codes. | Fault Code 5725, 5726, 5727, 5728, 5729, 5731, 3998, 3999, 4111, 4112, 4113, or 4114 active?
 | STEP 1C. Read the fault codes. | Fault Code 5892 active?
 | STEP 1D. Perform aftertreatment SCR system cleaning. | Aftertreatment SCR system cleaning complete?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check INSITE™ electronic service tool software revision level.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Troubleshooting this fault code requires INSITE™ electronic service tool version 8.1.1 or higher.

Check INSITE™ electronic service tool software revision level.

  • Select "Help".
  • Select "About INSITE™ Electronic Service Tool".
  • Verify the INSITE™ electronic service tool version is 8.1.1 or higher

INSITE™ electronic service tool version 8.1.1 or higher?
YES NO
No Repair

Update INSITE™ electronic service tool to version 8.1.1 or higher.

Go to 1B

1B

Guided Step 1B - Check for active aftertreatment 1 SCR intake temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5725, 5726, 5727, 5728, 5729, 5731, 3998, 3999, 4111, 4112, 4113, or 4114 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5892 active?
YES NO

This fault code indicates that an aftertreatment SCR system cleaning has been unable to be completed. An aftertreatment SCR system cleaning should be automatically initiated by the original equipment manufacturer (OEM) equipment when requested by the ECM. Troubleshoot OEM hardware to determine cause of auto-load functionality issue.

No Repair

Go to 1D

Go to 2A

Guided Step 1D - Perform aftertreatment SCR system cleaning.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform aftertreatment SCR system cleaning.

Refer to Procedure 011-109 in the Associated Procedures Table.

  • With Fault Code 5889 active, operation time will be limited to 1 hour. If aftertreatment SCR system cleaning is not completed within 1 hour, restart engine and load engine again to complete.

Aftertreatment SCR system cleaning complete?
YES NO
No Repair

See equipment manufacturer service information if loading could not be initiated.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 27-Feb-2019


FAULT CODE 5893 - Aftertreatment 2 SCR System Hydrocarbon - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Selective Catalytic Reduction (SCR) System Cleaning | Refer to Procedure 011-109 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibilty of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check INSITE™ electronic service tool software revision level. | INSITE™ electronic service tool version 8.1.1 or higher?
 | STEP 1B. Check for active aftertreatment 1 SCR intake temperature sensor fault codes. | Fault Code 5725, 5726, 5727, 5728, 5729, 5731, 3998, 3999, 4111, 4112, 4113, or 4114 active?
 | STEP 1C. Read the fault codes. | Fault Code 5893 active?
 | STEP 1D. Perform aftertreatment SCR system cleaning. | Aftertreatment SCR system cleaning complete?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check INSITE™ electronic service tool software revision level.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Troubleshooting this fault code requires INSITE™ electronic service tool version 8.1.1 or higher.

Check INSITE™ electronic service tool software revision level.

  • Select "Help".
  • Select "About INSITE™ Electronic Service Tool".
  • Verify the INSITE™ electronic service tool version is 8.1.1 or higher

INSITE™ electronic service tool version 8.1.1 or higher?
YES NO
No Repair

Update INSITE™ electronic service tool to version 8.1.1 or higher.

Go to 1B

1B

Guided Step 1B - Check for active aftertreatment 1 SCR intake temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5725, 5726, 5727, 5728, 5729, 5731, 3998, 3999, 4111, 4112, 4113, or 4114 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5893 active?
YES NO

This fault code indicates that an aftertreatment SCR system cleaning has been unable to be completed. An aftertreatment SCR system cleaning should be automatically initiated by the original equipment manufacturer (OEM) equipment when requested by the ECM. Troubleshoot OEM hardware to determine cause of auto-load functionality issue.

No Repair

Go to 1D

Go to 2A

Guided Step 1D - Perform aftertreatment SCR system cleaning.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform aftertreatment SCR system cleaning.

Refer to Procedure 011-109 in the Associated Procedures Table.

  • With Fault Code 5893 active, operation time will be limited to 1 hour. If aftertreatment SCR system cleaning is not completed within 1 hour, restart engine and load engine again to complete.

Aftertreatment SCR system cleaning complete?
YES NO
No Repair

See equipment manufacturer service information if loading could not be initiated.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 27-Feb-2019


FAULT CODE 5949 - SAE J1939 Data Link 2 Engine Network - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an active fault code. | Fault Code 5949 active?
 | STEP 1B. Check for related J1939 Network 2 fault codes. | Fault Code 3329 active?
STEP 2. | Check the secondary engine control module (ECM) supply voltage circuits. |
 | STEP 2A. Inspect the ECM and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for correct ECM supply voltage. | Between 21 and 27 volts of direct current (VDC)?
 | STEP 2C. Check the keyswitch signal circuit. | Less than 5 ohms?
STEP 3. | Check the Society of Automotive Engineers (SAE) J1939 data link 2 circuit. |
 | STEP 3A. Inspect the engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the SAE J1939 data link 2 resistance in the engine harness. | Between 50 and 70 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5949 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for related J1939 Network 2 fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3329 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the secondary ECM supply voltage circuits.

Guided Step 2A - Inspect the ECM and OEM harness connector pins.

Conditions

Perform this check on ECM 2, 3, and 4.

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for correct ECM supply voltage.

Conditions

Perform this check of ECM 2, 3, and 4.

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Check for correct ECM supply voltage.

  • Measure the voltage between the ECM power supply voltage SUPPLY pins and the ECM power supply voltage RETURN pins in the OEM ECM connector.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 21 and 27 VDC?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Repair or replace the damaged section of the harness.

  • Use the following procedure for engine harness repair. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the keyswitch signal circuit.

Conditions

Perform this check on ECM 2, 3, and 4.

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the 16 pin power connector.

Action

Check for an open keyswitch signal circuit.

  • Measure the resistance of the keyswitch SIGNAL wire between the 16 pin power connector and the OEM connector at the ECM.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Repair or replace the damaged section of the engine harness.

  • Use the following procedure for engine harness repair. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the SAE J1939 data link 2 circuit.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

Perform this check on each ECM.

  • Turn keyswitch OFF.
  • Disconnect the engine connector from the ECM.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only when there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the SAE J1939 data link 2 resistance in the engine harness.

Conditions

Perform this check on each ECM.

  • Turn keyswitch OFF.
  • Disconnect the engine connector from the ECM.

Action

Check the SAE J1939 data link 2 engine network resistance.

  • Measure the resistance between the SAE J1939 data link 2 SUPPLY pin and the SAE J1939 data link 2 RETURN pin in the ECM engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 50 and 70 ohms?
YES NO

The SAE J1939 data link 2 resistance is within specification.

There is a problem in the calibration.

Check to make sure the appropriate calibrations are installed in the ECMs.

An open or shorted SAE J1939 data link 2 circuit has been detected in the engine harness.

Check the terminating resistors and their connectors.

Troubleshoot each harness connected in series to determine which one contains the open or short circuit.

Repair or replace the damaged section of engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

No Repair

Go to 1A

Repair complete.

Last Modified: 29-Mar-2016


FAULT CODE 6253 (Source Address 00) - Control Module Identification Input State Error - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6253 active?
STEP 2. | Check for the correct calibration. |
 | STEP 2A. Check for the correct calibration on the ECM. | Calibration correspond with the ECM source address and location of the ECM in the harness?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6253 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check for the correct calibration.

Guided Step 2A - Check for the correct calibration on the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct calibration.

  • Use INSITE™ electronic service tool to check the calibration installed on the ECM.

Calibration correspond with the ECM source address and location of the ECM in the harness?
YES NO
No Repair

The ECM has the wrong calibration or the ECM has been installed in the wrong location.

Download the correct calibration to the ECM or install the ECM in the correct location.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the original equipment manufacturer (OEM) harness connector from the ECM.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit on the connected harness keying pins.

  • Measure the resistance between the control module identification SIGNAL 1 pin and the control module identification RETURN pin in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the control module identification circuit in the harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM harness ECM connector control module identification SIGNAL 1 pin and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

A pin-to-pin short circuit has been detected in the control module identification circuit in the harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 29-Mar-2016


FAULT CODE 6253 (Source Address 01) - Control Module Identification Input State Error - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an active fault code. | Fault Code 6253 active?
STEP 2. | Check for the correct calibration. |
 | STEP 2A. Check for the correct calibration on the ECM. | Calibration correspond with the ECM source address and location of the ECM in the harness?
STEP 3. | Check the harness |
 | STEP 3A. Inspect the harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6253 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check for the correct calibration

Guided Step 2A - Check for the correct calibration on the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct calibration.

  • Use INSITE™ electronic service tool to check the calibration installed on the ECM.

Calibration correspond with the ECM source address and location of the ECM in the harness?
YES NO
No Repair

The ECM has the wrong calibration or the ECM has been installed in the wrong location.

Download the correct calibration to the ECM or install the ECM in the correct location.

Go to 3A

Go to 4A

Guided Step 3 - Check the harness

Guided Step 3A - Inspect the harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the original equipment manufacturer (OEM) harness connector from the ECM.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit on the connected harness keying pins.

  • Measure the resistance between the control module identification SIGNAL 2 pin and the control module identification RETURN pin in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the control module identification circuit in the harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM harness ECM connector control module identification SIGNAL 2 pin and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

A pin-to-pin short circuit has been detected in the control module identification circuit in the harness.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 01-Sep-2015


FAULT CODE 6253 (sa144) - Control Module Identification Input State Error - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an active fault code. | Fault Code 6253 active?
STEP 2. | Check for the correct calibration |
 | STEP 2A. Check for the correct calibration on the ECM. | Calibration correspond with the ECM source address and location of the ECM in the harness?
STEP 3. | Check the engine harness |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes |
 | STEP 4A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6253 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check for the correct calibration

Guided Step 2A - Check for the correct calibration on the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct calibration.

  • Use INSITE™ electronic service tool to check the calibration installed on the ECM.

Calibration correspond with the ECM source address and location of the ECM in the harness?
YES NO
No Repair

The ECM has the wrong calibration or the ECM has been installed in the wrong location.

Download the correct calibration to the ECM or install the ECM in the correct location.

Go to 3A

Go to 4A

Guided Step 3 - Check the harness.

Guided Step 3A - Inspect the harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the original equipment manufacturer (OEM) harness connector from the ECM.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit on the connected harness keying pins.

  • Measure the resistance between the control module identification SIGNAL 3 pin and the control module identification RETURN pin in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the control module identification circuit in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM harness ECM connector control module identification SIGNAL 3 pin and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

A pin-to-pin short circuit has been detected in the control module identification circuit in the harness.

Replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 19-May-2016


FAULT CODE 6253 (Source Address 186) - Control Module Identification Input State Error - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6253 active?
STEP 2. | Check for the correct calibration. |
 | STEP 2A. Check for the correct calibration on the ECM. | Calibration correspond with the ECM source address and location of the ECM in the harness?
STEP 3. | Check the harness. |
 | STEP 3A. Inspect the harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6253 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check for the correct calibration.

Guided Step 2A - Check for the correct calibration on the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct calibration.

  • Use INSITE™ electronic service tool to check the calibration installed on the ECM.

Calibration correspond with the ECM source address and location of the ECM in the harness?
YES NO
No Repair

The ECM has the wrong calibration or the ECM has been installed in the wrong location.

Download the correct calibration to the ECM or install the ECM in the correct location.

Go to 3A

Go to 4A

Guided Step 3 - Check the harness.

Guided Step 3A - Inspect the harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the original equipment manufacturer (OEM) harness connector from the ECM.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit on the connected harness keying pins.

  • Measure the resistance between the control module identification SIGNAL 1 pin and the control module identification RETURN pin in the OEM harness ECM connector.
  • Measure the resistance between the control module identification SIGNAL 2 pin and the control module identification RETURN pin in the OEM harness ECM connector.
  • Measure the resistance between the control module identification SIGNAL 3 pin and the control module identification RETURN pin in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the control module identification circuit in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM harness ECM connector control module identification SIGNAL 1 pin and all other pins in the connector (except for the other ID SIGNAL pins).
  • Measure the resistance between the OEM harness ECM connector control module identification SIGNAL 2 pin and all other pins in the connector (except for the other ID SIGNAL pins).
  • Measure the resistance between the OEM harness ECM connector control module identification SIGNAL 3 pin and all other pins in the connector (except for the other ID SIGNAL pins).

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

A pin-to-pin short circuit has been detected in the control module identification circuit in the harness.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Reapir complete.

Last Modified: 01-Sep-2015


FAULT CODE 6369 - Aftertreatment 2 Outlet NOx Sensor - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3988, 3989, or 3995 active?
 | STEP 1B. Check for active fault codes. | Fault Code 6369 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3988, 3989, or 3995 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6369 active?
YES NO

An internal error has been detected in the aftertreatment outlet nitrogen oxides (NOx) sensor.

Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 29-Mar-2016


FAULT CODE 6373 - Aftertreatment 2 Diesel Exhaust Fluid Doser Heating Mode Request - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 6373 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

  • Check for other active aftertreatment diesel exhaust fluid (DEF) related fault codes.

Fault Code 6373 active?
YES NO

This is an information only fault code that will only become active if other aftertreatment DEF system related fault codes are active or if the DEF system is currently in thawing mode.

Troubleshoot all other active DEF system related fault codes.

This fault code will become inactive when the system has successfully primed.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 29-Mar-2016


FAULT CODE 6378 - Aftertreatment 2 Diesel Exhaust Fluid Pressure 1 Sensor Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for aftertreatment 2 diesel exhaust fluid (DEF) dosing valve 1 fault codes. | Fault Code 6378 active?
STEP 2. | Check the aftertreatment 2 DEF dosing valve 1 and circuit. |
 | STEP 2A. Inspect the original equipment manufacturer (OEM) aftertreatment 2 harness and aftertreatment 2 DEF dosing valve 1 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the OEM harness aftertreatment 2 DEF dosing valve 1 return circuit. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the OEM aftertreatment 2 harness. | Greater than 100k ohms?
 | STEP 2D. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 2E. Check the aftertreatment 2 engine harness DEF dosing valve 1 return circuit. | Less than 10 ohms?
 | STEP 2F. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for aftertreatment 2 DEF dosing valve 1 fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6378 active?
YES NO
No Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the aftertreatment 2 DEF dosing valve 1 and circuit.

Guided Step 2A - Inspect the OEM aftertreatment 2 harness and aftertreatment 2 DEF dosing valve 1 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 2 DEF dosing valve 1 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Inspect the OEM harness, aftertreatment 2 connector, and DEF dosing valve 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the valve or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the OEM harness aftertreatment 2 DEF dosing valve 1 return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 1 from the OEM harness.

Action

Check the dosing valve sensor return circuit.

  • Measure the resistance from the OEM harness aftertreatment 2 DEF dosing valve 1 connector sensor RETURN pin to the OEM harness aftertreatment 2 connector DEF dosing valve 1 sensor RETURN pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the OEM aftertreatment 2 harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.
  • Disconnect the aftertreatment 2 DEF dosing valve 1 from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing valve 1 sensor RETURN pin in the OEM harness aftertreatment 2 connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness.

Troubleshoot all harness connections in series to determine which one contains the open circuit. Refer to Procedure 019-598 in the Associated Procedures Table, if equipped.

If an open circuit is isolated to a damaged harness, repair or replace the damaged section of harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2E

Guided Step 2E - Check the aftertreatment 2 engine harness DEF dosing valve 1 return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness from the engine harness aftertreatment 2 connector.

Action

Check the dosing valve sensor return circuit.

  • Measure the resistance from the engine harness aftertreatment 2 connector sensor RETURN pin to the ECM connector aftertreatment 2 DEF dosing valve 2 sensor RETURN pin.

Use to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2F

Go to 3A

Guided Step 2F - Check for pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing valve 1 sensor RETURN pin in the OEM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the aftertreatment 2 DEF dosing valve 2. Refer to Procedure 011-059 in the Associated Procedures Table.

A pin-to-pin short circuit has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 29-Mar-2016


FAULT CODE 6379 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 2 - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6379 active?
STEP 2. | Check the aftertreatment 1 diesel exhaust fluid (DEF) dosing valve 2. |
 | STEP 2A. Check for a stuck closed aftertreatment 1 DEF dosing valve 2. | Dosing valve meets the specification outline in Procedure 011-063?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6379 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the aftertreatment 1 DEF dosing valve 2.

Guided Step 2A - Check for a stuck closed aftertreatment 1 DEF dosing valve 2.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment 1 DEF dosing valve 2. Refer to Procedure 011-059 in the Associated Procedures Table.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a stuck closed or low flowing aftertreatment 1 DEF dosing valve 2.

  • Perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test. Refer to Procedure 011-063 in the Associated Procedures Table.

Dosing valve meets the specification outline in Procedure 011-063?
YES NO
No Repair

A damaged aftertreatment DEF dosing valve has been detected.

Inspect and clean the aftertreatment DEF dosing valve.

  • Refer to Procedure 011-059 in the Associated Procedures Table.

After cleaning, perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test again. If the dosing valve does not meet the specifications outlined in Procedure 011-063, replace the aftertreatment DEF dosing valve.

  • Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Codes" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 29-Mar-2016


FAULT CODE 6381 - Aftertreatment 2 Diesel Exhaust Fluid Dosing Valve 2 - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6381 active?
STEP 2. | Check the aftertreatment 2 diesel exhaust fluid (DEF) dosing valve 2. |
 | STEP 2A. Check for a stuck closed aftertreatment 2 DEF dosing valve 2. | Dosing valve meets the specification outline in Procedure 011-063?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6381 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the aftertreatment 2 DEF dosing valve 2.

Guided Step 2A - Check for a stuck closed aftertreatment 2 DEF dosing valve 2.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment 2 DEF dosing valve 2. Refer to Procedure 011-059 in the Associated Procedures Table.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a stuck closed or low flowing aftertreatment 2 DEF dosing valve 2.

  • Perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test. Refer to Procedure 011-063 in the Associated Procedures Table.

Dosing valve meets the specification outline in Procedure 011-063?
YES NO
No Repair

A damaged aftertreatment DEF dosing valve has been detected.

Inspect and clean the aftertreatment DEF dosing valve.

  • Refer to Procedure 011-059 in the Associated Procedures Table.

After cleaning, perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test again. If the dosing valve does not meet the specifications outlined in Procedure 011-063, replace the aftertreatment DEF dosing valve.

  • Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Codes" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 29-Mar-2016


FAULT CODE 6382 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 3 - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6382 active?
STEP 2. | Check the aftertreatment 1 diesel exhaust fluid (DEF) dosing valve 3. |
 | STEP 2A. Check for a stuck closed aftertreatment 1 DEF dosing valve 3. | Dosing valve meets the specification outline in Procedure 011-063?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6382 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the aftertreatment 1 DEF dosing valve 3.

Guided Step 2A - Check for a stuck closed aftertreatment 1 DEF dosing valve 3.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment 1 DEF dosing valve 3. Refer to Procedure 011-059 in the Associated Procedures Table.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a stuck closed or low flowing aftertreatment 1 DEF dosing valve 3.

  • Perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test. Refer to Procedure 011-063 in the Associated Procedures Table.

Dosing valve meets the specification outline in Procedure 011-063?
YES NO
No Repair

A damaged aftertreatment DEF dosing valve has been detected.

Inspect and clean the aftertreatment DEF dosing valve.

  • Refer to Procedure 011-059 in the Associated Procedures Table.

After cleaning, perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test again. If the dosing valve does not meet the specification outlined in Procedure 011-063, replace the aftertreatment DEF dosing valve.

  • Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Codes" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 29-Mar-2016


FAULT CODE 6383 - Aftertreatment 2 Diesel Exhaust Fluid Dosing Valve 3 - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6383 active?
STEP 2. | Check the aftertreatment 2 diesel exhaust fluid (DEF) dosing valve 3. |
 | STEP 2A. Check for a stuck closed aftertreatment 2 DEF dosing valve 3. | Dosing valve meets the specification outline in Procedure 011-063?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6383 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the aftertreatment 2 DEF dosing valve 3.

Guided Step 2A - Check for a stuck closed aftertreatment 2 DEF dosing valve 3.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment 2 DEF dosing valve 3. Refer to Procedure 011-059 in the Associated Procedures Table.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a stuck closed or low flowing aftertreatment 2 DEF dosing valve 3.

  • Perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test. Refer to Procedure 011-063 in the Associated Procedures Table.

Dosing valve meets the specification outline in Procedure 011-063?
YES NO
No Repair

A damaged aftertreatment DEF dosing valve has been detected.

Inspect and clean the aftertreatment DEF dosing valve.

  • Refer to Procedure 011-059 in the Associated Procedures Table.

After cleaning, perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test again. If the dosing valve does not meet the specification outlined in Procedure 011-063, replace the aftertreatment DEF dosing valve.

  • Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Codes" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 29-Mar-2016


FAULT CODE 6385 - Aftertreatment 1 Diesel Exhaust Fluid Doser 3 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid System Leak Test | Refer to Procedure 011-080 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active diesel exhaust fluid (DEF) dosing system fault codes. | Fault Code 6385 active?
STEP 2. | Check the DEF dosing system. |
 | STEP 2A. Inspect the aftertreatment 1 DEF dosing valve 3 and connectors. | Damage to the DEF dosing valve or DEF line connectors detected?
 | STEP 2B. Inspect the aftertreatment 1 DEF dosing valve 3 for leaks. | DEF leaking from the aftertreatment 1 DEF dosing valve 3 during the system leak test?
 | STEP 2C. Check the aftertreatment 1 DEF dosing valve 3 for proper operation. | Aftertreatment 1 DEF dosing valve 3 operates according to the specifications in Procedure 011-063?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active DEF dosing system fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6385 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the DEF dosing system.

Guided Step 2A - Inspect the aftertreatment 1 DEF dosing valve 3 and connectors.

Conditions

  • Turn keyswitch ON.

Action

Check the aftertreatment 1 DEF dosing valve 3, DEF line, and connectors at the dosing valve for the following:

  • Loose or leaking connections
  • Damage from overheating or melted connectors.

Damage to the DEF dosing valve or DEF line connector detected?
YES NO

Replace any damaged components.

  • Replace the aftertreatment 1 DEF dosing valve 3. Refer to Procedure 011-059 in the Associated Procedures Table.
  • Replace the aftertreatment DEF line(s). See equipment manufacturer service information.

 No Repair

Go to 2B

Go to 2B

Guided Step 2B - Inspect the aftertreatment 1 DEF dosing valve 3 for leaks.

Conditions

  • Connect all DEF lines and electrical connectors.
  • Remove the aftertreatment 1 DEF dosing valve 3 from the decomposition reactor tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the aftertreatment 1 DEF dosing valve 3 for proper operation.

  • Use INSITE™ electronic service tool to perform the DEF System Leak Test found under ECM Diagnostic Tests. Refer to Procedure 011-080 in the Associated Procedures Table.

The DEF dosing valve must be removed and placed in a measuring container in order to leak check the DEF valve.

DEF leaking from the aftertreatment 1 DEF dosing valve 3 during the system leak test?
YES NO

A leaking aftertreatment 1 DEF dosing valve 3 has been detected. Replace the aftertreatment 1 DEF dosing valve 3. Refer to Procedure 011-059 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the aftertreatment 1 DEF dosing valve 3 for proper operation.

Conditions

  • Make sure all DEF lines and electrical connectors are connected appropriately.
  • Remove the aftertreatment 1 DEF dosing valve 3 from the decomposition reactor tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the DEF Doser Pump Override Test found under ECM Diagnostic Tests.

  • Refer to Procedure 011-063 in the Associated Procedures Table.

The DEF dosing valve must be removed and placed in a measuring container in order to perform the DEF Doser Pump Override Test. Make sure the DEF dosing valve is not plugged and the DEF spray pattern is correct.

Aftertreatment 1 DEF dosing valve 3 operates according to the specifications in Procedure 011-063?
YES NO
No Repair

Replace the aftertreatment 1 DEF dosing valve 3.

Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 29-Mar-2016


FAULT CODE 6387 - Aftertreatment 2 Diesel Exhaust Fluid Doser 3 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid System Leak Test | Refer to Procedure 011-080 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active diesel exhaust fluid (DEF) dosing system fault codes. | Fault Code 6386 active?
STEP 2. | Check the DEF dosing system. |
 | STEP 2A. Check the aftertreatment 2 DEF dosing valve 3 and connectors. | Damage to the DEF dosing valve or DEF line connectors detected?
 | STEP 2B. Inspect the aftertreatment 2 DEF dosing valve 3 for leaks. | DEF leaking from the aftertreatment 2 DEF dosing valve 3 during the system leak test?
 | STEP 2C. Check the aftertreatment 2 DEF dosing valve 3 for proper operation. | Aftertreatment 2 DEF dosing valve 3 operates according to the specifications in Procedure 011-063?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active DEF dosing system fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6386 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the DEF dosing system.

Guided Step 2A - Inspect the aftertreatment 2 DEF dosing valve 3 and connectors.

Conditions

  • Turn keyswitch ON.

Action

Check the aftertreatment 2 DEF dosing valve 3, DEF line, and connectors at the dosing valve for the following:

  • Loose or leaking connections
  • Damage from overheating or melted connectors.

Damage to the DEF dosing valve or DEF line connector detected?
YES NO

Replace any damaged components.

  • Replace the aftertreatment 2 DEF dosing valve 3. Refer to Procedure 011-059 in the Associated Procedures Table.
  • Replace the aftertreatment DEF line(s). See equipment manufacturer service information.

 No Repair

Go to 2B

Go to 2B

Guided Step 2B - Inspect the aftertreatment 2 DEF dosing valve 3 for leaks.

Conditions

  • Connect all DEF lines and electrical connectors.
  • Remove the aftertreatment 2 DEF dosing valve 3 from the decomposition reactor tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the aftertreatment DEF dosing valve for proper operation.

  • Use INSITE™ electronic service tool to perform the DEF System Leak Test found under ECM Diagnostic Tests. Refer to Procedure 011-080 in the Associated Procedures Table.

The DEF dosing valve must be removed and placed in a measuring container in order to leak check the DEF valve.

DEF leaking from the aftertreatment 2 DEF dosing valve 3 during the system leak test?
YES NO

A leaking aftertreatment 2 DEF dosing valve 3 has been detected. Replace the aftertreatment 2 DEF dosing valve 3. Refer to Procedure 011-059 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the aftertreatment 2 DEF dosing valve 3 for proper operation.

Conditions

  • Make sure all DEF lines and electrical connectors are connected appropriately.
  • Remove the aftertreatment 2 DEF dosing valve 3 from the decomposition chamber.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the DEF Doser Pump Override Test found under ECM Diagnostic Tests.

  • Refer to Procedure 011-063 in the Associated Procedures Table.

The DEF dosing valve must be removed and placed in a measuring container in order to perform the DEF Doser Pump Override Test. Make sure the DEF dosing valve is not plugged and the DEF spray pattern is correct.

Aftertreatment 2 DEF dosing valve 3 operates according to the specifications in Procedure 011-063?
YES NO
No Repair

Replace the aftertreatment 2 DEF dosing valve 3.

Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 29-Mar-2016


FAULT CODE 6517 - Aftertreatment SCR Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSK95 CM2350 K113 | 4388663
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSK95 CM2350 K113 | 4388663
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | QSK95 CM2350 K113 | 4388663
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK95 CM2350 K113 | 4388663
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6517 active or inactive with more than one count in the last 25 engine hours?
 | STEP 1B. Check for active aftertreatment fault codes. | Fault codes active or inactive with more than one count in the last 25 engine hours?
STEP 2. | Check the aftertreatment 1 and diesel exhaust fluid (DEF) dosing system. |
 | STEP 2A. Check the exhaust system for leaks. | Exhaust system leaks found?
 | STEP 2B. Check the DEF quality. | DEF free from contamination and within the specifications outlined in Procedure 011-056 table?
 | STEP 2C. Check for the correct aftertreatment 1 DEF dosing valve(s). | Each aftertreatment 1 DEF dosing valve correct for the engine configuration?
 | STEP 2D. Check for air in the aftertreatment 1 DEF. | Any air bubbles found in the aftertreatment 1 DEF dosing system?
 | STEP 2E. Check the aftertreatment 1 DEF dosing system operation. | Dosing volume within the specifications in Procedure 011-063 table and DEF spray pattern is correct for each of the three dosing systems?
 | STEP 2F. Check for deposits in the decomposition chamber. | DEF deposits found inside the decomposition chamber?
STEP 3. | Check aftertreatment NOx sensors. |
 | STEP 3A. Check the aftertreatment NOx sensor readings. | Aftertreatment NOx sensor readings within specifications found in Procedure 019-451 table?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an engine control module (ECM) calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6517 active or inactive with more than one count in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for active aftertreatment fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for active or inactive fault codes with two or more counts within the last 25 engine hours of the aftertreatment intake and outlet NOx sensors: 1885, 2771, 3228, 3232, 3649, 3682, 3717, 3718, 3725, 4452, 6458, 6459, 6462, 6521, 6565, 6581 or 6582.
  • Check for active or inactive fault codes with two or more counts within the last 25 engine hours for the aftertreatment SCR temperature sensors: 3142, 3148, 3165, 4164, 4165, 4166, 4518, 4519, 4521, 4524, 4525, 6266, 6267, 6268, 6517 or 6569.
  • Check for active or inactive fault codes with two or more counts within the last 25 engine hours for the aftertreatment DEF dosing unit system: 1668, 1669, 1673, 1682, 3497, 3498, 3558, 3559, 3571, 3572, 3574, 3575, 4677, 4732, 5278, 6562 or 7123.

Fault codes active or inactive with more than one count in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment 1 and DEF dosing system.

Guided Step 2A - Check the exhaust system for leaks.

Conditions

  • Turn keyswitch ON.
  • Start the engine.

Action

Check the exhaust for leaks.

  • Inspect the entire exhaust system between the turbocharger outlet and the SCR outlet. Inspect for loose connections, leaking connections, and broken exhaust system components.

Exhaust system leaks found?
YES NO

Repair or replace the damaged exhaust system component.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the DEF quality.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the DEF quality.

  • Inspect the DEF in the tank for signs of debris or contamination.
  • Use the Cummins® DEF Refractometer Service Tool, Part Number 4919554, to test the DEF concentration. Refer to Procedure 011-056 in the Associated Procedures Table.

DEF free from contamination and within the specifications outlined in Procedure 011-056 table?
YES NO
No Repair

The fluid in the DEF tank is not certified DEF, or the DEF is diluted or degraded.

Completely drain the DEF tank, and rinse the tank with water.

Fill the DEF tank with certified DEF.

Refer to Procedure 011-056 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for the correct aftertreatment 1 DEF dosing valve(s).

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment 1 DEF dosing valve(s).

  • Verify the aftertreatment 1 DEF dosing valves are correct for the engine configuration.

Each aftertreatment 1 DEF dosing valve correct for the engine configuration?
YES NO
No Repair

Replace only the DEF dosing valve that does not match the engine configuration. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 2D

Go to 4D

Guided Step 2D - Check for air in the aftertreatment 1 DEF.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for air in the aftertreatment 1 DEF.

  • Refer to Procedure 011-075 in the Associated Procedures Table.

Any air bubbles found in the aftertreatment 1 DEF dosing system?
YES NO

Visually inspect the dosing systems components. Repair according to procedure. Refer to Procedure 011-075 in the Associated Procedures Table.

 No Repair

Go to 2E

Go to 4A

Guided Step 2E - Check the aftertreatment 1 DEF dosing system operation..

Conditions

  • Remove each of the aftertreatment 1 DEF dosing valves from the decomposition chamber.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the aftertreatment 1 DEF dosing system operation.

  • Use the following procedure for instructions and specifications. Refer to Procedure 011-063 in the Associated Procedures Table.
  • Make sure each of the DEF dosing valves are not plugged and the spray pattern is correct.

Each DEF dosing valve must be removed and placed in a measuring container in order to perform the DEF Doser Pump Override Test.

Dosing volume within the specifications in Procedure 011-063 table and DEF spray pattern is correct for each of the three dosing systems?

YES NO
No Repair

Replace only the DEF dosing valve that was found to be out of specification. Refer to Procedure 011-059 in the Associated Procedures Table.

Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 2F

Go to 4A

Guided Step 2F - Check for deposits in the decomposition chamber.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Check for deposits in the decomposition chamber.

  • Remove inspection cover from SCR catalyst.
  • Inspect for DEF deposits.
  • Refer to Procedure 011-036 in the Associated Procedures Table.

DEF deposits found inside the decomposition chamber?
YES NO

Clean the decomposition chamber. Refer to Procedure 011-036 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check aftertreatment NOx sensors.

Guided Step 3A - Check aftertreatment NOx sensors.

Conditions

  • Turn keyswitch ON.

Action

Clean the DOC.

  • Perform the Aftertreatment NOx Sensor Rationality Test. Refer to Procedure 019-451 in the Associated Procedures Table.

Aftertreatment NOx sensor readings within specifications found in Procedure 019-451 table?
YES NO

Replace the aftertreatment SCR catalyst. Refer to Procedure 011-036 in the Associated Procedures Table.

Replace the aftertreatment intake and outlet NOx sensors.

  • For the intake NOx sensor use the following procedure. Refer to Procedure 019-463 in the Associated Procedures Table.
  • For the outlet NOx sensor use the following procedure. Refer to Procedure 019-451 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 04-Dec-2017


FAULT CODE 6573 - Engine Diesel Fuel Metering Valve Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fuel temperature or fuel metering valve fault codes. | Fault Code 261, 266, 4927, or 4933 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fuel temperature or fuel metering valve fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 261, 266, 4927, or 4933 active?
YES NO

The fuel metering valve internal temperature has exceeded the maximum limit. No repair is necessary. This fault code is for information only.

The fuel metering valve internal temperature has exceeded the maximum limit.

Replace the fuel metering valve. Refer to Procedure 005-242 in the Associated Procedures Table.

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 29-Mar-2016


FAULT CODE 6574 - Engine Diesel Fuel Metering Valve Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fuel temperature or fuel metering valve fault codes. | Fault Code 261, 266, 4927, or 4933 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fuel temperature or fuel metering valve fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 261, 266, 4927, or 4933 active?
YES NO

The fuel metering valve internal temperature has exceeded the maximum limit. No repair is necessary. This fault code is for information only.

The fuel metering valve internal temperature has exceeded the maximum limit.

Replace the fuel metering valve. Refer to Procedure 005-242 in the Associated Procedures Table.

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 29-Mar-2016


FAULT CODE 6594 - Engine Fuel Leakage - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | QSK95 CM2350 K113 | 4388663
Fuel Leak Indicator Tank | Refer to Procedure 006-095 | QSK95 CM2350 K113 | 4388663
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6594 active?
 | STEP 1B. Drain the fuel leak indicator tank. | Fuel present in tank?
 | STEP 1C. Check for an active fault code. | Fault Code 6594 active?
STEP 2. | Check the fuel leak indicator tank level sensor. |
 | STEP 2A. Inspect the harness and fuel leak indicator tank connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the fuel leak indicator tank. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
 | STEP 3E. Read the fault codes. | Fault Code 6594 active?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE electronic service tool to read the fault codes.

Fault Code 6594 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Drain the fuel leak indicator tank.

Conditions

  • Turn keyswitch OFF.

Action

Drain the fuel leak indicator tank.

  • Refer to Procedure 006-095 in the Associated Procedures Table.

Fuel present in tank?
YES NO

A fuel leak has been detected in the high-pressure fuel system. Perform the High-Pressure Fuel System Leak Test. Refer to Procedure 005-236 in the Associated Procedures Table.

 No Repair

Go to 1C

Go to 2A

Guided Step 1C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6594 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fuel leak indicator tank level sensor.

Guided Step 2A - Inspect the harness and fuel leak indicator tank connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the fuel leak indicator tank.

Action

Inspect the harness and tank connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness or fuel leak indicator tank, whichever has the damaged pins.

  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Use the following procedure for the fuel leak indicator tank. Refer to Procedure 006-095 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the fuel leak indicator tank.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the fuel leak indicator tank.

Action

Check for an open circuit.

  • Measure the resistance between the fuel leak indicator tank SIGNAL pin and the fuel leak indicator tank RETURN pin at the fuel leak indicator tank connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the fuel leak indicator tank. Refer to Procedure 006-095 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the fuel leak indicator tank.

Action

Check for a short circuit to ground.

  • Measure the resistance from each pin of the fuel leak indicator tank connector to the ECM power supply ground circuit.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the fuel leak indicator tank. Refer to Procedure 006-095 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the original equipment manufacturer (OEM) connector from the ECM.

Action

Inspect the harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Perform these check on all interconnecting harness connectors in the circuit.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only when there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel leak indicator tank RETURN pin in the engine harness connector to all others pins in the OEM ECM harness connector.
  • Measure the resistance from the fuel leak indicator tank SIGNAL pin in the engine harness connector to all other pins in the OEM ECM harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the engine harness connector from the fuel leak indicator tank.

Action

Check for a short circuit to ECM power supply ground circuit.

  • Measure the resistance from the fuel leak indicator tank SIGNAL pin in the fuel leak indicator tank engine harness connector to the ECM power supply ground circuit.
  • Measure the resistance from the fuel leak indicator tank RETURN pin in the fuel leak indicator tank engine harness connector to the ECM power supply ground circuit.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the engine harness connector from the fuel leak indicator tank.

Action

Check for an open circuit.

  • Measure the resistance from the fuel leak indicator tank SIGNAL pin in the fuel leak indicator tank engine harness connector to the fuel leak indicator tank SIGNAL pin in the OEM ECM harness connector.
  • Measure the resistance from the fuel leak indicator tank RETURN pin in the fuel leak indicator tank engine harness connector to the fuel leak indicator tank RETURN pin in the OEM ECM harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Read the fault codes.

Conditions

  • Connect all components.
  • Connector INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6594 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

No Repair

Go to 1A

Repair complete.

Last Modified: 29-Mar-2016


FAULT CODE 6595 - Engine Speed - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Unswitched Power Supply Circuit | Refer to Procedure 019-087 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 6595. | Active or inactive counts of Fault Code 6595?
 | STEP 1B. Check for supply voltage fault codes. | Active or inactive counts of Fault Code 441 or 442?
 | STEP 1C. Inspect crankshaft and camshaft position sensor connector pins | Dirty or damaged pins?
 | STEP 1D. Check the engine control module (ECM) power supply voltage. | ECM power supply voltage above 24 VDC?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Read the fault codes. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 6595.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 6595?
YES | NO
No Repair | No Repair

Go to 1B

Repair complete.

Guided Step 1B - Check for supply voltage fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 441 or 442?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1C

Guided Step 1C - Inspect crankshaft and camshaft position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft and camshaft position sensors.

Action

Inspect the connector(s) for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 1D

Guided Step 1D - Check the ECM power supply voltage.

Conditions

  • Turn keyswitch ON.

Action

Measure the ECM power supply voltage.

  • Refer to Procedure 019-087 in the Associated Procedures Table.

ECM power supply voltage above 24 VDC?
YES NO
No Repair

See equipment manufacturer service information.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process.

Repair complete.

Last Modified: 02-Jan-2017


FAULT CODE 6633 - Fuel Pump Priming Status - Special Instructions

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 6633 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6633 active?
YES NO

This is an information only fault code that will get cleared once the fuel supply pump is primed. The starter lockout will be active until the fuel supply pump is primed.

Troubleshoot all other active fault codes.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 23-Mar-2016


FAULT CODE 6692 - Aftertreatment 1 SCR System Soot - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Selective Catalytic Reduction (SCR) System Cleaning | Refer to Procedure 011-109. | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check INSITE™ electronic service tool software revision level. | INSITE™ electronic service tool version 8.1.1 or higher?
 | STEP 1B. Read the fault codes. | Fault Code 6692 active?
 | STEP 1C. Perform aftertreatment SCR system cleaning. | Aftertreatment SCR system cleaning complete?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check INSITE™ electronic service tool software revision level.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Troubleshooting this fault code requires INSITE™ electronic service tool version 8.1.1 or higher.

Check INSITE™ electronic service tool software revision level.

  • Select "Help".
  • Select "About INSITE™ Electronic Service Tool".
  • Verify the INSITE™ electronic service tool version is 8.1.1 or higher.

INSITE™ electronic service tool version 8.1.1 or higher?
YES NO
No Repair

Update INSITE™ electronic service tool to version 8.1.1 or higher.

Go to 1B

Go to 1B

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6692 active?
YES NO

This fault code indicates that an aftertreatment SCR system cleaning has been unable to be completed. An aftertreatment SCR system cleaning should be automatically initiated by the original equipment manufacturer (OEM) equipment when requested by the ECM. Troubleshoot OEM hardware to determine cause of auto-load functionality issue.

No Repair

Go to 1C

Go to 2A

Guided Step 1C - Perform aftertreatment SCR system cleaning.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform aftertreatment SCR system cleaning.

Refer to Procedure 011-109 in the Associated Procedures Table.

  • With Fault Code 6692 active, operation time will be limited to 1 hour. If aftertreatment SCR system cleaning is not completed within 1 hour, restart engine and load the engine again to complete.

Aftertreatment SCR system cleaning complete?
YES NO
No Repair

See equipment manufacturer service information if loading could not be initiated.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

 No Repair

Go to 1A
Escalate or call for assistance.

Repair complete.

Last Modified: 04-Mar-2020


FAULT CODE 6698 - Engine Electric Fuel Lift Pump Supply Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6698 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6698 active?
YES NO

Low voltage has been detected at the engine electric fuel lift pump motor.

Check for a tripped or malfunctioning circuit breaker. Check the voltage source for proper operation. Inspect the original equipment manufacturer (OEM) harness for damage and dirty, corroded, or loose connection between the engine fuel supply pump motor and voltage source.

Repair or replace damaged or malfunctioning components. See equipment manufacturer service information.

Intermittent low voltage has been detected at the engine electric fuel lift pump motor.

Troubleshoot the OEM harness for an intermittent harness malfunction.

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 23-Mar-2016


FAULT CODE 6699 - Engine Electric Fuel Lift Pump Supply Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6699 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6699 active?
YES NO

Low voltage has been detected at the engine electric fuel lift pump motor.

Check for a tripped or malfunctioning circuit breaker. Inspect the original equipment manufacturer (OEM) harness for damage and dirty, corroded, or loose connection between the engine electric fuel lift pump motor and voltage source.

Repair or replace any damaged or malfunctioning components. See equipment manufacturer service information.

Intermittent low voltage has been detected at the engine electric fuel lift pump motor.

Troubleshoot the OEM harness for an intermittent voltage malfunction.

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 23-Mar-2016


FAULT CODE 6711 - Engine Electric Fuel Lift Pump Fuel Supply - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | QSK95 CM2350 K113 | 4388663
Air in Fuel | Refer to Procedure 006-003 | QSK95 CM2350 K113 | 4388663
Fuel Supply Lines | Refer to Procedure 006-024 | QSK95 CM2350 K113 | 4388663
Stage 0 Fuel-Water Separator Filter | Refer to Procedure 006-094 | QSK95 CM2350 K113 | 4388663
Fuel Inlet Pressure Measurement | Refer to Procedure 006-104 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6711 active or inactive counts?
STEP 2. | Check the low-pressure fuel system. |
 | STEP 2A. Check for adequate fuel supply. | Equipment has adequate fuel supply?
 | STEP 2B. Check the fuel lines. | Kinked, restricted, or damaged fuel lines?
STEP 3. | Check the low-pressure fuel system operation. |
 | STEP 3A. Check fuel inlet pressure. | Fuel lift pump inlet pressure within the specifications found in Procedure 006-104?
 | STEP 3B. Check Stage 0 fuel-water separator restriction. | Stage 0 fuel-water separator restriction within the specifications found in Procedure 005-236?
 | STEP 3C. Check for air in the fuel system. | Air in the fuel?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6711 active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the low-pressure fuel system.

Guided Step 2A - Check for adequate fuel supply.

Conditions

  • Turn keyswitch ON.
  • Turn engine OFF.

Action

Check for adequate fuel supply.

  • Do not rely on the equipment fuel gauge.
  • Verify there is fuel in the tank.

Equipment has adequate fuel supply?
YES NO
No Repair

Add fuel to the fuel tank or perform repairs to the equipment tank or fuel gauge.

Go to 2B

Go to 4A

Guided Step 2B - Check the fuel lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the suction fuel lines for kinks or damage.

Kinked, restricted, or damaged fuel lines?
YES NO

Replace the damaged fuel line(s). Refer to Procedure 006-024 in the Associated Procedures Table or equipment manufacturer service information.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the low-pressure fuel system operation.

Guided Step 3A - Check fuel inlet pressure.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel inlet pressure.

  • Refer to Procedure 006-104 in the Associated Procedures Table.

Fuel lift pump inlet pressure within the specifications found in Procedure 006-104?
YES NO
No Repair

Repair or replace the malfunctioning component(s). See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Check Stage 0 fuel-water separator restriction.

Conditions

  • Turn keyswitch ON.

Action

Check the Stage 0 fuel-water separator restriction.

Refer to Procedure 005-236 in the Associated Procedures Table.

Stage 0 fuel-water separator restriction within the specifications found in Procedure 005-236?
YES NO
No Repair

Replace the Stage 0 fuel-water separator filter. Refer to Procedure 006-094 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for air in the fuel system.

Conditions

  • Turn keyswitch ON.

Action

Check for air in the fuel.

Refer to Procedure 006-003 in the Associated Procedures Table.

Air in the fuel?
YES NO

Repair or replace the malfunctioning component(s).

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 29-Mar-2016


FAULT CODE 6714 - Engine Electric Fuel Lift Pump Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Lift Pump | Refer to Procedure 005-045 | QSK95 CM2350 K113 | 4388663
Fuel System Diagnostics | Refer to Procedure 005-236 | QSK95 CM2350 K113 | 4388663
Fuel Filter Head (Stage 1) | Refer to Procedure 006-079 | QSK95 CM2350 K113 | 4388663
Stage 0 Fuel-Water Separator Filter | Refer to Procedure 006-094 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes and low-pressure fuel system. |
 | STEP 1A. Check the fault codes. | Fault Code 6711, 6698, or 6699 active or inactive counts?
 | STEP 1B. Check for high fuel delivery temperature fault codes. | Fault Codes 4888 and 4889 active or inactive counts?
 | STEP 1C. Check the Stage 0 fuel filter restriction. | Stage 0 fuel filter restriction within the specifications found in Procedure 005-236?
 | STEP 1D. Check recirculation line restriction. | Kinked, restricted, or damaged fuel lines?
 | STEP 1E. Check pressure regulator valve restriction. | Pressure regulator valve damaged or restricted?
 | STEP 1F. Check the fault codes. | Fault Code 6714 active or inactive counts?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes and low-pressure fuel system.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6711, 6698, or 6699 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for high fuel delivery temperature fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 4888 and 4889 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check the Stage 0 fuel filter restriction.

Conditions

  • Turn keyswitch ON.

Action

Check the Stage 0 fuel filter restriction.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Stage 0 fuel filter restriction within the specifications found in Procedure 005-236?
YES NO
No Repair

Replace the Stage 0 fuel filters. Refer to Procedure 006-094 in the Associated Procedures Table.

Go to 1D

Go to 2A

Guided Step 1D - Check recirculation line restriction.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Inspect the fuel recirculation line for kinks or damage.

  • See equipment manufacturer service information.

Kinked, restricted, or damaged fuel lines?
YES NO

Repair or replace the source of the high fuel drain line restriction. See equipment manufacturer service information.

 No Repair

Go to 2A

Go to 1E

Guided Step 1E - Check pressure regulator valve restriction.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Inspect the condition of the pressure regulator valve at the Stage 1 fuel filter.

  • Refer to Procedure 006-079 in the Associated Procedures Table.

Pressure regulator valve damage or restricted?
YES NO

Repair or replace the pressure regulator. Refer to Procedure 006-079 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 1F

Guided Step 1F - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6714 active or inactive counts?
YES NO

Replace the electric fuel lift pump. Refer to Procedure 005-045 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 28-Mar-2016


FAULT CODE 6715 - Engine Electric Fuel Lift Pump Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Lift Pump | Refer to Procedure 005-045 | QSK95 CM2350 K113 | 4388663
Fuel System Diagnostics | Refer to Procedure 005-236 | QSK95 CM2350 K113 | 4388663
Fuel Filter Head (Stage 1) | Refer to Procedure 006-079 | QSK95 CM2350 K113 | 4388663
Fuel Filter (Stage 2) | Refer to Procedure 006-094 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes and low-pressure fuel system. |
 | STEP 1A. Check the fault codes. | Fault Code 6711, 6698, or 6699 active or inactive counts?
 | STEP 1B. Check for high fuel delivery temperature fault codes. | Fault Codes 4888 and 4889 active or inactive counts?
 | STEP 1C. Check the Stage 0 fuel filter restriction. | Stage 0 fuel filter restriction within the specifications found in Procedure 005-236?
 | STEP 1D. Check recirculation line restriction. | Kinked,, restricted, or damaged fuel lines?
 | STEP 1E. Check pressure regulator valve restriction. | Pressure regulator valve damaged or restricted?
 | STEP 1F. Check the fault codes. | Fault Code 6715 active or inactive counts?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes and low-pressure fuel system.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6711, 6698, or 6699 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for high fuel delivery temperature fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 4888 and 4889 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check the Stage 0 fuel filter restriction.

Conditions

  • Turn keyswitch ON.

Action

Check the Stage 0 fuel filter restriction.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Stage 0 fuel filter restriction within the specifications found in Procedure 005-236?
YES NO
No Repair

Replace the Stage 0 fuel filters. Refer to Procedure 006-094 in the Associated Procedures Table.

Go to 1D

Go to 2A

Guided Step 1D - Check recirculation line restriction.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Inspect the fuel recirculation line for kinds or damage.

  • See equipment manufacturer service information.

Kinked, restricted, or damaged fuel lines?
YES NO

Repair or replace the source of the high fuel drain line restriction. See equipment manufacturer service information.

 No Repair

Go to 2A

Go to 1E

Guided Step 1E - Check pressure regulator valve restriction.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Inspect the condition of the pressure regulator valve at the Stage 1 fuel filter.

  • Refer to Procedure 006-079 in the Associated Procedures Table.

Pressure regulator valve damage or restricted?
YES NO

  • Repair or replace the pressure regulator valve. Refer to Procedure 006-079 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 1F

Guided Step 1F - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6715 active or inactive counts?
YES NO

  • Replace the electric fuel lift pump. Refer to Procedure 005-045 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 28-Mar-2016


FAULT CODE 6716 - Engine Electric Fuel Lift Pump - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Pump | Refer to Procedure 005-016 | QSK95 CM2350 K113 | 4388663
Fuel Lift Pump | Refer to Procedure 005-045 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes | Fault Code 6716 active?
 | STEP 1B. Check for active J1939 data link 3 fault codes. | Fault Code 3331 active?
 | STEP 1C. Check for active fuel metering valve and engine fuel supply pump fault codes. | Fault Code 4929, 4931, or 6759 active?
 | STEP 1D. Check for active fuel metering valve and engine fuel supply pump communication fault codes. | Fault Codes 4892 and 4961 active?
STEP 2. | Check the fuel lift pump circuit. |
 | STEP 2A. Inspect the fuel lift pump, engine fuel supply pump, engine harness, and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the fuel lift pump. | Voltage within 1 VDC or OEM power supply voltage as read in INSITE™ electronic service tool?
 | STEP 2C. Check the J1939 terminating resistance. | 50 to 70 ohms?
 | STEP 2D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2E. Check for an open circuit in the fuel lift pump engine control module (ECM) power supply voltage supply or return circuit. | Less than 10 ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6716 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active J1939 data link 3 fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3331 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1C

Guided Step 1C - Check for active fuel metering valve and engine fuel supply pump fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4929, 4931, or 6759 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1D

Guided Step 1D - Check for active fuel metering valve and engine fuel supply pump communication fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 4892 and 4961 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the fuel lift pump circuit.

Guided Step 2A - Inspect the fuel lift pump, engine fuel supply pump, engine harness, and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel lift pump from the OEM harness.
  • Disconnect the OEM harness from the engine harness.
  • Disconnect the engine fuel supply pump from the OEM harness.

Action

Inspect the engine harness, OEM harness, fuel lift pump, and engine fuel supply pump connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the fuel lift pump, engine fuel supply pump, engine harness, or OEM harness connector.

Clean the connector and pins.

Repair or replace the damaged component.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Use the following procedure for the fuel lift pump connector. Refer to Procedure 005-045 in the Associated Procedures Table.
  • Use the following procedure for the engine fuel supply pump connector. Refer to Procedure 005-016 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the voltage to the fuel lift pump.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel lift pump from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the fuel lift pump.

  • Measure the voltage between the fuel lift pump supply circuit and fuel lift pump return circuit at the fuel lift pump OEM harness connect.

Use the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC or OEM power supply voltage as read in INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2D

Guided Step 2C - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel lift pump from the OEM harness.

Action

Measure the terminating resistance of the Society of Automotive Engineers (SAE) J1939 data link 3.

  • Measure the resistance between the SAE J1939 data link 3 (+) wire and the J1939 data link 3 (-) wire at the fuel lift pump OEM harness connector.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 to 70 ohms?
YES NO

An open circuit has been detected on the SAE J1939 data link 3 (+) or (-) wire in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 3A

Guided Step 2D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the fuel supply pump.
  • Disconnect the OEM harness from the fuel lift pump.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the fuel lift pump SIGNAL pin in the OEM harness fuel supply pump connector and all other pins in the OEM harness fuel supply pump connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the damaged section of harness.

See the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for an open circuit in the fuel lift pump ECM power supply voltage supply or return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel lift pump from the OEM harness.
  • Disconnect the engine fuel supply pump from the OEM harness.

Action

Check for an open supply or return circuit.

  • Measure the resistance from the fuel lift pump SUPPLY pin of the fuel supply pump connector to the fuel lift pump SUPPLY pin in the supply pump connector.
  • Measure the resistance from the fuel lift pump RETURN pin of the fuel supply pump connector to the fuel lift pump RETURN pin in the fuel supply pump connector.

Refer to the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

Repair or replace the fuel supply pump. Refer to Procedure 005-045 in the Associated Procedures Table.

An open circuit has been detected in the OEM harness.

Repair or replace the damaged OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Go to

Repair complete.

Last Modified: 27-Jan-2017


FAULT CODE 6717 - Engine Electric Fuel Lift Pump - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Lift Pump | Refer to Procedure 005-045 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check fault codes. |
 | STEP 1A. Check fault codes. | Fault Code 6717 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6717 active?
YES NO

The firmware version in the engine fuel lift pump is not compatible with the ECM software.

Download the correct firmware to the engine fuel supply pump. Refer to Procedure 005-045 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 23-Mar-2016


FAULT CODE 6718 - Engine Electric Fuel Lift Pump Supply - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Lift Pump | Refer to Procedure 005-045 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active engine fuel lift pump fault codes. | Fault Code 6798, 6699, or 6745 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active engine fuel lift pump fault codes.

Conditions

  • Turn the keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 6798, 6699, or 6745 active?
YES NO
No Repair

A malfunctioning engine fuel lift pump has been detected.

Replace the engine fuel lift pump. Refer to Procedure 005-045 in the Associated Procedures Table.

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 23-Mar-2016


FAULT CODE 6734 - Aftertreatment 2 SCR Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSK95 CM2350 K113 | 4388663
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSK95 CM2350 K113 | 4388663
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK95 CM2350 K113 | 4388663
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6734 active or inactive with more than one count in the last 25 engine hours?
 | STEP 1B. Check for active aftertreatment 2 mono-nitrogen oxides (NOx) sensor fault codes. | Fault codes related to the aftertreatment 2 intake NOx sensor and aftertreatment outlet NOx sensor active?
 | STEP 1C. Check for active aftertreatment 2 SCR temperature sensor fault codes. | Fault codes related to the aftertreatment 2 SCR temperature sensors active?
 | STEP 1D. Check for active diesel exhaust fluid (DEF) dosing system fault codes. | Fault codes active or inactive with two or more counts within the last 25 engine hours?
STEP 2. | Check the aftertreatment 2 and DEF dosing system. |
 | STEP 2A. Check the exhaust system for leaks. | Exhaust system leaks found?
 | STEP 2B. Check the DEF quality. | DEF free from contamination and within the specifications outlined in Procedure 011-056 table?
 | STEP 2C. Check the aftertreatment DEF dosing system operation. | Dosing volume within the specifications in Procedure 011-063 table and DEF spray pattern correct for each of the three dosing systems?
 | STEP 2D. Check for deposits in the decomposition chamber. | DEF deposits found inside the decomposition chamber?
 | STEP 2E. Check for the correct aftertreatment 2 DEF dosing valve(s). | Each aftertreatment DEF dosing valve correct for the engines configuration?
STEP 3. | Check aftertreatment 2 NOx sensors. |
 | STEP 3A. Check the aftertreatment 2 NOx sensor readings. | Aftertreatment NOx sensor readings within specifications found in Procedure 019-451 table?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6734 active or inactive with more than one count in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for active aftertreatment 2 NOx sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to the aftertreatment 2 intake NOx sensor and aftertreatment outlet NOx sensor active?
YES | NO
No Repair | No Repair

Go to the appropriate Fault Code Troubleshooting Tree.

Go to 1C

Guided Step 1C - Check for active aftertreatment 2 SCR temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to the aftertreatment 2 SCR temperature sensors active?
YES | NO
No Repair | No Repair

Go to the appropriate Fault Code Troubleshooting Tree.

Go to 1D

Guided Step 1D - Check for active DEF dosing system fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes relating to the DEF dosing system.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for active or inactive fault codes with two or more counts within the last 25 engine hours of the aftertreatment intake and outlet NOx sensors: 3982, 3984, 3985, 3986, 3988, 3989 or 3995.
  • Check for active or inactive fault codes with two or more counts within the last 25 engine hours for the aftertreatment SCR temperature sensors: 3998, 3999, 4111, 4112, 4113, 4114, 4115, 4117, 4118, 4119 or 4121.
  • Check for active or inactive fault codes with two or more counts within the last 25 engine hours for the aftertreatment DEF dosing unit system: 4456, 4457, 4458, 4459, 4461, 4462, 4464, 4465, 4466, 4467, 4468, 4471, 4472, 4474, 4475, 4476, 4477, 4478, 4712, 4754, 4755, 5767, 5768, 5769, 5772, 5773, 5775, 5829, 5831,5832 or 7124.

DEF dosing system or DEF quality related fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate Fault Code Troubleshooting Tree.

Go to 2A

Guided Step 2 - Check the aftertreatment 2 and DEF dosing system.

Guided Step 2A - Check the exhaust system for leaks.

Conditions

  • Turn keyswitch ON.
  • Start the engine.

Action

Check the exhaust for leaks.

  • Inspect the entire exhaust system between the turbocharger outlet and the SCR outlet. Inspect for loose connections, leaking connections, and broken exhaust system components.

Exhaust system leaks found?
YES NO

Repair or replace the damaged exhaust system component.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the DEF quality.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF quality.

  • Inspect the DEF in the tank for signs of debris or contamination.
  • Use the Cummins® DEF Refractometer Service Tool, Part Number 4919554, to test the DEF concentration. Refer to Procedure 011-056 in the Associated Procedures Table.

DEF free from contamination and within the specifications outlined in Procedure 011-056 table?
YES NO
No Repair

The fluid in the DEF tank is not certified DEF, or the DEF is diluted or degraded.

Completely drain the DEF tank, and rinse the tank with water.

Fill the DEF tank with certified DEF.

Refer to Procedure 011-056 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the aftertreatment 2 DEF dosing system operation.

Conditions

  • Remove each of the aftertreatment 2 DEF dosing valves from the decomposition chamber.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the DEF Doser Pump Override Test found under ECM Diagnostic Tests.

  • Use the following procedure for instructions and specifications. Refer to Procedure 011-063 in the Associated Procedures Table.
  • Make sure each of the DEF dosing valves are not plugged and the spray pattern is correct.

Each DEF dosing valve must be removed and placed in a measuring container in order to perform the DEF Doser Pump Override Test.

Dosing volume within the specifications in Procedure 011-063 in the Associated Procedures Table and DEF spray pattern correct for each of the three dosing systems?

YES NO
No Repair

Replace only the DEF dosing valve that was found to be out of specification. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2D - Check for deposits in the decomposition chamber.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the decomposition chamber for deposits.

  • Remove inspection cover from SCR catalyst.
  • Inspect for DEF deposits.
  • Refer to Procedure 011-036 in the Associated Procedures Table.

DEF deposits found inside the decomposition chamber?
YES NO

Clean the decomposition chamber. Refer to Procedure 011-036 in the Associated Procedures Table.

 No Repair

Go to 2E

Go to 3A

Guided Step 2E - Check for the correct aftertreatment 2 DEF dosing valve(s).

Conditions

  • Turn keyswitch OFF.

Action

Verify the correct aftertreatment DEF dosing valve is installed for the engine.

  • Verify each aftertreatment 2 DEF dosing valve is correct for the engines configuration.

Each aftertreatment DEF dosing valve correct for the engines configuration?
YES NO
No Repair

Replace only the DEF dosing valve that does not match the engine configuration. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check aftertreatment 2 NOx sensors.

Guided Step 3A - Check the aftertreatment 2 NOx sensor readings.

Conditions

  • Turn keyswitch ON.

Action

Check the aftertreatment 2 NOx sensor readings.

  • Preform the Aftertreatment 2 NOx Sensor Rationality Test. Refer to Procedure 019-451 in the Associated Procedures Table.

Aftertreatment NOx sensor readings within specifications found in Procedure 019-451 table?
YES NO

Replace the aftertreatment SCR catalyst. Refer to Procedure 011-036 in the Associated Procedures Table.

Replace the aftertreatment intake and outlet NOx sensors.

  • For the intake NOx sensor use the following procedure: Refer to Procedure 019-463 in the Associated Procedures Table.
  • For the outlet NOx sensor use the following procedure: Refer to Procedure 019-451 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 04-Dec-2017


FAULT CODE 6759 - Engine Electric Fuel Lift Pump Supply Voltage - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Lift Pump | Refer to Procedure 005-045 | QSK95 CM2350 K113 | 4388663
Engine Fuel Supply Pump | Refer to Procedure 005-241 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6759 active?
 | STEP 1B. Check for active fuel metering valve and engine fuel supply pump fault codes. | Fault Code 4931 active?
STEP 2. | Check engine control module (ECM) power supply circuit. |
 | STEP 2A. INspect the fuel lift pump connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the ECM power supply voltage. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 2C. Check for an open ECM power supply voltage supply circuit. | Voltage within 1 VDC of ECM power supply voltage?
 | STEP 2D. Check the fault codes. | Fault Code 6759 active or inactive counts?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6759 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fuel metering valve and engine fuel supply pump fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4931 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the ECM power supply circuit.

Guided Step 2A - Inspect the fuel lift pump connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel lift pump from the original equipment manufacturer (OEM) harness.

Action

Inspect the OEM harness power and device connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the device or OEM connector.

Clean the connector and pins.

Repair the damaged OEM harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

Use the following procedure for a damaged fuel lift pump connector. Refer to Procedure 005-045 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the ECM power supply voltage.

Conditions

  • Turn keyswitch ON.
  • Disconnect the fuel lift pump from the OEM harness.

Action

Check the ECM power supply voltage at the fuel lift pump OEM harness..

  • Measure the voltage between the fuel lift pump OEM harness voltage SUPPLY pin and the fuel lift pump connector OEM harness voltage RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Voltage within 1 VDC of the ECM power supply voltage?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C

Guided Step 2C - Check for an open ECM power supply voltage supply circuit.

Conditions

  • Turn keyswitch ON.
  • Disconnect the fuel lift pump from the OEM harness power connector.

Action

Check for an open circuit at the fuel lift pump OEM harness.

  • Measure the voltage between the fuel lift pump connector ECM power supply voltage SUPPLY pin and ECM power supply ground circuit.

Use the wiring diagram or wiring diagram for connector pin identification.

Voltage within 1 VDC of ECM power supply voltage?
YES NO

An open circuit has been detected in the fuel lift pump ECM power supply voltage return circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-071 in Section 19.

Replace the fuel lift pump. Refer to Procedure 005-045 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 2D - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6759 active or inactive counts?
YES NO

Replace the engine fuel supply pump. Refer to Procedure 005-241 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 13-Apr-2016


FAULT CODE 6853 - Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit 1 Heater Relay - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Delphi® 96 Way Engine Control Module Connector | Refer to Procedure 019-505 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Heater Relay | Refer to Procedure 019-620 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box Circuit Breaker | Refer to Procedure 019-623 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box Resistor | Refer to Procedure 019-625 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6853 active?
 | STEP 1B. Check for diesel exhaust fluid (DEF) dosing unit heater relay fault codes. | Fault Codes 4459, 4461, and 6854 active?
STEP 2. | Check the aftertreatment 2 DEF dosing unit heater circuit breaker and relay. |
 | STEP 2A. Test the aftertreatment 2 DEF dosing unit heater circuit breaker. | Circuit breakers within specifications?
 | STEP 2B. Test the aftertreatment 2 DEF dosing unit heater relay. | Aftertreatment 2 dosing unit heater relay within specification?
STEP 3. | Check the harness. |
 | STEP 3A. Inspect the aftertreatment 2 connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 3E. Check for a short-to-ground in the harness. | Greater than 100k ohms?
STEP 4. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 4A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6853 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for diesel exhaust fluid (DEF) dosing unit heater relay fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 4459, 4461, and 6854 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment 2 DEF dosing unit heater circuit breaker and relay.

Guided Step 2A - Test the aftertreatment 2 DEF dosing unit heater circuit breaker.

Conditions

  • Turn keyswitch OFF.

Action

  • Test the aftertreatment 2 DEF dosing unit heater circuit breaker. Refer to Procedure 019-623 in the Associated Procedures Table.

Circuit breakers within specifications?
YES NO
No Repair

Replace circuit breaker or repair harness. Refer to Procedure 019-623 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Test the aftertreatment 2 DEF dosing unit heater relay.

Conditions

  • Turn keyswitch OFF.

Action

  • Test the aftertreatment 2 DEF dosing unit heater relay (K2). Refer to Procedure 019-620 in the Associated Procedures Table.

Aftertreatment 2 dosing unit heater relay within specification?
YES NO
No Repair

A damaged dosing unit heater relay has been detected. Replace damaged relay. Refer to Procedure 019-620 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the harness.

Guided Step 3A - Inspect the aftertreatment 2 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.

Action

Inspect the connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in the Section 19.
  • For the aftertreatment junction box: Refer to Procedure 019-598 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit heater RETURN pin in the aftertreatment junction box C1 connector and terminal A2 of the aftertreatment 2 DEF dosing unit heater relay (K2).

Reference the wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all wire(s) in series to determine which one contains open circuit.

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit heater SIGNAL pin in the aftertreatment junction box C1 connector and terminal 7 of the aftertreatment 2 DEF dosing unit heater relay (K2).
  • Measure the resistance between the aftertreatment 2 DEF dosing unit heater DIAGNOSTIC SIGNAL pin in the aftertreatment junction box C1 connector and terminal 8 of the aftertreatment 2 DEF dosing unit heater relay (K2).

Reference the wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all wire(s) in series to determine which one contains open circuit.

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.
  • Remove the aftertreatment 2 DEF dosing unit heater relay resistor (R4) from the aftertreatment junction box. Refer to Procedure 019-625 in the Associated Procedures Table.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit heater DIAGNOSTIC SIGNAL pin in the aftertreatment junction box C1 connector and all other pins in the connector.

Reference the wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all wire(s) in series to determine which one contains short circuit.

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short-to-ground in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit heater DIAGNOSTIC SIGNAL pin in the aftertreatment junction box C1 connector to the G2 connector.

Reference the wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all wire(s) in series to determine which one contains short circuit.

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine control module (ECM) and original equipment manufacturer (OEM) harness.

Guided Step 4A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector (J2) from ECM (2).

Action

Inspect the connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-505 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector (J2) from ECM (2).
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit heater DIGNOSTIC SIGNAL pin in the OEM connector (J2) from ECM (2) and all other pins in the connector.

Reference the wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harness connections in series to determine which one contains the short circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process.

Repair complete.

Last Modified: 21-Aug-2017


FAULT CODE 6854 - Aftertreatment 2 Diesel Exhaust Fluid Dosing Unit 1 Heater Relay - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Delphi® 96 Way Engine Control Module Connector | Refer to Procedure 019-505 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Heater Relay | Refer to Procedure 019-620 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box Resistor | Refer to Procedure 019-625 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6854 active?
 | STEP 1B. Check for aftertreatment 2 diesel exhaust fluid (DEF) dosing unit heater relay fault codes. | Fault Code 4159 or 1461 active?
STEP 2. | Check the aftertreatment 2 DEF dosing unit heater relay. |
 | STEP 2A. Check the aftertreatment 2 DEF dosing unit heater relay. | Aftertreatment 2 DEF dosing unit heater relay within specifications?
 | STEP 2B. Check the aftertreatment 2 DEF dosing unit heater resistor. | Aftertreatment 2 DEF line heater resistor within specifications?
STEP 3. | Check the aftertreatment 2 harness. |
 | STEP 3A. Inspect the aftertreatment 2 connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 4A. Inspect the aftertreatment 2 connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 4C. Check for an open circuit. | Less than 10 ohms?
 | STEP 4D. Inspect the OEM harness ECM connector pins. | Dirty or damaged pins?
 | STEP 4E. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 4F. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6854 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for aftertreatment 2 diesel exhaust fluid (DEF) dosing unit heater relay fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4159 or 4161 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment 2 DEF dosing unit heater relay.

Guided Step 2A - Test the aftertreatment 2 DEF dosing unit heater relay.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment 2 DEF dosing unit heater relay (K2) from the aftertreatment junction box. Refer to Procedure 019-620 in the Associated Procedures Table.

Action

  • Test aftertreatment 2 DEF dosing unit heater relay. Refer to Procedure 019-620 in the Associated Procedures Table.

Reference the wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Aftertreatment 2 DEF dosing unit heater relay within specifications?
YES NO
No Repair

Replace the aftertreatment 2 DEF dosing unit heater relay (K2). Refer to Procedure 019-620 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Check the aftertreatment 2 DEF dosing unit heater resistor.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment 2 DEF dosing unit heater resistor (R5) from the aftertreatment junction box. Refer to Procedure 019-625 in the Associated Procedures Table.

Action

  • Test aftertreatment 2 DEF dosing unit heater resistor. Refer to Procedure 019-625 in the Associated Procedures Table.

Reference the wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Aftertreatment 2 DEF line heater resistor within specifications?
YES NO
No Repair

Replace the aftertreatment 2 DEF dosing unit heater resistor (R5). Refer to Procedure 019-625 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the aftertreatment 2 harness.

Guided Step 3A - Inspect the aftertreatment 2 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.

Action

Inspect the connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • For the OEM harness: Refer to Procedure 019-071 in the Section 19.
  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.
  • Remove the aftertreatment 2 DEF dosing unit heater relay resistor (R5) from the aftertreatment junction box. Refer to Procedure 019-625 in the Associated Procedures Table.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit heater DIAGNOSTIC SIGNAL pin in the aftertreatment junction box C1 connector and all other pins in the connector.

Reference the wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in aftertreatment junction box.

Troubleshoot all wire(s) in series to determine which one contains short circuit.

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit heater DIAGNOSTIC SIGNAL pin in the aftertreatment junction box C1 connector and terminal 8 of the aftertreatment 2 DEF line heater relay (K2).

Reference the wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all wire(s) in series to determine which one contains open circuit.

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Install the aftertreatment 2 DEF dosing unit heater relay resistor (R5) in the aftertreatment junction box. Refer to Procedure 019-625 in the Associated Procedures Table.
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit heater relay RETURN pin in the aftertreatment junction box connector C1 connector and aftertreatment 2 DEF line heater resistor (R5) terminal B.

Reference the wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all wire(s) in series to determine which one contains open circuit.

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine control module (ECM) and original equipment manufacturer (OEM) harness.

Guided Step 4A - Inspect the aftertreatment 2 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness at the aftertreatment 2 connector.

Action

Inspect the connector(s) for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

For the OEM harness: Refer to Procedure 019-071 in Section 19.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.
  • Disconnect the OEM harness at the aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit heater DIGNOSTIC SIGNAL pin in the aftertreatment 2 connector and all other pins in the connector.

Reference the wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harness connections in series to determine which one contains the short circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-071 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C1 connector from the aftertreatment junction box.
  • Disconnect the OEM harness at the aftertreatment 2 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit heater relay DIAGNOSTIC SIGNAL pin in the aftertreatment junction box C1 connector and the aftertreatment 2 DEF dosing unit heater relay DIAGNOSTIC SIGNAL pin in the aftertreatment 2 connector.
  • Measure the resistance between the aftertreatment 2 DEF dosing unit heater relay RETURN pin in the aftertreatment junction box C1 connector and the aftertreatment 2 DEF dosing unit heater relay RETURN pin in the aftertreatment 2 connector.

Reference the wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all harness connections in series to determine which one contains the open circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-071 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Inspect the OEM harness ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector (J2) from ECM (2).

Action

Inspect the connector(s) for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-505 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4E

Guided Step 4E - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector (J2) from ECM (2).
  • Disconnect the OEM harness at the aftertreatment 2 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit heater DIAGNOSTIC SIGNAL pin in the OEM connector (J2) from ECM (2) and all other pins in the connector.

Reference the wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harness connections in series to determine which one contains the short circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4F

Go to 5A

Guided Step 4F - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector (J2) from ECM (2).
  • Disconnect the OEM harness at the aftertreatment 2 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 2 DEF dosing unit heater DIAGNOSTIC SIGNAL pin in the OEM connector (J2) from ECM (2) and the aftertreatment 2 DEF dosing unit heater DIAGNOSTIC SIGNAL pin in the 47 pin aftertreatment 2 connector.
  • Measure the resistance between the aftertreatment 2 DEF dosing unit heater RETURN pin in the OEM connector (J2) from ECM (2) and the aftertreatment 2 DEF dosing unit heater RETURN pin in the aftertreatment 2 connector.

Reference the wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all harness connections in series to determine which one contains the open circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process.

Repair complete.

Last Modified: 21-Aug-2017


FAULT CODE 6855 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Relay - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Delphi® 96 Way Engine Control Module Connector | Refer to Procedure 019-505 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Heater Relay | Refer to Procedure 019-620 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box Circuit Breaker | Refer to Procedure 019-623 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box Resistor | Refer to Procedure 019-625 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6855active?
 | STEP 1B. Check for diesel exhaust fluid (DEF) dosing unit heater relay fault codes. | Fault Code 4471, 4472 and 6856 active?
STEP 2. | Check the aftertreatment 1 DEF dosing unit heater circuit breaker and relay. |
 | STEP 2A. Test the aftertreatment 1 DEF dosing unit heater circuit breaker. | Circuit breakers within specifications?
 | STEP 2B. Test the aftertreatment 1 DEF dosing unit heater relay. | Aftertreatment 1 dosing unit heater relay within specification?
STEP 3. | Check the harness. |
 | STEP 3A. Inspect the aftertreatment 1 connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 3E. Check for a short-to-ground in the harness. | Greater than 100k ohms?
STEP 4. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 4A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6855 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for diesel exhaust fluid (DEF) dosing unit heater relay fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 4471, 4472 and 6856 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment 1 DEF dosing unit heater circuit breaker and relay.

Guided Step 2A - Test the aftertreatment 1 DEF dosing unit heater circuit breaker.

Conditions

  • Turn keyswitch OFF.

Action

  • Test the aftertreatment 1 DEF dosing unit heater circuit breaker. Refer to Procedure 019-623 in the Associated Procedures Table.

Circuit breakers within specifications?
YES NO
No Repair

A damaged circuit breaker or harness has been detected.

Replace circuit breaker or repair harness. Refer to Procedure 019-623 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Test the aftertreatment 1 DEF dosing unit heater relay.

Conditions

  • Turn keyswitch OFF.

Action

  • Test the aftertreatment 1 DEF dosing unit heater relay (K1). Refer to Procedure 019-620 in the Associated Procedures Table.

Aftertreatment 1 dosing unit heater relay within specification?
YES NO
No Repair

A damaged dosing unit heater relay has been detected. Replace damaged relay. Refer to Procedure 019-620 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the harness.

Guided Step 3A - Inspect the aftertreatment 1 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.

Action

Inspect the connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in the Section 19.
  • For the aftertreatment junction box: Refer to Procedure 019-598 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit heater RETURN pin in the aftertreatment junction box C5 connector and terminal A2 of the aftertreatment 1 DEF dosing unit heater relay (K1).

Reference the wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all wire(s) in series to determine which one contains open circuit.

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit heater SIGNAL pin in the aftertreatment junction box C5 connector and terminal 7 of the aftertreatment 1 DEF dosing unit heater relay (K1).
  • Measure the resistance between the aftertreatment 1 DEF dosing unit heater DIAGNOSTIC SIGNAL pin in the aftertreatment junction box C1 connector and terminal 8 of the aftertreatment 1 DEF dosing unit heater relay (K1).

Reference the wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all wire(s) in series to determine which one contains open circuit.

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.
  • Remove the aftertreatment 1 DEF dosing unit heater relay resistor (R2) from the aftertreatment junction box. Refer to Procedure 019-625 in the Associated Procedures Table.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit heater DIAGNOSTIC SIGNAL pin in the aftertreatment junction box C5 connector and all other pins in the connector.

Reference the wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all wire(s) in series to determine which one contains short circuit.

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short-to-ground in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit heater DIAGNOSTIC SIGNAL pin in the aftertreatment junction box C5 connector to the G2 connector.

Reference the wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all wire(s) in series to determine which one contains short circuit.

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine control module (ECM) and original equipment manufacturer (OEM) harness.

Guided Step 4A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector (J2) from ECM (1).

Action

Inspect the connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-505 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector (J2) from ECM (1).
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit heater DIGNOSTIC SIGNAL pin in the OEM connector (J2) from ECM (1) and all other pins in the connector.

Reference the wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harness connections in series to determine which one contains the short circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process.

Repair complete.

Last Modified: 22-Aug-2017


FAULT CODE 6856 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Relay - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663
Delphi® 96 Way Engine Control Module Connector | Refer to Procedure 019-505 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box | Refer to Procedure 019-598 | QSK95 CM2350 K113 | 4388663
Aftertreatment Diesel Exhaust Fluid Dosing Unit Heater Relay | Refer to Procedure 019-620 | QSK95 CM2350 K113 | 4388663
Aftertreatment Junction Box Resistor | Refer to Procedure 019-625 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6856 active?
 | STEP 1B. Check for aftertreatment 1 diesel exhaust fluid (DEF) dosing unit heater relay fault codes. | Fault Code 4171 or 4172 active?
STEP 2. | Check the aftertreatment 1 DEF dosing unit heater relay. |
 | STEP 2A. Check the aftertreatment 1 DEF dosing unit heater relay. | Aftertreatment 1 DEF dosing unit heater relay within specifications?
 | STEP 2B. Check the aftertreatment 1 DEF dosing unit heater resistor. | Aftertreatment 1 DEF line heater resistor within specifications?
STEP 3. | Check the aftertreatment 1 harness. |
 | STEP 3A. Inspect the aftertreatment 1 connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 4A. Inspect the aftertreatment 1 connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 4C. Check for an open circuit. | Less than 10 ohms?
 | STEP 4D. Inspect the OEM harness ECM connector pins. | Dirty or damaged pins?
 | STEP 4E. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 4F. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6856 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for aftertreatment 1 diesel exhaust fluid (DEF) dosing unit heater relay fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4171 or 4172 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment 1 DEF dosing unit heater relay.

Guided Step 2A - Test the aftertreatment 1 DEF dosing unit heater relay.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment 1 DEF dosing unit heater relay (K1) from the aftertreatment junction box. Refer to Procedure 019-620 in the Associated Procedures Table.

Action

  • Test aftertreatment 1 DEF dosing unit heater relay. Refer to Procedure 019-620 in the Associated Procedures Table.

Reference the wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Aftertreatment 1 DEF dosing unit heater relay within specifications?
YES NO
No Repair

Replace the aftertreatment 1 DEF dosing unit heater relay (K1). Refer to Procedure 019-620 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Check the aftertreatment 1 DEF dosing unit heater resistor.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment 1 DEF dosing unit heater resistor (R2) from the aftertreatment junction box. Refer to Procedure 019-625 in the Associated Procedures Table.

Action

  • Test aftertreatment 1 DEF dosing unit heater resistor. Refer to Procedure 019-625 in the Associated Procedures Table.

Reference the wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Aftertreatment 1 DEF line heater resistor within specifications?
YES NO
No Repair

Replace the aftertreatment 1 DEF dosing unit heater resistor (R2). Refer to Procedure 019-625 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the aftertreatment 1 harness.

Guided Step 3A - Inspect the aftertreatment 1 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.

Action

Inspect the connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • For the OEM harness: Refer to Procedure 019-071 in the Section 19.
  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.
  • Remove the aftertreatment 1 DEF dosing unit heater relay resistor (R2) from the aftertreatment junction box. Refer to Procedure 019-625 in the Associated Procedures Table.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit heater DIAGNOSTIC SIGNAL pin in the aftertreatment junction box C5 connector and all other pins in the connector.

Reference the wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in aftertreatment junction box.

Troubleshoot all wire(s) in series to determine which one contains short circuit.

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit heater DIAGNOSTIC SIGNAL pin in the aftertreatment junction box C5 connector and terminal 8 of the aftertreatment 1 DEF line heater relay (K1).

Reference the wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all wire(s) in series to determine which one contains open circuit.

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Install the aftertreatment 1 DEF dosing unit heater relay resistor (R2) in the aftertreatment junction box. Refer to Procedure 019-625 in the Associated Procedures Table.
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit heater relay RETURN pin in the aftertreatment junction box connector C5 connector and aftertreatment 1 DEF line heater resistor (R2) terminal B.

Reference the wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all wire(s) in series to determine which one contains open circuit.

Repair or replace damaged wire(s). Refer to Procedure 019-598 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine control module (ECM) and original equipment manufacturer (OEM) harness.

Guided Step 4A - Inspect the aftertreatment 1 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness at the aftertreatment 1 connector.

Action

Inspect the connector(s) for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

For the OEM harness: Refer to Procedure 019-071 in Section 19.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.
  • Disconnect the OEM harness at the aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit heater DIAGNOSTIC SIGNAL pin in the aftertreatment 1 connector and all other pins in the connector.

Reference the wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harness connections in series to determine which one contains the short circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-071 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness C5 connector from the aftertreatment junction box.
  • Disconnect the OEM harness at the aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit heater relay DIAGNOSTIC SIGNAL pin in the aftertreatment junction box C5 connector and the aftertreatment 1 DEF dosing unit heater relay DIAGNOSTIC SIGNAL pin in the aftertreatment 1 connector.
  • Measure the resistance between the aftertreatment 1 DEF dosing unit heater relay RETURN pin in the aftertreatment junction box C5 connector and the aftertreatment 1 DEF dosing unit heater relay RETURN pin in the aftertreatment 1 connector.

Reference the wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all harness connections in series to determine which one contains the open circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-071 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Inspect the OEM harness ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector (J2) from ECM (1).

Action

Inspect the connector(s) for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-505 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4E

Guided Step 4E - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector (J2) from ECM (1).
  • Disconnect the OEM harness at the aftertreatment 1 connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit heater DIAGNOSTIC SIGNAL pin in the OEM connector (J2) from ECM (1) and all other pins in the connector.

Reference the wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harness connections in series to determine which one contains the short circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4F

Go to 5A

Guided Step 4F - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector (J2) from ECM (1).
  • Disconnect the OEM harness at the aftertreatment 1 connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment 1 DEF dosing unit heater DIAGNOSTIC SIGNAL pin in the OEM connector (J2) from ECM (1) and the aftertreatment 1 DEF dosing unit heater DIAGNOSTIC SIGNAL pin in the 47 pin aftertreatment 1 connector.
  • Measure the resistance between the aftertreatment 1 DEF dosing unit heater RETURN pin in the OEM connector (J2) from ECM (1) and the aftertreatment 1 DEF dosing unit heater RETURN pin in the aftertreatment 1 connector.

Reference the wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all harness connections in series to determine which one contains the open circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process.

Repair complete.

Last Modified: 21-Aug-2017


FAULT CODE 7123- Aftertreatment 1 Diesel Exhaust Fluid Actual Dosing Quantity - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSK95 CM2350 K113 | 4388663
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine control module (ECM). |
 | STEP 1A. Check for active aftertreatment fault codes. | Active or inactive counts?
 | STEP 1B. Check the ECM. | Fault Code 7123 active?
STEP 2. | Check diesel exhaust fluid (DEF) for air. |
 | STEP 2A. Inspect the aftertreatment DEF lines and fittings. | Reversed, damaged, leaking, or restricted connections found?
 | STEP 2B. Check for air in each DEF in each aftertreatment 1 DEF dosing system. | Air bubbles present?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the engine control module (ECM).

Guided Step 1A - Check for active aftertreatment fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for any other active aftertreatment fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts?
YES | NO
No Repair | No Repair

Refer to appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 7123 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check diesel exhaust fluid (DEF) for air.

Guided Step 2A - Inspect the aftertreatment DEF lines and fittings.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment DEF lines and fittings for the following:

  • Dosing unit supply line between the tank and the dosing unit (suction line)
  • Dosing valve supply line between the dosing unit and the dosing valve (pressure line)
  • Return line between the dosing valve and the tank (return line).

Inspect all three DEF lines and associated fittings/connectors:

  • Verify the lines are not swapped at the dosing unit, dosing valve, or DEF tank connections. Reversed DEF line connectors cause the dosing system to fail to prime.
  • Check the DEF tank connections (suction and return lines) for cracks and pitting.
  • Check both dosing unit connections and fittings for loose, leaking, or damaged connections.
  • Disconnect the suction line and pressure line dosing unit connectors and look for signs of build-up or blockage.
  • Check the suction line for signs of leakage or openings which will allow the dosing unit to suck in air with the DEF.
  • Check the pressure line for signs of leakage or rupture.
  • Verify proper sealing at all connection points, including DEF tank (two connections), dosing unit (two connections), and dosing valve (two connections).

Refer to Procedure 011-058 in the Associated Procedures Table.

Reversed, damaged, leaking, or restricted connections found?
YES NO

Replace the leaking DEF line, as necessary. See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for air in each DEF in each aftertreatment 1 DEF dosing system.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Check for air in each DEF in each aftertreatment 1 DEF dosing system. Refer to Procedure 011-075 in the Associated Procedures Table.

Air bubbles present?
YES NO

Repair damaged component.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Codes" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Follow the technical escalation process.

Repair complete

Last Modified: 03-May-2017


FAULT CODE 7124- Aftertreatment 2 Diesel Exhaust Fluid Actual Dosing Quantity - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSK95 CM2350 K113 | 4388663
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine control module (ECM). |
 | STEP 1A. Check for active aftertreatment fault codes. | Active or inactive counts?
 | STEP 1B. Check the ECM. | Fault Code 7124 active?
STEP 2. | Check diesel exhaust fluid (DEF) for air. |
 | STEP 2A. Inspect the aftertreatment 2 DEF lines and fittings. | Reversed, damaged, leaking, or restricted connections found?
 | STEP 2B. Check for air in each DEF in each aftertreatment 2 DEF dosing system. | Air bubbles present?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the engine control module (ECM).

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for any other active aftertreatment fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts?
YES | NO
No Repair | No Repair

Refer to appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 7124 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check diesel exhaust fluid (DEF) for air.

Guided Step 2A - Inspect the aftertreatment 2 DEF lines and fittings.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment 2 DEF lines and fittings for the following:

  • Dosing unit supply line between the tank and the dosing unit (suction line)
  • Dosing valve supply line between the dosing unit and the dosing valve (pressure line)
  • Return line between the dosing valve and the tank (return line).

Inspect all three DEF lines and associated fittings/connectors:

  • Verify the lines are not swapped at the dosing unit, dosing valve, or DEF tank connections. Reversed DEF line connectors cause the dosing system to fail to prime.
  • Check the DEF tank connections (suction and return lines) for cracks and pitting.
  • Check both dosing unit connections and fittings for loose, leaking, or damaged connections.
  • Disconnect the suction line and pressure line dosing unit connectors and look for signs of build-up or blockage.
  • Check the suction line for signs of leakage or openings which will allow the dosing unit to suck in air with the DEF.
  • Check the pressure line for signs of leakage or rupture.
  • Verify proper sealing at all connection points, including DEF tank (two connections), dosing unit (two connections), and dosing valve (two connections).

Refer to Procedure 011-058 in the Associated Procedures Table.

Reversed, damaged, leaking, or restricted connections found?
YES NO
No Repair

Replace the leaking DEF line, as necessary. See equipment manufacturer service information.

Go to 3A

Go to 2B

Guided Step 2B - Check for air in each DEF in each aftertreatment 2 DEF dosing system.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Check for air in each diesel exhaust fluid in each aftertreatment 2 DEF dosing system. Refer to Procedure 011-075 in the Associated Procedures Table.

Air bubbles present?
YES NO

Repair damaged component.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Codes" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process.

Repair complete

Last Modified: 03-May-2017


INDEX
402-fc111.htm

402-fc111sa00.htm

402-t05-111sa00.htm

402-fc111sa01.htm

402-t05-111sa01.htm

402-fc111sa144.htm

402-t05-111sa144.htm

402-fc111sa186.htm

402-t05-111sa186.htm

402-fc115.htm

402-t05-115.htm

402-fc122.htm

402-t05-122.htm

402-fc123.htm

402-t05-123.htm

402-fc135.htm

402-t05-135.htm

402-fc141.htm

402-t05-141.htm

402-fc143.htm

402-t05-143.htm

402-fc144.htm

402-t05-144.htm

402-fc145.htm

402-t05-145.htm

402-fc146.htm

402-t05-146.htm

402-fc151.htm

402-t05-151.htm

402-fc153.htm

402-t05-153.htm

402-fc154.htm

402-t05-154.htm

402-fc155.htm

402-t05-155.htm

402-fc156.htm

402-t05-156.htm

402-fc157.htm

402-t05-157.htm

402-fc158.htm

402-t05-158.htm

402-fc187.htm

402-fc187sa00.htm

402-t05-187sa00.htm

402-fc187sa01.htm

402-t05-187sa01.htm

402-fc195.htm

402-fc195-2wire.htm

402-t05-195-2wire.htm

402-fc195-3wire.htm

402-t05-195-3wire.htm

402-fc196.htm

402-fc196-2wire.htm

402-t05-196-2wire.htm

402-fc196-3wire.htm

402-t05-196-3wire.htm

402-fc197.htm

402-t05-197.htm

402-fc212.htm

402-t05-212.htm

402-fc213.htm

402-t05-213.htm

402-fc214.htm

402-t05-214.htm

402-fc221.htm

402-t05-221.htm

402-fc222.htm

402-t05-222.htm

402-fc227.htm

402-t05-227.htm

402-fc228.htm

402-t05-228.htm

402-fc231.htm

402-t05-231.htm

402-fc232.htm

402-t05-232.htm

402-fc234.htm

402-t05-234.htm

402-fc235.htm

402-t05-235.htm

402-fc238.htm

402-t05-238.htm

402-fc239.htm

402-t05-239.htm

402-fc245.htm

402-t05-245.htm

402-fc249.htm

402-t05-249.htm

402-fc251.htm

402-t05-251.htm

402-fc256.htm

402-t05-256.htm

402-fc261.htm

402-t05-261.htm

402-fc263.htm

402-t05-263.htm

402-fc265.htm

402-t05-265.htm

402-fc266.htm

402-t05-266.htm

402-fc285.htm

402-t05-285.htm

402-fc286.htm

402-t05-286.htm

402-fc319.htm

402-t05-319.htm

402-fc322.htm

402-t05-322.htm

402-fc323.htm

402-t05-323.htm

402-fc324.htm

402-t05-324.htm

402-fc325.htm

402-t05-325.htm

402-fc331.htm

402-t05-331.htm

402-fc332.htm

402-t05-332.htm

402-fc342.htm

402-t05-342.htm

402-fc344.htm

402-t05-344.htm

402-fc349.htm

402-t05-349.htm

402-fc351.htm

402-t05-351.htm

402-fc352.htm

402-fc352sa00.htm

402-t05-352sa00.htm

402-fc352sa01.htm

402-t05-352sa01.htm

402-fc386.htm

402-t05-386.htm

402-fc415.htm

402-t05-415.htm

402-fc421.htm

402-t05-421.htm

402-fc426.htm

402-t05-426.htm

402-fc431.htm

402-t05-431.htm

402-fc441.htm

402-t05-441.htm

402-fc442.htm

402-t05-442.htm

402-fc449.htm

402-t05-449.htm

402-fc451.htm

402-t05-451.htm

402-fc452.htm

402-t05-452.htm

402-fc488.htm

402-t05-488.htm

402-fc515.htm

402-t05-515.htm

402-fc516.htm

402-t05-516.htm

402-fc545.htm

402-t05-545.htm

402-fc546.htm

402-t05-546.htm

402-fc547.htm

402-t05-547.htm

402-fc553.htm

402-t05-553.htm

402-fc555.htm

402-t05-555.htm

402-fc556.htm

402-t05-556.htm

402-fc559.htm

402-t05-559.htm

402-fc581.htm

402-t05-581.htm

402-fc582.htm

402-t05-582.htm

402-fc611.htm

402-t05-611.htm

402-fc621.htm

402-t05-621.htm

402-fc622.htm

402-t05-622.htm

402-fc623.htm

402-t05-623.htm

402-fc624.htm

402-t05-624.htm

402-fc625.htm

402-t05-625.htm

402-fc626.htm

402-t05-626.htm

402-fc627.htm

402-t05-627.htm

402-fc628.htm

402-t05-628.htm

402-fc631.htm

402-t05-631.htm

402-fc632.htm

402-t05-632.htm

402-fc633.htm

402-t05-633.htm

402-fc634.htm

402-t05-634.htm

402-fc635.htm

402-t05-635.htm

402-fc636.htm

402-t05-636.htm

402-fc637.htm

402-t05-637.htm

402-fc638.htm

402-t05-638.htm

402-fc671.htm

402-t05-671.htm

402-fc672.htm

402-t05-672.htm

402-fc673.htm

402-t05-673.htm

402-fc674.htm

402-t05-674.htm

402-fc675.htm

402-t05-675.htm

402-fc676.htm

402-t05-676.htm

402-fc677.htm

402-t05-677.htm

402-fc678.htm

402-t05-678.htm

402-fc689.htm

402-t05-689.htm

402-fc691.htm

402-t05-691.htm

402-fc692.htm

402-t05-692.htm

402-fc697.htm

402-t05-697.htm

402-fc698.htm

402-t05-698.htm

402-fc699.htm

402-fc699sa00.htm

402-t05-699sa00.htm

402-fc699sa01.htm

402-t05-699sa01.htm

402-fc699sa144.htm

402-t05-699sa144.htm

402-fc699sa186.htm

402-t05-699sa186.htm

402-fc721.htm

402-t05-721.htm

402-fc722.htm

402-t05-722.htm

402-fc723.htm

402-t05-723.htm

402-fc724.htm

402-t05-724.htm

402-fc725.htm

402-t05-725.htm

402-fc726.htm

402-t05-726.htm

402-fc727.htm

402-t05-727.htm

402-fc728.htm

402-t05-728.htm

402-fc731.htm

402-t05-731.htm

402-fc782.htm

402-t05-782.htm

402-fc1117.htm

402-t05-1117.htm

402-fc1135.htm

402-t05-1135.htm

402-fc1256.htm

402-fc1256sa00.htm

402-t05-1256sa00.htm

402-fc1256sa01.htm

402-t05-1256sa01.htm

402-fc1256sa144.htm

402-t05-1256sa144.htm

402-fc1256sa186.htm

402-t05-1256sa186.htm

402-fc1358.htm

402-t05-1358.htm

402-fc1359.htm

402-t05-1359.htm

402-fc1362.htm

402-t05-1362.htm

402-fc1367.htm

402-t05-1367.htm

402-fc1368.htm

402-t05-1368.htm

402-fc1376.htm

402-t05-1376.htm

402-fc1379.htm

402-t05-1379.htm

402-fc1383.htm

402-t05-1383.htm

402-fc1384.htm

402-t05-1384.htm

402-fc1385.htm

402-t05-1385.htm

402-fc1386.htm

402-t05-1386.htm

402-fc1389.htm

402-t05-1389.htm

402-fc1521.htm

402-t05-1521.htm

402-fc1522.htm

402-t05-1522.htm

402-fc1523.htm

402-t05-1523.htm

402-fc1524.htm

402-t05-1524.htm

402-fc1525.htm

402-t05-1525.htm

402-fc1526.htm

402-t05-1526.htm

402-fc1527.htm

402-t05-1527.htm

402-fc1529.htm

402-t05-1529.htm

402-fc1531.htm

402-t05-1531.htm

402-fc1532.htm

402-t05-1532.htm

402-fc1533.htm

402-t05-1533.htm

402-fc1534.htm

402-t05-1534.htm

402-fc1535.htm

402-t05-1535.htm

402-fc1536.htm

402-t05-1536.htm

402-fc1548.htm

402-t05-1548.htm

402-fc1549.htm

402-t05-1549.htm

402-fc1551.htm

402-t05-1551.htm

402-fc1552.htm

402-t05-1552.htm

402-fc1553.htm

402-t05-1553.htm

402-fc1554.htm

402-t05-1554.htm

402-fc1555.htm

402-t05-1555.htm

402-fc1556.htm

402-t05-1556.htm

402-fc1557.htm

402-t05-1557.htm

402-fc1618.htm

402-t05-1618.htm

402-fc1619.htm

402-t05-1619.htm

402-fc1622.htm

402-t05-1622.htm

402-fc1636.htm

402-t05-1636.htm

402-fc1637.htm

402-t05-1637.htm

402-fc1668.htm

402-fc1668-2wire.htm

402-t05-1668-2wire.htm

402-fc1668-3wire.htm

402-t05-1668-3wire.htm

402-fc1669.htm

402-fc1669-2wire.htm

402-t05-1669-2wire.htm

402-fc1669-3wire.htm

402-t05-1669-3wire.htm

402-fc1673.htm

402-t05-1673.htm

402-fc1677.htm

402-t05-1677.htm

402-fc1678.htm

402-t05-1678.htm

402-fc1679.htm

402-t05-1679.htm

402-fc1682.htm

402-t05-1682.htm

402-fc1683.htm

402-t05-1683.htm

402-fc1684.htm

402-t05-1684.htm

402-fc1685.htm

402-t05-1685.htm

402-fc1686.htm

402-t05-1686.htm

402-fc1695.htm

402-fc1695sa00.htm

402-t05-1695sa00.htm

402-fc1695sa144.htm

402-t05-1695sa144.htm

402-fc1696.htm

402-fc1696sa00.htm

402-t05-1696sa00.htm

402-fc1696sa144.htm

402-t05-1696sa144.htm

402-fc1712.htm

402-t05-1712.htm

402-fc1713.htm

402-t05-1713.htm

402-fc1714.htm

402-t05-1714.htm

402-fc1715.htm

402-t05-1715.htm

402-fc1774.htm

402-t05-1774.htm

402-fc1775.htm

402-t05-1775.htm

402-fc1843.htm

402-t05-1843.htm

402-fc1844.htm

402-t05-1844.htm

402-fc1845.htm

402-t05-1845.htm

402-fc1846.htm

402-t05-1846.htm

402-fc1847.htm

402-t05-1847.htm

402-fc1852.htm

402-t05-1852.htm

402-fc1885.htm

402-t05-1885.htm

402-fc1887.htm

402-t05-1887.htm

402-fc1984.htm

402-t05-1984.htm

402-fc2121.htm

402-t05-2121.htm

402-fc2122.htm

402-t05-2122.htm

402-fc2123.htm

402-t05-2123.htm

402-fc2124.htm

402-t05-2124.htm

402-fc2125.htm

402-t05-2125.htm

402-fc2126.htm

402-t05-2126.htm

402-fc2127.htm

402-t05-2127.htm

402-fc2128.htm

402-t05-2128.htm

402-fc2131.htm

402-t05-2131.htm

402-fc2132.htm

402-t05-2132.htm

402-fc2133.htm

402-t05-2133.htm

402-fc2134.htm

402-t05-2134.htm

402-fc2135.htm

402-t05-2135.htm

402-fc2136.htm

402-t05-2136.htm

402-fc2137.htm

402-t05-2137.htm

402-fc2138.htm

402-t05-2138.htm

402-fc2185.htm

402-t05-2185.htm

402-fc2186.htm

402-t05-2186.htm

402-fc2196.htm

402-t05-2196.htm

402-fc2215.htm

402-t05-2215.htm

402-fc2249.htm

402-t05-2249.htm

402-fc2261.htm

402-t05-2261.htm

402-fc2262.htm

402-t05-2262.htm

402-fc2288.htm

402-t05-2288.htm

402-fc2343.htm

402-t05-2343.htm

402-fc2372.htm

402-t05-2372.htm

402-fc2377.htm

402-t05-2377.htm

402-fc2442.htm

402-t05-2442.htm

402-fc2443.htm

402-t05-2443.htm

402-fc2444.htm

402-t05-2444.htm

402-fc2445.htm

402-t05-2445.htm

402-fc2446.htm

402-t05-2446.htm

402-fc2447.htm

402-t05-2447.htm

402-fc2474.htm

402-t05-2474.htm

402-fc2544.htm

402-t05-2544.htm

402-fc2651.htm

402-t05-2651.htm

402-fc2652.htm

402-t05-2652.htm

402-fc2653.htm

402-t05-2653.htm

402-fc2654.htm

402-t05-2654.htm

402-fc2655.htm

402-t05-2655.htm

402-fc2656.htm

402-t05-2656.htm

402-fc2657.htm

402-t05-2657.htm

402-fc2658.htm

402-t05-2658.htm

402-fc2727.htm

402-t05-2727.htm

402-fc2771.htm

402-t05-2771.htm

402-fc2963.htm

402-t05-2963.htm

402-fc3142.htm

402-t05-3142.htm

402-fc3143.htm

402-t05-3143.htm

402-fc3144.htm

402-t05-3144.htm

402-fc3146.htm

402-t05-3146.htm

402-fc3147.htm

402-t05-3147.htm

402-fc3148.htm

402-t05-3148.htm

402-fc3151.htm

402-t05-3151.htm

402-fc3164.htm

402-t05-3164.htm

402-fc3165.htm

402-t05-3165.htm

402-fc3229.htm

402-t05-3229.htm

402-fc3231.htm

402-t05-3231.htm

402-fc3232.htm

402-t05-3232.htm

402-fc3235.htm

402-t05-3235.htm

402-fc3242.htm

402-t05-3242.htm

402-fc3329.htm

402-t05-3329.htm

402-fc3331.htm

402-t05-3331.htm

402-fc3379.htm

402-t05-3379.htm

402-fc3497.htm

402-t05-3497.htm

402-fc3498.htm

402-t05-3498.htm

402-fc3543.htm

402-t05-3543.htm

402-fc3545.htm

402-t05-3545.htm

402-fc3547.htm

402-t05-3547.htm

402-fc3558.htm

402-t05-3558.htm

402-fc3559.htm

402-t05-3559.htm

402-fc3562.htm

402-t05-3562.htm

402-fc3563.htm

402-t05-3563.htm

402-fc3567.htm

402-t05-3567.htm

402-fc3571.htm

402-t05-3571.htm

402-fc3572.htm

402-t05-3572.htm

402-fc3573.htm

402-t05-3573.htm

402-fc3574.htm

402-t05-3574.htm

402-fc3575.htm

402-t05-3575.htm

402-fc3583.htm

402-t05-3583.htm

402-fc3596.htm

402-t05-3596.htm

402-fc3613.htm

402-t05-3613.htm

402-fc3622.htm

402-t05-3622.htm

402-fc3649.htm

402-t05-3649.htm

402-fc3681.htm

402-t05-3681.htm

402-fc3682.htm

402-t05-3682.htm

402-fc3697.htm

402-t05-3697.htm

402-fc3712.htm

402-t05-3712.htm

402-fc3713.htm

402-t05-3713.htm

402-fc3714.htm

402-t05-3714.htm

402-fc3718.htm

402-t05-3718.htm

402-fc3725.htm

402-t05-3725.htm

402-fc3727.htm

402-t05-3727.htm

402-fc3741.htm

402-t05-3741.htm

402-fc3748.htm

402-t05-3748.htm

402-fc3866.htm

402-t05-3866.htm

402-fc3867.htm

402-t05-3867.htm

402-fc3868.htm

402-t05-3868.htm

402-fc3878.htm

402-t05-3878.htm

402-fc3925.htm

402-t05-3925.htm

402-fc3969.htm

402-t05-3969.htm

402-fc3971.htm

402-t05-3971.htm

402-fc3972.htm

402-t05-3972.htm

402-fc3973.htm

402-t05-3973.htm

402-fc3974.htm

402-t05-3974.htm

402-fc3982.htm

402-t05-3982.htm

402-fc3984.htm

402-t05-3984.htm

402-fc3985.htm

402-t05-3985.htm

402-fc3986.htm

402-t05-3986.htm

402-fc3988.htm

402-t05-3988.htm

402-fc3995.htm

402-t05-3995.htm

402-fc3998.htm

402-t05-3998.htm

402-fc3999.htm

402-t05-3999.htm

402-fc4111.htm

402-t05-4111.htm

402-fc4112.htm

402-t05-4112.htm

402-fc4113.htm

402-t05-4113.htm

402-fc4114.htm

402-t05-4114.htm

402-fc4115.htm

402-t05-4115.htm

402-fc4117.htm

402-t05-4117.htm

402-fc4118.htm

402-t05-4118.htm

402-fc4119.htm

402-t05-4119.htm

402-fc4121.htm

402-t05-4121.htm

402-fc4122.htm

402-t05-4122.htm

402-fc4124.htm

402-t05-4124.htm

402-fc4145.htm

402-t05-4145.htm

402-fc4152.htm

402-t05-4152.htm

402-fc4159.htm

402-t05-4159.htm

402-fc4164.htm

402-t05-4164.htm

402-fc4165.htm

402-t05-4165.htm

402-fc4166.htm

402-t05-4166.htm

402-fc4168.htm

402-t05-4168.htm

402-fc4169.htm

402-t05-4169.htm

402-fc4174.htm

402-t05-4174.htm

402-fc4175.htm

402-t05-4175.htm

402-fc4235.htm

402-t05-4235.htm

402-fc4243.htm

402-t05-4243.htm

402-fc4261.htm

402-t05-4261.htm

402-fc4277.htm

402-t05-4277.htm

402-fc4437.htm

402-t05-4437.htm

402-fc4456.htm

402-t05-4456.htm

402-fc4457.htm

402-t05-4457.htm

402-fc4458.htm

402-t05-4458.htm

402-fc4459.htm

402-t05-4459.htm

402-fc4461.htm

402-t05-4461.htm

402-fc4462.htm

402-t05-4462.htm

402-fc4463.htm

402-t05-4463.htm

402-fc4464.htm

402-t05-4464.htm

402-fc4465.htm

402-t05-4465.htm

402-fc4466.htm

402-t05-4466.htm

402-fc4467.htm

402-t05-4467.htm

402-fc4468.htm

402-t05-4468.htm

402-fc4471.htm

402-t05-4471.htm

402-fc4474.htm

402-t05-4474.htm

402-fc4475.htm

402-t05-4475.htm

402-fc4481.htm

402-t05-4481.htm

402-fc4482.htm

402-t05-4482.htm

402-fc4528.htm

402-t05-4528.htm

402-fc4529.htm

402-t05-4529.htm

402-fc4531.htm

402-t05-4531.htm

402-fc4572.htm

402-t05-4572.htm

402-fc4585.htm

402-t05-4585.htm

402-fc4587.htm

402-t05-4587.htm

402-fc4588.htm

402-t05-4588.htm

402-fc4615.htm

402-t05-4615.htm

402-fc4643.htm

402-t05-4643.htm

402-fc4644.htm

402-t05-4644.htm

402-fc4645.htm

402-t05-4645.htm

402-fc4646.htm

402-t05-4646.htm

402-fc4647.htm

402-t05-4647.htm

402-fc4648.htm

402-t05-4648.htm

402-fc4649.htm

402-t05-4649.htm

402-fc4651.htm

402-t05-4651.htm

402-fc4652.htm

402-t05-4652.htm

402-fc4653.htm

402-t05-4653.htm

402-fc4677.htm

402-t05-4677.htm

402-fc4679.htm

402-t05-4679.htm

402-fc4682.htm

402-t05-4682.htm

402-fc4688.htm

402-t05-4688.htm

402-fc4689.htm

402-t05-4689.htm

402-fc4696.htm

402-t05-4696.htm

402-fc4697.htm

402-t05-4697.htm

402-fc4698.htm

402-t05-4698.htm

402-fc4699.htm

402-t05-4699.htm

402-fc4711.htm

402-t05-4711.htm

402-fc4731.htm

402-t05-4731.htm

402-fc4732.htm

402-t05-4732.htm

402-fc4736.htm

402-t05-4736.htm

402-fc4737.htm

402-t05-4737.htm

402-fc4738.htm

402-t05-4738.htm

402-fc4739.htm

402-t05-4739.htm

402-fc4745.htm

402-t05-4745.htm

402-fc4768.htm

402-t05-4768.htm

402-fc4769.htm

402-t05-4769.htm

402-fc4842.htm

402-t05-4842.htm

402-fc4863.htm

402-t05-4863.htm

402-fc4883.htm

402-t05-4883.htm

402-fc4884.htm

402-t05-4884.htm

402-fc4885.htm

402-t05-4885.htm

402-fc4886.htm

402-t05-4886.htm

402-fc4887.htm

402-t05-4887.htm

402-fc4888.htm

402-t05-4888.htm

402-fc4889.htm

402-t05-4889.htm

402-fc4891.htm

402-t05-4891.htm

402-fc4892.htm

402-t05-4892.htm

402-fc4893.htm

402-t05-4893.htm

402-fc4894.htm

402-t05-4894.htm

402-fc4927.htm

402-t05-4927.htm

402-fc4928.htm

402-t05-4928.htm

402-fc4929.htm

402-t05-4929.htm

402-fc4931.htm

402-t05-4931.htm

402-fc4932.htm

402-t05-4932.htm

402-fc4933.htm

402-t05-4933.htm

402-fc4934.htm

402-t05-4934.htm

402-fc4935.htm

402-t05-4935.htm

402-fc4936.htm

402-t05-4936.htm

402-fc4937.htm

402-t05-4937.htm

402-fc4941.htm

402-t05-4941.htm

402-fc4942.htm

402-t05-4942.htm

402-fc4943.htm

402-t05-4943.htm

402-fc4944.htm

402-t05-4944.htm

402-fc4945.htm

402-t05-4945.htm

402-fc4946.htm

402-t05-4946.htm

402-fc4947.htm

402-t05-4947.htm

402-fc4958.htm

402-t05-4958.htm

402-fc4959.htm

402-t05-4959.htm

402-fc4961.htm

402-t05-4961.htm

402-fc5115.htm

402-t05-5115.htm

402-fc5116.htm

402-t05-5116.htm

402-fc5117.htm

402-t05-5117.htm

402-fc5178.htm

402-t05-5178.htm

402-fc5247.htm

402-t05-5247.htm

402-fc5261.htm

402-t05-5261.htm

402-fc5329.htm

402-t05-5329.htm

402-fc5331.htm

402-t05-5331.htm

402-fc5332.htm

402-t05-5332.htm

402-fc5333.htm

402-t05-5333.htm

402-fc5725.htm

402-t05-5725.htm

402-fc5726.htm

402-t05-5726.htm

402-fc5727.htm

402-t05-5727.htm

402-fc5728.htm

402-t05-5728.htm

402-fc5729.htm

402-t05-5729.htm

402-fc5731.htm

402-t05-5731.htm

402-fc5747.htm

402-t05-5747.htm

402-fc5748.htm

402-t05-5748.htm

402-fc5749.htm

402-t05-5749.htm

402-fc5751.htm

402-t05-5751.htm

402-fc5752.htm

402-t05-5752.htm

402-fc5753.htm

402-t05-5753.htm

402-fc5754.htm

402-t05-5754.htm

402-fc5755.htm

402-t05-5755.htm

402-fc5756.htm

402-t05-5756.htm

402-fc5757.htm

402-t05-5757.htm

402-fc5758.htm

402-t05-5758.htm

402-fc5759.htm

402-t05-5759.htm

402-fc5764.htm

402-t05-5764.htm

402-fc5767.htm

402-t05-5767.htm

402-fc5768.htm

402-t05-5768.htm

402-fc5769.htm

402-t05-5769.htm

402-fc5771.htm

402-t05-5771.htm

402-fc5772.htm

402-t05-5772.htm

402-fc5773.htm

402-t05-5773.htm

402-fc5774.htm

402-t05-5774.htm

402-fc5775.htm

402-t05-5775.htm

402-fc5776.htm

402-t05-5776.htm

402-fc5777.htm

402-t05-5777.htm

402-fc5778.htm

402-t05-5778.htm

402-fc5779.htm

402-t05-5779.htm

402-fc5794.htm

402-t05-5794.htm

402-fc5795.htm

402-t05-5795.htm

402-fc5796.htm

402-t05-5796.htm

402-fc5797.htm

402-t05-5797.htm

402-fc5798.htm

402-t05-5798.htm

402-fc5799.htm

402-t05-5799.htm

402-fc5813.htm

402-t05-5813.htm

402-fc5814.htm

402-t05-5814.htm

402-fc5815.htm

402-t05-5815.htm

402-fc5816.htm

402-t05-5816.htm

402-fc5817.htm

402-t05-5817.htm

402-fc5818.htm

402-t05-5818.htm

402-fc5819.htm

402-t05-5819.htm

402-fc5821.htm

402-t05-5821.htm

402-fc5822.htm

402-t05-5822.htm

402-fc5823.htm

402-t05-5823.htm

402-fc5824.htm

402-t05-5824.htm

402-fc5825.htm

402-t05-5825.htm

402-fc5828.htm

402-t05-5828.htm

402-fc5829.htm

402-t05-5829.htm

402-fc5831.htm

402-t05-5831.htm

402-fc5832.htm

402-t05-5832.htm

402-fc5833.htm

402-t05-5833.htm

402-fc5834.htm

402-t05-5834.htm

402-fc5862.htm

402-t05-5862.htm

402-fc5863.htm

402-t05-5863.htm

402-fc5875.htm

402-t05-5875.htm

402-fc5876.htm

402-t05-5876.htm

402-fc5877.htm

402-t05-5877.htm

402-fc5887.htm

402-t05-5887.htm

402-fc5888.htm

402-t05-5888.htm

402-fc5889.htm

402-t05-5889.htm

402-fc5891.htm

402-t05-5891.htm

402-fc5892.htm

402-t05-5892.htm

402-fc5893.htm

402-t05-5893.htm

402-fc5949.htm

402-t05-5949.htm

402-fc6253.htm

402-fc6253sa00.htm

402-t05-6253sa00.htm

402-fc6253sa01.htm

402-t05-6253sa01.htm

402-fc6253sa144.htm

402-t05-6253sa144.htm

402-fc6253sa186.htm

402-t05-6253sa186.htm

402-fc6369.htm

402-t05-6369.htm

402-fc6373.htm

402-t05-6373.htm

402-fc6378.htm

402-t05-6378.htm

402-fc6379.htm

402-t05-6379.htm

402-fc6381.htm

402-t05-6381.htm

402-fc6382.htm

402-t05-6382.htm

402-fc6383.htm

402-t05-6383.htm

402-fc6385.htm

402-t05-6385.htm

402-fc6387.htm

402-t05-6387.htm

402-fc6517.htm

402-t05-6517.htm

402-fc6573.htm

402-t05-6573.htm

402-fc6574.htm

402-t05-6574.htm

402-fc6594.htm

402-t05-6594.htm

402-fc6595.htm

402-t05-6595.htm

402-fc6633.htm

402-t05-6633.htm

402-fc6692.htm

402-t05-6692.htm

402-fc6698.htm

402-t05-6698.htm

402-fc6699.htm

402-t05-6699.htm

402-fc6711.htm

402-t05-6711.htm

402-fc6714.htm

402-t05-6714.htm

402-fc6715.htm

402-t05-6715.htm

402-fc6716.htm

402-t05-6716.htm

402-fc6717.htm

402-t05-6717.htm

402-fc6718.htm

402-t05-6718.htm

402-fc6734.htm

402-t05-6734.htm

402-fc6759.htm

402-t05-6759.htm

402-fc6853.htm

402-t05-6853.htm

402-fc6854.htm

402-t05-6854.htm

402-fc6855.htm

402-t05-6855.htm

402-fc6856.htm

402-t05-6856.htm

402-fc7123.htm

402-t05-7123.htm

402-fc7124.htm

402-t05-7124.htm